Environment Manager powered by AppSense

Size and Usage Reports

In this section:

About Size and Usage Reports

These reports show the amount of application and user personalization data used together with the applications that managed users are accessing. Three separate reports are available:

  • Size - Generates a report to show how much personalization data is stored on the database per application and user. This information can identify bottlenecks and resource problems for applications and used to eliminate unnecessary registry keys and folders from personalization to reduce the amount of data being transferred between endpoints and the server.
  • Usage - Generates a report which displays the number of times a managed application has been accessed by users over a specified time period.

Each report has a combination of functions, accessible from generated analysis reports. Right-click on a bar in one of the graphs to access the shortcut menu.

Size and Usage Report Criteria

The size and usage reports can be generated using the following criteria:

  • Report by User and <All Users> - Reports are generated per user for all users in the database, in size or usage order. Double-click on a user to see data on their individual applications. For the application size report, each bar represents the total amount of personalization data for the user. For usage reports, each bar represents the total usage count for applications run by users.
  • Report by User for a specific user - Reports show all applications for that user, with the data displayed per application.
  • Report by Application and <All Applications> - Reports are displayed per application showing the data for all users in the Personalization Group. The size graph for this report shows the total size of settings stored for all users in the group for each application. Double-click on an application to show data for each user.
  • Report by Application for a specific application - Shows the report data for each user’s usage of that application. For example, the application size graph shows the amount of personalization data for each user for that application only.

To report on all users or all applications, delete any existing contents of the Report By field.

Move a User’s Personalization Settings to Another Group

When a user is added to a specific personalization group, their personalization settings are only relevant for that group. Personalization Analysis enables the administrator to move the settings to another group.

This option is only available for User data and can only be performed if more than one personalization group exists.

This task only moves the user data from one personalization group to another. An administrator must move the actual user from one group to another using group membership rules. See Personalization Group Membership Rules.

  1. Select the User Personalization navigation button.
  2. Select Personalization Groups and select a personalization group.
  3. Click Personalization Analysis from the Tools & Wizards ribbon. The Personalization Analysis report window displays for the selected personalization group.
  4. Select a compatible report; Size or Application Usage.
  5. Ensure the Report By settings are configured to User and <All Users>.
  6. Click Display. The report for all users displays.
  7. Right-click the user you wish to move and select Move the settings for [user] to another group... This prompts you to choose an available group to move the chosen user’s personalization settings to.
  8. Select the Personalization group to receive the user settings.
  9. Click Continue to proceed and OK to confirm. The graph is refreshed with the user removed from the report.

Delete All User Data For a Selected User

In a size or usage report, select this option from a user bar shortcut menu to delete all personalization data and archives for that user. The next time the user starts any application, the default settings will be reinstated.

Delete Application Settings for a User

In a size or usage report, select this option from an application bar shortcut menu to delete the cache of an application for the selected user. Next time the user starts the application, it will revert to the default settings.

If you delete the application cache for a user who is logged on, the deletion may take longer to delete on the client as it is linked to the configuration poll, which runs every 10 minutes by default.

Clear All Usage Counts for a User

This action can be performed for usage reports on both application and user bars. Select this option from the shortcut menu to reset the application accesses count to zero for all of the user’s managed applications.

Delete All User Data for a User

In a size or usage report, select this option from the shortcut menu of a user or application bar to delete all settings and archives for all applications for the specified user.

Edit Virtual Registry for an Application

Once generated the size and usage reports allow administrator's access to a registry editor which enables stored registry data for an application to be examined and edited. Files can be imported and exported and registry keys can be added, deleted, edited and excluded.

Caution: Editing registry settings can cause application failure and serious system problems which may require re-installation of your operating system. Before making any changes, create an archive for this application. See Archive Reports.

  1. Create a size or usage report for a user.
  2. Locate the application you want to view, right-click on the bar for that application and select Edit application registry...
  3. A warning dialog displays. Disable the dialog for the session if required using the checkbox and click OK.

    The Edit Registry Settings dialog box displays showing the virtual registry structure for the application.

  4. Select the required option:
    • Import - Click Import from the File menu to import a registry key from the local disk for the selected application. Imported files have the REG extension, as used by the Windows Regedit utility.
    • Export - Highlight a registry key and click Export from the File menu to export and save it to the local disk. The key can then be imported into other application’s registries as required. Exported files have the REG extension, as used by the Windows Regedit utility.
    • Print - Click from the File menu to generate a printable Registry Settings Report for the application.
    • New - Click New from the Edit menu to create a new key and set the required values.
    • Rename Key - Highlight a registry key and select Rename Key from the Edit menu.
    • Delete Key - Highlight a registry key and select Delete Key from the Edit menu.
    • Exclude - Highlight a registry key and select Exclude from the Edit menu. The selected key is added to the Exclude list for the application. For further information, see Inclusions and Exclusions.
    • Hide R.I.P. Entries - Keys with an RIP extension represent residual keys, for example, keys that have been renamed or deleted. These keys are still virtualized to ensure correct behavior. However, when examining the registry, it may give a clearer view if these keys are hidden.
  5. Select this checkbox to hide these entries from the registry editor.
  6. When all required actions have been made, click OK to commit them to the database.

Edit the Application File List

Once generated the Size and Usage reports enable administrators to view the folder structure for an application or application group. This structure allows files and folders to be imported, excluded and deleted directly from Personalization Analysis reports.

  1. Create a Size or Usage report for a user.
  2. Locate the application you want to view, right-click on the bar for that application and select Edit application file list...
  3. From the Folder Display drop-down, select the file structure you want to view:
    • Vista and Windows 7 and above
    • XP
    • Raw
  4. Select a View Type; Tree File View or Flat File View.
  5. Navigate to the required folder.
  6. The following options are available:
    • Import - Right-click in the details pane and select Import to add files from the local disk to the selected folder.
    • Export - Right-click on a file and select Export to save the selected file to the local disk.
    • Open - Right-click on a file and select Open. This extracts the file to a temporary location and attempts to open the associated application. If the application modifies the file the modifications are written back to the profile in the database.
    • Delete - Right-click on a file and select Delete to remove the selected file from the database. Multiple files can be selected using CTRL and shift when selecting files. You can also select a file and delete its contents.
    • Print - Click Print to generate a printable Application File Report for the selected file.
  7. Click OK to save any changes or to quit the file list.

Related topics


Was this article useful?    

The topic was:

Inaccurate

Incomplete

Not what I expected

Other