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About This Document

This document provides information on the administrative tools which are available with Environment
Manager.

For each tool the guide describes how it should be used and includes a usage scenario to
demonstrate a circumstance in which the tool may be used.
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Environment Manager Administrative Tools

Environment Manager is packaged with the following standalone tools to assist administrators when
they create configurations and work with the Personalization database:

Environment Manager Logging Setup
Environment Manager Monitor
Personalization Server Log Viewer
Environment Manager Log File Conversion
EMP File Utility

EMP Migrate Utility

EMP Migrate Command Line Utility

EMP Registry Utility

File Based Registry Explorer

The tools cover a range of functionality and employ a variety of user interfaces - from command line
utilities such as the EMP File utility to more extensive graphical interfaces such as the EM Log Viewer.

Installation

The 32 and 64-bit Administrative Tools installers are included with the Environment Manager
installation media:

EnvironmentManagerTools32

EnvironmentManagerTools64

Once installed to the default location, the tools are available from the Start > All Programs >
AppSense > AppSense > Tools menu.

The tools are run independently from Environment Manager and all our other products.
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Environment Manager Monitor

User Interface

Environment Manager Monitor (EmMon) provides a user interface to view and analyze log files from
the Environment Manager Agent. The tool replaces Environment Manager LogViewer.

The landing page displays when the Environment Manager Monitor loads. The landing page provides

access to load log files, view raw logs and analyze logs. Links are available to access commonly used
filters.

=] Environment Manager Monitor - |0 -
Commeon Tasks
Load a log file, then select one of the tasks below to analyze and display the log entries. a
Recent log files EmTracelog.et - 5
Include event types User Activity - Incdude detail levels | Critical, Error, Warning, Info
S b
E View/Search all detailed logging Session Information
% Analyze user activity & Find personalization bottenecks
B/} Find trigger bottenecks % Search for any failures
(‘b Search for failed actions and conditions & View failed personalization synchronizations
‘I [Py
) view personalization server latency statistics L‘-(l View windows fapplication personalization logaing onl
Loaded 214833 log entries from file 'EmTracelog. et B [ skip next time
Label Description
a Load Log Files

Load a log file from disk. Recently used log files are populated in the drop-down menu.
Select the event types and logging level to load into Environment Manager Monitor.

For further details, see Loading Log Files.

b View Raw Logs from Live or Disk

View raw log lines from the live log or from a log file on disk. You can sort, filter, group,
search, and format the dataset.

For further details, see Viewing Raw Logs from Live or Disk.
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Label Description

C

View Session Information
View detailed information about each user’s session from the loaded log file.

For further details, see Viewing Session Information.

Analyze Log Files from Disk

View an analysis of a log file, either in a grid or chart. Log entries relating to the same
event are collected together.

The Analyze user activity option displays the analyzed view with no filters applied.

The dataset can be sorted, filtered, grouped, and searched. Built-in filters are available on
the landing page to provide access to the following commonly used tasks:

« Find personalization bottlenecks - Display long-running Personalization events.
« Find trigger bottlenecks - Display long-running Policy events.

« Search for any failures - Display Policy and Personalization failures.

« Search for failed actions and conditions - Display Policy failures.

« View failed personalization synchronizations - Display Personalization failures.

« View personalization server latency statistics - Display Personalization session
requests, configuration requests, application synchronizations and Windows
Personalization synchronizations.

« View windows/application personalization logging only - Display
Personalization session requests, configuration requests, application starts,
application synchronizations, Windows Personalization synchronizations, Windows
Personalization saves and Windows Personalization restores.

For further details, see Analyzing Log Files from Disk.

Viewing Loading Progress

When loading a log file, the loading progress displays. The log file may take a few minutes
to load depending on its size, event types and event detail.

After a log file is loaded, the number of log entries in the file displays.

Selecting Loading Behavior
The Skip next time option can be set as follows:

« Disabled - The landing page displays when Environment Manager Monitor is
loaded.

« Enabled - The live log displays when Environment Manager Monitor is loaded. To
show the landing page for subsequent loads, click Options > Settings and enable
Show Landing Page.
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Load a Log File from Disk

1. Fromthe Recent Log Files drop-down, select Open Log File.

2. Fromthe Include Event Types drop-down, select the logging event types to load from the
selected log file. Options are available for specific user and computer events.

3. Fromthe Include Detail Levels drop-down, select the logging level to load from the selected log
file and click OK. The following levels are available:

o Critical
o Error
o Warning

o Info

A file browse dialog displays.
5. Select an ETL log file and click Open.

Environment Manager Monitor loads the log file. The loading progress displays at the bottom
of the dialog. The log file may take a few minutes to load depending on its size, event types and
event detail.

After opening a log file, the file is added to the Recent Log Files drop-down. To open a

recently used log file, select the file, event types, detail level and click =

Clear the Recently Used Log Files List

1. Fromthe Recent Log Files drop-down, select Clear Log Files.

2. Click ﬁ

3. Click Yes in the confirmation dialog.

Entries from the Recent Log Files drop-down are removed.

View Raw Logs from Live or Disk

This view displays the raw log lines from either the live log or from a log file on disk.

You can sort, filter, group, search, and format the dataset to display the relevant information.
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[=] Environment Manager Monitor - a
File Edit View Tools Optiens -
£ Live | & EmTracelog
Time Stamp « Uger Tme KernelTime PID | TID Ewvent Component SessionId  Raw Log Line -
b 12/23/2014 10:41:27 683 i 5 2616 1752 Emuser Main Enter Emuser 2 Event: Emuser Main Enter Id: <Empty > Component: Emuser Sess
12/23f2014 10:41:27 712 1 & 2616 1752 Etw Log Message Emuser 2 GetUserToken Got user token 384 from EmCoreService for sessior
12/23[2014 10:41:27 714 1 6 2616 1752 Etw Log Message Emuser 2 UserInfo::GetUserDetails User: CHILDTEST \mdavies
12/23f2014 10:41:27 714 1 6 2616 1752 Etw Log Message Emuser 2 LogSystemDetails System Details Follow:
12232014 10:41:27 714 1 & 2616 1752 Session Information Emuser 2 Event: Session Information Id: <Empty> Component: Emuser Ses
12/23/2014 10:41:27 714 1 & 2616 1752 Etw Log Message Emuser 2 LogSystemTime TIME: (DMfY H:M:5.m) UTC=23f12/2014 10:41:Z
12/23/2014 10:41:27 714 1 & 2616 1752 Etw Log Message Emuser 2 ApplicationVersionumber
12/23[2014 10:41:27 714 1 6 2616 1752 Etw Log Message Emuser 2 EngKey::GetValueData Retrieved engineering value
12/23[2014 10:41:27 715 1 & 2616 1752 Etw Log Message Emuser 2 EngKey::GetValueData Retrieved engineering value
12/23/2014 10:41:27 715 1 & 2616 1752 Etw Log Message Emuser 2 CClientComms::ConnectToServer Connecting to pipe \\. \PIPE\EMF
12/23/2014 10:41:27 715 1 & 2616 1752 Etw Log Message Emuser 2 CdlientComms: :ConnectClient Sending connected message to ser
12f23/2014 10:41:27 716 1 6 2616 1752 Etw Log Message Emuser 2 CClientComme::ConnectClient Sent EMC_CLIENT_CONMNECT mess:
12/23/2014 10:41:27 716 1 & 2616 1752 Etw Log Message Emuser 2 CMessageHandler::StartHandler Connected to server
12/23/2014 10:41:27 768 a 0 2616 2748 Etw Log Message Emuser 2 WorkerPool::WorkerThread waiting
12/23[2014 10:41:27 768 a 0 2616 27838 Etw Log Message Emuser 2 WorkerPool::WorkerThread waiting
12/23/2014 10:41:27 768 a 0 2616 2752 Etw Log Message Emuser 2 WorkerPool::WorkerThread waiting
12232014 10:41:27 768 3 7 2616 1752 Etw Log Message Emuser 2 EmEventDispatcher::RegisterHandler Registered new handler for
12/23/2014 10:41:27 768 1] 0 2616 2860 Etw Log Message Emuser 2 WorkerPool::WorkerThread waiting
12/23/2014 10:41:27 768 3 7 2616 1752 Etw Log Message Emuser 2 EmEventDispatcher::RegisterHandler Registered new handler for
12/23/2014 10:41:27 759 3 7 2616 1752 Etw Log Message Emuser 2 EmEventDispatcher::RegisterHandler Registered new handler for
12/23[2014 10:41:27 769 3 7 2616 1752 Etw Log Message Emuser 2 EM::Config::CXMLConfig::CXMLConfig Revert actions will unapply
12/23/2014 10:41:27 765 3 7 2616 1752 Etw Log Message Emuser 2 EM::Config::CX¥MLConfig::CXMLConfig Initialising reader...
12/23/2014 10:41:27 765 3 7 2616 1752 Etw Log Message Emuser 2 EM::Config: :CXMLConfig: :InitislizeReader Initislizing function poin
12/23/2014 10:41:27 770 3 7 2616 1752 Etw Log Message Emuser 2 EM::Config::CXMLConfig: :InitislizeReader Initializing schema defin
12/23[2014 10:41:27 776 3 7 2616 1752 Etw Log Message Emuser 2 IsTSTempSessionKeySet Returning 0
12/23f2014 10:41:27 782 3 8 2616 1752 Etw Log Message Emuser 2 EM::Config::CConfigManager::SetlegacyLogonMode Setting Legz
12/23/2014 10:41:27 783 3 & 2616 1752 Etw Log Message Emuser 2 GetConfigurationFilePath C:\ProgramData'AppSense \Environment
12232014 10:41:27 7534 3 8 2616 1752 Etw Log Message Emuser 2 EM::Config::CXMLConfig::WaitForFileAccess: : <lambda_5d955ed -
1 b
214833 of 214833 events @

Log lines displayed in bold contain multiple lines that are not displayed in the view. To display the data,

either hover over the row or select Options > Auto Row Height.

Enable Logging

To enable logging on the endpoint, select Options > Settings > Logging Enabled. A reboot or agent
restart is not required. Logging can be enabled using the Environment Manager Logging Setup tool.

For further information, see Enable Logging. To view the live log in real time, see Load Live Logs.
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Change Logging Settings

Basic settings
[+] Enable ETVW logging

Logfile name |C:\Logs\EmTraceLog

Event tracing

cassion nome. | EM_ETW_Session

Log detail

Level: Trace

Components to enable
[v] EmCoreService

[+] EmCredentialManager
[v] EmEst
[w] Winlogon detour

[w] Al components

y

[+ EmUser

[+ EmUserLogoff

[+ EmAutherticationPackage
[v] EmWOWES

® Rolloverlog
() Circularlog () Unlimited log

Advanced perfarmance settings
File size limit (Mb)

Mz buffers
Buffer size (Kb)
Min buffers

= o
I
o
a

<] [<2] [<2] |<[*]

[+] EmSystem

[+] EmlLoggedOnUser

[+] Winlogon netify package
[+ EmLogoffliApp

Further logging settings are available within the Environment Manager Monitor. Use these settings to
define the name, location, detail level, components, and performance.

1. Select Options > Settings > Logging Settings.

The ETW Settings dialog displays.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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2. Set the required options for logging. The following settings are available:

Setting Description

Enable ETW logging

Enable or disable logging on the local endpoint.

Log file name

The location and name to which the log file is written.

Event tracing session
name

The name for the event tracing session. This name is used in
Performance Monitor.

Log detail

The level of detail that is logged. The following options are
available:

o Critical

o Error

« Warning

o Informational

« Trace

o Unless advised otherwise by Support, it is recommended
that the Log detail slider is set to Trace.

Components to enable

The components that are logged. The following components are
available:

o EmCoreService

o EmUser

o EmSystem

o EmCredentialManager
o EmUserLogoff

o EmLoggedOnUser

o EmExit

« EmAuthenticationManager
« Winlogon notify package
« Winlogon detour

« EmMWOWe4

o EmLogoffUiApp

File size limit

The maximum size of the log file in Mb if Circular Logging or Live
Logging is enabled.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
Page 11 of 76



http://www.ivanti.com/en-US/company/legal

Environment Manager 10.1 FR4 Administrative Tools Guide

Setting Description

Max buffers The maximum number of buffers.

Buffer size The size of each buffer in Kb.

Min buffers The minimum number of buffers.

Log File Mode Set the log file mode. The following options are available:

« Rollover log - The log file grows to the specified size limit.
Once it has reached the limit, a new log file is created with a
version number appended to the name.

« Live log - Logging can be viewed in real time using the
Environment Manager Monitor. This is the equivalent of
Real Time logging in Windows Event Tracing.

« Circular log - The log file grows to the specified size limit.
Once it has reached the limit, the log file automatically
overwrites the oldest entries.

« Unlimited log - The log files grows indefinitely regardless
of the size limit.

3. Click OK.

The logging settings are applied. A reboot or agent restart is not required.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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Loading Log Files

Load Live Logs

Iflogging is enabled in Live Log mode on the current endpoint, the live log file can be viewed in real
time. To view the live log, select File > Live Logs.

To stop the view automatically scrolling as new log entries are received, deselect Options > Auto
Scroll.

Load Log File From Disk

1. Select File > Open Log File.
A file browse dialog displays.
2. Select an ETL log file and click Open.

Environment Manager Monitor loads the log file. The loading progress displays at the bottom
of the dialog. The log file may take a few minutes to load depending on its size, event types and
event detail

Load a Recently Used Log File

1. Select File > Recent Log Files.
A list of recently used log files displays.
2. Select a log file to open.

Environment Manager Monitor loads the log file. The loading progress displays at the bottom
of the dialog. The log file may take a few minutes to load depending on its size, event types and
event detail.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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Export Log Files

1. Select File > Export.

2. Select a format to export to. The following options are available:

(e}

[¢]

[e]

Excel

csv

Text

Rich Text

Web Page

PDF

A file save dialog displays.

3. Select an export location and click Save.

The current dataset is exported to the selected location.

Manipulate the Data View

Add Columns

1. Right-click a column heading

2. Select Column Chooser.

The Customization dialog displays.

d

Awverage Rate
Data Size
Direction
Errar

Flags

Level -

Customization .

.

3. Drag a column from the Customization dialog into the desired position on the header row.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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Sort Columns

1. Right-click a column heading.
2. Select asort order:
« Sort Ascending - Sort the data in ascending order.
« Sort Descending - Sort the data in descending order.

3. To clear the sorting, right-click the column heading and select Clear Sorting.

Filter Columns from Existing Values
This option displays all of the unique values for a field, such as all Session IDs, from the open log file.
Columns can be filtered by a specific value from the dataset.

1. Hover over a column heading and click the filter icon.

A list of unique values within the column displays.

3 Live | €} EmTracelog

Time Stamp 4+ User Time Kernel Time  PID ¥.TIN__ Fuent
(Custom) “
12232014 10:41:27 683 1 5 267 (Blanks) in Ente
12/23/2014 10:41:27 712 1 & 261(Mon blanks) Resage
12/23/2014 10:41:27 714 1 6 261 i;é; =53a0e
12/23/2014 10:41:27 714 1 6 26177208 =5sage
12/23/2014 10:41:27 714 1 & 252316 ormat
2616
12/23/2014 10:41:27 714 1 & 2613337 =5sagE
12/23/2014 10:41:27 714 1 6 26513752 zza50e
12/23/2014 10:41:27 714 1 6 261 ﬁg; =5ag0e
12/23/2014 10:41:27 715 1 6 2614712 =5sage
12232014 10:41:27 715 1 & 2519938 sssage
4976
12/23/2014 10:41:27 715 1 5 261425 =53a0e
12232014 10:41:27 716 1 6 2615032 Egsage
12/23/2014 10:41:27 716 1 6 261 :;‘:’E 25ea0e
12/23/2014 10:41: 27 763 0 0 2615724 + BESsEge
12/23/2014 10:41:27 768 0 0 261 4 pSsage
12/23/2014 10:41:27 768 0 0 2616 2752 Etw Log Messs

ISP A A e AT T
lafef 1S RSl s /o

oo
|
(=]
L=}
Lay]

2. Select a value on which to filter the selected column.

The data is filtered to show only entries that match the criteria.
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Filter Columns using Auto Filter Row
The Auto Filter Row displays above the dataset and allows columns to be filtered by entering basic
filtering criteria.
1. Select View > Filters > Auto Filter Row.
The Auto Filter Row displays below the column headings.

2. To filter a column, enter the text into the Auto Filter Row.

£ Live | £} EmTracelog X

Time Stamp User Time |Kernel Time  TID PID T Component Raw Log Line
¥ 4975

12/23/2014 10:44:04 204 0 16 5000 4975 Emuser Event: Emus

12/23/2014 10:44:04 237 0 17 5000 4975 Emuser GetlserToke

12/23/2014 10:44:04 238 ] 17 5000 4975 Emuser LserInfo::

The data is filtered to show only entries that match the criteria entered in the Auto Filter Row.

3. Toclear thefiltering, select View > Filters > Clear.

Filter Columns using Filter Editor

The Filter Editor allows conditions to be created to target specific data in the dataset. Complex
conditions can be created by using multiple expressions and nested Boolean operators.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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1. Select View > Filters > Filter Editor.
2. Edit the condition as required:
o Click a red Boolean operator, such as And, to edit the operator or add a new condition
group.
o Click a blue field name, such as [Time Stamp], to change the field to match.
o Click a green operator, such as Equals, to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click = to add a new expression to the condition.

> [User Mame] Equals TESTING\pgould &3
Lore
' [Session Id] Equals 2 &

[Session Id] Equals 4 &

3. Click Apply to preview the filter.
4. Click OK.
The data is filtered to show only entries that match the criteria entered in the Filter Editor.

5. Toclear thefiltering, select View > Filters > Clear.

Group Columns

1. Select View > Groups > Group By Box.

The Group By box displays above the column headings.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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2. Drag a column heading into the Group By box. More columns can be dragged into the Group
By box to create nested groupings.

3 Live | €} EmTracelog

SessionId =«
PID &

Tirme Stamp User Time Kernel Tir
+ Session Id : 2 (Count = 2)
b PID: 2616 (Count = 8132)
* PID:3752 (Count = 1130)
+ Session Id : 3 (Count = 2)
b PID: 4976 (Count = 10395)

The data is grouped by the fields specified in the Group By box.
3. Toclear the grouping, right-click the Group By box and select Clear Grouping.

Search Log Entries

1. Select Edit > Find Panel.The Find Panel displays above the column headings.
Enter a search term.

2. Click Find.Rows containing text in any column that matches the entered search term are
displayed.

3. To clear the search, click Clear in the Find Panel or close the Find Panel.

Add Conditional Formatting

Conditional formatting allows rows or text to be formatted based upon the data within one or more
fields.

1. Select Tools > View > Formatting Editor.
The Formatting Editor dialog displays.

2. Click Add to add a new condition. Edit the condition as required:

o Click a red Boolean operator, such as And, to edit the operator or add a new condition
group.

o Click a blue field name, such as [Time Stamp], to change the field to match.
o Click a green operator, such as Equals, to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click % to add a new expression to the condition.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
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3.

Once the condition has been constructed, set the formatting properties for rows that match
the condition. Available options include row background color, row border color and text
formatting.

[Properties.Componen | | and o
[Component] Equals Core Service ©)
oo
E [Time Stamp] Is today &
[Time Stamp] Is yesterday &

BackColor 192, 255, 192

BackColor2

BorderColor

Font Tahoma, 8.25pt, style=Bold

ForeColor

GradientMode Harizontal

Image (none)
¥ Options UseBackColor = True, UseFont =
b TextOplons

add || Delete

4. Click Apply to preview the conditional formatting.
5. Click OK.

6.
7

. Toclear the formatting, select View > Formatting > Clear.

Rows matching the criteria specified in the Formatting Editor are formatted.

View Footer

The footer allows statistics to be displayed for one or more fields. The sum, minimum, maximum, count,
and average values are available for each field.

1.

Select View > Footer.

The footer displays above the status bar.
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2. Below a column, right-click the footer. Select a statistic from the following options:

o Sum
o Min
o Max
o Count

o Average

The statistic displays in the footer and automatically updates as data is added or removed.

1402502014 10:41:27 826

3

12/23/2014 10:41:27 827 0
12/23/2014 10:41:27 827 a
12(23/2014 10:41:27 373 i
AVG=1085.83

1

10 2618 1752 Etw Log Message
0 2616 3040 Etw Log Message
1 2516 3040 Etw Log Message
N 2616 30720 Ftwl on Messane

214833 of 214833 events |

Copy Log Lines to New Tab

One or more log lines can be copied to a new tab to allow the data to be analyzed independently. Tabs
can be renamed to make it easier to work with multiple tabs.

1. Select one or more log lines from the log file. Multiple lines can be selected by using the Ctrl or

Shift keys.

2. Select Edit > Copy To New Tab

3. Anew tabis created containing the selected log lines.

4. Torename the created tab, right-click the tab and select Rename.

Merge and Compare Tabs

Data from two tabs can be merged and compared in a single view. The rows are color-coded to

differentiate between the two sources.

1. Select the first tab to compare.
2. Select Tools > Compare With.
A list of open tabs displays.
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3. Select a tab to compare with the current tab.
The Compare Tabs dialog displays.

Log lines that are present in both tabs display in white, those from only the first tab display in
red and those from only the second tab display in yellow.

End

Time Stamp User Tme  Kermel Time PID |TID |Ewvent
ko1
prs
3
4
5§ 12/23/2014 10:41:27 768 3 72616 1752 ETW_LOG_MESSAGE
6  12/23/2014 10:41:27 7a9 3 72616 1752 ETW_LOG_MESSAGE
7 | 12/23/2014 10:41:27 759 3 ¥ 20616 1752 ETW_LOG_MESSAGE
8  12/23/2014 10:41:27 7a9 3 72616 1752 ETW_LOG_MESSAGE
9 | 12/23/2014 10:41:27 759 3 72616 1752 ETW_LOG_MESSAGE
10 12/23/2014 10:41:27 770 3 7 2616 1752 ETW_LOG_MESSAGE
11 12/232014 10:41:27 776 3 72616 1752 ETW_LOG_MESSAGE
12 | 12/23/2014 10:41:27 732 3 8 2616 1752 ETW_LOG_MESSAL

. T A AT A T T = —g

]
-
J

Ty

Ty

]

n

J
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4. Click to access merge and compare options.

Merged

B start
Mame Visible Calculated
iTime Stamp '
User Time
Kernel Time
PID

TID

Level

Tirne Stamp User Time | Kerre

12232014 10:41:27 768
12232014 10:41:27 769
12232014 10:41:27 769
12232014 10:41:27 769
12232014 10:41:27 769
12232014 10:41:27 770
12232014 10:41:27 776
12 | 12/23(2014 10:41:27 782
13 12/23/2014 10:41:27 783
14 | 12/23/2014 10:41:27 784
15  12/23/2014 10:41:27 819

Event
Component
Session Guid

Emmumm_hwmn—n

Lummmummmmmlmll

Session Id

Id

Raw Log Line
Result

—
[

ODONONONNONNNE S
ODONONONNONNNE S

5. Change the options as required and click Refresh. The following options are available:
o Visible - Change the columns that are displayed in the comparison.
o Calculated - Change the columns that are used for the comparison.

The merged data is displayed with the specified columns visible.

Look Up Error Codes

Look up system error codes from the log file using the built-in tool.

1. Click Tools > Error Code Lookup.
The Error Code Lookup dialog displays.

2. Enter an error code.
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3. Click w.

The error information displays for the entered error code.

Enter Error Mumber: 2

The system cannot find the file specified

View Session Information

The Session Information dialog provides information about each user session from the loaded log file.

The drop-down lists the session number and the logon and logoff times. When a session is selected,
detailed information about the session displays.

Session 2 @ 12/23/2014 10:41:27 683 - 12:07:30 308

IJser Mame TESTIMNG\pgould
User 5ID 5-1-5-21-2792019302-485093558-3332333992-1106
Windows Dir C:\Windows

System Root C:\Windows\system32

Operating System  Windows NT Version 6.1 Build 7601
Service Pack Service Pack 1

Terminal Services  Terminal Services Present
WorkGroup/Domain TESTING [Domain]

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
Page 23 of 76


http://www.ivanti.com/en-US/company/legal

Environment Manager 10.1 FR4 Administrative Tools Guide

Analyze Log Files from Disk

This view displays an analysis of the loaded log file. Log entries relating to the same event are collected

together.
Filters Pane

] orphans -

+ ] Result
] Passed
W Failed
~ [H] Policy
- [ Triggers
+ [] computer
~ [H user
+ ¥ Logen
[ Logoff
[ Process Started
[ Process Stopped
[ Network Connected
[ Network Discannected
[] Session Reconnected
[] Session Disconnected
[] Session Locked
[] Session Unlocked
] Windows Personalization
] Policy Nodes
+ ] actions
+ ] custom & Execute
+ /] Drive & Printers

Session1d 2
User Name:

Trigger 1d  {ICICEI0S BEAS Y

Result passed
parameters

gndTme /!
Duration  681MS

=

Py nn‘"awlﬂﬂﬁ’ |

sl A

+ ] Environment .

| SelectAl | | Desclectal | [T Refesh |

Detais
Name EARLY_LOGON

< Time Stamp

|+ 3ispo1s e0nsa 80

Work Area

Grid Chart

Type Name Desription

~ User Name : DEVELOPMENT \pmoran (Count = 2)
~ Session : 3/18/2015 14:04:45 247 - 14:47:58 249 (Count = 22)

Lser Tme Kemel Trve P T Event

Component Sesson i Ram LogLre. -
2 Event: Begn Trigger 1t §

StartTme  *

Details Pane

s CMOLIN

04:48
3/18/2015 14
Start Time: ST Lo

EARLY_LOGON

DEVELOPMENT\pmoran
{1C1CE105-BEAS-404A-AF 15-B7987 16DB

; CMDLINE =;PID:

3/18/2015 14:04:48 380
3/18/2015 14:04:49 061

T

0w Do pegeTige e r——
0 W% 060 Ebvloghemage Frset 2 [CBwometer GeDvS]
Time Stamp User Time |KemelTme PID  TID  Event
3/18/2015 14:04:48 380 5 0 303 3060 Begin Trigger
3/18/2015 14:04:48 381 5 0 303 3060 EtwLog Message
3/18/2015 14:04:48 382 5 0 303 3060 EtwLog Message
3/18/2015 14:04:48 382 5 0 3036 3060 EtwlogMessage
5 0 3036 3060 EtwlogMessage
5 0 3036 3060 EtwlogMessage
3/18/2015 14:04:48 384 5 0 3036 3060 EtwlogMessage

Component  Session 1d |Raw Log Line

2 Event: Begin Trigger Id: 5 ”
2 [CEMParameter::Decode]

2 [CEMParameter::GetData]
2 [CEMParameter:;GetData]
2 [CEMParameter:;GetData]
2 [CEMParameter:;GetData]
2 [CEMParameter:;GetData]
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Grid View

The Grid view provides an analysis of activity. Each row is an event, such as an action or condition.

Grid t

g

Type Mame Description Session [d  Category Start Time o

+ User Name: TESTING \pgould {(Count = 2)
~ Session:3/18/2015 14:04:45 247 - 14:47:58 249 (Count = 22)
{EARLY_LOGON Early Logon 2

L

4 C ] 3

You can sort, filter, group, search, and format the dataset to display the relevant information.

Add Columns

1. Right-click a column heading
2. Select Column Chooser.

The Customization dialog displays.

End Time

End Time {calculated)
End Time {zeroed)
Start Time (calculated)
Start Time (zeroed)
Status

Trigger Id

3. Drag a column from the Customization dialog into the desired position on the header row.
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Sort Columns

1. Right-click a column heading.

2. Select a sort order:

o Sort Ascending - Sort the data in ascending order.

o Sort Descending - Sort the data in descending

3. Toclear the sorting, right-click the column heading and select Clear Sorting.

Filter Columns from Existing Values

order.

This option displays all of the unique values for a field, such as all Session IDs, from the open log file.

Columns can be filtered by a specific value from the dataset.

1. Hover over a column heading and click the filter icon.

A list of unique values within the column displays.

3 Live | £} EmTracelog X

Time Stamp 4+ User Time Kernel Time  PID ¥.TI0 Fuent
| {Custom)

12/23/2014 10:41:27 683 1 5 261 lanks)
12/23/2014 10:41:27 712 1 & 251(Non blanks)
12/23/2014 10:41:27 714 1 & 261 i;;;
12/23/2014 10:41:27 714 1 & 2612208
12/23/2014 10:41:27 714 1 & 2512316

2616
12/23/2014 10:41:27 714 1 6 2613335
12/23/2014 10:41:27 714 1 & 2613752
12/23/2014 10:41:27 714 1 6 267 ﬁg;
12/23/2014 10:41:27 715 1 6 26147212
12/23/2014 10:41:27 715 1 5 259388

4976
12/23/2014 10:41:27 715 1 6 261495
12/23/2014 10:41:27 716 1 6 2615032
12/23/2014 10:41:27 716 1 6 26 :;E
12/23/2014 10:41:27 768 0 0 2615724
12/23/2014 10:41:27 768 0 0 267
12/23/2014 10:41:27 758 0 0 2616 2752

212312014 104127 768

[}
-
I
o

2. Select a value on which to filter the selected column.

[aj]

1752

el

Etw Log Messz

The data is filtered to show only entries that match the criteria.

I

3. To clear thefiltering, right-click the column heading and select Clear Filter.
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Filter Columns using Auto Filter Row

The Auto Filter Row displays above the dataset and allows columns to be filtered by entering basic
filtering criteria.

1. Right-click a column heading and select Show > Auto Filter Row.
The Auto Filter Row displays below the column headings.

2. To filter a column, enter text into the Auto Filter Row.

Grid Chart

Type Mame T Descriptin:-n
¥ Explurer '

Windows Personalization Rest... Explorer Settings

Windows Personalization Rest... Explorer Settings

Windows Personalization Rest... Explorer Settings

Windows Personalization Rest...  Explorer Settings

The data is filtered to show only entries that match the criteria entered in the Auto Filter Row.
3. To clear thefiltering, right-click the column heading and select Clear Filter.
Filter Columns using Filter Editor

In the Filter Editor, create conditions to target specific data in the dataset. Use multiple expressions
and nested Boolean operators to create complex conditions.

1. Right-click a column heading and select Filter Editor.

The Filter Editor dialog displays.
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2. Edit the condition as required:
o Click a red Boolean operator, such as And, to edit the operator or add a new condition
group.
o Click a blue field name, such as [Time Stamp], to change the field to match.
o Click a green operator, such as Equals, to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click = to add a new expression to the condition.

And ©
[User Mame] Equals TESTING\pgould &3
or O
E [Session Id] Equals 2 &

[Session Id] Equals 4 &4

3. Click Apply to preview the filter.
4. Click OK.
The data is filtered to show only entries that match the criteria entered in the Filter Editor.

5. Toclear thefiltering, right-click a column heading and select Clear Filter.

Group Columns

Data can be grouped by one or more columns to create nested datasets. By default, the view is
grouped by Username followed by Session Description to create a nested view of users and each
user's sessions.

The username and Session ID are captured at logon. If logging is enabled mid-session, these fields
may not be populated.

1. Right-click a column and select Group By Box.

The Group By box displays above the column headings.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
Page 28 of 76


http://www.ivanti.com/en-US/company/legal

Environment Manager 10.1 FR4 Administrative Tools Guide

2. Drag a column heading into the Group By box. More columns can be dragged into the Group

3.

By box to create nested groupings.

Grid Chart

SessionId -

Type =

MName Description Category 55

+ Session Id : 2 (Count = 14)
+ Type : Trigger (Count = 39)
b Type: Task (Count = 344)
b Type : Policy Node (Count = 86)
¢ Type : Action (Count = 18)

— = -

The data is grouped by the fields specified in the Group By box.
To clear the grouping, right-click on the Group By box and select Clear Grouping.

Export and Compress Session Logs

Individual session logs can be exported and compressed in ZIP format. The log can be emailed to
Support if required. Group the log by Username followed by Session Description. For further
information, see Group Columns.

Right-click a session heading and select Export and Compress Session.

1
2. The Browse for Folder dialog displays.
3.
4

. The session log is exported to the selected location.

Select a location to save the exported session log and click OK.

Search Log Entries

1.
2.

Click inside the grid.

Press Ctrl+F.

The Find Panel displays above the column headings.

Enter a search term.

Click Find.

Rows containing text in any column that matches the entered search term are displayed.

To clear the search, click Clear in the Find Panel or close the Find Panel.

Recalculate Times

The start date and time of the log can be set to a different date and time. This allows timings of each

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
Page 29 of 76


http://www.ivanti.com/en-US/company/legal

Environment Manager 10.1 FR4 Administrative Tools Guide

event to be displayed relative to a specified date and time.
Add the Start Time (calculated) and End Time (calculated) columns to the grid.

For further information about adding columns, see Add Columns.

1. Right-click in the work area and select Update Calculated Times.

The Recalculate Times dialog displays.

2. Enter a date and time for the start of the log. To specify the current date and time, click Now.

Date
3/23/2015

3. Click OK.

The Start Time (calculated) and End Time (calculated) columns update to represent the log start
time specified.

Grid Chart
MName Start Time «  Start Time (calculated) Descriptio

EM_TASK_CLIENT_INITIALIZE  12/23/2014 10:41:30 302 3/23/2015 10:00:02 519 Client In
Task EM_TASK_NODE_EXECUTIO... 12/23/2014 10:41:30 309 3/23/2015 10:00:02 626 Mode E.o

Trigger EARLY_LOGOM 12232014 10:41:30 310 3/23/2015 10:00:02 625 Early Logo

e e [ I co v

Task EM_TASK_USER_EARLY LO.., 12f23/2014 10:41:30 673  3/23/2015 10:00:02 390 User E=r
Task EM_TASK_DS_SMAPSHOT 12/23/2014 10:41:30 945 3/23/2015 10:00:03 261 Ds

Change Row Colors

Modify default row background colors to uniquely identify event types.
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1. Right-click a row and select Update Colors.
2. The Update Colors dialog displays.

Event Action

Event Color [ 154, 205, 50

|_....
e

From the Event field, select the event type.

4. Fromthe Event Color field, select a new color for the event. Click More Colors to set a custom
color.

5. Click OK.

6. To revert to the default colors, open the Update Colors dialog and click Reset.
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Chart View

The Chart View provides a graphical representation of activity over time. Each bar is an event, such as
an action or condition.

The drop-down lists user sessions in the loaded log file. From the drop-down, filter the chart by
selecting or deselecting user sessions.

Use the mouse scroll wheel to change the zoom level or press Ctrl+Plus to zoom in and Ctrl+Minus to
zoom out. To zoom to a specific chart area, press Shift and draw a rectangle around the required
elements. If zoomed in, drag within the chart to pan.

The context menu provides view options, such as bar and axis labels.
Grid Chart
1/9/2015 11:19:30 212 - 11:20:28 605 -
' EM_TASK_DS_SHAPSHOT |
EM_TASK_PMM_HANDLE_APPLICATION_START [
EM_TASK_MODE_EXECUTION_RUM_PROCESS_START_ACTIONS |:|
USER_PROCESS_START [ |
EM_TASK_DS_SMAPSHOT _REFRESH |
EM_TASK_LOCEDOWMN_APPLICATION START |
EM_TASK_DEYICE_LOCKDOWN_APPLICATION START |
EM_TASK_DS_SMAPSHOT |
EM_TASK_PMM_HAMDLE_APPLICATION START |:|
EM_TASK_PMM_RESTORE_ICOMS |:|

EM_TASK_DS_SMAPSHOT_POSTSHELL_REFRESH [ |

EM_TASK _NODE_EXECUTION_RUN_PROCESS_START_aCTIONS [ |

USER_PROCESS START [ |
Cm
- - - - - - - - - - - - -
] o~ [at) o~ ol (5] o~ [at) [ [ (5] (8] )
o oo () o~ -+ pi=) oo () (&) -+ pi=) o (=)
i i w0 o0 o0 w0 o0 1] 1] 1] 1] 1] =2
o o Lr) ) ) Lr) ) L) L) w1 L) L) =+
= = o = = o = o o o o o =
£ £ ] £ £ ] £ ] ] ] ] ] £
— — — — — — — — — — — — —
= = s = = s = s s s s s =

To display the bar relating to a specific event from the Grid view, right-click the row and select Show in
Chart. To display the row relating to a specific bar from the Chart view, right-click the bar and select
Show in Grid.

Filters Pane

The Filters pane provides filters that can be applied to the current dataset.

You can apply trigger filters in conjunction with other selected filters. For example, selecting Logon
and Actions displays action events in the Logon trigger.

o To show events for the Citrix vDisk Client Settings condition, add File & Folder to the filter.
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[] orphans a

- @ Result

"~

m Passed

E Failed

G| [E

- Policy

= Triggers

2 |:| Computer
- User
b m Logan
[ Logoff
[ Process Started
[ Process stopped
[] Metwork Connected
[] Network Disconnected
[ session Reconnected
[ ] session Disconnected
[7] session Locked
[ session Unlocked
[] windows Personalization
[] Policy Modes

- m Actions

b m Custom & Execute
2 m Drive & Printers
2 m Environment -

e

Select all Deselect Al T Refresh

To apply filters:

1.
2.
3.

4.

Click Filters to expand the Filters pane.

Select the required filters. Click Select All to select all filters or Deselect All to deselect all filters.
Click Refresh.

The filter is applied to the grid or list.

To clear the filtering, expand the Filters pane, click Select All and click Refresh.

Details Pane

The Details pane provides further information about the selected item in the Grid or Chart view.

The left-hand section shows detailed information about the event, such as error details, duration, user
name, user session, and Policy configuration node path. The right-hand section shows the raw log
lines for the selected event.
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~ Details
Mame EM_TASK_CLIENT _IMITIALIZE Time Stamp User Time  Kernel Time  PID TID Event Component  Session Id |Raw Log Line -
Sessionld 1 ¥ 19/2015 11:19:31 827 1 0 2695 2768 StartTask Emuser 1 Event: Start Task Id: 3
Le=re TSI A 1/5/2015 11:19:31 827 1 0 2696 2768 EtwlogMessage Emuser 1 HandlerNode: :RunHandler
Task Client Initialize . .
T Both 1/9/2015 11:19:31 827 1 0 269 2768 Etw Log Message Emuser 1 EmEventDispatcher::Regis
Message  Client Initialize : 1/9/2015 11:19:31 827 1 0 269 2768 Etw Log Message Emuser 1 EmEventDispatcher::Regis
Start Time 1/9/2015 11:19:31 827 1/9/2015 11:19:31 828 1 0 2696 2768 Etw Log Message Emuser 1 EmEventDispatcher::Regis
End Tme  1/9/2015 11:19:31 839 1/9/2015 11:19:31 828 1 0 2696 2768 EtwLlogMessage Emuser 1 EmEventDispatcher::Regis
Duration  012ms 1/9/2015 11:19:31 828 1 0 2696 2768 EtwlogMessage Emuser 1 EmEventDispatcher::Regis
1 0

1/3/2015 11:19:31 828 2696 2768 Etw Log Message Emuser 1 EmEventDispatcher::Regis

You can sort, filter, group, and search the data in the Details pane just as you can in the work area.

For more information, see Work Area.

Look Up Error Codes

Look up system error codes from the log file using the built-in tool.

1. Right-click within the work area and select Error Code Lookup.
The Error Code Lookup dialog displays.

2. Enter an error code.

3. Click w.

The error information displays for the entered error code.
| Error Code Loockup \;‘i-

Enter Error Mumber: 2 W

The system cannot find the file spedified
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User Scenarios

The following sections provide procedures to guide you through common tasks when using this
feature. The scenarios are high level with the processes already documented elsewhere in Environment
Manager Administrative Tools. They may not exactly reflect your particular Environment Manager setup
or business requirements but demonstrate how the feature can be used.

Diagnose a Failed Map Drive Action

Scenario

As an administrator, you want to diagnose why a Map Drive action in your Policy configuration fails.

Process

In the Environment Manager Monitor tool:

1

2
3.
4

Load an Environment Manager log file from an affected user.

Click Search for failed actions and conditions.

In the Filters pane, deselect all actions and conditions except for Map Drive and click Refresh.

In the work area, select one of the failures.

In the Details pane, the error code and error details display.

v Detals
Mode Name
Node Path
Task 1d

Pre Desktop
\LOGON'\Pre DesktopiMap Drive > Z:\ to \\SERVER\SHARE
53C6E9A5-230A-4E30-A107-DEBS7D 12BE78

Result
Error Code
Error

Failed
3
The system cannot find the path specified

Type EMX.MapDrive

Start Time 12{23/2014 10:41:31 696

End Time 12(23/2014 10:41:36 899

Duration 05s 203ms
Result

Time Stamp

12/23/2014 10:41:31 696
12/23/2014 10:41:31 696
12/23/2014 10:41:31 767
12/23/2014 10:41:31 767
12/23/2014 10:41:31 767
12/23/2014 10:41:31 767
12/23/2014 10:41:31 767

Use...

p o o o o o oo

Ker...

y o o o o o oo

TID Event Component Sessionld Raw Log Line -

3004 Star...
3004 Etw ...
3004 Etw ...
3004 Etw ...
3004 Etw ...
3004 Etw ...
3004 Etw ...

Emuser
Emuser
Emuser
Emuser
Emuser
Emuser

Emuser

2 Event: Start Action Id: 47

2 CEMExecutionMode::Execute
2 CEMAction::Execute Create

2 EM::Config::CConfigCOMCreat
2 CreateDriveMapAction

2 EM::Config::CXMLConfig::Dere
2 EM::Config::CreateComAction

The path to the mapped drive cannot be found. Check the Policy configuration to ensure that the
path is correct.
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View Long-Running Logon Actions

Scenario

As an administrator, you want to locate long-running Logon actions in the Policy configuration.

Process

In the Environment Manager Monitor tool:

1. Load an Environment Manager log file.
2. Click Find trigger bottlenecks.
3. Inthe Filters pane, deselect all triggers except for Logon and click Refresh.
4. Sort the work area by the Duration field in descending order.
The work area displays the longest running Logon actions.

In the following example, the Logon trigger took 5s 307ms to complete due to four failing Map
Drive and Map Printer actions:

Type Name Description Session Id  Category Start Time Duration - -

. 0
Task EM_TASK_MODE_EXECUTION_RUM_POST...  Mode Execution Run Post Logon Actions 2 Palicy 12/23/2014 10:47:22 602 06s 216ms
Trigger POST_LOGON Post Logon 2 12/23/2014 10:47:22 602 06s 215ms

Task EM_TASK_NODE_EXECUTION_RUN_LOGQ... Node Execution Run Logon Actions ZPcicv 12/23/2014 10:41:31 639 05s 305ms

Trigger LOGON Logon 12/23/2014 10:41:31 690 055 307ms

Task EM_TASK_MODE_EXECUTIOM_RUM_LOGO... Mode Execution Run Logon Actions

2 Policy 12/23/2014 11:42:46 736 05s 205ms

Result

The failure of the Map Drive and Map Printer actions need to be investigated. If the Policy

configuration is incorrect, it requires updating to avoid this action failing or timing out on each user
logon.

For a user scenario about investigating failed Map Drive actions, see Diagnose a Failed Map Drive
Action.
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View Bottlenecks for Single Session

Scenario

As an administrator, you want to locate Policy or Personalization bottlenecks within a single user
session.

Process

In the Environment Manager Monitor tool:

Load an Environment Manager log file.

1

2

3. Click View/Search all detailed logging.

4. Filter the view so that only a single session is displayed.
5

. Select Parsing > Find trigger bottlenecks to view Policy bottlenecks or Parsing > Find
personalization bottlenecks to view Personalization bottlenecks.

Result

The bottleneck report is displayed for a single user session only. The report can be analyzed to
compare multiple user sessions.
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Environment Manager Logging Setup

The Environment Manager Logging Setup tool provides a user interface to enable and disable the
generation of diagnostic log files.

Administrators or our Support team may need log files to diagnose unexpected Environment
Manager behavior, such as Personalization failing for a specific application, or Policy configuration
actions not applying as expected.

Environment Manager uses Event Tracing for Windows (ETW) to record log events. Log files are stored
in ETL format that can be opened using Environment Manager Monitor.

For information about using Environment Manager Monitor to view and analyze ETL files, see
Environment Manager Monitor.

User Interface

Enable or disable logging in the user interface. Use the options to enable logging for specific
components or set advanced logging settings.

o AppSense Environment Manager Logging Toaol \;li-
-—‘ User | TESTING pgould ls Administrator | YES
Debugging is OM. Enter settings and click OK to save to the registry

General logging | Managed Application logging | Locked down application logging |

Basic settings Advanced peformance settings
Enable ETW logging File size limit (Mb) 512 -
Log fil -
g file name |C.-.L|:|gs \EmTraceLog etl | I:I Max buffers B4 ®
Evert tracing - Buffer size (Kb) 256 =
session name |EM—E-I—“""I—SESS":In | ) =
Min buffers 16 )
Log detail 0 ) - =
® Rollover log () Livelog
Level: Trace () Circularlog (2 Unlimited log
Components to enable
EmCoreService Emlser EmSystem
EmCredentialManager EmlserLogoff EmLoggedOnlUser
EmEsit EmAuthenticationPackage Wirlogon notify package
Winlogon detour EmWOWe4 EmLogoffLiApp
All companents
oK || Cancel
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Enable Logging

1. Click the On/Off button located at the top left-hand corner of the dialog to enable logging.

2. Select the General logging tab and modify the settings as required.

Setting Description

Enable ETW logging

Enable or disable logging on the local endpoint.

Log file name

The location and name to which the log file is written.

Event tracing session
name

The name for the event tracing session. This name is used in
Performance Monitor.

Log detail

The level of detail that is logged.

o Unless advised otherwise by Support, it is recommended
that the Log detail slider is set to Trace.

Components to enable

The components that are logged.

File size limit The maximum size of the log file in Mb if Circular Logging or Live
Logging is enabled.

Max buffers The maximum number of buffers.

Buffer size The size of each buffer in Kb.

Min buffers The minimum number of buffers.

Log File Mode Set the log file mode. The following options are available:

« Rollover log - The log file grows to the specified size limit.
Once it has reached the limit, a new log file is created with a
version number appended to the name.

« Live log - Logging can be viewed in real time using the
Environment Manager Monitor. This is the equivalent of
Real Time logging in Windows Event Tracing. For more
information about opening the live log in the Environment
Manager Monitor, see Load Live Logs.

« Circular log - The log file grows to the specified size limit.
Once it has reached the limit, the log file automatically
overwrites the oldest entries.

« Unlimited log - The log files grows indefinitely regardless
of the size limit.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
Page 39 of 76


http://www.ivanti.com/en-US/company/legal

Environment Manager 10.1 FR4 Administrative Tools Guide

3. Select the Managed Application logging tab and modify the settings as required.

Setting Description

Enable PVC Enable or disable logging for the PVC (Personalization Virtualization
logging Component). A separate log is generated for each managed process
that runs on the endpoint. PVClogging is in text file format.

Enable FBR Enable or disable logging for the FBR (File Based Registry) files used for
logging Application Personalization. FBR logging is in text file format
Enable FBR Enable or disable logging for the FBR (File Based Registry) files used for

logging ifafileis | Application Personalization if an FBR file is detected as corrupted.
detected as
corrupted

Check FBR file for | Check FBR files for corruption and attempt to repair the file where
corruption when | possible.

logging enabled | | 5gging must be enabled for this setting to take effect.

Enabling PVC or FBR logging causes a significant increase in system utilization. Unless
reproducing a problem or advised otherwise by our Support team, it is recommended that FBR
and PVClogging are disabled.
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4. Select the Locked down application logging tab and modify the settings as required.

Setting Description

Enable Lockdown Enable or disable logging for Environment Manager Policy
logging Lockdown activity. Lockdown logging is in text file format. Select
which applications are logged:

« All applications - Log Lockdown activity for all
applications.

o The selected application - Log Lockdown activity for
specific applications. Enter one or more executable names
in the Application name field. Separate executable names
with semicolons.

Enable EmLoader Enable or disable logging for the injection of the EmLoader
logging component. EmLoader logging is in text file format
EmLoader and The location and name to which the EmLoader and Lockdown log

Lockdown log directory | files are written.

Enabling EmUser or Lockdown logging causes a significant increase in system utilization. Unless
reproducing a problem or advised otherwise by Support, it is recommended that EmUser and
Lockdown logging are disabled.

5. Click OK
6. A confirmatory dialog displays.
7. Click OK to confirm.

A log file is created in the specified location and logging is enabled on the endpoint. A reboot or
agent restart is not required for the change to take effect.

Disable Logging

1. Click the On/Off button located at the top left-hand corner of the dialog to disable logging.
2. Click OK.

A confirmatory dialog displays.
3. Click OK to confirm.

Logging is disabled on the endpoint. A reboot or agent restart is not required for the change
to take effect.
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Personalization Server Log Viewer

Interface Overview

Personalization Server Log Viewer provides a user interface to view and analyze log files from the
Environment Manager Personalization Server.

agl Personalization Server Log Viewer = || = -
Eile
Time Stamp Process Id  Thread Id Event Name Message =
L4
3(23/2015 15:04:294 467 13200 7448 Info (1) [ProfileService, HandlerImplementation. GlobalApplication] +Application_s...
3/23/2015 1::04:24 470 13200 7448 Info (1) [ProfileService.HandlerImplementation. GlobalApplication] Personalization. ..
3/23/2015 15:04:24 472 13200 7448 Info (1) [ProfieService. HandlerImplementation. Global Application] Personalization.. .
3/23/2015 15:04:24 472 13200 7443 Info (1) [ProfileService. HandlerImplementation. GlobalApplication] CPU count: 4u...
3/23/2015 15:04:24 473 13200 7448 Info (1) [ProfileService, HandlerImplementation. GlobalApplication] Setting the ser...
3/23/2015 1::04:24 477 13200 7448 Debug (1) [ProfileService. BusinessEntities, PerformanceStats] +PerformanceStats....
3/23/2015 15:04:24 478 13200 74438 Debug (1) [ProfieService. BusinessEntities. PerformanceStats] PerformanceStats. Ar...
3/23/2015 15:04:24 478 13200 7443 Debug (1) [ProfileService. BusinessEntities. PerformanceStats] +PerformanceStats. ...
3(23/2015 15:04:24 488 13200 7448 Debug (1) [ProfileService, BusinessEntities, PerformanceStats] PerformanceCounter. ..
3/23/2015 1::04:24 438 13200 7448 Debug (1) [ProfileService, BusinessEntities, PerformanceStats] PerformanceCounter...
3/23/2015 15:04:24 488 13200 74438 Debug (1) [ProfieService. BusinessEntities. PerformanceStats] < <PerformanceStats. ..
3(23/2015 15:04:24 439 13200 7443 Info (1) [ProfileService. HandlerImplementation. GlobalApplication] +RegisterServ. ..
3(23/2015 15:04:24 503 13200 7448 Info (1) [ProfileService, HandlerImplementation. GlobalApplication] +RegisterServ...
3/23/2015 1::04:24 506 13200 7448 Info (1) [ProfileService, Common.ServerInfo] +HGetFQDN
3/23/2015 15:04:24 515 13200 7448 Info (1) [ProfieService. Common.ServerInfo] +BuildFQOM
3/23/2015 15:04:24 515 13200 7443 Info (1) [ProfileService. Common.ServerInfo] BuildFQDM
3(23/2015 15:04:24 515 13200 7448 Info (1) [ProfileService, Common.ServerInfo] -GetFQDMN
3/23/2015 1::04:24 515 13200 7448 Info (1) [ProfileService.HandlerImplementation. GlobalApplication] ServerInfo.Get...
3/23/2015 15:04:24 542 13200 74438 Debug (1) [ProfieService. DataAccess. Repository ™ 1] ctor ProfileService. Datafcces. ..
3/23/2015 15:04:24 557 13200 7443 Debug (1) [ProfileService. DataAccess. DatabaseConnection] +InitializeConnection
3(23/2015 15:04:24 613 13200 7448 Debug (1) [ProfileService, DataAccess. DatabaseConnection] -InitializeConnection
3/23/2015 1::04:24 627 13200 7448 Debug (1) [ProfileService.DataAccess. Repasitory] ProfieService. DataAccess, IntCa. .. .
Showing 1847 entries from file 'PersonalizationServer.20150323030424. etl'

The tool is compatible with Personalization Server log files in an ETL format only

For information on how to analyze endpoint log files, see Environment Manager Monitor.

Load a Log File

1. Select File > Open.
A file browse dialog displays.
2. Select an ETL log file and click Open.

Personalization Server Log Viewer loads the log file. The loading progress displays at the
bottom of the dialog.
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Export Logs

1. Select File > Export.

Select a format to export to. The following options are available:

(e}

[¢]

[e]

[e]

o

o

Excel

csv

Text

Rich Text
Web Page
PDF:

A file save dialog displays

2. .Select an export location and click Save.

The current dataset is exported to the selected location.

Sort Columns

Right-click a column heading.

Select a sort order:

« Sort Ascending - Sort the data in ascending order.

» Sort Descending - Sort the data in descending order.

To clear the sorting, right-click the column heading and select Clear Sorting.
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Filter Columns from Existing Values

This option displays all of the unique values for a field, such as all Thread IDs, from the open log file.
Columns can be filtered by a specific value from the dataset.

1. Hover over a column heading and click the filter icon.

A list of unique values within the column displays.

Eile
Time Stamp

3/23/2015 15:04:24 467
3/23/2015 15:04:24 470
3/23/2015 15:04:24 472
3/23/2015 15:04:24 472
3/23/2015 15:04:24 473
3/23/2015 15:04:24 477

Process Id

13200
13200
13200
13200
13200
13200

Threadld T
(Custom)

(BElanks)

742 (Non blanks)
7448
a972

744 106365

744 12064

44

) [ProfileService . Handlerl
) [ProfileService. Handler?
) [Profileservice. Handlerl
) [ProfileService . HandlerT
"’/f.} [ProfileService . HandlerT

7448 Debug

2. Select a value on which to filter the selected column.

The data is filtered to show only entries that match the criteria.

(1) [ProfileService. Bus

To clear the filtering, right-click the column heading and select Clear Filter.
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Filter Columns using Auto Filter Row

The Auto Filter Row displays above the dataset and allows columns to be filtered by entering basic
filtering criteria.

1. Right-click a column heading and select Show Auto Filter Row.:
2. The Auto Filter Row displays below the column headings.

3. To filter a column, enter text into the Auto Filter Row.

ol Personalization Server Log Viev =
File
Time Stamp Process Id  Thread Id Event Mame Message
v 12080
3/23/2015 15:05:58 429 13200 12064 Info (449) [ProfileService. Glok
3/23/2015 15:05:58 429 13200 12064 Info (449) [ProfileService.Glo

The data is filtered to show only entries that match the criteria entered in the Auto Filter Row.

4. To clear the filtering, right-click the column heading and select Clear Filter.
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Filter Columns using Filter Editor

The Filter Editor allows conditions to be created to target specific data in the dataset. Use multiple
expressions and nested Boolean operators to crate complex conditions.

1. Right-click a column heading and select Filter Editor.
The Filter Editor dialog displays.

2. Edit the condition as required:

o Click a red Boolean operator, such as And to edit the operator or add a new condition
group.

o Click a blue field name such as [Time Stamp] to change the field to match.
o Click a green operator such as Equals to edit the operator.
o Click either <enter a value> or a black value to enter a value.

o Click = to add a new expression to the condition.

[Thread Id] Equals 7448 &
[Thread Id] Equals 12064 &4

3. Click Apply to preview the filter.
4. Click OK.
The data is filtered to show only entries that match the criteria entered in the Filter Editor.

To clear the filtering, right-click a column heading and select Clear Filter.
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Group Columns

Data can be grouped by one or more columns to create nested datasets.

1. Right-click a column and select Group By Box.
The Group By box displays above the column headings.

2. Drag a column heading into the Group By box. More columns can be dragged into the Group
By box to create nested groupings.

o)
File
Process Id =
Thread Id «
Time Stamp Event Mame Mes

* Process Id : 13200 (4)
¢ Thread Id : 7448 (34)

The data is grouped by the fields specified in the Group By box.
To clear the grouping, right-click on the Group By box and select Clear Grouping.

Search Log Entries

1. Press Ctrl+F.
The Find Panel displays above the column headings.
2. Enter asearch term.
3. Click Find.
Rows containing text in any column that matches the entered search term are displayed.

To clear the search, click Clear in the Find Panel or close the Find Panel.
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Command Line Interface

The Personalization Server Log Viewer tool also provides a command line interface. The following
commands are available:

o Open the userinterface

EtwLogFileReader.exe

o Openan ETL log file in the user interface
EtwLogFileReader.exe C:\Logs\Input.etl

« Convert an ETL log file to text file
EtwLogFileReader.exe C:\Logs\Input.etl /export

o Convertan ETL log file to text file in a different output directory
EtwLogFileReader.exe C:\Logs\Input.etl /export:C:\Temp\Output.txt
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Environment Manager Log File Conversion

The Environment Manager Log File Conversion tool (EtI2Txt) is a command line driven tool to convert

ETL log files to text files.

o It is recommended that the Environment Manager Monitor is used to view and analyze ETL
log files. For further information, see Environment Manager Monitor.

The Environment Manager Log File Conversion tool is located in the Tools installation folder and is run
from the command prompt.
To run the Environment Manager Log File Conversion tool:

1. Open the Run dialog and enter cmd.exe.

2. Using the command prompt, navigate the Tools installation folder -
%ProgramFiles%\AppSense\Environment Manager\Tools\.
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3. Run the Etl2Txt.exe, together with the appropriate parameters as detailed in the following
table:

Parameters Input Parameter Details
Arguments
g n/a Outputs the help text to the console.
-help
-f filename Specify the name of the source ETL file to convert.
——filename This is a required parameter.
-C components | Specify the name of the Environment Manager
—--components components to include in the conversion:
o EmUser
o EmCoreService
o EmSystem
o EmUserLogoff
o Other
Separate multiple components with a space.
If the parameter is not specified, all components are
included by default.
-s yes or no Specify whether output log files are split or collated:
--split_output « yes - Output log files split by Environment
Manager component.
« no - Output a single collated log file for all
Environment Manager components.
If the parameter is not specified, the argument
defaults to yes.
-1 yes or no Specify whether trace events are included in the
--include events output:
» yes - Output trace events with the raw log
lines.
« no - Output raw log lines only.
If the parameter is not specified, the argument
defaults to no.
-e yes or no Specify whether trace events are output:
--events_only « yes - Output trace events only.
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Parameters Input Parameter Details

Arguments

« no - Output raw log lines and, if --include
events is set to yes, trace events.

If the parameter is not specified, the argument
defaults to no.

-0 path Specify the directory for the output files.

--output_dir If the parameter is not specified, the current
directory is used for the output.

-t yes or no Specify how log levels are displayed:
—~text_levels « yes - Output log levels as text.
« no - Output log levels as numbers.

If the parameter is not specified, the argument
defaults to no.
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EMP File Utility

The Environment Manager Personalization File Utility (EMP File Utility) imports and exports files to and
from the Environment Manager Personalization database using a command-line interface. Before the
tool can be used, a valid connection string to the database must be defined. The user specified in the
connection string must have the privilege to read, write, and run stored procedures in the database.
The simplest privilege is "dbowner".

The utility accesses the database directly and does not use a Personalization Server.

This is a low level tool that uses elements of scripting in the command-line interface to input
commands and set parameters. A knowledge of command-line utilities and scripting is an
advantage when using this tool.

[N Administrator: EMP File Utility
Type "EMPFileltil ~7" for help

C:“Program Files <xB6>-~AppSense~Environment Manager~Tools>

Requirements

A username and password of a user with access to the database tables is required because the utility
accesses the database directly. Using the Personalization service account will not work.

Supported software versions

The EMP file utility no longer supports older versions of Environment Manager. The 8.5 utility can only
be used on software version 8.5.
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Windows Settings Group Support

The file utility may be used to import and export files from windows settings groups contained in the
parent Windows Settings profile. To do this the application name is replaced by the Windows setting
group name prefixed by "wsg:". For example, to import and export from the Windows Setting group
named Appearance and Personalization, specify wsg:Appearance and Personalization as the application
name.

Usage Scenario

A typical scenario is when a specific user or group requires that a certain file is updated through a
batch process rather than via a user interface. The EMP File Utility can also be used in conjunction with
Environment Manager Policy Configuration to directly manipulate the users settings within the
database.

Export a File from a Database

A valid connection string to the database must be defined in the environment variable
EMPFileUtilConnectionString inthe same command window in which EMPFileUtil is run. This
procedure shows how to set the environment variable and then run the utility.

1. Select Start > AppSense > Environment Manager > Tools > EMP File Utility.

2. Onthe command line, enter SET EMPFileUtilConnectionString=<connection
string>

Forexmﬂpb,SET EMPFileUtilConnectionString=Data Source=(local);Initial
Catalog=PersonalizationServer;Integrated Security=SSPI

3. Press Enter.

This environment variable can also be set globally in the System Properties. For

o Windows Vista and above, right-click Computer on the Start menu and select
Properties. Select Advanced system settings, click the Advanced tab and select the
Environment Variables button.
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4.

In the command line, enter a command in the following format: EMPFileUtil EXPORT
<username> <usergroup> <application> <databaseroot> <outputfolder>

Where:

Parameters Definition

<username> The user’s name with preceding domain, for example,
appsense\smithj
<usergroup> The personalization group for the user, for example, “Default

Users”

<application>

The name of the application or group (not the name of the
executable, although it may be the same, for example Notepad), or
the name of the Windows Settings group prefixed by “wsg:".

If the name contains spaces, the entire parameter, including the
wsg:, must be included in quotation marks The following reserved
application names are recognized:

« Certificates (for Legacy Certificates profile)

« Legacy Certificates

« Windows Settings

« Windows Personalization (for Windows Settings profile)

o Legacy Session Data

<databaseroot>

The root of the file tree to be exported in “raw” format, for
example, {CSIDL_APPDATA}.

The value * (asterisk) may be used here to export all of the files in
the directory. This also exports the registry file “settings.for” (or
“registry.fbr” in the case of a Windows Setting group). These files
should be re-imported only to the same user because they contain
the user’s SID.

Note; In such cases it might be more appropriate to use the EMP
Registry Utility for transfer of registry settings.

See EMP Registry Utility for further details.

<outputfolder>

The folder where the files are to be exported. A directory structure
is built here matching the one in the database. Relative paths can
be used, for example, a dot refers to the current path.

Existing files are not overwritten and folders are created as
required.
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Parameters Definition

Parameters Definition

<username> The user’s name with preceding domain, for example,
appsense\smithj

<usergroup> The personalization group for the user, for example, "Default

Users”

<application>

The name of the application or group (not the name of the
executable, although it may be the same, for example Notepad), or
the name of the Windows Settings group prefixed by “wsg:".

If the name contains spaces, the entire parameter, including the
wsg:, must be included in quotation marks The following reserved
application names are recognized:

« Certificates (for Legacy Certificates profile)

« Legacy Certificates

« Windows Settings

« Windows Personalization (for Windows Settings profile)

o Legacy Session Data

<databaseroot>

The root of the file tree to be exported in “raw” format, for
example, {CSIDL_APPDATA}.

The value * (asterisk) may be used here to export all of the files in
the directory. This also exports the registry file “settings.for” (or
“registry.for” in the case of a Windows Setting group). These files
should be re-imported only to the same user because they contain
the user’s SID.

Note; In such cases it might be more appropriate to use the EMP
Registry Utility for transfer of registry settings.

See EMP Registry Utility for further details.

<outputfolder>

The folder where the files are to be exported. A directory structure
is built here matching the one in the database. Relative paths can
be used, for example, a dot refers to the current path.

Existing files are not overwritten and folders are created as
required.

o Parameters must be enclosed in quotes if they include embedded spaces.

5. Press Enter to export all applicable files.
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Import a File to the Database

Select Start > AppSense > Environment Manager > Tools > EMP File Utility.
On the command line enter a command in the following format:
EMPFileUtil IMPORT <importdescription>.xml

The XML file contains information about users, application groups, and files to be loaded into the
database.

There can be one XML file per user, or lots of users in the same file.

Example XML File

<?xml version="1.0" encoding="utf-8"?>
<Users>

<User

Name="appsense\smithj"
RetrieveSID="yes" >
<PersonalizationGroup

Name="Default Users">

<Application

Name="Groupl"

Type="group"

DeleteExisting="yes"
RootFolder="c:\Dev\TestData\Groupl" />
<Application

Name="Notepad"

Type="single"

DeleteExisting="yes"
RootFolder="c:\TestImport\Notepad" />
</PersonalizationGroup>

</User>

<User

Name="appsense\jonesa"
RetrieveSID="no"
Sid="S-1-5-21-203209604-3446334822-3473717970-1002" >
<PersonalizationGroup

Name="Default Users">

<Application

Name="0Office"

Type="group"

DeleteExisting="yes"
RootFolder="c:\TestImport\Office" />
<Application

Name="Notepad"

Type="single"

DeleteExisting="yes"
RootFolder="c:\TestImport\Notepad" />
</PersonalizationGroup>

</User>

</Users>

There can be one or more <User> elements under the top-leve I<Users> element. Each User element
can specify multiple Personalization groups (User groups) for a user if required.

Multiple applications can be specified under the <PersonalizationGroup>. Each application has a
folder where the utility finds the files to read - the RootFolder attribute.
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Element Attribute Meaning

User Name User name in the form domain\user. This user need not
exist if the SID is specified. The user need not have
logged on to the Personalization server previously.

RetrieveSID Value is “yes” or “no”. If “yes”, EMPFileUtil will check AD
(if in a domain) or the local machine (if not) to find the
user's SID.
SID User's Sid, required if RetrieveSID="no" has been
specified.
PersonalizationGroup | Name Name of the group to which the user and applications

are to be loaded. This group must exist already. Note
that you will create redundant data if the memberships
do not put the user in the group.

Application Name Name of the application, application group or Windows
Settings group preceded by “wsg:". A group must be
assigned to the Personalization Group or EMPFileUtil
reports an error. Reserved application names (as listed
for export above) may be used, but note that importing
into a legacy profile will only affect legacy clients.

Type “Single” for an application or “group” for an application
group.

DeleteExisting | “Yes” or “no”. If the application already exists with data
for the user/group, specifying “yes” will cause
EMPFileUtil to delete all the old data. If "no”, new files
will be added. If a new file has the same name and path
as the old, a duplicate key error is generated and
processing stops.

Path where files to be imported are situated. The root
must contain subdirectories of the form {CSIDL_xxx},
and no files. Below this anything is allowed and will be
loaded into the database. Registry files cannot be
loaded - this must be done instead with EMPRegUtil.

Personalization Analysis

Once the XML file has been imported you can drill into the users settings using the Personalization
Analysis too.
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For more information on Personalization Analysis see Personalization Analysis in the Environment
Manger Help system.
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EMP Migrate Utility

The Environment Manager Personalization Migrate Utility (EMP Migrate Utility) is a standalone tool
that allows user data to be copied from a source database to a target database, mapping the user
names to the target domain and adjusting saved registry settings accordingly. The utility contacts the
respective databases directly and does not use existing personalization servers.

The utility checks the personalization group of each user that it encounters on the source database
with a group of the same name on the target database. If incomparable data exists whereby users or
groups are listed on the source but not the target databases, an Import/Export operation from the
Environment Manager console has to be performed to align both the source and target databases.
When the comparison is complete you can view an output summary by clicking View Log.

The following table shows the EMP Migrate Utility version requirements for source and target
databases.

EMP Migrate Utility Version Source Version Target Version

8 FR4 8.1,82,830r8 8 FR4
FR4

8.5 8.5 8.5

8.6 8.50r 8.6 8.6

10.x 8.5 or later 10.x

For more information about the Import/Export function, see Import and Export Personalization
Configurations in the Environment Manager help.

Usage counts are not transferred for applications so the count starts again on the new database.
Therefore transferred applications do not appear on the Application Usage report. Usage counts for
discovered applications are set to one on transfer and appear on the Discovered Application report.

Usage Scenario

Typical usage of the EMP Migrate Utility can be when a specific user or group requires access to, for
example, a User Acceptance Testing (UAT) environment for testing a particular application. The EMP
Migrate Utility can be used to migrate the users existing personalization data from a UAT database

into the production database to ensure the user has a consistent experience in both environments.

Another example is when a specific user is moving from one region to another, the EMP Migrate Utility
can be used to migrate the users personalization data ahead of time to ensure that the user has a
consistent experience in the new location.
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Runthe EMP Migrate Utility

1. Select Start > All Programs > AppSense > Environment Manager > Tools > EMP Migrate
Utility.
2. Inthe Target Database dialog, enter the following information for the target database that will
receive data:
o SQL Server Name\lnstance
o SQL Database Name
o User ID and Password (or select Use Windows Authentication to use the current
Windows identity)

The user must have sufficient privileges to modify data in the tables directly in the
database. The service account user (used by Personalization Servers) is not sufficient, as
this only has permission to run stored procedures.

& Target Database

— Data Source

Server MameInstance:

DEVSGLNSGL DOCS

— Database Name

Database Name

IPersunaIizatinnSen.rer

— S0QL Server Authentication

Login: I

Passwaord: I

WV Use Windows Authentication

Test QK Cancel
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3. Click OK to connect and display the console.

Q EMPMigrate - Environment Manager Personalization Migration Tool — x

Configure databases and domain mapping

Source database  Click button to select database

Target database |TWE_2KER2 9\SOQLEXPRESS - PersonalizationServer

Domain mapping Use current domain =

Select users or personalization groups

Groups 4 Add All Users <] Remove

L addUsers i Ad

=

Start Migration Exit

4. Click the ellipsis (...) to select the Source database.
5. Select the domain mapping from the Domain mapping drop-down menu:
o Use current domain- The domain in which the utility is running is used

o Map to new domain- Use the ellipses to select the domain or enter the NetBIOS name
of the domain directly into the field.

o No domain mapping- Users are not modified if this option is selected. This is useful for
combining databases in the same domain.
If domain mapping is used, the domain of all selected users is altered to the target
database, regardless of the previous values. The utility must be able to look up the SID of
each user in the target domain.

o The utility does not add the users to Active Directory for the target domain.
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6. Select the users you want to add using the following options:

o Add Users - Select users from available groups. Enter the name, optional domain or
select a user group and click Search to display the users within that group.

o Click the Load file... button to load a list of users from a CSV file. Each user must be
separated by a comma:

m User list.csv - Notepad

File Edit Format Wiew Help
lLizerl, User?, Uszer3, Userd, Users

o Add Groups - Select all users from a group.
o Add All Users - Select all available users from the database.
7. Users and groups can be taken out of the migration using the Remove button.

8. Once all the required users have been added, click OK.
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9. Click the Start Migration button to display the Migration Options.

[

EMPMigrate - Migration options

Specify migration options

] Ignore global data differences

Skip the chedk that global settings match in source and target,
Global settings refer to the global path data (global registry and file path
indudes and exdudes) and Windows Setting Groups.,

L] Replace existing users’ data

If existing data is found for a user, the transferred
data replaces it.

Ll Copy archives

Copy archives as well as current data

L] Copy discovered applications

Copy discovered applications

< Back Mext =

10. Use the check boxes to apply the following settings:

o Ignore global data differences - If any global data differences exist between the source
and target databases the tool will ignore these discrepancies and proceed with the
migration. Global data refers to the global path data, such as global registry file path
includes and excludes and Windows Setting Groups.

o Replace existing users' data - If the same user is found for a user, the old data is
deleted and replaced by the source data. If unchecked the old data is not replaced.

o Copy archives - Archive data as well as current data is transferred.

o Copy discovered applications - Discovered applications are transferred.
11. Click Next to start the transfer.
12. A processing dialog displays, showing the number of transfers which pass and fail.

13. When complete, the Error and View Logs can be scrutinized using the available buttons. The
logs are written to the current user's Documents folder.

Copyright © 2017, Ivanti. All Rights Reserved. Terms of Use.
Page 63 of 76


http://www.ivanti.com/en-US/company/legal

Environment Manager 10.1 FR4 Administrative Tools Guide

14. Once you have migrated the data, you can launch the Personalization Analysis tool on the
target database to see the data exist for the migrated user.

o The EMP Migrate Utility does not remove the users data from the source database.
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EMP Migrate Command Line Utility

The Environment Manager Personalization Migrate Command Line Utility (EMP Migrate Command Line
Utility) is a command line driven tool that allows user data to be copied from a source database to a
target database, mapping user names to the target domain and adjusting saved registry settings
accordingly. The utility contacts the respective databases directly and does not use existing
personalization servers. The EMP Migrate Command Line Utility provides the same functionality as the
EMP Migrate Utility.

The EMP Migrate Command Line Utility is located in the Tools installation folder and is run from the
command prompt.

Run the EMP Migrate Command Line Utility

1. Open the Run dialog and enter cmd.exe.

2. Using the command prompt, navigate the Tools installation folder:
%ProgramfFiles%\AppSense\Environment Manager\Tools\

3. Run the EMPMigrateCmd.exe together with the appropriate parameters as detailed in the
table below.

EMP Migrate Command Line Utility Parameters

Parameters Input Arguments Parameter Details

/7 n/a Outputs the help text to the console.
/help

/sourcedb dbname The name of the source database.

This is a required parameter

/sourceinstance server[\\instance] The server or instance name for the source
database. The instance name is optional.

This is a required parameter.

/targetdb dbname The name of the target database.

/targetinstance server[\\instance] The server or instance for the target database.
The instance name is optional.

This is a required parameter.

/sourcewindowsauth | trye or false The authentication type used to connect to
the source database:

o true - use this argument to use the
Windows authentication type.
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Parameters Input Arguments Parameter Details

« false - use this argument to select the
SQL authentication type.

If an argument is not specified Windows
authentication is automatically used.

/sourcesglusername | ysername The username for SQL authentication on the
source database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/sourcesqglpassword | password The password for SQL authentication on the
source database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/targetwindowsauth | trye or false The authentication type used to connect to
the target database:

o true - use this argument to use the
Windows authentication type.

« false - use this argument to select the
SQL authentication type.

If an argument is not specified Windows
authentication is automatically used

/targetsqglusername | ysername The username for SQL authentication on the
target database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/targetsglpassword | password The password for SQL authentication on the
target database. If SQL authentication is
required set the sourcewindowsauth
parameter to false.

/domainmapping [current]|[map]| The type of mapping to apply for users to the
[nomap] new domain. If not specified this parameter
defaults to current.

/mapto domainname The target domain name if the mapto
parameter is set to map.

/users [all]|[group]]|[list] Specifies which users to migrate:
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Parameters Input Arguments Parameter Details

« all - migrate all users.

o group - migrate usersin a
personalization group.

« list - migrate user listed to a specified
file.
This is a required parameter.

If duplicate users are found in the source
database, only the most recent user will be
migrated.

/usersgroup groupname The name of the personalization group to
migrate. Used when users is set to group.

/userlist listfile Full path to a file containing a list of users to
migrate. Used then users is set to list.

The file path must be enclosed in quotation
marks. Each user listed in the file must be on a
separate line or in CSV format.

If a filename is specified without a path, the
EMPMigrateCmd.exe working directory is

assumed.
/options [replace], One or more of these options can be specified
[ignoreglobal], by comma separating parameters:
[copyarchives], « replace - this option replaces existing
[copydiscovered] user data in the target database.

« ignoreglobal - ignores differences in
global data settings.

» copyarchives - copies the user's
archives together with their current
data.

« copydiscovered - copies the user's
discovered applications.

/output outputfile The output location of the report file. When
specifying the output path, the path name
must be enclosed in quotation marks. If a path
has not been specified, a default path of
%USERPROFILE%\\Documents\\EMPMigrate.log
is used.
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Parameters Input Arguments Parameter Details

/threads number The number of threads used when migrating
the data. A value of 0 forces the number of
threads used to equal the processor count
and is the default value.

Required Format of User Names

User names must match the dbo.User.Name field in the Source database. These are in the down-level
logon name format as defined by Microsoft. For example, the format for the user, ExampleUser, in the
local domain AppSense.local is APPSENSE\ExampleUser. Using the fully qualified APPSENSE.local
domain name causes the user to be ignored and not migrated. While technically correct, it does not
correspond to the Name field specified in the database.

The User Principal Name (UPN) format is not supported.
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Usage Scenarios and Solutions

The following scenarios demonstrate how the EMPMigrate Command Line Utility can be used. For the
purpose of these scenarios SrcSqlrepresents the source location and TgtSQL the target destination.
Each scenario includes an outline of a task to be completed, followed by the command line solution.

Scenario One

Using Windows Authentication, you are required to migrate a Personalization Group called Prod Users
to a new target location and replace existing user's data in the target database with from the source
database. To migrate the group, you must check if the Personalization Group exists on your target
location and check for no difference in the global data settings.

Solution

EMPMigrateCmd.exe /Sourcelnstance SrcSQL /SourceDB PSDB /TargetInstance
TgtSQL /TargetDB PSDB /Users Group /UserGroup "Prod Users" /Options Replace

Scenario Two

Using Explicit SQL Credentials for both the Source and Target locations, you are required to migrate all
users to a target location. The migration must replace existing Personalization Groups, ignoring any
global data differences but must not map to a new domain.

Solution

EMPMigrate.exe /Sourcelnstance SrcSQL /SourceDB PSDB /SourceSQLusername sa
/SourceSQLPassword sourcePass /TargetInstance TgtSQL /TargetDB PSDB
/TargetSQLUsername sa TargetSQLPassword targetPass /DomainMapping NoMap
/Users All /Options Replace, IgnoreGlobal

Scenario Three

Using Windows Authentication in the source location, you are required to migrate a list of users found
in c:\Temp\UserList.txt to a target location that requires explicit SQL credentials. The migration must
replace existing Personalization Groups and include data for Discovered Applications. It must ignore
any difference in global data settings but must not map to a new domain.

Solution

EMPMigrate.exe /Sourcelnstance SrcSQL /SourceDB PSDB /TargetInstance TgtSQL
/TargetDB PSDB /TargetSQLUsername sa /TargetSQLPassword targetPass /Users
List /UserList "c:\Temp\UserList.txt" /Options

Replace, IgnoreGlobal, CopyDiscovered
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EMP Registry Utility

The Environment Manager Personalization Utility (EMP Registry Utility) is a command-line utility that
can import and export REG files to and from an Environment Manager personalization database. It
also includes a function to delete keys. The REG files are in the same format used by the Microsoft
RegEdit utility. All functions apply to a single application for a single user.

Requirements

A username and password of a user with access to the database tables is required because the utility
accesses the database directly. Using the Personalization service account will not work.

Windows Settings Group Support

The registry utility can be used to import and export registry setting files from Windows Settings
groups contained in the parent “Windows Settings” profile. To do this the application name is
replaced by the Windows Setting group name prefixed by “wsg:”. So to import and export from the
Windows Setting group named "Appearance and Personalization”, specify “wsg:Appearance and
Personalization” as the application name.

Usage Scenario

A typical scenario is when a user or group requires that a certain registry key is updated through a
batch process rather than via a user interface. The EMP Registry Utility can also be used in conjunction
with Environment Manager Policy Configuration to directly manipulate the users settings within the
database.
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Define a Connection String for the Database

A valid connection string to the database must be defined in the environment variable
EMPFileUtilConnectionString in the same command window that EMPRegUtil is run. This
procedure shows how to set the environment variable and subsequently run the utility.

1.
2.

Select Start > AppSense > Environment Manager > Tools > EMP Registry Utility .

On the command line, enter SET EMPRegUtilConnectionString=<connection
string>.

For example, SET EMPRegUtilConnectionString=Data Source=(local);Initial
Catalog=PersonalizationServer; Integrated Security=SSPI

Press Enter.
This environment variable can also be set globally in the System Properties.

On the command line, enter EMPRegUtil followed by the command and parameters for the
required function:
o EXPORT <user> <group> <app> <key> <file>

© IMPORT <user> <group> <app> <file>

°© DELETE <user> <group> <app> <key>
For example: EMPReqUtil EXPORT domainl\smithj “Default Users” Outlook
HKEY CURRENT USER\Software\Outlook Outlook.reg.

Press Enter to perform the specified function.
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File Based Registry Explorer

When Environment Manager personalizes an application on an endpoint, registry writes from the
application are captured to a File Based Registry (FBR) file called settings.fbr in the virtual cache for
that application. Registry keys captured are those defined in the global inclusion/exclusion list and any
application-specific list defined in the personalization database.

When the application exits, Environment Manager saves the cache contents, including the settings.fbr
file, to the personalization database. When the application is next run, the cache contents are
restored from the database.

The FBR Explorer provides a way to view the settings.fbr file on the endpoint. Although it is possible to
make edits to the file in the FBR Explorer, they are ineffective because the file will be overwritten with
the copy from the database the next time the application is run. To make changes, it is necessary to
edit the database copy using the registry edit function of Personalization Analysis in the Environment
Manager console.

Although the FBR Explorer is available to use it is recommended to use Personalization Analysis in the
Environment Manager console.

For more information, see the AppSense Environment Manager Personalization Product Guide.

Incorrectly editing the registry may severely damage your system. Before making changes to the
registry, you should back up any valued data on your computer.
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Usage Scenario

The FBR Explorer is used to open the virtual FBR files created by User Personalization and allows you
to view a given users virtual registry for a given application. The FBR Explorer provides a client side
ability to open and view a FBR file for an application, allowing you to review which registry keys are
being used by the application with regards to the user.

BN FBR Explorer C:\settings.fbr

File  Help

| Registry Mame Type Data
|-[2] USER
e
=[] Software
=[] Microsoft
[ cTF
[ Internet Explarer
[ M3 Design Tools
D ISDAIPP
[ Office
[T Shared
[[7] Shared Toals
[0 WebService Provider:
[ Windows
[ Windows NT
[] Metscape
[ oDBC

< | 2 [

\Reqgistry USERYS-1-5-21-1649455457-385503046-1 23223684 - 1000

|
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Create a New Entry or Data Type, Rename, or Delete

1. Select Start > All Programs > AppSense > Environment Manager > Tools > FBR Explorer.
2. Select File > Open.
The Open dialog displays.
3. Navigate to the FBR file and click Open.
The FBR file displays in the FBR Explorer and is organized into a tree format.
4. Torefresh the FBR Explorer tree at any time, select File >Refresh or press the F5 key.
5. Perform one or more of the following actions:

o To create a new entry or data type, right-click a node or data type in the FBR Explorer
tree and select New.

o A new node or data type is created.

o Torename an entry or data type, right-click a node or data type and select Rename.
Enter the new name for the node or data type in the FBR Explorer tree.

o For adata type specify the Value type and Value data and click OK.
For more information on data types, see Data Types.
6. To delete an entry, right-click the node and select Delete.

The node and all sub-nodes are deleted.:

When you delete a node or data type from within the FBR Explorer it is automatically
o deleted. A confirmation message is not displayed and you cannot undo. Ensure that
you want to delete the node before selecting the Delete command.

Export a FBR File from the FBR Explorer

You can export the entire FBR file for a single user or a section of the FBR file. The default export file
extension is REG. You can double-click this file to add the information contained within the file to the

registry.

1. Do one of the following:
o To export the complete FBR file for a user, right-click the Registry node in the FBR
Explorer tree and select Export.

o Right-click the node that contains the section you want to export and select Export.

2. Enter a name for the export file and click Save.

Edit the Data Value for a Data Type within an FBR File

1. Right-click the node that contains the data type and select Edit.
The Edit Value dialog displays.
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2. Edit the data value and click OK.

E FBR Explorer, C:\settings.fbr

|A

=[] Eeplorer
[0 Advanced
[T Discardable
0] FileBas
[ MountPoints2
[) sessioninfo
[T Shell Folders
[ UserShell Falds
[ MewEntry

[ T AU P —

>

[;j ShowSuperHidden
[;] ShowTypelverlay

[;| WebView

|A

REG_DWORD
REG_DWORD
REG_DWORD

File  Help

=[] CTF || MName Type Data
(3 DirectswitchHotkeys () AutoCheclselsct REG_DWORD 000000000 {0}
0 me () bontPratrypath REG_DWORD 000000000 {0}
(9 imernet Explorer [ Fitter REG_DWORD 0x00000000 (0}
S ::E;;?fnm's ) Hidden REG_DWORD 0:00000001 1)
0 offce e cec oworn 0x00000000 {0
[ Sharsd __|lcan | Mew. .. REG_DWORD 0x00000000 (0)
[ SharedTools [;|TV1EI|:| Edt... |REG_ WORD 000000000 {0)
[[0] WebService Providers [;JSEF' Rename REG_DWORD 0x00000000 {0}
=[5 Windows C)she Doiet REG_DWORD 0x00000001 (1)
=[] Currentversion [;|5|10 Elele FEG_DWORD 0x00000001 (1)

0x00000001 {1)
0x00000001 1)
0x00000001 1)

|
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Data Types

The following table shows the data types currently defined and used by the system.

Data type Description

REG_BINARY Raw binary data. Most hardware component information is
stored as binary data and displays in the Registry Editor in
hexadecimal format.

REG_DWORD Data represented by a number that is 4 bytes long. Many

parameters for device drivers and services are this type and are
displayed in the Registry Editor in binary, hexadecimal, or decimal
format.

REG_EXPAND_SZ

A variable length data string. This data type includes variables
that are resolved when a program or service uses the data.

REG_MULTI_SZ A multiple string. Values that contain lists or multiple values in a
form that people can read are usually this type. Entries are
separated by spaces, commas, or other marks.

REG-SZ A fixed length text string.

REG_FULL_RESOURCE_
DESCRIPTOR

A series of nested arrays designed to store a resource list for a
hardware component or driver.
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