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CAM Administrator Overview
CAM Administrator is the integrated user interface for administrators to manage Cherwell Asset
Management, see data, and monitor software usage in real time.
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What Is CAM?
Cherwell Asset Management (CAM) is a specialized IT asset management solution that tracks and
integrates all the data related to your hardware and software inventory, usage, entitlements, and
purchases.  By consolidating, reconciling, and reporting on all your critical IT asset data, Cherwell Asset
Management enables you to track and manage your organization’s IT assets from purchase through
retirement using one straightforward, easy-to-use product.

Cherwell Asset Management gives you the information and tools you need to:

• Stay compliant with licensing agreements.

• Eliminate spending on unused software.

• Manage hardware assets.

• Track and report on IT assets.

• Keep unauthorized applications off the network.

Cherwell Asset Management is available to use as a standalone product, or in tandem with Cherwell
Service Management. Contact us for more information.
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How Cherwell Asset Management Works in an On-
premises Installation

The CAM architecture diagram illustrates how data flows in on-premises installations.

Cherwell Asset Management collects and uses data in on-premises installations as follows:

• The CAM Agent captures information about applications present on the machine (inventory), when
those applications are started and stopped (metering), and some configuration data.

• This information is passed to the CAM Access Point, which manages communications between the
agent and the database. Organizations may use multiple access points (for example, for scalability
reasons or to provide separate access points for certain domains).

• The access point passes the information to the CAM Database, which stores the collected data. You
should only have one CAM Database.

• If applications are being controlled, the CAM Access Point may respond to the notification of an
application launch to block the launch or warn the user (control).

• When you open CAM Administrator, the collected information passes through the CAM
Administration Service. The CAM Administration Service includes all the administrative services to
support presenting the information to CAM Administrator and the ability to perform tasks like
automatically configure license units and run discovery.

• The authentication service facilitates secure communications between agents, web applications,
and the CAM Database and CSM Database.

• Comprehensive reporting of collected and processed data is presented via the Reporting website,
which runs on Microsoft Internet Information Services (IIS) and is accessible from a browser on any
machine.

• Comprehensive purchasing information is presented via the Purchasing website, which, like the
Reporting website, runs on IIS and is accessible from your browser.

• Using the data collected from CAM Administrator and Purchasing, License Analytics evaluates your
organization's compliance with contractually-specified rights for certain Microsoft products.  
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Download CAM
To download the latest CAM image:

1. Log in to https://cherwellsupport.com

2. Click Downloads.

3. Click Download Cherwell Asset Management.
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How Cherwell Asset Management Works in a
Hosted Installation

The CAM architecture diagram illustrates how data flows in hosted installations.

Cherwell Asset Management works much the same in a hosted installation as it does in an on-premises
installation. The difference is that, with a hosted installation, some components are on premises and
others reside on a cloud server.

The on-premises components are:

• CAM Administrator and CAM Administration Service, including a Scheduled Task Scheduler and
Work Queue Manager

• CAM Access Point

• CAM Agents

The hosted components are:

• CAM Database

• Cherwell Service Management database

• Web applications: the Authentication service, Purchasing, Reporting, and License Analytics

• Cloud service for communications between CAM Administrator (and CAM Administration Service)
and the CAM Database

• CAM Access Point to database cloud service
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More information about hosted installations

Related concepts
On-premises vs. Hosted Installations
CAM Applications and Components
Installing or Upgrading CAM in a Hosted Environment
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Name Change
Cherwell Asset Management was formerly named Express Software Manager; other current and former
names associated with the product are listed here.

Beginning with version 12.2, Cherwell Software renamed this product to better align with our product
naming convention and brand identity:

Current Term Previous Term

Cherwell Asset Management (CAM) Express Software Manager (ESM)

CAM Administrator Express Administrative Console

Reporting Express Reports Console

Purchasing Express Purchasing Console

License Analytics Express License Analytics Console

CAM External Connector Express Connector

CAM Agent Express Client

CAM Database Express Database

CAM Access Point Express Access Point

CAM Administration Service Express Server

Cherwell Software Identification Database (CSID) Express Software Identification Database (ESID)
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CAM Applications and Components
Cherwell Asset Management includes the following applications and components, which work together to
manage your organization's software licenses:

• CAM Administrator: The primary user interface for configuring and administering Cherwell Asset
Management.

• Reporting: A collection of reports. You can view, filter, and save Cherwell Asset Management data in
reports.

• Purchasing: A  web-based application for recording and tracking purchasing information for
hardware and software in your environment.

• License Analytics: A web-based application to evaluate license compliance for a specific set of
products, within the context of contractually-defined product use rights.

• CAM Certificate Manager: A utility for generating a certificate that contains a persistent, private key
for export and loading on other CAM Administration Service machines.

• CAM External Connector: A utility for importing data collected by supported data sources for
analysis and reporting.

• CAM Administration Service: A collection of components that reside on the server. This collection
sits between the administrative component and the data store. The components provide the
management functionality in CAM Administrator.

• CAM Database: The data store that holds inventory and usage data from machines, and stores its
data in Microsoft SQL Server 2012 or above format. Reports are generated from the data in the
CAM Database.

• CAM Access Point: A conduit that facilitates communications between the machines and the CAM
Database.

◦ For on-premises installations, the access point is a web service that runs under Microsoft
Internet Information Services (IIS).

◦ For hosted installations, the access point communicates with a web service running on the
remote host.

• CAM Agent:The software that gathers inventory and software usage data from machines. On
Windows machines, the agent passes this data to the CAM Access Point, which writes the data to
the CAM Database.

• CAM API: The collection of web services that allows you to interchange data with external systems.
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CAM Administration Service
The CAM Administration Service is a collection of services that provide most of the administrative
functionality in Cherwell Asset Management.

A Cherwell Asset Management installation will normally have a CAM Administration Service installed with
each CAM Administrator.
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CAM Database
The CAM Database is a SQL Server database that stores information about machines, other assets,
users, files, and license units discovered and managed by Cherwell Asset Management.

The information stored in the CAM Database is used to configure agent installation and data collection,
manage inventory and metering, and generate a variety of reports in several formats. A Cherwell Asset
ManagementCAM installation will normally have only one CAM Database.

On-premises installations: To view information about the CAM Database you're using, go to the Status
Panel. Here you can view information about the database, including the name of the database server and
name of the database, a description of the SQL Server in which the database resides, the date the
database was created, and the Cherwell Software Identification Database version.

Hosted installations: The Hosted Cherwell Asset Management section in the Status panel lists
information on the remote host for the database, and the version of the CSID.

30

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_CSID_overview


CAM Access Point
The CAM Access Point, a web service running under Microsoft Internet Information Services (IIS),
manages data communication between the database and machines on which the CAM Agent is installed.

The primary component of CAM Access Point is the Agent Services functionality, which accepts inventory
information and metering data. It also provides agents with configuration information as needed. (The
user interface to agent configuration is via CAM Administrator.)

A CAM installation may have more than one access point for access or scalability reasons.

In hosted environments, an Access Point manages this process.

Related concepts
How Cherwell Asset Management Works in a Hosted Installation
Installing or Upgrading CAM in a Hosted Environment
CAM Access Points and Hosted Installations
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CAM Agent
The CAM Agent is a collection of components that gather information from Windows computers on your
network.

The CAM Agent is made up of the following functional components:

• Inventory: Gathers hardware and software inventory data from machines with the CAM Agent
installed on them.

• Metering: Gathers application usage information from machines with the CAM Agent installed on
them.

• Control: Facilitates the ability to control application execution, either to restrict usage or control
concurrently licensed applications.

Notes:

• If you are licensed to use only certain features in Cherwell Asset Management, the component(s)
you are not licensed to use are still installed, but are not functional until you upgrade your license.

• An agent is not installed or used by the Linux/Unix/Mac OS discovery process.

• It is recommended that you use the current version of the agent software. Pre-10.0 versions of the
CAM Agent are not supported.
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CAM Administrator Reports
You can access reports from within CAM Reporting or CAM Administrator.

Cherwell Asset Management provides two ways to access reports:

• Reporting, a separate application, lets you analyze data that Cherwell Asset Management collects in
a wide variety of formats. Reporting allows you to view reports in a browser.

• You can access certain reports directly from within CAM Administrator. These reports present a
more detailed administrative view of certain entities (license units, machines, etc.) with the CAM
environment. You can open any of these reports from the Reporting menu:

◦ Activity Log Report

◦ Login History Report

◦ CAM History Report

◦ License Unit Summary Report

◦ Machines Waiting and License Allocation Status Report

◦ License Checkout Summary Report

◦ Overallocated License Units Report

◦ Machine Summary Report

◦ Network Device Summary Report

Notes:

• The availability of the above reports depends on the state of your CAM Administrator session. For
example, the Machine Summary report is only available when a machine is selected.

• You can also open some of these reports by right-clicking an item (for example, a license unit or
machine) and selecting the report from the context-sensitive menu.
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Activity Log Report
This report shows which license units have run on a single machine, by a single user, or in the last 30
days.

• The Activity Log report shows the license units that have run on a selected machine or by a selected
user.

• If a license unit is selected, this report shows which machines that license unit has run on in the last
30 days.

Note:

This report is based on a single selected license unit, machine, or user in the current panel. If a
panel other than License Units, Machines, or Users is selected, or if more than one object is
selected, the report is unavailable.
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CAM History Report
This report shows a record of actions taken for the current item, sorted by date and time. This report
includes the following information, if available, for each action:

• Date and time performed

• User name

• Type of action (for example, deleted) or type of item (for example, machine)

• Name of parameter changed

• Brief description of action taken

• Old and new values for the parameter
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Login History Report
This report shows a record of metered logins for the selected machine or user over the last 30 days.

This report is only available if you are licensed to use the metering feature. Information on the user name,
machine name, login time, logout time, domain, and terminal server (if relevant) is shown.
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License Checkout Summary Report
This report lists information on how many licenses are checked out for each concurrent use license.

 Getting There

To specify that an application is a concurrent application (an application for which you have a concurrent
use license), see How to Configure a Concurrent Application

The License Checkout Summary Report lists the following:

• License unit name

• Number of licenses currently allowed

• Number of licenses currently in use (checked out)

• Number of licenses available for use

• Machine

• User

• Checkout type
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License Unit Summary Report
This report displays the following for the selected license unit:

• Installation Information: The suite/application name, its version number, its platform, and number
of installations.

• Activity Information: Machine name, whether the license unit is installed on the corresponding
machine, and count.

38

CAM 14.2 Administrator

CAM 14.2 Administrator



Machine Summary Report
 Getting There

The Machine Summary report includes the following for the selected machine, where applicable and
available:

• Hardware Summary: Basic hardware information such as IP address, CPU type and speed, RAM,
BIOS information, and more.

• Disk Drive Summary: Disk drive information including drive letter and type, and maximum and
available free space.

• Purchasing Assignments: Information on purchasing assignments for this machine, as entered in
Purchasing. This information includes order date and number, line item name, unit price, and
assignment type.

• Services: Status, start mode, and path information for available services.

• Network Adapter Summary: Connection information, including IP configuration, as well as any
Ethernet and wireless connection data.

• Custom Machine Properties: System information, including information on installed devices.

• Application Inventory Summary: Installed applications, including application name, version, and
install path(s).

If you are licensed to collect metering data, you can also click the View Activity Log option at the top of the
report. This opens an activity log for the selected machine in a separate window.
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Machines Waiting and License Allocation Status
Report

This report lists any machines that are waiting to use the selected license unit and the availability of this
license unit.

 Getting There

The name of the selected license unit is at the top of the report, and the next line shows how many
licenses are allowed.

The first part of the report includes the following:

• Names of any machines currently waiting to use the license unit

• Names of the current users of those machines

• How long each machine/user has been waiting

• The allocation group(s) to which this license unit belongs

The second part of the report includes the following:

• The name of each allocation group to which this license unit belongs

• Total number of license units

• Number of licenses available for use

Note: The amount of data that is shown in this report depends on how you have configured the
selected license unit.
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Network Device Summary Report
 Getting There

The Network Device Summary report includes the following for the selected network device:

• Fixed Network Device Attributes: Information on the device's name, description, serial number, up
time, status, services, contact name, and location.

• Custom Network Device Attributes: Information on any custom property values and the object
identifiers (OIDs) that were used to return the data.
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Overallocated License Units Report
This report shows you any license units for which your organization has over the allocation limit.

 Getting There

This report includes the following information for each, if available:

• License unit name

• Number of licenses

• Number of allocations

• Number of licenses over the allocation limit

• The allocation group

• Number of allocations allowed for the group

Related information
../admin_how_to/Admin_How_to_allocate_concurrent_licenses.xml#concept3228
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What Are Baselines?
Baselines are a minimum or starting point, used to compare changes in your hardware and software
inventory.

Baselines allow you to compare changes in your hardware and software inventory. When you set a
particular inventory level as your baseline, the What's Changed and What's Changed: Added or
Deleted Machines reports will measure the changes that have occurred against this baseline.

You can configure multiple baselines and run reports against any or all of them. You can compare the
current state against any baseline, or compare two baselines against each other.

To create a baseline:

• From the Tools menu, select Configure Baselines.

To access your reports:

• Select View Reports on the toolbar.
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Options for Tracking Purchasing Information
Your organization can still track some purchasing information for licenses units, even if you're not licensed
to use CAM Purchasing.

Cherwell Asset Management includes a web-based component for tracking purchasing and licensing
information for software and hardware assets in your environment: Purchasing. This component is
optional, so your organization may not have it in your CAM implementation.

If your organization is not licensed to use Purchasing, you can track some purchasing information for
license units as follows:

1. From within CAM Administrator, select the license unit.

2. Select Properties.

3. Select the Purchasing tab.

Note: You cannot enter or track information for any hardware assets you've added in CAM
Administrator.

Contact us for information about licensing Purchasing.
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CAM Administrator Layout
CAM Administrator's main page is the Status panel, a summary of your Cherwell Asset Management
configuration. The icons in the left pane provide a quick way to navigate to other areas of the application
(for example, to the License Units panel or Machines panel).

Each panel also includes a status bar that provides information on current processes, as well as a toolbar
from which you can launch Reporting, Purchasing, or License Analytics, or perform other tasks.
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CAM Administrator Panels
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Administrator Status Panel
When you start CAM Administrator, the Status Panel provides a summary for your entire Cherwell Asset
Management configuration.

Select any link on this page or the icons in the left pane to navigate to different panels. A Setup Checklist
window is on the right, and the Work Queue window may appear at the bottom of the screen; click the X
at the top right of these windows to hide them.

The Status panel is divided into the following sections:

License Units/Applications
The total number of license units.

Unconfigured Applications
Applications, organized by platform, that haven't yet been configured into license units.

Machines
The number of computers on your network that have the CAM Agent installed on them, as well as the
number of Cherwell Asset Management licenses currently in use on your network, broken out by the
number of licenses for the inventory and metering features.

This section also includes the number of machines that are running an earlier version of the CAM Agent
and the current version available to be installed. Using the current version of the agent software is
recommended. Pre-10.0 versions are not supported.

Network Devices
The total number of network devices discovered on your network.

Other Assets
The total number of other assets that you've configured in Cherwell Asset Management.

Users
The number of total users.

For Hosted Installations: Hosted Cherwell Asset Management
Information about the remote host and the version number of the Cherwell Software Identification
Database (CSID).

For On-Premises Installations: Database
Information about the CAM Database, including:
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• The name of the server machine on which the CAM Database is running.

• The database name.

• The version of Microsoft SQL Server in use.

• The date the database was created.

• The database version number.

• The version number of the Cherwell Software Identification Database (CSID) installed, and a link for
updating the CSID if a newer version is available.

If you are running an evaluation license of Cherwell Asset Management or your subscription is expiring,
this section also includes your license expiration date. Click this link to learn how to purchase a full
license.

Licensed Features
Information about what Cherwell Asset Management functionality you are licensed to use. Click Change
to upgrade your license. You can also specify whether to automatically meter new license units.

Administration Servers
Information about the CAM Administration Service, a collection of services that provide most of the
administrative functionality in Cherwell Asset Management.

Access Points
Information about the CAM Access Point (or the CAM Access Point Proxy in hosted installations), the web
services that handle the communication between the CAM Agents and the CAM Database. Click Alerts to
set up alerts that notify you via email when an access point becomes unavailable.

Web Component Locations
This section includes URL locations of the following:

• Authentication: The web-based service that manages CAM user authentication.

• License Analytics: The web-based License Analytics component.

• Purchasing: The application that licensed users of this component can use to record and analyze
purchasing information for applications in their network.

• Reporting: The web-based Reporting component.

CAM Authentication: Select Configure to specify URLs for all web components.

CSM Authentication: Copy the links and paste them into a browser.

Administrator
The number of currently running CAM Administrator machines. You can click the hyperlink to see who is
logged in from which machine.
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User Policies
CAM Authentication: Information about the Administrator, Reporting and License Analytics, and
Purchasing user policies feature. It shows which permissions the logged-in user has for Administrator
user policies, and whether Reporting, License Analytics, and Purchasing user policies are enabled.

CSM Authentication: Access to Cherwell Asset Management is controlled by Cherwell Service
Management. See Overview: Authentication and authorization for general information, and the online help
that accompanies CSM for help with specific options.
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License Units Panel
The License Units panel lists all configured license units.

Left Pane
The left pane shows all configured license units, grouped into the following categories:

• By platform: License units grouped by the operating system they run on: Linux, Mac OS, Unix,
Windows, and Multiple (for license units that have applications found on more than one platform).

• By manufacturer: All known manufacturers, along with the license units associated with them.

• By license type: All license units, organized by license type: concurrent, freeware, per core, per
processor, per seat, per seat with usage, per server, per user, shareware, site, unmanaged (license
type not defined).

• By control profile: Only those license units associated with a control profile, organized by profile.

• By category group: All predefined software category groups (indicated with folder icons) and
software categories within those groups (indicated with gray icons). Icons that also show a "person"
indicate that the category group or category was created by a user.

• By purchase required: All license units, organized by value for the Purchase required setting: Yes,
No, and Unknown.

• Full list: All known license units.

• Deleted license units: Any license units you've deleted.

• Any license unit groups you've created.

If you click the plus sign next to a folder to open it, license units in that folder are listed in the left pane.

Right Pane
The larger pane on the right lists all the license units that fall under the currently selected folder. You can
customize which of the following columns are visible by right-clicking a column header:

• License unit name
• Whether metering is enabled

• License type
• Number of licenses
• Date added
• CAM-edited: Whether the license unit was modified by Cherwell Asset Management during an

automatic identification process (the column reads Yes), or by a system administrator (No).

• Manufacturer
• Platform

• Control profile
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• Category group

• Category

• ID

The items in bold are the columns that are displayed by default.

Note: When you select a license unit in the left pane, the right pane shows the applications or
suites that make up the license unit. When you select a suite in the left pane, the right pane shows
its applications.

Context-Sensitive Menus
You can also right-click on a license unit to open a context-sensitive menu from which you can perform
various tasks such as adding an application or suite to the license unit, enabling metering, specifying the
type of licensing agreement, or viewing license unit properties. You can also select multiple license units
in the list pane and right-click your selection to open a context-sensitive menu.

Note: You can use the By Control Profile part of the tree to create new control profiles or modify
existing profiles. You can use the right-click options in this folder to perform these operations.

Hyperlinks in the Right Pane
You can use the three hyperlinks at the top of the License Units panel's right pane for help with common
tasks. Each hyperlink is described below:

• Refresh—Refreshes the display in the License Units panel.

• How to configure license units—Opens a help topic that walks you through the process of
configuring a license unit.

• Click here for help—Opens this help topic, which provides an overview of the License Units panel.
From here, you can navigate to any CAM help topic.

Related information
../admin_common_tasks/Admin_License_units_common_tasks.xml#concept834
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Unconfigured Applications Panel
You can use the Unconfigured Applications panel to find information about any Windows applications that
exactly or closely match applications in the Cherwell Software Identification Database (CSID), or are
identified as Linux, Unix, or Mac OS applications, but have not yet been configured into license units.

Left Pane
Unconfigured applications are grouped into categories shown in the tree on the left. They are all listed
under the Identified folder, which means that they were found during the inventory process and are not yet
configured into license units.

The Identified folder includes the following folders:

• Linux, Mac OS, and Unix folders—Files identified on each platform that have not yet been
configured into license units.
Configuration tip: Look through these lists carefully and only configure the applications that you are
interested in. Move applications you don't want to track or that are not individually licensed to the
Don't configure list (see below).

• Windows exact match—Executable files (.exe or .com files) on the Windows platform for which
there is an exact match in the CSID. An "exact match" is a match of both file name and file size, or
GUID.
Configuration tip: Exact match applications are automatically identified and converted to license
units on a scheduled basis by default, so this list should normally be empty. If you do see
applications in this list, you can convert them to license units by right-clicking them and selecting
Automatically Configure.

• Windows close match—Files recognized by the CSID as closely matching main executables for
Windows applications. A close match application may have the same file name as a known
application, but the file size may be slightly different.
Configuration tip: By default, close match applications are converted to license units when exact
match applications are converted to license units. (See the General tab in the Options dialog box.) If
there are applications remaining in this list, you can convert them into license units by selecting
them, right-clicking on your selection, and then clicking Automatically Configure from the context-
sensitive menu. By default, close match applications are also configured on a scheduled basis.

• Don't configure—Applications that you don't want to configure into license units.
Configuration tip: Place any applications you don't want to see in any of the above lists here.

Right Pane
When you open a folder in the Unconfigured Applications panel, the larger pane on the right lists all the
applications that fall under the currently selected folder and the following information, if available. You can
customize which of the following columns are visible by right-clicking a column header:

• Application name

• Version
• Company who manufactured the application (if available)
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• Platform
• Main executable
• Size (in bytes)

• Added—Date it was added to the CAM Database

• Path on which it was found
Note that the single path shown is the one most commonly found as a result of the inventory and
metering processes.

• Launch information

• GUID

• Match (exact or close)

The items in bold are the columns that are displayed by default.

Context-Sensitive Menus
When one or more applications are selected, you can right-click on your selection to open a context-
sensitive menu from which you can perform various tasks like configure the application into a license unit
or move it to the Don't configure folder.

Hyperlinks in the Right Pane
You can use the hyperlinks at the top of the Unconfigured Applications panel's right pane for help with
common tasks. Each hyperlink is described below:

• Refresh—Refreshes the display in this panel; this feature is handy, for example, when you've
configured some listed applications into license units and want to see which applications remain.

• Click here for help—Opens this help topic, which provides an overview of the Unconfigured
Applications panel. From here, you can navigate to any CAM help topic.

Related information
../admin_common_tasks/Admin_Common_tasks_in_the_Unconfigured_Applications_panel.xml#concept623
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Files Panel
You can use the Files panel to search for and view information about files in the CAM Database that have
been inventoried or recorded as launched by the CAM Agent. First, search for files that meet your criteria,
and then, from the list of files that is displayed, you can perform various tasks, including configuring files
into license units or marking them as files you don't care about.

Left Pane
The Files box in the left pane contains one folder, Search results. When this folder is selected, the results
of your most current file search are shown in the right pane.

The Search area is just below the Files box. It includes a number of criteria you can use to search for
files. See How to Search for Files for details on how to use it.

Right Pane
When you open a folder in the Files panel, the larger pane on the right lists all the files that fall under the
currently selected folder. You can customize which of the following columns are visible by right-clicking a
column header:

• Name
• Size (in bytes)

• Date added
• Type
• CSID Match: Whether this file closely or exactly matches an application file in the Cherwell Software

Identification Database.

• Path on which it was found: Note that the single path shown is the one most commonly found as a
result of the inventory and metering processes. You can view a complete list of paths on which the
file was found on the Locations tab of the File Properties dialog box.

• Launch information

If the file is recognized as belonging to (or closely matching) an application in the CSID, it also includes:

• Application name

• Version

• Company who manufactured the application (if available)

• Product information

• ID

The items in bold are the columns that are displayed by default.
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Context-Sensitive Menus
When one or more files are selected, you can right-click on your selection to open a context-sensitive
menu from which you can perform various tasks like add the file(s) to a new or existing license unit, or
check a file's properties and location.

Hyperlinks in the Right Pane
You can use the hyperlinks at the top of the Files panel's right pane for help with common tasks. Each
hyperlink is described below:

• Refresh—Refreshes the display in the Files panel; this feature is handy, for example, when you've
configured some listed files into license units and want to see which files remain in one of the folders
in the Files panel.

• How to configure files—Opens a help topic that walks you through the process of manually
configuring files into license units.

• Click here for help—Opens this help topic, which provides an overview of the Files panel. From
here, you can navigate to any CAM help topic.

Related information
../admin_common_tasks/Admin_Files_common_tasks.xml#concept556
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Machines Panel
The Machines panel lists all discovered and/or managed computers on your network.

Search
The Search text box is at the top of the panel. You can search for machines by name, IP address, or last
logged-in user. Wildcards are automatically added to the beginning and end of the text you enter. For
more information, see Searching for Machines.

• Select the machine grouping on the left to search, then enter text in the box.

Tip:
Press Ctrl+F from anywhere in the Machines panel to start typing in the search box.

When you click a category in the tree on the left, the right pane displays the list of machines that fall into
that category. You can customize which of the following columns are visible by right-clicking a column
header:

• Machine name and domain
• IP address, if available

• Last install status; see Agent Status Messages for a list of messages that can appear in this
column

• Agent version;(not applicable for Linux, Unix, and most Mac OS machines)

• Inventory status
• Last heartbeat
• Platform

• Access point to which the machine reports

• Date and time the machine was discovered

• Name of the proxy server, if used

• Name of the last user to log into the machine (not applicable for machines found using the Linux/
Unix/Mac OS discovery feature)

• NIC address

• Name of the VM host, if applicable

• SMS ID and ID information, if available

• ID

• Chassis

• Exclude auto-scan

The items in bold are the columns that are displayed by default.
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You can sort the list of machines by clicking on any column heading.

Machine Groupings
The left pane shows all machines, grouped into the following categories:

• Linux machines discovered via Linux/Unix/Mac OS discovery.

• Mac OS machines discovered via the Linux/Unix/Mac OS discovery feature or via Active Directory
discovery. If you have machines that are running earlier versions of the Mac OS, you can also
discover machines by using either the remote inventory procedure or from a network share location.
Mac OS machines discovered by any of these methods are included in this list.

• Unix machines discovered via the Linux/Unix/Mac OS discovery feature.

• Windows machines, broken out by these categories:
◦ Not installed: Machines that do not yet have the CAM Agent installed on them and are

therefore not yet managed by Cherwell Asset Management.

◦ Installed: The CAM Agent is installed on these machines, and they are reporting to an CAM
Access Point.

◦ By access point: Each configured access point is listed here; machines associated with each
access point are listed in the right pane.

• Licenses in use includes all machines that have inventory and/or usage (also known as metering,
for Windows machines only) data collected from them, broken out into Inventory and Metering
folders. The Inventory folder is further broken out by platform.

Note: Machines do not have to have the CAM Agent currently installed on them to appear in
these lists.

• Full list: All known machines on your network.

• Discovered: All machines discovered by Active Directory or domain discovery, organized into
groups as defined by the results of the discovery process.

• Deleted machines: Any machines you've deleted.

• Any machine groups you've created.

Context-Sensitive Menus
When one or more machines are selected, you can right-click on your selection to open a context-
sensitive menu from which you can perform various tasks including inventorying the machine(s), installing
the CAM Agent, uninstalling the agent, viewing machine properties, and so on.

Hyperlinks
You can use the hyperlinks at the top of the Machines panel's right pane for help with common tasks.

• Refresh: Refreshes the display in the Machines panel.
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• Machine installation help: Opens the help topic associated with installing or uninstalling the CAM
Agent.

• Click here for help: Opens the help topic associated with the Machines panel. From here, you can
navigate to any help topic.

Related information
../admin_common_tasks/Admin_Machines_common_tasks.xml#concept810
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Network Devices Panel
The Network Devices panel displays information on all discovered network devices on your network. You
can select and view information on one device at a time.

Left Pane
The left pane shows all network devices, grouped into the following categories:

• By device type: All discovered device types, such as switches, routers, printers, and so on.

• By location: All locations in which network devices were discovered.

• By manufacturer: All known manufacturers of discovered network devices.

• Full list: All discovered network devices on your network.

• Deleted devices: Any network devices you've deleted.

• Any network device groups you've created.

Right Pane
When you click a category in the tree on the left, the right pane displays the list of discovered network
devices that fall into that category, along with the following information for each, if available. You can
customize which of the following columns by right-clicking a column header:

• Device name
• Manufacturer
• A general description of the device

• Type of device, as interpreted by Cherwell Asset Management

• Serial number
• Discovery IP address
• Physical address
• Uptime of the device, shown in days, hours:minutes:seconds format

• Status
• Services (an SNMP-returned integer that defines device function)

• Contact person for this device, if available

• Location of device as configured by the device system administrator

• Agent managed (whether inventory data exists for this device)

• Discovered on (date and time)

• ID

The items in bold are the columns that are displayed by default.
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You can sort the list of network devices by clicking on any column heading.

Context-Sensitive Menus
You can select one or more network devices and right-click on your selection to open a context-sensitive
menu from which you can perform various tasks including deleting it, viewing its properties, and so on.
Not all items are available in the context-sensitive menu when multiple network devices are selected.

Hyperlinks in the Right Pane
You can use these hyperlinks at the top of the Network Devices panel's right pane for help with common
tasks. Each hyperlink is described below:

• Refresh—Refreshes the display in the Network Devices panel.

• Click here for help—Opens this help topic, which provides an overview of the Network Devices
panel. From here, you can navigate to any CAM help topic.

Related information
../admin_common_tasks/Admin_Common_tasks_in_the_Network_Devices_panel.xml#concept633
../admin_network_devices/Admin_Overview_Network_devices_vs_other_assets.xml#concept1627
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Other Assets Panel
The Other Assets panel lists all assets (devices that are not SNMP-enabled) you've manually added to
your CAM Database.

Note: The Other Assets panel only displays information if your site is licensed to use Cherwell
Asset Management's inventory component. Contact us for information if you need to upgrade your
license.

Left Pane
The left pane shows all the assets you've configured, grouped into the following categories:

• By manufacturer: All known manufacturers, along with the assets associated with them.

• By asset type: All assets, organized by type—Backup device, Data storage, Firewall, Printer,
Router, Server, Switch, and Unknown. You can add, rename, and delete asset types.

• Full list: All known assets you've added.

• Deleted assets: Any assets you've deleted.

• Any asset groups you've created.

Right Pane
When you click a category in the tree on the left, the right pane displays the list of assets that fall into that
category, along with the following information for each, if available (if entered when the asset was added).
You can customize which of the following columns are visible by right-clicking a column header:

• Asset name
• Serial number
• Manufacturer
• Location
• Type of asset

• IP address
• Description

• Owner

• ID

The items in bold are the columns that are displayed by default.

You can sort the list of other assets by clicking on any column heading.
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Context-Sensitive Menus
When one or more assets are selected, you can right-click on your selection to open a context-sensitive
menu from which you can perform various tasks including renaming its type, viewing its properties, and so
on.

Hyperlinks in the Right Pane
You can use the hyperlinks at the top of the Other Assets panel's right pane for help with common tasks.
Each hyperlink is described below:

• Refresh—Refreshes the display in this panel.

• Click here for help—Opens this help topic, which provides an overview of the Other Assets panel.
From here, you can navigate to any CAM help topic.  

Related information
../admin_common_tasks/Admin_Common_tasks_in_the_Other_Assets_panel.xml#concept654
../admin_network_devices/Admin_Overview_Network_devices_vs_other_assets.xml#concept1627
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Users Panel
The Users panel displays information about users in your environment. You can find login information for
all known users, delete users, and create and work with user-defined user groups in this panel.

Note: You cannot modify discovered user groups.

Left Pane
Users are grouped into the following categories:

• Full list—All known user names on the network.

• Discovered—All user names discovered by Active Directory or domain discovery.

• Deleted users—Any user names you've deleted.

• Any user groups you've created—Click a user group name and the list of users contained in that
group are shown in the right pane.

Right Pane
The larger pane on the right lists all the users that fall under the currently selected folder. You can
customize which of the following columns are visible by right-clicking on a column header:  

• User name
• Domain the user belongs to

• Last logged into—Machine the user last logged into (if your site is licensed to use metering
functionality and metering is enabled)

• Last metered login—Date and time of the user's last login (if your site is licensed to use metering
functionality and metering is enabled)

• First name of the user associated with that user name, if available

• Last name of the user associated with that user name, if available

• ID

The items in bold are the columns that are displayed by default.

Context-Sensitive Menus
When a user is selected, you can right-click on it to open a context-sensitive menu from which you can
perform various tasks such as customize the columns, and view activity and user properties.

Hyperlinks in the Right Pane
You can use the hyperlinks at the top of the Users panel's right pane for help with common tasks. Each
hyperlink is described below:
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• Refresh—Refreshes the display in this panel.

• Click here for help—Opens this help topic, which provides an overview of the User panel. From
here, you can navigate to any CAM help topic.
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Setup Checklist
 Getting There

The Setup Checklist helps you get started with Cherwell Asset Management. As you complete each listed
task, a check mark appears next to it to help you track your progress.

You can click any listed task for detailed instructions on completing it. This information appears just below
the Setup Checklist, as do links to other relevant topics.

By default, the Setup Checklist is docked to the right-hand side of CAM Administrator and is always
visible, but you can change how and whether it is displayed. You can also click Setup Checklist on the
View menu to toggle its visibility.
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Setup Checklist Display Options
The Setup Checklist is docked to the right-hand side of CAM Administrator and is always visible by
default, but you can change how and whether it is displayed. Click the down arrow at the top right of the
Setup Checklist window to select another display option. The options are:

• Floating Window—The Setup Checklist is in its own small window, and is not docked to any part of
the display, so you can move it and resize it as needed. To choose another display option while in
this mode, right-click its title bar.

• Dock to Right (the default)—The Setup Checklist is docked to the top right-hand corner, and is
always visible. You can resize it while it is docked.

• Auto Hide—The Setup Checklist is only visible when you position the mouse over the small Setup
Checklist tab that's now visible at the far right of the display.

You can also click Setup Checklist on the View menu to toggle its visibility.
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Work Queue
Open the Work Queue

The Work Queue is a window that lists in-progress and to-be-completed tasks that it runs in the
background. These are tasks that affect the CAM Database and are initiated by actions you take in CAM
Administrator or with CAM Agents. Examples of tasks that can appear in the Work Queue include
inventorying machines, saving changes to license units, and deleting machines.

The Work Queue lists each task, the date and time the task was added to the queue, and the status of
task. When queued tasks are completed, they are removed from the list. If a task cannot be completed
after three attempts, the task is removed from the Work Queue and information about the error is saved to
the event log, but Work Queue information is not saved in the history log.

By default, the Work Queue is hidden, but you can change how and whether it is displayed. You can also
click Work Queue on the View menu to toggle its visibility.

The Work Queue service is installed with the CAM Administration Service component.
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Work Queue Display Options
The Work Queue is not visible by default, but you can change how and whether it is displayed. Click the
down arrow at the top right of the Work Queue window to select another display option. The options are:

• Floating Window—The Work Queue is in its own small window, and is not docked to any part of
the CAM Administrator display, so you can move it and resize it as needed. To choose

• Dock to Bottom (the default)—The Work Queue is docked to the bottom of CAM Administrator, and
is always visible. You can resize it vertically while it is docked.

• Auto Hide—The Work Queue is only visible when you position the mouse over the small Work
Queue tab that's now visible at the bottom of the display.

You can also click Work Queue on the View menu to toggle its visibility.
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CSM Authentication in CAM
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Authentication and Authorization
In a nutshell, authentication is the process of confirming a user's identity via the user's login credentials.
It is not the same as authorization, which gives access to systems based on that confirmed identity.
Read on for an explanation of both and how each are handled within Cherwell Asset Management.

Authentication
The authentication process at your site will take one of two forms:

• CAM authentication: Used in sites where Cherwell Asset Management (CAM) is installed on-
premises as a stand-alone product. In some situations where both CAM and Cherwell Service
Management (CSM) are installed on-premises, you may choose to configure authentication
separately in each product and thus use CAM authentication in Cherwell Asset Management. In this
configuration, authentication is managed by CAM, which uses your Windows login to authenticate.
This was the only authentication method available in pre-12.0 versions.

• CSM authentication: Used in all hosted installations of CAM (which also include CSM), and available
in on-premises installations that include both CAM and CSM. Authentication is managed by CSM;
CAM makes use of CSM services during some processes.

There may be cases where your site changes authentication methods. For example:

• You can evaluate Cherwell Asset Management in an on-premises installation and then migrate to a
hosted installation. In this case, the change happens as part of provisioning and you don't need to
take action.

• You have an on-premises installation, which uses CAM authentication by default, and you want to
instead use CSM authentication. In this case, see Checklist for using CSM authentication and How
to change the authentication method for the procedures to follow.

Authorization
The authentication method used at your site dictates how users are authorized to use Cherwell Asset
Management.

• In sites that use CAM authentication, access to all, or certain features of, Cherwell Asset
Management is controlled by means of user policies in CAM Administrator and access profiles in
Purchasing. With CAM authentication, users of each application (CAM and CSM) are separate.

• In sites that use CSM authentication, access to Cherwell Asset Management and Cherwell Service
Management is managed from within CSM (using the Cherwell Service Management Administrator
application) and controlled via integration between the two products as follows:

◦ Instead of configuring user policies in CAM Administrator, you create security groups in CSM
and assign rights to access all or part of Cherwell Asset Management to each security group.
Then you add CSM users to those security groups to give them access to the parts of the
CAM product you want them to use.

◦ Regardless of whether you were using the access profiles feature in Purchasing to manage
purchasing users, once you change to the CSM authentication method, access profiles are
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automatically enabled and are defined by CSM teams. You set up CSM user teams, which
become available anywhere access profiles appear in Purchasing.

Note that before you can use CSM authentication, there are some tasks you need to perform in Cherwell
Service Management before and after changing the authentication method. Also, contact us if you need to
verify compatibility between your versions of CAM and CSM.

Effects in Cherwell Asset Management
Some features in Cherwell Asset Management will appear unavailable depending on your site's
authentication method.

If you use CSM authentication in either an on-premises or hosted installation, you use Cherwell Service
Management to manage access to Cherwell Asset Management, rather than CAM's user policies feature.
Thus, the Administrator, Reporting and License Analytics, and Purchasing items are unavailable from
CAM Administrator's Tools > User Policies and Authentication menu. You'll still use the Administration
panel in Purchasing to control visibility within Purchasing via access profiles, but CSM teams will function
as your access profiles.

Sites that use CSM authentication in either an on-premises or hosted installation will not use the
Administration panel in Reporting to control access to reporting functions. Instead, reports rights are
managed by CSM security groups. Thus, the Administration panel in Reporting is not visible when using
CSM authentication.

Relevant help topics
Help topics that pertain to only one authentication method or installation environment are flagged at the
top, as follows:

• This topic applies to: Hosted installations

• This topic applies to: On-premises installations

• This topic applies to: CSM authentication

• This topic applies to: CAM authentication

In cases where a topic contains sections that only apply to certain configurations, you'll see this flag at
top:

In these topics, sections that apply to only certain configurations are set off with the colored squares
shown above.
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On-premises vs. Hosted Installations
Cherwell Asset Management is available in the following configurations:

• On-premises installation—Cherwell Asset Management, with or without Cherwell Service
Management (CSM). If CSM is present, you have the option to use CAM authentication or CSM
authentication.

• Hosted installation—Cherwell Asset Management and Cherwell Service Management. CSM
authentication is used in these environments. Note that even with hosted installations, some
components (CAM Administrator, CAM Administration Service, CAM Access Point, and CAM
Agents) are installed on premises. Other components are run in a cloud environment.

As noted above, the authentication method varies by how you have installed and deployed the product.
See Authentication and Authorization for an explanation of how this works; contact us if you need more
information on the available solutions.

Because this help system describes all available Cherwell Asset Management configurations, colored
blocks are used to set off information that only pertains to certain configurations. See If Some Items Are
Unavailable for more information.
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Checklist for Using CSM Authentication
 This topic applies to: CSM authentication

CSM authentication is used in hosted installations, and is an option for on-premises implementations
where CSM is installed.

Before Using CSM Authentication
Before you can use CSM authentication with Cherwell Asset Management, you need to configure
Cherwell Service Management for this purpose by performing these tasks:

1. Install Cherwell Service Management.

2. Install the Cherwell Web Service (part of Cherwell Browser Apps). See the CSM online help if you
need installation assistance.

3. Follow the steps in How to Set Up CSM Security Groups, Teams, and Users for CAM access.

Changing the Authentication Method to CSM

 Relevant for on-premises installations.

Once the above "before" tasks are completed, you can change from CAM to CSM authentication by
following the below procedure:

1. Change the authentication method to CSM.
In CAM Administrator, go to the Tools menu, point to User Policies and Authentication, and click
Change Authentication. In this dialog box, enter the REST API URL (usually http://<csm-machine-
name>), the API key you generated when you set up CSM security groups, and the credentials for
the CSDAdmin user.

2. Restart CAM Administrator.

3. Synchronize CSM data with Cherwell Asset Management.
From the Tools menu, click Synchronize with CSM and then click Synchronize in the dialog box that
opens. Note that the synchronize process may take a few moments to complete.

4. Direct any other users to log out of all Cherwell Asset Management applications, and then log back
in.
When they log back in, they should use their CSM credentials.

The change to CSM authentication is now complete.

Effects of Changing to CSM Authentication
Users of pre-12.0 versions of Cherwell Asset Management and anyone who uses CAM authentication first
should note the following after switching to CSM authentication:
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• In Reporting, there are two things to note. First, the Administration panel is not available, as access
to Reporting is managed by CSM teams. Second, any filters you created are still available, but you
will need to assign ownership of them to CSM users.

• In Purchasing, you'll need to migrate any existing CAM access profiles to CSM user teams.

Related information
Admin_Overview_Authentication.xml#concept6703
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How to Set Up CSM Security Groups, Teams, and
Users

 This topic applies to: CSM authentication

Before you begin, note the following:

• This topic describes one part of the process of setting up CSM authentication for use with Cherwell
Asset Management. See Authentication and Authorization for an overview of available
authentication methods, and Checklist for Using CSM Authentication for a list of all tasks you need
to complete before using CSM authentication.

• This topic only discusses these terms and procedures in the context of CSM authentication for
Cherwell Asset Management; for more information on Cherwell Service Management, see its online
help.

After you've installed Cherwell Service Management and have a connection for use with Cherwell Asset
Management, you need to configure CSM by setting up CSM security groups, CSM users, and CSM
teams.

CSM Security Groups
You can think of CSM security groups as being similar to user policies in Cherwell Asset Management.
Both entities manage user access to the product.

You need to set up one or more CSM security groups for the purpose of assigning CAM-specific rights to
certain users. If you use LDAP/Active Directory plus Windows authentication, you'll associate AD groups
with CSM security groups that have CAM rights.

CSM Users
It's important to note that each CSM user can only belong to one CSM security group. You'll assign users
to CSM security groups, and then assign CAM component-specific access rights.

CSM Teams
Using CSM teams is optional. If you plan to strictly control access to data created with Purchasing, you
should set up one or more CSM user teams. If you don't need to fine-tune access to that data, you skip
this section as well as step 7, below.

Within the context of Purchasing, a CSM user team functions the same as an access profile. The names
of CSM user teams appear anywhere access profiles appear, and you can apply them to orders and
contracts in the same way you do with access profiles. The difference is that you create the teams and
assign users to those teams in Cherwell Service Management Administrator.

If you change to the CSM authentication method after using access profiles while configured for CAM
authentication, you will need to create CSM teams for each existing access profile and then migrate
orders and contracts from your existing access profiles to the new CSM team-based access profiles in
Purchasing.
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Configuring for CSM Authentication

 Relevant for on-premises installations. The following procedure applies to sites using the CSM’s
internal authentication login mode (the default). See the section at the end of this topic for additional steps
you’ll need to take if using another login mode.

1. Start Cherwell Service Management Administrator and select the connection you use for CAM.

2. Log in to a CSM account that has rights to generate the REST API key, create groups, and assign
groups.

3. Click Security in the left pane.

4. Generate a REST API key.
◦ From the Pick a task screen, click Edit REST API client settings.

◦ Click the green plus sign and enter a name to use for the REST API client.

◦ Copy the string that's generated in the Client Key box. You will later paste this string in CAM's
Change Authentication dialog box, in the API key text box.

5. Create security groups for providing CAM-specific rights.
The CAM-specific rights are CAM Administration, CAM Purchasing, and CAM Reporting. When you
select one of these from the Categories list box, the list updates with subcategories of the selected
rights. Select what permissions users in this group should have, and then click Allow. Do this for
each subcategory you want to include, and then click the Save icon.

For example, a security group that has only CAM Purchasing rights has permissions to only run
Purchasing, but not CAM Administrator. A security group with CAM Administration rights and the top
subcategory in its list—Configure all aspects of the CAM system (CAM system administrator)—has
permissions to run all Cherwell Asset Management applications.

6. Add users to the security group(s).

7. Optional: Add a CSM user team. (See the explanation of CSM teams, above, for help with
determining if you need to perform this task.)

8. Click the Save icon and then exit the current screen. Note that each user can belong to multiple
teams.
Tip: if you are changing to CSM authentication from an existing installation where you already used
access profiles, you may want to give your CSM teams the same names as those existing access
profiles. Doing so will make that part of the change invisible to your Purchasing users; from their
view, they simply apply the same access profiles to orders and contracts as before. You as an
administrator still need to migrate access profiles from CAM to CSM, but the authentication method
appears in parenthesis after each access profile name in Purchasing. This makes it easy to
distinguish between access profiles with the same name using different authentication methods as
you migrate from CAM to CSM authentication.

CSM authentication is configured for use with Cherwell Asset Management. From here, you can add or
change users, security groups, and user teams in Cherwell Service Management Administrator as
needed.
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Using Non-default CSM Authentication Login Modes
If you're using Windows authentication:

1. Create a CSM security group with CAM Administration rights.

2. Import a Windows user.

3. In CSM, assign the imported Windows user into the CSM security group with CAM Administration
rights.

4. In CAM, use the credentials for the CSDAdmin user to change the authentication method to CSM.
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How to Change the Authentication Method
 This topic applies to on-premises installations.

Going from CAM Authentication to CSM Authentication
To change from CAM authentication to CSM authentication:

1. If you haven't already done so, set up Cherwell Service Management for use with Cherwell Asset
Management by completing the tasks described in Checklist for Using CSM Authentication.

2. In CAM Administrator, go to the Tools menu, point to User Policies and Authentication, and then
click Change Authentication.

3. In the Change Authentication dialog box, enter the following information:
◦ API URL—This is usually http://<csm-machine-name>.

◦ API key—You should have already generated this key when you set up CSM security groups.

◦ User name and password—The credentials for the CSDAdmin user.

4. Click OK. Read the dialog box that opens, and then click OK. Proceed to "After making
authentication changes," later in this topic.

Going from CSM Authentication to CAM Authentication
To change from CSM authentication to CAM authentication:

1. In CAM Administrator, go to the Tools menu, point to User Policies and Authentication, and then
click Change Authentication.

2. In the Change Authentication dialog box, select CAM authentication and click OK.

3. Read the dialog box that opens, and then click OK. Proceed to "After making authentication
changes," next.  

After Making Authentication Changes
After making any changes, click OK. If your credentials are validated, you are prompted to restart CAM
Administrator for your changes to take effect. Click OK in that dialog box to shut down CAM Administrator,
and then do the following:

• Restart CAM Administrator.

•  If you changed to CSM authentication, click Synchronize with CSM from the Tools menu and
then click the Synchronize button in the dialog box that opens. The synchronization process may
take a few moments to complete, and the dialog box closes when finished.

• Direct any other users to log out of all Cherwell Asset Management applications, and then log back
in. That way, their sessions will use the new authentication settings.

Related information
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Admin_Overview_Authentication.xml#concept6703
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How to Edit Filter Ownership
To edit filter ownership, do the following from the Filters panel:

1. Select a filter from the list.

If you're transferring ownership from a CAM user to a CSM user, note the "(CAM)" suffix after each
CAM user name to help you track which filters to save to a new user.

Note: You do not need to edit ownership of shared filters. See the second Tip, below.

2. Click the Save As button at the top right of the right pane. The right pane updates.

3. Optional: Enter a description for the filter, and specify whether to make it a shared filter (available to
other users).

4. From the Filter owner list, select the user to which you want to transfer ownership.

5. Click Save.

Tips:

• After saving the filter to the new user, it's a good idea to delete the original filter to avoid confusion
and keep only current filters in the list.

• Because shared filters are available to all authorized users of reports, you do not need to save
shared filters to a CSM user in order to allow CSM users to use the filter. However, if you want to
change a shared filter’s owner, you can unmark the Shared box, save the filter, and then mark the
Shared box and save it again.

Related information
../../cam_reporting/Rep_Overview_Filter_ownership.xml#concept1394
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How to Migrate Access Profiles
This topic applies to: Sites that use CSM authentication

Upgraded Installations
To migrate access profiles:

1. Select Migrate Access Profiles from the left pane of the Administration panel.

A list of access profiles that need to be migrated (they don't use your current authentication method
or were deleted and are still referenced by orders or contracts) appears in the right pane.

2. Click Migrate for the access profile you want to map to a CSM team.

3. From the dropdown list, select the access profile (CSM team) you want your existing orders and
contracts to reference.
If you don't see all the CSM user teams you expected, click the hyperlink just above the list to
synchronize CSM data.

Tip: If you want to apply the new access profile to most, but not all, of the affected contracts and
orders, you can make changes to individual contracts and individual orders in the Order
Administration and Contract Administration sections of the Administration panel after the
migration.

4. Click Migrate.

New Installations
If you are enabling CSM authentication on a new Cherwell Asset Management installation (new CAM
Database), migrate one access profile that is bound to several built-in contracts provided within
Purchasing. After you have enabled CSM authentication from CAM Administrator, relaunch Purchasing,
log in with a CSM user account that has CAM Purchasing rights, and do the following:

1. From the Status page, select the Administration tab, then click Migrate Access Profiles.

2. Click Migrate.

3. Select Administrator (CSM) from the list.

4. Click Migrate.

The built-in contracts have now been updated to use the correct CSM-based profile.
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Using SAML Authentication
 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

Starting in CAM version 13.2, CAM supports use of SAML authentication for sites that also use Cherwell
Service Management (CSM) version 9.1 and above. Because your SAML identity provider configuration
may not yet support authentication using the CSM REST API, do the following if you plan to use SAML:

•  Contact technical support for assistance.

•  See the topics below, in order, for detailed instructions.
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Testing SAML Compatibility
 This topic applies to on-premises installations.

Before you can use SAML as the default authentication mode in CAM, you must configure SAML in CSM.
See the CSM help for information on configuring SAML and configuring the REST API for SAML
authentication.

Once SAML is properly configured in CSM, you need to test your SAML configuration for compatibility
when logging in from CAM web applications (Reporting, Purchasing, and License Analytics).

To test, force CAM to use SAML authentication by appending the query parameter auth_mode=SAML to
the end of the CAM web application URLs. For example:

• http://<cam-machine>/CAMReporting/Default.aspx?auth_mode=SAML
• http://<cam-machine>/CAMLicenseAnalytics/Default.aspx?auth_mode=SAML
• http://<cam-machine>/CAMPurchasing/Default.aspx?auth_mode=SAML

If the test is successful, the CAM web application opens and you are logged in. You may notice several
redirect messages while you wait. After a successful test, you can set SAML as the default authentication
method in your database; you won't need to append the query parameter used in the test anymore.

If the test is not successful, an error is shown. Check your SAML identity provider's error logs for
information on the problem.
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Setting SAML as Default Authentication Method
 This topic applies to on-premises installations.

Once you've tested your SAML configuration, you can follow these steps to switch from CSM
authentication (including LDAP/Windows authentication) to SAML:

1. Execute the following query against your CAM Database:

-- Change default authentication from Internal Authentication to SAML A
uthentication
UPDATE 
       dbo.options   
SET
       optionvalue = 'CSM/SAML'
FROM
       dbo.options   
WHERE 
       optionname = 'Authentication Mode' AND
       optionvalue = 'CSM/REST'

2. Restart the IIS server that's hosting the CAM Authentication application.

SAML is now the default authentication method. When you launch CAM Administrator or one of the CAM
web applications, your organization's sign-on page (rather than the CAM sign-on page) is shown.

Switching Back to CSM Authentication
If you need to use CSM authentication for a single session, you can do one of the following:

• Close the sign-on dialog box to get prompted for internal (CSM) credentials.

• Append the query parameter auth_mode=internal to the end of the CAM web application URLs.
For example:

◦ http://<cam-machine>/CAMReporting/Default.aspx?auth_mode=internal
◦ http://<cam-machine>/CAMLicenseAnalytics/Default.aspx?
auth_mode=internal

◦ http://<cam-machine>/CAMPurchasing/Default.aspx?auth_mode=internal

To change the authentication method default from SAML back to CSM, you can revert the changes you
made to the CAM Database by executing the following query against it:
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-- Change default authentication from SAML Authentication to Internal CSM A
uthentication (Includes LDAP/Windows Authentication)
UPDATE 
       dbo.options   
SET
       optionvalue = 'CSM/REST'
FROM
       dbo.options   
WHERE 
       optionname = 'Authentication Mode' AND
       optionvalue = 'CSM/SAML'
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General CSM Information
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Overview: Cherwell Service Management
 This topic applies to: Hosted installations & CSM authentication

Cherwell Service Management (CSM) is an IT service management (ITSM) solution and business
enablement platform available from Cherwell Software. Cherwell Service Management software enables
IT organizations to implement and automate IT service management, as well as empowering them to
build innovative solutions to address a variety of business challenges beyond IT. It is available to use in
tandem with Cherwell Asset Management.

Related information
../admin_troubleshooting/Admin_Contacting_support.xml#concept445
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Overview: mApp Support
 This topic applies to: Hosted installations & CSM authentication

An mApp is a bundle of CSM system definitions and merge instructions that allows for the transfer of
definitions between databases and for merging functionality. A number of CSM mApp solutions and third-
party integrations are available, and you can create your own. For more information, see About mApp
Solutions and Integrations.

With the Cherwell Asset Management mApp, you can integrate Cherwell Asset Management’s IT asset
data (including information on machines, configured software, purchasing, network devices, user logins,
and more) into the Cherwell Service Management Configuration Management Database (CMDB). This
makes it possible to view some data collected by Cherwell Asset Management from within Cherwell
Service Management.
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Common Tasks
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Common Tasks in the Files Panel
The following are common tasks you're likely to perform in the Files panel. Click any listed item for step-
by-step instructions.

• Configure files into license units

• Delete files from the list

• Search for specific files

• Customize which columns are visible in the right pane
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Common Tasks in the License Units Panel
The following are common tasks you're likely to perform in the License Units panel. Click any listed item
for step-by-step instructions.

• Enable metering on selected license units

• Use the License Unit Properties dialog box to configure an existing license unit

• Add an application or suite to a license unit

• Delete a license unit

• Create a license unit group

• Allocate licenses of an application

• Determine if CAM modified any license units

• Customize which columns are visible in the right pane
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Common Tasks in the Machines Panel
The following are common tasks you're likely to perform in the Machines panel. Click any listed item for
step-by-step instructions.

• Discover machines and users from Active Directory or NT domain

• Discover Linux/Unix/Mac OS machines

• Discover your virtual environment

• Install or update the CAM Agent on selected machines

• Enable agent self-upgrades on selected machines

• Perform an on-demand inventory

• Create a machine group

• Delete a machine

• Restore a deleted machine

• View a Machine Summary report
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Common Tasks in the Other Assets Panel
The following are common tasks you're likely to perform in the Other Assets panel. Click any listed item
for step-by-step instructions.

• Add an asset

• Modify an asset

• Delete an asset

• Create custom asset fields

• Add asset types or manufacturers

• Rename asset types or manufacturers

• Delete asset types

• Import asset information from an Excel spreadsheet
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Common Tasks in the Unconfigured Applications
Panel

The following are common tasks you're likely to perform in the Unconfigured Applications panel. Click any
listed item for step-by-step instructions.

• Automatically configure Windows applications

• Configure Linux/Unix/Mac OS applications

• Specify that you don't want to configure an application
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Common Tasks with CAM Agents
The following are common tasks you're likely to perform with machines on your network that have the
CAM Agent installed on them. Click any listed item for step-by-step instructions.

• Enable machines to self-upgrade when a new version of the CAM Agent is available

• Install or update the CAM Agent on selected machines

• Install the CAM Agent on a single machine using its IP address or machine name

• Install the CAM Agent on multiple machines using their IP addresses

• Start an on-demand inventory

• Collect inventory on Mac OS machines

• Uninstall the CAM Agent from machines
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Common Tasks Using the Control Feature
The following are common ways to use the control feature. Click any listed item for step-by-step
instructions.

• Prevent users from launching a specific application

• Apply a control profile to a license unit

• Determine whether a user or machine is denied access to an application

• Allocate licenses of an application

• Create a new control profile

• Allow users to wait for a concurrent application when all licenses for it are in use

• Control use of applications left open and unused on machines
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Common Tasks with Network Devices
The following are common tasks you're likely to perform with network devices on your network. Click any
listed item for detailed instructions.

• Discover network devices

• Create a network device group

• Delete a network device

• Customize columns in the Network Devices panel

• Set up custom data properties to collect during network device discovery
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Common Tasks with the CAM Database
 This topic applies to on-premises installations.

Periodically, you may want to perform the following database maintenance tasks:

• Reset the database—From the Tools menu, point to Reset Data and then click either Files and
Usage or History. The Files and Usage item clears all data and files with other extensions that you
inventoried from before a specific date from the database. By default, Cherwell Asset Management
automatically keeps one year of usage data and 90 days of historical data.

• Reindex the database—From the Tools menu, click Reindex Database to reindex the tables. You
may notice improved performance after a reindex.
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Dialog Boxes
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Activate Cherwell Asset Management Dialog Box
(eval)

The configuration key is a value you type into this dialog box to start Cherwell Asset Management.

Enter the configuration key you were given when you purchased the product, then click OK.

Contact Us if you need to obtain a configuration key.
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Activate Cherwell Asset Management Dialog Box
The configuration key is a value you type into this dialog box to start Cherwell Asset Management.

Enter the configuration key you were given when you purchased the product, then click OK.

Contact Us if you need to obtain a configuration key.
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Add Active Directory OU Path Dialog Box
You can limit discovery to a specific OU path.

 Getting There

To limit discovery to a specific OU path, enter the path in the text field. Use the syntax shown in the dialog
box. Active Directory discovery is done only on specified paths unless no paths are specified, in which
case the entire Active Directory is discovered.

Click OK when finished. You're notified if you used incorrect syntax or if the specified path is not one that
can be examined. Otherwise, you'll return to the AD Discovery tab of the Options dialog box, and you'll
see the path you added in the list. Discovery will now be limited to the listed OU path(s).

Related information
../admin_troubleshooting/Admin_Syntax_issues_with_limiting_discovery_to_an_OU.xml#concept935
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Add as Alternate Executable Dialog Box
You can specify an alternate executable for an application within a license unit.

 Getting There

To specify an alternate executable:

• Select a license unit from the list, select the application, then click OK.

The file will be added to the selected application in the specified license unit.
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Add as Support File Dialog Box
For metering purposes, you may want to associate a support file with an application within a license unit.

 Getting There

Metering tracks usage of the Windows applications and suites on your network so you can validate that
the licenses you purchase are actually being utilized.

Select a license unit from the list, select the application, then click OK. The file will be added as a support
file to the selected application in the specified license unit.
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Add as Version Dialog Box
You can add an unconfigured file to an existing license unit as another version of an application.

 Getting There

To add an unconfigured file to an existing license unit:

• Select a license unit from the list and click OK.

The file will be added as a new application version of the specified license unit.

105

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Add_as_Version_dialog_box.html


Add Asset to Group Dialog Box
Asset groups are collections of assets (user-defined devices other than the machines that are found
during discovery) that you define.

Specify the group to which you want to add the asset, and click OK.

Related information
../admin_other_assets/Admin_Overview_Asset_groups.xml#concept960
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Add Authorized Machine Dialog Box
You can specify which machines are affected by the current control profile. A control profile defines how
access to an application is controlled.

 Getting There

To specify which machines are affected by the current control profile:

1. Select one or more machines, then click Add Machine to add your selection to the authorized list.

2. Select a group and click Add Group to add a group of machines.

3. When you have specified all machines and groups to add, click OK.

107

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Add_Authorized_Machine_dialog_box.html
https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_control%2FAdmin_About_authentication_profiles.html


Add Authorized User Dialog Box
You can specify which users are affected by the current control profile. A control profile defines how
access to an application is controlled.

 Getting There

To specify which users are affected by the current control profile:

1. Select one or more users, and then click Add User to add your selection to the authorized list.

2. Select a group and click Add Group to add a group of users.

3. When you have specified all users and groups to add, click OK.
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Add Executable Version Dialog Box
You can specify which version of an executable is used for an application or suite in a license unit.

 Getting There

Use the Add Executable Version dialog box to specify the executable file to be used for an application or
suite in a license unit.

You can enter information in one of the following ways:

• Manually enter file information: This option is selected by default, and you can either type the file
name, size, and version (if known), or click Browse to find it.

• Browse local computer: Select this option and click Browse to search for it on the local machine.

• Browse inventoried files: When you select this option, the bottom half of the dialog box changes to
list all .com and .exe files that Cherwell Asset Management has inventoried. If you used the
Inventory Extensions dialog box to also inventory files with other extensions, those files (if marked
as runnable) will appear in this list as well. But by default, only .exe and .com files are shown. You
can select a file and click Properties to learn more about it.

If the number of files that meet your criteria exceeds this maximum in this text box, an alert is shown. You
can enter another maximum value in the text box, or check the Unlimited check box to return all files that
meet the search criteria. You can change the default value for this text box in the Advanced tab of the
Options dialog box.

When you find the file, click OK to add it as an alternate executable file for the application or suite in the
current license unit. It will then show up in the list of executable files in the New Application dialog box.

Related information
../admin_license_units_suites_applications/
Admin_About_license_units_suites_and_applications.xml#concept1660
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Add License Unit to Group Dialog Box
Groups are collections of assets, users, etc. that you define. You can add a license unit to a group.

Specify the group to which to add the license unit, and click OK.

Related information
../admin_license_units_suites_applications/Admin_license_units_groups_overview.xml#concept906
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Add Machine to Group Dialog Box
Groups are collections of assets, users, etc. that you define. You can add a machine to a group.

Specify the group to which to add the machine, and click OK.

Related information
../admin_machines/Admin_Machine_groups_overview.xml#concept1167
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Add Network Device to Group Dialog Box
Groups are collections of assets, users, etc. that you define. You can add a network device to a group.

To add a network device to a group:

Specify the group where you want to add the network device, and click OK.

Related information
../admin_network_devices/Admin_Overview_Network_device_groups.xml#concept747
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Add Support File Dialog Box
Support files are executable files that are separate from the main application executable file, and are
identified by the CSID for metering purposes. You can associate a support file with an application in a
license unit.

 Getting There

Support files usually have .com or .exe extensions and are not licensed separately from the main
application.

To associate a support file with an application in a license unit:

1. Choose one of the following ways to associate the file:
◦ Manually enter file information: This option is selected by default, and you can either type the

file name and size, if known, or click Browse to find it.

◦ Browse local computer: Select this option and click Browse to search for it on the local
machine.

◦ Browse inventoried files: When you select this option, the bottom half of the dialog box
changes to list all .com and .exe files that Cherwell Asset Management has inventoried. If you
used the Inventory tab of the Agent Options dialog box to also inventory files with other
extensions, those files (if marked as runnable) will appear in this list as well. But by default,
only .exe and .com files are shown. You can select a file and click Properties to learn more
about it.

2. When you find the file, click OK to add it as a support file in the current license unit. It will then show
up in the Support Files tab of the New Application or New Suite dialog box.

If the number of files that meet your criteria exceeds this maximum in this text box, you are alerted, and
you can enter another maximum value in the text box, or check the Unlimited check box to return all files
that meet the search criteria. You can change the default value for this text box by selecting the Options
dialog box, then the Advanced tab.

Related information
../admin_files/Admin_About_support_files.xml#concept1163
../admin_license_units_suites_applications/
Admin_About_license_units_suites_and_applications.xml#concept1660
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Add User to Group Dialog Box
Groups are collections of assets, users, etc. that you define. You can add a user to a group.

Specify the group to which to add the user, and click OK.

Related information
../admin_users/Admin_User_groups_overview.xml#concept811

114

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_User_groups_overview


Add/Change Administrator User Policy Dialog Box
With Administrator user policies, you can set up multiple CAM Administrators and manage permissions for
them. You can add or change administrator user policies through this dialog box.

 This topic applies to: CAM authentication

 Getting There

To add or change an Administrator user policy:

1. Enter a user name and domain in the appropriate text boxes, or click Browse to open the Browse
for User dialog box and search for a user.

2. Specify the permissions to give this user:
◦ CAM System Administrator: Can perform any and all tasks in CAM Administrator.

◦ User: Can perform tasks in one or more of these panels:
◦ License Units, Unconfigured Applications, and Files

◦ Machines and Users

◦ Network Devices and Other Assets

◦ Not authorized: Cannot launch or perform any tasks in CAM Administrator.

3. Click OK. Your changes are shown in the Administrator User Policies dialog box.

Note: This dialog box is called Add Administrator User Policy when you are doing the following:

• Adding a user to the list of users who have permission to all or portions of CAM
Administrator.

• Adding a user to your list in order to specify that this user is not authorized to run CAM
Administrator.

This dialog box is called Change Administrator User Policy when you select an existing user in the
Administrator User Policies dialog box and click Change.  

Related information
../admin_user_policies/Admin_Overview_User_policies.xml#concept2747
../admin_user_policies/Admin_More_information_on_user_policy_permissions.xml#concept7850
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Add/Change Exclude Folder Dialog Box
You can specify that certain folders and their files be excluded from inventory scans.

 Getting There

To specify that certain folders are not included in inventory scans:

1. Folder name fragment: Enter information on folders to exclude by typing in all or part of a folder
name.

2. Click OK.

Note: This dialog box is called Add Exclude Folder when you are adding a folder to exclude from
inventories, and Change Exclude Folder when you select an existing folder in the Additional
Exclude Folders dialog box and click Change.  

Related information
../admin_inventory/Admin_Tips_for_entering_folder_name_fragments.xml#concept1961

116

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Add_Change_Exclude_Folder_dialog_box.html
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Tips_for_entering_folder_name_fragments


Add/Change Extension Dialog Box
Besides .exe and .com files, which are always included, you can specify additional file types to be
included in inventory scans.

 Getting There

To specify any additional file types (besides .exe and .com files, which are always inventoried) that
you want included in inventory scans:

1. Type the extension to add. You don't need to type the preceding period.

Also, specify whether the extension is runnable. Non-runnable files are files that cannot start an
application and cannot be configured into license units.

2. Click OK.

Note: This dialog box is called Add Extension when you are adding a file extension to the list of
types of files to collect, and Change Extension when you select an existing file extension in the
Inventory Extensions dialog box and click Change.  
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Add/Change File Dialog Box
You can specify that certain files are included in inventory scans.

 Getting There

To specify that certain files are included in inventory scans:

1. Select an option:
◦ File name: Type the name of the file to include when inventorying machines.

◦ Folder name fragment: (Optional) Enter the file location by typing in all or part of a folder
name.

◦ This file is runnable: Check this box if the file is runnable (starts an application); otherwise,
leave this check box unchecked.

Note: You can only configure files that are runnable into license units.

◦ Notes: (Optional) Enter information about why you want these files included in inventory scan.

2. Click OK.

This dialog box is called Add File when you are adding a file to the list of files to include in inventories,
and Change File when you select an existing file in the Inventory These Files dialog box and click
Change.  

Related information
../admin_inventory/Admin_Tips_for_entering_folder_name_fragments.xml#concept1961
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Add/Change License Allocation Dialog Box
License allocation can be used to control usage for a concurrently licensed application.

 Getting There

Use this dialog box to specify how many licenses to allocate to machine groups. You can either add a new
allocation, or change an existing one.

Note: You must have previously specified at least one purchase of licenses (via the License Unit
Properties Purchasing tab or via Purchasing) to be able to allocate them.

1. Specify how many licenses out of the total to allow a machine group to use.

2. Select a machine group from the list. All discovered machine groups, as well as all machine groups
you created, appear in the list box. When you select a group, it is added to the Selected group box.

3. When you're done, click OK to return to the Concurrent License Allocations dialog box. You'll see
the allocation information you just entered as well as information about how many licenses you have
for this application, and how many are allocated.

Note: This dialog box is called Add License Allocation if you are defining a new allocation, and
Change License Allocation if you selected an existing licensing allocation to modify.

Related information
../admin_control/Admin_About_license_allocation.xml#concept2806
../admin_control/Admin_About_concurrent_licenses.xml#concept855
../admin_machines/Admin_Machine_groups_overview.xml#concept1167
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Add/Change Linux/Unix/Mac OS Discovery IP
Address Range Dialog Box

You can search for Linux/Unix/Mac OS machines within a range of IP addresses.

 Getting There

To specify an IP address range to query for Linux/Unix/Mac OS machines:

1. In Range, enter an IP address range to search.

2. Optional:
◦ If you need to specify a port other than the default of 22, mark the Use custom port option

and enter a port number in the accompanying text box.

◦ Enter any additional information you want to include for this configuration in the Notes text
box.

3. Enter the required credentials for the machine(s) you want to discover. A user name is required, and
you can specify either a password or a private key and passphrase.

4. Optional but recommended: Before clicking OK, click Test to open the Test Linux/Unix/Mac OS
Discovery dialog box, where you can verify that a connection can be established before proceeding.

5. When you are satisfied with your settings, click OK.

6. After you click OK, a dialog box opens to tell you how many IP addresses this configuration will
attempt to query. You have the option to save your configuration by clicking Yes or, if the number of
machines is not what you expect, click No to return to the dialog box to make changes. Although
querying a large number of machines can take time, it does not affect machine performance or the
ability to run other tasks.

Related information
../admin_discovery/Admin_Overview__Discovering_Linux_Unix_Mac_OS_machines.xml#concept1814
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Add/Change Linux/Unix/Mac OS Discovery
Machines Dialog Box

You can discover Linux/Unix/Mac OS machines by name or by IP address.

 Getting There

To specify which Linux/Unix/Mac OS machines to discover by machine name or IP address:

1. Enter the machine name or IP address to query. Multiple machine names must be separated by
commas.

2. Optional:
◦ If you need to specify a port other than the default of 22, check Use custom port and enter a

port number in the accompanying text box.

◦ Enter any additional information you want to include for this configuration in the Notes text box.

3. Enter the required credentials for the machine(s) you want to discover. A user name is required, and
you can specify either a password or a private key and passphrase. 

4. Optional but recommended: Before clicking OK, click Test to open the Test Linux/Unix/Mac OS
Discovery dialog box, where you can verify that a connection can be established before proceeding.

5. Click OK.

Related information
../admin_discovery/Admin_Overview__Discovering_Linux_Unix_Mac_OS_machines.xml#concept1814
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Add/Change Linux/Unix/Mac OS Discovery Subnet
Dialog Box

You can query a specific subnet for Linux/Unix/Mac OS machines.

 Getting There

To specify a subnet to query for Linux/Unix/Mac OS machines:

1. Enter the subnet address and the subnet mask.

2. Optional:
◦ If you need to specify a port other than the default of 22, check Use custom port and enter a

port number in the accompanying text box.

◦ Enter any additional information you want to include for this configuration in the Notes text box.

3. Enter the required credentials for the machine(s) you want to discover. A user name is required, and
you can specify either a password or a private key and passphrase. 

4. Optional but recommended: Before clicking OK, click Test to open the Test Linux/Unix/Mac OS
Discovery dialog box, where you can verify that a connection can be established before proceeding.

5. When you are satisfied with your settings, click OK to return to the Configure Linux/Unix/Mac OS
Discovery dialog box.

6. After you click OK, a dialog box opens to tell you how many IP addresses this configuration will
attempt to query. You have the option to save your configuration by clicking Yes or, if the number of
machines is not what you expect, click No to return to the dialog box to make changes. Although
querying a large number of machines can take time, it does not affect machine performance or the
ability to run other tasks.

7. Click OK.

Related information
../admin_discovery/Admin_Overview__Discovering_Linux_Unix_Mac_OS_machines.xml#concept1814
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Add/Change Network Device Discovery Dialog Box
You can discover network devices by name or IP address, including devices with IPv6 addresses.

 Getting There

To specify the network devices to discover:

1. Enter the device name or IP address to query. Multiple device names must be separated by
commas.

2. Specify the SNMP version: v1, v2, or v3. Then enter the required SNMP credentials for the SNMP
version you specified.  

3. Optional but recommended: Before clicking OK, click Test to open the Test Network Device
Discovery dialog box, where you can verify that a connection can be established before proceeding.

4. When you are satisfied with your settings, click OK.

Related information
../admin_network_devices/Admin_SNMP_credentials.xml#concept1549
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Add/Change Network Device Discovery
Configurations Dialog Box

You can configure network device discovery and view existing discovery configurations.

 Getting There

Prerequisite: You need to configure discovery for at least one machine before you can launch the
discovery process.

To configure a network discovery configuration:

1. Click Add.

2. Select one of the following:
◦ IP Address Range: Use when you have a range of IP addresses to query for network devices.

◦ Subnet: Use to query a specific subnet on your network.

◦ Device: Use to discover IPv6 devices, or in cases where you know the host name or IP
address of a device(s) you want to discover.

3. Click OK.

Existing network device discovery configurations are shown in the box. Check the checkbox next to the
configurations you want to run. The following information is shown for each configuration:

• Configuration type (Range, Subnet, or Machine)

• Description

• SNMP version

• Notes (any additional information entered)

• CAM Administration Service machine that ran the discovery process

• Last time discovery ran

• Last results

To change or remove existing configurations:

• Click one or more existing configurations, then click Change or Remove to make changes or delete
them.

Note: Changing multiple configurations forces you to use the same SNMP version and credentials
for each selected entry. The Test button will not be available in the Change Network Device
Discovery Devices dialog box.

Related information
../admin_discovery/Admin_How_to_discover_network_devices.xml#concept3950
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Add/Change Network Device Discovery IP Address
Range Dialog Box

Enter a range of IP addresses to search for network devices.

 Getting There

To specify a range of IP addresses to query for network devices:

1. In the Range text boxes, enter an IP address range to search.

2. Specify the SNMP version: v1, v2, or v3. Then enter the required SNMP credentials for the SNMP
version you specified.  

3. Optional but recommended: Before clicking OK, click Test to open the Test Network Device
Discovery dialog box, where you can verify that a connection can be established before proceeding.

4. When you are satisfied with your settings, click OK.

5. After you click OK, a dialog box opens to tell you how many IP addresses this configuration will
attempt to query. You have the option to save your configuration by clicking Yes or, if the number of
devices is not what you expect, you can click No to return to the dialog box to make changes.
Although querying a large number of devices can take time, it does not affect machine performance
or the ability to run other tasks.

Related information
../admin_network_devices/Admin_SNMP_credentials.xml#concept1549
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Add/Change Network Device Discovery Subnet
Dialog Box

You can specify a subnet to search for network devices.

 Getting There

To specify a subnet to search for network devices:

1. Enter the subnet address and the subnet mask.

2. Specify the SNMP version: v1, v2, or v3. Then enter the required SNMP credentials for the SNMP
version you specified.  

3. Optional but recommended: Before clicking OK, click Test to open the Test Network Device
Discovery dialog box, where you can verify that a connection can be established before proceeding.

4. When you are satisfied with your settings, click OK.

5. After you click OK, a dialog box opens to tell you how many IP addresses this configuration will
attempt to query. You have the option to save your configuration by clicking Yes or, if the number of
devices is not what you expect, click No to return to the dialog box to make changes. Although
querying a large number of devices can take some time, it does not affect machine performance or
the ability to run other tasks.

Related information
../admin_network_devices/Admin_SNMP_credentials.xml#concept1549
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Add/Change Upgrade Path Location Dialog Box
Specify where the files are located for the agent self-upgrade.

 Getting There

To specify where the agent upgrade package (the files for the agent self-upgrade feature) is
located:

1. Do one of the following:
◦ Enter a UNC or a mapped drive that is accessible to machines on which the CAM Agent is

installed.

◦ Click Browse to find the folder on the network share location where you installed the agent
upgrade package.

Note: The path must be accessible to other computers. If, for example, the folder
resides on the same machine as CAM Administrator, browse to the network name of
the machine instead of the local drive.

2. Click OK.

Note: This dialog box is called Add Upgrade Path Location when you are adding a location for
these files, and Change Upgrade Path Location when you select an existing location in the Self-
upgrade tab in the Agent Options dialog box and click Change.  

Related information
../admin_machines/Admin_Overview_Client_self-upgrade_feature.xml#concept1180
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Add/Change Virtual Environment Discovery IP
Range Dialog Box

Enter a range of IP addresses to search for your virtual environment.

 Getting There

To search a range of IP addresses:

1. Enter an IP address range in the Range text boxes.

2. Select Hyper-V or VMware for the VM platform, and enter the required credentials. You can also
enter any additional information you want to add to the configuration in the Notes text box.

3. Before clicking OK, click Test to open the Test Virtual Environment Discovery dialog box, where you
can check that a connection can be established before proceeding.

Note: After you click OK, a dialog box opens to tell you how many IP addresses this
configuration will attempt to query. You have the option to save your configuration by clicking
Yes or, if the number of machines is not what you expect, you can click No to return to the
dialog box to make changes. Although querying a large number of machines can take time,
it does not affect machine performance or the ability to run other tasks.

4. Click OK when you're done.
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Add/Change Virtual Environment Discovery Subnet
Dialog Box

You can specify a subnet to query for your virtual environment.

 Getting There

To specify a subnet to query for your virtual environment:

1. Enter the subnet address and the subnet mask.

2. Select Hyper-V or VMware for the VM platform, and enter the required credentials. You can also
enter any additional information you want to add to the configuration in the Notes text box.

3. Before clicking OK, click Test to open the Test Virtual Environment Discovery dialog box, where you
can check that a connection can be established before proceeding.

4. After you click OK, a dialog box opens to tell you how many IP addresses this configuration will
attempt to query. You have the option to save your configuration by clicking Yes or, if the number of
machines is not what you expect, click No to return to the dialog box to make changes. Although
querying a large number of machines can take time, it does not affect machine performance or the
ability to run other tasks.

5. Click OK.
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Add/Change Virtual Environment Discovery
Machine Dialog Box

You can specify which machine(s) to query for your virtual environment.

 Getting There

To specify the machine(s) to query for your virtual environment:

1. Enter the machine names or IP address(es) to query, or click Browse to open the Browse for
Machines dialog box. Multiple machine names or IP addresses must be separated with commas.

2. Select Hyper-V or VMware for the VM platform, and enter the required credentials. You can also
enter any additional information you want to add to the configuration in the Notes text box.

3. Before clicking OK, click Test to open the Test Virtual Environment Discovery dialog box, where you
can check that a connection can be established before proceeding.

4. When you're satisfied with your settings, click OK.
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Additional Exclude Folders Dialog Box
You can specify that files in certain folders are excluded from inventories.

 Getting There

Excluding folders may help speed up the inventory process in sites with large numbers of folders that are
unlikely to contain files that need monitoring with Cherwell Asset Management.

To exclude folders and files from inventories:

1. Click Add.

2. Enter a folder name, or select an item in the list and click Change. You can also select an entry from
the list and click Remove if you no longer want to exclude that folder from inventories.

3. The list in this dialog box includes one column:
◦ Folder name fragment: Folders already excluded from inventories, as specified in the Add/

Change Exclude Folder dialog box.

Related information
../admin_how_to/Admin_How_to_exclude_folders_from_inventory_scans.xml#concept839
../admin_inventory/Admin_Tips_for_entering_folder_name_fragments.xml#concept1961
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Administrator User Policies Dialog Box
With Administrator user policies enabled, you can allow other users to have specified permissions to CAM
Administrator.

 This topic applies to: CAM authentication

 Getting There

To enable and configure Administrator user policies:

1. Select one from the following options:
◦ Enable Administrator user policies check box: The first user to check this check box

becomes the administrator, with administrator privileges. When you enable user policies, any
users who attempt to launch CAM Administrator afterward are prevented from doing so unless
you've specifically granted permissions to them.

◦ User name list: This list shows all users who have attempted to launch CAM Administrator,
regardless of whether user policies are enabled, and includes domain and permissions
information for each listed user. You can only make changes to this list when the Enable
Administrator user policies check box, above, is checked.  

◦ When user policies are enabled, you can add users to this list so you can give them
permissions or deny access. To add users to this list, click Add.

To change a listed user's permissions, select that user and click Change.

Click Remove to remove selected users. When user policies are enabled, removing a
user from this list has the same effect as marking that user as Not authorized.

◦ Not Authorized Message: The bottom portion of this dialog box displays the message that
users will see if they try to launch CAM Administrator and are not authorized to run it. You can
change the text of this message by typing over the existing message.

2. Click OK to save your changes.

Related information
Admin_Overview_User_policies.xml#concept2747
Admin_More_information_on_user_policy_permissions.xml#concept7850
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Agent Options Advanced Tab
You can specify heartbeat, metering, wait list, and terminal server usage for machines that have the CAM
Agent installed on them.

This topic applies to Windows machines only.

Use this tab to specify the following options:

Heartbeat
Use these options to specify how often machines that have the CAM Agent installed on them will contact
their associated access point.

• Heartbeat: The default heartbeat rate is 2 hours. Note that a change to the heartbeat rate will not
fully take effect on a given machine until the agent next checks in with the access point.

• Heartbeat window: This option specifies how much the heartbeat rate can vary among machines
reporting to the same access point, and is used to ensure a degree of randomness to prevent all
machines associated with the same access point from checking in at the same time when the
access point is restored after going offline.
Recommendation: Use the same value here as for the Heartbeat option above.

◦ The smaller the Heartbeat window value (though still nonzero), the closer to a regular interval
the heartbeats will be.

◦ The default window is 2 hours, and you cannot set this value higher than the Heartbeat value
specified above.

◦ You can disable this option for individual machines in the Machine Properties Advanced tab.

Metering
By default, the option in this section, Send metering data immediately, is unchecked. Check this option
if you'd rather metering data is sent as it is collected, rather than cached, which is the default behavior. Be
aware that checking this option impacts performance.

Wait list
If you use the wait list feature, you can use this option to specify how soon a user must launch a waitlisted
application once a license for it is available. The default is 1 minute.

Once this period of time expires, the license is not available for that first waiting user anymore, and the
next waiting user is notified that a license is available. If no one is waiting, the license becomes available
to any authorized user.
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Terminal server usage
The option in this section, Ignore remote usage through terminal server, specifies whether to collect
data from machines that have the agent installed on them and are connected to terminal servers and
Citrix servers on your network.

This option is useful, for example, in situations where a user is away from the office and needs to check
email from a machine that is not controlled by your organization (for example, from a kiosk or Internet
cafe). The user can connect to your organization's network, but it is not necessary or appropriate to
collect usage data from that machine.

When this option is selected, usage data from these machines is ignored, provided these machines do
not have the CAM Agent installed on them and that they are not present in Active Directory, your local NT
domain, or any machine group you've created. Since Cherwell Asset Management will not manage these
machines, they will not consume a  metering license.

If you later add one of these machines to Active Directory, your local NT domain, or a machine group,
Cherwell Asset Management will automatically start managing those machines.
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Agent Options Custom Tab
Use the Custom tab of the Agent Options dialog box to customize what information Cherwell Asset
Management collects from machines during the inventory process. You can add or change WMI
(Windows machines only) and user-defined (all platforms) properties.

Descriptions of each custom request are listed on the left, with the name of the property and its type (WMI
or user-defined) listed on the right. Use the up and down arrows if you want to move requests higher or
lower in the list; the list order is used when these values are displayed in reports.

Click New or Change to open dialog boxes where you can add or change requests. If you want to change
a WMI property, you should be familiar with WMI class and WMI property syntax.

The WMIViewer utility, provided as a part of CAM Administrator installation, allows you to browse various
WMI parameters. You may find this useful in determining which parameters you want to add to customize
your inventory. To use it, open WMIViewer.html in Internet Explorer. WMIViewer.html is typically located in
one of the following locations:

• For 64-bit systems: C:\Program Files (x86)\Cherwell Asset Management\WMIViewer

• For 32-bit systems: C:\Program Files\Cherwell Asset Management\WMIViewer

Note: Internet Explorer will warn you about the ActiveX control used to interact with WMI. Click
Yes in the warning dialog box to use the WMIViewer utility.
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Agent Options Inventory Tab
You can specify how the inventory process occurs.

To define the inventory process:

1. On the Inventory tab in the Agent Options dialog box, select the following:

Note: The following three options apply to Windows machines only.

a. Inventory frequency: By default, complete inventory scans are run once a month, and
information on all .exe and .com files is always collected.

◦ To schedule regular inventory scans, check the Perform a complete scan every box and
then set the frequency (months, weeks, or days). Adjust the value in the first box to
specify the exact frequency. For example, you can enter a 3 in the first box and then
choose Months in the second box to run inventory every quarter.

b. Inventory files with these extensions: To collect information on files with extensions other
than .exe and .com, click Extensions. In the Inventory Extensions dialog box, list other
extensions (for example, .mp3 or .ini files) to inventory.

c. Inventory these files: There may be cases where you want to collect inventory information on
specific files, rather than on all files with the same extension. In these cases, click Files, then
add specific files to the inventory process.

2. In the Exclude these folders from agent inventory section, uncheck boxes to add files to inventory
that are excluded by default from inventory scans:

◦ Temporary Internet Files folders

◦ Folders that contain install, patch, and cache files

◦ Mac OS system library, backup, and software update folders

3. If there are other folders that contain files you don't want to include in inventories, click Advanced to
open the Additional Exclude Folders dialog box, where you can specify which folders to exclude
from inventories.
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Agent Options Messages Tab
You can specify what messages are shown to users when different events occur.

 Getting There

The options in this section of the dialog box apply to Windows machines only.

1. Choose an item from the Description list box that best describes the event for which you want to
specify a message. The default message for that event is shown in the Message text box.

2. Click OK to accept that message, or edit the message to suit your needs and click OK.
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Agent Options Self-upgrade Tab
You can specify where the Windows agent self-upgrade files are located.

To specify where the Windows agent self-upgrade files are located:

1. Enter a UNC or a mapped drive that is accessible to machines that have the CAM Agent installed on
them.

2. Click OK when you are finished.
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Asset Template Asset Types Tab
You can add, rename, or delete asset types.

 Getting There

Asset types listed here will appear in the General tab of the New Asset dialog box, so that whenever you
add or modify an asset, you can specify the type of device.

By default, the following asset types are already defined:

• Backup device

• Data storage

• Firewall

• Printer

• Router

• Server

• Switch

To add another asset type:

1. Click New to open the New Asset Type dialog box.

After you enter a type in that dialog box, it will appear in the Asset Types box, as well as in the Asset
type drop-down list box in New Assets dialog box.

2. Click OK.

To rename or delete an existing asset type:

1. Select an asset type, then click Rename or Delete.

2. Click OK.

Note: This topic applies to the Asset Types tab of the Asset Template dialog box, and to the Asset
Types dialog box you can open from the New Asset/Asset Properties dialog box. Regardless of
the method you use to open this tab or dialog box, the presented options are the same and are
configured the same way.
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Asset Template Custom Asset Data Tab
Fields you create here are added to your asset template, and also appear in the User-defined tab of the
New Asset dialog box.

 Getting There

This tab displays any custom asset fields you've created: their label (name), description, and type.  

You can create custom fields here, as well as modify, delete, and change the order of any custom fields
you've already created.

To create a custom field:

1. Click New to open the New Custom Data Property dialog box.

2. Enter a label, description, and type for the field.

To modify a custom field:

• Select it from the list and click Change.

To delete a custom field:

• Select it from the list and click Delete. You are not prompted to confirm the delete, so make sure
you've selected the appropriate field.

To change the order of existing fields:

• Click a field and use the up and down arrow buttons to move it to the appropriate location.

When you're finished adding, modifying, deleting, or ordering custom fields, click OK to save your
changes, or click Cancel to exit the dialog box without saving your changes.

Note: You can only create custom asset data fields if your site is licensed to use the Inventory
feature; check the Licensed Features section of the Status panel to find out if this feature is
available to you.
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Asset Template Dialog Box
The asset template allows you to define custom fields and asset types you can use when you create a
new or modify an existing asset.

 Getting There

From the Tools menu, point to Template and click Asset.

Related information
Admin_Asset_Template_Custom_Asset_Data_tab.xml#concept1810
Admin_Asset_Template_Asset_Types_tab.xml#concept1562
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Automatically Configure Applications Dialog Box
You can see your inventoried or metered Windows applications or suites match the CSID, as well as how
many non-Windows applications were identified.

 Getting There

This dialog box informs you of the following:

• How many inventoried or metered Windows applications or suites you have that either closely or
exactly match information in the Cherwell Software Identification Database (CSID).

◦ You can specify whether exact match files only, or exact match and close match files are
automatically configured into license units.

◦ In most cases, you should click Yes here to automatically configure exact and close matches
of known application files into license units that you can manage. Also, it saves you the work
of manually configuring the files into license units; you can begin managing the license units
now.

◦ If you click No, the files will not be configured into license units and they'll show up in the
Unconfigured Applications panel.

• How many non-Windows applications were identified. You are directed to configure them in the
Unconfigured Applications Panel. It's recommended that you first move any applications you don't
want to track to that panel's Don't configure folder, and then configure the applications you do want
to track. See How to Configure Linux, Unix, and Mac OS Applications.

Related information
../admin_license_units_suites_applications/
Admin_About_license_units_suites_and_applications.xml#concept1660
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Browse for License Unit Dialog Box
You can specify the license unit to contain the application.

 Getting There

Use this dialog box to specify where to copy the selected application. All configured license units are
listed. Select the one that you want to contain the application, then click OK.
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Browse for Machines Dialog Box
You can specify which machines to query for virtual environment discovery.

To specify which machines to query for virtual environment discovery:

• Machines are grouped into the same categories as they are in the Machines panel. You can use the
Shift and Ctrl keys to select multiple machines, up to a limit of 1000.

• Select the machine(s) you want to query and click OK to return to the Add Virtual Environment
Discovery Machine dialog box.

Tip: If you can't find the machine you need, cancel out of the virtual environment discovery
configuration process and run discovery on non-virtual machines. After that discovery completes,
check the Machines panel to see if the machine is now listed. The Browse for Machines dialog
box can only list machines that appear in the Machines panel.
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Browse for User Dialog Box
You can apply an Administrator user policy to a specific user.

 Getting There

To select a user to which to apply an Administrator user policy:

• Users are grouped into the same categories as they are in the Users panel. Select the user to which
you want to apply the user policy, and click OK.

Tip: If you can't find the user you need, cancel out of this dialog box and the preceding two dialog
boxes, then run discovery again. After discovery completes, check the Users panel to see if the
user is now listed. The Browse for User dialog box can only list users that appear in the Users
panel.

Related information
../admin_user_policies/Admin_Overview_User_policies.xml#concept2747

145

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Browse_for_User_dialog_box.html
https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_how_to%2FAdmin_How_to_discover_machines_and_users.html
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overview_User_policies


Browse for Windows Program Dialog Box
Use this dialog box to browse for the executable file used to identify the application you want to add to a
license unit.

You can browse all Windows programs, or restrict browsing to programs that exist only on the selected
machine. When you choose to browse only on the selected machine, the dialog box changes to include a
list of machines on the left, from which you choose the machine you want to browse. In either case, the
installed Windows programs are listed by name along with version and GUID information.
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CAM Administration Service Dialog Box
Specify the CAM Administration Service to connect to, and the login credentials.

 Getting There

Enter the name of the service first. If the service resides on the same machine that you're using, you can
enter localhost. (In most cases, you should accept the port offered; if you change the port, you also
need to change your service configuration file.)

• Click Check Service to check whether the server is started and running. Note any messages that
appear in the status box at the bottom of this dialog box. If the service has not yet started, click Start
CAM Administration Service.

• Click Connect to connect to the specified CAM Administration Service and open CAM
Administrator. If you changed the service name, you will be prompted to restart CAM Administrator
for the change to take effect.
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CAM Database Dialog Box
You can specify the CAM Database to which the CAM Administration Service should connect.

 This topic applies to on-premises installations.

 Getting There

To specify the CAM Database to which the CAM Administration Service connects:

1. Select a database server, enter authentication information (normally the information that you
specified when the database was created during Setup), select the database, and click OK.

2. Choose a server from the drop-down list or type a server name, and then enter the appropriate login
name and password. If you are using a non-default instance of Microsoft SQL Server for your
database server machine, you must append a \ and the instance name to the server name. For
example, if your database server is MYSERVER and you are running an instance called CAM, specify
MYSERVER\CAM as the server name.

3. To specify the database name, select from the drop-down list.

Note: If the authentication data is not valid, no databases appear in the database name list.
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CAM System License Units Dialog Box
CAM system license units can be displayed in the License Units panel.

 Getting There

Tip: You can also delete license units that you won't ever want to monitor; see How to Delete a
License Unit.

License units that are not displayed in the License Units panel are shown in the box on the left; license
units that are displayed are shown in the box on the right.

To change whether a license unit is hidden or visible:

1. Select the license unit and click the appropriate arrow.

2. Click OK when you're done.

Related information
../admin_license_units_suites_applications/Admin_Overview_System_License_Units.xml#concept1468
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Change Authentication Dialog Box
The authentication method used at your site can be changed via this dialog box.

 This topic applies to on-premises installations.

 Getting There

Prerequisite: Before proceeding, read Authentication and Authorization for an explanation of these
concepts and the effects of changing your site's authentication. Also, review Checklist for Using CSM
Authentication and How to Change the Authentication Method for the complete procedures to follow.

One common scenario for changing the authentication method is after you've evaluated Cherwell Asset
Management in an on-premises installation, and want to integrate your solution with Cherwell Service
Management.

To change the authentication method used at your site:

1. Select one of the following authentication methods:
◦ CAM authentication: You use user policies and access profiles to control access to Cherwell

Asset Management.

◦ CSM authentication: With this method, access is managed in Cherwell Service Management.
Enter the following:

◦ API URL: This is usually http://<csm-machine-name>.

◦ API key: You should have already generated this key when you set up CSM security
groups.

◦ User name and password: The credentials for the CSDAdmin user.

2. After making any changes, click OK. If your credentials are validated, you are prompted to restart
CAM Administrator for your changes to take effect. Click OK in that dialog box to shut down CAM
Administrator, and then do the following:

a. Restart CAM Administrator.

b. If you changed to CSM authentication, select Tools > Synchronize with CSM.

c. Click Synchronize. The synchronization process may take a few moments to complete.

d. Direct any other users to log out of all Cherwell Asset Management applications, and then log
back in. That way, their sessions will use the new authentication settings.
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Change Authentication for Multiple Oracle
Database Instances Dialog Box

You can provide credentials to the database instances you selected in the Configure Oracle Database
Discovery dialog box.

 Getting There

To provide credentials to the database instances you selected in the Configure Oracle Database
Discovery dialog box:

1. Enter the user name and password for the multiple configurations.

2. Click OK.
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Change Authentication for a Single Oracle
Database Instance Dialog Box

Provide credentials to the single database instance you selected in the Configure Oracle Database
Discovery dialog box.

 Getting There

The fields in the top portion of this dialog box are populated using information collected during the Linux/
Unix/Mac OS discovery or virtual environment discovery processes, and you cannot edit them.

1. The User name field is pre-populated, but you can change it if you prefer to use another account.

2. Enter the password for the user. You can also enter additional information in the Notes text box.

3. Optional but recommended: Before clicking OK to save your settings, click Test to open the Test
Oracle Database Discovery dialog box, where you can verify that a connection can be established
before proceeding.

4. Click OK when you're done.
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Change Baseline Dialog Box
You can change a previously configured baseline, in order to measure any changes that have occurred.

 Getting There

Use this dialog box to change a previously configured baseline. Baselines are used in What's Changed
reports to measure any changes that occurred after the specified baseline was created.

Edit the name and/or description for the baseline and click OK. The modified baseline now appears in the
Configure Baselines dialog box. You can select it when you open Reporting and run the What's Changed
reports in Administrative Tools, Hardware Inventory, or Software Inventory.
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Change Licensed Features Dialog Box
Paste a configuration key into this dialog box to add features, licenses, or time to Cherwell Asset
Management.

 Getting There

To add any of these features, contact us for a new configuration key. Then enter the configuration key in
the box, and click OK.
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Change Virtual Environment Discovery Machine
Dialog Box

You can change the credentials to use for the selected virtual environment configurations.

 Getting There

To change the credentials to use for the selected virtual environment configurations:

1. In the Configure Virtual Environment Discovery dialog box, select multiple configurations and click
Change.

2. Before clicking OK, click Test to open the Test Virtual Environment Discovery dialog box, where you
can check that a connection can be established before proceeding. Note that the Test button is only
available when changing a single configuration at a time.

3. When you are satisfied with your settings, click OK to return to the Configure Virtual Environment
Discovery dialog box.
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Check in License Dialog Box
When you have licenses checked out, you can manually check them in here.

 Getting There

This dialog box lists all machines that currently have a license checked out for the current license unit.
You can use this dialog box to force a license to become available. This can be helpful, for example, in
situations where a user checks out a license and then disconnects from the network without checking that
license back in.

To force a license to become available:

1. Uncheck the check boxes next to any machine(s) from which you want to release the license.

2. Click OK.

Note: The user(s) on the machine(s) are not notified that the license was released. Keep in
mind that forcing a license to be checked in when the license is still in use may lead to
overuse of that license.
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Check In/Out Licenses Dialog Box
Listed here are the concurrently licensed applications that the selected machine is authorized to use.

 Getting There

You can check a license in or out by checking or unchecking the check box next to a listed application.

This feature is useful, for example, in situations where users need to use a concurrent application while
traveling and didn't check out a license before disconnecting from the access point.

Related information
../admin_control/Admin_About_concurrent_licenses.xml#concept855
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Cherwell Asset Management License Expired
Dialog Box

A message is shown if your CAM license has expired.

Your license for Cherwell Asset Management has expired. Contact us to purchase the license(s) you need
to continue collecting and processing data.

Note: If you don't purchase a license, CAM Administrator remains functional and you can still view
reports, but you won't be able to collect or process any additional data or use the control feature.
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Choose Details Dialog Box
The columns that appear in the right pane of various panels can be customized.

 Getting There

Use this dialog box to customize the columns that appear in the right pane of the License Units,
Unconfigured Applications, Files, Machines, Network Devices, Other Assets, and Users panels. You can
specify which columns are shown, as well as their width and order.

To customize columns:

1. Check the check boxes next to columns you want to view in the panel, and uncheck the check
boxes to columns you want to hide.

2. Use the Move Up and Move Down buttons to reorder the list. The columns will appear in the right
pane of the panel in the same order as in this dialog box, from left to right.

3. Change a column width by selecting it and specifying a width (in pixels).

4. Click OK when you're done. Your changes are shown in the right pane of the panel you're viewing.
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Concurrent License Allocations Dialog Box
Concurrently licensed applications are distributed across groups of machines. You can specify new
allocations here.

 Getting There

For example, if you purchase 50 licenses of an accounting application, you may want to allocate 45
licenses to the accounting group and the remaining 5 licenses to the executive group. How license
allocation is used depends on the license type.

License Types

• Concurrently licensed applications: allocation can control who is allowed to run the application
based on license availability

• Non-concurrent applications: use group assignments in Purchasing to assign licenses to specific
groups

Prerequisite:

Before you can allocate licenses, you must first add purchase information either via the License Unit
Properties Purchasing tab, or via the CAM Purchasing application. You can also use Purchasing to
allocate license units.

To modify license allocations:

• To allocate licenses, click Add and specify how many licenses to allocate to which groups.

• To change your license allocation settings, select a group from the list and click Change.

• To remove a license allocation setting, select a group from the list and click Remove. That number
of licenses is now freed up to allocate to other groups.

• Use the arrow buttons to move groups up and down the list. Groups that appear first in the list have
top priority, and so on.

Notes:

• Licenses left unallocated are implicitly in the "default" allocation group. Any licenses in the default
group are available to be checked out by anyone authorized to run the application.

• To actually control who is allowed to run a concurrently licensed application, you must also specify a
control profile for the license unit.

Related information
../admin_control/Admin_About_license_allocation.xml#concept2806
../admin_control/Admin_About_concurrent_licenses.xml#concept855
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Configure Baselines Dialog Box
Baselines can be used to capture current inventory information.

 Getting There

What's Changed reports can be used to compare baselines against later inventory information. You can
run What's Changed reports within Reporting for Administrative Tools, Hardware Inventory, or Software
Inventory.

The name, description, and creation date for any existing baselines are listed in this dialog box. You can
create new baselines, modify the name and description of existing baselines, and delete existing
baselines.

To create a new baseline:

• Click New to open the New Baseline dialog box.

To change or delete an existing baseline:

• Select the baseline, then choose Change or Delete.

Related information
Baselines
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Configure Linux/Unix/Mac OS Discovery Dialog
Box

You can configure Linux/Unix/Mac OS discovery and view existing discovery configurations.

 Getting There

Prerequisite: You need to configure discovery for at least one machine before you can launch the
discovery process.

To configure Linux/Unix/Mac OS discovery:

1. From the Add Linux/Unix/Mac OS Discovery Machine(s) dialog box, select Add, then select one of
the following:

◦ IP Address Range: Use when you have a range of IP addresses you want to query for Linux/
Unix/Mac OS machines.

◦ Subnet: Use to query a specific subnet on your network.

◦ Machine: Use in cases where you know the name or IP address of the machine(s) you want to
discover. Multiple entries must be separated by commas.

Note: The credentials used to connect to the machine can consist of a User name and either
a Password or Private Key/Passphrase. If you use a Private key (a cryptographic key
composed of a long random number), you can use a key generator to view the key, then
copy and paste it from there into the Private key box. See example.

2. Click OK.

Any selected configurations are discovered next time you run discovery, or when a scheduled
discovery runs.

You can come back to this dialog box during the discovery process to view the status.

Existing Linux/Unix/Mac OS discovery configurations are shown in the box, and check boxes specify
which configurations to run. The following information is shown for each configuration:

• Configuration type (Range, Subnet, or Machine)

• Description

• Port number

• Any additional notes entered for this configuration

• The name of the CAM Administration Service machine where the configuration was saved

• Last date that this configuration was run
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• Results of the last time the configuration was run

To change or remove existing configurations:

• Click one or more existing configurations, then click Change or Remove to make changes or delete
them.

Note: Changing multiple configurations forces you to use the same credentials for each selected
entry. The Test button will not be available in the Change Linux/Unix/Mac OS Discovery Machines
dialog box.

Related information
../admin_discovery/Admin_Overview__Discovering_Linux_Unix_Mac_OS_machines.xml#concept1814
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Change Multiple Configurations in the Configure
Network Device Discovery Dialog Box

You can change the SNMP version and credentials for multiple configurations.

 Getting There

This dialog box is similar to the dialog boxes you used to first configure network device discovery, and the
parameters you change here are changed in all selected configurations.

1. Select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Device Discovery dialog box, select configuration(s), then click Change.

4. Specify the SNMP version: v1, v2, or v3. Then enter the required SNMP credentials for the SNMP
version you specified.

5. Click OK when you're done.

6. Click OK again to return to the Discover Network Devices dialog box, where you can click Discover
if you want to run network device discovery using the credentials you just entered.

Related information
../admin_network_devices/Admin_SNMP_credentials.xml#concept1549
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Configure Oracle Database Discovery Dialog Box
You can configure Oracle Database discovery and view existing discovery configurations.

 Getting There

Prerequisite: Before you can run Oracle Database discovery, run Linux/Unix/Mac OS discovery, and
virtual environment discovery if you have Oracle Databases running on virtual machines. Once you do
that, you must configure Oracle database discovery for at least one machine before you can launch the
Oracle database discovery process to collect Oracle licensing information.

Note: Oracle database discovery is not currently supported on Microsoft Windows Server
Operating Systems.

To configure Oracle database discovery:

• Click one or more listed machines, then click Configure to open a dialog box and specify
credentials for the machines.

Existing discovery configurations are shown in the box, and checkboxes specify which configurations to
run. Before you run Oracle database discovery, the following information is shown for each configuration:

• IP address

• Machine name

• Service name

• Protocol

• Port number

• Database name

• User name

• Notes (if any)

Once you run discovery, the following information about the discovered Oracle database instances is also
listed:

• Database version

• Sid (along with the Service name, this field represents how the instance is configured to accept
incoming connections)

• Admin service

• Last run

• Last result
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The Oracle database discovery process runs on any machines that are checked the next time you run
discovery or a scheduled discovery runs.

Related information
../admin_discovery/Admin_How_to_discover_Oracle_databases.xml#concept3950
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Configure Virtual Environment Discovery Dialog
Box

You can configure virtual environment discovery and view existing discovery configurations.

 Getting There

Prerequisite: You must configure virtual environment discovery before you can run it.

To configure virtual environment discovery:

1. Click Add, then click one of the following:
◦ IP Address Range: Use when you have a range of IP addresses you want to query.

◦ Subnet: Use to query a specific subnet on your network.

◦ Machine: Use in cases where you know the name or IP address of the machine(s) you want to
query. Multiple entries must be separated by commas.

2. Click OK.

You can run discovery immediately by clicking Discover, or click Close to run discovery later. The options
you specified are used the next time you run virtual environment discovery, and remain in effect until you
change them.

Existing virtual environment discovery configurations are shown in the box, and checkboxes specify which
configurations to run. The following information is shown for each configuration:

• Configuration type (Range, Subnet, or Machine)

• Description

• VM platform (Hyper-V or VMware)

• Notes (any additional information entered)

• CAM Administration Service machine that ran the discovery process

• Last time discovery ran

• Last results

To change or remove existing configurations:

• Click one or more existing configurations, then click Change or Remove to make changes or delete
them.

Note: Changing multiple configurations forces you to use the same credentials for each selected
entry. The Test button will not be available in the Change Virtual Environment Discovery Machines
dialog box.

Related information
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../admin_discovery/Admin_How_to_discover_virtual_machines.xml#concept3918
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Configure Web Components Location Dialog Box
Specifying where web components are located can help prevent issues with upgrading or Internet
Information Services (IIS) configuration.

 This topic applies to on-premises installations.

 Getting There

You can specify one root location where all web components are installed, or different URLs for each
component. Specifying fully-qualified domain names is recommended in all cases, and required if you
install web components to different machines.

Click OK to validate and save your settings.

Related information
../admin_troubleshooting/Admin_If_a_URL_is_not_listed_for_Reporting.xml#concept1683
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Contribute to the CSID Dialog Box
The CAM AppScanner utility collects information about application files on the selected machine in order
to find applications that do not yet exist in the Cherwell Software Identification Database (CSID).

 Getting There

Important: No personal, sensitive, or confidential information is sent when you run CAM
AppScanner. The only information sent is from applications found during the scan. The information
you enter in this dialog box is only used to identify you, and to verify that you are authorized to run
the utility on the selected machine.

To run CAM AppScanner:

1. Enter the administrator information, along with the name of the application scan file that is
generated:

◦ Name: Your name

◦ Company: Your company name

◦ Email address: The email address we should use to contact you, if necessary.

◦ Comments: An optional field that you can use, for example, to call attention to a specific
application.

2. When the Send application scan file later (manually) checkbox is unchecked, as it is by default, the
application scan file is sent to Cherwell via HTTPS as soon as it is generated.

If you check this box, the generated application scan file is saved to the CAM Administration Service
machine in the location shown. Each application scan file has a unique name, and you can send the
application scan file(s) you generate to us at csid@cherwell.com later.

3. Enter the credentials information for the selected machine:
◦ Full user name: A valid user authorized to run applications on the selected machine.

◦ Password: The password associated with the above user name.

◦ Domain or machine name: The user domain (or the machine name if a local user).

If the credentials are incorrect, an error is shown, and you won't be able to run the utility.

Notes:

• You can only scan one machine at a time, and the utility runs transparently on the selected machine.

• This dialog box is only available when a machine is selected, and the word "from" and the name of
the selected machine appear in the title bar.

• You can opt in to automatically send unrecognized applications directly to the CSID team; select
Yes in the Do you want to enable automatic contribution to the Cherwell Software Identification
Database? dialog box.
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Related information
../cherwell_id_database/Admin_Overview_AppScanner_utility.xml#concept1517
../cherwell_id_database/Admin_CSID_overview.xml#concept1555
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Control Profiles Dialog Box
Control Profiles are groups of settings that help system administrators control which users and machines
are allowed or denied access to specific applications.

 Getting There

Use this dialog box to view and manage control profiles.

The predefined control profiles and any control profiles you created are listed in the box, along with their
descriptions.

Related information
../admin_control/Admin_About_authentication_profiles.xml#concept1614
../admin_control/Admin_Predefined_authentication_profiles.xml#concept2375
../admin_how_to/Admin_How_to_create_a_new_authorization_profile.xml#concept2111
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Convert to License Unit Dialog Box
You can move or copy an application to a new or existing license unit.

 Getting There

1. Specify what you want to do with the application:
◦ Move the selected application(s) into a new license unit: Select this option to move the

application out of one license unit and into a new license unit that you'll define in the
subsequent dialog box. The new license unit is added, and will be displayed in the left pane of
the License Units panel under the same categories as the original.

◦ Example use: Two different versions of an application are installed on machines in your
organization, each under a different licensing agreement, and you want to track them
separately. Suppose that you have a per-seat licensing agreement for Adobe Acrobat 6.0
Standard and a concurrent use license for Adobe Acrobat 7.0 Standard. By default,
Cherwell Asset Management configures both applications into one license unit, called
Adobe Acrobat Standard.

◦ After selecting the Adobe Acrobat 7.0 Standard application in the Adobe Acrobat
Standard license unit and right-clicking your selection to open this dialog box, select this
first option and click OK. In the Convert Applications to License Unit dialog box, enter the
name of the license unit to create, and which versions of the application to include in it.

◦ Upon completion, consider renaming the original Adobe Acrobat Standard license unit to
reflect the applications that are still in it.

◦ Move the selected application(s) into an existing license unit: Select this option to remove
the application from one license unit and into another existing license unit.

◦ Example use: You have one or more versions of an application that you want to track
separately within the same license unit.

◦ Copy the selected Windows application(s) into a new license unit: Select this option if you
want to separately monitor Windows applications that use identical main executable files. With
this option, you copy an application to a new license unit and assign it a GUID to distinguish it
from other installations.

◦ Example use: Two applications that have the same executable file are installed on
machines in your organization, and you want to monitor them separately.

After selecting the first application's unit and right-clicking your selection to open this dialog
box, select this second option and click OK. In the Add Existing Applications to New License
Unit dialog box, browse to the appropriate GUID and click OK to complete the conversion
process.

Upon completion, consider renaming the original license unit to reflect the applications that are
still in it.

◦ Copy the selected Windows application(s) into an existing license unit: Select this option
if you want to separately monitor Windows applications that use identical main executable
files. With this option, you copy an application to an existing license unit and assign it a GUID
to distinguish it from other installations.
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◦ Example use: You have another version of an application that does not have a GUID
assigned to it, and you already created a license unit for it.

◦ After selecting the application in its license unit and right-clicking your selection to open
this dialog box, select this third option and click OK. In the Add Existing Applications to
Existing License Unit dialog box, select the license unit, fill in the other fields, and click
OK to complete the conversion process.

2. Click OK to continue with the conversion procedure.

Tip: You can also move (not copy) an application from one license unit to an existing license unit.
To do so, cancel out of this dialog box and move the application to the existing license unit.

Related information
../admin_how_to/Admin_How_to_separate_an_application_from_its_license_unit.xml#concept2219
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Copy Existing Applications to Existing License
Unit Dialog Box

In order to copy an existing application to an existing license unit, you must specify where to copy it.

 Getting There

Use this dialog box to specify where to copy the application, and to assign a GUID to the application. All
fields are required.

To specify where to copy the application:

1. Complete the following:
License Unit

◦ Name: Click Browse, then select the license unit to contain the application.

Application
◦ GUID: Click Browse, then search for the application's GUID.

◦ Name: After you find the GUID, the name of the application is shown here.

◦ Version: After you find the GUID, the application's version number is shown here.

2. Click OK. The application is added to the license unit.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Copy Existing Applications to New License Unit
Dialog Box

You can copy existing applications to a new license unit.

 Getting There

Use this dialog box to specify how to create the new license unit for the selected application(s). All fields
are required.

Complete the following:

1. License Unit:
◦ Name: Accept the suggested name for the license unit you're creating, or enter a new name.

The name you use here will show up in the License Units panel for the license unit you're
creating.

2. Application:
◦ GUID: Click Browse, then search for the application's GUID.

◦ Name: After you find the GUID, the name of the application appears here.

◦ Version: After you find the GUID, the version number of the application appears here.

3. Click OK.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Copy Existing Suite to Existing License Unit Dialog
Box

Specify where to copy the suite, and assign a GUID to it.

All fields are required.

Complete the following:

1. License Unit:
◦ Name: Click Browse, then select which license unit should contain the suite.

2. Suites:
◦ GUID: Click Browse, then locate the suite's GUID.

◦ Name: After you find the GUID, the name of the suite appears here.

◦ Version: After you find the GUID, the version number of the suite appears here.

3. Click OK.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Copy Existing Suite to New License Unit Dialog
Box

In order to copy an existing suite to a new license unit, you must specify both the license unit and the
suite information.

Use this dialog box to specify how to create the new license unit for the selected suite. All fields are
required.

Complete the following:

1. License unit:
◦ Name: Accept the suggested name for the license unit you're creating, or enter a new name.

The name you use here will show up in the License Units panel for the license unit you're
creating.

2. Suites:
◦ GUID: Click Browse, then search for the suite's GUID.

◦ Name: After you find the GUID, the name of the suite appears here.

◦ Version: After you find the GUID, the version number of the suite appears here.

3. Click OK.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Delete Rule Set Dialog Box
A rule set is a group of settings that you chose to save when you ran a wizard to import asset information
into Cherwell Asset Management.

To delete a rule set so that you cannot select it again in the wizard:

1. Select the rule set from the list.

2. Click OK.
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Discover Active Directory or NT Domain Dialog
Box

Learn how to configure and execute the Active Directory or NT Domain discovery process.

 Getting There

• If you haven't run discovery before, click Configure to set up how you want to run discovery of
machines and users from Active Directory or the NT domain.

• Otherwise, click Discover to run discovery immediately.
◦ When you run the discovery process from here, Cherwell Asset Management uses NT domain

discovery by default, if you haven't previously configured discovery. Once you select either
Active Directory or NT Domain in the AD Discovery tab of the Options dialog box, this choice
is the default for later discovery processes and is also used for scheduled discovery.
(Discovery automatically runs weekly.)

• After the discovery process is complete, discovered machines and users will show up in the
Machines panel and Users panel, respectively.

Notes:

• When you choose NT domain discovery, only machines in your current domain will be discovered.

• If you're using Active Directory in a large environment, you can limit discovery to certain
organizational units (OUs). Click Configure to open the Add Active Directory OU Path dialog box
and configure your options.

Related information
Admin_Overview_Discovery.xml#concept605
../admin_users/Admin_About_machine_discovery.xml#concept1217
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Discover Linux/Unix/Mac OS Dialog Box
Learn how to configure and execute the Linux/Unix/Mac OS discovery process.

 Getting There

If you haven't run Linux/Unix/Mac OS discovery before, configure how it will run:

1. Click Configure.

2. When you've configured your discovery process, click Discover to run it.

Related information
../admin_discovery/Admin_Overview_Discovery.xml#concept605
../admin_discovery/Admin_Overview__Discovering_Linux_Unix_Mac_OS_machines.xml#concept1814
../admin_discovery/Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
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Discover Network Devices Dialog Box
Learn to configure and execute network device discovery.

 Getting There

If you haven't run network device discovery before, configure how it will run:

1. Click Configure.

2. When you've configured your discovery process, click Discover to run it.

Related information
../admin_discovery/Admin_Overview_Discovering_network_devices.xml#concept1322
../admin_discovery/Admin_How_to_discover_network_devices.xml#concept3950
../admin_discovery/Admin_Overview_Discovery.xml#concept605
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Discover Oracle Databases Dialog Box
Learn to configure and execute Oracle Database discovery.

 Getting There

Prerequisites

Before launching Oracle Database discovery, do the following:

• Run Linux/Unix/Mac OS discovery to find Oracle Database instances in these environments.

• Run virtual environment discovery. This process maps database instances that were found via
Linux/Unix/Mac OS discovery to their virtual environments, and is necessary for gathering accurate
licensing requirements.

If you haven't run network device discovery before, configure how it will run:

1. Click Configure.

2. Provide credentials for selected servers.

3. When you've configured your discovery process, click Discover to run it.

Related information
../admin_discovery/Admin_Overview_Discovering_Oracle_Databases.xml#concept1322
../admin_discovery/Admin_How_to_discover_Oracle_databases.xml#concept3950
../admin_discovery/Admin_Overview_Discovery.xml#concept605
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Discover Virtual Environment Dialog Box
Learn how to configure and execute virtual environment discovery.

 Getting There

If you haven't run virtual environment discovery before, configure how it will run:

1. Click Configure.

2. When you've configured your discovery process, click Discover to run it.

Related information
../admin_discovery/Admin_Overview_Discovering_virtual_machines.xml#concept730
../admin_discovery/Admin_How_to_discover_virtual_machines.xml#concept3918
../admin_discovery/Admin_Overview_Discovery.xml#concept605
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Enable Agent Self-Upgrade Dialog Box
Specify the location of the upgrade package.

 Getting There

Prerequisite:

Copy the upgrade package, either manually or via the included script, to a network share location.

To select the location of the upgrade package and enable self-upgrade:

1. Once in the Enable Agent Self-Upgrade dialog box, select the location of the upgrade package,
either from the list or by clicking Add and browsing to the location.

2. Click Enable Upgrade.
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File Properties Dialog Box
You can find the basic properties of a selected file in the File Properties dialog box.

 Getting There

The dialog box consists of the following tabs:

• File Properties General Tab

• File Properties Version Tab

• File Properties Locations Tab

Note: The name of the selected file is shown in the title bar in place of the word file.
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File Properties General Tab
The File Properties General tab displays basic file information.

The General tab displays:

• File name

• Description

• Version

• Size

• Date the file was added to the CAM Database

• Whether the file has been launched since it was added

Note: The name of the selected file is shown in the title bar in place of the word file.
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File Properties Locations Tab
The Locations tab displays a list of machines on which the file was found, and the path to the file on each
machine.

Note: The name of the selected file is shown in the title bar in place of the word file.
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File Properties Version Tab
The Version tab displays version information for a selected file.

The Version tab displays:

• File version

• Description

• Copyright date

• Other version information:
◦ Company

◦ File Version

◦ Original File name

◦ Product Name

◦ Product Version

◦ Author

◦ Comments

◦ Legal Trademarks

How much of this information is available depends on:

• What is present in the file; most of the information is optional and may not have been specified by
the file's creator.

• Whether extended inventory information has been collected.

The name of the selected file is shown in the title bar in place of the word file.
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Hosted Cherwell Asset Management Dialog Box
For hosted installations, your host connection can be configured here.

 Getting There

Use this dialog box to configure your host connection. Consult the email message you received from
Cherwell Software for specific information you need to enter for each of these fields:

• Remote host

• User name

• Password
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Import Remote Inventory Files Dialog Box
You can import remote inventory files (inventory files from Windows machines that are not connected to
the network).

Specify the location of the folder that contains the remote inventory files you want to import, and click
Import.
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Import SCOM Data Dialog Box
You can configure and run the process for importing Microsoft System Center Operations Manager
(SCOM) data from discovered machines.

 Getting There

1. Enter (or browse to) the name of your SCOM server, and the required credentials.

2. Recommended: Click Test to validate credentials before continuing.

3. Click Import to save your settings and start importing, or click Save if you want to save your settings
but run the import process later.

Related information
../admin_machines/Admin_Overview_SCOM_integration.xml#concept654
../admin_how_to/Admin_How_to_import_SCOM_data.xml#concept1110
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Install Agent to Multiple IP Addresses Dialog Box
You can install or update the CAM Agent on multiple machines using their IP addresses.

Tip: Consider enabling machines to use the self-upgrade feature.

To install the CAM Agent on multiple machines using their IP addresses:

1. Enter an IP address subnet in the boxes at the bottom of the dialog box. The fourth box acts as a
wildcard, so that all IP addresses in the specified subnet are shown when you click Display.

2. In most cases, you should keep the Perform DNS lookup check box checked. That way, Cherwell
Asset Management only presents a list of IP addresses that are resolved to their associated
machine names. If you uncheck this check box, the entire range of IP addresses is shown, without
machine names.

3. After clicking Display, the machines in the IP address subnet that you entered are listed. Select
which machines you want to install the CAM Agent on, and click Install.

4. Enter your installation credentials. You can also specify other settings in that dialog box as well.

Note: The process for updating the CAM Agent is mostly the same as that for installing the CAM
Agent for the first time. The main difference is that when updating, you should check the
Overwrite existing installations option in the Install/Update CAM Agent dialog box.

Related information
../Admin_Overwrite_existing_installations_option.xml#concept1695

193

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_machines%2FAdmin_Overview_Client_self-upgrade_feature.html
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overwrite_existing_installations_option


Install/Update Agent on Single Machine Dialog Box
You can install or update the CAM Agent on a single Windows machine. You can also update the
connection properties.

The version of the CAM Agent software to be installed is shown at the top of the dialog box.

Tip: Consider enabling machines to use the self-upgrade feature.

The following sections describe the options in each area of the dialog box, and the final section explains
how to start the agent installation, and provides some tips.

Selecting the CAM Access Point
The following options are available in this dialog box:

• Machine name or IP address: Specify the name or IP address of the machine on which the CAM
Agent should be installed.

• Select the Access Point that the agent will use: From this drop-down list, select the access point
to which the selected machine will report.

• Overwrite existing installations (select to upgrade or reinstall out of date agents): If you're
updating the CAM Agent, check the Overwrite existing installations box.

◦ In most other cases, keep this check box unchecked. For more information, see Overwrite
Existing Installations Option.

Credentials
In the Credentials portion of the dialog box, enter the domain or local machine administrator credentials:

• User name

• Password

• Domain or machine name

Use IP address instead of machine name
If you check the Use IP address instead of machine name check box, also type in the machine's IP
address in the Domain or machine name option in Credentials.

Note: You can only install using an IP address to machines where the IP address is known. This is
most often the case when you previously installed to an IP address range and are now updating
those machines.

194

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_machines%2FAdmin_Overview_Client_self-upgrade_feature.html
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overwrite_existing_installations_option
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overwrite_existing_installations_option


Proxy server options
By default, the first option, Save proxy settings to agent machine, is unchecked. Only check this box if
the machine needs to use a proxy server, and see Proxy Server Options for help configuring the related
options.

Proceeding with the agent installation
Click Install when done to install the agent software on the selected machine.

The Status box keeps you informed of the progress of the installation, and lets you know if the process
failed.

By default, this dialog box stays open until agent installation to the specified machine is complete so that
you can view installation status. Clear the Close this dialog box when install succeeds check box to
change that behavior.

Once you start the installation, you can close the dialog box at any time, or you can wait and enter
another machine on which to install the agent.

Tips:

• The process for updating the CAM Agent is mostly the same as that for installing it for the first time.
The main difference is that when updating, you should check the Overwrite existing installations
option (see the explanation of this option above).

• To update the CAM Access Point that the agent will use, select a new one from the drop-down list,
then click Install.
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Install/Update CAM Agent Dialog Box
You can install or update the CAM Agent to a selected Windows machine. You can also update the
connection properties.

The version of the CAM Agent software that will be installed is shown near the top of the dialog box.

Tip: Consider enabling machines to use the self-upgrade feature.

The following sections describe the options in each area of the dialog box. The final section explains how
to start the agent installation, and provides some tips.

Select the CAM Access Point
The following options are available in this dialog box:

• Select the Access Point that the agent will use: From this drop-down list, select the access point
to which the selected machine will report.

• Overwrite existing installations (select to upgrade or reinstall out of date agents): If you're
updating the CAM Agent, check Overwrite existing installations. In most other cases, keep this
check box unchecked.

Enter Credentials
In the Credentials section, enter the domain or local machine administrator credentials:

• User name

• Password

• Domain or machine name

Use IP address instead of machine name
If you check Use IP address instead of machine name, also type in the machine's IP address in
Domain or machine name in the Credentials section.

Note: You can only install using an IP address to machines where the IP address is known. This is
most often the case when you previously installed to an IP address range and are now updating
those machines.

Proxy server options
By default, the first option, Save proxy settings to agent machine, is unchecked. Only check this box if
the machine needs to use a proxy server.
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Proceeding with the agent installation

1. Click Install.
The Status box keeps you informed of the progress of the installation, and lets you know if the
process failed.

2. To find out whether the installation completed properly, press F5 to refresh the display after a few
minutes, or check the status line at the bottom right of the window for updates.

Tips:

• The process for updating the CAM Agent is mostly the same as that for installing it for the first time.
The main difference is that when updating, you should check Overwrite existing installations.

• To update the CAM Access Point that the agent will use, select a new one from the drop-down list,
then click Install.

Related information
../Admin_Overwrite_existing_installations_option.xml#concept1695
../admin_troubleshooting/Admin_Proxy_server_options.xml#concept2440
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Inventory Extensions Dialog Box
.exe and .com files are always inventoried; you can also collect inventory information on other types of
files.

 Getting There

To add, change, or remove files from inventory:

• To add a file extension, click Add and enter the extension.

• To change inventoried file extensions, select an item in the list and click Change.

• To remove an extension, select it and click Remove.

The list in this dialog box includes the following columns:

• Extension: File extensions to include when inventorying machines.

• Runnable: Whether files with this extension start an application.

Note: You can only configure files that are runnable into license units.

Information on files with extensions you specify here will not appear in the Files panel unless you search
for them, but they will appear in some reports.
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Inventory Machines Dialog Box
You can start an inventory on a selected machine here.

Any machines already running the CAM Agent will be inventoried; machines on which the agent is not
installed will temporarily receive the agent, have inventory run on them, and have the agent removed.

The following sections describe the options in each area of the dialog box, and the final section explains
how to start the inventory process.

Select the CAM Access Point

• Select the Access Point that the agent will use: From this drop-down list, select the access point
to which the selected machine will report inventory information.

• Overwrite existing installations (select to upgrade or reinstall out of date agents): This option
is disabled in this dialog box.

There may be cases where one or more of the selected machines are already configured to report
inventory to another access point. Any machines that have the agent already installed will use the access
point specified at installation.

Enter Credentials
Enter the domain or local machine administrator credentials:

• User name

• Password

• Domain or machine name

Use IP address instead of machine name option
If you select this check box, also type in the machine's IP address in the Domain or machine name
option above.

Note: You can only install using an IP address to machines where the IP address is known. This is
most often the case when you previously installed to an IP address range and are now updating
those machines.

Proxy server options
By default, the first option, Save proxy settings to agent machine, is unchecked. Only check this box if
the machine needs to use a proxy server; see Proxy Server Options for help configuring the related
options.
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Proceeding with the inventory
Click Inventory to start the inventory process.

To find out whether the inventory completed properly, press F5 to refresh the display after a few minutes,
or check the status line at the bottom right of the window for updates.

Note: Neither the access point nor the proxy information will be changed on the machine if the
CAM Agent is already installed on it.
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Inventory Multiple IP Addresses Dialog Box
You can inventory multiple Windows machines using their IP addresses.

To inventory multiple IP addresses:

1. Enter the IP address subnet in the boxes at the bottom of the dialog box. The fourth box acts as a
wildcard, so that all IP addresses in the specified subnet are shown when you click Display.

2. In most cases, you should keep the Perform DNS lookup check box selected. That way, Cherwell
Asset Management only presents a list of IP addresses that are resolved to their associated
machine names. If you uncheck this check box, the entire range of IP addresses is shown, without
machine names.

3. Select which machines you want to inventory, then click Inventory.

4. Specify the access point. The access point is the where the inventory agent will report, and it is also
used for the domain or local machine administrator credentials required to install the agent. You can
also specify other settings in this dialog box.

Note: Any machines that already have the CAM Agent installed on them are inventoried by that
agent; on other selected machines, the CAM Agent is temporarily installed and then removed
when the inventory is complete.
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Inventory Single Machine Dialog Box
This dialog box allows you to inventory a single Windows machine.

Options in each area of the dialog box are described below, and the final section explains how to start the
inventory process.

Select the CAM Access Point
The first three options apply to selecting the CAM Access Point:

• Machine name or IP address: Specify the name or IP address of the machine you want to
inventory.

• Select the Access Point that the agent will use: Choose the access point to which the selected
machine will report inventory information.

• Overwrite existing installations (select to upgrade or reinstall out of date agents): This option
is disabled.

Credentials
In the Credentials portion of the dialog box, enter the domain or local machine administrator credentials:
the username, password, and domain or machine.

Use IP address instead of machine name
If you check this box, enter the machine's IP address in the Machine name or IP address option in the
previous section (Select the CAM Access Point).

Note: You can use an IP address instead of a machine name when you know the machine's IP
address. This is most often the case when you previously installed to an IP address range and are
now updating those machines.

Proxy server options
By default, the first option,Save proxy settings to agent machine, is not marked. Only mark this box if
the machine needs to use a proxy server, and see Proxy Server Options for help configuring the related
options.

Start the Inventory Process
Click Inventory to start the inventory process.

By default, this dialog box stays open until the inventory of the specified machine starts. To change this,
uncheck Close this dialog box when inventory starts; an example of when you might want to do this is
when you want to leave the dialog box open so you can inventory another machine.

Notes:

• If the specified machine already has the CAM Agent installed on it, inventory is performed by that
agent. Otherwise, the CAM Agent is temporarily installed and then removed when the inventory is
complete.

202

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Proxy_server_options


• Neither the access point nor the proxy information will be changed on the machine if the CAM Agent
is already installed on it.
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Inventory These Files Dialog Box
You can tell Cherwell Asset Management to collect inventory information only on specific files.

 Getting There

To add, change, or remove files from inventory:

• Click Add to add files.

• To change files included in inventory, select an file in the list and click Change.

• To remove a file, select it and click Remove.

The list in this dialog box includes the following columns:

• File name: The files to include when inventorying machines.

• Folder name fragment: Information on where the file is located, if path information was specified
when this file was added.

• Runnable: Whether the file is runnable (starts an application).

Note: Note that you can only configure files that are runnable into license units.

Information on files listed here will not appear in the Files panel unless you search for them, but they will
appear in some reports.

Related information
../admin_inventory/Admin_Tips_for_entering_folder_name_fragments.xml#concept1961
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License Unit Properties Advanced Tab
You can set additional license unit options.

If the current license unit represents an operating system, check the This license is an operating
system check box.

In the Application versions section, the following options specify how Cherwell Asset Management
consolidates application versions:

• In most cases, leave the Track each version separately option (the default) selected.

• Ignore version specifies that Cherwell Asset Management will only track an application by its
name.

Important: If you select this option, support files may be removed from other license units.
This is irreversible.

When you track each version separately, Cherwell Asset Management uses the pattern in the version
level field to determine whether a particular version of the application is configured into this license unit.
By default, * groups all versions into one license unit. You can change this pattern to specify different
groupings.

Example: If the pattern is 5.*, only versions whose major number is 5 will be automatically added. Other
versions will go into a separate license unit.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.
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License Unit Properties Applications Tab
You can add, change, and remove applications (versions) included in the license unit.

• Click New to add an application to this license unit.

• To remove an application from this license unit, select the application in the list and click Delete.

• To check the properties of an application in this license unit, select it and click Properties.
◦ To add executable files, click Add.

◦ To remove executable files, select an executable in the list and click Remove.

◦ To view an executable's properties, select an executable in the list and click Properties.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.
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License Unit Properties Control Tab
You can apply an existing control profile to the current license unit(s).

A control profile defines how access to an application is controlled. For more information, see control
profile.

To apply a control profile to the current license unit(s):

1. Click Use control profile.

2. Select a profile from the list. The information box changes with your selection to describe how the
selected control profile works.

3. If none of the listed profiles meets your needs, click New and create your own. Any control profiles
you create will appear in the list of available profiles.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.
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License Unit Properties Dialog Box
You can view the basic properties of a selected license unit.

 Getting There

The dialog box contains the following tabs:

• General *

• Purchasing

• Applications or Suites

• Control *

• Advanced

• Member Of

* The General and Control tabs are the only tabs available when multiple license units are selected.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.  If multiple license units are selected, the number of selected license units is shown here
instead.
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License Unit Properties General Tab
You can view and change general information about the selected license unit(s).

• Name: The first field in this tab displays the selected license unit's name.

• Licensing: By default, all license units are "unmanaged" until you specify a type of licensing
agreement. You can specify the type of licensing agreement your organization has for the
application this license unit contains.

• Meter this license unit: Check this box if you want this license unit to be metered.

• Allocations: If you selected the Concurrent Licensing option, click Allocations to view how
concurrently licensed applications are distributed across groups of machines. You can also specify
new allocations here.

• Purchase required: Select Yes for any license units for which you want to require purchases, or No
for any license units that don't require payment. For more information, see Purchase Required
Setting.

• Manufacturer The manufacturer is displayed in this text box. If you click Manufacturers, you can
select a manufacturer from a list, or add/change manufacturer information.

• Category: The software category that includes this license unit is shown. Click Categories to select
a category from a list, or add, delete, or change categories.

• Notes: Enter any additional information about the license unit in this text box.

If you make any changes to these options, click OK to exit and save those changes.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.

Related information
../admin_control/Admin_About_license_allocation.xml#concept2806
../admin_control/Admin_About_concurrent_licenses.xml#concept855
../admin_license_units_suites_applications/Admin_About_license_unit_templates.xml#concept915
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License Unit Properties Member Of Tab
If any groups have been added by users, you can see the license units that belong to them.

To add or remove groups to which a license unit belongs:

• Click Add to add a group.

• To remove a group, select a license unit, then click Remove.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.

210

CAM 14.2 Administrator

CAM 14.2 Administrator



License Unit Properties Purchasing Tab
The options in this tab vary, depending on whether your Cherwell Asset Management implementation
includes the separate Purchasing application, and how you've configured the License Unit Template
Purchasing tab.

• If your organization is licensed to use Purchasing, you can launch it from this tab. . Note that if you
do edit the purchasing information taken from Purchasing, the software line item gets unreconciled
in Purchasing.

◦ This tab also shows some purchasing information for the current license unit, as reconciled in
Purchasing; you can edit this information only if you selected the Specify license count and
per-unit cost only option in the Purchasing tab of the License Unit Template dialog box.

◦ Tip: Even if you use Purchasing, you may have license units for which you want to
enter the count and per-unit price here, in the license unit's Purchasing tab, rather than
in a more comprehensive record in Purchasing. Check the Specify license count and
per-unit cost only option, and complete the license count and unit cost for those license
units.

• If your organization is not licensed to use Purchasing, you can use this tab to enter a license count
and per-unit cost for the current license unit.

1. Check Specify license count and per-unit cost only , if is not already selected.

2. The License count and Last per-unit cost options become available; complete these options
and then click OK.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.
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License Unit Properties Suites Tab
You can add or remove suites from a license unit.

You can also check the properties of a suite by selecting it and clicking Properties. This tab is only
available for license units designated as containing a suite of applications.

Note: The name of the selected license unit precedes the words "License Unit Properties" in the
title bar.
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License Unit Template Advanced Tab
You can change how application versions are grouped.

In the Advanced tab of the License Unit Template dialog box, you can modify the Consolidate
application versions by option.

• By default, all versions of a given application (typically as specified by the file version of the main
executable) are consolidated into a single license unit. You can change the default pattern if you
want to group versions differently.

◦ For example, if you want each major version of an application to go into a separate license
unit, you can change this pattern to "Major version (e.g. 1.*)".

Important: Use caution when changing this setting. It determines how license units are created. If
you change this and later decide that you want all versions consolidated, you will need to
manually recombine them in the license units list.
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License Unit Template Dialog Box
You can set up a template that contains default values for license unit properties.

 Getting There

This template and the values it specifies are used whenever new license units are created. You can
change license unit properties once the license unit is created, but the values in the license unit template
provide the initial values for these properties.

This dialog box contains these tabs:

• General

• Software Categories

• Purchasing

• Advanced
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License Unit Template General Tab
You can specify the general default options to use when a new license unit is created.

You can always change these options later on any newly created license unit; the values you enter here
are used as defaults.

If most of the applications you want to monitor are of one licensing type, specify that type in the Licensing
list box. If you plan to meter most license units, check Enable metering for new license units.

Notes:

• You can only specify unmanaged or per-seat license types in the template. To specify other
licensing types, you must modify the individual license unit.

• The Manufacturer, Category, and Notes fields are not shown because you can add this information
for individual license units in their License Unit Properties dialog boxes. If defaults for these options
were set here, they would apply to all license units.
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License Unit Template Purchasing Tab
You can specify license count and per-unit cost.

Use this tab to specify the default for new license units. Changing the template will affect any license units
configured after the change, not license units that have already been configured.
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License Unit Template Software Categories Tab
You can create new, edit existing, or delete existing groups and categories.

To create a new software category group:

1. Click New, then select Group.

2. Enter the name for the group. Once you create a new software category group, you can create
categories to which you can add license units; this is described next.

To create a new software category:

1. Click New, then select Category.

2. Enter a name for the category and click OK.

To change the name of a software category or group:

1. Select the item you want to change from the list and click Change.

2. Enter the new name for the category or group in the Change Software Category Group dialog box
and click OK.

When you rename a software category or group, the new name appears in Cherwell Asset
Management, but the original names in the Cherwell Software Identification Database (CSID) are
unchanged.

To delete a user-created category or group:

1. Select a category or group and click Delete.

If the category you want to delete contains license units, you are prompted to confirm the operation.
Any license units that were in that category still exist, but are not part of any category.

2. Click OK.
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Machine Properties Advanced Tab
Set heartbeat and CSID options for the selected Windows machine(s).

To Set Heartbeat Options
The Heartbeat option is in the Agent Options Advanced tab and applies to all Windows machines on
which the CAM Agent is installed in your network. You can set the following heartbeat options here for the
selected Windows machine(s) only:

• Optimize for disconnected state: Select this option if you want to turn off the heartbeat window for
the selected machine(s). Doing so might be useful, for example, in situations where you have
isolated laptop machines that might have only intermittent connection to the access point. Disabling
the heartbeat window for these machines makes it more likely that they will check in to their access
point when they are connected.

• Optimize for Citrix published applications: Recommended: Select this option on machines that
connect to Citrix servers. When you select this option, the machine will check in when the user logs
in.

To Set CSID Options
If you enabled automatic contribution to the Cherwell Software Identification Database (CSID), either by
answering Yes to the relevant dialog box upon startup or by selecting the option in the Options Advanced
tab, you can exclude any machine from this process. To exclude the selected machine(s), select Exclude
from automatic CSID contribution scanning.
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Machine Properties Authorization Tab
See whether a machine is authorized to use all license units, or not authorized to use certain license
units.

Note: The name of the selected machine is shown in the title bar in place of the word "machine."
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Machine Properties Dialog Box
View and modify basic properties of a selected machine through various tabs.

 Getting There

The Machine Properties dialog box contains basic properties of a selected machine. The dialog box
consists of these tabs:

• General

• User-defined (only available if inventory is licensed)

• Options (only available when the selected machine is a Windows machine)

• Authorization

• Advanced (only available when the selected machine is a Windows machine)

• Member Of

Note: The name of the selected machine is shown in the title bar in place of the word "machine."  
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Machine Properties General Tab
View general machine properties, such as machine name, domain, IP address, the last time the machine
was inventoried, and others.

 Getting There

The machine properties displayed in this tab include:

• The machine name and platform

• The domain to which the machine belongs

• The last user to log onto this machine (Windows machines only)

• The last time this machine was inventoried

• The last time this machine reported to the access point (Windows machines only)

• The most recent metered launch for this machine (Windows machines only)

• The date and time that the CAM Agent was installed on this machine (Windows machines only)

• The machine's IP address, VM Host, NIC address, SMS ID, and hard drive partition serial number

• A details box that provides information on the current status of the selected machine. See Error
Messages in the Machine Properties Dialog Box for solutions to common error messages that can
appear in this box.

This tab also provides a link to a Machine Summary report in these cases:

• Windows machines: The CAM Agent is installed on the machine.

• Linux/Unix/Mac OS machines: Discovery (including data collection) of that machine is complete.

Note: The name of the selected machine is shown in the title bar in place of the word "machine."
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Machine Properties Member Of Tab
View the groups to which machines belong.

Click Add or Remove to change these group assignments.

Note: You can only change group assignments for user-added groups; you cannot change group
membership for discovered groups.

The name of the selected machine is shown in the title bar in place of the word "machine."  
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Machine Properties Options Tab
Specify metering, control, and inventory options for selected Windows machine(s).

 Getting There

Metering and control options
The following metering and control options are available:

• Enable metering: Lets you use the metering feature on the selected machine(s).

• Enable control: Lets you use the control feature, provided the above option is also selected.

By default, metering and control are both enabled, if your license allows you to use these features.

Inventory options
The following inventory options are available:

• Enable inventory: Lets you use the inventory feature on the selected machine(s); this option is
selected by default.

• Collect extended inventory information: By default, this option is unchecked. Leave the Collect
extended inventory option unchecked if the selected machines are remote. See Gathering
Inventory Data for more information.

• Perform scheduled inventory only when user is logged in: By default, this option is unchecked,
so scheduled inventories for this machine(s) will not require a logged-in user to run.

Note: When this option is set, inventories are run in the context of the logged-in user instead
of system context.

• Override default inventory start date/time: Check this option, which is cleared by default, if you
want to override the default date and time to start the inventory process, and instead set a specific
date and time to start the first complete inventory scan. By default, the first scan occurs immediately
after the agent installation completes, and subsequent scans occur every month thereafter.

CAM Access Point drop-down list box
You can also view the following information for the selected machine(s) in this tab:

• The access point to report to

• Proxy server information, if used

This box displays the access point assignment for the machine(s).
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Proxy server options
The following options display information only if you use a proxy server:

• Proxy list: Displays the name of the proxy server machine.

• Bypass list: Displays the proxy bypass information.

Note: The name of the selected machine is shown in the title bar in place of the word "machine"
or, if multiple machines are selected, the number of machines is shown.
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Machine Properties User-defined Tab
View custom machine properties you created in the New Custom Machine Property dialog box.

Use the text boxes to fill in the information so that Cherwell Asset Management can report on it.

For example, if you added a property called "Employee ID number" in the New Custom Machine Property
dialog box, that label appears in this tab, followed by a blank text box. You would fill in the actual
employee ID number (for example, "99999") associated with the user of the current machine in that text
box.

Note: The name of the selected machine is shown in the title bar in place of the word "machine."
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Manufacturers Dialog Box
Add or update manufacturer information here.

 Getting There

Many manufacturers are already defined in the Cherwell Software Identification Database (CSID).
Manufacturer information is sometimes included with the properties of license units and other assets,
depending on what information is available when the license unit or asset is configured. You can add
manufacturers to this list, or change a listed manufacturer. Once a manufacturer is listed, you can specify
that a license unit or asset is from a specific manufacturer by opening that item's Properties dialog box.

To add a manufacturer:

• Click New and enter the appropriate information in the New Manufacturer dialog box.

To change an already-defined manufacturer:

1. Select it from the list and click Change.

2. Make your changes in the Change Manufacturer dialog box.
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More Email Settings Dialog Box
Enter additional information about your email account, such as port and connection information, user
name, and password.

 Getting There

Use this dialog box to enter the following additional information if your email service provider requires it:

• SMTP port: By default, port 25 is specified.

• This server requires an encrypted connection (SSL): By default, this check box is unchecked.

• User name: User name associated with your email account.

• Password: Password for your email account.
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Move Applications to Existing License Unit Dialog
Box

Move applications to new or existing license units.

 Getting There

Use this dialog box to specify where to copy the application and to verify that the correct application is
included.

The options in this dialog box are as follows:

• License unit: Select the license unit where you want to add the application.

• Selected applications: Verify that the applications you want moved to this new license unit are
listed.

When you are finished entering and verifying information, click OK. The application is added to the license
unit.
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Move Applications to New License Unit Dialog Box
Enter the name of the license unit to create for the selected application, and specify which version(s) of
the application to include in the license unit.

 Getting There

To move applications to a new license unit:

1. Complete the fields in the New License Unit section:
a. Name: In this text box, either accept the name suggestion or type a new name. The name you

use here is the name that will show up in the License Units panel for the license unit you are
creating.

b. Version pattern: In this text box, specify what version(s) of the selected application to include
in the new license unit. When a new version of this application is identified, the value you
specify here determines whether the new version is included in this license unit. You can
specify that the license unit include only a specific version (for example, 2.0), or use an *
(asterisk) to specify that major versions (2.*) or minor versions (2.0.*) are also included.

2. Selected applications: Verify that the applications you want moved to this new license unit are
listed.

3. When you are finished entering and verifying information, click OK. The new license unit will be
created, and will include the specified applications.
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Move Suites to Existing License Unit Dialog Box
Move suites to an existing license unit, and verify that the correct suite is included.

 Getting There

The options in this dialog box are as follows:

• License unit: Select the license unit where you want to add the suite.

• Selected suites: Verify that the suites you want moved to this new license unit are listed.

When you are finished entering and verifying information, click OK. The suite is added to the license unit.
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Move Suites to New License Unit Dialog Box
Move suites to a new license unit, and verify that the correct suite is included.

 Getting There

To move suites to a new license unit:

1. Complete the fields in the New License Unit section:
a. Name: In this text box, either accept the name suggestion or type a new name. The name you

use here is the name that will show up in the License Units panel for the license unit you are
creating.

b. Version pattern: In this text box, specify what version(s) of the selected application to include
in the new license unit. When a new version of this application is identified, the value you
specify here determines whether the new version is included in this license unit. You can
specify that the license unit include only a specific version (for example, 2.0), or use an *
(asterisk) to specify that major versions (2.*) or minor versions (2.0.*) are also included.

2. Selected suites: Verify that the applications you want moved to this new license unit are listed.

3. When you are finished entering and verifying information, click OK. The new license unit will be
created, and will include the specified suites.
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Network Device Properties Dialog Box
 Getting There

The Network Device Properties dialog box contains basic properties of a selected network device. The
dialog box consists of these tabs:

• General

• Member Of

Note: The name of the selected network device is shown in the title bar in place of the words
"network device."
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Network Device Properties General Tab
 Getting There

Use this tab to view properties of the selected network device. You can also open the Network Device
Summary report for the selected network device from here by clicking the hyperlink at the top right.

The following information is displayed for the current network device, if available:

• Device name

• Manufacturer

• General description of the device

• Type of device

• Serial number

• IP address

• Physical address—The device's MAC address

• Uptime of device, in <days>, <hours>:<minutes>:<seconds> format

• Status of device

• Services—Information on the device's function

• Contact person for this device

• Location of device as configured by device system administrator

• Agent managed—Whether the CAM Agent collects data from this device

• Date and time device was found by discovery process

Note: The name of the selected network device is shown in the title bar in place of the words
"network device."
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Network Device Properties Member Of Tab
This tab shows which user-added groups, if any, the selected network device belongs to. Click Add or
Remove to change these group assignments.

Note: The name of the selected network device is shown in the title bar in place of the words
"network device."
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Network Device Template Custom Network Device
Data Tab

 Getting There

Use this tab to view all fixed and user-defined  network device properties that are available for collection
during network device discovery.

You can use the New or Change buttons to add or change user-defined properties. (See How to Collect
Custom Network Device Properties for the full procedure.) You can also select a user-defined property
and click Delete to remove it.

Any properties that show "Fixed" in the Type column are defined by the Cherwell Software Identification
Database (CSID) and you cannot delete them or change their names and descriptions. You can, however,
select a Fixed property and click Change to open the Change Custom Data Property dialog box, where
you can view and add SNMP OIDs to use when retrieving data for that property.
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New Application Dialog Box
The New Application dialog box contains basic properties of a new application and lets you specify that
information for applications as you add them. The dialog box consists of two tabs:

• General

• Support Files (for Windows applications)
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New Application General Tab
The General tab of the New Application dialog box displays the application name, version, and GUID (if
any, for Windows applications) of the application's main executable and lets you specify that information
for an application when you add it to a license unit.

Windows Applications
For Windows applications, you can add a new application to the current license unit or as a new license
unit, first enter its name or click Browse to find it. You can also enter version and GUID information for the
application. (Both version and GUID information are optional; in fact, you should leave the GUID option
blank unless you're certain of what to enter here. Entering an invalid string in the GUID text box can
cause the application to not be recognized properly.)

Next, click the Add button to open the Add Executable Version dialog box, where you enter the file name,
size, and version of the executable file that is used to identify the application. You can specify this
information manually or browse either your local computer or all unconfigured files. You can also remove
executable files from the list, and view the properties of an executable file you select from the list.

If you want to specify support files for the application, click the Support Files tab.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245

237

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_About_GUIDs


New Application Support Files Tab
The Support Files tab is available for Windows applications. It displays the support file names and sizes
associated with the current application and lets you specify that information for an application when you
add it.

To add a support file for the application, click Add to open the Add Support File dialog box, where you can
specify this information. You can specify this information manually or browse either your local computer or
all unconfigured files.

You can also check the properties of a support file or remove it from the list of support files associated
with the current application.
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New Asset dialog box
 Getting There

This dialog box contains the basic properties of a selected asset. You can also use this dialog box to add
a new asset to your Cherwell Asset Management configuration.

• General

• User-defined

• Member Of

Note: If an existing asset is selected, its name appears in the title bar, followed by "Properties", as
in "HR Printer Properties". If you are adding a new asset, the title bar reads "New Asset".
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New Asset General Tab
 Getting There

Use this tab to view the basic properties of a selected asset, or to add a new asset to your Cherwell Asset
Management configuration.

When you add a new asset, you are required to enter a name for it. All other fields are optional. You can
enter, change, or view the following information for the current asset:

• Name—The name of the asset you are viewing or adding. This is the only required field in this tab.

• Serial number—If you enter a serial number for the asset, the serial number must not match the
serial number of any other asset that has the same name.

• Description—A text description of the asset.

• Asset type (list box)—By default, these types are listed: Backup device, Data storage, Firewall,
Printer, Router, Server, Switch, <Unknown>, and <New...>. The default is <Unknown>. Clicking
<New...> opens a dialog box where you can define a new asset type.

• Asset Types (button)—Opens a dialog box where you can add, rename, or delete asset types.

• IP address—The IP address of the asset.

• Manufacturer—This box is blank until you click the accompanying button and select a manufacturer
from the list in the dialog box that opens.

• Location—Information about the device's physical location.

• Owner—The owner of the device.

• Notes—Any additional text to describe the device.

Note: If an existing asset is selected, its name appears in the title bar, followed by "Properties", as
in "HR Printer Properties". If you are adding a new asset, the title bar reads "New Asset".

Related information
../admin_network_devices/Admin_Overview_Network_devices_vs_other_assets.xml#concept1627

240

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Asset_Properties_dialog_box.html
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overview_Network_devices_vs_other_assets


New Asset Group Dialog Box
Specify the name of the asset group to add, and click OK.

The group is created as a top-level group unless an existing added asset group is selected. If that is the
case, the new group is created in the selected group.
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New Asset Member Of Tab
The Member Of tab of the New Asset dialog box shows which user-added groups, if any, the selected
asset belongs to. Click Add or Remove to change these group assignments.

Note: If an existing asset is selected, its name appears in the title bar, followed by "Properties", as
in "HR Printer Properties". If you are adding a new asset, the title bar reads "New Asset".
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New Asset Type Dialog Box
 Getting There

Type in a name for the asset type and click OK.

The asset type you just added to the asset template will now be available to select whenever you add or
modify an asset.
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New Asset User-defined Tab
This tab lists any custom asset fields you created in the Custom Asset Data tab of the Asset Template
dialog box.

For example, if you added a field called "Main user" in the Custom Asset Data tab, that label appears in
this tab, followed by a blank text box for you to fill in for the current asset.

Note: If an existing asset is selected, its name appears in the title bar, followed by "Properties", as
in "HR Printer Properties". If you are adding a new asset, the title bar reads "New Asset".
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New Baseline Dialog Box
 Getting There

Use this dialog box to add a baseline to your Cherwell Asset Management configuration. Baselines are
used in What's Changed reports to show any changes in hardware and software configurations between
the two points in time. What's Changed reports are available within Reporting for Administrative Tools,
Hardware Inventory, or Software Inventory

Specify a name for the baseline and a description to help you differentiate between this baseline and any
others that already exist or that you add later. Click OK when you're finished. The baseline you added
now appears in the Configure Baselines dialog box and you can select it when you run the What's
Changed report.  

Related information
../../cam_reporting/Rep_Welcome.xml#concept3028
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New/Change Control Profile Authorization Tab
Use the options in this tab to specify the following:

• Who is authorized or not authorized to launch certain applications.

• How to handle attempts to launch concurrent applications when all licenses are in use or when the
requesting user or machine is not authorized to run the application.

• Whether to immediately terminate any unauthorized launches Cherwell Asset Management was
unable to prevent.

Descriptions of the options in this tab are grouped into sections below.

Authorization
Select an item from the Authorization list box to specify whether everyone, no one, or selected users and
machines are authorized or not authorized to run any application that you later apply this control profile to.

If the control profile is to apply only to specific machines or users, click Add Users or Add Machines to
open a dialog box where you can specify which users or machines are affected by this control profile.
You'll then see the users and machines you selected in the list in this tab.

To remove a user or machine from this profile, click it and then click the Remove button.

If an application is not authorized or licensed
These options are as follows:

• When machine is connected to the Access Point—Specify whether to prevent the application from
launching, simply warn users that they are not authorized or licensed to run it, or allow the launch to
proceed without any intervention.

• Allow user to request notification when concurrent license is available—Specify whether to allow
users to put themselves on a wait list when all licenses of the concurrent application are in use.

• When machine is disconnected from the Access Point—The same three options (Prevent Usage,
Warn Users, and Don't Control) as above appear in this drop-down list box, but the default here,
Warn users, is different.

The ability to specify a different action for when machines are connected to a CAM Access Point, and for
when machines are not (for example, for remote users) is useful, for example, if you want to impose strict
control over a certain application, but only if the user is connected to the network and, therefore, the
access point. You'd prevent the launch when connected to the access point, but allow the launch if the
user is not connected.

If CAM is unable to prevent the launch of an unauthorized application
Specify how to shut down an application that you don't want run. The default is to shut down the
application gracefully, and this is the recommended option. If you choose to immediately terminate the
application (in other words, kill the process), the machine may become unstable and data may be lost in
other open applications.
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Notes:

• In most situations, a controlled application is terminated after it launches.

• You can edit the text of warning messages that users will see in the Agent Options Messages tab.

• You can specify how long a user has to launch a wait-listed application when a license becomes
available in the Advanced tab of the Agent Options dialog box.

When you are satisfied with your authorization settings for this control profile, either click OK to save it or
click the Idle Time tab to set up options for handling applications that are left open and unused.  

Related information
../admin_control/Admin_Overview_Wait_list.xml#concept1878
../admin_metering/Admin_How_metering_works.xml#concept2279
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New/Change Control Profile Dialog Box
 Getting There

The New/Change Control Profile dialog box contains basic properties of a control profile. The dialog box
consists of these tabs:

• General

• Authorization

• Idle Time

Note: This dialog box is called New Control Profile if you are defining a new profile, and Change
Control Profile if you selected an existing profile to modify.
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New/Change Control Profile General Tab
 Getting There

Use the options in this tab to start creating or modifying a control profile. After you set up a control profile,
you can then apply it to any license units you've configured.

In this tab, enter a name for your new control profile and optionally, a description.

Tip: If you are modifying an existing control profile, that profile's name and description are already
entered. You can edit the name and description if you want to keep the existing control profile
intact and base a new control profile on it.

When you are satisfied with the name and description, click the Authorization tab to set up who is allowed
or denied access to the applications this control profile is later applied to. Nothing is saved until you click
the OK button.  

Related information
../admin_how_to/Admin_How_to_apply_an_authorization_profile_to_a_license_unit.xml#concept1168
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New/Change Control Profile Idle Time Tab
Idle time options specify what happens when an application is left open and unused on a machine that is
connected to a CAM Access Point.

If an application is idle
The options in this section are as follows:

• Warn user after—When this option is checked, users who are running this application receive a
warning message that informs them that the application has been left idle. When you mark this box,
also specify a number of minutes the application can be idle before the warning appears. The
acceptable range is 5 to 2880 (the equivalent of two days).

• Remind user every—Only available when the Warn user after option is selected, this option sends
reminders to users at the interval you specify in the minutes thereafter box, where the acceptable
range is 1 to 720 (12 hours).

• Close application after—When this option is checked, the idle application is closed after the
number of minutes you specify in the adjacent minutes of idle time box. The number of minutes
specified for this option must be greater than the number of minutes specified for the Warn user
after option, if used.

• Only if user is waiting—Use this option to enforce the above options only if another user is waiting
to use the concurrent application. In other words, a user can leave the application idle indefinitely
without receiving warnings of any kind, unless another user attempts to launch the application, finds
that all licenses are in use, and elects to go on the wait list for it. Once another user is waiting for the
application, the above options are in effect. (Note that since users can't wait for non-concurrent
applications, idle time control settings will be ignored if you use this setting in a control profile that
you apply to a non-concurrent application.)

You can mark more than one option. For example, you can specify that users are warned when an
application is idle for 15 minutes and that the application is closed after 60 minutes of idle time.

How should CAM shut down an idle application?
The default is to shut down the application gracefully, and this is the recommended option. If you choose
to immediately terminate the application (in other words, kill the process), the machine may become
unstable and data may be lost in other open applications.

Note: You can edit the text of warning messages that users will see in the Agent Options
Messages tab.

When you are satisfied with your idle time settings for this control profile, either click OK to save it or click
one of the other tabs to set other options.

Related information
../admin_control/Admin_Overview_Wait_list.xml#concept1878
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New/Change Custom Asset Data Property Dialog
Box

 Getting There

Use this dialog box to enter information for any custom asset data fields you want to create. Any fields
you create here are added to the asset template and thus are available in the User-defined tab of the New
Asset/Asset Properties dialog box for completion whenever you add or modify an asset.

First, enter a label (name) for your custom field.

Next, type a description for your custom field.

Finally, select what type of field you are adding. You can enter these types of fields:

• Text—A field that accepts alphanumeric input; the maximum length of a text field is 255 characters.

• Number—A field that accepts only whole number input (for say, indicating quantities).

• Currency—A field that accepts input in currency format only.

• Date—A field that allows you to select a date.

• Shortcut—A field where you enter a location for a document that contains purchasing information.
The document you specify becomes available as a hyperlink in the Other Assets report in Reporting
Tip: You can click the Test button to test the shortcut.

When you are finished entering information for your custom field, click OK to return to the Custom Asset
Data tab of the Asset Template dialog box. In that tab, click OK when you are done creating custom asset
fields to add to your asset template.

Note: This dialog box is called New Custom Data Property if you are adding a new field. If you are
modifying an existing field, this dialog box is called Change Custom Data Property.
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New/Change Custom Data Property Dialog Box
This dialog box lists SNMP OIDs used to retrieve data for custom data properties. The layout and
available options vary depending on how you reached it:

• If you clicked the New button in the Custom Network Device Data tab of the Network Device
Template dialog box, this dialog box is called New Custom Data Property, and you can use it to add
a new user-defined data property:

◦ Type a name and description for the property to add, and specify whether the property has
multiple instances.

◦ Click New to open the New SNMP OID dialog box, where you add the OID to use for the
property.

• If you selected an existing fixed custom data property, and then clicked Change, this is called the
Change Custom Property dialog box and it includes the following:

◦ The name and description for the fixed property, which you cannot change.

◦ A list of any SNMP OIDs you added for this property. You can use the buttons below this list to
add, edit, or delete items in this list.

◦ A list of any predefined OIDs for this property, which you cannot change.

• If you selected an existing user-defined custom data property and then clicked Change, this is also
called the Change Custom Property dialog box, but its options are different than in the above case:

◦ You can change the property's name and description, and specify whether it has multiple
instances.

◦ You can use the buttons below the list to add, edit, or delete items in the SNMP OIDs list.
There is no separate list of predefined OIDs.

After making any additions or changes and returning to this dialog box, click OK to save the property and
return to the Custom Network Device Data tab.

Related information
../admin_how_to/Admin_How_to_collect_custom_network_device_properties.xml#concept1902
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New/Change Custom Machine Property dialog box
CAM Administrator

 Getting There

Use this dialog box to add or change custom properties associated with each machine. You can specify
the following:

• WMI-based properties collected from Windows machines during the inventory process.

• User-defined properties (all platforms), which you can manually enter for each machine or import
from an Excel spreadsheet.

Specifying WMI information
To use WMI to define the custom information to collect, click the WMI button and specify the WMI class
and property to collect during the inventory process. You can also provide a description and WHERE
clause for this custom request, and whether you want multiple instances of the property to be returned.

The inventory agent also supports a set of "special" custom machine properties that are specific to
Cherwell Asset Management. You can add these properties in the same way that you can add any other
custom WMI property. The class name for these properties is WIN32_ESM_CUSTOM.

Note: To make additions or changes to WMI properties, you should be familiar with how to use
WMI settings.

Specifying user-defined information
To add a user-defined custom machine property that can be manually entered or imported from an Excel
spreadsheet, click the User-defined button and enter the Label and Description for the new property.
Labels are typically short identifiers to remind you of the data to be entered for each machine; the
description can provide more complete information and is used in reports. Once a user-defined custom
machine property has been defined, values for each machine can be entered via the Machine Properties
dialog box or by importing the data from an Excel spreadsheet.

Notes:

• This dialog box is called New Custom Machine Property if you are adding a new request. If you are
modifying an existing request, this dialog box is called Change Custom Machine Property.

• The information in this topic applies to Windows machines only.

Related information
../Admin_Example_of_how_to_specify_WMI_information.xml#concept1854
../admin_inventory/Admin_CAM-specific_custom_machine_properties.xml#concept2736
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New/Change Manufacturer Dialog Box
 Getting There

Use this dialog box to add or change a manufacturer's contact information. Once this manufacturer is
added, you can select it from a list in the Manufacturers dialog box when you configure license units or
assets from this company.

It is not necessary to complete each option in this dialog box; only enter as many of the options as you
need to be able to identify the manufacturer. You may find it useful to include complete contact
information and comments for this manufacturer, in the event that you need to add or modify your
licensing agreement with that company.

Notes:

• This dialog box is called New Manufacturer if you opened it by clicking New in the Manufacturers
dialog box. It's called Change Manufacturer if you opened it by selecting a manufacturer in the
Manufacturers dialog box and then clicked Change.

254

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Add_Change_Manufacturer_dialog_box.html


New/Change SNMP OID Dialog Box
Use this dialog box to specify the SNMP OID to use to retrieve data for the custom property you're adding
or modifying for network device discovery. The OID is the object identifier used by SNMP and consists of
a series of numbers and periods.

First, type the SNMP OID, and then do one of the following:

• Specify that the OID applies to all manufacturers.

• Search for and select a manufacturer.

To narrow down your results, the Only show discovered manufacturers option is marked; clear it to
broaden your search. Click the manufacturer to use from the list, and then click Select.

Click OK to save your SNMP OID information and return to the New Custom Data Property dialog box.
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New/Change Software Category Dialog Box
Use this dialog box to add a new software category or to change the name of an existing category.

In either case, enter a name for the category and click OK. You can also change the group to which this
category belongs in this dialog box by selecting another group from the list box.

Any new categories you create are added, in alphabetical order, to the list of categories within their
groups in the left pane of the License Units panel. Software categories you add or change are also shown
in the Software Categories tab of the License Unit Template dialog box.

When you change a software category's name, the new name appears in Cherwell Asset Management,
but the original names in the Cherwell Software Identification Database (CSID) are unchanged.

256

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fcherwell_id_database%2FAdmin_CSID_overview.html


New/Change Software Category Group Dialog Box
Use this dialog box to add a new software category group or to change the name of an existing group.

In either case, enter a name for the group and click OK. The alphabetical By category group list in the left
pane of the License Units panel is updated with this name. Any software category groups you add or
change are also shown in the Software Categories tab of the License Unit Template dialog box.

When you change the name of a software category group, the new name appears in Cherwell Asset
Management, but the original names in the Cherwell Software Identification Database (CSID) are
unchanged.
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New License Unit Group Dialog Box
Specify the name of the license unit group to add, and click OK. The name of the new license unit group
appears in the tree pane portion of the License Units panel, and you can add license units to it.

The group is created as a top-level group unless an existing added license unit group is selected. If that is
the case, the new group is created in the selected group.
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New Machine Group Dialog Box
Specify the name of the machine group to add, and click OK.

The group is created as a top-level group unless an existing added machine group is selected. If that is
the case, the new group is created in the selected group.
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New Network Device Group Dialog Box
Specify the name of the network device group to add, and click OK.

The group is created as a top-level group unless an existing added network device group is selected. If
that is the case, the new group is created in the selected group.
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New Suite Dialog Box
This dialog box lists the suites that are currently configured as part of the selected license unit or a new
license unit, and allows you to add additional suites to it.

To add a suite to the license unit, first enter its name or click Browse to find it. You can also enter version
and GUID information for the suite. Both version and GUID information is optional; however, in most
cases you will need a GUID to properly distinguish a suite installation from installations of individual
applications.

You can also add and remove applications from the suite, and view the properties of an application you
select from the list.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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New User Group Dialog Box
Enter the name of the user group to add, and then click OK.

The group is created as a top-level group unless an existing added user group is selected. If that is the
case, the new group is created in the selected group.
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Options AD Discovery Tab
Use this tab to specify whether to discover machines and users from Active Directory or the NT domain.

If you select Active Directory, you can limit the discovery to organizational units (OUs) you specify. This
option is helpful in large organizations with many machines, so that you can limit the discovery to only the
groups of machines you want to monitor with Cherwell Asset Management.

To specify that only machines in certain OUs are discovered, click Add to open the Add Active Directory
OU Path dialog box, and enter the information there. Any OU paths you enter in that dialog box will then
show up in the Options AD Discovery tab.

If you need to modify an already-listed OU path in this tab, select a path and click Change. You can also
select a path and click Remove to delete it.
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Options Advanced Tab
 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

Use the options in this dialog box to specify advanced global options.

The following sections describe the options in each area of the dialog box.

Performance
You can use the Search feature in the Files panel to look for files that meet specific criteria. By default, the
maximum number of files displayed that meet your search criteria is 1000. (You are alerted if the number
of files that meet your criteria exceeds this maximum.) You can change this limit per search operation
within the Search area of the Files panel.

To change this limit globally, specify a new limit in the Performance area of this dialog box, or mark the Do
not limit the number of records returned by file search option here.

CAM System License Units
Click the CAM System License Units button to open the CAM System License Units dialog box, where
you can specify whether CAM System License Units are displayed or hidden in the License Units panel.

Suite Applications
This option, Meter suite applications individually, is cleared by default. This means that Cherwell Asset
Management will meter applications contained in a suite (such as office productivity suites) as a group,
rather than by each application in the suite. Mark this option if you'd rather meter each application
separately.

Note: This is a "global" option, so when you mark this box, you are specifying that all applications
contained in suites that you have enabled metering for are metered separately.

Contribute to the CSID
When this option, Enable automatic contribution to the CSID, is marked, Cherwell Asset Management
automatically scans machines for unrecognized software so that these applications can be included in the
Cherwell Software Identification Database (CSID). This occurs for both on-premises and hosted
environments.  Marking this option is the same as answering Yes in the dialog box that may appear at
startup. Even when this option is marked, you can exclude certain machines from being scanned for
unrecognized software.

 In hosted environments, checking this option also gives Cherwell Software permission to view SNMP
data from discovered network devices in your hosted database for the purposes of improving our SNMP
attribute recognition capabilities.
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See Do You Want to Enable Automatic Contribution to the Cherwell Software Identification Database? for
information on why contributing to the CSID is safe.
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Options Alerts Tab
Use this dialog box to set options for alerts.

Email address options
The options in this section are as follows:

• Send email alerts—If you want to be notified when an event occurs that requires attention, mark
this check box and fill in the below text boxes. These events include:

◦ The CAM Access Point becomes unavailable.

◦ The Work Queue stops for any reason.

◦ The CAM Database cannot be accessed from the CAM Administration Service.

◦ The CAM Administration Service does not appear to be running.

• Send alert to—Specify an email address to which to send alerts.

• Test—Click this button to send an alert to the email address you specified. You can delete the test
message.

• From address—Specify an email address from which the alert generates, and to which recipients of
the alert can respond.

• SMTP server—Specify a valid SMTP Server address for outgoing messages.

• More Settings—Click this button if you need to specify additional options. The More Email Settings
dialog box opens.

Access Points options
All the access points you've set up are listed in this section. Mark the check boxes next to any access
points about which you want to be notified in case of accessibility problems.

When you're done configuring the alert options, click OK to put them into effect, or Test to generate a test
message.

Note: By default, access point availability is checked every hour, on the hour. The Work Queue is
checked every hour at five minutes past the top of the hour. You can change how often to check
access point and Work Queue availability using the Task Scheduler (also called simply the
Scheduler), which is a System Tools accessory that ships with Windows.
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Options Dialog Box
 Getting There

This dialog box consists of these tabs:

• General

• AD Discovery

• Alerts

• Schedule

• Warnings

• Advanced
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Options General Tab
 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

 Getting There

Use this dialog box to view and specify Web component locations, and set automatic identification and
CAM history options.

Web component locations
This section shows where the web components (Authentication, License Analytics, Purchasing, and
Reporting) are located. Click the Configure button if you want to change any of these locations.

 In hosted installations, you cannot change the locations of web components, but you can select a
URL and copy it for pasting to the Clipboard or into a browser.

Automatically configure applications
This section includes these options:

• Automatically configure Windows close match applications—Specifies whether Cherwell Asset
Management should automatically configure close match main executable files into license units
when it also automatically configures exact match files. By default, this option is selected.

• On startup, prompt to automatically configure applications—Specifies whether you are
prompted to automatically configure Windows applications when you start CAM Administrator. By
default, this option is selected.

CAM history
By default, the one option is this section, Log CAM history is marked. You should only clear it if you don't
want historical information on changes to your Cherwell Asset Management configuration saved.
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Options Schedule Tab
You can turn automated processes on or off in this tab.

Generally, you can use the default options. How often these processes are run is managed through the
Task Scheduler, a System Tools accessory that ships with Windows.

To access the Schedule tab:

1. In CAM Administrator, select Tools > Options.

2. Select the Schedule tab.

To access the Task Scheduler:

1. In Windows, select the Control Panel.

2. Select Administrative Tools > Schedule Tasks.

Note: This may be called Task Scheduler, depending on your version of Windows.

Discovery Options

Note: Run times for scheduled processes are server local time.

The following options can be checked or unchecked to enable or disable various types of discovery. leave
these options checked to run the task as scheduled. Go to the Task Scheduler to change the times and
days of the week on which these scheduled tasks are run.

• Discover Active Directory or NT Domain: This discovery process automatically runs at 1:00 AM
every Sunday.

• Discover Linux/Unix/Mac OS: Once you configure Linux/Unix/Mac OS discovery, this discovery
process automatically runs at 2:30 AM every Sunday.

• Discover network devices: Once you configure network device discovery, this process
automatically runs at 3:00 AM every Sunday.

• Discover virtual environment: Once you configure virtual environment discovery, this process
automatically runs at 1:30 AM every Sunday.

• Discover Oracle Database instances: Once you configure Oracle Database discovery, this
discovery process automatically runs at 4:00 AM every Sunday.

Other Options
The remaining options on the Schedule tab control other automatic processes in CAM. It is recommended
that you leave the default values for these options.

Import SCOM Data
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This option is unchecked (turned off) by default.

To enable Import SCOM Data:

1. Select Tools > Import > Machine Data (SCOM) to configure SCOM data import.

2. Return to the Schedule tab and check the Import SCOM Data checkbox.
When enabled, this process automatically runs at 3:30 AM every Sunday (server local time).

More Options

• Discard usage data older than <n> days: When this option is checked (the default), usage data
older than the number of days specified is removed from the CAM Database as scheduled.

• Discard CAM history data older than <n> days: When this option is checked (the default),
historical data older than the number of days specified is removed from the CAM Database as
scheduled.

• Automatically configure Windows applications every <n> days: By default, the automatic
configuration process is scheduled to run once a week.

• Evaluate unrecognized files every <n> days: By default, files not recognized as application files
are reevaluated every day; leave this option checked to run this task as scheduled.

• Delete machine if last heartbeat older than <n> days: Any machines that have not contacted
their access points for a specified number of days will be deleted. This option is unchecked (turned
off) by default. You can check it (turn it on) and specify a number of days here.
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Options Warnings Tab
Use this tab to specify whether you'll receive a warning when you perform the listed actions. Warnings are
grouped into the following categories:

• License Units

• Files

• Machines

• Network Devices

• Other Assets

• Users

You may need to scroll down in the dialog box to see all the warnings.

By default, all warnings are selected, which means that you'll be warned in all of these cases. Clear the
check boxes associated with any warnings you do not want to receive.

If Administrator user policies are enabled, the list of warnings depends on the permissions assigned to
you.
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Overwrite Existing Installations Option
This topic describes how the Overwrite existing installations (select to upgrade or reinstall out of
date agents) option works. This option is available in the dialog boxes from which you launch the
installation of the CAM Agent.

To use this option:

• If you want the selected machines to run the latest version of the CAM Agent, mark the Overwrite
existing installations box.

• If you want to install to machines that do not have the CAM Agent installed on them and update
connection properties on machines that do have the CAM Agent installed on them, leave this box
clear.

When the Overwrite existing installations check box is selected:

• The CAM Agent is installed on all specified machines. (In cases where the CAM Agent is already
installed on a machine, the agent is first uninstalled and then reinstalled.)

• The CAM Agent on all specified machines will report to the access point specified in the installation
dialog box.

When the Overwrite existing installations check box is cleared:

• The CAM Agent is only installed on specified machine(s) where it is not already installed.

• The CAM Agent on specified machine(s) will report to the access point specified in the installation
dialog box.

• The access point assignments are updated.

Note: The Overwrite existing installations check box does not determine whether proxy settings
are overwritten; see Proxy Server Issues for information on when proxy settings are saved.
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Prepare Remote Inventory Agent Dialog Box
 Getting There

You can use the remote agent package to collect inventory on a machine that is not connected to the
network. You can also use it to collect inventory on Mac OS machines that do not have one of the
operating systems listed here installed on them. (Otherwise, using the Linux/Unix/Mac OS discovery
feature is more efficient for collecting data from Mac OS machines.)

Two remote agent packages are installed with Cherwell Asset Management: one for Windows machines
and one for Mac OS machines. This dialog box lists the locations of both packages.

To use the remote agent package:

1. Note the location of the package you need, based on the operating system of the remote machine
you want to inventory.

2. Copy the contents of this folder to a USB drive or other portable media you can use with the remote
machine.

3. Take the media to the disconnected machine and then do one of the following:
◦ If the remote machine is Windows-based, run the Standaloneinventory.bat file.

◦ If the remote machine is running a Mac OS, run the Inventory Mac.app file.

4. Windows machines only: Copy the generated inventory .xml files onto portable media and take the
media back to the CAM Administrator machine.

5. Use the Machine/Remote Inventory/Import menu item to import the inventory data from the portable
media.

Running a Full Scan on Remote Windows Machines
By default, a normal, non-extended inventory is run by invoking the StandaloneInventory.bat file. If you
want to collect extended file information (in other words, perform a full scan) during a remote inventory, do
the following:

1. Locate the line in the batch file that starts with:

start /w eminvcli.exe /ondemand /forceremote /nocleanup /limited

2. Remove the /limited switch at the end of this line and save the file.

The above is equivalent to setting the Collect extended inventory information option in the Options tab
in the Machine Properties dialog box.

You can do this for a single machine by modifying the batch file after you have copied it to the machine, or
for any remotely inventoried machine by modifying the batch file found in the CAM Administrator
\AgentInstallPackage folder of your Cherwell Asset Management installation. Note that if you do this,
you'll need to modify the batch file again when you upgrade CAM.
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Purchasing User Policies Dialog Box
 This topic applies to: CAM authentication

 Getting There

Use this dialog box to enable Purchasing user policies.

By default, the Purchasing user policies feature is not enabled. If you want to enable this feature, be
aware that the first user who enables Purchasing user policies becomes the Purchasing administrator,
with Purchasing administrator privileges.

This dialog box has one option: Enable Purchasing user policies. Mark this option if you want to choose
which users have access to Purchasing. (If it is not checked, all users have access to it.) Once you enable
this feature, you can click the hyperlink at the bottom of this dialog box to open Purchasing, where you
can use the Administration tab to create access profiles that control who has access to purchasing
records.
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Reports and License Analytics User Policies Dialog
Box

 This topic applies to: CAM authentication

 Getting There

Use this dialog box to enable Reporting and License Analytics user policies.

By default, the Reporting and License Analytics user policies feature is not enabled. If you want to enable
this feature, be aware that the first user who enables these user policies becomes a Reporting
administrator, with Reporting administrator privileges.

This dialog box includes one option: Enable Reporting and License Analytics user policies. Mark this
option if you want to allow multiple users access to Reporting and License Analytics. Once you click OK to
enable this feature, you can click the hyperlink at the bottom left of this dialog box to open Reporting,
where you can use the Administration tab to add users and specify whether each user has full or limited
permissions to view and change reports. (The other hyperlink opens License Analytics.) You can also
prevent specific users from viewing these reports at all.
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Reset CAM History Dialog Box
 This topic applies to on-premises installations.

 Getting There

To save disk space and improve the performance of history reports, you may want to limit the amount of
historical data stored in the CAM Database. Use this dialog box to remove all historical data prior to a
specific date. Specify a date and click Reset.
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Reset File and Usage Data Dialog Box
 This topic applies to on-premises installations.

 Getting There

To save disk space and improve the performance of usage reports, you may want to limit the amount of
file and usage data stored in the CAM Database. Use this dialog box to remove the following from the
CAM Database:

• All usage data prior to a specific date.

• Information from the CAM Database about any files with extensions other than .exe and .com that
were collected prior to a specific date, but are no longer collected during inventories.

Specify a date and click Reset.
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Software Categories Dialog Box
 Getting There

You can use this dialog box to do the following:

• Specify to which software category the selected license unit(s) should belong. Select a category
group to expand it, and then select the category for the license unit(s).

• Create a new software category group. Click the New button, select Group, and enter the name for
the group. Once you create a new software category group, you can create categories to which you
can add license units; this is described next.

• Create a new software category. Click the New button, select Category, and then enter a name for
the category and click OK. Leave this category selected in the Software Categories dialog box to
assign the selected license unit(s) to it.

• Change the name of a software category or group. Select the item you want to change from the list,
and click Change. Enter the new name for the category or group in the Change Software Category
Group dialog box and click OK. When you rename a software category or group, the new name
appears in Cherwell Asset Management, but the original names in the Cherwell Software
Identification Database (CSID) are unchanged.

• Delete a user-created category or group. Select a category or group and click Delete. If the category
you want to delete contains license units, you are prompted to confirm the operation. Any license
units that were in that category still exist, but are not part of any category.

• Return the current license unit to its default category by clicking Reset.

 When you are finished, click OK to return to the General tab of the License Unit Properties dialog box.

Related information
../admin_license_units_suites_applications/Admin_Overview_System_License_Units.xml#concept1468
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Synchronize with CSM Dialog Box
 This topic applies to: CSM authentication

 Getting There

Use this dialog box to synchronize CSM data, including CSM teams and users, with Cherwell Asset
Management. This is generally the last step in changing to CSM authentication, and a task you can
perform any time you update users, teams, and security groups in Cherwell Service Management. If you
don't see the CSM users you expect to see in Reporting and Purchasing, it's a good idea to click
Synchronize here. The synchronization process may take a few moments to complete, and users won't be
able to log into Cherwell Asset Management applications during that time. The dialog box closes when
finished.

Note: You can also synchronize CSM teams in Purchasing's Administration panel.  
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Test Linux/Unix/Mac OS Discovery Dialog Box
 Getting There

Use this dialog box to verify that a connection can be made before proceeding with discovering Linux/
Unix/Mac OS machines. If you are querying a specific machine, click the Test button to proceed. If you
entered an IP address range or subnet, specify one or more machines to check, and then click Test.
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Test Network Device Discovery Dialog Box
 Getting There

Use this dialog box to verify that a connection can be made before proceeding with discovering network
devices. If you are querying a specific device, click the Test button to proceed. If you entered an IP
address range or subnet, specify one or more devices to check, and then click Test.
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Test Oracle Database Discovery Dialog Box
 Getting There

Use this dialog box to verify that a connection can be made to the instance shown before proceeding with
Oracle database discovery.

Click the Test button to proceed, and click Close when your test is complete.
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Test Virtual Environment Discovery Dialog Box
 Getting There

It's a good idea to test the connection to the specified virtual environment before you save your virtual
environment configuration. Click Test to proceed. (If you are querying an IP address range, first type the
machine(s) to test.) The Status box updates with the results of the test.
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Unconfigured Applications General Tab
This tab lists the following information for the current unconfigured application:

• Name

• Version

• Company

• GUID

• Platform

• Information on where it is installed (machine name, path, date the application was added to the
CAM Database, and whether the application has been launched since then)

This information may be helpful, for example, if you decide to configure the application into a license unit.

Note: The name of the selected unconfigured application is shown in the title bar in place of the
words "Unconfigured Application".

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Unconfigured Applications Main Executables Tab
This tab lists the file name and size for the main executable files associated with the current unconfigured
application. This information may be helpful, for example, if you decide to configure the application into a
license unit.

Note: The name of the selected unconfigured application is shown in the title bar in place of the
words "Unconfigured Application".
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Unconfigured Applications Properties Dialog Box
 Getting There

The Unconfigured Applications Properties dialog box contains basic properties of a selected unconfigured
application. The dialog box consists of two tabs:

• General

• Main Executables

Note: The name of the selected unconfigured application is shown in the title bar in place of the
words "Unconfigured Application".

286

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_dialog_boxes%2F..%2Fadmin_getting_there%2FAdmin_Getting_to_the_Unconfigured_Application_Properties_dialog_box.html


Uninstall CAM Agent Dialog Box
Use this dialog box to uninstall the CAM Agent software from the selected machine(s). Enter the user
name and password that were required when you installed the agent—the user name, password, and
domain—and then click Uninstall.

If you want to uninstall the agent from a machine using its IP address instead of machine name, click the
option at the bottom of this dialog box.

The proxy server settings are disabled in this dialog box.

The machine(s) will still show up in the Machines panel next time the view is refreshed, with status listed
as "Not installed."
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Update CSID Automatic Updates Tab
 This topic applies to on-premises installations.

Use this tab to automatically check for and install new versions the Cherwell Software Identification
Database (CSID) when available, and then specify how often these checks should occur.

To set up automatic CSID updates, first mark the Install updates automatically option. Then decide
whether to check for updates daily, weekly, or on a schedule you set up in the Task Scheduler. For daily
updates, specify the hour the update should take place. For weekly updates, specify a day of the week
and the time of day. To use the Task Scheduler, select Custom and then set up a task in the Scheduler.

Once you've set up automatic updates, the CSID will be updated on the specified schedule when new
versions of the CSID are available. If a newer version of the CSID is not available at the time of a
scheduled update, no action will occur.
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Update CSID Dialog Box
 This topic applies to on-premises installations.

 Getting There

Use this dialog box to see whether an update to the Cherwell Software Identification Database (CSID) is
available, as well as to manually update it or set up automatic updates. This dialog box includes two tabs:

• Install CSID

• Automatic Updates
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Update CSID Install CSID Tab
 This topic applies to on-premises installations.

 Getting There

Use this tab to see whether an update to the Cherwell Software Identification Database (CSID) is
available, as well as to manually update it if an update is available.

You can also schedule automatic CSID updates in the Automatic Updates tab.
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User Properties Authorization Tab
The Authorization tab of the User Properties dialog box lists any license units that this user is not
authorized to run.

Note: The name of the selected user is shown in the title bar in place of the word "user."
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User Properties Dialog Box
 Getting There

The User Properties dialog box contains basic properties of a selected user. The dialog box consists of
three tabs:

• General

• Authorization

• Member Of

Note: The login ID of the selected user is shown in the title bar in place of the word "user."
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User Properties General Tab
The General tab of the User Properties dialog box provides the following information, when available:

• The ID of the user

• The domain to which the user belongs

• The first and last name of the user, if available

• Machine the user last logged into (if your site is licensed to use metering functionality and metering
is enabled)

• Date and time of the user's last login (if your site is licensed to use metering functionality and
metering is enabled)

• A link to the Login History report for this user

Note: The login ID of the selected user is shown in the title bar in place of the word "user."
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User Properties Member Of Tab
The Member Of tab of the User Properties dialog box shows which user-added or discovered groups, if
any, the selected user belongs to. Click Add or Remove to change these group assignments. Note that
group assignments can only be changed for user-added groups. Group membership cannot be changed
for discovered groups.

Note: The login ID of the selected user is shown in the title bar in place of the word "user."  

Related information
../admin_users/Admin_User_groups_overview.xml#concept811
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Open Dialog Boxes
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Open the Add Active Directory OU Path Dialog Box
To open the Add Active Directory OU Path dialog box:

1. Select Tools > Options.

2. Select the AD Discovery tab.

3. Select Discover from Active Directory, then click Add.

4. Add your OU path and click OK.

- or -

1. Select Tools > Discover > Active Directory or NT Domain.

2. Click Configure.

3. Select Discover from Active Directory, then click Add.
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Open the Add as Alternate Executable Dialog Box
To open the Add as Alternate Executable dialog box, do one of the following from the Files panel:

• Right-click on a file and select Add as Alternate Executable.

- or -

• With a file selected, select File > Files > Add as Alternate Executable.
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Open the Add as Support File Dialog Box
To open the Add as Support File dialog box, do one of the following from the Files panel:

• Right-click on a file, then select Add as Support File.

- or -

• With a file selected, select File > Files > Add as Support File.
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Open the Add as Version Dialog Box
To open the Add as Version dialog box:

• Right-click on a file and select Add as Version.

- or -

• With a file selected, select File > Files > Add as Version.

To open the Add as Version dialog box from the Unconfigured Applications Panel:

• Right-click an application and select Add as Version.
- or -

• With an application selected, select File > Unconfigured Applications > Add as Version.
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Open the Add Authorized Machine Dialog Box
The Add Authorized Machine dialog box is accessible when you add a new or modify an existing control
profile.

To add a new control profile:

1. Select File > New Control Profile.

2. Select the General tab in the New Control Profile dialog box, then type a name and description
(optional) for the control profile you want to create.

3. Select the Authorization tab.

4. From the Authorization list box, select either Selected users and machines are authorized or
Selected users and machines are NOT authorized.

5. Select Add Machines.

To modify an existing control profile:

1. Select Tools > Control Profiles.

2. Select a profile from the list and click Change.

3. Select the Authorization tab.

4. From the Authorization list box, select either Selected users and machines are authorized or
Selected users and machines are NOT authorized.

5. Select Add Machines.
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Open the Add Authorized User Dialog Box
The Add Authorized Machine dialog box is accessible when you add a new or modify an existing
authorized user.

Add a New Control Profile

1. Select File > New Control Profile.

2. In the General tab of the New Control Profile dialog box, type a name and description (optional) for
the control profile you want to create.

3. Select the Authorization tab.

4. From the Authorization list box, select either Selected users and machines are authorized or
Selected users and machines are NOT authorized.

5. Select Add Users.

Modify an Existing Control Profile

1. Select Tools > Control Profiles.

2. Select a profile from the list and click Change.

3. Select the Authorization tab.

4. From the Authorization list box, select either Selected users and machines are authorized or
Selected users and machines are NOT authorized.

5. Select Add Users.

301

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_getting_there%2F..%2Fadmin_dialog_boxes%2FAdmin__HID_CONTROL_PROFILE_GENERAL_TAB.html
https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_getting_there%2F..%2Fadmin_dialog_boxes%2FAdmin__HID_CONTROL_PROFILE_AUTHORIZATION_TAB.html
https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_getting_there%2F..%2Fadmin_dialog_boxes%2FAdmin__HID_CONTROL_PROFILE_AUTHORIZATION_TAB.html


Open the Add Executable Version Dialog Box
You can specify which version of an executable is used for an application or suite in a license unit.

To open the Add Executable Version dialog box:

1. Select File > New Application or New Suite.

2. Select either New License Unit or Selected License Unit.
3. Depending on what you selected in Step 1, choose an option:

◦ If you selected New Application, select Add.

◦ If you selected New Suite, select New. In the New Application dialog box, select Add.
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Open the Add Support File Dialog Box
To open the Add Support File dialog box, do one of the following:

1. Select File > New Application.

2. Select in New License Unit or in Selected License Unit.
3. Select the Support Files tab and select Add.

- or -

1. Select File > New Suite.

2. Select in New License Unit or in Selected License Unit.
3. Select New, then select the Support Files tab.

4. Select Add.
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Open the Add/Change Administrator User Policy
Dialog Box

This dialog box is only available in sites that use CAM authentication.

To open the Add/Change Administrator User Policy dialog box:

1. Select Tools > User Policies and Authentication > Administrator.
2. Select Enable Administrator user policies.

3. Select Add, or select an item from the list and select Change.
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Open the Add/Change Exclude Folder Dialog Box
To open the Add/Change Exclude Folder dialog box:

1. Select Machine > Agent Options.

2. Select the Inventory tab, then select Advanced.

3. Select Add, or select an item from the list and select Change.
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Open the Add/Change Extension Dialog Box
To open the Add/Change Extension dialog box:

1. Select Machine > Agent Options.

2. Select the Inventory tab, then select Extensions.

3. Select Add, or select an item in the list and select Change.
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Open the Add/Change File Dialog Box
To open the Add/Change File dialog box:

• Go to Machine > Agent Options.

• Select the Inventory tab, then select Files.

• Select Add, or select an item in the list and select Change.
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Open the Add/Change License Allocation Dialog
Box

To open the Add/Change License Allocation dialog box:

1. Right-click a License Unit and select Properties.

2. Select Concurrent from the Licensing drop-down list.

3. Click Allocations.

4. In the Concurrent License Allocations dialog box, do one of the following:
◦ Click Add.

- or -

◦ Select a machine group from the list and click Change.
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Open the Add/Change Linux/Unix/Mac OS
Discovery IP Address Range Dialog Box

To open the Add/Change Linux/Unix/Mac OS Discovery IP Address Range dialog box:

1. Select Tools > Discover > Linux/Unix/Mac OS.

2. In the Discover Linux/Unix/Mac OS dialog box, click Configure.

3. In the Configure Linux/Unix/Mac OS Discovery dialog box, select Add, then click IP Address
Range.

- or -

You can also select an existing IP range in the box, then click Change.
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Open the Add/Change Linux/Unix/Mac OS
Discovery Machines Dialog Box

To open the Add/Change Linux/Unix/Mac OS Discovery Machines dialog box:

1. Select Tools > Discover > Linux/Unix/Mac OS.

2. In the Discover Linux/Unix/Mac OS dialog box, click Configure.

3. In the Configure Linux/Unix/Mac OS Discovery dialog box, click Add, then click Machine.

- or -

Select an existing machine, then click Change.
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Open the Add/Change Linux/Unix/Mac OS
Discovery Subnet Dialog Box

To open the Add/Change Linux/Unix/Mac OS Discovery Subnet dialog box:

1. Select Tools > Discover > Linux/Unix/Mac OS.

2. In the Discover Linux/Unix/Mac OS dialog box, click Configure.

3. In the Configure Linux/Unix/Mac OS Discovery dialog box, click Add, then click Subnet.

- or -

Select an existing subnet in the box, then click Change.
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Open the Configure Network Device Discovery
Dialog Box

To open the Configure Network Device Discovery dialog box:

1. Select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Device Discovery dialog box, select Add, then click Device.

- or -

Select an existing device and click Change.
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Open the Add/Change Network Device Discovery
IP Address Range Dialog Box

To open the Add/Change Network Device Discovery IP Address Range dialog box:

1. Select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Device Discovery dialog box, click Add, then click IP Address Range.

- or -

You can also select an existing IP range in the box, then click Change.
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Open the Add/Change Network Device Discovery
Subnet Dialog Box

To open the Add/Change Network Device Discovery Subnet dialog box:

1. Select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Device Discovery dialog box, click Add, then click Subnet.

- or -

You can also select an existing subnet in the box, then click Change.
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Open the Add/Change Upgrade Path Location
Dialog Box

To open the Add/Change Upgrade Path Location dialog box:

• Select Machine > Agent Options, then click the Self-upgrade tab. Click Add, or select a location
and click Change.

- or -

• In the Machines panel, right-click a machine and select Enable Agent Self-Upgrade, then click
Add.
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Open the Add/Change Virtual Environment
Discovery IP Range Dialog Box

To open the Add/Change Virtual Environment Discovery IP Range dialog box:

1. Select Tools > Discover > Virtual Environment.
2. In the Discover Virtual Environment dialog box, click Configure.

3. In the Configure Virtual Environment Discovery dialog box, click Add, then click IP Address Range.

- or -

You can also select an existing IP range in the box, then click Change.
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Open the Add/Change Virtual Environment
Discovery Subnet Dialog Box

To open the Add/Change Virtual Environment Discovery Subnet dialog box:

1. Select Tools > Discover > Virtual Environment.
2. In the Discover Virtual Environment dialog box, click Configure.

3. In the Configure Virtual Environment Discovery dialog box, click Add, then click Subnet.

- or -

You can also select an existing subnet in the box, then click Change.
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Open the Add/Change Virtual Environment
Discovery Machine Dialog Box

To open the Add/Change Virtual Environment Discovery Machine dialog box:

1. Select Tools > Discover > Virtual Environment.
2. In the Discover Virtual Environment dialog box, click Configure.

3. In the Configure Virtual Environment Discovery dialog box, click Add, then click Machine.

- or -

Select an existing IP range in the box, then click Change.
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Open the Active Directory or NT Domain Dialog
Box

To open the Active Directory or NT Domain dialog box:

• Select Tools > Discover > Active Directory or NT Domain.
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Open the Additional Exclude Folders Dialog Box
To open the Additional Exclude Folders dialog box:

• Select Machine > Agent Options.

- or -

• In the Inventory tab of the Agent Options dialog box, click Advanced.
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Open the Administrator User Policies Dialog Box
To open the Administrator User Policies dialog box:

• Select Tools > User Policies and Authentication > Administrator.

- or -

• From the Status page, click Administrator in the User Policies section.

Note:

This dialog box is only available in sites that use CAM authentication.
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Open the Agent Options Dialog Box
To open the Agent Options dialog box:

• Select Machine > Agent Options.
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Open the Agent Options Messages Tab
To open the Agent Options Messages tab:

• Select Machine > Agent Options, then select the Messages tab.
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Open the Asset Properties Dialog Box
To open the Asset Properties dialog box, do one of the following:

• In the Other Assets panel, select one or more assets, right-click on your selection, then select
Properties from the context-sensitive menu.

- or -

• Select one or more assets and select Properties from the Edit menu.

To add a new asset:

• Select File > New Asset.
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Open the Asset Template Dialog Box
To open the Asset Template dialog box:

• Select Tools > Template > Asset.
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Open the Asset Types Dialog Box
To open the Asset Types dialog box:

• Select File > New Asset. In this dialog box, click Asset Types.

- or -

• Right-click on an asset in the Other Assets panel, then select Properties from the context-sensitive
menu. In the Properties dialog box, click Asset Types.

The Properties dialog box is also a tab in the Asset Template dialog box.

To open it from the asset template:

1. Select Tools > Template > Asset.
2. Click the Asset Types tab.

No matter which method you use to open this tab or dialog box, the options shown are the same and are
configured the same way.
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Open the Automatically Configure Applications
Dialog Box

To open the Automatically Configure Applications dialog box:

• Select Tools > Automatically Configure Applications.
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Open the Browse for License Unit Dialog Box
To open the Browse for License Unit dialog box, do the following:

1. In the left pane of the License Units panel, select the license unit that contains the application you
want to add to an existing license unit. If the license unit contains more than one application, expand
the license unit by clicking the plus sign next to its folder.

2. In the right pane, select the application, right-click it, then select Convert to License Unit from the
context-sensitive menu.

3. In the Convert to License Unit dialog box, select the third option and click OK.

4. In the Add Existing Applications to Existing License Unit dialog box, click Browse in the License
Unit section.
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Open the Browse for User Dialog Box
To open the Browse for User dialog box, do the following:

1. Select Tools > User Policies and Authentication > Administrator.
2. In the Administrator User Policies dialog box, select the Enable Administrator user policies check

box.

3. Select OK.

4. Back in the Administrator User Policies dialog box, click either Add or Change.

5. In the Add/Change Administrator User Policy dialog box, click Browse.
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Open the CAM Administration Service Dialog Box
To open the CAM Administration Service dialog box:

• Select Tools > Connection, then click CAM Administration Service.

Note: You may see this dialog box when you start CAM Administrator if there is a problem
connecting to the CAM Administration Service (for example, if invalid credentials were entered,
the service has not started, or the administration service name is incorrect).  
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Open the CAM Database Dialog Box
To open the CAM Database dialog box:

• Select Tools > Connection > CAM Database.

Note:

This dialog box is only available in on-premises installations.
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Open the CAM System License Units Dialog Box
To open the CAM System License Units dialog box:

1. Select Tools > Options.

2. In the Options dialog box, click the Advanced tab.

3. Click CAM System License Units.
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Open the Change Authentication Dialog Box
To open the Change Authentication dialog box:

• Select Tools > User Policies and Authentication > Change Authentication.

Note:

This dialog box is only available in on-premises installations.
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Open the Change Authentication for Multiple
Oracle Database Instances Dialog Box

To open the Change Authentication for Multiple Oracle Database Instances dialog box:

1. Select Tools > Discover > Oracle Database.

2. From the Discover Oracle Databases dialog box, click Configure.

3. In the Configure Oracle Database Discovery dialog box, highlight the applicable instances and click
Configure.
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Open the Change Authentication for a Single
Oracle Database Instance Dialog Box

To open the Change Authentication for a Single Oracle Database Instance dialog box:

1. Select Tools > Discover > Oracle Databases.

2. Click Configure.

3. In the Configure Oracle Database Discovery dialog box, select an instance, then click Configure.
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Open the Configure Network Device Discovery
Dialog Box

To open the Configure Network Device Discovery dialog box, do the following:

1. Select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Device Discovery dialog box, select configuration(s), then click Change.
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Open the Change Licensed Features Dialog Box
Paste a configuration key into this dialog box to add features, licenses, or time to Cherwell Asset
Management.

To open the Change Licensed Features dialog box:

• In the Status panel's Licensed Features section, click Change.
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Open the Change Virtual Environment Discovery
Machine Dialog Box

To open the Change Virtual Environment Discovery Machine dialog box:

1. Select Tools > Discover > Virtual Environment.
2. In the Discover Virtual Environment dialog box, click Configure.

3. In the Configure Virtual Environment Discovery dialog box, select multiple configurations and click
Change.

338

CAM 14.2 Administrator

CAM 14.2 Administrator



Open the Check In License Dialog Box
To open the Check In License dialog box:

• In the License Units panel, right-click a license unit of Type Concurrent, then select Check In
License from the context-sensitive menu.

- or -

1. Select a concurrent license unit.

2. Select File > License Units > Check In License.
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Open the Check In/Out Licenses Dialog Box
To open the Check In/Out Licenses dialog box:

• Select the machine you want, then select Machine >Check In/Out License.

- or -

• In the Machines panel, select one machine, right-click it and select Check In/Out License from the
context-sensitive menu.
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Open the Choose Details Dialog Box
To open the Choose Details dialog box:

1. Go the License Units, Unconfigured Applications, Files, Machines, Network Devices, Other
Assets, or Users panel.

2. Select the View menu, then click Choose Details.
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Open the Concurrent License Allocations Dialog
Box

To open the Concurrent License Allocations dialog box:

1. In the License Units panel, right-click on a license unit and select Properties from the context-
sensitive menu.

2. In the Licensing drop-down list, select Concurrent.
3. Click Allocations.

4. Click Add, Change, or Remove concurrent license allocations, then click OK.
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Open the Configure Baselines Dialog Box
To open the Configure Baselines dialog box:

• Select Tools > Baselines.
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Open the Configure Linux/Unix/Mac OS Discovery
Dialog Box

To open the Configure Linux/Unix/Mac OS Discovery dialog box:

1. Select Tools > Discover > Linux/Unix/Mac OS > Configure.
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Open the Configure Network Device Discovery
Dialog Box

To open the Configure Network Device Discovery dialog box:

1. Select Tools > Discover > Network Devices.

2. From the Discover Network Devices dialog box, click Configure.
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Open the Configure Oracle Database Discovery
Dialog Box

To open the Configure Oracle Database Discovery dialog box:

1. Select Tools > Discover > Oracle Databases.

2. Click Configure.
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Open the Configure Virtual Environment Discovery
Dialog Box

To open the Configure Virtual Environment Discovery dialog box:

1. Select Tools > Discover > Virtual Environment.
2. Click Configure.
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Open the Configure Web Component Locations
Dialog Box

To open the Configure Web Component Locations dialog box:

• In the Status panel's Web Component Locations section, click the Configure hyperlink.

Note:

This dialog box is available in on-premises installations only.
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Open the Contribute to the CSID Dialog Box
To open the Contribute to the CSID dialog box:

• Right-click the machine you want to scan and click Contribute to the CSID.

- or -

• Select the machine to scan and select the Machine menu, then Contribute to the CSID.
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Open the Control Profiles Dialog Box
To open the Control Profiles dialog box:

• Select Tools > Control Profiles.
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Open the Convert to License Unit Dialog Box
To open the Convert to License Unit dialog box:

1. In the left pane of the License Units panel, select the license unit that contains the application you
want to convert.

If the license unit contains more than one application, expand the license unit by clicking the plus
sign next to its folder.

2. In the right pane, select the application, right-click it, then select Convert to License Unit.
3. Select the option you want and click OK.
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Open the Copy Existing Applications to Existing
License Unit Dialog Box

To open the Copy Existing Applications to Existing License Unit dialog box:

1. In the left pane of the License Units panel, select the license unit that contains the application you
want to add to an existing license unit.

If the license unit contains more than one application, expand the license unit by clicking the plus
sign next to its folder.

2. In the right pane, select the application, then right-click it and select Convert to License Unit.
3. Select Copy the selected Windows application(s) into an existing license unit and click OK.
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Open the Copy Existing Applications to New
License Unit Dialog Box

To open the Copy Existing Applications to New License Unit dialog box:

1. In the left pane of the License Units panel, select the license unit that contains the application you
want to add to a new license unit.

If the license unit contains more than one application, expand the license unit by clicking the plus
sign next to its folder.

2. Right-click the application you selected and select Convert to License Unit from the context-
sensitive menu.

3. In the Convert to License Unit dialog box, select Copy the selected Windows application(s) into
a new license unit.

4. Click OK.
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Open the Discover Linux/Unix/Mac OS Dialog Box
To open the Discover Linux/Unix/Mac OS dialog box:

• Select Tools > Discover > Linux/Unix/Mac OS.
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Open the Discover Network Devices Dialog Box
To open the Discover Network Devices dialog box:

• Select Tools > Discover > Network Devices.

355

CAM 14.2 Administrator

CAM 14.2 Administrator



Open the Discover Oracle Databases Dialog Box
To open the Discover Oracle Databases dialog box:

• Select Tools > Discover > Oracle Databases.
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Open the Discover Virtual Environment Dialog Box
To open the Discover Virtual Environment dialog box:

• Select Tools > Discover > Virtual Environment.
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Open the Enable Agent Self-Upgrade Dialog Box
To open the Enable Agent Self-Upgrade dialog box:

• Right-click a machine, then select Enable Agent Self-Upgrade from the context-sensitive menu.

- or -

• Select a machine, then select Machine > Enable Agent Self-Upgrade.
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Open the File Properties Dialog Box
To open the File Properties dialog box:

• In the Files panel, right-click a file and select Properties from the context-sensitive menu.

- or -

• Select a file, then select Edit > Properties.
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Open the File Search Area
To open the File Search area, go to the Files panel; the Search area is at the bottom of the left pane.
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Open the Hosted Cherwell Asset Management
Dialog Box

To open the Hosted Cherwell Asset Management dialog box:

• Select Tools > Connection > Hosted Cherwell Asset Management.

Note:

This dialog box is only available in hosted installations.
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Open the Import SCOM Data Dialog Box
To open the Import SCOM Data dialog box:

• Select Tools > Import > Machine Data (SCOM).
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Open the Inventory Extensions Dialog Box
To open the Inventory Extensions dialog box:

1. Select Machines > Agent Options.

2. In the Inventory tab, click Extensions.
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Open the Inventory These Files Dialog Box
To open the Inventory These Files dialog box:

• Select Machines > Agent Options.
• In the Inventory tab, click Files.
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Open the License Checkout Summary Report
To open the License Checkout Summary report:

• Select Reporting > License Checkout Summary.
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Open the License Unit Properties Dialog Box
To open the License Unit Properties dialog box:

• In the License Units panel, right-click a license unit and select Properties.

- or -

• Select a license unit, then select Edit > Properties.

Note: When multiple license units are selected, you can view a subset of properties using either of
these methods.
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Open the License Unit Template Dialog Box
To open the License Unit Template dialog box:

• Select Tools > Template > License Unit.
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Open the Machine Properties Dialog Box
To open the Machine Properties dialog box:

• In the Machines panel, select one or more machines, right-click and select Properties.

- or -

• Select one or more machines, then select Edit > Properties.
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Open the Machine Search Area
To open the Machine Search area:

1. Go to the Machines panel.

2. The Machine Search text box is at the top of the right pane, toward the middle.

- or -

When you are in the Machines panel, press Ctrl-F and start typing in the Machine Search text box.
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Open the Machine Summary Report
To open the Machine Summary report, select a managed machine and then do one of the
following:

• In the Machine Properties dialog box, select the General tab, then select Machine Summary.

• Right-click a machine and select Machine Summary.

• Select Reporting > Machine Summary.

Before the report opens, you may be prompted to enter the location of the reports.
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Open the Machines Waiting and License Allocation
Report

To open the Machines Waiting and License Allocation report:

• Right-click a license unit, then click Show Machines Waiting.

- or -

• Select a license unit, then select Reporting > Show Machines Waiting.
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Open the Manufacturers Dialog Box
To open the Manufacturers dialog box:

• Select Tools > Manufacturers.

You can also open this dialog box when you are configuring license units and other assets. Each method
is described below.

Configuring License Units
To open the Manufacturers dialog box while configuring license units:

1. Go to the License Units panel.

2. Select one or more license units, right-click your selection and select Properties.

3. In the General tab of License Unit Properties dialog box, click Manufacturers.

Configuring Other Assets
To open the Manufacturers dialog box while configuring other assets:

• Select File > New Asset > Manufacturers.
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Open the More Email Settings Dialog Box
To open the More Email Settings dialog box:

1. Select Tools > Options.

2. In the Options dialog box, select the Alerts tab.

3. Check the Send email alerts check box, then click More Settings.
a. Specify the SMTP port (the default is 25).

b. If SSL is required, check the This server requires an encrypted connection (SSL) check
box.

c. Enter credentials if necessary.

d. Click OK.

4. You can send a test alert by entering an email address in theSend alert to: box and clicking Test.
5. You can also enter a From address and SMTP server in their respective boxes.

6. If necessary, test your access points in the Access Points section.

7. Click OK.
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Open the Move Applications to Existing License
Unit Dialog Box

To open the Move Applications to Existing License Unit dialog box:

1. In the left pane of the License Units panel, find the license unit that contains the application you
want to convert. If the license unit contains more than one application, expand the license unit by
clicking the plus sign next to its folder.

2. Select the license unit.

3. In the right pane, select the application, right-click it, then select Convert to License Unit.
4. In the Convert to License Unit dialog box, select Move the selected application(s) into a new

license unit.
5. Click OK.
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Open the Move Applications to New License Unit
Dialog Box

To open the Move Applications to New License Unit dialog box:

1. In the left pane of the License Units panel, click the plus sign next to the license unit that contains
the application you want to convert.

2. Select the license unit.

3. In the right pane, select the application, right-click it, then select Convert to License Unit.
4. In the Convert to License Unit dialog box, select the first option (Move selected application(s) into

a new license unit) and click OK.
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Open the Move Suites to Existing License Unit
Dialog Box

To open the Move Suites to Existing License Unit dialog box:

1. In the left pane of the License Units panel, find the license unit that contains the suite you want to
convert.

2. Expand the license unit by clicking the plus sign next to its folder.

3. Select a suite, right-click it, then select Convert to License Unit.
4. In the Convert to License Unit dialog box, select Move the selected suite(s) into an existing

license unit.
5. Click OK.
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Open the Move Suites to New License Unit Dialog
Box

To open the Move Suites to New License Unit dialog box:

1. Select License Units.

2. In the left pane under License Units, select the license unit that contains the suite you want to
convert.

3. Expand the license unit by clicking the plus sign next to its folder.

4. Select a suite, right-click it, then select Convert to License Unit.
5. In the Convert to License Unit dialog box, select Move the selected suite(s) into a new license

unit.
6. Click OK.
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Open the Network Device Summary Report
To open the Network Device Summary report, select a discovered network device, then do one of
the following:

• In the Network Device Properties dialog box, select the General tab, then click Network Device
Summary.

• Right-click a network device and select Network Device Summary.

• Select Reporting > Network Device Summary.
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Open the Network Device Template Dialog Box
To open the Network Device Template dialog box:

• Select Tools > Template > Network Device.
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Open the Network Devices Properties Dialog Box
To open the Network Devices Properties dialog box:

• In the Network Devices panel, right-click a network device, then select Properties.

• Select a network device, then select Edit > Properties.
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Open the New/Change Baseline Dialog Box
To open the New/Change Baseline dialog box:

1. Select Tools > Baselines.

2. In the Configure Baselines dialog box, click New, or select an existing baseline and click Change.
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Open the New/Change Control Profile Dialog Box
To open the New Control Profile dialog box:

• Select File > New Control Profile.

To open the Change Control Profile dialog box:

1. Select Tools > Control Profiles.

2. Select a control profile from the list, then click Change.
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Open the New/Change Custom Data Property
Dialog Box

To open the New/Change Custom Data Property dialog box:

1. Select Tools > Template > Asset.
2. In the Custom Asset Data tab, click New, or select an existing custom asset data field and click

Change.
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Open the New/Change Custom Machine Property
Dialog Box

To open the New/Change Custom Machine Property dialog box:

1. Select Machine > Agent Options.

2. Click the Custom tab.

3. Click New, or select an existing property and click Change.
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Open the New/Change Manufacturer Dialog Box
To open the New/Change Manufacturer dialog box:

• Select Tools > Manufacturers > New.

- or -

• Select a manufacturer in the list and click Change.

You can also open this dialog box when you are configuring license units and other assets. Each method
is described below.

Configuring License Units
To open the New/Change Manufacturer dialog box for license units:

1. In the License Units panel, select one or more license units, right-click and select Properties.

2. In the General tab of License Unit Properties dialog box, click Manufacturers.

3. In the Manufacturers dialog box, click New or select a Manufacturer and click Change.

Configuring Other Assets
To open the New/Change Manufacturer dialog box for assets:

1. Select File > New Asset > Manufacturers.

2. Click New or select a Manufacturer and click Change.
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Open the Options Dialog Box
To open the Options dialog box:

• Select Tools > Options.
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Open the Overallocated License Units Report
To open the Overallocated License Units report:

• Select Reporting > Overallocated License Units.

Note:

This report is only available if overallocated licenses exist.
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Open the Prepare Remote Inventory Agent Dialog
Box

To open the Prepare Remote Inventory Agent dialog box:

• Select Machine > Remote Inventory > Prepare Agent.

388

CAM 14.2 Administrator

CAM 14.2 Administrator



Open the Purchasing User Policies Dialog Box
This dialog box is only available in sites that use CAM authentication.

To open the Purchasing User Policies dialog box:

• Select Tools > User Policies and Authentication > Purchasing.

- or -

• From the Status page, click the Purchasing hyperlink in the User Policies section.
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Open the Reporting and License Analytics User
Policies Dialog Box

This dialog box is only available in sites that use CAM authentication.

To open the Reporting and License Analytics User Policies dialog box:

• Select Tools > User Policies and Authentication > Reporting and License Analytics.

- or -

• From the Status panel, click the Reporting & License Analytics rlink in the User Policies section.
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Open the Reset CAM History Dialog Box
To open the Reset CAM History dialog box:

• Select Tools > Reset Data > History.

Note:

This dialog box is only available in on-premises installations.
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Open the Reset File and Usage Data Dialog Box
To open the Reset File and Usage Data dialog box:

• Select Tools > Reset Data > Files and Usage.

Note:

This dialog box is only available in on-premises installations.
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Open the Setup Checklist
To see the Setup Checklist:

• Select View > Setup Checklist.
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Open the Software Categories Dialog Box
To open the Software Categories dialog box:

1. Go to the License Units panel.

2. Select one or more license units, right-click, then click Properties.

3. In the General tab of License Unit Properties dialog box, click Categories.
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Open the Synchronize with CSM Dialog Box
To open the Synchronize with CSM dialog box:

• Select Tools > Synchronize with CSM.

Note:

This dialog box is only available in sites that use CSM authentication.
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Open the Test Device Discovery Dialog Box
To open the Test Device Discovery dialog box:

1. Select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Device Discovery dialog box, click Add, then select IP Address Range,
Subnet, or Machine.

You can also select an existing configuration and click Change.

4. Complete the dialog box that opens, then click Test.  
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Open the Test Linux/Unix/Mac OS Discovery Dialog
Box

To open the Test Linux/Unix/Mac OS Discovery dialog box:

1. Select Tools > Discover > Linux/Unix/Mac OS.

2. In the Discover Linux/Unix/Mac OS dialog box, click Configure.

3. In the Configure Linux/Unix/Mac OS Discovery dialog box, click Add, then select IP Address
Range, Subnet, or Machine.

To modify an existing configuration, select it and click Change.

4. Complete the dialog box that opens, then click Test.  
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Open the Test Oracle Database Discovery Dialog
Box

To open the Test Oracle Database Authentication dialog box:

1. Select Tools > Discover > Oracle Database.

2. Click Configure.

3. In the Configure Oracle Database Discovery dialog box, select a configuration, then click
Configure.

4. In the Change Authentication for a Single Oracle Database Instance dialog box, enter a user name
and password for the Oracle Database instance, then click Test.
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Open the Test Virtual Environment Discovery
Dialog Box

To open the Test Virtual Environment Discovery dialog box:

1. Select Tools > Discover > Virtual Environment.
2. In the Discover Virtual Environment dialog box, click Configure.

3. In the Configure Virtual Environment Discovery dialog box, click Add, then click either IP Address
Range, Subnet, or Machine, depending on what you want to test.

4. Complete the dialog box that opens, then click Test.
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Open the Unconfigured Application Properties
Dialog Box

To open the Unconfigured Application Properties dialog box:

1. Right-click an unconfigured application in the Unconfigured Applications panel.

2. Select Properties.
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Open the Update CSID Dialog Box
To open the Update CSID dialog box:

• Select Tools > Update Software Identification Database.

- or -

• From the Status panel, check the Database section. Click the link to an update of the CSID (the last
line of this section) if it's available.

Note:

This dialog box is only available in on-premises installations.
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Open the User Properties Dialog Box
To open the User Properties dialog box:

• In the Users panel, right-click on a user and select Properties.

- or -

• Select a user, then select Edit > Properties.
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Open the Work Queue
To see the Work Queue:

• Select View > Work Queue.
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Discovery
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Discover Linux/Unix/Mac OS Machines
The Linux/Unix/Mac OS discovery feature provides agentless inventory capabilities for supported non-
Windows systems. It works by connecting to such systems over the SSH protocol and issuing standard
shell commands to generate data required to gather information about machine hardware and software.
Once data is collected, you can do things like configure applications you want to track into license units,
run reports, and track purchasing information.

Certain commands may require administrative-level privileges, so in order for discovery and data
collection to successfully run, each machine you want to discover must meet these conditions:

• Allow SSH connections.

• Have a user that is allowed to connect via the SSH protocol and elevate to administrator (see More
on the "sudo" Command).

Note: Once configured, the Linux/Unix/Mac OS discovery process automatically runs at 2:30 a.m.
each Sunday by default. You can clear this option in the Schedule tab of the Options dialog box to
turn off this scheduled task. If you want to change how frequently discovery runs, you need to do
that through the Windows Task Scheduler; the name of the task is "Linux, Unix, Mac OS
Discovery" and it's under the Cherwell Asset Management node.

Related information
Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
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Discover Machines and Users from Active
Directory or NT

If you use Active Directory or NT domains in your network environment and the CAM Administration
Service machine is part of the Active Directory or domain, you can find named computers and users from
CAM Administrator.

If you are using Active Directory, you can also specify that Cherwell Asset Management only runs
discovery on specific organizational units (OUs). This option is especially useful for large Active Directory
implementations.

To find out whether the discovery process has completed, press F5 to refresh the display after a few
minutes, or check the status line at the bottom right of the window for updates.

By default, the discovery process automatically runs at 1:00 a.m. each Sunday.

Related information
../admin_how_to/Admin_How_to_discover_machines_and_users.xml#concept1715
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Multiple Domain or Active Directory Discovery
The default domain or Active Directory discovery will provide a list of machines currently turned on in the
current domain or Active Directory. The current domain or Active Directory is the domain or Active
Directory in which the CAM Administration Service is installed.

If a trust relationship exists across multiple AD domains, you can discover machines across them by
entering an LDAP string in the Add Active Directory OU Path Dialog Box.

For example, if your CAM Administration Service is in the sea.mycompany.local domain and it has a trust
relationship with mycompany.local, you can discover machines across the entire mycompany.local Active
Directory by entering the following in the Add Active Directory OU Path dialog box:

LDAP://DC=mycompany,DC=local
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Discover Network Devices
You can configure Cherwell Asset Management to discover any network devices on your network. There
are several ways to discover network devices: by IP address range, by subnet, and by device (use this
option for IPv6 devices).

Once configured, the network device discovery process automatically runs at 3:00 a.m. each Sunday by
default.

To clear this option, go to the Options dialog box, then select the Schedule tab.

You can change how frequently discovery runs through the Task Scheduler itself.

 

Related information
Admin_How_to_discover_network_devices.xml#concept3950
../admin_network_devices/Admin_Overview_Network_devices_vs_other_assets.xml#concept1627
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Discover Oracle Database Instances
Oracle Database discovery collects Oracle Database licensing data from Oracle Database instances, so
you can assess your licensing position.

CAM supports discovery of Oracle Database instance information in Unix/Linux environments for the
following Oracle releases:

• Oracle Database version 12c, release 2, Enterprise and Standard editions

• Oracle Database version 11g, release 2, Enterprise and Standard editions

Once configured, the discovery process automatically runs at 4:00 A.M. Pacific Time each Sunday.

To turn off the scheduled task:

• From the Schedule tab, select Options.

Change how frequently discovery runs through the Task Scheduler itself.
Related information
Admin_How_to_discover_Oracle_databases.xml#concept3950
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Discover Your Virtual Environment
You can configure Cherwell Asset Management to discover any virtual machines on your network.

To find out whether the discovery process has completed, press F5 to refresh the display after a few
minutes, or check the status line at the bottom right of the window for updates.

Related information
Admin_How_to_discover_virtual_machines.xml#concept3918
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About Virtual Environment Discovery
CAM Virtual Environment Discovery does the following:

• Collects Virtual Machine host and guest relationships for Windows operating systems

• Collects Virtual Machine host and guest relationships for Linux/Unix operating systems

• Collects Microsoft Windows Server Licensing information from guests

• Collects Microsoft SQL Server Licensing information from guests

Supported Environments
Host Environments

• VMware vSphere®

• Microsoft Hyper-V

Guest Environments

• Any Microsoft Operating Systems supported by CAM

• Any Linux/Unix environments supported by CAM

Requirements

Discovery Requirements

VMware: Microsoft OS guests

• Provide read-only credentials to vSphere

• Credentials must have WMI access to the guest
machines, in order to collect Windows Server
and SQL Server licensing details from the guest

• VMware tools must be installed on the guest OS

VMware: Linux/Unix guests

• Provide read-only credentials to vSphere

• Do not need credentials for the guest Linux/Unix
guests

• VMware tools must be installed on the guest OS
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Discovery Requirements

MS Hyper-V: Microsoft OS guests

• Provide read-only credentials to Microsoft
SCCM Virtual Machine Manager (SCCM VMM)

• Credentials must have WMI access to the host
and guest machines. This is required to collect
Windows Server and SQL Server licensing
details

• Remote PowerShell must be enabled on the
SCCM VMM

MS Hyper-V: Linux/Unix guests

Collect host/guest information by completing the
following steps:

1. Discover VMs (read-only credentials to
Microsoft SCCM Virtual Machine Manager): This
collects the host information.

2. Discover Linux/Unix VMs: This identifies the
host and guest relationship.

Discovery Log
The discovery log is located in C:\Program Files (x86)\Cherwell Asset Management\Administration
Service\VMDiscovery.log

Common Error Messages

• The RPC server is unavailable: This message means the RPC Server has encountered an error,
typically because the RPC server is not running, or security systems are preventing access needed
to run the commands.

• VMware Tools not installed: We can’t collect data from the guest because VMware Tools are not
installed.

• Access is Denied: This typically occurs when you don’t have the correct credentials to the guest
OS, and cannot reach the guest via WMI. This only happens when the guest is Microsoft OS.
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How to...
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Alerts
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How to Configure Alerts
Alerts allow you to be promptly notified when an event occurs that requires attention.

To configure alerts:

1. Open the Alerts tab of the Options dialog box by doing one of the following:
◦ From the Status panel, click the Alerts link in the CAM Access Points section.

◦ From the Tools menu, click Options, then click the Alerts tab.

2. Check the Send email alerts check box if it isn't already checked.

3. In the Send alert to box, specify the email address where you want to send alerts. The email
address should be one that is checked frequently.

4. In the From address box, specify the email address where the alert originates, and to which
recipients of the alert can respond.

5. In the SMTP server box, specify a valid SMTP Server address for outgoing messages.

If your email service provider requires additional information, click thMore Settings to open the
More Email Settings dialog box.

6. Make sure the check boxes next to all the access points you use are marked.

7. Click Test or OK. If you click Test, you'll receive a test message at the email address you specify.
You can delete the test message.

Note: By default, access point availability is checked every hour, on the hour. The Work Queue is
checked every hour at five minutes past the top of the hour. You can change how often to check
access point and Work Queue availability using the Task Scheduler, which is a System Tools
accessory that ships with Windows.
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Applications
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How to Add an Application to the CAM Database
If you want to report on applications in license units, you must add those applications to the CAM
Database.

To add an application to your CAM Database:

1. In CAM Administrator, select File > New Application.

2. Select either in New License Unit or in Selected License Unit.
3. In the New Application dialog box, enter the information for the application. You can add or edit the

same types of information as for applications added from the CSID.

4. Click OK.

The application is now included in the list of configured license units in CAM Administrator.

Note: This procedure affects only the configuration of applications in your environment. It does not
impact the Cherwell Software Identification Database (CSID) used to automatically configure
applications.
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How to Automatically Configure Applications
You can configure applications into license units so that you can report on them.

Note: This procedure applies to Windows applications.

To automatically configure license units:

1. From the Tools menu, select Automatically Configure Applications.

2. In the dialog box that opens, decide whether you want only exact match files configured into
license units, or if you also want to include close match files.

Exact match files are those that exactly match the file name and file size of known applications in
the Cherwell Software Identification Database (CSID). Close match files may have the same file
name as a known application, but the file size may be slightly different.

3. Click Yes to begin the automatic configuration process. This may take a few moments to complete.

Running this automatic configuration feature when you first start using the product is recommended, and
this process should find and properly configure most, if not all, of the applications you want to monitor.

Related information
../admin_license_units_suites_applications/Admin_About_auto-identifying_applications.xml#concept1898
Admin_How_to_configure_Mac_OS_applications.xml#concept1308
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How to Configure a Concurrent Application
A concurrent application is an application for which you have a concurrent use license.

To specify a concurrent application:

1. In the License Units panel, select the license unit that contains the application.

2. Right-click your selection, then select Properties.

3. In the General tab of the License Unit Properties dialog box, select theConcurrent from the
Licensing drop-down list.

4. Optional but recommended: Use Purchasing to enter information about the number of licenses your
organization owns, the price paid, and so on.

You can click the Purchasing tab to view the basic information you entered or, if you are not licensed
to use Purchasing, you can enter some purchasing information here. Without purchasing
information, compliance with your licensing agreements cannot be properly determined.

5. Optional but recommended: Click the Control tab to assign a control profile to control use of this
license unit. You will usually want to control or at least monitor use of applications that are under a
concurrent licensing agreement.

6. Click OK.

Related information
../admin_control/Admin_About_authentication_profiles.xml#concept1614
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How to Configure Idle Time Options
Idle time is the period of time that an application is running, but not in use, on a machine.

To configure idle time options for an application:

1. If you haven't already done so, enable metering on the license unit that contains the application:
◦ Right-click the license unit, point to Enable Metering, then click Yes.

2. Optional: If you want to configure the application as concurrently licensed, see How to Configure a
Concurrent Application.

Note: Although the application does not have to be concurrently licensed in order to specify
idle time options, selecting Only when user is waiting and applying it to a non-concurrent
application ignores all idle time options because users cannot wait for a non-concurrent
application.

3. Determine whether you want to use one of the predefined control profiles that include idle time
options, or create a new control profile.

◦ If the application is a concurrent application, you can use one of these two predefined control
profiles:

◦ Prevent Concurrent Idle Time: Use the default idle time options.

◦ Prevent Concurrent Idle Time w/Wait List: Allows users to place themselves on a wait
list.

◦ If you're creating a new control profile, use the options in the Authorization and Idle Time tabs
of the New Control Profile dialog box.

For example, if you want to discourage users from keeping an application open and unused on
their desktops, you could allow everyone to use the application in the Authorization tab, then
go to the Idle Time tab to set the number of minutes an application can be idle before a user
receives a warning message.

4. Apply the control profile to the license unit that contains the application:
a. Right-click the license unit, then select Properties.

b. In the license unit's Properties dialog box, select the Control tab.

c. Select Use control profile, then select the appropriate profile from the drop-down list.

d. Click OK.

Related information
../admin_control/Admin_Overview_Idle_time.xml#concept2296
../admin_control/Admin_Predefined_authentication_profiles.xml#concept2375
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How to Configure Linux, Unix, and Mac OS
Applications

Once Linux, Unix, and Mac OS applications are discovered, they can be configured into license units so
that you can report on them.

Machines with older Mac OS systems installed on them can be discovered via the inventory process, then
configured into license units and reported on.

Note: You can configure all applications on a given platform at once, but it's recommended that
you only configure the applications you want to track.

To configure applications:

1. In the Unconfigured Applications panel, move any applications you don't want to track to the
Don't configure folder.

2. Once you are satisfied with the list of applications for each platform, right-click the Linux, Unix, or
Mac OS folder, then select Automatically Configure.

Tip: To configure only certain applications, select the application(s), right-click, then select
Automatically Configure.

Related information
../admin_discovery/Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
Admin_How_to_collect_inventory_data_from_Mac_OS_machines.xml#concept1543
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How to Create a New Control Profile
A control profile defines how access to an application is controlled.

To create a new control profile:

1. From the File menu, click New Control Profile.

2. In the General tab of the New Control Profile dialog box, type a name and, optionally, a description
for the profile.

3. Select the Authorization tab. This is where you specify who will be allowed or denied access to
applications when this control profile is applied.

4. Select an item from the Authorization list:
◦ Everyone is authorized

◦ No one is authorized

◦ Selected users and machines are authorized

◦ Selected users and machines are NOT authorized

5. If you selected the third or fourth option in the previous step, click Add Users or Add Machines to
specifically include or exclude users or machines in the profile.

6. In the If an application is not authorized or licensed section, specify what happens when users
attempt to launch applications they are not authorized to run, or when all available licenses are in
use. By default, users are prevented from launching the application.

7. Optional: If you want users to be able to put themselves on a wait list for when a license becomes
available, check the Allow user to request notification when concurrent license is available
check box.

8. In the bottom section of this tab, specify whether CAM should shut down unauthorized launches
gracefully or immediately kill the process.

9. Optional: Click the Idle Time tab if you want to set up options for handling applications that are left
open and unused.

10. When you're satisfied with your settings, click OK.

You can now apply this profile to specific license units.

To create a new control profile from the Control tab of the License Unit Properties dialog box:

• From the Control tab, select Use control profile, click New, then follow the steps above.

Related information
../admin_control/Admin_About_authentication_profiles.xml#concept1614
../admin_control/Admin_Overview_Wait_list.xml#concept1878
Admin_How_to_apply_an_authorization_profile_to_a_license_unit.xml#concept1168
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How to Meter Suite Applications Separately
To meter applications that are part of a suite separately:

1. Select Tools > Options .

2. Click the Advanced tab.

3. Select the Meter suite applications individually check box.

4. Click OK.

Notes:

• This is a global option, so when you mark this box, you are specifying that all applications contained
in suites for which you have enabled metering, are metered separately.

• When you select this option, previously hidden CAM System License Units may now be visible in
the License Units panel. (For example, if only Microsoft Office was visible in the License Units panel,
selecting this option makes the applications that make up Microsoft Office visible as well.)

• You must enable metering for the individual license units, and set other license unit properties (such
as license allocation settings) appropriately.

• Usage reports will show information on the individual applications, but inventory reports will show
only suite information.

Related information
../admin_license_units_suites_applications/Admin_Overview_System_License_Units.xml#concept1468
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How to Separate an Application from its License
Unit

To monitor an application separately from the license unit in which it's contained:

1. In the left pane of the License Units panel, find the license unit that contains the application. If the
license unit contains more than one application, expand the license unit by clicking the plus (+) sign
next to its folder.

2. Click the license unit or suite.

3. Right-click an application and select Convert to License Unit from the context-sensitive menu.

4. In the Convert to License Unit dialog box, specify which option best suits your needs for the selected
application:

◦ Move the selected application(s) into a new license unit

Example use: You have two different version numbers of an application and want to monitor
them separately.

◦ Move the selected application(s) into an existing license unit

Example use: You have one or more versions of an application that you want to track
separately within the same license unit.

◦ Copy the selected Windows application(s) into a new license unit

Example use: You want to distinguish a Windows application from other installations by putting
it in its own license unit and assigning it a GUID.

◦ Copy the selected Windows application(s) into an existing license unit

Example use: You want to distinguish a Windows application from other installations by putting
it in an existing license unit and assigning it a GUID.

Click Help for more information on how each option works.

5. Click OK to open another dialog box, where you'll enter the necessary information to convert the
selected application to a license unit.

Note: Which dialog box opens is dictated by the option you chose in the Convert to
License Unit dialog box.

6. Click OK.

Related information
../admin_license_units_suites_applications/
Admin_About_license_units_suites_and_applications.xml#concept1660
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How to Specify That You Don't Want to Configure
an Application

If you know you don't want to configure an application into a license unit, you can move it to the Don't
configure folder so you won't be prompted again to take action:

1. In the Unconfigured Applications panel, select the application.

2. Drag it to the Don't configure folder in the left pane.
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How to Tell if a User or Machine Can't Use an
Application

To find out if a user or machine can't access an application:

1. From the Users or Machines panel, locate the user or machine you want to check.

2. Right-click the user or machine in question and select Properties.

3. In the User or Machine Properties dialog box, select the Authorization tab.

If there are any license units that the user or machine cannot use because the system administrator
applied a control profile to the application's license unit that restricts the selected user or machine, they
are displayed in the information panel.

Related information
../admin_control/Admin_About_authentication_profiles.xml#concept1614
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Assets
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How to Add an Asset
To add an asset:

1. Select File > New Asset.
2. In the General tab of the New Asset dialog box, enter a name for the asset.

3. Optional: Enter a serial number that is different than the serial number of any other asset with this
same name.

4. Optional: Enter information in the other fields to further identify the asset.

5. Optional: If you defined custom fields for assets, click the User-defined tab to fill in those fields.

6. Click OK.

You can also use the Asset Import Wizard to import asset information from an Excel spreadsheet.
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How to Add an Asset Manufacturer
You can add an asset manufacturer while you are adding an asset:

1. From the File menu in CAM Administrator, click New Asset.
2. In the New Asset dialog box, enter the name of the asset and fill in any other fields as needed.

3. Click Manufacturers.

4. In the Manufacturers dialog box, click New.

5. In the New Manufacturer dialog box, enter the manufacturer's name and then fill in as many of the
other fields as you need to be able to identify the manufacturer.

6. Click OK.

7. Back in the Manufacturers dialog box, click OK to save the information.

The manufacturer you just added will now be available to select whenever you add or modify an
asset.
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How to Add an Asset Type
You can add an asset type either while you're adding an asset, or in the Asset Types tab of the Asset
Template dialog box.

Add an Asset Type While Adding an Asset

1. From the File menu in CAM Administrator, click New Asset.
2. In the New Asset dialog box, enter the name of the asset and fill in any other fields as needed.

3. Click Asset Types
- or -

Select New from the Asset type drop-down list, which lets you skip the next step.

4. In the Asset Types dialog box, click New.

5. In the New Asset Type dialog box, type a name for the asset type and click OK.

6. Back in the Asset Types tab, click OK to save the information. The asset type you just added will
now be available to select whenever you add or modify an asset.

Add an Asset from the Asset Template Dialog Box

1. From the Tools menu in CAM Administrator, select Template > Asset.
2. Click the Asset Types tab.

3. Click New.

4. In the New Asset Type dialog box, type a name for the asset type and click OK.

5. Back in the Asset Types tab, click OK to save the information. The asset type you just added will
now be available to select whenever you add or modify an asset.
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How to Create an Asset Group
Asset groups are collections of assets (user-defined devices other than the machines that are found
during discovery) that you define. Asset groups are used to organize your assets and for filtering in
reports.

To create an asset group:

1. From the Other Assets panel, select the File menu.

Point to New Group and click Asset.

Tip: If the Asset option is dimmed when you point to New Group, click  Other Assets in
the left pane of the panel and try again.  

2. In the New Asset Group dialog box, enter the name of the new group and click OK.

The new group appears in the Other Assets panel, below the Deleted assets folder. If you selected an
existing user-added group before opening the New Asset Group dialog box, the new group will be created
as a subgroup of the selected group. You can also create a group by right-clicking on Other assets (at the
top of the tree) or on an existing assets group, then selecting New Group.

To add assets to this group:

• Select the assets in the right pane and drag them to the group in the left pane.
- or -

• Right-click on a machine to open the New Asset dialog box, then in the Member Of tab, click Add.

Related information
../admin_other_assets/Admin_Overview_Asset_groups.xml#concept960

431

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overview_Asset_groups


How to Create Custom Asset Data Fields
To create custom asset data fields:

1. Select Tools > Template > Asset.
2. In the Custom Asset Data tab, click New.

3. Enter a label (name) for your new field, as well as a description and type, then click OK.

4. Back in the Custom Asset Data tab, you can click New to add another custom field, or use the arrow
buttons to change the order in which the custom fields will appear. Once you are satisfied with the
custom fields, click OK to save them.

5. The custom fields you just created will now appear in the User-defined tab of the New Asset/Asset
Properties dialog box. You can fill in the fields you created whenever you add or modify an asset.
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How to Delete an Asset
To delete an asset, do one of the following in the Other Assets panel:

• Select the asset(s), right-click your selection, and click Delete Asset.
• Select the asset(s) and press Delete.

• Move the asset(s) to the Deleted assets folder in the left pane.

• Select the asset(s) and select Edit > Delete.

The asset(s) you deleted now appear in the Deleted assets folder.

You can permanently remove assets from the Deleted assets folder by selecting them and pressing
Delete, or by right-clicking your selection and clicking Delete. You can also right-click the Deleted assets
folder and click Empty "Deleted assets" folder to permanently remove all deleted assets.

By default, you are prompted to confirm the permanent delete action. You can turn off this confirmation
option by marking the check box in the dialog box that displays the prompt, or in the Warnings tab of the
Options dialog box.
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How to Delete an Asset Type
You can delete an asset type in these ways:

• In the Other Assets panel

• In the Asset Types tab of the Asset Template dialog box

• While you are adding an asset

In the Other Assets Panel

1. Find the asset type you want to delete in the left pane.

2. Right-click it and select Delete from the context-sensitive menu.

From the Asset Template Dialog Box

1. Select Tools > Template > Asset.
2. Click the Asset Types tab.

3. Select an asset type from the list, then click Delete.

4. Click OK.

While Adding an Asset

1. Select File > New Asset.
2. In the New Asset dialog box, enter the name of the asset and fill in any other fields as needed.

3. Click Asset Types.

4. Select an asset type from the list, then click Delete.

5. Click OK.

6. Back in the New Asset dialog box, click OK again.

Notes:

• You can turn off the delete confirmation prompt by selecting the check box in the dialog box that
displays the prompt, or in the Warnings tab of the Options dialog box.

• Any assets of the type you just deleted revert to the asset type of <Unknown>. You cannot delete
the <Unknown> type.
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How to Delete Custom Asset Data Fields
To delete a custom asset data field:

1. Select Tools > Template > Asset.
2. In the Custom Asset Data tab, select an item from the list and click Delete.

3. Click OK.
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How to Modify an Asset
To modify an asset:

1. Select the asset you want to modify.

2. Right-click on your selection and select Properties.

3. Enter or modify your entries for any of the fields in the General, User-defined, or Member Of tabs.

4. Click OK.

Tip: To quickly assign an asset type or manufacturer to an asset, select the asset in the right pane
and then drag it to the asset type or manufacturer.
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How to Rename an Asset Manufacturer
You can rename an asset manufacturer in the following ways:

• In the Other Assets panel

• While you are adding an asset

Note: With this method, you can also edit a manufacturer's information (address, phone
number, etc.).

In the Other Assets Panel

1. In the left pane, find the manufacturer you want to rename.

2. Right-click it and click Rename.

3. Enter the new name.

While Adding an Asset

1. Select File > New Asset.
2. In the New Asset dialog box, enter the name of the asset and other fields as needed.

3. Click Manufacturers.

4. Select a manufacturer from the list and click Change.

5. Type the new name for this manufacturer, and edit information in the other fields as needed.

6. Click OK.

7. Click OK until you exit the New Asset dialog box. The renamed manufacturer will be available for
you to select whenever you add or modify an asset.

Note: You cannot rename the <Unknown> manufacturer.
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How to Rename an Asset Type
You can rename an asset type in the following ways:

• In the Other Assets panel

• From the Asset Template dialog box

• While adding an asset

In the Other Assets Panel

1. In the left pane, find the asset type you want to rename.

2. Right-click it and select Rename.

3. Enter the new name.

From the Asset Template Dialog Box

1. Select Tools > Template > Asset.
2. Select the Asset Types tab.

3. Select an asset type from the list and click Rename.

4. Type the new name for this asset type over the previous name (the previous name is highlighted
and boxed).

5. Click OK.
The renamed asset type will be available for you to select whenever you add or modify an asset.

While Adding an Asset

1. Select File > New Asset.
2. In the New Asset dialog box, enter the name of the asset and other fields as needed.

3. Click Asset Types.

4. Select an asset type from the list and click Rename.

5. Type the new name for this asset type over the previous name (the previous name is highlighted
and boxed).

6. Click OK.
This renamed asset type will be available for you to select whenever you add or modify an asset.

Note: You cannot rename the <Unknown> asset type.
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How to Restore a Deleted Asset
To restore a deleted asset, do one of the following in the Other Assets panel:

• Select the asset(s) from the Deleted assets folder, right-click your selection, and click Restore.

• Move the asset(s) out of the Deleted assets folder.

• Select the asset(s) from the Deleted assets folder and click Edit > Restore.

Any restored assets are now listed in the Full list folder. Its properties and group memberships are also
restored.

Note: You can only restore a deleted asset that still appears in the Deleted assets folder. If you
permanently deleted it (removed it from this list), you cannot restore it using this method.
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CAM Agent
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How to Cancel an Agent Installation
Cancelling an agent install, uninstall, or upgrade will only affect pending operations; operations already in
progress cannot be cancelled.

To cancel a CAM Agent installation on a machine:

1. From the Machines panel, select the machines on which to cancel the CAM Agent installation.

2. Right-click and select Cancel Pending (Un)install/Upgrade.
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How to Enable SSL Communications
This topic applies to on-premises installations.

Follow the procedure below if your access point's website uses an SSL certificate not signed by a
common Certificate Authority. This will ensure that each machine on which the CAM Agent is installed
trusts the certificate.

To enable machines to communicate over SSL:

1. Configure Internet Information Service (IIS) on the access point machine to support SSL. This
involves obtaining a server certificate and installing it in IIS; see your IIS documentation for details.

2. Register the access point using https in the address, using the same name that is in the certificate.

If you don't use the same name, the server name used by the agent will not match the name in the
SSL certificate and the connection will fail. For example, if the web server certificate is issued to
cam.example.com, register the access point using https://cam.example.com/etc.

3. Ensure that the web server certificate is trusted by the CAM Administration Service machine, so the
CAM Administration Service can test access point availability.

4. Ensure that the web server certificate is trusted by machines that will use the https access point.

5. Install the CAM Agent and specify the https access point.

Notes:

• If you use a certificate from a common Certificate Authority, you can skip steps 3 and 4, as
machines should already trust certificates signed by VeriSign, Thawte, Entrust, and so on.

• If your organization uses a certificate it signs, you are probably already aware of the issues of
getting machines to trust that certificate. In steps 3 and 4, above, it's recommended that the root
certificate for the web server's certificate be installed in the Trusted Root Certificate Authorities store
for the local computer.
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How to Install the CAM Agent by Machine Name or
IP Address

There may be cases in which you want to install the CAM Agent on a single Windows machine using its
machine name or IP Address.

This procedure applies to Windows machines only.

To install or update the CAM Agent on a single Windows machine using its machine name or IP
address:

1. Select Machine > Install/Update > CAM Agent > Single Machine.

2. In the Install/Update Agent to Single Machine dialog box, type the machine's name or IP address.

3. Specify the access point to which the selected machine will report.

4. If you are updating the CAM Agent, select the Overwrite existing installations check box.
Otherwise, leave the check box unchecked.

5. Enter the administrative credentials for the machine: the full user name, password, and domain or
machine.

6. If the machine communicates through a proxy server, select the Save proxy settings to agent
machine check box, and complete the related options.

7. Click Install.

Notes:

• Consider enabling machines to use the self-upgrade feature.

• The process for updating the CAM Agent is mostly the same as that for installing the CAM Agent for
the first time. The main difference is that when updating, you should check the Overwrite existing
installations option.

Related concepts
Agent Self-upgrade Feature
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How to Install the CAM Agent Using a Batch File or
Script

In order to gather information from Windows computers on your network, the collection of components
called the CAM Agent must be installed. You can install it manually, or you can use a batch file or script.

Install the CAM Agent Using a Batch File or Script
The information in this topic applies to Windows machines only.

In order to install the agent via a batch file or script where no previous version of the agent is installed, the
CAM Agent MSI file must be available. The client.msi file is available on the machine on which the CAM
Administration Service is installed. By default, the folder is in one of the following locations:

• On 32-bit systems:

C:\Program Files\Cherwell Asset Management\CAM Administrator\ClientInst
allPackage

• On 64-bit systems:

C:\Program Files (x86)\Cherwell Asset Management\CAM Administrator\Clie
ntInstallPackage

Note: You must have local administrative rights in order to install and uninstall the CAM Agent.
Typically, a domain administrator has local administrator rights on all computers.

To proceed, find the folder and complete the following:

1. Copy the ClientInstallPackage folder to a shared location where the installation will run.

2. Create a batch file or script with the appropriate agent installation syntax. The following steps
contain the syntax to use, followed by an example. Note that the entire syntax consists of one long
command typed on one line; do not enter any line breaks.

a. For on-premises installations:
Syntax for a batch file or script (version 12.2 and later):

msiexec.exe –i "<folder-containing-client-msi-file>\express softwar
e manager client.msi" /qn ESMWEBSERVICE=http://<access-point-machin
e>/camaccesspoint/clientservices.asmx

Example batch file or script syntax (version 12.2 and later):
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msiexec.exe –i "\\myserver\myshare\express_client\express software 
manager client.msi" /qn ESMWEBSERVICE=http://myiisbox/camaccesspoin
t/clientservices.asmx

Where myiisbox is the name of the CAM Access Point machine and http://myiisbox/
camaccesspoint/clientservices.asmx is the CAM Access Point URL.

b. For hosted installations:
Syntax for batch file or script:

msiexec.exe –i "<folder-containing-client-msi-file>\express softwar
e manager client.msi" /qn ESMWEBSERVICE=http://<ap-proxy-machine>:<
proxy port>/EMCServices/clientservices.asmx

Example batch file or script syntax:

msiexec.exe –i "\\myserver\myshare\express_client\express software 
manager client.msi" /qn ESMWEBSERVICE=http://myproxybox:5002/EMCSer
vices/clientservices.asmx

Where myproxybox is the name of the CAM Access Point proxy machine and 5002 is the
proxy port, and the following is the CAM Access Point URL:

http://myproxybox:5002/EMCServices/clientservices.asmx

Note: For machines that have UAC enabled, you cannot use the MSI file to manually install the
agent. Instead, manually run Setup.exe and explicitly choose Run as administrator.

Uninstalling the CAM Agent Using a Batch File or Script
Create a batch file or script with the appropriate syntax to uninstall the agent. The syntax to uninstall the
agent is as follows:  

msiexec /q /x {04F73471-157F-4F63-A2AD-50C1BBEECD66}

Note: You must have local administrative rights in order to uninstall the CAM Agent. Typically, a
domain administrator has local administrator rights on all computers.
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Upgrading the CAM Agent Using a Batch File or Script
The recommended method for upgrading the CAM Agent is to uninstall the currently running version and
install the new one. The steps required for each of these operations are described above. If you only want
to upgrade an earlier version of the agent, check the agent's version number prior to uninstalling and
reinstalling. The version of the CAM Agent is the value of the DisplayVersion key in this folder in the
Windows Registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{04F
73471-157F-4F63-A2AD-50C1BBEECD66}

A script that uses the Windows Scripting Host will allow you to make this Registry check, and then
upgrade the agent only if there is a newer version available.

446

CAM 14.2 Administrator

CAM 14.2 Administrator



How to Install or Update the CAM Agent to
Machines Listed in the Machines Panel

If you already have machines listed in the Machines panel, you can install or update the CAM Agent from
the context-sensitive menu.

This procedure applies to Windows machines only.

To install or update theCAM Agent from the Machines panel:

1. In the Machines panel, select the machine or machines on which you want to install the agent.

2. Right-click and select Install/Update CAM Agent.
3. In the dialog box, select which CAM Access Point these agents should report to from the drop-down

list.

4. If you are updating the CAM Agent, select the Overwrite existing installations check box.
Otherwise, keep the Overwrite existing installations check box unchecked.

5. Enter the appropriate credentials for installing the agent: the full user name, password, and domain
or machine.

6. If the machine communicates through a proxy server, mark the Save proxy settings to agent
machine box, and complete the related options.

7. Click Install.

The status bar at the bottom right of the window will display a message when the process is complete.
Click F5 to refresh the Machines panel.

Tips:

• If you are updating the CAM Agent, you can sort machines based on the version of the agent
software installed by clicking the Install Status column in the Machines panel.

• Consider enabling machines to use the self-upgrade feature.

Related concepts
Overwrite Existing Installations Option
Proxy Server Environments
Proxy Server Issues
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How to Install or Update the CAM Agent to Multiple
Machines by IP Address

You can easily install or update the CAM Agent on multiple machines using their IP addresses.

This procedure applies to Windows machines only.

To install or update the CAM Agent on multiple machines by IP address:

1. Select Machine > Install/Update CAM Agent > Multiple IP Addresses.

2. In the Install Agent to Multiple IP Addresses dialog box, enter the IP address subnet in the boxes at
the bottom of the dialog box. (The fourth box acts as a wildcard, so that all IP addresses in the
specified subnet are shown when you click Display.)
In most cases, you should keep the Perform DNS lookup check box checked, so you can see a list
of IP addresses with their associated machine names for machines that respond to an IP address
inquiry. If you uncheck this check box, only the IP addresses are shown.

3. Click Display.

4. Select the machines on which to install the CAM Agent.

5. Click Install.
6. In the Install/Update CAM Agent dialog box, specify the access point to which these machines

should report.

7. If you are updating the CAM Agent, select the Overwrite existing installations check box. In most
other cases, keep the Overwrite existing installations check box unchecked.

8. Enter login credentials required to install the agent: the full user name, password, and domain or
machine.

9. If the machine communicates through a proxy server, select the Save proxy settings to agent
machine check box, and complete the related options.

10. Click Install.

Notes

• The process for updating the CAM Agent is generally the same as installing it for the first time. The
main difference is that when updating, you should check the Overwrite existing installations
option.

• Consider enabling machines to use the self-upgrade feature.

Related concepts
Overwrite Existing Installations Option
Proxy Server Environments
Proxy Server Issues
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How to Manually Install, Uninstall, or Upgrade the
CAM Agent

There may be cases in which you do not want to install the CAM Agent on Windows machines from CAM
Administrator (for example, if you have machines that are not connected to the network).

The information in this topic applies to Windows machines only.

Note: You must have local administrative rights in order to install or uninstall the CAM Agent.
Typically, a domain administrator has local administrator rights on all computers.

To install the agent manually (where no previous version of the agent is installed), the CAM Agent MSI file
must be available. This file is located on the machine on which the CAM Administration Service is
installed. By default, it is in one of the following folders:

• On 32-bit machines:

C:\Program Files\Cherwell Asset Management\CAM Administrator\ClientInst
allPackage

• On 64-bit machines:

C:\Program Files (x86)\Cherwell Asset Management\CAM Administrator\Clie
ntInstallPackage

Manually Install the Agent
After you find the CAM Agent MSI file, manually install the agent:

1. Copy the ClientInstallPackage folder to a shared location where the Setup program will run.

2. Run the Express Software Manager Client.msi file as an administrator.

3. Enter the Access Point URL to which the agent will report.
For on-premises installations, the format for the CAM Access Point URL is:

http://<ap-machine>/camaccesspoint/clientservices.asmx

(version 12.2 and later)

http://<ap-machine>/expresssoftwaremanagerap/clientservices.asmx

(earlier versions and upgrades)
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Note: <ap-machine> is where the CAM Access Point is installed.

For hosted installations, the format for the CAM Access Point proxy URL is:

http://<ap-proxy-machine>:<proxy port>/EMCServices/clientservices.asmx

Note: <ap-proxy-machine> is where the proxy is installed; the default <proxy port> is
5002.

4. Select Complete to install the agent.

Note: For machines that have UAC enabled, you cannot use the MSI file to manually install the
agent. Instead, you'll need to manually run Setup.exe and explicitly choose Run as
administrator.

Manually Uninstall the Agent
You must have local administrative rights in order to uninstall the agent. Typically, a domain administrator
has local administrator rights on all machines.

To manually uninstall the agent:

msiexec /x {04F73471-157F-4F63-A2AD-50C1BBEECD66}

To run this command silently:

msiexec /q /x {04F73471-157F-4F63-A2AD-50C1BBEECD66}

Manually Upgrade the CAM Agent
To manually upgrade the agent, first manually uninstall the agent, then manually install the agent as
described above.

Tip: Consider enabling machines to use the self-upgrade feature. This is the most efficient way to
keep these machines up-to-date with the most recent version of the CAM Agent.
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How to Set Up the Agent Self-upgrade Feature
You can specify that machines self-upgrade, which means they receive new versions of the Windows
CAM Agent software at the next heartbeat, if the package in the specified share folder is newer than what
is currently installed.

Note: The information in this topic applies to Windows machines only.

Setting up the self-upgrade feature for the first time is a three-part process.

Part 1. Prepare a Network Share Location for the Agent Upgrade Files

1. Create the network share location.

2. Grant read access to the share to Everyone, and full access to the administrator (the user who will
run the script mentioned below, or manually copy the files to the share).

3. Run the provided script, which copies the necessary files to the share you specify when prompted.
By default, the script is located here:

◦ On 32-bit machines: C:\Program Files\Cherwell Asset Management\CAM
Administrator\ClientInstallPackage\Windows
\AutoUpgrade_CopyClientPackage.wsf

◦ On 64-bit machines: C:\Program Files (x86)\Cherwell Asset Management\CAM
Administrator\ClientInstallPackage\Windows
\AutoUpgrade_CopyClientPackage.wsf

Part 2. In CAM Administrator, Point to the Share

1. Select Machine > Agent Options.

2. Select the Self-upgrade tab.

3. Enter the location of the share. You can enter a UNC or a mapped drive that is accessible to
machines.

4. Click OK.

Part 3. Specify Which Machines Should Self-upgrade

1. In the Machines panel, select which machines should self-upgrade.

2. Right-click your selection(s), then click Enable Agent Self-upgrade.

3. Select the location of the share, then click Enable Upgrade.
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What Happens Next on the Machines?
At the next heartbeat after a newer version of the CAM Agent software is available in the share, eligible
agent(s) upgrade to that version.

Note: Any eligible machines that are powered off when an upgrade becomes available are
upgraded the second time they check in with their access points after being powered on. (This
check-in process is called the heartbeat rate, and you can configure it in the Advanced tab of the
Agent Options dialog box.)

You can cancel a pending self-upgrade only if the upgrade hasn't started yet. Right-click the machine,
then click Cancel Pending (Un)install/Upgrade.

What About Adding New Machines?
When new machines are added to your network, or if you want to implement the self-upgrade feature on
more existing machines, follow the instructions in Part 3 above.

What Should I Do When I Update or Upgrade the CAM Agent Software?
When you receive an update or upgrade of the CAM Agent software, copy the agent upgrade files to the
network share, as described in Part 1 above. Next, re-enable self-upgrades on the machines to upgrade.

Related concepts
Agent Self-upgrade Feature
Updating vs. Upgrading
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How to Uninstall the CAM Agent from Machines
This procedure applies to Windows machines only.

To uninstall the CAM Agent from the selected machine(s):

1. Once you have selected one or more machines, right-click and select Uninstall CAM Agent from
the context-sensitive menu.

2. In the Uninstall CAM Agent dialog box, enter the user name and password that were required when
you installed the agent: the user name, password, and domain (or machine).

3. Click Uninstall.

This machine will show up in the Machines panel the next time the view is refreshed, with its status listed
as Not installed.
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How to Encrypt Database Connection Strings
CAM provides a file that can be run by system administrators to encrypt database connection strings in
the web application configuration files.

The system administrator can encrypt database connection strings in several web application
configuration files, including those used in Purchasing, License Analytics, Reporting, and the CAM Access
Point, as well as other configuration files used for data retrieval functions.

The program uses the local machine's certificate to encrypt the credentials.

Notes:

• You must have Administrator privileges to install the program and encrypt or decrypt files.

• You can run Encryptwebconfigs.exe -help to see a list of possible commands.

Install the Tool

1. Contact Cherwell Support to obtain the file.

2. Copy it to the C:\Program Files(x86)\Cherwell Asset Management\CAM Web directory.

3. Run C:\Program Files(x86)\Cherwell Asset Management\CAM Web
\EncryptWebConfigs.msi to install the program.

Note: The MSI file runs, but does not provide additional feedback.

4. Go to the following location to verify the installation was successful:
C:\Program Files (x86)\Cherwell Asset Management\CAM Web\Encrypt Web
Configs

Encrypt Web Application Configuration Files
The following commands encrypt the CAM web applications installed and configured with IIS on a single
web server. If CAM web applications are installed on multiple web servers, the commands must be run on
each web server.

1. Open a command prompt as an Administrator.

2. Change the directory to C:\Program Files (x86)\Cherwell Asset Management\CAM Web
\Encrypt Web Configs

3. Run the following command to display all the files the tool is going to encrypt, without actually
encrypting them:
Encryptwebconfigs.exe -dryrun

4. Run the following command to encrypt the files:
Encryptwebconfigs.exe -encrypt

455

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Contacting_support


Decrypt Web Application Configuration Files

1. Open a command prompt as an Administrator.

2. Change the directory toC:\Program Files (x86)\Cherwell Asset Management\CAM Web
\Encrypt Web Configs

3. Run the following command to display all the files the tool is going to decrypt, without actually
decrypting them:
Encryptwebconfigs.exe -dryrun

4. Run the following command to decrypt the files:
Encryptwebconfigs.exe -decrypt

Update the Database Server's Connection Details

1. Open a command prompt as an Administrator.

2. Change the directory to C:\Program Files (x86)\Cherwell Asset Management\CAM Web
\Encrypt Web Configs

3. Run the following command to show all the files and values that will change, without actually making
the changes:
Encryptwebconfigs.exe -dryrun -server=servername -database=databasename -
username=username -password=password

Note: This command can be run for any combination of values. If a value is not specified in
the command line, it's assumed the value will stay the same.

4. Run the command without the dryrun:
Encryptwebconfigs.exe -server=servername -database=databasename -
username=username -password=password
If the connection string is not already encrypted, this command automatically encrypts the string at
the same time.

If you want the Connection String to remain unencrypted, run the following command:
Encryptwebconfigs.exe -decrypt

Uninstall the Program
Uninstalling the program does not decrypt the files; it only removes the program from the server. If you
need to later decrypt the files or change the database, reinstall the program.

1. Open your Control Panel, then select Programs > Programs & Features > Uninstall or change a
program, then find and select Cherwell Asset Management Credential Encryption Tool.

Note: Your path in the Control Panel may vary, depending on your version of Windows.

2. Select Uninstall.
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How to Install the CAM Database
This topic applies to on-premises installations.

The CAM Database is installed when you run the Cherwell Asset Management Setup program on your
SQL Server machine and select the appropriate Setup options. You should first determine whether to
install only the database on the server machine, or to install the other Cherwell Asset Management
components as well.

To install the CAM Database:

1. Run camsetup.exe from your SQL Server machine. Verify that SQL Server is installed and continue.

2. In the Feature Selection screen of the Setup program, make sure the CAM Database is selected, as
well as any other Cherwell Asset Management components you want to install on the current
machine.

3. Continue with the Setup program until finished.

4. If you're installing the other components on another machine, run Setup from that machine and in
the Feature Selection screen, clear the CAM Database option.  

Once the CAM Database is installed, you can select it from the CAM Database dialog box in CAM
Administrator to connect to it.

Note: Initialization of the CAM Database requires that the Microsoft .NET Framework is installed.
If your database server machine is not running .NET or if you do not have authorization to run
Setup directly on the database machine, you can install the tools required to create and initialize
the CAM Database on your local machine and run them against a remote machine. To do this,
choose Remote Database Install from the initial setup screen. After the tools are installed, read
RemoteCAMDatabase.txt for further information about performing a remote database installation.
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How to Contribute to the CSID
You can search for applications not currently included in the Cherwell Software Identification Database
(CSID), and send them to Cherwell Software for possible future inclusion in the CSID.

You cannot directly change your local copy of the Cherwell Software Identification Database (CSID). You
can run the CAM AppScanner utility to search for applications not already included in the CSID, to be
considered for possible inclusion in future versions of the CSID. The CAM AppScanner collects
information about application files on a selected machine in order to find applications that do not yet exist
in the CSID, and either sends the resulting file to Cherwell Software's CSID team via HTTPS, or saves the
file so that you can manually send it later.

To scan for applications:

1. Right-click the machine you want to scan and click Contribute to the CSID. (Alternatively, you can
select Contribute to the CSID from the Machines menu.)

2. In the Contribute to the CSID dialog box, enter your contact information in the Administrator's
information area: your name, company name, and an email address where you can be contacted.

3. Optional: Enter any comments, such as a particular application you'd like to see added to the CSID,
in the Comments text box.

4. To immediately send the file to Cherwell Software via HTTPS , leave the Send application scan file
later (manually) check box unchecked.
To manually send the file later, check this box. The application scan file is saved to the CAM
Administration Service machine. Each application scan file has a unique name, and you can send
the application scan file(s) you generate to csid@cherwell.com.

5. In the Credentials area of the dialog box, enter a user name, associated password, and name of the
machine or its domain. These credentials must be valid for the selected machine.

6. Click Start to run the CAM AppScanner. The status bar informs you when the scan completes.

Important: No personal, sensitive, or confidential information is sent when you run CAM
AppScanner. The only information sent is from the applications found during the scan. The
information you enter in this dialog box is only used to identify you, and to verify that you are
authorized to run the utility on the selected machine.

Note: You can "opt-in" to automatically send unrecognized applications directly to the CSID team.
Select Yes in the Do you want to enable automatic contribution to the Cherwell Software
Identification Database? dialog box.
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How to Create a New Software Category or Group
Software categories are used to group license units by function in the Cherwell Software Identification
Database (CSID), making it easier to find specific license units by function.

You can create a new software category or category group from any of the following:

• License Units panel

• License Unit Properties dialog box

• Software Categories tab of the License Unit Template dialog box

License Units Panel
To create a new software category group:

1. Right-click on the By category group folder in the panel's left pane, then select New Category
Group from the context-sensitive menu.

2. In the New Software Category Group dialog box, enter a name for the group and click OK.

To create a new software category:

1. Right-click on the software category group to which you want to add the new software category, then
click New Category from the context-sensitive menu.

2. In the New Software Category dialog box, enter a name for the category, then click OK. You can
also change the group to which this category belongs in this dialog box by selecting another group
from the list box.

License Units Properties Dialog Box
To create a new software category or group:

1. Select one or more license units, right-click on your selection, then select Properties from the
context-sensitive menu.

2. In the General tab of License Unit Properties dialog box, click Categories.

3. In the Software Categories dialog box, click New.

4. Select Category or Group.

5. Enter the category or group name in the dialog box that opens, and click OK.

6. Click OK twice more to exit all dialog boxes and save your changes.

Software Categories Tab of the License Unit Template Dialog Box
To create a new software category group:

1. Click New and select Group.
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2. In the New Software Category Group dialog box, enter a name for the group and click OK.

To create a new software category:

1. Click New and select Category.

Note: You can also select a group before you click New, to specify that the category will
belong to the selected group.

2. In the New Software Category dialog box, enter a name for the category, then in the list box, select
the group to which this category belongs.

3. Click OK.

After Creating a Software Category or Group Using Any Method
New groups are added, in alphabetical order, to the list of category groups in the left pane of the License
Units panel. Any new categories you create are added, in alphabetical order, to the list of categories
within their groups. Software categories and groups you add are also shown in the Software Categories
tab of the License Unit Template dialog box.

Software Categories and Groups
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How to Delete a Software Category or Group
You can delete software categories and groups using any of these methods:

• From the License Units panel

• From the License Unit Properties dialog box

• From the Software Categories tab of the License Unit Template dialog box

Each method is described here, and the effects of creating new categories and groups are also described.

Note that you can only delete user-created software categories and groups (those whose icons include a
"person").

From the License Units Panel

• Right-click on the category or group, and then click Delete from the context-sensitive menu.

From the License Units Properties Dialog Box

• Right-click one or more license units, and click Properties from the context-sensitive menu. Click the
Categories button to open the Software Categories dialog box. Select a category or group from the
list, and then click OK.

From the Software Categories Tab of the License Unit Template Dialog Box

• Select the category or group, and then click the Delete button. Click OK to exit the dialog box.

After Deleting a Software Category or Group Using Any Method
Deleted categories or groups are removed from the lists of categories and groups in the left pane of the
License Units panel, and from the list in the Software Categories tab of the License Unit Template dialog
box. Any license units that were in a deleted category still exist, but are not part of any category.

Related information
../cherwell_id_database/Admin_Overview_Software_categories.xml#concept1777
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How to Rename a Software Category or Group
To rename a software category or group, do the following:

1. In the License Units panel, select the software category or software category group.

2. Right-click your selection and click Rename.

3. Type in the new name for the category or group.

Notes:

• When you rename a software category or group, the new name appears in Cherwell Asset
Management, but the original names in the Cherwell Software Identification Database (CSID) are
unchanged.

• You can also rename a software category or group from the Software Categories dialog box or the
Software Categories tab of the License Unit Template dialog box by selecting an item from the list,
clicking the Change button, and then entering a new name.

464

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/bundle/cam_administrator_1420_help_only/page/cam_administrator%2Fadmin_how_to%2F..%2Fcherwell_id_database%2FAdmin_CSID_overview.html


Discovery

465

CAM 14.2 Administrator

CAM 14.2 Administrator



How to Discover Linux/Unix/Mac OS Machines
Linux/Unix/Mac OS discovery provides agentless inventory capabilities for supported non-Windows
systems. Once discovered, you can configure applications you want to track into license units, run
reports, and track purchasing information.

Configure Linux/Unix/Mac OS Discovery

1. From the Tools menu, select Discover, then click Linux/Unix/Mac OS.

2. In the Discover Linux/Unix/Mac OS dialog box, click Configure.

3. In the Configure Linux/Unix/Mac OS Discovery dialog box, click Add.

4. Enter information about where to look for Linux/Unix/Mac OS machines, then, depending on where
you want to look, click the appropriate option.
To query a range of IP addresses:

a. Click IP Address Range. This opens the Add Linux/Unix/Mac OS Discovery IP Address
Range dialog box.

b. Enter the start and end IP addresses for the range, and the required credentials. A username
is required, and you can enter either a password or a private key and passphrase.

To query a specific subnet of your network:
a. Click Subnet. This opens the Add Linux/Unix/Mac OS Discovery Subnet dialog box.

b. Enter the subnet address and mask to query, and the required credentials. A username is
required, and you can enter either a password or a private key and passphrase.

If you know the name or IP address of the machine(s) you want to discover:
a. Click Subnet. This opens the Add Linux/Unix/Mac OS Discovery Subnet dialog box.

b. Enter the subnet address and mask to query, and the required credentials. A username is
required, and you can enter either a password or a private key and passphrase.

5. Click Machine. This opens the Add Linux/Unix/Mac OS Discovery Machine(s) dialog box.

6. Enter the IP address or name of the machine(s) you want to discover, and the required credentials.
A username is required, and you can enter either a password or a private key and passphrase. Use
commas to separate multiple names or IP addresses.

7. Recommended: Click Test to make sure a connection can be established before proceeding.

8. Click OK to save your configuration and return to the Configure Linux/Unix/Mac OS Discovery dialog
box. The checkbox for the configuration you just entered is marked, which means these machines
will be discovered next time discovery or scheduled discovery runs.

Note: If you are configuring an IP address range or subnet, a dialog box opens to tell you
how many IP addresses this configuration will attempt to query.

9. Save your configuration by clicking Yes or, if the number of machines is not what you expect, click
No to return to the dialog box and make changes. Although querying a large number of machines
can take some time, it does not affect machine performance or the ability to run other tasks.
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10. Repeat steps 3 – 5 for any additional discovery configurations you want to add.

11. Click OK to return to the Discover Linux/Unix/Mac OS dialog box. Linux/Unix/Mac OS discovery
configuration is now complete and available to run, as described next.

Run Linux/Unix/Mac OS Discovery
You can run Linux/Unix/Mac OS discovery immediately after configuration by clicking Discover, or you
can run it later.

To run discovery later:

1. After completing the configuration steps above, click Close.

2. Select the Tools menu, then click Discover.
3. Click Linux/Unix/Mac OS Discovery, then click Discover.

The options you specified during configuration remain in effect until you change them, and all selected
processes listed in the Configure Linux/Unix/Mac OS Discovery dialog box are run when you click
Discover.
Once configured, the Linux/Unix/Mac OS discovery process automatically runs at 2:30 AM Pacific Time
each Sunday by default (unless you manually ran Linux/Unix/Mac OS discovery during a given week, in
which case the scheduled discovery is skipped for that week but will run the following week).

To turn off this scheduled task, select the Options dialog box, then the Schedule tab.

Change how frequently discovery runs through the Windows Task Scheduler by selecting Linux, Unix,
Mac OS Discovery under the Cherwell Asset Management node.

Tip: To view discovery status, return to the Configure Linux/Unix/Mac OS Discovery dialog box.

Post-discovery

• Once Linux/Unix/Mac OS discovery is complete, click F5 or Refresh from the View menu to view
the discovered machines.

• After discovering Linux, Unix, and Mac OS machines, see How to Configure Linux, Unix, and Mac
OS Applications for help with tracking applications on these platforms.

• For more help, see Troubleshooting Linux/Unix/Mac OS Discovery.
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How to Discover Machines and Users from Active
Directory or NT Domain

If you use Active Directory or NT domains in your network environment and the CAM Administration
Service machine is part of the Active Directory or domain, you can find named computers and users from
CAM Administrator.

To discover machines and users from Active Directory or NT domain:

1. From the Tools menu, point to Discover, then click Active Directory or NT Domain.

2. Specify whether to use Active Directory or NT Domain for the discovery. If you use Active Directory,
you can also restrict discovery to certain organizational units (OUs).

A message appears in the status bar when the discovery process is complete. Click F5 or Refresh from
the View menu to see the discovered machines and users.

Notes:

• In order to use discovery, you must use Active Directory or NT Domains on your network, and the
computer that runs the CAM Administration Service must be part of the Active Directory or NT
Domain on which discovery is to be performed.

• When you choose NT Domain discovery, the only machines that will be discovered are those in the
domain on the machine where CAM Administration Service resides.

• Once configured, the discovery process automatically runs at 1:00 AM each Sunday. To change this:
◦ In the Options dialog box, select the Schedule tab, then clear the check box.

◦ Change how frequently discovery runs through the Task Scheduler.

Related information
../admin_discovery/Admin_Overview_Discovery.xml#concept605
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How to Discover Network Devices
Network Device Discovery discovers SNMP-enabled network devices, such as routers, switches, and
printers, within your network.

First configure where to look for network devices, then run discovery.

Configure Network Device Discovery
To configure network device discovery:

1. From within CAM Administrator, select Tools > Discover > Network Devices.

2. In the Discover Network Devices dialog box, click Configure.

3. In the Configure Network Devices dialog box, click Add, then, depending on where you want to look,
click the appropriate option.

◦ To query a range of IP addresses, click IP Address Range. In the Add Network Device
Discovery IP Address Range dialog box, enter the start and end IP addresses for the range
you want to search, and specify the SNMP version.

◦ To query a specific subnet of your network, click Subnet. In the Add Network Device
Discovery Subnet dialog box, enter the subnet address and mask to query, and specify the
SNMP version.

◦ To discover IPv6 devices, or if you know the host name or IP address of a device(s) you want
to discover, click Device. In the Add Network Device Discovery Device(s) dialog box, enter the
IP address or name of the device(s) to discover. You can enter multiple names or IP
addresses by separating them with commas. Also, specify the SNMP version for the device(s).
 

4. Enter SNMP credentials.

5. Optional but recommended: Click Test to open the Test Device Discovery dialog box, where you can
check whether a connection can be established before proceeding.

6. Click OK to save your configuration and return to the Configure Network Device Discovery dialog
box.

Note: If you are configuring an IP address range or subnet, a dialog box opens to tell you
how many IP addresses this configuration will attempt to query. You have the option to save
your configuration by clicking Yes or, if the number of devices is not what you expect, click
No to return to the dialog box and make changes. Although querying a large number of
devices can take some time, it does not affect machine performance or the ability to run
other tasks.

7. Repeat steps 3 – 6 for any additional discovery configurations you want to add.

8. Click OK.

You can further configure network device discovery to collect additional network device properties. See
Related Content for more information.
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Once you have finished your configuration, you can run network device discovery, as described next.

Run Network Device Discovery
You can run network device discovery immediately after configuration, or later:

• To immediately run network device discovery, click Discover.
• To run it later, click Close. You can return to this dialog box any time you want to run network device

discovery. To do so:
1. Select Tools > Discover.
2. Click Network Devices.

3. Click Discover.

The options you specified during configuration remain in effect until you change them, and all selected
(checked) processes listed in the Configure Network Device Discovery dialog box are run when you click
Discover.
Tips:

• Once network device discovery is complete, click F5 or Refresh from the View menu to see the
discovered devices.

• Once configured, the network device discovery process automatically runs at 3:00 AM each Sunday
by default.

◦ To turn off this scheduled task, select the Options dialog box, then the Schedule tab.

• Change how frequently discovery runs through the Windows Task Scheduler. Select Network
Device Discovery Task, then select the Cherwell Asset Management node.

Related concepts
How to Collect Custom Network Device Properties
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How to Collect Custom Network Device Properties
To add custom properties to network device discovery, or to add custom object identifiers (OIDs) to
always-collected properties, add properties/OIDs to the network device template:

1. From the Tools menu, point to Template.

2. Select Network Device to open the Custom Network Device Data tab of the Network Device
Template.

3.  Check whether the property you want to include during discovery is listed here.

If it is listed (either as a fixed or user-defined property):

a. Click Change.

b. Click New to open the New SNMP OID dialog box.

If it isn't listed:

a. Click New to open the New Custom Data Property dialog box.

b. Type a name and description for the property to add, and whether it has multiple instances.

c. Click New to open the New SNMP OID dialog box.

4. In the New SNMP OID dialog box, enter the SNMP OID to use to retrieve data for the property
you're adding.

5. Specify whether the OID applies to all manufacturers, or click Search to find a specific
manufacturer.

To narrow down your results, the Only show discovered manufacturers option is checked;
uncheck it to broaden your search.

6. Click the manufacturer to use from the list, then click Select.
7. Click OK to save your SNMP OID information and return to the New Custom Data Property dialog

box.

8. Click OK again to save the property and return to the Custom Network Device Data tab of the
Network Device Template.

The new property now appears in the list, and the network discovery process will attempt to collect data
on this property the next time it runs.

Related concepts
Network Devices
Discover Network Devices
Network Device Template
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How to Discover Oracle Databases
When you discover Oracle Databases, licensing data from Oracle Database instances is collected, so you
can review your licenses and view data in reports.

Prerequisites

1. If you have Oracle databases running on virtual machines, run virtual environment discovery.

2. Run Linux/Unix/Mac OS discovery to find machines that have Oracle databases installed on them.

Note: Oracle Database discovery is not currently supported on Microsoft Windows Server
Operating Systems.

Configure Oracle Database Discovery
After you complete the prerequisites and discover any Linux/Unix/Mac OS or virtual machines with Oracle
databases installed on them, configure Oracle Database discovery as follows:

1. From the Tools menu, point to Discover, then click Oracle Databases.

2. In the Discover Oracle Databases dialog box, click Configure.

3. In the Configure Oracle Databases dialog box, select one or more listed instances, then click
Configure to open a dialog box where you specify credentials for the machines.

4. Provide credentials for the selected configuration(s).
To successfully query an Oracle Database, you must provide valid Oracle Database credentials. The
username and password must have select permissions for the following tables:

◦ SYSTEM table: PRODUCT_COMPONENT_VERSION

◦ SYSTEM table: DBA_FEATURE_USAGE_STATISTICS

Recommended: If you selected a single configuration, click Test before proceeding, to make sure a
connection can be established.

5. Click OK to save your configuration and return to the Configure Oracle Databases dialog box. The
checkbox for the configuration(s) you just entered is marked, which means Oracle licensing
information will be discovered next time you run discovery or scheduled discovery runs.

6. Repeat steps 3 – 5 to add additional discovery configurations.

7. Click OK to return to the Discover Oracle Databases dialog box. Oracle Database discovery
configuration is now complete and available to run, as described next.

Run Oracle Database Discovery
You can run Oracle Database discovery immediately after configuration, or later:

• To immediately run Oracle Database discovery, click Discover.
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• To run it later, click Close. You can return to this dialog box any time you want to run Oracle
Database discovery by selecting the Tools menu, pointing to Discovery, and clicking Oracle
Databases.

The options you specified during configuration remain in effect until you change them, and all selected
processes listed in the Configure Oracle Database Discovery dialog box are run when you click Discover.
Once configured, the Oracle Database discovery process automatically runs at 4:00 AM each Sunday by
default.

Note: The timezone in which the discovery and other scheduled tasks are run depends on the
timezone where the CAM Administration Service machine is located. For more information, see
How Cherwell Asset Management Works in an On-premises Installation or How Cherwell Asset
Management Works in a Hosted Installation, depending on whether you have an on-premises or
hosted installation, respectively.

To clear this option:

1. In the Options dialog box, select the Schedule tab.

2. Clear the check box.

Change how frequently discovery runs in the Windows Task Scheduler.

Post-discovery
To verify Oracle Database discovery successfully gathered the data needed for your Oracle instance
analysis, open the Configure Oracle Database Discovery dialog box and view the Last Result column.

Related information
Admin_Overview_Discovering_Oracle_Databases.xml#concept1322
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How to Discover Your Virtual Environment
You can configure CAM to discover any virtual machines on your network.

To discover your network's virtual environment, you must first configure virtual environment discovery,
then run discovery.

Configure Virtual Environment Discovery
To configure virtual environment discovery:

1. From the Tools menu, point to Discover, then click Virtual Environment.
2. In the Discover Virtual Environment dialog box, click Configure.

3. In the Configure Virtual Environment dialog box, enter information about where to look for virtual
machines by clicking Add; then, depending on where you want to look, click the appropriate option.

◦ To query a range of IP addresses: Click IP Address Range. This opens the Add Virtual
Environment Discovery IP Address Range dialog box. There, enter the start and end IP
addresses for the range and the required credentials. Select Hyper-V or VMware for the VM
platform.

◦ To query a specific subnet on your network: Click Subnet. This opens the Add Virtual
Environment Discovery Subnet dialog box. There, enter the subnet address and mask to
query, and the required credentials. Select Hyper-V or VMware for the VM platform.

◦ If you know the name or IP address of the machine(s) you want to query: Click Machine.
This opens the Add Virtual Environment Discovery Machine(s) dialog box. There, type the IP
address or name of the machine(s) to query, or click Browse to open the Browse for Machines
dialog box to find machines to query. If you type in multiple names or IP addresses; use
commas to separate them. Select Hyper-V or VMware for the VM platform, and enter the
required credentials.

Recommended: Click Test before proceeding, to make sure a connection can be established.

4. Click OK to save your configuration and return to the Configure Virtual Environment Discovery
dialog box. The checkbox for the configuration you just entered is marked, which means those
machines are queried the next time you run discovery or scheduled discovery runs.

Note: If you are configuring an IP address range or subnet, a dialog box opens to tell you
how many IP addresses this configuration will attempt to query. You have the option to save
your configuration by clicking Yes or, if the number of machines is not what you expect, click
No to return to the dialog box and make changes. Although querying a large number of
machines can take some time, it does not affect machine performance or the ability to run
other tasks.

5. Repeat steps 3 – 4 for any additional discovery configurations you want to add.

6. Click OK to return to the Discover Virtual Environment dialog box. Virtual environment discovery
configuration is now complete and available to run, as described next.
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Running Virtual Environment Discovery
You can run virtual environment discovery immediately after configuration, or later:

• To immediately run network device discovery, click Discover.
• To run it later, click Close. You can return to this dialog box any time you want to run network device

discovery. To do so:
1. Select the Tools menu and point to Discover.
2. Click Virtual Environment.
3. Click Discover.

The options you specified during configuration remain in effect until you change them.

Tips:

• Once virtual environment discovery is complete, click F5 or Refresh from the View menu to view the
discovered virtual machines.

• Once configured, the network device discovery process automatically runs at 1:30 AM each Sunday
by default.

◦ To turn off this scheduled task, select the Options dialog box, then the Schedule tab

• Change how frequently discovery runs through he Windows Task Scheduler. Select Virtual
Machine Discovery Task, then select the Cherwell Asset Management node.

Related information
Admin_Overview_Discovery.xml#concept605
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How to Limit Discovery to Specific OUs
You may want to limit your discovery and/or reporting only to certain organizational units.

To limit discovery to specific organizational units (OUs), do one of the following.

To always discover machines only in specific OUs:

1. From the Tools menu, click Options.

2. In the Options dialog box, click the AD Discovery tab.

3. Click the Discover from Active Directory option, then click Add.

4. In the Add Active Directory OU Path dialog box, type in the path for the OU to which you want to
limit discovery. Use the syntax shown in the dialog box.

5. Click OK. If the syntax is correct, you are returned to the AD Discovery tab, and you'll see the path
you just entered in the list box.

6. Select the path from the list and click OK.

To immediately run discovery and limit it to specific OUs:

1. From the Tools menu, point to Discover and then click Active Directory or NT Domain.

2. Click Discover from Active Directory, then click Configure.

3. In the AD Discovery tab of the Options dialog box, click Add.

4. In the Add Active Directory OU Path dialog box, type in the path for the OU to which you want to
limit discovery. Use the syntax shown in the dialog box.

5. Click OK. If the syntax is correct, you are returned to the AD Discovery tab, and you'll see the path
you just entered in the list box.

6. Click OK to return to the Discover Active Directory or NT Domain dialog box.

7. Click Discover to run the discovery.

Note: When you specify OUs for discovery through the Discover Active Directory or NT Domain
dialog box, those OUs will also be used for scheduled discoveries in the future.

Related information
../admin_troubleshooting/Admin_Syntax_issues_with_limiting_discovery_to_an_OU.xml#concept935
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How to Customize the Columns in the Files Panel
To customize the columns in the Files panel:

1. From the Files panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them within the list.

3. To change column widths, drag the dividers between the columns headers.
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How to Delete Files
You can't actually delete files; instead, you mark them as "Don't care" files.

To mark files as "don't care" files:

1. From the Files panel, select or search for the folder that contains the files.

2. Select the files you want to "delete."

3. Right-click your selection to bring up a context sensitive menu, and select "I don't care about this
file".

Related information
../admin_files/Admin_Overview_Dont_care_files.xml#concept671
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How to Inventory Files with Specific Extensions
To include Windows files with extensions other than .exe and .com (which are always inventoried) in
inventory scans, do the following:

1. From the Machine menu, click Agent Options.

2. In the Inventory tab, click the Extensions button.

3. In the Inventory Extensions dialog box, click the Add button.

4. In the Add Extension dialog box, type the extension you want inventoried. (You don't need to type
the preceding period.) Also mark the This extension is runnable check box if files with this
extension start applications.

5. Click OK, and then click OK twice more to exit all the dialog boxes.

Note: The above procedure applies to Windows machines only.

480

CAM 14.2 Administrator

CAM 14.2 Administrator



How to Inventory Specific Files
To include specific files in inventory scans, do the following:

1. From the Machine menu, click Agent Options.

2. In the Inventory tab, click the Files button.

3. In the Inventory These Files dialog box, click the Add button.

4. In the Add File dialog box, enter the name of the file to include when inventorying machines. If the
file is runnable (starts an application), mark the This file is runnable check box; otherwise, leave this
check box unmarked.

5. Optional: Enter Information on where the file is located by typing in all or part of a folder name.

6. Click OK, and then click OK twice more to exit all the dialog boxes.

Note: The above procedure applies to Windows machines only.

Related information
../admin_inventory/Admin_Tips_for_entering_folder_name_fragments.xml#concept1961
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How to Prevent Users from Launching a Particular
File

There may be cases where you want to prevent all users from launching a particular file; for example,
Virus1234.exe. To do so, first configure the file as a license unit, and then follow the procedure to prevent
users from launching a license unit.

Note: If the file in question has never been inventoried or launched, it will not appear anywhere in
the unconfigured files list.

Configure the file as a license unit:

1. Select File > New Application in New License Unit.
2. Give the application a name and specify a version.

3. Click Add to open the Add Executable Version dialog box.

4. Enter the name and the size of the file you want to block, then click OK. If you don't know the exact
file size of the executable, you can specify that this license unit includes all versions of the named
file, regardless of size.

5. Click OK to save the application.

You are taken to the License Unit Properties dialog box. From here, follow the procedure to prevent
users from launching a license unit.

Related information
Admin_How_to_configure_license_units.xml#concept2461
../admin_control/Admin_About_authentication_profiles.xml#concept1614
Admin_How_to_prevent_users_from_launching_an_application.xml#concept1048
../admin_dialog_boxes/Admin__HID_DLUPROPS_ADVANCED.xml#concept1451
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How to Search for Files
You can use the Search feature in the Files Panel to find specific files or types of files.

 Getting There

Searching for files or types of files is useful if, for example, you need to track down a known virus on your
network or when you want to configure an application that Cherwell Asset Management didn't
automatically recognize.

You can search for a file using whatever information you have about it. For example, you can search for a
file by name, type, path, whether it was launched, whether it is configured or unconfigured, a close match
or an exact match, and when it was first inventoried or metered. Click the or icons, or the scroll bar, to see
more search options.

You can search for a file using one or more of the following options:

• File name: Enter the file name, or as much of the file name as you know. You can use ? (question
mark) and * (asterisk) wildcards. For example, if you type den*.exe in the File name field,
Cherwell Asset Management returns a list of all executable files whose names start with "den".

• Path: Enter the path where you think the files you need may reside. You can use ? (question mark)
and * (asterisk) wildcards. For example, if you type C:\Program Files (x86)\* in the Path
field, Cherwell Asset Management returns any files that meet the criteria and are located in the C:
\Program Files (x86) folder and in any of its subfolders. If you didn't use the asterisk in the above
example, you'd only find the relevant files in the C:\Program Files (x86) folder itself.

Note: The _ (underscore) character is treated as a special character by SQL. In order to find
files that contain underscores in their names, you need to place [ and ] (square brackets)
characters around any underscore in any file or path string you enter in the File Search area.

• Search these file categories: Specify the category of file to search for. You must select at least one
of these categories before you can run a search. You can select multiple file categories.

◦ Unconfigured: Files that are executable, but not yet configured into license units. This file
category is selected by default.

◦ Unconfigured exact match: Unconfigured files that exactly match an application in the CSID.

◦ Unconfigured close match: Unconfigured files that closely match an application in the CSID.

◦ Configured: Executable files that are configured into license units.

◦ Configured exact match: Executable files that exactly match an application in the CSID and
are configured into license units.

◦ Configured close match: Executable files that closely match an application in the CSID and
are configured into license units.

◦ Don't care: Unless you check this box, files marked as Don't care or I don't care about this
file do not show up when searching for unconfigured files.

◦ Non-runnable: Non-executable files that you specifically set up to be inventoried by CAM.
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If you select More search options , the following choices appear:

• What machine is it located on?: To search for files on a specific machine, enter the machine name
here.

• What size is it?: By default, this option is set to Any size. To search for files of a specific size,
select Exactly in the first list box, then enter a value in the text box. You can also select Greater
than or Less than in the first list box, and then enter a value in the text box.

• Has it been launched?: Specify whether to search for files that were launched, not launched, or
both (Doesn't matter). By default, Doesn't matter is selected, which means Cherwell Asset
Management searches for both Launched and Not launched files. You should only select
Launched if you want to find files that have actually been run and if your organization is licensed to
run the metering component to collect launch information.

• When was it first inventoried or metered?: To search for files based on the date you first
inventoried or metered them, select one of these options or enter a range of dates. If you enter a
range of dates, be sure to specify the month, day, and year of the start and end dates. By default,
Doesn't matter is selected, which means that Cherwell Asset Management searches for files
regardless of first inventory or metering dates.

• Search limit: If the number of files that meet your criteria exceeds this maximum in this text box,
you are alerted. You can alter your search criteria to get fewer results, enter another maximum value
in the text box, or check the Unlimited check box to return all files that meet the search criteria. You
can change the default value for this text box by selecting the Tools menu, then selecting Options.
Select the Advanced tab, then modify the value in the Limit file search to [ ] records.

When you've entered all the information you want, click Search. Cherwell Asset Management searches
the CAM Database for files that meet the criteria you specified, and displays the results in the right pane.

Once the search is complete, you can right-click any of the found files to open a context-sensitive menu
with various options.

Tips:

• If you don't find the files you expected to find, try broadening your search.

• Use more options to narrow down your search if you wind up with too many files.

• To later revisit your search results, go to the left pane in the Files Panel and click the Search
results folder to display the most recent search results.

Related information
Admin_Overview_Dont_care_files.xml#concept671
Admin_Overview_Non_runnable_files.xml#concept760
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How to Exclude Folders from Inventory Scans
To exclude certain folders from inventory scans, do the following:

1. From the Machine menu, click Agent Options.

2. In the Inventory tab, mark the relevant check boxes to specify which types of files to exclude. To
exclude any additional folders, click the Advanced button.

3. In the Additional Exclude Folders dialog box, click the Add button.

4. In the Add Exclude Folder dialog box, type a folder name fragment to specify which folder(s) to
exclude from inventories.

5. Click OK, and then click OK twice more to exit all the dialog boxes.
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How to Schedule an Inventory
By default, all machines that have the Windows CAM Agent installed on them are inventoried once a
month, starting when the agent is first installed. You can override that setting and specify that some or all
of the machines are inventoried starting at times other than when they are installed. You can also change
the inventory frequency for all installed machines.

To specify how often all machines should be inventoried:

1. From the Machine menu, click Agent Options.

2. In the Inventory tab, make sure the Perform a complete scan every option is marked.

3. Use the text box and list box to specify how often inventory should occur. (For example, you can
enter an 8 in the first box and then choose Week(s) in the second box to run inventory every eight
weeks.)

4. Optional: From this tab, you can also specify other inventory options.

5. Click OK.

To specify when specific machines should start being inventoried:

1. In the Machines panel, select the machines for which you want to schedule inventory.

2. Right-click your selection and click Properties from the context-sensitive menu.

3. In the <Machine name> Properties dialog box, click the Options tab.

4. Click the Override default inventory start date/time option.

5. Specify a start date and start time.

6. Click OK.

Notes:

• By default, machines are immediately inventoried when the agent is installed. If you want to change
this behavior for the first inventory, you'll need to perform the above steps before the agent is
installed.

• The above procedures apply to Windows machines only.

Related information
../admin_dialog_boxes/Admin__HID_DCLIENT_OPTS_INV.xml#concept2264
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How to Set Up a Network Share Location
You need to set up a network share location before running inventory from it.

Note: You only need to do this once.

Prepare the Network Share Location

1. Create a network share location with read-only access. If you plan to use the same location to write
the generated output files, grant read-write access by other machines to this network share.

2. From a machine that has the CAM Agent installed on it, such as the Administrator's machine, go to
the following location:

◦ 64-bit Windows: C:\\Windows\\SysWOW64\\wex4962
◦ 32-bit Windows: C:\\Windows\\System32\\wex4962

3. Copy these files to the share:

Note: Some of these files are hidden. In order to see and copy them, go to Windows
Explorer and select the option to show hidden files and folders.

◦ AgentShared.dll

◦ ApplicationCollection.exe

◦ EmInvCli.exe

◦ EMInvCli.exe.config

◦ EmInvCliExtend.dll

◦ InventoryAgent.dll

◦ log4net.dll

◦ MaterialSkin.dll

◦ Microsoft.Threading.Tasks.dll

◦ QueryHelp.dll

◦ SQLite.Interop.dll

◦ System.Data.SQLite.dll

◦ System.Data.SQLite.EF6.dll

◦ System.Data.SQLite.Linq.dll

◦ System.Threading.Tasks.dll

◦ Unity.Abstractions.dll

◦ Unity.Container.dll
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How to Allocate Licenses
To allocate licenses, specify purchasing information to establish the total number of licenses available for
allocation, then determine how the total number of licenses are allocated across your organization.

Before Proceeding
Prior to performing these steps, do the following:

1. Verify that you have machine groups set up as needed. You will allocate licenses across these
groups.

2. Set the license type to Concurrent in the License Unit Properties General tab. For non-concurrent
applications, use group assignments in Purchasing

Part 1: Entering Purchasing Information
You can enter purchasing information in the Purchasing tab of the License Unit Properties dialog box, or
from Purchasing, a separate, web-based component for tracking purchasing and licensing information for
software and hardware assets in your network.

If You ARE NOT Licensed for Purchasing
To enter purchase information:

1. Right-click on the license unit, then click Properties to open the License Unit Properties dialog box.

2. Click the Purchasing tab.

3. Enter a license count and per-unit price.

If You ARE Licensed for Purchasing
Do one of the following:

• Enter the license count and per-unit cost in Purchasing, and then reconcile the line item to the
license unit.
- or -

• In the Purchasing tab of the License Unit Properties dialog box, first select the Specify license
count and per-unit cost only option, then enter the license count and per-unit price. Use this
method for license units for which you don't need detailed purchasing information.

Part 2: Allocating Licenses
After entering purchasing information, do the following to allocate licenses:

1. Click the General tab in the License Unit Properties dialog box.

2. Make sure the Licensing type is set to Concurrent.
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3. Click Allocations to open the Concurrent License Allocations dialog box.

4. Click Add to open the Add License Allocation dialog box. (If you already allocated some licenses
and you need to make changes, select a machine group from the list and click Change.)

5. Select a machine group from the list.

6. Enter the number of licenses you want to allocate to this group. Click OK to return to the Concurrent
License Allocations dialog box.

7. Repeat steps 4 — 6 for each machine group to which you want to allocate licenses.

8. When you're done allocating licenses, click OK in the Concurrent License Allocations dialog box,
then click OK again in the License Unit Properties dialog box.

Notes:

• Any licenses left unallocated will be available to any machine authorized to run the application.

• You can also use Purchasing to allocate license units using the purchasing information you enter
there.

Related information
../admin_control/Admin_About_license_allocation.xml#concept2806
../admin_control/Admin_About_concurrent_licenses.xml#concept855
../admin_machines/Admin_Machine_groups_overview.xml#concept1167
../admin_components/Admin_Overview_Purchasing.xml#concept2788
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License Units

492

CAM 14.2 Administrator

CAM 14.2 Administrator



How to Add an Application or Suite to a License
Unit

To add an application or suite to an existing license unit:

1. In the License Units panel, select the license unit to which you want to add the application or suite.

2. Right-click your selection, then click either New Application or New Suite.

To add an application or suite to a new license unit:

1. From the File menu, select New Application or New Suite in New License Unit.
2. Set up your new license unit and add the new application or new suite to it.

3. Click OK.
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How to Apply a Control Profile to a License Unit
You can apply control profiles, which are groups of settings that help system administrators control which
users and machines are allowed or denied access to specific applications, to license units.

To apply an existing control profile to a license unit:

1. In the License Units panel, select the license unit(s) that contain the application(s) you want to
control.

2. Right-click on the license unit, then select Properties.

3. In the license unit's Properties dialog box, select the Control tab.

4. In the Control tab, click Use control profile, then select a profile from the drop-down list. The
information box below the profile list changes to explain what happens when you use this profile.

5. Click OK.

You can also apply a control profile to a license unit by dragging the license unit to a specific folder in the
By control profile portion of the tree view in the License Units panel.

Related information
../admin_control/Admin_About_authentication_profiles.xml#concept1614
../admin_control/Admin_Predefined_authentication_profiles.xml#concept2375
Admin_How_to_create_a_new_authorization_profile.xml#concept2111
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How to Configure Files
Organize files into the applications and suites that make up license units. You can then report on, meter,
and control access to them.

Note: This topic applies to Windows applications only.

Follow this procedure if you have some Windows application files that were not automatically identified
and configured into license units.

To manually configure files into license units:

1. From the Files Panel, enter the file name and path for the file you want to configure. Check the
necessary categories.

2. Click More search options to enter more specifics, or click Search.

3. Right-click the file and, from the context-sensitive menu, choose an option:
a. Automatically Configure: Automatically configure this file.

b. Add as New License Unit: Create a new license unit with this file as the basis for its
associated application.

c. Add as Version: Add this file as another version in an existing license unit.

d. Add as Alternate Executable: Add this file as an alternate executable in an existing license
unit.

e. Add as Support File: Add this file as a support file in an existing license unit.

f. If you don't want to manage this file, click I don't care about this file. This classification
prevents the file from showing up in other unconfigured file categories, where you would have
to repeatedly evaluate how to handle it.

4. Depending on the choices made above, dialog boxes lead you through the configuration process.
Click Help in any of these dialog boxes for assistance.

5. Repeat this process for each file you want to configure into a license unit.

Tips:

• Right-click a file and select Properties if you are unsure of a given file's use. The Properties dialog
box may provide additional information that can help decide how to configure this file. It also shows
locations where the file was found.

• Make use of the I don't care about this file command to keep the number of files you need to
evaluate limited only to those newly inventoried.

Related information
../admin_license_units_suites_applications/
Admin_About_license_units_suites_and_applications.xml#concept1660
../admin_license_units_suites_applications/Admin_About_auto-identifying_applications.xml#concept1898
../admin_files/Admin_File_Search_dialog_box.xml#concept5660
../admin_files/Admin_Overview_Dont_care_files.xml#concept671
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Admin_How_to_configure_Mac_OS_applications.xml#concept1308
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How to Configure License Units
"Configuring license units" means converting application files into license units that Cherwell Asset
Management can report on, meter, and control.

There are several ways to configure license units. This topic provides links to procedures you can follow
for each situation.

Automatic Method
The most common way to configure license units is to let Cherwell Asset ManagementCAM automatically
identify inventoried or launched application files and configure them into license units; using this feature
should be sufficient in most cases.

Other Methods
If, after letting Cherwell Asset Management automatically configure license units, you find that you want to
make some changes to how your license units are configured, see the following table. Example scenarios
are listed on the left; links to procedures to follow are listed on the right.

Example Scenario Procedure to Follow

An application you want to monitor
was not automatically configured into
a license unit

Windows platform: Use the File Search feature first to find the
file, and then see How to Configure Files.
Linux/Unix/Mac OS platforms: See How to Configure Linux,
Unix, and Mac OS Applications.

You want to track two different
versions of a Windows application
separately

See How to Separate an Application from its License Unit; when
you get to the Convert to License Unit dialog box, select option
1.

You want to separately monitor
Windows applications that use
identical main executable files

See How to Separate an Application from its License Unit; when
you get to the Convert to License Unit dialog box, select option
2 or option 3, depending on whether you want to copy the
application to a new or an existing license unit.

You want to clean up the License
Units panel to see only license units
you are interested in viewing

See How to Delete a License Unit; this topic also contains
information on how to merely hide a license unit.

Related information
../admin_license_units_suites_applications/
Admin_About_license_units_suites_and_applications.xml#concept1660
../admin_license_units_suites_applications/Admin_About_auto-identifying_applications.xml#concept1898
Admin_How_to_automatically_identify_license_units.xml#concept1311
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How to Create a License Unit Group
License unit groups help you keep track of configured license units and filter reports.

To create a license unit group:

1. In the License Units panel, select the File menu and point to New Group.

2. Select License Unit.
Tip: If License Unit is dimmed when you point to New Group, click (License Units) in the left
pane of the panel and try again.  

3. In the New License Unit Group dialog box, enter the name of the new group and click OK.

The new group appears in the License Units panel, below the Deleted license units folder. If you selected
an existing user-added group before selecting New License Unit Group, the new group will be created as
a subgroup of the selected group.

To create a new group as a subgroup of an existing group:

• Right-click License Units (at the top of the tree).
- or -

• Click an existing license units group and select New Group.

To add license units to this group:

• Select the license units in the right pane and drag them to the group in the left pane.
- or -

• Right-click a license unit to open the License Unit Properties dialog box, then in the Member Of tab,
click Add.

Related information
../admin_license_units_suites_applications/Admin_license_units_groups_overview.xml#concept906
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How to Delete a License Unit
To delete a license unit, do one of the following in the License Units panel:

• Select the license unit(s), right-click your selection, and click Delete License Unit.
• Select the license unit(s) and press Delete.

• Move the license unit(s) to the Deleted license units folder in the left pane.

• Select the license unit(s) and select Edit > Delete.

Note that a dialog box may prompt you to confirm the delete action. You can bypass this dialog box in the
future by checking its Do not show this warning again option, or by clearing this option in the Warnings
tab of the Options dialog box.

The license unit(s) you deleted now appear in the Deleted license units folder. If you don't care about a
license unit, you can just leave it in the Deleted license units folder.

Related information
../admin_license_units_suites_applications/Admin_Overview_Deleting_license_units.xml#concept1285
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How to Determine if CAM Created or Modified
License Units

In the License Units panel, you can find out whether listed license units were last modified by the system
administrator, or by Cherwell Asset Management itself during an automatic identification process. This
information can be helpful to system administrators who want to sort out which license units they've
already modified (for example, by controlling access to an application), and which license units were
newly added or remain unchanged since their files were automatically converted to license units.

To determine whether any license units were created or modified:

• In the License Units panel, find the CAM-edited column in the right pane.
◦ Any "No" entries in this column indicate that a system administrator last updated the

corresponding license unit.

◦ Any "Yes" entries in this column indicate that Cherwell Asset Management last created or
modified the corresponding license unit. As system administrator, you may want to review
these license units to see if you want to change their default configurations.
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How to Enable Metering on Selected License Units
To enable metering for selected license units, select the license units you want to meter in the License
Units panel, and then do one of the following:

• Right-click your selection, point to Enable Metering, and then click Yes.

• Right-click your selection, click Properties, select the Meter this license unit check box, and then
OK the Properties dialog box.

• Choose Properties from the Edit menu, select the Meter this license unit check box, and then OK
the Properties dialog box.
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How to Move a License Unit to Another Software
Category

To move a license unit from one software category to another, do one of the following from the License
Units panel:

• Expand the By category folder in the right pane. Select the license unit and drag it to a new
category.

• Right-click the license unit and select Properties. In the License Unit Properties dialog box, click the
Categories button to open the Software Categories dialog box, where you can select another
category from the list. When you are finished, click OK twice to exit the dialog boxes.

To revert a license unit to its original category, do one of the following:

• Select the license unit from its By category folder and drag it to its original software category.

• Right-click the license unit and select Properties. In the License Unit Properties dialog box, click the
Categories button to open the Software Categories dialog box. Click Reset, and then click OK twice
to exit the dialog boxes.

Related information
../cherwell_id_database/Admin_Overview_Software_categories.xml#concept1777
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How to Restore a Deleted License Unit
To restore a deleted license unit, do one of the following in the License Units panel:

• Select the license unit(s) from the Deleted license units folder, right-click your selection, and click
Restore.

• Move the license unit(s) out of the Deleted license units folder.

• Select the license unit(s) from the Deleted license units folder and click Edit > Restore.

The restored license unit is now listed in the Full list folder. Its properties and group memberships are
also restored. If you want to meter this restored license unit, you will have to enable metering on it,
regardless of whether metering was enabled on it before the license unit was deleted.

Note: You can only restore a deleted license unit that still appears in the Deleted license units
folder. If you unconfigured it (removed it from this list), you cannot restore it using this method.
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How to Set Up the Wait List Feature
To give users the option of placing themselves on a wait list when they attempt to launch a concurrent
application when all its licenses are in use, do the following.

Note: If you've already configured your license unit as concurrent and set up purchasing
information, you can skip steps 1–4; instead, right-click the license unit and select Properties
from the context-sensitive menu. Then start with step 5.

1. Select the license unit that contains the application.

2. Right-click your selection, and then click Properties.

3. In the General tab of the License Unit Properties dialog box, select Concurrent from the Licensing
drop-down list box and mark the Meter this license unit check box.

4. Enter purchasing information for the license unit, either in the Purchasing, or in the Purchasing tab
of the License Unit Properties dialog box.

5. Click the Control tab.

6. Mark the Use control profile check box and either select a control profile from the list or click New
to create a new one.

◦ The two predefined control profiles you can use in this situation are Prevent Concurrent Idle
Time w/Wait List and Prevent Concurrent Users w/Wait List. Use the latter if you just want to
allow users to put themselves on wait lists; the former also sets idle time options.

◦ If you're creating a new control profile, make sure that the Allow user to request notification
when concurrent license is available option in the Authorization tab of the New Control
Profile dialog box is marked. This is the option that "turns on" the wait list feature.

7. Once you're satisfied with the control profile, click OK to exit the License Unit Properties dialog box.

Now authorized users who attempt to launch the application when no licenses are available will see a
dialog box that lets them know all licenses are in use, and asks whether they want to be notified when a
license is available.

You can later apply the control profile you used here to other license units.

Note: You can specify how long a user has to launch a wait-listed application when a license
becomes available in the Advanced tab of the Agent Options dialog box.

Related information
../admin_control/Admin_Overview_Wait_list.xml#concept1878
../admin_control/Admin_Predefined_authentication_profiles.xml#concept2375
Admin_How_to_apply_an_authorization_profile_to_a_license_unit.xml#concept1168

504

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overview_Wait_list
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Predefined_authentication_profiles
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_How_to_apply_an_authorization_profile_to_a_license_unit


How to Unconfigure License Units
To unconfigure a license unit, do the following in the License Units panel:

1. Select the license unit(s).

2. Right-click your selection and click Unconfigure.

3. A dialog box warns you that license allocation and metering data associated with the license unit(s)
will be removed. Click Yes to continue.

The license unit(s) you unconfigured now appear in the Unconfigured Applications panel. By default, any
applications in the Identified subfolders in this panel are configured into license units the next time the
automatic configuration process runs. You can move the unconfigured application to the Don't configure
folder to prevent that behavior.

Related information
../admin_license_units_suites_applications/Admin_Overview_Deleting_license_units.xml#concept1285
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Machines
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How to Add Custom Machine Information
You can add custom information to machines, such as a property identifying a machine's physical
location, that isn't automatically collected during inventory or discovery.

To add custom machine information, first create the custom field (also known as a label), then add the
custom field to a machine's properties.

To create a custom field:

1. From the Machine menu in CAM Administrator, click Agent Options to open the Agent Options
dialog box.

2. Click the Custom tab.

3. Click New.

4. In the New Custom Machine Property dialog box, click User-defined.

5. In the Label text box, enter the name of the field to add to the machine's properties, then enter a
description for that field.

6. Click OK. The custom field you just entered now appears in the list box in the Custom tab of the
Agent Options dialog box. Click OK in this dialog box to add the custom field.

To add custom fields to a machine's properties:

1. From the Machines panel, select a machine.

2. Right-click your selection, then click Properties from the context-sensitive menu to open the
Machine Properties dialog box.

3. Click the User-defined tab.

4. The fields (labels) you added are visible in this tab. In the text field next to each label, enter the
information for this machine. For example, if you added an Employee ID label, enter the appropriate
information for the employee associated with this machine.

5. When you're finished, click OK.

After setting up the custom machine information, you can then view the Machine Summary report to
validate the data.

If you have the user-defined properties available in an Excel spreadsheet, you can import the data directly
rather than enter it manually.
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How to Collect Inventory Data from Mac OS
Machines

The most common way to collect inventory data from Mac OS machines is to use the Linux/Unix/Mac OS
discovery feature, which does not require the use of an agent. These machines are inventoried upon
discovery.

You can still collect inventory data from machines with earlier versions of Mac OS that are not supported
by Linux/Unix/Mac OS Discovery. Use the appropriate remote agent package to collect the data, then
import that data into CAM Administrator.

To collect and import data:

1. From CAM Administrator Machine menu, select Remote Inventory > Prepare Agent. Note the
location of the Mac OS remote agent package.

2. Copy the contents of that folder to a USB drive or other portable media that you can use on Mac OS
machines, or to a shared drive.

3. Copy the folder from the portable media or shared drive to the Mac OS machine, then run the
Inventory Mac.app file on the machine.

4. From CAM Administrator Machine menu, select Remote Inventory > Import.
5. Browse to the location of the .xml files on the portable media or shared drive and click Import.

Related information
../admin_discovery/Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
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How to Create a Machine Group
Machine groups are groups of machines in various categories (installed, uninstalled, etc.).

To create a machine group:

1. From the Machines panel, select the File menu, or right-click Machines at the top of the tree.

Point to New Group and click Machine.

Tip: If Machine is dimmed when you point to New Group, click  Machines in the left pane
of the panel, and try again.

2. In the New Machine Group dialog box, enter the name of the new group and click OK.

The new group appears in the Machines panel, below the Deleted machines folder. If you selected an
existing user-added group before selecting New Group > Machine, the new group will be created as a
subgroup of the selected group.

To add machines to this group:

• Select the machines in the right pane and drag them to the group in the left pane.

- or -

• Right-click on a machine to open the Machine Properties dialog box, then in the Member Of tab,
click Add.

Related information
../admin_machines/Admin_Machine_groups_overview.xml#concept1167
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How to Customize the Columns in the Machines
Panel

To specify which columns should appear in the right pane of the Machines panel:

1. From the Machine panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them to a new location within the list.

3. To change column widths, drag the dividers between the columns headers.
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How to Delete Machines
To delete machines from the Machines panel, do one of the following:

• Select the machine(s), right-click your selection, and click Delete.

• Select the machine(s) and press Delete.

• Move the machine(s) to the Deleted machines folder in the left pane.

• Select the machine(s) and click Edit > Delete.

The machine(s) you deleted now appear in the Deleted machines folder. You can permanently remove
machines from the Deleted machines folder by selecting them and pressing Delete, or by right-clicking
your selection and clicking Delete. You can also right-click the Deleted machines folder and click Empty
"Deleted machines" folder to permanently remove all deleted machines.

Tip: To delete machines and permanently remove them from the Deleted machines folder in one
step, hold down the Shift key when you press Delete or move machines to the Deleted
machines folder.

Related information
../admin_machines/Admin_About_deleting_machines.xml#concept1544
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How to Ignore Remote Usage Data
You can have Cherwell Asset Management ignore usage data from machines that are connected to your
network via a terminal or Citrix server. See Agent Options Advanced Tab for more information and an
example of when doing so is useful.

To ignore this remote usage data:

1. Select Machine > Agent Options .

2. In the Agent Options dialog box, select the Advanced tab.

3. Select Ignore remote usage through terminal server.
4. Click OK.
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How to Import SCOM Data
To import SCOM data:

1. Select Tools > Import > Machine Data (SCOM).
2. In the Import SCOM Data dialog box, enter the name of your SCOM server and required credentials

for that server.

3. Optional: Click Test to validate your credentials before saving your settings or starting the import
process.

4. Click Import to save your settings and start importing, or click Save if you want to save your settings
now and run the import process later.

The status of the import process is shown in the status bar. Data is collected from any discovered
machines that have SCOM data. You can view this data in the Machine Summary report (available in
 CAM Administrator) and in the Machine Attributes report (available in Reporting).

Tip:

You can also schedule a SCOM import in the Schedule tab of the Options dialog box.
Related information
../admin_machines/Admin_Overview_SCOM_integration.xml#concept654
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How to Import User-Defined Custom Machine Data
If you have created user-defined custom machine properties, you can import that user-defined data from
an Excel spreadsheet directly into your CAM Database. To import this data:

1. From the Tools menu, point to Import and then click Machine Data (Excel).

2. A wizard opens, which steps you through the process of specifying the filename, worksheet, and
fields to import.

3. Enter the appropriate information in each dialog box of the wizard, and click Next at each one to
continue.

4. After completing all the dialog boxes, click Finish to import the data.

Once completed, you will be presented with a summary of the import process. You can click Close to
close the import dialog or View Log to view more details of any data that was skipped during the import
process.

Notes:

• Your spreadsheet must include columns that contain the machine names and domain names. These
are used to match the imported data to the correct machine.

• Your spreadsheet does not need to contain all of your user-defined custom machine properties. You
can import other properties from another spreadsheet or enter it manually.

• Your spreadsheet can contain data that is not to be imported. Only those columns you associate
with user-defined custom properties are imported.

• If you have trouble importing data using this method, please consult Technical Note 1078, available
from the Cherwell Customer Support Portal.

• If you want to create an Excel spreadsheet into which you can manually enter the user-defined
custom machine property data, first add the user-defined property definitions, and then view the
Custom Inventory report from Reporting and export it to Excel format. You can then modify the
spreadsheet in Excel and import it back into Cherwell Asset Management using the process
described above.
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How to Inventory Machines

Note: The information in this topic applies to Windows machines only.

Normally, inventories of machines that have the CAM Agent installed on them are done on a scheduled
basis. You can inventory machines on demand if you want to re-inventory a machine before its normally
scheduled date, or quickly inventory a machine that is not running the CAM Agent.

To do an on-demand inventory of machines:

1. In the Machines panel, select the machine or machines you want to inventory.

2. Right-click your selection and click Inventory on the context-sensitive menu.
Alternate method: You can also select the Machine menu, point to Inventory, and then click Selected
Machines.

3. Select the CAM Access Point that the agents will report to, supply the required credentials.

4. If the machine communicates through a proxy server, mark the Save proxy settings to agent
machine box, and complete the related options.

5. Click Inventory.

The on-demand inventory begins. The status bar at the bottom right of the window will display a message
when the process is complete. Click F5 to refresh the Machines panel.

Machines with the CAM Agent already installed are inventoried immediately; on those that do not, the
agent is installed on them long enough to perform the inventory, and then the agent is removed.

Related information
../admin_machines/Admin_Overview_Proxy_Server_environments.xml#concept947
../admin_troubleshooting/Admin_Overview_Proxy_server_issues.xml#concept272
../admin_discovery/Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
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How to Inventory Mac OS Machines from a Share
• This topic applies to Mac OS machines only.

• For Linux/Unix/Mac OS machines, you can discover and inventory those machines without an agent
from within CAM Administrator.

Running inventory from a share is a three-step process that includes preparing, running, and processing.

To run inventory from a share:

Part 1: Prepare the Network Share Location
Note that you only need to do this first part once. To prepare the network share location:

1. Create a network share with read access and, if you plan to use the same location to write the
generated output files, write access by other machines.

Note: If you also run inventory from a Windows share, make sure this location is different.

2. From CAM Administrator's Machine menu, select Remote Inventory > Prepare Agent.  This will
generate an inventory configuration file in the location shown in the Prepare Remote Inventory
Agent dialog box.

Note: This dialog box lists locations for both Windows-based machines and Mac OS
systems. Navigate to the appropriate location and copy all the files in that folder to the share.

Part 2: Run Inventory

1. From the machine you want to inventory, navigate to the share location you prepared in part 1
above, and run the Inventory Mac.app script.
The agent will write its inventory files into a subfolder of the folder where Inventory Mac.app is
located. The agent creates the subfolder in the form esm_<machinename>_yyyymmdd. For
example, an inventory run in August 10, 2012 would create the esm_JERRY160L20120810
subfolder.

2. Once inventory completes, you can process it for inclusion in the CAM Database.

Part 3: Process Each Inventory
You can process the inventory .xml files in one of two ways:

• Select Machine > Remote Inventory > Import. Enter (or browse to) the subfolder containing the
inventory files, and click Import.
- or -

• Use the ProcessEMInvFS.wsf script from any machine on which the CAM Agent is installed:
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1. Find the ProcessEMInvFS.wsf script in this location on the machine where the CAM
Administrator is installed:

◦ On 32-bit machines: C:\Program Files\Cherwell Asset Management\CAM
Administrator\InventoryFromShare

◦ On 64-bit machines: C:\Program Files (x86)\Cherwell Asset Management
\CAM Administrator\InventoryFromShare

2. Copy the ProcessEMInvFS.wsf script to the C:\Windows\System32\Wex4962 folder or
C:\Windows\SysWoW64\Wex4962 folder of a Windows machine running the CAM Agent.

3. Run ProcessEMInvFS.wsf from the machine you copied the file to in the previous step.

ProcessEMInvFS.wsf takes the following arguments:

• /input:"EmInvFS-output-folder"
This is the folder into which one or more subfolders containing the inventory files are located. If you
did not specify an output folder in part 2 above, this is the share folder itself. In the above example,
you would specify:

• /input:"\\myserver\esminv"
All subfolders with names conforming to the convention used to inventory from a share will be
processed.

• /visible
(Optional) Use this to specify that the user interface of the agent used to process the inventory files
will be visible. If you do not specify this, the agent runs without displaying its user interface.

Note: If you are processing more than one inventory, you will need to press the agent's
Close button after each inventory is processed.

• /nosummary
(Optional) Use if you do not want the ProcessEMInvFS.wsf script to display a summary once all
inventories have been processed. If you do not use /summary, a message box is displayed.

• /delete
(Optional) Use this to specify that each subfolder of inventory data is to be deleted once it has
processed. If you do not specify /delete, each folder is renamed once it has been processed by
pre-pending "processed_" to the subfolder name. For example, after the inventory contained in
esm_JERRY160L20120810 is processed, that folder will be renamed to
processed_esm_JERRY160L20120810. This is done so that if the script is rerun at a later date,
the folder will not be re-processed.

• /debug
(Optional, undocumented) Use to display script progress messages.

Related information
../admin_discovery/Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
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How to Inventory Windows Machines from a
Network Share

Running inventory from a network share involves preparing the network share, running the inventory, and
processing each inventory.

The information in this topic applies to Windows machines only.

Part 1: Prepare the Network Share Location
You only need to do this part once.

To prepare the network share location:

1. Create a network share with read access and, if you plan to use the same location to write the
generated output files, write access by other machines.

2. From a machine that has the CAM Agent installed on it (for example, the administrator’s machine),
navigate to C:\Windows\SysWOW64\wex4962 (64-bit versions of Windows) or C:\Windows
\System32\wex4962 (32-bit versions of Windows).

3. Copy the contents of the wex4962 folder to the share.

4. From CAM Administrator's Machine menu, select Remote Inventory, then click Prepare Agent.
This will generate an inventory configuration file (config.xml) in the location shown in the Prepare
Remote Inventory Agent dialog box.

Note: This dialog box lists locations for the both Windows-based machines and Mac OS
systems.

5. Navigate to the appropriate location and copy the config.xml file to the share. (You do not need
to copy all of the files there, just config.xml. If a config.xml file was copied over in step 3,
overwrite it with this one.)

6. From the machine on which CAM Administrator is installed, navigate to one of the following folders
and copy EMInvFS.wsf to the share:

◦ On 32-bit machines: C:\Program Files\Cherwell Asset Management\CAM
Administrator\InventoryFromShare

◦ On 64-bit machines: C:\Program Files (x86)\Cherwell Asset Management\CAM
Administrator\InventoryFromShare

7. Copy ProcessEMInvFS.wsf to the same wex4962 folder you used in step 3 above.

For example, the rest of this topic assumes a share of \\myserver\esminv was created and populated
with the files specified in steps 3 and 4 above.
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Part 2: Run Inventory

1. On your local machine, open a command prompt and use cscript to execute the EminvFS.wsf
script:

◦ Example with parameters:

cscript <share location>EMInvFS.wsf [/output:<writable shared locat
ion>][/quiet][/debug]

◦ Example without parameters:

cscript "\\myserver\myshare\EMInvFS.wsf"

◦ If your source share is read-only and your destination share is read-write:

cscript "\\myserver\myshare\EMInvFS.wsf" /output: "\\myserver2\mysh
are2\myfolder\"

◦ Optional parameters:
◦ /output:"writable-folder-location"

Use to specify the output folder into which a subfolder containing the inventory files will
be created. If this parameter is not specified, the share folder itself is assumed to be the
output folder.

◦ /quiet
Use to run the inventory agent without displaying its user interface; if this parameter is
not specified, the user interface is displayed.

◦ /debug
Use to display EmInvFS.wsf script progress messages.

The inventory agent will write its inventory (a set of .xml files) into a subfolder in the output folder (either
the share or the folder specified by the /output parameter as described above). The name of the subfolder
is of the form esm_<machine-name>yyyymmdd. For example, if the script is run on August 10, 2012 on
a machine named JERRY160L and no output folder is specified, the inventory files would be created in \
\myserver\esminv\esm_JERRY160L20120810\
Once inventory completes, you can process it for inclusion in the CAM Database.

Part 3: Process Each Inventory
You can process the inventory .xml files in one of two ways:

• From CAM Administrator's Machine menu, select Remote Inventory > Import. Enter (or browse to)
the subfolder containing the inventory files (for example, \\myserver\esminv
\esm_JERRY160L20120810), and click Import.
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- or -

• On the machine where the CAM Agent is installed, open a command prompt and use cscript to
execute the ProcessEmInvFS.wsf script.

Note: If you want to be able to run ProcessEMInvFS.wsf from a different machine, copy
the ProcessEmInvFS.wsf file to the appropriate location on that machine as well.

• ProcessEMInvFS.wsf takes the following arguments:
◦ /input:"EmInvFS-output-folder"

This is the folder into which one or more subfolders containing the inventory files are located. If
you did not specify an output folder in part 2 above, this is the share folder itself. In the above
example, you would specify:
/input:"\\myserver\esminv"
All subfolders with names conforming to the convention used to inventory from a share will be
processed.

◦ /visible
(Optional) Use this to specify that the user interface of the agent used to process the inventory
files will be visible. If you do not specify this, the agent runs without displaying its user
interface. Note: If you are processing more than one inventory, you will need to press the
agent's Close button after each inventory is processed.

◦ /nosummary
(Optional) Use if you do not want the ProcessEMInvFS.wsf script to display a summary once
all inventories have been processed. If you do not use /summary, a message box is displayed.

◦ /delete
(Optional) Use this to specify that each subfolder of inventory data is to be deleted once it has
processed. If you do not specify /delete, each folder is renamed once it has been processed
by pre-pending "processed_" to the subfolder name. For example, after the inventory
contained in esm_JERRY160L20120810 is processed, that folder will be renamed to
processed_esm_JERRY160L20120810, so that if the script is rerun at a later date, the
folder will not be re-processed.

Related information
Admin_How_to_run_inventory_from_a_share_mac.xml#concept4542
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How to Launch Windows Remote Desktop
Connection

To launch the Windows Remote Desktop Connection accessory from within CAM Administrator:

1. From the Machines panel, find the machine whose desktop you want to view.

2. Right-click on that machine, then click Launch Remote Desktop Connection.

Alternate method: Select Machine > Launch Remote Desktop Connection.

Notes:

• The Launch Remote Desktop Connection item is only available on the Machine menu and context-
sensitive pop-up menu when the accessory itself is installed on your machine and you've selected a
single machine.

• If the remote connection fails for any reason, the Windows Remote Desktop Connection, not
Cherwell Asset Management, provides feedback on the cause.
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How to Restore a Deleted Machine
To restore a deleted machine, do one of the following in the Machines panel:

• Select the machine(s) from the Deleted machines folder, right-click your selection, and click
Restore.

• Move the machine(s) out of the Deleted machines folder.

• Select the machine(s) from the Deleted machines folder and select Edit > Restore.

The restored machine(s) is now listed in the Full list folder, the Not installed folder, and in the folder of
any other discovered group to which it belongs.

Note: You can only restore a deleted machine that still appears in the Deleted machines folder. If
you permanently deleted it (removed it from this list), you cannot restore it using this method.
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Network Devices
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How to Create a Network Device Group
Network Device groups are collections of network devices. They help organize your devices in ways that
make sense for your organization, and you can use them for filtering in reports.

To create a network device group:

1. From the Network Devices panel, select the File menu.

2. Point to New Group, then click Network Device.
Tip: If Network Device is dimmed when you point to New Group, click  Network Devices in the
left pane of the panel and try again.  

3. In the New Network Device Group dialog box, enter the name of the new group and click OK.

The new group appears in the Network Devices panel, below the Deleted devices folder. If you selected
an existing user-added group before opening the New Network Device Group dialog box, the new group
will be created as a subgroup of the selected group. You can also create a group by right-clicking on
Network Devices (at the top of the tree) or on an existing network devices group, and then selecting New
Group.

To add network devices to this group:

• Select the network devices in the right pane and drag them to the group in the left pane.
- or -

• Right-click on a machine to open the Network Devices Properties dialog box, then in the Member Of
tab, click Add.

Related information
../admin_network_devices/Admin_Overview_Network_device_groups.xml#concept747
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How to Customize the Columns in the Network
Devices Panel

To specify which columns should appear in the right pane of the Network Devices panel:

1. From the Network Devices panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them to a new location them within the
list.

3. To change column widths, drag the dividers between the columns headers.
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How to Delete a Network Device
To delete a network device, do one of the following in the Network Devices panel:

• Select the network device, right-click your selection, and click Delete.

• Select the network device and press Delete.

• Move the network device to the Deleted devices folder in the left pane.

• Select the network device and select Edit > Delete.

The network device(s) you deleted now appear in the Deleted devices folder.

You can permanently remove network devices from the Deleted devices folder by selecting them and
pressing Delete, or by right-clicking your selection and clicking Delete. You can also right-click the
Deleted devices folder and click Empty "Deleted devices" folder to permanently remove all deleted
devices.

By default, you are prompted to confirm the permanent delete action. You can turn off this confirmation
option by marking the check box in the dialog box that displays the prompt, or in the Warnings tab of the
Options dialog box.
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How to Restore a Deleted Network Device
To restore a deleted network device, do one of the following in the Network Devices panel:

• Select the network device(s) from the Deleted devices folder, right-click your selection, and click
Restore.

• Move the network device(s) out of the Deleted devices folder.

• Select the network device(s) from the Deleted devices folder and click Restore from the Edit menu.

Any restored network devices are now listed in the Full list folder. Its properties and group memberships
are also restored.

Note: You can only restore a deleted network device that still appears in the Deleted network
devices folder. If you permanently deleted it (removed it from this list), you cannot restore it using
this method.
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Panels
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How to Customize the Columns in the License
Units Panel

To specify which columns should appear in the right pane of the License Units panel:

1. From the License Unit panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them to a new location within the list.

3. To change column widths, drag the dividers between the columns headers.
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How to Customize the Columns in the Other Assets
Panel

To specify which columns should appear in the right pane of the Other Assets panel:

1. From the Other Assets panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them to a new location within the list.

3. To change column widths, drag the dividers between the columns headers.
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How to Customize the Columns in the
Unconfigured Applications Panel

To specify which columns should appear in the right pane of the Unconfigured Applications panel:

1. From the Unconfigured Applications panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them to a new location within the list.

3. To change column widths, drag the dividers between the columns headers.
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How to Customize the Columns in the Users Panel
To specify which columns should appear in the right pane of the Users panel:

1. From the Users panel's right pane, right-click on a column header.

2. In the list of columns that opens, you can do one or both of the following:
◦ Mark the check boxes next to any columns that should be visible, and clear any columns that

you want hidden.

◦ To change the order that the columns appear, move them to a new location within the list.

3. To change column widths, drag the dividers between the columns headers.
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How to Create a User Group
User groups are groupings of users that you define. You can use them to control what data is displayed in
certain reports, and to indicate contract affinity in Purchasing.

To create a user group:

1. From the Users panel, select the File menu.

Select New Group > User.

Tip: If the User option is dimmed when you point to New Group, click  Users in the left
pane of the panel and try again.

2. In the New User Group dialog box, enter the name of the new group and click OK.

The new group appears in the Users panel, below the Deleted users folder. If you selected an existing
user-added group before selecting New User Group, the new group will be created as a subgroup of the
selected group. You can also create a group by right-clicking on Users (at the top of the tree) or on an
existing user group, then selecting New Group.

To add users to this group

• Select the users in the right pane and drag them to the group in the left pane.

- or -

• Right-click on a machine to open the User Properties dialog box, then in the Member Of tab, click
Add.

Related information
../admin_users/Admin_User_groups_overview.xml#concept811
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How to Delete an Administrator User Policy
 This topic applies to: CAM authentication

To delete an existing Administrator user policy:

1. From the Tools menu, point to User Policies and Authentication, and then click Administrator.

2. Select a policy from the list and click Remove.

3. Click OK in the Administrator User Policies dialog box to save this change.
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How to Delete Users
To delete users from the Users panel, do one of the following:

• Select the user(s), right-click your selection, and click Delete.

• Select the user(s) and press Delete.

• Move the user(s) to the Deleted users folder in the left pane.

The user(s) you deleted now appear in the Deleted users folder. You can permanently remove users
from the Deleted users folder by selecting them and pressing Delete, or by right-clicking your selection
and clicking Delete. You can also right-click the Deleted users folder and click Empty "Deleted users"
folder to permanently remove all deleted users.

Tip: To delete users and permanently remove them from the Deleted users folder in one step,
hold down the Shift key when you press Delete or move users to the Deleted users folder.

Related information
../admin_users/Admin_About_deleting_users.xml#concept1245
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How to Disable Administrator User Policies
 This topic applies to: CAM authentication

To disable the Administrator user policies feature, do the following:

1. From the Tools menu, point to User Policies and Authentication, and then click Administrator.

2. In the Administrator User Policies dialog box, clear the Enable Administrator user policies check
box.

3. Click OK.

4. Restart CAM Administrator so the change can take effect.
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How to Enable Administrator User Policies
 This topic applies to: Sites that use CAM authentication

To set up multiple administrators, use the Administrator user policies feature. First you enable the feature
and then you add users and give them all or specific permissions to use CAM Administrator.

To set up Administrator user polices:

1. From the Tools menu, point to User Policies and Authentication, and then click Administrator.

2. In the Administrator User Policies dialog box, mark the Enable Administrator user policies check
box.

3. If you are prompted to confirm this action, click OK.

4. Note that only users who have attempted to launch CAM Administrator are listed. If the user you
want to apply the user policy to is listed, do the following and then skip to step 6:

◦ Select that user and click Change to open the Change Administrator User Policy dialog box.

◦ Specify whether to give this user CAM System Administrator privileges, User privileges to the
areas you mark (License Units, Unconfigured Applications, and Files; Machine and Users; or
Network Devices and Other Assets), or whether this user is not authorized to run CAM
Administrator at all.

5. If the user is not listed, click the Add button to open the Add Administrator User Policy dialog box.
◦ Type in the user's name and domain, or click Browse to open a dialog box where you can

search for the user. (Tip: If you cannot find the user you need, cancel out of this dialog box and
the preceding two dialog boxes, and then run discovery again. After discovery completes,
check the Users panel to see if the user is now listed. The Browse for User dialog box can only
list users that appear in the Users panel.)

◦ Specify whether to give this user CAM System Administrator privileges, User privileges to the
areas you mark, or whether this user is not authorized to run CAM Administrator at all.

6. Click OK.

7. Back in the Administrator User Policies dialog box, note that the user is listed in the box, with the
new permissions. Click OK to exit the dialog box and save your changes.

8. Restart CAM Administrator for the changes to take effect.
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How to Prevent All Users from Launching an
Application

To prevent all users from launching a particular application:

1. Make sure the application is configured as a license unit.

2. In the License Units panel, find the license unit that contains the application. (You can select
multiple license units.)

3. Right-click on the license unit, and then select Properties from the context-sensitive menu.

4. In the license unit's Properties dialog box, click the Control tab.

5. In the Control tab, click the Use control profile option.

6. Select the Prevent Usage profile from the drop-down list box, and click OK.

Note: Depending on the situation, you may want to use a different control profile or create a new
one. For example, you may want to allow some users to launch the application.

Related information
Admin_How_to_configure_license_units.xml#concept2461
../admin_control/Admin_About_authentication_profiles.xml#concept1614
Admin_How_to_prevent_only_some_users_from_launching_an_application.xml#concept1859
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How to Prevent Some Users from Launching an
Application

You may want to restrict access to certain applications.

To prevent some users from launching a particular application:

1. Make sure the application is configured as a license unit.

2. In the License Units panel, find the license unit that contains the application. (You can select
multiple license units.)

3. Right-click on the license unit, then select Properties from the context-sensitive menu.

4. In the license unit's Properties dialog box, click the Control tab.

5. In the Control tab, click the Use authorization profile option and click New.

6. In the New Control Profile dialog box, enter a name for the control profile and (optional) a
description.

7. Click the Authorization tab. In the Authorization list box, select one of the following:
◦ Selected users and machines are authorized

◦ Selected users and machines are NOT authorized

8. Click Add Users or Add Machines to open a dialog box where you can specify which users or
machines are affected by this control profile.

9. Select individual users or machines, or entire groups, and then click Add Users or Add Machines.
Continue until you've selected all the users or machines you want to either allow or deny access for
the current license unit(s).

10. When you are satisfied with your control profile, click OK. You'll be returned to the Control tab with
the profile selected. Notice that the display contains a summary of the newly created profile.

11. Click OK to save changes to the license unit(s).

Related information
Admin_How_to_configure_license_units.xml#concept2461
../admin_control/Admin_About_authentication_profiles.xml#concept1614
Admin_How_to_prevent_users_from_launching_an_application.xml#concept1048
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How to Restore a Deleted User
To restore a deleted user, do one of the following in the Users panel:

• Select the user(s) from the Deleted users folder, right-click your selection, and click Restore.

• Move the user(s) out of the Deleted users folder.

• Select the user(s) from the Deleted users folder and click Edit > Restore.

The restored user(s) is now listed in the Full list folder and in the folder of any other discovered group to
which it belongs.

Note: You can only restore a deleted user that still appears in the Deleted users folder. If you
permanently deleted it (removed it from this list), you cannot restore it using this method.
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WMI
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How to Specify WMI Information
To make additions or changes to WMI properties, you should be familiar with how to use WMI settings.
For general information on WMI and what WMI properties may be gathered, search the Microsoft website
for "WMI".

Cherwell Asset Management also provides syntax for further qualifying how certain WMI properties are
gathered. For more information, search the Microsoft website for “Windows Management Instrumentation
Query Language (WQL)".

You might find the following example useful in getting started with entering WMI information in Cherwell
Asset Management. You can adjust your entries according to your needs. This example shows how you
would complete the fields in the New/Change Custom Machine Property dialog box if you wanted to
gather MAC addresses for machines with an adapter type of Ethernet 802.3, and only receive back only
the values that begin with 00.

To gather the above information, you would first click WMI in the New/Change Custom Machine Property
dialog box, and then complete the fields as follows. (The fields are listed first, followed by the entry you
would make.)

• WMI class: Win32_NetworkAdapter

• WMI property: Name

• Description: (optional)

• Where clause: AdapterType="Ethernet 802.3" AND MACAddress LIKE "00%"

This brings back the names of all adapters where the adapter type is Ethernet 802.3 with a MAC address
that starts at 00.

Alternatively, if you know you have a MAC Address commonly found on machines that you want to
exclude (for example, one starting with 42), you could modify the Where clause as follows:

Where clause: AdapterType="Ethernet 802.3" AND MACAddress LIKE "[^42]%"
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Web Components
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How to Access the CAM API Documentation
The CAM API is the collection of web services that allows you to interchange data with external systems.
For more information, see the CAM API Documentation.
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How to Change the Location of Web Components
This topic applies to on-premises installations.

To change the location of web components (Authentication, License Analytics, Purchasing, and
Reporting):

1. Select the Status panel. In the Web Component Locations section, click Configure.

2. In the Configure Web Component Locations dialog box, specify whether all web components are
installed on single or different machines, then enter the URL(s).

Note: Entering fully-qualified domain names is recommended in all cases, and required
when using multiple locations.

3. Click OK.

Note: If you plan to use Internet Explorer (IE) to access the web components, ensure that the
name of the machine on which you install these components does not include an underscore
character. There are known issues with IE storing cookies on machines whose names include an
underscore.
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Inventory
You can inventory each Windows computer on your network from CAM Administrator.

This topic applies to Windows machines.

Cherwell Asset Management allows you to perform an enterprise-wide inventory of the software and basic
hardware on each machine without having to visit each one. You can inventory your network's machines
in several ways:

• Scheduled inventory: By default, complete inventory scans occur once a month.
◦ You can change this setting by going to the Agent Options dialog box, then selecting the

Inventory tab.

◦ Also by default, inventory is run on a machine the first time the agent is installed. You can
modify this for any Windows machine by selecting the Properties dialog box, then the
Options tab.

• On-demand inventory
To inventory multiple machines by machine name:

1. Select the machines in the Machines panel, then right-click your selection.

2. Select Inventory Selected Machines.

To inventory multiple machines by IP address:
◦ See Inventory Multiple IP Addresses Dialog Box

To inventory a single machine:
◦ See inventory a single machine

• Remote inventory: A standalone inventory package allows you to inventory Windows and Mac OS
machines not currently connected to the network, or for platforms where other methods are not
supported.

• Inventory from a network share location: From a network share location, run inventory on
Windows and Mac OS machines that don't have the CAM Agent installed on them.

To see when the last inventory was performed:

1. Go to the Machines panel in CAM Administrator.

2. In the Inventory status column, find the machine you want to check.

You can also click on this column header to sort the list in the order of when inventory was last run.

Related information
../admin_discovery/Admin_How_to_discover_Linux_Unix_Mac_OS_machines.xml#concept4773
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Gathering Inventory Data
The CAM Agent gathers two types of file identification information:

• Basic file information consisting of installation path, file name, size, date, and time stamp. (Windows
and Mac OS machines.)

• Extended file information including versioning from the file header and calculation of a Cyclic
Redundancy Check (CRC). Extended file information is only collected if the Collect extended
inventory information check box in the Options tab of the machine's Properties dialog box is marked.
(Windows machines only.)

Note: Basic file information is sufficient to recognize and match data contained in the Cherwell
Software Identification Database (CSID) for Windows applications. Extended file information is
useful for unconfigured files, as it gives you more information you can use to manually configure
an application.

Inventory Scan Frequency (Windows Machines Only)
On the Inventory tab in the Agent Options dialog box, you can configure the inventory agent to perform a
complete scan every <n> days, weeks, or months.
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What Inventory Information Is Collected?

Windows Machines
On the Windows platform, Cherwell Asset Management collects the following information from
workstations and servers:

• File information, including name, size, date, path, and version. Extended file information such as
CRC and data stored in the file header can also be collected for any machine by enabling the
Collect extended inventory information option in the Options tab of the machine's Properties dialog
box. Inventory scans for .exe and .com files, but you can add other extensions to be searched as
well.

Tip: You can also scan for any type of file extension (such as .doc) by typing the extension
in the Add Extension dialog box.

• Status, start mode, and path information for available services.

• Information about installed applications.

• Workstations’ basic hardware information, such as computer name, SMS ID, CPU type and speed,
memory, disk space, and network card address.

• ISO tag file information.

• From network devices, information like manufacturer, description, type of device, serial number, IP
address, physical address, uptime, location, and status.

You can also configure Cherwell Asset Management to collect custom information when inventory runs on
Windows machines; see New/Change Custom Machine Property dialog box for details.

Linux/Unix/Mac OS Machines
On Linux/Unix/Mac OS machines, Cherwell Asset Management collects the following information:

• Hardware information as available, including disk drive and network adapter summaries.

• Operating system name and version.

• Status, start mode, and path information for available services.

• Installed software packages on each machine.

Related information
../admin_machines/Admin_Overview__Linux_Unix_Mac_OS_machines.xml#concept994
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How Long Does it Take to Run an Inventory?
A number of factors affect the length of time it takes to complete the inventory process on Windows
machines:

• Machine hardware (CPU speed, drive access times, etc.) and the number of files and folders on the
machine

• Speed of the machine running the CAM Access Point

• Speed of the SQL Server machine hosting the CAM Database

The inventory process takes anywhere from 1-15 minutes to complete on one machine, with typical times
being between three and five minutes. But when you inventory multiple machines at once, the length of
time to complete the process does not increase linearly—the processes run in parallel. This means that
simultaneously inventorying multiple machines completes much more quickly than inventorying each
machine one at a time.
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If an On-demand Inventory Stalls
 This topic applies to on-premises installations.

If you run an on-demand inventory process that seems to stall (stay in the inventorying state indefinitely),
it's possible that there is an issue with your local Microsoft Internet Information Services (IIS) user
account.  

One way to tell is to search for and check the EmInvCli.log file on the machine on which the CAM Agent is
installed. The following is an excerpt of an EmInvCli.log file that contains errors like those you might see if
IIS is not correctly set up:

7/19/2004 12:46:14 - SOAPCLIENT_SEND_ERROR: (null) - 0

7/19/2004 12:46:24 - Communication Terminated: (null) - 0

7/19/2004 12:46:24 - Could not get Configuration file from Web Service.: (null) - 0

By default, when you set up IIS, a new local IIS user account is created. The name of this account is
usually IUSR_<machine name>, sometimes followed by a numeral. If this user is not created, you may
experience the above problem because the machine is unable to communicate with the IIS machine. To
correct this problem, either reinstall IIS or manually create the account using Windows administrative
tools. You can validate that this is the account IIS is attempting to use by viewing the Directory Security
settings of the virtual directory (CAMAccessPoint or ExpressSoftwareManagerAP) created during access
point installation. You can use the Internet Information Services control panel to view these settings.
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Inventorying Mac OS Machines
You can collect inventory data from Mac OS machines in your network and configure Mac OS applications
into license units in either of these ways:

• The most efficient way to do this is to use the Linux/Unix/Mac OS discovery feature, which does not
require use of an agent.

•  You can also use the remote inventory procedure or run inventory from a network share location.

With either method, to configure inventoried Mac OS applications into license units, go to the Mac OS
folder in the Unconfigured Applications panel. See How to Configure Linux, Unix, and Mac OS
Applications.
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Remote Inventory
You can inventory Windows machines that are not connected to the network.

In order to run a remote inventory, follow the instructions in the Prepare Remote Inventory Agent dialog
box.

Note:

If you can't install the agent from CAM Administrator, you can install it using any removable
media.
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Specifying Access Points
When you install the CAM Agent on machines in your network or inventory machines, you also specify to
which CAM Access Point the selected machines report. Installed CAM Access Points are shown in the
installation dialog box; select which one to use for all machines you are installing from this list.
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Collecting Information on Printers and Mapped
Drives

Hardware inventory includes information on network printers and mapped drives, if available. By default,
scheduled inventories are run under the System account on the machine where the CAM Agent is
installed. This is so inventories will run even if no one is logged into the machine. There is one limitation in
this scenario: User account-specific information about network printers and mapped drives may not be
accurate, as the System account will typically not have these mappings defined.

If network printer and mapped drive hardware information is required, you will need to run inventory under
the account of a logged-in user. You can do this in one of the following ways:

• If you want scheduled inventories to always run under a logged-in user account, enable the Perform
scheduled inventory only when user is logged in option, available on the Options tab of the
machine’s Properties dialog box. When this option is marked, scheduled inventories will only be run
when a user is logged in.

• Run inventory on demand using the credentials of the end user. Inventory on demand is run under
the account specified in the credentials dialog displayed when the inventory is requested. If you use
the local user’s credentials, the inventory will run under that account.

• Run inventory manually on the machine. You can launch the inventory agent manually on any
machine while logged in.

On 64-bit machines, launch the agent from the Start menu by pointing to Run and then enter the following
command in the Run dialog box:

%windir%\syswow64\wex4962\eminvcli.exe

On 32-bit machines, enter this command:

%windir%\system32\wex4962\eminvcli.exe

Note that when run manually, the inventory agent will display a simple user interface to inform you of its
status.

Note: The information in this topic applies to the Windows platform only.
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CAM-specific Custom Machine Properties
The inventory agent supports a set of custom machine properties that are specific to Cherwell Asset
Management. You can enter these properties in the New/Change Custom Machine Property dialog box, in
the same way that you would enter any other custom WMI property.

In all cases, enter WIN32_ESM_CUSTOM in the WMI class field, and then enter the property name in the
WMI property field. The following is a categorized list of all property names.

Note that the information in this topic applies to the Windows platform only.

Registry Access

• hkey_classes_root

• hkey_users

• hkey_current_user

• hkey_local_machine

• hkey_current_config

Use the above property names to specify which registry hive you want to access. You must then enter a
WHERE clause that specifies the exact key you want to be returned. (See the next section for more
information on specifying the WHERE clause.)

For example, suppose you want to obtain the key value from the following:

hkey_local_machine\Software\Microsoft\Internet Explorer

In this case, you'd specify the property as:

hkey_local_machine

And specify the WHERE clause as:

Software\Microsoft\Internet Explorer

More Information on Specifying the WHERE Clause
When you specify the WHERE clause, there are some issues to consider. If you want the "(Default)" value
of a registry entry returned, you need to add two backslashes to the end of the registry key name.

For example, if you click on the hkey_classes_root\.html key in the left pane, you'll see at least one value
in the right pane, under the Name column: (Default). Depending on your configuration, you may see
additional values in the right pane.

In this example, set up the custom inventory property in the New/Change Custom Machine Property
dialog box as follows:

1. In the WMI property field, type: hkey_classes_root

2. In the Where clause field, type one of the following:
◦ To get the "(Default)" value: .html\\
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◦ To get another value (for example, PerceivedType): .html\PerceivedType

Notes:

• Cherwell Asset Management supports collection of STRING and DWORD registry value types only.

• If you are searching the hkey_current_user hive, you must specify that the inventory agent be run
only when a user is logged in; otherwise no registry value will be returned. To set this option, see the
Options tab of the machine's Properties dialog box.

Other

• PhysicalCPUCount: Number of physical CPUs; this property is only supported for Intel-based
systems.
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ISO Tags
 In support of the ISO 19770-2 (Software Identification Tag) standard, ISO 19770-2 tags are collected
when present on workstations or servers during the inventory process, and you can view this information
in reports.
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Run Inventory from a Network Share Location
By using a network share location, you can run inventory on a Windows or Mac OS machine without
having to install the CAM Agent.

This is designed for smaller environments that may not have access to a CAM Access Point and cannot
deploy CAM Agents.

Note: You can discover and inventory Linux/Unix/Mac OS machines without an agent from within
CAM Administrator.

To run inventory from a network share:

1. Set up the network share location (only required once).

2. Access the share and run the inventory from each machine that you want to inventory.

3. Process each inventory, thereby adding it to the CAM Database.

See Also:

• How to Inventory Windows Machines from a Network Share
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Tips for Entering Folder Name Fragments
You can enter folder name fragments in the Add/Change File and Add/Change Exclude Folder dialog
boxes to specify where files that you want to include or exclude from inventories are located.

Cherwell Asset Management takes the folder name fragment you specify and attempts to match it to any
folders that contain the fragment string, including any subfolders. You can also use a backslash character
to specify that folders should start or end with the specified fragment.

The following examples show how to enter fragments to achieve different results. Note that the way you
specify folder name fragments is the same, regardless of whether you are using fragments to include
specific files in inventories, or to exclude certain folders from inventories.

• Folder name fragment: String that does not include a backslash (like Personal)

Result: All folders that include that string anywhere in the path are specified. If you specify
Personal, folders with names like PersonalKathy and DebbiePersonal are also specified.

• Folder name fragment: String that starts with a backslash (like \Personal)

Result: All folders that start with that string are specified. If you specify \Personal, folders with
names like \PersonalKathy (but not \KathyPersonal) are also specified.

• Folder name fragment: String that ends with a backslash (like Personal\)

Result: All folders that end with that string are specified. If you specify Personal\, folders with
names like DebbiePersonal\ (but not PersonalDebbie\) are also specified.

• Folder name fragment: String that starts and ends with backslashes (like \Personal\)

Result: Specifies only folders that match that string exactly.
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Metering
The metering component of Cherwell Asset Management tracks usage of the Windows applications and
suites on your network so you can validate that the licenses you purchase are actually being utilized.  

Using the metering feature, you can:

• Specify for which applications usage will be tracked.

• Gather statistics on application launches to help determine the proper number of application
licenses you need based on actual usage.

Notes:

• Because various organizations have differing agreements with particular software vendors, using
metering does not necessarily guarantee that you will comply with all of your license agreements.
You must carefully review each of your software license agreements to determine what rights, if any,
you have to share programs among users.

• Metering is not supported on Mac OS machines.
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How Metering Works
Metering is the process of collecting application start and end statistics from machines. The metering
component of the CAM Agent is installed on machines when you install the CAM Agent and reports usage
to the CAM Database if you are licensed to use the metering functionality of Cherwell Asset Management
and metering is enabled for a particular machine (the default). You decide which license units you want to
meter, and the metering component communicates with the CAM Access Point to provide information on
when applications in those metering-enabled license units are started and stopped.

Control Messages
Cherwell Asset Management provides a set of messages, one of which is displayed to the user whenever
control impacts the launch of an application. The list includes messages for each unauthorized and
unlicensed situation. You can change any of these messages from the Messages tab of the Agent
Options dialog box.

Impact of Changes to a Control Profile
Control behavior is specified through the use of a control profile, which defines what machines/users are
allowed (or not allowed) to run the application as well as if the launch is to be completely blocked or the
user simply warned. Due to the way the CAM Agent caches control information, behavior following a
change to a control profile may be unexpected until machines check in to see the change. For example, if
a previously unauthorized machine is added to a profile as now being authorized, an attempt to launch an
application assigned the profile might be initially allowed, but shortly after launch, caught and terminated.
Once the CAM Agent has checked in (heartbeat) and noticed the change, this situation will be remedied.
(Note that logging out and back into the machine on which the CAM Agent is installed will also have this
effect.)
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Metering Remote Users
When a machine that has the CAM Agent installed on it is not connected to the CAM Access Point (for
example, a laptop not connected to the network), usage data is still collected and locally cached. When a
network connection is re-established and the CAM Access Point is available, the cached information is
sent to the CAM Database.
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Control
The control component of Cherwell Asset Management lets you control user access to applications.
Control can be based on an authorized/unauthorized list or, for concurrently licensed applications, license
availability. Besides specifying which machines or users are allowed or denied access to an application,
you can also specify what happens when a user attempts an unauthorized or unlicensed launch. You can
block the launch, provide a warning that gives the user a choice, or silently monitor launches and view the
results later in reports.

To understand how the control feature works, and to learn how to configure it according to your
organization's needs, see the following topics:

• How to Prevent All Users from Launching an Application

• How to Prevent Some Users from Launching an Application

• How to Prevent Users from Launching a Particular File

• How to Allocate Licenses

• How to Set Up the Wait List Feature

• How to Configure Idle Time Options

Note: The control component is not supported on Mac OS machines.
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Control Behavior
You can use control profiles to specify:

• Authorization: A list of which users or machines are or are not authorized to run an application

• Behavior: Rules used to determine what happens when an unauthorized or unlicensed launch is
attempted

In general, changes to a license unit’s authorization or control behavior will not fully take effect until the
next agent heartbeat. (Changes to authorization may take several heartbeats in an evaluation situation
where the heartbeat is, by default, 5 minutes.)
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Concurrent Licenses
If you have a concurrent license for an application, you are allowed to install as many copies of the
application as you like, but you can only use a certain number of copies of the application at any given
time, as specified by your organization's agreement with the vendor.

You can use control profiles and the license allocation feature to help your organization adhere to its
concurrent license agreements. You can use license allocation to determine what groups are allowed to
access a license, and use control profiles to determine what happens when a license is not available.
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License Allocation
License allocation allows you to define how the ownership of the total number of licenses purchased for a
particular application is to be distributed throughout your company. The effect of license allocation
depends on whether the license type is concurrent:

• Concurrent licenses—For license units with a license type of concurrent, license allocation gives you
control over how licenses are checked out. For example, if you purchased 10 total licenses of an
application for two groups to use, you might want to split these ten licenses evenly between the two
machine groups. To do so, you'd use the Concurrent License Allocations dialog box to set up two
allocation pools, one for each group. If the first group is already using five licenses, an attempt to
launch a sixth instance from a machine in that machine group would not be allowed. A launch from a
machine in the second group, however, would be allowed if licenses were still available from that
allocation pool.

• Nonconcurrent licenses—For non-concurrent applications, use group assignments in Purchasing to
assign licenses to specific groups.

How does the allocation process work with purchasing information?
Allocation is the process of placing resources (such as licenses, computers, and other hardware assets)
into groups. From the standpoint of Purchasing, the reason you would allocate something to a group is
that the group has some kind of responsibility for it—usually for the purposes of accounting for expenses.

For items that are reconciled, Purchasing makes an entry in the appropriate machine, user, or other asset
group for the item you allocate. For example, if you allocate a machine to the accounting machine group,
Purchasing will add the machine to that group if it is not already part of that group. Purchasing adds other
assets to other asset groups, and adds user-based software licenses to user groups, and machine-based
software licenses to machine groups.

For items that are not yet reconciled, Purchasing will “remember” your allocation request. At the time that
the software, computer, or other asset is actually reconciled, Purchasing adds the software licenses or
hardware to the requested groups on your behalf.

While Purchasing will add resources to groups, it will not remove them later if, for example, they are
deleted or returned from a lease. This behavior is deliberate. CAM Administrator is the primary interface
used to manage group allocations, and Purchasing cannot keep track of changes to allocations it may
have made initially.

Related information
Admin_About_concurrent_licenses.xml#concept855
../admin_machines/Admin_Machine_groups_overview.xml#concept1167
../admin_dialog_boxes/Admin_Concurrent_License_Allocations_dialog_box.xml#concept2236
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Control Profiles
A control profile defines how access to an application is controlled.

Cherwell Asset Management's control feature uses control profiles, which are groups of settings that help
system administrators control which users and machines are allowed or denied access to specific
applications.

The following are examples of ways to use control profiles:

• To specify that unauthorized users are warned or blocked when they attempt to launch an
application.

• To specify what happens when there's an attempt to launch a concurrently licensed application, and
no licenses are available.

• To allow only certain users or machines to launch specific applications.

• To specify what happens when applications left open and unused on machines.

• To allow users to wait for a concurrent application to become available when all licenses are in use.

Cherwell Asset Management includes several predefined control profiles for the most common situations.
You can create your own custom control profiles to suit your organization's needs; see How to Create a
New Control Profile.

To use an existing control profile:

1. Select the license unit that contains the application you want to control.

2. In the License Unit Properties dialog box, select the Control tab, then apply the control profile to the
license unit selected in Step 1.

Related information
Admin_About_concurrent_licenses.xml#concept855
Admin_Predefined_authentication_profiles.xml#concept2375
../admin_how_to/Admin_How_to_create_a_new_authorization_profile.xml#concept2111
../admin_dialog_boxes/Admin__HID_DLUPROPS_AUTHORIZATION.xml#concept924
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Predefined Control Profiles
Cherwell Asset Management includes several predefined control profiles:

• Prevent Concurrent Idle Time: Blocks launches of concurrent applications when all licenses for
that application are in use, and sets limits on the amount of time an application can be idle before
shutting down that application and releasing it for a waiting user.

• Prevent Concurrent Idle Time w/Wait List: Blocks launches of concurrent applications when all
licenses for that application are in use and sets limits on the amount of time an application can be
idle, as above, but only if a user is waiting for a license of that application to become available.
Users who are prevented from launching the application are given the option to put themselves on a
wait list for it.

• Prevent Concurrent Users: Blocks launches of concurrent applications when all licenses for that
application are in use. You can use license allocation to restrict license availability, but any machine
or user is allowed to request a license.

• Prevent Concurrent Users w/Wait List: Blocks launches of concurrent applications when all
licenses for that application are in use, and gives authorized users whose launches are blocked the
option to put themselves on a wait list for the application.

• Prevent Usage: Blocks all users and machines from launching an application.

• Warn Concurrent Users: Warns users when they launch a concurrent application whose licenses
are all in use. You can use license allocation to restrict license availability, but any machine or user
is allowed to request a license. If no licenses are available, the user is warned but is still allowed to
override the warning and launch the application anyway. Note that launches of a concurrent
application when no licenses are available may violate your software license agreement.

• Warn Users: Warns all users that they are not authorized to launch the application, but does not
prevent launches.

To access any of these control profiles or create a new control profile:

1. Select a license unit, then select its Properties dialog box.

2. Select the Control tab.

Related information
Admin_About_authentication_profiles.xml#concept1614
Admin_Overview_Idle_time.xml#concept2296
Admin_About_license_allocation.xml#concept2806
../admin_dialog_boxes/Admin__HID_DLUPROPS_AUTHORIZATION.xml#concept924
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Idle Time
In Cherwell Asset Management, the term "idle time"’ refers to the period of time that an application is
running, but not in use, on a machine. An application is considered to be not in use when its window does
have not focus.

As the system administrator, you can specify what happens to metered applications that exceed an idle
time limit you specify. For example, you may want to specify that users can't keep a specific application
open all day if it's not in use. You can warn users about the idle application, send reminders after the initial
warning, and even shut down the application after a specified amount of time. You can also set up the
feature so that these rules are enforced only when another user is waiting for the application.

To set up idle time options, apply one of the predefined control profiles that includes idle time options to
the license unit that contains the application. You can also create a new control profile, making sure to set
up the options you want in the Idle Time tab of the New Control Profile dialog box.

Notes:

• Once a user switches the window focus to an application and that focus is maintained for 30
seconds, the application is no longer considered idle.

• Do not apply a control profile with idle time settings to an application that will never have focus, such
as perating systems, SQL Server, and services that run in the background.

• Idle time settings only apply to machines that are connected to a CAM Access Point.

• Idle time is reported for all metered applications, even if no control profile is used.

• You can view information on idle time in your environment in some reports.  

• If an application that doesn't have focus is metered, activity log reports in Reporting will show the
entire launch as being idle.

Related information
Admin_Overview_Wait_list.xml#concept1878
Admin_Predefined_authentication_profiles.xml#concept2375
../admin_how_to/Admin_How_to_configure_idle_time_options.xml#concept2224
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Wait List
You can give users the option of placing themselves on a wait list when they attempt to launch a
concurrent application and all its licenses are in use.

If users are on a wait list, they're notified when a license becomes available so they can decide whether to
launch the application at that time.

To allow users to wait for concurrent applications:

1. From the New Control Profile dialog box, select the Authorization tab.

2. Apply a control profile that has Allow user to request notification when concurrent license is
available checked.  

Notes:

• If there are multiple users on the wait list for an application, the user who has been waiting the
longest generally gets the opportunity at the first available license. The exception to this is if that
user is not part of any allocation group you've set up for the application's licenses, or is part of an
allocation group that is currently using all of its allotted licenses.

• In the Advanced tab of the Agent Options dialog box, you can specify how long a user has to launch
a wait-listed application before it goes to the next waiting user.

• Once a license becomes available, the first eligible user is notified via a dialog box. The user must
launch it within a set period of time, or the user is removed from the wait list and the next user on
the wait list is notified.

• Users are removed from wait lists when they log out from or shut down their machines.

• You can view information in some reports on the wait list feature's use in your environment.   

Related information
../admin_how_to/Admin_How_to_set_up_the_wait_list_feature.xml#concept2402
../admin_dialog_boxes/Admin__HID_DCLIENT_OPTS_ADVANCED.xml#concept3501

571

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_How_to_set_up_the_wait_list_feature
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin__HID_DCLIENT_OPTS_ADVANCED


License Units, Suites, and Applications
As you use Cherwell Asset Management, you'll notice that the term "license unit" is used in places where
you may expect to see the terms "application" or "suite." This is because Cherwell Asset Management
groups versions of a given application or suite (which consist of two or more related applications) into
license units for information collection and reporting purposes. This grouping allows license counts to
apply to a group of applications that may have differing version numbers, but are grouped under the same
licensing agreement.

In Cherwell Asset Management, license units, suites, and applications are defined as follows:

• License unit—A collection of one or more versions of suites or applications used in reporting to
determine which products are present on machines throughout the company in order to ensure
license compliance. Typically, the applications or suites that make up a license unit differ only by
version. Control and metering are also implemented at the license unit level.

• Suite—A collection of two or more applications that are sold as a bundle (for example, Microsoft
Office) in several possible configurations.

• Application—A collection of one or more main executables and related support files. Presence of
the main executable file is the primary means of identifying which license units are on which
machines.
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Automatically Configuring Applications
As you use Cherwell Asset Management, inventory and usage information is collected from:

• Windows machines where the CAM Agent is installed.

• Machines that were discovered via the agentless Linux/Unix/Mac OS discovery feature.

When you start CAM Administrator, Cherwell Asset Management checks whether there are any new files
that have been collected that are identified in the Cherwell Software Identification Database (CSID).

• For Windows applications, you are prompted to decide whether to configure these applications into
license units. You can also decide whether to configure both exact match and close match
application files. It's recommended that you answer Yes in most cases to save yourself the work of
manually converting these applications into license units.

• For Linux, Unix, and Mac OS applications, you are prompted to go to the Unconfigured Applications
panel. From there, it's recommended that you first move the applications you don't want to track into
the Don't configure folder and then configure the remaining applications; see How to configure
Linux, Unix, and Mac OS applications for details.

The automatic configuration process runs at these times for Windows applications:

• When you first start CAM Administrator.

• When you run the Setup Wizard.

• When you click Automatically Configure Applications from the Tools menu.

• Once a day for evaluation versions of Cherwell Asset Management; once a week otherwise. You
can change this behavior using the Schedule tab of the Options dialog box.
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License Unit Template
The license unit template contains default values for license unit properties. This template and the values
it specifies are used whenever new license units are created. You can change license unit properties once
the license unit is created, but the values in the license unit template provide the initial values for these
properties.

When a file is recognized and automatically converted to a license unit, if the application's main
executable name and file version do not match those of an existing license unit, a new license unit is
created. Default values for the new license unit are taken from the license unit template dialog box.
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License Units Groups
You can create your own categories to help you keep track of configured license units and filter reports in
Reporting. To do so, simply create a license unit group.

Any license unit groups you create will show up in the left pane of the License Units panel.

For example, you could create a license unit group called "Shareware" and then store all the shareware
applications found on your network's machines in that group.

A license unit group is created as a top-level folder in the tree unless an existing group is selected. If an
existing group is selected, the new group is created as a subgroup of the selected group.
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Alternate Executables
In some cases, a given license unit may contain multiple executable (.exe) files. Alternate executables are
files with .exe extensions capable of starting the application contained in the license unit.

To specify alternate executables, use the Add as Alternate Executable dialog box.

Note: In most cases, an application can be identified by a single main executable with other
executables categorized as support files. Specifying an alternate main executable is only required
if the presence of an application cannot be determined by a single executable file.
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Purchase Required Setting
You can use the Purchase required setting in the General tab of the License Unit Properties dialog box
to specify whether an actual purchase is required in order for that license unit to be considered compliant.
Almost all software titles require that you agree to licensing terms when you install, but some (for
example, Adobe Reader, Google Chrome, and .NET) do not require any form of payment. The options for
the Purchase required setting are Yes, No, and Unknown. Here are some tips on how to use these
options:

• Select Yes for any license units for which you do want to require purchases. Doing so will make it
easier for you to manage your site's long list of license units, and to use filters in reports.

• Select No for any license units that don't require payment (such as those mentioned above).

• For automatically configured applications, the CSID determines this setting.

• If this setting is set to Unknown, this means that there is no purchasing data available for that
license unit. This choice is the best option for license units that are not important to monitor for
compliance, or for which you have not yet entered purchasing information. You can always change
this setting later.
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Deleting License Units
You can delete any license units that you're sure you don't want to monitor or view in reports.

When you delete a license unit:

• You will not be able to meter or control the license unit's applications.

• The license unit name appears in the Deleted license units list in the left pane; it no longer appears
in the Full list or in any other folder.

• The license unit is not added back the next time the automatic configuration process runs.

• You can restore any deleted license units that still appear in the Deleted license units list.

What Is the Difference Between Deleting a License Unit and Unconfiguring It?
When you delete a license unit, the above rules apply. When you unconfigure it, it is moved to the
Unconfigured Applications panel. By default, any applications in the Identified subfolders in this panel are
configured into license units the next time the automatic configuration process runs. You can move the
unconfigured application to the Don't configure folder to prevent that behavior.
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CAM System License Units
A CAM System License Unit is a license unit that Cherwell Asset Management automatically configures
that contains the applications that are also included in a GUID-based license unit that was automatically
configured. For example, the applications that make up the Microsoft Office suite (Microsoft Word,
Microsoft Excel, and so on) are CAM System License Units.

You can use the CAM System License Units dialog box to specify which of these license units are to be
hidden and displayed.

The most common reason to use this feature is to make visible previously hidden license units that
contain the applications mentioned above. Most organizations won't need to use this feature.

Note: Hidden CAM System License Units will automatically become visible if a machine launches
or inventories them. For example, if a machine has a standalone version (not part of Microsoft
Office) of Microsoft Word, the Microsoft Word CAM System License Unit will change from hidden
to visible as soon as that machine is inventoried or Microsoft Access is launched from that
machine. You can view the CAM History report for the license unit to see why it became visible.
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GUIDs
GUIDs (Global Universal Identifiers) are unique identification strings that help Cherwell Asset
Management distinguish one version of an application from another in situations where there may be no
difference between editions in the size of the main executable file.

The GUID string is used to determine the version of the application, and can also distinguish whether the
application was sold separately or as part of a suite with other products. (For example, a GUID associated
with Microsoft Office 2013 distinguishes it from Microsoft Word as a standalone application.) The Cherwell
Software Identification Database (CSID) includes GUID information for suites such as Microsoft Office
and other non-suite applications where needed.

Unless you're absolutely certain of the GUID assigned to the application or suite in question, leave any
GUID text boxes in Cherwell Asset Management dialog boxes blank. Entering an invalid string in a GUID
text box will cause that application to be misidentified.
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Updating vs. Upgrading
The terms "update" and "upgrade" are often used interchangeably, but have different meanings in
software terminology:

• An update is a minor release (say, from 12.0 to 12.01) of a software product. An update may
include minor software enhancements and address known issues, and it is usually free to current
customers of the product. An update does not usually require that you perform a complete re-install
of the software.

• An upgrade is a major release (say, from 12.0 to 12.1) of a software product that provides new
features and improvements over an earlier version. An upgrade is not generally free, but current
customers of the product are usually offered the upgrade for a reduced price (as opposed to the full
price paid by new customers).  An upgrade usually requires a complete installation process.

Note: When the agent self-upgrade feature is enabled on machines, those machines will receive
updates as well as upgrades of the CAM Agent software.
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Software Categories and Groups
Cherwell Asset Management uses software categories to group like license units by function in the
Cherwell Software Identification Database (CSID).

Predefined software categories are organized into category groups, and are shown in the left pane of the
License Units panel, which can make it easier for you to find specific license units by function. For
example, the Business function specific category group includes categories like Bar coding, Office suites,
Project management, and others.

Note the following about software categories and groups:

• You can rename software categories and groups. When you do so, the new name appears in the
License Units panel and in the Properties dialog boxes of affected license units, but the original
names in the CSID are unchanged.

• You can move license units from one category to another, but once moved, you cannot revert a
license unit to its original category. Instead, you can find the license unit in the full list and either
drag it to another category or change its category in the license unit's Properties dialog box.

• You can create your own software categories and groups. Categories and groups you add are not
overwritten when you install updates to the CSID.

• You can only delete any user-created software categories and groups. If the category you want to
delete contains license units, you are prompted to confirm the operation. Any license units that were
in that category still exist, but are not part of any category.
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Files
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Don't Care Files
You can select I don't care about this file for any files that you don't want to convert into license units for
tracking. For example, you might not care about tracking any non-licensed internal applications, so you
could select I don't care about this file for each of these files; then they will no longer show up when you
search for unconfigured files.

"Don't care" files will show up in the Files panel only when you run a file search for them.
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Support Files
Support files are executable files that are separate from the main application executable file. Support files
usually have .com or .exe extensions and are not licensed separately from the main application. Support
files are identified by the Cherwell Software Identification Database (CSID) for metering purposes.

Support files are typically launched by the main executable file.

Notes:

• Support files are used by the metering agent and make it appear as though the application is still
running even after the main executable is shut down. An application is recorded as launched when
a main executable file starts, and is recorded as stopped only after the main executable file and all
support files have stopped running. Support files are also included in the CSID to help reduce the
number of files you have to manually configure.

• The information in this topic applies to the Windows platform only.
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Non-runnable Files
By default, Cherwell Asset Management only inventories runnable files, meaning those with .exe or .com
extensions. To inventory non-runnable files, use the Add Extension dialog box to specify that Cherwell
Asset Management should inventory files with extensions other than .exe and .com.

Notes:

• Non-runnable files cannot be configured into license units, and are not visible in the Files panel
unless you search for them.

• The information in this topic applies to Windows machines only.
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Machines
In Cherwell Asset Management, the term "machine"’ refers to computers on your organization’s network.
Machines are listed in the Machines panel and are shown in categories based on platform, the install
state of the CAM Agent (Windows machines), how and where they were discovered, and any other
grouping you have defined.

Once the CAM Agent is installed on a Windows machine or you've collected inventory data from a Linux,
Unix, or Mac OS machine, a machine represents not only the physical presence of the hardware in your
environment, but the inventory and usage information collected from it.
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Searching for Machines
 Getting There

You can search for machines by name, IP address, or last logged-in user.

How to Search
To search for machines:

1. In the left pane, select the machine grouping to search.

Note: The Search text box is not available when the selected machine grouping does not
contain any machines.

2. Type the text to search for in the text box, then press Enter or click the magnifying glass icon.
Wildcards are automatically added to the beginning and end of the text you enter.

All machines with names, IP addresses, or last logged-in users that meet the search criteria are shown in
the right pane.

How to Clear Results
To clear the results, do one of the following:

• Select X.

• Search for an empty string.

• Click a different machine grouping.

Tips:

• If you don't see the expected results, verify that the correct machine grouping is selected in the left
pane.

• Select the topmost grouping, Machines, to search all machines.

• Press Ctrl+F from anywhere in the Machines panel to start typing in the Search text box.
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Deleting Machines
There may be situations where you want to delete machines from the Machines panel. For example:

• A machine is physically removed from the network.

• You ran the discovery process but are really only interested in collecting data from certain machines
(say, those used in a particular department).

When you delete a machine:

• The machine name appears in the Deleted machines list in the left pane; it no longer appears in the
Full list or in any other folder.

• The machine no longer appears in any user-defined groups, discovered groups, and profiles it
belonged to before the deletion.

• The machine is not added back to any machine lists when you next run discovery.

• The machine's inventory information is removed from the CAM Database; metering (usage) data,
which contributes to the accuracy of peak usage information, is not deleted until the database is
reset with a date that is later than the data, and you can still view this information in reports.

• If any software licenses were allocated to that machine, those licenses are released.

• If the CAM Agent is installed on the machine, Cherwell Asset Management uninstalls it. You are
prompted for credentials.

• You can restore deleted machines that still appear in the Deleted machines list.

Related information
../admin_how_to/Admin_How_to_delete_machines_from_the_Machines_list.xml#concept1239
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Machine Groups
Machine groups are collections of machines that you define. When you first start using Cherwell Asset
Management, only the predefined machine categories (installed, uninstalled, and so on) exist. Machine
groups are also created as a result of the machine and user discovery process. Use machine groups to
help organize your machines in ways that make sense for your organization, for use in reports, and to
indicate contract affinity in Purchasing .

Any machine groups you create will display in their own folders in the Machines panel, and you can use
machine groups to allocate concurrent licenses of an application.

The group is created as a top-level folder in the tree unless an existing machine group is selected. If a
machine group is selected, the new group is created within that existing group.
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Agent Status Messages
The following are the agent status messages that can appear in the Last install status column in the right
pane of the Machines panel:

• Agent connection properties update started—The process of updating the CAM Access Point or
proxy server for the selected machine(s) has started. Updates may take up to 20 minutes to
complete, and any additional operations you attempt for the selected machine(s) will be ignored
during that time.

• Agent connection properties update succeeded—The update is complete; the new CAM Access
Point or proxy server assignment takes effect.

• Enabled Agent self-upgrade—The selected machine(s) will upgrade to a new version of the CAM
Agent when available.

• Failed agent connection properties update—The attempt to update the CAM Access Point or
proxy server assignment for the selected machine(s) failed, and the connection properties remain
unchanged.

• Failed agent self-upgrade—The self-upgrade process on the selected machine(s) failed and the
earlier version of the CAM Agent remains on the machine(s).

• Failed install—The CAM Agent was not installed on the selected machine(s) and no files were
copied to it.

• Failed install; OS not supported—The CAM Agent was not installed because the selected
machine(s) are running an operating system that does not meet the requirements for running it.

• Failed uninstall—The CAM Agent and its files were not successfully removed from the selected
machine(s).

• Failed upgrade—The attempt to upgrade the CAM Agent failed and the earlier version of it remains
on the machine.

• Install started—The process of installing the CAM Agent on the selected machine(s) has started.
Installations may take up to 20 minutes to complete, and any additional operations you attempt for
the selected machine(s) will be ignored during that time.

• Install succeeded—The CAM Agent and its files were installed on the selected machine(s).

• Not installed—The CAM Agent is not present on the selected machine(s).

• Pending install/update—An installation, upgrade, or connection property update is pending. This
operation may take up to 20 minutes to complete, and any additional operations you attempt for the
selected machine(s) will be ignored during that time.

• Pending uninstall—The uninstall process is pending; the message will change to "started" once
the operation is underway.

• Terminal Server Metered—The CAM Agent is not installed on the selected machine(s), but is
connected to a machine that has the CAM Agent installed on it via Remote Desktop or some other
Terminal Server software. These machines (the machines without the CAM Agent installed on them)
will be displayed in the "Not installed" folder on the left side of the Machines panel, but you can still
check out licenses for those machines and view activity.
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• Uninstall started—The process of uninstalling the CAM Agent from the selected machine(s) is
underway. Uninstalls may take up to 20 minutes to complete, and any additional operations you
attempt for the selected machine(s) will be ignored during that time.

• Upgrade started—The process of upgrading the CAM Agent on the selected machine(s) has
started. Upgrades may take up to 20 minutes to complete, and any additional operations you
attempt for the selected machine(s) will be ignored during that time.

• Upgrade succeeded—The CAM Agent upgrade on the selected machine(s) is complete.

• Waiting for agent check-in—The CAM Agent files are installed on the selected machine(s); once
the machine(s) check in with the CAM Access Point (which may take a few minutes), the status will
change to one of the following, depending on the situation:  "Install succeeded," "Upgrade
succeeded," or "Agent connection properties update succeeded."

You can always press F5 or click Refresh from the View menu to refresh the display and see if the
message has changed.

Note: The information in this topic applies to Windows machines only.
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Agent Self-upgrade Feature
The agent self-upgrade feature lets you specify that machines automatically receive new versions of the
CAM Agent software when available, without further intervention from an administrator.

This streamlines the agent update/upgrade process.

Note: The information in this topic applies to Windows machines only.

Instead of installing the CAM Agent on machines and then repeating the process every time an update or
upgrade is available, you can set up this feature and keep the files in the network share location up to
date.  Every time you re-enable machines for self-upgrades, those machines are upgraded the next time
they check in with their CAM Access Point (this check-in is also known as the "heartbeat"). Any machines
that are powered off when a new version becomes available are self-upgraded at the second heartbeat,
not immediately upon startup.
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Proxy Server Environments
Cherwell Asset Management supports proxy server environments. You can specify that machines use a
proxy server as well as a proxy bypass when you install the CAM Agent.

Important: Proxy information for the CAM Agent is stored in a Registry location on the machine
where the CAM Agent is installed and is used by all applications that utilize WinHTTP. For this
reason, setting or changing the proxy settings can impact other applications running on that
machine.

Related information
../admin_troubleshooting/Admin_Overview_Proxy_server_issues.xml#concept272
../admin_troubleshooting/Admin_Troubleshooting_proxy_server_settings.xml#concept3643
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SCOM Integration
If your organization uses Microsoft System Center Operations Manager (SCOM), you can import certain
machine properties from SCOM into Cherwell Asset Management for viewing in the Machine Summary
and Machine Properties reports. Note that SCOM data can only be collected from discovered machines.

Related information
../admin_how_to/Admin_How_to_import_SCOM_data.xml#concept1110
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Virtual Machines
A virtual machine is a software-based environment that emulates a computer. Cherwell Asset
Management supports virtual machines in the following ways:

• You can configure Cherwell Asset Management to discover any virtual machines hosted by VMWare
and Hyper-V Servers on your network.

• During the inventory process, Cherwell Asset Management identifies any virtual machines in your
network as well as the name of each virtual machine's host, if available.

• In the Machines panel, you can customize the columns to include a VM type (guest or host) and VM
host name column. Virtual machine information is also available in each affected machine's Machine
Summary report.

Related information
../admin_discovery/Admin_How_to_discover_virtual_machines.xml#concept3918
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Linux/Unix/Mac OS Machines
CAM Administrator supports agentless discovery from machines running the following platforms:

• Linux
◦ Red Hat Enterprise versions 7.x, 6.x, and 5.x

◦ CentOS version 7.2

◦ Fedora version 24

◦ SUSE Enterprise Server version 11 SP4 and above

◦ Oracle Linux version 6.8 and above

• Unix
◦ Oracle Solaris versions 11 and 10

◦ IBM AIX versions 7.2 and 7.1

• Mac OS
◦ Versions 10.8 and above

Notes:

• If you have machines you want to track that run other Linux or Unix operating systems or versions
not listed here, please contact us.

• The agentless discovery process may collect some information from machines on unsupported
platforms.

• To track machines with earlier versions of the Mac OS, see How to Collect Inventory Data from Mac
OS Machines.
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Network Devices
For the purposes of Cherwell Asset Management, network devices are devices that are SNMP-enabled
and thus available for discovery and data collection. You can also view information about network devices
in some reports. Network devices can include printers, routers, switches, and so on. .

Cherwell Asset Management supports network devices in the following ways:

• You can configure Cherwell Asset Management to discover network devices on your network.

• In the Network Devices panel, you can view all available information on discovered devices,
customize the columns to show or hide different properties, and view the selected device's Network
Device Summary report.

• You can create network device groups to organize network devices and for use in filtering in reports.

• You can modify the network device template to include additional properties for discovery, as well as
additional object identifiers (OIDs).

Related information
Admin_Overview_Network_devices_vs_other_assets.xml#concept1627

598

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overview_Network_devices_vs_other_assets


Network Devices vs. Other Assets
The terms "network device" and "other asset" can both be used to describe hardware items like routers,
switches, printers, and so on. For the purposes of Cherwell Asset Management, the primary difference
between the two terms is that network devices are SNMP-enabled devices and thus available for
discovery.

Other assets, on the other hand, are any devices or assets that you manually add to your Cherwell Asset
Management configuration. In earlier versions of Cherwell Asset Management, you may have manually
added hardware devices that are actually SNMP-enabled.

In general, if your hardware items are SNMP-enabled, it's best to discover them and view the information
that is collected on them. With other assets, you have to manually create them and specify their
properties.

Tip: Users of pre-12.0 versions may want to discover network devices, and then consider deleting
any other assets that are now duplicates of the discovered network devices.

Groups and Reports
You can create groups of network devices as well as groups of other assets, and use those groups for
filtering in reports.

In CAM Administrator, you can select a network device and then open its Network Device Summary
report. Reporting includes a Network Devices report as well as an Other Assets report for viewing
information about your non-computer hardware items.
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SNMP Credentials
The SNMP credentials you need to enter when configuring network device discovery vary depending on
what version of SNMP is enabled on the devices you want to discover.

All SNMP Versions
For all SNMP versions, you also have the option to enter text into the Notes field to help you later identify
your saved configuration.

SNMP v1 or v2
For SNMP v1 or v2c devices, all you need to enter is the SNMP community string, which is set to "public"
by default.

SNMP v3
For v3 configurations, you need to enter the following information, as specified by the administrator who
set up the SNMP devices:

•  User name
• Authentication method and corresponding Password/Key—The authentication method options

are None, MD5, and SHA. If the SNMP v3 device(s) you want to discover don't require an
authentication method, select None; no further information is required. If your devices use MD5 or
SHA, you will also need to enter the corresponding password/key.

• Privacy/encryption method and corresponding Password/Key—The options here are None, DES,
and AES, and you must select an option if you entered MD5 or SHA as the authentication method
above. DES and AES privacy/encryption methods also require a password/key.

Password/key information is encrypted when stored in the CAM Database.
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Network Device Groups
Network device groups are collections of network devices that you define. When you first start using
Cherwell Asset Management, only the predefined network device categories (by device type,
manufacturer, and so on) exist. Any groups you create are added to the list of categories to the left of the
Network Devices panel.

You can use network device groups to help organize your devices in ways that make sense for your
organization, and for use in filtering in reports.
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Network Device Template
You can use the network device template to add additional properties for discovery, as well as additional
object identifiers (OIDs). You can only change or delete user-defined custom properties. Any properties
that are fixed are defined in the Cherwell Software Identification Database (CSID) and you cannot change
them.

The Network Device Template dialog box contains one tab: Custom Network Device Data, where you can
view, add, change, and delete custom properties. Any fields that are listed in this tab, both fixed and
custom, are available for you to select whenever you use the New/Change Custom Data Property dialog
box to add a new custom property for network devices.
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Other Assets
Besides tracking machines in your network, you can specify that Cherwell Asset Management tracks
"other assets" in your network that are not SNMP-enabled.

Other assets include any non-computing devices you want to track that are not SNMP-enabled. Unlike
machines, these assets are not found during discovery, but you can manually add them to your CAM
Database. Once you add an asset, you can then view it in the Other Assets panel, add it to groups of
assets, and modify its properties. You can report on other assets in reports.

Note: In order to use the other assets feature, you must be licensed to use Cherwell Asset
Management's inventory component. Contact us for information if you need to upgrade your
license.

Related information
../admin_network_devices/Admin_Overview_Network_devices_vs_other_assets.xml#concept1627
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Asset Groups
Asset groups are collections of assets (user-defined devices other than the machines that are found
during discovery) that you define. When you first start using Cherwell Asset Management, only the
predefined asset categories (by manufacturer, by asset type, and so on) exist in the Other Assets panel.
You can use asset groups to help organize your assets in ways that make sense for your organization,
and for use in filtering reports.

Any asset groups you create are listed in their own folders in the Other Assets panel.

The group is created as a top-level folder in the tree unless an existing asset group is selected. If an asset
group is selected, the new group is created within that existing group.
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Users
For the purposes of Cherwell Asset Management, a user is someone who logs onto a machine on which
the CAM Agent is installed, or on which inventory has run.

All users discovered in your environment are displayed in the Users panel; however, users are only
reported on in conjunction with data from a machine running the CAM Agent.

You can create user groups in CAM Administrator; you can also add and delete users from user groups,
and delete users from the Users panel entirely.
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Deleting Users
There may be situations where you want to delete users from the Users panel. For example:

• A user leaves the organization but the network administrator hasn't yet deleted the user account
from Active Directory or the domain.

• You ran the discovery process but are really only interested in collecting data from certain users
(say, those who work in a particular department).

When you delete a user:

• The user name appears in the Deleted users list in the left pane; it no longer appears in the Full list
or in any other folder.

• The user no longer appears in any user-defined groups, discovered groups, and profiles it belonged
to before the deletion.

• The user is not added back to any user lists when you next run discovery.

• You can restore deleted users that still appear in the Deleted users list.

Note: When Administrator user policies are enabled, you cannot delete users who have user
policies applied to them.  

Related information
../admin_how_to/Admin_How_to_delete_users.xml#concept1118
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User Groups
User groups are groupings of users that you define. When you first start using Cherwell Asset
Management, there are no user groups. Use these groups to help organize your users in ways that make
sense for your organization. You can use user groups to control what data is displayed in certain reports,
and to indicate contract affinity in Purchasing.

Any user groups you create will display in their own folders in the Users panel.

The group is created as a top-level folder in the tree unless an existing user group is selected. If a group
is selected, the new group is created within the existing group.
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Welcome to the Import Wizard
Use this wizard to import user-defined machine properties from an Excel file into Cherwell Asset
Management. Before you can use this wizard, you must have already defined machine properties; see
Agent Options Custom Tab for help with that.

The wizard guides you through the process of importing this user-defined data, with screens that prompt
you to enter the appropriate information at each step. You can always press Back if you need to change
information you entered on a previous screen, and you can press the Cancel button at any time. If you
need help with any of the wizard's screens, click the Help button on the bottom left of the screen.

Notes:

• You can only import Microsoft Excel files.

• If you cancel an import operation, no records are imported.

Click Start on the Welcome screen to begin the import process.
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Select Filename Dialog Box
Click the Browse button and navigate to the Excel file that contains the user-defined data you want to
import. Select a file, and then click Next to continue.
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Select Worksheet Dialog Box
The worksheets contained in the Excel file you selected in the previous screen are listed here. Any named
ranges in your worksheets are also listed. Click the worksheet or range that contains the user-defined
data you want to import, and specify whether the worksheet's or range's first row of data contains column
headers. Click Next to continue.

Note: You can only select one worksheet or range at a time.  
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Select Fields Dialog Box
This final step tells the wizard what columns in your spreadsheet map to values you want to input. The
Excel file must include, at a minimum, columns containing the name and domain of each machine for
which data is to be imported.

Select which field corresponds with which column from the Excel file, and then click Finish to start the
import process.

The data in the Excel spreadsheet is imported into Cherwell Asset Management. When the import is
complete, a summary of the operation is displayed. Click Close to close this dialog box, or View Log if you
want to view details of the import process.
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Importing Asset Information
Cherwell Asset Management includes an Asset Import Wizard that you can use to import asset
information from an Excel spreadsheet into the CAM Database. The spreadsheet must be in Excel 8.0
format or later. You can import the following information:

• Asset name
• Serial number
• Description

• Type

• IP address

• Manufacturer

• Cost

• Purchase date

• Location

• Owner

• Date maintenance agreement expires

• Notes

• Any custom fields you created

Note: The Excel spreadsheet you want to import must contain, at a minimum, columns that
correspond to the required fields in bold above. However, although a column that corresponds to
the Serial number field is required, its cells can be blank; no actual serial numbers are required in
the spreadsheet. The other items are optional.
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Welcome Screen
Use this wizard to import information about other assets from an Excel file into your CAM Database. The
wizard guides you through the process of importing this data, with screens that prompt you to enter the
appropriate information at each step. You can always click Back if you need to change information you
entered on a previous screen, and you can click Cancel at any time. If you need help with any of the
wizard's screens, click Help at the bottom left of the screen.

As you work in this wizard, keep in mind that columns in your spreadsheet correspond to asset fields. (For
example, you may have a column in your spreadsheet that's labeled SN that matches up to the field that
Cherwell Asset Management calls Serial #.) Each row in your spreadsheet corresponds to a single asset.

As noted on the Welcome screen, you can import more information besides the basic information such as
asset type, IP address, and so on. If you want to import additional information, first create the fields you
want to import.

Notes:

• You can only import Microsoft Excel files.

• If you cancel an import operation, no records are imported.

Click Start on the Welcome screen to begin importing asset data.

Related information
../Admin_Overview_Importing_asset_information.xml#concept1058
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Choose Rule Set Dialog Box
Use this dialog box to create a new rule set (a group of settings used in the import process), re-use or
modify a rule set you previously saved, or to delete an existing rule set.

To create a new rule set based on the settings you choose as you go through this wizard, click Create a
new rule set and click Next to continue.

If you saved a rule set (settings you configured when you previously ran the Asset Import Wizard), you
can open that rule set here. You'll have the opportunity to modify or verify how to match up your
worksheet with the terms Cherwell Asset Management uses. Select the Use/modify existing rule set
option, and then select a rule set from the drop-down list box. Click Next to continue.

To delete an existing rule set, select the Delete Rule Set button. A dialog box opens where you can select
the rule set you want to remove.
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Prepare Data Dialog Box
Please wait while Cherwell Asset Management prepares to import the asset data you've specified. After
data preparation is complete, you'll see a preview of the results and have the opportunity to verify that you
want to complete the import operation.
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Preview Window
This window provides a preview of what your imported asset data will look like so that you can verify that
the results will be what you expect. This preview window shows all columns that will be imported, plus
their corresponding row numbers. Note that this window only shows rows that contain an asset name; any
rows that do not contain at least this information are not imported.

You can use the items on this window's toolbar to perform these operations:

• Back—Go back to the previous screen. You can step your way back through the wizard at any time
to make changes to your previous selections.

• Import—Proceed with the import.

• View Log—Open a text-only log file of the import operation in Windows Notepad. This log file
contains detailed information about the import operation.

• Open Worksheet—Open the spreadsheet in Microsoft Excel. Here you can correct any errors and
then save your spreadsheet.

• Refresh—If you made changes to your worksheet or import operation since this preview first
appeared, click this button for an updated preview.

• Cancel—Cancel the import operation.

• Help—Open the Help topic for this window.

Tips:

• The Row# field in the preview window corresponds to the first row in your worksheet that contains
data. For example, if the first two rows of your worksheet are blank, the third row of your worksheet
(the first one that contains data) will appear as Row 1 in the preview window.

• You can only import 1000 rows of data in one operation. If you receive an error to this effect and
your spreadsheet contains fewer than 1000 rows with actual data, do the following: Click the Open
Worksheet button and delete the rows from your worksheet that you are not concerned with. Even if
the rows are empty of data, you still need to delete them rather than merely clear them, or Cherwell
Asset Management will still try to import their (nonexistent) data.
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Select Fields Dialog Box
In this screen, you assign columns in your worksheet to the asset field names that Cherwell Asset
Management uses to store asset data, and specify whether the first row of each column in your worksheet
is a column header or actual data.

To start, click the drop-down list that is next to the Asset name (required) field to see a list of all column
headers in the current worksheet. Click the one that corresponds to the asset's name. (For example, you
may have a column called Device or Name that contains this information.)

If you're not sure what fields in the worksheet correspond to what asset fields, you may want to open your
spreadsheet and then the appropriate worksheet in Microsoft Excel to investigate. You can have the
spreadsheet open at the same time that you are running the Asset Import Wizard. You'll have a chance to
preview the results later in the wizard, so you can make assignment changes then if necessary.

Continue matching worksheet columns with Cherwell Asset Management asset fields. You'll need to
match columns with fields for the Asset name and Serial number fields. Assigning worksheet columns to
the other fields is optional, but you may find it helpful to import this information as well if your spreadsheet
contains that data.

By default, the final option (First row of data contains column headers) is selected. You should only clear it
if you know that your worksheet does not include column headers in its first row (in other words, if the
columns are unlabeled). If your spreadsheet does not have column headings, you will see the first row of
actual asset data in the drop-down lists described above.
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Select Filename Dialog Box
Click the Browse button and navigate to the Excel file that contains the asset data you want to import.
Select a file, and then click Next to continue.

The Excel spreadsheet you want to import must, at a minimum, contain columns that are equivalent to the
following asset fields:

• Asset name

• Serial number (which can be blank)

Your spreadsheet may also contain columns that are equivalent to the following asset fields:

• Description

• Type

• IP address

• Manufacturer

• Cost

• Purchase date

• Location

• Owner

• Maintenance expires

• Notes

• Any custom fields you created

You'll specify how to match up the columns in your spreadsheet with asset fields in the CAM Database in
a subsequent step.
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Select Worksheet Dialog Box
The worksheets contained in the Excel file you selected in the previous screen are listed here. Any named
ranges in your worksheets are also listed. Click the worksheet or range that contains the asset data you
want to import, and then click Next to continue.

You'll have a chance to preview the results later in the wizard, so if you mistakenly select the wrong
worksheet or range, you'll have the opportunity to go back and select another one at that time.

Note: You can only select one worksheet or range at a time.
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User Policies
 This topic applies to: CAM authentication

You can use the following types of user policies to restrict or enable access to all or portions of the
product. See the following links for more information on each type:

• Administrator User Policies

• Purchasing User Policies

• Reports and License Analytics User Policies Dialog Box

Note: If you use CSM authentication, you control who can use Cherwell Asset Management from
within Cherwell Service Management.

Related information
../admin_csm_authentication/Admin_Overview_Authentication.xml#concept6703
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Administrator User Policies
 This topic applies to: CAM authentication

Administrator user policies allow you to set up multiple CAM Administrators. Once enabled, you can give
specific users full administrator or limited permissions to perform tasks in the CAM Administrator. You can
also completely block specific users from launching CAM Administrator.  

For example, you may want to allow a member of the IT department to install the CAM Agent on
machines. In this case, you can give this user permission to view and use the Machines and Users panel,
while preventing this user from viewing or using the License Units, Unconfigured Applications, Files, and
Other Assets panels.

Note: By default, Administrator user policies are disabled. The first user who selects Enable
Administrator user policies is configured as the CAM system administrator, with administrator
privileges.

When Administrator user policies are enabled, three levels of permissions are available:

• Administrator permissions: Can perform any and all tasks in CAM Administrator. For more
information, see Administrator and User Permissions.

• User permissions: Can only perform tasks in the areas you specify. For more information, see
Administrator and User Permissions.

• Not authorized: Cannot launch or perform any tasks in CAM Administrator.

Notes:

• Only users with administrator permissions can enable and disable Administrator user policies, grant
permissions, and deny access to other users.

• When Administrator user policies are enabled, no user can delete users who have user policies
applied to them.

• If you use CSM authentication, permissions to Cherwell Asset Management are controlled from
within Cherwell Service Management.

Related information
../admin_csm_authentication/Admin_Overview_Authentication.xml#concept6703
Admin_More_information_on_user_policy_permissions.xml#concept7850
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Purchasing User Policies
 This topic applies to: CAM authentication

Purchasing is an optional web-based component that allows you to track purchasing and licensing
information for software and hardware assets in your network. If your site is licensed to use it,
administrators can use Purchasing user policies to set up access profiles; this makes orders accessible to
certain users or groups, and you can apply different access profiles to different orders to control who can
view and edit them.

This feature is to be set up by Purchasing administrators only.

To set up Purchasing user policies:

1. From within CAM Administrator, select Tools, then select User Policies and Authentication.

2. Select Purchasing ...
3. In the Purchasing User Policies dialog box, check Enable Purchasing user policies.

Note: By default, Administrator user policies are disabled. The first user who selects Enable
Administrator user policies is configured as the CAM system administrator, with
administrator privileges.

4. Once this feature is enabled, click View Purchasing on the toolbar to open Purchasing, and then
click the Administration tab to create access profiles that control who has access to purchasing
records.

Note: Control over who can use Purchasing is managed from within Cherwell Service
Management. If you use CSM authentication, you still use access profiles in Purchasing.

Related information
../admin_csm_authentication/Admin_Overview_Authentication.xml#concept6703
../../cam_purchasing/Purch_How_to_add_an_access_profile.xml#concept1831
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Access Profiles
For CAM only: Access profiles control who has access to orders in Purchasing.  When Purchasing user
policies are enabled in CAM Administrator, you can use access profiles in Purchasing to control who can
view, edit, and create orders. For more information, see How to Add an Access Profile in Related
Content.

For CSM only: For sites that use CSM authentication, CSM user teams function as access profiles.
Migrate any existing CAM access profiles to CSM user teams after you move to CSM authentication. For
more information, see Migrating Access Profiles in Related Content.
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Reporting and License Analytics User Policies
 This topic applies to: CAM authentication

Reporting and License Analytics user policies control who can use Reporting (with roles you specify) and
License Analytics.

This feature is to be set up by Reporting administrators only.

Note: By default, these user policies are disabled. The first user who selects Enable Reporting
and License Analytics user policies is configured as the CAM system administrator, with
administrator privileges.

To use Reporting and License Analytics user policies:

1. From within CAM Administrator, select the Reporting and License Analytics User Policies dialog
box.

2. Select Enable Reporting and License Analytics User Policies.

3. From the toolbar, select View Reports.

4. Select the Administration tab to add or delete users, and to assign specific roles to users that give
them full or limited permissions. On this tab, you can also prevent certain users from viewing these
reports.

For more information about configuring user policies and roles, see Administration Panel.

Note: If you use CSM authentication, who can use Reporting and License Analytics is controlled
from within Cherwell Service Management.  

Related information
../admin_csm_authentication/Admin_Overview_Authentication.xml#concept6703
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Administrator and User Permissions

Overview
When you enable the CAM Administrator user policies feature or use CSM authentication to manage user
access, users can have full or limited functionality in CAM Administrator, Purchasing, and Reporting. This
topic provides details on what each type of permissions includes in both Cherwell Asset Management
(CAM) and the equivalent rights as configured in Cherwell Service Management (CSM).

Administrator Permissions

• Permissions Available to All Administrators

• Permissions Available to Reporting and License Analytics Administrators

• Permissions Available to Purchasing Administrators

Users without administrator permissions cannot do the following:

• Run the Setup Wizard

• Configure baselines

• Reset data

• Change the license key

• View all panels

• View and configure all tabs and options in the Options dialog box

• (CAM) Enable or configure user policies

User Permissions
The following topics list the permissions available to each panel. Panels that a user does not have
permission to access are not shown in CAM Administrator or the Status panel. (For example, users with
permissions to the Machines and Users panels will only see those panels; the License Units, Files,
Network Devices, and Other Assets panels will not be visible.)

• User Permissions for the License Units, Configured Applications, and Files Panels

• User Permissions for the Machines and Users Panel

• User Permissions for the Network Devices and Other Assets Panel

• User Permissions for the Restricted Purchasing Panel

• User Permissions for the Restricted Reporting Panel
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Users Who Are Not Authorized
Users designated as "Not authorized" in the Administrator User Policy dialog box cannot run CAM
Administrator.

Related information
../admin_csm_authentication/Admin_Overview_Authentication.xml#concept6703
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Permissions Available to All Administrators

All Administrator Permissions
The following permissions are available to all Administrators:

• Full permissions to CAM Administrator

• Run all CAM Administrator reports

• Full access to Reporting
◦ Add or remove administrators and users

◦ Change permissions

◦ Change filter owners

• Full access to License Analytics

• Full access to Purchasing
◦ Add/manage users/profiles

◦ Configure email

◦ Move orders/contracts among profiles

Users without administrator permissions cannot do the following:

• Run the Setup Wizard

• Configure baselines

• Reset data

• Change the license key

• View all panels

• View and configure all tabs and options in the Options dialog box

• (CAM) Enable or configure user policies

Related concepts
Permissions Available to Reporting and License Analytics Administrators
Permissions Available to Purchasing Administrators
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Permissions Available to Reporting and License
Analytics Administrators

Reporting and License Analytics Administrators have full access to Reporting and License Analytics, and
the following permissions:

• Add/remove administrators and users

• Change permissions

• Change filter owners

Related concepts
Permissions Available to All Administrators
Permissions Available to Purchasing Administrators
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Permissions Available to Purchasing
Administrators

Purchasing Administrators have full access to Purchasing, and the following permissions:

• Add and manage users and profiles

• Configure email

• Move orders/contracts among profiles

Related concepts
Permissions Available to Reporting and License Analytics Administrators
Permissions Available to All Administrators
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User Permissions for the License Units,
Unconfigured Applications, and Files Panels

Panels that a user does not have permission to access are not shown in CAM Administrator or the Status
panel. The following user permissions are available for the License Units, Unconfigured Applications, and
Files panels:

• View License Units, Unconfigured Applications, and Files panels

• Add, modify, or delete license units

• View or modify the license unit templates

• Automatically configure applications into license units

• Mark any unconfigured apps that you don't want to configure into license units

• Enable metering

• Configure control panels

• Add, delete, or modify license unit groups

• Organize files

• Run administrative reports related to license units

Related concepts
User Permissions for the Machines and Users Panel
User Permissions for the Network Devices and Other Assets Panel
User Permissions for the Restricted Purchasing Panel
User Permissions for the Restricted Reporting Panel
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User Permissions for the Machines and Users
Panel

The following permissions are available for the Machines and Users panel:

• View Machines and Users panels

• Inventory machines

• Install and uninstall the CAM Agent on machines.

• Run remote inventory

• Discover machines and users from Active Directory or NT domain

• Discover your virtual environment

• Discover Linux/Unix/Mac OS machines

• Discover Oracle database instances

• Launch the Remote Desktop Connection

• Open the Agent Options dialog box

• Check licenses in and out for selected machines

• Import machine data

• Add, delete, or modify machine groups

• Add, delete, or modify user groups

• Delete and restore machines

• Delete and restore users

• Run administrative reports related to machines and users

Related concepts
User Permissions for the License Units, Unconfigured Applications, and Files Panels
User Permissions for the Network Devices and Other Assets Panel
User Permissions for the Restricted Purchasing Panel
User Permissions for the Restricted Reporting Panel
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User Permissions for the Network Devices and
Other Assets Panel

Panels that a user does not have permission to access are not shown in CAM Administrator or the Status
panel. The following permissions are available for the Network Devices and Other Assets panels:

• View the Network Devices and Other Assets panels

• Discover network devices

• Delete network devices

• Add, modify, or delete other assets

• Import asset data

• View and modify the network device template

• View and modify the asset template

• Add, delete, or modify network device groups and asset groups

• Run reports related to network devices and other assets

Related concepts
User Permissions for the License Units, Unconfigured Applications, and Files Panels
User Permissions for the Machines and Users Panel
User Permissions for the Restricted Purchasing Panel
User Permissions for the Restricted Reporting Panel
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User Permissions for the Restricted Purchasing
Panel

The following permissions are available for the Restricted Purchasing panel:

• Run Reporting

• Run License Analytics

• Run Purchasing

• View orders and contracts available for the relevant access profile

Related concepts
User Permissions for the License Units, Unconfigured Applications, and Files Panels
User Permissions for the Machines and Users Panel
User Permissions for the Network Devices and Other Assets Panel
User Permissions for the Restricted Reporting Panel
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User Permissions for the Restricted Reporting
Panel

The following permissions are available for the Restricted Reporting panel:

• Run Reporting

• Run License Analytics

Related concepts
User Permissions for the License Units, Unconfigured Applications, and Files Panels
User Permissions for the Machines and Users Panel
User Permissions for the Network Devices and Other Assets Panel
User Permissions for the Restricted Purchasing Panel
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How to Enable Administrator User Policies
 This topic applies to: Sites that use CAM authentication

To set up multiple administrators, use the Administrator user policies feature. First you enable the feature
and then you add users and give them all or specific permissions to use CAM Administrator.

To set up Administrator user polices:

1. From the Tools menu, point to User Policies and Authentication, and then click Administrator.

2. In the Administrator User Policies dialog box, mark the Enable Administrator user policies check
box.

3. If you are prompted to confirm this action, click OK.

4. Note that only users who have attempted to launch CAM Administrator are listed. If the user you
want to apply the user policy to is listed, do the following and then skip to step 6:

◦ Select that user and click Change to open the Change Administrator User Policy dialog box.

◦ Specify whether to give this user CAM System Administrator privileges, User privileges to the
areas you mark (License Units, Unconfigured Applications, and Files; Machine and Users; or
Network Devices and Other Assets), or whether this user is not authorized to run CAM
Administrator at all.

5. If the user is not listed, click the Add button to open the Add Administrator User Policy dialog box.
◦ Type in the user's name and domain, or click Browse to open a dialog box where you can

search for the user. (Tip: If you cannot find the user you need, cancel out of this dialog box and
the preceding two dialog boxes, and then run discovery again. After discovery completes,
check the Users panel to see if the user is now listed. The Browse for User dialog box can only
list users that appear in the Users panel.)

◦ Specify whether to give this user CAM System Administrator privileges, User privileges to the
areas you mark, or whether this user is not authorized to run CAM Administrator at all.

6. Click OK.

7. Back in the Administrator User Policies dialog box, note that the user is listed in the box, with the
new permissions. Click OK to exit the dialog box and save your changes.

8. Restart CAM Administrator for the changes to take effect.
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How to Disable Administrator User Policies
 This topic applies to: CAM authentication

To disable the Administrator user policies feature, do the following:

1. From the Tools menu, point to User Policies and Authentication, and then click Administrator.

2. In the Administrator User Policies dialog box, clear the Enable Administrator user policies check
box.

3. Click OK.

4. Restart CAM Administrator so the change can take effect.
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Cherwell Software Identification Database
The Cherwell Software Identification Database (CSID) is a database of software information. It contains
information compiled on thousands of software applications, organized by software categories, and is
updated regularly for the benefit of maintained customers.

The CSID is a required part of the CAM Database. The CSID allows Cherwell Asset Management to
automatically identify applications and convert them into license units.

The CSID is used as a reference to specify how license units are configured. You cannot modify it, but
you can create your own application definitions to add to your database, simply by creating new license
units and applications based on the files found during the inventory and metering processes.

You can use the Contribute to the CSID dialog box to scan a selected machine for applications not
already included in the CSID for possible inclusion in future versions of the CSID. You can also
automatically scan machines determined to be the best candidates for providing new recognition data, by
answering Yes in the Do you want to enable automatic contribution to the Cherwell Software Identification
Database dialog box.

You cannot merge the CSID with other vendors’ knowledgebases.

Note: The CSID includes Windows applications only.
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CAM AppScanner
The CAM AppScanner utility collects information about installed Windows application files on the selected
machine in order to find applications that do not yet exist in the Cherwell Software Identification Database
(CSID). The utility generates a file that you can send in (either via HTTPS from the Contribute to the CSID
dialog box, or manually). These application scan files are then analyzed to help determine what
applications to add to the CSID.

From CAM Administrator, you can run CAM AppScanner on any Windows machine that's listed in the
Machines panel. You can only scan one machine at a time, and the utility runs transparently on the
selected machine.

Notes:

• No personal, machine, or environmental information is collected during the scanning process. Only
the information contained in executable files and some program-specific initialization files to obtain
data for inclusion in the CSID is used.

• You can also can "opt-in" to automatically send unrecognized applications directly to the CSID team
by answering Yes in the Do you want to enable automatic contribution to the Cherwell Software
Identification Database? dialog box. Use CAM AppScanner when you want to manually contribute to
the CSID.
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Application Identification
Application identification is the process that compares data gathered from agent Windows machines with
data in the Cherwell Software Identification Database (CSID). Application identification associates
collected files with CSID applications, and creates application versions and license units in the CAM
Database for these identified applications.  

Application identification of Windows applications automatically runs on a scheduled basis, which you can
specify in the Schedule tab of the Options dialog box. You can also run it manually by selecting
Automatically Configure Applications from the Tools menu.
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Do You Want to Enable Automatic Contribution to
the Cherwell Software Identification Database?

 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

Recommendation: Answer Yes in this dialog box. Read on for an explanation of this recommendation, and
why contributing to the Cherwell Software Identification Database (CSID) is safe.

Besides Yes, the recommended option, you can click No or Ask Me Later. You can also enable or disable
this option in the Options Advanced tab, and exclude specific machines from this process in the Machines
Properties Advanced tab of the machine(s) you want to exclude.

Why Collecting Application Data Is Safe
We rely on our customers and partners to help continually improve application recognition. Key to this
process is obtaining “scans” of installed application information from individual machines for analysis and
inclusion in the CSID. You can help by allowing Cherwell Asset Management to automatically scan
machines determined to be the best candidates for providing new recognition data. Note the following:

• A “scan” is roughly equivalent to an inventory of software data only.

• Scanning a machine does not have any perceptible impact on the user of the machine.

• Only installed application information (.exe file signatures, Add/Remove program entries, and so on)
is collected.

• No identifying information is sent other than the CAM machine ID and your customer number.

• New entries added to the CSID as a result of a scan contain no information that can lead back to the
scanned machine.

• Scans are sent over a secure HTTPS connection.

• Scans are infrequent; only a few machines are scanned per month.

 Why Collecting SNMP Data Is Safe
By giving us permission to view SNMP data collected in a hosted CAM Database, our hosted customers
who collect SNMP data from discovered network devices help us improve our SNMP attribute recognition
capabilities. The data is transmitted over a secure connection and only the tables involved with SNMP
data are viewed; no other data is examined and no changes are made.
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How to Download and Manually Install CSID
Updates

To download and manually install updates to the Cherwell Software Identification Database (CSID):

1. Download the CSID .zip file from the Cherwell Customer Support Portal.

Note that there are two .zip files; make sure to download the version for newer versions of CAM.

2. Extract the CSID update files from the .zip and copy them to the \Database folder of your CAM
installation.

This is typically C:\Program Files (x86)\Cherwell Asset Management\Database on the machine
running the SQL Server that hosts your CAM Database.

3. From the \Database folder, run EMSIDInstaller.exe.

4. In the dialog box that opens, complete the fields as follows:
◦ SQL Server—The name of the machine running SQL Server, including the instance name, if

applicable

◦ CAM Database—The name of your CAM Database

◦ Username—The username of your SQL Server CAM account

◦ Password—The password of the SQL Server CAM account

◦ Path to .DAT files—The full path to the location of the CSID .DAT files.

5. Click Install to start the update process.

6. When installation completes, click OK and then Exit to exit the installer.

641

CAM 14.2 Administrator

CAM 14.2 Administrator



Troubleshooting
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Access Point Issues
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If an Access Point Becomes Unavailable
There is a problem with an access point. The access point may have been operational earlier, but is
unavailable now. You should investigate the machine on which the access point is installed to see if the
machine shut down, lost its connection to the network, or encountered another problem that makes the
access point unavailable.
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If No Access Points Are Available
 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

 On-premises Installations
If no CAM Access Points are listed on the Status panel, or if you receive an error message that an access
point was not contacted or found, first check the Event Viewer (Tools -> Event Viewer -> Access Points)
for more information. The issue could be one of the following:

• The CAM Access Point is installed on another machine and is from an earlier version. Upgrade it to
the same version as the other CAM components.

• You need to properly install IIS and then register the access point.

The CAM Access Point component requires that Microsoft's .NET Framework version 4.6.2 and Internet
Information Services (IIS) be installed. Operating system, installation defaults, security, and installation
ordering may result in the machine not being configured to properly host the CAM Access Point. The
Cherwell Asset Management Requirements Analyzer checks to make sure IIS and .NET are installed;
however, there may still be issues with the IIS configuration that must be resolved. Click the following links
below for instructions on completing these procedures.

• Installing IIS on Windows 2008 Server

• Installing IIS on Windows 7 and Windows 8

• Registering the CAM Access Point

See Technical Note 1082 at the  Cherwell Customer Support Portal for additional information on IIS and
the CAM Access Point.

 Hosted Installations
If you encounter issues with the CAM Access Point proxy, try the following:

• Register the CAM Access Point proxy

• Use the settings utility to update the CSM user name and password to the credentials provided to
you by Cherwell Software support. The utility is available in the folder from which you installed the
on-premises components of your installation. Run the following from a DOS prompt for a list of
commands and syntax information:

esmsettings /?  
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If Web Components Are Not Registered
If you install CAM in a TLS environment, CAM's web applications may not get properly registered with IIS
and you must register them manually.

1. In the Status panel, select Web Component Locations.

2. If there are no URLs for each component, follow the registration instructions in Registering the CAM
Access Point. Make sure to use https instead of http. Use the register links for the access point
and authentication service.

3. In Web Component Locations, select Configure to configure the URLs for the web components to
the same server using https.
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Registering the CAM Access Point

On-premises Installations
Normally, the CAM Access Point is registered during the Setup process; however, if Internet Information
Services (IIS) was not installed or not configured properly, you may need to re-register it. If you run the
Setup Wizard and it fails because there is no CAM Access Point, follow these instructions to register it.

Tip: Check the Status panel to see whether a CAM Access Point is properly set up.

Step 1: Verify CAM Access Point Installation

1. Validate that the CAM Access Point files were installed to C:\Inetpub\Wwwroot\Esmweb
\ExpressSoftwaremanagerAP

2. If this folder does not exist on your system, re-run the Setup program.

Step 2: Check the CAM Access Point Virtual Directory
Setup creates a virtual directory (a mapping between a name and a physical disk location) to reference
the CAM Access Point. To verify that this was created properly, do the following:

1. From the Start menu, select Control Panel.
2. Select Administrative Tools, then select Internet Information Services (IIS) Manager.
3. In the tree view on the left, open the machine's node, then under Sites, select Default Web Site.

This will list all virtual directories defined for your website.

4. Locate camaccesspoint (version 12.2 and later) or expresssoftwaremanagerap (earlier versions
and upgrades) in the list.

◦ If it is not there, uninstall the CAM Access Point and reinstall it.

◦ If it is shown with , verify that it is pointing to the correct folder (see Step 1).

◦ If it is shown with , the CAM Access Point has been created properly and you can proceed
to Step 3: Register the CAM Access Point.

5. Right-click  and select Properties.

6. Select the Virtual Directory tab and verify that the Local Path setting points to where the CAM
Access Point files were installed. If it doesn't, browse to the installed location and click OK.

Note: Even if the path is correct, you may want to click Browse and verify it. If the folder is
correct, the icon should change.

7. Click OK in the Properties dialog box, then close the IIS management console.
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Step 3: Register the CAM Access Point

1. Open a browser window on the CAM Access Point machine and enter the following URL:

http://<ap-machine>/camaccesspoint/clientservices.asmx

(for version 12.2 and later)

http://<ap-machine>/expresssoftwaremanagerap/clientservices.asmx

(for earlier versions and upgrades)

where <ap-machine-name> is the name of the machine on which the CAM Access Point is
installed.

Note: Do not use localhost for the machine name, as the CAM Access Point will not get
registered properly. For example, if your CAM Access Point machine is MYIISBOX, enter:

http://MYIISBOX/camaccesspoint/clientservices.asmx

For TLS environments, use https instead of http. See If Web Components Are Not
Registered.

2. A list of the functions provided by the CAM Access Point should be listed. (If you do not see a list,
please contact technical support.) Click RegisterAccessPoint.

3. Select Invoke.

Note: If you do not see the Invoke button, you may not be running the browser on the CAM
Access Point machine, which is required in order to register the CAM Access Point.

4. When you select Invoke, a new browser window will appear in which the status of the registering
process is displayed. There should be two lines, the second of which includes an <int> </int>
tag enclosing a status value. If the value is 0, the registration succeeded. If it is 1, registration failed.

a. If registration failed, verify that the credentials you specified when installing the CAM Access
Point are valid.

b. If registration succeeded, you're finished, and can now go back and run CAM Administrator. To
get started, select Setup Wizard from the Help menu.

Step 4: Verify the CAM Access Point's Database Credentials
If you were able to successfully display the CAM Access Point function list but the registration process
failed (a 1 was returned by Invoke), the CAM Access Point was not able to contact the CAM Database. If
you installed the CAM Access Point separately, this is most likely caused by an incorrect CAM username
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or password during Setup. (The CAM Database account information must match what was specified
during database creation.) Unencrypted database access credentials are stored in this file on the CAM
Access Point:

C:\Inetpub\Wwwroot\Esmweb\ExpressSoftwaremanagerAP\Web.config

If you check the Web.config file and the credentials are incorrect, change them as follows:

1. Open Web.config in a text editor such as Notepad.

2. Locate the <DBInfo> tag in the file. In this section of the file, you'll see the database server name,
database name, username, and password.

3. Verify that all entries are correct for your installation. If your database server is case-sensitive, these
values are also case-sensitive.

4. Save and close the file.

5. Follow the steps in Step 3: Register the CAM Access Point.

Hosted Installations
If you need to manually register the CAM Access Point proxy, you can use the settings utility. The utility is
available in the folder from which you installed the on-premises components of your installation.

You need the machine name and port you used during the installation process.

To find the port:

1. Go to the machine where you installed the proxy, and open the Registry.

2. Look for the DWORD APProxyPort in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node
\Express Metrix\7.0

3. If you're upgrading from a pre-12.2 version of Cherwell Asset Management, enter your virtual
directory name. You can find this value in the APProxyVirtualDir field, from the same Registry
where you found your value for APProxyPort.

4. Run the following command from a DOS prompt:

esmsettings.exe -A=<ap-proxy-machine> -P=<AP-proxy-port> -D=<AP-virtual
-dir>
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Communicating with an Access Point via SSL
 This topic applies to on-premises installations.

CAM Agents can communicate with the CAM Access Point via Secure Sockets Layer (SSL) in these
situations:

• The access point's website uses an SSL certificate signed by a common Certificate Authority such
as VeriSign. In this case, the machine most likely already trusts the certificate.

• The access point's website uses an SSL certificate not signed by a common Certificate Authority. In
this case, see How to Enable SSL Communications for instructions on how to ensure that each
machine trusts the certificate.
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Hiding Available APIs
 This topic applies to on-premises installations.

In some cases, you may want to hide supported SOAP operations when accessing the
Clientservices.asmx file. To do so:

1. Locate the Web.config file on the machine where your access point is located.

Typically, this file is located here:

C:\Inetpub\Wwwroot\Esmweb\ExpressSoftwaremanagerAP\Web.config

2. Add the following lines after the "trace enabled" line:

<webServices>
<protocols>
<remove name="Documentation" />
</protocols> 
</webServices>

Note: When these lines are added to the Web.config file, you cannot register the access point
using a browser; instead you must create and send a web SOAP request.
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Agent Issues

652

CAM 14.2 Administrator

CAM 14.2 Administrator



Failed Agent-self Upgrade
In most cases, this message indicates that the agent self-upgrade feature was not completely set up, or
that the machine is not pointing to the correct location for the necessary files. See How to Set Up the
Agent Self-upgrade Feature for detailed steps to follow, and then verify that you haven't pointed to an
inaccessible network share or an incorrect version of the agent installation package.

After you correct the problem and the correct, upgraded version of the agent installation package is
available, the machine will begin the self-upgrade process at its next heartbeat.
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Machine Installation Help
The following topics provide information on common issues that you may encounter when installing or
uninstalling the CAM Agent:

• Problems Installing the CAM Agent

• Problems Uninstalling the CAM Agent

• Agent Status Messages

• Troubleshooting CAM Agent Status in the Machines Panel

• Error Messages in the Machine Properties Dialog Box

• Remote Desktop Connection
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Naming Issues with Mac OS Machines
If you use a Mac OS machine to connect a Terminal Server machine that is running the CAM Agent to
meter usage, it is possible to end up with multiple machine records in the database for the Mac OS
machine.

To avoid this issue, use the following guidelines when naming Mac OS machines:

• Assign names that have 15 or fewer characters.

• Use only characters that are also supported for Microsoft Windows machine names.
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Out of Date CAM Agents
This informational message appears when some machines on your network are running versions other
than the most current of the CAM Agent software. This is for your information only, as you are not
required to update/upgrade those machines. However, upgrading machines to the current version when
possible is recommended.

To see which version of the CAM Agent is available, see the Status panel. This panel also tells you how
many machines are running earlier versions of the CAM Agent.

You can use any of the methods available for first-time installation of the CAM Agent to update/upgrade
machines; click one of the following for step-by-step instructions for a given method:

• How to Install or Update the CAM Agent to Machines Listed in the Machines Panel

• How to Install the CAM Agent by Machine Name or IP Address

• How to Manually Install, Uninstall, or Upgrade the CAM Agent

• How to Install the CAM Agent Using a Batch File or Script

• How to Install or Update the CAM Agent to Multiple Machines by IP Address

• How to Set Up the Agent Self-upgrade Feature
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Problems Installing the CAM Agent
In some cases, you may experience problems with installing the CAM Agent to machines from CAM
Administrator. The following are examples of situations where this problem may occur:

• Cause: Microsoft XML may need to be upgraded or the WMI repository may be corrupt.

Symptom: You receive Error 1904 in the distribution log when installing the CAM Agent. The
distribution log is located on that machine in the %windows%\system32\wex4962 folder (or, on 64-
bit machines, in the %windows%\syswow64\wex4962 folder), and is named DistributionLog.txt.

Solution: Download and install Microsoft Core XML Services (MSXML) 6.0 to the targeted machine,
reboot the machine, and then re-install the CAM Agent. MSXML is available for download at the
Microsoft website.

If the above doesn't resolve the problem, you need to repair WMI on the target machines. Search
the Microsoft website for help with WMI.

• Cause: WMI is not installed on machines.

Solution: Use the Add/Remove Windows Components feature in the Windows Add/Remove
Programs Control Panel to install WMI on the affected machines, or install the CAM Agent manually.

• Cause: A machine has an earlier version of the Microsoft Installer program, MSI.

Solution: Visit Microsoft's website to find out how to download a newer version of MSI.

• Cause: A personal firewall on the machine is blocking the agent installation.

Solution: Read on to diagnose and fix this problem.

Overview of Firewall Issues
Personal firewalls installed on agent computers may interfere with remote CAM Agent installations.
Machines with personal firewalls may cause the installation to fail.

Diagnosing Firewall Issues
To check whether a firewall is causing agent installations to fail, check the system log and event viewer
log. The following messages in those logs usually indicate invalid login credentials but can also indicate a
firewall conflict.

System log:

DCOM was unable to communicate with the computer <computer-name> using any of the configured
protocols.

 

Event viewer log:

Message: The machine could not be reached.
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(This error message is then followed by a stack trace.)

Solutions to Firewall Conflicts
To install the CAM Agent on machines that have a personal firewall, you have the following options:

• Manually install the agent on the affected machine.

• Disable its firewall and then install the agent.

• Run the appropriate command for the machine's operating system, as described next.

Windows Commands
Run the following commands on a Windows 7 or later machine to allow access to it for installing the CAM
Agent:

netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=Yes

netsh advfirewall firewall set rule group="Windows Management Instrumentation (WMI)" new enable=yes

Note: If you receive a "Group cannot be specified with other identification conditions" error after
running the above command, make sure the command does not include "smart" (curled or angled)
quotation marks.
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Problems Uninstalling the CAM Agent
If you run into problems completely uninstalling the CAM Agent (Cherwell Asset Management Agent still
shows up in Add/Remove Programs, and/or the agent tries to install itself over and over again when you
attempt to execute a program), there may be an issue with MSI or InstallShield. Also note that local
administrative rights are required in order to uninstall the agent. This topic describes three ways to resolve
this issue, in the order that you should try them.

• See How to Manually Install, Uninstall, or Upgrade the CAM Agent.

• Download, run, and install the Install and Uninstall Fix It utility from Microsoft. (This utility is available
from the Microsoft Download Center.)

• Contact technical support for assistance if the above methods don't resolve the issue.
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Troubleshooting CAM Agent Status in the
Machines Panel

 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

In the Machines panel, the status bar at the bottom right of the window lets you know when an install or
inventory operation has completed. This information is also displayed in the right pane, next to the
machine name. If the status of the inventory or installation process does not update, read on for
troubleshooting tips.

If you use the Windows Remote Desktop Connection accessory on your machine, you can launch it
directly from CAM Administrator to diagnose a problem with a machine. See Remote Desktop Connection
for more information.

The “Inventory Started” Status Does Not Update
Description: This problem typically occurs if the CAM Agent cannot communicate with the CAM Database
via the CAM Access Point.

Troubleshooting: See the following topics and then, after correcting the CAM Access Point issue, try
starting the inventory process again:

• If no access points are available

• Registering the CAM Access Point

If you cannot correct the issue using the tips in the above topics, go to the target machine, and search for
the Eminvcli.log file. Have this file handy and then contact technical support for assistance in resolving
this issue.

Note: The above log file is in a hidden system folder. The exact location depends on how
inventory was run.

 The “Last Install” Status Does Not Update
Description: You attempted to install the CAM Agent to use a CAM Access Point that references a CAM
Database other than the one you are using. This can happen if you are transitioning from an evaluation to
production environment and have an access point in your production database that is no longer used.

Troubleshooting: On the CAM Access Point machine, open the C:\Inetpub\wwwroot\esmweb
\ExpressSoftwareManagerAP\Web.config file in Notepad and verify that the values for <DBMachine> and
<Database> tags match the Server and Database entries in the CAM Database section of the Status
panel in CAM Administrator. In addition, verify that the values for <User> and <Passwd> are valid for the
specified database.
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The "Last Install" Status Does Not Show the Correct Access Point
Description: CAM Access Point information is stored in the CAM Database, not on each machine, so the
information is only updated in the Machines panel when you install the CAM Agent or update its CAM
Access Point.

Troubleshooting: This behavior is only an issue if you want to load balance your CAM Access Points. In
this case, you can update the information shown in the Machines panel by updating the CAM Agent on
affected machines (and being sure not to mark the Overwrite existing installations option in the dialog
box from which you launch the agent installation).

The "Waiting for Agent Check-in" Status Does Not Update
If you use a proxy server and encounter this problem, see Troubleshooting Proxy Server Settings for help.
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CAM Administration Service Issues
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CAM Certificate Manager
Use CAM Certificate Manager when you need to be able to use encrypted credentials on multiple CAM
Administration Service machines. You can use this utility to generate a certificate that contains a
persistent, private key, and then export the certificate for loading on other CAM Administration Service
machines. This is useful when you have multiple CAM Administration Service machines for redundancy,
so that you do not lose saved credentials if one machine fails.

To launch CAM Certificate Manager, start the following:

C:\Program Files (x86)\Cherwell Asset Management\Administration Service\CAMCertMgr.exe

For 32-bit systems, the default root folder is C:\Program Files.

Notes:

• In order to use CAM Certificate Manager, you must be logged in to the machine running the CAM
Administration Service as a Windows administrative user. Tip: In most cases, the CAM
Administration Service and CAM Administrator run on the same machine, but this is not required. To
determine which machine is running the CAM Administration Service, check the Status page in CAM
Administrator.

• If you are using  Cherwell Service Management (CSM) authentication, you are prompted to enter
credentials when you upload a certificate. The credentials you enter must be for a CAM user that
has CAM administrative rights in CSM.
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Other Issues
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Change History
Cherwell Asset Management saves a record of changes made to your configuration. Viewing this change
history log can be helpful, for example, if you have multiple administrators and need to keep track of
changes each administrator makes, such as installing the CAM Agent to new machines, configuring files
into license units, and so on. The ability to view a record of these changes can also be helpful in
diagnosing any issues that may arise in your configuration.

What Kinds of Changes Are Saved to the Change History Log?
You can view the change history for the following objects in your Cherwell Asset Management
configuration:

• Assets

• Contracts

• License units

• Machines

• Network devices

• Orders

• Profiles

• Users

• Other

Notes:

• Basic information such as the date and time a change was made, and by which user, is saved in the
change history log. Specific information on a change, such as an object's new value, is not always
available.

• You can right-click on the above objects and select CAM History to view information about when the
objects were created or changed.

• Information on the Work queue is not saved to the change history log.
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General Troubleshooting Techniques
Knowing how to approach a problem is critical to being able to resolve problems. Try the techniques
described in this topic, and gather as much information as you can.

Verify the Environment
Consider the following:

• What is the network environment (network topology, network connection speeds, etc.)?

• What authorization is required to access certain machines on the network?

• What operating systems are installed?

• What Cherwell Asset Management configuration is being used and where are each of the server
components installed?

• Have all server and machine minimum requirements been met?

Identify Symptoms and Frequency of the Problem
Consider the following:

• Is this a new installation?

• Has Cherwell Asset Management ever worked? If so, what has changed since then?

• Is the problem sporadic or continual?

• What error messages are displayed and when?

• Can you re-create the problem?

• Have you examined the Windows Event Viewer or any other Cherwell Asset Management-related
log files?

Determine Where the Problem Exists
Sometimes the most difficult part of troubleshooting is identifying the source of the problem.

If you are working on a problem with a machine on which the CAM Agent was installed, determine if that
installation was successful. If you can determine that this is the case, you eliminate one possible source
for the issue and can focus on the access point and the SQL Server database.

To resolve agent-related issues, you should first examine the installation folder (C:\windows
\syswow64\wex4962 on 64-bit machines) on the affected agent for any .log files that might indicate where
the problem exists. Log files can also exist in other locations, such as %appdata%\Cherwell Asset
Management and %allusersprofile%\Cherwell Asset Management.

For non-agent problems, you should examine the Event Viewer for any Cherwell Asset Management-
related events that have been reported. (To launch the Event Viewer, click Event Viewer from the Tools
menu.)
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If a URL Is Not Listed for Web Component
Locations

 This topic applies to on-premises installations.

If you don't see a URL for Authentication, Reporting, Purchasing, or License Analytics on the Status
panel, you may have issues with upgrading or Internet Information Services (IIS) configuration.

Upgrade Issues
If you are upgrading to this version of Cherwell Asset Management and you don't see URLs for Reporting,
Purchasing, or License Analytics, make sure the appropriate components are installed:

1. Run the Cherwell Asset Management Setup program (camsetup.exe) on the appropriate machine.  

2. The Requirements Check dialog box the components that are already installed. Depending on which
component you're checking, select the Reporting, Purchasing, or License Analytics component to
verify that the machine meets the requirements for it.

3. Follow the prompts to modify the existing installation. In the Feature Selection dialog box, make sure
the Reporting, Purchasing, or License Analytics item is set to This feature will be installed on local
hard drive.

IIS Issues
See Technical Note 1082 at the Cherwell Customer Support Portal for information on IIS.

667

CAM 14.2 Administrator

CAM 14.2 Administrator

https://cherwellsupport.com/CherwellPortal/CherwellSelfService


If Some Items Are Unavailable
 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

There may be cases where certain panels, features, or menus are unavailable (either "grayed" out or not
visible at all). This can happen due to:

• Your Cherwell Asset Management configuration

• Other reasons

Read on for an explanation of each.

Cherwell Asset Management Configurations
You have choices in how you use Cherwell Asset Management (in on-premises vs. hosted environments,
and using CAM vs. CSM authentication). This help system covers all available configurations, but the way
some features work can vary by configuration.

Other Reasons
Other reasons some items may not be available include:

•  Administrator user policies—The main administrator has enabled the Administrator user policies
feature and you are logged in as an administrator with limited permissions. If this is the case, you'll
only see the panels you have permission to view.

• Licensing—Your organization is not licensed to use all features of the product. For example, the
other assets feature is only available if you are licensed to use the inventory component. See the
Status panel for information on what features you are licensed to use.

• Current configuration—Your current configuration affects what menu items and commands are
available. For example, the Launch Remote Desktop Connection item on the Machine menu is only
available when the Windows Remote Desktop Connection accessory is present on the current
machine.

• Current selection—Your current selection affects what menu items and commands are available. For
example, the Inventory Selected Machines item on the Machines menu is only available if at least
one machine is selected.

Related information
../admin_csm_authentication/Admin_Overview_Authentication.xml#concept6703
../admin_csm_authentication/Admin_product_solutions.xml#concept1628
../admin_user_policies/Admin_Overview_User_policies.xml#concept2747
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Notes on Citrix and Terminal Server Machines

Issues with Concurrent Applications
On Citrix machines, concurrent applications delivered in published application mode can't notify users of
available licenses.

Running the CAM Agent on Citrix and Terminal Server Machines
There are no changes necessary if you run the CAM Agent on Citrix Metaframe or Windows Terminal
Server machines that don't publish applications.

If you want to run the CAM Agent to machines that run Citrix Metaframe or Windows Terminal Server and
publish applications, you need to add emmeter.exe to the userinit line in the machine's Registry in the
following location:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

The following is an example of how the edited userinit line should look on a 64-bit machine:

C:\windows\syswow64\wex4962\emmeter.exe

The following is an example of how the edited userinit line should look on a 32-bit machine:

C:\windows\system32\wex4962\emmeter.exe

Important: Be careful when editing this line, as an error here could prevent the Windows user
interface from loading.
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Problems Importing Custom Data
If you experience problems importing custom machine properties, please visit the Cherwell Customer
Support Portal. Tech Note/Solution Article 1078 provides detailed information on resolving common issues
with importing custom data.
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Remote Desktop Connection
If you use the Windows Remote Desktop Connection accessory on the machine where you run CAM
Administrator, you can launch that accessory directly from CAM Administrator.

This is useful, for example, if you're using CAM Administrator to troubleshoot a remote machine and you
need to connect to that machine to investigate the problem. For example, you can use this feature to
easily check a remote machine's CAM Agent installation folder (%windows%\system32\wex4962 on 32-bit
machines, %windows%\syswow64\wex4962 on 64-bit machines) to investigate why installation of the
CAM Agent failed.

You don't have to leave CAM Administrator to open the Remote Desktop Connection. Instead, you can
simply right-click the remote machine from the Machines panel and select Launch Remote Desktop
Connection to view the remote machine's desktop.

Notes:

• You can select the Launch Remote Desktop Connection item from the Machine menu or from a
context-sensitive pop-up menu when the accessory itself is installed and you've selected a single
machine.

• If the remote connection fails for any reason, the Windows Remote Desktop Connection, not
Cherwell Asset Management, provides feedback on the cause.
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Troubleshooting CAM Administrator
This topic provides tips for troubleshooting CAM Administrator and Reporting.

General Problems

• Look in the Windows Event Viewer for errors.

Installation Problems

• Try installing CAM Administrator on a different machine to determine if the problem is computer-
specific.

• Make sure the virus checker is not set to scan all files on open or copy.

• Verify that you have administrator permissions on the computer you are installing the software to.

Performance Problems
If CAM Administrator takes a long time to open, check to see whether you have a virus program on your
system configured to scan all files on open. For example, Norton AntiVirus has a setting called "Auto-
Protect" that automatically scans files when they are opened, moved, copied, or created. By default, this
setting is configured to only scan program files (*.exe, *.com, *.dll, *.doc, *.xls). If this setting is changed to
scan all files, the performance of CAM Administrator is significantly impacted.

The solution is to turn off Auto-Protect scanning for all files, and instead, only scan program files on open.
Further, if the system administrator is concerned about network traffic, turning this feature off should
dramatically improve network performance.

CAM Administrator Not Responding
Some database operations can take considerable time to complete. During these operations, Cherwell
Asset Management may cease updating the CAM Administrator screen, resulting in a "CAM not
responding message" if you look in Task Manager.
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Troubleshooting Hosted Installations
 This topic applies to: Hosted installations

General Issues
Most issues can be resolved by consulting the email message you received from Cherwell Software
regarding your hosted installation.

Access Point Issues After Switching Remote Hosts
For correct access point operations, you should make sure that your on-premises components point to
your current remote host (the one shown in the Status panel and in the Hosted Cherwell Asset
Management dialog box). To check this, go to the Status panel and look at the Access Points section.
Verify that a valid access point is listed (with no exclamation mark to indicate a problem) for the remote
host that is listed in the Hosted Cherwell Asset Management section of this panel. If a problem exists,
open the Registry on all machines from which you run CAM Administrator, and update the
ConnectRemoteAPURI setting to point to the same hosted environment as the remote server.
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Troubleshooting Idle Time Behavior
In rare situations, you may encounter problems with the CAM Agent when an application is to be
terminated on a machine due to idle time settings you've specified.  

This can happen when you've specified that certain applications be shut down gracefully after exceeding
the time limit specified in the Idle Time tab of the New/Change Control Profile dialog box. In this situation,
the CAM Agent will unsuccessfully attempt to shut down the application every 30 seconds after this time
period expires, and the machine's user will see a warning message each time. When an application is set
to terminate gracefully, the CAM Agent sends a shutdown message to the application and the application
must shut itself down. Most, but not all, applications will prompt you to save any unsaved data before
shutting down this way. Although the problem is rare, some applications will ignore the shutdown
message and continue running.

To correct this issue, reconsider whether idle time settings are necessary for this application, and then
update the control profile that is applied to it accordingly. If you want to continue to monitor idle time for
this application, you can select the Terminate application immediately option instead of Shutdown
application gracefully in the Idle Time tab for this application's control profile. It's important to note,
however, that terminating applications in this manner may result in lost data for this application, as the
application will not be given the option to save its unsaved data before being terminated.
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Troubleshooting Terminal Server Issues

Issues with Concurrent Applications
In a Terminal Server environment, you may encounter problems when you launch a concurrent application
from a local machine's session, and then launch that same application from a Terminal Server session on
the same machine.

Licenses are checked out on a per-machine basis so in this situation, two launches for the same
application are reported but only one license is checked out.

The problem arises when you terminate either one of the application launches, because the application's
license is checked back in at that point. The other instance of the application is still running, but no license
is checked out for it and it will not appear in an Am I Compliant report. This can cause an organization to
exceed its licensing agreement for the application.

Issues with Remote Takeover of Session
Note that when you perform a remote takeover of a Terminal Server session, Emmeter.exe doesn't start
as expected. For example: 

1. Configure Terminal Server to allow only one session per user. This means that if a user logs in using
the same user account from a second machine, the second machine takes over the existing session
from the first machine.

2. Disable metering on the first machine and enable it on the second.

3. Launch a remote desktop session to the server with a particular user name from the first machine.
Emmeter.exe launches but then terminates as expected.

4. Launch a remote desktop session to the same server using the same user name from the second
machine. The session on the first machine is terminated, but the metering agent does not start on
the second machine as expected.  

675

CAM 14.2 Administrator

CAM 14.2 Administrator



Troubleshooting Wait List Behavior
When a CAM Access Point that is associated with a machine on the wait list for a concurrent application
becomes unavailable, you may experience these issues:

• No record of wait time

A user's wait time for an application may be longer than expected if a CAM Access Point goes
offline and then comes back online during the waiting period. This is because the CAM Agent has
no way of checking for an available license while offline. The wait time "counter" starts when the
CAM Access Point is back online.

• Misordered information on waiting in Activity Log reports in Reporting

Normally, when a user chooses to be notified that a concurrent license is available, two activity
records are generated: one showing that the launch terminated due to unavailable licenses, and one
showing that the user is waiting. If the access point is offline when the user launches the concurrent
application, it is possible for the "User Waiting" activity to appear in reports before the terminated
launch information appears. This is because the "User waiting" activity record is saved as soon as a
license becomes available for the waiting machine/user, but the "Launch terminated" activity record
isn't saved until the agent sends its cached launch data.
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Database Issues
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Error When Upgrading the CAM Database
If SQL Browser 2016 is disabled, upgrading the CAM database using the database installer causes an
error. SQL Browser 2016 is disabled by default, and must be enabled in order to use the database
installer to upgrade CAM.

To resolve this, enable SQL Browser before upgrading CAM using the database installer, or complete the
following steps:

1. Use the CAM 13.2 installer to uninstall the database component.
2. Run the CAM 14.0 installer to perform a normal install, and install only the CAM database.
3. When prompted, give the "new" database you are installing the same name as the existing 13.2

database.

The installer will recognize that a database with that name already exists and will upgrade the existing
database.
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Problems with Data Schema Creation
 This topic applies to on-premises installations.

There may be cases where you install the CAM Database using the system administrator (SA) account
and the correct password without a problem, but receive an error like, "Cannot open License Unit
Template Table" when you start CAM Administrator. This means that the database was created, but the
tables were not, and can happen for one of these reasons:

• The CAM Database account already exists with a password that doesn't match what you entered
during Setup.

• SQL Server won't allow the account to be created.

To correct this problem, do one of the following:

• Delete the existing account and re-run the Setup program to re-create it.

• Re-run the Setup program and enter the correct password for the existing account.
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Reindexing the CAM Database
 This topic applies to on-premises installations.

To speed up the retrieval of data from the CAM Database, you may want to periodically reindex it. To do
so, click Reindex Database from the Tools menu in CAM Administrator. Read on for details about the
reindexing process and how often you should reindex the CAM Database.

As data is added, SQL Server adds indexes to where the data is stored. Later, when SQL Server needs to
look up this data, it can search the index to find the data. However, the indexes might not be created for
optimal performance in retrieving data, so you may want to improve this performance by reindexing the
CAM Database. Reindexing reorders the indexes so as to speed up data retrieval.

As you run initial inventories on the machines in your network, large amounts of data are added to the
CAM Database, so it's a good idea to reindex the CAM Database often at these times (daily if possible, or
once a week). After most first-time inventories are completed, you don't need to reindex the CAM
Database as often.

The best time to reindex the CAM Database is during off hours when new data is not being written to it.
By default, Cherwell Asset Management runs a scheduled task that reindexes the CAM Database every
Saturday morning at 1:00 a.m. This setting should be adequate in most cases and if it works in your
organization, you won't need to reindex the database manually from the Tools menu.

If your site is a large one where a lot of machines were recently inventoried, or if you enable metering for
a large number of applications, you may want to reindex the database daily for the first week to improve
performance. Even then, you really only need to reindex the database if users complain about slow
application launches, or if reports time out or take an unusually long time to display.

For optimal performance, metering only the applications you want to closely monitor is recommended.

The length of time it takes to reindex the CAM Database depends on variables like computer speed,
available memory, and the amount of data stored in the CAM Database. Typically, reindexing completes in
less than one minute, but can take as long as 15 minutes. During this time, SQL Server may be
unresponsive to requests for data input and output to the CAM Database, which may cause CAM Agents
to temporarily go into offline mode and cache their data. When a CAM Agent goes offline, the next launch
can take an extra five seconds or so. When a CAM Agent is offline, it caches data and subsequent offline
launches are not delayed. Offline CAM Agents create a small amount of additional overhead on the
network, as data has to be sent twice. The additional network overhead is only an issue if data is sent
over a slow link and even then, the amount of additional overhead is very small.

Note: Even under optimal conditions, a few reports (the Am I Compliant and the peak usage
reports) can take a long time to display. Depending on filter settings and whether a peak usage
report was recently run, these reports may need to generate peak usage data at report creation
time.
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Discovery Issues
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Problems with Discovery

Issues with Active Directory Discovery
Active Directory discovery may not bring back information on all machines, users, and groups in very
large Active Directory environments. If Active Directory discovery fails, you can do one of the following:

• Use NT domain discovery

• Install machines by name or IP address

• Limit discovery to specific organizational units (OUs)

Issues with Limiting Discovery by OU
Active Directory discovery works by determining what groups a particular machine belongs to by looking
at its "member-of" property. (The member-of property is a list of all the groups the machine is a member
of.) Machines can be a member of a group that's in a different OU than the machine is in. Therefore, it's
possible that you could restrict discovery to a given OU that contains only references to machines that are
actually in another OU. Unless you are also discovering machines in the other OU, Cherwell Asset
Management may not discover the machines you are interested in. To prevent this from happening,
examine your OUs and machine groups carefully before limiting discovery to specific OUs.

If you receive a syntax error when you enter an OU path in the Add Active Directory OU Path dialog box,
see Syntax Issues with Limiting Discovery to an OU for help.
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Syntax Issues with Limiting Discovery to an OU
If you receive a syntax error message when you enter an OU path in the Add Active Directory OU Path
dialog box, check to see whether you use any of these special characters:

,  =  +  <  >  #  ;  \  "

You can still use these characters, but you need to "escape" them by preceding each special character
with a backslash character (\). This is an Active Directory requirement.

For example, to enter Smith, John, you need to enter a backslash before the comma, as in Smith\,
John. The complete LDAP string for a user named Smith, John in a testdomain.com domain would be as
follows:

LDAP://OU=Smith\, John, DC=testdomain, DC=com
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Troubleshooting Linux/Unix/Mac OS Discovery
Some of the more common discovery issues and resolutions are described below.

Sudo Issues
With Linux/Unix/Mac OS discovery, CAM uses certain commands in data collection that require the use of
the sudo command. This means that the credentials you enter when you configure Linux/Unix/Mac OS
discovery must be for a user who is authorized to execute sudo. For example, Services on Mac OS
requires using the sudo command. If you set up discovery using credentials that don't allow for executing
sudo, services information cannot be collected during discovery.

To ensure you can collect all data:

• Verify that your Linux/Unix/Mac OS machines are set up to allow use of sudo.

• If you are using a private key instead of a password, the user must be able to run sudo commands
without being prompted for a password.

• With some operating systems, you may also need to check the secure_path value for commands
run using sudo. This value should include those directories that are normally used to store
administrative commands. In most cases, this information is stored in the /etc/sudoers file and
should read as follows:

Defaults secure_path =/sbin:/bin:/usr/sbin:/usr/bin

Generated Files
Machines discovered via Linux/Unix/Mac OS discovery must have a file associated with each GUID
returned by the discovery process. When the discovery process does not find such a file for a GUID, it
creates one with the following characteristics:

• File name = <guid>.<platform>

where <platform> = linux, unix, or app (Mac OS)

• Path = "/"

• File size = 500 (Linux), 600 (Unix), or 100 (Mac OS)

Can't Connect to a Machine
If you can't connect to a known machine (for example, if you receive an error when you click Test to
validate your credentials, or discovery fails to find a known machine), check whether the machine
supports SSH connections. You can do this by using a tool like PuTTY. If you can connect via PuTTY, but
not from CAM Administrator, contact technical support for assistance.
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Inventory Information Missing from Some Machines
If the discovery process completes successfully but some inventory information is missing, check the
following:

• Operating system. Supported operating systems are listed in Linux/Unix/Mac OS Machines. If you
want to discover machines on other operating systems, please contact technical support for
assistance.

• Commands used. If one or more commands for collecting data were unsuccessful, contact
technical support.

• Whether the commands used require sudo. See Sudo Issues above.

Previously Successful Discovery Fails
If discovery for a particular configuration previously succeeded but now fails, check whether you are
running discovery from the same CAM Administration Service machine where the configuration was
saved, or if you are on a machine that uses a shared certificate (see CAM Certificate Manager).

Related information
Admin_sudo_overview.xml#concept445
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
Admin_Contacting_support.xml#concept445

685

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Overview__Linux_Unix_Mac_OS_machines
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Cert_Welcome_to_the_CAM_Certificate_Manager
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_sudo_overview
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_About_GUIDs
https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Contacting_support


More on the "sudo" Command
"sudo" is a command that runs on Linux, Unix, and Mac OS computers that allows you to run commands
with administrator privileges.

As noted in Product requirements, running Linux/Unix/Mac OS discovery requires that you have sudo
credentials. This is because the discovery process runs the following commands using sudo in order to
collect information on Linux distributions:

• dmidecode—Retrieves hardware inventory information from the BIOS.

• lshw—Lists hardware information.

• launchctl—Mac OS: Lists running services.
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Troubleshooting Network Device Discovery
If network discovery fails with a timeout exception, it may indicate that your SNMP credentials (such as
SNMP community string) are invalid. Enter the correct credentials and try again.  

For additional help with troubleshooting network device discovery, please see Technical Note 1092 at the
Cherwell Customer Support Portal.
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Troubleshooting Virtual Environment Discovery
Collecting virtual guest information and SQL Server 2005 GUIDS are common issues with virtual
environment discovery.

Issue: Discovery Completes but Virtual Guest Information Is Missing
Virtual environment discovery involves querying virtual hosts and virtual machine managers for host
information and a list of guests for each host. Once guests are known, the guests themselves are queried
to determine the guest operating system. Any issues with the second part of this process are written to
the Vmdiscovery.log file (found in C:\Program Files (x86)\Cherwell Asset Management\Administration
Service on 64-bit machines). Also check the following:

• Virtual guests must have remote access enabled:
◦ The remote registry service must be up and running.

◦ The inbound "Remote Service Management" rule must be enabled in firewall settings.

• Virtual guests must be part of the domain. Depending on how the virtual environment was
discovered (via the virtual machine manager or directly from the host), you will see an RPC error.
You may also see a DNS lookup error attempting to contact the guest.

• Virtual environment discovery finds virtual machines running Windows, Linux, and Unix operating
systems.

Issue: GUIDs Are Not Collected for Microsoft SQL Server 2005
Virtual environment discovery does not collect GUIDs for Microsoft SQL Server 2005.

Related information
../../cam_quick_start/QS_Requirements_for_running_Cherwell_Asset_Management.xml#concept13902
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Error Messages
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Another Administrator Modified This License Unit
One of the other administrators in your organization has already modified or deleted the current license
unit.
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Are You Sure You Want to Permanently Delete the
Selected Machine(s)?

When you permanently delete a machine:

• All inventory and usage data on that machine is removed from the CAM Database. Removing usage
data may affect the accuracy of peak usage reports.

• You cannot restore it.

• The machine is removed from the CAM Database.

• If the machine still exists on your network or still exists in Active Directory, it will be found again the
next time discovery runs.

You should only permanently delete a machine when the machine is physically removed from your
organization.

Confirm the delete operation, or click No to cancel it.

Related information
../admin_machines/Admin_About_deleting_machines.xml#concept1544
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Are You Sure You Want to Permanently Delete the
Selected Network Device?

When you permanently delete a network device:

• You cannot restore it.

• The network device is removed from the CAM Database.

• If the network device still exists on your network, it will be found again the next time discovery runs.

Confirm the delete operation, or click No to cancel it.
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Are You Sure You Want to Permanently Delete the
Selected User(s)?

When you permanently delete a user:

• The user is removed from the CAM Database.

• All usage data on that user is removed from the CAM Database. Removing usage data may affect
the accuracy of peak usage reports.

• If the user still exists in your organization, the discovery process will find that user again the next
time discovery runs.

Confirm the delete operation, or click No to cancel it.

Related information
../admin_users/Admin_About_deleting_users.xml#concept1245
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CAM Administration Service Cannot Communicate
with the CAM Database

The CAM Administration Service cannot communicate with the CAM Database, usually for one of these
reasons:

• Your SQL Server is unavailable. Check your SQL Server configuration, and restart it if necessary.

• The CAM Administration Service and CAM Database are of different versions. Upgrade the earlier
component to match the newer component.
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Error Copying an Application
Cherwell Asset Management was unable to copy the application to the selected license unit or suite. This
failure usually occurs because of conflicts between pairings of application executable files and their
associated GUIDs. For instance, you cannot move a standalone application to a license unit that already
contains a version of that application that is contained in a suite. In this case, use the Convert to License
Unit dialog box to convert the application to another license unit; that dialog box presents several options
for doing so. See the above link for help, or press the Help button in the Convert to License Unit dialog
box.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Error Messages in the Machine Properties Dialog
Box

The following error messages can appear in the box at the bottom of the General tab in the Machine
Properties dialog box. Click on an error message for troubleshooting tips.
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Access Is Denied
If you receive this message, try the following:

1. Verify that remote access is allowed.

2. Verify that the account you are using to deploy the agent can access the following folder:
◦ \\{machinename}\c$\{windows}\syswow64 (64-bit machines)

◦ \\{machinename}\c$\{windows}\system32 (32-bit machines)

Note: The CAM Administration Service is responsible for deploying the CAM Agent.
Therefore, the computer running the CAM Administration Service must be able to access
remote computers using the specified account. When you do the test above, log into the
CAM Administration Service machine with the account you are using in CAM Administrator
to deploy the agent and then test access to the \system32 (or \syswow64) folder.

3. If step 1 above is successful, verify that you have WMI access by launching WMIViewer.html (from
one of the locations mentioned earlier in this topic) and then remotely connect to the target machine.
If you are unable to connect, do the following:

◦ Verify WMI is enabled on the target machine.

◦ Repair or reinstall WMI. For assistance, search the Microsoft website for instructions on
repairing or reinstalling WMI.

697

CAM 14.2 Administrator

CAM 14.2 Administrator



Invalid NameSpace, Class Not Registered, Invalid
Class

Description: This problem occurs when WMI (Windows Management Instrumentation) is not installed or is
corrupt.

Resolution: These errors are most often displayed when WMI is not installed. However, you may see
these errors in rare cases if WMI is corrupt. Please search Microsoft online resources for help with this.
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Inventory Failed Due to Shortage of Inventory
Licenses

Description: This problem occurs if the number of inventory licenses in use is equal to the number of
inventory licenses available.

Troubleshooting: Look at the Status panel for a summary of Cherwell Asset Management licenses in use
and the number of available Inventory licenses. You can only use as many licenses as indicated here.
Contact us if you need to purchase more licenses.
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Inventory Failed: This Machine Is Running a Mac
OS

Description: The standard inventory process cannot be run on the selected machine because the
machine is running a Mac OS.

To resolve, see one or more of the following for help:

• How to Discover Linux/Unix/Mac OS Machines.

• If you have older Mac OSes, see How to Collect Inventory Data from Mac OS Machines.

• How to Inventory Mac OS Machines from a Share.
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The Machine Could Not Be Reached
Description: This error can occur when the machine is turned off, or when the RPC Service is not running.

Resolution: Try the following troubleshooting steps.

1. Verify that the account you are using can access the \\{machinename}\c$\{windows}\syswow64
folder. (On 32-bit machines, look for the \system32folder instead.) If you cannot access this folder,
the account doesn't have the proper privileges.

Note: The CAM Administration Service is responsible for deploying the CAM Agent. Therefore, the
computer running the CAM Administration Service must be able to access remote computers using
the specified account. When you do the test above, log into the CAM Administration Service
machine with the account you are using in CAM Administrator to deploy the agent, and then test
access to the \system32 (or \syswow64) folder.

2. If you can access the folder noted above, verify that you have WMI access. To do so, launch the
WMI Viewer from one of the following locations, and then remotely connect to the target machine:

◦ On 64-bit machines: C:\Program Files (x86)\Cherwell Asset Management\CAM Administrator
\WMIViewer\WMIViewer.html

◦ On 32-bit machines: C:\Program Files\Cherwell Asset Management\CAM Administrator
\WMIViewer\WMIViewer.html

3. Verify that WMI is enabled on the target machine.

4. Repair or reinstall WMI. Please search Microsoft online resources for help with this.

5. Check the following registry setting to make sure that DCOM is enabled on the target machine:
HKEY_LOCAL_MACHINE\Software\Microsoft\OLE\EnableDCOM. A value of Y indicates DCOM is
enabled; N indicates it is disabled. Microsoft resources may provide more information on this
subject.
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The Network Path Was Not Found
Description: This error occurs when File and Print sharing is disabled or blocked by a firewall.

Resolution: Enable file and print sharing on the target computer.
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Error Sending Test Email
You can use the Test button in the Alerts tab of the Options dialog box to test if you've correctly set up
alerts to be sent to a valid email address when an access point becomes unavailable or the work queue
stops for any reason. There are times where the test may fail and you'll receive the following message:

Error sending test email. SMTP server is invalid.

To correct this problem, check your SMTP server settings in the Alerts tab of the Options dialog box; enter
a valid SMTP server address.
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Failed to Move Application
Cherwell Asset Management was unable to move the application to the selected license unit or suite. This
failure usually occurs because of conflicts between pairings of application executable files and their
associated GUIDs. For instance, you cannot move a standalone application to a license unit that already
contains a version of that application that is contained in a suite. In this case, create a separate license
unit for each.

Related information
../admin_license_units_suites_applications/Admin_About_GUIDs.xml#concept1245
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Incompatible Group Assignments
This dialog box warns you that you are about to change the license type for the selected license units to a
non-compatible license type. If you click Yes to proceed, any group assignments for a purchasing
software line item reconciled to the license unit(s) will be unreconciled and thus affect your purchasing
data. Click No to cancel the operation.
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None of the Machines You Have Selected Are Self
Upgradable

This error message appears when the machines you selected do not require an upgrade of the CAM
Agent software, or have installed on them an earlier version of the CAM Agent that does not support the
self-upgrade feature.
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Setup Wizard Access Point Failure
 This topic includes sections that are noted as only relevant in certain configurations:

 Hosted installations;  On-premises installations;  CSM authentication;  CAM authentication

As the Setup Wizard runs, it checks to see if the CAM Access Point is up and whether the CAM Agent is
checking in with it. If you see this error message, one of those items failed. Common reasons for a failure
of this type include:

• A CAM Access Point was not installed. To resolve:

◦  Re-run Setup and install a CAM Access Point.

◦  Re-run the Hosted CAM Setup application and install a CAM Access Point proxy.

• The CAM Access Point is unavailable. Click one of the following for help:
◦ If an Access Point Becomes Unavailable

◦ If No Access Points Are Available

• The CAM Agent can't communicate with the CAM Access Point.
◦ Either the CAM Access Point is unavailable (see above), or you have a proxy server

environment. You'll need to install the CAM Agent from the Machines panel if you need to
configure it for use with a proxy server.

◦ If this information does not resolve the issue, please contact technical support.

Related information
../admin_machines/Admin_Overview_Proxy_Server_environments.xml#concept947
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This Machine Does Not Have Any Supported SQL
Server Instances Installed

 This topic applies to on-premises installations.

The upgrade failed because the SQL Server Browser Service is required to upgrade the CAM Database,
and it was not running. Start the SQL Browser Service and then restart the upgrade.
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Unable to Save License Unit
Your attempt to add an application to the selected license unit failed because the file you attempted to add
is already configured as belonging to another application. See the error message for the names of the file
and application in question, correct the error, and try the operation again.
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Update the Cherwell Software Identification
Database Dialog Box

 This topic applies to on-premises installations.

The Cherwell Software Identification Database (CSID) does not contain the required License Analytics
data. You can either click Update to update the CSID from here, or click Cancel and then manually update
it from the Update CSID dialog box.
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Installation Issues
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Installing IIS on Windows 2008 Server
To install and configure Internet Information Services (IIS) on your Windows 2008 Server installation, see
the Microsoft website. Once installed make sure the following options are set:

• Static Content under Common HTTP Features on the Select Role Services screen is selected.

• On the same screen, in the Security category, click Windows authentication if you want to use
Windows Authentication for reports.
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Installing IIS on Windows 7 and Windows 8
 This topic applies to on-premises installations.

Windows 7 and Windows 8 do not, by default, have Internet Information Services (IIS) installed. To install
IIS, see the Microsoft website.

IIS installation includes creation of the default web directory structure into which the CAM Access Point
will be installed. You should now be able to access your new website by opening a browser and going to:

http://name-of-iis-machine

The default page will be displayed in your browser along with the top-level IIS help page. If everything is
working properly, you are ready to move on to registering the access point.
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Multiple NICs on a Cherwell Administration Service
Machine

If the machine on which you installed the CAM Administration Service contains two network interface
cards (NICs) on separate subdomains, the CAM Administration Service will default to using NIC 0. To
change this default setting, you can configure the TCP channel to use the bindto attribute. This attribute
allows you to specify an IP address of the NIC to bind to when more than one NIC is installed in a
machine.

To make this change:

1. Open the EmExpServ.exe.config file. This file is located in the CAM Administration Service folder of
your Cherwell Asset Management installation. (For example, in C:\Program Files\Cherwell Asset
Management\CAM Administration Service on 32-bit machines, or C:\Program Files (x86)\Cherwell
Asset Management\CAM Administration Service on 64-bit machines.)

2. In this file, search for the channel ref="tcp" line, as shown in the example below. Add or change the
bindto address to the appropriate IP address of the NIC to which you want the CAM Administration
Service machine to bind. In the below example, 10.2.1.39 is the IP address. 

<channel ref="tcp" port="5001" bindTo="10.2.1.39">
   <serverProviders>
   <formatter ref="binary" typeFilterLevel="Full" />
   <formatter ref="soap" typeFilterLevel="Full" />
  </serverProviders>
  </channel>

3. Save the file and restart the CAM Administration Service.
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.NET Requirements
Microsoft .NET Framework version 4.6.2 is required on any machine that runs CAM Administrator, the
CAM Administration Service, and the CAM Access Point.

The Cherwell Asset Management Setup program checks for the correct version of the .NET Framework
when you install the product. If it is not already installed, you can install it from the Setup program.
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Post-uninstall Cleanup: Agents and Files
After uninstalling Cherwell Asset Management, you may need to manually remove parts of the application
that are not removed by the uninstall process.

Removing CAM Agents
If you uninstalled CAM Administrator without first uninstalling all CAM Agents, you'll need to manually
uninstall those CAM Agents.

Removing CAM Registry Entries
CAM entries in your Windows Registry may still be left even after uninstalling the product. These entries
are benign, but if you prefer to remove them, delete this Registry key:

• 64-bit: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Express Metrix
• 32-bit: HKEY_LOCAL_MACHINE\Software\Express Metrix

Removing Other CAM Files
When you run CAM, it creates some files that the uninstall process may not be able to remove. By default,
CAM installs these files into the following folders, which you can safely remove:

• 64-bit:

C:\Program Files (x86)\Cherwell Asset
  Management\

C:\inetpub\wwwroot\esmweb

• 32-bit:

C:\Program Files\Cherwell Asset
  Management\

C:\inetpub\wwwroot\esmweb

Note: If you entered any non-default locations when you installed CAM, you'll need to instead
remove those folders.
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Post Uninstall Cleanup: CAM Database and SQL
Server Instance

You'll need to remove the CAM Database and the SQL Server instance if you want to completely uninstall
Cherwell Asset Management.

Removing the CAM Database
The uninstall process removes CAM components that communicate with the CAM Database, but does not
delete the CAM Database from the SQL Server on which it is installed. This behavior is intentional, so that
you can move components without risking loss of CAM data.

Note: Cherwell Software recommends that you back up your CAM Database before removing it.

To remove the CAM Database and CAM user login on the SQL Server:

1. Verify that no processes are currently using the CAM Database; that is, all CAM server components
are removed and no other SQL applications (such as SQL Management Studio) are connected to
your CAM Database.

2. To remove the CAM Database, issue the following command:

DROP DATABASE CAMDB

Note: Do not use quotation marks with this command.

3. To remove the CAM user login, issue the following command:

EXEC sp_droplogin 'CAM'

Where 'CAM' (single quotation marks required) is the name of the CAM account created when you
installed Cherwell Asset Management.

Note: The above procedure removes the CAM Database from the SQL Server, but not the
database files; you have to manually delete the files if you no longer need them.

Removing an SQL Server Instance
To uninstall an instance of SQL Server that you created when you installed Cherwell Asset Management,
use the standard Windows Control Panel method as if you were planning to uninstall SQL Server, and
select the instance to remove.
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Removing SQL Server Express
If you installed SQL Server Express Edition as part of your CAM installation, you can remove it through
the standard Windows Control Panel method. SQL Server installs several components separately; you'll
need to remove all of them to completely uninstall SQL Server.

Related information
../../cam_setup/Setup_Backing_up_your_existing_database.xml#concept2876
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Problems Installing .NET
Cherwell Asset Management requires that the Microsoft .NET Framework is installed on the machine(s)
where CAM Administrator and server components are installed. The Cherwell Asset Management Setup
program prompts you to install .NET if necessary.
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Problems Using Change in Add/Remove Programs
You may run into a known InstallShield issue if you select Change in the Windows Add/Remove Programs
feature to remove a component of Cherwell Asset Management and then later attempt to re-install that
component using the Add/Remove Programs feature. You'll see an error 2335 message. In these cases,
simply re-run the Cherwell Asset Management Setup program to re-install the component.
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Running Web Components on Workstation
Versions of Windows

 This topic applies to on-premises installations.

You may experience issues running Cherwell Asset Management web components (the CAM Access
Point, Authentication, Reporting, Purchasing, and License Analytics) on machines that are running
workstation versions of Windows. In these cases, the machine's status may appear to hang at the
"Waiting for agent check in" message, and you may see a firewall notification message that lets you know
that Cherwell Asset Management has already been associated with Inbound rules and that web services
need to be configured.

This occurs when the Windows firewall is not allowing inbound connections. To correct this problem, you
can disable the firewall or change its configuration.
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Metering Issues
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Problems with Metering
This topic describes what to do to correct these metering problems:

• Issues with manually setting system clocks

• Issues with nonsynchronized clocks

• Issues with offline machines

• Reporting delays in license usage counts

Issues with Manually Setting System Clocks
You may experience problems with the metering agent on machines that have had the system clock
manually set forward. The WMI event mechanism that Cherwell Asset Management uses for application
launch and termination notifications stops posting events when the system clock is set forward.

For example, if the system clock is set forward by 10 minutes, Cherwell Asset Management will not
receive events during that period of time.

To correct this problem, restart the agent by logging out and back in again, or reboot the machine.

Issues with Nonsynchronized Clocks
The agent clock and the SQL Server clock need to remain in sync, or the following issues may occur:

• If the agent reports a launch 15 minutes or more in the future according to the time on the SQL
server or 15 minutes before the database was created, the launch is reported as failed due to invalid
time reported.

• If the agent reports that an application was terminated before the actual launch is reported because
the clock was set while the application was running, or the termination occurs 15 minutes or more in
the future, the launch is reported as failed due to invalid time reported.

These events will be indicated in the notes field of any activity log reports you run in Reporting.

Issues with Offline Machines
There may be cases where a machine goes offline (disconnects from the CAM Access Point). This can
happen for various reasons, and can cause problems if the machine was running a metered application at
the time of the disconnect. When the machine reconnects with it, the CAM Access Point may terminate
the metered application and erroneously report the license unit that contains the application as controlled.

Reporting Delays in License Usage Counts
When you change the Meter suite applications individually option in the Advanced tab of the Options
dialog box after application usage has already been metered, all suite applications must be shut down on
users' machines before the new option can take effect. This means that license usage counts in any
reports you run between the time you changed the option and the time all affected applications are closed
may be incorrect.
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Proxy Server Issues
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Troubleshooting Proxy Server Settings
There may be cases where CAM Agent behavior is not as expected. This is because the CAM Agent
shares its proxy server settings with all other applications that utilize WinHTTP. This topic describes how
to handle these issues, as well as how to check for correct proxy settings and Registry entries.

Agent Status Hangs on "Waiting for Agent Check-in" Message
There are two situations where the agent installation or update process seems to run smoothly, but the
agent status message "Waiting for agent check-in" does not update:

• The machine has WinHTTP proxy settings that were configured outside of Cherwell Asset
Management, and the proxy server is not running. This can happen, for example, if a WinHTTP
application was installed and working through a proxy at one time, but the application was later
removed and the proxy shut down. Then, when you installed or updated the CAM Agent, you either
marked the Save proxy settings to agent machine check box and then selected Save only if new
from the accompanying list box, or did not mark the Save proxy settings to agent machine check
box at all.

• The machine has WinHTTP proxy settings that were configured outside of Cherwell Asset
Management, the proxy server is running, and the CAM Access Point is not configured to accept
traffic from that proxy server. Then, when you installed or updated the CAM Agent, you marked the
Save proxy settings to agent machine check box and then selected Save only if new from the
accompanying list box.

In either case, do the following:

1. Check machine's properties (see the following section) to see if the agent has proxy settings.

2. Determine if any other applications on the machine require those settings.

3. Resolve any conflicts. Possible ways to resolve conflicts include:
◦ Clearing the agent proxy settings if they are not needed.

◦ Configuring the access point to allow traffic through the agent's configured proxy server.

◦ Making sure the access point is considered a local address, and then configuring the proxy to
bypass local addresses.

Checking Proxy Server Settings
To find out what proxy server settings are used for a machine, check the Options tab in the Machines
Properties dialog box, or the Machine Summary report.

Registry Entries
On 64-bit machines, the corresponding Registry key is:

• HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet
Settings\Connections\WinHttpSettings
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The corresponding Registry key is as follows for all features on 32-bit machines:

• HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
\Connections\WinHttpSettings

There are two other relevant Registry keys and if you need to edit them, you must do so in the Registry
itself, as you cannot edit them in CAM Administrator. These keys are as follows for 64-bit machines:

• HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Express Metrix\7.0\ProxyServer
Value: <machine>:<port>

This key will be used by the CAM Administration Service and CAM Administrator as the proxy server
to access any external websites.

• HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Express Metrix\7.0\ProxyServerAP
Value: <machine>:<port>

This key will be used by the CAM Administration Service as the proxy server to test each CAM
Access Point.

Related information
Admin_Proxy_server_options.xml#concept2440

726

CAM 14.2 Administrator

CAM 14.2 Administrator

https://help.cherwell.com/csh?product=version-cam-14.20&topicname=Admin_Proxy_server_options


Proxy Server Options
This topic describes the proxy server options that are available in the dialog boxes from which you launch
the installation or inventorying of the CAM Agent. Use these options if the machine needs to use a proxy
server.

The options are:

• Save proxy settings to agent machine—Marking this check box (which is cleared by default)
controls the conditions under which the proxy settings that are specified are saved. Once you mark
this box, specify one of the following conditions:

◦ Save only if new—Proxy settings are only saved to machines that do not already have proxy
settings defined. Any machines that are already configured to use a proxy server are left
unchanged. Enter new information in the Proxy server list and Proxy bypass list options
below. This is the default.

◦ Always save—Proxy settings are always saved to the selected machine(s) by writing the
proxy information to each machine’s Registry. Note that this affects all applications that use
WinHTTP.

◦ Always clear—Proxies are disabled for the machine(s) by setting the machines’ Registries to
specify that no proxies are used. Note that this affects all applications that use WinHTTP.

• Proxy server list—Enter the proxy server machine name(s) to use. This string cannot exceed 255
characters.

• Proxy bypass list—Enter the proxy bypass information. This string cannot exceed 255 characters.

Syntax Information
Cherwell Asset Management processes the above strings exactly as entered, and cannot verify or modify
syntax. If you need help with the syntax for specifying proxy information, search the Microsoft website for
help.

Inventorying Machines
If you are inventorying machines, neither the access point nor the proxy information will be changed on
the machine if the CAM Agent is already installed on it.

Note: The proxy server information is determined when you install or update the CAM Agent on machines.
If proxy server information is updated by some other means after the CAM Agent is installed or updated,
the proxy information displayed in the Options tab of the Machine Properties dialog box may not be
accurate.
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SQL Server Issues
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Memory Issues
If you receive an error like the following while using CAM Administrator, you may need to adjust your SQL
Server settings or move SQL Server to its own machine:

Could not perform the requested operation because the minimum query memory is not available.
Decrease the configured value for the 'min memory per query' server configuration option.

If you do not want to move SQL Server to its own machine, open Server Properties in SQL Server
Enterprise Manager, click on the Memory tab, and adjust the Minimum Server Memory setting for the
application.
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Contact Us
• Complete contact information is available at https://pages.cherwell.com/contact.html

• Technical support contact information is available at https://www.cherwell.com/technical-support/

◦ To contact technical support via email, send a message to camsupport@cherwell.com

• To reach the sales department via email, send a message to ITAMSales@cherwell.com

730

CAM 14.2 Administrator

CAM 14.2 Administrator

https://pages.cherwell.com/contact.html
https://www.cherwell.com/technical-support/
mailto:camsupport@cherwell.com
mailto:ITAMSales@cherwell.com


Task Scheduler
The Task Scheduler is a System Tools accessory that ships with Windows. It allows you to schedule
automated tasks that perform actions at a specific time or when a certain event occurs, as well as a
number of other specifics for each task.

There are several Cherwell Asset Management scheduled tasks (such as Oracle Database Discovery,
and checks for access point and Work Queue availability) that are set up in the Task Scheduler, and you
can change when and how often these events occur.

Note: If you just want to enable/disable these tasks, see the Options Schedule Tab.

To access the Task Scheduler:

1. Select Control Panel in Windows.

2. Select Administrative Tools > Schedule Tasks (or Task Scheduler, depending on your version of
Windows).

Recommendation for Users of Windows 7 and Above
If you edit Task Scheduler settings for Cherwell Asset Management tasks on machines running Windows
7 or later, it is recommended that you not change the Configure for option. By default, this option, which
is in the General tab of the Task Scheduler when you select a task, is set to Windows Vista, Windows
Server 2008. If you change the Configure for option, you cannot change it back to the default.

In addition, since Task Scheduler tasks are not visible to Cherwell Asset Management, changing this
option may cause the following problems:

• Any automatic updates you've scheduled with the Scheduler will occur as planned, but the Install
updates automatically option in the Automatic Updates tab of the Update CSID dialog box will not
be selected, which may cause issues.

• If you uninstall Cherwell Asset Management, the Uninstall application cannot remove Scheduler
tasks that are not visible to Cherwell Asset Management.  

Note:
In hosted installations, some scheduled tasks are managed in the cloud. To update the schedule
for these tasks, contact your cloud provider.
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