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Getting Started

Now that you have installed GoldMine Premium Edition, this chapter will help you understand the GoldMine
Architecture.

m The GoldMine File System

m File Server and Client/Server Architecture

For more information and procedures, see the GoldMine User Guide PDF or the Online Help.

The GoldMine File System

GoldMine stores information in one or more databases in which related records are logically organized. Storing
information in a database provides advantages such as a common point of access for multiple users, applications,
and data security.

Network applications managing information typically organize shared data in a relational database structure,
supervised by a Database Management System (DBMS). The DBMS supervises maintenance of and access to the
database. It has a database engine that defines the database structure, stores data, and responds to requests by
retrieving data from the stored locations. The DBMS can organize data in one large database that stores all system
data or in multiple unique databases in the same system.

Information systems today facilitate quick and reliable data management and retrieval using the relational
database. At the most basic level, a relational database consists of tables organizing data in columns and rows. The
cell at any column/row can contain only one value. Columns and rows work together to define the type of
information a cell contains.

GoldMine, acting as a DBMS, uses a number of different files to store various elements of the data it collects. In a
GoldMine Premium Edition installation, the shared database files and Contact files are hosted on the server
database while licensing and user files remain local to the GoldMine folder.

In a network environment, you can run workstations from the executable on the server. You can also install
GoldMine's executable files locally to a workstation if the data files are centrally located and accessible to all
GoldMine users. The physical configuration of GoldMine on the hard drive is important. The main GoldMine
executables should always be one level deep in a directory structure. The path to GoldMine should be
x:\GoldMine, where “x” is the network drive where GoldMine is installed. Installing by using Universal Naming
Convention (UNC) paths, the server path should be \\server\GoldMmine\GoldMine or
\\server\sharename\Gold™mine.

File Server and Client/Server Architecture

Networks require configuration that manages shared data stored in a central location. Users need a way of
accessing information from the central file(s), and the organization needs a way of protecting data integrity and
controlling traffic to maintain the availability of shared resources. These needs are met using file server and
client/server architecture.
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Client/Server Architecture

GoldMine Premium Edition utilizes a client/server architecture:
= The client/server uses network resources more efficiently to reduce network traffic and respond to requests for
data while maintaining data security.
= The client/server architecture effectively divides the functions of the DBMS between the client and the server.
m The server acts as the database engine maintaining and administering access to the data.
= When the server receives a request from a client, the server scans the database for data on the server and
returns only the requested piece rather than a whole block.
m Processing occurs at the server, so the server sends back the data in final form as the response to the query.
m Structured Query Language (SQL) is the tool enabling the application user interface to communicate with the
server database engine.
NOTE: To encrypt database traffic between GoldMine and SQL Server, turn on Force Protocol Encryption
option in the properties of the Native Client Configuration for SQL server. Note that file attachments are
transferred using Microsoft networking file system and might not be encrypted.

Best Practices for Customizing GoldMine

In GoldMine, Administrators have a number of ways in which they can customize and modify fields or files in order
to tailor the product for the needs of the organization. These customizations could encompass user-defined fields
(Contact2), Field Views, Details, F2 Lookups, and Resources.
Following are a few best practices that GoldMine recommends that Administrators follow in order to minimize
issues.
= Create or Modify Customizations only from the main server
It is best to implement customizations only from the main network installation of GoldMine Premium Edition.
= Implement access and security controls over modifying the customizations. GoldSync can be configured not to
retrieve customizations from remote sites.

We do not recommend allowing remote users or remote sites to customize their local copies and sync those
customizations back to the main servers. In general all customizations should occur on the main server and be
synchronized to the remote sites or remote users.

This limits the possibility of duplicate or 'similar' customizations or confusion over which customizations
should prevail on a company-wide basis
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User Administration

Select from one of the following topics for information on how to manage security, access, and user options.

m Managing User Security and Access
m Managing User Options

m GoldMine .INI Files

m Configuring System Settings

= GoldMine Macros

Managing User Security and Access

GoldMine’s security is based on user groups and users, which must be set up to make the security effective.

Each GoldMine user should have a unique user name and password. This is the first level of security. The GoldMine
administrator assigns each user the minimum level of necessary access without restricting the functionality related
to the user’s job performance.

Define user groups according to the function users perform. User and user group security access applies to:

= GoldMine Functions. The administrator can permit or deny access to GoldMine functions. For example, permit
or deny a user or user group the ability to create new Contact Records, delete records, or access other users’
Calendars.

= Menu Commands, Toolbar, and Taskbar Settings. Remove menu items from the user’s menu customizing the
selection of available menu options and customize toolbars and the Taskbar.

= Contact Databases. Assign user groups access to databases. If a database is assigned to a user or user group,
only members of the group can open the database in GoldMine. Each database can have different access
restrictions.

= Screens and Fields. Restrict access rights to user-defined screens attached to particular contact databases. If a
screen is public, all GoldMine users can view the information. If access is set to a user group, only members of
the group can see the screen.

= Record Ownership. Each Contact Record is assigned an owner. The default owner is public; however, assign a
record or group of records to a user or user group. If a record is owned by a group, each group member is
treated as the owner of the record. Ownership determines whether a user who is not an owner can read all
or part of the Contact Record or whether a user can edit the record.

The GoldMine administrator can also restrict access to such items as the Relationship Trees, InfoCenter entries,
and the ability to launch Ivanti from GoldMine Premium Edition.

Users with Master Rights can access all parts of the system and bypass all the security settings except for the
user’s:

= Personal Contacts
= PersonalBase files in the InfoCenter

= Encrypted e-mail

Master Rights users are the only users permitted to access and modify user settings. GoldMine administrators
should have Master Rights.
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For more information, see the following topics:

Record Ownership

Record Curtaining

Users Properties

To Set the User Profile

To Set Up User Membership
Setting Up User Groups

To Set User Access

To Set User Menus

Creating User Menu Templates
To View the User Time Clock

To Set the Outlook Sync Options
Clone User Settings

User Passwords

I o I o [
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Record Ownership

Contact records can be owned by everyone (public), by a user, or by user groups. Ownership determines security
on contact records. Consider the following when setting record ownership:

= Records owned by (public) can be viewed and edited by all users. Viewing and editing security can be set on
individual fields.

m Record Ownership is used when record curtaining (see Record Curtaining) is applied. Ownership is stored in the
Owner field in the Contact1 table.

Ownership can be set when you

= Create a Contact Record (see To Set the User Profile)

m Configure Record Ownership (see Setting Ownership in the Record-Related Settings)

Record Curtaining

Record curtaining (see Setting Ownership in the Record-Related Settings) lets you hide information in a contact
record from those individuals who do not own the record. With record curtaining active, if you try displaying a
contact record you do not own, the lower portion or all of the contact record is “curtained,” hiding the data from
view.

NOTE: Curtaining status is stored in the Contactl table. The level of curtaining is stored in the second
position in the Status field. A blank or zero indicates no curtaining, a 1 indicates partial curtaining, a 2
indicates complete curtaining, and a 3 indicates semi-partial curtaining.

Record curtaining is controlled by the record Owner. Each contact record can be either “public” or “private.” When
a new record is added to the database, ownership defaults to (public). Public records can be viewed by all
GoldMine users.

Private records are records with an assigned an owner, either an individual GoldMine user, or a user group. If you
select complete record curtaining, private records can be viewed only by their owners, or by members of the
owner user group. If you select partial curtaining, other users can see only the company, contact, and phone
number for the private records.

NOTE: When an non-owning user performs global operations, such as mass deletions or field updates,
GoldMine ignores completely curtained records. In addition, scheduled activities linked to a curtained
record appear as unlinked to unauthorized users.
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Curtaining Levels
= None: All users can view the entire Contact Record.

= Semi-partial (hide tabs): Users who are not record owners can view the upper four panes, but cannot view the
Tabs.

m Partial: Users who are not record owners can view only the contact name, and phone number areas.
= Complete: Users who are not owners cannot access any of the contact information.
NOTE: Curtaining status is stored in the Contactl table. The level of curtaining is stored in the second

position in the Status field. A blank or zero indicates no curtaining, a 1 indicates partial curtaining, a 2
indicates complete curtaining, and a 3 indicates semi-partial curtaining.

To set the record curtaining, select Edit > Record Properties > Record-related Settings, Then click the Ownership
tab.

TIP: The Global Replace Wizard can be used to perform a mass update to change ownership of
records. For more information, see Globally Replacing Field Data.

Users Properties

Control a user’s security access in GoldMine through the User Properties, which define a user’s security and access
in GoldMine (Tools > Users' Settings).

NOTE: For new users, click the New button. For existing users, select the user and then click the Properties
button.

= The Profile tab defines security, automatic record ownership, and forced log-out for a user (see To Set the User
Profile).

= The Membership tab assigns or removes a user from a group (see To Set Up User Membership).

m The Access tab sets general security to control user access to GoldMine features (see To Set User Access).

= The Menu tab configures menu options available to the user (see To Set User Menus).

= The Time Clock tab displays a log showing the user’s activity in GoldMine (see To View the User Time Clock).

= The Outlook tab contains options for synchronization between Outlook and GoldMine (see To Set the Outlook
Sync Options).

Best Practices for a GoldMine Administrator

Create one or several ideal users to reflect basic settings applicable to many users. For example, you might have
two prototype users: Sales Staff and Supervisor. Each of these user types has different rights and menus in
GoldMine. Allow the Sales Staff to add and edit new contacts but not to delete contacts or view other’s calendars.
The Supervisor can add and delete contacts and view anyone’s calendar. After the ideal user or users are created,
clone the user’s settings (see Clone User Settings) for each actual user with the same rights.
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To Set the User Profile

Use the Profile tab to create and set basic user information such as a user name, initial security, and force log out
(forcing users out at a particular time or when inactive for a period of time).

Use the following procedure to set up a user profile.

1. Select Tools > Users' Settings.

2. Atthe Users' Master File dialog box, click New to create a new user, or select an existing user and click
Properties.

At the user's Properties dialog box, click the Profile tab.

Type the Username (up to 8 characters; must begin with a letter).
Type the user's Full Name.

Type the user’s E-mail address.

N o v AW

In the Security area configure these settings:

O Password. Type the password assigned to the user. You must provide the user name and password you
created so the user can log into GoldMine.

O Confirm Password. Re-type the password assigned to the user. The value must match the value from the
Password field.

O Valid for days. In the drop-down list, select the number of days the user’s password is valid, or accept the
default (Always).

O Next change. If you change the Valid for days field, select the date the password becomes invalid and the
user cannot launch GoldMine.

O Master Rights. Select this option to give the user unrestricted access to all of GoldMine.

O The Ownership button displays the New Record Ownership dialog box. Ownership lets you specify whether
the new Contact Records the user adds to the database are public records or owned by a specific user or
user group (see Record Ownership).

O The Forced Logout button opens the Forced Logout dialog box with the following options:

NOTE: The Forced Logout option is disabled (set to 0) by default.
- Log out user and terminate GoldMine when idle for a period of time. Click this box to automatically
log the user out of GoldMine and activate the following settings:
- When idle for. Select the period of inactivity before users are automatically logged out of GoldMine.
- Forced logout only after this time. Select the time for a forced logout.

This option is useful for making your system available for nightly maintenance, without forcing users
to log out during the business day.

TIP: The Force log out options are important in managing a limited number of licenses.; many
maintenance functions can be performed only if all users are logged out of GoldMine.

8. Select one of the E-mail Options:
O Always use e-mail server (recommended) sends the e-mail message using the address entered above.
O Use GoldMine messaging when available uses the user-to-user messaging for e-mails send within
GoldMine.
9. Click OK to save the user's Profile settings without configuring the detailed user security settings, or click the
Membership tab to continue configuring the user’s properties
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To Set Up User Membership

Users can belong to several groups, allowing them access to the group’s contacts for collaboration. Groups must
be created before assigning a user to a user group. If user groups were not created, click User Groups Setup to add
the user to a group or to create a group(s). See Setting Up User Groups.

Use the following procedure to set up a user membership

1.
2.
3.

© N un s

Select Tools > Users' Settings.
Select the user and then click Properties.
Click the Membership tab.

The Member of Groups list indicates which groups the user already belongs to. The Excluded from list
indicates which groups the user is not a member of. To change the user's membership, double-click the user
name to move the user from one column to the other.

To create user groups or refine the membership, click User Groups Setup.

At the User Groups Setup dialog box, highlight the group to which to add the user.

Click Member Setup to launch the Group Membership Setup dialog box.

Double-click the user's name in the Users' List box to add the user to the Group Members list.

To add the user to other groups, return to the User Groups Setup dialog box and highlight the new group.

Click Member Setup to launch the Group Membership Setup dialog box and double-click the user's name in
the Users' List box.

NOTE: You can create User Groups while adding the user to a group. On the User Groups Setup dialog box,
click New and follow the steps.

9.

Click OK and then click Close.

The Member of Groups list displays the groups of which the user is a member.

10. Click OK to return to the Users' Master File, or click the Access tab to continue configuring user properties.

Setting Up User Groups

It is recommended that you logically group users according to functions they perform. User group names store in
the Lookup table; user group members are encrypted in the User.dbt table.

Use the following procedure to set up user groups.

1.
2.
3.
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Select Tools > User Groups.

At the User Groups Setup dialog box, click New.

Type the User Group's name in the field and click OK.
The user group displays in the User Groups box.

To add users, click Members Setup.

The Group Membership Setup dialog box opens.

To add individual users or all members of an existing group to the Group Members box, double-click the user
in the User List, or the group in the Group List, to add users to the Group Members list.

Click OK.
After creating groups and adding members, click Close.
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To Set User Access

Use the Access tab to configure a user’s access rights on Contact Records, access to information of other users,
and miscellaneous access rights. If an item is selected, the user can perform the action in GoldMine.

1. Select Tools > Users' Settings.
2. Select the user's name and click Properties.
3. Click the Access tab.
4. In the Contact Record area, select:
O Add New. Add a contact record.

O Edit Fields. Edit fields in the top half of the contact record, the user-defined fields in the Fields tab, and the
Notes tab.

NOTE: Without Edit Fields rights, users cannot edit fields on any contact records, including the records they
own.

O Delete. Delete contact records.

O Required field override. Authorize an override on a required field.
O Assign Owner. Assign Contact Record ownership to other users.

O Edit Tab Folders. Edit data in the tabs.

NOTE: Without Edit Tab folders rights, users cannot edit tab folders on any contact records, including the
records the they own.

O Schedule Process. Assigns an automated process to a contact.
5. Inthe General Access area, select:
O Build Groups. Build their own groups of Contact records in the Filters and Groups dialog box.

O ‘Output to’ menu. Enable the Output to option in the local menus in GoldMine to allow output to printer,
Word, Excel, and clipboard.

NOTE: Non-Master users cannot select Printer in the Output to menu because of Reports security
considerations.

O Delete unlinked e-mail.
O Issue SQL Queries. Write and send SQL queries to retrieve data for display.
O Real-Time folder. View the Real-Time tab in the Activity List. Displays all users’ completed activities. The

Real-time folder displays history items that were updated within the selected date range. It is not based
on the completion date for the activity.

NOTE: When applied to many users, this option can affect network performance.

O Customize Toolbar. Add and remove toolbar icons.

O SQL Logon name and SQL Password.
If using GoldMine with a SQL database and you assigned the user an individual or group logon name and
password in SQL, type the information in the text boxes. This launches GoldMine without requiring the
user's SQL logon name and password each time.

6. Inthe Notes Access area, select:

O Insert Notes. Allow endusers to add notes.

O Edit/Delete. Allow endusers to edit or delete their own notes.

O Edit/Delete others’ notes. Allow endusers to edit or delete notes from other users.
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7. Inthe Access to Others area, select the options and modify as needed.

NOTE: Access to other user’s Calendars, History, and Forecasts are hidden from a user when access to
others has been removed.

O Calendar. Select this option to do the following:
- Designate the available options from the User drop-down on the Calendar or Activity List window.
- Designate if pending activities from other users are available on a contact record's Pending tab

O History. Select this option to do the following:
- View other users’ completed activities in the Closed or Filed tab of the Activity List.
- Designate if completed activities from other users are available on the contact record's History tab.
- View other users’ completed sales activities in the Completed Activities Analysis dialog box.

O Forecast. Select this option to designate the users available when you click the Select User(s) button on the
Forecasted Sales Analysis window. (Go To > Analysis > Forecast Analysis.... Checking (or unchecking) this
option will change what is viewed on the Pending tab.

O Reports. Access other users’ reports.

O Template. Access other users’ templates in the Document Management Center.

O Filters. Access other users’ Contact record filters.

O Groups. Access other users' groups of contacts.

O Links. Access and launch other users’ linked documents.

O Opp/projects. View opportunities and projects assigned to other users.

O Cases. View cases (on the Cases tab and in the Service Center) assigned to other users.

8. Click OK to return to the Users' Master File, or click the Menu tab to continue configuring the user’s
properties.

To Set User Menus

Use the Menu tab to configure menu options available to users. This is another way of setting security and
controlling user access to features. Also create templates of menu options to apply to users as you create their
properties.

Use the following procedure to set up a user menu.

Select Tools > Users' Settings.

2. Highlight the user and click Properties.
3. Click the Menu tab in the User Properties dialog box.
4. To use a menu, select one option:

O Apply a menu template you created by selecting the template name in the drop-down list.
O Click Expand to display all menu options.

To expand the menu display, click the icon next to each option to change the status. When the icon is
red, the option is unavailable to the user. When the icon is green, the option is available.

NOTE: If the Resize menu option located under Edit > Record Details > Resize is restricted, the custom
screens in the Fields tab display as GoldMine menu options.

5. OKto save the Menu configuration and return to the Users' Master File, or click the Time Clock tab to
continue configuring the user’s properties
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Restricting User Options Access

The GoldMine Administrator can restrict a user's access to the User Options dialog box.

1.
2.
3.
4.

Open the Tools menu and select Users' Settings.

Select a user from the list.

Click Properties and then select Menu.

Choose available main menu items for the selected user and then click Save.

Menu layouts can be saved for instant recall for any user.

Creating User Menu Templates

Save User Property Menu configurations as a template and apply the template to other users.

Use the following procedure to set up a user menu template.

1.

5.
6.
7.

NOTE

Select Tools > Users' Settings.

Highlight the user and click Properties.

Click the Menu tab in the User Properties dialog box.

Click Expand to display menu options.

Click the icon beside the option to change the status.

When the icon is red, the menu option is unavailable to the user. When the icon is green, it is available.
Click Save to save the setup as a menu template.

At the Save Menu Template dialog box, type the name of the template.

Click OK to save the template.

: To delete a Menu template, select it in the drop-down list and click Delete.

To View the User Time Clock

The Time Clock tab is a management tool rather than a configuration option. View the user's activities in
GoldMine.

GoldMine Administrator's Guide

O Date. Date of the logged activity by the selected user.

O Login. Time the user logged into GoldMine.

O Logout. Time the user logged out of GoldMine.

O Logged. Total time the user was logged into GoldMine, including any time logged away.

O In. Total number of times the user logged into GoldMine.

O Keys. Number of keystrokes pressed by the user while working in GoldMine.

O Clicks. Number of mouse clicks performed by the user while working in GoldMine.

O CRC. Indicates whether the data in the user log was modified outside of GoldMine. This column displays OK
for every log entry that is free of tampering; that is, external.
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To Set the Outlook Sync Options
The Outlook tab allows you to set synchronization abilities for the user.

1. Select Tools > Users' Settings.
Highlight the user and click Properties.
Click the Outlook tab in the User Properties dialog box.

Select from the following options:
O Enable on-demand sync with Outlook

This option determines if user has an access to a menu item Synchronize with Outlook menu option
(Tools > Synchronize > Synchronize with Outlook). Disabling this menu item does not necessarily mean
that sync does not occur for this user. A user with Master rights can configure the Outlook profile for
automatic synchronization.

NOTE: This option is automatically selected and enabled for Master users.

O Enable sync with Outlook when system time zone is different from user’s home time zone

This option determines if sync can occur if Windows time zone changed since the last time sync took
place.
4. Click OK to return to the Users' Master File, or click another tab to continue configuring the user’s properties.

Clone User Settings

After creating an ideal user with settings applying to many users, clone the user's Properties. All security settings in
the User Properties apply to the new user except the Username, Full Name, and Password on the Profile tab.

Use the following procedure to clone a user setting.

1. Open the Tools menu and select Users' Settings.

2. Right-click the user whose settings you want to clone and select Clone from the menu.

3. Atthe New User Properties dialog box, enter the Username, Full Name, and Password; select the other Profile
settings.
The Membership, Access, and Menu settings apply to the new user.

4. Change the individual user properties as needed.

5. Click OK.

User Passwords

GoldMine users are required to have passwords to log into the product. As a part of GoldMine’s security
enhancements, password complexity is in place and is enforced by default for all newly created users. All options
regarding passwords are located on the Password Policy tab in the System Settings.
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To Define User Passwords

Open the Tools menu and select Configure > System Settings.

Click the Password Policy tab. All defined passwords must respect the following rules:
O Have a length of 8 characters, or a custom length set up by the administrator here.
O Contain 1 uppercase character.

O Contain 1 lowercase character.

O Contain 1 digit.

O Contain 1 special character, suchas: |, #, @, S, %, &, /, (, ), ?, and so on.

To Enable a User Account

If a user fails to login after 3 attempts, the account becomes disabled (locked) and can only be reinstated by a user
with Master rights (see To Set the User Profile). To enable a user’s account that has been locked, follow the steps

below.

1. Open the Tools menu and select Users’ Settings.

2. Select the user that needs to be enabled from the list and then click the Properties button.
3. On the Profile tab, click the Unblock Account button and then click OK.

To Enable a Master User Account

If the Block the account after 3 invalid logon attempts option is checked on the Password Policy tab (see User
Passwords) and a Master user fails to login after 3 attempts, any other Master user can reinstate the account (see
To Enable a User Account).

However, if there are no other Master users to reinstate the account, you can follow the steps below to reinstate
the account.

IMPORTANT: You will need to enter your GoldMine license number as part of this process. If you don’t have it,
contact your system administrator for this number. You cannot proceed with the process without it.

1.

GoldMine Administrator's Guide
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Browse to the GoldMine installation folder (typically \Program Files\GoldMine or
\Programbata\GoldMine)

Locate the 1icenseGM. bin file and rename it to TicenseGM. temp.

Launch GoldMine.

Enter your license information for validation purposes and then click Next.

Enter a Username and optional Password, then click Finish to display the GoldMine login dialog box.
Enter your login information and then click OK.

Browse to the GoldMine installation folder and delete the newly generated 1icenseGM. bin file.

Rename the TicenseGM. temp file to licenseGM.bin.
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Managing User Options

Define GoldMine settings unique to you. GoldMine saves user options (settings that control how GoldMine looks

and acts for each user) settings in your user’s initialization file (username.in1i).

NOTE: While the User Options tabs have settings that allow users to customize their work environment,
many GoldMine administrators configure these settings for users and then restrict their ability to change
the Options. For more information, see Restricting User Options Access.

Set User Options on the following tabs:

Personal Change your password and add personal information. See Setting Options on the Personal Tab.

Record Control the appearance of Contact records, tab displays, and zip code validation. See Setting
Options for the Record Tab.

Calendar Determine calender appearance and functions. See Setting Options for the Calendar Tab
Set parameters for scheduling and working with activities. See Setting Options for the

Schedule
Schedule Tab.

Alarms Configure GoldMine alarms. See Setting Options for the Alarms Tab.

Lookup Set display options for Contact records and the Contact Search Center. See Setting Options for
the Lookup Tab.

E-mail Configure settings for your e-mail server, login information, and rules to apply when sending
and receiving e-mail. See Setting Options for the E-mail Tab.

Telephon Control settings for your computer's modem and dialing options and SoftPhone advanced

phony settings in GoldMine. See Setting Options for the Telephony Tab.

System Set date and time settings. Select classic navigation and taskbar settings, and specify an
Outlook username, if different than your GoldMine username. See Setting Options for the
System Tab.

Speller Specify GoldMine spell checking options. See Setting Options for the Speller Tab.

) Configure SMS message reception for a user’s mobile device. See Setting Options for the

Messaging .
Messaging Tab.
Determine the locations of the GoldMine default databases and system files, and other system

Login settings. This tab is available only to users with Master Rights. See Setting Options for the

Login Tab.

GoldMine Administrator's Guide
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Setting Options on the Personal Tab

Use the following procedure to set up user personal information.

1. Select Tools > Options.
2. Atthe User's Options dialog box, select Personal.

The Personal tab displays User Name and Full Name.
NOTE: A Master Rights user can change the Full Name in the User Profile.

3. Click Change Password to change your GoldMine Password.

4. Inthe Title field, type your professional title.
NOTE: For Title and following Department, Phone, and FAX text boxes, selecting the Select contents of field
option chooses the entire contents of a field. If this option if selected and your screen saver is set to On,
you might inadvertently delete the contents of the field when you clear the screen saver. If you press ESC
before leaving the field, the data is replaced.

5. Inthe Department field, type the name of the organization or group you are affiliated with.

6. Inthe Phone field, type your primary telephone number.

7. Inthe FAX field type your fax number.

8. Click OK to save the settings and close the dialog box.

To Change Your Password
To change your GoldMine Login password, you must be the user logged into GoldMine.
1. Select Tools > Options.
At the User's Options dialog box, select the Personal tab.

Click Change Password.
At the Change Password dialog box, type your current password in the Enter your current password field.
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Type your new password in the Please enter a new password field, and then type it again in the next text
box.

6. Click OK to save the new password and return to the Personal tab.
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Setting Options for the Record Tab

Use the Record tab to customize the display of the contact record and set the ZIP code validation and title
appearing on the contact window.

1. Select Tools > Options.
2. Atthe User's Options dialog box, select Record.
3. Inthe Appearance area select:
O Dark background. Browse windows appear with a gray background.
O Bright background. Browse windows appear with a white background.
O Use Large Font. Displays dialog box text in a large font.
This setting is designed for use with monitor display resolution of 1024x768 or higher using Windows’
small font option. It is not available if your display is set to a resolution of 640x480 or if using Windows’
large font option.
The Use Large Font option does not apply to the GM+View tab. To increase the display font size in IE 6.0,
select View > Text Size and select the appropriate size.

O Label Color. Displays the Color dialog box to select a color for all field labels displayed in Contact Records.

O Data Color. Displays the Color dialog box to select a color for all field data displayed in Contact Records.

O Tabs. Displays the Display Tabs dialog box to select the tabs to appear in the contact record and the tab
order.

O Select contents of fields. Selects or highlights data entered in a field when you click inside it.

O Use a word format for user-defined dates. Displays dates in text form based on the format selected in the
drop-down list.

NOTE: Typically, this setting affects fields in the Fields tab of the Contact Record, but the selected format
affects user-defined fields placed anywhere in the Contact Record. The user-defined date format you select
from this tab overrides the Show dates format of the local settings option if selected in the Misc tab.

O Show numerics aligned to the right. Right-aligns numbers.

O Show sort-by field on status bar. Displays the sort field on the left side of the status bar.

O Open org tree when maximized. Displays the organization tree automatically when you maximize a contact
record.

4. Inthe ZIP Code Validation area, select.

O No Validation. GoldMine does not perform ZIP Code validation. When adding a new Contact Record or
editing an existing record, the City field is edited first, followed by the State and Zip fields.

O Default to primary city. GoldMine automatically validates ZIP Code entries on the contact record. When
adding a new record or editing an existing record, the Zip field is edited first. If the entered ZIP code is
found in the ZIP Code file, the city and state from the first matching ZIP Code record is placed
automatically in the City and State fields on the Contact Record.

O Show window of cities. When more than one city exists for a particular ZIP Code, GoldMine displays a
browse window containing all the cities that ZIP Code is valid for. To select the appropriate city from the
window, highlight the record, then press ENTER or double-click the entry.

O Show 9 digits in lookup. Enlarges the ZIP column in the All ZIP Codes Lookup list to display a ZIP plus four
entry.

NOTE: A complete ZIP Code database is available. Call your local GoldMine Partner or Ivanti for
information.
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5. Inthe Contact Window Title area, select:

O Contact name. Displays the name of the contact in the title bar of each Contact Record. For example, if the

contact name entry is John Doe, the title bar displays John Doe for that Contact Record.

NOTE: Whether this option displays Contact name or another name depends on the field label in GoldMine.

If the field name is Contact, the label can be customized by the administrator.
O Company name. Displays the company name in the title bar of the contact record.

NOTE: Whether this option displays Company name or another name depends on the field label in
GoldMine. If the field name is Company, the label can be customized by the administrator.

6. Click OK to save the settings and close the dialog box.

To Change User Labels and Data Colors

When you click the Label Color or Data Color buttons on the Record tab, the Color dialog box displays. Use this

dialog box to select from a predefined palate of colors or customize the color selection.

Color

Basic colors:
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Red: [0
Green: IU_
Blue: [255

Add to Custom Colors

Picking a New Color for Labels or Data
1. Click the Label Color or Data Color button.

2. Use one of the following methods to pick a color:

O Select a color from the Basic colors pallet.

O Define and add a custom color to the Custom colors pallet.

3. Click OK to use the selected color.

Creating a Custom Color

1. On the Record tab, click the Define Custom Colors button.
2. Click anywhere in the color picker to select the approximate color.

3. Move the luminosity slider (located on the right of the color pallet) up or down to adjust the color brightness.

Alternately, you can enter the Hue, Saturation, Luminosity, as well as the Red, Green, and Blue levels

manually by typing in their respective values.
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4. Click the Add to Custom Colors button.
Custom colors are added to Custom colors pallet and are also available for future selection
Select the new color on the Custom colors pallet.
Click OK to use the selected color.

To Set the Contact Record Tabs

The User's access to Contact Record tabs can be configured by a Master User. After being set for the user (or all
users) by a Master User, only the tabs selected in the Tabs Access dialog box are available.

1. Onthe User’s Options dialog box, click the Record tab.
2. Click the Tabs button.

Tabs Access EJ

ﬁ Please select the tabs to be avaliable For "JOHN'
A
¥ Details
W Notes Move Down
¥ G+
v Pending .
v History 0 globalky
¥ Opportunities
¥ Projects
v Cases
¥ Summary
v Fields Reset
v Additional Contacts
v Referrals
v Members
I¥ Processes w

3. Make the following changes as desired:
O Check the tabs that you want available for the selected user.
O Reposition the tabs by selected the tab name and clicking the Move Up and Move Down buttons.
O Rename any selected tab by clicking the Rename button and making your change on the Edit Tab Label
dialog box. If you create a shortcut, be sure that it is not currently used by another tab.

O Apply these changes to all users by checking the Customize globally option.
4. Click OK to apply your changes and close the dialog box.
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Setting Options for the Calendar Tab

Use the Calendar tab to set up your calender appearance and functions.

1. Select Tools > Options.
2. Atthe User's Options dialog box, select Calendar.
3. At the Calendar Settings area, select:
O Work day starts at: Enter the time or using the F2 graphical clock to indicate the time you typically arrive at
the office. This information is used to set up your available time on the calendar.

O Work day ends at: Enter the time or using the F2 graphical clock to indicate the time you typically leave the
office each day.

O Increment time by: Select a time from the drop-down list. This option sets the minutes in your displayed
calendar. The default is 30 minutes. If you select 10 minutes, for example, the daily and weekly calendar
will be divided into 10-minute increments.

O Set color as: Select your calendar color from the drop-down list.

O Font size: Select the font size from the drop-down list.

4. Click More Options to open the Calendar Options dialog box to set the Activity Details, Publishing, and

Free/Busy tab settings.

For information about these tabs, see the following topics:

O To Configure the Calendar Options Activity Details Settings

O To Configure the Calendar Options Publishing Settings

O To Configure the Calendar Options Free/Busy Settings

5. Click Holidays to open the Calendar Options dialog box to the Holidays tab.
For information about the Holidays tab, see To Configure the Calendar Options Holidays Settings.
6. Inthe Work Days area, select the days of the week you work.

Days selected display as a lighter shade in the calendar. Days cleared display as a darker shade and are not
considered work days.

7. Inthe Auto Roll-overarea, select the types of activities to automatically roll the activity to the next day if it is
not completed.

NOTE: Auto Roll-over is not normally set for Appointments or Forecasted Sales because users cannot make
today's 10:00 appointment tomorrow or the next day at the same time. They should reschedule.

Select Sync Roll-overs for the new roll-over date to synchronize to remote users. Clear the box to preserve
the original date.

8. Set the Calendar refresh rate (sec): by typing the number of seconds or scrolling through the numbers in the
text box.

GoldMine updates the Calendar entries at the end of the interval you specify in number of seconds. The
default entry 0 disables the option so GoldMine will not automatically update the calendar.

NOTE: Increasing the Calendar refresh rate sends a signal to the server to update every x seconds and
sends you the same data again if no changes are made to your Calendar. Setting this option to update too
frequently might increase the network load unnecessarily.

9. Click OK to save the settings and close the dialog box.
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To Configure the Calendar Options Holidays Settings
Use the following procedure to add predefined holidays to your calendar display, or create your own.

NOTE: Only users with Master Rights can add or edit Holiday Categories. The Holiday Categories are
available to all users with access to their User Options. They can select the categories appearing on their
individual calendars.
1. Open the Tools menu and select Options.
2. On the Calendar tab, click Holidays.
The Calendar Options dialog box opens with the Holiday tab active.
3. Inthe Holiday Categories list, select any predefined holiday category(s) you are adding to your calendar
display.
Holidays for the selected categories display in the Holidays list. Predefined sets include both fixed holidays
such as New Year's Day and variable holidays such as Easter.

4. To create a new Holiday Category, click New and then enter the name in the text box on the Add a Holiday
Category dialog box and click OK. The new category adds to the list.
5. To manage the Holiday Categories use the following options:
O Import. Imports iCalendar (.1 cs) holidays.
O Export. Exports holidays to iCalendar.
O Reset. Removes user-defined categories and adds predefined categories previously removed.
O New. The Add a Holiday Category dialog box opens.
O Remove. Removes the select category.
O Edit. The Add a Holiday Category dialog box opens. Edit the category name.

Adding or Editing Holidays

1. Atthe Holidays area, click New.
At the Add a Holiday dialog box, type a name of the holiday in the Holiday field.
In the Repeats area, type or select how often the holiday repeats in the Every: x year(s) field.
In the Duration area, type or select the number of days the holiday lasts in the # Days: field.
Select the holiday either by:
Specific Date. Select the month and day in the drop-down lists.
Day of the Week. Select the week, the day of the week, and the month in the drop-down lists.
Click OK.
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Adding and Editing Holidays to Categories

Highlight the Holiday Category to which you are adding the holiday.

In the Holidays area, click New.

The Add a Holiday dialog box opens.

To change the settings for a holiday, highlight the holiday and click Edit.
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The Edit a Holiday dialog box opens. The editing options are the same as the Add a Holiday dialog box
options.
6. To remove a holiday, select the holiday and click Remove.
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To Configure the Calendar Options Activity Details Settings

Use the Activity Details tab to configure how scheduled and completed activities display on your calendar.

P W N

Open the Tools menu and select Options.

On the Calendar tab, click More Options.

At the Calendar Options dialog box, select the Activity Details tab.

In the Scheduled Activity Detail Display area and the Completed Activity Detail Display area, select from the

following options:

O Show “Contact's Name. Reference” displays the name of the contact before the activity reference
information in the calendar entry on the Day tab, Week tab, and Month tab. This is the default display
option.

O Show “Reference. Contact's Name” displays the activity reference information before the name of the
contact in the calendar entry on the Day tab, Week tab, and Month tab.

O Show “Company Name: Reference” displays the company name information before the activity reference
information in the calendar entry on the Day tab, Week tab, and Month tab.

O Show “Reference: Company Name” displays the activity reference information before the company name
information in the calendar entry on the Day tab, Week tab, and Month tab.

O Show results of an xBase expression allows users to specify text appearing for each activity in the calendar
on the Day tab, Week tab, and Month tab. Type the expression in the text box. For example, to display an
entry listing the contact’s city then reference information, type this expression:

Trim(Contactl->City)+ ":"

Select Show Activity Code to display the three-character activity code as the first part of the calendar entry

on the Day tab, Week tab, and Month tab.

The activity code appears first, if available, when selected with any other format option; that is, with

Contact's Name: Reference, Reference: Contact's Name, and xBase expression.

To Configure the Calendar Options Publishing Settings

1.
2.
3.

Open the Tools menu and select Options.
On the Calendar tab, click More Options.
At the Calendar Options dialog box, select the Publishing tab.

For more information, see Calendar Options Dialog Box, Publishing Tab in the GoldMine User's Guide.

To Configure the Calendar Options Free/Busy Settings

1.
2.
3.

Open the Tools menu and select Options.
On the Calendar tab, click More Options.

Set the options as desired.

For more information, see Calendar Options Dialog Box, Free/Busy Tab in the GoldMine User's Guide.
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Setting Options for the Schedule Tab

Use the Schedule tab to set parameters for scheduling and working with activities.

1. Select Tools > Options.
2. Atthe User's Options dialog box, select Schedule.

3. To configure the Schedule, select from the following:

O Check for timing conflicts while scheduling notifies you of a scheduling conflict.

O Prompt to schedule a follow-up activity when completing an activity is an optional and “best practices”
workflow. When an activity is completed in GoldMine, there is a Schedule a follow-up checkbox at the
bottom of the dialog. If you select this option, it prompts you to schedule a follow-up activity with a
contact, allowing you to not lose track of the contact and keep in contact with them.

O Carry over completion notes when scheduling follow-up calls. The notes are carried over from the
completed activity to the follow-up activity.

Selecting this option means the notes from a completed call are available in the scheduled follow-up call.
This allows for consistency when working with the customer by providing information about previous
conversations.

O Start timer when completing activities helps managers review team member activities in Statistical
Analysis. If not activated, numbers do not appear in analysis features. Users do not need to know this is
turned on.

O Show the details section in the Activity Listing window displays two detail panes in the Activity List that
include the contact, company, create on, as well as notes and related information for the activity.

O Sync the Contact window with the Activity Listing window displays the contact record for the selected
activity in the Activity Listing window.

NOTE: For Administrators: You might want to disable the prompt for the following options to prevent user
error. For Example: if an activity is scheduled for multiple contacts, and then one is completed but the
wrong prompt is selected, the activity will be marked as completed for all contacts.

O Show prompt when completing an activity with other associated displays a dialog box asking whether you
want to complete a single instance or multiple instances at one time. If you choose not to show the
prompt, GoldMine will apply to a single instance without asking.

O Show prompt when editing an activity with other associated displays a dialog box asking whether you
want to edit a single instance or multiple instances at one time. If you choose not to show the prompt,
GoldMine will apply to a single instance without asking.

O Show prompt when deleting an activity with other associated displays a dialog box asking whether you
want to delete a single instance or multiple instances at one time. If you choose not to show the prompt,
GoldMine will apply to a single instance without asking.

4. Click OK to save the settings and close the dialog box.

Setting Options for the Alarms Tab

Use the Alarms tab to select how GoldMine notifies you of an appointment.

1. Select Tools > Options.
2. Atthe User's Options dialog box, select Alarms.
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9.

10.

Select one of the following:

O Disable alarms. Turns alarms off and disables the remaining alarm options.

O Pop-up alarms. An alarm window pops up on your screen.

O Task-bar notification. The notification alarm displays on the Windows taskbar and an alarm icon appears in
the system tray.

After you select Pop-up alarms or Task-bar notification, select the Alarms default lead time. x minutes to
specify the number of minutes before an event the alarm pops up.

Set the Scan for alarms every. x seconds to specify how often GoldMine scans for alarms.
Set the Task-bar notification reminder. x minutes.

This option determines the number of minutes before an event the taskbar notice appears. GoldMine also
plays an alarm sound if specified.

Set the number of minutes on the When | ignore alarms, snooze the ignored alarm for. x minutes option.

Select Page me with the alarm when not acknowledged within x minutes and set the time. This only works if
you configured the Pager tab notify you if an alarm is not acknowledged.

Select Play alarm sound file and browse to the sound file to play as an alarm signal.

Select Place GoldAlarm icon on my desktop to place a shortcut to the GoldAlarm.exe on the desktop and
place the icon in the system tray when GoldAlarm is running in the background.

NOTE: GoldAlarm notifies you about alarms even when GoldMine is not running.

11.
12.

Select Run GoldAlarm when Windows starts to automatically run the GoldAalarm.exe when Windows starts.

Click the More Options button to select from activity types for which the alarm is automatically turned on.

NOTE: The Show a single alarm for activities linked to multiple contacts option prevents multiple alarms
when there are more than one contact for an appointment.

13.

Click OK to save the settings and close the dialog box.

Setting Options for the Lookup Tab

The options on the Lookup tab on the <User> Options dialog box allow you to configure the display attributes and
functionality of the Contact Search Center.

1.
2.
3.

GoldMine Administrator's Guide

Select Tools > Options.
At the User's Options dialog box, select Lookup.
Select from the following options:

O Show SQL query editor in the Search Center to display the Query Editor on the Contact Search Center page
(see Contact Search Center Query Editor in thee GoldMine User's Guide).

O Sync the Contact window with the Search Center window to display the selected record in the Contact
Search Center as the active record in the work area.

Type or select the Lookup alignment delay while typing (1/10 sec).

This specifies the delay in tenths of a second between when you type an entry in the Find Value field of the
Contact Search and when the Contact Search Center window displays a record that matches the entry.

In the Default Lookup by area, select an option: Contact, Company, or Remember Lookup by.

This option becomes the Contact Search Center window default when selected on the toolbar or the menu.
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6. Inthe Once a record is selected from the Search Center area, select one of the following:
O Move the Search Center window to the back brings the Contact Record to the front and places the
Contact Search Center behind the contact record.
O Close the Search Center window closes the Contact Search Center.
O Minimize the Search Center window minimizes the Contact Search Center.
7. Click the More Options button to view the Select CSC fields options.
This opens a dialog which lists the fields available on the system. A check box by each field allows the user to
control which fields are displayed in the Search-by list (see Searching for Contact Records in the GoldMine
User's Guide).
Check the fields that you want to be available in the Search by drop-down list for the current user.

Click OK to save the settings and close the dialog box.

Setting Options for the E-mail Tab

To send and retrieve e-mail through GoldMine, configure e-mail options on the E-mail tab.
NOTE: You cannot edit E-mail Options while the E-mail Center window is active on the screen.

1. Select Tools > Options.
2. Atthe User's Options dialog box, select E-mail.
3. In the Getting Mail area, complete the fields.

For the POP3 or IMAP protocols:

O Server. Select the correct protocol radio button, then type your e-mail server name or IP address. It can be
your local Exchange server, or the POP3 or IMAP server for your ISP.

O Username. Type your login for the Exchange server or ISP e-mail account.

O Password. Type your password on the Exchange server or your ISP e-mail account.

O Use encrypted connection (SSL). Select this checkbox to use a secure connection. This ensures the privacy
of the connection between your account and the server. Enabling SSL does not verify the identity of your
account or the e-mail server, but does prevent a third party from listening or recording messages sent
between them.

For the OAUTH2 protocol:

O Server. Select the OAUTH2 protocol radio button.

O Provider. Select your provider type from the drop-down menu. The server name will auto-fill based on the
provider you select.

O Connect button. Click to connect to your email server. You'll be asked for your e-mail address and e-mail
account password to sign in with either Google or Microsoft Office. You'll then be asked to grant
GoldMine PE permission to access your email with a secure connection. Once access is complete, and
you're finished entering all e-mail options, your e-mail account will display by default in the Online folder
of GoldMine PE's left navigation pane. To add other e-mail accounts, click the Accounts button.

O Use encrypted connection (SSL). Select this checkbox to use a secure connection. This ensures the privacy
of the connection between your account and the server. Enabling SSL does not verify the identity of your
account or the e-mail server, but does prevent a third party from listening or recording messages sent
between them.

4. Select the Use Outlook for linked E-mail Addresses option to set Outlook as the default e-mail application.

After you make this change, any e-mail address link that you click will open Outlook to compose a new e-mail

message. For more information about Outlook, see Outlook Integration Administration.
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5. Inthe Sending Mail area, complete the fields:

O SMTP server. Type your e-mail server name or IP address. It can be your local Exchange server or the SMTP
server for your ISP. If you're using OAUTH2, the SMTP server auto-filled when you selected a provider.

O Your return address. Type a complete e-mail address that you want all return e-mails to go to. This could
be your e-mail address or one for a different department, such as marketing.

O Use Start TLS or Use encrypted connection (SSL). Select one of these check boxes according to your
provider's information. This ensures the privacy of the connection between your account and the server.
Enabling TLS or SSL does not verify the identity of your account or the e-mail server, but does prevent a
third party from listening or recording messages sent between them.

6. Inthe Network connection area, select:

O User Dial-up networking. Dials your Internet provider automatically when you send and retrieve Internet e-
mail. If you subscribe to more than one Internet provider, select the provider you want GoldMine to dial
by selecting the Internet account in the drop-down list next to the field that appears below this option.

O Hang up when done. Terminates the telephone connection after finishing sending and retrieving Internet
e-mail.

7. Click More Options to configure e-mail settings in more detail:

O Composing (see To Set E-mail Options on the Composing Tab)

O Retrieval (see To Set E-mail Options on the Retrieval Tab)

O Accounts (see To Set E-mail Options on the Accounts Tab)

O Security (see To Set E-mail Options on the Security Tab)

O E-mail Center (see To Set E-mail Options on the E-mail Center Tab)

O Advanced (see To Set E-mail Options on the Advanced Tab)

8. The Accounts button takes you directly to the Accounts tab that is also available through More Options.

To Set E-mail Options on the Composing Tab
Define settings for GoldMine to apply when writing an Internet e-mail.
1. Select Tools > Options.

At the User's Options dialog box, select the E-mail tab.

Click the More Options button.
At the E-Mail Options dialog box, select the Composing tab.
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In the General area, select:

O Show public E-mail templates. The drop-down list in the e-mail Subject line lists all e-mail templates saved
to (public) in the E-mail Templates dialog box.

O Attach VCard to outgoing E-mail. Attaches your VCard (VCF file) to each e-mail message. A VCard contains
information similar to a contact record. If the receiving system has VCard capabilities, the system will
decipher the . VCF file to import this information.

O When forcing line wrap, wrap at column x. Specifies how many characters GoldMine includes before the
text wraps to the next line.

O Send attachments as links for GM users. Provides the link to each attached file for GoldMine users instead
of sending the files to each recipient. This is a space saver for users on the same shared network.

O Enable autosave as draft. Enables GoldMine to save email messages in edit mode automatically.

O Autosave interval (in seconds). Number of seconds to wait until the next attempt to save an email
message in edit mode. This works only if the Enable autosave as draft option is selected.

GoldMine Administrator's Guide Page 41 of 439



GoldMine™®

6. Inthe Replies area, select:

O Complete original message. Places the original message in the History tab when you reply or forward a
message. If you do not want to designate the original message as a completed activity when you respond,
clear the check box.

O Use line quote style with prefix. Specifies the characters GoldMine uses to identify lines quoted from the
original message when you copy those lines into your reply. By default, GoldMine uses >>.

O Quote entire message by default. GoldMine copies the entire text of the original message in your reply,
using the characters entered in Use line quote style with prefix.

O Wrap quoted lines in replies at column x:. Specifies the number of characters GoldMine uses before
wrapping to the next line of quoted text. You can use this option to create an indented block for text
quoted from the original message.

7. Inthe Misc. area, select:

O Use 8 bit encoding. Converts 7-bit encoding into 8-bit encoding. Useful for international GoldMine users.

O Always send a Bcc to myself. Sends a blind courtesy copy (bcc) of each outgoing message to your e-mail
account.

O Use user supplied VCard. Ensures the VCard attached to your outgoing e-mail includes updates.

O Encode E-mail using character set. To encode your messages with a special character set, type the
character set in the field. For example, to use the Western European character code, type iso-8859-1. If
left blank, GoldMine uses the local default character set for encoding. GoldMine supports these character
sets: UTF-8, 1ISO-8859-1, I1SO-8859-15, and Windows-1252.

8. Inthe Default templates area, select Public or your user-defined templates in the drop-down lists:

O For new outgoing E-mail messages

O For replies

O For forwarded messages

NOTE: Templates must be created before they are available in the drop-down lists.

9. Click OK to save the settings and close the window, or click the next Internet Options tab to configure.

To Set E-mail Options on the Retrieval Tab
Specify a variety of Internet e-mail retrieval options to define attachment locations, scan intervals, and the criteria

GoldMine uses to select messages for retrieval.

1. Select Tools > Options > E-mail .
2. Click the More Options button.
3. At the E-Mail Options dialog box, select the Retrieval tab.
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4. Inthe Retrieval Options area, select:

O Open ‘Read E-mail’ dialog on retrieval. After the e-mail is retrieved, GoldMine opens and displays the first
retrieved message.

O Use date from mail header. Sets the date of incoming mail to the date sent as indicated in the header
information of the message and posts e-mail in true chronological order on your calendar.

If you do not retrieve e-mail frequently, you might want to clear the check box corresponding to this
option.

O Scan mail for UUEncoded data. GoldMine scans the Internet mail server for any e-mail messages that
contain UUEncoded attachments. Selecting this option does not affect the retrieval of MIME-encoded
files.

O Prompt if E-mail address is not on file. GoldMine displays the Attach E-mail to Contact dialog box upon
retrieving an unlinked e-mail message. Options are available for linking the message.

O Preview x lines of the message. Specifies the number of lines of text GoldMine displays in the lower pane
of the E-mail Center. By default, GoldMine displays 15 lines.

O Do not retrieve VCard attachments. If you select this option, GoldMine will not retrieve VCards with
incoming e-mail.

O Mark incoming messages as private. Limits the information available to other users about your incoming
messages and prevents unauthorized users from reading the text.

Example: On the Pending tab, received messages are marked (Private); Master users can read the
messages, but other users cannot.

5. Inthe Background E-mail Retrieval area, select:

O Retrieve mail every x minutes. GoldMine connects with your POP3 mail server to check for new mail at the
interval you specified. For example, to retrieve waiting Internet e-mail every 2 hours, type 120 in this
field. The default value of 15 sets GoldMine to scan for and retrieve waiting e-mail every 15 minutes. If
you do not select Auto-retrieve on the Accounts tab but select Retrieve mail every x minutes and Send
gueued messages, GoldMine sends queued mail only.

The following options are available only if you select Retrieve mail automatically every x minutes.
- Skip read mail (recommended). Bypasses displaying e-mail messages you already read.

- Skip mail larger than x KB. GoldMine retrieves only Internet e-mail messages that are equal to or
smaller than the kilobyte (KB) value in this field.

- Skip messages from contacts not on file. GoldMine retrieves only e-mail from those contacts who have
Internet e-mail addresses in their detail records.

- Send queued messages. GoldMine sends all queued messages when automatically retrieving mail.
6. Type or browse to the location of the Attachments directory. This is the destination folder for retrieved e-
mail attachments.
NOTE: These directories should be shared so other users can access the attachments.
7. Select Save attachments as linked documents to link files attached to incoming e-mail to the senders’
contact records.
To prevent linking attachments to your contacts, clear this option.

8. Click OK to save the settings and close the window, or click the Internet Options tab to configure.
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To Set E-mail Options on the Accounts Tab

Add and edit additional Internet accounts for sending e-mail from GoldMine. Establish a non-standard
authentication protocol for your primary account.

1.
2.
3.

Select Tools > Options >E-mail.

Click the More Options button.

At the E-Mail Options dialog box, select the Accounts tab.

The accounts are listed in the field.

To add an account, click New.

At the E-mail Account Properties dialog box, define properties for an Internet e-mail account.
A user can log in and retrieve mail for up to 256 separate accounts.

To edit an existing account, select the account and click Edit.

At the E-mail Account Properties dialog box, make changes to the Internet e-mail account.

To remove an Internet account, select the account and click Delete.
WARNING: No confirmation prompt appears to verify the deletion.

With multiple accounts, set one account as your primary account by highlighting it and clicking Set as Default.
The default account is indicated by a green ball or dot in the accounts display box.

Select Show only the default account in the E-mail Center if you have multiple accounts but only want the
default account to display in the E-mail Center.

The accounts set to display in the E-mail Center are indicated by eyeglasses to the left of the account name in
the Accounts display box.

NOTE: By default, GoldMine shows all accounts in the E-mail Center letting you check Internet accounts
from one location in GoldMine.

10. Change the order of the accounts displayed in the E-mail Center.

Click Move Up to move the highlighted account up one line. Click Move Down to move the highlighted
account down one line.

11. Click OK to save the settings and close the window, or click the next Internet Options tab to configure.

To Set E-mail Options on the Security Tab

If you have a digital ID (digital certificate) to verify your signature and receive encrypted e-mail messages,
GoldMine lets you configure your Internet Options to include the information when sending a message.

i hwnNR
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TIP: For information about Windows Certificates, see Import Windows Certificates to Decrypt E-
mails.

Select Tools > Options.

At the User's Options dialog box, select the E-Mail tab.

Click the More Options button.

At the E-Mail Options dialog box, select the Security tab.

Click Digital ID(s) to configure your IDs.

The Manage Digital IDs dialog box opens.
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6.

In the Signature Settings area, you can select one option:

O Sign ALL outgoing E-mail with a Digital ID, by default. Sends all your e-mail messages with your digital ID.
If you do not select this option, you can still encrypt individual messages by selecting Encrypt Messages
on the Edit E-mail toolbar. The message is sent with a signature but is not encoded (clear), allowing
recipients who cannot support S/MIME to read the message.

O Encode any outgoing E-mail signed with a Digital ID (Recipients required to have S/MIME to read
'opaque' messages). Sends outgoing e-mail messages signed with your digital ID as S/MIME encoded
(opaque). Older e-mail clients that do not support S/MIME cannot read the body of this type of e-mail
message.

To encrypt all outgoing messages by default, select Encrypt ALL outgoing E-mail, by default (Recipients'
Certificates are required in advance).

Selecting this option sets the encryption to digital IDs on outgoing messages. With this option selected, you
can still select Do not Encrypt on the encryption menu on the Edit E-mail toolbar.

In the Other Settings area, select:

O Import new/updated certificates for ALL incoming signed E-mails, by default. Automatically imports the
digital ID on all signed incoming messages into the contact's Record Properties > Contact Details >
Digital IDs tab.

O Save ALL incoming S/MIME e-mails as 'clear' messages. Saves all S/MIME encoded (opaque) messages and
all encrypted messages as clear, or not encoded. As clear-text messages, all GoldMine users with access
to the e-mail record can read the messages. If this option is not selected, the messages are saved as they
were received. Whenever GoldMine users want to read the e-mail message, they must enter the
password for the private key of the GoldMine recipient.

NOTE: If you do not select this setting, encrypted messages from contacts are unreadable by other users on
the History and Pending tabs. Carefully consider the consequences before clearing this option.

9.

Click another tab or click OK to save and close the dialog box.

Import Windows Certificates to Decrypt E-mails

Certificates from Windows can be imported into GoldMine using the following actions procedure.

1.

i W

6.
7.
8.

NOTE

Select Tools > Options.

At the User's Options dialog box, select the E-Mail tab.
Click the More Options button.

At the E-Mail Options dialog box, select the Security tab.
Click Digital ID(s) to configure your IDs.

The Manage Digital IDs dialog box opens.

Click the Trusted Certificate Authorities tab.

Click the Import button.

Select the Import from your Windows system certificate stores option.

: Expired certificates from Windows are not imported into GoldMine and matching certificates

between Windows and GoldMine are skipped during import.

9.

Click OK.

NOTE: Some of the certificates that are imported into GoldMine are not available as “Trusted Root
Certification Authorities” or “Intermediate Certification Authorities” in Windows.
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To Set E-mail Options on the E-mail Center Tab
Configure the E-mail Center using the E-mail Center tab of the Internet Options dialog box.

Select Tools > Options.

At the User's Options dialog box, select the E-mail tab.

Click the More Options button.

At the E-Mail Options dialog box, select the E-mail Center tab.

i W NR

In the General Settings area, select:

O Show both E-mail Address and Account Name (if available) for Online accounts. Select to list the accounts
in the E-mail Center by both the E-mail Address and the Account Name. If the Account Name is left
blank, GoldMine uses the e-mail address as the account name. If the Account Name contains an entry
and you clear this option, GoldMine lists the account by the Account Name only.

O Show Outlook Folder. Displays the Outlook folder from the local computer in the E-mail Center.

6. Inthe Trash Can Settings area, select:

O Move deleted E-mail to Trash Can. Places deleted mail in the Deleted folder in the E-mail Center.
GoldMine holds the mail until you select Empty trash can in the local menu.

O Empty Trash Can when closing the E-mail Center. Automatically deletes any messages placed in the
Deleted folder when you close the E-mail Center.

O Confirm before emptying Trash Can. Displays a warning prompt for confirmation to delete messages in the
Deleted folder.

7. Inthe Header Display Options area, select one option:

O Hide Headers. Shows no header information in the e-mail message.

O Show Summary Headers. Shows relatively high-level information only in the e-mail message such as date,
sender, subject, recipient, and so on. This option does not show detailed routing information.

O Show ALL Headers. Shows all header information in the e-mail message including routing information and
message ID.

8. Inthe Mail Folders Display Options area, select one option:

O Long date format. Spells out the date in the E-mail Center including the day.

O Short date format. Uses numeric format for month, day, year, and transmission time.

9. Inthe Auto-filed Folders' Storage Options area, select one option:

O Organize Auto-filed mail in month-year folders. Uses one level to store incoming messages by month,
year.

O Organize Auto-filed mail by year folders first, and by month sub-folders second. Uses two levels to store
incoming messages in month folders under separate folders for each year.

10. Check the Show most recent Auto-filed folders at the top option if you want to sort the folders by most
recent date.

O Click More Auto-filed Folders’ Options to change the default month-name labels assigned to folders. The
Auto-filed Folders' Month Names dialog box appears. Select Override the default month names and type
the new label names to assign to the Filed folders.

11. Click OK to return to the E-mail Center tab.

12. Click OK to save the settings and close the window, or click the next Internet Options tab to configure.
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To Set E-mail Options on the Advanced Tab

Define advanced Internet settings to apply globally to your E-mail Center, existing attachment files, message
operations, and data imported from a Web site.

Use the following procedure to set up Internet Options on the Advanced tab.

1.
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Select Tools > Options.

At the User's Options dialog box, select the E-mail tab.

Click the More Options button.

At the E-Mail Options dialog box, select the Advanced tab.

In the E-mail Center area, select from:

O Enable ‘Delete All Server Mail’. Activate the Delete all messages on the server button on the E-mail Center
toolbar to delete all messages on the Internet mail server. By default, GoldMine excludes this icon in the
E-mail Center toolbar.

O Download old messages first. Retrieve messages from the mail server in chronological order (oldest to
newest). By default, GoldMine retrieves messages in reverse chronological order (newest to oldest).

O Suppress file overwrite prompt. Do not display a warning before overwriting an existing file with an
attached file having the same name.

In the Existing attachment default action area, specify the default method for handling a file of the same

name:

NOTE: This option will not work automatically unless the Suppress file overwrite prompt option is also
selected.
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O Overwrite existing file. Replaces the existing file.

O Choose a new file name. Lets you rename the file.

O Auto name assignment. Appends a number to the file name. If GoldMine cannot append a number (up to
64), a random, unique name assigns to the new file.

O Do not save the file. Deletes the attached file.

In the Message area, select from:

O Use HTML when creating new E-mail. GoldMine recognizes HTML encoding in incoming messages, and
applies HTML formatting to outgoing messages. This option adds an HTML editing toolbar to the Create
Internet E-mail dialog box letting you add a formatting attributes, such as color, picture file insertion, and
alignment.

O Auto spell-check before sending. Checks the spelling in a message when selecting Send in the Create
Internet E-mail dialog box.

O Link e-mail address to contact record by default. When retrieving an e-mail message that is linked to a
contact record, selecting this option causes the From: address in the message to be linked to the same
contact. To link messages to contacts without linking the e-mail address, un-select this option.

O Mark attachments for synching by default. Marks e-mail attachments as linked documents to be
synchronized, except for VCards an d transfer sets.

O Delete attachments when deleting the mail. When an email is deleted any attachments are also deleted.
The setting also deletes any references in the GoldMine Links tab. Once the email is deleted, to ensure
that the attachments are also deleted, the email must be emptied from the GoldMine email trash. This is
regardless of the location from where the email was deleted—such as: email center inbox, contact
record, pending tab, or contact record history tab.
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8.

In the Weblmport area, select from:

O Import data when retrieving E-mail Center mail. Imports Webimport data when GoldMine retrieves e-mail
messages. To manually import Weblmport data, clear this option.

O Import data on background e-mail retrieval. Imports Weblmport data when GoldMine performs
background e-mail retrieval.

O Discard message after importing data. Deletes the Weblmport message from the Web site after GoldMine
retrieves the message.

In the Communication timeout field, type the number of seconds GoldMine remains idle before

disconnecting from the mail server (default is 60 seconds).

10. Click OK to save the settings and close the window.

Setting Options for the Telephony Tab

Configure special modem and dialing settings to use with GoldMine's auto-dialer feature.

NOTE: You must have a TAPI modem locally installed and working on your computer before you can
successfully configure the modem settings.

Use the following procedure to set up options on the Telephony tab.

1.
2.
3.

Select Tools > Options.

At the User's Options dialog box, select Telephony.

In the Modem Settings area, configure these settings:

O TAPI Line. Select the TAPI settings in the drop-down list that match your computer's Phone Dialer TAPI
settings.

O Dialing Properties. Displays the Phone And Modem Options dialog box.

O Line Properties. Displays the modem Connection Options dialog box.

NOTE: Consult your Windows and modem documentation for configuration details.

4.
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In the Dial Number Formatting area, configure:

O Let TAPI format phone numbers. Allows TAPI to add numbers required for dialing a phone number such as
international access and country codes.

O Dial numbers as entered. Dials the numbers as they are formatted in GoldMine.

O Local Area Code. The area code you are dialing from.

O Dial Prefix. A number sequence accessing a special line or service.

O Dial Suffix. A number sequence after the telephone number to access a special line or service.

O Hang up after: x sec. Specifies the number of seconds before GoldMine tries to reconnect.

In the SoftPhone area, enter the local extension number and set SoftPhone as the default.

Access and edit SoftPhone advanced settings by clicking the Advanced button.

Click OK to save the settings and close the dialog box.
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Setting Options for the System Tab

Click the System tab on the Options dialog box to define your GoldMine system settings.

1. Navigate to Tools > Options.

The Options dialog box opens.

Select the System tab.

In the Navigation area, select the checkbox next to the following options as needed:

O Use classic GoldMine menu. Select this option to display the default main menu rather than the current
menu configuration.

O Show status bar. Select this option to use the status bar.

O Recent item shown. In the dropdown box, select the number of recent items you want to display.

4. Inthe Theme and Font area, select the color theme you prefer for the Ul background. You can also select the
font face and size to be used. Note that you must restart GoldMine to enable these particular changes.
5. In the Classic toolbar area, click Show button text to show the Classic GoldMine toolbar buttons.

In the Activity tabs area, select Show activity code in history tabs to show the activity code in the History

tab.

7. Inthe Date and Time area, select the checkbox next to the following options as needed:

O Show time in 24 hour format. Select this option to display time in a 24-hour format on the status bar and
the time fields of windows. For example, 9:00 P.M. appears as 21:00 in the 24-hour time format.

O Set EPOCH. Select this option to determine how GoldMine interprets dates when no century is indicated,
that is, a date entry containing only the last two digits of the year. To scroll through values by five-year
increments, click the up and down arrows next to the field. For example, if you set the value to 80,
GoldMine will interpret the entry 03/10/80 as March 10, 1980 and the entry 10/01/70 as October 1,
2070.

8. Inthe Help area, select the checkbox next to Show tips at startup to display the User Tips when you launch

GoldMine. Do not select this checkbox if you do not want to see the User Tips.

NOTE: For best results, assign the same user name in both GoldMine and MS Outlook.
9. At the MS Outlook user name if not the same as the GoldMine user text box, type the Microsoft Outlook
user name if the Outlook user name is different than the GoldMine user name.
10. After making all of your selections, click OK.

Setting Options for the Speller Tab

Use the Speller tab to select settings for the spell-checking options. Use spell checking in GoldMine windows
offering text editing such as e-mail messages and the InfoCenter.

1. Select Tools > Options. The User's Preferences dialog box appears.

2. Select Speller.

3. Inthe Spelling Options area, select from the following options:
O Ignore capitalized words: Ignores proper names.
O Ignore all-caps words: Ignores acronyms and initialisms.
O Ignore words with numbers: Ignores words with numeric characters in them.
O Ignore words with mixed case: Ignores specialized words such as GoldMine.
O Ignore domain name: Ignores Web and Internet addresses.
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O Report doubled words: Notifies when the same word appears twice.
O Case sensitive: Spell checker evaluates a word beginning with a capital letter as different from the same
word that does not begin with a capital letter.
O Phonetic suggestions: Offers phonetic suggestions that sound like the targeted word.
O Typographical suggestions: Offers words with a similar letter organization to the targeted word.
O Suggest split words: Suggests two words for compound words that do not appear in the dictionary.
O Auto correct: When enabled, words marked with "Auto Change" actions are automatically changed to their
specified replacements. When disabled, you are prompted before the words are changed.
4. Inthe Suggestions area, select one of the following options:
O Fast but less accurate: Evaluates your unrecognized word based on your Spelling Options and quickly
generates a broadly based suggestion list.
O Moderately fast and accurate: Evaluates your unrecognized word based on your Spelling Options and
generates a fast and accurate suggestion list.
O Slow but accurate: Evaluates your unrecognized word based on your Spelling Options and generates a
carefully constructed suggestion list.
5. Inthe Dictionaries area, select your Main Dictionary language in the drop-down list. There are 18 dictionaries
to select from.
6. Click Setup Dictionaries to launch the Dictionaries dialog box where you create and customize . t1x dictionary
files (see Creating Dictionaries in the GoldMine User's Guide).

7. Click OK to save the settings and close the dialog box.

Setting Options for the Messaging Tab

Use the Messaging tab to enable sending SMS messaging (Short Message Service) to GoldMine Web for reminders
of upcoming scheduled activities.

IMPORTANT: Before GoldMine can send Activity reminders, sending must be enabled within the GoldMine
system (Tools > Configure > System Settings > Messaging tab). See Configuring System Settings.

Navigate to Tools > Options. The Options dialog box opens.
Click on the Messaging tab.
Check the Send activity alarms as a message to my device box.
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Specify the GoldMine user’s e-mail address used for receiving SMS messages in the E-mail address for the
mobile device text box.

NOTE: This option is also available for non-master rights users provided that message sending has already
been enabled in the Messaging tab in the System Settings (see Configuring System Settings).

TIP: For assistance in determining the e-mail address, refer to the following article for a listing of
service providers’ SMS gateways: http://en.wikipedia.org/wiki/List_of SMS gateways

5. Click OK to save the settings and close the dialog.
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Setting Options for the Login Tab

Use the Login tab to set default databases and login information. This tab is available only to users with Master
Rights.
WARNING: These settings rewrite the gm. ini file and are global. Any changes you make will
affect all users
1. Navigate to Tools > Options.
The Options dialog box opens.
Click on the Login tab.

At the GoldMine home directory: field, browse to the GoldMine directory location. for which you want to set
the default.

If you are working on a network, this should be the drive mapped to the main GoldMine directory, for
example, G:\Apps\GoldMine.

4. For GoldMine database:, select the alias for which you want to set the default from the drop-down list (for
example, GoldMine 9.0:).

5. For Default contact database:, select the alias for the database for which you want to set the default in the
drop-down list (for example, GoldMine:).

6. Click the Default login user checkbox to write the settings to the local gm.ini file.

This is fine for single-user installations but not for network installations. For network installations, each
workstation generally has a different user with their own login.

To Modify the GoldMine Login

On some operating systems, especially NT-based operating systems, the Default login user is not respected and
the GoldMine login defaults to the network login name.

1. On anetwork workstation where you log in to GoldMine with a login differing from your network login,
create a GoldMine shortcut on the desktop.
Right-click the shortcut and select Properties > Shortcut.
In the Target text box, type /u:username (where username is your GoldMine login).
An example of a full path is: \GoldMine\gmw.exe/u:username.
This populates the GoldMine login with your correct GoldMine login name.

4. The Time Clock drop-down list contains three options for monitoring the login activity of the user. The
information displays on the Time Clock tab in each User Properties dialog box. Select from the following:
Disable Time Clock. Turns off the login and time tracking.

Track daily totals. Monitors the total number of times a user logs into GoldMine and displays the cumulative
amount of time the user is logged in per day. These statistics appear in the Time Clock tab of the User
Properties dialog box.

Track each login. Monitors the amount of time a user is logged in to GoldMine for each login session. These
statistics appear in the Time Clock tab of the [Username] Properties dialog box.
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5. Click on the Bypass login banner checkbox to skip the login banner if there is no password for the user.
6. Click on the Open files exclusively checkbox to allow only the currently logged in user to open GoldMine.
NOTE: Open files exclusively is useful for GoldMine administrators working in the database who need to
keep other users out. When you are finished using the files exclusively, remove this option so other users

can log in. When selected, this option writes the line Exclusive=1 in the [GoldMine] section of the GM. ini
file and locks the Flags.bin table. Do not enable this feature if planning to use the GoldMine Backup Wizard.

7. Click OK to save the settings and close the dialog box.

Updating Undocked Users

IMPORTANT: Do not allow undocked users to synchronize with an updated GoldMine system until they have
updated to the same version the updated site is using.

To update undocked users after performing an upgrade on the main GoldMine system, locate the gmsetup.exe
file. Depending on the connection speed, and how undocked users communicate with the network and GoldMine
system, send the gmsetup.exe file to the undocked user by putting it on CD, posting it on an FTP site, e-mailing it,
or placing it on an accessible network drive.

Include directions for executing the gmsetup.exe file and what undocked users should expect after the upgrade.

After the undocked users update to the same version of GoldMine, they can synchronize with the master site. To
change the registration information, select Update Registration Information.

For additional information, see "Creating an Undocked User License" on page 430.

GoldMine .INI Files

GoldMine contains . INI files (initialization files) that define program and user parameters. Each GoldMine user
has a username.ini and username.tbi (which is the user login name followed by the file extension).

For Example: If the user’s login is JohnS, then the user’s .ini file is johns.ini.

m The username.ini stores options and is in the GoldMine directory. See Username.ini.

m The username. tbi file stores the user’s taskbar settings. See Username.tbi.
For more information about INI files, see the following topics:

O GM.ini Settings

O Username.ini

O Changing Settings in the INI File in GoldMine
O Configuring System Settings

O Changing the User INI Settings

O Setting E-mail Preview Text Amounts

O Setting Keep or Clear on Tagged Records

O Setting Calendar Publishing Output to XML
O Username.tbi
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GM.ini Settings

NOTE: For information about Reporting Service configuration, see To Configure the GM.INI File For
Reporting Services.

GM. ini file found in the main GoldMine folder contains the paths to these locations:

[GoTdMmine]
GoldDir=Goldmine:
CommonDir=GoldMine:

Select Help > About GoldMine, and then click the System button to view the file locations.

Section Command Values Description

Orders the username
display as FirstName
LastName (LoginName). If
UserNameFormat= 1 the command is not added,
the default display is
LoginName (FirstName

[GoldMine]

LastName).
. Places your custom logo on
UserLogo= <path\fil >
Ser-ogo path\filename the GoldMine login screen.
<number of Changes the delay before an

RecAlertSec=
seconds> alert appears.

Creates only a partial record
(Contactl) rather than a full

NewComplete= 0
P record (Contactl and
Contact2).
Database alias for base
GoldDir= <database alias>
! ! GoldMine database.
Datab lias for default
CommonDir= <database alias> atabase alias for detau
Contact database.
Path to the GoldMine
SysDir= <path\filename> )
system files.
. Locks all other users out of
Exclusive= 1

GoldMine.
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Section Command Values Description

Set the number of days to
wait before performing
another Automatic
Maintenance.

LastRun= <number of days>

Displays the scheduled
activity Notes as simple text
rather than HTML. To
display the Notes as HTML,
the value is 1.

Also enabled in Tools >
Configure > System Settings
on the Display tab.

HTML_Cal_Notes= 0

Sets the global timeout for

SQLQueryTimeout= <minutes> .
all database queries.

Sets the global timeout for
critical operations such as
synchronization and
database re-indexing.

LongSQLQueryTimeout <minutes>

Sets the label for an
alternate phone contact.
The default value is “Fax”,
but can be changed to
“Mobile” or any other text
label.

AddContactFaxLabel= <label name>

Renames tabs. Only an
Admin with Master rights
can record in Detailed view.
To access this option open
Contact Record in Detailed
view, use the Tab Selector
arrow-button and select
Customize. Then, highlight a
tab and click the Rename
button.

ROTabs
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Section Command Values Description
Requires passwords on
[WeblmpPassword] Passwordx= <password> Weblmport files. X is the
number of the password.
Lets fiel
wantTo Allow | e
[WeblmportOverwrite] IAgree= Fields To Be Updated | . p P . ¥
fields using the Fields=
By WebIimport )
setting.
<field
. 'eld names Specifies the fields updated
Fields= separated by
by Weblmport.
commas>

To Configure the GM.INI File For Reporting Services

After installing Microsoft SQL Server Reporting Services and configured on the network, add a section to the
gm.ini file typically located in Program Files/GoldMine/. This tells GoldMine where the Reporting Services is

hosted.

Use the following procedure to configure the ini file

1. Close GoldMine.
2. Openthegm.ini file using Notepad.

3. Type the following code:
[ReportServer]
webServiceURL=http://localhost/ReportServer/ReportService.asmx

[P GM.ini - Notepad
File Edit Format Wiew Help

[GoldMine]
Go1dDir=gm?
CommonDir=gm?
User=5vsDBA
UserLog=1
DocCtr=0DochConvertead
ssce_path=speller
UnitsConwToF loat=1
[Docctr]
DoceConvertedsl
[oprgr]
OpMgraConverteds=1
[Reportserver]
webserviceURL=http://Tocalhost /Reportserver /Reportservice. asmx

4. Click Save and close Notepad.

5. Open GoldMine.
6. Select Go To > Reports > Report Scheduling. The Scheduled Reports dialog box opens.
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Username.ini

This file controls user settings not set from interface menus. GoldMine generates some default <username>.ini

settings.

NOTE: user.ini settings can be inserted to gm.ini but only in [User-Override:GoldMine] section.

The default <username.ini> settings appear in the following table:

Section Command Options Notes
E-mail Center Preview settings can
) 0 -- Preview off be toggled on/off. Right-click an
ShowPreview= . Lo
1 -- Preview on object in the tree pane and select
[Internet] Show Preview.
Increase the amount of a e-mail
BodySizeLimitKB= Size in KB message previewed in the E-mail
pane
When creating an additional contact
) on the Contacts tab, use the primary
1 -- Auto-fill selected
[GoldMine] AutoFillAddIAddress= contact's address information to

by default

automatically populate the address
fields.

AutoFillEmailAddr=

1 -- Auto-fill selected
by default

Auto-fills new e-mail addresses with
the @<domain.name> of the
selected primary e-mail address

OnByDefault

ACDEMOQST where:
A-- appointment

C-- Call Back

D -- To-do

E -- event

M -- message

O -- other

Q -- queued email

S -- f.sale

T -- next action

Turn calendar alarms on by default
(separate setting for each activity
type).

Also enabled in Tools > Options on
the Alarms tab by clicking the Alarms
on by Default button.

FollowUp

0 -- false
1--true

Prompt to schedule a follow-up
activity when completing an activity.
Also enabled in Tools > Options on
the Schedule tab. Then, check the
Prompt to schedule a follow-up
activity when completing an activity
box.
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Section Command Options Notes

Displays tips at login, which can also
be disabled on login page. Also
enabled in Tools > Options on the
System tab. Then, check the Show
tips at startup box.

0 -- false

ShowTipOfThe Days 1 - true

Maximum number of records shown
in SQL Query results. In the Global
settings area, only an Admin with
Master rights can make edits.
MSSQLMaxBrowseRecs number of recs Also enabled in Tools > Configure >
System Settings on the Display tab.
Then, set Maximum number of
records shown in SQL Query results
value to any number.

The maximum records displayed in
Contact Search Center. Only admin
SearchTopRec number of recs with master rights can edit.

Admin Ul only needs support as
corporate override in gm.ini).

In the Global settings area, only an
Admin with Master rights can make
SQLQueryLimit number of recs edits.

Also enabled in Tools > Configure >
System Settings on the Display tab.

The maximum number of

ber of . .
numMbEr of recs Opportunity, Project, and Case

MaxRegardingListSize

default=50 :
records for E-mail Center.
Allows e-mail addresses to be
0 -- false duplicated on multiple records.
AllowDupEmails - 1 true Also enabled in Tools > Configure >

System Settings on the Advanced
tab.

Add or modify command statements to <username>.ini to customize:

m Access to macros of another user
= Title bar display
= Modem and dialing settings

= Configurations for messaging activities

GoldMine updates most of the settings in the username.ini when settings in options, toolbars, and other user
areas of GoldMine are changed. Manually add or change the settings by editing the file with a text editor.
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GoldMine organizes settings in this format:

[section]
Setting=x

The section name always appears in brackets, the setting is the specified setting, and (x) represents the value of
the designated setting. Be sure to place each new command in the correct section of <username>.1ini. However,
the order of statements within a section does not affect proper execution.

The GoldMine section options are listed in the following table.

Setting Option Description
Instructs GoldMine to automatically select the Schedule a
Followup= 1 . .
follow-up check box when completing an activity.
Syncs the current contact record object with the
SyncActiveObj= 1 ynes €0 ore obl
highlighted activity in the activity list.
Syncs the contact record object as the contact if a grou
SyncGroupObj= 1 .y L ) group
listing is changed.
PubForm= 1 Show (public) user forms in the merge forms menu
Lets you change labels on the tabs. Type new labels in
ROTabs= 1 the order the tabs display on the screen with commas
B separating the labels and no spaces. For example,
Summary,Notes,Fields.
ROTitle= 1 Displays the contact name in the record object title bar.
MacFile= 2 Uses the macros of the user specified

Changing Settings in the INI File in GoldMine

GoldMine has the ability to change some settings in the .1in1 files by configuring the System Settings and <User>
Options tabs. For more information, see Configuring System Settings and Managing User Options.

You can change the settings in the following table.
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Setting

Configure

HTML_CAL_NOTES

To View Notes as HTML:

1. In GoldMine, open the Tools menu and select Configure > System
Settings.

2. Click the Display tab.

3. Inthe Notes Format area, select HTML.

4. Open any contact, click the Pending tab, and create a new
Activity.

5. Add a Note in the Note area and verify that you can set the font
color, type, size, and alignment.

HTML_CAL_NOTES

To View Notes as Plain Text:

1. In GoldMine, open the Tools menu and select Configure > System
Settings.
Click the Display tab.

3. Inthe Notes Format area, select Plain text.

4. Open any contact, click the Pending tab, and create a new
Activity.

5. Add a Note in the Note area and verify that you are not able to
set the font color, type, size, and alignment.

MSSQLMaxBrowseRecs

To Configure the MSSQLMaxBrowseRecs Setting:
1. In GoldMine, open the Tools menu and select Configure > System
Settings.
2. Click the Display tab.
3. Set Maximum records shown in contact search center, activity
list, contact list, and contact record tabs value to any number
(10 for example).
4. Test the result by:
O Running a search in the Contact Search Center
QO Opening any Records Pending tab and schedule more than 10
activities (10 records display)
QO Opening the Activity List and view Open Activities (10 records
display)
O Opening Contact List (10 records display)
1. Torestore the default value, set the Maximum records shown in

contact search center, activity list, contact list, and contact
record tabs value to 500.

SearchTopRec
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Setting

Configure

SQLQueryLimit

To Set Maximum Number of Records Shown in SQL Query Results:

1. In GoldMine, open the Tools menu and select Configure > System
Settings.

2. Click the Display tab.

3. Set Maximum number of records shown in SQL Query results
value to desired number and then click OK.

AllowDupEmails

To Allow Duplicated E-mail Addresses:

1. In GoldMine, open the Tools menu and select Configure > System
Settings.

2. Click the Advanced tab.

3. Check Allow e-mail addresses to be duplicated on multiple
records check box and then click OK.

OnByDefault

To Turn Calendar Alarms On by Default:
1. In GoldMine, open the Tools menu and select Options.

2. Click the Alarms tab and then click the Alarms on by Default
button.

3. Check the box(es) next to the desired types of Activity for which
you want to have alarms and then click OK.

4. Click OK again to close the dialog box.
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Setting Configure

To Set Automatic Scheduling of Follow-Up Activity when
Completing an Activity:

1. In GoldMine, open the Tools menu and select Options.
2. Click the Alarms tab.

3. Check Prompt to schedule a follow-up activity when completing
an activity check-box and then click OK.

When you complete a scheduled Activity, a FollowUp activity creation

window appears.

FollowUp

To Switch On the Option of Showing Tips at Every Startup:
1. In GoldMine, open the Tools menu and select Options.
ShowTipOfThe Days 2. Click the System tab.

3. Check Show Tips at startup check-box and then click OK.
This option can be disabled on the Tip of the Day dialog box.

To Rename Tabs for One User:

1. In GoldMine, open any Contact Record.

2. Onthe tabs row, click tab selector tab (drop-down triangle) and
select Customize from the menu.

ROTabs 3. High-light the tab to be renamed and then click the Rename
button to give the tab new name.

To Rename Tabs Globally:

To rename tabs globally, follow the procedure above, but select

Customize tab labels globally.

Changing the User INI Settings

1. Open the username.1ini file:

O From Windows Explorer, double-click username.ini; the file opens in Notepad.
O From a text editor (such as Notepad), select File > Open. Navigate to the GoldMine directory and select
Username.ini.
2. To customize the file with command statements, see:
O Setting E-mail Preview Text Amounts
O Setting Keep or Clear on Tagged Records.
O Setting Calendar Publishing Output to XML.
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Setting E-mail Preview Text Amounts

By default, GoldMine displays 63 KB of message text. Increase the amount to preview very large messages.

1. Open the username.ini file.
2. Beneath the [Internet] section, add:
BodySizeLimitkB=<size in KB>

3. Select File > Save and then exit.

Setting Keep or Clear on Tagged Records

Set a standard of keeping or clearing tagged records.

1. Open the username.ini file.

2. Beneath the [GoldMine] section, add this line, using a defined number:
Clickunselectbefault=<a number (where 0 is always ask, 1 is keep tagged records without
asking, and 2 is clear tagged records without asking)>

3. Select File > Save and then exit.

4. Restart GoldMine to apply the changes.

Setting Calendar Publishing Output to XML

By default, GoldMine publishes the calendar to HTML. You can also publish to an XML file.

1. Open the username.ini file.

2. Beneath the [CalObj] section, add:
XMLOutput=1 (Publishes to XML. If XMLOutput=0 or if there is not XMLOutput setting,
the calendar publishes to HTML.)

3. Use a customized XSLT file when publishing daily, weekly, or monthly calendars. In the same section, specify
these transformation files:
O ExternalXxsLDaily=DailyFile.xs]
O ExternalXxsLweekTy=weeklyFile.xs]
O ExternalxSLMonthly=MonthlyFile.xs]1

4. Select File > Save and then exit.

NOTE: For best results, backup your .1ini file before adding or changing any settings, and change only
settings exactly as described in the online Help topics or contact Technical Support.

Username.tbi

Copy entire taskbars or just task groups from one user to another. The taskbar has one section, called [gmbar]. If
you delete the username.th1i, you must log back into GoldMine as the user to recreate the file; however, it only
has global task groups. You must copy or manually create the task groups.
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Configuring System Settings

Select Tools > Configure > System Settings.
2. Select from the following tabs:

O Auto-Upgrade (see Automatic Upgrade of Workstations)

O Display (see Contact Records and Notes Formatting)

O Advanced (see Duplicate E-mail on Records)

O Preview (see File Type Previews)

O Password Policy (see User Password Policy)

O Script for unattended installation (see Unattended Installation)
3. Click OK to close the dialog box.

Automatic Upgrade of Workstations

On the System Settings dialog box, click the Auto-Upgrade tab to setup workstations to automatically upgrade
when GoldMine upgrades.

O UNC path and filename of installer (usually gmsetup.exe). Browse to find location.

O UNC path and filename of configuration file (usually gm_si.1in1). Browse to find location.

Contact Records and Notes Formatting

On the System Settings dialog box, click the Display tab to set contact record result limits and Notes formats.

2. At the Limits area:
O Select the maximum number of records to display in the Contact Search Center, contact lists. Activity list
and contact record tab.
O Select the maximum number of MSSQL query results to display.

3. At the Notes area, select the HTML or Plain text option.

Duplicate E-mail on Records

1. On the System Settings dialog box, click the Advanced tab to allow e-mails to be duplicated on multiple
records.

At the Contact’s permissions area, click the checkbox to allow e-mails to be duplicated on multiple records.
At the Universal Search area, click the button to install or uninstall Universal Search (see Universal Search in
the GoldMine User's Guide).

4. Atthe Fiscal year end area, set the month when the fiscal year ends. For example, for a fiscal year ending on
September 30, you would set the month to 9.
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File Type Previews

1. On the System Settings dialog box, click the Preview tab to select the file types to display, such as Microsoft
Word Document (doc) or HTML (htm).

2. Click each file type you want to display. All file types are selected by default.
3. Tocreate a new file type, click New and type in the name of the file.

NOTE: If you add a new file type, the document will open in the application associated with the file type,
not within the GoldMine preview pane.

4. To delete afile type, select the type and click Delete.

User Password Policy

1. On the System Settings dialog box, click the Password Policy tab to set up password policies for users (see
User Passwords).

Enter a Minimum password length value.
Check to Block the account after 3 invalid logon attempts to prevent unauthorized access.

Enter a password repeat value.

Unattended Installation

On the System Settings dialog box, click the Script for unattended installation tab to:
2. Open the drop-down menu and select from the following installation types:

O GM Upgrade from previous versions

O New GM installation with connect to existing database

O New GM installation with new database

Select or modify any of the Property Values.

4. Click the Create button to generate the script. The generated script is located in the \Goldmine\Setup\
directory.

NOTE: For more information, see “To Create an Unattended Installation Script” in the GoldMine Installation
Guide.

Mobile Device Messaging

1. On the System Settings dialog box, click the Messaging tab to set up alarm delivery messages (SMS - Short
Message Service) to a users’ mobile device.

IMPORTANT: Before GoldMine can send Activity reminders to mobile device users, receiving must be
enabled for the GoldMine selected users (Tools > Options > Messaging tab). See the Setting Options for

the Messaging Tab.

2. Check the Enable GoldMine Messaging box.
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3. Specify the GoldMine username used to send GoldMine Alarms from the Send from drop-down list.

NOTE: The selected username must have an email account already configured in their user options or the
user will not receive reminder messages.

4. Inthe Message Template area, you can make changes to the following areas:
O Text: The text the alphanumeric characters preceding the Macro.
O Macro: The following macros can be used in the message body:
- [date] — date of an activity (CAL.ONDATE)

- [time] — time of an activity (CAL.ONTIME)

- [reference] — reference (CAL.REF)

- [company] — linked contact name (Contactl.Company)
- [contact] — linked contact name (Contactl.Contact)

- [phone] — linked contact name (Contactl1.Phonel)

5. Click the Show Example button to view a sample of the SMS message.

GoldMine Macros

m Working with Macros
m DDE Macros
= GoldMine Report Macros

Working with Macros

In GoldMine, a macro is a button or hot key shortcut representing an instruction, action, or a series of instructions,
actions, or text inputs. For example, create a macro to launch the Schedule a Call window with a code, color
reference, notes predefined, and the cursor waiting in the date field for you to finish editing the activity and save.

TIP: Record a macro using keystrokes rather than mouse-clicks. To use the GoldMine menus,
type ALT+ <Underlined letter of menu item>. Use the arrow keys or ALT+ <Underlined letter
of menu item> to navigate the menu options.

NOTE: Macro buttons are not displayed on the Standard Toolbar by default. To show the Record, Edit,
Stop, and Pause buttons, add them to the Standard Toolbar. For more information, see Customizing
Toolbars in the GoldMine User's Guide .
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To Record Macros

1.

With Macro buttons activated in the Global Toolbar, click Record.

The macro is ready to record. Also start the recording process by typing CTRL+SHIFT+HOME.
TIP: Record a macro using keystrokes rather than mouse-clicks. To use the GoldMine menus,
type ALT+<Underlined letter of menu item>. Use the arrow keys to navigate the menu options

Begin the steps to record.

When finished, click Stop on the Global Toolbar or press CTRL+SHIFT+END.

The Define Macro Button dialog box opens.

In the Status Bar Description field, type a description of the macro to serve as the button name and pop-up
text.

The Optional Hot Key is optional. Type the hot keys you are assigning to the macro; for example, to use

ALT+9 as the hot key, hold down the ALT key and the 9 key. The Optional Hot Key box displays ALT+9.
IMPORTANT: Define hot keys carefully. SHIFT and a letter runs the macro every time it is typed. For
example, using SHIFT+ G as your hot key, and then trying to type a company or contact name that
begins with G in a new Contact record, the capital letter will not work. In other areas, such as the

Contact Search Center, it runs the macro rather than searching for contacts beginning with capital G.

From the Playback drop-down list, select the playback speed for the macro.

Select Full Speed to launch or run the macro quickly, or Recorded Speed to run the macro at the speed it was
recorded.

To Add Macros to the Taskbar

After creating macros (see To Record Macros) use the following procedure to add a macro to the GoldMine

Taskbar.
1. Click the Customize button on the Taskbar.
2. Right-click in the task group area and select Add New Item.
3. At the Taskbar Group Item Selection dialog box, select GoldMine Users’ Macro from the Item Type drop-
down list.
4. Select the user who created the macro from the User drop-down list. Highlight the macro to add to the
taskbar.
5. Browse to an icon file.
The options display in the area below. Select an icon.
6. Click OK to add the item to the taskbar.

To Delete Macros

1.
2.

GoldMine Administrator's Guide

With Macro buttons activated in the Global Toolbar, click Edit. The Edit Macro Button dialog box appears.
Select the macro to delete, then click Delete. The Macro button on the Global Toolbar button is deleted.
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DDE Macros

Facilitate DDEAUTO fields by selecting a macro as the service item. A DDE service item starts with an ampersand
(&). When encountered, GoldMine searches an internal table of macro names. If a match is found, the macro
processes and the result returns, as if a DDE function or expression was used.

Most macros are sensitive to the setting of the RECORDOBIJ function’s SETRECORD subfunction. This function gains
access to contacts and supplementary information.

When the SETRECORD type is set to PRIMARY, macros return the value from the corresponding fields in the
primary information portion of the contact record.

When set to CONTACTS (additional contacts), or another supplementary record type, macros return the value
from the corresponding field in the supplementary file (CONTSUPP).

These macros can be used as DDE service items:

&Address

Returns a string containing the values of &ADDRESS1 and &ADDRESS?2, separated by a carriage return and line
feed character. If &RADDRESS1 or &ADDRESS2 do not contain data, a single line of data returns, without the
carriage return and line feed character.

Use this macro to perform rudimentary blank line suppression within linked applications that do not support
blank address line suppression internally.

Use the &ADDRESS macro to return an additional contact address using the RECORDOBJ SETRECORD
subfunction.

&Address1

Returns the first Address field from the active contact record. Typically, this value is extracted from the
Address1 field in the primary display portion of the contact record; however, when using the RECORDOBJ
SETRECORD subfunction to change the returned record type to CONTACTS, GoldMine returns the value from
the Address1 field on the additional contact record, if a value is entered. When the Address1 field on the
additional contact record is blank, the &Address1 macro returns the value in the Address1 field in the primary
display portion of the contact record. When the RECORDOBJ SETRECORD type is set to return a record type
other than CONTACTS, the &Address1 macro returns the value in Addressl field of the primary display
portion of the contact record.

&Address2

Returns the second Address field from the active Contact Record. Typically, this value is extracted from the
Address2 field in the primary display portion of the contact record; however, when using the RECORDOBJ
SETRECORD subfunction to change the returned record type to ADDITIONAL, GoldMine returns the value
from the Address2 field on the additional contact record, if an entry exists in the Address2 field on the
additional contact record. When the Address2 field on the additional contact record is blank, the &ADDRESS2
macro returns the value in the Address2 field in the primary display portion of the contact record. When the
RECORDOBJ SETRECORD type is set to return record types other than PRIMARY or ADDITIONAL, the
&Address2 macro returns the value in the Address2 field of the primary display portion of the contact record.
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&BrowseRecNo

Returns the record ID of the last selected record in a browse window.

&CalRefresh

Refreshes the graphical calendar display. Set up GoldMine to run this macro after adding calendar records
using DDE.

&City
Returns the City field from the active contact record (similar to the action of the &Address1). Use the &City
macro to return an additional contact city using the RECORDOBJ SETRECORD subfunction.

&CityStateZip
Returns a format string of text containing the City, State and Zip fields from the active contact record. This
string returns in this format:

City, State ZIP

The action of this macro string is similar to the action of the &Address1. Use the &CityStateZIP macro to
return an additional contact city, state, and ZIP Code using the RECORDOBJ SETRECORD subfunction.

&CommonDir
Returns the BDE alias where the contact sets are located.

&Contact

Returns a contact name from the active Contact Record. Typically, this value is extracted from the Contact
field in the primary display portion of the contact record; however, use the RECORDOBJ SETRECORD
subfunction to change the returned record type to additional contact or another type of supplementary
record. When the RECORDOBJ SETRECORD type is set to return record types other than PRIMARY, the
&Contact macro returns the value in Contact field in CONTSUPP for the current supplementary record.

Returns the Country field from the active Contact Record (similar to the action of the &Address1 macro). Use
the &Country macro to return an additional contact country using the RECORDOBJ SETRECORD subfunction.

&Dial1

Returns the Phonel entry from the active Contact Record. The returned phone number is formatted for
dialing. GoldMine applies the same rules used to dial the phone via TAPI. If selected, PREDIAL.INI settings are
applied to phone number selection.

&Dial2
Returns the Phone2 entry from the active Contact Record. For details, see &Diall above.

&Dial3
Returns the Phone3 entry from the active Contact Record. For details, see &Diall above.

&DialFax
the FAX entry from the active Contact Record. For details, see &Diall above.
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&EmailAddress

Returns the primary e-mail address for the selected contact.

&Fax

Returns the fax number as it is sent to an auto-dialer for automatic fax transmission.

&Filter

the activated filter expression.

&FirstName
the first name of the current contact.

&FullAddress
Returns a string containing the address for the Contact Record, composed of values of &Address1,
&Address2, &City, &State, and &ZIP.

The action of this macro string is similar to the action of the &Address1. Use the &FullAddress macro to
return an additional contact address using the RECORDOBJ SETRECORD subfunction.

&GetRoTabID

The ID of the currently selected tab. Typically, this value verifies that the correct tab is selected when a user
starts a custom application.

The following values are valid:

O Value Tab
O 0 Summary
O 1 Fields

O 2 Notes

O 3 Contacts
O 4 Details

O 5 Referral
O 6 Pending
O 7 History

O 8 Links

O 9 Members
O 10 Processes
O 11 Opps

O 12 Projects
O 13 Tickets

Example: (The following example tests the selection of the Details tab):
ch=DDEInitiate("Goldmine", "Data")If DDERequest$(Ch, "&GetRoTabID") <> "4" ThenMsgBox "You

must select a detail record first"eEnd If
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&GetRoTabPos
Returns the currently selected tab position. Since the tabs can be rearranged, this method is not always
reliable for determining the currently selected tab. For more information, see &GetRoTablID above.

&GoldDir
path information for BDE alias in which GoldMine is installed.

&LastFirstName
the name of the current contact in the format: last name, first name.

&LicUsers
the number of concurrent users allowed to log in to the installed copy of GoldMine.

&LicUsersAvailable
the number of users allowed to log in to the installed GoldMine license copy.

&NameAddress
Returns a string containing the contact name, company, and complete address of the active Contact Record.
Each address line is separated by a carriage return and line feed, and the string is formatted so it can be
inserted into a merge template. Any empty address lines on the Contact Record are suppressed. Use this
macro to perform rudimentary blank line suppression within linked applications that do not support blank
address line suppression internally.
The action of this macro string is similar to the action of the &Address macros, and the &NameAddress
macro can be used to return an additional contact address using the RECORDOBJ SETRECORD subfunction.

&NameTitleAddress
Returns a string containing the contact name, title, department, company, and complete address of the active
Contact Record. Each line is separated by a carriage return and line feed, and the string is formatted so it can
be inserted into a merge template. Any empty lines on the contact record are suppressed. Use this macro to
perform rudimentary blank line suppression within linked applications that do not support blank address line

suppression internally.

The action of this macro string is similar to the action of the &Address macros, and the & NameTitleAddress
macro can be used to return an additional contact address using the RECORDOBJ SETRECORD subfunction.

&NewRecID
Returns a unique record ID, which can be used when creating records.

&Notes
Returns the Notes from the active Contact Record. Typically, this value is extracted from the Notes field in the
primary display portion of the Contact Record; however, use the RECORDOBJ SETRECORD subfunction to
change the returned record type to additional contact or another type of supplementary record. When the
RECORDOBJ SETRECORD type is set to return record types other than PRIMARY, the &Title macro returns the
value in Notes field in CONTSUPP for the current supplementary record.
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&Phone

Returns a telephone number from the currently selected Contact Record (similar to the action of the
&Address1 macro). Use the &Phone macro to return an additional contact telephone number using the
RECORDOBJ SETRECORD subfunction.

&Profile(s)
Includes two related macros:

O &Profile. Returns the first matching detail record for the selected contact.
O &Profiles. Returns detail records for the selected contact.

These macros take optional parameters. Each parameter must be separated by a period (.). Although
GoldMine does not typically pass parameters with a DDE macro, the structure of &Profiles must be different
for DDE fields in Microsoft Word document templates, which do not take DDE commands.

These examples show the syntax for the &Profile(s) macros:

&Profile Example 1
&Profile.ProfileName.Reference.Flags
Retrieves the first profile that matches the ProfilleName and Reference.
&Profiles Example 1
&Profiles.ProfileName.Reference.Flags
Retrieves all profiles matching the ProfileName and Reference.

In both of these examples, the Reference parameter is optional. If passed, it acts as a begin with condition
on the profile reference. If the Reference parameter is not passed, all ProfileName profiles are evaluated.

Flag Parameters
The Flags parameter is also optional; it has these values:
- 2 returns the extended profile fields

- 4 returns the ProfileName and Reference

The &Profile(s) macro can easily fill in a Word table with the selected contact’s profile information
because tabs separate each field value, and a CR/LF separates each profile record.

&Profile Example 2
This example returns the first e-mail address of the contact:
O &Profile.E-mail Address
O &Profiles Example 2
This example returns computer profiles beginning with the word notebook:

O &Profiles.Computer.Notebook
O &Profile Example 3
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These examples use the Flag parameter to specify the profile fields to return:

O &Profiles.Computer.NotebookNotebook Toshiba P105-S6167 | Notebook HP Pavilion dv9260us| Notebook
Lenovo ThinkPad T60 |

O &Profiles.Computer.Notebook.2Computer | Notebook Toshiba P105-56167 | Computer|Notebook HP
Pavilion dv9260us | Computer | Notebook Lenovo ThinkPad T60|

O &Profiles.Computer.Notebook.4Computer | Notebook Toshiba P105-
S6167|Toshiba|1.60GHz | Computer|Notebook HP Pavilion dv9260us|HP|2.0GHz | Computer | Notebook
Lenovo ThinkPad T60|Lenovo|166GHz|

&RoTabPage
Returns the selected tab. Typically, this value verifies that the correct tab is selected when a user starts a
custom application. Values between 1-9 represent tabs in the first row of tabs; for example, 1 represents the
Summary tab. Values between 10—-18 represent tabs in the second row, and 19-27 represent tabs in the third
row.
This example tests the selection of the fifth (Details) tab:

ch=DDElInitiate("GoldMine", "Data")If DDERequest$(Ch, "&RoTabPage") <> "5" ThenMsgBox "You must select
a profile record first"End If

&SerialNo
Returns the serial number of the installed GoldMine program.

&ShutDown
Logs out the currently logged user, and quits GoldMine.

&State

Returns the State field from the active Contact Record (similar to the action of the &ADDRESS1). Use the
&State macro to return an additional contact state using the RECORDOBJ SETRECORD subfunction.

&SysDir
Returns the GoldMine system directory.

&Sysinfo
Displays system information as returned by Help > About GoldMine > System information.

&Title
Returns the Title from the active Contact Record. Normally, this value is extracted from the Title field in the
primary display portion of the contact record; however, use the RECORDOBJ SETRECORD subfunction to
change the returned record type to additional contact or another type of supplementary record. When the
RECORDOBIJ SETRECORD type is set to return record types other than PRIMARY, the &Title macro returns the
value in the Title field in CONTSUPP for the current supplementary record.
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&User_Var
Returns the defined field value from all users, a specified user, or the currently logged user.

The &User_Var macro allows GoldMine users to store specific data that can be retrieved later into
applications that are linked via DDE with GoldMine. This macro can be defined in the [user_var] section of

both the GM.INI and the username. INI of GoldMine.
Usage Syntax: &User_Var.<variable name>.<GoldMine username>
Example: &User_Var.Territory.Dan

where<variable name>is a descriptive name of the macro and <GoldMine username> assigns a defined value
to a specific GoldMine user. <GoldMine username> is optional, as GoldMine will assign these values to the
current GoldMine user.

&UserFullName
Returns the full name of the logged in GoldMine user as it appears in the FullName field in the Users Master
File.

&UserName

Returns the name of the logged in GoldMine user.

&Version

the version number of the installed GoldMine program.

&WebSite

Returns http://<web site> for the active contact.

&ZIP

Returns the ZIP field from the active Contact Record (similar to the action of the &Address1). Use the &ZIP
macro to return an additional contact ZIP Code using the RECORDOBJ SETRECORD subfunction.

GoldMine Report Macros

The following is a compiled listing of information pertaining to the macros used within GoldMine reports along
with a short description.

Some macros are only available within the “Calendar Printouts” reports category. The remaining macros are
available in all of the report categories. They have been separated within this document for organizational
purposes.

m All Report Categories

m Calendar Printouts Section Only
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All Report Categories

&FullAddress

Displays Address1, Address2, City, State, Zip, and Country. A line feed separates address lines. City, State, Zip
values are displayed on one line.

&Company&Address

Displays Contact Name, Company Name, Address1, Address2, City, State, Zip, and Country. A line feed
separates all fields except for City, State, and Zip, which are displayed on one line.

&Address1&2
Displays Address1 and Address2 data separated by a line feed.

&Contact, Company

Displays Contact Name and Company Name separated by a semi-colon.

&Name&Address

Displays Contact Name, Title, Department, Company Name, Address1, Address2, City, State, Zip and Country.
A line feed separates all fields except for City, State, and Zip, which are displayed on one line.

&Company

Contact Company Name, Contact Name separated by a semi-colon.

&Title&Address

Contact Name, Title, Department, Company Name, Address1, Address2, City, State, Zip, and Country. All fields
separated by a line feed, except for City, State, Zip, which appear on the same line.

&CityStateZip

City, State, Zip displayed on the same line. City and state values are separated by comma.

&SourceFile

Returns the name of the database file being accessed in the current Section.

&CalActvName

Outputs the name of the scheduled activity being printed, based on the RECTYPE. For example, if a record of
RECTYPE S is printed, the macro will return a value of “Sale”.

&HistActvName

Works in the same manner as &CalActvName, except that it returns names based on history records, not
calendar data.

&User

Outputs the user name of the currently logged in user.
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&FullName

Returns the full name of the currently logged in user, as defined in File > Configure GoldMine > Users File.

&Licensee

Outputs the “Licensed To:” company name as defined when the GoldMine serial number was specified.

&Sort1
Outputs the data from the field set as the primary sort for the report. Can also be used to specify a break field
within a sort header. For example, if the primary sort of a report is set to contactl->company and | insert the
value of &Sort1 for the break field in the sort header, the report will then break on contactl->company.
&Sort2
Outputs the data from the field set as the secondary sort for the report. Can also be used to specify a break
field in the same manner as the &Sort1 value.
&Sort3
Outputs the data from the field set as the tertiary sort for the report. Can also be used to specify a break field
in the same manner as the &Sort1 value.
&Phones
Outputs all three of the phone numbers, the fax number, and the extension fields.
&LocallLabel

Returns the local label of the field specified after the colon.

&Suppfile="xxx" Used to specify break fields and filters within sections of reports. The “xxx” value must be at
least two characters, but no greater than three. It is used to specify the database and record types you want
to include in a report section. The first two characters specify the database and the third specifies the
RECTYPE within that database. Possible values for the different databases are as follows: cs = CONTSUPP.DBF,
ca = CALENDAR.DBF, ch = CONTHIST.DBF. The different RECTYPEs that can be specified as the third character
are listed in the “Database Structures” section of your manual.

NOTE: The ADDRESSS3 field data found in the GoldMine CONTACT1 table is included in those macros that
return address information.

Calendar Printouts Section Only

&Detail1

Displays the information that has been specified in the “Options” window for the report.
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&Year
Returns the value of the current year in four-digit format, such as 2009. The macro will also return the value
of the year for all dates within the specified date range under the report’s options. For example, if the date
range is set as 01/01/07 to 01/31/09, the macro will return all values that fall within the date range (i.e. 2007,
2008, and 2009).
&Month Returns the numeric equivalent of the current month. For example, January = 1, February = 2, etc.
The macro also returns the value of the month for all dates within the specified date range in the report’s
options. For example, if the date range is set as 10/01/08 to 01/31/09, the macro will return all values that
fall within the date range (i.e. 10, 11, 12 and 1).

&CMonth
Returns the name of the current month (For Example, January, February, etc.). The macro will also return the
value of the month for all dates within the specified date range under the report’s options. For example, if the
date range is set as 10/01/08 to 01/31/09, the macro will return all values that fall within the date range (i.e.
October, November, December and January).

&CMonthYr
Returns the name of the current month, plus the 4-digit year (For example: January 1998). The macro will also
return the value of the month and year for all dates within the specified date range in the report’s options.
For example, if the date range is set as 11/01/07 to 01/31/09, the macro will return all values that fall within
the date range (i.e. November 2007, December 2008, and January 2009).

&Day
Returns the numeric value of the current day (For example, 12, 100, 300, etc.). The macro will also return the
value of the day for all dates within the specified date range under the report’s options. For example, if the
date range is set as 01/29/09 to 01/31/09, the macro will return all values that fall within the date range (i.e.
29, 30, and 31).

&Dow
Returns the numeric value of the day of the week. For example, a date which falls on Wednesday would
return a value of 4, etc. Sunday is considered as being the 1st day of the week. This macro will also return all
values within a date range.

&CDow
much in the same manner as the &Dow macro, except that instead of returning a numeric value, it returns
the actual name of the day. For example, if a date falls on a Sunday, the macro will return the value “Sunday”
and so forth.

&DayNo
Returns the day number based on the year. For Example: January 2, 2009 = Day 2.

&WeekNo

Returns the week number of the year, similar to &DayNo. Jan 5-11 = Week 2.
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&WDay1
Returns the numeric day value of the Monday for the workweek in which the date falls. Assume that we are
looking at records that fall on Wednesday January 28, 2009, the value returned by the macro would be 26.
Since the 28th is a Wednesday, Monday is the 26th for the week of January 28, 2009.

&WDay3
Functions in the same manner as the macro &Wday1, except that it returns the numeric day value of the
third work day of the week, or Wednesday.

&WDay4
Functions in the same manner as the macro &Wday1, except that it returns the numeric day value of the
fourth work day of the week, or Thursday.

&WDay7
Functions in the same manner as the macro & Wday1, except that it returns the numeric value of the seventh
work day of the week, or Sunday.

&Hour
Displays the time in hourly increments from 7:00 AM to 7:00 PM, generated in 12-hour format.

&Time

Returns the scheduled time for calendar records, in 12-hour format.

&FrDate

Displays the From: date entry from the report’s options.

&ToDate

Displays the To: date entry from the report’s options.

&LastMonth

Generates a graphical representation of the prior month, based on the date of the calendar records on the
current report page. For example, if my report is displaying items for the month of January, the macro will
print the graphical month of December.

&ThisMonth

Generates a graphical representation of the current month, based on the date of the calendar records on the
current report page. For example, if my report is displaying items for the month of January, the macro will
print the graphical month of January.”

&NextMonth

Generates a graphical representation of the next month, based on the date of the calendar records on the
current report page. For example, if my report is displaying items for the month of January, the macro will
print the graphical month of “February.”
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Contact Management Administration

GoldMine uses the contact record (contact) as the core component to which all information is tied. When a

contact is added to GoldMine's database, a contact record is created. It contains information such as name,

address, and telephone information for a person or company. The record's many fields record pertinent and
updated information, always making the newest contact information available to GoldMine users.

NOTE: The default view for Contact Records is the Contact List view. Double-click on a contact to open that
Contact Record.
The Contact Record has two basic sections:
m Upper section contains standard contact information such as name, address and telephone numbers, and five
user-definable fields. This is the primary contact information which displays the company's name and primary
contact.

= Lower part organizes secondary information, such as Relationships, notes, pending activities, and history
records, into Contact tabs storing information linked to the Contact Record.

Each record also has a set of associated customizable properties:

O Record-related Settings. Phone number format, record ownership, and alerts.
O Contact Details. Occasions, free/busy, and digital IDs.

This section covers Administrator topics. For information on User procedures, refer to Contact Management in the
GoldMine User's Guide.

About Record-Related Settings

You can define or view record-related settings for the active contact record. To access the Record-related Settings
dialog box, select Edit > Record Properties > Record-related Settings and select a tab:

= Phone Formatting. Select the USA Format, which applies the standard telephone number format for the United
States and Canada, or the Non-USA Format, which does not apply formatting. See Setting Phone Formatting
in the Record-Related Settings.

= Ownership. Control what information can be viewed and updated by other users. SeeSetting Ownership in the
Record-Related Settings

m Alerts. Assign a code to an active contact record to alert other GoldMine users of a special status or situation
regarding the contact. See Setting Alerts in the Record-Related Settings.
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Setting Phone Formatting in the Record-Related
Settings

GoldMine formats telephone numbers in standard US format if your Windows language setting is English. The
standard US format is (999)999-9999. You can type the numbers in without formatting, and GoldMine translates it
in the formatted style.

Change the telephone number format for an active contact record from the Phone Formatting tab of the Record-
related Settings dialog box.

For other language settings, GoldMine formats telephone numbers in the international telephone number format.
The international telephone number format leaves the telephone number as entered.

Each contact record maintains its own telephone format setting. To specify the international telephone number
format when adding a new contact record, change the setting of the International Format field in the Add a New
Record dialog box.

To Set Up Phone Formatting

1. At the contact detail view, select Edit > Record Properties > Record-related Settings.

Record-related Settings m

Phone Fomatting | Ownesship | Alerts

@ Select the phone formatting of the cusrrent contact record.

Phone Format

() USA Format

() MorrlJSA Format

ok || Cance |
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2. Select the Phone Formatting tab and select one of the following:

USA Format. Formats the telephone number on the contact record to the United States and Canadian
standard: (999) 999-9999. No matter how the numbers are entered they will be formatted in this style.

Non-USA Format. Does not apply formatting to the telephone numbers.

Use a consistent format for international phone number entries. When checking for duplicate records,
GoldMine considers entries for the same number but with differing formatting as separate entries. For
example, GoldMine considers 55 12 345-6789 to differ from 5512 345-6789.

3. Click OK.

The phone format you selected applies to the active contact record.

Setting Ownership in the Record-Related Settings

Record curtaining is controlled by the record Owner. Each contact record can be public or private. Private records
are records that have been assigned an owner, either an individual GoldMine user, or a user group. Applying
record curtaining hides data on contact records from users who are not owners of the record. With record
curtaining, if a user tries to display a contact record that he or she does not own, the contact screen is partially or
completely curtained, hiding the data from view.

1. Select Edit > Record Properties > Record-related Settings.

Record-related Settings @

Phane Farmatling | Dwnesship | Alerts

To restict access for the cunent contact record, select
from the following ownerzhip and curtaining options:;

Owned by: |

Fecord Curtaining
@) Mone
O Semi-partial [hide tabs])
) Paitial

() Complete

o0k || Cancel |

Select the Ownership tab.
At the Owned by drop-down list, select the owning user or user group.

When new records are added to the database, the default owner is (public) unless the user has specific
Ownership settings configured in the User Properties dialog box.
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4. Inthe Record Curtaining area, select an option:
O None. All users can view the entire contact record.
O Semi-partial (hide tabs). All users can view the contact information in the Primary Fields View, but only the
owning user or user group can view the information in the Tabs. The tabs are curtained, marked private,

and cannot be viewed.
Setting this option will not allow users logged in through GoldMine Web (other than the owning user or
group) to edit the record or schedule activities for the contact.

O Partial. All users can view the top four rows of the Primary Fields View. The other rows in the Primary Fields
View and the tabs are curtained, marked private. The owning user or user group can view all information
in the Contact record.

Setting this option will not allow users logged in through GoldMine Web (other than the owning user or
group) to edit the record or schedule activities for the contact.

O Complete. The entire record is curtained, which means that users who do not own the record cannot see it
or locate it using the Contact Search Center. The owning user or user group can view all information in
the Contact record.

NOTE: In all cases, Users with Master Rights are able to view information in the contact records, without
regard to the owner or what level of curtaining has been set. If logged in through GoldMine Web, change
the User Role to Master to view and edit the record.

5. When you are finished, select OK. The settings you configured are now applied to the active contact record.
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Setting Alerts in the Record-Related Settings

Assign an alert to an active contact record to notify other GoldMine users of a special status or situation regarding

the contact.

To Set Up an Alert

1. Select Edit > Record Properties > Record-related Settings.

Record-related Settings

| Phone Fomatiing | Dwnership | Alerts

X]

To zet up a waming regarding the cument contack
record, select from the following Alerts;

(1]

][ Cancel ]

Select the Alerts tab.

Click on the Enable alerts check box. After selecting this option you can activate one or more of the alerts in

the panel.

By default, GoldMine displays the alert seven seconds after you display the record. However, change the

delay period by changing the GM.ini file setting for RecAlertSec.
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4. Click New Alert to add a new alert.

Hew Contact Alert @

Pleaze enter the 3 character alert code, the alert dezcription and an
optional mezzage. The new alert can be found in the Knowledge
Base under the "System | Contact Alerts’ section for futher editing

Code: Alert Dezcription

Meszage

(1] 4 l [ Cancel

5. Onthe New Contact Alert dialog box, define these options for the three-character alert code you are
creating:
O Code. Type the three-character code representing the alert status.
O Alert Description. Type a brief description of the alert.

NOTE: You must enter an Alert Description to save the alert.

O Message. Type the extended message to appear when users activate the Contact record.
Click OK to return to the Alerts tab.
Select one or more alerts to activate when accessing the contact record.

Select Log this alert in history when user is alerted to log the date, time viewing user, alert code and the
assigning user in the History tab. GoldMine adds the history record when the alert appears, not when the
view user closes the alert.

9. When finished, click OK.
The alerts are assigned to the active Contact record.
View available alert codes in the InfoCenter. In the InfoCenter, select System > Contact Alerts.

Changing the Delay Time on Alerts
By default, GoldMine displays an alert 7 seconds after the user displays a contact record to which an alert has
been assigned.

To change the time delay before the alert appears, place the following setting in the [GoldMine] section of the
GM.ini file.

RecAlertSec= <number of seconds before alert appears>
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Setting Digital IDs in Contact Details

If a contact uses a digital ID when sending you e-mail, configure the contact's record with the ID information.

To Set Digital IDs
1. With the contact record active in GoldMine, select Edit > Record Properties > Contact Details.
2. At the Contact Details dialog box select the Digital IDs tab.
3. Click Import to add a contact's digital ID file to the GoldMine contact record.
4. At the Import Digital ID dialog box, at the Filename field type or browse to the *.p7b or *.cer certificate file
you are importing.
In the Name field, type the name to display.
Click OK to return to the Digital IDs tab.
To export the file to another location, click Export and select a location.
To review the certificate details, click View.
To remove a digital ID, highlight the ID and click Delete.
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Contact Communication Administration

You can use GoldMine to print and fax correspondence, send e-mail, send pages, and distribute literature.
GoldMine integrates the functionality of your word processor and e-mail software to communicate with contacts
and coworkers.
= E-mail. Send, retrieve, and manage Internet e-mail. Individuals within an organization can use GoldMine e-mail,
providing the same features as Internet e-mail, but not requiring an online connection.

= Printing and Faxing Correspondence. GoldMine works with Microsoft Word to merge contact information from
GoldMine into templates, generating personalized correspondence. GoldMine’s Document Management
Center provides a central location to access and manage correspondence.

= Distributing Literature. Organizations can manage requests for printed material, such as brochures and price
lists, using GoldMine’s Literature Fulfillment Center.

= Paging. Send a pager message by dialing or sending e-mail.

This section describes Administrator procedures. For User procedures see Contact Communication in the
GoldMine User's Guide PDF or in Online Help.

Setting Default File Name and Folder Location for
Templates

Use the following procedure to set default document file names and folders for document templates.

1. Using a text editor (such as Windows Notepad), open USER.ini (your <username>.ini).

2. Find the statement under the [Internet] section that begins with AttachDir:
AttachDir=C:\Program Files\GoldMine\MailBox\Attach\

3. Replace this with the following:
AttachDir=C:\Program Files\GoldMine\Templates\
ForceFilename=1
In this example, C:\Program Files\GoldMine\ should be replaced with the path to your main GoldMine
folder. When ForceFilename is set to 1, GoldMine forces each file that a user saves to follow a format that
includes the user's destination folder\filename_date in the YYYYMMDDformat_incremental three-digit
number (to prevent duplicate file names).
This example shows a force file setup forJohn:
C:\Program Files\Goldmine\Templates\John\BlankLetter_20101115_001.doc

4. Select File > Save to save the changes to the USER.ini and exit the text editor.
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Setting E-mail Account Properties

Define properties for individual Internet e-mail accounts when selecting New or Edit from the Accounts tab of the
Users Options dialog box. The E-mail Account Properties dialog box opens.

1. Onthe User’s Options dialog box, click the E-Mail tab.

2. Click the Accounts button, highlight the account you are changing and then click Edit; or click New to create a
new account. The E-mail Account Properties dialog box opens.

3. Inthe Account Name field, type a descriptive name for the account to appear on the E-mail Center >
Accounts tab.

4. Select Show the account in the E-mail Center to display the account in the E-mail Center. For the account to
not appear in the E-mail Center, clear the option.

5. In the Getting Mail area, complete the fields.

For the POP3 or IMAP protocols:

O Server. The name of the mail server retrieving your mail. For example, the structure of the entry might look
like mail.somewhere.com. Typically, the same server is used for outgoing protocol SMTP and retrieval
protocols POP3 or IMAP. If you do not know the correct entry for this field, contact your Internet service
provider.

O Username. The name you use to log into your Internet mail server. Type only your user account name, not
your entire e-mail address.

O Password. The password you use to log into your Internet mail server. When you type the password into
the field, each character appears as asterisks (*).

For the OAUTH2 protocol:

O Server. Select the OAUTH2 protocol radio button.

O Provider. Select your provider type from the drop-down menu. The server name will auto-fill based on the
provider you select.

O Connect button. Click to connect to your email server. You'll be asked for your e-mail address and e-mail
account password to sign in with either Google or Microsoft Office. You'll then be asked to grant
GoldMine PE permission to access your email with a secure connection. Once access is complete, and
you're finished entering all e-mail options, your e-mail account will display by default in the Online folder
of GoldMine PE's left navigation pane.

For all protocols:

O Auto-retrieve. Select Auto-retrieve for GoldMine to automatically connect with your mail server for the
selected account and check for new mail. The interval for checking the account is defined globally in the
Retrieval tab. GoldMine checks for new mail in all accounts with this option.

O Auto-delete. Select Auto-delete to remove messages from the Internet mail server after they have been
retrieved.
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O Use encrypted connection (SSL). Select this checkbox to use a secure connection. This ensures the privacy
of the connection between your account and the server. Implementing SSL does not verify the identity of
your account or the e-mail server, but does prevent third parties from listening or recording messages
sent between them.

NOTE: Selecting Use encrypted connection (SSL) changes port numbers on the server side. Servers usually
have dedicated ports for secure connections.

O Port. Type any non-standard port address to the mail server for the selected account. This option allows
greater flexibility in setting up a nonstandard server. The default POP3 Port value is 110. The default
IMAP and OAUTH2 Port value is 143. Typically, this entry should not be changed. However, if your
account uses a non-standard server configuration requiring a different port entry, contact your network
administrator or Internet service provider.

6. Inthe Authentication area, configure the way your mail server recognizes and authenticates your account
and password. The selections are:

O Login

O NTLM

O CRAM-MD5

O Plain

O None

7. Inthe Sending Mail area, configure:

O SMTP server. Type the name of the mail server sending your mail. For example: mail.somewhere.com.
Typically, the same server is used for both SMTP and POP3 or IMAP. If you do not know the correct entry
for this field, contact your Internet service provider or network administrator. If you're using OAUTH2,
the SMTP server auto-filled when you selected a provider.

O Your return address. Type your Internet address. This is typically a combination of your Internet user name
and server name. For example, johndoe@somewhere.com.

8. Inthe Authentication area, configure the way your SMTP server recognizes and authenticates your account
and password.
9. Click the Advanced Options button to set special options for the POP and SMTP server.

10. Select OK to return to the Accounts tab of the Internet Preferences window.

Configuring Your Computer to Access Your ISP

If your computer is connected to a LAN or other high-speed internet connection, you need only set account
properties in GoldMine to access e-mail and other Internet-based features.

Use the following procedure to create a new network connection in Microsoft Windows.

1. From the desktop, select Start > Programs > Accessories > Communications > Network Connections.
The Network Connections dialog box opens.
At the Network Tasks menu, click Create a new connection.
At the New Connection Wizard welcome screen, follow the on screen instructions to create a new high-speed
or dial-up connection.

For more information about configuring Windows networking functions, see Microsoft Windows Help.

NOTE: Default modem and dialing properties in Windows are set up in the Phone and Modem Options
Control Panel. However, select special modem and dialing settings for use only with GoldMine in the
Options dialog box under the Telephony tab.
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Configuring Internet E-mail Retrieval

To retrieve Internet e-mail within GoldMine using a dial-up Internet Service Provider (ISP), you must use a ISP with
true Internet mail access. Internet access provided by most commercial online services, such as CompuServe and
Microsoft Network, will not work with the GoldMine Internet e-mail feature. You must configure Windows for dial-
up networking to connect to your ISP.

NOTE: For assistance with setting up Windows to communicate with your Internet service provider, contact
your service provider.

You can retrieve e-mail two ways: Manually or Automatically.

To Configure Manual E-mail Retrieval

The default configuration in Windows requires manual dialing.

1.

vk wWwN

From the Microsoft Windows status bar, click Start.

Select Programs > Accessories > Dial-up Networking.

In the Dial-Up Networking window, double-click the icon for your service provider.

In the Connect To window, ensure all settings are correct, then select Connect.

After your computer connects successfully, start or switch to GoldMine, then retrieve Internet e-mail.

To Configure Automatic E-mail Retrieval

Your Internet Preferences must be configured properly in the User's Preferences. Using the Microsoft Internet
Explorer, you can configure Windows to automatically dial your ISP when you retrieve Internet e-mail. The default
configuration in Windows requires manual dialing.

1.

From the Microsoft Windows status bar, click Start and then select Programs > Accessories > Dial-up
Networking.

In the Dial-Up Networking window, double-click the icon for your service provider.

In the Connect To window, ensure all settings are correct, then select Connect.

After your computer connects successfully, start or switch to GoldMine, then retrieve Internet e-mail.

Configuring Internet E-mail

Use the following procedure to configure Internet e-mail.

1.

Configure e-mail settings by selecting Tools > Options.
The User's Options dialog opens. Select the E-mail tab.

After e-mail options have been set, select Go To > Mail. to open the Email Center and to retrieve internet or
Outlook e-mail messages manually or automatically in the E-mail Center.

In the view window of the Navigation Pane, click an account in your Online folder to check internet e-mail, or
open the Outlook folder to manage Outlook messages.

TIP: For more information, see Configuring the Sending and Retrieving of E-mail
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Creating E-mail Rules

Create rules set to specify conditions and actions for handling e-mail. For example, use e-mail rules to filter
incoming messages, minimizing the amount of unwanted e-mail.

1. Inthe E-mail Center, right-click and select Options > Set up E-mail rules or click Set up E-mail Rules from the
toolbar.

Sync Conkack
v Shiow Presdew

Edit E-mail preferences
Cusktomize E-mail kernplates

G

Srnup Set up E-rnail rules
!_lmmaw Sek up Distribution Lisks

Filker
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The E-mail Rules Center welcome page appears. Click

M [-mail Rules

Y E-mail Rules

Welcome to GoldMine's E-mail Rules!

You can create an unlimited number of E-mail rules for your personal use, or for
system-wide use.

NOTE: Only users with Master-Rights administrative access can create Global E-mail
Rules.

Whether you need to handle large numbers of incoming or outgoing messages,
GoldMine’s E-mail Rules can help you more effectively handle your E-mail
communication.

If you need to re-distnbute incoming E-mail to various internal GoldMine users or
contacts in the database, move them to specific Inboxes, or automatically quarantine
them or delete them to block 'SPAM messages, GoldMine's E-mail Rules make it
simple stay on top of your mail.

E-mail rules can also help you with outgoing messages, allowing you to quickly and
easily send ‘Carbon Copies’ for selected E-mail, to either yourself, a manager or other
contact as needed, or to automatically encrypt or mark selected content as ‘private’.

You can create an unlimited number of Rule Sets, each with their own indnvidual rules,
Each rule can be based on a variety of conditions, including the information in the
From/To, Subject or Message Body of an E-mail, and can support different actions such
as replying, forwarding, moving attachments, filing, etc

To learn more about how GoldMing's E-mail Rules can help you, click here.

To begin working with E-mail Rules, please click OK to continue.

™ Don't show me this message again More Info. OK_
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2.

Right-click the left pane and select New Rule Set., to open the E-mail Rules Wizard.

E-mail Rules Wizard: Welcome

E-mail Rules Wizard : Welcome!

Thiz vazard will help pou process and organize incoming E -mail by
walking vou through the procedue to create management miles.
For example, an E-maid e set can be created to automatically
mark all meszages from a particular sender as pivate, of to
automatically file all mezzages that contain a paticular word in a
cuztom folder in your E-maill Center that tracks a specific project.
Goldiine alloves you bo achivate or deactivate any number of

1ule etz at atime. So, if necessary, you may activate an E-mail
e set tempaoranly to send an automatic responze whenever
pou're away from the office.

To begin, pleaze enter a unique name for this E-mail Rule:
Hule

Select what type of E-mail should this e handle:
(®) Incoming E-mail ) Dutgoing ) Incoming and Oulgaing

| New> | | Fiish || Cancel

3. Type a name in the text box.

4. To apply the rules to different types of messages, select from Incoming E-mail, Outgoing E-mail or Incoming

and Outgoing, and then click Next.

E-mail Rules Wizard: Conditions

Edit "Rule" Conditions

Each mule is made up of one or more condiions and actions.
!ﬁioh:ih!ha uses the condition(s) defined balow to determine if an

incoming message should be processed by the mile's actionis).
To begin, select New to add & condition to this E-mail Rule Set:

(%) ALL of the following conditions must be tue
() ANY OME of the following conditions may be tue

Field Condition Walue

[ <Back || MNew> | [ Fiish | [ Cancel
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5. At the E-mail Rules Wizard: Condition page, select one of the following and click Next:
O Select ALL of the following conditions must be true.
O ANY ONE of the following conditions be true.
To delete a selected rule condition, click Delete.

6. To define or change a condition, click New or Edit. The E-mail Rule: Condition dialog box appears.

E-mail Rule: Condition @

Please zelect a hield rom the 'Mail Field,' then choose an operstor from the
Logical condition' field and finally type a "Value' to determine the specific
mezsages that will be checked by the rule.

I ail Field: =4 "
Logical condition: | % Contains -
Value: Erter Candition Value here

From Containg Enter Condition Walue here

| ok || conce |

About E-mail Rule: Conditions

You can define one or more conditions for GoldMine to evaluate when retrieving online messages. These
conditions specify attributes for GoldMine to check. If a message meets the conditions, GoldMine can then apply
the actions defined using the E-mail Rules Wizard.

O Mail Field: Select the e-mail field for GoldMine to search for a specified value, such as From, To, CC, and so
on.

O Logical Condition: Select a condition such as Begins with, Contains, Equal to, Not Equal to and so on.
Value: Type the value for GoldMine to search when evaluating the field selected in Mail Field. The Value
depends on what Mail Field field and Logical Condition are used. For example, if the Mail Field field is set
to From and Logical Condition is set to Contains, then in the Value field you can set any part of the E-mail
address of the sender.

7. Click OK to enter the condition.
O To add another condition, click New.
O To change a selected condition, click Edit.
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8. After adding all conditions, click Next. The E-mail Rules Wizard: Actions dialog box appears.

E-mail Rules: Actions

Edit "Rule" Actions

Each mle is made up of one or more condibons and actions.
GoldMine uses the action(s] that you define below to detemine
hvow b process an incoming meszage, which matches the
previously defined conditionfz) of the nule,

To continue, select New to add an action to this E-mail Rule Set

Action Walue

Mew

e | [_Finsh ] [_Concel
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About E-mail Rule: Actions

The actions you set in the E-mail rules determine what happens to the e-mail after conditions are met. The E-mail
Rules: Actions dialog box appears after you configure e-mail rule conditions.

a. Tocreate a new rule, click New.

E-mail Rule: Action EJ

Please select the desired ‘Action on Mail' to specify how GoldMine should
pIOCESE tm_rqessages:. Then, if applicahla, select a value, template,
or other additional action a5 appropriate.

Action on Mail | & w

File

2K, l [ Cancel

- Action on Mail: In the drop-down list, select the operation GoldMine will perform upon detecting a
message with the specified conditions such as Move to inbox or Delete Attachments.

- Value: Provides additional information necessary for GoldMine to complete the operation. For example,
if you selected Move to inbox as the Action on Mail, select the subfolder of your inbox where
GoldMine will place the messages that meet the condition(s).

b. To create a new rule, click New.
NOTE: The Value field only appears when a value is needed to complete the action. For example, if you

selected Delete Attachments as the Action on Mail, GoldMine needs no further information to process this
request, so the Value field does not appear.

c. Click OK to enter the rule in the browse window of the Actions screen. To add another action, click New.
To change a selected action, click Edit.

d. Click Finish. GoldMine adds the rule to the selected rule set. The name of the rule appears in the left
pane under the rule set. The selected condition(s) and action(s) of the rule set appear in the right pane.

9. After configuring actions, click Finish.

GoldMine adds the rule to the selected rule set. The name of the rule appears in the left pane under the rule
set. The selected conditions and actions of the rule set appear in the right pane.

GoldMine Administrator's Guide Page 94 of 439



GoldMine™®

Using the Document Management QuickStart Wizard

GoldMine Plus for Microsoft Office is installed during the main GoldMine application installation. It can also be
installed independently by using the Add/Remove Programs Windows control panel.

GoldMine Plus for Adobe Acrobat is installed from its own installer. For more information about installing and
using GoldMine Plus for Adobe Acrobat, refer to the GMAcrobatLink.pdf, or via:_
http://www.goldmine.com/goldmine-support/.

NOTE: GoldMine must be installed locally in order to install the Acrobat Link. It will not function from a
shared folder location.

This Document Management QuickStart Wizard directs you to an informational web page. It does not install any
add-on products.

1. Select Tools > Quick Start Wizard.
The GoldMine QuickStart Wizard dialog box opens.
2. Click the Document Management Wizard button.

e,

G

A web page opens in your browser showing details about the GoldMine Plus suite of products.

Customizing Auto-dialer Settings

With the advent of multiple area codes in metropolitan areas and telephone dialing capabilities in computers,
GoldMine developed a method for differentiating between local and long distance calls, letting GoldMine users
dial the phone using the modem in a computer without entering special dialing codes.

A user-created, configuration settings file called predial.ini that is placed in the GoldMine folder handles the
differentiation between local and long-distance calls. The file consists of four sections: [City], [Prefix], [Suffix], and
[PBX]. Each section is scanned in the listed order until a match is found. This terminates the search, and GoldMine
uses the values found to dial the phone ignoring settings in lower sections of the predial.ini. The exception is the
[Suffix] section; GoldMine checks this section for a match, thus terminating the search when a match is found.

Set auto-dialer to recognize differing telephone number types, prefixes, and suffixes by creating an Exception List
in a predial.ini file. An exception list provides a set of conditions GoldMine checks when processing telephone
numbers formatted for North America. For example, you might need to set up your auto-dialer to recognize
different types of telephone numbers, such as local and long distance. Upon finding a match to specified
conditions, GoldMine processes telephone numbers according to the formatting entered for the condition.

See knowledge document “Using and Setting up GoldMine’s PREDIAL.INI for Special Dialing Needs” at
https://community.ivanti.com/docs/DOC-61744
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Configure Calls with SoftPhone

SoftPhone integration with GoldMine uses SIP (Session Initiation Protocol) and VolP (Voice over IP) technology to
place and answer contact calls. The SIP Proxy (not included with GoldMine) must be configured and its
functionality verified by an administrator. The administrator can then configure GoldMine to make and receive
calls through the SIP Proxy Server by setting SoftPhone preferences.

NOTE: For administrators: If a SIP Proxy Server is being unused in the environment, edit user properties to
remove Launch SoftPhone from the GoldMine menu. This avoids attempts to call through this feature when
a SIP Proxy Server is not present.

WARNING: You can record phone calls through the use of the Licensed Software. The law on
recording phone calls varies from country to country and state to state. Ivanti Software
recommends that you inform the other party or parties to your phone call that you are recording
their conversation. However, it is your responsibility to comply with all applicable laws and
regulations in your use of the Licensed Software. You agree to abide by all applicable
communication, privacy and similar rules, directives and other laws in your use of the Licensed
Software. In no event will lvanti Software be liable for any action or inaction on your part which
leads to or causes you to break the law.

Data Maintenance and Management

GoldMine's extensive feature set lets you share data between GoldMine and other applications, to globally replace
field data, and to monitor running processes.

Maintaining the data in your GoldMine database ensures the highest performance for your system and the most
effective use of information. GoldMine is equipped with many features to help maintain your system.

Choosing an Edition of SQL Server

In most environments, GoldMine works well with SQL Server Express Edition to support about 20 concurrent
GoldMine users. In environments with more users or with a significant amount of data in the GoldMine database,
select an appropriate edition of SQL Server based on need. For more information about which SQL Server Edition is
appropriate for the needs of your organization, please visit Features Supported by the Editions of SQL Server 2012.

About Contact Set Databases

Use the Contact Set Databases dialog box to create, attach, delete, and edit contact database properties. To open
the Contact Set Databases dialog box, use the following procedure.

1. Select Tools > Databases > Open Database.

The Contact Set Databases dialog box opens. The currently attached Contact Set databases display in the
database list stored in the SPFiles table. The buttons are explained below:

O New. Launches the Database Wizard. Create a new database. See Data Maintenance and Management.

O Attach. Opens the Contact Set Profile dialog box. Attach a database to the Contact Set listing. See Defining
Contact Set Profiles.
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O Delete. Deletes the highlighted database.

O Properties. Opens the Contact Set Profile dialog box. Edit properties of an existing database. See Defining
Contact Set Profiles.

O Open. Opens the highlighted database in GoldMine. See Opening Databases.
O Close. Closes the Contact Set Databases dialog box.

2. If you right-click the database list with a database highlighted, select Open, Attach Database, New, Delete,
and Properties options, and also select:

O Maintain Database. Launches the Maintenance Wizard. See About Maintaining Databases.
O Find. Searches for words in the Description, Access, and Database/Location fields.

O Output to. Output the Contact Set list to the printer in a GoldMine Report format, Word, Excel, or the
clipboard.

Defining Contact Set Profiles

The Contact Set Profiles dialog box appears when editing the Properties or Attaching Databases. You can set the
description and path, ownership and access, and the SQL login information.

Use the following procedure to define contact set profiles.

1. Select Tools > Databases > Open Database.
The Contact Set Databases dialog box opens.

2. Highlight the database and click Properties to edit an existing database, or click Attach to add a database to
the Contact Set Database list. The Contact Set Profiles dialog box opens.

3. Inthe Contact Set area, type the Description in the field.
Type the three-letter File Code.
This is a unique code used to identify a database among multiple databases when GoldMine synchronizes.

NOTE: The File Code is required for synchronization.

5. The Server Type drop-down list displays the type of database (fixed; you cannot add or change an entry in
this field).

6. Select the appropriate Alias from the drop-down list (displays known aliases; auto populated based on
Database Connections Manager).

In the Owner text box, retain the default dbo or type the owner of a SQL database.

In the GoldMine File Ownership & Access area, select a user or user group from the Grant access to this file
for drop-down list, or leave as (public). Only the owning user or user group can open this Contact Set.

NOTE: Users with Master Rights can access all contact databases, without regard to the owner.

9. Select Grant Access from this GoldMine license only to let only the currently running GoldMine to open the
database.

NOTE: Type the Logon name and Password you placed on the SQL database.
10. Click OK.
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Opening Databases

GoldMine lets you have more than one Contact Set database. For example, departments within your company
might use different databases.
1. Select Tools > Databases > Open Database.

The Contact Set Databases dialog box opens.

2. Highlight the database to open and click Open. The new database opens with the database name in the lower
left corner of the GoldMine status bar.

About Creating Databases

Use the Databases Wizard to create a database for new data or rehost an existing database to a new database.
You can create or rehost the Contact Set tables and/or the base GoldMine tables.

The Contact Set tables contain all the tables related to the Contact records; when you create a new Contact Set,
the database name is added to the Contact Set Databases dialog box. The base GoldMine tables contain tables
shared between all Contact Sets such as Calendar, Filters, Mailbox. When you create a new database of any of
these files, GoldMine does not add the database name to the Contact Set Databases dialog box.

Rehosting creates a new database, and copies data from the old database to the new one without affecting the
original database.

NOTE: Database traffic between GoldMine and SQL Server is encrypted by default. Note that file
attachments are transferred using Microsoft networking file system and might not be encrypted.

Creating SQL Databases
Creating a new SQL database is a three-stage process. Create the:

= SQL database shell
m Alias
m Database in GoldMine
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Using the Databases Wizard

Use the Databases Wizard to create a new Contact Set database and/or a new base GoldMine database. The new

database can be created as either a copy of the currently active database, or as an empty database containing the
same fields as the currently active database.

1. Select Tools > Databases > New Database.

The Welcome to the Databases Wizard dialog box opens.

i Rehost GoldMine Database .
Welcome to the Databases Wizard!

Using the Database Wizard you can create a new GoldMine
databasze, copy data from an existing dBASE database, or
rehiost the cument database to another server.

[] Create or copy data for contact set tables

[] Create or copy data for base GoldMine tables

&

Select the check boxes corresponding to the type of database you will create or copy.

O Contact set tables. Select this option to create a new Contact Set or to copy the current Contact Set.

O Common GoldMine tables. Select this option to create the base GoldMine tables shared with all Contact
Sets. Select this option only when creating a complete copy of the entire database.

NOTE: For this example, both contact set and base GoldMine tables are selected.
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2. Click Next.

§ | Rehost GoldMine Database -

I you need to create a new alias or a new database, please
use the alias manager

Please select the database alias for the new contact set
tables:
| v

Flease enter the description for the new cortact set:

Flease select the database alias forthe base GoldMine tables:

| Y]

3. To create a new alias or database, click the Alias Manager button.
The Database Alias Manager dialog opens. After you create your new alias or database, the Databases Wizard
will reopen. See About the Database Alias Manager.

O If you chose to create or copy contact set tables in the previous step of the Wizard, select the database
alias for the new contact set from the drop-down menu, then enter a description for it in the text field
below.

O If you chose to create or copy base GoldMine tables in the previous step of the Wizard, select the database
alias for the new GoldMine tables from the drop-down menu.

Click Next.

W Rehost GoldMine Database -

Select source of data for the new database

() Create blank tables (no data, except a few system records)

(®) Copy data from the cumently active database

Advanced settings:
[] Select individual tables to rehost
[ ] Create unicode database for M5 SQL Server only)

<Back | Ned> | | Cancel
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Select the data source for your new database using the radio buttons

O Create blank tables. (no data, except for a few system records): Select to create an empty database. Click
Next, or go to Select individual tables to rehost below to individually select the tables for your new
database.

O Copy data from the currently active database. Select to copy records from the currently active database
into the new database. Click Next, or go to Select individual tables to rehost below to individually select
the tables for your new database.

O Advanced Settings:

- Select individual tables to rehost: Select this check box to choose individual tables to rehost in your
new database.

- Create unicode database (for MS SQL Server only: Select this check box only if you wish to create a
unicode database.

- Click Next.
If you selected individual tables to rehost, the Rehost Selected Tables dialog box opens. Select the
tables you wish to rehost and click Next.

- The Database Access dialog opens.

W Database Access -

In addition to the security enforced by the database server,
GoldMine can restrict access to only certain users. Below
you can specity access to a User Group, or allow access to
evenyone by selecting (public):

Allow access to: | {public) A4 | @

To allow synchronization of multiple contact sets, entera
unigque file code to identify this contact set.

Contact set code: | | E E

You can set access to this database to only the cument
system’s seral number. This restricts access when attaching
to this database from other Gold Mine installations .

[] Mlow database access only from this GoldMine installation

4. Select from the following options:
O From the Allow access to drop-down list, accept the default (public). This grants access to all users and
groups. To select a user or user group, select a name in the drop-down list.
O In the Contact set code text box, type a unique value. GoldMine uses this to associate synchronized data
with the correct database, regardless of its local name.

Example: An East Coast branch office and a West Coast branch office might have the same Contact Set.
Each branch office wants to synchronize data from their local Contact Set with the other office. The East
Coast office names the Contact Set Industrial; the West Coast office names the same contact set
"Manufacturing". As long as each office assigns the same Contact set code value to the local copy of the
database, the offices can synchronize data.
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5. Clear the Allow database access only from this GoldMine installation check box.

NOTE: Selecting this check box allows only the currently active GoldMine system (as determined by serial
number) to log into the database. A GoldMine system with a different serial number cannot log into the
database.

Click Next. The Creating Database Files dialog box opens.

§ Creating Database Tables -

GoldMine is now ready to create your new database files.
To start the process, click "Finish”.

<Back || Fish | | Cancel |

6. Click Finish. The status dialog box opens.
When complete, a message appears asking if you want to open this new database now.

About Maintaining Databases

GoldMine includes a database Maintenance Wizard that generates indexes, rebuilds and packs the data, and sorts
and verifies the database. Indexing ensures data integrity and quick access to the data in indexed fields. Rebuilding
and packing creates fresh data files and builds tables, and then repacks the database, minus the deleted records.
Sorting the database orders database files by the most-used indexes. Verifying data ensures it is readable, that the
fields in the synchronization records are populated and readable, and that unique fields are not duplicated.

= Indexing Databases
= Rebuilding and Packing Databases
= Sorting and Verifying Databases
IMPORTANT: Before maintaining the database, always do a full backup of your database. This guarantees you

can restore the database if something interrupts the process. For example, a power outage or network failure
during the process could cause data loss.

Only one user should be logged into the GoldMine system during maintenance operations. Before the
maintenance begins, GoldMine ensures no other user is accessing that data. Once the operation is in progress,
GoldMine prevents other users from accessing the system by renaming the License.bin to License.bix. When
maintenance is completed, the license renames back to License.bin.

To monitor what database maintenance has been initiated, view the Maintenance Logs.
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Attaching Databases

Attach an existing database to make it available in GoldMine. Then tell GoldMine where the database is located,
who the owner is, and, if necessary, the SQL login information.

Use the following procedure to attach a database.

1. Select Tools > Databases > Open Database.

2. At the Contact Set Databases dialog box, click Attach.
The Contact Set Profile dialog box opens.

Update the fields as needed. See Defining Contact Set Profiles.
Click OK.

About the Lookup.ini

The Lookup.ini file does not exist in GoldMine until you create it using a text editor. It writes as a standard
configuration file, similar to the win.ini and System.ini files and stores in the GoldMine directory.
m Lookup.ini performs functions based on a trigger and resulting action:
m Update a Contactl or Contact2 field based on an entry in another Contactl or Contact2 field.
m Update Contactl or Contact2 field based on an expression.
= Launch an external application based on an expression or the occurrence of a specified field entry.
= Apply an activity color code to calendar activities based on either an activity type, an activity code, or both.
= Launch an external application when a new record is created.
NOTE: If the Lookup.ini script updates a field based on updates to another field, the update of the
second field does not follow the update access security for the second field set in the Field Properties

dialog box. Example: use a Lookup.ini to update Key2 based on updates to Keyl. The user has update rights
to Keyl, but not to Key2 — but can update Keyl and the Lookup.ini updates Key?2.

NOTE: A Lookup.ini thatis configured to automatically update a Key field will only do so if the Key field is
empty. This is to ensure that a value specifically entered by the user is not overwritten.

Lookup.ini includes:

= [AutoUpdate]: Specifies trigger fields (fields that create an update if modified) and the resulting field to be
updated. The second section comprises the specific instructions and parameters used when updating the
GoldMine field.

= [OnNewRun] and [OnEditRun]: Determines the external application to launch when a new record is created (a
contact record or a supplemental file record adding a new calendar activity).

= [CalCIrCode]: Specifies the color to assign to the activity being scheduled.

For more information about using the lookup.ini file, see Examples of Using Lookup.ini.
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Examples of Using Lookup.ini

Following are some examples of how to configure the lookup.ini file.

Entering Data in One Field Updates Another

A company requires that the Salesperson field, USalesRep, is automatically updated [AutoUpdate] when the
GoldMine user entering data populates the City field.

The Lookup.ini section [AutoUpdate] is where the trigger and update fields are defined in the format: Trigger
field=Update field.

There is no need to prefix field names with a database (Contact1->City) because no two fields in the Contactl
or Contact2 data files (except AccountNo) have the same field name.

The following example automatically updates field data.

[AutouUpdate]
City=USalesRep

When the trigger field (City) is updated, the Lookup.ini evaluates the subroutine of the same update field
name (USalesRep). The evaluation determines what is entered into the USalesRep field.

In the following example, the subroutine (USalesRep) contains a reference to the trigger field (City) and a list
of potential values that could be contained within the City field (Seattle, Aspen, Kansas City).

[usalesRep]
Lookupl=Contactl->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden

If a match is found, for example, the City field contains Seattle, Lookup.ini populates the USalesRep field with
Janice Parks (Seattle=Janice Parks).

For every possible entry in the City field, a Lookup must be listed if it is to update another field.

Checking a Sequence of Fields to Update Field

A company requires the Salesperson field (USalesRep) automatically update when the GoldMine user
entering data populates the City field. If no city is matched, the State field (or other geographic boundary)
must be evaluated so a second attempt is made at populating the Salesperson field.

Apply a second Lookup command. If GoldMine cannot match the City field with one of the listed values, it
moves on to the next Lookup, which in this case is State. If required, a maximum of 9 different Lookups can
be defined.

[Autoupdate]

City=USalesRep

[usaTlesRep]

Lookupl=Contactl->City

Seattle=Janice Parks

Aspen=Danny Davis

Kansas City=Ken Linden
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Lookup2=Contactl->State
WA=Janice Parks
CO=Danny Davis

MO=Ken Linden

If the City field does not contain Seattle, Aspen, or Kansas City, the State field is evaluated. If the State returns
a value of CO, the USalesRep field populates with Danny Davis. Set every parameter to update the field
correctly.

If No Match is Found

A company requires the Salesperson field (USalesRep) automatically update [AutoUpdate] when the
GoldMine user typing data populates the City field. If no state is entered or if an erroneous entry is made, the
Salesperson field updates with Unallocated.

The Lookup.ini can update a field with a set entry if no matches are found. The otherwise statement is
included after all Lookups 1-9 are listed.

If the City field does not contain Seattle, Aspen, or Kansas City, USalesRep populates with Unallocated.

[Autoupdate]
City=USalesRep
[usaTlesRep]
Lookupl=Contactl->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
Otherwise=Unallocated

Updating Two Fields from One Trigger Field

A company requires the Salesperson field (USalesRep) and the Region field (URegion) populate when the City
field populates.

The trigger field launches two subroutines rather than one. Note the [AutoUpdate] section containing a
reference to both fields, separated by a comma, and the existence of two separate subroutines.

The order of referencing is important if one field must be updated first because its new value affects the
entry in the second field.

If updating both the City and the Salesperson field affected the update of the Region, the USalesRep section
must be referenced first under [AutoUpdate].

If updating the Region and the City would affect the Salesperson, the URegion field must be referenced first
in the [AutoUpdate] section. If the fields are to be updated independently, either can be referenced first.

[Autoupdate]
City=USalesRep, URegion
[usalesRep]
Lookupl=Contactl->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
[URegion]
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Lookupl=Contactl->City
Seattle=Northwest
Aspen=Mountain

Kansas City=Midwest

If the Field to Update is Pre-Populated

GoldMine does not automatically overwrite an existing value in a field to be updated unless it specified to do
so. The OverWrite statement is a toggle statement (On/Off or True/False). If:

O Overwrite=0: Existing values in the update field are not overwritten.
O Overwrite=1: Existing values in the update field are overwritten.

The statement is placed at the end of the subroutine.

[Autoupdate]
City=USalesRep
[usalesRep]
Lookupl=Contactl->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
Otherwise=Unallocated
Overwrite=1

Update a Field Based on an Expression

The Lookup.ini, by way of expression, returns an actual value to a field that can be used like every other field
within GoldMine. The [AutoUpdate] section contains a trigger field and a reference to a subsection to
execute.

The subroutine contains an expression rather than a list of returned values from a Lookup1; however, the
subroutine must be written in a standard way, and therefore a dummy Lookupl must be inserted—although
it is set to not return any values—so the Otherwise command is invoked.

Use the expression with the Otherwise command, but prefix it with an ampersand (&).

The Calculation of Numeric Fields

A Company has quarterly sales figures (USales Qtr1-USalesQtr4) for each customer. It requires a Total
(UTotal) field that sums up business quarters one through four and returns a value.

The [AutoUpdate] section includes four trigger fields: Usales Qtrl-4. When any one of these fields updates,
the Lookup.ini runs the subroutine UTotal.

The Lookupl command looks in a placeholder field. In the example, Contactl->Company is referenced. No
values are listed under Lookup1; therefore, no match is found. The Lookup.ini progresses to the Otherwise
command.

[AutouUpdate]
UsalesQtrl=UTotal
UsalesQtr2=UTotal
UsalesQtr3=UTotal
UsalesQtr4=UTotal
[uTotal]
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Lookupl=Contact->Company
Otherwise=&(Contact2->UsalesQtrl+Contact?2
->UsalesQtr2+Contact2->UsalesQtr3+
contact2-> UsalesQtr4)

Overwrite=1

Calculation Fields Using Decimal Places
For the Lookup.ini to calculate a value that includes a decimal place, each field referenced when calculating
must contain the same amount of decimal places whether needed.
The Otherwise command must include a String statement (STR) in order to calculate to x decimal places.
[Autoupdate]
UsalesQtrl=UTotal
UsalesQtr2=UTotal
UsalesQtr3=UTotal
UsalesQtr4=uTotal
[uTotal]
Lookupl=Contact->Company
Otherwise=&STR(Contact2->UsalesQtrl+Contact2->UsalesQtr2+Contact2-
>UsalesQtr3+Contact2->UsalesQtr4,2,10)
Ooverwrite=1
The Otherwise statement ends in 2,10 where 2 indicates the number of decimal places and 10 the length of
the field.

Averaging Blank and Filled Fields Using Hypothesis Values

If the Otherwise command holds an expression that calculates the sum of the contents of all fields, then
divides the total by the number of fields, those empty fields (set to zero) are also included.

Otherwise=&((Contact2>Ufieldl+Contact2->Ufield2+Contact2->Ufield3)/3)

If the field values were:

0 10, 20 and 30, the Lookup.ini returns a value of 20 (60 divided by 3).

0 10, 20 and 0, the Lookup.ini returns a value of 10 (30 divided by 3).

Inclusion of the blank or zero fields might be inappropriate. In our example the final calculation should be
divided by 2 not 3, resulting in an average of 15.

True/False fields calculate using an if statement followed by the value indicating whether the value is true,
then are suffixed with a value to replace if true, and then a value to replace if false:

(iif(field=value, truel[x],falsel[y]))

GoldMine Administrator's Guide Page 107 of 439



GoldMine™®

The expression otherwise=&(iif (contact2 ->ufield1=0,0,1)) states the value in Ufield1 should equal 0. If it
does (true), the count field populates with 0. If the field is not equal to 0 (it contains either a higher or lower
value), the count field populates with 1 for false (not true). Each field evaluated must have its own count
field.

The Utotal section then calculates the sum of all counter fields and uses that figure to divide the total of the
fields Ufield1-Ufield3.

The programming standard of 0 = false and 1 = true has no bearing in this example.

[Autoupdate]

UFieldl=ucountl, utotal

UField2=ucount2, utotal

UField3=ucount3, utotal

utotal=utotal

[ucountl]

Lookupl=contactl->company
otherwise=&(iif(contact2->ufield1=0,0,1))
Ooverwrite=1

[ucount2]

Lookupl=contactl->company
otherwise=&(iif(contact2->ufield2=0,0,1))
Ooverwrite=1

[ucount3]

Lookupl=contactl->company
otherwise=&(iif(contact2->ufield3=0,0,1))
Ooverwrite=1

[uTOoTAL]

Lookupl=contactl->company
otherwise=&((contact2->ufieldl+contact2> ufield2+contact2->ufield3)/(contact2>
ucountl+contact2->ucount2->+contact2> ucount3))
overwrite=1
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Using the Lookup.ini to Launch External Applications or
Macros

Automatically launch external applications or Macros for further processing to occur outside of GoldMine after
record data is changed.

= [OnNewRun]: Sets up external applications for each type of contact-related record.

= [OnEditRun]: Launches applications when a record is changed.

Records in Contactl, Contact2, Cal, ContHist, and ContSupp can be considered by the [OnNewRun] and
[OnEditRun] sections. Set up specific record types in Cal, ContHist, and ContSupp to launch different applications
by appending the rectype to the table name.

Example 1:

[onNewRun]
Cal-s=SaleCApp.exe
cal-c=CallcApp.exe
Cal=CalApp.exe
ContHist-S=SaleHApp.exe
ContHist-CI=InCalTHApp.exe
ContHist=HistApp.exe
contSupp-P=ProfileApp.exe
Contactl=NewContact.exe
Otherwise=AnyApp.exe
AppendRecNo=1
DisableFromapP=1

Or, specify entries under [OnNewRun] and [OnEditRun] for each contact-related record and record type. GoldMine
first checks for a specific Rectype entry, then for a general table entry not suffixed with a Rectype. Example: when
a sale is completed, check for ContHist-S=. If no ContHist-S=, check for the general ContHist=. If no ContHist=
entry, check for Otherwise=. Thus, GoldMine launches ProfileApp.exe if a detail record is added.

Add to End of Scripts

= AppendRecNo=1: Append the RecNo of new record to the command line. Example: a completed incoming call
from the example launches a command=InCallApp.exe 1234 (where 1234=the record number of the
completed record in the ContHist file). With this entry, use a DDE command to query GoldMine for the new
record's data.

= DisableFromAP=1: Disable the [OnNewRun] options if an activity is processed by Automated Processes.

m Otherwise=: Entry is suffixed with the File+RecType, such as "AnyApp Cal-A 1234".

When a contact record is created and the [AutoUpdate] NewRecord option is specified, that option is executed
first so the resulting updates can be used by a subsequent [OnNewRun] Contactl=NewContact.exe entry.
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Running Macros

A macro is a button or hot key shortcut representing an instruction, action, or a series of instructions, actions, or
text inputs (see Working with Macros). Macros can also be added to the Lookup.ini file.

When you create a macro, it is saved to a file called <username>.mac. The macros are saved in the
\GoldMine\macros\ directory. This file lists all the recorded macros with numbers associated to them. When you
open this file in a text editor (such as Notepad), you see a list of all the macros that you have recorded. In the list,
there is a number that precedes the section with the Title and Description you added when you recorded the
macro.

To use a macro in the Lookup.ini, you must use the number associated with the macro in the <username>.mac
file. For example:

<username>.mac Field Description
[800] macro number
T=0OutlookSync Title
D=Synchronize with Outlook Description
F=user.800

H=85,0,1441793 Hot Key Code
S=1 Playback Speed

When you use a macro as part of the Lookup.ini, use the following format for example:

[onNewRun]
Contactl = &PlayMacro(800)

What this will do is watch the Contactl table. If there is a change, then macro 800 is run. In this example, if the
Contactl table is modified, GoldMine will synchronize with Outlook.

TIP: Macros can also be added to the GoldMine Taskbar. For more information, see To Add
Macros to the Taskbar.

Moving Linked Documents and Attachments

E-mail attachments and/or documents linked to contacts, the Knowledge Base and Service Center can be stored in
folders on disks.

Use the following procedure to move that folder to another location, (for example from the c: drive to the E:
drive, or from Program Files to ProgramData for Windows 7, Windows 8 and Windows 10 compliance).

NOTE: Synchronization logs will not be created by this tool, so remote machines will not be affected.
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Use the following procedure to move linked documents and attachments.

1. Select Tools > Data Management > Move Linked Docs and Attachments.
2. Click the Move the Linked Documents, Knowledge Base and Case Attachments to checkbox if not selected
and then define destination folder.
The Move Linked Docs and Attachments dialog box opens.
O Go to Step 3 if you want GM to automatically find ALL linked documents, knowledge base and attachments,
and move them to destination folder.
O Click the Add button and select the source folder(s) to set the list of directories manually.
Each time a new record will appear in the Move documents from: list.
O To remove a record from Move documents from: list highlight it by right mouse click and click Remove.
3. To move mail attachments check the Move all Mailbox Attachments to: checkbox and then define
destination folder.
4. Inthe Options area, select one:
O Move actual files and folders, and update database references.
O Update the database reference only. (Choose this selection when files and folders are already been moved
to destination directory).
5. Click Go to finish or Cancel to cancel operation.

The files are moved along with all existing subdirectories.

Backing Up Databases

If you encounter a problem while working in GoldMine that causes data loss or data corruption, the problem can
be internal or external to your system. Ensure data availability in the event of data loss or corruption using a
regular program of data backup.

To maintain an optimal backup system, make a separate backup on each day for a 2-week cycle. That is, your
backup system should include 10 to 14 individual backups. Two weeks of backups are recommended because data
corruption might not be discovered for several days. Only 1 or 2 backups might contain corrupted data. Use tape
or diskettes as a backup medium.

For added security and recovery, keep a backup in secure offsite location (a bank deposit). Ensure you periodically
update the backup.

NOTE: Maintain regular backups of GoldMine contact data, setup data, and program files. To back up
contact data in GoldMine on an MSSQL database, use a utility designed to back up SQL data.

Backing Up SQL Databases

With an SQL database, the files needed for a backup can be copied to another directory, another drive, a disk, or
an external drive. It is recommended that you keep a daily backup on a 2-week cycle, as hardware failures or
unforeseen problems can cause you to lose your data.

NOTE: It is highly recommended that you create a database backup using SQL Server Management Studio.
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A full backup of GoldMine on SQL Server requires you to back up the GoldMine system files and the SQL database.
To perform a manual backup of your SQL database, the following GoldMine system files and their typical locations
(listed in the table below) must be copied to create a safe backup file.

Location Files
\GoldMine\ *.exe
\GoldMine\ *.D*
\GoldMine\Reports *.FP
All other subdirectories of \GoldMine * . D¥

For complete information, see the SQL Server Online Help and SQL Books Online.

Restoring SQL Databases

To use the SQL restore utility, find the SQL Server Enterprise Manager and right-click the database name. Select All
Tasks > Restore Database. The SQL Server Restore dialog box appears. Select the backup file to restore and click
OK. The Restore Progress window shows the restoration process status.

SQL Query for Counting Contacts

If you are running GoldMine on an SQL database, the Summary tab does not display the database count. Instead
you see n/a in the Record field. You can, however, count the number of records in an SQL database by running a
query from the SQL Query tab of the Filters and Groups dialog box.

To Run the SQL Counting Query
1. Select Lookup > SQL Queries. The Filters and Groups dialog box opens to the SQL Query tab.
2. Inthe large upper pane, type this statement:
Select Count(*) from contactl

3. Select Query. GoldMine displays the record count results under Column1 in the lower pane.

Using the GoldMine Maintenance Wizard

Configure the following maintenance options:

= Indexing. Ensures data integrity and quick access to the data in indexed fields. See Indexing Databases.

= Rebuilding and Packing: Creates fresh data files and builds tables, then repacks the database minus deleted
records.

= Sorting and Verifying: Sort reorders records in the tables based on the most-used indexes. Verify checks data
for readability. It checks to see if all fields in the synchronization records of the database files are populated
and for any duplication of unique fields. See Sorting and Verifying Databases.

IMPORTANT: Always back up your database before using the wizard for GoldMine maintenance.
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Use the following procedure to use the Maintenance Wizard.

1. Select Tools > Databases > Maintain Databases. The Welcome to the GoldMine Maintenance Wizard dialog
appears.
2. Select:
O Current Contact Set Files. Includes currently open contact files. Does not include GoldMine files, such as
Calendar, Lookup, or Mailbox.
O Individual Files. Lets you select individual tables from open contact files and GoldMine files.
O All Database Files. Lets you select GoldMine files, current Contact Set, or all contact sets.
O Automatic Maintenance. Lets you configure automatic maintenance options (regular maintenance without
user intervention).
3. Click Next. The dialog box that opens varies based on previous selection (each box eventually opens the
Rebuild, Sort and Verify Database Files dialog box).

NOTE: If the required database indexes for contact tables do not exist, GoldMine Premium may fail silently
at start up. This can occur if the database server runs out of disk space during database maintenance.

Indexing Databases

If a large amount of data is added or removed or statistics update has been disabled, you might want to re-index
the database in order to let the SQL engine recalculate index selectivity (also known as index statistics) due to
indexes becoming lost or corrupt. Selectivity is an internal measurement of efficiency of the index and it is used by
the SQL engine in deciding how best to access the data.

Use the following procedure to index the database.

1. Select Tools > Databases > Maintain Databases.

The Welcome to the GoldMine Maintenance Wizard dialog box opens.

NOTE: : Depending on the size of your database, indexing the entire database can be time-consuming.
Select All Database Files if you are indexing the entire database. To index a particular table, select Individual
Files.

2. Select one of the following options:

O Current Contact Set Files. Indexes only the contact files/tables in the currently open contact database. If
you select Current Contact Set Files, the Rebuild, Sort and Verify Database Files dialog box opens.

O Individual Files. Specifies which files/tables in the GoldMine directory and in the open database that
GoldMine indexes. If you select Individual Files, the Maintain Selected Tables dialog box opens.

O All Database Files. Indexes and rebuilds contact files/tables in the open contact database, and those
contained in the GoldMine system directory. If you select All Database Files, the Maintain All Database
Files dialog box opens.

NOTE: Select Automatic Maintenance to configure GoldMine to automatically perform indexing and
rebuilding. The Automatic Maintenance dialog box opens.
3. Click Next.

4. Based on your selection in step 2:
O If you selected Individual Files, at the Maintain Selected Tables dialog box, select the table or tables to be
indexed. Click Next.

To select all tables, click Set All. To clear all tables, select Reset All.
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O If you selected All Database Files, select Files in GoldMine Directory and Current Contact Set Files. Select
All Contact Set Files to index other contact databases. Click Next.

5. The Rebuild, Sort and Verify Database Files dialog box opens. To perform a simple indexing, do not select the
options. Click Next.

6. Select Force all users to exit GoldMine within x minutes. Set the number of minutes.

A message is sent to the currently logged in users telling them the GoldMine Administrator is performing
maintenance, to complete their work, and close GoldMine.

7. Click Finish. GoldMine deletes the current indexes for the selected table or tables, and creates new ones.

Sorting and Verifying Databases

Sort reorders records in the tables based on the most-used indexes. Verify checks data for readability. It checks to

see if all fields in the synchronization records of the database files are populated and for any duplication of unique
fields.

NOTE: Always back up your database before maintaining GoldMine (see Backing Up Databases).

1. Select Tools > Databases > Maintain Databases.

2. At the Welcome to the GoldMine Maintenance Wizard dialog box select:

O Current Contact Set Files. Includes currently open contact files. Does not include GoldMine files, such as
Calendar, Lookup, or Mailbox.

O Individual Files. Lets you select individual tables from both the currently open contact files and the
GoldMine files.

O All Database Files. Lets you select GoldMine files, current Contact Set, or all contact sets.

O Automatic Maintenance. Lets you configure automatic maintenance options (regular maintenance without
user intervention).

3. Click Next.

The dialog box that appears varies based on previous selection (each box eventually opens the Rebuild, Sort
and Verify Database Files dialog box).

4. Select Rebuild and Pack the database files.

If using GoldMine with a SQL database, a warning message appears reminding you SQL tables do not need
rebuilt.

If appropriate, select Sort the database files.
If appropriate, select Verify the data and synchronization information. Click Next.

From the GoldMine Maintenance Wizard dialog box, select Force all users to exit GoldMine within x
minutes. Set the number of minutes. A message is sent to the currently logged in users telling them the
GoldMine Administrator is performing maintenance, to complete their work, and close GoldMine.

8. Click Finish.

Setting Up Automatic Maintenance

Configure GoldMine to automatically maintain the database based on specified criteria.

1. Select Tools > Databases > Maintain Databases. The Welcome to the GoldMine Maintenance Wizard dialog
box appears.
Select Automatic Maintenance.

Click Next. The Automatic Maintenance dialog box appears.
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4. Select the Logged User (designates the user with Master Rights responsible).

NOTE: The Logged User must be logged into GoldMine at the specified start time and day for the automatic
maintenance to run.

5. Type or select the Start Time. Click the right arrow to access the F2 graphical clock.

6. In the Maintain Files box, select a file to maintain.

NOTE: Because GoldMine forces all network users to log out of GoldMine during indexing and rebuilding,
index after regular business hours.

NOTE: Maintain Calendar File and Sync Log Files often (rebuild and pack weekly).

7. Select the Frequency.
O Pack, rebuild and index: Indexes, rebuilds, and packs the selected files.
O Index only: Only indexes the selected files. Available only for the GoldMine Files, Current Contact Set, All
Contact Sets, and System Logs.

8. Select Save.

View the Maintenance Logs to verify the process has run successfully.

NOTE: If you maintain a SQL database with the Wizard, you must reset table permissions.

Viewing System Logs

GoldMine records system activity for a variety of operations in System Logs. To view a system log, select Tools >
Logs > GoldMine Logs. The left pane displays the log types and the right pane displays the details. To see details,
expand the log type until you locate the day to view. Select the day; details appear in the right pane.

The System Logs window displays these log types:

= Process Monitor Logs: Activities recorded in the GoldMine Process Monitor.

= Maintenance Logs: Dates and outcomes of database maintenance procedures.
m Users' Login Logs: Users' login activity.

= Sync Wizard Logs: Dates and details for GoldMine synchronization.

m GoldSync Logs: Details about GoldSync synchronization.

= Contact Files Logs: Changes made to the Contact Set files.

= GoldMine Files Logs: Changes made to GoldMine files.

= Error Logs: Details of errors.

Use the logs for troubleshooting. To prevent performance problems, periodically purge the logs (see Purging Log
Entries).
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Purging Log Entries

The System Logs (see Viewing System Logs) can consume a significant amount of disk space. Periodically purge old
logs to reduce space required.

IMPORTANT: Purging synchronization logs can cause problems with your synchronization process. Only purge
logs older than the oldest successful synchronization. Example: for a site that has not synchronized in the last 2
months, set the purge date back more than 2 months.

Select Tools > Logs > GoldMine Logs. The System Logs window appears.

In the left pane, right-click and select Purge Logs. The Purge Logs dialog box appears.

Select the logs to purge from the Log Types area.

Select the Cutoff Date using the F2 graphical calendar. The date defaults to the previous month.

If purging User's Login Logs, select the Users you are purging from the list.

oV Pk wWwNERE

Click OK. The Process Monitor appears, displaying the status of the purging process

About the Database Alias Manager

The Database Connections Manager lets you establish an “alias” for each database management system used with
GoldMine. An alias is required to connect your database to the application. It tells GoldMine where to find the
database, collecting information from which to build the ADO connection string.

Use the Manager if you are already using an existing or multiple databases with GoldMine. It imports any existing
MSSQL BDE aliases.

NOTE: The Database Connections Manager creates the alias and the shell (only two of the three stages for
creating a database). If you are creating a new database, use the Databases Wizard. The wizard process
leads you through the three-stage process often needed for creating the database and allows you to create
the tables as well. To access the wizard, select Tools > Databases > New Database.

See Using the Database Alias Manager for SQL Databases

Using the Database Alias Manager for SQL Databases

From the menu bar, select Tools > Databases > Alias Manager, or from the appropriate window in the Databases
Wizard, click the Alias Manager button. The Database Alias Manager appears.

To alias a database, click New Alias. The Edit Alias dialog opens.

NOTE: This dialog window contains a form for collecting information used to build an ADO connection
string. This information is stored in an INI file.

1. Inthe Alias Name text box, type a name for the alias.
There is a 100-character limit.
2. From the Server Type drop-down list, select either MSSQL.
NOTE: The form will change depending on the Server Type selected.

3. Inthe Host text box, type the name of the computer hosting the database.
4. In the Database text box, type the name of the database.
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5. Inthe Owner text box, type the database owner's name (typically, this is dbo).
6. Inthe Login text box, type the username for the database.
7. Inthe Password text box, type the password for the database.

NOTE: By default, the Password text box displays a fixed number of asterisks as a security measure.

NOTE: This action registers the alias and creates the database specified. The new database will not be
created without completing this step, although it will appear in the list. You cannot test it prior to
completing this step.

8. Select the Use Windows Authentication (SSPI) check box if you have designated Windows Authentication
Mode instead of the SQL authentication. [This only applies to MSSQL aliases.]

9. Click Create New Database.

10. Click Test Connection. This verifies that the alias was created successfully.

11. Repeat this process for each alias you want to create.

12. Click OK when done.

To Edit an Alias
1. From the menu bar, select Tools > Databases > Alias Manager.
The Database Alias Manager opens.
2. Select an alias from the list and click Edit.
This activates the associated form.
3. Make appropriate changes to the information in the text boxes.
Click Save and then click OK.

To Delete an Alias
1. To delete an alias, select the alias.
2. Click Delete and then click OK.

Globally Replacing Field Data
The Global Replace Wizard helps you replace the value of a field in the contact record.

IMPORTANT: Before beginning a global replace, back up the GoldMine databases (see Backing Up Databases).

If using a global replace to operate on a subset of data, first build that subset with a filter or group you can then
select during the process.
= Users without Master Rights cannot replace the Owner or Status fields.
= Apply global updates only to Contactl and Contact2 fields.
To Use the Global Replace Wizard
1. Select Tools > Data Management > Global Replace.

2. At the Global Replace Wizard dialog box, select one option:
O Replace a Field with a value (see Globally Replacing Fields with a Value)
O Update a field using advanced options (see Globally Updating Fields Using Advanced Options)
O Exchange the value of two fields (see Globally Exchanging the Values of Two Fields)
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3. Click Next to continue with the wizard.

Globally Replacing Fields with a Value

Use the Replace a Field with a Value option in the Global Replace Wizard to change the value of a field with
another value.

To Globally Replace Fields with a Value

Select Tools > Data Management > Global Replace.
At the Global Replace Wizard, select Replace a Field with a Value, then click Next.
Select a Replace Field in the drop-down list.

This specifies the field to be updated. The data in this field will be replaced by the value specified in the With
Value field.

Select the GoldMine fields in the drop-down list.

4. Type or select from the F2 Lookup list the With Value to insert in the selected field.

This option specifies the replacement value that will be placed in the Replace Field. GoldMine will replace the

specified field in all contact records with the value in this field. For example, if the Replace Field is City, and

the With Value entry is Long Beach, GoldMine will replace all City entries with Long Beach.

Click Next.

Check the fields and replacement values before initiating the process:

O Expand partial contact records. Expands partial contact records in the database into complete records if
the field to be replaced is contained in the Contact2.dbf file. If the field is contained in Contact2.dbf, this
option is selected by default.

If you clear the Expand partial contact records option, partial records are not expanded, and field values
in these records are not updated. However, when additional entries require more space, GoldMine
converts a partial record to a complete record. Clearing Expand partial contact records prevents
GoldMine from automatically converting partial records during a global replacement.

O Update linked fields (based on lookup.ini). Changes values in linked fields according to the instructions in
the [AutoUpdate] section of the Lookup.ini file. This option is available only if one or more selected
fields include fields listed in Lookup.ini.

O Log updates in history. Records global changes to fields in the following System Logs:

O Process Monitor Logs. Displays the date, time, user, and number of records affected by the global
replacement

O Contact Files Logs. Displays the date, time, user, field name, and the value inserted by the global
replacement. This option appears only if you selected Log updates in history for each field from the Field
Label dialog box which you can access by pressing CTRL and double-clicking the field label.

7. You can globally replace more than one field at a time. To add another field and replacement value, click

Back.

8. If you have more than one replacement entry, Remove becomes active. You can delete any entry other than a
single entry.
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9. Click Remove to delete the highlighted global replacement entry.
10. Click Next.
The Global Replace Wizard displays a list of available filters and groups to apply to limit the records updated
by the global replacement. The filter or group does not have to be activated prior to selection.
Select the filter or group to apply in the drop-down list, then click Next.
The final Global Replace dialog box appears.
11. Click Finish.

Globally Updating Fields Using Advanced Options

Use the Updating Fields Using Advanced Options in the Global Replace Wizard for the following advanced options:

= Replacing an entire field with a value

= Replacing field text only with a value

= Replacing field text with a value at the specified position

To Globally Update Fields Using Advanced Options

1.
2.
3.
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Select Tools > Data Management > Global Replace.
A the The Global Replace Wizard, select the Update a field using advanced options and click Next.

Select from the following options:

O Update Field. Specifies the field to replace with the selected option.

O Replace. Type the value to insert into the specified field. GoldMine replaces the specified field in all contact
records with this value.

O Replace the entire Field with Value. Removes any entry in the field and inserts the contents of the field.

O Replace text with Value. Removes specified text only from the field and inserts the value from this field.
GoldMine conducts a case-sensitive search for the value you enter. An F2 Lookup list is not available for
this option.

O Insert Value at position. Specifies the position, in character spaces, where the replacement value appears
in the specified field.

O Evaluate Value as dBase expression. Replaces the field with the result of the dBase expression entered in
Replace.

In the Convert to area, select one:

O Proper case. Converts characters in the field value to initial capitals. For example, if the field value is ACME
PRODUCTS, the entry is converted to Acme Products.

O Upper case. Converts all alphabet characters in the field value to capital letters. For example, if the field
value is Acme Products, the entry is converted to ACME PRODUCTS.

O Lower case. Converts all alphabet characters in the field value to lowercase letters. For example, if the field
value is Acme Products, the entry is converted to acme products.

O Phone format. Converts all telephone numbers in the replacement entry to the format that was selected
for the record. Telephone numbers in contact records set up for a USA format appear as (999)999-9999;
telephone numbers in contact records set up for an international phone format have no formatting
applied.

O Click Next.

Check the fields and replacement values before initiating the process.
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O Expand partial contact records. Expands partial records in the database into complete records if the field
to replace is contained in the Contact2.dbf file.

NOTE: If the field is contained in Contact2.dbf, this option is selected by default. If you clear the Expand
partial contact records options, partial records are not expanded, and field values in these records are not
updated.

O Update linked fields (based on lookup.ini). Changes values in linked fields according to the instructions in
the [AutoUpdate] section of the Lookup.ini file. This option is available only if one or more selected fields
include the field(s) listed in Lookup.ini.

6. You can globally replace more than one field at a time.
To add another field and replacement value, click Back.

7. Click Remove to delete the highlighted global replacement entry.
If you have more than one replacement entry, Remove becomes active. You can delete any entry other than a
single entry.

8. Click Next.

The Global Replace Wizard displays a list of available filters and groups you can apply to limit the records to
be updated by the global replacement. The filter or group does not have to be activated prior to selection.

9. Select the filter or group to apply from the drop-down list and click Next.
10. At the final Global Replace dialog box, click Finish.

Globally Exchanging the Values of Two Fields

Use the Global Replace Wizard to update data in one field with data from another field by:

m Exchanging values of two specified fields on a contact record

= Replacing the value of one field on a contact record with the value of another field

To Globally Exchange the Values of Two Fields

1. Select Tools > Data Management > Global Replace.
2. At the Global Replace Wizard, select Exchange the values of two fields, and then click Next.
3. Select one option:
O Exchange the values of both fields. Trades the value of one specified field with the value of a second
specified field.
O Replace value of the left field with the value of the right field. Inserts the value in the first specified field
with the value in the second specified field. The original field remains unchanged.
4. Select the fields to update in the drop-down lists.
O Update this field. The field to replace or exchange.
O With this field. The field to exchange data with the first field or provide the replacement value.

NOTE: GoldMine converts the replacement data into the appropriate data type before copying the data
into the selected replace field.

5. Click Next.
6. Use the Global Replace Wizard setup dialog box to check fields and replacement values before initiating the
process.
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O Expand partial contact records. Expands partial records in the database into complete records if the field
to replace is contained in the contact2.dbf file. If so, this option is selected by default. If you clear
Expand partial contact records, partial records are not expanded, and field values in these records are not
updated.

O Update linked fields (based on lookup.ini). Changes values in linked fields according to the instructions in
the [AutoUpdate] section of the Lookup.ini file. This option is available only if one or more selected
fields include the fields listed in the Lookup.ini.

You can globally replace more than one field at a time. To add another field and replacement value, click
Back.

7. Select Remove to delete the highlighted global replacement entry.

NOTE: If you have more than one replacement entry, Remove becomes active. You can delete any entry
other than a single entry.

8. Click Next. The Global Replace Wizard displays a list of available filters and groups to apply to limit the
records to be updated by the global replacement. The filter or group does not have to be activated prior to
selection.

9. Select the filter or group o apply, then click Next. The final Global Replace dialog box opens.
10. Click Finish.

Importing and Exporting Data

About Importing Data

GoldMine provides several ways to import data. Use the GoldMine Import Wizard (see Using the Import Contact
Records Wizard) to import data from other applications into GoldMine using predefined profiles or by creating
your own profiles using the wizard. A predefined utility is included for importing from ACT!.

TIP: GoldMine also provides a wizard for importing data from an XML file (see Importing XML).

NOTE: For information about collecting contact information from web sites, see Web Import.

Import Sources
Import data into GoldMine from these database sources:

ASCII file

GoldMine can import and export ASCII text files. The delimited ASCII format is the most commonly used file
format. When viewed with a word processor or text editor, data saved in a delimited format might look like

this:
"ABC Company","John Smith","123 Main Street","Anytown","CA","97021"
"Joe’s Cleaners","Joe Turner","55 Third st.","Burbank","cA","91502"
"Mr. T’s Ribs","","22543 Eton Ave.","New York","NY","10027"

"ABC Company","John Smith","123 Main Street","Anytown","CA","97021"
"Joe’s Cleaners","Joe Turner","55 Third St.","Burbank","CA","91502"
"Mr. T’s Ribs","","22543 Eton Ave.","New York","NY","10027"
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Each field in the file is surrounded by a delimiter which is usually the double-quote character ("). Adjacent
fields are separated by a field separator which is usually a comma (,). Each record is terminated by a carriage-
return/line-feed combination. Carriage return or line feed characters cannot be embedded within the data.

A blank field’s position in the record contains empty quotes as shown in the second field in the third record.

In the delimited ASCII format, fields are referred to by their position in the record. For example, company
name is field 1, contact name is field 2, and so forth.

SDF file
Many report generators can suppress the output of titles, headings and page numbers to print only the report
detail lines. Most mailing list companies supply mailing lists in the SDF format, called a fixed-length format,
commonly used by mainframe computers. This is a sample:

ABC Company John Smith 123 Main Street
Joe’s Cleaners Joe Turner 55 First St.
Mr. T’s Ribs 2543 Eton Ave.

Each field has a fixed starting and ending position in the record. Regardless of the length of fields before it, a
field starts and ends in the same position in every record. Since each field is padded with spaces until the
start of the next field, files employing this format are sometimes called Space Delimited Files (SDF files). Like
the Delimited ASCII format, each record is terminated by a carriage-return/line-feed combination.

Fields in the SDF format are referred to by starting and ending character positions. In the above example, the
company name field occupies positions 1-16, contact name 17-28, and the address occupies positions 29-45.

SQL file
The SQL import option is used to import SQL tables from MSSQL.

About Exporting Data

The exporting process copies data into a formatted file the receiving application understands. The Export Wizard
provides simplifies the task. Using the Export Wizard, create a data file from GoldMine records according to
criteria in a predefined profile, or define your own profile. GoldMine can export from the current database in
three formats:

= DBF file

= ASCII (TXT) file

= SDF (fixed length) file

m export data to an XML file.

Considerations for Importing and Exporting Data
When importing and exporting data:

= Only fields in the Contactl and Contact2 tables and the primary e-mail and Web site Details are available for
standard import or export. The XML import and export lets you import or export the full database.
= Merge information and check for duplicates while importing.

m Save import and export profiles to facilitate the process. A profile is predefined field mappings and specifics of
data file locations.
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= GoldMine supports the importing and exporting of calendar, history, and supplemental contact information
when using the predefined ACT! import profile or XML.

= When importing or exporting, all fields are referenced by their GoldMine field names, which can differ from
their label name. After being created, the field name never changes, though the label can be changed by the
user.
For example, the field Key1 located in the Contactl table is commonly labeled Contact Type. This means the
field would be listed as Key1 and not as Contact Type in the lists of GoldMine fields in the import and export
wizards. This is important because you might not recognize the field name as the field you want to use.

NOTE: If your import requirements include calendar, supplemental contact information, or history records,
use third-party utilities to import. Several products designed to work with GoldMine are GoldBox Utilities,
Inaport, CRMSwitch, and Beyond Gold. As third-party products, they are not supported by Ivanti Software
technical support.

Data Preparation

Before importing, establish the source file and destination file components. Do not start the importing procedure
until you create necessary fields in GoldMine.

Taking the source file, create a list of all of the field names and lengths, then manually match the GoldMine field
and its length. If the fields do not exist or are not long enough, make structural changes to the fields before
proceeding. The data should be in ASCII, SDF, SQL, or DBF format for importing.

IMPORTANT: Failure to save the file correctly could result in loss of data.

Using the Import Contact Records Wizard

1. Open the File menu and select Import and Export > Import Contact Records.
The Welcome to GoldMine's Import Wizard dialog box opens.

2. Select one option:

O Import a new file: Incoming data formats according to the profile you define in the Import Wizard. You can
save the profile for future use.

O Import a new file using an existing profile: If importing:
- DBF, ASCII, or SDF, select a profile you created on the Select File to Import dialog box.
- DBF, select an ACT profile or one you created.
- ASCII or SDF, select a profile you created.
- from SQL, the Select SQL Table to Import dialog box appears.

3. Select one option for the file type to import.

O CSV file. Text file that uses a comma to separate the values.

O ASCII file. Incoming data is in delimited text file format. A delimited text file formats data with field
delimiters, field separators, and record separators. In the delimited ASCIl format, fields are referred to by
their position in the record.

O SDF file. Incoming data is in a text file with fixed-length record format which is commonly used by
mainframe computers. Fields in the SDF format are referred to by starting and ending character positions
(see To Import a .SDF File).

O SQL file. Incoming data is from an SQL table.

4. Click Next.
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The dialog box that appears depends on the options you selected:

O Import an new file from DBF, ASCII, or SDF, the Import a New File dialog box opens.

O Import a new file from SQL, the Import a New SQL Table dialog box opens.

O Import a new file using an existing profile from DBF, ASCII, or SDF, the Select File to Import dialog box
opens.

O Import a new file using an existing profile from SQL, the Select SQL Table to Import dialog box opens.

To Import a .SDF File

After selecting the SDF file option in the Import Contact Records Wizard (see Using the Import Contact Records
Wizard), continue with the following procedure.

i wWwNR

9.

Browse to the location of the .sdf file.

Selecting file location and then click next. The Import file profile screen displays.
On the Import SDF Profile options dialog box, click the Options button.

Select LF for record separator.

Under record structure, enter the field delimiter “|“ (SHIFT + \). This will place “|” perform this between
contact, company, etc., and separate the data for field mapping.

Click Ok and preview of the separated data. If it appears correct, click Next.

On the Field Mappings dialog box, select the Import Field item and matching GoldMine Field, then click the
Map to GM button to map to the fields as desired.

You can press Back to preview the contents without disrupting or removing mappings that you have already
selected.

After all field mappings are selected and you are satisfied with the content to be imported, click Next .

10. If you want to save profile, check Yes on the Save Profile dialog box, otherwise click No.

11. Click Next to view the Ready to Import dialog box.
12. Click Finish to import the records that are listed in the SDF file.

Using the Export Contact Records Wizard

1.

GoldMine Administrator's Guide

Select File > Import and Export > Export Contact Records.

The Welcome to the GoldMine Export Wizard dialog box opens.

Select an export option:

O Export to a new file: GoldMine exports the data according to the settings defined in the Export Wizard. You
can save the new settings for future use.

O Export to a new file using an existing profile: Displays the Select Export Profile dialog box where you select
a predefined profile GoldMine will use to format the data for export.

Page 124 of 439



GoldMine™®

3. Select the file type to export into:

O ASCII (TXT) file: Specifies data will export in the delimited text file format. A delimited text file formats data
with field delimiters, field separators, and record separators. In the delimited ASCII format, fields are
referred to by their position in the record. For example, company name is field 1, contact name is field 2,
and so on.

O SDF (fixed length) file: Specifies data will export to a text file with fixed-length record format which is
commonly used by mainframe computers. Fields in the SDF format are referred to by starting and ending
character positions.

4. Click Next. If you selected:
O Export to a new file, the Select Filter/Group dialog box opens.
O Export to a new file using an existing profile,the Select Export Profile dialog box opens.

About Importing and Exporting XML Files

Import and export GoldMine contact data to or from an Extensible Markup Language (XML) format. XML is a meta
language used to facilitate the easy exchange of data between systems using different applications. Importing or
exporting your GoldMine data as an XML file helps you share information with different applications, such as
contact management systems, that support XML.

Like HTML, XML uses tags (words bracketed by < and >) and attributes (name = "value"). However, XML provides
more flexibility when interpreting the tags and values. For example, HTML specifically defines the meaning of each
tag and attribute as well as the appearance of the tagged text when displayed in a browser; XML uses tags only as
data delimiters, leaving the interpretation to the receiving application.

NOTE: When exchanging data with other GoldMine systems, be sure to synchronize with GoldMine instead
of sharing exported data. Synchronization provides features unavailable when you export data as an XML
file, including cutoff dates to limit the date range of data and the capability to exchange updates to
additional contact data and calendar data.

Use the GoldMine XML Import Wizard to import data from an XML file. The wizard takes you through the process
and lets you save the settings in a profile to reuse.

Use the GoldMine XML Export Wizard to export your contact data as an XML file. The wizard guides you through
the procedure. All the data you export is placed in one file that the recipient can import and use as a key to map
the imported data into the recipient’s database.

Exporting to XML

Export GoldMine contact data to Extensible Markup Language (XML) format. XML is a meta language is used to
facilitate the exchange of data between systems using different applications. Exporting your GoldMine data as
a.xml file helps you share information with recipients using a different contact management application
supporting XML. Data exported is placed in one file the recipient can import and use as a key to map the imported
data into the recipient’s database.
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The following is a view part of a sample XML export.

- <3ccounts>
- <account gm_recid="000000091{{{>2R" gm_accountno="ELAN SOFTWARE CORP.">
- <properties»
- zproperty name="Accnt Mngr" db_name="KEY4">
zproperty_string=C.Stott</property_string>
</property>
- <property name="Actionon" db_name="ACTIONON"=
<property_string>20021109</property_string>
</property>
- «property name="Address" db_name="ADDRESS1">
<property_string=1150 Kelly Johnson Boulevard«/property_string>
</property>
- zproperty name="Asst" db_name="SECR">
<property_string=Jane</property_strings
</property>
- <property name="Business" dbo_name="KEY2">
<property_string>=Comp. 8fw. Dev._ < /property_strings
</property>
- <property name="Callbkfreq" db_name="CALLBKFREQ">
<property_string>0</property_string=
</property>
+ <property name="City" db_name="CITY">
- zproperty name="Company" db_name="COMPAMNY">
<property_string=FrontRange Solutions Inc.</property_string=
</property>
- <property name="Contact" db_name="CONTACT">
<property_string=Patrick B. Hillyard</property_string>
</property>
- <property name="Contact Type" db_name="KE¥1">
<property_string=Internal</property_string>

NOTE: When exchanging data with other GoldMine users, synchronize with GoldMine instead of sharing
exported data. Synchronization provides features unavailable when you export data as an XML file,
including cutoff dates to limit the date range of data as well as the capability to exchange updates to
additional contact data and calendar data.

To Export GoldMine Contact Data to XML

1. Select File > Import and Export > Export GoldMine Data to an XML File. The GoldMine XML Export Wizard
opens.

O Export to a new XML file: Displays the Select GoldMine Data for Export dialog box. GoldMine exports the
data according to a profile created as you define settings in the GoldMine XML Export Wizard. You can
save the new profile for future use.

O Export to a new XML file using an existing profile: Displays the Select Profile dialog box to select a
predefined profile GoldMine will use to format the data for export.

2. Make a selection and click Next to advance to the Select GoldMine Data for Export dialog box (new .xm1 file)
or Select Profile dialog box (select an existing profile).
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To Export Data Using an Existing XML Profile
If you selected Export to a new XML file using an existing profile, the Select Profile dialog box appears.
1. Inthe Select one of the following, predefined XML export profiles text box, select the existing profile you
want to use.
2. Click Delete Profile to delete the highlighted profile.
3. After highlighting your profile, click Next. The Select GoldMine Data for Export dialog box appears

Importing XML

GoldMine can import contact data and user activities from an XML file. The GoldMine XML schema dictates how
data is arranged within the XML file in order for GoldMine to recognize contacts, calendar activities, and other
data when importing into GoldMine. The XML file you importing into GoldMine must conform to the GoldMine
XML schema for the field mapping to work. You can use XSL Transformations (XSLT) to transform XML source
documents to GoldMine-compliant XML documents.

NOTE: For more about XSLT, see http://www.w3.org/TR/xslt.

Create an XML transformation sheet converting the XML file to match the GoldMine schema. Then import the data
into GoldMine.

Example: Your XML source schema has the contact’s first name in one field and the last name in another field.
Because the GoldMine schema requires the first and last names to be in the same field, you must create a
transformation sheet merging the two fields in your source XML file. Once your source file matches the GoldMine
schema, you can import the XML data into GoldMine.

= To view the GoldMine schema, export your GoldMine data to an XML file and include the schema. Open the file
in Internet Explorer and view the schema.

= To create a transformation sheet (a language for transforming XML documents into other XML documents) and
transform the data, use Notepad or an XML transformation utility.
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Example of the first few lines of a GoldMine schema:

<%uml version="1.0" encoding="utf-8" 7>
- <xs:schema xmins:xs="http://www.w3.0rg/2001,/XMLSchema"
targetNamespace="http:/ /www . frontrange.com/goldmine /xmlexport"
srnlns="http:/ /veww frontrange.com/goldmine /xmlexport" version="1.0">
- zxs:element name="gmdata">
- «xsicomplexTypes>
- <HS!SEqQUENCE>
wsielement ref="header" minOccurs="1" maxOccurs="1" />
zus:element ref="accounts" minOccurs="0" maxOccurs="1" /=
zus:element ref="unlinked_content" minCccurs="0"
maxOccurs="1" />
</®s:sequence>
</usicomplexTypes
< s element>
- «xs:element name="header">
- <us:complexType>
- <HsisEquence>
<xsielement ref="goldmine_wversion" minOccurs="1"
maxCccours="1" /=
<us: elerment ref="gmdbdef" minJccurs="D" maxOccurs="1" />
</®s:sequence>
<fusicomplexTypes
< fmselements
zxs:element name="goldmine_version" type="xs:string" />
- zusielement name="gmdbdef">
- <xs:complexType>
- <HsisEquUEnce>
<z element ref="gmdbfld" minGccurs="0"
maxCccurs="unbounded" /=
</®5i5equences
</usicomplexTypes
= fuselemeant>

To Import GoldMine Contact Data from XML

1. Select File > Import and Export > Import GoldMine Data from an XML File. The GoldMine XML Import
Wizard appears.
2. Select one option in the GoldMine XML Import Wizard:
O Import a new file: Displays the Import a New File dialog box. GoldMine imports the data according to a
profile created as you define settings in the GoldMine XML Import Wizard.
O Import a new file using an existing profile: Displays the Select File to Import dialog box to select a
predefined profile GoldMine will use to format the data you import from.

3. Click Next to advance to the Import a New File dialog box or the Select File to Import dialog box.
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Import a New File Dialog Box

The Import a New File dialog box appears when you select Import a new file from DBF, ASCII, or SDF on the
GoldMine XML Import Wizard dialog box.

1. Inthe Enter the full path and filename of the file to be imported text box, type or browse to the path of the
.xm1 file to import.
2. Click Next.

Either the Select Data to be Imported From File or Import File Profile dialog box appears.

Importing from Other Applications

Importing Data from ACT!

GoldMine offers an import wizard to help convert ACT! data to GoldMine. Select an import method based on the
ACT! version you are importing from.

O If importing from ACT! 6.x, select File > Import and Export > Convert from ACT! 6.0. The Welcome to the
ACT! Import Wizard! opens.

O If importing from ACT! 2000 or ACT! 4 and lower, select File > Import and Export > Import Contact
Records. The Welcome to GoldMine's Import Wizard opens.

Using the ACT! Import Wizard
The ACT! Import Wizard appears when configuring ACT! data importing using one of these methods:

1. Select File > Import and Export > Convert from ACT! 6.0. The ACT! Import Wizard appears.
2. Select File > Import and Export > Import Contact Records.

NOTE: We recommend backing up your data before beginning.

3. Onthe ACT! Import Wizard dialog box, type or browse to the location of your ACT! .dbf file in the Enter the
full path and filename of the ACT! file to be imported text box.

4. Inthe User field, type the name of the ACT! user.
In the Password field, type the user's password.
6. Click Next. The ACT! Import Options dialog box appears.

Using the Outlook Conversion Wizard

The Outlook Conversion Wizard provides an easy way to convert your Outlook files (Contacts, Calendar, Tasks, and
E-mail folders) to GoldMine. This is useful when moving information from Outlook to GoldMine as your business
contact management system. The conversion wizard is an import feature and is not to be used in lieu of Outlook
synchronization.

NOTE: Outlook contact and calendar notes with rich text formatting and embedded URLs import into

GoldMine as plain text.
1. Select File > Import and Export > Convert from Outlook. The Outlook Conversion Wizard dialog box appears.
2. Click Next. The Import Options dialog box appears.

O Apply GoldMine's Formatting to phone numbers being imported: Converts the Outlook format—
commonly (719) 555-5555) to GoldMine—commonly (719)555-5555.
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O Select the username...: Select the user in the drop-down list who will become the owner of the records and
who the calendar and history activities will be assigned to.
O Select one duplicate checking option:

O Do not import duplicate records: Does not import any records where the company, contact, and phone
fields in Outlook match a GoldMine record.

O Import all record to GoldMine: Imports all selected records into GoldMine without checking for duplicate
records.
3. Click Next. The Contact Folder(s) dialog box appears.

O To select Contact folders to import, click Add. The Select Folder dialog box appears. Select a contact folder
to import and click OK. Repeat the process for each contact folder to import.

O Click Remove to delete a highlighted folder on the Contact Folder(s) dialog box.
O If not importing any contact folders, click Next without adding folders to the Folder list.
4. Click Next. The Calendar Folder(s) dialog box appears.

O To select Calendar folders to import, click Add. The Select Folder dialog box appears. Select a calendar
folder to import and click OK. Repeat the process for each calendar folder to import.

O Click Remove to delete a highlighted folder on the Calendar Folder(s) dialog box.
O If not importing any calendar folders, click Next without adding folders to the Folder list.
5. Click Next. The Calendar Options dialog box appears.
O To set the date range of calendar records you are importing, select number of days, months, years before
today for the Starting date, and the number of day, month, or year before today for Ending date.
6. Click Next. The Task Folder(s) dialog box appears.

O To select Task folders to import, click Add. The Select Folder dialog box appears. Select a task folder to
import and click OK. Repeat the process for each task folder to import.

O Click Remove to delete a highlighted folder on the Task Folder(s) dialog box.
O If not importing any task folders, click Next without adding folders to the Folder list.
7. Click Next. The E-mail Folder(s) dialog box appears.

O To select E-mail folders to import, click Add. The Select Folder dialog box appears. Select an e-mail folder to
import and click OK. Repeat the process for each e-mail folder to import.

NOTE: Imported e-mail folders and Inbox messages are categorized and filed in the E-mail Center in a
separate Outlook Import folder.

O Remove to delete a highlighted folder on the E-mail Folder(s) dialog box.
O If not importing any e-mail folders, click Next without adding folders to the Folder list.

8. Click Next. The Ready to Import dialog box appears.
9. Click Back to change any settings and then click Finish.

Exporting From Microsoft Excel to GoldMine

After GoldMine Plus for Microsoft Office is installed, data can be exported from Microsoft Excel to your GoldMine
database using new menu options in Excel.

GoldMine Plus for Office adds an export feature to the GoldMine menu in Excel. Use this menu option to map
Excel columns to GoldMine fields and initiate the export process.

IMPORTANT: Backup your database before you begin.

IMPORTANT: Using underscores ("_") in column headers may result in an error when exporting data.
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NOTE: Before proceeding with the export, verify that phone numbers are formatted consistently and make
changes as needed. The format of the phone numbers in your Excel spreadsheet must be the same for the
Excel ODBC to interpret the numbers correctly. If formats are inconsistent, the ODBC driver interprets all
the values in the column as null and you lose phone number data during the export process. For example,
you cannot have one phone number that is 1235557894 and another that is 777-555-1236. Before
exporting to GoldMine, specify one format and update all phone numbers in your spreadsheet to match the
selected format. When the phone number format is consistent, begin exporting to GoldMine.

1. Launch GoldMine.

2. Open the Excel spreadsheet you are exporting to GoldMine.

3. Select the cells you are exporting to GoldMine and specify the Named Range. In Excel, select Insert > Name >

Define. The Define Name dialog box appears. See Excel Help for details.

NOTE: To perform this function in Microsoft Office 2007/2010, select the cells to export to GoldMine, right-
click on the selected cell range and select Name a Range from the drop-down menu. You can also select the
Formulas tab, then select Define Name > Define Name from the menu.

4. Inthe Names text box, type the desired name of the range.
NOTE: The first row of the selected range must contain only header data.

5. Select either Workbook or Sheet from the Scope drop-down menu.

6. Select GoldMine > Export Data to GoldMine. The Export Data to GoldMine dialog box appears.
The Welcome to the GoldMine Plus for Microsoft Excel Export Wizard! appears.
Click Next. The field mapping dialog box appears.

To map columns to GoldMine fields, highlight the column in the Excel Fields list and then highlight the
GoldMine field to map the column to. Click Add Mapping. Your selection is added to the Mapped Fields list
(for example, Column1<=>C1.Company).

9. Continue to map desired fields. When finished, click Next. The GoldMine is now Ready to export your Excel
data! dialog box appears.

10. Click Finish.

When the import process completes, a dialog box appears, indicating the number of records imported into
GoldMine.

Importing and Exporting iCalendar Files

m Importing iCalendar Files

m Exporting iCalendar Files

Importing iCalendar Files

1. Select File > Import and Export > Import from an iCalendar file. The Windows Open dialog box appears.

2. Locate the iCalendar (*.ics) files to import and click Open. The Import from an iCalendar file dialog box
appears.
3. To import a single iCalendar activity, select the activity and click Import.

NOTE: When importing iCalendar files from Lotus Notes, GoldMine schedules activities without assigned
participants, or invitees, as unlinked. Identify this situation whenever the Organizer entry is UNKNOWN.

4. To import all activities, click Import All.
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5. As each activity is processed, the Attach imported activity to contact dialog box appears. Select one option:
O Find an existing contact and then link this activity.
O Find an existing contact, create a new additional contact and link to it.
O Create a new contact and then link this activity.
O Do not link this activity to any contact
Click OK. Depending on the option selected, different windows and dialog boxes appear.
Click Close.

Exporting iCalendar Files

Export iCalendar files so users of iCalendar-enabled applications, such as Microsoft Outlook or Lotus Notes can
import activities from your iCalendar file to their calendars.

1. Select File > Import and Export > Export to an iCalendar file. The Export to an iCalendar file dialog box
appears.
2. In the Select based on Contact(s)/User(s) area, select one:
O Activities based on Contact(s). Exports activities scheduled for the current contact record, or for records
based on the selected filter.
- Select from:

- Current Contact record: Exports the information for the current record.

- Filters/Groups: Exports information based on the filter or group selected in the drop-down list.
O Activities based on the User(s): Exports activities scheduled for selected users.

- Select the any or all users' activities to export.
In the Selection Criteria area, select the activity types to export.

To narrow the export to a range of dates, select Date range and select the From and To dates on the F2
graphical calendar.

Click Export. The Windows Save As dialog box appears.
Locate the folder to save the files to and type the File Name.
Verify the Save as type is iCalendar format (*.ics).

7. Click Save. The GoldMine Process Monitor appears displaying the progress of the export.

Merging and Purging Records

Users can accidentally create duplicate contact records in GoldMine that, over time, might be too great for manual
deletion. GoldMine provides several methods for consolidating information and deleting duplicate records (Using
the Delete Wizard):

= Merge/Purge Records Wizard. Simplifies the replacement process by guiding you through the entire procedure.

= Merge Open Records. Updates the contact record with input focus by merging information in two contact
records displayed in GoldMine’s work area.

= Merge Tagged Records. Creates one contact record by merging information from all tagged records.

IMPORTANT: Merging and purging permanently changes the database. We recommend backing up the
database first.
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Using the Merge/Purge Records Wizard

Use the Merge/Purge Wizard to select records based on a predefined profile or define your own criteria. Set up a
custom merge/purge profile by defining:

= Contact record field. Select as many as you want GoldMine to use during the evaluation process to match
records.

= Method. Select a criterion for each record match which can be case sensitive, case insensitive, Soundex, or first
n characters.

= Weight. Select and assign a numeric weight to each criterion. When a record is evaluated, each match with a
criterion accrues the assigned weight value. If the total weight earned by matches between two records and
the specified criteria equal or exceed the qualifying weight value, GoldMine selects the records as duplicates.

You can also select the method for disposing of duplicate records. Merge data from two duplicate records to
create one updated record, or delete one of the duplicates according to a condition such as deleting the older

record. Specify GoldMine process the merge/purge automatically, or display duplicate records for viewing or
manual deletion.

IMPORTANT: Merging and purging permanently changes the database. We recommend you back it up before
performing a merge/purge.

NOTE: It is highly recommended that you select Prompt me before merging records and Dry run: Only
show duplicates—do not merge nor purge before actually performing a purge.

1. Select Tools > Data Management > Merge/Purge Records > Merge/Purge Records Wizard. The GoldMine
Merge/Purge Wizard appears.

2. Select one procedure:
O Merge/Purge using a predefined profile: Displays the Select a Merge/Purge Profile dialog box containing a

list of previously defined merge/purge profiles. Highlight the profile to use to search for duplicate
records.

O Merge/Purge using new criteria: Set up weighted criteria for the current merge/purge. The settings can be

used one time only or saved as a merge/purge profile for future use.
3. Click Next.

O If you selected Merge/Purge using a predefined profile, select the profile from the Select a Merge/Purge
Profile dialog box. You can also delete a previously defined profile by selecting Delete Profile. After
selecting a profile, click Next. The Select a Filter/Group dialog box appears.

O If you select Merge/Purge using new criteria, the Select a Filter/Group dialog box appears.
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Selecting the Merge and Purge Methods

The Merge Method and Purge Method dialog boxes contain settings that determine how GoldMine treats records
selected as duplicates.

1. The Merge Method dialog box appears after selecting merge/purge criteria.
2. Select one merge method:
O Keep the record that was Created First: Selects the contact record saved first. The date is determined by
the entry logged in the Creation field of the Summary tab.
O Keep the record that was Last Updated: Selects the contact record changed last. The date is determined
by the entry logged in the Last Update field of the Summary tab.
O Create Linked Additional Contacts in each record: GoldMine keeps both records and creates additional
contacts in the Contacts tab of the duplicate records. For example, if GoldMine determines Jon Smith and
John Smyth are duplicate contacts, Jon Smith is added as an additional contact in the John Smyth contact
record. John Smyth is added as an additional contact in the Jon Smith contact record.

NOTE: Selecting Create Linked Additional Contacts does not prompt you for a purge method, but displays
the Save the Merge/Purge Profile dialog box.

3. Select one of the following options:

O Create Additional Contact of non-surviving record: The primary contact of the deleted duplicate record is
stored as an additional contact in the surviving contact record. GoldMine stores the new additional
contact in the Contacts tab of the surviving contact record.

O Prompt me before merging records: Check this box for GoldMine to display duplicate records and offer
options so the user can make individual decisions on each set of duplicate records.

O Dry run: Only show duplicates—do not merge nor purge: Check this box for GoldMine to display duplicate
records without any options to select records for purging. At the end of the process, duplicate records
remain in the contact database.

NOTE: If you select Dry run, GoldMine does not prompt you for a purge method, but displays the Save the
Merge/Purge Profile dialog box.

NOTE: It is recommended that you select Prompt me before merge records and Dry run: Only show
duplicates—do not merge or purge before actually performing a purge.

4. After selecting a merge/purge option, click Next. Unless creating linked additional contacts or performing a
dry run, the Purge Method dialog box appears.

5. Select one option:
O Delete the duplicate record: GoldMine automatically deletes records meeting the qualifying weight
specified in the merge/purge profile.
O Update a field with a value to indicate record deletion: Changes the specified field with a specified
value—selecting this option does not purge duplicate records.

TIP: Selecting Update a field with a value to indicate record deletion is the safest way to
merge/purge records. This option performs the merge based on your criteria and then marks the
non-surviving record but leaves it in your database. Review the records and delete based on the
value with which the specified field is updated.
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6. Next. The Purge Method: Update Field Settings dialog box opens.
O Update Field: Select the field in the drop-down list.
O Value: Type the value you are updating the field with to indicate deletion. If any record had an entry in the
specified field, this data overwrites the existing value.

7. Select Merge Calendar, History, and ContSupp records to move this data to the surviving contact record
from the purged record. This option moves data from these records:
O Calendar
O History
O Additional contact
O Referral
O Detail

8. Click Next. The Save the Merge/Purge Profile dialog box opens.

Merging Open Contact Records

You can merge two or more open contact records. The active contact record is updated with information from the
other record. The non-active contact is deleted.
1. Select Window > New Contact Window. A second contact window opens.

2. Display the second record you are merging. Make the record you are keeping in the database the active
contact record.

3. Select Tools > Data Management > Merge/Purge Records > Merge Open Records. The Merge/Purge Visible
Contact Records dialog box appears.

4. The dialog box reminds you that the active contact record will survive. Information from the other records
will be consolidated on the surviving record, and the other records will be deleted.

5. Click Yes.

Merging Tagged Records
You can consolidate information from all tagged contact records into one contact record.
NOTE: GoldMine updates the first tagged contact record and deletes all other tagged contact records.

1. Select the records to merge.

2. Select Tools > Merge/Purge Records > Merge Tagged Records. The Merge/Purge Tagged Contact Records
dialog box appears.

3. The dialog box reminds you that the first record tagged will be the surviving record with data from the other
records consolidated on that one record. Once consolidated, the other records are deleted.

4. Click Yes.
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Using the Delete Wizard

To update your contact database by deleting some or all Calendar records, history records, and/or contact records,
use GoldMine’s Delete Wizard to reduce the possibility of an unintentional deletion.

NOTE: Only users with Master Rights can access the Delete Wizard.

1. Select Tools > Data Management > Delete Records. The Delete Wizard appears.

2. Select one delete option:
O Delete old history records: Purges old history data from the contact database. Delete all history records
from the contact database, or activate a filter or group, then use this option to delete history records
from the subset of records.

NOTE: Removing old history records periodically can significantly reduce the amount of disk space used by
contact sets.

O ALL (filtered) contact records: Deletes a subset of records from the contact database based on a filter or
group.
3. Click Next. If you selected Delete old history records or Delete ALL, the select filter/group dialog box
appears.

Monitoring Processes

The GoldMine Process Monitor launches automatically when executing or running processes within GoldMine,
including synchronization, Automated Processes, importing and exporting, or merging and purging.

The Process Monitor can float anywhere on the GoldMine screen, or it can be docked to any of the four sides of
the GoldMine screen. The window can also be resized to maximize available workspace. For best results, dock the
Process Monitor to the bottom of the GoldMine screen.

The upper pane displays processes running and general status, while the lower pane displays the status of the
component tasks. Use the toolbar or the local menu to manage process options.

NOTE: The Process Monitor uses color codes, assigned to text or the background, to indicate process status.

Color Meaning

Black text on default background Operation normal

Blue text on default background Notice

Black text on yellow background Warning

White text on red background Error

Green text on default background Task successfully completed
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Understanding GoldMine Data Files

m GoldMine Table Structure (see page 137)
m GoldMine Tables (see page 137)

m Contact Table (see page 142)

m Rec Types (see page 150)

GoldMine Table Structure

GoldMine tables and Contact tables make up the GoldMine database, which consists of data organized in columns
and rows. Cells at any column/row can contain only one value. Columns and rows work together to define the type
of information a cell can contain.

Columns: Each column contains values providing information of one type such as Company, City, or State, and
each column represents a field. One column, or a combination of columns, is the unique index (the unique value
each record can be identified by).

Rows: Each row contains one record consisting of a set of column values. A table can contain as few as 0 rows or
an unlimited number of rows. SQL Server can retrieve data from tables by working with relationships represented
by common data values between tables. A common data value is a value that is the same between multiple tables.
For example, both a Contactl table and a Cal table contain AccountNo values. The shared value creates the
relationship between the records in the 2 tables.

GoldMine Tables

The Cal table contains a record for each scheduled activity. Different record types are distinguished by the
RecType. Each record type can use the same field for different purposes. The Cal table is part of the GoldMine files

Field Name Type Length Description

USERID String 8 User Name

ACCOUNTNO String 20 Account number of the linked contact
ONDATE Date 8 Activity date

ONTIME String 5 Activity time

ENDDATE Date 8 Ending date of a scheduled activity
ALARMFLAG String 1 Alarm flag

ALARMTIME String 5 Alarm time

ALARMDATE String 8 Alarm date

ACTVCODE String 3 Activity code
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Field Name Type Length Description

RSVP String 1 RSVP notification

DURATION Integer 3 Duration/Probability

RECTYPE String 1 Record type

ACONFIRM String 3 Meeting confirmation

APPTUSER String 10 Meeting confirmation user
STATUS String 4 The first character is flag. The second character=1 if notes exist.
DIRCODE String 10 Contact Set code of the contact file
NUMBER1 Integer 8 Sales potential

NUMBER2 Integer 8 Units of a forecasted sale
COMPANY String 60 Company/Contact name

REF String 80 Reference

NOTES Memo 1 Notes

LINKRECID String 15 Linked record ID

LDOCRECID String 15 Reserved for future use

LOPRECID String 15 Linked Opportunity Manager record ID
CREATEBY String 8 Created by user

CREATEON Date 8 Created date

CREATEAT String 6 Creation time

LASTUSER String 8 Last modified by

LASTDATE String 8 Last modified date

LASTTIME Date 8 Last modified time

RECID String 15 Record ID

= Fields5 stores the location and tab order of every field within the Fields tab and the field position and tab order
of the primary contact fields.

m Filters holds all filters created in the system.
m Forms stores the merge form template properties added to the merge forms system.
m FormsFld contains information about fields in the merge forms.

= FormsQue is a queue of mail-merged documents waiting to be sent.
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= GMTLog, with the ContTlog table, controls the synchronization process. The Primary Tlog holds the
synchronization time stamp for the tables in the GoldMine files, such as Cal, Filters, and others.

= GSLogs is the GoldSync log table.
m GSServer contains the GoldSync server settings.
m GSSites contains configuration parameters for GoldSync sites.

= InfoMine stores data from the InfoCenter. The InfoCenter is part of the GoldMine files.

Field Name Type Length Description
ACCOUNTNO String 20 Account number
CREATEBY String 8 Creation user
RECTYPE String 10 Record type
SORTKEY String 20 Sort key
TSECTION String 100 Section

TOPIC String 80 Topic

KEYWORDS String 80 Keywords
OPTIONS String 10 Options

OPTION1 String 20 Option 1
OPTION2 String 20 Option 2
LINKEDDOC Memo 1 Linked document
NOTES Memo 1 Notes

USERREAD String 8 Read access
USERWRITE String 8 Write access
LASTUSER String 8 Last modified by
LASTDATE Date 8 Last modified date
LASTTIME String 5 Last modified time
RECID String 15 Record ID

= ImpExp stores the Import/Export profiles used to export and import data.
= LeadDbfs holds leads analysis definitions set from the Go To > Analysis menu.

m Lookup contains each F2 Lookup entry. The Lookup table is part of the GoldMine files.
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Field Name Type Length Description
FIELDNAME String 11 Field name
LOOKUPSUPP String 10 Lookup Options
ENTRY String 40 Description
RECID String 15 Record ID

. Corresponding value for cross-
MASTERVALUE String 40 i L

field validation

= Mailbox stores all GoldMine e-mail. The Mailbox is part of the GoldMine files. The history display of messages
pulls information from here. If an e-mail message has an attachment, it stores in the
\goldmine\mailbox\attach folder by default.

Field Name Type Length Description
LINKRECID String 15 Linked Record ID
FLAGS String 8 Flags

USERID String 8 User name
FOLDER String 20 Folder

FOLDER2 String 20 Subfolder
ACCOUNTNO String 20 Account number
CREATEON Date 8 Creation date
MAILSIZE String 8 Mail size
MAILDATE Date 8 Mail date
MAILTIME String 8 Mail time
MAILREF String 100 :_ii::ed contact name and subject
RFC822 Memo 1 Mail message
RECID String 15 Record ID

= The OpMgr table contains the data in the Opportunity and Project Managers. The OpMgr table is part of the

GoldMine files.
Field Name Type Length Description
OPID String 15 Opportunity ID
RECTYPE String 3 Record type
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Field Name Type Length Description
ACCOUNTNO String 20 Account number
USERID String 8 User name
FLAGS String 10 Flags
COMPANY String 40 Company
CONTACT String 40 Contact
NAME String 50 Opportunity name
STATUS String 50 Status
CYCLE String 50 Cycle
STAGE String 30 Stage
SOURCE String 30 Source
F1 String 20
F2 String 20
F3 String 10
STARTDATE Date 8 Start date
CLOSEDDATE Date 8 Close date
CLOSEBY Date 8 Close by
FORAMT Float 10 For amount
FORPROB Integer 4 Probability
CLOSEAMT Float 10 Close amount
NOTES Memo 1 Notes
RECID String 15 Record ID

= OpMrgFld

= PerPhone serves as personal contacts, containing names and phone numbers. The PerPhone table is part of the

GoldMine files.

Field Name Type Length Description
RECTYPE String 1 Record type
USERID String 8 User name
STATUS String 2 International or U. S. phone format
CONTACT String 30 Contact name
PHONE1 String 16 Phone number
RECID String 15 Record ID
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= Report32 holds the report definitions and settings appearing in the Reports Menu dialog box.

= Resltems contains the resource(s) you created, such as equipment, facilities, and other resources scheduled
from the Resources' Master File. The Resltems table is part of the GoldMine files.

Field Name Type Length Description
NAME String 8 Name

CODE String 10 Code
RESDESC String 40 Description
CUSTODIAN String 8 Custodian
NOTES Memo 1 Notes

RECID String 15 Record ID

= Scripts holds telemarketing branching scripts.

= SPFiles is the directory of the GoldMine Contact Set databases. The SPFiles table is part of the GoldMine files.

Field Name Type Length Description

DIRNAM String 35 Contact file description
DITPTH String 100 Contact file path
USERID String 8 Contact file user
DIRCODE String 10 Contact Set code
DBPASSWORD String 36 Database password
DRIVER String 25 Database driver

RECID String 15 Record type

m SysLog is a global table used by all databases and processes. It records errors occurring when using the
database tables. This table can be deleted if a user is running out of disk space and the old tables are no

longer needed for troubleshooting. The system creates a new log.
= Processes holds the Automated Processes definitions.

m UserLog contains information used for each user’s Time Clock.

Contact Table

Contact1

Contactl contains the main contact fields, such as name, company, address, and the Key1 through Key5
tables. The Contactl table is part of the Contact files (The tables storing a database's contact information.
Also referred to as Common files. The CommonDir line in the GM. ini points to the default contact files).
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Field Name Type Len Description
ACCOUNTNO String 20 Account number
COMPANY String 40 Company name
CONTACT String 40 Contact name
LASTNAME String 15 Contact's last name
DEPARTMENT String 35 Department

TITLE String 35 Contact title

SECR String 20 Secretary

PHONE1 String 25 Phone 1

PHONE?2 String 25 Phone 2

PHONE3 String 25 Phone 3

FAX String 25 Fax number

EXT1 String 6 Phone extension 1
EXT2 String 6 Phone extension 12
EXT3 String 6 :;:he;()zr\:?ci)tz \i/selz(iz.:::o maintain compatibility
EXT4 String 6 Phone extension 3
ADDRESS1 String 40 Address 1
ADDRESS2 String 40 Address 2
ADDRESS3 String 40 Address 3

CITY String 30 City

STATE String 20 State

ZIP String 10 Zip code

COUNTRY String 20 Country

DEAR String 20 Dear (Salutation)
SOURCE String 20 Lead Source

KEY1 String 20 Key 1

KEY2 String 20 Key 2

KEY3 String 20 Key 3

KEY4 String 20 Key 4

KEY5 String 20 Key 5
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Field Name Type Len Description
Internal Status
O Position 1 tracks the type of phone number.
If the first character is U, the USA-style
. phone format is used.
STATUS St 3
ring O Position 2 tracks curtaining level (O=None,
1=partial, 2=full, 3=semi-partial)
O Position 3 indicates a record alert if the value
is 1.
NOTES Memo Notes
Merge codes (Three-character codes used as the
MERGECODES String 20 basis for e-mail and document merging for mass
mailings)for contact
CREATEDBY String 8 Creation user
CREATEDON Date 8 Creation date
CREATEAT String 8 Creation time
LASTUSER String 8 Last modified by
LASTDATE Date 8 Last modified date
LASTTIME String 6 Last modified time
RECID String 15 Record ID

Primary Fields Stored in the Contact1 Table

Field Name Field Label Indexed Field
COMPANY COMPANY Yes
CONTACT CONTACT Yes
DEPT DEPT No
TITLE TITLE No
SOURCE SOURCE No
LAST LAST Yes
DEAR DEAR No
SECR ASST No
ADDRESS1 ADDRESS1 No
ADDRESS2 [not displayed] No
ADDRESS3 [not displayed] No
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Field Name Field Label Indexed Field
CITY CITY Yes
STATE STATE Yes
ZIP ZIP Yes
COUNTRY COUNTRY Yes
MERGECODES MERGECODES No
PHONE1 PHONE1 Yes
EXT1 EXT No
PHONE2 PHONE2 No
EXT2 EXT No
PHONE3 PHONE3 No
EXT3 EXT No
FAX FAX No
EXT4 EXT No
KEY1 CONTACT TYPE Yes
KEY2 INDUSTRY Yes
KEY3 INTEREST Yes
KEY4 ACCOUNT MNGR Yes
KEY5 OPEN Yes

NOTE: The AccountNo and the Recld fields are also indexed fields

Contact2

Contact2 contains additional fields associated with the Contact Record, primarily the user-defined fields. The
Contact2 table is part of the Contact files (The tables storing a database’s contact information. Also referred
to as Common files. The CommonDir line in the GM.ini points to the default contact files). The fields listed
below are added during installation. Add fields to this table beginning with U.

Field Name Type Len Description

ACCOUNTNO String 20 Account number

CALLBACKON Date 8 Call back date

CALLBACKAT String 8 Call back time (unused compatibility field)
CALLBKFREQ Smallint 3 Call back frequency

LASTCONTON Date 8 Last contact date
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Field Name Type Len Description
LASTCONTAT String 8 Last contact time
LASTATMPON Date 8 Last attempt date
LASTATMPAT String 8 Last attempt time
MEETDATEON Date 8 Meeting date
MEETTIMEAT String 8 Meeting time
COMMENTS String 65 Comments
PREVRESULT String 65 Previous results
NEXTACTION String 65 Next action
ACTIONON Date 8 Next action date
CLOSEDATE Date 8 Expected close date
USERDEF01 String 10 User-defined 1
USERDEF02 String 10 User-defined 2
USERDEF03 String 10 User-defined 3
USERDEF04 String 10 User-defined 4
USERDEF05 String 10 User-defined 5
USERDEF06 String 10 User-defined 6
USERDEFO07 String 10 User-defined 7
USERDEF08 String 10 User-defined 8
USERDEF09 String 10 User-defined 9
USERDEF10 String 10 User-defined 10
USERDEF11 String 10 User-defined 11
USERDEF12 String 10 User-defined 12
USERDEF13 String 10 User-defined 13
USERDEF14 String 10 User-defined 14
USERDEF15 String 10 User-defined 15
USERDEF16 String 10 User-defined 16
RECID String 15 Record ID
ContSupp

ContSupp is the Supplementary Contact table, which contains a record for each additional contact, referral,
and detail record. The different record types are distinguished by the contents of the RecType (A record type
code identifying different types of records within the database) field. The different RecTypes can use each

field for a different purpose.
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Field Name Type Len Description

ACCOUNTNO String 20 Account number

RECTYPE String 1 Record type (see Rec Types)

CONTACT String 30 Contact name/Detail

TITLE String 35 Contact’s title/Referral’s account number

CONTSUPREE String 35 E::;Bceigﬁi;(;i;qeader name and Detail tab

DEAR String 20 Dear (salutation)

PHONE String 20 Phone

EXT String 6 Phone extension/Detail field 5

FAX String 20 Fax number

LINKACCT String 20 Linked account/Detail field 2

NOTES Memo 1 Notes/Detail header field labels

ADDRESS1 String 40 Additional contact address/Detail field 7

ADDRESS2 String 40 Additional contact address 2/Detail field 8

CITY String 30 ﬁtrjndeitional contact city/Detail user, date, and

STATE String 20 Additional contact state/Detail field 6

ZIP String 10 Additional contact zip/Detail field 4

COUNTRY String 20 Additional contact country/Detail field 3
Merge codes (Three-character codes used as the

MERGECODES String 20 basis for e-mail and document merging for mass
mailings)

STATUS String 4 Elcr):'; cez?gicter is a flag, second character=1 if

LINKEDDOC Memo 10 Linked document

LASTUSER String 8 Last modified by

LASTDATE Date 8 Last modified date

LASTTIME String 5 Last modified time

RECID String 15 Record ID

ContHist

ContHist contains records of completed activities. The ContHist table is part of the Contact files (The tables
storing a database's contact information. Also referred to as Common files. The CommonDir line in the
GM.ini points to the default contact files).
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Field Name Type Len Description
USERID String 8 User
ACCOUNTNO String 20 Account number
First character of RecType (A record type code
SRECTYPE String 1 identifying different types of records within the
database)
RECTYPE String 10 Record type (see Rec Types)
ONDATE Date 8 Action date
ONTIME String 5 Action time
ACTVCODE String 3 Activity code
STATUS String 5 Zixris;'i.character is flag, second equals 1 if notes
DURATION String 8 Duration
UNITS String 8 Forecasted sale units
REF String 65 Reference
NOTES Memo 1 Notes/Detail header field labels
LINKRECID String 15 Linked record ID
LOPRECID String 15 Linked Opportunity Manager record
CREATEDBY String 8 Creation user
CREATEDON Date 8 Creation date
CREATEAT String 8 Creation time
LASTUSER String 8 Last modified by
LASTDATE Date 8 Last modified date
LASTTIME String 5 Last modified time
RECID String 15 Record ID
ContGrps

ContGrps contains the header defining each group and the members of the groups. ContGrps table is part of
the Contact files (The tables storing a database's contact information. Also referred to as Common files. The
CommonDir line in the GM. in1i points to the default contact files).

Header Records

Field Name Type Len Description

USERID String 15 Group user
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Field Name Type Len Description
CODE String 8 Group code
Header information
ACCOUNTNO String 20 | Positions Value
1-8 “M:
15-20 Total members in group
REF String 24 Group reference
RECID String 15 Record ID/Group number
Member Records
Field Name Type Len Description
USERID String 15 Group number (from group header)
CODE String 8 Member sort value
ACCOUNTNO String 20 Linked contact account number
REF String 24 Member reference
RECID String 15 Record ID
ContUdef

ContUdef is a file specific to each database created within GoldMine. It stores name, type, and length of user-
defined fields for the database and drives the rebuilding process by recreating the GoldMine database and
working with the Fields5 table.

ContTlog

ContTlog tables hold synchronization information for the contact set. Each contact database has its own
ContTlog table. When a change is made to a contact database file (not calendar file), an entry is made in the
Tlog tables with the field information and date and time of the change. When synchronization occurs, the
Tlog tables determine what information transfers.

NOTE: The Tlog tables, for example, ContTlog and GMTlog, track (to the millisecond) the date and time of
every change to the database to provide greater reliability. The Tlog keeps track of the field-level changes
made to tables in the GoldMine database. Each Tlog record consists of two time stamps. LogStamp contains
the date and time the record was changed, while SyncStamp contains the date and time the record was last

synchronized.
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Rec Types

Rectypes are codes identifying different types of records. For example, within the Cal, ContSupp, OpMgr, and
ContHist tables in the database.

Calendar Rectypes

A Appointment

o Phone call

D To-do

E Event

F Literature Request

L Form

M Unfiled (pending) message
(o) Other Action

Q Queued e-mail

S Forecasted Sale

ContSupp Rectypes

A

Assigned Contact Alert

Additional contact

Automated Process (Event)

Linked document

Organizational structure

Detail

Extended Detail header

| xT| 9| O

Referral

OpMgr Rectypes

1st

2nd 3rd Definition

Opportunity

Opportunity Influencer

Opportunity Issue
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1st 2nd 3rd Definition

o K Opportunity Task

0] P Opportunity Competitor

0] T Opportunity Team

(o] X Opportunity Template

(0] Z Abandoned, Closed Opportunity

\") z L Lost Opportunity

o z w Won Opportunity

P Project

P C Project Influencer

P | Project Issue

P K Project Task

P T Project Team

P X Project Template

P Z Complete Project or set status to Closed/Abandoned

P Z L Lost Project (Status Lost)

P Z w Won Project (Status Won)

o Campaign (GoldMine)

C C Campaign Contact

C T Campaign Task

F P Lookup values for Competitors
ContHist

The Rectypes in ContHist are created by combining letters and by placing the letters in one of four positions.

Ist 2nd 3rd 4th Definition

A Appointment

C Phone Call

C C Call Back

o | Incoming Call

C M Returned Message
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1st

2nd

3rd

4th

Definition

Outgoing Call

To Do

Event

Literature Request

Task from Cases

-

Form

Sent Message

Email Message

Received Email

Sent Email

Other Action

10|82

Sale

Next Action

c| -

Unknown

{Space}

Successful

Unsuccessful

{Space}

Non-Private, Non-RSVP

Private

RSVP

Private and RSVP
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Dashboards Management

The Dashboards that install with GoldMine have been developed to provide you with the majority of your needs.
However, you can modify, customize, and create new Dashboards to fill the needs not met by the predefined
Dashboards (see Predefined Dashboards in the GoldMine User's Guide).

NOTE: For an overview of the Dashboard, refer to Dashboards in the GoldMine User's Guide.
Follow the links below to learn more about managing Dashboards in GoldMine.

m Sample Dashboard Tutorial

m External Database Dashboard

m Tabs and Splitters

m Dashboard Part Properties Details
m Data Source Management

m Dashboard Tables

m Dashboard Management

m Events and Actions

m Import and Export Dashboards

Sample Dashboard Tutorial

This section is a tutorial for creating a new Sample Dashboard. The examples used will take you through the
Dashboard creation process from start to finish, including initial creation, adding Splitters, Parts, and configuring
the Dashboard Parts.

For this tutorial, the Sample Dashboard will consist of the following:
m Creating a New Dashboard
m Creating a New Data Source
m Adding a Label
m Adding a Chart
m Adding a Drop-down List

After adding all the Dashboard Parts to the Sample Dashboard, you can continue to experiment by adding
additional Dashboard Parts, Splitters (see Working with Splitters), and Tabs (see Working with Tabs).
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When completed, your sample dashboard should resemble the one below.

Nashboard >

Design |

Sample Dashboard

[2n

Totnl Sales

W

Clozed Sales by Usars
B0 000
00,000
E00 000
00,000 I usER
400,000 Wmary
500010 o
2000 000
100,000

o -
LISER MARY  JOHN
Liser hiame

Creating a New Dashboard

The first step in creating a new Dashboard is to establish the Dashboard’s basic properties. This includes: the
Category, Grid Size, Name, Timer interval, and Owner of the Dashboard.

NOTE: A user must be defined as a Master user to create a new Dashboard (see "Using the User QuickStart
Wizard" in the GoldMine User's Guide or Online Help).

To Create a New Dashboard

1.

2
3.
a

GoldMine Administrator's Guide

Click the Dashboards Navigation button or choose Go To > Dashboards from the menu.

Click the Design button on the Dashboard toolbar.

Click the New button on the Dashboard toolbar.

In the Properties pane (below the Dashboard Parts Palette) enter or select the following values:
O Category: Sample

O Grid Size: 8

O Name: MyDashboard

O Timer: 0

O Owner: (none)

Click the Save button on the Dashboard toolbar.
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The new blank Dashboard canvas is now ready to add Dashboard Parts.

Creating a New Data Source

For many Dashboards that you create, you can use one of the many predefined Data Sources that come with
GoldMine. For this example, you want to use a Data Source that does not exist in the predefined data sources:

Closed Sales by Users. The following procedure demonstrates how to create a new Data Source.

To Create a New Data Source

1.

2
3.
a

Click New Data Source link at the bottom of the Dashboards Objects panel.

Morslay. Sepierba 58 2008 X 20 pm

Select Closed sales for the Type of data and Start with blank data source for the Creation Method.

Click Next to view the General Properties page.
Enter the following:

O Name: Closed Sales by Users

O Security level: None

O Owner: (public)

O Output type: Table

Click Next to view the Select page.

Click the Add button to view the Add/Edit Field dialog box.

Enter the following:

O Field: Amount

O Aggregation: SUM

O Column name: Amount
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Click OK to return to the Select page.
Click the Add button to view the Add/Edit Field dialog box.
10. Enter the following:
O Field: CONTHIST(h).USERID
O Column name: USERID
11. Click OK to return to the Select page.
12. Click Next to view the Predefined Search Criteria dialog box. No changes are needed at this time.
For additional information, see About Adding Predefined Search Criteria.
On the Predefined Search Criteria screen of the New Data Source Wizard, you can add predefined search
criteria to the list by clicking the Add button.

NOTE: When using the Begins, Contains, or In Operator options, you must write the criteria Value in correct
SQL expression form (such as %value)

13. Click Next to view the Runtime Parameter dialog box.
14. Click Add to view the Add/Edit Runtime Search dialog box and enter the following:
O Name: User
O Select Field Based
O Logical: AND
O Field: CONTHIST(h).USERID
O Operator: Equal to
15. Click OK and then click Next.
In the Group by / Order by dialog box, CONTHIST(h).USERID already appears in Group by list.
16. Open the Sort by drop-down lists and select:
O Amount for the category
O descend for the method
17. Click the Add button.
18. Click Next to review the SQL query code.
O If you want to validate the code, click the Check button.
O If you want to preview the query output, click the Preview button.
19. Click Finish.

About Adding Predefined Search Criteria

On the Predefined Search Criteria screen of the New Data Source Wizard, you can add predefined search criteria
to the list by clicking the Add button.

NOTE: When using the Begins, Contains, or In Operator options, you must write the criteria Value in correct
SQL expression form (such as %value)

Add/Edit Predefined Search Criterion

Logical: Fladd: Orpersbor e

[ ex ][ canca
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Adding a Label

The Label Dashboard Part is typically used to add heading and other title text on the Canvas. Additional
functionality can be set to the label, but for this example the Label will be used strictly as reference text on the
Dashboard.

Adding the Label requires that you first add the Label Dashboard Part and then set the Label Properties.

To Add a Label Dashboard Part
1. Click and drag the Label Dashboard Part from the Palette to the upper-left corner on the canvas.
2. Use the Arrow keys on the keyboard to move the Label, or place the cursor on the part and then click and
drag the part to refine the location.
NOTE: You can use the canvas’ grid points to help align the various components on the Canvas.

3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then
click and drag the resize point to the desired size.

To Set the Label Properties
4. Click the Label Dashboard Part to select it.
5. Inthe Properties pane, make the following changes:

Appearance
O BackColor: Window
O Font: Arial, 12, Bold
O Horizontal Align: Left
O Multiline: False
O TextColor: RoyalBlue.
O Vertical Align: Top
Data
O DataBinding: False,,,,,0
General
O Name: labell
O Text: Sample Dashboard
O Value: <blank>
Layout
O Anchors: False, False, False, False
Click the View button to preview the Label.
Click the Design button to return to the Designer.
Make any changes to the size or position of the Label and preview it again until satisfied.
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Adding a Chart

The Chart for the Dashboard provides visual representation of your data. The example Chart created using this
tutorial is a Bar chart that displays Users and Sales totals.

Adding a Chart consists of the following tasks:

m To Add a Chart Dashboard Part
m To Set the Chart Properties

m To Bind Data to the Chart

m To Create a Stacked Chart

To Add a Chart Dashboard Part

1. Click and drag the Chart Dashboard Part from the Palette to the upper-left corner on the canvas below the
Label.
Leave enough room between the Label and the Chart. You will need to have enough space to insert a Drop-
down List (see To Add a Drop-down List Dashboard Part) later in this tutorial.

2. Use the Arrow keys on the keyboard to move the Chart, or place the cursor on the part and then click and
drag the part to refine the location.

NOTE: You can use the canvas’ grid points to help align the various components on the Canvas.

3. the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and
drag the resize point to the desired size.

Chart properties must be set after adding the Chart (see To Set the Chart Properties).

To Set the Chart Properties
1. Click the Chart Dashboard Part to select it.
2. Inthe Properties pane, make the following changes:
Property

O 3D Depth: 20

O 3D Mode: True

O Back Color: Control

O Color Scheme: Solid

O Colored Values: True

O Girdlines: None

O Inside Color: Window

O Key Axis Title: User Name
O Stacked: No

O Title: Closed Sales by Users
O Value Axis Title: Total Sales
O View Mode: Bar

Data

O DataBinding: Closed Sales by Users (see To Bind Data to the Chart)
O Retain Source Order: True
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Format

O Keys: None

O Keys Decimals: 0
O Values: Number

O Values Decimals: 0

General
O Name: Closed Sales Chart
Layout
O Anchors: False, False, False, False
3. Click the View button to preview the Chart.
Click the Design button to return to the Designer.

5. Make any changes to the size or position of the Chart and preview it again until satisfied.

To Bind Data to the Chart

1. Click the ellipsis button (...) to the right of the Data Binding field.
2. Click the Mode tab and select Multiple Series in Multiple Columns.
3. Click the Details tab and set the following:

O Data source category: Closed sales

O Data source: Closed Sales by Users

O Data are summarized by: USERID

O Summarized values: Amount

4. Click OK to set the Chart Data Binding.

To Create a Stacked Chart

A typical chart is defined by X and Y coordinates (Key and Values) as defined in the Action’s Properties (see
Viewing the Events and Actions Dialog Box). You can also create a “stacked” chart, like the one located on the
Closed sales tab on predefined Lead Dashboard. A “stacked” chart is one that uses the Series field, which is
defined on the Action’s properties for a Drill down Action.

When you want to create a “stacked” chart you must set options on the Action’s Properties and Chart Data

Binding Properties dialog boxes.

Action’s Properties

Runtime Parameter 2: Success

Set value

() Predefined value

(*) Runtime { from part ) Closed Sales By Source w | Field: |Series v

[ Ok ] I Cancel

m On the Action’s properties dialog box:

O Select any Action from the drop-down list that contains the options to set the Runtime Parameter(s).
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- Refresh a dashboard part based on user selection
- Set runtime parameter for a dashboard part without refreshing
- Drill Down
O In the Runtime Parameter area, select the Runtime (from part) option.

O Select Series from the Field from drop-down list (right-click the dashboard part, select Event to add/edit
the action.

Chart Data Binding Properties

Chart Data Binding

Mode | Details
Data source category: _Chsed sales b
Data source: _Clnsad sales by source_EPDTYTA{/&™:~Z! bt |
Diata are summarized by: .5m_|p\c|-: W .
Sunmmarizing key legends {optional): .S«D{_IRCE v
Summarized values: Amount w

If the source contains multiple series of data, specify the Following options.

Series distinguishing Field {optional): .Resm v
Series legends (optional): .Resl_.: v
| ok || cancel

= On the Chart Data Binding dialog box, click the Details tab:

O Set the Series distinguishing (optional) field as Result.
O Set the Series legends (optional) field as Result.

Adding a Drop-Down List
The Drop-down list allows you to select which product you want to view in the Chart. Place the list in an easily
accessed and visible location.
m To Add a Drop-Down List Dashboard Part
m To Create a New Data Source for Drop-Down List
m To Bind Data to the Drop-Down List
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To Add a Drop-Down List Dashboard Part

1. Click and drag the Drop-down List Dashboard Part from the Palette to the upper-left corner (below the Label)
on the canvas.

2. Use the Arrow keys on the keyboard to move the Drop-down List, or place the cursor on the Drop-down List
and then click and drag the part to refine the location.

3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then
click and drag the resize point to the desired size.

4. Inthe Properties pane, make the following changes:
General
O Name: ProductLineList

After adding the drop-down list, you must create a new data source and bind data to the drop-down list. See To
Create a New Data Source for Drop-Down List and To Bind Data to the Drop-Down List.

To Create a New Data Source for Drop-Down List
1. Click New Data Source link at the bottom of the Dashboards Objects panel.

2. Onthe New Data Source window, select Manually typed for the Type of data and Start with blank data
source for the Creation Method.

3. Click Next to view the General Properties page.
Enter Product Lines - Demo for the Name, then click Next to view the Runtime Parameter page.
Click Next to view the Query page and enter the following text:
Select distinct ProductLine from Accounting..Inventory order by ProductLine
O To validate the code, click the Check button.
O To preview the query output, click the Preview button.
6. Click Finish.

After creating the data source for the drop-down list, you must bind data to the drop-down list (see To Bind Data
to the Drop-Down List).

To Bind Data to the Drop-Down List
1. Select the Drop-down List on the Dashboard.
2. Inthe Properties panel, expand the Data Binding section.
3. Set the following options:
O Data Category: Manually typed
O Data Source: Product Line - Demo
O Text field: ProductLine
O Value field: ProductLine
4. Click View to preview the Dashboard.

The drop-down list is now functional, but the data does not yet filter based on the drop-down selection. An
Event must be added to complete the drop-down list functionality (see Adding an Event to the Drop-Down
List).

5. Click the Design button.
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Add the “All” Option to the Drop-Down List

If you want to add the “All” option to the drop-down list, you will need to enter a more complex SQL query on the

Query tab for the data source (see To Edit a Data Source).

The following example uses information based on a GoldMine database:

select 'Al11' as [text],

union

select USERNAME as [text], USERNAME as [value],
order by [order],

External Database Dashboard

'<<__INACTIVE_STATE__>>' as [value], 0 as [sort_index]

[text]

1 as [sort_index] from USERS

Dashboards are not limited to linking and displaying data from only the GoldMine database. Data that you have in
other SQL databases can be linked to and used to display on a Dashboard. You can create a new Dashboard
specifically for the data, or add parts to an existing Dashboard for the desired data.

NOTE: The SQL login must have “read” permissions on the database to display the results in the Dashboard.

For this example, we will create a Dashboard that displays the individual Product inventory levels for all products
stored in an MSSQL database outside of GoldMine. To do this, we will create a new Dashboard with a Chart and

Drop-down List, and then link it to an external SQL database.

Our sample database (Accounting) and table (Inventory) contains a list of products sorted by product type and

product.
Product Quantity ProductLine
Nano 32 iPod
Touch 44 iPod
Droid 43 Phones
Super Mario 14 Games

You can use this database example as a reference when mapping the fields in your own database.
Following is a list for creating the new External Database Dashboard.

m Creating a New Dashboard

= Adding a Label

m Creating a New Data Source for the Chart

m Adding a Chart

m Adding a Drop-Down List

m Adding an Event to the Drop-Down List
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Creating a New Dashboard

The first step in creating a new Dashboard to display your external data is to establish the Dashboard’s basic
properties. This included, the Category, Grid Size, Name, Timer interval, and Owner of the Dashboard.

NOTE: A user must be defined as a Master user to create a new Dashboard (see "Using the User QuickStart
Wizard" in the GoldMine User's Guide).

To Create a New Dashboard
1. Click the Dashboards Navigation button or choose Go To > Dashboards from the menu.
2. Click the Design button on the Dashboard toolbar.
3. Click the New button on the Dashboard toolbar.
4. Inthe Properties panel (below the Dashboard Parts Palette) enter or select the following values:
O Category: Sample
O Grid Size: 8
O Name: ExternalData
O Timer: 0
O Owner: (none)
5. Click the Save button on the Dashboard toolbar.
The new blank Dashboard canvas is now ready to add to the Dashboard Parts

Adding a Label

The Label Dashboard Part is typically used to add heading and other title text on the Canvas. Additional
functionality can be set to the label, but for this example the Label will be used strictly as reference text on the
Dashboard.

m To Add a Label Dashboard Part
m To Set the Label Properties

To Add a Label Dashboard Part
1. Click and drag the Label Dashboard Part from the Palette to the upper-left corner on the canvas.

2. Use the Arrow keys on the keyboard to move the Label, or place the cursor on the part and then click and
drag the part to refine the location.

NOTE: You can use the canvas’ grid points to help align the various components on the Canvas.

3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then
click and drag the resize point to the desired size.

After adding the label, you must set the label properties (see To Set the Label Properties).

To Set the Label Properties
1. Click the Label Dashboard Part to select it.
2. Inthe Properties pane, make the following changes:
General

O Text: Accounting Dashboard
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3. Click the View button to preview the Label.
4. Click the Design button to return to the Designer.
5. Make any changes to the size or position of the Label and preview it again until satisfied.

Creating a New Data Source for the Chart

For the external database linking example, we want to link to a different SQL Database. The following procedure
demonstrates how to create a new Data Source for the external database.

To Create the New Data Source
1. Click New Data Source link at the bottom of the Dashboards Objects panel.

2. Onthe New Data Source window, select Manually typed for the Type of data and Start with blank data
source for the Creation Method.

3. Click Next to view the General Properties page.
4. Enter Accounting Demo for the Name, then click Next to view the Runtime Parameter page.
5. Click the Add button to view the Add/Edit Runtime Parameter dialog box.
NOTE: The Runtime Parameter expression will enable the product line to be selected by the end user when
viewing the Dashboard.
6. Enter ProductLineParam for the Name.
7. Select the Custom option and perform the following:
O Open the Logical drop-down list and select: AND
O Enter the following Expression: ProductLine = '<<VALUE>>'
Click OK and then Next to view the Query dialog box.
Enter the SQL query statement in the upper text box:
O Start with a basic SQL query that returns a list of product and their corresponding quantities.
Select Product, Quantity from Accounting..Inventory order by product
Where “Accounting” is the name of the external SQL database and “Inventory” is the TableName.
O Then we add the "Where" clause that will enable the runtime parameter to be used:
Where 1=1 <<ProductLineParam>>

O Finally note that additional parameters can be used, for example to enable multiple drop-down lists in a
single dashboard. For example:
Where 1=1 <<ProductLineParam>> <<Parameter2>> <<Parameter3>>
Each of these additional parameters (Parameter2, Parameter3) must be set up in the Data Source, on
the Runtime Parameters tab.

O The final SQL query should resemble the one below:
Select Product, Quantity from Accounting..Inventory Where 1=1 <<ProductLineParam>>
<<Parameter2>> <<Parameter3>> order by product
10. To validate the code, click the Check button.
11. To preview the query output, click the Preview button.
12. Click Finish.
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Adding a Chart

The Chart for this Dashboard is used to give you a visual representation of the your data. For the example, the
Chart will be a Bar chart representing Item and Count totals for Inventory.

m To Add a Chart Dashboard Part

m To Bind Data to the Chart

To Add a Chart Dashboard Part
1. Click and drag the Chart Dashboard Part from the Palette to the upper-left corner on the canvas.
2. Use the Arrow keys on the keyboard to move the Chart, or place the cursor on the part and then click and
drag the part to refine the location.

NOTE: You can use the canvas’ grid points to help align the various components on the Canvas.

3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then
click and drag the resize point to the desired size.

After adding the part, you must bind the data to the chart (see To Bind Data to the Chart).

To Bind Data to the Chart
1. Select the Chart on the Dashboard.
2. Inthe Properties panel, scroll down to the Data section and click the ellipses (...) button next to Data Binding.
3. On the Data Binding dialog box, click the Details tab.
4. Make the following changes:
O Data source category: Manually typed
O Data source: Accounting Demo
O Data are summarized by: Product
O Summarizing key legends: Product
O Summarized values: Quantity
Click OK to apply the changes.
Click View to preview the chart.
Click Design to return to the Dashboard Designer.

Adding a Drop-down List

The Drop-down List will be used to select the data (in this case User) which displays in the Chart.
Adding the Drop-down List has three main parts:
m To Add a Drop-down List Dashboard Part

m To Set the Drop-down List Properties
= To Add an Event to the Drop-down List

To Add a Drop-down List Dashboard Part

1. Click and drag the Drop-down list Dashboard Part from the Palette to the upper-left corner (below the Label)
on the canvas.
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2. Use the Arrow keys on the keyboard to move the Drop-down list, or place the cursor on the Drop-down List
and then click and drag the part to refine the location.

NOTE: You can use the canvas’ grid points to help align the various components on the Canvas.
3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then

click and drag the resize point to the desired size.

4. Continue to the next step: To Set the Drop-down List Properties.

To Set the Drop-down List Properties
1. Click the Drop-down List Dashboard Part to select it.
2. Inthe Properties pane, make the following changes:
Data

O DataBinding
- Data Category: Manually typed

- Data Source: List of users
- Text field: text

- Value field: value
General
O Name: User Filter
O Tab order
Layout
O Anchors: False, False, False, False
Click the View button to preview the Drop-down List.
Click the Design button to return to the Designer.

Make any changes to the size or position of the Drop-down List and preview it again until satisfied.

AN L S

Continue to the next step: To Add an Event to the Drop-down List.

To Add an Event to the Drop-down List

1. Select the Drop-down List.

2. Click the Events button to view the Events and Actions dialog box.

3. Enter the following:
O Select Dashboard Part: User Filter
O Event: State changed

4. Click the Add button to view the Action’s Properties dialog box, and enter the following:
O Action: Refresh a dashboard part based on user selection
O Update Dashboard Part: Closed Sales Chart
O Data Source: Closed Sales by Users
O Runtime Criteria: User
O Select Runtime (from part): User Filter and Field: Value

5. Click OK to return to the Events and Actions dialog box, then click OK to close the box.
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Adding an Event to the Drop-Down List

When the drop-down list is used, the Chart needs to update based on the selection made in the drop-down list. A
Event must be added to refresh the Chart based on the drop-down list selection.

To Add an Event to the Drop-Down List

1. Right-click the drop-down list and select Events from the menu.

2. On the Events and Actions dialog box, click the Add button.

3. Onthe Actions’s properties, part, event - State changed dialog box, set the following options:
O Action: Refresh a dashboard part based on user selection
O Update dashboard part: chart2 (actual chart name might be different)
O Data source: Accounting Demo
O Runtime Parameter: ProductLineParam
O Runtime (from part) ProductLineList and Field: Value

NOTE: The actual part names might be different than those listed depending on the order of parts added.

4. OKto close the Action’s properties dialog box.
5. Click OK to close the Events and Actions dialog box.
6. Click View to preview the Dashboard.

NOTE: You might need to close the Dashboards and reopen again to refresh the Dashboards and view the
new Dashboard functionality.

Tabs and Splitters

Tabs and Splitters are elements that you can use to further define the Dashboard. Tabs can increase the usable
area on the Dashboard by switching between the tabs to display different data. Splitters are horizontal and vertical
bars used to define and segregate regions of the Dashboard for easier viewing.

For more information, see Working with Tabs and Working with Splitters.

Working with Tabs

The Dashboards can be defined by adding tabs. Tabs act like a Dashboard within the current Dashboard and allow
you to add additional Parts on individual tabs that might not otherwise fit on your canvas. Tabs can be labeled and
setup according to the type of information that you view. For example, you might have a tab that displays
information about your leads while another might show your forecasted sales.

NOTE: Tabs can be added to the canvas or the regions inside of splitters. If you want to tab the full
Dashboard canvas, add the tabs before you add the splitters. Otherwise, the tabs will apply to the region
within the splitters.

To Create a Tab
1. Create a new Dashboard or edit an existing one (see Creating a New Dashboard).
2. Right-click and select Change to tab frame from the context menu.
3. Enter a name for the tab in the highlighted tab label.
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4. To add more tabs, right-click in the tab and select Add tab again.

5. Click Save to save your changes.

To Rename a Tab
1. Inthe Dashboard Designer, select the tab you want to rename.
Place the cursor over the highlighted tab, right-click, and then select Edit tab from the context menu.
Enter the new tab name in the highlighted text box.
Press the Enter key or click anywhere outside the tab.

vk wN

Click Save to save your changes.

To Delete a Tab
1. Inthe Dashboard Designer, select the tab you want to delete.
2. Place the cursor over the highlighted tab, right-click, and then select Delete tab from the context menu.
3. Repeat this process for any other tabs you want to delete.
4. Click Save to save your changes.

NOTE: If there is only one tab on the tabbed frame, deleting this tab will also delete the frame.

To Delete All Tabs
1. Inthe Dashboard Designer, move the cursor to the tabbed area of the frame you want to delete.
WARNING: Deleting the tabbed frame also deletes all the associated tabs and Dashboard Parts
within that tabbed frame. Be sure you want to delete the tabbed frame as there is no undo for
this command.
2. Right-click and select Delete from the context menu.
3. Click Save to save your changes.

Working with Splitters

A splitter is a horizontal or vertical line used to visually divide the canvas into separate areas. Unlike parts, splitters
are added from the context menu. A splitter can be moved and deleted after it has been added. After an area has
been defined by splitters, you can then add Dashboard Parts and Tabs (see Working with Tabs).

To Add a Splitter
1. Place the mouse in the approximate area where the splitter will be placed.
2. Right-click and select one of the following from the context menu:
O Add horizontal splitter
O Add vertical splitter
3. Add additional splitters as desired.
4. Click the Save button to save your changes.
NOTE: The first splitter added extends to the limits of the canvas. Subsequent splitters divide only the area

where they are added. If you add a horizontal splitter and then add a vertical splitter, the vertical splitter
will only divide the half of the canvas where you initiated the command.
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To Move a Splitter
1. Place the mouse over the splitter. The cursor changes to the to the reposition cursor.
2. Click and hold the Left-Mouse button and move the splitter to the desired location.

3. Repeat this process to move any other vertical or horizontal splitter.

Any adjoining splitters automatically adjust to the movement of other splitters.

To Delete a Splitter
1. Place the mouse over the splitter. The cursor changes to the to the reposition cursor.
2. Right-click and select Delete from the context menu.
3. Repeat this process to delete any other vertical or horizontal splitter.
Any adjoining splitters automatically adjust to the movement of other splitters.

4. Click the Save button to save your changes.

Dashboard Part Properties Details

The Properties, located below the Dashboard Parts Palette, displays the properties and values for the currently
selected Dashboard Part. The Properties pane is where you can establish, view, and modify the various properties
for the selected Dashboard Part. Depending on the property type, you can change the property values by entering
them manually, selecting from a drop-down list, or by opening a dialog box.

For more information, see the following topics:

m Setting the Dashboard Part Properties
m Types of Charts

Setting the Dashboard Part Properties

After you add the Dashboard Part to the Canvas, you must configure properties for the part. Some properties are
mandatory for a specific Part, while others are optional. The properties of the Dashboard Part vary depending on
the part.

The following Dashboard Parts are listed with their associated properties as a reference.

m Label Properties

m Button Properties

m Check Box Properties

m Radio Button Properties
m Link Properties

m Text Box Properties

m Drop-down list Properties
= Web View Properties

m Chart Properties

m Table View
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m Date Picker

Selecting one of the Property field, displays a description for the field displays in the panel at the bottom of the
pane. Selecting the text box to the right of the Property field, activates the field editing for the property.

For examples of adding some of these parts, refer to the Sample Dashboard Tutorial.

Notes About Data Binding Properties

= General > Text and General > Value fields are applicable only if no data binding has been configured. If a data
source is selected, then DataBinding > Text Field and DataBinding > Value Field are used instead. This is
applicable for all controls which have General > Text and General > Value properties

m Link control uses two value fields: Primary Key and Secondary Key. If Data Binding is not used, only the Primary
Key is available and aliased as General > Value.

Label Properties

Property Description

Appearance

O Back Color Background color

O Font Label font style

O Horizontal Align Horizontal position of the text

O Multiline Display text on multiple lines

O TextColor Color of the text

O Vertical Align Vertical position of the text

Data

O DataBinding Data binding information for the Label

) Data from selected data source will be exclusive (private) for this
QO Exclusive Data

part or not.
O Data Category Bound category of the data source
O Data Source Bound data source based on Data Category
O Text field Field the Dashboard Part displays
O Value field Value the Dashboard Part stores
O Row Row the label shows
General
O Name Name of the Dashboard Part
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Property Description

O Text Dashboard Part text

O Value Dashboard Part value

Layout

O Anchors Edge definitions that bound the Dashboard Part.

Button Properties

Property

Description

Data

O DataBinding

Data binding information for the Dashboard Part

QO Exclusive Data

Data from selected data source will be exclusive (private) for this

part or not.
QO Data Category Bound category of the data source
O Data Source Bound data source based on Data Category
O Text field Field the Dashboard Part displays
QO Value field Value the Dashboard Part stores
O Row Row the Dashboard Part shows
General
O Name Name of the Dashboard Part
O Tab order Order of the Button tabs
O Text Dashboard Part Text label
O Value Dashboard Part value
Layout
O Anchors Edge definitions that bound the Dashboard Part.

Check Box Properties

Property

Description

Appearance
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Property Description
O Back Color Background color
Data

O DataBinding

Data binding information for the Dashboard Part

QO Exclusive Data

Data from selected data source will be exclusive (private) for this
part or not.

O Data Category Bound category of the data source
O Data Source Bound data source based on Data Category
O Text field Field the Dashboard Part displays
O Value field Value the Dashboard Part stores
O Row Row the Dashboard Part shows
General
O Name Name of the Dashboard Part
O Tab order Order of the Check Box tabs
O Text Dashboard Part Text label
O Value Dashboard Part value
Layout
O Anchors Edge definitions that bound the Dashboard Part.

Radio Button Properties

Property Description
Appearance

O Back Color Background color
Data

O DataBinding

Data binding information for the Dashboard Part

QO Exclusive Data

Data from selected data source will be exclusive (private) for this
part or not.

O Data Category

Bound category of the data source
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Property

Description

O Data Source

Bound data source based on Data Category

O Text field Field the Dashboard Part displays

O Value field Value the Dashboard Part stores

O Row Row the Dashboard Part shows
General

Group

Group of the Dashboard Part

Name

Name of the Dashboard Part

Order of the Check Box tabs

O
O
O Tab order
O
O

Text Dashboard Part Text label
Value Dashboard Part value
Layout
O Anchors Edge definitions that bound the Dashboard Part.

Link Properties

Property

Description

Appearance

Back Color

Background color

Font

Label font style

Horizontal position of the text

Multiline

Display text on multiple lines

TextColor

Color of the text

O
O
O Horizontal Align
O
O
O

Vertical Align

Vertical position of the text

Data

O DataBinding

Data binding information for the Label

QO Exclusive Data

Data from selected data source will be exclusive (private) for this
part or not.

O Data Category

Bound category of the data source
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Property

Description

O Data Source

Bound data source based on Data Category

Q Text field

Field the Dashboard Part displays

O Primary Key

Data Source’s field that contains the Primary Key for destination

O Secondary Key

Data Source’s field that contains the Secondary Key for
destination

O Row

Row the label shows

O Destination

Hyperlink destination information (see About Dashboard Link
Data Destinations)

O Primary

Displays what will open

O Secondary

Name of the corresponding tab (Pending, History, etc.)

General

O Name Name of the Dashboard Part

O Text Dashboard Part text

O Value Dashboard Part value

Layout

O Anchors Edge definitions that bound the Dashboard Part.

About Dashboard Link Data Destinations

Following is a list of all available primary and secondary destinations with corresponding key field names.

Destination Corresponding Field
Contact accountNO
Opportunity recid

Project recid

Case recid

Calendar Activity recid

Activity recid

E-mail Message recid

Campaign recid
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Destination Corresponding Field

Document Template recid

InfoCenter recid

Leads recid

Dashboards Dashboard

GoldMine Help Topic-specific marker (see Online Help Topic Markers)
Web Resource URL

Online Help Topic Markers

The Online Help for GoldMine is context-sensitive. What that means is that certain topics in the Online Help have
special markers that allow GoldMine to link directly to those topics when used in context. You can benefit from
this ability by linking directly to specific topics from the Dashboard when using the Link dashboard part (see Link
Properties ) and configuring the properties accordingly.

To Configure the Link

Set the Destination > Primary field to GoldMine Help. Then, enter the Help Link Code for the desired topic in the
General > Value field.

For example the H-Dashboards value opens the GoldMine Online Help to the main Dashboards topic.

= Data
+ Data Binding Faks,,.... 0
= GoldMine Help, [empty)
Prirnary GoldMine Help  ffm—

Secondary [Emphy]
- General
Name label3
Text Link
Walue H_Dashboards

The following topic lists all of the topic-specific Link Code Values currently available in the GoldMine Help.

Topic-Specific Help Link Code Values Found in GoldMine

Help Link Code GoldMine Help Topic
H_Activities_NavPane Activities

H_AutomatedProcesses Automated Processes

H_BackupDB Backing Up Databases
H_Calendar_NavPane Calendars

H_CalendarOptsFBTab Calendar Options Dialog Box, Free/Busy Tab
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Help Link Code

GoldMine Help Topic

H_CalendarOptsPubTab

Calendar Options Dialog Box, Publishing Tab

H_Campaigns_NavPane

About the Campaign Management Center

H_ChangePassword

To Change Your Password

H_CompForecastSales

Completing Forecasted Sales

H_ConfigemailOpts

Configuring E-mail Options

H_Contact_NavPane

Contact Management

H_ContactSearchCenter

Accessing the Contact Search Center

H_ContactSetDB

About Contact Set Databases

H_CopyMoveRecords

Using Copy/Move Records

H_CreateActions

Creating Actions

H_CreateCustomScr

Creating Custom Screens

H_CreateDatabase

About Creating Databases

H_CreateDistLists

Creating Distribution Lists

H_CreateEmailRules

Creating E-mail Rules

H_CreateEmailTemplates

Creating E-mail Templates

H_CreateGMViewTemplates

Creating GM+View Templates

H_CreateMtgRequests

Creating Meeting Requests

H_CreateSQL

Creating SQL Databases

H_CreateTriggers

Creating Triggers

H_Dashboards

Dashboards

H_DefineContactSetProfile

Defining Contact Set Profiles

H_DeleteContactRecs

Deleting Contact Records

H_DigitallD

Using Digital IDs with E-mail Messages

H_DocMgntCenter

About the Document Center

H_EditFieldProps

Editing Field Properties

H_EmailAcctProps

Setting E-mail Account Properties

H_F2Lookup

F2 Lookup Lists

H_FirstTopic

GoldMine Help Start Page

H_GlobalReplaceWiz

Globally Replacing Field Data

H_GMProcessMonitor

Monitoring Processes
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Help Link Code

GoldMine Help Topic

H_GMViewTab

About the GM+View Tab

H_GoldMinePlus

GoldMine Plus for Microsoft Office

H_GoldSync

About GoldSync

H_GoldSyncAdminCntr

Using the GoldSync Administration Center

H_HistoryTab

About the History Tab

H_ImportContactRecords

Using the Import Contact Records Wizard

H_ImportData

About Importing Data

H_KnowledgeBase_NavPane

Knowledge Base

H_LaunchGM

Launching GoldMine

H_LeadsAnalysis

Using Leads Analysis

H_Leads_NavPane

About the Leads Management Center

H_Licensing

Licensing

H_LoginTabPrefs

Setting Options for the Login Tab

H_Mail_NavPane

Contact Communication

H_MaintainDB

About Maintaining Databases

H_MergePurge

Merging and Purging Records

H_NewfFilter

Creating Filters

H_NewGroup

Creating a New Group

H_Opportunities_NavPane

Using the Opportunity Manager

H_Outlookintegration

Outlook Integration

H_PredefinedDashboards

Predefined Dashboards

H_Projects_NavPane

Using the Project Manager

H_RecordTypes

Record Types

H_RecordTypesAdminCntr

Using the Record Types Administration Center

H_RetrievingEmail

Retrieving E-mail

H_SchedActBusyFree

Scheduling Based on Contact’s Free/Busy Times

H_SchedForcastSales

Scheduling Forecasted Sales

H_SchedMtgRequests

Scheduling from Meeting Requests

H_SchedRecurAct

Scheduling Recurring Activities

H_SendEmailMulti

Sending E-mail to Multiple Recipients
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Help Link Code

GoldMine Help Topic

H_Service_NavPane

Service Center

H_SIctResourceToAddDialog

Select a Resource to Add Dialog Box in My GoldMine

H_SyncMSOLPalmPktPC

About Synchronizing with Microsoft Outlook, or a Pocket PC Device

H_TerritoryRealignment

About Territory Realignment

H_UsingEmailTemplates

Using E-mail Templates

H_UsingKB Accessing the Knowledge Base
H_Weblmport Web Import
Text Box Properties
Property Description
Data

O DataBinding

Data binding information for the Dashboard Part

QO Exclusive Data

Data from selected data source will be exclusive (private) for this

part or not.
O Data Category Bound category of the data source
O Data Source Bound data source based on Data Category
O Text field Field the Dashboard Part displays
O Value field Value the Dashboard Part stores
O Row Row the Dashboard Part shows
General
O Multiline The editbox it multiline (true/false)
O Name Name of the Dashboard Part
O Tab order Order of the Button tabs
O Text Dashboard Part Text label
O Value Dashboard Part value
Layout
O Anchors Edge definitions that bound the Dashboard Part.
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Drop-down list Properties

Property Description
Data
O DataBinding Data binding information for the Dashboard Part
6 Exclusive Data Data from selected data source will be exclusive (private) for this
part or not.
O Data Category Bound category of the data source
O Data Source Bound data source based on Data Category
O Text field Field the Dashboard Part displays
O Value field Value the Dashboard Part stores
O Row Row the Dashboard Part shows
General
O Name Name of the Dashboard Part
O Tab order Order of the Button tabs
Layout
O Anchors Edge definitions that bound the Dashboard Part.
Web View Properties
Property Description
Data
O DataBinding Data binding information for the Dashboard Part

. Data from selected data source will be exclusive (private) for this
O Exclusive Data

part or not.
O Data Category Bound category of the data source
O Data Source Bound data source based on Data Category
O Text field Field the Dashboard Part displays
O Value field Value the Dashboard Part stores
O Row Row the Dashboard Part shows
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Property Description

General

O Name Name of the Dashboard Part

O URL URL address

Layout

O Anchors Edge definitions that bound the Dashboard Part.

Chart Properties

Property Description
Appearance
3D Depth Depth of the chart image in 3D

3D Mode

3D view setting of the chart

Back Color

Background color

Color Scheme

Color scheme for the chart

Colored Values

Fill values for multiple colors

Gridlines

Gridline display

Chart image area color

Key Axis Title

Title of the Keys Axis

Stacked

Display chart values stacked

Title

Chart Title text

Values Axis Title

Title of the Values Axis

O
O
O
O
O
O
O Inside Color
O
O
O
O
O

View Mode

Type of chart display

Data

O DataBinding

Data binding of the chart

O Retain Source Order

Resorting of data order option

Format

O Keys

Key values formatting
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Property

Description

O Keys Decimals

Key values decimal accuracy

O Values

Value formatting

O Values Decimals

Value decimal accuracy

General

O Name Name of the Dashboard Part

Layout

O Anchors Edge definitions that bound the Dashboard Part.
Table View

Property Description

Appearance

O Back Color Background color

O Flat Flat appearance of grid

O Font Label font style

O Line Color Color of lines between columns and rows

O Text Color Color of the table text

Data

O DataBinding

Data binding of the Table

General

O Name

Name of the Dashboard Part

Layout

O Anchors

Edge definitions that bound the Dashboard Part.

Date Picker

Property

Description

Data

O DataBinding

Data binding information for the Dashboard Part
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Property

Description

QO Exclusive Data

Data from selected data source will be exclusive (private) for this
part or not.

O Data Category

Bound category of the data source

QO Data Source

Bound data source based on Data Category

O Text field Field the Dashboard Part displays
O Row Row the Dashboard Part shows
General
O Name Name of the Dashboard Part
Layout
O Anchors Edge definitions that bound the Dashboard Part.

Types of Charts

When defining the properties for the chart-type Dashboard Parts, you have the option to also determine the visual
type of chart to display. Below are examples of the various types of charts that are available under the drop-down

menu for the View Mode chart property.

Each Chart can have a slightly different appearance based on the data being reported and the properties defined
for the chart (see Chart Properties ).

Name Example
Closed Sales by Users
&00,000 a
% 600,000 - B LSER
. Y 400,000 g B MARY
Lines £
= 200,000 B JOHN
0

USER PSR JOHM
User Name
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Name Example
Clozed Sales by Users
00,000
£ 500,000 B UsER
ﬁ 400,000 - B mary
Bar 2
= 200,000 | B JoHr
1]
USER MARY JOHRM
Llzer Name
Clozed Sales by Users
500,000 5
£ 500,000 e & USER
i 400,000 e B MARY
Curve £
= 200,000 -| - JOHM
1]
USER MARY JOHM
User Mame
Clozed Sales by Users
00,000 -
% 00,000 = B usEr
— 400 000 - MARY
Scatter T u —
— 200,000 -| B JoHm
u]
USER MARY JOHRM
User Mame
Clozed Sales by Users
M useErR
Pie B mary
B joHM
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Name Example
Clozed Sales by Users
00,000
g 500,000 M UsER
@ 400,000 - B mary
Area £
= 200,000 | B JoHr
i)
USER MALRY JOHM
Llzer Name
Clozed Sales by Users
800,000 —=
g 500,000 B USER
ﬁ 400,000 - B MARY
Pareto *E
— 200,000 -| - JOHM
i)
USER MARY JOHM
User Mame
Clozed Sales by Users
00,000 -
g 500,000 B USER
ﬂ 400,000 - B MARY
Step £
— 200,000 -| - JOHM
u]
USER MALRY JOHM
User Mame
an
Surface _
0 T
1 2 3 4 5
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Name Example
Clozed Sales by Users
USER
800,000
- USER
Radar B MARY
-
JOHM MAARY 2
Clozed Sales by Users
800,000
== Il o
= 400,000 - MARY
Cube £ : 0
— 200,000 -| W JoHr
u |
USER MARY JOHN
Uszer Mame
Clozed Sales by Uszers
M user
Doughnut Emary
B joHM
Clozed Sales by Users
M user
Pyramid Emary
B joHM
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Name Example
80
C L A A N )
Bubble
i}
1 2 3 4 5
1 2 3 4 5
Clozed Sales by Users
800,000
g 500,000 W usErR
@ 400,000 B mary
CurveArea £
= 200,000 W soHN
1}
LSER MARY  JOHMN
User Mame
Cloged Sales by Uszers
JOHM
E M UsER
Gantt - MARY B mary
= M JoHN
USER
0 300,000 00,000
Total Sales
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Name

Example

HiLowClose

3

Forecasted (range) and aciual values of growth, %

# & # R F 38

#

Monthby turmorser growdh in 2008

I

Februnry Apail June August October Cwrcomber
Morth

OpenHiLowClose

Duadly turnorver, thousands of §

10

o

Lo I T -

By month lcvwvest and highest daily turnover for sl the time and for 2008

I“I“II i

Fetruary April June August October  December
Month

GoldMine Administrator's Guide

Page 187 of 439



GoldMine™®

Name Example

By month lcvwvest and highest daily turnover for sl the time and for 2008
10

=1} o

(-]

| [
[0 open

I L L1 =

Z ﬁ¥ %v &¥ B

February Apri June August Oclober  December
Month

"

Candlestick

Dradby turnover, thousands of §
&

Data Source Management

A data source is a SQL template that used as a data feeder for a Dashboard control. GoldMine comes with many
predefined data sources that you can use to bind your data to a Dashboard Part. You can use these data sources as
they are, or you can modify them to meet your needs. You can also create new data sources using the New Data
Source wizard help you create.

For more information, see the following topics:

m Managing Data Sources

m Dashboard Macros

Managing Data Sources

The Data Source Manager is only accessible while in the Design mode on the Dashboards. To open the Data Source
Manager, click the Data sources manager link located below the Objects tree in the pane to the left immediately
above the Navigation buttons.

Using the buttons on the Data Source Manager, you can:
= Add a new Data Source using the New Data Source wizard (see To Create a New Data Source)
= Edit the selected Data Source in the Edit Data Source dialog box (see To Edit a Data Source).
m Delete the selected Data Source from the list of available data sources (see To Delete a Data Source ).

= Export the selected Data Source and save it as an Datasources (*.ds.xml) file (see To Export a Data Source).
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M Data source summary view .El
Cabadory: Lisse:
L] {al} v
HName = Descigplon = | Category
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A0 ope by mroeith Dy Picy EI
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Clotnd 2ol jdetads] Clorbed 1abect
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Closed sales by sounce Closed gades
Closed sales sucosss bl sy Bypesd
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Coompleted appointrments - preol Condack completed achivilies
Coompleted apps | detads | Condack completed achvifies
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Completed cally - detaly Condack commpleted vt
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Frmecat chotady [ dhraaeme;  peochs Qper cae Corgel

To Create a New Data Source

1.
2.

On the Data Source Manager, click the Add button to start the New Data Source wizard.
Select the Type of Data and Creation Method.

NOTE: The Manually Typed data source type refers to one in which the database is not a GoldMine
database. You must be familiar with this database in order to enter the SQL query manually.

3.
4.

© N o WU

the Name and optional Description, and then click Next.

Select the Security Level from the drop-down list.

O None

O Show ‘n/a’

O Hide

Select the Owner.

Select the Output type: (Table or Matrix) and then click Next.

Specify the Columns to bind to a Dashboard control.

Add fields to the list or modify existing fields using the following options.
O Select the maximum number of records to include from the drop-down list.
O Click Add to add a new entry.

O Click Edit to modify an existing selected entry.

O Click Delete to remove a selected entry.

O Click Up or Down to move the selected entry on the list.

Specify the search criteria for the data source.

O Click Add to add a new entry.

O Click Edit to modify an existing selected entry.

O Click Delete to remove a selected entry.
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10. Specify the runtime search criteria for the data source by clicking Add and entering the following information,
then click Next.
O Enter the Name and choose whether or not to Interpret as String.
O Choose Field Based or Custom for the search string
O The Default Value option activates the string entered in the associated text box.
11. Specify how to group and sort the data and then click Next.
O Open the Group by drop-down list and select an item. Then use the buttons to add, arrange, or delete the
list items.
O Open the Sort by drop-down list and select an item. Then use the buttons to add, arrange, or delete the list
items.

12. Review the SQL template.
O Click the Check button to perform an automated inspection of the SQL query code.
O Click the Query button to run a preview of the SQL query.

If you want to edit the template manually, check the Edit manually option and then modify the text in the
box below.

13. Click Finish to save the SQL template.

To Edit a Data Source
1. On the Data Source Manager, select the data source on the list to modify.
2. Click the Edit button to open the Edit Data Source dialog box.
3. Click the appropriate tab an make your modifications as needed.
4

Click the Query tab and Inspect the changes.
O Click the Check button to perform an automated inspection of the SQL query code.
O Click the Query button to run a preview of the SQL query.

5. Click Apply to save your changes and OK to close the dialog box.

To Delete a Data Source

NOTE: If you think you might want to use this data source again in the future, you can Export the data
source and use it at a later date to create a new data source (see To Export a Data Source).

1. Onthe Data Source Manager, select the data source on the list to delete.
2. Click the Delete button to remove the selected data source.
3. Click OK the delete the data source.

To Export a Data Source

1. On the Data Source Manager, select the data source on the list to Export.
2. Click the Export button open the Save As dialog box.

3. Browse to the desired location to save the file.

4. Enter a name for the file and then click Save.

NOTE: An exported Data Source can be used during the creation of a new Data Source by checking the
Import datasource definition from a file option on the first screen of the New Data Source wizard (see To
Create a New Data Source).
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Dashboard Macros

Following is a list of supported Macros that can be used when creating SQL query statements for a New Data

Source.

Date Macros

This group can be used only with date/datetime fields (OnDate, CREATED, etc.)

O <<~CURRENT_YEAR>> current year
O <<~CURRENT_MONTH>> current month
O <<~CURRENT_QUARTER>> current quarter
O <<~CURRENT_DAY>> current day

This group can be used only with date/datetime f

ields (OnDate,MODIFIED, etc.)

<<~LAST_YEAR>>

last (previous) year

<<~LAST_MONTH>>

last month

<<~LAST_QUARTER>>

last quarter

<<~LAST_DAY>>

last day

<<~”CURRENT_DATE>>

current date

O
O
O
O
O
O

<<~FY_END>>

when fiscal year ends (month)

User Macros

O <<~CURRENT_USER>>

logged/current user

O <<~IS_CURRENT_USER_MASTER>>

replaced by

O <<~USER_GROUP_MEMBERS>>

user group’s name, replaced by group’s members list (“,
‘USERY’, ‘USER2’)

Contact Macros

O <<~CONTACT_FILTER>>

contact filter

O <<~CONTACT_GROUP>>

contact group
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Runtime Filters

O <<__ INACTIVE_STATE_ >> ignore runtime filter (by default value will be placed)
O <<_ IGNORE_STATE_ >> ignore runtime filter and its default value
O <<VALUE>> shows place where value from part will be replaced

the same as <<VALUE>>, but several values can be

O <<VALUES>> . . .
replaced (our grid supports multi selection)

Dashboard Tables

Dashboard Tables display a variety of data. You can customize how the data is displayed (adding/removing
columns) and how it functions, such as linking to other data. The follow procedures will assist you in designing a
table that meets your needs.

m Adding a Column to an Existing Table (see page 192)

m Removing a Column from an Existing Table (see page 193)

m Changing the Column Label Displayed in the Dashboard (see page 193)

m Creating Table Cell Hyperlinks (see page 193)

Adding a Column to an Existing Table

There are two parts to adding a column to an existing table: Update the SQL Query and Edt the Data Binding
Properties.

To Update the SQL Query

1. Click New Data Source link at the bottom of the Dashboards Objects panel.
On the Data Source Manager, select the data source on the list to modify.
Click Edit to open the Edit Data Source dialog box.
Click the Select tab.
Click Add to add a field.

Click OK to save your changes.

o vk wWwN

NOTE: If you have a Manually Typed data source, you might need to manually edit the SQL Query.
However, if you have a state that contains code such as “Select*”, then it will already query for all the
columns in the table.

Edit the Data Binding Properties
1. Select the Table on the Dashboard.
2. Inthe Properties area, locate the Data > Data Binding field.
3. Click the ellipses button (...) to open the Table View Data Binding dialog box.
4

There are two list boxes:
O Unbound fields (columns) contains columns that are not available for display in the table.
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O Bound fields contains columns that can be displayed in the table.

5. Select an item from the Unbound fields list and then use the Right Arrow button (or double-click the field
name) to move it to the Bound Fields.

6. Click OK to save your changes.

Removing a Column from an Existing Table

Removing a column from a table does not actually remove any data from your database table. It only hides the
column from view in the Dashboard Table part.

To Remove a Column from a Table
1. Select the column name from the Bound fields list box.
2. Click the Left Arrow button to move it to the Unbound list box.

You can also select the column name in the Bound Fields list box and the uncheck the Visible box under the
Column Properties area.

3. Click OK to save your changes.

Changing the Column Label Displayed in the Dashboard

By default, the column label on the table used that label from your database table for that column. If you want the
column to have a different name on your Dashboard Table, you can change the display name using the procedure
below.

To Change the Name of the Column
1. Select the Table on the Dashboard.
In the Properties area, locate the Data > Data Binding field.
Click the ellipses button (...) to open the Table View Data Binding dialog box.
Select the column from the Bound fields list box.
In the Column Properties area, change the text in the Caption text box as desired.
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Click OK to save your changes.

Creating Table Cell Hyperlinks

The process of hyperlinking a cell shown in a dashboard Table View is set up within the Data Binding for the
Dashboard Part. In the case of a Table, the column must be linked to the record the GoldMine will use for the
destination.

To Create Linked Table Cells
1. Select the Table on the Dashboard.
In the Properties area, locate the Data > Data Binding field.
Click the ellipses button (...) to open the Table View Data Binding dialog box.
Select a Bound field that you want to be a hyperlink.

i W

Uncheck the Visible option under Column Properties.

Normally, you will want to make this field invisible because it does not contain readable data.
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Check Enable as hyperlink option.
Select Primary Destination (see About Dashboard Link Data Destinations).
Select Field that identifies <x> record

v ® N O

Click OK to save your changes.

Dashboard Management

Managing your Dashboards involves adding/removing parts from a Dashboard and manipulating the size and
location of parts, as well as creating copies of a Dashboard and deleting an unwanted Dashboard.

IMPORTANT: You cannot modify any of the predefined Dashboards. Dashboards that can be modified are
based on those of your own design or from a copy of a predefined Dashboard (see "Predefined Dashboards" in
the GoldMine User's Guide PDF).

m Removing a Part from a Dashboard

m Repositioning and Relocating a Dashboard Part
m Creating a Copy of a Dashboard

m Deleting a Dashboard

Removing a Part from a Dashboard

Any part or parts that you no longer need can be removed using the following procedure. It is recommended that
you make a copy or a backup of the current Dashboard before you make any permanent changes. See Creating a
Copy of a Dashboard and/or Import and Export Dashboards

To Remove a Dashboard Part
1. Select the Dashboard from the list of Available Dashboards.
2. Click the Design button to start the Dashboard Designer.

3. Select the Dashboard Part on the canvas, then right-click the Dashboard Part and select Delete control from
the context menu, or press the Delete key on the keyboard.

Click the Save button on the Dashboard toolbar to save your changes.

Click the View button to view the new Dashboard.

Repositioning and Relocating a Dashboard Part

You can easily move or resize a Dashboard Part if it is not located where you want it, or if it is not the desired
size/shape.

TIP: Use the canvas’ grid points to align the various components on the Canvas.

To Move a Dashboard Part

1. Click Dashboard Part to select it.

2. Use the Arrow keys on the keyboard to move the Dashboard, or place the cursor on the part and then click
and drag the part to refine the location.

3. Click the View button to view your changes.
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To Resize a Dashboard Part

1. Click Dashboard Part to select it.

2. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then
click and drag the resize point to the desired shape and size.

3. Click the View button to view your changes.

Creating a Copy of a Dashboard

When you create a copy of the Dashboard, you create an exact duplicate of the currently active Dashboard. By
default, the copy is placed under the same Category as the current Dashboard, but the phrase “copy_from_" is
prepended to the current Dashboard name.

To Create a Copy of a Dashboard

Click the Dashboards button on the Navigation Pane.
Expand the Available Dashboards tree to locate the desired Dashboard.
Select the Dashboard from the tree to view the Dashboard.

P wWwnNR

Right-click and select Copy from the context menu.

A message box displays with the following question:

Would you like ko create new instances of data sources?

Ves ] [ i ] ]

Would you like to create new instances of data sources?

O Yes creates new instances (which allows for editing of the data sources).
O No uses the existing data source (which might not allow for editing of the data sources if they are based on
those of a predefined Dashboard).

The screen switches to the Dashboard Designer.
Change the Name and Category properties for the Dashboard as desired.
Add, remove, or edit the Dashboard Parts as desired.

Click the Save button on the Dashboard toolbar to save your changes.

© X N o U

Click the View button to view the new Dashboard.

NOTE: You can also use the Copy button in the Dashboard Designer tool bar to create a copy of the current
Dashboard.
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Deleting a Dashboard

Any Dashboard on the list of Available Dashboards can be deleted. If you want to backup the Dashboard before
you delete it, you can use the Export command to save a copy of the Dashboard. This allows you to add it back to
GoldMine at a later date using the Import command. For more information, see Import and Export Dashboards.

NOTE: A user must be defined as a Master user to delete an existing Dashboard (see "Using the User
QuickStart Wizard" in the User Guide or Online Help).

To Delete a Dashboard

1. Click the Dashboards button on the Navigation Pane.

2. Expand the Available Dashboards tree to locate the desired Dashboard.
3. Select the Dashboard from the tree to view the Dashboard.

4. Click the Design button to switch to the Dashboard Designer.

5. Click the Delete button L on the Dashboard toolbar.

6. Click Yes to delete the current Dashboard, or No to cancel.

Events and Actions

Events and Actions can be added to any Dashboard Part while in Design mode. The Event is what occurs with the
Dashboard Part, such as clicking a Button or making a selection from a Drop-down list. The Action is what happens
as a result of the Event.

For example: a Dashboard Part that is a Refresh button. When the button is clicked, all the data on the Dashboard
is updated to display the latest information. Another example is used in the Sample Dashboard Tutorial (see page
153). In that example, a Drop-down list is assigned an Event and Action that updates the selected Chart.

There are many types of Events and Actions that you can use in the Dashboard.

Viewing the Events and Actions Dialog Box

The Events and Actions Dialog box is only accessible from the Dashboard Design mode. To view the Events and
Actions dialog box, add a Dashboard Part or select an existing part, then click the Events button on the Dashboard
toolbar.
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() Main View
(%) Dashboard part | User Filter A
Ewent: Skate changed v

List of ackions:

Refresh a dashboard part based on user selection - Closed Sales Chart

Edit

Delete
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Add, Edit, and Delete actions and events for the selected Dashboard Part by using the buttons in the Events and
Actions dialog box. A Dashboard Part can have multiple Actions assigned to it.

To Add an Event and Action
1. Select the Dashboard Part and then click the Events button on the Dashboard tool bar.
2. Onthe Events and Actions dialog box select the area affected: Main View or Dashboard Part.

NOTE: The Main View option automatically adds the Refresh entire dashboard Action to the List of
Actions.

3. Select the Event from the drop-down list.
4. Click the Add button to view the Action’s properties dialog box.
5. Select the type of Action:
O Refresh entire dashboard updates all data on the Dashboard
O Focus on a dashboard part changes focus to the specified Dashboard part
O Refresh a dashboard part refreshed the data of the specified Dashboard part
O Refresh a dashboard part based on user selection refreshed the data of the specified Dashboard part by
data source, runtime parameter, and set values.

O Set runtime parameter for a dashboard part without refreshing updates a Dashboard part based on data
source, runtime parameter, and set values without refreshing the selected Dashboard part.

O Drill down moves further into the details.
6. Make selections for each section from the drop-down lists for the selected Action type.

The properties that display vary depending on the type of Action selected. For more information, see Set
Action Properties.

7. Click OK and add the Action to the List of Actions on the Events and Actions dialog box.

To add another Action, click the Add button again and repeat the process.
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8. Click OK to save the action and close the dialog box.

NOTE: If you click Cancel, the Action is not saved nor added to the list of actions for the Dashboard Part.

To Edit an Event and Action
1. Select the Dashboard Part and then click the Events button on the Dashboard toolbar.
Select either the Main View or Dashboard Part as desired.
Select the Event from the drop-down list as desired.
Select an Action from the List of Actions and the click the Edit button.

Select the type of Action (see “To Add an Event and Action” above for Action details).

oV P wWwN

Make selections for each section from the drop-down lists for the selected Action type.
The properties that display after your Action type selection vary depending on the type of Action selected.
7. Click OK to return to the Events and Actions dialog box.
TIP: To add another Action, click the Add button and repeat the process.
8. Click OK to save the action/s and close the dialog box.

NOTE: If you click Cancel, the Action changes will not be saved.

To Delete an Action from an Event
1. Select the Dashboard Part and then click the Events button on the Dashboard toolbar.
2. Select an Action from the List of Actions and the click the Delete button.
3. Click OK to save the Action deletion and close the dialog box.

NOTE: If you click Cancel, the Action will not be deleted.

Set Action Properties

The following tables list the available options depending on the type of Action selected from the Action drop-down
list when you click the Add button on the Events and Actions dialog box (see Viewing the Events and Actions
Dialog Box).

= Focus on a dashboard part

= Refresh a dashboard part

Dashboard part The name of the affected Dashboard part.

= Refresh a dashboard part based on user selection

= Set runtime parameter for a dashboard part without refreshing

Update dashboard part The name of the affected Dashboard part
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Data source The name of the Data source linked to the Dashboard part

Runtime Parameter

O Predefined value

O Runtime (from part)

Key
O Field Value
Series
Drill down
Update dashboard part The name of the affected Dashboard part
Data source The name of the Data source linked to the Dashboard part
Runtime Parameter 1
O Predefined value
O Runtime (from part)
Key
O Field Value
Series
Runtime Parameter 2
O Predefined value
O Runtime (from part)
Key
O Field Value
Series

Import and Export Dashboards

GoldMine Dashboards are created using an XML file format. Any Dashboard that you export creates an XML file
containing all the required components to recreate the Dashboard, including the Category and Name. Similarly,
any Dashboard you import must be in an XML format.

Importing a Dashboard XML File
1. Click the Dashboards button on the Navigation Pane, or select Go To > Dashboards from the menu.
Click the Design button on the Dashboard toolbar.
Enter a Category and Name for the imported Dashboard.
Click OK to view the blank Dashboard canvas.
Click the Import button on the Dashboard tool bar.
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Browse to the location of the XML file that you want to import.
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7. Select the file from the list and then click the Open button.

NOTE: If the name of the Dashboard contained in the XML file matches a Dashboard you already have, a
warning message displays. Click Yes to overwrite the existing Dashboard or No to cancel the import.
The contents from the imported file populates the blank Dashboard canvas.
8. Click the Save button on the Dashboard toolbar.
9. Click the View button on the Dashboard toolbar to view the Dashboard.

Exporting a Dashboard XML File
1. Click the Dashboards button on the Navigation Pane, or select Go To > Dashboards from the menu.
Click the Design button on the Dashboard toolbar.
Enter a Category and Name for the new Dashboard.
Click OK to view the blank Dashboard canvas.
Click the Export button on the Dashboard tool bar.

Browse to the location where you want to save the file.
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Enter a name for the file and then click the Save button on the Dashboard tool bar.
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Web Import

Set up Internet Web sites to collect contact information from interested visitors. Use the data in GoldMine by
creating a Web form (see Creating Web Forms) that includes instructions for handling the data.

After information is submitted, a Web server script (see Creating Server Scripts) can format the data into an
Internet e-mail message which can then be sent to a designated recipient. When retrieving the e-mail message
(see Importing Contacts with Web Import), GoldMine recognizes the import instructions and creates a Contact
Record with data captured from the Web page. Or, if a Web Import contact duplicates an existing contact, update
selected fields (see Updating GoldMine Fields with Web Import Data).

Combining the Web Import feature with GoldMine’s Automated Processes (see Formatting Web Import Files) can
automate capturing and responding to leads. Initiate Automated Processes automatically and send e-mail
messages to GoldMine users alerting them of the incoming contact data.

An advanced knowledge of gateway scripts is not needed to implement the GoldMine Web Import feature. Begin
by contacting your Web administrator and providing him or her with the sample HTML and Perl script. Writing and
modifying scripts requires some programming expertise not covered in this material. Many sources for getting
started with Common Gateway Interface (CGl) scripts are available on the Internet and in bookstores.

NOTE: Ivanti technical support cannot provide support for creating or maintaining HTML code or CGI
scripts.

Using Web Import Profiles

Access the Web Import Profiles dialog to configure the system-wide settings that control the Web Import. You can
open the dialog one of two ways:
m From the GoldMine menu bar, click Web > Setup Web Import.

= From GoldMine Campaigns, select a campaign and click the Configure WebIlmport button.
Users with Master rights have these settings available:

= Web Import authorization password: Protect the Web Import process with a password so only authorized
incoming instruction files can be imported. This prevents unauthorized persons from sending e-mail messages
and inundating a GoldMine system with unwanted data. A password is always required to use Web Import.
The incoming instruction file will not be processed if it doesn’t contain a password or if it contains an invalid
password. Note that you must set this password before the Web Import functions are made available.

= Fields to be Updated by Weblmport: Type “I Want To Allow Fields To Be Updated By Weblmport” in the text
box to let visitors to your Web site update their information in your GoldMine database.

= Fields that can be updated: Select the fields to be updated by the Web Import.
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Web Import Profiles X
Password is required to use Web Import
Web Import authorization frasaesEn
Web Import Profiles

Starting with Goldmine 2020, 1 HF2, the ability to create, edit, and delete
Web Import profiles has been removed.

Local System Settings

Here you can define the system wide settings that control Web Import
and apply to all profiles.

To allow fields to be updated through Web Import, please type in the
following box :

I 'Want To Allow Fields To Be Updated By WebImport

Fields that can be

v Account Size (USERDEFO4) ~
v Account Type (USERDEFOS)
Address3 (ADDRESS3)
City (CITY)
Class (KEY3)
Crlnr (KEYEY v

QK Cancel

Creating Web Forms

The Web form is an HTML document for collecting information. Users type text and make choices from check
boxes, radio buttons, and selection lists. Design forms meeting customer requirements by combining these input
types; use or modify the sample HTML form below. The name of fields in your form must be identical to the names
in your GoldMine databases.

How Forms Work

A Web form works with a script on a server to process submitted information. When a person fills out a form and
clicks Submit, the browser sends (or posts) information in the form to the script or application running on the
server for processing. The script processes the information passed from the browser to the server. The processed
information can be sent back to the server, or, as with GoldMine's Web Import feature, sent by e-mail to a
designated recipient.

Example of an HTML file using a form:
<!----The following is an example of an HTML file using a form---->
<HTML>
<HEAD><TITLE>Ivanti - Online
Registration</TITLE></HEAD>
<BODY BGCOLOR="#008080" Text="#FFFFFF" LINK="#000000" VLINK="#FF8900">
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<BASEFONT SIZE=3>

<!----This is where the table Tayout begins---->
<TABLE BORDER=3>

<TR>

<TD><FONT SIZE=+3>Ivanti.</FONT></TD>

</TR>

<TR><TD><FONT SIZE=+2>0Online Registration Form</FONT></TD>
</TR>

</TABLE>

><!----This is where the table layout ends---->
<P>

<B>

<CENTER>To register your copy of GoldMine, please fill out the following
form.</CENTER>
<CENTER>Your registration number is located on the registration card.</CENTER>

<HR>

<l----- This is where the form layout begins---->

<!----The Tine below references the PERL script---->

<FORM METHOD=POSTACTION="http://www.ivanti.com/cgi/webimp.p1">

><!----The Tine below references an HTML page, created separately, that will appear
once the message has been sent---->

<INPUT TYPE="hidden" Name="thankURL" value="thankyou.htm">
<!----Replace "yourname@yourname.com" in the 1line below with the E-Mail address where
you want to receive the results of this form---->

<INPUT TYPE="hidden" NAME="email_to"value= "yourname@yourdomain.com">
<DT>GoldMine Serial Number

<DD>

<INPUT NAME="csl_Rectype" TYPE="hidden" VALUE="P">

<INPUT NAME="csl_Contact" TYPE="hidden" VALUE= "Serial Number'">>
<INPUT NAME="csl_ContSupRef" TYPE="text" SIZE="15" MAXLENGTH="15">
<BR>

<DT>Number of Licenses

<SELECT NAME="Keyl">

<OPTION VALUE="Gold 01/Single user">Single user

<OPTION VALUE="Gold 05 Net">5 user Network

<OPTION VALUE="Gold 10 Net">10 user Network

<OPTION VALUE="Gold 10-25 Net">10 - 25 user Network

<OPTION VALUE="Gold 25-50 Net">25 - 50 user Network

<OPTION VALUE="Gold 51+ Net">51+ user Network

<OPTION VALUE="Gold Net Unknown">Not Sure

<OPTION SELECTED>Choose One

</SELECT>

<P>

<DT>Date of Purchase

<INPUT NAME="csl_Country" TYPE="text" SIZE="35" MAXLENGTH="35" VALUE="MM/DD/YY">
<P>

<DT>Place of Purchase
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<INPUT NAME="cs2_Rectype" TYPE="hidden" VALUE="P">

<INPUT NAME="cs2_Contact" TYPE="hidden" VALUE="Place of Purchase">
<INPUT NAME="cs2_ContSupRef" TYPE="text" SIZE="35" MAXLENGTH="35" VALUE="">
<HR>

Ms. <INPUT TYPE="radio" NAME="Dear" VALUE="Ms.">

Mr. <INPUT TYPE="radio" NAME="Dear" VALUE="Mr.">

<DT>Name

<DD><INPUT SIZE="40" MAXLENGTH="40" NAME="CONTACT">

<DT>Title

<DD><INPUT SIZE="30" MAXLENGTH="30" NAME="TITLE">

<DT>Company Name

<DD><INPUT SIZE="40" MAXLENGTH="40" NAME="COMPANY">

<DT>E-Mail Address

<DD>

<INPUT NAME="cs3_Rectype" TYPE="hidden" VALUE="P">

<INPUT NAME="cs3_Contact" TYPE="hidden" VALUE="Internet Address'>
<INPUT NAME="cs3_ContSupRef" TYPE="text" SIZE="30" MAXLENGTH="30">

<DT>Addressl1

<DD><INPUT SIZE="40" MAXLENGTH="40" NAME="Addressl">
<DT>Address?2

<DD><INPUT SIZE="40" MAXLENGTH="40" NAME="Address2">
<DT>City

<DD><INPUT SIZE="26" MAXLENGTH="26" NAME="City">
<DT>State/Province

<DD><INPUT SIZE="3" MAXLENGTH="3" NAME="State'>

<DT>Country

<DD><INPUT SIZE="20" MAXLENGTH="20" NAME="Country">

<DT>Zip/Postal Code

<DD><INPUT SIZE="10" MAXLENGTH="10" NAME="Zip">

<DT>Telephone Number (WITH AREA CODE)

<DD><INPUT SIZE="30" MAXLENGTH="30" NAME="Phonel" VALUE="(XXX)XXX-XXXX">
<DT>Fax Number (WITH AREA CODE)

<DD><INPUT SIZE="30" MAXLENGTH="30" NAME="Fax" VALUE="(XXX)XXX-XXXX">
<HR>

<DT>Contact Manager/PIM, if any, prior to purchasing GoldMine
<SELECT NAME="userdef05">

<OPTION VALUE="ACT!">Act!

<OPTION VALUE="TeleMagic'">TeleMagic

<OPTION VALUE="Janna Contact'>Janna Contact

<OPTION VALUE="Ecco">Ecco

<OPTION VALUE="Lotus Organizer">Lotus Organizer

<OPTION VALUE="Other">0ther

<OPTION SELECTED>Choose One

</SELECT>

<P>

Computer Type:<BR>

<INPUT TYPE="radio" NAME="cs5_cContSupRef" VALUE="Desk top">Desktop
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<INPUT TYPE="radio" NAME="cs5_cContSupRef" VALUE="Laptop/NOTEbook"> Laptop/NOTEbook
<INPUT TYPE="radio" NAME="cs5_cContSupRef" VALUE="Desktop & Laptop/NOTEbook"> Both

<INPUT NAME="cs5_Rectype" TYPE="hidden" VALUE="P">
<INPUT NAME="cs5_Contact" TYPE="hidden" VALUE="Computer Type'>

<P>

<DT>Network Operating System

<SELECT
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION

<OPTION VALUE="windows NT 4.0">Windows NT 4.0
<OPTION VALUE="oOther">0ther

<OPTION SELECTED>Choose One

</SELECT>

<P>

Primary Business at your company:

<SELECT
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION

NAME="userdef07">
VALUE="LAN Man">LAN Manager
VALUE="Novell1">Novell
VALUE="0S/2">0S/2
VALUE="Pathworks">Pathworks

VALUE="Win4wrkGrp">windows 3.11 for workgroups

VALUE="Windows 98">Window 98
VALUE="Windows NT">Windows NT

NAME="Key3">
VALUE="Advertising">Advertising
VALUE="Real Estate'">Real Estate

VALUE="Banking/Finance">Banking/Finance

VALUE="Med1ical">Med1ical

VALUE="TeTlecommunications">Telecommunications

VALUE="Government">Government
VALUE="Aerospace">Aerospace
VALUE="Insurance">Insurance
VALUE="Computer">Computer
VALUE="Manufacturing">Manufacturing
VALUE="Legal">Legal

<OPTION VALUE="Entertainment'">Entertainment
<OPTION VALUE="ETlectronics">Electronics
<OPTION VALUE="Other">0ther

<OPTION SELECTED>Choose One

</SELECT>

<P>

<DT>Where did you Tearn about GoldMine?

<SELECT
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION
<OPTION

NAME="Source">
VALUE="Advertising">Advertising
VALUE="Acquaintance">Acquaintance
VALUE="Demo Disk">Demo Disk
VALUE="Trade Show">Trade Show

VALUE=""Magazine Review'">Magazine Review

VALUE="Reseller">Reseller
VALUE="Literature">Literature
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<OPTION VALUE="Other">0ther

<OPTION SELECTED>Choose One

</SELECT>

<P>

<DT>Comments

<TEXTAREA NAME="NOTEs" ROWS=4 COLS=72></TEXTAREA>
<P>

</DL>

<INPUT TYPE="submit" VALUE="Register">

<INPUT TYPE="reset" VALUE="Reset Form">
</FORM>

<!----This is where the form layout ends---->
<B>

</BODY>

</HTML>

Creating Server Scripts

The Common Gateway Interface (CGl) is the specified standard for communication between HTTP servers (Web
servers) and server-side gateway programs. The CGl specifications define how data passes from the server to
gateway programs, and vice versa.

Gateway programs can be compiled programs written in languages such as C, C++ or Pascal, or they can be
executable scripts written in languages such as Perl, TCL, ASP, and other various shell programs. Most gateway
programs are Perl scripts; they are easy to write and modify and are transportable between computers.

Sample PERL Gateway Script for GoldMine Web Import
#!/usr/Tocal/bin/perl
# check for the POST method
if ($ENV{‘REQUEST_METHOD’} eq ‘POST’)
{
# How many bytes are we supposed to receive?
read(STDIN, $buffer, $ENV{‘CONTENT_LENGTH’});
# make a Tist of keyword/value pairs
@pairs = split(/&/, $buffer);
# cycle through each pair and decipher the values foreach $pair (@pairs)
{
# get the name/value pair strings
($name, $value) = split(/=/, $pair);
# translate "+" to a space
$value =~ tr/+/ /;
# decipher ASCIhexidecimal escaped characters, if any
$value =~ s/%([a-fA-F0-9][a-fA-F0-9])/pack("C", hex($1))/eg;
# find profile/contsupp field names that begin with cs*_
if ($name =~ /cs\d_/)
#add the profile/contsupp pair to a list keyed on the name of the variable
{$csarry{$name} = $value;}
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else {

#add the basic field data pair to a list keyed on the name of the variable

$contents{$name} = $value

}

}

}

($mon, $day, $year) = split(m>>/>>,‘/bin/date +%B/%e/%Y‘);
$date = "$mon $day, S$year";

$to = $contents{‘email_to’};

&mailto;

&thankyou;

HARHRH#H# SRR

## subroutines from here on down!

HHARHHHHHHH AR A

sub thankyou {

print "Location: http://www.ivanti.com/thankyou.htm\n\n";
exit;

}

sub mailto {

open (MAIL, ">>/usr/Tib/sendmail -t") >>>>die "can’t open pipe to sendmail \n";

print MAIL "Content-Type: application/x-gm-impdata\n";
print MAIL "To: $to\n";

print MAIL "From: $csarry{‘cs2_contSupRef’}\n";

print MAIL "Subject: datafromgoldform.pl\n";

print MAIL "\n\n";

print MAIL "\[Instructions\]\n";

print MAIL "SaveThis=web Import File\n";

print MAIL "DupCheckl=Contact\n";

print MAIL "\n";

print MAIL "OnNewSendEmail=Bart,NEW,Prospect requesting information \n";

print MAIL "oOnDupSendEmail=Natalie,,Duplicate Record \n”;
print MAIL "\n";

print MAIL "onNewAttachTrack=wEBLead\n";

print MAIL "\n";

# The following is an example of testing a field for a value
#print MAIL "Below a message will be printed if the CITY is

Torrance\n\n";
if ($contents{CITY}eq "Torrance") {

print MAIL "OnAnySendEmail=John,wWCC,This one is from Torrance\n";

}

print MAIL "\n";

#print MAIL "Run=c:\goldmine\webimp.exe\n";
print MAIL "\n";

print MAIL "\n";

print MAIL "\[Data\]\n";

# print out general fields and values
foreach $name (sort keys %contents) {
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next if $contents{$name} eq ;

print MAIL "$name = $contents{$name}\n";
}

print MAIL "\n";

print MAIL "\[ContSupp\]\n";

# print out profile/contsupp fields and values
foreach $name (sort keys %csarry) {
next if $csarry{$name} eq "";

print MAIL "$name = $csarry{$name}\n";

}

print MAIL "\n";

print MAIL "\n";

print MAIL "\n";

print MAIL "\n\n";

close (MAIL);

}

Formatting Web Import Files

The incoming import file contains contact data and instructions. It must conform to a specific format, similar to
.ini files. Three major import file sections:

= [Instructions]: Define import instructions. These instructions allow duplicate checking, sending e-mail messages
to GoldMine users, attaching Automated Processes, and running external applications to further process the
incoming contact data. GoldMine can check if the contact already exists by considering the DupCheck#=
instructions. The first duplicate checking instruction usually must be based on one of the indexed fields,
Contact, Company, Phonel, City, State, Country, Zip, AccountNo, Keyl, Key2, Key3, Key4, or Key5. Additional
DupCheck#= instructions can be specified to test more than one field to determine if the incoming contact
data is a duplicate.

Example:
DupCheckl=Contact
DupCheck2=Company

= [Data]: Defines contact data. Format each entry as fieldname=value; for example, City=Long Beach. The
filename should be the actual field name in the Contactl or Contact?2 files. A special email=field can be used
to insert the contact’s e-mail address.

= [ContSupp]: Allows addition of detail records. The fields of each record must have a prefix of cs#_, and must
appear consecutively. For example, the fields of the first ContSupp record would have the prefix cs1_, while
the fields of a second record would have a prefix of cs2_. Add a maximum of 8 ContSupp records.

For more information about formatting, refer to the following topics:
m Checking for Duplicate ContSupp Data
m Checking for Duplicate E-Mail Addresses
m Using Commands to Automatically Perform Operations

m Extracting Import Instructions and Data
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Checking for Duplicate ContSupp Data

GoldMine can check for duplicate records based on ContSupp data by specifying the ContSupp record prefix; for
example, CS1. When GoldMine identifies a duplicate record, but notices the contact name does not match the
existing name, an additional contact is created with the incoming data under the existing Contact record.
GoldMine also adds ContSupp records that do not already exist.

Checking for Duplicate E-Mail Addresses

Configure GoldMine to check for duplicate records based on an e-mail address. Run this check without including a
check based on indexed fields. To check for duplicate e-mail addresses, include the statement:

DupCheck=Email

Using Commands to Automatically Perform Operations

E-Mail

Send e-mail messages to GoldMine users alerting them of newly created contact records. Send a separate e-mail
message based on whether the contact is new [OnNewSendGMEmail=], or already exists on file
[OnDupSendGMEmail=]. Designate a user as the message recipient, followed by an optional activity code, then an
optional reference. Send multiple e-mail messages by appending consecutive numbers to the send e-mail
instructions; for example, OnNewSendGMEmaill=, OnNewSendGMEmail2=, and so on.

Automated Processes

Attach Automated Processes to the contact to initiate an automated response. Initiate letters, faxes, e-mail, and
other activities to automate responding to the captured leads. Attach a separate Automated Process based on
whether the contact is new [OnNewAttachTrack=], or already exists on file [OnDupAttachTrack=]. You must specify
the track name, followed by an optional attaching user. For faster processing, also specify the internal track
number instead of the track name. Attach multiple Automated Processes by appending consecutive numbers to
the attach track instruction; for example, OnNewAttachTrackl=, OnNewAttachTrack2=, and so on.

Launch an External Application

To launch an external application for further processing of the incoming data, use the Run=<exefile> instruction.
This command allows flexibility, since custom programs can be written to perform a variety of tasks. GoldMine
saves import instructions to a file, and passes that file name as a parameter to the launched application.

Extracting Import Instructions and Data

Since the import instructions are similar to .1ini files, use Windows APl GetPrivateProfileString to extract the
import instructions and data. The ImportData=0 instruction prevents GoldMine from importing any new data, and
lets the custom application append the data.

The SaveThis=<reference> instruction saves the instruction file to the notes of a new history record. Specify any
history reference; for example, SaveThis=Web import file.

Protect the Web Import process with passwords to allow importation of only authorized incoming instruction files.
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GoldMine can also process an import instruction file by sending a DDE command. Using a DDE command lets other
applications create Contact records in GoldMine. To start processing an instruction file through DDE, send the
Execlnilmp (<filename>) command; for example, Execlnilmp(i.C:\GoldMine\imp.ini)].

NOTE: Also requires a password on your Weblmport Files (see Using Web Import Profiles).

Example 1:

Since GoldMine stores Web site addresses as detail records (called Web Site), import these addresses using
the following syntax:

[ContSupp]

csl_RecType=P

csl_Contact=web Site
csl_conSupRef=http://www.web.site.com
cs_Addressl=notes (optional)

Example 2 (correct format for an import instruction file):
[Instructions]
DupCheckl=Contact
onNewSendGMEmail=JOHN, NEW, Prospect requesting information
[Data]
Company=GlobalcCorp.
Contact=John Doe
Phonel=555/333-1234
email=jdoe@global.com
[contSupp]
csl_RecType=P
csl_Contact=Serial Number
csl_contSupRef=10000002
csl_Addressl=This is a test....
The following example shows a short instruction file containing the password “Doodle”:

[Instructions]

Password=Doodle

DupCheckl=Contact

OonNewSendGMEmail=JOHN, NEW, Prospect requesting information
[Data]

Company=GlobalCorp.

Contact=John Doe

Phonel=555/333-1234

email=jdoe@global.com

Example 3 (an import instruction file containing all possible instructions:)
[Instructions]
DupCheckl=Contact
DupCheck2=userbef05
DupCheck3=csl
OnNewSendGMEmai1=JOHN, NEW, Prospect requesting information
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onDupSendGMEmail=AMI, ,Repeated request...
onNewAttachTrack=web Lead
onbDupAttachTrack=100067,JOHN
Run=c:\goldmine\webimp.exe
SaveThis=web import file

; ImportData=0

Password=verify

[Datal

Company=GlobalCorp.
Contact=John Doe
Phonel=555/333-1234
Address1=1401 west Baker Street
City=Garden Grove

State=CA

Zip=90220

Source=Web Page
email=jdoe@global.com
[ContSupp]

csl_RecType=P
csl_cContact=Serial Number
csl_contSupRef=10001001
csl_Addressl=This is a test...
cs2_RecType=C

cs2_cContact=Jane Adams
cs2_Title=Beta Program Manager

Importing Contacts with Web Import

GoldMine’s Internet e-mail reader identifies data retrieved from the Web Import Gateway. GoldMine looks at the
header of every e-mail message for handling instructions.

Example of Special Header Information
Content-Type: application/x-gm-impdata

When an e-mail message containing Web Import information is retrieved, GoldMine handles the message.
Alternatively, an incoming message can trigger the Web Import with this To: line entry:

{$GM-WEBIMPORTS$}

TIP: For more information, see Formatting Web Import Files.

Updating GoldMine Fields with Web Import Data

If a contact already in your database fills out a Web form, set the Web Import to update specified Contactl and
Contact2 fields instead of creating duplicate records. Also enable Web Import to update e-mail addresses and
append Notes.
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With these settings, GoldMine updates only the specified fields and discards changes to fields not included in the
list.

The e-mail address is added only if it differs from the existing addresses. It is added as the new primary address
and the others save as alternative addresses.

Important Information About Weblmport Overrides
IMPORTANT: Accepting changes from a Web Import can cause data integrity problems.

It is recommended that you follow these additional security precautions when enabling Web Import overrides:

= Do not accept Web Import e-mails from an unknown e-mail address.
m Limit access to the Web Import e-mail account to one user, the GoldMine administrator with Master Rights.
m Protect your Web Import files with a password and monitor the Web Import passwords regularly for changes.

TIP: It is recommended that you back up GoldMine data daily when performing daily Web
Imports.

Enabling Field Updates with Web Importing

1. Using a text editor, such as Windows Notepad, open the GM.ini.

2. Add this section and lines:
[webImportoverwrite]
IAgree=I Want To Allow Fields To Be Updated By WebImport
Fields=<Tist the contactl and contact2 fields that can be updated, separated by a
comma>

Example: Fields=Key1,Fax,UData

3. Select File > Save and close the text editor.

NOTE: The Accountno or Recid fields can never be overwritten using the GoldMine Web Import.

Configuring GoldMine Connect

GoldMine Connect is used to install GoldMine Web. For installation information, see the GoldMine Connect
Installation Guide.

Use GoldMine Premium Edition to configure GoldMine Connect and allow GoldMine Web access to GoldMine

Premium Edition data.

IMPORTANT: Users will not be able to access GoldMine Web without both a user name and a password.
Ensure that a password is set for all users when installing GoldMine Connect.

NOTE: For information about User settings see Configuring User Settings for GoldMine Connect

To Configure GoldMine Connect
1. Loginto GoldMine Premium Edition as a Master User
2. Select Tools > Configure > GoldMine Connect to open the GoldMine Connect configuration dialog

The dialog contains settings for GoldMine Web.
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3. Select the check box to Automatically retrieve and link email messages when a user is logged in to
GoldMine Connect.
a. Set the Retrieval interval (in minutes). The default setting is 15 minutes. You can select between 3 to 999
minutes.

The auto-retrieval process begins shortly after the user logs into GoldMine Web or GoldMine Connect. It
continues to run at the interval specified until the user logs out.

b. If using IMAP (preferred) as your email protocol, enter the Name of the Sent Items folder. This setting
will allow users to retrieve Sent email messages. This functionality is not available for POP.

For example:
- For Gmail: [Gmail]/Sent Mail
- For Microsoft Exchange Server: Sent Items

Once configured, emails from the Inbox and Sent email folders are retrieved when users connect to
GoldMine through GoldMine Web. This applies even if the email address does not exist in GoldMine.

NOTE: If the Sent folder is for a specific email server (for e.g. Gmail), only Sent emails for that server are
retrieved for users. Emails for users with Sent Folders on a different email server (such as Exchange) will not
be retrieved.
c. The GoldMine Messaging Service notification for an alarmed activity can include a link to the activity.
To create the link, enter the URL to the GoldMine Connect web server in the text box.
For example: http://<ipaddress>/goldmine

Clicking the link when a user is logged into GoldMine Web opens the activity. If the user is not logged in,
the GoldMine Web login screen opens. Users can log into GoldMine Web to access the activity.

Changing Settings in the web.config File.

For GoldMine Web, some default and other settings are controlled by the web.config file, which is usually located
in the following directory:

C:\Program Files (x86)\GoldMine Connect\web.config

Open the web.config file using a text editor such as Notepad. You can change the following settings:

m Default time out period for GoldMine Web. This setting controls the number of minutes a user can be 'inactive
before they are automatically logged out of a session. Once a user is logged out by the system, the license is
released and the user must log in again. To change the default, edit the following setting:

<sessionState timeout='30'></sessionState>

The timout number is expressed in minutes. The number of minutes entered will override the IIS default
setting of 20 minutes. For security reasons we strongly recommend that this setting not be increased. If the
setting is changed you must stop and restart the Internet Information Services (lIS).

m Change logging levels for troubleshooting

The log files are located under: C:\Program Files (x86) \GoldMine Connect\Logs.

The GMConnect.log file is where general server errors are logged. Additional information about user access, server
requests and exceptions for GoldMine Web are stored in the associated log file in the ~\Web directory.
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Configuring User Settings for GoldMine Connect

For a user to retrieve email while logged into GoldMine Web, you must enable the user's email account for
auto-retrieval in GoldMine Premium Edition. If the email address is in GoldMine, the message will be automatically
linked to the contact. For sent messages, linking is only done for the first address in the To: field. With this release,
it is not possible to manually link messages in Web. Received emails are retrieved as Pending items. Sent emails
are retrieved as History items.

A Master user can set up more than one user at a time, but each user must be set up sequentially.

Configure User Email accounts for Auto-retrieve from GoldMine Premium Edition
1. Loginto GoldMine Premium Edition as a Master user.

Go to Tools > Users’ Settings... and select a user.

Click the Preferences button, select the E-Mail tab then click the Accounts... button.

Ensure that the account is highlighted and click Edit...

Select the Auto-retrieve checkbox then click OK for E-mail Account Properties, E-mail Options, and
<username> Options dialogs.

ik wNnN

6. If you have finished editing users click the Close button
or
Select another user account and repeat the procedure.
7. When you are finished click the Close button or add Passwords as seen in Setting User Passwords.

NOTE: Users can configure their own e-mail preferences using the procedure seen in Setting Options for
the E-mail Tab

Setting User Passwords
To use GoldMine Web all users must be assigned both usernames and passwords. Both are required at the
GoldMine Web login page for security reasons. If a password is not assigned, the GoldMine Web login will fail.
1. Loginto GoldMine Premium Edition as a Master user.
Go to Tools > Users’ Settings > Properties > Profile Tab > Security section and select a user.
Assign a password and click OK.
Edit settings for other users.

ik wNnN

When you are finished click the Close button.

Ensure that you communicate the password to each user.
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Knowledge Base

The Knowledge Base provides a resource for maintaining any type of information useful to an organization or an
individual. It can provide easily accessible storage for graphics, multimedia files, and/or program applications. This
information can then be linked to a Contact Record (displays the record whenever you access that topic).

The Knowledge Base consists of the Knowledge Base, and the Personal Base. Configure them to present newly
added information to the user, control user reading and updating privileges, and search for specific entries based
on user-defined criteria. Topic pages are arranged in outline format. Locate information by navigating through
different sections, conducting a search, or opening a linked file.

NOTE: Users with Master Rights can set up user access to the Knowledge Base; each connected user can set
up information in his or her Personal Base.

TIP: Knowledge Base material is stored in the InfoMine table.
Select from the following topics to learn more about managing Knowledge Base.

= Knowledge Base Toolbar
m Creating Knowledge Base Books, Folders, and Topics

m Editing Knowledge Base Books, Folders, and Topics

Knowledge Base Toolbar
& O3 X % 4

@& Adds a book to the Knowledge tree.
- Adds a folder to the selected book

E Adds a topic to the selected book or folder

Displays the Topic or Section Properties dialog box for the selected item.
0 Displays the Attach File tab of the Topic or Section Properties dialog box.
x Deletes the selected item.

e Displays a Table of Contents in the lower right pane of the selected book.
® Displays the Search dialog box and allows you enter search terms.

A Launches attachments, graphics, or other applications
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Accessing the Knowledge Base
Use the following steps to access the Knowledge Base.

Select Go To>>Knowledge Base, or select Knowledge Base from the main navigation pane. The Knowledge Base
window opens.

1. Use the Knowledge Base toolbar to navigate and manage.

2. View information by selecting a tab:
O Knowledge Base. Maintains information created by, for, and about an organization and available to
multiple users.

NOTE: Depending on rights, all users can potentially view all Knowledge Base topics. However, only users
with Master Rights can add, edit, or delete Knowledge Base items.

O Personal Base. Maintains information useful to an individual user that only the user can view and update.

NOTE: The only way to access a Personal Base is to log in to GoldMine as the user who created the Personal
Base.

3. Create, edit, and search the Knowledge Base and set security and notification for users. See Creating
Knowledge Base Books, Folders, and Topics and Editing Knowledge Base Books, Folders, and Topics.
Create and edit topic text and linked files. See Adding HTML Text to Knowledge Base Topics.

Click X to close.

Creating Knowledge Base Books, Folders, and Topics

Organize information in the either Knowledge Base or Personal Base by creating high level books, internal folders,
and pages to address individual topics.

Use the following procedure to create or Knowledge Base material.

1. Select Go To>>Knowledge Base, or select Knowledge Base from the main navigation panel. The Knowledge
Base window opens.

2. To create a Book, click the New Book toolbar icon. See Knowledge Base Toolbar.
The <new book> appears in the left pane.
Type a name and press Enter.
Click in the right pane to add HTML text or click the Attach a file toolbar icon to add an attachment.

TIP: Adding text or attachments at the book level is possible but will interfere with a book level
Table of Contents. Adding a TOC replaces the text on the book, folder, or topic.

5. To add a Folder, highlight the book to add the folder to and click the New Folder toolbar icon. See Knowledge
Base Toolbar.
O The <new folder> appears under the selected book.
O Type the name of the folder.
O Click in the right pane to add HTML text or click the Attach a file toolbar icon to add an attachment. See

Adding HTML Text to Knowledge Base Topics.

6. To add a Topic Page, highlight the book or the folder to add the topic to, and click the New Topic Page
toolbar icon. See Knowledge Base Toolbar.
O The <new page> appears under the selected book or folder.
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O Type the name of the topic.
O Click in the right pane to add HTML text or click the Attach a file toolbar icon to add an attachment.

Editing Knowledge Base Books, Folders, and Topics

You can change the structure of the organizational tree, add keywords, attach files, and set security.
1. Select the book or folder to edit.
2. Right-click and select Edit.
The Section Properties dialog box opens.

3. Click the Book, Attached File or Access tab.
O Book. Allows you to rename a book or add a subfolder.

To rename a book, at the Book field, type the new name of the book.
To add a folder, follow the directions on the screen.
O Attached File. Allows you to link existing files to your information.

To attach a file, at the Attached file field, type in the file name or click the ellipse button and then select a
file.

To synchronize the file, check the Synchronize the file checkbox to include the attachment when the
Knowledge Base information is synchronized to remote users.

Note that the File Information area fields will change according to the file you enter.

O Access. Sets reading and updating security access on books, folders, and topics. See Setting Security Access
on Knowledge Base Topics.

To set the Read access, follow the directions on the screen.
4. To edit a topic, select the topic, right-click on it and then select Edit.
The Topic Properties dialog box opens.
O Topic. Allows you to use keywords to speed up searches and to create a tree structure of the book.
At the Topic field, select the topic.

At the Keywords field, type the keywords separating each word using commas (,). See Adding Keywords
to Knowledge Base Topics.

At the Folder field, edit the tree structure of the book and folder by typing a new folder name after the
book name, separated by semi-colons.

Adding Keywords to Knowledge Base Topics

At the topic level, add keywords (one or more words that succinctly describe a document's contents.) to topics to
facilitate organization. Assigning a keyword to related topics makes searching more efficient.

1. Select a topic, right-click, and select Edit.
The Topic Properties dialog box opens.
2. Inthe Keyword text box, type a keyword or select a keyword from the F2 Lookup list.
NOTE: To input multiple keywords, insert commas between words. When creating F2 Lookup terms, use

semi-colons after each word. When selecting multiple entries, the words display with commas between
them.
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3.

Click OK.

Adding HTML Text to Knowledge Base Topics

Use the capabilities of HTML to create pages in the InfoCenter.

NOTE: The information provided here is specifically for the topic level, but is applicable at the Book and

Folder levels.
1. Inthe Knowledge Base window, click the right pane. A blinking cursor and the HTML toolbar appear.
2. Type the information into the page, or copy and paste it in from other sources.
3. Right-click the text pane and use the local menu options to format your document an add features.
The HTML lets you format the text in a pleasing display and add Internet hyperlinks and graphics.
4. Click Save.

Setting Security Access on Knowledge Base Topics

Set reading and updating security access on books, folders, and topics.

1.

Select a book, folder, or topic and right-click and select Edit. The Book, Section, or Topic Properties dialog box
opens.

Select the Access tab.

At the Read Access drop-down list, select the user or user group to grant Read permission.

If you want everyone to have access, leave as (public).

In the Update Access drop-down list, select the user or user group to grant Update permission.
If you want everyone to have access, leave as (public).

Click OK.

Configure Alarm Messages for GoldMine Connect

Alarms for upcoming activities can be sent to a mobile device as SMS messages (Short Message Service). This
enables users to receive reminders even when they are not logged in to GoldMine Web. After being configured in
GoldMine Premium Edition, users can receive text message reminders, and audible or vibration alerts.

Messaging must be configured within GoldMine Premium Edition in the following places:

m Enabling Activity Reminders in GoldMine Premium Edition
m Setting the Web Server URL

m Enable Receiving Messages for GoldMine Web Users

TIP: Modifying the SMS Template allows you to customize the content of the text messages.

Enabling Activity Reminders in GoldMine Premium Edition

You must enable messaging, before GoldMine Premium Edition can send Activity reminders to GoldMine Web
users.
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IMPORTANT: GoldMine Connect must be installed before you can enable activity reminders.

P W NR

5.

Log into GoldMine Premium Edition as a user with Master rights.

Open Tools > Configure > System Settings.

Click the Messaging tab.

Check the Enable GoldMine Messaging box.
O For Workgroup Installations: Change the logon account for the GoldMine Messaging Service.

a.

S

S® ™0 oo

Start > Settings > Control Panel > Administrative Tools > Services.
Select the GoldMine Messaging Service.

Right-click and select Properties.

Click the Log On tab.

Select the This account radio button.

Enter the GoldMine Windows account (e.g, gmmobile) and password.
Click OK.

Start the GoldMine Messaging Service.

Specify the GoldMine username used to send GoldMine Alarms from the Send from drop-down list.

NOTE: The selected username must have an email account already configured in their user options or they
will not receive reminder messages.

6. Click OK.

Modifying the SMS Template

The SMS Message contains text and macros that produce the reminder message. Modify the Message Template as
follows, to change the content that displays within the activity reminder message.

1.

2
3.
4

Log into GoldMine Premium Edition as a user with Master rights.

Open the Tools > Configure > System Settings.

Click the Messaging tab.

Modify the Message Template.

The Message Template field contains a combination of Text and Macros.

m Text: The alphanumeric characters before and/or after the Macro.

= Macro: Macros are marked with surrounding brackets (e.g., [date]).

5.

The following macros can be used in the message body:
[date] — date of an activity (CAL.ONDATE)
[time] — time of an activity (CAL.ONTIME)
[reference] — reference (CAL.REF)
[company] — linked contact name (Contact1l.Company)
[contact] — linked contact name (Contactl.Contact)
[phone] — linked contact name (Contact1.Phonel)

Click Show Example to view a sample message.

6. Click OK to save your changes.
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Setting the Web Server URL

The Alarm message includes a link to the Activity in the GoldMine database. The URL to the GoldMine Connect
web server must be defined in order to enable this feature.
1. Loginto GoldMine Premium Edition as a user with Master rights.
2. Open the Tools > Configure > GoldMine Connect.
3. Inthe Web server URL text box, enter the path to the site for GoldMine Web.
For example: http://yourcompany.com/goldmine/web
4. Click OK.

Enable Receiving Messages for GoldMine Web Users

After Enabling Activity Reminders in GoldMine Premium Edition, specify the GoldMine users who can receive
activity message reminders from GoldMine Premium Edition, and configure the message reception for their
mobile devices.

IMPORTANT: GoldMine Connect must be installed before enabling message reception.

Log into GoldMine Premium Edition as a user with Master rights.
Open the Tools menu and select Users’ Settings.

Select a GoldMine user and click Preferences.

On the <User’s> Options page, select the Messaging tab.

Check the Send activity alarms as a message to my device box.

o vk wWNERE

Specify the GoldMine User’s e-mail address used for receiving SMS messages in the E-mail address for the
mobile device text box.

TIP: For assistance in determining the e-mail address, refer to the following article for a listing of
service providers’ SMS gateways: http://en.wikipedia.org/wiki/List_of SMS gateways

Click OK.

Repeat this process for other GoldMine Web users as needed.

Troubleshooting GoldMine Web

When troubleshooting GoldMine Web you must allow a user to Modify the GoldMine Connect Program folder.
This setting is not enabled by default. When enabled, it creates a Logs directory and a debug file for the device.
Once the issue is resolved and a debug file or log is no longer needed, we recommend changing permissions back
to the default.

Use the following procedure to create a debug file:
1. From the users computer, log in as Admin and navigate to Program Files > GoldMine Connect.

2. Right-click the folder and select Properties then select the Security tab.

3. Inthe Group or user names: pane, select the user name to check if the user has permissions to Modify.
If not, click Edit...

4. Ensure that the user name is highlighted (selected) and under the Allow column click Modify.
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This enables the user to create a debug file when using their mobile device.
5. Click Apply then click OK.
6. Click OK to exit the GoldMine Properties dialog.

Troubleshooting GoldMine Web

Use the following information to troubleshoot the installation or access.

User is unable to log into GoldMine Web

Users need both a Login and a Password to access GoldMine Web. Ensure that the user has both before they log
in.

Users cannot access GoldMine Web

The URL for web access may not be configured correctly. See "Grant Access to the GoldMine Connect Web Server"
in the GoldMine Connect Installation Guide for more information.

Customizing GoldMine

GoldMine provides extensive customization opportunities. You can configure your calendar, and customize record
types, field views, and fields and screens.

TIP: Before you begin to customize your installation of GoldMine we recommend that you read
and follow the recommendations in Best Practices for Customizing GoldMine.

Two files store user-related information: username.ini and username.tbi. The username is the GoldMine login
name. For example, JohnB.ini and the JohnB. tbi are files in the GoldMine directory.

Calendar Options

To customize Calendar options see the following sections:
= Holidays: Holiday categories and holidays to display.
(see To Configure the Calendar Options Holidays Settings)

= Activity Details: How scheduled and completed activities display.
(see To Configure the Calendar Options Activity Details Settings)

= Publishing: iCalendar and Web publishing options.
(see Calendar Options Dialog Box, Publishing Tab in the GoldMine User's Guide)

= Free/Busy: How your scheduled busy times display.
(see Calendar Options Dialog Box, Free/BusyTab in the GoldMine User's Guide)
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Record Types

Record types are customized combinations of Primary Fields Views, Custom Screens, and GM+Views. Linked and
applied based on user-defined rules, record types determine what users see when working in GoldMine. The full
record type combination (Primary Field View, Custom Screens and GM+View) is an entity. Manage record types in
the Record Types Administration Center.

Effective use of the Record Types Administration Center depends on a workflow.

The Workflow: Creating Primary Fields Views, Custom Screens, and GM+Views
1. Defining Primary Fields Views (see Primary Field Views)
O Creating Primary Fields Views (see Creating Primary Field Views)
O Editing fields (see Editing Field Properties)
O Using Field Typing (see Customizing Field Typing)
2. Creating Custom Screens
O Creating Custom Screens (see Creating Custom Screens
O Adding Fields to Screens (see Adding Fields to Screens
O Editing fields (see Editing Field Properties)
O Using Field Typing (see Customizing Field Typing)
O Customizing Labels (see Customizing Field Typing
3. Creating GM+Views (see Creating GM+View Templates)
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Using the Record Types Administration Center

The Record Types Administration Center allows you to create and manage Contact Record customizations. Record
typing is powerful and dynamic, letting you customize the type of Contact Record GoldMine users see and
combine, within one database, what might appear to be disparate types of Contact Records.

To access the Record Types Administration Center, select Tools > Configure > Record Types.
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Users can perform searches for record types instead of field names which allows them to find information without

identifying a field name. Logical pick lists display field names for the record type.

Use the Record Types Administration Center to create Record Types based on combinations of different Primary
Field Views, Custom Screens, and GM+Views, and apply them in GoldMine based on your user-defined Record
Type Rules. The full record type combination (Primary Field View, Custom Screens, and GM+View) is an entity.

Examples:

O A manufacturing company uses GoldMine to track suppliers and customers. They use record typing to

create a Supplier record type and a Customer record type.

O Realtors use GoldMine to maintain information about properties, sellers, buyers, and real estate financing
sources. They use record typing to create customized record types for each category they work with.
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Part of the Record Typing is determining New Record Creation Options to specify fields displayed to a user who is
creating a record based on a record type. Available fields are limited to fields included in the selected record type
and are only available when the field value-based record type rules are activated.

NOTE: The New Record Creation Options, once configured, let you create new records based on record
types. Select File > New > New Default Record Type. A customized dialog box appears.

Also create and apply Record Type Rules to govern what record type displays based on a field value-based rule, or
to disable the rules. Rules can be as simple as when the value in the Acct. Type field is Property display the
Property record type; when the value is Buyer, display the Buyer record type; or when the value is Seller, display
the Seller Record type.

Creating Record Types

After creating the appropriate Primary Fields Views, Custom Screens, and GM+Views, create new Record Types. A
record type consists of a unique name and is composed of a combination of Primary Fields, Custom Screens, and
GM+Views. The combination of these components creates an record type entity.

1.
2.

Select Tools > Configure > Record Types. The Record Types Administration Center opens.

In the Record Types Details pane, right-click and select New Record Type or click the New Record Type

button _ on the toolbar. The Record Type Settings dialog box opens.

Specify:

O Record Type Name: A unique name for the record type.

O Relationship Tree Section Name: The name assigned to the relationship tree.

O Primary Fields drop-down list.:The Primary Fields View to associate with this record type.

O Custom Screens drop-down list: The Custom Screen to associate with this record type.

O GM+View drop-down list: The GM+View to associate with this record type.

To specify a different field layout for the New Default Record Type dialog, check New record dialog uses
different field layout and then select a layout from the New Record Layout pull-down menu.

Set as Default Record Type uses the current record type as default when record type rules are not met.
The default record type could be a generic view or the record type used by the largest number of users. Only
one record type can be the default at one time. Selecting this option on a different record type makes it the
default. Bold Type in the Record Types Details pane identifies the default record type.2023.1

Click OK to close the Record Type Settings dialog box.

Click the Apply Changes Z button.

Editing Record Types

GoldMine Administrator's Guide

Open the Tools menu and select Configure > Record Types. The Record Types Administration Center appears.
Expand the Record Types Details tree and expand Record Types. Select the Record Types to edit. The
associated Custom Screen, GM+View, and Primary Fields display in the upper right pane. The lower right pane
displays the fields (for Custom Screens and Primary Views) and the HTML template (for the GM+View) when
the object is selected in the upper right pane.

To edit change the Record Type Name, reconfigure new record selection options, or select new Primary
Fields, Custom Screens, or GM+Views, right-click and select Edit. The Record Type Settings dialog box
appears. Make necessary changes.
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4. Edit Primary Fields and Custom Screen fields by right-clicking on the field when it displays in the lower right
pane and select Edit. The Field Properties dialog box appears.

5. Edit GM+View templates by right-clicking on the GM+View in the upper right pane and select Edit. The Edit
<template name> GM+View dialog box appears.

6. Click the Apply Changes _ button to apply the changes to GoldMine records.

Configuring Record Type Rules

Record type rules are key to effective use of record types. They govern which record types display when the
conditions of the rules are met.

Select one of three rules to apply to the record types: use text boxes and drop-down lists, use dBASE expressions,
or disable rules. If no rules are configured, users can manually select Primary Fields Views, Custom Screens, and
GM+Views as they work in GoldMine. Apply only one set of rules at a time when working with record types.
1. Select Tools > Configure > Record Types.
The Record Types Administration Center opens.
2. Inthe Record Types Details pane, right-click on Record Type Rules and select Edit. The Rule Definition for
Record Type dialog box appears.

3. Select arule type:
O Field value-based: Evaluates the field for the specified values and displays the record type you select.
O dBase Expression result-based: Evaluates an expression that returns a string the name of a record type.
O Inactive (disable rules): Turns off the record type rules. When the rules are inactive, manually change the
primary field view, custom screen, or GM+View.

4. Click the Apply Changes _ button to apply the changes to your GoldMine records.
NOTE: If the rules are not met, GoldMine displays your default record type.

NOTE: Field value-based rules are limited to 32. If you have 33 or more, no rules are evaluated.

Creating Record Type Rules Based on dBASE Expressions

Use Record Type Rules to determine the displaying record type. Define rules by field values and dBASE
expressions, or make them inactive.

dBASE expressions are for advanced users. If you activate the dBASE expression rules, you cannot create new
records based on record types. Activate field value rules to create new records based on record types.

1. Select dBase Expression result-based on the Rule Definition for Record Type dialog box. The dialog box
displays an Expression text box.
In the text box, type or copy and paste the expression you are creating.
As you type or modify the expression, use the Insert Record type from List button to select a record type
from the list and guarantee data consistency.
After creating your expression, click OK and then Apply Changes on the Record Types Administration toolbar.
To verify your record type selection is based on rules, right-click in the primary fields and select Select
Primary Fields. On the expanded local menu, Rules-Based selection should have a check mark next to it;
otherwise, select Rules-Based selection.
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Expressions Using Values Corresponding to Record Type Names
Expressions Using Values Corresponding to Record Type Names

When the string value in the field being evaluated corresponds to the name of the record type, use these
expressions:

Simple Expression

Assuming Key1 can have Supplier, Customer, or Equipment as a value and assuming you have record types named
Supplier, Customer, and Equipment, use this expression:

trim(contactl->keyl)

Results: Each record where the keyl field value equals Supplier, the Supplier record type displays. Each record
where the keyl field value equals Customer, the Customer record type displays. Each record where the key1 field
value equals Equipment, the Equipment record type displays.

Sum of Two Fields Expression

Assuming Key1 can contain the value Supplier or Customer and Key2 can contain Insured or Uninsured and
assuming four record types are named Supplier Insured, Supplier Uninsured, Customer Insured, Customer
Uninsured, use this expression:

trim(contactl->keyl)+ +trim(contactl->key2)

Results: The expression returns <Keylstring><space><Key2string>. If the value in Key1 is Supplier and the value in
Key2 is Uninsured, then the Supplier Uninsured record type display for the record. When moving to another record
where the value of Key1 is Customer and the value in Key2 is Insured, then the Customer Insured record type
display for the record.

If...Then...Else Expressions

An even more effective expression is the dBASE IIF statement. The structure of the iif statement, for example, iif
((trim(contactl1->key1)="Supplier"),"Supplier","Customer") reads as: If the statement is true (contact1-

>key1)="Supplier"), then display the Supplier record type, else (if statement is not true) display the Customer
record type.

Simple IIF Expression

Assuming Key1 can have Supplier or Customer as a value and assuming record types are named Supplier and
Customer, use this expression:

iif((trim(contactl->keyl)="Supplier"),"Supplier"”,"Customer")

Results: For each record where the Key1 field value equals Supplier, the Supplier record type displays; otherwise
the Customer record type displays.
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Complex IIF with .AND. Expression

Assuming Key1 can contain the value Supplier or Customer and Key2 can contain Insured or Uninsured and
assuming four record types are named Supplier Insured, Supplier Uninsured, Customer Insured, Customer
Uninsured, use this expression:

(iif((trim(contactl->keyl)="supplier™).and. (trim(contactl-
>key2)="Insured"),"Supplier Insured","Supplier Uninsured"))

Results: If the value in Key1 is Supplier and the value in Key2 is Insured, then the Supplier Insured record type
display for the record. When moving to another record where the value of Key1 is Supplier and the value in Key2 is
Pending, the Supplier Uninsured record type displays for the record.

Complex Multiple IIF Expression

Assuming Key1 can have Supplier, Customer, or Equipment as a value and assuming record types are named
Supplier, Customer, Equipment, and Standard, use this expression:

iif(contactl->keyl="supplier","supplier",iif(contactl-
>keyl="cCustomer","Customer",iif(contactl->keyl="Equipment"”,"Equipment"”,"Standard")))

Results: If the value in Key1 is Supplier, display the Supplier record type. If the value is not Supplier, evaluate
whether Key1 is Customer. If the value is Customer, display the Customer record type; otherwise, evaluate
whether Key1 is Equipment. If it is Equipment, display the Equipment record; otherwise, display the Standard
record type.

Creating Record Type Rules Based on Field Values

Use Record Type Rules to determine the record type that displays. Define the rules by field values, or make them
inactive.

Field value-based rules are the easiest to use and are required for creating new records based on record types.

To create field value rule, select Field value-based on the Rule Definition for Record Type dialog box. Field value-
based rules evaluate the value in only one field at a time, but can trigger the display of different record types
depending on the value in the field.

The dialog box displays field names, values, and record types.

1. Click New to add a new value/record type rule to the list.

2. Select afield in the Field Name drop-down list.
NOTE: Although you can have several field value-based rules configured on fields, the field displayed in the
Field Name text box is the only field evaluated by the rules. To evaluate from a different field, select the
field in the drop-down list. Rules configured on the newly selected field go into effect when you apply
changes

3. Inthe Field Value text box, type or select a value in the F2 Lookup list.

4. Select a Rec. Type in the drop-down list.

5. Toremove a rule, highlight the rule and click Delete.
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6.

7.

When finished, click OK.

Click the Apply Changes Z button.

To verify your record type selection is based on rules, right-click in the primary fields and select Select
Primary Fields. On the expanded local menu, Rules-Based selection should have a check mark next to it;
otherwise, select Rules-Based selection.

Primary Fields Views

Open the Tools menu and select Configure > Record Types. The Record Types Administration Center appears.

Expand the Record Types Details tree and expand Primary Fields Views. Select the Primary Fields View to
edit. The fields appear in the upper right pane.

To change the name or the access to the view, right-click the view name and select Edit. The Main View
Profile dialog box appears. Make necessary changes.

To edit field properties (for example, to make a field a required field), right-click on the field in the upper right
pane and select Edit. The Fields Properties dialog box appears. Make necessary changes.

Click the Apply Changes Z button to apply the changes to GoldMine records.

Editing Custom Screens

Open the Tools menu and select Configure > Record Types. The Record Types Administration Center appears.

Expand the Record Types Details tree and expand Custom Screens. Select the Custom Screen to edit. The
fields appear in the upper-right pane.

To change the name, the tab, or the access to the view, right-click the view name and select Edit. The Custom
Screen Profile dialog box appears. Make necessary changes.

To edit field properties (for example, to make a field a required field), right-click the field in the upper right
pane and select Edit. The Fields Properties dialog box appears. Make necessary changes.

Click the Apply Changes _ button to apply the changes to GoldMine records.

Editing GM+Views

GoldMine Administrator's Guide

Open the Tools menu and select Configure > Record Types. The Record Types Administration Center appears.

Expand the Record Types Details tree and expand GM+Views. Select the GM+Views to edit. The template
name appears in the upper right pane and the view of the template displays in the lower right pane.

To change the name and edit the template, right-click on the view name and select Edit. The Edit <template
name> GM+View dialog box appears. Make necessary changes.

Click the Apply Changes _ button to apply the changes to GoldMine records.
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Viewing the Master List of Fields

The Master Field List provide you with a quick way to look up the field name in the database corresponding to a
field you see in the user interface (Ul).

The Master Field List is the last object on the Record Types Details tree on the Record Types Administration Center
(Tools > Configure > Record Types). The list contains all field properties (both custom and default) and allows you
to view and manage the fields by selecting the field and clicking the Edit Selected button or double-clicknig the

field.
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With the Master Field List you can quickly look up the database name for all fields without having to manually
open each one and check its properties. This makes it easier to map fields during import or export when using the

Import/Export Wizard.

Primary Field Views

Primary field views are customized views of primary fields. Primary fields are in the upper pane of a Contact
Record and are Contact1 fields.

GoldMine now allows you to move fields around the screen as your needs dictate. The customizations can include
changing the displayed label or color for a field or hiding a field. Apply many changes to many fields, creating a
unique view for a type of record you are creating, and save the combination of customization as a primary fields

view.

Create as many primary field views as needed. The only set limit to the number of views in GoldMine is the
amount of available computer memory.
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Creating a primary field view relies primarily on the field typing. Use field typing to customize the look of the fields
and the values displayed in GoldMine's primary and user-defined fields.

Primary field views are a key component of record typing in the Record Types Administration Center. For more
information, see About the Record Types Administration Center.

Use Primary Fields Views To:
= Create Primary Fields Views (see Creating Primary Field Views)
m Customize Primary Fields (see Editing Field Properties)
m Edit Primary Fields Views (see Editing Field Properties (Profile Tab))
= Add to Record Type (see Record Types and Contact Records)
m Delete Primary Fields Views (see Deleting Primary Field Views)

= Manually Change Primary Fields Views (see Manually Changing Primary Field Views)

Customizing Primary Fields

Primary fields appear in the upper pane of the contact record. Many fields are indexed fields. You can modify the
field labels and data display with colors or other expressions using the fields properties to create custom field

typing.
NOTE: Whenever a form of DDE is used, the external application extracts data based on the hard-coded
Field Name regardless of the field label.

After you make the modifications to the primary fields, save as primary fields views. The Contact1 table stores
primary field data.

1. Right-click on the field and select Properties. The Field Properties dialog box appears.

2. Modify field properties using the Field Properties dialog box.

Creating Primary Field Views

Primary field views are customized modifications to the primary fields saved as views. They are in the upper pane
of a Contact record.

The GM+View template is chosen automatically. It is driven by the record type, but can be over-ridden under Web
> Setup GM+View > Rules (see Creating GM+View Rules). Manually changing the Primary Fields View does not
change the GM+View.

NOTE: When creating your first primary field views, create a named view based on your current view
before modifying the fields to create your new view.

TIP: If you already have several primary field views, to create a new one, select the view that
most closely resembles the view you are creating; create a new named view based on that view
before modifying the fields to create your new view.
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To Create a Primary Field View

IMPORTANT: There's a limit to how many fields you can add to a primary view. The upper limit is 129
fields. After that, GoldMine may crash on login or when a new contact is created. We recommend using

custom screens when numerous fields are required.

Before modifying the fields, right-click in the primary fields (top) pane and select Select Primary Fields.
2. Select a view from the menu.

The primary fields update to the selected view.
3. Right-click in the primary fields panes and select Screen Design.

The Screen Design toolbar appears and the contact record displays with a grid-like series of lines.

Select one of the following from the toolbar and then click OK:

O New. To add a new field to the view, click New and then select the field from the Place Field drop-down
box.

To add a new field to the list, click New Field and do the following:
- At the New Field field type a unique name for the new field.
- At the Description field type a brief description of the new field.
- At the Field Type field select the type of the new field and then add the number of characters in the Len
(length) and/or Date fields.
O Save As. Save the screen as a new Primary Fields View.
O Load. Load the new Primary Fields View.
O Rebuild. Rebuild the database and add the fields to the Contact2 table. Review details on rebuilding before
proceeding at About Maintaining Databases.
O Exit. Exit the Screen Designer.

4. Click the Save as a Primary Field. button.

The Main View Profile dialog box appears. Use this dialog box to name and set access on Primary Fields
Views. Complete the following fields and then click OK:

O Name. Type a descriptive name in the field.
O User Access. Select the user or user group to have access to this new group in the User Access. Select
(public) for all users to have access this view.

The new view appears in screen design mode and ready for modification.

5. To modify the fields in the view, see Customizing Primary Fields.
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Manually Changing Primary Field Views

Primary Fields Views are typically determined by the record types and record type rules configured in the Record
Types Administration Center. However, with permissions, manually change the displayed primary field view.

To Manually Change the Primary Field Views

Right-click in the primary fields of a record and select Select Primary Fields. The sub-menu includes Rule-Based
selection and a list of primary fields views. Then, on the menu, select the view to apply to the displayed record.
The record updates to selected primary fields view.

Deleting Primary Field Views

Deleting Primary Fields Views does not remove field data from the database.

1. Open the Tools menu and select Configure > Record Types. The Record Types Administration Center appears.
2. Expand the Record Types Details tree and expand Primary Fields Views.
3. Select the view to delete, right-click and select Delete. The view is removed from GoldMine.

Custom Fields and Screens

Apply several levels of customization to Contact records. When creating custom screens and fields, you have
greater flexibility in the information stored in GoldMine.

Customize GoldMine by:

m Creating custom screens (see Creating Custom Screens)

= Creating custom fields (see Creating Custom Fields)

m Changing field labels (see Editing Field Properties (Profile Tab))
m Customized field typing (see Customizing Field Typing)

Custom Screens

Custom screens let you group related custom fields together. Create up to 20 custom screens, each with up to 250
fields. Custom screen information is stored in the Fields5 table.

Custom Fields

Custom fields, also called user-defined fields, make GoldMine an adaptable program, able to meet the needs of a
broad range of businesses. Information about user-defined fields are stored in the Contact2, ContuDef, and Fields5
table. For more information about Fields and Details, see User-Defined Fields vs. Details.

GoldMine on an SQL database can store 1024 fields. For additional information, consult the knowledge base at
http://www.goldmine.com/goldmine-support/.

GoldMine Administrator's Guide Page 232 of 439


http://www.goldmine.com/goldmine-support/

GoldMine™®

The system administrator determines each field’s type. Fields can store the following:

= Character field type: Alphanumeric data.
= Numeric field type: Numeric data; required for the field to calculate values related to other numeric fields.
= Date field type: Contains dates.

When creating user-defined fields, plan your implementation: what is the field type, what data is going into the
field, will it be a calculating field, and will it be associated with other fields in a custom screen?

To create a field, select Tools > Configure > Custom Fields. The list of 10 user-defined fields and other user-
defined fields appear. The mechanism is the same for creating one field as for creating many fields; it makes the
repeated creation of fields easier by not returning to the screen designer after the one field is created.

Field Labels

Field properties determine the field's label in GoldMine. When changing labels on fields (whether primary fields or
user-defined fields) you have a limit of 15 characters for the label. To change the label, right-click its name and
select Properties. The Field Properties dialog box appears.

Field Typing

Use field typing to customize the look of field labels and values. The customization can include changing the label
or data color in a field based on the value in that field or in another field, hide labels and values, assign a generic
field use name to a field that can have different labels and values.

User-Defined Fields vs. Details

The GoldMine administrator must decide what type of field (user-defined or detail) is most appropriate for the
information being recorded.

When setting up a field as a Detail or user-defined field, consider:

= Details allow unlimited multiple entries without the need for the repetitive creation of fields and Lookup Tables.

m Unlike creating a new user-defined field, adding a new Detail does not allocate field space to every record in the
database; therefore, less time is required to perform system maintenance.

= All Details are indexed for fast searching and browsing.

m User-defined fields can be updated using the Lookup.ini.

m User-defined fields can be date, numeric, or character and allow for complex filtering.
= Filters can be built on user-defined fields only.

m Groups can be built on Detail.
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Creating Custom Screens

Custom screens are user-defined areas that appear under the Fields tab or as an individual tab. Use these screens
to logically group user-defined fields.

You can create up to 20 screens, each one with maximum of 250 fields.
Custom screens are a key component of the record typing in the Record Type Administration Center.

1. Select Tools > Configure > Custom Screens.
2. At the Custom Screens Setup dialog box, click New.
The Custom Screen Profile dialog box opens. See Custom Screen Profile Dialog Box.
3. After configuring the Custom Screen Profile dialog box, click OK.
The Custom Screens Setup dialog box reopens.
4. Click Close.

You can now add fields to your new custom screen.

Custom Screen Profile Dialog Box

1. Inthe Screen Name field, type the name (up to 20 characters) you want to appear in the Fields tab local
menu and on the configuration dialog boxes.
2. Inthe Tab Name field, type the name for the tab.

Leave this box blank for the screen to not display as an individual tab.

View Tab Name tips.

O Due to viewing limitations, a tab name should not exceed eight characters, and it should not contain
spaces.

O GoldMine alphabetizes tabs. To reorder tabs, place a number at the beginning of the tab name. The
number does not appear on the tab, but determines the position of the title within the bank. For
example, for the Reseller View tab to appear before the Mgt View tab, type 1Reseller in the Tab Name
field.

O To create a blank tab with no name on it, type two asterisks (**) in this field. The tab label remains blank.

3. Leave the User Access as (public) to let users view the screen, or select a user or user group from the drop-
down list.

4. Select This screen is available in the current Contact Set to let users see the screen listed in the Fields tab
local menu.

When this option is cleared, the screen is unavailable in the current contact set. If you have three contact

sets, disable the screen in only two of the databases, log on to each contact set and disable the option.

5. When finished, click OK.
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Creating Custom Fields

GoldMine's flexibility meets a range of business information needs. The ability to create user-defined custom fields
goes beyond the variety of options in GoldMine and better tailors the contact record to meet your company's
needs.

Plan custom field implementation by considering the following:

= What is the field-type: numeric, alpha, or both?
= What type of data will the field contain?
= Will the field calculate?

NOTE: When adding user-defined fields, create a custom screen (see Custom Screen Profile Dialog Box) to
display the related fields. Always back up your databases before creating user-defined fields.

TIP: Create telephone number fields that format numbers like other phone fields. Create a field
named UPHONEN, where n is a user-defined number.

To Create a Custom Field

1. Select Tools > Configure > Custom Fields.

2. At the User Defined Fields dialog box, select New.
The User Defined Field Profile dialog box opens.

3. Type a unique name, beginning with U, in the Field Name field (it can be up to nine alphanumeric characters
in length, including the U).
The field name should not contain spaces or special characters, such as asterisks (*), an underscore(_)
immediately following the U, or percent signs (%).

NOTE: The Field Name appears when inserting fields into Microsoft Word; therefore, make the field name
user-friendly and identifiable.

WARNING: User-defined field names must not use an underscore (_) immediately following the
U (example: U_fieldname). Fields named in this way will not synchronize and will result in data
loss. This will also prevent the field from being inserted into a Word or Excel template. Do not
use any of the following SQL reserved words as field names: UNION, UNIQUE, UNPIVOT, UPDATE,
UPDATETEXT, USE, USER.

4. Inthe Description field, type the field label to appear in the contact record. Field labels must not include an
apostrophe/single quote (‘) or double quote (“) within the label.
5. At the Field Type options select one of the following:
O Character. Formats data as a text string.
O Numeric. Formats data as numbers to run mathematical functions against.
O Date. Formats data as a date, month/day/year.
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6. Inthe Len field, type or select a field data length.
The maximum length for a character field is 256; numeric is 16.
7. The Dec field is available when creating a numeric field.
It sets the number of decimal places within the field. GoldMine assigns one character place to the decimal

point in determining field length. For example, create a field that can accept hold values up to 9.99 by
assigning a Len value of 4 and a Dec value of 2. This field applies to numeric data types.

8. Click OK.

The User Defined Fields dialog box reopens with your new field added to the list. Next, add the field to your
custom screen (see Adding Fields to Screens).

After fields are created, GoldMine will prompt you (the Master user) to rebuild the database for the fields to be
physically placed in the Contact2 table. You must restart the web server in order for the fields to be propagated to
GoldMine Web. Otherwise you will be unable to view or access the contact record.

IMPORTANT: Not restarting the web server after adding a new field could introduce inconsistent data in
database due to conflicts between GoldMine Premium Edition, and GoldMine Web when multiple users are
updating information.

Review help topics regarding maintaining your SQL database. See the support site for information on rebuilding.

Editing Field Properties

Field Properties determine the field type, label and data appearance, field location, label and data field size, and
field security.

Use the following procedure to edit the field properties.

1. Right-click on the field label and select Properties.
The Field Properties dialog box appears.

2. Configure the settings on these tabs and then click OK:

O Profile. Field labels and field data options. For more information on editing these properties, see Editing
Field Properties (Profile Tab).

O Color. Colors on the Contact record for the field label and field data. For more information on editing these
properties, see Editing Field Properties (Color Tab).

O Layout. Field size, position, and tab order. For more information on editing these properties, see Editing
Field Properties (Layout Tab).

O Security. Fields requiring data, users having read and update rights to the field, and options to update the
log on the History tab. For more information on editing these properties, see Editing Field Properties
(Security Tab).

3. Click OK after configuring the Field Properties.
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Editing Field Properties (Profile Tab)

1. Select the Profile tab. In the Field Label area, select Global Label and type the field label in the associated
field. The Global Label applies to all GoldMine databases.

Global Labels:

O Display in all databases unless there is a Local Label.

O Have a length limit of 15 characters, but are limited by the field label size.
O Are stored in the Contudef and Fields5 table in the database.

2. Type the field label in the Local Label field if the local label differs from the Global Label. The Local Label
applies only to the current database.

Local Labels:

O Display in the current database.
O Have a length limit of 15 characters, but are limited by the field label size.
O Are stored in the Contudef table in the database.
O Take precedence over the Global Label.

O Are always applied when the field is displayed within the corresponding contact set database, regardless of
Record Type or Primary Fields View being used.

NOTE: Global or Local Field must not include an apostrophe/single quote (‘) or double quote (“) within the

label.

3. Select Expression if editing an expression field.

See Adding Expression Fields to Screens for details about the Expression option and the Label Reference.

NOTE: Use expressions to create complex field typing (see Customizing Field Typing) related to displaying

and hiding the field label and data.

Remember these general rules for Label Types in the following table.

Label (Type)

Priority
(Versus Other Label
Types)

Stored with Contact
Set

(Different for each
Contact Set)

Stored with Field View
(Different for other
Record Types or view

types)

Global No Yes
2 - Overrides Global

Expression verriges &loba No No
Label Types
1 - Overrides both Global

Local and Expression Label Yes Yes

Types

4. Inthe Field Data area, select Name in Database.

The field name displays in the field. The All Fields button is active for user-defined fields, not primary contact

fields.
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5. Select All Fields to change the data field.
The User Defined Fields dialog box opens.

Select the new field data to display in the field. After selecting a new field, the Global Label remains the same;
however, the Local Label changes to reflect new data.

6. Select Expression if editing the data expression.
See Adding Expression Fields to Screens for details about the Expression option.

7. Configure the Color tab, Layout tab, and Security tab.

Editing Field Properties (Color Tab)

Right-click the field label and select Properties.
At the Field Properties dialog box, select the Color tab.
In the Label Color area, select Fixed Color and click Colors.
The Color dialog box opens.
4. Select the color from the palette to use as the label color.
O Select Define Custom Colors to create custom colors.
O Click Use default label color to reset the color to black.
5. Select Expression if you know the system number for the color.
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6. Type the number in the field.

NOTE: Use expressions to create more complex field typing, related to changing the color of field labels and
field data.

Examples:
Use expressions to create a variable color based on a more complex expression. For example, to display a
red label on Key1 if the field is empty and a black label if it not empty, use this expression: iif((len(trim
(contactl->Key1))=0),255,0). In the example 255 is the Windows color profile for red and 0 is the profile
for black.
Use field label expressions with predefined colors. For example, to flag companies with a credit limit of
$1000 or higher with a red field label and a green label for less than $1000, use this expression: color(iif
(contact2->ucredit>1000, "RED","GREEN")) where ucredit is the user-defined numeric field storing the
credit limit value.
If a user-defined field of type varchar is empty, change the color on the Company field label to red;
otherwise, it displays black. The expression to add to the Company field is:
iif(contact2->userdefinedfield=" ",color("RED"),color("BLACK")).
In the last two examples, the expressions are configured differently — Either is valid.
If the user-defined fields are set up with a type of date or numeric, it might be necessary to use additional
expressions to convert the values into a string value, in order to evaluate them. For example, for empty
date fields the following examples can be used:
iif((empty(dtos(contact2->udate))),color("Brightred"),color("Black™))
or
iif(dtos(contact2->udate) < ' ', color('Brightred'), color('Black'))
In the last two examples, the expressions are configured differently — Either is valid.
Use expressions to create more complex field typing, related to displaying and hiding the field label and
field data. For further information for using dBase expressions refer to
https://community.ivanti.com/docs/DOC-61794.

7. Inthe Data Color area, select Fixed Color and click Colors.

The Color dialog box opens.

8. Select the color from the palette to use as the data color.
O Select Define Custom Colors to create custom colors.
O Click Use default data color to reset the color to dark blue.

9. Select Expression if you know the system number for the color.
Type the number in the field.
10. Configure the Profile tab, the Layout tab, and the Security tab.
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Editing Field Properties (Layout Tab)

Right-click the field label and select Properties.
2. At the Field Properties dialog box, select the Layout tab to configure field size and position and to select field
tab order.
3. Inthe Field Size & Position area, configure these by typing in numbers or increasing or decreasing the values
with the up and down arrows for each field:
O Field Label Size. Sets the size of the field label (up to 15 characters).
O Data Size. Sets the size of the data field to display. To increase the actual size of a field, select File >
Configure > Custom Fields (see Creating Custom Fields).
O (:) Row (y): and Column (x). Sets the placement of the field based on a grid of rows and columns. Refine
field placement after dragging and dropping.
4. Inthe Field Order area, Position field, type or select the numbered tab order for the field.

NOTE: Increase data entry efficiency by setting the field tabs in the order the data should be entered.

5. Click Screen Fields to view field order on the active Field Screen.
6. Configure the Profile tab, the Color tab, and the Security tab.

Editing Field Properties (Security Tab)

NOTE: When using GoldMine Web there is no alert for Required Fields. Instead, the field displays a
placeholder message requesting data and is outlined in red. Entering data removes the validation message.
If no data is entered for a required field, you will be unable to save the record.

When settings are changed and saved in GoldMine Premium Edition, the changes and any validation
messages will appear (or dissapear) the next time the GoldMine Web window is refreshed.

1. Right-click the field label and select Properties.
2. Inthe Field Properties dialog box, select the Security tab to configure the Field Data Entry Requirement,
configure Field Access, and turn on Field Auditing.
3. Inthe Field Data Entry Requirement area, select Required Data Entry to force users to fill in the field.
O A required field displays on the contact record with a red box around it.
O If the Required Data Entry flag is set, but the record was not modified in any way, no alert is displayed
when the user navigates to a different contact record.
O If the record was modified and there is a required field that was left empty, the Required Field(s)s Alert
dialog box appears reminding the user to complete the field before navigating to a different record.
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Required Fields Alert Dialog Box

The Required Fields Alert dialog box appears when saving or leaving a Contact Record with one or more
fields requiring data.

WARNING: Required Field(s) Alert! X

“fiou are being notified that this record containg field(z) with
‘Required Entry' Secunty zettingz, Before continuing, pleaze
enter the required data for the field(z) listed below,

E-mail

Skip Required Entry > l [ Ok

When the Required Fields Alert dialog box appears, select either:
- OK to close the dialog box, allowing you to add data to the fields.

- Skip Required Entry to expand the dialog box allowing you specify the reason and authorize the
override.

O In the Reason text box, type the reason for not updating the field or select the reason
from the F2 Lookup list.

Q In the Authorizing user drop-down list, select the user with permission to override the
entry.

Q Type the user's Password and then click Authorized. Save the Contact Record without
the required data; an Override activity is added to the History tab of the record.

After the record modifications are complete and the user navigates to another record, the record is
saved.

O If a required field is overridden, an Override activity is added to the associated History tab with a Result
code of OVR. The record is not removed when the field is updated and can only be deleted by a user with
Master rights.
4. Inthe Field Access area, leave the Read Rights as (public) to allow users to view field data.
O To limit user access to fields, select a user or user group from the drop-down list.
O If Required Data Entry is selected, the field must have (public) read and update rights.

NOTE: This setting does not override record ownership and record curtaining. If record ownership is
assigned and record curtaining is activated, only the owning user or user group sees the field.
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5. To set Update rights, select the user or user group from the drop-down list.
Only the selected user or user group can update field data. To let users update the field, leave as (public).

NOTE: This setting does not override record ownership. If record ownership as been assigned, only the
owning user or user group can update the field.

6. Inthe Field Audit area, select Log changes in history to record changes made to the field data.
NOTE: The record is kept on the History tab with an Activity code of Other and a Result code of LOG.
7. Configure the Profile tab, the Color tab, and the Layout tab.

Adding Expression Fields to Screens

Use expressions to create titles or text messages on screen or to create calculated fields (fields that contain a
mathematical expression rather than data). Calculated fields have no value; they only display a value, so reporting
or filtering cannot take place on the field. If filtering or reporting is required, create a field and use the Lookup.ini

to calculate its value. The Lookup.in1i returns a value.
Use the following procedure to add an expression field to a screen.
1. Select the Fields tab and right-click in the area under the tab. Select the screen to which you are adding the
field.
The selected custom screen becomes active under the Fields tab.
2. Right-click and select Screen Design.
The GoldMine Screen Designer Toolbar toolbar appears with a grid-like background in the Contact record (see
Adding Fields to Screens).
Click New on the design toolbar to open the Place Field dialog box.
At the Field drop-down list; select -- dBASE Expression --.
5. Click OK.
The field box appears in the upper left corner of the Fields tab. Drag and drop the field in the desired location
on the Field Screen.
Double-click to open the Field Properties dialog box.
In the Field Label area on the Type tab, select either:
O Global Label. Designate the Global Label that applies to all databases. With Expression fields, the Local
Label is not an option.
O Expression. Type text in quotes or type a field expression.
Examples:
- To create a text expression label, type Total:in the Field Label area Expression box. GoldMine displays
Total: as the field label.
- To create a field expression label, type Contact1->Company in the Expression box. GoldMine displays
the first 15 characters of the company name as the field label.
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8. If you use Expression as a field label, type the Label Reference label for the expression field.

9. Inthe Field Data area, select Expression and type the expression that displays the field value.

Example:

For two numeric fields, called USUM1 and USUM2, create a calculation expression to add them together. For
example, Contact2->USUM1+Contact2->USUM2. Remember, you cannot report on the total value. If you create a
complex expression, test it using the dBASE Expression Tester.

Customizing Field Typing

Use field typing to customize the look of field labels and values, including changing the label or data color in a field
based on the value in that field or another field, hide labels and values, assign a generic field use name to a field
that can have different labels and values. Create custom views for different users or user groups, or let users
switch between customized views. Field typing is the first level of customization you can add to primary field views
and record types.

Use the following procedure to customize a field type

1. Right-click on the field label and select Properties.

2. At the Field Properties dialog box, select the Profile or Color tab as needed.
The Profile tab holds the settings for the field label and data.
The Color tab holds settings for the label color and field data color.
Examples:
O Field Type

Change the text of the label depending on the value in that field or in another field. The following
example displays the field label as all capital letters if the field is blank and as initial capital if it contains a
value. This expression is added to the Field Label Expression box on the Profile tab for the Key1 field.

iif((Ten(trim(contactl->keyl))=0), "ACCT TYPE:","Acct Type:")
Change the label depending on the value in another field. In the following example the country field is
evaluated to determine what is displayed as the Zip field label. This expression is added to the Field Label
Expression field on the Profile tab for the Zip field.

iif(Cupper(contactl->country)="U.S.A.").or.(len(trim(contactl-
>country))=0),"zip:","PostCode:")

O Field Color

GoldMine provides several predefined color choices or you can specify the Windows profile color
number. Add the expressions to the Label Color Expression field to affect the label or to the Data Color
Expression field to affect the data color.

- Using Predefined Colors
iif(contactl->keyl=" ", color("red"),color("black™))
- Using Windows Color Profile Codes
iif((Ten(trim(contactl->keyl))=0),255,0)

3. After customizing field typing (saved to your current view), save the customizations as a new Primary Fields
View.
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Inserting Labels in Reports

1. Right-click the report template and select Insert > Label.
An edit box opens. Drag the edit box to the desired location and click to place.

2. The box shows the word Label, Double-click the label box and the Text Field Parameters dialog box opens.
NOTE: Labels appear on the report regardless of whether the field contains data.

3. the Text field, type the words to appear in the label.

In the Text Position area, select the Horizontal and Vertical placement of the text within the label box.
Click Outline to create an outline of the text field and set the Line Properties.

Click Background to create a background color and type within the label box.

Click Font to select the text font.

Click OK to save and close the text parameters.

Hiding Field Labels and Values

Hide the label and the value based on the value in the field or in another field using the Label Color Expression
and the Data Color Expression fields.

® N o v k&

In the following example, the label and data for the Source field are hidden if the Key1 field value is Employee.
Example

To hide both the label and the data, add the expression to the Label Color Expression field and the Data Color
Expression field in the Field Properties of the Source field.
iif((Contactl->keyl)="Employee",-2,-1)
NOTE: In this example the expression looks for an exact match with Employee. If the Key1 field data is

entered as employee, the expression fails and the Source field and data remain visible. Force valid data
with F2 Lookup lists to keep data entry consistent.

Combining Hiding and Color

To effectively use color and hiding, add expressions in several Field Property areas. Add this data to the Field
Properties of the Source field:

Use the following procedure to combine hiding and color.

1. Right-click on the Source field and select Properties.
The Field Properties dialog box open:s.
On the Profile tab, select Expression in the Field Label area.

Copy this into the Expression field:

iif((len(trim(contactl->source))=0).and.(trim(contactl-
>keyl)<>"Employee™),"SOURCE:", "Source:")

4. Select the Color tab.
5. Select Expression in the Label Color area.
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6. Copy this into the Expression text field:

iif((Ten(trim(contactl->source))=0).and.trim(contactl->keyl)<>"Employee",b255,iif
(contactl->keyl="Employee",-2,-1))

7. Select Expression in the Data Color area and copy the following:

iif((len(trim(contactl->source))=0).and.trim(contactl->keyl)<>"Employee",b255,iif
(contactl->keyl="Employee",-2,-1))

8. Click OK to save the changes.

Results: If the Key1 field contains the value Employee, the Source field label and value are hidden. If the Key1l
field does not contain Employee, and the Source field is empty, the Source field label displays SOURCE:; if
there is a value, the field label displays Source: in the default color.

Adding Fields to Screens

After you have created the fields and screens, place these types of fields on the screens:

= Fields. Hold data.
= Expression fields. Display titles, messages, or mathematical calculations based on other fields.
Use the Screen Designer to place the fields on screens. Only users with Master Rights can access the Screen

Designer. The Screen Designer lets you click and drag fields in the display. Only unindexed fields can be dragged
from the upper panes to the Fields tab area.

NOTE: If asked to rebuild the database, review Help topics regarding rebuilding and maintaining SQL.
Use the following procedure to add fields to a screen.
1. Atthe Screen Designer, select the Fields tab and right-click in the area under the tab.
2. Select the screen to which you are adding the field.
The selected custom screen becomes active under the Fields tab.
3. Right-click and select Screen Design.

The GoldMine Screen Designer Toolbar appears with a grid-like background in the contact record.

NOTE: Changing the field order position of Company, Contact, Phonel, or any of the Key 1-5 fields can
cause problems—especially with synchronization and querying the database.

The Screen Design Toolbar appears when designing primary fields or Fields tab screens.

Right-click in the field area of the Fields tab and select Screen Design. The Screen Design Toolbar appears
and the Contact Record displays a grid-like series of lines.

- New: Create a field.

- Save As: Save the screen as a new Primary Fields View.
- Load: Load the selected Primary Fields View.

- Rebuild: Rebuild the database and add the fields to the Contact2 table. Review details on rebuilding
before proceeding.

- Exit: Exit the screen designer.

4. Click New on the design toolbar. The Place Field dialog box opens.
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5. From the Field drop-down list, select the field to place on the screen.
TIP: Click New Field to create a new field without accessing Tools > Configure > Custom Fields.

6. Click OK. The field appears in the upper left corner of the Fields tab. Drag and drop the field in the desired
location on the Field Screen.

NOTE: When working with Row and Column entries, do not delete indexed fields from the primary Contact
Record display or move indexed fields to custom user screens. Moving or deleting indexed fields can reduce
GoldMine’s ability to find records based on these fields when using search commands from the Lookup
menu.

7. Click the field. The Field Properties dialog box opens.

8. Make changes to the Profile, Color, Layout, and Security tabs and click OK.

The field is placed on the screen with an n/a in the data area.
9. Log out and back into GoldMine to see the field.
10. Select File > Exit and then relaunch GoldMine.

About the GM+View Tab

Create a customizable information page using HTML capabilities. Display images, linked documents, or inserted
GoldMine fields. Create several templates, set default templates, and then create rules controlling what template
displays for contacts meeting the rules.

The tab uses Internet Explorer, so the local menu and HTML design options are |E-based. Settings in the IE menu
(View > Text Size) control font size.
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Information in the tab stores in the Mailbox table and synchronizes to remote users. Users with Master Rights can
create or edit a template by selecting Web > Setup GM+Browser. The GM+Browser Tab Settings dialog box opens.

GM-+View Tab Settings X)

Then GM +View bab lats pou creste HTML-bazed page: to display any kind of infoemahion ralated o the contach onscieen

You can add fields from GoldMine, inks 1o the Web (ke a map (o the contact's location]. or any type of content such oz
pichunes, sound flaz, oo video chpe nbo & G+Vies,

To begn. please chok Hew' to create a GM«Wiew lemplate,
Templabe Lid Set Defaudl GM +View

airplsl ow musd speciy o “delaull” G +iew, which GoldMine:

|:Ta — [E] vall desplay foo all pouw confacts

Fropery v
Audaz Freriew Template based on Contact

To test 2o G Vi lamplate, highlight the lemplate and
theen bk, ook up' 10 find a contact 1o see how the

G +View tamplate looks vath that corlact, usng the
GM-+ieww Prenvews vandow bedow,

[ Prev |[I.cu:kupil Mext ]

G+ Prawsew

Sample GM+View using local graphics files. Other sample GM+Views are available by #u
right-clicking and selecting the name from the local menu. Please review the README
file for important information on using GM+Views with Internet content.

Images: wow.freeimages.co.uk

Lok ][ coce |

Views on this tab are a key component of the record-typing used in the Record Type Administration Center. If
record type rules are activated, right-click in the tab area and select another view; or, to reactivate the rules, right-
click in the tab area and select Rules-Based Selection.

About the GM+Browser

This floating window allows you to have important GM+View and other Web pages at your fingertips from within
GoldMine, regardless of the contact displayed.

From the menu bar, select Web > GM+Browser. GM+Browser appears. Your Microsoft Internet Explorer home
page is displayed in the Browser.
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Configuring GM+Browser

1. Inthe GM+Browser tab bar, click the GM+Browser Setup button.

The setup page appears.

™ GMsBrowser

FrontRange Scolutions Inc. - Browser | GM+Browser Setup

Awailable
Propery
Car

Givi+Browser is a floating window that displays Gi+Views and o[iie: web content.
Use GM-+Browser Setup to select the Gh+Views to display.

To include a GM+View within the Gh+Browser window, salact it from the Awailable
list below and click the right amow button. To show additional Web browser tabs
within the GM+Erowser window, enter the desired number of tabs below,

ﬂl
ﬂ

Clear All | Add Al |

Add |1_ Browser tabs

Sou

Selected

2. From the Available list, highlight an available GM+View (such as, Property, from the demo data).

NOTE: This list is autofilled based on all available GM+View templates.

3. Click the [>>] move button to move the Property view to the Selected list.

4. To make all views available, click Add All. All Available views move to the Selected list.

Available

>
<

Clear Al | Add All |

Add IQ_ Browser tabs

Save |

Selected

Property
Car

5. To create a placeholder for other Web pages in GM+Browser, in the Add _ Browser Tabs field, type 2.
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6. Click Save. A tab for the Property and Car views and an extra Browser tab now appear in the GM+Browser
tab bar.

":-: GM+Browser

FrontRange Solutions Inc. - Browser  Browser  Car Property  GM+Browser Setup
|| || http:tiwww.frontrange.com/ ~| [ Go | [ Refresh |

7. Click the unassigned Browser tab. It loads the default Web page until changed.

™2 GM+Browser E”El E'

FrontRange Solutions Inc. - Browser | | FrontRgage Solutions Inc. - Browser = Car Pal»
“< || || nttp:tiwew.frontrange.com/ ) ~| [ Go | [ Refresh |
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8.

In the address bar, type the appropriate Web address of a different Web page to assign to this tab and click

Go (alternatively, you can navigate to the appropriate page through the default page). The tab title changes

to the assigned page.

@ GM+Browser
Home | GoldMine CRM - Simple, Affordable, Proven - GoldMine - Browser

Ld| b2diihttp ihwasnw.goldmine.comd

GM+Browser Setup

DEMO Products Pricing Partners On-Demand Webinars

GoldMine™

SIMPLE | AFFORDABLE | PROVEN
OVER 25 YEARS OF CRM SOLUTIONS

-

EXPLORE GOLDMINE VIEW A DEMO

Explore GoldMine and CRM capabilities Take a tour of GoldMine CRM

I WANT TO...
D RUN MY BUSINESS MORE EFFICIENTLY
HR, Support and Marketing also benefit from CRM.
PY GROW MY BUSINESS

Five tips to using GoldMine CRM for better sales productivity.

USA 1-800-443-5457 or in the UK +44 (01344407003) 9| ¥ A7

=N Bk =5
~ [[Go | [Refrest]

Contact Resources Support  Q

m

GET STARTED

Simple, affordable & proven CRM

NOTE: When the tab bar exceeds the size of the GM+Browser window, forward and back buttons appear
on the right side of the bar. Use these buttons to navigate to additional tabs. Or, resize the window.

O As you work in GoldMine, minimize GM+Browser or leave it open.
O If you click a Contact record, GM+Browser moves behind the record.

O When you close this instance of GM+Browser, it retains all settings except the additional Browser tab

addresses.
O The Browser tabs always display ahead of the GM+View tabs in the tab bar
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Working with GM+View Templates

Create a customizable information page using HTML capabilities. Display images, linked documents, or inserted
GoldMine fields. Create several templates, set default templates, and then create rules controlling what template
displays for contacts meeting the rules.

The tab uses Internet Explorer, so the local menu and HTML design options are |E-based. Settings in the IE menu
(View > Text Size) control font size.

Information in the tab stores in the Mailbox table and synchronizes to remote users. Users with Master Rights can
create or edit a template by selecting Web > Setup GM+View. The GM+View Tab Settings dialog box appears.

Views on this tab are a key component of the record-typing used in the Record Type Administration Center. If
record type rules are activated, right-click in the tab area and select another view; or, to reactivate the rules, right-
click in the tab area and select Rules-Based Selection.

NOTE: To integrate Internet-based content within the GM+View tab, we recommend using JavaScript,
ActiveX objects, or other similar methods. It is strongly advised that you do not use the IFRAMES or
FRAMES/FRAMESET HTML tags.

Creating GM+View Templates

Use the following procedure to create a GM+View template.

1. Select Web > Setup GM+View.

The GM+View Tab Settings dialog box opens.
2. Inthe Template List area, click New.

The Edit GM+View dialog box opens.

NOTE: Select Edit to change an existing template, or Rules to set the display rules.

3. Type a name in the Template Name field.
4. Click in the design box to activate the template design toolbar.

5. Design using these toolbar options (or right-click and Select):
O Font. Formats fonts.
O Paragraph. Sets alignment and check spelling.
O Style. Selects from Normal, Formatted, Address, Heading.
O Picture. Inserts images stored in shared directories. See To Insert Pictures in GM+View Templates.
O Insert HyperlLink. Inserts a hyperlink to a Web site.
O Insert Fields. Inserts GoldMine fields (user name and contact information), linked images, or linked
documents.
O Insert Background Image. Browses to the location of the image file.
O Remove Background Image. Deletes the background.
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O Spell check. Checks spelling.

O Save as file. Saves to a location.

O Print. Prints.

O Edit HTML Source. Edits the template directly in the HTML code.

Examples:
Hyperlink in Template
To insert a fixed hyperlink, type the following in the HTML code:
<A href="https://www.goldmine.com.com/">GoldMine</A>
This inserts a hyperlink to the https://www.goldmine.com/ Web site with GoldMine as the label.

Display Full Web Page
This code example configures a GM+View template to display the GoldMine Web site as a GM+View
template:

<!DOCTYPE HTML PUBLIC "-//w3C//DTD HTML 4.0 Transitional//EN">

<HTML><HEAD>

<STYLE type=text/css> P, UL, OL, DL, DIR, MENU, PRE { margin: O

auto; }</STYLE>

<META content="MSHTML 6.00.2800.1264" name=GENERATOR></HEAD>

<BODY leftMargin=1 topMargin=1 rightMargin=1><FONT face="MS Sans Serif"

color=#ff0000 size=4>

<DIV>Please wait while the GoldMine web Site loads....... </DIV>
<SCRIPT>

window.Tocation.href = "http://www.goldmine.com/"

</SCRIPT>

</FONT></BODY></HTML>
6. Right-click in the design box and select Save.

Editing GM+View Templates

After creating templates, edit them as needed. There are several ways to access the Edit <template name>
GM+View dialog box. The dialog box is used when you are creating a new template and when you are editing an

existing template.
1. Open the Edit <template name> GM+View dialog box.
O Select Web > Setup GM+View. The GM+View Tab Settings dialog box appears. Click Edit. The Edit
<template name> GM+View dialog box appears.

O Select Tools > Configure > Record Types. The Record Types Administration Center appears. Expand
GM+Views. Right-click the GM+View name and select Edit. The Edit <template name> GM+View dialog

box appears.
In the Template Name text box, change the template name.
Click in the design box to activate the template design toolbar.
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To edit the template, use the toolbar options:
O Font: Formats fonts.
O Paragraph: Set alignment and check spelling.
O Style: Select from Normal, Formatted, Address, Heading.
O Insert:
- Picture: Inserts images stored in shared directories (see To Insert Pictures in GM+View Templates).

- Link: Inserts a hyperlink to a Web site (see To Insert Links in GM+View Templates).

- Fields: Inserts GoldMine fields (seeTo Insert Fields in GM+View Templates), linked images (see To Insert
Linked Images in GM+View Templates), and linked documents (see To Insert Linked Documents in
GM+View Templates).

- Insert Background Image: Browses to the location of the image file.
- Remove Background Image: Deletes the background.

O Spell check: Checks spelling.

O Save as file: Saves to a specific location.

O Print: Prints.

O Edit HTML Source: Edits the template directly in the HTML code.

Example:
To insert a fixed hyperlink by typing the following in the HTML code:
<A href="http://www.goldmine.com">GoldMine</A>
This inserts a hyperlink to the GoldMine Web site with GoldMine as the label.

Right-click in the design box and select Save.

To Insert Pictures in GM+View Templates

1.

vk wWwN

Place cursor in the design box where you want to insert the picture.

Right-click and select Insert > Insert Picture.

At the Picture dialog box, click Browse to select the Picture Source from a shared directory.
Type Alternative Text to describe the picture.

In the Layout area, select the Alignment from the drop-down list and type the number of pixels to use for the
Border Thickness.

In the Spacing area, type the number of pixels to use as the Horizontal and Vertical spacing around the
picture.

Click OK.

To Insert Links in GM+View Templates

1.

2
3.
4

GoldMine Administrator's Guide

Place cursor in the design box where you want to insert the link.

Right-click and select Insert > Insert Link.

At the Hyperlink dialog box, select hyperlink type from the Type drop-down list.
Type the appropriate Internet address in the URL field and then click OK.
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To Insert Fields in GM+View Templates

1.
2.
3.

4.

Place cursor in the design box where you want to insert the field.
Right-click and select Insert > Insert Field.
At the Field local menu, select the field to insert.

The field macro is inserted in the template (use <<&company>> to insert the appropriate company name).
The Contact Details expands to include more fields, including Linked Image and Linked Document File name.

Right-click and select Save.

To Insert Linked Images in GM+View Templates

1.
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At the GM+View design template dialog box, right-click and select Insert > Insert Field > Contact details >
Linked Image.

The Linked Image Field Properties dialog box opens.

Type the Linked Image (Links tab Document Name).

The name must be the one that appears in the Links tab Document field.

Type a description for the linked image in the HTML Alt (Alternative Text) Attribute field.
Select the Linked Image's Alignment from the drop-down list.

In the More HTML Attributes field, type the HTML code for the other formatting options.
Click OK.

To Insert Linked Documents in GM+View Templates

1.

3.

At the GM+View design template dialog box, right-click and select Insert field > Contact details > Linked
Document File name.

The statement <<LinkedIlmageFileName:?>> is inserted.

Replace the question mark (?) with the document name in the Document column of the Links tab
(<<LinkedIlmageFileName:MyDocument>>).

Save and Exit.

The path to the linked document displays on the GM+View tab.

Setting GM+View Default Templates

Set a default GM+View template to display for Records not meeting template rules.

1.
2.
3.

Select Web > Setup GM+View. The GM+View Tab Settings dialog box appears.
In the Set Default GM+View area, select the default template.
Click OK.

NOTE: To see the new template, users on other workstations must log out and back in.
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Creating GM+View Rules

Apply templates to particular contact records by creating rules. GoldMine evaluates a rule and if a Record meets
the criteria, the specified template is displayed. Create templates prior to creating rules.

Use the following procedure to create a GM+ View rule.

1. Select File > Configure > GM+View tab.
The GM+View Tab Settings dialog box opens.
2. In Template List, click Rules.
The GM+View Tab Rules for Template Selection dialog box opens.
The template rule selected becomes the primary set of rules that are applied to the GM+View templates:

O Field Value. See Creating GM+View Rules for Field Values.
O dBase Expression. See Creating GM+View Rules for dBASE Expressions.
O User Selected. See Creating GM+View Rules for the User Selected Option.

Creating GM+View Rules for Field Values

1. Select File > Configure > GM+View tab.
2. At the GM+View Tab Settings dialog box, click Rules.
3. Atthe GM+View Tab Rules for Template Selection dialog box, select Field Value.
4. Select a Field Name.
This is the field for which you will select the Field Value.
5. Click New.
The Field Value and Corresponding Template dialog box opens.
6. Inthe Field Value field, type the value to be the trigger for the rule.

If the values in the field are determined by F2 Lookup list, the right arrow on the Field Value text box will
display the F2 Lookup value for the field.

7. Select a Template.
This is the template that displays when the Field Value is triggered.
8. Click OK.

The GM+View Tab Rules for Template Selection dialog box reopens.

GoldMine Administrator's Guide Page 255 of 439



GoldMine™®

Creating GM+View Rules for dBASE Expressions

1. Select File > Configure > GM+View tab.
2. At the GM+View Tab Settings dialog box, Click Rules.
3. At the GM+View Tab Rules for Template Selection dialog box, select dBase Expression.
4. Type the dBASE expression in the Expression field.
Examples:

The expression used must return a string, and the string must be the name of one of the templates. One option is

iif, which functions as an if ... else statement:
iif(contact2->uacctbal<500, "GM+Viewl", "GM+View2")

In the above statement, GM+View1 and GM+View2 are defined templates. If the amount in the Account Balance

field is less than 500, the GM+View1 template displays. If the amount is over 500, the GM+View2 template
displays.

1if(trim(CONTACT1->KEY1)=="test","GM+Viewl", "GM+View2")

If the Keyl field is "test," then the GM+View1 template displays. If the value of Key1 is not equal to "test," then
the GM+View2 template displays. Take note of the double equal signs (==) in the above statement.

Creating GM+View Rules for the User Selected Option

Select File > Configure > GM+View tab.
At the GM+View Tab Settings dialog box, click Rules.
At the GM+View Tab Rules for Template Selection dialog box, select User Selected.

P wWwnNR

Right-click the GM+View tab and select a template to display for the current contact.

Online Searching

The Search Online command located on the Web menu opens the Internet Search window. On this window, you
can access web links for searching the internet. The search engines that display are determine by the iSearch.ini
file. This file can be modified to display the search engines that you want.

m Searching the Internet for Contact Record Information

m Modifying the iSearch.ini File

Searching the Internet for Contact Record Information

Select Web > Search Online.
At the Internet Search dialog box, select one of the available search engines.

In the toolbar, click the Search now P button.

4. Your default browser opens to the search engine’s results page for the currently active company contact.

NOTE: The default configuration searches only for contacts that have a Company name listed in the Contact
Record.
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Modifying the iSearch.ini File

1. Select Web > Search Online.
2. At the Internet Search dialog box, click the iSearch.ini properties k| button.

The isearch.ini file opens in Notepad.

Select the display location where you want to add/remove a search engine.
Press Return to give yourself a line of space.

5. Modify the file accordingly.
Example: Insert Bing as a new corporate search engine.

[Section: Corporate Search: <<Company>>]
Icon=1

[Google]

URL1= http://www.google.com/search
Data= ?7p=<<Company>>

Icon= 5

[Bing]
URL1=http://www.bing.com/search
Data= ?7g=<<Company>>

Icon=5

[Yahoo]

URL1= http://search.yahoo.com/bin/search
Data= ?7p=<<Company>>

Icon= 5

[Yahoo Corporate News]

URL1= http://search.news.yahoo.com/search/news

Data= ?7p=<<Company>>

Icon=6
NOTE: Determine the structure of the entry (unique to each search engine) by testing a search and
determining where the search begins.

In this example, the test search returned the following results in the Internet Explorer Address text box
http://www.bing.com/search?q=GoldMine%20Inc%2E

Notice the search command for Bing, &q, and the company name, GoldMine Inc, at the end. In the
iSearch.ini entry, this is replaced by the company macro, <<Company>>. The macro allows the search
to remain interactive with the current contact record.

6. Select File > Save.

When launching the Internet Search, the new entry appears in the dialog box.
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About the Record Types Administration Center

The Record Types Administration Center manages record types.

= Creating Record Types. See Creating Record Types.
= Configuring Record Type Rules

Record Types and Contact Records

After creating record types and configuring the in the Record Types Administration Center, the record type (entity)
displaying in GoldMine is based on how the record meets the rules criteria.

With the Field value-based rules activated, the File > New menu expands to include record types with the New
Record Creation Options configured. The New Default Record Type option provides you with an efficient data
entry option.

You are not always restricted to the views determined by the record types and rules. With sufficient GoldMine
permissions, manually change the primary field view, custom screen, or GM+View.

Customizing the Opportunity and Project Managers
Properties

Opportunity and Project share the same table, fields, and user-defined fields. Modify the field labels or reorder
and hide tabs of an opportunity listed in the Manager.

Use the following procedure to customize the opportunity and project properties or contact your administrator.

1. Select Go To > Opportunities, or click Opportunities on the Navigation Pane.
The Opportunities window opens.
O To customize Project Manager, select Go To > Projects, or click Projectson the Navigation Pane.
The Projects Manager window opens.
Select a listed opportunity or project. and click Customize.

At the Opportunity Manager Customization Properties dialog box, click the Fields tab and select from these
options:
O New. Creates a new user-defined field on the Opportunity/Project Properties dialog box.

WARNING: User-defined field names must not use an underscore (_) immediately following the

U (example: U_fieldname). Fields named this way will not synchronize and will result in data loss.

Do not use any of the following SQL reserved words as field names: UNION, UNIQUE, UNPIVOT,
UPDATE, UPDATETEXT, USE, USER.

Click New. At the User Defined Field Profile dialog box enter the Field Name, Description and select a
field type.

- Character. A character field.Select the length of the field in the Len. drop-down list.

- Numeric. A numeric field. Select the number of decimals in the Dec. drop-down list

- Date. A date field.
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O Edit. Edits a user-defined field.

Click Edit. At the User Defined Field Profile dialog box enter the Field Name, Description and select a field
type.

- Character. A character field.Select the length of the field in the Len. drop-down list.

- Numeric. A numeric field. Select the number of decimals in the Dec. drop-down list

- Date. A date field.

O Delete. Deletes a user-defined field. Click Delete and click Yes at the message.
O Move Up. Reposition the selected field above other fields. Select a field and click Move Up. The field moves
up one position
O Move Down. Reposition the selected field below other fields. Select a field and click Move Down. The field
moves down one position.
4. Click the Labels tab. Allows you to change the name of a label.

O In the Default Label list, find the label name you want to change. Click once next to the field (under the
New Label list). A text box opens.

O Type in the new label name and click OK.
O At the message click Yes.

NOTE: Field labels must not include an apostrophe/single quote (‘) or double quote (“) within the label.
5. Click the Tabs tab. Select from the following options:
NOTE: For each tab title listed, clear the associated check box to hide tab from view.

O Move Up. Repositions the tab. Select a tab and click Move Up. The tab moves up one position.
O Move Down. Repositions the tab. Select a tab and click Move Down. The tab moves down one position.

O Customize tab labels globally. Applies changes to all users. Select the check box if you want changes to
apply to all users.

O Rename. Renames the tab. Select a tab and click Rename. At the Edit Tab label dialog box, type in the new
tab label and click OK. The new tab name appears.

O Reset. Return the tabs to default order.

6. Click the Options tab and select the When adding a New Opportunity/Project, prompt the user to use
either the wizard or the manual method check box and then click OK.

Setting Completion Variables for Date/Time

The date, time, and user for most activity types defaults to the current date, time, and user when completing the
activity. A GoldMine Administrator can set variables to retain the originally scheduled date, time and/or user when
completing activities.

Different variables are available to retain the original date/time or user when completing activities with different
properties and types. The setting is applied on the ENVIRONMENT Table using a SQL INSERT statement.

Note the following information about the settings:

m Setting is not sync-aware. This means that it must be or can be applied separately on Sites and Undocked User
systems.
m Setting is valid for all users on the current GoldMine system.

m Setting is available for each Activity type (Appointments A, Events E, Calls C, Next Actions T, Other Actions O,
Sales S)
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= The changes can be reverted by applying an UPDATE statement by setting the VAL entry from 1 to 0 or by
deleting the specific row.

m Single Activities can later be modified manually in the Completion Window.

The following Variables are available:

= useOriginalDatelnComplete
Default Date/Time when completing non-recurring or single instance of a recurring activity
= useOriginalUserInComplete
Default User when completing non-recurring or single instance of a recurring activity
= useOriginalDateCompleteRecurrence
Default Date/Time when completing all Pending instances of a recurring activity
= useOriginalUserCompleteRecurrence

Default User when completing all Pending instances of a recurring activity or default date/time and user
when completing multi-user and/or multi-contact activity

To Set the Completion Variable
The following is an example for applying the variable useOriginalDateInComplete to the GoldMine system:
1. Open the SQL Server Management Studio and browse to the GoldMine database.

2. Select the New Query button.

3. Ensure that you have the correct GoldMine database (where the ENVIRONMENT table resides) selected in the
database drop-down.

4. Enter the desired INSERT statement depending on the activity type.
Appointments:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDatelnComplete-A','1",",'S",'lIZZIRCOUFSDY=0P')
Events:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDatelnComplete-E','1",",'S",'IZZITNCTYRJH=0P")
Other Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDateInComplete-0','1",",'S",'IZZIVYOWERWE=0P')
Calls:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDateInComplete-C','1',",'S",'1ZZIYAOGFDFG=0P')
Next Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDatelnComplete-T','1",",'S",'1ZZ)JOLCJHGHG=0P')
Sales:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDatelInComplete-S','1",",'S",'1ZZ)2WOIUYUU=0P')
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5. Execute the specific desired statement(s) and ensure that the INSERT statements were successful.

The same steps may be followed for the other variables with the related statements below.

useOriginalUserInComplete
Appointments:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserInComplete-A','1',",'S",'1ZZJ58 0JHRXC=0P")
Events:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserinComplete-E','1",",'S",'1ZZ)7JCJHGTE=0P")
Other Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserInComplete-0','1",",'S",'1ZZJ9UONBMNH=0P')
Calls:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserInComplete-C','1",",'S",'IZZ)JC60JHGEX=0P')
Next Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserinComplete-T','1",",'S",'IZZJEHCGFDNW=0P')
Sales:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserInComplete-S','1',",'S",'1ZZJGSOTRYTR=0P')

useOriginalDateCompleteRecurrence
Appointments:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDateCompleteRecurrence-A','1",",'S',"HCP31X4(4!{ W<')
Events:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDateCompleteRecurrence-E','1",",'S','HCP328Y%I|/49 W<')
Other Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDateCompleteRecurrence-0','1",",'S',"HCP334L(1FP3 W<')
Calls:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalDateCompleteRecurrence-C','1",",'S',"HCP3389(RK1E W<')
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Next Actions:

Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)

values ('useOriginalDateCompleteRecurrence-T','1",",'S',"HCP33BF&A]&5 W<')
Sales:

Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)

values ('useOriginalDateCompleteRecurrence-S','1",",'S','HCP33EG%X<G& W<')

useOriginalUserCompleteRecurrence
Appointments:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserCompleteRecurrence-A','1',",'S',')2EQVST%B0)0002")
Events:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserCompleteRecurrence-E','1",",'S",'J2EQVST%B0)0003')
Other Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserCompleteRecurrence-0','1",",'S','J2EQVST%B0)0004")
Calls:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserCompleteRecurrence-C','1',",'S','J2EQVST%B0)0005')
Next Actions:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserCompleteRecurrence-T','1",",'S','J2EQVST%B0)0006')
Sales:
Insert into Environment (NAME, VAL, USERID, RECTYPE, recid)
values ('useOriginalUserCompleteRecurrence-S','1",",'S",'J2EQVST%B0)0007')

IMPORTANT: The settings will not apply when performing an Auto-Update with Completing Activities using the
Activity list.

To Toggle an Existing Setting
Following is an example for toggling the first variable.

1. Open the SQL Server Management Studio and browse to the GoldMine database
2. Select the New Query button.

3. Ensure that you have the correct GoldMine database (where the ENVIRONMENT table resides) selected in the
database drop-down.

4. Enter the specific UPDATE statement depending on the activity type where:
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0 = disables the original scheduled DATE/TIME for the specific activity type

1 = enables the the original scheduled DATE/TIME for the specific activity type
Appointments:

Update Environment Set VAL = '0' where NAME= 'useQOriginalDateInComplete-A'
Events:

Update Environment Set VAL = '0' where NAME= 'useOriginalDatelnComplete-E'
Other Actions:

Update Environment Set VAL = '0' where NAME= 'useQriginalDateInComplete-O'
Calls:

Update Environment Set VAL = '0' where NAME= 'useOriginalDatelInComplete-C'
Next Actions:

Update Environment Set VAL = '0' where NAME= 'useOriginalDatelnComplete-T'
Sales:

Update Environment Set VAL = '0' where NAME= 'useOriginalDatelInComplete-S'

The same steps may be followed for the other variables by changing the variable name in the update statement.
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Plug-Ins

GoldMine contains a mechanism to support ActiveX controls and HTML-based integrations as if they were part of
GoldMine. The structures allow for rapid integration, ease-of-use, and security.

To begin, create an Active X control (see ActiveX Controls) or an HTML file/web site (see HTML Integrations) for
integration, then set up security (see Plug-in Security).

ActiveX Controls

ActiveX structure provides the most control and can be created with these programming languages: C++, Delphi,
Visual Basic, and .NET. When used with other GoldMine APIs, ActiveX is powerful.

Within the ActiveX support, 4 methods can be implemented in your control for stronger interaction with
GoldMine. It is not necessary to implement these functions:

public void GMOnStart(longhWnd)T

This is the only function that passes a parameter. The parameter is the HWND (window handle) of the
container window in GoldMine. Use the Windows APl SendMessage() call to control what happens to the
container (for implementing a Close button—since the control is late bound in GoldMine, and cannot expose
events).

public void GMOnActivate()
This function tells you when the user has given your control’s container focus in GoldMine.

public void GMLostFocus()
This function is called whenever the user gives focus to another object when your control had focus.

public void GMOnDestruct()
This function is called when the window is just about to close; it provides the opportunity to clean up.

For more information, see Plug-in Description File.

HTML Integrations

The HTML attempts to call a JavaScript or VBScript function named like the last 3 ActiveX methods, meaning
exactly the same thing. The GMOnStart() function is not supported in HTML:

function GMOnActivate();
function GMLostFocus();
function GMOnDestruct();

Plug-in Description File

The plug-in description file is a well-formed XML file describing the plug-in. The extension for the file is .GME
(GoldMine Extension).

m HTML for Plug-ins

m ActiveX for Plug-ins
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HTML for Plug-ins

Structure for the HTML plug-in
<PlugInDefs>
<PlugInbef>
<URL>http://gmail.google.com/gmail</URL>
<Querystring>q=&1t;&1t;&amp;Addressl&gt;&gt;, &1t;&1t;&amp;City&gt;&gt;,
&1t;&Tt;&amp;State&gt;&gt;, &1t;&1t;&amp;zip&gt;&gt;</QuerysString>
<Description>
<Language Locale="1033" Isbefault="1">
<Name>G-Mail</Name>
<Publisher>Google</PubTlisher>
<Description>Launches Google's Gmail Service</Description>
<Menu>Launch GMAIL</Menu>
</Language>
<Language Locale="4000">
<Name>eegay ale-</Name>
<PubTisher>oogle-Gay</Publisher>
<Description>aunches-Lay oogle-Gay’s eegay ale- Urvice-Say</Description>
<Menu>aunch-Lay eegay ale-</Menu>
</Language>
</Description>
<OnDemand>1</0OnDemand>
<Startup>1l</Startup>
<MultipleInstance>0</MultipleInstance>
<Modal>0</Modal>
<DefaultPos>
<top>50</top>
<left>50</left>
</DefaultPos>
<DefaultSize>
<width>800</width>
<height>600</height>
</Defaultsize>
<Visible>1l</visible>
</PlugInDef>
</PlugInDefs>

HTML plug-in details

The root node must be PluginDefs and as the name implies, multiple plug-ins can be installed under one definition
file. For each plug-in, there is a PluginDef. The child nodes for PluginDef are:

m URL: The URL for the HTML file or Web site must be http://, https://,or file://.

= QueryString: The querystring to be tacked on to the end of the URL. Can contain GoldMine field macros that
will be evaluated on launch of the plug-in. The macro wrapping structure is <<field>>, like <<&Contact>> or
<<Contactl->AccountNo>>.
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NOTE: You must XMLEncode the macros as shown in the structure above.

= Description: The values here describe the item to the user and can contain multiple languages to describe the
file, using the locale code associated with the target language. One language structure must be marked as
IsDefault and is used in case the target language is not supported by the plug-in. Use XML entities in place of
extended characters. For example, N would be &#209;.

O Name: Dialog name used for security.

O Publisher: Your company name. Creates a sub menu under the Plug-ins menu.
O Description: Used in the Help > About Plug-ins button.

O Menu: The text the user sees for a menu item.

= OnDemand: Determines if the plug-in is added to the plug-ins menu. 1 = True, 0 = False. If false, the item is
started up with GoldMine.

= StartUp: Determines if the item is started up with GoldMine. This is for situations where you want it to start,
but if the user closes the window you want them to be able to access the plug-in via a menu. 1 = startup with
GoldMine, 0= don’t start with GoldMine.

= Multiplelnstance: Determines if multiple instances of the plug-in are allowed. 1 = allow multiple instances, 0 =
false. When false, if the user chooses the menu item for that plug-in, GoldMine will bring that window to the
front and give it focus. non-OnDemand, Modal, and non-visible plug-ins are automatically single instance.

= Modal: Determines if any action can occur outside of the window in GoldMine. 1= Modal, 0 = Modeless.
Startup/non-OnDemand items cannot be modal. Modal items are strictly single instance.

m DefaultPos: The coordinates where your dialog first appears. This is only used the first time the plug-in is run
and is ignored for Modal plug-ins, which automatically center in relation to the GoldMine window.

m DefaultSize: Describes the height and width of the dialog box for first time use or for modal windows, which
cannot be resized.

= Visible: Determines if the user can see the window. Not recommended for HTML-based plug-ins.

ActiveX for Plug-ins

Structure for the ActiveX plug-in
<PlugInDefs>
<PlugInDef>
<ProgID>myApp.ClassInstance</ProgID>
<Installer>myAppInstaller.exe</Installer>
<Description>
<Language Locale="1033" IsbDefault="1">
<Name>G-Mail</Name>
<PubTisher>Google</Publisher>
<Description>Launches Google's Gmail Service</Description>
<Menu>Launch GMAIL</Menu>
</Language>
<Language Locale="4000">
<Name>eegay ale-</Name>
<PubTisher>oogle-Gay</Publisher>
<Description>aunches-Lay oogle-Gay’s eegay ale- Urvice-Say</Description>
<Menu>aunch-Lay eegay ale-</Menu>
</Language>
</Description>
<OnDemand>1</0OnDemand>
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<Startup>1l</Startup>
<MultipleInstance>0</MultipleInstance>
<Modal>0</Modal>
<DefaultPos>
<top>50</top>
<left>50</Teft>
</DefaultPos>
<DefaultSize>
<width>800</width>
<height>600</height>
</DefaultSize>
<Visible>1l</visible>
</PlugInDef>
</PlugInDefs>

ActiveX plug-in details

Although it is very similar to the HTML plug-in description, there are 2 primary differences, the ProgID and Installer
nodes instead of the URL and QueryString nodes.

The ProglD is the ProglD for your ActiveX control and the Installer is the installer name for the application. The
Installer should be sitting in a folder named Installers under the plug-in directory.

Plug-in Security

Using GM.ini or the User.in1, a user or administrator can block the use of plug-ins altogether, block individual
plug-ins, and add user-specific directory for more plug-ins (see Adding a Local Plug-in Directory).

GM. INI has precedence over the user INI file. Two methods are available:
= Optimistic:
[PTugIns]
allow_by_default=1
m Pessimistic:
[PTugIns]
deny_by_default=1

allow_by_default=0 is the same as deny_by_default=1 and vice versa. If the keys are missing, the method is
assumed to be Optimistic.

If Optimistic, you only need to add blocked plug-ins to the INI files. If Pessimistic, you must give a plug-in
permission to run.

To Block with Optimistic
[PTugIns]
allow_by_default=1 or deny_by_default=0
EVIL_PLUGIN=0

To Allow a Plug-In with Pessimistic
[PTugIns]
deny_by_default=1 or allow_by_default=0
GOOD_PLUGIN=1
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Adding a Local Plug-in Directory

By default, the plug-in directory is under /SysDir/Plug-ins. For server installs, this means that all users have
the plug-ins under that folder. If users want to add their own local plug-in directory, they could add it to the user
INI:

[PTugIns]
LocalPath=c:\personal\GMPlugIns

The user still gets the global level programs (assuming they are not blocked) so ensure there is no duplication.

Security

The ShowActvForCurtained setting in [GoldMine] section of the GM.ini file lets you specify whether or not the
calendar shows activities linked to completely curtained contacts. Set this field to 1 if you want the calendar to
show activities linked to completely curtained contacts. For example: [GoldMine]

ShowActvForcCurtained=1

WARNING: Storing this setting in GM.ini means that GM.ini must be read-only for all except
administrators/masters. This weakens GoldMine security.

Automated Processes

You can automate routine tasks by setting up a series of predefined actions to perform the tasks on Contacts in
the database. These tasks include:

m Administrative and tracking duties
= Generating direct mail

= Validating data
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For example, print introductory letters to new contacts whenever a Contact Record is created. After printing the
letter, the Automated Process can schedule a follow-up activity (such as a call back) on the calendar of a GoldMine
user.

Select from the following topics to learn more about Automated Processes in GoldMine.

m Automated Processes Components

m Automated Processes Center Components
m Process Options Update

m Creating Automated Processes

m Working with Automated Processes

m Creating Processes

m Creating Events

m Creating Triggers

m Creating Actions

m Attaching Processes to a Contact

m Executing Processes

= Removing Attached Automated Processes

m Trigger Dialog Boxes

Automated Processes Components

The following is a list of the automated process components.

= Processes. This is a sequence of two or more events used as the step-by-step instructions GoldMine evaluates
to perform a defined series of activities. Also known as an automated process. You can link several events to
form a process.

= Events. An automated process consists of a sequence of one or more events. An event refers to the step-by-
step instructions contained in an Automated Process or process GoldMine evaluates to perform a series of
activities. An event consists of a trigger and an action. Events within each process perform an action when
triggered by a condition.

= Action. Each Automated Process event has a triggered action. The trigger is evaluated and if the criteria is met,
the event's action is performed.

= Trigger. Each Automated Process event is processed based on a trigger. The trigger evaluates and, if the criteria
is met, performs the event's action and the processing continues to the next event.

Use the Automated Processes Center to create and edit processes and events and to execute processes. Manage
processes attached to contacts on each record with the Processes tab.Use the available menu options to Execute
Processes and Manage Processes.

Designing Automated Processes

When an event is created, it is assigned a preemptive or sequential number. GoldMine evaluates preemptive
events first and then sequential events.
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When creating preemptive events you generally set the condition to eliminate the scanned record rather than
confirm this process is appropriate. For example, a sales rep and territory is designated in the Sales Rep and
Territory fields, then remove this process from the record; otherwise populate these two fields with the defined
criteria.

Preemptive events are numbered from 0 to 99. GoldMine processes all of the preemptive events of a process first
before moving on to sequential events. If the Preemptive event if statements is:

B True. Perform the action and go to the next event.

= False. Do not perform the action but still go to the next event.

Preemptive events should be numbered 5, 10, 15, and so on. Keep space between the events to insert additional
events.

Sequential events perform actions such as printing a letter, sending an e-mail, or scheduling a call. They are
numbered from 100 to 999. Sequential events should be numbered 100, 110, 120, and so on to add other events
between existing events.

After completing all preemptive events, GoldMine runs the first sequential event and processes sequential events.
If the statement is:
= True. Perform the action and go to the next sequential event.
= False. Do not perform the action and do not proceed to the next sequential event. Do not perform the action
and do not proceed to the next sequential event.

After GoldMine completes the sequential events, it processes the next process for the Contact, or if there is no
process to process, GoldMine goes to the next Contact.

When creating an automated process, define the process, then allocate the events, triggers, and actions to the
process. The following image diagrams an example plan:
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Automated Processes Center Components

Toolbar

The Automated Processes Center toolbar has the following buttons:
User: | [public) - 693 4N | By X &

= New Automated Process. Creates a new automated process.
= New Event. Creates a new event.

= Clone New Process. Clones an automated process.

m Delete. Delete the Automated Process

= Properties.

= Move Event Up. Moves the event up the list.

= Move Event Down. Moves the event down the list.

= Execute Automated Process. Executes the automated process.

Event Local Menu

The Event Local Menu contains the following commands:

Refresh
Fefresh Al

Move Up
Move: Down

New, ..

Delete, ..
Properties...

= Refresh. Updates the selected Automated Process or event display.

= Refresh All. Updates the display of all Automated Processes and events for the selected User.

= Expand. Displays all items contained under the selected Automated Process.

= Move Up. Moves the selected event up by one line.

= Move Down. Moves the selected event down by one line.

= New. Displays the GoldMine Automated Process Event Wizard, from which you can create an event.
m Delete. Deletes the selected event.

= Properties. Displays the GoldMine Automated Process Event Wizard, from which you can make changes to the
selected event.
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Process Local Menu

Refresh
Fefresh Al

Expand

Mew, ..
Clone. ..

Delete, .,
Properties...

= Refresh. Updates the selected Automated Process or event display.

= Refresh All. Updates the display of all Automated Processes and events for the selected user.
= Expand. Displays all items contained under the selected Automated Process.

= New. Displays the GoldMine Automated Processes Wizard. Use to create a process.

= Clone. Displays the GoldMine Automated Processes Wizard. Use to create a copy of the selected Automated
Process.

m Delete. Deletes the selected process.

= Properties. Displays the GoldMine Automated Processes Wizard to enable you to edit the process.

Process Options Update

The Process Options allows you to determine when and how processes attach and execute.
= Allow only one attachment of this process per contact. Prevents multiple attachments of the one process to a
contact’s record.

= Execute this process immediately upon attachment. Starts processing the process as soon as a user attaches
the process to one or more contact records.

= Execute this process only when scanning for processes. Prevents GoldMine from executing a process attached
to a single contact record. Use to restrict process execution to a specific system.

m For example, if a print action requires a special printer that is connected to one workstation, selecting this
option and Execute this process immediately upon attachment prevents the printing process from running a
different workstation.

= Restart this process each time that it ends. Reattaches the process when processing for the process
completes.

= Allow users to attach this process. Lets other users attach the process.

= Attach this process to all new contact records. Attaches the process to each new contact record. Apply to only
one Automated Process.
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Creating Automated Processes

Create new automated processes using the Automated Process Wizard.
1. Select Tools > Automated Processes > Manage Processes.
Click OK at the Welcome message. The Automated Processes Center opens.

2. Right-click on Automated Processes and select New to open the Automated Processes Wizard.

GoldMine Automated Process Wizard E'

Welcome to the Automated Processes
Wizard!

Thiz Automated Processes wizard will help you to et up or modify
an Automated Process. Wou can creale target, “drip" marketing,
sales and retention campaigns

using processes bo stay in bouch with all of your prospects and
customers, while at the same time, reducing day to day tasks for
your bearm.

To begin, specify the unique name, identifying code and owner of
thiz process:

Process Marme: :Smd Letter

Process Code: » Owrier: .LISEH [user] v |

I MNext » I[ Cancel

3. Typeinaname, then select a process code and then click Next.

GoldMine Automated Process Wizard: Options E'

GoldMine allows you to assign certain global properties to each
procezs. The options below can affect a large number of contact
records and users schedules, If applicable, activate a filtes o
group before attaching a process.

Please zelect from the following options in order to define the
propeities for this process:

[C] Allow anly one attachment of this process per contact

[[] Execute this process immediately upon attachment

[[] Execute this process only when scanning 2 group of cortacts
[C] Restart this process each time that it ends

[#] Allows users to attach this process

[[] Astach thiz process to all new contact records [this oplion
is available for only one process)

< Back ]I MNext » I[ Cancel |
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4. Select from the following options and click Next.

O Allow only one attachment of this process per contact. Prevents multiple attachments of the one process
to a contact’s record.

O Execute this process immediately upon attachment. Starts processing the process as soon as a user
attaches the process to one or more contact records.

O Execute this process only when scanning for processes. Prevents GoldMine from executing a process
attached to a single contact record. Use to restrict process execution to a specific system.
For example, if a print action requires a special printer that is connected to one workstation, selecting
this option and Execute this process immediately upon attachment prevents the printing process from
running a different workstation.

O Restart this process each time that it ends. Reattaches the process when processing for the process
completes.

O Allow users to attach this process. Lets other users attach the process.

O Attach this process to all new contact records. Attaches the process to each new contact record. Apply to
only one Automated Process.

Goldkine Automated Process Wizard: Events EJ

Each process is made up of one or more events. Each event is
made up of a tigger and a condition. To set up or modify an
event, select the appropriate oplion belov:

Seq Event Trigger Action

| < Back ]I Mext = I[ Cancel
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5. Click New to open the Event Properties dialog.

Event Properties E]

Event
Event Desciption: {1 Sequertial Sequence:
asff | @ Presmptive |10 [
Trigaer
=i Trager on:
} History Activity v [] Trigget Filter
Action

=g Pesfarm Action:

,_‘\. Pt Fosm w

| ok || Cancel |

6. Inthe Event area, type a description of the event in the Event Description field.
At the radio buttons, select either:

O Sequential. Numbered between 100 - 999, these events evaluate one at a time, starting with the lowest
numbered event. The next event is not processed unless the previous event's trigger evaluates as True.

For example, if you create a process with multiple sequential events, where each event is numbered 100,
110, and 120, GoldMine evaluates event 100 but does not evaluate event 110 until the trigger for event
100 is fulfilled.

O Preemptive. Numbered 00 - 99, these events are evaluated individually. The next preemptive event is
processed, whether or not the first event is True.

At the Sequence drop-down box, type or select the Sequence number (between 100 - 999 for Sequential; 00 -
99 for Preemptive).

7. Inthe Trigger area, at the Trigger On drop-down box, select a trigger.
Depending on the trigger you select, a series of configuration options open.
8. Inthe Action area, at the Perform Action box, select an action.
Click Options to configure the selected action.
9. Click Next and then click Finish.

The new automated process appears in the Automated Processes Center.
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10. Click Next.
The Automated Process Event Wizard: Additional Trigger dialog box appears. Configure using:

O Attempt the trigger only once. If the current event is triggered, it executes the corresponding action, then
continues to the trigger of the next event. However, if the event is not triggered, it skips the event and
continues to the trigger of the next event. Example: a process includes 2 events (send a gift to contacts
purchasing >$30 and print a thank-you to a contact making any purchase). Select this option to just print
the thank-you letter.

NOTE: Trigger only once events function like a loop and are dependant on having an event that can escape
from the loop. Therefore, make your trigger only once events preemptive; the process will be attached and
when the Automatic Process is processed, the preemptive events are also processed.

11. Click Next. The Automated Process Event Wizard: Action dialog box appears.

12. Click Next and click Finish.

Working with Automated Processes

Manage processes using these options:

m Creating Processes. See Creating Processes

= Creating Events. See Creating Events

= Editing Processes.See Editing Processes

= Editing Events. See Using the Automated Processes Center
m Attaching Processes. See Attaching Processes to a Contact
= Executing Processes. See Executing Processes

= Deleting Processes or Events. See Removing Attached Automated Processes

Creating Processes

Create, clone, or modify Automated Process processes with the GoldMine Automated Processes Wizard.

NOTE: Planning is key. Take time to determine what you want to accomplish, how the triggers and actions
work together for each preemptive or sequential event, and how the series of events, the process, will fit
together.
1. Select Tools > Automated Processes > Manage Processes. The Automated Processes Center appears.
2. From the drop-down list, select the User who owns this Automated Process.

3. Right-click Automated Processes in the left pane and select New, or click the New Automated Process
button.

The Welcome to the Automated Process Wizard dialog appears.

In the Process Name text box, type a descriptive name.

Type or select the Process Code from the F2 Lookup list.

Select the Owner. By default, the user name selected in the Automated Process Center displays.

No v s

Click Nextto open the GoldMine Automated Process Wizard: Options dialog.
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8.

Select one of the following options:
O Allow only one attachment of this process per contact: Prevents multiple attachment of the same process
to a contact’s record.

NOTE: If two duplicate contact records are merged that already have automated processes attached, both
processes will be attached to the merged contact record, regardless of whether the above check box was
selected.

10.

11.
12.
13.

O this process immediately upon attachment: Starts processing the process as soon as a user attaches the
process to one or more contact records.

O Execute this process only when scanning a group of contacts: Prevents GoldMine from executing a
process attached to a single contact record. This option is useful to restrict process execution to a specific
system. Example: if a print action requires a designated workstation printer, selecting this option and
Execute this process immediately upon attachment prevents the printing process from running from any
other workstation.

O Restart this process each time that it ends: Reattaches the process as soon as the processing of the
process completes.

O Allow users to attach this process: Permits other users to select and attach the process.

O Attach this process to all new contact records: Automatically attaches the process to each new contact
record. Apply only to one Automated Process (can only be applied to one Automated Process).

Click Nextto open the GoldMine Automated Process Wizard: Events dialog.

Select one of the following options:

O Seq (Sequence): Sequence ordered number for each event in an Automated Process. The sequence number
begins with is either P for a Preemptive event or S for a Sequential event. Each event is processed in
order based on the sequence number.

O Event: Step-by-step instructions contained in an Automated Process, or track, that GoldMine must evaluate
to perform a specified series of activities. An event consists of an action and a trigger. An Automated
Process consists of a sequence of two or more events.

O Trigger: A predefined condition in an Automated Process event that, when the condition is true, causes
GoldMine to execute an action.

O Action: The Automated Process action is the activity performed when triggered) for each event. While
creating a new track, the display is empty.

Select from the following:

O New. Opens a blank Event Properties dialog, and lets you create an event.

O Delete. Deletes the selected.

O Edit. The Event Properties dialog displays the selected event's settings. Edit and save.

Click OKto open the GoldMine Automated Process Wizard: Events dialog.

Click New to add another event, or when you finish adding events. Click Next.

Click Finish. For the Automated Process to work, attach the process and process the process.

Editing Processes

P wnNR
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In the Automated Processes Center, highlight the process you are editing and right-click.
Select Properties from the local menu. The Automated Process Wizard opens.

Use the Wizard to edit. See Creating Processes.

Click Finish.
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Creating Events

Events are the triggered actions that take place in a specific order. Each Automated Process or process, can have
up to 900 sequential events and 100 preemptive events. Create or edit events using:

= Automated Process Event Wizard. Available when right-clicking and select New.

= Event Properties dialog box. Available while creating or editing an Automated Process.

Using the Automated Processes Center

Select Tools > Automated Processes > Manage Process. The Automated Processes Center opens.
2. Create or modify processes using tool and menu options:

O Toolbar

O Process Local Menu

O Events Local Menu

NOTE: For information on the toolbar and local menus see Automated Processes Center Components.

O Process Options Update. See Process Options Update.
3. Manage processes using these options:
O Creating Processes. See Creating Processes
O Creating Events. See Creating Events
O Editing Processes. See Editing Processes
O Editing Events. See Editing Events
O Attaching Processes. See Attaching Processes to a Contact
O Executing Processes. See Executing Processes
O Deleting Processes or Events. See Removing Attached Automated Processes

Event Properties Dialog Box

When you are using the Automated Process Wizard to create a process and add events, the Event Properties
dialog box opens when selecting New (or Edit) on the GoldMine Automated Process Wizard: Events dialog box.
1. Inthe Event area, type the Event Description.

2. Select one of the following:
O Sequential: Numbered between 100 - 999, these events evaluate one at a time, starting with the lowest
numbered event. The next event is not processed unless the previous event's trigger evaluates as true.

Example: If you create a process with multiple sequential events, where each event is numbered 100,
110, and 120, GoldMine evaluates event 100 but does not evaluate event 110 until the trigger for event
100 is fulfilled.

O Preemptive: Numbered 00 - 99, these events are evaluated individually. The next preemptive event is
processed, regardless whether the first event is true.

Type or select the Sequence number (between 100 - 999 for Sequential; 00 - 99 for Preemptive).
Select a Trigger. Configuration options vary depending on the Trigger on option selected.

Select an Action. Click Options to configure the select action.

Click OK.

AN L S
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Editing Events

After and event has been created, you can edit the events within a track. Follow the procedure below to edit the
even.

1. Inthe Automated Process Center, double-click on an event or right-click on an event and select Properties.
The Welcome to the AP Events Wizard appears.
Use the Automated Process Event Wizard to edit.
Click Finish.

Creating Triggers

Each Automated Process event is processed based on a trigger. The trigger evaluates and, if the criteria is met, the
event's action is performed and processing continues to the next event. Select one of these from the drop-down
list and configure the associated settings:

Elapsed Days

Specify the number of days that must pass before the action is executed. GoldMine begins counting days as soon
as the event immediately prior to the current event is triggered. If an event is the first event of the track,
GoldMine begins counting days as soon as the event is attached to a Contact Record. You can also select Trigger
Filter and click Filter. The Expression Builder dialog box appears.

Immediate

Sets GoldMine to immediately execute the action associated with the event. This allows you to set up a sequence
of actions based on a single trigger. You can also select Trigger Filter and click Filter. The Expression Builder dialog
box appears.

Detail Record

Specifies that the processing of an event’s action cannot be executed until a specified detail record, document link,
other contact, or referral has been added to the Contact Record. Configure the following settings:

= Click Options to configure the Detail Trigger dialog box.

= Select Attempt trigger only once to branch to the next event whether or not the current event is triggered. If
the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of
the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger
of the next event. For example, a track might include two events: Send a gift to contacts who make purchases
over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting
Attempt to trigger only once enables GoldMine to print the thank-you letter for all purchases, regardless of
the dollar amount.

GoldMine Administrator's Guide Page 280 of 439



GoldMine™®

History Activity

Specifies that the processing of the event’s action cannot be executed until a specified history record has been
saved for the Contact Record. Configure the following settings:

= Click Options to configure the History Trigger dialog box.

= Select Attempt trigger only once to branch to the next event whether or not the current event is triggered. If
the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of
the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger
of the next event. For example, a track might include two events: Send a gift to contacts who make purchases
over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting
Attempt to trigger only once enables GoldMine to print the thank-you letter for all purchases, regardless of
the dollar amount.

Scheduled Activity

Specifies that the processing of an event’s action cannot be executed until a selected activity type has been
scheduled for the contact. Configure the following settings:

= Click Options to configure the Schedule Activity dialog box.

= Select Attempt trigger only once to branch to the next event whether or not the current event is triggered. If
the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of
the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger
of the next event. For example, a track might include two events: Send a gift to contacts who make purchases
over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting
Attempt to trigger only once enables GoldMine to print the thank-you letter for all purchases, regardless of
the dollar amount.

Opportunity

Specifies that the processing of the event’s action cannot be executed until a specified opportunity record has
been recorded for the Contact Record. Configure the following settings:

= Click Options to configure the Opportunity Trigger dialog box.

= Select Attempt trigger only once to branch to the next event whether or not the current event is triggered. If
the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of
the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger
of the next event. For example, a track might include two events: Send a gift to contacts who make purchases
over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting
Attempt to trigger only once enables GoldMine to print the thank-you letter for all purchases, regardless of
the dollar amount.
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Project

Specifies that the processing of the event’s action cannot be executed until a specified project record has been
recorded for the Contact Record. Configure the following settings:
= Click Options to configure the Project Trigger dialog box.

= Select Attempt trigger only once to branch to the next event whether or not the current event is triggered. If
the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of
the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger
of the next event. For example, a track might include two events: Send a gift to contacts who make purchases
over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting
Attempt to trigger only once enables GoldMine to print the thank-you letter for all purchases, regardless of
the dollar amount.

Disabled

Turns off the trigger condition setting for the selected event.

Creating or Editing Filters and dBASE Expressions

On the Expression Builder dialog, select the user from the Owner drop-down list.

Select the filters owned by the selected user in the Filters drop-down list. The filter expression appears in the
text box below. Click OK to accept, or continue with more options.

Select the Field name. Only Contactl and Contact2 are available when creating a filter.
Select the Operator (see Filter Expression Operators in the User Guide).

Type a Value in the text box or select a value from the F2 Lookup list.

Click Insert Condition. The expression is inserted in the text box.

No v esw®w

Click AND or OR to insert a Boolean Operator (see Boolean Operators in the User Guide) and then construct
the additional expression using Field, Operator, and Value, as well as the left and right parentheses.

%

Click Insert Condition to add the new expression to the existing expression.

When finished, click OK. The dialog closes and the Event Properties dialog or the Automated Process Event
Wizard reappear.
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Creating Actions

Each Automated Process event has a triggered action. The trigger is evaluated and if the criteria is met, the event's
action is performed. Select one of these actions from the drop-down list, then click Options to configure the
associated settings:

O Print Form (see page 283)

O E-mail Message (see page 284)
O Print Report (see page 284)

O Schedule Activity (see page 285)
O Create History (see page 285)

O Create Detail (see page 286)

O Add to Group (see page 286)

O Update Field (see page 286)

O Remove Process (see page 286)
O Add a New Process (see page 287)
O Branch to Event (see page 287)
O Run Application (see page 287)
O Create Case (see page 288)

Print Form
1. Select the Document Type.

NOTE: Spreadsheet templates with link fields do not print with Automated Processes, because it does not
allow proper update of the linked fields; Use only when the file has static data.

2. Select the User who owns the template you want to print.
3. Select a Template. The list is limited to the templates in the Document Management Center owned by the
selected user and of the selected document type.
4. Inthe Printing Schedule area, select:
O Print immediately: The form is printed immediately upon execution.
O Queue for immediate printing: The form is queued and is printed on the queued printing schedule.
O Queue for printing in x days: Queues the form until the specified number of days is reached. Type the
number of days in the text box.
5. Inthe User area, select a user the activity is recorded for:
O Record Owner: Owner of the Contact record, if record ownership was set.
O Assigned User: User specified in the Activity Details.
O Attaching User: User attaching the Track to the record.
O Logged User: User currently logged into the workstation executing the Automated Process.
6. In the Output method area, select Print or Fax.
7. Click OK.

NOTE: When a Print Form action is executed, 2 records are added to the History tab. One records the
history of the action and the other records the successful printing of the form.
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E-mail Message
Chose a template to print as an E-mail message action in an Automated Process.

1. Inthe Template tab, configure:

O User: Select the user who owns the e-mail template to be sent.

O Template: Templates displayed are limited to those owned by the selected user and configured in the
Document Management Center.

O Merge for: Select the user to be listed in the From field of the e-mail message.

O User: Select Merge for > Selected User > User, then select a particular user.

2. On the Recipient tab, configure:

O Contact Section: Select Primary Address to send the message to the primary e-mail address or All
addresses linked to this record to send the message to other e-mail addresses associated with the
Contact Record.

O Select All addresses linked to this record and configure specific settings.

- Primary: Sends to the primary e-mail address on the Contact Record.
- Additional: Sends to additional contacts with e-mail addresses.
- Other: Sends to a different e-mail address of the primary contact.
- Limit to E-mail merge code: Sends to contacts with the same e-mail merge code.
O Delivery Options: Specify delivery options for all recipients. Select an option from the list.
3. On the File in History tab, configure:

O Create a history record: Select to create a sent e-mail message record on the contact's History tab.

O Save the template in history: Select to create a complete record of the message sent.

O Reference: Type or select a descriptive reference line to display on the history record.

O Activity: Type or select an activity code for the message.

O Result: Type or select an result code for the message.

4. Click OK.

Print Report

1. From the User drop-down list, select (public) to see the standard reports, or select a particular user if a user
has created a custom report you wish to use.

2. Select the Type:
O GoldMine: The GoldMine Reports.

3. From the Reports Categories List, display:
O Contact Reports: Contact Listing reports.
O Calendar Printouts: Activity List reports.
O Analysis Reports: Analytical reports.
O Labels and Envelopes: Special templates that print data on special paper sizes.
O Other Reports: Six special report templates.

4. Select areport to generate from the Report Description list.

NOTE: The reports available in the Report Description list vary depending on selections made in the
Reports Categories area.
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5. In the Contacts area, select:
O All: Report includes all contact records.
O Current: Report includes only the currently displayed contact record.
O Filter or Group: Report includes only the contact records that meet the filter criteria or are in an activated

group.
NOTE: GoldMine saves your selection with the report profile.
6. Click OK.

Schedule Activity
1. Inthe Schedule Activity area, select the activity type.
2. Inthe User area, select the user the activity is assigned to based on the following options:
O Record Owner: Owner of the Contact record, if record ownership was set.
O Assigned User: User specified in the Activity Details.
O Attaching User: User attaching the Track to the record.
O Logged User: User currently logged into the workstation executing the Automated Process.
O User from Field: A user can be selected from a Contactl or Contact?2 field, if the fields are configured
accordingly. Example: a Sales Rep field.
3. Click Activity Details. The related Scheduling dialog appears. Use to specify information about the scheduled
activity.
NOTE: Automated Processes do not allow you to schedule and send iCalendar meeting requests as you
schedule an action.
4. Specify how many days out to schedule the activity in the Schedule x days into the future text box.
5. Select one:
O From Today: Starts counting days from the current date.
O From Trigger Date: Starts counting days from the date the event is triggered.
Select Skip Weekends to not include weekend days in the total.
Click OK.

Create History

Choose the history activity as your Create History action in an Automated Process.

1. Select the Activity Type.
2. Select the User the activity is assigned to:
O Record Owner: Owner of the Contact record, if record ownership was set.
O Assigned User: User specified in the Activity Details.
O Attaching User: User that attached the Track to the record.
O Logged User: User currently logged into the workstation executing the Automated Process.
O User from Field: A user can be selected from a Contactl or Contact? field, if the fields are configured
accordingly.
3. Click Activities Details. The Complete an activity dialog appears. Use it to create a specific completed activity
record to file in History.

4. Click OK.
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Create Detail
Choose the detail to use as your Create Detail action in an Automated Process.

Select the Detail from the F2 Lookup list.

Type or select the relevant Reference information from the F2 Lookup list.
Add Notes, as needed.

Select the Info tab to access additional fields.

Click OK.

i W NPR

Add to Group
Add the contacts as group members to your Add to Group action in an Automated Process.

Select the owner of the group from the User drop-down list.
Select the Group to which you are adding the contacts.

Type or select the Membership Reference from the F2 Lookup list.
Select the Sort field from the drop-down list.

Click OK.

i W NPR

Update Field
1. From the drop-down list, select the field to update.
2. Select Look-up a replacement value in the Lookup.ini if you have an existing subsection in the Lookup.ini
that updates this field.
3. Select Update with dBASE Expression and type a dBASE expression in the text box.
Example, "Updated 5/15/2011".
4. Click OK.

Remove Process

Terminate and remove the track at any point during the processing phase, assuming the trigger is true. Does not
require the setting of additional options.
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Add a New Process

Appears under two different scenarios: when building a process and when manually attaching a process on the
Processes tab (see Attaching Processes to a Contact. To add an existing track to your current track as your Add a
New Track action in an Automated Process:

1. Select the process to add from the Code and Process Name list.

2. To execute the attached process immediately, select Process immediately.

3. Click OK.

Branch to Event
Use to jump to another event as your Branch to Event action in an Automated Process.

Example: The Branch to Event acts as a go to statement. If, after processing sequential event 110, the Branch to
Event is set to go to 200, all the "skipped" unprocessed sequential events are ignored.

1. Select the event from the Branch to Event drop-down list.

2. Click OK.

Run Application

Launch an external application or execute a Dynamic Database Exchange (DDE) command.

To Run an Application

1. Select Run Application.

2. Browse to the location of the Application executable file that launches the outside application.
3. Add Command line parameters to the launch command.
4

Select Run minimized to run the application in the background and place a button for the application in the
Windows Task bar.

5. Click OK.

To Send DDE Commands
1. Select Execute a DDE Command.
2. Select a DDE Service.
3. Select a Topic.
4. Select or type a DDE Client Command.

NOTE: Each product application uses a unique format for DDE requests. Consult that product's
documentation for details.

5. Click OK.
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Create Case

For the Automated Process, you can either create a new case based on an existing Service Template (if available)
or create an empty case.

1. Select Create Case from the Perform Action drop-down list. The Automated Process - Create Case dialog
appears.

2. Select one of the options:
O Use Existing Case Template and then select from the list of available templates.
O Create an empty case if you want to start with a blank case.

NOTE: If you want to create a new Case Template, click the Create A New Case Template button. The Edit
Template dialog opens. Complete the fields as desired and then click Save.

3. Click OK.

Attaching Processes to a Contact

Before an Automated Process can be executed, the process must be attached to selected Contact Records. One
record can have multiple processes assigned to it. GoldMine stores the attached processes on the Processes tab.
Build your processes in the Automated Processes Center, then manually attach a process to a record.

To Attach Processes to a Single Contact Record
1. Right-click in the Processes tab and select Attach a Process. The Attach an Automated Process dialog
appears.
Select the process to add from the Code and Process Name list.
Select Attaching User from the drop-down list.
Click OK to attach the process and continue.

To Attach Processes to Multiple Contact Records
1. Select Tools > Automated Processes > Execute Processes.
The Automated Processes Execution dialog opens.

2. Select one of the following:
O Scan current contact. GoldMine processes only the active contact, then returns to an idle mode.
O Scan a group of contact. Select ALL Contact Records! or a filter or group as the basis for selecting contacts.
GoldMine processes the contacts in the filter or group, then returns to idle mode.
3. GoldMine scans to evaluate and execute attached processes. In the Scan Method area, select from the
following:
O Scan once. Executes the process as you attach it.
O Scan continuously. Scans the database continuously as configured in the Server Agents Administrator.
O Do not scan. Attaches the process, but does not evaluate it for execution (available only when selecting
Attach Process to selected contacts).
Select Attach Process to selected contacts to select the process to be attached from the drop-down list.

5. Click Process. The Process Monitor opens, processing the attachments and the events triggered.
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Executing Processes

Execute a process for a single contact, a group of records based on a filter or group, or for all contacts. Execute a
track manually whenever necessary, or set GoldMine to scan the database continuously, or use the Automated
Process Server Agent.

1. Select Tools > Automated Processes > Execute Processes.

The Automated Processes Execution dialog box appears.
2. Select one of the following:

O Scan current contact. GoldMine processes only the active contact, then returns to an idle mode.

O Scan a group of contacts. Select ALL Contact Records, or select a filter or group from the drop-down list.
3. Inthe Scan Method area, select one:

O Scan once. GoldMine scans the contact database, or the contacts selected by a filter or group, and
processes all processes. When complete, it returns to an idle mode, unless you have the Automated
Processes Server Agent running. If running, the Automated Process scans again in the time frame
designated.

O Scan continuously. GoldMine scans the contact database and processes all processes, then repeats the
process continuously. This allows you to set up a workstation on the network that continuously scans for
triggered events and immediately performs the event actions. It can be interrupted by selecting Stop in
the GoldMine Process Monitor dialog box.

NOTE: The option Do not scan is available only when you select Attach Process to selected contacts, which
lets you attach processes without scanning the database for processes to execute.

4. In the Options area, configure:
O Max Events. Maximum number of events (up to 99,999) to be processed during this scan.
O Max Contact. Maximum number of contact records (up to 99,999) evaluated.

TIP: To control the number of letters printed at one time, set the Max Contact to process only 25
records per day, or queue the print job to print manually or in off hours using the Print/Fax
Server Agent.

O Time. Sets a time to start processing the track. Use this option to take advantage of periods of lower
demand to run the process. To set the time using the graphical clock, press F2.
Select Attach Process to selected contacts to select the process to be attached from the drop-down list.

Click Process. The Process Monitor appears, displaying the number of contacts scanned and triggered.

Removing Attached Automated Processes

After attaching a track to an individual or many Contact Records, you might need to remove the attached track.

1. Select the Processes tab.
2. Right-click the process to be removed and select Remove Process.

3. Click Yes.
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Trigger Dialog Boxes

Opportunity Trigger Dialog Box

Automated Process events can be triggered based on the opportunity information selected. Trigger based on a
single opportunity setting or a combination.

Opportunity Trigger rZJ
Ophions Stage
Max sge: |0 : " Dpen
" Won

Manager: |

|
Opportunity: | v
O

Stage |

1. Inthe Options area, configure:
O Max Age: Select the age of the project (in days).
O Manager: Select the manager.
O Opportunity: Select the opportunity name.
O Stage: Select the stage of the opportunity.
In the Status area, select either Open or Closed.
Click OK.

GoldMine Administrator's Guide Page 290 of 439



GoldMine™®

Project Trigger Dialog Box

Automated Process events can be triggered based on the project information you select in the Project Trigger
dialog box. You can trigger on a single project setting or a combination of settings.

Project Trigger EJ

Dptions Stage
Magige: [0 = « Open
Manager: | = o
Project: | ]
Stage: | O {I—:ﬂ
[ ] oo |

1. Inthe Options area, select or configure one or more of the following:
O Max Age: Select the age of the project (in days).
O Manager: Select the manager.
O Project: Select the project name.
O Stage: Select the stage of the project.
In the Status area, select either Open or Closed.

Click OK.

Schedule Action Dialog Box

1. Inthe Schedule Activity area, select the activity type.

2. Inthe User area, select the user the activity is assigned to based on the following options:
O Record Owner. Owner of the Contact record, if record ownership was set.
O Assigned User. User specified in the Activity Details.
O Attaching User. User attaching the Track to the record.
O Logged User. User currently logged into the workstation executing the Automated Process.
O User from Field. A user can be selected from a Contactl or Contact2 field, if the fields are configured

accordingly. Example: a Sales Rep field.

3. Click Activity Details.

The related Scheduling dialog box appears. Use to specify information about the scheduled activity.

NOTE: Automated Processes do not allow you to schedule and send iCalendar meeting requests as you
schedule an action.

4. Specify how many days out to schedule the activity in the Schedule x days into the future text box.
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5. Select one:
O From Today. Starts counting days from the current date.
O From Trigger Date. Starts counting days from the date the event is triggered.

6. Select Skip Weekends if you do not want to include weekend days in the total.

NOTE: The weekends are skipped only if the process occurs on a weekend day. For example, you schedule
an activity on 02.15 for nine days later on 02.24, which happens to be a Sunday. GoldMine will actually
schedule it for 02.25, the following Monday. If you scheduled an activity for eight days which would be a
Saturday, then GoldMine schedules for Monday as well. However if you schedule an activity for seven days

later, GoldMine will schedule for Friday.

7. Click OK.
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Synchronization

Synchronization is a process where one GoldMine system exchanges information with another GoldMine system
through a Local Area Network (LAN), Wide Area Network (WAN), or the Internet. It is useful for organizations with
employees in distant offices and in the field who can link their GoldMine systems to communicate effectively and
remain dynamically connected.

Synchronization is also used when exchanging data between a GoldMine system and Microsoft Outlook, or Pocket
PC.

To synchronize, each GoldMine system must have a unique license number (see Licensing). However, a GoldMine
Administrator working on a GoldMine network can create a GoldMine sublicense to work on an undocked basis.

It is required that you run the same version and build of GoldMine on all systems. To maintain the current version
on all systems, undocked users can update their copies via unattended installation. For more information, see
“Unattended Installation” in the GoldMine Installation Guide.

IMPORTANT: If a newer version of GoldMine is installed locally, remote clients might not be made aware of
this upgrade and might continue to work with older local versions instead. To avoid the synchronization
between different GoldMine database versions, remote clients receive a warning message indicating that they
must upgrade before they can synchronize with the newer database.

Transfer Sets
Synchronization involves the creation, distribution, and retrieval of transfer sets:
m Stage 1. The transfer set is created based on changes to the data since the specified date.

m Stage 2. The systems connect and exchange data.

= Stage 3. The retrieving system incorporates the updates into the databases.
For more information see About Transfer Sets.

During remote synchronization, GoldMine creates a transfer set that is a database of all the changes made to a
GoldMine database from the beginning date/time until the present time frame. The receiving GoldMine system
uses data in the transfer set to update the resident GoldMine system’s database and retains only data from the
transfer set that is newer than the information in its own GoldMine database.

NOTE: The transfer set does not contain every change ever made to a GoldMine database. Records go back
only far enough to include changes made to the database since a specified cut-off date.

The transfer set contains only records from the originating GoldMine system’s database modified within a
specified time frame, only those changed records are updated on the GoldMine system that retrieves the transfer
set.

GoldSync uses a system of unique record identifiers and time stamps to track when a record was created, when it
was last successfully synchronized, and which update is the most current. During synchronization, GoldSync:

= Evaluates the database to determine what records to include in the transfer set based on Send Options and the
cutoff date.

= Sends the transfer set.

m Evaluates the contents of the transfer set to determine what data to retrieve based on the Retrieve Options.
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m Compares the date and time stamp of a field in the transfer set with the date and time stamp of the same field
in the database to determine which record is more recent and will overwrite the older data.

Tlogs

GoldSync uses Tlogs to keep track of changes to each field in the database and to track new records. (Tlogs is the
general name for the two types of logs: ContTlog and GMTlog. They track date and time stamps for changes to
fields and the synchronization of the data.) For more information on GoldSync, see About GoldSync.

Changes you make to your GoldMine data are tracked to the millisecond and stored in the Tlogs. This ensures that
if two users update the same field on a record, the most recent change saves.

IMPORTANT: When creating a new remote site, do not copy tables from one system to another since this
causes inconsistent data with synchronization. Remote sites should be set up with a fresh installation of
GoldMine, and the data should be synchronized with the main GoldMine site.

Configure specialized settings in the Synchronization Settings (see Configuring Synchronization Settings).

Uses
Use synchronization in these ways:

= One-button Sync with GoldSync Server. See Synchronizing Using One-Button Synchronization.
= Synchronization Wizard. See Using the Synchronization Wizard.
= GoldSync Administration Center. See Using the GoldSync Administration Center.

= Copy/Move Records. See Using Copy/Move Records.

About Transfer Sets

Transfer sets are the containers that transport data between systems. They contain the contact and user-related
information that is specified by record type, record filters, and specified date ranges.

As a transfer set is built, GoldMine follows a basic protocol. It evaluates the syncstamp (Contains the time and date
when the record was last successfully retrieved during synchronization.) if a particular record falls between the
cutoff date and the current date and time when the transfer set is being created. If it falls within that range, the
record is included in the transfer set (as long as it is not excluded by other criteria, including security settings
determining whether a remote site can update the server, the server can update the site, or both update each
other). If the cutoff date is older than the oldest Logstamp (Contains the time and date the record was last
changed.) in the TLogs (The general name for the two types of logs: ContTlog and GMTlog. They track date and
time stamps for changes to fields and the synchronization of the data.), GoldSync uses the RecID method to
evaluate whether a record in the database was created after the cutoff date. With the RecID method, GoldSync
evaluates the first seven characters of the RecID for the date and time the record was created. There is a Cut-off
date, which can be set to include all records that have a date on or after that date. If the record data is newer than
the cutoff date, the then record is included in the transfer set.

NOTE: When a previously synchronized Contact Record's ownership changes, for example from (public) to a
specific user, and there has been no further synchronization, the Contact Record can still be updated by a
“non-Master Rights” user on the remote system. The remote user's ability to modify the record is not
restricted until after the next synchronization; record ownership is updated during synchronization.
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When the transfer set is created, it contains the data to transfer and the transfer set Tlogs. When GoldSync
retrieves a transfer set, it compare the Logstamp of the records in the transfer set with the Logstamp of the
records on the retrieval site. If the sending Logstamp is newer than the Logstamp for a record in the retrieval site,
the record is retrieved.

Synchronization Scenario

ABC Company is a medium-sized manufacturer employing about 100 people. It has departments handling sales,
order processing, customer service, and support. Ideally, these departments collaborate to accomplish ABC’s
goals.

Whenever a prospect calls to inquire about ABC’s products, the inside sales representative adds the prospect to
the database, including name, address, telephone, how the prospect heard about ABC Company, and the products
in which the prospect is interested.

The literature fulfillment department uses this information to send the requested product information to the
prospect. They inform the outside sales representative of the date the information was sent.

The outside representative assigned to the prospect’s territory follows up with a call to the customer a week or so
after the product information was sent from the home office. Several subsequent, qualifying sales calls are made
to secure the sale of an ABC product. During this period, the salesperson is responsible for updating ABC's sales
management on sales activity including related calls and forecasts.

After a sale is completed, the accounting department generates an invoice the shipping department uses to fill the
customer’s order. If the customer fails to pay the invoice, the collections department sends a delinquent letter to
the customer to indicate payment is due for the ABC product.

Meanwhile, the customer service department records the date the merchandise was received by the customer
and initiates the warranty period. Then, when the customer requires support, the customer service department
determines and notes the nature of the problem for future reference. If necessary, a follow-up support call is
scheduled at the customer’s location.

ABC Company’s field technicians handle support calls. A field technician uses the customer information gathered
by sales and customer service to locate a customer’s office and to determine the nature of the problem. When the
problem has been corrected, the technician creates a support record for future reference, then prepares an
invoice based on whether the product is within its warranty period.

In this scenario, several employees access the same customer information at the same time, and, in some cases,
these individuals work in locations that do not allow direct access to the office. The remote staff, such as the
outside sales representatives and field technicians, need access to the same information available to inside ABC
Company staff.

To share critical account information, they must be able to transfer this contact data between the office staff and
the mobile staff. With synchronization, ABC Company transfers sales leads to outside salespeople, sends support
requests to service technicians, and collects follow-up reports from staff in the field. Without remote
synchronization, this information would probably have to be printed, sent by facsimile to the remote location, and
re-entered into GoldMine by the salesperson or service technician. Synchronization automatically sends updated
information to ensure timely, accurate communications for organizations with mobile or distributed personnel.

Configuring Synchronization with Microsoft Outlook

Synchronize data between GoldMine and Microsoft Outlook.
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After creating at least one synchronization profile, configure the Server Agents Administrator to automatically
synchronize GoldMine and Outlook regularly.

IMPORTANT: Some Outlook synchronization settings must be defined at the local workstation.

NOTE: Outlook must be installed on the synchronizing workstation.

Select Tools > Synchronize > Synchronize with Outlook. The Outlook Synchronization dialog box opens.

Automatic Synchronization

If you want synchronization to occur automatically with GoldMine, check the Automatically synchronize with
Outlook box.

Manual Synchronization
Select from the following options:
= If you want synchronization to occur automatically with GoldMine, check the Automatically synchronize with
Outlook box.

= If you want to use the setting from the Outlook integration, select the Use the settings for the Outlook
Integration option.

= If you want to select what to synchronize, select the Choose what to synchronize, using the Outlook Sync
Wizard and then click Synchronize now (see To Manually Synchronize Now with Outlook).

To Manually Synchronize Now with Outlook

1. Open the Tools menu and select Synchronize > Synchronize with Outlook. The Outlook Synchronization
dialog box opens.

Select the Choose what to synchronize, using the Outlook Sync Wizard option.

Click the Synchronize now button. The GoldMine Outlook Synchronization Wizard opens.

Select from the following options:

O Start a new session. Configure settings for a new synchronization session.
If you selected Start a new session, click Next and continue to the Outlook Synchronization Options
dialog box.

O Sync using the setting of the following Profile. Select a saved profile from the drop-down list.

If you select Sync using the settings of the following Profile, select Finish. The GoldMine Process
Monitor shows the status of the process. Edit settings by clicking Next. The Outlook Synchronization
Options dialog box appears.
5. On the Outlook Synchronization Options dialog box, select a send and retrieve options:
O Send and retrieve: To/From Outlook: Sends and retrieves data between GoldMine and Outlook.
O Send Only: To Outlook from GoldMine: Sends data from GoldMine to Outlook, but does not retrieve data
from Outlook to GoldMine.

O Retrieve only: To GoldMine from Outlook: Retrieves data from Outlook to GoldMine, but does not send
data from GoldMine to Outlook.

Select Synchronize Contact Items to send or retrieve contact information.
Select Synchronize Calendar Items to send or retrieve calendar information.
Click the Advanced button to define the Advanced Options for synchronization.

The Advanced Options dialog box opens. Click the following tabs to set options for the following areas:
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O General defines the telephone extension separator, record modification tolerance, duplicate activity
checking by Outlook ID number, synchronizing RSVP, and using categories for activities in Outlook.

NOTE: You can change the information displayed in the Outlook activity Subject line of a retrieved
GoldMine activity by editing the Goldsync.in1 file (see Adding Macros to the GoldSync.ini File).

O Deletions defines how deletions synchronize between GoldMine and Outlook.
O Field Mapping defines mapped fields so GoldMine can place data in the corresponding Outlook fields.

IMPORTANT: If you choose to use a different folder than the default option in the Folder selection area on the

Contacts, Calendar, or Task tabs, it is required to define that custom folder path at the system where the
profile will be used.

NOTE: The synchronization of Notes is not supported between GoldMine and Outlook.

O Contacts specifies the location of the Outlook folder in which GoldMine sends and retrieves contact
information.

O Calendar specifies the Outlook folder in which GoldMine sends and retrieves activity information.
O Task specifies the Outlook folder in which GoldMine sends and retrieves.

9. After configuring advanced options, click OK and you return to the Outlook Synchronization Options dialog
box.

10. Click Next.
The dialog box that appears depends on the option you selected:
O Send and retrieve: To/From Outlook (see GoldMine Record Selection and User’s Calendars)
O Send Only: To Outlook from GoldMine (see GoldMine Record Selection and User’s Calendars)
O Retrieve only: To GoldMine from Outlook (see Outlook Record Selection Dialog Box)

GoldMine Record Selection and User’s Calendars

The first two options on the Outlook Synchronization Options dialog box allow you to send-and-retrieve or
send-only records to Outlook (see To Manually Synchronize Now with Outlook).

= Send and retrieve: To/From Outlook
= Send Only: To Outlook from GoldMine

Both of these option present the following scenario. However, the Send and retrieve: To/From Outlook option
will proceed to the Outlook Record Selection Dialog Box when you complete the “send” portion of the wizard.

The first dialog box that appears after selecting either of these options and then clicking Next is the GoldMine
Record Selection dialog box.
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Qutlook Synchronization: GoldMine Record Selections

Specify which GoldMine records you wizh to send to Outlack.
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On this dialog box, make selections to choose the Current contact record, cutoff date/time, filter, contact records
and groups to include since cutoff. The Also include contacts with calendar activities from check box enables the
start/finish date range boxes. You can also choose to Omit records previously retrieved from Outlook by checking

the box.

After you complete the GoldMine Record Selection dialog box, click Next to go to the User’s Calendar Selection

dialog box.

Qutlook Synchronization; User’'s Calendar Selection
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Select the Calendar Records that you want to send to Outlook. The My Calendar will only send your calendar. The
Others’ Calendar option enables the list of other available calendars to send. Make you selections and then click

Next to continue the wizard, or Finish to complete the wizard.
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Outlook Record Selection Dialog Box

The third option on the Outlook Synchronization Options dialog box, Send and retrieve: To/From Outlook, allow

you retrieve-only records to Outlook (see To Manually Synchronize Now with Outlook).

The dialog box that appears after selecting this option and then clicking Next is the Outlook Record Selections

dialog box.

Qutlook Synchronization; Outlook Record Selections

Pleaze specify which Dutlook records you wish to send to
GoldMine.

All Dutlook, records changed since cutoff
Cutoff; | EXESTENI * |10:54 am | ¥

[ Ignore last synchronized date

X]

| <Back || New> | [ Finish | Ccancel

The Cutoff date/time allows you to specify a starting point for records with a modification date/time until the
current date/time for all Outlook records. What that means is that any Outlook record that is newer than the
specified date/time will be synchronized. You can also choose to Ignore last synchronized date when sending
Outlook records to GoldMine. Make the desired selections and then click Next to continue the wizard, or Finish to

complete the wizard.

Using Copy/Move Records

Move a single record or a group of contact records to a Contact Database. Copy/Move is a synchronization

process. To copy or move only some of the records, build the appropriate filter or group first.

IMPORTANT: When copying or moving records that have cases linked to the records, they will not

appear in the “Other” contact set.

NOTE: It is recommended that you back up your database before moving data.

For example, move contacts into an archive database, or copy records from a leads database to a customer

database once the lead becomes a customer.

1. Select Tools > Data Management > Copy/Move Records. The Copy/Move Records Between Contact Sets

dialog box appears.

2. From the Select Target Contact Set drop-down list, select the Contact Database. The records copy or move

from the open database.
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3. Inthe Record Selection area, select either:
O Current Record. Copies or moves the active contact record.
O Group of Contact Records. Copies or moves all records in the filter or group selected from the drop-down
list.

4. Inthe Transfer Method area, select either:

O Copy Records: Creates a duplicate of the records in the target contact set. The duplicate records have the
same account numbers as the original records, and all associated notes, history, additional contacts,
detail, and referral records also copy.

O Move Records: Moves records from the current Contact Set to the target file. Records delete from the
original file.

IMPORTANT: Shared data (such as Opportunities, Scheduled Activities, and Cases) must be carefully
considered before deletion. This data exists only once in the Base tables and is shared between all
contact sets. If shared data is selected when deleting a contact record from one contact set that has
been copied to another contact set, it will no longer be available from either contact set.

It is recommended that you use the copy feature only. Copy and verify the data in the new contact set,

and delete the data that is not shared in the originating data set.

NOTE: Scheduled Activities, Opportunities, and E-mails (shared data) MUST be completed (filed) in the
correct Contact Set. Otherwise, the History information will go into the wrong Contact Set.

5. If you selected Move Records, select Sync Deletions to mark moved records as deleted. Selecting this option
marks the Tlogs for the records as deleted and GoldMine does not recognize attempts by another GoldMine
system to re-synchronize the records.

Click Details to read a description of the Sync Deletions option.
Click Go. The Copy/Move begins.

The Process Monitor displays progress in the process.

Using the Sync Spy

When synchronizing records you might need to use the Sync Spy to check the records updating in the sync logs.
Use Sync Spy to view the sync stamp, log stamp, field name, and user.

NOTE: With Sync Spy you determine if there is a sync stamp for the field and whether you set the cutoff
date back far enough.

Sync Spy window contains an upper and lower pane. The upper pane is summary information for the active
Contact Record. The lower pane reflects the information stored in the Contact file Tlogs (ContTlog). This log file
holds synchronization information for the contact set. Each contact database has its own ContTlog file.

1. Select Tools > Synchronize > Sync Spy. The Sync Spy window opens.
2. On the Contact Record for which you are checking the updates, click the field in question.
O Database. Name of the table you are currently evaluating.

O Sync Stamp. The date and time when the field was synchronized from the remote site and the date and
time the field was modified by a user local to this system.

NOTE: On the transfer set creation side, the Sync Stamp is used with the cut-off date and time to determine
if the field-level or record-level change should be included in the transfer set.

O Stamp. The date and time when the field was modified by a user local to the system the Sync Spy is run on.
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NOTE: On the retrieval system, the Log Stamp is used to compare which system has the latest change.
O Field Name. Field modified in the selected database.

NOTE: Curtained fields are viewable in the Sync Spy. If this is a security concern for your organization,
disable the Sync Spy option for non-Master Rights users you do not want viewing the fields. Select Tools >
User Settings. Highlight the user and click Properties. Click the Menu tab and expand Tools. Disable the
Sync Spy menu option for the user.

O User: User who made the modification to the field. Also shows if the modification was made by a remote or
local user.
3. To select a table for the Sync Spy to display if values for a certain area are stored in more than one table, you
can select the table from the drop-down right from table. For example, the Fields tab information is stored in
Contact2. Select Contact2 from the drop-down list to view the values.

4. To view field values stored in another table, click the tab containing the values to view.
For example: Browse to the Additional Contacts tab, highlight an additional contact, and then open Sync Spy.
To display data in the Sync Spy for another contact, click the Contact Record and scroll through the database.

Use the local menu to access Find and Output options.

Sync Spy Local Menu
Right-click in the upper pane or lower pane to display the Sync Spy local menu which contains:

= Find. Displays the Find dialog box where you search for contacts based on entered text.

= Output to. Sends the data to the printer, Word, Excel, or the clipboard.

About the Synchronization Wizard

Use the GoldMine Synchronization Wizard to synchronize with another remote GoldMine system using an
IP/Network connection or Internet e-mail. GoldMine can initiate or accept a connection from a remote GoldMine
system and perform the synchronization by transferring data across the selected carrier. Save settings in a profile
for use in future synchronization sessions.

The wizard lets you specify the settings needed to synchronize with another site. Synchronize data in one direction
to send new leads to a salesperson or synchronize bidirectionally to let a traveling salesperson exchange data with
the home office.

To use the Synchronization Wizard, you must:

m Establish a TCP/IP connection between the server and remote machine. This is the default configuration.

= Have Internet e-mail configured in GoldMine if sending and retrieving transfer sets by e-mail.

Using the Synchronization Wizard

Define a variety of data and communication options to synchronize with a remote GoldMine or GoldSync system.

Define the settings needed to create a transfer set or immediately start a synchronization session.

1. Select Tools > Synchronize > Synchronization Wizard. The GoldMine Synchronization Wizard dialog box
appears.

2. Select one option:
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O Start a new session. Define settings for a synchronization session. Use these settings once or save for
future use.

O Sync using the settings of a Sync Profile. Synchronizes according to the settings already defined in a profile
selected in the drop-down list.

O Sync using the settings of a GoldSync Site. Synchronizes according to the previously defined settings for
the site selected in the drop-down list. The site settings are defined in the GoldSync Administration
Center. GoldMine uses only the send and retrieve options for the selected site configuration.

O Use the following profile/site settings. Specifies the synchronization profile to use during the current

session. This option is available only if you select Sync using the settings of a Sync Profile or Sync using
the settings of a GoldSync Site.

NOTE: You can delete a synchronization profile selected in the drop-down list by pressing the Delete key on
the keyboard.

3. If you selected Sync using the settings of a Sync Profile or the settings of a GoldSync Site, click Finish to

synchronize according to existing settings. The GoldMine Process Monitor appears.

TIP: The Process Monitor (see Monitoring Processes) can float anywhere on the GoldMine
screen, or it can be docked to any of the four sides of the GoldMine screen. The window can also

be resized to maximize available workspace. For best results, dock the Process Monitor to the
bottom of the GoldMine screen.

4. To verify or change existing settings, click Next to continue to the Connection Method dialog box. (see
Configuring the Synchronization Connection Method).

Configuring the Synchronization Connection Method

When configuring synchronization, select a connection method. Then, click Next to continue to the appropriate
connection options.

= Connection Method (IP to IP/Network):

O Answer an incoming connection. Sets GoldMine to wait for an incoming connection from another
GoldMine or GoldSync system. When the outside system makes contact, GoldMine accepts the
connection, establishes a conversation with the remote system, and begins transferring data. The Wait
for Incoming Connection dialog box appears (see To Configure the Wait for Incoming Connection
Options).

O Connect to remote. Sets GoldMine to contact the remote GoldMine or GoldSync system via modem, direct
Internet connection, or network. The Connect/Send E-mail to Remote dialog box appears (see To
Configure Connect/Send E-mail to Remote (Connect to Remote)).

= No connection with remote:

O Send a transfer set to remote by E-mail. Sets GoldMine to send a transfer set as an attachment to Internet
e-mail. The Connect/Send E-mail to Remote dialog box appears (see To Configure Connect/Send E-mail to
Remote (Transfer Set by E-mail)).

O Create a transfer set. Displays the Create a Transfer Set dialog box where you specify the destination for
the transfer set, and an optional password. GoldMine does not attempt to contact another GoldMine or
GoldSync system (see To Configure the Create a Transfer Set Options).

O Retrieve a transfer set. Displays the Retrieve a Transfer Set dialog box where you define the location where
GoldMine can find the transfer set, options for unpacking and deleting the transfer set, and an optional

password. GoldMine does not attempt to contact another GoldMine or GoldSync system (To Configure
the Retrieve a Transfer Set Options).
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To Configure the Wait for Incoming Connection Options

When selecting Answer an incoming connection from the Connection Method dialog box, (see Configuring the
Synchronization Connection Method), the Wait for an Incoming Connection dialog box appears.

1. Select Send changed data to remote to send changed data from this site to the remote. By default, GoldMine
waits for another GoldMine or GoldSync system to call. When the other system calls, GoldMine answers to
establish a connection with the remote system and begins transferring data.

Select Retrieve changed date from remote to retrieve changed date from the remote to this site.

Select Wait continuously for an incoming connection so GoldMine resets after a synchronization cycle and
waits for another connection.

Type the Optional connection password.

5. Type the TCP Port synchronization is using. The default TCP Port is 5993. Typically, do not change this entry; if
you override the default port, you must select the same port as the remote system.

To Configure Connect/Send E-mail to Remote (Connect to Remote)

Set connection options when selecting Connect to remote on the Connection Method dialog box (see Configuring
the Synchronization Connection Method).

1. Select Send changed data to remote to send changed data from this site to the remote.

2. Select Retrieve changed date from remote to retrieve changed date from the remote to this site.

3. Inthe Remote's Internet IP Address text box, type the Internet IP address you are connecting to. If creating a
one-button synchronization profile, the remote in this case is the GoldSync server the undocked computer
synchs to.

4. Type the TCP Port. The default TCP Port is “5993”. Typically, do not change this entry; if you override the
default port, you must select the same port as the remote system.

Click IP to add or edit alternative IP addresses.
Type the Optional connection password in the text box.

Click Next. If you selected Send changed data to remote, the Send Options dialog box appears (see
Configuring Send Options).

To Configure Connect/Send E-mail to Remote (Transfer Set by E-mail)

When selecting Send transfer set to remote by E-mail on the Connection Method dialog box, (see Configuring the
Synchronization Connection Method), you can then set the e-mail options.

1. Type the Remote's E-mail address in the text box.
2. Type the Optional connection password in the text box.
3. Click Next. The Send Options dialog box appears (Configuring Send Options).

To Configure the Create a Transfer Set Options

If you select Create a Transfer Set on the Connection Method dialog box (see Configuring the Synchronization
Connection Method), set the options in the Transfer Set Options dialog box.

1. Type or browse to the Path for the transfer set to be placed location. This specifies the destination for the
transfer set upon creation.
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2. Select Update cutoff time if previous transfer set in the above path has been retrieved (deleted) to prevent
GoldMine from updating the cutoff time if a previously retrieved transfer set is detected in the directory
designated for transfer set placement.

3. Type the Optional transfer set password. When a password is used, both the local and remote GoldMine
systems must use the same password.

4. Click Next. The Send Options dialog box appears (Configuring Send Options).

To Configure the Retrieve a Transfer Set Options

If you select Retrieve a transfer set on the Connection Method dialog box (see Configuring the Synchronization
Connection Method), set the options on the Retrieve a Transfer Set dialog box.

1. Inthe Path for the transfer set to be retrieved box, type or browse to the location to place the retrieved
transfer set.

2. Select Unpack transfer set only - do not retrieve records to decompress the transfer set, and place the
transfer set in the directory designated in Path for the transfer set. GoldMine also decrypts the transfer set
(with a password value if entered in Optional transfer set password below). GoldMine will not retrieve the
data into a Contact Set.

NOTE: Beginning with GoldMine 7.0, an unpacked transfer set is no longer a .dbf file, but an EBML file
instead. This is a binary format similar to text-based XML, but with much better performance. lvanti
Support has tools to decode the EBML files into a text form, should troubleshooting become necessary.

3. Select Delete transfer set after unpacking or retrieval to delete the transfer set after unpacking or retrieving
the records into the designated Contact Set.

4. Type the Optional transfer set password to specify a password and protect the system from unauthorized
connection attempts. When a password is used, both the local and remote systems must use the same
password.

5. Click Next. The Retrieve Options dialog box appears (Configuring the Retrieve Options).

About GoldSync

GoldSync provides unattended and automated remote synchronization for 2 or more GoldMine systems. GoldSync
remote synchronization includes multilevel security and administrative controls and enhanced flexibility over
GoldMine’s one-to-one remote synchronization.

GoldMine Administrator's Guide Page 304 of 439



GoldMine™®

GoldSync Server

GoldMine Server

Remote Site

GoldSync licenses are included with GoldMine Premium Edition. GoldSync can simultaneously update multiple
GoldMine systems with added or changed information in other GoldMine systems. Updates can be sent to as
many users as are configured for the synchronization.

Although most users are not responsible for configuring or maintaining GoldSync, they might be required to
synchronize their GoldMine with a GoldSync server. If so, they can use the One-button Sync with GoldSync Sync to
set up and run a GoldSync profile with settings provided by their GoldSync administrator.

GoldSync administrators choose connection methods, session intervals, and the sending/retrieving data options
that work best for their remote-to-host scenarios.

Systems using GoldSync to synchronize enjoy the added convenience of One-button Sync with GoldSync Server
synchronization. Users can employ click-and-go synchronization using a profile defined by the GoldSync
administrator. In some cases, users can install GoldMine and the One-button synchronization profile in one
operation.

Recommendations
= To maximize potential for success, a certified GoldSync administrator should perform administrative duties.
m It is recommended that only GoldSync administrators create sync profiles.

m It is recommended, and set by default, that undocked Users are denied access to the Synchronization Wizard.
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GoldSync Key Terms and Concepts

Host Site: The GoldMine system accepting incoming connections from one or more remote sites. The site running
GoldSync with the Master license typically is called as the host site.

Remote Site. A GoldMine system initiating a connection to the host site. A remote site typically is an undocked
user or branch office with a sublicense.

Site Group. A group of remote sites sharing common configuration settings. These settings define which data
synchronizes, who sends/receives the data, how often the data synchronizes, and the method of data transport.

Site Group Members. The individual sites belonging to a site group. While the site group members inherit
properties of the site group, an individual site group member can also have its own unique settings.

Site Code. An identifier limiting connected and initiated processes and nonconnected processes to only those sites
with matching site codes. The site code is assigned to both the process and the site(s).

GoldSync Server. Any network computer GoldMine is installed on and where synchronization processes run. More
than one GoldSync Server on a network is allowed. A GoldSync Server is a host site or a remote site depending
upon whether it accepts or initiates connections.

Processes. The synchronization tasks performed on a GoldSync Server. Processes pack, send, and retrieve the
data. Each process can initiate multiple tasks.

Transfer Set. A file comprising all the changes made in a GoldMine database during a specified time frame,
including new Contact records and updates to existing Contact Records. Transfer sets can include changes down to
the field level for each type of information stored.

NOTE: The transfer set does not contain all historical changes made to a GoldMine database. It includes
records starting with the most recent and spans only to include database changes since a specified cutoff
date.

Contact Set. A database of Contact Records.

File Code. A unique identifier used to distinguish one Contact Set from another. File Codes are defined in the main
GoldMine application. (Select Tools > Database > Open Database, then select the Contact File from the list and
click the Properties button.) When using the Synchronization Wizard or Gold Sync, all available Contact Sets MUST
have a File Code otherwise the specific Sync feature will not open. When the File Code is set, the Contact Set is
available for selection in the Synchronization Wizard and the GoldSync Administration Center.

NOTE: It is strongly recommended that the remote system must have a matching File Code.

ReclID. The unique identifier for every record in GoldMine. This value is always compared during synchronization
to determine if there is a matching record in the respective databases.

GoldSync Administration Center: The command center where synchronization settings are configured. The
GoldSync Administration Center lets you administer multiple sites and automate the processing of transfer sets
and connection management.

After you configure GoldSync, no further operator intervention is required. the GoldSync Administration Center
handles dialing, redialing, and information transfers for remote GoldMine sites.

GoldSync Synchronization Wizard: The tool used by remote sites to manually define configuration settings and
initiate synchronization sessions with the host site.
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One-button Synchronization: Lets remote users synchronize with GoldSync with a single click. The administrator
sets up a one-button sync profile for the remote user in the GoldSync Administration Center.

GoldSync Implementation Considerations

To understand how to make synchronization part of your business process, analyze:

= The anticipated number of records in the database.

= The volume of changes you expect to make to the data.

= Whether the entire database or a filtered subset of data is to be synchronized with remote sites.
= The number of remote sites.

= Whether the sync model is dynamic (several synchronizes per site per day) or static (once per week for
reporting and data archive purposes).

m The expected future growth of the overall implementation (additional records/databases, users, remote sites).
= To understand the technology issues, consider:

= Bandwidth currently available between potential remote sites and all synchronization servers.

m Future plans for enhancing bandwidth (for example, VPN, corporate WAN, and so on).

= Firewall and network security limit synchronization options.

m Personnel resources available to administer and maintain synchronization.

Planning a GoldSync System

Analyze information needs, resources, and challenges presented by geography, time zones, or other factors.
GoldSync accommodates a variety of configurations.

First, map a diagram of the GoldSync setup to show requirements for accomplishing business goals and providing a

reference during final implementation.
r' Sydney
ﬁﬂ I Office

Heidi, Sales Rep
in New Jersey

Chicago -
Corporate Headquarters

T ”1 Los Angeles
fy || Office
Bill, Sales Rep
in Texas
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Determine individual needs of the different remote sites. In the sample diagram, the Chicago office creates three
site licenses with the appropriate number of seats. Sydney and Johannesburg need at least one GoldSync license
each to synchronize with Chicago. Los Angeles needs one GoldSync license for synchronizing with Chicago and two
more GoldSync licenses to create two remote sites for Heidi and Bill, who synchronize with Los Angeles; and Los
Angeles, Johannesburg, and Sydney synchronize with Chicago.

Determine individual needs of the different remote sites. For example, your Chicago office creates three site
licenses with the appropriate number of seats. You Sydney and Johannesburg offices need at least one GoldSync
license each to synchronize with Chicago. Los Angeles needs one GoldSync license for synchronizing with Chicago
and two more GoldSync licenses to create two remote sites for Remote Sites (Sales Representatives), who
synchronize with Los Angeles; and Los Angeles, Johannesburg, and Sydney synchronize with Chicago.

Planning Variables
The GoldSync administrator must identify variables to evaluate when installing GoldSync.

Because the amount of data and load an organization require of GoldSync varies, no simple way exists to
determine if a computer’s configuration or network infrastructure effectively serves GoldSync’s processing
requirements. GoldSync’s requirements change as variables change.

IMPORTANT: GoldSync service does not see mapped drives. If GoldMine was installed to
an existing database, and the server path was defined as a mapped location (such as
G:\GoldMmine) you will receive an error message when starting GoldSync. To avoid this,
use the UNC path or make corrections to the gm.ini as in the following example:

1. Openthe gm.ini file for edit.

2. Locate the realini and sysdir entries
QO realini=G:\GoldMine

O sysdir=G:\GoldMine

3. Replace with your UNC path

O realini=\\<yourhost>\<GMPath>
O sysdir=\\<yourhost>\<GMPath>
4. Save thefile.

= Operating System: The GoldSync server performs a considerable amount of intensive processing, so the
GoldSync administrator must ensure the system acting as the GoldSync server can consistently sustain the
demands of heavy load processing. Select a system that is stable, reliable, and scalable. We strongly
recommend administrators install and deploy GoldSync on Microsoft Windows Server 2012 or higher.

The key benefit of determining the differences is to understand how this variable affects planning for the SQL
Server implementation with GoldSync. Also, different operating system versions offer varying levels of
support for memory and processing capabilities.

= Microsoft SQL Server: Refer to the Compability Matrix in order to determine SQL Servers currently supported
by GoldMine Premium Edition. Understanding how SQL Server is configured and managed is critical to
GoldSync’s successful deployment.

= Memory Usage: Newer versions of Microsoft SQL Server require more RAM than earlier versions because the
redesigned query optimizer using hash and merge takes more in-memory processing.
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The more memory available, the better caching capability SQL Server has for loading the database into
memory, and for performing queries in memory.

Operating systems can impose limits on the amount of memory any application can use. Administrators must
know key differences between various versions and editions of the Windows NT-based systems to effectively
determine what memory capabilities are available to SQL Server.

m Disk 1/0 Subsystem Performance Can Affect SQL Server’s Performance: SQL Server tries to cache as much
information as it can into memory; at some point, available RAM will likely be insufficient to hold all the
information (especially when running queries on large databases). Consequently, virtual memory is used,
which can result in decreased performance.

I/0 performance becomes critical in sustaining heavy read/write activities. The physical disk subsystem must
provide the database server with sufficient I/O processing power for the database server to run without disk
queuing.

= SQL Server Profiler and SQL Server Performance Monitor: Tools such as SQL Profiler and SQL Server
Performance Monitor can help administrators with performance tuning. SQL Server Profiler provides detailed
information about activity occurring on the database server. Its logs are useful when troubleshooting SQL
error messages and symptoms with applications issuing queries on the databases hosted to SQL.

= Resources, Data, and Load: These variables can have a significant impact on GoldSync’s functionality and
performance. They have an interdependent relationship, making it difficult to plan a GoldSync
implementation without accounting for all three.

NOTE: After determining the amount of data and load the GoldSync Server must process, determine the
hardware requirements. Look at the organization’s infrastructure to determine the limitations it can impose
on the overall GoldSync implementation.

= Selecting a GoldSync System Server: Depending upon the amount of data and load, the GoldSync server might
need to perform intensive processing. We recommend a dedicated GoldSync Server.
Systems serving as SQL Servers and acting as servers for other applications or systems running resource-
intensive applications are not good candidates for GoldSync Servers.
Although GoldSync functions on systems meeting minimum requirements, we recommend (especially when
running multiple sites) administrators deploy GoldSync on systems using at least a Windows 2012 operating
system with at least 256 MB of RAM. A safe guideline is to install as much memory as the computer can hold,
especially in the case of single-processor computers.
The overall load the GoldSync server processes influences GoldSync’s performance. The more data GoldSync
processes through concurrent tasks, the more processing power it requires from the computer it runs on.
The location of the GoldMine executable GoldSync uses has no observed bearing on GoldSync’s performance.
To simplify management and troubleshooting, we recommend administrators run the same executable for
GoldSync while the main GoldMine server is running.

= Setting Maximum Simultaneous Synchronization Sessions: Hardware components such as processor speed,
memory, and disk subsystem available, affect the number of simultaneous synchronization sessions the
GoldSync server can handle.
We recommend no more than 10 simultaneous synchronization sessions per GoldSync server. This applies to
connected and nonconnected sync methods and can fluctuate due to dependency on variables such as the
amount of data each site needs to process and the processing power of the GoldSync and SQL Servers.
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= Determining the Need to Use Multiple GoldSync Servers: Process more than 10 sites concurrently by setting
up multiple GoldSync Servers. This procedure is synonymous to load balancing, where application tasks are
distributed to multiple systems to increase and leverage the computing power that cannot be realized
through a single, dedicated GoldSync Server.

You might not realize any potential load-balancing benefits if conflicting limitations from the SQL Server’s
capability exist. The number of simultaneous GoldSync processes is always physically constrained by the SQL
Server. See Microsoft’s SQL Server documentation on Performance Tuning.

= Setting the Synchronization Period: Schedule a time when the GoldSync server can handle processes. By
assigning a time for sites to synchronize, the administrator is assured the server can handle the processing
load without needing to physically monitor the system.

Administrators can access GoldSync’s Process Properties to use the Sync Period setting on the group
member’s properties.

= Selecting a Synchronization Connection Method: We recommendthat administrators implement the IP to
IP/Network method because:

O Configuration is simple. Administrators specify the address (numeric or name) of the GoldSync computer
the remote is connecting to.

O It works well with common network security options, especially firewalls. GoldSync uses 5993 as its default
port where the network administrator can configure a port on its firewall to receive and send packets of
data securely. This method offers the flexibility of assigning another port number to receive the GoldSync
connection.

O It is the most reliable transport method when using the TCP/IP protocol. The TCP/IP protocol guarantees
the retransmission of dropped packets, typically due to network problems. Additionally, it ensures each
packet received has the same content as when it was sent. (If a bit changes or drops for some reason, the
protocol detects this and retransmits the packet.)

O IP to IP/Network is easier to troubleshoot. A Telnet procedure is usually the only tool needed to confirm a
problem with the IP to IP/Network method.

Example: With e-mail synchronization, there is no way to verify a transfer set was retrieved by a remote
site with the e-mail sync method because e-mail synchronization is a nonconnected procedure. GoldSync
updates the cutoff date for the next synchronization session after successfully creating a transfer set even
if the remote site fails to retrieve that transfer set. This might leave gaps in the remote’s data in a
situation where a transfer set was not successfully retrieved due to a condition external to
GoldSync/GoldMine.
= Designing a Plan to Reduce Processing Time: When using a connected method for synchronization, reduce

processing time by:

O Creating transfer sets in advance.

O Using filters and groups to limit the amount of data in the transfer set.

O Using multiprocessor systems. GoldSync takes advantage of the high-performance computing power
Windows NT-based technology provides.

GoldSync Sites Local Menu

Use the Sites menu to configure and manage Site Groups and Sites using:
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DakefTime Stamp Conyversion. ..

Refresh
Refresh Al

Disable

Generate Yerification Code. ..
Create Installation File For One-bukkon Sync,..

Email One-button Sync Profile ko Remoke. ..
New. ..
Clone. ..

Delete, ..
Properties...

= Date/Time Stamp Conversion: Opens the Date/Time Stamp Conversion dialog box to convert the SyncStamp,
LogStamp, and the first seven characters of the ReclD to a standard date or convert a regular date to a time
stamp. See To Use the Date/Time Stamp Conversion Utility.

= Refresh: Updates the item.
= Refresh All: Updates levels and items in the GoldSync Administration Center.
= Expand: Displays items under the selected item.

= Enable: Lets the selected site synchronize. GoldSync checks Allow this site to synchronize on the first page of
the GoldSync Site Group Member Wizard.

= Disable: Prevents the site from synchronizing, but leaves it listed under the site group. When selecting this local
menu command, GoldSync clears Allow this site to synchronize on the first page of the GoldSync Site Group
Member Wizard.

= Generate Verification Code: Displays the Generate Verification Code dialog box. The site must use the code to
synchronize with GoldSync. The code is only valid for the site until the remote user uses a different profile.
See Synchronization Verification Codes.

= Create Installation File for One-button Sync: Creates a GoldMine installation file according to the specifications
defined in the user’s synchronization profile. Create the synchronization profile for the user before running
this command and creating the installation file. When selecting this command, the Create Undocked User(s)'
Installation Files appears. See Creating Installation Files for One-button Synchronization.

= One-button Sync Profile: Displays the GoldSync Site One-button Synchronization Profile Wizard to create a
synchronization profile for an undocked user. This profile enables the undocked user to synchronize via One-
button Sync with GoldSync Server. See Creating One-Button Synchronization Profiles.

= Email One-button Sync Profile to Remote: Sends the remote synchronization profile as an e-mail attachment
to the undocked user. See E-mailing One-Button Synchronization Profile to Remote

= New: Creates a site group or site. See Creating Site Groups.

= Clone: Displays the New Site Group Member dialog box to create a site based on attributes of the selected site.
See Cloning Site Settings.

= Delete: Removes the selected site group or site.

= Properties: Displays the Site Group Wizard to modify the selected site group or site.
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Configuring Synchronization Settings

The Synchronization Settings dialog box Is available only to users with Master Rights. It allows you define the
synchronization options for One-button Sync, retrieving linked documents, running GoldSync as a service, and the
overrides to the default time-out settings.

1. Select Tools > Synchronize > Synchronization Settings. The Synchronization Settings dialog box appears.
2. Configure the tabs:
One-button Sync

TIP: For additional information, see Retrieving One-Button Synchronization Profiles.

O This tab is available when you retrieve a one-button synchronization profile. The One-button Sync option is
included in the profile.

O If the Check for a GoldSync connection every minute option is selected, GoldMine checks for network
connections 15 seconds after login and prompts the user to synchronize if a network connection and the
specified IP address are reachable; however, the GoldSync server might not be listening.

O In the Instant Sync Connection dialog box, you can synchronize, be prompted again in one minute, or turn
off the prompt for the session duration.

O Clear the Check for a GoldSync connection every minute checkbox if you do not want GoldMine to query
you about synchronizing whenever it detects your GoldSync server.

Linked Documents

NOTE: If running GoldSync as a service, you must use UNC paths for the folder location. Mapped drives are
not recognized properly by Windows Services.

O Configures how linked documents are handled in the synchronization process. Configure these options in

the Attempt to retrieve linked files to drop-down list:

- Select File's original drive and folder for GoldSync to place the linked documents in the original drive or
location. If not found there, GoldSync searches available alternate drives.
Then specify alternative drives in the text box below, telling GoldMine where to retrieve linked
documents. For multiple drive entries or shares, separate each drive or share entry by a semicolon
().
For example, C;\\SERVER\DOCS;D;F;. If the linked documents are not found in the original or
alternate drives, GoldSync retrieves the document into the default directory. If you did not assign a
directory in default drive and folder, the default directory is the x : \SYSDIR
directory\TmpLinks\; typically, the SYSDIR directory is the GoldMine directory.

- Select Specified default drive and folder for GoldMine to retrieve linked documents only to the default
directory. If you did not assign a directory in the default drive and folder, the default directory is the
x:\SYSDIR directory\TmpLinks\; typically, the SYSDIR directory is the GoldMine directory.

IMPORTANT: The Search for the original folder name on the drives I've specified ONLY option is very
important for undocked users who have a server share or mapped drive available. If this option in not
checked, the document will remain on the original location and will not be available on the undocked

user’s machine.

O Continue configuring the linked document settings by selecting Allow new linked documents to sync by
default for new linked documents to automatically synchronize.
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O Select Backup existing files prior to overwriting them during retrieval (As .BAK files) for GoldSync to place
a document in a directory where there is already a file with the same name; this option instructs
GoldSync to rename the existing file with an extension of . bak. After the old file is renamed, the new file
is saved. This setting can be over-ridden by the sync settings for the Site.

Timeouts

O Configure the Internet timeout settings.

O Type or select the Handshake timeout (sec). The handshake setting (the electronic protocol exchanged
between two systems when establishing a connection) determines the number of seconds GoldMine or
GoldSync waits to complete a handshake routine before disconnecting. The default value is 20 seconds.

O Type or select the Connection timeout (sec). The connection setting determines the number of seconds
GoldMine or GoldSync waits after an interruption in the transmission to continue receiving status data
before disconnecting. The default value is 60 seconds.

O Click set Set Defaults to return all time-out settings to their original default settings.

NOTE: The Set Defaults setting can have a maximum of 600 (sec) for the Handshake timeout and 120 (sec)
for the Connection timeout.
GoldSync

O This tab is available only when GoldSync is installed on your computer. Configures the notification settings
if GoldSync appears to fail.
- Send an E-mail if a synchronization error occurred. Activates the e-mail notification options.
- E-mail error messages to this address. Type the e-mail address of the person to notify. Use your
address or the address of the GoldSync administrator.

GoldSync Service

O When your GoldSync server is running on computer with a Windows 2012 Server, you can run GoldSync as
a Service. A service is an application type that runs in the background.

Running GoldSync as a service provides added security by eliminating the need to log onto the computer

to start GoldSync. It also saves administrative time since the service can be configured to restart

whenever the operating system on the computer starts, thus avoiding the task of manually starting

GoldSync.

Install, start, and configure the GoldSync Service from the GoldSync Administration Center toolbar, but

use the GoldSync Service tab to manage the service without launching the GoldSync Administration

Center.

- Set up GoldSync as Service: Installs the service.

- Uninstall GoldSync Service: Removes the service.

- Configure GoldSync Service: Launches the GoldSync Services Settings dialog box where you start, stop,
and automatically start the service.

NOTE: To use the GoldSync Service feature on Windows 10, Windows 8, or Windows 7, you must launch
GoldMine using the Run As Administrator option.

3. Click OK to save the Synchronization Settings.
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Using the GoldSync Administration Center

To start the GoldSync Administration Center, you must have GoldMine installed, running, and licensed with the
correct licenses (E-license, S- and Y-licenses). Systems with U-licenses do not have access to the GoldSync
Administration Center.

The GoldSync Administration Center is the point of access for the site groups, sites, servers, and processes servers
perform as defined for each site group.
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Select Tools > Synchronize > GoldSync Administration Center.

At the GoldSync Administration Center window, configure or edit these settings using the wizards:

O Site Group Wizard: Creates a site group with the connection method and transfer set you select. See
Creating Site Groups.

O Site Group Member Wizard: Adds members to the newly created site group (Creating Sites).

O Server Wizard: Adds servers synchronizing with remote sites (Creating Servers).

O Process Wizard: Defines the processes performed for the site (Creating Server Processes).

After configuring various aspects of the GoldSync Administration Center, use the toolbar, the Site local menu,

and the Servers local menu to manage and edit the functions.

For synchronization to work automatically, you must start the processes. Expand Servers, the server name,

and the server process. Highlight the process to start, right-click, and select Start to initiate the selected

process or AutoStart On for GoldSync to run automatically during the times designated in the Server Agents

Administrator.

NOTE: You must start the processes in the GoldSync Administration Center of the computer running the

synchronization processes.

TIP: GoldSync can be also be run as a service (see Configuring GoldSync as a Service).
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Creating Sites

Sites are Site Group Members. They commonly have the same communication method and similar settings in the
Site Group. Customize site send and retrieve options and filters.

There are two ways to create sites in the GoldSync Administration Center: after you create the Site Group or from
the local menu.

1.
2.

In the GoldSync Administration Center, right-click a site group folder and select New.

At the New Site Group Member dialog box, select one of these options:

O Undocked User: Select the undocked user from the drop-down list. The list includes undocked users
created in the License Manager. If the undocked user does not exist, see Creating an Undocked User
License.

O Sub-License: Select the site from the drop-down list. The list includes sites created in the License Manager.
For more information see f the site does not exist, see About Sub-licenses.

O Other License: Type the license serial number in the text boxes.

Click OK.

At the Welcome to the GoldSync Site Wizard dialog box, type a name for the site.

Select Allow this site to synchronize to make the site active for synchronization after configuring it. and click

Next.

The Site Group dialog box opens.

To make the site belong to a different group, select the Site Group from the drop-down list. and click Next.
The Cutoff Date/Time dialog box appears.

Select Ignore cutoff time (send all records) to send records. This option is available if you selected ALL
changed contact records on the Send Contact-related Options dialog box.

Select ALL contact records' cutoff date and time to include new and changed data from the cutoff date you
type or select from the F2 Lookup graphical calendar and clock. This option is available if you select ALL
changed contact records or All filtered records and user-scheduled activities' records on the Send Contact-
related Options dialog box.

Select Contact records linked to Activities cutoff date and time to include new and changed data linked to
activities scheduled from the cutoff date and time. This option is available if you select Contact records linked
to the 'Send users' calendar list or All filtered records and user-scheduled activities' records on the Send
Contact-related Options dialog box.

10. Select the Deletion-Filter from the drop-down list. This option applies the deletion filter for a single

synchronization and then clears the filter selection.

NOTE: When deleting a record on the remote site through a deletion filter, the deletion is not recorded as a
change in the database. This prevents the deletion from synchronizing back to the host and lets the record
synchronize back to the remote, if necessary.

11. Click Next. The Override Options dialog box opens, unless configuring a shared directory site (in this case, the
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Next Synchronization Options dialog box opens).

For more information, see Configuring the GoldSync Site Group Override Options.
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Configuring the GoldSync Site Group Override Options

Unless configured differently, each site group member synchronizes according to the settings entered for the
GoldSync Site Group. However, you can modify settings for a site in the GoldSync Override Options dialog box of
the GoldSync Site Group Member wizard.

The Overrides Options allows you to override the group settings for the current site. To configure special settings
for a particular site, check the necessary options on the Override Options screen. For example, if you are creating a
site where you want a number of retries before failing a sync session, at the Overrides Options window select the
Number of retries before failing the sync session option. The wizard will move you to the appropriate window in
which you can choose the number of retries needed.

To Navigate to the Override Options

1. Atthe GoldSync Administration window select a Site and click Properties.

GoldMine
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2. Click Yes at the message. The GoldSync Site Wizard opens.
3. Navigate through the wizard to the Overrides Options window and select from the list of options.

GoldSync Site Group Member Wizard: Overrides Options FZJ
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O General Settings
- Connection/transfer set password

- Logging Options
O Sending transfer sets settings
- Send changes to remote
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- Transfer set creation types

- The selected contact sets to send to remote
- Transfer set record type creation options

- Filter used for transfer set creation

O Retrieving transfer set settings
- Receive change from remote

- Default contact set to retrieve changes info
- The selected contact sets to retrieve from remote
- Transfer set record type retrieval options

O Intervals and synchronization frequency
- Successful synchronization session interval

- Failed synchronization session interval

- Active period of this site

- Number of retries before failing the sync session
Depending on the choices you make, the wizard will move you to the appropriate window on which you can
make the necessary selections.

Click Next and then select Finish to the GoldSync Administration Center.

Creating Site Groups

Use the Site Group Wizard to set up site groups (the first step in configuring GoldSync). Configuration options you
set for the group are inherited by each group member you add to the group. Using the Site Group Wizard, set the
connection method, synchronization method and intervals, and the method by which transfer set data
communicates between the remote site and the server and vice versa.

1.

2
3.
4
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Select Tools > Synchronize > GoldSync Administration. The GoldSync Administration Center appears.
Right-click on Site Groups and select New. The Welcome to the Site Group Wizard dialog box appears.
Type a descriptive name for the site group and click Next. The Synchronization Method dialog box appears.
Select either:

O In the Connected Methods (IP to IP/Network) area, select an option:

- Accept an incoming connection: The server accepts the initial request for data via modem, Internet
direct, or network.

- Initiate an outgoing connection at set intervals: The server transfers data at a specified time. The
interval is set by the user.

O In the Non-connected Methods (Internet: E-mail, Shared Directories) area, select an option. Data transfer
occurs without an active connection between the GoldSync Administration Center and the remote sites,
using an Internet e-mail account or shared directory to transfer information:

- Send and retrieve transfer sets via E-mail: The transfer set creates in advance and transfers by e-mail.
- Synchronize with another GoldSync server via shared directories: Uses defined paths to directories for
depositing and retrieving transfer sets.

Click Next. The General Options dialog box opens.
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Configuring the General Options (Site Groups)

In the General Options set the send and retrieve, password, and log information.

1. Select Send changed data to site group’s members to let GoldSync accept a request from a remote site to
create a transfer set.

2. Select Retrieve changed data from site group’s members to let GoldSync retrieve a transfer set from the
remote site.

3. Type an Optional connection password requiring remote users to enter a password when connecting to the
server.

4. Inthe Log Options area, select from:

O Log the details of each synchronization session. Records Process Monitor information in the GoldMine
system logs.

O Log the transfer set details for the records sent/retrieved. Records changes made to synchronized
records.

NOTE: If information is stored for every synchronization session, the log information storage file could grow
very large. Unless you are troubleshooting a sync issue, we recommend disabling log options.

5. Click Next.
O If you selected Accept an incoming remote connection and Send changed data, the Transfer Set Creation
Method dialog box opens. See Configuring the Transfer Set Creation Method.

O If you selected another synchronization methods, and selected Send changed data, the Send Options
dialog box opens. See Configuring Send Options.

O If you selected only Retrieve changed data, the Retrieve Options dialog box opens. See Configuring the
Retrieve Options.

Configuring the Transfer Set Creation Method

Use the Transfer Set Creation Method dialog box to determine if the transfer set is created while the remote site is
connected or to have the transfer set created in advance for the remote site to pick up.

1. Select an option:
O Generate transfer set while site group member waits online. When the remote sites initiate
synchronization, they wait online while the transfer set is built and sent to them.
O Generate transfer set in advance for site group member(s) to pick up. Your system generates the transfer
set in advance and stores it in a shared directory. When the remote sites initiate synchronization, they
stay online long enough for to send the transfer to them.

2. Click Next. The Send Options dialog box appears. See Configuring Send Options.

Configuring the Retrieve Options

The Retrieve Options determine what is considered for addition to the database when retrieving a transfer set
from another system.

If you select either Retrieve a transfer set from the second dialog box of the Synchronization Wizard or Retrieve
changed data from remote from the Connect/Send E-mail to Remote or Wait for an Incoming Connection dialog
boxes, GoldMine opens the Retrieve Options dialog box.
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1. Inthe Retrieve record types area, select the record types to retrieve from a remote site. By default, all record
types are selected (except when setting up goldsync).

NOTE: If you want to synchronize Users to remote users, select the Users option. You will also need to set
the Send Records Type for Users in the Configuring Send Options to allow both retrieving and sending of
data to the remote users.

NOTE: If you are a main site, clear many of the customization types unless retrieving from a remote site
responsible for GoldMine customization.

2. Inthe Retrieve users' calendar area, select one or more users whose calendar activities you want to retrieve.
To retrieve calendar activities for all users, select (all).

TIP: History items are treated as user calendar items, and are only synchronized between users
when user calendars are synchronized.

3. Click Next. The Retrieve Contact Sets dialog box opens (see To Configure the Retrieve Contact Set Options).

To Force the Override of Tlogs

The Force overwrite of values with missing t-logs option in the Retrieve record types area is used to force an
update for records that are included in a transfer set based on the RECID value. These are records for which the t-
logs have been purged as a result of routine maintenance. This option ignores any existing t-logs and forces the
record update.

NOTE: It is recommended that one computer be designated as the primary host; this option should be set

only at the computers connecting to the primary host, and not on the primary host.
IMPORTANT: This option can update recently entered data. For example, when a contact record that
does not have t-logs is modified at the remote. Normally, this change would update the central host.
However, if the cutoff date at the host has been back-dated to include the original contact record, the
host contact would be updated with the remote changes and the remote contact would be updated to

the original record.

To Configure the Retrieve Contact Set Options
Select which multiple contact sets to synchronize.
1. Inthe Please specify which contact sets you wish to retrieve from the remote site area, select the contact

sets to retrieve.
2. Inthe Default Contact Set area, select the Contact Set in the drop-down list. This is the Contact Set to
retrieve data into if there is no matching file code from the incoming transfer set.
3. Click Next. If you selected:
O Answer an incoming connection on the connection method dialog box, the Ready to Synchronize dialog
box opens.
O Connect to remote, the Connect/Send E-mail to Remote dialog box opens.

To Synchronize a Record After Purging T-logs

Suppose you are synchronizing a record after you purged t-logs. You don’t have enough information to do a field
level sync, you can only do a record level sync.

On the retrieving side you have two options:
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m Assume that the copy of the record you have is the same or newer than the one that comes with transfer set
and ignore the record from transfer set. This is the old and the default behavior.

m Assume that the copy of the record from transfer set is newer than yours and overwrite your copy with the
version from transfer set. This is what is done with “Force overwrite” option. The main use case is when you
are trying to bring an undocked computer to be in sync with the server. Your undocked computer might have
been out of service for a few months and you no longer have all t-logs.

Creating Servers

A GoldSync Server is any computer handling the synchronization processes. It can be any computer on the
network running a network copy of GoldMine.

For example, your main GoldMine Server might not have a modem. Rather than installing a modem, assign
another computer on the network that does have a modem as the GoldSync Server. Each GoldSync Server
assumes the computer name as the server name.

You can designate more than one computer on your network as a GoldSync Server. Have one server for
IP/Network synchronization and one for e-mail synchronization.

NOTE: The GoldSync Server computers must have proper resources for the processes they are running.

TIP: Because GoldSync is resource-intensive, we recommend dedicating a server to executing
GoldSync processes, especially when many users are synchronizing throughout the day. Creating
transfers for multiple users and managing multiple connections uses a significant amount of the
system's memory, processor, and hard disk capacity.

To Create a Server

1. Inthe GoldSync Administration Center, right-click on Servers and select New. The Welcome to the Server
Wizard dialog box appears.

Type or browse to the name of the server to make a GoldSync Server.
Click Next. The available processes dialog box appears.

Select the processes to assign to the server.

O IP to IP/Network: Accepts incoming remote connections

O IP to IP/Network: Initiates remote connections.

O E-mail: Scans for incoming transfer sets.

O E-mail: Sends outgoing transfer sets.

O Shared Paths: Creates/retrieves transfer sets created in advance.
Click Next. The Finish dialog box appears.

Click Finish and the Welcome to the Process

Cloning Site Settings

Cloning site setting to create site group members with the same or similar settings.

1. Inthe GoldSync Administration Center, highlight the site you are using a baseline, right-click and select Clone.
The New Site Group Member dialog box appears.
Select or create the new undocked user to whom you are assigning the cloned settings.
Click OK.
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The Welcome to the GoldSync Site Wizard dialog box opens. Wizard settings are based on the source site's
configuration. Keep the defaults or make necessary changes using the Override options.

To Use the Date/Time Stamp Conversion Utility

You might need to view date and time stamps in a regular date format. The utility converts the seven-character
SyncStamp, LogStamp, or the first seven digits of the RecID to a standard date and time format; or it converts a
standard date format to a stamp format.

TIP: Use this utility while troubleshooting synchronization issues to verify the date and time in
the Tlogs of unpacked transfer sets and compare the information to that in the database.

1. Select Tools > Synchronize > GoldSync Administration Center. The GoldSync Administration Center window
appears.

2. Right-click the Site Group and Server area and select Date/Time Stamp Conversion.
The Date/Time Stamp Conversion dialog box opens.

3. Inthe Conversion Method area, select one:
O Date and Time > Sync Stamp: Converts the date you select from the F2 Lookup calendar and the time from
the F2 Lookup graphical clock to a date stamp format.
O Sync Stamp > Date and Time: Converts a date stamp to a standard date and time format.
4. After selecting the date and time or typing the sync stamp, click Convert. The conversion displays in the
Results area with your initial input on the left and the conversion to the right of the arrow. The results box
displays multiple results so you can track the time stamps you are researching.

5. Click Cancel to close the dialog box.

Creating Server Processes

Use the Process Wizard to configure processes you are running on the GoldSync Server.

1. Inthe GoldSync Administration Center, right-click on the server name and select New from the local menu.
The New Process dialog box appears.
Select the Server and the Process Type from the drop-down lists.
Click OK. The Welcome to the Process Wizard dialog box appears.
The Welcome to the Process Wizard dialog box displays the Server Name and the Process Type you are
configuring. (If you are continuing from the Server Wizard, you start on this dialog box.)
5. The Process Name displays the process you are configuring. Click Next.
O If configuring IP to IP/Network or Shared Directories, the Number of Connections dialog box appears. See
Configuring the Number of Connections.
O If configuring E-mail: Scan for incoming transfer sets, the Incoming E-mail Settings dialog box opens. See
Configuring Incoming E-mail Settings.
O If configuring E-mail: Sends outgoing transfer sets, the Outgoing E-mail Settings dialog box appears. See
Configuring Outgoing E-mail Settings.

Configuring the Number of Connections

The Number of Connections dialog box appears when configuring IP/Network and Shared Directories processes.

1. Select the maximum number of concurrent connections. This option controls the number of remote users
who can connect at one time.
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NOTE: If you have the maximum number of concurrent connections set to 5, only 5 remote users can
connect at one time. The next user is refused a connection until there is an open slot. This option prevents
your server from running out of resources.

2. If necessary, type another port number in the Wait for incoming Internet connection at TCP port field.

3. Click Next. The Active Period dialog box appears.

Configuring Incoming E-mail Settings

In The Host name of the inbound (POP3) mail server field, type the name of the POP3 server.

2. Select The Frequency period to check for e-mailed transfer sets by clicking the browse button (...). The
Synchronization Frequency dialog box appears. Select the days, hours, or minutes.

3. Type the User Name and Password for the e-mail account retrieving the transfer sets.
Click Next. The Active Period dialog box opens. See Configuring the Active Periods for Synchronization.

Configuring Outgoing E-mail Settings

1. Type The Host name of the outbound (SMTP) mail server in the text box.
2. Type The return E-mail address for the outgoing transfer set.
3. Click Next. The Active Period dialog box opens. See Configuring the Active Periods for Synchronization.

Configuring the Active Periods for Synchronization

The Active Periods dialog box defines the days and hours the process is active.
1. Onthe Active Period dialog box, select Start this sync process automatically if the GoldSync Agent detects
the current time... to use the GoldSync Server Agent to the start the process automatically.
Select the active days.
Select the active beginning and ending time using the F2 Lookup clock.

Click Next. The Finish dialog box opens.

ik wNnN

If configuring an Accept incoming connection process, click Finish to complete the process construction. If
configuring an Initiate remote connection process, type a Site Code in the text box.

NOTE: Assign multiple site codes to a process, separated by a space. A site can be assigned only one site
code.

6. Click Finish. The process adds to the GoldSync Administration Center.

If you need to view date and time stamps in a regular date format, see To Use the Date/Time Stamp Conversion
Utility.

Synchronization Verification Codes

Verification codes are a security measure ensuring remote users do not change their synchronization profile
without the GoldSync administrator's knowledge. If the remote user receives a message that his or her Verification
Code is invalid, the GoldSync Administrator must generate another and send it to the remote user.

1. Inthe GoldSync Administration Center, select the site needing a new Verification Code and right-click. Select
Generate Verification Code. The Generate Verification Code dialog box appears.
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The Verification Code generates.
Copy the number and click OK to close.
Send the remote site the code.

The remote site types in the new verification code (the code remains valid until the remote user tries using
another profile).

Running GoldSync as a Service

When your GoldSync server is running on a computer with Windows 2012 Server, run GoldSync as a Service. A
service runs an application in the background.

Running GoldSync as a service provides added security by eliminating the need to log on to the computer to start
GoldSync. Saves administrative time by configuring the service restart whenever the operating system on the
computer starts.

Use the GoldSync Administration Center toolbar options for installing, starting and configuring, and uninstalling

Dy Kg
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the service. Also configure GoldSync as a service in the Synchronization Settings dialog box

To Run GoldSync as a Service

.
1. On the GoldSync Administration Center toolbar, click the Set up GoldSync as a service = putton.
2. Adialog box opens indicating the GoldSync Service was created successfully.

NOTE: After installing GoldSync as a service, but before starting the service, change the GoldSync Service
logon from Local System account to This account. In the Services management window, right-click
GoldSync Service and select Properties > Log On. Select This account and configure the logon information
using a Windows account with full access rights on the GoldSync computer and to the shared UNC locations
where your linked documents are stored. Please note that when using the GoldSync Service,
synchronization will NOT include linked documents referenced by mapped drive designations. If linked
documents were added using mapped drive paths, you can use the Linked Document Mover (Tools > Data
Management > Move Linked Docs and Attachments) to replace a mapped drive path with a UNC path
before synchronizing. Alternatively, you can use the Synchronization Wizard to synchronize linked
documents referenced by mapped drive designations.

Configuring GoldSync as a Service

You can access GoldSync Services configurations using either of the following methods:

<
m On the GoldSync Administration Center toolbar, click the Configure GoldSync Service =~ button.
The GoldSync Services Settings dialog box opens.

= Select Tools > Synchronize > Synchronization Settings. The Synchronization Settings dialog box opens. Click the
GoldSync Services tab and Configure GoldSync Service.

The GoldSync Services Settings dialog box opens.

GoldMine Administrator's Guide Page 323 of 439



GoldMine™®

NOTE: After installing GoldSync as a service, but before starting the service, change the GoldSync Service
logon from Local System account to This account. In the Services management window, right-click GoldSync
Service and select Properties > Log On. Select This account and configure logon information using a
Windows account with full access rights on the GoldSync computer and to the UNC locations where linked
documents are stored.

NOTE: To use this feature on Windows 10, Windows 8, Windows 7, or Windows 2012, you have to launch
GoldMine using the Run As Administrator option.

Important Consideration

GoldSync service does not see mapped drives. For example, if GoldMine was installed into the existing database
and you defined the server path as a mapped location (e.g. G:\Goldmine), then GoldSync service is started with
an error. GoldSync service will not find any linked documents or attachments written through mapped drives
(e.g. G:\Goldmine\picture. jpg). So, the files will not be synchronized with GoldSync service.

Use UNC path instead of mapped, or you can edit the gm.in1i file manually:

= Find ‘realini=" and ‘sysdir=" entries:
realini=G:\GoldMine
sysdir=G:\GoldMine

= Replace with your UNC path

realini=\\yourhost\GMPath
sysdir=\\yourhost\GMPath

To Configure GoldSync as a Service
1. Select the server running GoldSync in the Server drop-down list.
2. Click Start or Stop to start or stop the service.
3. Select Automatically start as a service whenever this computer boots up to start the service.
The Status box displays indicates whether the service is running.
4. Click OK to exit the dialog box.

To Uninstall GoldSync as a Service

X5
On the GoldSync Administration Center toolbar, click the Uninstall GoldSync service = button.

A dialog box appears indicating the GoldSync Service was successfully uninstalled.

Adding the Users Table as an Option for Sync

On the Server, open the Tools menu and select Synchronize > GoldSync Administration.

2. On the GoldSync Admin Center, right-click on the sync site and select Properties from the local menu (see
GoldSync Sites Local Menu).

The Site Group Wizard opens.
Click Next 3 times until you reach the Sync overrides screen.
Select Send undocked user's securities and password and then click Next.

Verify that the Undocked user's information and corresponding securities and password check boxes are
checked below in Send Options area.
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6. Finish the wizard.

Adding Macros to the GoldSync.ini File

In the Goldsync.in1 file, you can create and modify a section that contains a string of macros that run when
GoldMine is synchronized with Outlook. These macros are used to control the formatting of the activity Subject.

The default string is:
<<&user>>, <<&contact>>, <<&company>>, <<&phone>>, <<&emailaddress>>, <<&fulladdress>>
Below is an example of the string used in the Goldsync.ini file

[outTlooksync]
CalsubjectPattern= contact=<<&contact>>, user=<<&user>>,, <<&company>>, <<&phone>>,
<<&emailaddress>>, <<&fulladdress>>

NOTE: You can change the order or add you own words which will be stored and shown in the subject.

Regarding Multiple Contacts and Multiple Users

O If the activity has multiple contacts, the CalSubjectPattern is ignored and the text “multiple contacts” is
inserted in its place.

O If the activity has multiple users, the settings for the user is ignored and the text “multiple users” is inserted
in its place.

The following example demonstrates how the string of macros display in GoldMine:

= . Categories: Appointment (7 items

gj multiall [Regarding: Multiple users, Multiple contacts)

___’:_j multicontacts [Regarding: ALEX, Multiple contacts]

gﬂ multiusers [Regarding: user=Multiple users, contact=Primary cont, Super company national limited, 555-222-666-9897, P
__j additcontact [Regarding: user=ALEX, contact=AddContact, Super company national limited, 555-222-666-9897, PrimEm@&
_uf_ﬂ primecont [Regarding: user=ALEX, contact=Frimary cont, Super company national limited, 555-222-566-9897, PrimEm&5

User Macros

For the User, you can select from the following macros:

O <<&user>> O <<&userfullname>

Contact Macros

For a Contact, you can select from the following macros:

O <<&Addressl&2>> O <<&Phone>>
<<&CityStatezip >> O <<&FAX>>

O <<&FullAddress>> O <<&Contact,Company>>

O <<&Name&Address>> O <<&Company,Contact>>

O <<&Title&Address>> O <<&Contact>>

O <<&Company&Address>> O <<&Company>>
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O <<&Phones>> O <<&EMailAddress>>

About One-Button Synchronization

When enabled on the remote GoldMine system, one-button synchronization gives the undocked, remote user a
single-step synchronize process. Because the remote user cannot modify synchronization settings, the
organization increases data security and enhances control of information access for each synchronizing remote
system. One-button synchronization lets the GoldSync administrator:

= Create one-button synchronization profiles for each remote system running one-button synchronization. See
Creating One-Button Synchronization Profiles.

= E-mail the one-button synchronization profiles to remote, undocked users. See E-mailing One-Button
Synchronization Profile to Remote.

= Create an undocked installer to install GoldMine on the remote system with the one-button synchronization
profile (new GoldMine user). See Creating Installation Files for One-button Synchronization.

After created and sent, the remote user can:

= Retrieve the one-button synchronization profile. See Retrieving One-Button Synchronization Profiles.
= Retrieve the undocked installer file. See Retrieving One-Button Synchronization Installation Files.

= Synchronize using one-button synchronization. See Synchronizing Using One-Button Synchronization.

Synchronizing Using One-Button Synchronization

The GoldSync administrator configures one-button synchronization profiles and sends them to remote users. Once
installed, the profile streamlines the remote, undocked user synchronization process.

1. Select Tools > Synchronize > One-button sync with GoldSync Server. The One-button Synchronization dialog
box opens, indicating the GoldSync administrator has configured your system for One-button
Synchronization.

2. Click Sync. The Process Monitor opens, indicating synchronization status.

Creating One-Button Synchronization Profiles

Use the One-button Sync Profile Wizard option after creating site group members or from the GoldSync
Administration Center Sites local menu. One-button synchronization profiles include the Instant Sync option (see
Configuring Synchronization Settings) to remind undocked users to synchronize when it detects a network
connection.

To Create a One-Button Synchronization Profile
1. Inthe GoldSync Administration Center, highlight the site, right-click and select New One-button Sync Profile.
The Welcome to the GoldSync Site One-button Sync Profile Wizard dialog box appears.

Type the descriptive name of the profile in the text box. Click Next.
Enter the remote site’s E-mail address.

To restrict synchronization access to the One-button sync profile, check the Disable remote site’s access to
the ‘Synchronization Wizard’ option.
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10.

11.

12,

13.
14.

Click Next. The Connection Method dialog box opens.

Select a synchronization connection method:

O Connect to remote using IP to IP/Network method.

O Send a transfer set to remote by E-mail.

For more information, see Retrieving One-Button Synchronization Profiles.

Click Next. The Connect/Send E-mail to Remote dialog box opens.

O Check the desired send and retrieve options.

O Enter the Remote’s Internet IP address and port assignment or E-mail address

O Enter an optional password.

For more information, see To Configure Connect/Send E-mail to Remote (Connect to Remote) and To

Configure Connect/Send E-mail to Remote (Transfer Set by E-mail).

Click Next. The Send Options dialog box opens.

O Check the desired Send Record Types and Send user’s calendar options.

Click Next. The Send Contact-related Options dialog box opens.

O Specify the type of Contact Records to send to the remote site.

O Specify the Contact Sets to send to the remote site.

Click Next. The Send Filter Options dialog box opens.

O Select one of the Filters from the drop-down list.

O To you want to exclude filtered records previously stored in the last synchronization session with the
current transfer set for this remote site, check the Reset Auto-Territory Realignment feature option.

Click Next. The Cutoff Date/Time dialog box opens.

O If you want to ignore cutoff time, check the Ignore cutoff time (send all records) option.

O If you want to use a cutoff time, enter a cufoff date and time.

Click Next. The Retrieve Options dialog box opens.

O Check the desired Retrieve Record Types and Retrieve user’s calendar options.

Click Next. The Retrieve Contact Sets dialog box opens.

O Specify the type of Contact Set to retrieve from the remote site.

O Specify the default Contact Sets when the set is not specified.

Click Next. The Ready to Synchronize dialog box opens.

Check the desired Logging Options and then click Finish to save the profile settings.

To Configure Connect/Send E-mail to Remote (Connect to Remote)

Set connection options when selecting Connect to remote on the connection method dialog box.

1.
2.
3.
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Select Send changed data to remote to send changed data from this site to the remote.

Select Retrieve changed date from remote to retrieve changed date from the remote to this site.

In the Remote's Internet IP Address text box, type the Internet IP address you are connecting to. If creating a
one-button synchronization profile, the remote in this case is the GoldSync server the undocked computer is
synchronizing with.

Type the TCP Port. The default TCP Port is 5993. Typically, do not change this entry; if you override the
default port, you must select the same port as the remote system.

Click the IP button to add or edit alternative IP addresses.

Type the Optional connection password in the text box.

Click Next. If you selected Send changed data to remote, the Send Options dialog box appears.
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To Configure Connect/Send E-mail to Remote (Transfer Set by E-mail)
When selecting Send transfer set to remote by E-mail on the connection method dialog box, you can then send the
e-mail options.
1. Type the Remote's E-mail address in the text box.

2. Type the Optional connection password in the text box.
3. Click Next. The Send Options dialog box appears. See Configuring Send Options.

Retrieving One-Button Synchronization Profiles

When the GoldSync administrator creates or makes changes to your One-Button Synchronization Profile, they can
e-mail you the profile. One-button synchronization profiles include the One-button Sync option (see Configuring
Synchronization Settings) to remind undocked users to synchronize when it detects a network connection.

To Retrieve One-Button Synchronization Profiles in the GoldMine E-mail Center
1. Inthe GoldMine E-mail Center, double-click on the e-mail message with the subject line of One-button Sync

Profile.
A GoldMine message box appears, indicating the message has a sync profile attached. Click Yes.

The profile installs. The One-button Sync with GoldSync Server menu option becomes active. Use One-
button Sync with the GoldSync Server.

To Retrieve One-Button Synchronization Profiles From Another E-mail Client
If an undocked user is using another e-mail client (such as Outlook), the One-Button Synchronization Profile
appears as an attachment. The attachment can be saved to the hard drive and retrieved through the
Synchronization Settings dialog.
1. Save the One-Button Synchronization Profile attachment to your hard drive (for example: create a \Profile

directory in the \GoldM1ine directory).
2. In GoldMine, open the Tools menu and select Synchronize > Synchronization Settings.
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X

One-Button Syne | Linked Documents | Timeouts |

The option below allow GoldMine to check for a GoldSyne connection
s and prompts you ta synchronize. [F thiz option iz on, Goldiine will
S5 check for the connection every minute,

W Check for a GoldSync connection every minute

To update your One-button Sync settings specify the file path to the
One-button Sync Profile ransfer set below.

| .
Update |

(]9 I Cancel |

3. On the One-Button Sync tab, enter the location or browse to the location of the saved One-Button
Synchronization Profile transfer set file.

4. Click Update to retrieve the transfer set.

The sync profile includes the date and time of its creation. If an undocked user tries to retrieve an earlier profile
the following error message displays:

“A newer One-button Sync Profile has been found. To change your Profile settings contact the GoldSync
administrator.”

E-mailing One-Button Synchronization Profile to Remote
The GoldSync administrator can create or change a site's One-Button Synchronization Profile and e-mail it to the
remote user.

1. Inthe GoldSync Administration Center, highlight the site, and right-click. Select E-mail One-button Sync
Profile to Remote from the local menu.

2. A confirmation dialog box opens. Click Yes to e-mail the profile to the remote.

The profile is e-mailed to the e-mail address in the One-button Synchronization Profile.

Creating Installation Files for One-button Synchronization

With One-button Synchronization Profile, create an installation file containing fields and data for a new remote
user.

NOTE: To use this feature on Windows 10, Windows 8, Windows 7, or Windows 2012, you have to launch
GoldMine using the Run As Administrator option.

NOTE: Create a synchronization profile for the user before creating an installation file.
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1. Highlight the site in the GoldSync Administration Center and select Create Installation File for One-button
Synchronization.
The Create Undocked User(s') Installation Files dialog box opens.
2. Select the user or users for whom you are creating the installation files.
NOTE: Process up to five undocked sites simultaneously. If more than five sites must be processed,
GoldSync queues the additional sites until resources are available.
3. Click OK.
O If the gmsetup.exe is not in the default location, browse to the correct location. If you cannot locate the
.exe in the GoldMine directory, copy the file from the installation CD-ROM.

O If the gmsetup.exe file is in the default location of \GoldMine\Setup\GoldMine then the Process Monitor
displays the status of the creation process. GoldSync creates installation files and initial transfer sets
based on the profile settings.

NOTE: Creation of the initial transfer set can be time consuming. GoldSync ignores the cutoff date defined
in the user's synchronization profile for these tables and includes all records.The tables are: Fields,
ContUdef, Lookup, Users, InfoCenter, and Resources.

4. The installation file is placed in the GoldMine directory, \Goldmine\Setup\Remotes\.
5. As the GoldSync administrator, distribute the file to the remote site using these methods:
O Zip disk
O CD-ROM
O FTP
O E-mail via file attachment
6. The file must be retrieved on the remote computer.

It installs GoldMine based on the undocked user license for the site, copies the data, and installs the One-
button Synchronization Profile.

Retrieving One-Button Synchronization Installation Files

As a remote user, when you receive the Undocked Installer package, install GoldMine by running the installer,
named username.exe for the remote/undocked user.

The Undocked Installer package installs GoldMine using the undocked user license for your site, copies the data
and files selected by the GoldSync administrator, and sets up the configured synchronization profile.

1. Locate the file sent to you on a zip disk or CD-ROM, using FTP, or e-mailed as an attachment. The file is
named username.exe, where username is your GoldMine user name.

2. Open the file. It extracts the necessary files to the folder defined by the system’s Windows Temp variable,
usually c:\windows\Temp.

3. After files are extracted, the Undocked Installer installs GoldMine and imports the data.

Configuring Send Options

1. Use the Send Options dialog box to determine what data to include in the transfer set (a database of all
changes made to GoldMine contact records during a specified time frame that is sent to other GoldMine
locations and retrieved, updating that database with the new information).

2. Inthe Send Record Types area, specify record types to include in the transfer set.
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NOTE: Selecting a record type in the send options includes it in the transfer set; however, this does not
guarantee the data will be retrieved at the retrieving site.

TIP: If a User is added, deleted, or modified on the server, checking the Users option under
Customization will propagate these changes to a remote undocked site. This option is only
available for U and S Licenses. Also be sure that the remote users have retrieval rights by
checking the Users option in the Retrieve Options on the Synchronization Wizard for the remote
site (see Configuring the Retrieve Options).

3. Inthe Send users' calendar area, select one or more users whose calendar activities should be included in the
transfer set. To include the calendar activities of all users, select (all).

NOTE: For the user name(s) to be made available in the drop-down list of the remote's calendar, the user
names(s) must be synchronized with the Users database. Add user names in the Users Master File. History
items are treated as user calendar items, and are only synchronized between users when user calendars are
synchronized.

4. Select your Encryption level in the drop-down list. All transfer sets are encrypted at 128 or 32 bits.

5. Click Next. The Send Contact-related Options dialog box opens (see To Configure Send Contact-Related
Options).

To Configure Send Contact-Related Options

After configuring the Send Options (see Configuring Send Options), use the Send Contact-related Options dialog
box to evaluate records and send all new or changed contact records, send records based on whether they are
linked to the names in the Send Users' calendars area of the Send Options dialog box, or all filtered records and
records linked to selected users' activities.

1. Inthe upper drop-down list select one option:

O Only the current contact record: (Available only in the Synchronization Wizard - see About the
Synchronization Wizard). Includes all the data, without regard to a cutoff date, for the active Contact
Record only.

O All changed contact records: Includes all new or changed records since the cutoff date in the transfer set.

O Contact records linked to the 'Send user's calendar' list: Includes all new or changed records linked to the
users selected in the users' calendar send options and then evaluates those records for changes since the
cutoff date.

O All filtered records and user scheduled activity records: Includes records that meet your filter criteria and
those that do not fit the filter but have scheduled appointments linked to users selected in the Send
users' calendar list.

2. Inthe Please select contact sets you wish to send to the remote site area, select the Contact Set or sets to
include in the transfer set.

NOTE: When synchronizing multiple databases, they should have file codes. The database codes should be
same on the remote and on the main site.

3. Click Next. If you selected:
O Only the current contact record, the Retrieve Options dialog box appears.
O All changed contact records, Contact records linked to the 'Send user's calendar' list, or All filtered
records and user scheduled activity records, the Send Filter Options dialog box appears (see To
Configure the Send Filter Options).
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To Configure the Send Filter Options

Use the Send Filter to limit the number of records included in a transfer set the same way a filter limits the
number of Contact Records you are working with in GoldMine. The filter must already exist in the Filters and
Groups dialog box before you can apply it to the synchronization process.

1. Click the drop-down list to select All Contact Records or select records based on a filter owned by the user.

2. To select a different user, click <Filters of: username>. The Select a User dialog box appears. Select the user in
the drop-down list and click OK. Once a different user is selected, the user's filters and the public filters
display.

3. Select Reset Auto-Territory Realignment to send both records selected by your old filter and records selected
by your new filter. This enables GoldMine to hold old records for one last synchronization; then you can send
a deletion filter to remove unwanted records.

Click OK to return to the Send Filter dialog box.

Click Next. If you are:

O Using Synchronization Wizard, the Cutoff Date/Time dialog box appears (see GoldMine Record Selection
and User’s Calendars).

O Configuring GoldSync Site Groups, the Retrieve Options dialog box appears (see Configuring the Retrieve
Options).
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Server Agents

Use the Server Agents Administrator to process these operations on a recurring basis:

= Sending and retrieving e-mail from the Internet through GoldMine
m Synchronizing with GoldSync

= Synchronizing with Microsoft Outlook

= Printing and faxing correspondence

= Running Automated Processes

m Publishing Calendar information

IMPORTANT: Server Agents are configured around a user or user group, active time periods, and frequency.
They work with other configurable parts of GoldMine and must be started for the processes to work.

For information about Configuring Automated Processes in the Server Agents Administrator, refer to Automated
Processes.

For information about Configuring Calendar Publishing in the Server Agents Administrator, refer to "Calenders" in
the User Guide.
Server Agent Topics
m Starting the Server Agents
m Configuring the Sending and Retrieving of E-mail
m Configuring GoldSync
m Configuring Outlook Sync
m Configuring Printing and Faxing

Starting the Server Agents

Start the Server Agents for the settings you configured in the Server Agents Administrator to take effect.

1. Select Tools > Services > Start Server Agents.
2. The Process Monitor appears displaying information about the Server Agents running.
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[2] Automated Processes [11:14 am - 11/11,/2003)
[3] Sync Agent [11:14 am - 11/11,/2003]
1] GoldSync: Running...
< >

NOTE: To stop an agent, select the agent and then click the Stop Processes button.

Configuring the Sending and Retrieving of E-mail

Use the Server Agents Administrator to send queued e-mail and retrieved e-mail from the e-mail server on the
days and times specified.

1.
2.
3.

GoldMine Administrator's Guide

Select Tools > Services > Manage Server Agents. The Server Agents Administrator dialog box opens.
Click the Send/Retrieve E-mails tab.

If allowing only one user to send and retrieve e-mail using the Server Agent, select the user in the drop-down
list in the User's Settings area.

To allow other users to use the Server Agent capability, select Apply to other users to enable the Select Users
button.

Click Select Users to select one or more users or user groups.
In the Active Period area, select the days of the week the agent will be active.
Type or select the active time period for each day from the F2 graphical clock.

Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time
cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and
what activities can take place after regular business hours. In some cases, you need to select one scenario
over another. For example, you not want to send queued e-mail until after hours, but you do want to retrieve
e-mail throughout the day

In the Frequency area, type or select the number of day(s), hour(s), minute(s) GoldMine waits before
initiating the operation.

The minimum amount of time is 5 minutes.

Click OK.
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NOTE: You must start the Server Agents to begin processing (see Starting the Server Agents).

Configuring GoldSync

Use the Server Agents Administrator to process GoldSync sites on the days and times specified.

1. Select Tools > Services > Manage Server Agents. The Server Agents Administrator dialog box appears.
2. Click the GoldSync tab.

3. If allowing only one user to publish his or her calendar using the Server Agent, select the user in the drop-
down list in the User's Settings area.

4. To allow other users to use the Server Agent capability, select Apply to other users to enable the Select Users
button.

Click Select Users to select one or more users or user groups.
In the Active Period area, select the days of the week the agent will be active.

Type or select the active time period for each day using the right-facing arrows to access a list of times in
thirty minute increments.

Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time
cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and
what activities can take place after regular business hours. For example, GoldSync can draw upon many
network resources and configure GoldSync to run after regular business hours to keep other processes
running smoothly.

7. Click OK.

NOTE: You must start the Server Agents to begin processing (see Starting the Server Agents).

Configuring Outlook Sync

The Server Agents Administrator allows you to synchronize data between GoldMine and Outlook at the frequency

specified.

1. Select Tools > Services > Manage Server Agents. The Server Agents Administrator dialog box appears.

2. Click the Outlook Sync tab.

3. Inthe User's Settings area, select the user in the drop-down list.
This is the user whose Outlook account you are synchronizing to GoldMine.
In the Active Period area, select the days of the week the agent will be active.

5. Type or select the active time period for each day from the F2 graphical clock.

Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time
cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and
what activities can take place after regular business hours. For example, synchronize your Outlook with
GoldMine several times during the business day.
Select the Profile in the drop-down list.
In the Frequency area, type or select the number of day(s), hour(s), minute(s) GoldMine waits before
initiating the operation.
The minimum amount of time is 5 minutes.

8. Click OK.
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NOTE: You must start the Server Agents to begin processing (see Starting the Server Agents).

Configuring Printing and Faxing
Use the Server Agents Administrator to send queued print and fax jobs on the days and times specified.

1. Select Tools > Services > Manage Server Agents. The Server Agents Administrator dialog box appears.
2. Click the Print/Fax tab.

3. If allowing only one user to print or fax queued jobs using the Server Agent, select the user in the drop-down
list in the User's Settings area.

4. To allow other users to use the Server Agent capability, select Apply to other users to enable the Select Users
button. Click Select Users to select one or more users or user groups.

In the Active Period area, select the days of the week the agent will be active.
Type or select the active time period for each day from the F2 graphical clock.

Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time
cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and
what activities can take place after regular business hours. For example, printing large mailings during regular
business hours could make the printer unavailable to regular daily users. Printing large jobs before or after
business hours keeps the printer free.

7. Inthe Frequency area, type or select the number of day(s), hour(s), minute(s) GoldMine waits before
initiating the operation.

The minimum amount of time is 5 minutes.
8. Click OK.

NOTE: You must start the Server Agents to begin processing (see Starting the Server Agents).
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Reporting

GoldMine provides analysis reports for reviewing metrics. For example, you can calculate statistics based on
activities scheduled and completed by GoldMine users.

Select from over 200 standard GoldMine reports or design a custom report tailored to meet your organization's
needs.

NOTE: After installing Microsoft SQL Server Reporting Services and configured on the network, you must
add a section to the gm.ini file (typically located in Program Files/Goldmine/). This tells GoldMine where
the Reporting Services is hosted. For more information, see To Configure the GM.INI File For Reporting
Services.

About Reports

A report can include data from these database tables:

O Contactl. Main area of the Contact Record and the Summary and Notes tabs.
O Contact2. Fields tab and user-defined fields.

O ContSupp. Contacts, Details, Referrals, and Links.

O Cal. Calendar tab

O ContHist. History tab

O OpMgr. Opportunity Manager.

O Cases. Service Center

Special fields can include:

O Dialog. Prompts users to input data used within the report.

O Calculations. Calculates the total or performs other mathematical operations.

O Macros. Places multiple fields in the report. Macros are like those used within GoldMine/Microsoft Word
templates. For a list of available report Macros, see GoldMine Report Macros.

Select from the following topics to learn more about Reporting in GoldMine.

m About the Reports Center

m Report Types

m Using the Reports Center

m Setting Report Properties

m Creating Reports

m Cloning Reports

m Editing Report Layouts

m Previewing GoldMine Reports
m Printing Reports

m Saving Reports with Data

m Sorting Report Data

m Reporting Services Integration

m Configuring for E-Mail Delivery
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m Configuring the INI File

About the Reports Center

The Reports Center provides easy visual access to several reporting options available within GoldMine.

= Reports Center
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To access the Reports Center, select Go To > Reports > Reports Center or click the Reports button in the Global
Toolbar. The Reports Center appears and offers easy-management features:

O Report Center Toolbar
O A tree-view pane listing the selected user's reports (see Using the Reports Center)
O A description of the selected report
O A . jpg preview of the selected GoldMine Report (see Adding .JPG Previews to the Reports Center)

NOTE: System reports do not have . jpg previews.

Report Center Toolbar

User: |[public)

2 B | X

[& =

Y = B

| User: | [public)

are accessing in

the drop-down list.

Select the owner (public, user groups, or individual users) of the report you
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2 Launch the Report Properties dialog box to begin a new report (see Creating
Reports).
B Create a copy of the report (see Cloning Reports).

(recommended for creating new reports)

X Delete the report.
Launch the Report Properties dialog box, Profile tab (see Setting Report

Properties, Profile Tab).

=% Launch the Report Properties dialog box, Sorting tab (see Setting Report
Properties, Sort Tab).

Launch the Report Properties dialog box. Options tab (see Setting Report
Properties, Options Tab).

@

B Launch the report in the Layout mode (see Editing Report Layouts).

Open a report saved as . frcin a report preview window. Reports saved as

[3 .frc are reports with data rather than templates (see Saving Reports with
Data).

= Launch the Print Report dialog box to configure print settings (seePrinting
Reports).

Adding .JPG Previews to the Reports Center

Add your own . jpg previews to the Reports Center for reports you create.

1. Open the report with data.

2. Take a screen capture and save the file with the exact same file name as the user-created report but with a
. jpg extension.

3. Place a copy of the . jpg in the Reports folder where the matching . fp report is saved.

4. Inthe Reports Center, the report now has a . jpg preview in the lower right pane.

Report Types

GoldMine Reports

Generate reports from the data in your databases. Using the report generator, select data from your contact
database and then present the information in an easy-to-read format for printing or displaying on screen.
Approximately 200 reports are included when GoldMine is installed. Use GoldMine reports to generate reports
(see Using the Reports Center), clone reports (see Cloning Reports), edit reports (see Editing Report Layouts), and
create reports (see Creating Reports).
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The easy to run standard reports, which cover most aspects of the database, are organized in the following
categories and access only the listed tables:

= Contact Reports: Contactl, Contact2, ContHist, ContSupp, Cal, OpMgr, OpMgrFld.

= Calendar Printouts:Cal, Contactl, Contact2, ContHist, Cal, OpMgr, OpMgrFld.

= Service Reports: Users, Contactl, ContHist, ConstSupp, CASES, CaseAttachment, CaseContactsLink,

Caselnfolink, CaseTeamLink

= Analysis Reports: Contactl, Contact2, ContHist, Cal, OpMgr, OpMgrFld.

= Labels and Envelopes: Contactl, Contact2, ContHist, ContSupp, Cal, OpMgr, OpMgrFld.

= Other Reports: Users, Lookup, Filters, Reports, PerPhone, Forms, ScriptsW, OpMgr, OpMgrFld, Mailbox.

System Reports

The GoldMine Output to printer reports are available from the various GoldMine local menus. The System Reports
list is only available on the tree view when the selected user is (public).

Using the Reports Center

GoldMine’s report generator organizes data from your contact databases into a report and sends the report to an
on-screen display or a selected printer. Select from approximately 200 standard templates provided by GoldMine

to meet reporting and printing needs. For special reports, a developer can use GoldMine’s form designer to create
custom report templates.

1. Select Go To > Reports > Report Center. The Reports Center appears.
2. From the User drop-down list, select (public) to see the standard reports. Select a user if the user created a
custom report.
3. The Report Type tree contains the following report types:
O GoldMine Reports: GoldMine Reports.
O System Reports: GoldMine "Output to printer" reports available from GoldMine local menus.
Expand the report type to see a list of reports and sub-categories.
5. When you expand GoldMine Reports category, the following subcategories display:
O Contact Reports displays Contact Listing reports.
O Calendar Printouts displays Activity List reports.
O Service Reports displays Case and Service reports.
O Analysis Reports displays analytical reports.
O Labels and Envelopes displays templates that print data on special paper sizes.
O Other Reports displays six special report templates.
6. Select the report to generate.

NOTE: Depending on the selections made in the Reports Categories area, reports available in the Report
Description list vary. Access a local menu for each report. Highlight the report and right-click to view the
Reports Center local menu. (Also use the Reports Center toolbar.)

Within the Reports Center, you can work with reports using the following functions:

m Setting Report Properties

m Creating Reports
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= Cloning Reports

m Editing Report Layouts

m Previewing GoldMine Reports
m Printing Reports

m Viewing Saved Reports

Setting Report Properties

Use the Report Properties dialog box to specify description and file names, select sorting fields and levels, and set
data and date options. The Sorting and Options information can be altered before running or printing a report and
will change the information in the report based on changes made on these tabs.

ES
Click the Report Properties button 2 on the Reports Center toolbar for these tabs:
= Profile. Report's name, owner, notes, file name, and printer (see Setting Report Properties, Profile Tab).

= Sorting. Report's sort levels and fields (see Setting Report Properties, Sort Tab).

= Options. Report's data and date inclusion options (see Setting Report Properties, Options Tab).

Setting Report Properties, Profile Tab

Use the Report Properties Profile tab to display or configure report description, filename, and owner. The dialog
box appears when clicking Properties on the Reports Center toolbar or when selecting New from the Reports local
menu.

1. Atthe Report Center, select a report and click Report Properties on the Reports Center toolbar.

2. Atthe Reports Properties dialog box, click the Profile tab.
O Type (or edit) the name of the report in the Report description field.
O Select the owner of the report in the Owner drop-down list.
O Type in extra details about the report and variables in the Notes field.
O Type or select the name of the report file name in the Reports Filename field.

Reports store in the Reports folder of the main GoldMine directory. Report templates end with the
extension . fp; for example, MyReport. fp.

O Select a printer.
- Selected Printer. The printer designated in the Output to section of the Reports Menu.

- Layout Printer. The printer selected in GoldMine’s layout mode.

Setting Report Properties, Sort Tab

The Report Sorts tab of the Report Properties dialog box allows you to assign up to three sorting levels to a report.
For example, you can sort a report by Company, City, and finally Contact.

1. Atthe Report Center, select a report and click Report Properties on the Reports Center toolbar.

2. At the Reports Properties dialog box, click the Sort tab.

You can also select the Sort button % on the Report Center toolbar.

3. Select a sort level.
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O Primary Sort. This sort specifies the first set of parameters for ordering records.

NOTE: Every GoldMine report must have at least a Primary Sort defined to operate properly, even if no
sorting is required. To preclude sorting, set Sort Database to (none). If Primary Sort is defined as (none), the
Data Preparation browse window entry dims, indicating GoldMine sorts records by the natural order of
record entry.

To complete the sort definition, select the database Sort Database and Field Name GoldMine uses to
order records in the report. To specify a range of records, set a Start at and an End at value.

O Secondary Sort. This sort specifies a second set of parameters for ordering records.

To complete the sort definition, select the Sort Database and the Field Name by which GoldMine sorts
records. To specify a range of records, set a Start at and an End at value.

NOTE: Define a first-level sort before defining a second-level sort. For a report with only one sort level,
define the first level sort only.

O Tertiary Sort. Specifies the third set of parameters for ordering records. To complete the sort definition,
select the Sort Database and the Field Name by which GoldMine sorts records. To specify a range of
records, set a Start at and an End at value. Define a second level sort before defining a third level sort. For
a report with only two sort levels, define the first and second level sorts only.

4. Inthe Sort Database drop-down list, select the contact table containing the field on which the records are
sorted for the selected sort level (Primary, Secondary, or Tertiary). The selected database appears to the right
of the sort level.

5. Inthe Field Name drop-down list, select the field on which records sort for the selected sort level (Primary,
Secondary, or Tertiary). Available fields are determined by the table selected from the Sort Database list. The
selected field appears to the right of the sort level and the contact database name.

6. As needed, at the Start at field, type the beginning value of a range of ordered records.

If the Start at field and End at field are blank, (all) appears to the right of the sort level database and field, and
all records sort in ascending order.

7. Atthe End at field type the ending value of a range of ordered records.

NOTE: The Start/End range constraints are character-to-character comparisons. For example, if you
constrain your start and end range to Ivanti, the sort will return all contacts for Ivanti but none for lvanti
Software or Ivanti Software, Inc. Ivanti is within the start/end range, but lvanti<space> is outside the end
range. Also, searching for GoldMine would not return any results for Goldmine, because m is greater than
M and therefore outside the end range of the sort. Finally, note that the range criteria is limited to 20
characters, so Ivanti Software USA Inc. would not appear in any of the sort criteria described above, as it is
outside the character limit.

Setting Report Properties, Options Tab

The Options tab determines what type of information displays in the report, similar to a filter applied internally to
the report. Available options depend on the selected report category. Contacts, Analysis, and Labels and Envelopes
display one set of Options, while the Calendar displays another.

i
1. Atthe Report Center, select a report and click Report Properties on the Reports Center toolbar.
2. At the Reports Properties dialog box, click the Options tab.

-

You can also select the Options = button on the Report Center toolbar.
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In the History Data area, select the activity types to be included in the report and complete these fields:

O User. At the drop-down list, select (all) or select the individual user of the report.

O Date. Type or click the drop-down arrow and select the beginning date from the F2 Graphical Calendar. This
is the first date you want the report data to reflect.

O To. Type or click the drop-down arrow and select the end date from the F2 Graphical Calendar. This is the
last date you want the report data to reflect.

O Actv. Type the Activity Code assigned to the completed activities.

O Result. Type the Result Code assigned to the completed activities.This is a completion code to categorize
the outcome of activities.You can use result codes to analyze specific completed activities.

In the Calendar Data area, select the activity types to be included in the report and complete these fields:

O User. At the drop-down list, select (all) or select the individual user of the report.

O Date. Type or click the drop-down arrow and select the beginning date from the F2 Graphical Calendar. This
is the first date you want the report data to reflect.

O To. Type or click the drop-down arrow and select the end date from the F2 Graphical Calendar. This is the
last date you want the report data to reflect.

O Actv. Type the Activity Code assigned to the completed activities

In the Linked Data area, select the linked data to be included in the report. The selections are: Other

Contacts, Document Links, Details, Referrals, and Organizations.

Creating Reports

Reports can be create by either creating a report from a blank template or by cloning a report and then editing to
match your desired results.

NOTE: Creating a report from a blank template is not recommended for beginners. It is recommended that
beginners clone and then edit the report template to first become familiar with the process before
attempting to create a new report with a blank template. For more information, refer to Cloning Reports
and Editing Report Layouts.

To Create a New Report

1.

Select Go To > Reports > Report Center.

At the Reports Center click the New Report button ® or right-click inside the report name tree-view pane

and select New. The Report Properties dialog box opens.

When creating a report, click the Profile tab:

O Report Description: The name to display in the Report Center.

O Owner: Select the report owner in the drop-down list.

O Notes: Type extra details about the report and report variables.

O Report Filename: Type or select the file name of the report template. The reports store in the Reports
folder of the main GoldMine directory. Report templates should end with the extension . fp. For

example, MyReport. fp.

IMPORTANT: If you do not give the report a unique file name at this stage of the process, it does not save.
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O Default Printer: Select a printer:
O Selected Printer: The device designated in the Output to section of the Reports Menu
O Layout Printer: The special printer selected in GoldMine’s layout mode
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4. Click OK on the Profile tab to return to the Reports Center. The new report is now listed in the report list.

1—-
5. Highlight the new report and click the Layout button
opens.

M Blank Template

or right-click and select Layout. A blank template
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6. Use the Reports Layout Local Menu and Report Center Toolbar to format your GoldMine Report. For more

information, see Editing Report Layouts.

Reports Layout Local Menu

To access the local menu, right-click within the report editing window. The reports local menu has the following

options:

= Save: Save the report to the file name specified when the report was created or cloned, or save alterations to

an existing report.

= Edit: Edit items placed on the report including copying, pasting, text formatting, and editing expressions.
= Insert: Insert labels, sections, data fields, expressions, graphics, and pictures.

= Arrange: Alter the alignment and spacing of report items.

= Center: Position the selected field box in the center of the report page.

= Named Font: Add, edit, and delete a named font.

= Font Expression: Add, edit, delete, and rename a font expression.

= Grid Settings: Switch the Snap to Grid option on to position new items consistently. Edit the grid thickness for

smaller, finer grids.
m Printer Setup: Access the Printer Setup dialog box.

= Report Settings: Access a submenu with these options:

O Options: Alter margins, display or hide the ruler, and set the date format.

O Filter: Base the report on an embedded filter so, when run, it applies only to records matching the filter. An
alternative is to activate a filter in GoldMine and run a global report on just those records.
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= Dialog Fields Table: Create, edit, and delete report dialog fields (fields that can be inserted into a report for
user input).

Reports Layout Toolbars

The GoldMine Reports layout mode has four toolbars helping you design and edit reports. To edit Layout toolbar
options, right-click in the toolbar area and select the toolbars to display. Select Options to change how button
information displays, and select Insert items to add toolbar buttons. Also find toolbar options in the Layout local
menu.

Layout Toolbar

Use the Layout toolbar to perform basic functions, such as opening and closing report templates or switching to an
on-screen preview mode.

X EHR | BLF

= Open: Returns to the Report Menu.

= Close: Closes Reports.

= Save: Saves changes to the template.

= Preview: Previews the template with data from the database.
= Printer: Sends the report to the printer.

= Settings: Defines Report Parameters.

= Filter: Creates Record Selection Criteria.

Insert Toolbar

Use the Insert toolbar to insert fields, labels, and graphics, into the template.

i A=

"‘u“-

N

= Field: Inserts a field.

m Label: Inserts a text label.

= Section: Stars a new Section.

= Picture: Inserts a . bmp graphic file.

= Line: Inserts a line.

m Formula: Inserts a calculation formula.
= System: Inserts a system field.

= Dialog: Inserts a dialog field.

Style Toolbar
Use the Style toolbar to apply formatting effects.

ARG 2=

i
i

B & U

= Fonts: Selects a font.
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= Outline: Places a border around a field or section.

m Background: Selects a fill color for the background of a field or section.

= Position: Set the horizontal and vertical positioning for characters within a field or section.
m Left: Left justifies the text.

= Center: Centers the text within an object.

= Right: Right justifies the text.

= Bold: Makes selected characters bold.

m Italics: Makes selected characters italics.

= Underline: Underlines selected characters.

Align Toolbar

Use the Align toolbar to justify multiple selected items. To select the items to align, hold down the left mouse
button and drag the mouse over the items. A red-bordered box appears. Any item touched by the box is aligned.

2 E 3 Mk ko | E N0 =M

= Align Left: Aligns items to the left.

= Align Vert. Center: Aligns items vertically along a center point.

= Align Right: Aligns items to the right.

= Align Top: Aligns items to the top.

m Align Horiz. Center: Aligns items horizontally along a center point.
= Align Bottom: Aligns items along the bottom.

= Even Width: Makes items the same width.

= Even Height: Makes items the same height.

= Even Vert. Spacing: Aligns items with equal vertical spacing.

= Even Horiz. Spacing: Aligns items with equal horizontal spacing.

Cloning Reports

Identifying an existing report that is closest to meeting your needs and then cloning it is the most efficient way to
create new GoldMine reports. We recommend you clone existing reports before modifying them so you always
have a clean copy available for future edits.

1. Select Go To > Reports > Report Center. The Reports Center opens.

2. Select the user whose report you are cloning in the User drop-down list. Select (public) if the report is publicly
owned.

3. Select the report to clone and click the Clone Report button - or right-click the report name tree-view
pane and select Clone.
4. At the Report Properties dialog box, select the Profile tab and configure:
O Report Description: When cloning a report, the description defaults to Copy of <report name>. Type a new
and unique name for the report to replace the default.
O Owner: Select the report owner in the drop-down list.
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O Notes: Type extra details about the report and the report variables.
O Report Filename: Type a new, unique name for the report template. Reports store in the Reports folder of
the main GoldMine directory. Report templates should end with the extension . fp.

IMPORTANT: If you do not give the report a unique file name at this stage of the process, it does not save.

O Default Printer: Select a printer:
- Selected Printer: The device designated in the Output to section of the Reports Menu

- Layout Printer: The special printer selected in GoldMine’s layout mode.

5. Click OK on the Profile tab to return to the Reports Center. The new report is now listed in the report list.

6. Highlight the new report and click the Layout button or right-click and select Layout. The report layout
appears.

M plank Template
EXER BLT EHEMISI\ |3 AL S =SS B IU

e | | N A A o A | | S S R 1 |

Sort 1 Header

Detail 1 Section

Fih®dcs DETE By ZFiBLwm PE@ PAGE

£ >

7. Use the Reports Layout Local Menu and Report Center Toolbar to format your GoldMine Report.

Editing Report Layouts
The reports layout window displays a report's existing labels, fields, and sections for editing. Edit the report
parameters, pages, filters, and break fields. Within the report layout, add, remove, or change parts of the report.
NOTE: Before changing standard GoldMine reports, clone the report to preserve original settings.

1. To edit afield, label, or section, right-click on it and select Edit.
Available options depend on the type of item you are editing.
TIP: When editing, the default report layout displays XXXX instead of field names. To display the

field names and facilitate editing, right-click and select Edit > Show Field Names. The fields
names display in the layout window.

2. To quickly edit Reports, use the GoldMine Reports Shortcut Keys and the Layout local menu or the Layout
toolbar.

GoldMine Administrator's Guide Page 347 of 439



GoldMine™®

3. Customize the GoldMine Reports by:
O Cloning a Template (see Cloning Reports)
O Creating a New Template (see Creating Reports)
4. Refine the reports by:
O Editing Report Parameters (see Editing Report Parameters)
O Editing Report Pages
O Inserting Sections (see Inserting Sections in Reports)
O Inserting Fields (see Inserting Report Fields)
O Editing Fields(see Editing Report Fields)
These settings also determine the information and the order it displays in the report:

O Filters. Determines the information included in the report; apply filters on a global level or to a report
section (see About Report Filters)
O Break Fields. Manages the grouping of report information (see Report Break Fields)

Report Break Fields

Break fields manage the grouping of information, determining how multiple entry information such as Details,
Calendar, and History, displays in a report template. The break field ensures details or calendar entries group
together before moving to the next Contact Record.

NOTE: Break fields can only be used in Sort Headers.

Most reports use one of two main break fields to determine the format of the report, with other break fields
determining content.

= AccountNo: The unique number tying details relating to one Contact Record together. It appears in all of the
data holding tables and can be used from any of them. The choice of database is dependent upon the type of
information displayed in the report. If a mix of Contactl and ContSupp information displays, two AccountNo
fields that be used as break fields:

O Contactl->AccountNo: Groups together the information regarding the company, listing all the company’s
profiles together.

O ContSupp->AccountNo: ContSupp->AccountNo tries to center the information on the detail, attempting to
display the contact details every time and therefore not collate detail information together.

= UserID: The unique ID for users is generally used when displaying calendar information sorted by the user.
UserlID groups together all of a user's activities before moving to the next user. It is also the preferred break
field when reporting on history activity.

A report without break fields displays the assigned information for every Contact record whether that information
appears in sort headers, footers, or detail sections. Once break fields are implemented, each sort header with a
break field is dealt with one at a time, but detail sections always display. In this situation, include both filters and
break fields to stop non-relevant information from displaying under the sort header details.

The break field for Sort 1Header is nearly always set to Contact1->AccountNo or Cal->UserID depending on the
type of information in the report. Other break fields are used in the other sort headers, including macros. For
more information, see Editing Break Field in Reports.

Editing Report Parameters

Set report margins, rulers, date format, and print defaults with the report parameters.
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1. Right-click on the report template and select Report Settings > Options.
At the Report Parameters dialog box opens.
In the Margins area, type the Left, Right, Top, and Bottom margins in inches.
In the Ruler Selection area, determine if a ruler displays and whether it appears in inches or centimeters:
O Hide. No ruler displays on the template window.
O Inches. Each section displays a ruler calibrated in inches.
O Centimeters. Each section displays a ruler calibrated in centimeters.
4. In the Default Date Format area, select MM/DD/YY to display dates as month/day/year, or DD/MM/YY to
display day/month/year.
5. Select Print trial records when output to printer prior to running a report.
Use this option to run a test printing and adjust paper feed through the printer before sending the records.
6. Select Print report header before the page header to print report headers added before printing the page
header.
7. Click OK.

Inserting Sections in Reports

1. Right-click the report template and select Insert > Section.

The New Section window opens. The window displays sections available for inclusion. Detail and Sort sections
are numbered from 1 to 9 and are only available for inclusion in numeric order.

Select the section to insert in the Section Name area and then click OK.

Edit sections after inserting them. See Editing Report Sections.

Editing Report Sections

Click on the header, detail, or footer section. An editing box appears around the section.

2. Right-click and select Edit:
O Delete. Deletes the section.
O Outlines. Accesses the Line Properties dialog box. Select lines that outline the section, line size, and color.
O Background. Accesses the Item Background dialog box. Select the color and type of section background.
O Filter. Accesses the Section Selection Criteria dialog box. Create a filter to specify section contents.
O Show Field Names. Toggles the template display from XXXX to field names.
3. To edit using the Sort # Header or Detail # Section dialog boxes, double-click the section title. Select from:
O Compress Space Before the First Item. Compresses space between the beginning of the section and the
object at the top of the section.
O Compress Space After the Last Item. Removes space after the last object of the section to allow for large
word-wrapped fields.
O Advance Page Before Printing the Section. Advances to the next page before the beginning of the section.
O Advance Page After Printing the Section. Advances to the next page after printing the section.
O Reprint Titles on Every Page. Prints titles on every page (available for sort sections only).
O Number of Records Across the Page. Specifies the number of records that can be placed across the report
template. This option is useful for printing labels and is available for Detail Sections only.
O Filter. Accesses the Section Selection Criteria dialog box. Create a filter to specify section contents.
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O Outlines. Accesses the Line Properties dialog box. Select the lines that outline the section, line size, and
color.

O Break Field. Accesses the Break Field for Section dialog box. Edit a break field to manage the grouping of
multiple entries (available for Sort Header sections).

O Background. Accesses the Item Background dialog box. Select the color and type of section background.

Editing Break Field in Reports

Double-click the Sort Header section title. The Sort # Header dialog box appears.
Click Break Fields. The Break Field Section dialog box appears.

Click Data Field; the Select a Field dialog box appears. You can construct a simple break field. For example,
Contactl->AccountNo (see Report Break Fields) and can also use macros for break fields, for example,
&Sort2&Suppfile="csp" to define the break field for Sort 2 Header.

&Suppfile Chart:

TABLE CHARACTERS 1 AND CHARACTER 3
Where x =

a : appointment
c : call back

] t : next action
Calendar -- ca &suppfile="cax"
d : to-dos

m : E-mail

s : forecasted sale

o : other action

Where x =

c : additional contacts
] p : details
ContSupp -- ¢s &suppfile="csx"
r : referrals
| : linked documents

0 : organizational chart

Where x =
a : appointment
c:call

. t: next action

ContHist -- ch &suppfile="chx
d : to-dos

m : message
s : completed sale

o : other action
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NOTE: Generally, only data fields from the database file specified by the macro are used within that section
of the report.

Example of Break Fields in a Report:

Select the contact report Contact Profile (Detailed) and display the layout. By double-clicking each section
title in turn and clicking the Break Field button, it is possible to see the break field of each section.

Many of these sections cannot utilize a break field; others use the &suppfile macro.

O Page Header: No break field available.

O Sort 1 Header: Contactl and contact2 information. Break field: Contact1->AccountNo. This is the primary
break field—it groups together all information for one Contact record on a report before moving onto a
report for the next Contact record.

O Sort 2 Header: Labels and header information—no data fields. Break field: &sort2&suppfile="csc”. This
break field first groups together everything alphabetically according to the contents of the &sort2 field
and then groups together all additional contacts for the current Contact record.

O Sort 3 Header: Labels and header information—no data fields. Break field: &sort3&suppfile="csp”. This
break field first groups together everything alphabetically according to the contents of the &sort3 field
and then groups together all details for the current Contact record.

O Sort 4 Header: Labels and header information—no data fields. Break field: &sort4&suppfile="csr”. This
break field first groups together everything alphabetically according to the contents of the &sort4 field
even though this is not defined and then groups together all referrals for the current Contact record.

O Sort 5 Header: Labels and header information—no data fields. Break field: &sort5&suppfile="ca”. This
break field first groups together everything alphabetically according to the contents of the &sort5 field
even though this is not defined and then groups together all scheduled activities for the current Contact
record.

O Sort 6 Header: Labels and header information—no data fields. Break field: &sort6&suppfile="ch”. This
break field first groups together everything alphabetically according to the contents of the &sort6 field
even though this is not defined, and then groups together all completed activities for the current Contact
record.

O Sort 7 Header: Labels and header information—no data fields. Break field: &sort7&suppfile="csl”. This
break field first groups together everything alphabetically according to the contents of the &sort7 field
even though this is not defined and then groups together all linked documents for the current Contact
record.

O Detail 1-6 Section: No break fields available.

O Sort 1 Footer: No break field available.

O Page Footer: No break field available.

If break fields did not appear in the sort headers for multiple information sections, only the first piece of

information for that category would be included. Multiple instances of the same type of information such as

details would be omitted, as the report would move to the next section and/or Contact record.
4. Click Calculation Field and the Comp_XXX dialog box appears. A section break field can be a calculated field
that lets you generate complex sort breaks. The expression dialog box contains these options:

O System Field: Inserts a system field in the expression.

O Dialog Field: Inserts a dialog field in the expression.

O Data Field: Launches the Select a Field dialog box where you select a field or macro to insert in the
expression.

O Operator: Launches the Select an Operator dialog box where you select an operator such as <, >, =, .AND,,
etc.
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O Function: Launches the Select a Function dialog box. Select a predefined argument that return sa value of a
predefined type.

O Calc Field: Inserts a predefined calculation field in the expression.

Inserting Report Fields

Insert several types of fields into a GoldMine report. After inserting, edit the fields.

1. Right-click on the report template.
2. At the layout local menu, select Insert.
3. Insert the following field types as needed:
O Label. A text field to act as a field label.
O Section. A section in the report.
O Data Field. A macro field or a field from the database.
O Expression Field. A calculation field in the report.
O System Field. A predefined system field, such as a record count.
O Dialog Field. An interactive field in the report that requires a response from the user.
O Line. A line into the report.
O Picture from Clipboard. The .bmp that is in the clipboard.

O Picture from Disk File. A .bmp from a saved location.

Creating Dialog Fields for Reports

When a report launches, it can prompt the user for parameters to include in the report. For example, create a
dialog box to prompt the user for the first and last dates for a calendar report.

Before inserting Dialog Fields into a report, create them.
1. Right-click on the report template and select Dialog Fields Table > Create. The Create Dialog Field dialog box

appears.
2. Inthe Field Name text box, type a field name.

TIP: You cannot use spaces. To separate words, use the underscore (_).

3. Inthe Field Type area, select one:
O Text: Any alpha-numeric characters
O Numeric: Any numeric value
O Double: Any float value
O Logical: Logical True and False indicators; defaults are Y for true and N for false
O Date: Value must be in a date format (MM/DD/YY)

NOTE: After created, the field type cannot be modified.

4. OK.

5. The Field Name appears as a prompt on the Report Prompt dialog box. To make the prompt more user
friendly, right-click the report template and select Dialog Fields Table > Modify. The field name dialog box
appears.

6. Inthe User Prompt text box, type the text the user will see and respond to. For example, you may have a
Dialog Field name of Start_Date but you want the users to respond to the text "Type the starting date."

7. Inthe Prompt Order field, you can change the number to reflect the order multiple questions are asked in.
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8. Inthe Field Width text box, type the number of characters you want available in the dialog box.

9. After the Dialog Field is created, insert it in your report for the response to appear on your report (see To
Insert Dialog Fields in Reports .)

Editing Report Fields

Format fields inserted (see Editing Report Fields) into a report.

1. Click on the field. The editing box appears around the field.
2. Right-click the field and select Edit. Select an editing option:

O Cut: Cuts the selected field from the template.

O Copy: Copies the selected field to the clipboard.

O Paste: Places a copied field on the template where the cursor is located.

O Delete: Deletes the field.

O Position Text: Accesses the Text Position within Outlines dialog box. Position the text Horizontally and
Vertically within the field box (see To Set Text Position).

O Outlines: Accesses the Line Properties dialog box. Select the lines that outline the field box. Also select the
line size and color (see To Set Outline Properties).

O Background: Accesses the Item Background dialog box. Select the color and type of field background (see
To Set the Background).

O Default Item Font: Accesses the Font dialog box. Select font style, size, and color (see To Edit the Fonts in
Report Fields).

O Field Expression: The dialog box that appears varies, depending on the type of field you are editing:
- Data Fields (see To Insert Data Fields in Reports)
- Expression Fields (see To Insert Expression Fields in Reports)
- System Fields (see To Insert System Fields in Reports)
- Dialog Fields (see To Insert Dialog Fields in Reports )

O Show Field Names: Toggles the template display from XXXX to field names.

O Properties: Depending on the field type, one of these Field Properties dialog boxes appears:
- Basic Field Properties (see To Edit Field Properties in Reports)
- Date Field Properties (see To Edit Date Field Properties in Reports)

- Numeric Field Properties (see To Edit Numeric Field Properties in Reports)

Examples of Formatting Sections

The Contact Profile (Detailed) report example shows a report template divided into 17 sections, each one holding
different information. By default, the information displays as rows of Xs, plain text labels, and dates.

To display the field names instead of the Xs, right-click and select Edit > Show Field Names.

GoldMine Administrator's Guide Page 353 of 439



GoldMine™®

AMNarrsb EAddnes s LProres rcallabel:Keyl Hoyl
AMNarmelAddress EPmones rcallabel:Key? Hoy2
ANameLAddress EPhones scall abel:Keyd Koyl
ENampLAddress APhared scall abel:Keyl Hepd
ANarmedAddress seallabel:Keyh Feys

T AMarmeLAddoes s
AMameLAddress shellsardefll UVoardell]
EMameLAddress

bal:Userdefl? Usardeill
Label Userdelld Usardelld
Label UserdelDd Usardeild
Labal UserdelDS UserdeD5

Comments:  Comments
Prow Result Preveault
Mext Step:  Maxtsction

Last Contact: Lastcordon Lastcontat Label UserdelDE Usardell
Last Aflempt: Lastalmpon  Lastaimpa Label Userdel7 Userdeil?

Label UserdelDB UsardellB
Last Update: Lasidate Lastuser Label Userde)s Userdell

Creathon: ACCOUNTNG)

Labal Userdel10 Usardef1D

Sont & Headear

Sout J Header

Sont 4 Headar

Soet 5 Header

= Page Header. Company and Contact Name fields from the Contactl database. Also displays a line dividing the

header from following sections.

= Sort 1 Header. Contact name, address details, and telephone numbers as macros. It also displays the five key
fields and the first 10 user-defined fields along with the local label names. The final information shown is that

drawn from the Summary tab.

= Sort 2 Header. Title bar information for displaying additional contacts within the report. If additional contacts

exist, this section defines where they are displayed.
= Sort 3 Header. Sort 2 Header, but displays Details.
= Sort 4 Header. Sort 2 Header, but displays Referrals.
= Sort 5 Header. Sort 2 Header, but displays Pending Activities.
= Sort 6 Header. Sort 2 Header, but displays History Activities.
= Sort 7 Header. Sort 2 Header, but displays Linked Documents.
= Detail 1 Section. Information defined in Sort 2 Header listing all additional contacts.
= Detail 2 Section. Information defined in Sort 3 Header listing all profiles.

= Detail 3 Section. Information defined in Sort 4 Header listing all referrals.

= Detail 4 Section. Information defined in Sort 5 Header listing all pending calendar activities.

= Detail 5 Section. Information defined in Sort 6 Header listing completed history activities.
= Sort 5 Header. Sort 2 Header, but displays Pending Activities.

= Sort 6 Header. Sort 2 Header, but displays History Activities.

= Sort 7 Header. Sort 2 Header, but displays Linked Documents.

= Detail 1 Section. Information defined in Sort 2 Header listing all additional contacts.
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= Detail 2 Section. Information defined in Sort 3 Header listing all profiles.

= Detail 3 Section. Information defined in Sort 4 Header listing all referrals.

= Detail 4 Section. Information defined in Sort 5 Header listing all pending calendar activities.
= Detail 5 Section. Information defined in Sort 6 Header listing completed history activities.

= Detail 6 Section. Information defined in Sort 7 Header listing all linked documents.

= Sort 1 Footer. Section for notes from the Notes tab. With no criteria for determining whether notes exist, this
section prints in every report.

= Page Footer. System information such as the date the report was printed, by which user, and the page number.

When running this report, the page header and footer and Sort 1 Header and Footer have no filter and therefore
always display. The other sections use filters. If the data for the section exists, the section displays in the report.

Title bars for the optional sections display in sort headers while the actual information displays in detail sections.

Modifying the Appearance of Report Fields

m To Set Text Position (see page 355)

m To Set Outline Properties (see page 355)

m To Set the Background (see page 356)

m To Edit the Fonts in Report Fields (see page 357)

To Set Text Position
1. Click on the field in the template. The editing box appears around the field.

Text Position within Outli... [X]

Horizontal Yeitical

* Left * Top

" Center " Center

" Right " Boltom
[ Ok | Cancel

Right-click the field and select Edit > Text Position. The Text Position within Outlines dialog box appears.
In the Horizontal area, select Left, Center, or Right placement of the data within the field.
In the Vertical area, select the Top, Center, or Right placement of the data within the field.

ik wNwN

Click OK to save and close the dialog box

To Set Outline Properties

1. Inthe Draw on Sides area, select the sides the lines should appear.
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Draw on Sides Lirve Style

I b uiklie Liree ‘wfidth:
r (10 mim)

[ Inwvisible |

oK | cance |

In the Line Style area, select the style of outline to appear around the item.

The choices in the Label area vary depending on the kind of field you are outlining. Invisible masks the item
on the report.

Type the Line Width in millimeters.

5. Click Line Color to select an outline color. The effectiveness of choosing color over greyscale depends upon
whether you are printing on a color printer.

6. Click OK.

To Set the Background

1. Select a field on the report template. The editing box appears around the field.

ltem Background ﬁ|

[v Paint ltem Background

Paintbrush Color |

Paintbiuzh Type

* Solid Brush

" Horizontal Hatch Brush

" “ertical Hatch Brush

" Cross Hatch Brush

" Diagonal Cross Hatch Brush

" Forward Diagonal Hatch Brush
" Backward Diagonal Hatch Brush

1] Cancel
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Right-click and select Edit > Background. The Item Background dialog box appears.

To add a background, select Paint Item Background and select Paintbrush Color. The Color dialog box
appears. Select the color and click OK. You return to the Item Background dialog box.

Select Paintbrush Type and one option.
5. Click OK.

To Edit the Fonts in Report Fields

The default font for Reports is Arial or MS Sans Serif. Change to font on the fields on the report to better suite
your publication.

6. Click once on the field to edit. The editing box appears around the field.

Font @EJ

Farit: Fant style:
|Hegular oK I
Avial Black Cancel
() Arial Narow
T Asial Unicode M5 Bold Italic 14
Hr Batang 16
() Book Antiqua 18
() Bookman Old Style % 20 b
Effects Sample
[ Shikeout
™ Undetine AaBbYylz
Color:;
I B lack »| | Secipt
|Wesle:n ﬂ
Thiz iz an OpenT ppe font. This same font will be uzed on both your
printer and your screen.

Right-click and select Edit > Default Item Font. The Font dialog box appears.
In the Font list, select a typefaces from those installed on your computer.
Select a Font style: Regular, /talic, Bold, or Bold Italic.

10. Select the font point Size.

11. In the Effects area, select Strikeout to strike out the characters in the field.

12. Underline characters in the field.

13. Select the Color in the drop-down list.

14. Select the Script in the drop-down list.

NOTE: Selections you make on the Fonts dialog box are previewed in the Sample area, above the Script
option.

Fields in Reports

m To Insert Data Fields in Reports (see page 358)
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m To Insert Expression Fields in Reports (see page 358)

m To Insert System Fields in Reports (see page 359)

m To Insert Dialog Fields in Reports (see page 359)

To Insert Data Fields in Reports

1.
2.

Right-click on the report template and select Insert > Data Field. The Select a Field dialog box appears.

From the Database Name drop-down list, select one:

O Macros: Composite fields similar to those used when setting up a GoldMine/Word template. These fields
include blank line suppression.

O Contactl: A list of available fields from the Contactl database showing fields from the primary contact area
of GoldMine.

O Contact2: A list of available fields from the Contact2 database including information from the Summary tab
and all user-defined fields.

O ContHist: Information available from the ContHist table containing details shown on the History tab of a
Contact Record.

O ContSupp: Information available from the ContSupp table holding the contents of the Contacts, Details,
Referrals, and Links tabs.

O Cal: Information available from the Cal table containing the calendar details shown on the Pending tab.

O OpMgr: Fields available from the Opportunity Manager database OpMagr.

O OpMgrFld: Additional fields available from the Opportunity Manager database applicable to New
Opportunity templates.

After selecting a table, select the field from the Field Name drop-down list. Fields available in the Field Name

list are determined by the selected Database Name.

Click OK. The field appears as a movable box in the report template. Use the mouse to drag the box to the

desired location and left-click to place it.

Double-click the field to edit Field Properties (see To Edit Field Properties in Reports).

To Insert Expression Fields in Reports

GoldMine Administrator's Guide

Use expression fields to insert calculations in reports. Expressions can perform mathematical functions or derive
statistical information from numeric fields, such as averages, percentages, or the number of days between two
dates. Calculation fields are usually found in analysis and calendar reports, but they can be added to any type of
report.

1. Right-click a report template and select Insert > Expression Field. The Enter Field Name dialog box appears.
Type a descriptive name for the field. Do not use spaces.

Click OK. The CALC->FieldName expression dialog box appears.

> W N

In the Expression text box, type the calculation expression, including the tables you are drawing from. For
example, Contact2->Usum1+Contact2->Usum2 adds the sum of Usum1 and Usum?2 to the report.

Use the buttons to add expression elements:

O System Field: Inserts a system field in the expression.

O Dialog Field: Inserts a dialog field in the expression.

O Data Field: Launches the Select a Field dialog box to select a field or macro to insert in the expression.

O Operator: Launches the Select an Operator dialog box to select an operator such as <, >, =, .AND., etc.

O Function: Launches the Select a Function dialog box. Select a predefined arguments that returns a
predefined type value.
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O Calc Field: Inserts a predefined calculation field in the expression.
5. Click OK.

To Insert System Fields in Reports

1. Right-click the report template and select Insert > System Field. The System Field Selection dialog box
appears.

Select the field to insert.

Click OK. The field appears as a movable box in the report template. Drag the box to the desired location and
left-click to place it. System Fields are usually placed in the report Header or Footer.

To Insert Dialog Fields in Reports
NOTE: You must create dialog fields (see Creating Dialog Fields for Reports) before inserting them into your
report.
1. Right-click the report template and select Insert > Dialog Field. The Select Dialog Field dialog box appears.
2. Select the field to insert.

3. Click OK. The field appears as a movable box in the report template. Use the mouse to drag the box to the
desired location and left-click to place it.

4. Double-click the field box to change the parameters. For instance, change the True and False indicators on a
Logical dialog box.

Working with Field Properties in Reports

m To Edit Field Properties in Reports (see page 359)
m To Edit Date Field Properties in Reports (see page 360)
m To Edit Numeric Field Properties in Reports (see page 362)

To Edit Field Properties in Reports

This dialog box shows settings for a basic data field. Separate dialog boxes exist for date fields and numeric fields.
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[Field: @Phones]

Wiap Text Position
[ Mirap Text Harizantal YVertical
v “wiord Wiap Test & Left » i
[~ Wariable Mumber of Lines £ Center * Center
[ Triim Extra Spaces " Right " Bottam
Capitalizati

apitalization Qutine
[ Capitalize
[ Capitalize First Letter Background
[ Print in Lower Case Fort

ok | Cancel

Double-click the field in the report template. The Field Properties dialog box appears with the field name in
the title bar.

In the Wrap area, select:

O Wrap Text: Wraps text from one line to the next within the designated field box.

O Word Wrap Text: Wraps text from one line to the next without breaking words.

O Variable Number of Lines: Lets data display outside the field box.

NOTE: Without this option selected, information in a long field displays in one continuous line, with the
information disappearing outside the report boundaries.

O N o w

O Trim Extra Spaces: Removes extra spaces in the field.

In the Text Position area, select the Horizontal and Vertical placement of the text within the field box.
In the Capitalization area, select:

O Capitalize: Capitalizes data in the field, no matter how it is entered in the database.

O Capitalize First Letter: Capitalizes the first letter of each word.

O Print in Lower Case: Prints words in lowercase.

Click Outline to configure the outline of fields in the Line Properties dialog box.
Click Background to create a background color and type within the label box.
Click Font to select the font for the field.

Click OK to save the settings and close the dialog box.

To Edit Date Field Properties in Reports

This dialog box covers the basic settings for a date field. There are separate dialog boxes for basic data fields and
numeric fields.
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[Field: Contact1-=Lastdate]

[rate Format Test Pozition

£ mm dd yy Horizontal Yertical

£ dd mm yy (* |eft " Top
: " Center (* Center
¥ " Right " Bottom

Drate D elimiter: |a’_
[ Suppress Zero Date

Footer Fields m
Summanization Tupe: M

L Font

ok | LCancel

o vk wN

10.
11.
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Double-click the field in the report template. The Field Properties dialog box appears with the field name in
the title bar.

In the Date Format area, select the month, date, and year format to apply to the field.

Select the Date Delimiter character that separates month, date, and year. The default is /.

Select Suppress Zero Date to display nothing if there are only zeroes in the dates.

In the Text Position area, select the Horizontal and Vertical placement of the date within the field space.

In the Footer Fields area, click Summarization Type: Value to specify the summarized values you are using in

the footer field. This option is available only if you are working in a footer. The footer can include any of these

types:

O Value: Field value.

O Total: Cumulative field value of all records in the section.

O Average: Cumulative field value of all records in the section divided by the number of records in the
section.

O Count: Generates the total number of records in a section

O Max: Computes the maximum value of all records in a section.

O Min: Computes the minimum value of all records in a section.

Select Retain Value After Printing to print running totals instead of clearing the internal accumulator after

printing. This option applies only to numeric fields or float fields used in a footer.

Click Outline to set the Line Properties around the field box.

Click Background to set the color and background type in the field box.

Click Font to change the font used in the field.

Click OK to save and close.
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To Edit Numeric Field Properties in Reports

This dialog box shows basic settings for a numeric field. Separate dialog boxes exist for basic data fields and date

fields.
[Field; Contact2-=Unumber]
MNurnesic Format T et Poszition
Megative Sign Prefix I_ Horizontal Vettical
—— g " Left " Top
Megative Sign Sulfis:
I_ " Center {* Center

Pozitive Sign Prefis; {* Right i Bottom

Pozitive Sign S ulfis;
Footer Fields

# of Decimal Places; |0 Sumrarization Type:

Cumrency Symbaol I_ r

[ uatly

[ Suppress Zemno Yalues w
[ Pad with Zeroes Background

[v Use Comma Format Fork

ok, | Cancel

1. Double-click on the field in the report template. The Field Properties dialog box appears with the field name
in the title bar.
2. Inthe Numeric Format area, type the Negative Sign Prefix (defaults to -).
3. Type a Negative Sign Suffix as needed.
NOTE: If using just a negative sign (-) to indicate a negative value, you do not need to type any value in the
suffix box. To use parentheses around a value to indicate a negative amount, type the left parentheses “(“
in the prefix box and the right parentheses “)” in the suffix box.
4. Type a Positive Sign Prefix and a Positive Sign Suffix as needed.
5. Type the # of Decimal Places. This number specifies the number of digits that can be entered to the right of
the decimal point.
6. Type the Currency Symbol to be used, such as $, £, or ¥.
7. Select Suppress Zero Values to not print a value in the field if the value is zero.
8. Select Pad with Zeroes to pad decimal values with trailing zeroes.
9. Select Use Comma Format to separate thousands with commas. For example, 12345 appears as 12,345.
10. In the Text Position area, select the Horizontal and Vertical placement of the data within the field box.

11. In the Footer Fields area, click Summarization Type: Total to specify the summarized values you are using in
the footer field. This option is available only if you are working in a footer. The footer can include these types:
O Value: The field value.
O Total: The cumulative field value of records in the section.
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12.
13.

14.
15.
16.
17.

O Average: The cumulative field value of records in the section divided by the number of records in the
section.

O Count: The total number of records in a section.

O Max: The computed maximum value of records in a section.

Min: The computed minimum value of records in a section.

Select Retain Value After Printing to print running totals instead of clearing the internal accumulator after
printing. This option applies to numeric fields or float fields used in a footer.

Click Outline to set the Line Properties around the field box.
Click Background to set the color and type of background in the field box.
Click Font to change the font used in the field.

Click OK to save and close.

About Report Filters

Report filters determine what information to include when the report is run. Report filters are composed with the
same notation as other filters in GoldMine.

There are three ways filters can be applied to reports:

= Active GoldMine filters or groups (see Activating and Releasing Filters and Groups in the GoldMine User's

Guide)

= Global Report filters (see Editing Global Report Filters)

= Section filters (see Editing Section Filters in Reports)

GoldMine filters and Global filters to determine which Contact Records are included in a report. Section filters
specify what information is in the section the filter applies to. Different sections of reports can have different
filters, including macro filters.

Editing Global Report Filters

Use global report filters to include only Contact records me eting filter criteria.

NOTE: GoldMine Reports are not optimized for SQL Server and may cause slow performance.

1.
2.

Right-click the template and select Report Settings > Filters. The Record Selection Criteria dialog box appears.

In the Expression text box, type the filter expression to build, including the tables you are drawing from. For
example, Contactl->State="CQ" include records where the state is Colorado.

NOTE: For a Global Report filter like the one above, it is more efficient to create and activate a GoldMine
filter or group than use it as a global filter.

3.
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Construct your filter with these options:

O System Field: Inserts a system field in the expression.

O Dialog Field: Inserts a dialog field in the expression.

O Data Field: Launches the Select a Field dialog box to select a field or macro to insert in the expression.

O Operator: Launches the Select an Operator dialog box to select an operator such as <, >, =, .AND., etc.

O Function: Launches the Select a Function dialog box. Select a predefined arguments that returns a
predefined type value.

O Calc Field: Inserts a predefined calculation field in the expression.
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4. Click OK to save the filter and close the dialog box.

Editing Section Filters in Reports

Section Filters limit information displaying in the report sections. Each section can have its own filter.

1. Click the section header you are editing. The editing box appears around the section.

2. Right-click and select Edit > Filters. The Section Selection Criteria dialog box appears.

3. Inthe Expression text box, type the filter expression, including the tables from which you are drawing. For
example, Contsupp->Rectype="R" displays only the records with referrals in the section.

4. Use these buttons to construct your filter:
O System Field: Inserts a system field in the expression.
O Dialog Field: Inserts a dialog field in the filter.
O Data Field: Launches the Select a Field dialog box to select a field or macro to insert in the expression.
O Operator: Launches the Select an Operator dialog box to select an operator such as <, >, =, .AND., etc.
O Function: Launches the Select a Function dialog box. Select a predefined argument that returns a

predefined type value.

O Calc Field: Inserts a predefined calculation field.

5. Click OK to save the filter and close the dialog box.

Editing Macros in Filters

To edit a Section Filter with a macro, click in the section. The editing box appears around the section.
Right-click in the section and select Edit > Filters. The Section Selection Criteria dialog box appears.
Edit the filter in the Expression box or click Data Field to access the Select a Field dialog box.

P W NR

Select Macros from the Database Name drop-down list. Two types of macros are available:

O &Sort: &sortl, &sort2, and &sort3 hold the primary, secondary, and tertiary sorts that can be specified for
the report. Click the Sorts button in the Report Menu dialog box. These macros let the data within a
generic report be sorted by a user when selecting the report. Contact records are included in a report if
they contain specified report sort order criteria. These three special macros become more useful when
used as Break Fields.

O &suppfile: When used within section or report filters, this macro determines which area of the GoldMine
database to report on. For example, if the section deals with Referrals, this filter can be added:
&suppfile="csc". The first two letters reference the table; the second two reference the Rectype.

NOTE: The &suppfile macro cannot be selected from a list of variables and must be typed manually.
Responses for &suppfile must be a minimum of two letters and a maximum of three. See the &Suppfile
Chart.

Example of Macro Filters in a Report

Example of Macro Filters in a Report

Select the Contact Report Contact Profile (Detailed) and display the layout. By selecting each of the
report sections in turn, right-clicking, and selecting Edit > Filter, you see whether each section is filtered.

Many sections use the &suppfile macro. Each section:
- Page Header: No filter— this information displays in every report.

- Sort 1 Header: No filter—this information displays in every report.
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- Sort 2 Header: Title bar for additional contacts section. Filter: &suppfile="csc". This section displays if
additional contacts exist on the record.

- Sort 3 Header: Title bar for profiles section. Filter: &suppfile="csp". This section displays if details exist
on the record.

- Sort 4 Header: Title bar for referrals section. Filter: &suppfile="csr". Displays if referrals exist on the
record.

- Sort 5 Header: Title bar for pending activities section. Filter: &suppfile="ca". Displays if pending
activities of any type exist on the record.

- Sort 6 Header: Title bar for history activities section. Filter: &suppfile="ch". Displays if historical
activities of any type exist on the record.

- Sort 7 Header: Title bar for linked documents section. Filter: &suppfile="csl". Displays if documents
have been linked to the record.

- Detail 1 Section: Detail section for additional contacts. Filter: &suppfile="csc". Displays if additional
contacts exist on the record.

- Detail 2 Section: Detail section for details. Filter: &suppfile="csp". Displays if details exist on the record.

- Detail 3 Section: Detail section for referrals. Filter: &suppfile="csr". Displays if referrals exist on the
record.

- Detail 4 Section: Detail section for pending activities. Filter: &suppfile="ca”. Displays if pending activities
of any type exist on the record.

- Detail 5 Section: Detail section for history activities. Filter: &suppfile="ch”. Displays if historical activities
of any type exist on the record.
III

- Detail 6 Section: Detail section for linked documents. Filter: &suppfile="cs
linked to the record.

. Displays if documents are

- Sort 1 Footer: No filter—this information displays in every report.

- Page Footer: No filter—this information displays in every report.

If filters are not added to the Detail sections, information displaying there displays under every sort
header. Detail sections 1 through 6 display under each sort header (2 through 7) but are only shown
when filter criteria are met.

Adding a third letter to the &suppfile macro in the pending and history activity section filters narrows the
information included to only the type of activity specified.

5. Click OK to save and close the dialog box.

&Suppfile Chart
TABLE CHARACTERS 1 AND 2 CHARACTER 3
Calendar -- ca &suppfile="cax" Where x =
a : appointment
c : call back
t : next action
d: to-dos

m : E-mail
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s : forecasted sale

o : other action

ContSupp -- cs &suppfile="csx" Where x =
c : additional contacts
p : details
r : referrals
| : linked documents

o0 : organizational chart

ContHist -- ch &suppfile="chx" Where x =
a : appointment
c:call
t : next action
d : to-dos
m : message
s : completed sale

o : other action

Previewing GoldMine Reports

Previewing a GoldMine Report to check report results before printing or to view information without printing the
entire report.

1. Use one of these methods:

O In the Reports Center, configure the Report Properties to return the desired results and click the Print
button on Reports Center toolbar.The Print Report dialog box opens.

Configure the dialog box and select Print Report Output to Window. The Preview window appears with
the data in the report.

[&
O When working in the GoldMine Report layout, click the Preview button on the toolbar. The Preview
window appears with data in the report.

2. To print the report, right-click and select Print. The Print Pages dialog box appears. Type the first and last
pages to print and click OK.

3. To save a report with the previewed data, click Save -

GoldMine Administrator's Guide Page 366 of 439



GoldMine™®

Printing Reports

Select and print an existing report by one of the following ways:

= Selecting File > Print a Report. The Print Report dialog box appears.

= Selecting Go To > Reports > Report Center. The Reports Center dialog box appears. Select the report to print

and click Print on the Reports Center toolbar. The Print Report dialog box appears.

= From the Calendar, click Print on the Calendar toolbar. The Print Report dialog appears.

1.
2.

In the Print Report dialog box, select the report Type in the drop-down list. Select GoldMine.

In the Category drop-down list, select the report category to select from:

O Contact Reports

O Calendar Reports

O Service Reports

O Analysis Reports

O Labels and Envelopes

O Other Reports

In the User drop-down list, select the owning user of the report to print. If it is a public report, select (public)
in the drop-down list.

In the Report drop-down list, select the report name.

Determine the contacts against which the report is run:

O Current Contact Only: Prints the report based on the active Contact Record.

O All contacts in the following filter or group: Selects ALL Contact Records to generate the report for the
entire database (this can be time consuming), or select a predefined filter or group.

In the Print Report Output To area, select from:

O Window: Generates the report and displays data in a report Preview window.

O Printer: Generates the report and sends it to your designated printer.

Click OK to generate the report.

Saving Reports with Data

After previewing a report with specified Report Properties, save report results as a file and access the information
later.

1.

i W

In the Report Center, configure the Report Properties and preview the report.
Click Save. The Save the Report to a Disk File dialog box appears.

Select the location. and then type a File name.

Select Native Format (*.FRC) in the Save as type drop-down list.

Click OK. The report saves to that location.

Viewing Saved Reports

1.
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[&
In the Reports Center, click View saved report . The Open dialog box appears.
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2.
3.

Browse to the location of the *.frc file you are viewing.

Select the file and click Open. The report opens in a GoldMine report preview window.

Sorting Report Data

Present data in order of selected field(s). GoldMine provides 3 levels of sorting for each report. For example, if you
select Company as the first sort field, GoldMine orders all the records in the report alphabetically by company
name. However, if you select Zip as the first sort field, GoldMine lists records by ZIP code.

GoldMine queries the database in the most efficient way available. If you set up a multilevel sort, or a single-level
sort on a field not already indexed, GoldMine builds a report sort table. This additional step lets other users access
GoldMine data while the report is printing and also speeds the printing process.

NOTE: The Sorts option is only available for Contact Reports, Analysis Reports, and Other Reports.

1.
2.
3.

the Reports Menu dialog box, highlight the report, then click Report Sorts.

The Report Properties dialog box appears. Select the Sort Orders tab.

Select a second level of sorting for those records having the same primary sort field. For example, if you select
Company for the Primary Sort, and the Secondary Sort is Contact, GoldMine first orders records by company
name. When 2 records have the same company name, GoldMine sorts them alphabetically by contact name.
Select a Tertiary Sort field to order records by the third sort field when the first and second level sort fields
are identical. For example, if the first and second-level sorts are State and City, and the third level sort is Zip,
GoldMine orders records by Zip entries only when 2 or more records have the same City and State values.

NOTE: Without a second- or third-level sort, GoldMine orders records with the same first-level sort values
by the records’ creation date and time. Listing records by entry order is known as the natural order of

records.

5.
6.

the Start at field, specify the beginning value of a range defining record order within the selected sort level.
In the End at field, specify the end of the range.

If Start at and End at are blank, (all) appears to the right of the sort level database and field, and GoldMine
sorts all records in ascending order.

Example:

Primary Sort: Contactl->Lastname (all): The first level sort is ordering all records by the Lastname field of the
Contactl database in alphabetical order. When selecting a Start at value and an End at value, GoldMine
displays (range) to the right of the sort level database and field.

Click OK.

Reporting Services Integration

Use the Report Scheduling feature to run reports at scheduled times from within GoldMine. It works in
conjunction with Microsoft's SQL Server Reporting Services and Microsoft Visual Studio. These programs must be
installed and operating successfully for Scheduled Reports to function. Reporting Services must be configured for
E-Mail Delivery.

NOTE: This feature only works with SQL Server Standard Edition or higher.
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From the menu bar, select Go To > Reports > Report Scheduling. If the feature has not been configured, a

message appears.

GoldMine

Q

this Feature, contact vour systern administrator bo add & section ko Ehe GMLini File. Create a n
[ReportServer] and add a new entry under it WebServiceURL=http://computer [ReportServe

If wou have Microsoft Reporting Services installed in your network, GoldMine can schedule reports bo run, To set up

%]

ew section called
t/ReportService. asmx

If the feature has been configured, the Scheduled Reports dialog box appears.

See Using Scheduled Reports.

To Schedule Reports

1. From the menu bar, select Go To > Reports > Report Scheduling.
Scheduled Reports &'
Litive Completed
|f you have Microzoft Reparting Services installed in vouwr nebwork, GoldMine
can schedule reparts o run, Select a report to Edit, Delete, or Complete.
Click Mew to zchedule a report,
Date Report Delivery Format
M ] [ E dit ] [ [ielete J [ Complete J
[ oc || cance |
The Scheduled Reports dialog box opens.
This dialog box is blank until you have scheduled a report and it is pending.
2. Click New. The Schedule a Report dialog box opens.

NOTE: If Microsoft .NET 1.1 has not been installed, an error message appears explaining the
RepServicesBridge.dll has not been registered. Ask your system administrator to register this
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AL

8.

Schedule a report

Detall | Delivery|

Repaort:

fiarmat.

Schedule

Start Date: |4/11/2007

Start Tirne: |1E|;5|:| arn

Fleaze enter the full path name of the report [ex. Awebfolder/reportname] for which bo create a
subscrnption, the datestime when the report will be generated. the delivery method and the render

Delvery

() By e-mail {*) Shared directory

Render fomat

O Excel O POF

() HTML O xML

X

Ok || Cancel

Click the Detail tab.

From the Report drop-down list, select one of the reports contained in Microsoft Reporting Services.
From the Schedule area, select a Start Date and Start Time.

From the Delivery area, select By e-mail or Shared directory.

E-mail is sent by MSSQL Reporting Services, not from within GoldMine.

From the Render format area, select Excel, HTML, PDF, or XML. The report is delivered in this format. The
formats mimic those available in Microsoft Reporting Services.

If you have selected Shared directory, click the Delivery tab.

NOTE: If you selected Shared directory and do not configure the Delivery settings, an error is logged in the

GoldMine Process Monitor and the report is not delivered.
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10.
11.
12.
13.

14.
15.
16.

X

Schedule a report

Detail | Delivery
Pleaze enter the name and the UMC path [ex. Ycomputername’sharedfolder) for the report that will be
m generated bazed an thiz subzcnption.

You need ko enter the credentials uzed to access this file share and also howe you prefer to handle if a file
with the zame name 1z found at thiz location.

Owenante
File: narme:
| () Do not ovenswite
Path [IUMC): (%3 Oveivwiite wath newer file

(]

. : = O Increment file name
Add a file extenzion when the file is created

File Share Credentials

| smtrarne: |

Pazswaord: |

Ok || Cancel

If you selected Shared directory on the Detail tab, configure the path here.
In the File name text box, type the folder name of the shared directory.

In the Path (UNC) text box, type the UNC path to this folder.

Select Add a file extension when the file is created check box.

In the File Share Credentials, type a Username and Password for this folder. If the folder has an existing
username and password, type these.

In the Overwrite area, select Do not overwrite, Overwrite with newer file, or Increment file name.
Click OK.
The Scheduled Reports > Active tab reopens.

The report you just scheduled should be listed.

Report Notes
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O After the report runs based on the scheduled time in Scheduled Reports, that report is automatically
removed from the Active tab and then logged in the Completed tab.

O If you want a report to run immediately, select the report and click Complete.

O To make changes to the settings in the Schedule a Report — Detail or Delivery tabs, click Edit in the
Scheduled Reports dialog box.

O To delete a report from the schedule, select it in the Active tab, and click Delete.

O To delete a report from the Completed tab, select it and click Purge. Select Purge All to delete all reports.

O There is no recurrence with this feature. You must manually schedule a report to run each time.
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Configuring for E-Mail Delivery

Reporting Services includes an e-mail delivery extension so that you can distribute reports through an existing e-
mail server. Before it can be used, you must configure the report server to make e-mail delivery available to your
users. Report server e-mail delivery is implemented on Collaboration Data Objects (CDO), and requires a Simple
Mail Transport Protocol (SMTP) server. The e-mail delivery extension does not provide support for digitally signing
or encrypting outgoing mail messages.

The configuration file is an XML document called rsreportserver.config. Below is an example of how it should
be set for the e-mail delivery:

<RSEmailbPConfiguration>
<SMTPServer>mail.goldmine.com</SMTPServer>
<SMTPServerPort>25</SMTPServerPort>
<SMTPAccountName>cosmin</SMTPAccountName>
<SMTPConnectionTimeout>30</SMTPConnectionTimeout>
<SMTPServerPickupDirectory></SMTPServerPickupDirectory>
<SMTPUseSSL></SMTPUseSSL>
<SendUsing>2</SenduUsing>
<SMTPAuthenticate>0</SMTPAuthenticate>
<From>cosmin@goldmine.com</From>
<EmbeddedrenderrFormats>
<RenderingExtension>MHTML</RenderingExtension>
</EmbeddedrRenderFormats>
<PrivilegeduserRenderFormats></PrivilegeduserRenderFormats>
<ExcludedrenderrFormats>
<RenderingExtension>HTMLOWC</RenderingExtension>
<RenderingExtension>NULL</RenderingExtension>
</ExcludedRenderFormats>
<SendEmailToUserAlias>True</SendEmailToUserAlias>
<DefaultHostName></DefaultHostName>
<PermittedHosts></PermittedHosts>
</RSEmailbPConfiguration>

See the article Configuring a Report Server for E-Mail Delivery at http://msdn.microsoft.com/.

Configuring the INI File

After you have Microsoft SQL Server Reporting Services installed and configured on your network, the system
administrator must add a section to the gm.ini file typically located in Program Files/GoldMine/. This addition tells
GoldMine where the Reporting Services is hosted.

1. Close GoldMine and open the gm.ini file using Notepad.

2. Type the following:

3. Type the following as shown below (where localhost is the IP address, machine name, or domain name of
your Microsoft SQL Reporting Server).

[ReportServer] WebServiceURL=http://localhost/ReportServer/ReportService.asmx
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4. Click Save and close Notepad.

5. Open GoldMine and navigate to Go To > Reports > Report Scheduling. If the INI file was successfully revised,
the Scheduled Reports dialog box opens.

[ GM.ini - Notepad

File Edit Format Wiew Help
[GoldMine]

G0 1dDir=gm7?
CommonDir=gm?
User=5YsDBA
UserLog=1
DocCtr=DocaConverted
ssce_path=speller
unitsConvToF loat=1
[DocCtr]
DochConverteds=l
[opMar]
opMgraConverteds=1
[Reportserver]
webserviceUrL=http:/localhost /Reportserver /Reportservice. asmx

F2 Lookup Lists

Use F2 Lookup lists to standardize how users type information in some GoldMine fields. For example, limit entries
in the Dear field to a few standard responses, such as Dr., Mr., Mrs., and so on. F2 Lookups also enable quick data
entry into these fields. F2 Lookup values are stored in the Lookup table.

The F2 options for date and time fields offer a graphical interface.

F2 Lookup Benefits
Using the F2 Lookup lists helps:

O Force valid entry in a field.

O Set up field dependency between fields

O Enable the standardization of data entry by preventing similar entries, such as Finance Director, Director of
Finance, and Financial Director.

O Let users unsure about field entry choose from a list.

O Speed up data entry

O Help prevent spelling errors.

O Simplify report writing and filtration. Set security access on the F2 Lookups to prevent users from altering
contents or typing void data. Each F2 Lookup has its own settings; therefore, set the security on each list
one-by-one.
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A right-facing arrow at the end of the field box identifies fields with F2 Lookups. Access aspects of the F2 Lookups
by:

O Clicking F2 or F4

O Clicking the right-facing arrow on the field

O Entering text and then selecting from the auto-fill menu that displays below the field.

Using the F2 Lookup

The F2 Lookup lists appear in a variety of locations throughout GoldMine. Some fields can be configured to only
accept values from the lookup while other fields allow for “free-form” input. Still others are clocks or calendars.

You can open, set up, or edit your F2 values on the Field Lookup dialog box.

1. Click on a right-facing field arrow of a field or select F2.

The Field Lookup dialog box opens.

M Field Lookup X

Field Entry ﬁ Mew
Amenican Bank
AutimeS oftware
Blue Pelican Consulting
Cadten Enginesring Lid.
Compute-al M agazine
JHill billirvzry
JP Hutton

Select
LaMSupport
Movatech Lid. s

2. Select one of the following options:
O New opens the F2 Entry dialog box. Type in the new name and click OK (see Creating F2 Lookup Entries.

O Edit allows you to edit a selected entry. First, highlight the value you want to edit and then click Edit. At the
F2 Entry dialog box, type over the existing text and click OK (see Editing F2 Lookup Entries.

O Delete removes an entry. First highlight the value you want to delete and then click Delete. At the prompt,
click Yes.

O Setup opens the F2 Field Setup dialog box (see Configuring F2 Lookup List Security) to configure settings for
a field.

O Select chooses an entry. Highlight the entry and then click Select. The value you selected appears in the
field.

3. Click Cancel to close the Field Lookup dialog box.

For additional information, see Managing F2 Lookup Lists.
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Managing F2 Lookup Lists

You can manage F2 Lookup lists by:
m Creating F2 Lookup Entries
m Setting Dependency Between Lookup Lists
m Configuring F2 Lookup List Security
m Editing F2 Lookup Entries

Creating F2 Lookup Entries

The F2 Lookup lists appear in a variety of locations throughout GoldMine. Some fields can be configured to only
accept values from the lookup while other fields can allow free-form input. In other cases, the lookup displays a
clock or calendar.

You can add other values to your F2 Lookup table. For example you can add contact names, addresses, and so on.
You can even select which values will display.

Another lookup feature is the ability to set a limit on the types of values that can be added to a field by another
field. For example, if you want to enter only cities (City field) in the state of California (State field) you can set up
that limit on the Lookup lists.

NOTE: To place multiple entries in a field, with new entry after the existing entry, type a semi-colon (;) at
the end of the entry. This appends the entry after existing data in the field, separated by a comma.

Be sure to set security options before or after creating the F2 Lookup tables (see Configuring F2 Lookup List
Security).

1. Click on a right-facing field arrow of a field or select F2.
2. Atthe Field Lookup dialog box, click New.
The F2 Entry dialog box opens.

Enter the FZ value:

I

3. Type the new entry.

Use a method to designate special handling of field values:

O To place multiple entries in a field, with new entry after the existing entry, type a semi-colon (;) at the end
of the entry. This appends the entry after existing data in the field, separated by a comma. This way,
multiple entries can be placed in a field. When the entry does not end with a semi-colon, it overwrites
data already appearing in the field.

O To place a coded entry that has descriptive information in the lookup list, type two slashes (//) after the
entry, then the description. The entry for the field it is treated like a comment, and displays the text in
the field.
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Example:

0001//Shops & Retail
0002//Shipping
Selecting one of these places the numeric option into the field. To require multiple and coded entry,
place these in this order: code, semicolon, forward slashes, and description:
0001;//Shops & Retail
0002;//Shipping

4. Click OK. The entry adds to the F2 Lookup list.

Setting Dependency Between Lookup Lists

You can set up lookup values that are dependent on values from other fields. You can also create, change, or
delete necessary relationship.

For example, you set up the two fields State and City. This enhancement allows you to select only cities from a
corresponding state. You can set up the City F2 lookup list to depend on the State field value, then change it to
key1 (record type) field. The value from the City (that is, from the field which on the field city depends) field is
named as Master Value.
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To Set Up a Dependency
To set up a dependence, you must first configure the field setup.

1. Open aF2 Lookup dialog box and click Setup.

F2 Field Setup 3

GoldMine allows you ko add frequently used data entry
values. To help you track this information for reporting
purposes, security options may be set ko ensure
standardized data entry.

Field Name: I Ciky

Field Settings

Allow blank input [CList existing data
[]Force walid input Allow adding
Inse st ria allow editing

[]Capitalize first letter Allow deleting
[[]Pop-up when selected [ ] auto Fill

[ 1mport lookup entries from ancther Field

Context-dependent F2 lookup list
Lookup list depends on another Field:

Field narme:

SE

I Ok I[ Cancel l

The Setup dialog box opens; this is where you change the dependency for F2 lookup values.
2. Inthe Field Name area, select values.
3. Inthe Context-dependent F2 lookup list area, click on the Lookup list depends on another field checkbox.

NOTE: This checkbox must be selected. If left unchecked then the lookup values do not depend on any
other fields.
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4. Select the Contact (CONTACT1) button to select a master field from the Contactl table.

For example you can set an Activities result code which depends on the key 1 (record type) field in the
corresponding contact. If you select this button, then the Contactl fields appear in the Master field drop-
down box. If you select other fields, fields from the corresponding table appear. For Activities it is the CAL
table, for Cases it is the CASES or fields of cases.

O Select Go To > Service Center
O Click New case and create a new case
O Navigate to Subject field and press F2 > setup.

The CASES table is available for selection.

NOTE: After changing this field all lookup values will not update. Manually edit each field in the list. See To
Manually Editing Dependencies.

For a list of dependency tables, see Available Dependency Tables.

Available Dependency Tables

The following table shows the available dependency tables.

Fields Table

Contact record fields contactl table

Use defined contact fields contactl and contact2
Pending activity fields contactl and cal tables
History activity fields contactl and conthist tables
Opportunities and Projects contactl and opmgr tables
Cases (Service Center) contactl and cases tables

To Manually Editing Dependencies

1. Open the F2 Lookup dialog box for the dependency field and select a value.
2. Click Edit.

Enter the FZ value:

Only valid when [STATE] conkains: -
Cancel
CA »
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3. Check the Only valid when checkbox.

A valid value mean that master field has the appropriate value. In the example of city and state, the State
value is CA (California) and when the Only valid when checkbox is checked, the City values returned are all
cities in California.

4. Atthe drop-down box, select a value and then click OK.

The F2 Lookup dialog box now have a Show All checkbox.

Select an Entry by Ignoring Dependency Settings

After setting up all the dependencies, you can select them from the F2 lookup lists.

1. Open an F2 Lookup dialog box.

Field Entry
San Diego
San Francisco
S an Gabriel
SanJose

San Pedo
Santa Ana
Santa Barbara

S anta Clara

STATE
[ary)
[ary)
[ary)
[ary)
[ary)
[ary]
[any]

[any]

anta Monica

[any]

Ll

X

&
L
b=
(=]
=
e

e
Edit

Delete

Setup

Select

S eattle

[any]

Cancel

U el

2. Click the Show All checkbox.

This shows all values independent from the Master field value.

Unclick the Show All check box to show only valid values for the dependency.

Configuring F2 Lookup List Security

To ensure that data entries are consistent in a database, you must set security options for each F2 Lookup. Using
these security options standardizes data field values. Set security options before or after you create (see Creating
F2 Lookup Entries) or edit (see Editing F2 Lookup Entries) the lookup entries.

NOTE: To access the F2 Field Setup dialog box, you must have Master Rights.

1. Click on a right-facing field arrow of a field or select F2.
2. At the Field Lookup dialog box, click Setup.

The F2 Field Setup dialog box opens.

3. In the Field Name text box, type the name for the lookup list.

This can be the name of the field you are creating, its lookup, or a general name if you are planning to use the
lookup list with more than one field. To use the lookup with more than one field if you will be importing the
lookup entries, type a Field Name.
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4. Inthe Field Settings area, select from the following:

O Allow blank input. Keeps the data field blank. Selecting this option lets GoldMine skip the field when the
value is unknown.

NOTE: Selecting Allow blank input for a required field prevents you from determining whether the field
was supposed to be empty. Retain more control over field entries by including a lookup value of N/A to
indicate that no lookup value applies to the field.

NOTE: Any fields to which this setting is applied will also allow the blank input when editing a record while
using GoldMine Web.

O Force valid input. Requires selection of an F2 Lookup list value to update the field. GoldMine allows only
entries that appear in the lookup. If an invalid entry is attempted, GoldMine displays the lookup and
highlights the item closest to the actual field entry.

NOTE: Any fields to which this setting is applied will also allow the blank input when editing a record while
using GoldMine Web.

O Insert closest match. If an entry is typed in a field that does not match existing lookup entries, GoldMine
inserts an entry that most closely matches the typed value. GoldMine changes the entry when the cursor
is moved from the field. To enable this option, select Force valid input.

Because GoldMine inserts the entry that appears to be the closest match, Insert closest match can place
an incorrect value into a field.
O Capitalize first letter. Capitalizes the first letter of the entry.
O Pop-up when selected. Displays the corresponding F2 Lookup when the field is selected.
O List existing data. Lets users look for the existing values.
- For example, there are contacts with New York, Dublin, Moscow only. So, F2 Lookup will show these
cities only. This option will disable new F2 Lookup navigation (by two fields).
- Allow adding. Lets users add entries to the F2 Lookup.
- Allow editing. Lets users edit the entries in the F2 Lookup.
- Allow deleting. Lets users delete entries from the F2 Lookup.
- Auto Fill. As the user types, GoldMine places the closest matching entry from the lookup in the field.
O Import lookup entries from another field. Select this when importing an existing F2 Lookup list and then
select the field name from the drop-down containing the information to use as entries in the lookup list.

After selecting a field and closing the F2 Field Setup dialog box, entries corresponding to the selected
field appear in the lookup.

O Lookup list depends on another field.When this checkbox is selected the lookup value for a field depends
on the value of another field called a master. For example, if you want all entries in the City field to be in
the state of California, then you would check this box and in the Field name field, you would select State.

If this box is not selected, all values can be added to the Lookup list.

O Contact radio button. Allows the user to select a master field from the Contact1 table.

O Case (Opportunity, Calendar, Case and so on) radio button. This radio button allows you to select a
master field from the corresponding table.

5. When the form is completed click OK.
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Editing F2 Lookup Entries

You can edit F2 Lookup entries to reflect changes or incorporate special symbols that designate values in a text-

based lookup.

NOTE: When editing a lookup entry, make sure you change the security options on the entire table (see

Configuring F2 Lookup List Security).

1. Right-click on the field to open the Field Lookup dialog box.

M Department

Field Entry L
Adrminiziration

Sudvertising
Developer Relations
Enginesring

IT

b ark eting
Purchasing

Sales

Service

Shipping

Mew

Delete

Setup

Select

Zancel

3

2. Select the entry you want to edit and click Edit. The F2 Entry dialog box appears.

Enker the FZ value:
Enkry with semicalon;

3. In the Enter the value field, type the new entry.

Use the following methods to designate special handling of values in a field:

O To place multiple entries in a field, with new entry after the existing entry, type a semi-colon (;) at the end
of the entry. This appends the entry after existing data in the field, separated by a comma. This method
allows multiple entries in a field. When the entry does not end with a semi-colon, the entry will overwrite
any data that already appears in the field.

O To place multiple entries in a field, with the new entry before the existing entry, type a percent sign (%) at

the end of the entry. GoldMine does not insert a comma between entries
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O To place a coded entry with descriptive information in the lookup list, type a pair of forward slashes (//)
after the entry, followed by the description. The // symbol indicates breaks the string and treats text after
it is treated as informational and displays the text in the field.

This is useful when working with coded values, for example industrial sector codes, where SIC Codes (for
example) are 0 = Agricultural, Forestry and Fishing; 1 = Mining and Construction and so on.

In GoldMine you can either enter all possible values as real values or you setup the lookup list with 0 //
Agricultural, Forestry and Fishing 1 // Mining and Construction. When opening the lookup the user sees
the description but in the field only the Code is entered means 0 or 1.

4. Click OK to add the updated entry to the F2 Lookup list.
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My GoldMine

My GoldMine allows users to view current information from GoldMine and from the Internet in a customizable
window. The My GoldMine desktop contains columns and sections you can personalize to display business-critical
content from the Web or from within GoldMine. Personalize My GoldMine layout, content, and refresh rate. Users
can:

m Add and remove content from My GoldMine to optimize efficiency and instantly access information such as
stock quotes, e-mail, weather, pending activities, or other relevant information for planning and managing
business.

= Add GoldMine information, including appointments, e-mail inbox, or the day's sales.
= Also add Internet sites supporting Rich Site Summary (RSS) which is a simple XML format designed for sharing

Web headlines. Sites supporting RSS are usually offering "What's New" information from their site. RSS
versions 0.91-2.0 supported.

NOTE: The user’s system must be connected to the Internet to display and access Web sites. Set up the
appearance, content, and refresh rate for My GoldMine to display the Web site content and GoldMine
information.

Select from the following topics to learn more about My GoldMine.

m Configuring My GoldMine
m Using My GoldMine
m Select a Resource to Add Dialog Box in My GoldMine

Configuring My GoldMine

1. To access the My GoldMine configuration options, select Web > My GoldMine. The My GoldMine window
appears.
2. Click the Personalize Content button at the top right of the window.
The Configure My GoldMine dialog box opens.
On the Layout tab, select the Page Style in the drop-down list.
Select a 2 or 3 column style in the Column Scheme drop-down list.
O Default
O Windows
O Newspaper
O XP
5. For each column, select the Column Format in the drop-down list. Select Tab, which keeps the contents of the
other items in the column hidden when not selected, or Box, which displays the information or hyperlink for
all items.
O Classic Three Columns
O Even Three Columns
O Even Two Columns
6. Click the Contents tab.
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7. Select Column 1, 2, or 3. The information in the Items pane reflects the active resources for the selected
column. To add a resource, click Add. The Select Item to Add dialog box appears.

To change the display order, select the item and click Move Up or Move Down.
Click Remove to delete the selected item.
10. Click the Settings tab.

11. Select Refresh only on startup prevents you from setting a refresh rate. My GoldMine does not refresh while
it is open. If you do not select Refresh only on startup, type or select a time in the Refresh My GoldMine
Every x minutes text box.

12. Click OK to save the settings and close.

Using My GoldMine

Use My GoldMine as a personalized resource for current information from selected GoldMine and Internet
sources.
1. Select Web > My GoldMine. The My GoldMine window appears.

2. Depending upon the configuration you selected, My GoldMine displays with 2 or 3 columns, as tabs or boxes,
and with default, Windows, newspaper, or XP page style.

To change the setup, style, and content, select Personalize Content. The Configure My GoldMine dialog box
opens.

3. To add to the content of each column, click Add Item(s) to Columns. The Select Item to Add dialog box
appears.

4. To view the complete information where it is not displayed, clicking the hyperlink expands the view to include
the detailed information.

NOTE: : If you selected the Tab format in the Configure My GoldMine dialog box, you need to scroll to the
bottom of the column and double-click the resource's title bar. Use the arrow to minimize the view on the
tab format. The Box format keeps your resources actively displayed at the top of the column.
5. To copy information from the My GoldMine display, highlight the section and right-click.
Select Copy from the local menu.

Choose Select All to copy the entire My GoldMine display to the clipboard. Then paste the selected section or
the entire section in your target application.

6. To refresh news feed sites manually rather than wait for the automatic refresh, click Refresh.

Select a Resource to Add Dialog Box in My GoldMine

Use the Select a Resource to Add dialog box to add, store, and remove resources. The dialog box appears if you
click Add on the Content tab of the Configure My GoldMine dialog box or if you select Add Item(s) to Columns on
the My GoldMine window.

1. If the GoldMine or Web-based resource is listed, select the item and click OK. The item is added to the
selected column.
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NOTE: The Select a Resource to Add list displays only items not added to the My GoldMine display. The list
is universal, not column specific. To move an item from one column to the next, you must remove it from
the display by clicking the X in the title bar of the item in the My GoldMine window. The item is re-added to
the Select Item to Add list and can the be added to the column of your choice.
2. To add aresource to the item list, click Add Resource.
The Edit RSS Resource URL dialog box appears.

3. After adding the RSS resource, it appears on the item list. Select the item and click OK. The item is added to
the selected column.

4. To change the name or URL of an item, select the item and click Edit Resource.
The Edit RSS Resource URL dialog box appears.

5. Toremove an item from the list, select the item and click Delete Resource. The item is permanently deleted
from the item list.

6. Click OK to add a highlighted item or Cancel to close the dialog box.
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GoldMine Plus for Microsoft Office

GoldMine Plus for Microsoft Office is a powerful add-in for GoldMine that allows seamless integration between
Microsoft Office and your GoldMine environment. Create dynamically merged documents such as letters, faxes,
and e-mails using your GoldMine contact data, and then leverage the powerful features in the Microsoft Office
suite to produce and distribute your work. Easily move data between GoldMine and Microsoft Excel. Tools
embedded directly into Excel allow flexible generation of customized invoices, reports, and more, using your
GoldMine contact data.

IMPORTANT: GoldMine support the use of more than one contact set. However, the integration link supports
the use of only one contact set, and this must be the one in your primary SQL database that includes both
Contact and GMBASE tables.

Select from the following topics to learn more about GoldMine Plus for Microsoft Office.

m About GoldMine Plus for Microsoft Word

m About GoldMine Plus for Microsoft Excel

m About GoldMine Plus for Microsoft Outlook

m Installing GoldMine Plus for Microsoft Office

m Setting Preferences in GoldMine Plus for Microsoft Office
m Granting User Access to Templates

m Using GoldMine Fields in Microsoft Word

m Using GoldMine Fields in Microsoft Excel

m Adding Excel Templates

About GoldMine Plus for Microsoft Word

Installing GoldMine Plus for Microsoft Office adds the following features and enhancements to GoldMine and
Microsoft Word:

= Complete integration between GoldMine and Microsoft Word

= A GoldMine menu in Microsoft Word

= Enhanced functionality for GoldMine’s document management features
Generate form letters, faxes, and e-mails with primary contact field information (Contactl) such as name, address,
or primary phone number. Also include information from user-defined fields (Contact2). Create document
templates for use with complex merges in GoldMine’s Document Management Center, and manage scheduled

document production using Automated Processes. GoldMine fields used in templates remain dynamic, updating
automatically to reflect changes in your database.
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GoldMine Plus for Microsoft Office must be installed. After installed, a GoldMine menu option is added to the
Word main menu, and you can merge templates with groups of contacts using:

= Document Management Center. See "About the Document Center in the GoldMine User's Guide.
= Automated Processes. See Automated Processes
You can also customize the application (see Customizing GoldMine Plus for Word).

NOTE: Microsoft Word allows you to send e-mail messages through the program. To enable sending e-mail
attachments using Microsoft Office Word you must upgrade to Microsoft Office 2007 or newer.

About GoldMine Plus for Microsoft Excel

GoldMine Plus for Microsoft Office installs a GoldMine menu in Excel for accessing integrated functions.

= Insert GoldMine Fields. Provides a list of GoldMine fields and a field macros to map to Excel cells. Field
mappings remain dynamically linked to GoldMine fields, changing to reflect values in the active GoldMine
Contact Record. For example, create a billing form in Excel, insert the appropriate name, address, and
user-defined fields. Then use the integrated form to generate a printed bill for the current contact. See Using
GoldMine Fields in Microsoft Excel

= Save as GoldMine Linked Document. Save a workbook or worksheet that is linked automatically to a GoldMine
contact.

= Export Data to GoldMine. GoldMine Plus now offers field mapping options for exporting Excel databases into
GoldMine. Map Excel fields to GoldMine fields with a simple wizard-style interface, for the fastest, easiest
method yet to bring data into GoldMine.Exporting From Microsoft Excel to GoldMine.

GoldMine Plus for Microsoft Office must be installed. After the application is installed, create individual
spreadsheets with inserted GoldMine fields or create spreadsheet templates accessed through the Document
Management Center (see Adding Excel Templates).

NOTE: If you do not see the GoldMine menu in Excel after installing GoldMine Plus for Microsoft Excel,

open the Excel Help menu and select About Microsoft Office Excel. On the About Microsoft Excel dialog
box, click the Disabled Items button and look for an item called GMPlusOffice. Re-enable this item to make

the GoldMine menu available.
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About GoldMine Plus for Microsoft Outlook

With this Integration link, the contact message-linking and history tracking features in GoldMine's E-mail Center
are available to Microsoft Outlook users. The installation adds a GoldMine menu and toolbar to Outlook's main
window and a GoldMine Link tab to its Options dialog box.

Depending on the options installed with the integration, you can:

= Manage Customer Contacts

m Schedule Activities

m Track Forecast Sales

m Track Cases

= Track Opportunities

m Linking Messages

= E-mail Templates

= E-mail Merge to GoldMine Group or Filter

= Schedule an Activity for a GoldMine Group or Filter

For detailed information about GoldMine Plus for Microsoft Outlook, see Outlook Integration Administration.

Installing GoldMine Plus for Microsoft Office

GoldMine Plus for Microsoft Office is usually installed with GoldMine. However, you have the option of installing
GoldMine Plus later if desired.

Follow these steps to install GoldMine Plus after the main GoldMine installation.

1. From your desktop, go to: Start > Settings > Control Panel > Add or Remove Programs
2. Highlight GoldMine and then click the Change button.

3. The Welcome to the Installshield Wizard for GoldMine dialog box appears. Click Next.
4. Select the Modify radio button and then click Next.

The Custom Setup dialog box opens.

v

Click the GoldMine Plus! icon to open the drop-down menu.

Select This feature will be installed on local hard drive and then click Next.

The Installing GoldMine status screen opens.

7. When finished, the GoldMine Installation Completed dialog box appears. Click Finish to complete the
installation process.

NOTE: To uninstall GoldMine Plus! components, repeat the steps listed above, but instead select This
feature will not be available from the GoldMine Plus! icon drop-down menu. GoldMine Plus! will be
uninstalled from your local hard drive.

GoldMine Administrator's Guide Page 388 of 439



GoldMine™®

Setting Preferences in GoldMine Plus for Microsoft
Office

Use the GoldMine Plus Preferences for Microsoft Office dialog box to configure various system settings. GoldMine
Plus preferences are accessed from within Microsoft Word.

1. Open Microsoft Word.
2. From the GoldMine menu, select Setup.
3. The GoldMine Plus Preferences dialog opens.

Eﬂ‘} GoldMine PLUS Preferences >

Automatic GoldMine login

GoldMine PLUS needs GoldMine to be running and for your user to be logged in to be used
effectively. If yvou wish, you may set GoldMine PLUS to automatically login to GoldMine below.

[] Please login to GoldMine with the following user data automatically in the future.
User: Password:
File: Location
Choose the file location for documents linked to GeldMine:
(@ Use GoldMine to determine location
() Use Office Default Path

() Use: | |

OLEDE Data provider
Provider Name |Microsoft ACE.OLEDB.14.0 |

Fax Method

Prowider: Fax Macro

|[n|:|ne} v | |%Fa:¢ e |
Show Send Screen [ ] Use Fine' Resolution

Group Merge

Prompt for group merge destination

Field Automation

Fields that vou place in Ward will automatically attempt to update their values from GoldMine.
You can turn this off, but you will have to update the field information manually by right clicking
and choosing Update Field’. This will not affect any fields that have already been placed.

Flace GoldMine fields in a way that \Word will not attempt to update automatically.

About Save Close
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4. Set GoldMine Plus Preferences using the following options:

Automatic GoldMine Login: To login to GoldMine automatically when Microsoft Word or Excel are started:

O Check the box for Please login to GoldMine with the following user data automatically in the future.

O Enter your GoldMine User name and Password.

File Location: Select an option for a default file location where GoldMine Plus documents will be saved:

O Use GoldMine to determine location: The default file location for GoldMine Plus documents will be
determined from the GoldMine application.

O Use Word Default Path: GoldMine Plus documents will automatically be saved to Microsoft Word’s default
file location.

O Use (Browse to file location): Manually browse to a default file location for GoldMine Plus documents.

OLEDB Data Provider: Enter the OLEDB data provider used by GoldMine Plus add-ins to export data to

GoldMine and merge mail.

O Provider Name: The data provider name we recommend using is Microsoft. ACE.OLEDB.XX.0, where XX is
the driver version. The default value is Microsoft. ACE.OLEDB.14.0. For more information, see the related
Important note below.

Fax Method:
O Provider: Select your fax method in the drop-down list of fax applications:
- (none)
- OmniRush
- WinFax
- RightFax
- DelFax
- Zetafax
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O Fax Macro: Select the Fax Number Macro specified by you fax application in the drop-down list.

- &DIALFAX: The fax number from the active contact record.

- &FAX: The fax number as it should be sent to an auto-dialer for automatic fax transmission.

O The Show Send Screen and Use 'Fine' Resolution options are available in different combinations,

depending on the fax application.

Group Merge: Select Prompt for group merge destination (print only) to have GoldMine generate a prompt

before printing.

Field Automation: Select the Place GoldMine fields in a way that Word will not attempt to update
automatically option to all Microsoft Word to automatically update fields that you insert.

5. Click Save to exit the GoldMine Plus Preferences dialog.

IMPORTANT: If you have problems with the export from Excel to GoldMine or the mail merge, check the log
file for the following error message: "The 'Microsoft. ACE.OLEDB.14.0' provider is not registered on the local

machine."

If this error displays after the date and time you executed one of the operations, the version of the provider must
be changed to the version installed on the machine. The OLEDB data provider is installed with Microsoft Office—to

check which version is installed, follow these steps:

1. Open the ODBC Data Source Administrator (32-bit) or (64-bit) dialog.
2. Under the Drivers tab, look for the ACEODBC.DLL filename and the first two digits of the version number.

'-:?. QODBC Data Source Administrator (84-bit)

QODBC Drivers that are installed on yvour system:

User DSN  System DSN  File DSM  Drivers  Tracing Connection Pooling  About

Pt

Wersion

Mame
Microsoft Access Driver (*.mdb, *.accdb)

16.00.14723.20126

Company

Microsoft Corparation

ACECDBC.DLL

Wicrosof Limver | p U0 12723 20120 Microsor Lorparation ALEULIBL. .U
Microsoft Excel Driver (" xls, “xlsx, “xlsm, “xlsh) 16.00.14729.20126 Microsoft Comporation  ACECDBC.DLL
QDBC Driver 13 for SQL Server 2017140344502  Microsoft Camporation  MSODBCSQL13.0
SQAL Mative Client 2005.90.3042 .00 Microsoft Corporation  SQLMCLIDLL
SQL Server 10.00.15041.01 Microsoft Corporation  SGQLSRW3Z DLL
SQAL Server Mative Client 11.0 2011110654000  Microsoft Corporation  SQGLNCLIT1.DLL
SQL Server Mative Client RDA 11.0 2011110506566  Microsoft Corporation  SGQLMNCLIRDAI1.D
< >

An QDBC driver allows ODBC-enabled programs to get information from ODBC data sources. To install
D; new drivers, use the driver’s setup program.

Cancel Aeply Help
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Customizing GoldMine Plus for Word

Adding Signature Files

Add a bitmap signature file to be included in the documents you print by adding a SigDir=<drive: path> entry in
the GM. ini file under the [GoldMine] section where <drive: path> is the name of the directory containing the
signature bitmap. All signature bitmap files must be named <Username>.bmp (example: john.bmp).

[GoldMine]
GoldD1r=C:\GOLDMINE

CommonD1i r=C:\GOLDMINE\COMMON\
SigDir=C:\GOLDMINE\SIG\

To insert a Signature bitmap into a template, in Word select GoldMine > Insert GoldMine Field. Select
&Signature.

Forcing Template Default and File Name

Force a file name and/or default save folder. The path for the template folder should be to the GoldMine root
directory where users have their own folders. This option sets the default folder where merged documents, linked
documents, and new templates are saved. See Setting Default File Name and Folder Location for Templates.

Granting User Access to Templates

Many companies no longer allow local users access to certain functionality, such access permissions on program
installation folders. If the user has local administrator rights, then this is not an issue. However, if user rights are
restricted within the network, access to the GoldMine templates are also restricted. Access to the GoldMine
installation folder must be set by a Windows user that is designated as a local “Administration” to allow access to
the templates.

Depending on your operating system, your steps may vary from the following instructions.

To Grant User Access using Excel 2007

This process must be performed for each existing and new user, with the exception of the user that installed
GoldMine.

Start Excel.

Click the Office button.

Click Excel options.

Select Add-Ins.

On the Manage drop-down list, select Excel Add-ins and then click Go.

Click the Automation button.

Select GMPIlusOffice2007.UserDefined Functions and then click OK.

A message box displays and asks if you want to replace the file. Click No to close this message.
Select OK.

10. Restart Excel for the changes to take effect.

W e NSOV A WNDNRRE
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Using GoldMine Fields in Microsoft Word

After GoldMine Plus for Microsoft Office is installed, you can add GoldMine fields to a Word document. The fields
remain dynamic, meaning that when changes are made to the active GoldMine Contact Record, linked field data in
Word changes as well.

NOTE: GoldMine linked fields that have changed in Microsoft Word documents will not update until the
application's cache is cleared. To do this, close, then reopen Microsoft Word.

Installing GoldMine Fields into a Word Document

NOTE: If you are using Microsoft Office 2007, all GoldMine menu items are accessed by selecting the
GoldMine Tab from Word’s main menu.

1. Launch GoldMine and select a Contact Record as a data source.
2. Open Microsoft Word.

3. Select GoldMine > Insert GoldMine Field(s). The Insert GoldMine Fields floating toolbar appears. (To anchor
the Insert GoldMine Fields toolbar, drag-and-drop the floating toolbar to the Word toolbar.)

NOTE: In Microsoft Office 2007/2010, these fields are always located in the toolbar of the GoldMine Tab.

4. Place your cursor at the point in the document where you would like to insert the field.
5. Click the field drop-down list on the Insert GoldMine Fields toolbar, and select a field or macro.
Fields are listed as TABLE->FIELDNAME (for example, CONTACT1->CONTACT). Macros are listed as
&MacroName (for example, &UserFullName).
Continue adding desired fields to the document.
Complete the process by:
O Saving the document for later use: Select File > Save as from the Word menu. Save the file as
filename.doc. To reuse this file with dynamic fields, launch Word and open the saved . doc file. The
dynamic fields display data from the active GoldMine Contact Record.

O Saving the document as a template: Select File > Save as from the Word menu. Save the template as
filename.dot. If you are using this file as a Word template in GoldMine, save it in the GoldMine Template

folder.
NOTE: If you are sending a mail merge to a group of contacts using GoldMine Plus for Microsoft Office and
a required field is not populated in a contact record, an error message appear. Ensure all required fields are
populated.

For information on setting preferences in GoldMine Plus for Microsoft Office, see Setting Preferences in GoldMine
Plus for Microsoft Office.
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Using GoldMine Fields in Microsoft Excel

After GoldMine Plus for Microsoft Office is installed, you add GoldMine fields to an Excel document. The fields
remain dynamic, meaning that when changes are made to the active GoldMine Contact Record, linked field data in
Excel changes as well.

NOTE: If you are using Microsoft Office 2007, all GoldMine menu items are accessed by selecting the
GoldMine Tab from Excel’s main menu.

1. Launch GoldMine and select a Contact Record as a data source.
2. Open Excel.

3. Select GoldMine > Insert GoldMine Field. The GoldMine Fields floating toolbar appears. (To anchor the
GoldMine Fields toolbar, drag-and-drop it in the Excel toolbar.)

NOTE: In Microsoft Office 2007/2010, the fields toolbar is always available in the GoldMine Tab.

4. Select a target cell on the spreadsheet.
5. Click the field drop-down list on the floating GoldMine Fields toolbar and select a field or macro.

Fields list as TABLE->FIELDNAME (for example, CONTACT1->CONTACT). Macros list as &MacroName (for
example, &EmailAddress).

NOTE: Excel does not support multiple lines per cell, therefore, multi-line macros cannot function in Excel.

6. Continue adding desired fields to cells.
7. Finish the process by:

O Saving the spreadsheet for later use: Select File > Save as on the Excel menu. Save the file as filename.xls.
To reuse the file with dynamic fields, launch Excel and open the saved .x1s document. The dynamic fields
display data from the active Contact Record.

O Saving the spreadsheet as a template: Select File > Save as on the Excel menu. Save the file as
filename.xIt. If using it in GoldMine, save the new template in the GoldMine Template folder. Then add
the template to the Document Management Center (See "About the Document Center" in the GoldMine
User's Guide).

O Select NO. If you select YES an additional error message displays. GoldMine must be running in order for
Excel to access linked cells.

Exporting From Microsoft Excel to GoldMine

After GoldMine Plus for Microsoft Office is installed, data can be exported from Microsoft Excel to your GoldMine
database using new menu options in Excel.

GoldMine Plus for Office adds an export feature to the GoldMine menu in Excel. Use this menu option to map
Excel columns to GoldMine fields and initiate the export process.

IMPORTANT: Backup your database before you begin.

IMPORTANT: Using underscores ("_") in column headers may result in an error when exporting data.
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NOTE: Before proceeding with the export, verify that phone numbers are formatted consistently and make
changes as needed. The format of the phone numbers in your Excel spreadsheet must be the same for the
Excel ODBC to interpret the numbers correctly. If formats are inconsistent, the ODBC driver interprets all
the values in the column as null and you lose phone number data during the export process. For example,
you cannot have one phone number that is 1235557894 and another that is 777-555-1236. Before
exporting to GoldMine, specify one format and update all phone numbers in your spreadsheet to match the
selected format. When the phone number format is consistent, begin exporting to GoldMine.

1. Launch GoldMine.

2. Open the Excel spreadsheet you are exporting to GoldMine.

3. Select the cells you are exporting to GoldMine and specify the Named Range. In Excel, select Insert > Name >
Define. The Define Name dialog box appears. See Excel Help for details.

NOTE: To perform this function in Microsoft Office 2007/2010, select the cells to export to GoldMine, right-
click on the selected cell range and select Name a Range from the drop-down menu. You can also select the
Formulas tab, then select Define Name > Define Name from the menu.

4. Inthe Names text box, type the desired name of the range.
NOTE: The first row of the selected range must contain only header data.

5. Select either Workbook or Sheet from the Scope drop-down menu.

6. Select GoldMine > Export Data to GoldMine. The Export Data to GoldMine dialog box appears.
The Welcome to the GoldMine Plus for Microsoft Excel Export Wizard! appears.
Click Next. The field mapping dialog box appears.

To map columns to GoldMine fields, highlight the column in the Excel Fields list and then highlight the
GoldMine field to map the column to. Click Add Mapping. Your selection is added to the Mapped Fields list
(for example, Column1<=>C1.Company).

9. Continue to map desired fields. When finished, click Next. The GoldMine is now Ready to export your Excel
data! dialog box appears.

10. Click Finish.

When the import process completes, a dialog box appears, indicating the number of records imported into
GoldMine.

Adding Excel Templates

A template is a spreadsheet created in Microsoft Excel and contains embedded GoldMine DDE link fields. The DDE
fields link contact information to cells so the fields remain dynamic, displaying the data from the linked fields in
the configured cells.

NOTE: Use the Document Management Center to link to a spreadsheet template and edit as needed; the
template must exist as a file. The most common option for creating a spreadsheet document are using
Microsoft Excel with GoldMine Plus for Microsoft Office installed.
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To Add Excel Templates
1. Select Go To > Document Templates. The Document Management Center appears.
2. Select the User from the drop-down list.

3. Right-click on Spreadsheets in the Document Templates tree and select New. The Document Template
Properties dialog box appears.

4. Type the Document Name in the format to appear in the Document Management Center and in the template
drop-down list on the Merge Form dialog box.

5. Select the owning user from the Document User drop-down list.
6. In the Template Filename text box, type or browse to the location of the template.

NOTE: To make changes to the spreadsheet, click the Edit button to open the spreadsheet, make any
desired changes, then save the file.

7. Inthe Document Management area, select from the following options:
O Save in Links Tab when merging for a single contact
O Create History when merging
In the Document Type area, select Spreadsheet.
Click OK.
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GoldMine Link for Microsoft Outlook

GoldMine Link for Microsoft Outlook is a lightweight alternative to GoldMine Plus! for Microsoft Outlook to link
and unlink email messages to GoldMine contacts. When GoldMine Link is installed a GoldMine Link toolbar is

added to Outlook.

From the GoldMine toolbar, users will be able to:

m Link and Unlink email messages.
= View contacts in GoldMine.

m Synchronize calendar/activities between Outlook and GoldMine.

For information on how to configure GoldMine Link see Setting Up GoldMine Link.

Installing GoldMine Link for Microsoft Outlook

Only one (1) version of GoldMine plug-in for Microsoft Outlook can be installed with GoldMine Premium Edition. If
GoldMine Plus! for Microsoft Outlook is installed, it will have to be uninstalled before you can install GoldMine
Link for Microsoft Outlook. The same applies the other way around.

NOTE: This information only affects the plug-in for Microsoft Outlook, not GoldMine Plus! for Microsoft

Word and/or GoldMine Plus! for Microsoft Excel. Both these plug-ins can be installed at the same time as

GoldMine Link for Microsoft Outlook.
IMPORTANT: Switching frequently between the GoldMine Link for Microsoft Outlook and GoldMine
Plus! for Microsoft Outlook is not recommended as this may result in certain features not functioning
properly. The best practice recommendation is to select a version of the GoldMine plug-in for Microsoft

Outlook that works best for your users, and stay with that version until the next major release from

GoldMine.

Installing GoldMine Link with GoldMine Premium Edition
Use the following steps to install GoldMine Link at the same time as GoldMine Premium Edition:

1. On the Choose Plug-in for Microsoft Outlook window, select GoldMine Link for Microsoft Outlook.
2. Follow the rest of the installation steps to install both GoldMine Premium Edition and GoldMine Link for
Microsoft Outlook.
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ﬂ GoldMine - InstallShield Wizard
Choose Plug-in for Microsoft® Outlook®

Select the program features you want installed.

Please select the plug-in to install with Goldmine for working with Microsoft® Outlook®

@ GoldMine Link for Microsoft® Outlook®

O GoldMine Plus! for Microsoft@ Outlook®

O I don't wish to link emails using Microsoft® Outlook®

InstallShield

Installing GoldMine Link After GoldMine Premium Edition Is Installed
Use the following steps to install GoldMine Link with an existing installation of GoldMine Premium Edition:

1. From the Windows Control Panel, (depending on your operating system) select either Programs and
Features or Programs, followed by Uninstall a program.

] Control Panel [=Te |

[ Coni Panat 5

Adjust your computer's settings Vanwby: Catagory T

| 4 B &

F

=
=
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2. Select GoldMine and the Change button from the Programs and Features or Features window.
This opens the GoldMine InstallShield Wizard.

HEAT Software USA lnc
A

3. Select the Modify option then select Next.

Follow the steps in the installation process until you get to the Choose Plug-in for Microsoft Outlook
window.

ﬁ GoldMine - InstallShield Wizard

Choose Plug-in for Microsoft® Outlook®

LY
>

Select the program features you want installed.

Please select the plug-in to install with Goldmine for working with Microsoft@® Outlook®

@ GoldMine Link for Microsoft® Outlook®

O GoldMine Plus! for Microsoft@ Outlook®

O I don't wish to link emails using Microsoft® Outlook®

InstallShield

4. Select GoldMine Link for Microsoft Outlook then select the Next button
5. Follow the rest of the installation steps to install GoldMine Link for Microsoft Outlook.
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Setting Up GoldMine Link

Before GoldMine Link is ready for use, it must be completely configured so that Outlook can communicate
seamlessly with GoldMine.

As a GoldMine administrator, you can configure GoldMine Link using one of the following 2 methods:
Method 1: From Microsoft Outlook. Setting Up GoldMine Link From Microsoft Outlook

= This enables you to customize the set up of GoldMine Link for individual users on their workstations.
Method 2: From GoldMine Premium Edition Setting Up From GoldMine Premium Edition

= This enables you to specify configurations for all users in a single location so that users can easily get those
configurations when they set up GoldMine Link from their workstations.

= You can also specify whether users (without Master rights) have the ability to change the GoldMine Link
configuration.

IMPORTANT: When using an Exchange account with Microsoft Outlook, Cached Exchange Mode must be
turned on in Outlook. See the Microsoft Support article Turn on Cached Exchange Mode for information on
how to do this.

Setting Up GoldMine Link From Microsoft Outlook

After GoldMine Link for Microsoft Outlook has been installed, use the following steps to configure the settings:

1. Loginto GoldMine Premium Edition as the GoldMine user you want to use with GoldMine Link.

2. Open Microsoft Outlook. From the toolbar section, select GoldMine to go to the GoldMine toolbar.

File Home Send / Receive Folder View GoldMine
M o& ) B

o lco @ .) o U
Link Start/Stop = Settings Disconnect
Email Sync from GoldMine

Linking General
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3. From the GoldMine toolbar, select Settings to open the Settings window.

The window contains settings and configuration options for GoldMine Link.

Gielibiroll Lk foe Maressl® Cholice

Settings ﬁg Wisw sattings bor GoadMine® Link for Microsclt® Outiock®
Goraral
dars. =

AdMimer Lok St

a. If you are configuring GoldMine Link for the first time, select Start GoldMine & Read GoldMine Settings.
b. If you are re-configuring GoldMine Link, select Refresh GoldMine Settings.
This will read the settings for the user that is currently logged into GoldMine Premium Edition.

To Enable or Disable Automatic Linking

Automatic Linking links email messages automatically from your Outlook folders to GoldMine contacts. Automatic
Linking is not enabled by default. Use the following steps to set up or to disable Automatic Linking.

1. Select General from the Settings window.

Linking Exches ions | Eratie samans hriong shen lecerrg el
Syncheonzaton

About Emails

2. Specify if you want to automatically link received emails, sent emails, or both.

a. If Enable automatic linking when receiving emails is selected, GoldMine Link automatically tracks the
default Inbox folder.
If the email address of the sender matches the email address of a GoldMine contact, the message is
automatically linked to that contact.

b. If Enable automatic linking when sending emails is selected, GoldMine Link automatically tracks the
default Sent folder.
If the email address of the first recipient in the To field of the message matches the email address of a
GoldMine contact, the email message is automatically linked to that contact.
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Outlook Folders for Automatic Linking

If Automatic Linking is enabled, GoldMine Link monitors the default Inbox and/or Sent folders for email messages
to link. You can specify additional folders within Outlook that GoldMine Link should monitor for Automatic Linking.

To specify additional folders for GoldMine Link to monitor:

1. Select Outlook Folders from the Settings window.

CioldMane® Link for Mcroso® Ouliook®

Senngs 18 Soecty Outiook S &

Linking Exclusions
Spnchipazanion
Acut

Do i [mal] n grdentnstertiBigmal com

2. To add an Outlook folder for GoldMine Link to monitor.
a. Select a folder from the Your Outlook folders column.
b. Add it to the Folders for automatic linking column using the >> button.
c. If afolder contains sub-folders and you would like GoldMine Link to monitor those also, you must add

each sub-folder individually.
To remove a previously added folder:

1. Select the folder from the Folders for automatic linking column
2. Remove it using the << button.

NOTE: Outlook Folders are specific to individual workstations and are set up only for that workstation.

Linking Exclusions for Automatic Linking

When Automatic Linking is enabled, there may be certain email addresses that you would like GoldMine Link to
exclude during automatic linking. For example, email addresses from those who work in your company or mailing
list email addresses.

These email addresses can be excluded by adding them to the Linking Exclusions list.

NOTE: When GoldMine Link encounters an email address in the list, it will not link the email
message even though the email address matches an existing GoldMine contact.

You can still manually link an email message to a GoldMine contact even if the email address is in the Linking
Exclusions list.
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To Manage Linking Exclusions:

1. Select Linking Exclusions from the Settings window.

Gl Link for Mazsosolil Dok

|5¢"--‘m @ Ermail nddrusses 10 anchude when sussmatic lirking is enabied
Ganers: Specty the ermanl addnessen ko exthude wher sutomats lrkung i erabied fr recerved o sert emada, o Bot These ead
. toresses wil ot ba ke i Golsbdne
Outiook Folders
Nate: Inchviduat rmass can 884 be msnusity Sk 1o GokdMine 1 averwrite sy of hese axchussons
Symchroncation Exclubed Emal Addoasen
Arout Erter sl svemnes or emsd domasng in e gt ek bekow and melect Aot
Examplsa. *Jhon Smi@YeurCrmpary com’ or =@ YouaCompany o’ or spemameiE™
“Edgestusekly com
by watvonBmphacers; com
masernochresden b3t com
s ech g o
ra e

2. Inthe main input field, enter the email address or domain you wish to exclude during Automatic Linking, then
select Add to add it to the list.

You can use the * (asterisk) as a wild card. For example, *@yourCompany.comor mailer@*,

To Remove Email Addresses or Domains From Being Excluded:

1. Select the email address or domain from the list and click Remove.
This removes the selected item from the Linking Exclusions list.
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Setting Up From GoldMine Premium Edition

After installing GoldMine Link, log into GoldMine Premium Edition as a user with Master rights.

From the menu, select Tools > Configure > GoldMine Link Outlook Settings. This will open a window containing
the configuration options for GoldMine Link.

Actions Schedule

Synchronize

Automated Processes

Services

o ey

Databases

Data Management
Filters

Groups

SQL Query
Lookup Wizard
User Groups...
Users' Settings...

Configure

Complete Web Window Help

Custom Fields...

QuickStart Wizard...
Options

Logs

Custom Screens...

Record Types

Ré Relationships |

Outlook Integration Settings...

Company Resources...
License Manager...
Printer Setup...
System Settings
GoldMine Connect

GoldMine Link Outlook Settings...
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GoldMine Settings

Select the user for whom you want to configure GoldMine Link.

Setup GoldMine Link for Microsoft® Outlook® -|

Settngs | General | Linking Exchusions | Synchronizaton

GoldMine Link User Settings
GeldMine User JENNIFER, (Jennifer Watson) w
GokdMine Path: C:i'\Program Files (x36) GoldMine \gmw exe
Contact Set: GeldMinee:

] Aow wser to make changes to his/her own settings
Mote: Users with master right will always be able to make changes to hisjher settngs

In this tab, ensure that the correct values are populated in the GoldMine User, GoldMine Path, and Contact Set
fields for the user selected.

If you do not wish the user to make changes to any settings, ensure that the checkbox next to “Allow user to make
changes to his/her settings” is unchecked.

Enable/Disable Automatic Linking

Automatic Linking links email messages automatically from your Outlook folders to GoldMine contacts. Automatic
Linking is not enabled by default.

To enable or disable Automatic Linking, select the “General” tab.

= Specify if you wish automatic linking to track received and/or sent emails.

Set up GoldMine Link for Microsoft® Qutlook® -

Settngs | Gerersl | Linkng Exchasions | Symchvoniaton

Austomate Linking for JENNIFER
Enable sutomatic inking when recening emais.
Mote: Emads messages wil be Inked only if the emal address is found in GoldMine.

Enable autnmalc briong when serdng emals.
Hote: GoldMine: vl use the first emal address in the o™ field of the emal message to nk.
Emad messages will be linked only if the emal address is found in GoldMine,

ok | [ caned |

= If Enable automatic linking when receiving emails is selected, GoldMine Link will automatically track the
default Inbox folder.
O If the email address of the sender matches the email address of a GoldMine contact, the email message will
be linked automatically to that contact.
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= If Enable automatic linking when sending emails is selected, GoldMine Link will automatically track the default
Sent folder.

O If the email address of the first recipient in the “To” field of the message matches the email address of a
GoldMine contact, the email message will be linked automatically to that contact.

Linking Exclusions for Automatic Linking

When Automatic Linking is enabled, there may be certain email addresses which you would like GoldMine Link to

exclude from during automatic linking. For example, email addresses from those who work in your company or
mailing list email addresses.

These email addresses can be excluded by adding them to the Linking Exclusions list.

NOTE: When GoldMine Link encounters an email address in the list, it will not link the email
message even though the email address might match an existing GoldMine contact.

You can still manually link an email message to a GoldMine contact even if the email address of the message was
in the Linking Exclusions list.

To Manage Linking Exclusions:

1. Select Linking Exclusions from the Settings window.

Set up GoldMine Link for Microsoft® Outlook® -
Settngs | General | Likng Exdsens | Symchronization

Linking Exchusions for All Users

Speaify the emal sddresses or domans to excude whan sutcmatic nking is enabled. These emal address
well Nt bt bk to GoldMing.

Eriter & el sckdress o domain i the input Beld balow snd seiect the + buttsn t add. £.g.
“John.Semith §Your Campany.com” of ™ §YourCompanty.com” or Tmaker §™",

Changes are saved when email add: are added or removed.
T ——— + |
" Ggestweeky.com [ 1
TSdacvesty x]
jerrifer vwatson G om
mader fchoplyreaders-bot.com
no-reply @myshopsne. com
o [Ccmca |

2. Intheinput field, enter the email address or domain you wish to exclude during Automatic Linking, then

select the + button to add it to the list .

You can use the * (asterisk) as a wild card. For example, *@vyourCompany.comor mailer@*

To Remove Email Addresses or Domains From Being Excluded:

1. Select the email address or domain from the list and click X.
This removes the selected item from the Linking Exclusions list.

Once you have configured the GoldMine Link settings for a user, the user can now open Microsoft Outlook and
view these settings by following the steps in Setting Up GoldMine Link From Microsoft Outlook. If you have

disabled the user from making changes, the user can only view the settings. The user will not be able to make any
changes except for addingor removing Outlook Folders for Automatic Linking.

Adding GoldMine Address Book to Microsoft Outlook

Add the GoldMine Address Book so that you can send messages to GoldMine contacts directly from Microsoft
Outlook.
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To add the GoldMine Address Book, refer to the Microsoft Support article (Add or Remove an Address book) on
how to add an additional address book to Outlook.

NOTE: The GoldMine Address Book added to Outlook will correspond to the contact set that was
configured for use with GoldMine Link. This configured contact set can be found in the GoldMine
Link settings. See Setting Up GoldMine Link From Microsoft Outlook for more information.

Troubleshooting GoldMine Link

To troubleshoot issues with GoldMine Link, as a GoldMine administrator, you can access the log files for GoldMine
Link. The log files are created automatically and are usually located in the users ~\AppData\Roaming\ directory,
unless the directory has been changed or removed.

Typical location of the GoldMine Link log file:
C:\Users\<Username>\AppData\Roaming\GMOutlook\Logs\GoldMineLink.log

The log file GoTldMineL1ink. Tog contains the most recent data for most actions and errors encountered. The
maximum file size of this file is 10MB. Once the file size has reached 10MB, it is automatically archived and a
backup log file will be created using the following naming convention:

GoldMineLink.<x>.Tog. For example, GoldMineLink.1.Tog.

There will be a maximum of three(3) backup log files, in addition to GoldMineLink. Tog. (Backup file names are
GoldMinelLink.1.log, and GoldMinelLink.2.log). Each log file will have a maximum file size of 10MB.

For further assistance with troubleshooting GoldMine Link, contact GoldMine Support at
http://www.goldmine.com/goldmine-support/.
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Outlook Integration Administration

GoldMine’s integration with Microsoft’s Outlook adds the contact message-linking and history tracking features in
GoldMine's E-mail Center to Microsoft Outlook users. The installation also adds a GoldMine menu and toolbar to
Outlook’s main window and a GoldMine Navigation panel to the standard Outlook Navigation pane (see Outlook
Integration Administration).

NOTE: The GoldMine Outlook Integration must be configured before the integration is complete and ready
to use. For more information, see Setup GoldMine Outlook Integration.

NOTE: Exactly 1 concurrent license is used if you have GoldMine open and/or are connected to GoldMine
within Outlook.

This section covers the following Outlook Integration administration processes:

m Setting Up GoldMine Plus for Microsoft Outlook

m Add the GoldMine Address Book to Outlook

m Set Outlook as Default E-mail Application for GoldMine
m Troubleshooting GoldMine Plus! Outlook Integration

m Setting Up the GoldMine Outlook Synchronization

m Synchronizing Outlook and GoldMine Manually

m Displaying the Linked Contact Details in Outlook

m Setting the Contact/E-Mail Pane Display Options

m Set the Calendar Display Options

m Displaying the Linked Task Details in Outlook

Setup GoldMine Outlook Integration

GoldMine’s Outlook Integration is only available if you have included the GoldMine Plus! For Microsoft Outlook
components during installation.

TIP: If GoldMine Plus! For Microsoft Outlook was not included during installation, it can be
installed using the Add or Remove Programs control panel in Windows, and then selecting
Change for the GoldMine entry on the list. For more information, refer to the GoldMine
Installation Guide PDF.

When you open Microsoft Outlook after installing GoldMine and GoldMine Plus! For Microsoft Outlook, you must
complete the configuration between the two programs.

IMPORTANT: When using an Exchange environment with Outlook, Cached Exchange Mode must be enabled.
Performance issues will occur if a copy of the mailbox is not saved to your computer. See Microsoft Knowledge
Article Turn-on-or-off-Cached-Exchange-Mode or contact your IT or Exchange Administrator for more
information.
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m Setting Up GoldMine Plus for Microsoft Outlook
m Add the GoldMine Address Book to Outlook
m Set Outlook as Default E-mail Application for GoldMine

NOTE: If you have issues with performance or functionality after setup, refer to the Troubleshooting
GoldMine Plus! Outlook Integration topic.

Setting Up GoldMine Plus for Microsoft Outlook

The initial setup for GoldMine Plus! For Microsoft Outlook is a simple process of reading your GoldMine settings
and applying those settings to the Outlook Add-in.

To Setup GoldMine Plus

1. Open the GoldMine menu and select Setup GoldMine Plus or click the button on the GoldMine toolbar in
Outlook.

The Setup GoldMine Plus for Microsoft Outlook dialog box displays.
Click the GoldMine Setup tab.
Click the Read GoldMine Settings button.

Check the other tabs to ensure that the settings were properly read and applied. Additional changes can also
be made on the various tabs on the Setup GoldMine Plus for Microsoft Outlook dialog box.

NOTE: If you want to restrict the current user from making changes to their settings, uncheck the Allow
user to make changes to his/her settings option on the GoldMine Setup tab.

Add the GoldMine Address Book to Outlook

When sending a messages from Outlook, you can select Contacts and Contact groups from the GoldMine Address
Book. You must add the GoldMine Address Book before you can use it in Outlook.

NOTE: The address book uses the same information gathered by the Outlook link when the user clicked on
the Read GoldMine Settings button. For more information, see Setting Up GoldMine Plus for Microsoft
Outlook.

Note About VCards and GoldMine Contacts

A VCard (. vcf file) contains basic contact information similar to the entries made in your Personal tab or other
information you enter outside of GoldMine. The details on the VCard originate from your registration information.

If the receiving system has VCard capabilities, the system will decipher the . vcf file to import this information. If
the recipient uses GoldMine to retrieve e-mail, GoldMine can use your VCard information to create a contact
record if no existing contact record is detected.

The following fields are used in GoldMine when using address information for the VCard (. vcf file):

O Mailing Address = Address1 (street address) + Address2 (suite/room number)
O Home Street Address = Address1

For more information about these fields, refer to Contact Management in the GoldMine User's Guide.

GoldMine Administrator's Guide Page 409 of 439



GoldMine™®

To Add the GoldMine Address Book to Outlook 2007
1. In Outlook, open the Tools menu and select Account Settings.
Select the Address Books tab.
Click the New icon from the toolbar. The Add New E-mail Account dialog appears.
Select Additional Address Books, and then click Next. The Other Address Book Types page appears.
Select GoldMine Address Book from the list and then click Next. The GoldMine Integration Services for
Microsoft Outlook dialog appears.
O Verify or enter the path to the GoldMine application on your hard drive.
O Enter your User ID and Password.
O Verify or Browse to select the Contact Set for Outlook to access.
When finished, click OK.

A message appears:

ik wNnN

"Any changes made will take effect next time Outlook is run."
Click OK to continue.
A message appears:

"The E-mail Account you have just added will not start until you choose Exit from the File menu, and then
restart Microsoft Office Outlook."

10. Click OK to continue.
11. A message appears:

"Congratulations! You have successfully entered all the information required to setup your account. To
close the wizard, click Finish."

12. Click Finish to close the Account Settings.

To Add the GoldMine Address Book to Outlook 2010

In Outlook, click the File tab.

Click Account Settings button and then select the Account Settings option.
On the Account Settings dialog box, click the Address Books tab.

Click the New button. The Add New Account dialog box opens.

Select the Additional Address Books option and then click Next.

Select GoldMine Address Book from the list and then click Next.

Ny ks wDNRE

A message appears:

“You must restart Outlook for these changes to take effect”

%

Click OK to close this message.
Click Finish to close the Account Settings and restart Outlook to apply your changes.

Set Outlook as Default E-mail Application for GoldMine

To fully integrate Outlook with GoldMine, you can set Outlook as the default e-mail application. After you make
this change, any e-mail address link that you click will open Outlook to compose a new e-mail message.

To Open Outlook when Clicking E-mail Address Links in GoldMine

1. In GoldMine, open the Tools menu and select Options.
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On the <User’s> Options dialog box, click the E-mail tab.
Under the Getting Mail area, check the Use Outlook for linked E-Mail Addresses option.
Click OK to save the settings and close the dialog box.

ik wN

Click any e-mail address link to ensure that the link now opens using Outlook.

NOTE: If your e-mail account has an HTML Signature file, it will not display properly when sending e-mail
from a GoldMine through Outlook to send linked emails from GoldMine.

Displaying the Linked Contact Details in Outlook

When a message is linked to a GoldMine Contact, the GoldMine Panel is populated with Contact Information and
Items for the linked contact.

To Modify the Display of Contact Information
1. Click the Setup GoldMine Plus button.
2. Click the Contact Pane tab.

@ Setup GoldMine Plus for Microseft Outiook

GoldMine Selup | Options | Outlook Folders  Conlact Pare Ii'-uik Pane | GoldMine Fiekds | Linking Exchusions | §ynchronization |

The contact pane piovides a summay of GoldMine contact information: when vievang an E-mad or contact i Outlock.  Choose the helds and lapost bo
be shown in thiz pane.

E ezl Audkeess F A i e — U=
Vb Sie l & EEX A2 B 7 U
Addrazs] Companyy - ¢Contacts

Addrass? cAddessls

Addiess3 <Addegsds

City ciddiess

Coenpany «Cityer, < Skabes, (Fipo

Contact

Courtiy > | | Emstages
Craaheal « Pl 1>
Createby Save I

Craatean

Do Hesot

Depantment

Extl

Ewt2

GoldMine User. |USER <20 | Closs

O The panel on the left shows the available contact fields that you can add to the Contact Information panel
in Outlook.

O The panel on the right shows the layout of the contact information details as the display in the Contact
Information panel in Outlook when viewing an E-mail or Contact. You can use the formatting tools at the
top of this panel to adjust the color, alighment, and character styles of the display text.

3. Select the area where you want the field to be placed in the right panel.
NOTE: Where ever the blinking cursor is in the right panel is where the new field will appear.

4. Click the field in the left panel, then click the Arrow button to add the field.
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5. At the bottom of the Contact Pane tab, select the user that this change will affect. If this change should be for
all users, select All users from the list.

6. When you are satisfied with the layout, click the Save button to save your changes.

Troubleshooting GoldMine Plus! Outlook Integration

If necessary, Administrators can create log files that can help diagnose issues with application functionality or
performance of GoldMine’s integration with Outlook. Ivanti Support Services might request that these files be
created for troubleshooting purposes.

m GMOutlookLog. txt is a trace of the interactions between Outlook and GoldMine

= GMOutlookSpeed. txt shows the computing time of individual operations within the Outlook integration.
These files are not created by default. You must create each of these file manually in the

C:\Programbata\Goldmine directory. After creating these files, GoldMine will automatically populated the files;
no user action is required.

NOTE: If you have installed GoldMine to a different directory that the default C:\, you will need to create
the C:\Programbata\GoldMine and then create the GMOutlookLog. txt and GMOutlookSpeed. txt
files within that directory.

IMPORTANT: It is recommended that these files be deleted after the information for troubleshooting has been
collected. Otherwise, Outlook integration performance could be negatively affected.

For more information, contact Support at https://community.ivanti.com/community/heat-software/goldmine.

Synchronization

The Synchronization ability in Outlook updates your Outlook Contacts, Calendar, and Tasks with information from
GoldMine. You can set when the data from GoldMine is synchronized with Outlook or perform the synchronization
manually (data synchronization from Outlook to GoldMine occurs immediately).

NOTE: Outlook Integration does not support recurring or multiple-attendee Tasks created in Outlook when
synchronizing with GoldMine. Only one instance of the task is created and linked to the Contact, but only if
the Contact was selected in the Outlook Contacts field.

IMPORTANT: Outlook synchronization works only with local folders.

m Setting Up the GoldMine Outlook Synchronization
m Synchronizing Outlook and GoldMine Manually

Setting Up the GoldMine Outlook Synchronization

In Outlook, open the GoldMine menu and select Setup GoldMine Plus. Then, click the Synchronization tab to view
the following options:
m Set up Standard Configuration for Outlook Sync
(see To Set Up Standard Configuration for Outlook Sync)
= Set up Outlook synchronization for <UserName>

(see To Set Up Outlook Synchronization for a User)
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= Start GoldMine Sync when starting Outlook option
(see To Start GoldMine Sync When Starting Outlook)

To Set Up Standard Configuration for Outlook Sync
1. On the Synchronization tab, click the Set up Standard Configuration for Outlook Sync.

A message box appears.

\ ? J‘ The standard configuration For Ouklook sync must be created, Do you wank ko set i up ak this time?

i es I | Mo I

2. Click Yes to start the Standard Configuration for Outlook Sync Wizard.

x)

Standard Configuration for Outlook Sync

Welcome to the standard configuration
for Outlook sync!

This wizard will help you to configure Outlook synchronization
options for all GoldMine users.

By defaulk, every Outlook ussrname profile will inherit and
obey the synchronization options set For the skandard
configuration.

An administrakor may manually override the inherited
skandard options For each GoldMine user, For cuskom
synichronizakion configurakion.

Descriptive name

GoldMine

Back [ Mext = I[ Cancel
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3. Enter a descriptive name for the Group and then click Next.

Standard Configuration for Quilook Sync: Synchronization Options FZJ

Please seleck the options For transferring GoldMine records ko
Outlook.

Synchronize contacts from GoldMine to Outlook
Synchronize contacks from Outlaok bo GoldMine
[¥] synchronize calendar items from GoldMine ko Outlook
Synchronize calendar ikems from Quklook b Goldiine

[ Advanced. .. ]

Logaing Options
[]Log the details of each synchronizakion session

[[]Log the transFer set details For the records retrieved

[ < Back “ Mext = ][ Cancel

4. Select from the Synchronization options and Log Options.
NOTE: Any un-timed (no start/finish time) activities in GoldMine are synchronized to the current time.

5. Click the Advanced button to modify General, Deletions, Field Mapping, Contacts, Calendar, and Task tab
options (see Configuring the Advanced Options).
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Advanced Options

General I.De{atinm | Field Mapping | Contacts | Ealsndal.__ Tazk |

Phone extenzion separator;

todification tolerance in seconds [the ikem
iz conzidered not changed if the |ast
modification time in Qutlook ws. GM within
this lirnit]

0 Do not check duplicate activities by Outlook, id
nurnber

[T] 5vnchionize FSYP
[T Usze categories for activities in Outiook

[ Reset Auto-Temitory Realignment feature
Check thiz OMLY if you do nat want ta inchide
filkered records previously stored in the last
synchronization sezsion with the curent transfer set.

X

| ok

J|

Cancel

6. Click OK to close the Advanced Options dialog box.

7. Click Next to set the Synchronization Intervals.
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Synchronize automatically when Outlook is open

Please specify the sync inkervals which GaldMing will process
the group's members, In case of synchronization
errors/falures, please specify the ‘retry’ intervals, as well,

Sync Interval: 00:00:15 [3

Retry Interval: 00:00:02 E]

Mumber of retries before =
skipping the session: S v

Scan Outlook records once every | g & | sessions.

[ < Back ][ Mext = l[ Cancel

O You can click the ellipse buttons (...) to set the Sync Interval and Retry Interval when synchronizing.

IMPORTANT: Setting the Interval to a shorter rate might create performance issues on the workstation.

O Change the Number of retries before skipping the session value to set how many synchronization
attempts are made before skipping the synchronization.
O Set the Scan Outlook records once every [x] sessions to determine after how many sessions data is
synchronized from Outlook to GoldMine.
For Example: If you synchronize data from GoldMine to Outlook every hour, a value of 10 would sync

data from Outlook to GoldMine ever 10 hours. This value is set to 10 by default as the scanning of

Outlook is a lengthy operation and most activities go from GoldMine to Outlook.

8. Click Next and then Finish to complete the Standard Configuration for Outlook Sync Wizard.

NOTE: If you have not setup any User Profiles, the Outlook Username Profile Wizard opens (see To Set Up
Outlook Synchronization for a User).

Configuring the Advanced Options

The Advanced Options dialog box displays when you click the Advanced button when configuring Outlook
synchronization (see To Set Up Standard Configuration for Outlook Sync and To Set Up Outlook Synchronization

for a User).

The Advanced Options dialog box contains several tabs for individual configuration of the synchronization process:

= General: Define the telephone extension separator, record modification tolerance, duplicate activity checking

by Outlook ID number, synchronizing RSVP, and using categories for activities in Outlook

NOTE: You can change the information displayed in the Outlook activity Subject line of a retrieved
GoldMine activity by editing the Goldsync.ini file (see Adding Macros to the GoldSync.ini File).

= Deletions: Define how deletions synchronize between GoldMine and Outlook.

= Field Mapping: Define mapped fields so GoldMine can place data in the corresponding Outlook fields.
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IMPORTANT: If you choose to use a different folder than the default option in the Folder selection area on the
Contacts, Calendar, or Task tabs, it is required to define that custom folder path at the system where the
profile will be used.

m Contacts: Specify the location of the Outlook folder in which GoldMine sends and retrieves contact information.
= Calendar: Specify the Outlook folder in which GoldMine sends and retrieves activity information.

m Tasks: Specify the Outlook folder in which GoldMine sends and retrieves.

To Set Up Outlook Synchronization for a User

1. On the Synchronization tab, click the Set up Outlook synchronization for <UserName> to start the Outlook
Username Profile Wizard.

Qutlook Username Profile FZJ

Welcome to the Outlook Username
Profile Wizard!

This wizard will help you set up Outlook synchronization For
the user USER ().

GoldMine User: USER. ()

To begin, please enter a descriptive name for this profile,

Usemamel

allowe this user ko synchronize

Ba [ Mlexk = ] [ Cancel
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2. Enter a descriptive name for the user profile and select whether or not to allow this user to synchronize. Click
Next to continue.

Qutlook Username Profile; Overrides Options FZJ

Cutlook synchronizakion For Ehis user will be set up using the
skandard configuration for Outlook sync.,

IF it is necessary bo override the standard configuration For this
user, check the boxes below corresponding to any areas where
settings need to be changed for the current user,

= D Synchronization Options
[ Basic synchronization options
[ advanced options
[ Logging options
= Intervals and synchronization frequency
[ automatic and manual synchronization
[ 5uccessful synchronization session inkeryal
[ Failed synchronization session inkeryal
[ Humber of retries before Failing the sync session

[ < Back “ Mext = l[ Cancel

O Selecting any of the Synchronizations Options check boxes will display the Synchronization Options dialog
box (see To Set Up Standard Configuration for Outlook Sync).
- Basic synchronization options will enable options to sync contacts and/or calendar from GoldMine
and/or Outlook to GoldMine and/or Outlook.
- Advanced options will enable the Advanced button on the Outlook Username Profile: Synchronization
Options dialog box (see Configuring the Advanced Options).
- Logging options will enable the Logging Options check boxes on the Outlook Username Profile:
Synchronization Options dialog box.
O Selecting any of the Intervals and synchronization frequency options check boxes will display the
Synchronization Intervals dialog box (see To Set Up Standard Configuration for Outlook Sync).
3. Outlook synchronization uses standard configuration. If you need to make changes, check the boxes for the
areas that need changed for the current user, and then click Next.
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Qutlook Username Profile: Record Selections
Specify which Outlook records you wish to send bo GoldMine,
&ll Outlook records changed since cukoff
Cutoff |3f11/2010 | [ 1:33pm |
[]1grore last synchronized dake
Specify which GoldMine records wou wish to send to Outlook,
&ll GoldMine records changed since cukaff
Cutoff [3j11j2010 | [ 1:33pm |»

@Fiker: [y AL Contact Records! v
(_",‘l Group:
Also include contacts wikh calendar activities From:

112010 | o sy e
Omik records previously retrieved From Outlook,

[ < Back “ Mext = I[ Cancel

4. Specify the GoldMine contact records and Outlook records to sync by cutoff date. Click Next to continue.

QOutlook Username Profile: User's Calendar Selection FZJ

Please specify which user's calendar records you wish ko send ko
Cutlook.

Calendar Recards to Send

() USER's Calendar

© thers Calender
W ADMIMIST ()
¥ ASPMET (ASP.MET Machine Acco
V¥ GLUEST {}
[+ HELP&SSI (Remote Deskiop Help
[+ MASTER (FronktRange Solutions |
[+ SUPPORT_ (CH=Microsaft Corpc
W LSER )

[ < Back “ Mext = I[ Cancel

5. Select which calendars to synch with Outlook. Click Next to continue.
6. If needed, change the default date/time for the next scheduled sync, then click Next.
7. Click Finish to apply the changes and close the wizard.
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To Start GoldMine Sync When Starting Outlook

The Start GoldMine Sync when starting Outlook option on the Synchronization tab allows you to set how Outlook
synchronizes to GoldMine. By checking this option, Outlook will synchronize with GoldMine every time Outlook is
launched. If this option is not checked, you must synchronize manually with GoldMine (see Synchronizing Outlook
and GoldMine Manually).

Synchronizing Outlook and GoldMine Manually

By default, Outlook is set to synchronize automatically. However, if you’ve disabled this option (see To Start
GoldMine Sync When Starting Outlook) or have made a change that hasn’t synchronized yet, you can start the
synchronization process manually. Open the GoldMine menu and select Start/Stop Synchronization.

NOTE: GoldMine must be running to synchronize the database with Outlook.

Outlook Mail

m Matching Outlook Contacts Automatically to GoldMine Contacts
m Auto-Linking Outlook Messages

m Defining Outlook Folders for Auto-Linking

m Displaying the Linked Contact Details in Outlook

m Setting the Contact/E-Mail Pane Display Options

Matching Outlook Contacts Automatically to GoldMine
Contacts

By default, when a user selects a contact in Outlook, GoldMine Outlook Integration attempt to match the Outlook
contact with a GoldMine contact. The contact matching is done by e-mail address (in order: email address #1,
email address #2, and email address #3) until one or more matching contacts are found in GoldMine.

In the event that there are multiple matching contacts in GoldMine, GoldMine Outlook Integration displays a
dialog in which the user can select the desired matching GoldMine contact to link to the Outlook contact. When
there is only one match, this option causes the linking to automatically occur. When the option is not checked, the
Outlook contacts are not linked to GoldMine contacts.

IMPORTANT: This option does not “link” the Outlook contact to the GoldMine contact (i.e., it does not save

GoldMine data to the Outlook contact). Linking is achieved when the user clicks the Send data to GM button.
To Automatically Link Contacts

1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.

2. Click the Options tab.

3. Inthe General section, select the Link contact when the address matches single GM contact option.

4. Click Close to apply the changes and close the dialog box.
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Auto-Linking Outlook Messages

Auto-linking links messages automatically from senders in your Outlook mailbox to Contacts in your GoldMine
database. By default, messages are not set to link automatically to Contact records. If you want to set up auto-
linking, follow the procedure below.

TIP: You can link multiple messages to a Contact by pressing the Ctrl key on the keyboard and
then selecting multiple messages.

To Setup Auto-Linking of Messages to Contact Records
1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.
2. Click the Options tab.

3. Inthe GoldMine Auto-Linking and Attachments section, use the following options to set up how you want
the auto-linking feature to work.
O Enable Auto-Linking when sending E-Mail enables the drop-down list for To Sender or To First Recipient.

This option is for automatically linking of messages when the recipient/sender is one of your GoldMine
Contacts. Checking this option enables the following options:

- Prompt if E-mail address is not on file when Auto-Linking sent E-Mail.
- Save a copy of outgoing attachments.

O Enable Auto-Linking when receiving E-Mail enables the drop-down list for To Sender or To First Recipient.
This option is for automatically linking of messages when the sender/recipient is one of your GoldMine
Contacts. Checking this option enables the following options:

- Enable auto-linking for messages previously read in other e-mail clients.
- Prompt if E-Mail address is not on file when Auto-Linking received E-Mail.

O Do not prompt me to handle file names that already exist.

This option allows you to send attachments with the same name without having to click OK on the
overwrite warning dialog box for a file that already exists. This is especially useful for files such as a
signature GIF or other files that are sent repetitively.

With this option checked, retrieved attachments are processed using the attachment handling settings
configured in the user's GoldMine e-mail preferences. For more information, refer to To Set E-mail
Options on the Advanced Tab.

With this option checked, retrieved attachments are processed using the attachment handling settings
configured in the user's GoldMine e-mail preferences. For more information, refer to "To Set E-mail
Options on the Advanced Tab" in the GoldMine Administrator Guide or in the Online Help.

4. Click Close to apply the changes and close the dialog box.

To Set How the E-Mail is Linked to a Contact
1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.
2. Click the Options tab and, in the GoldMine E-Mail Center section, select one of the following options:
O As a pending activity in the E-Mail inbox folder
O As a completed activity in the filed E-Mail folder
3. Click Close to apply the changes.
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To Setup Linking Exclusions

When linking multiple messages to GoldMine, there might be certain e-mail address that you do not want to
include, such as anyone from your company or spam e-mail. You can add these e-mail addresses to the Linking
Exclusions list, which prevents them from being linked to GoldMine. Manual linking of single messages can still be

performed.

1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.

2. Click the Linking Exclusions tab.

3. Enter the e-mail address you want to exclude on the E-mail Address text box.

4. Click the Add to List button to add this address to the Linking Exclusions list.
The asterisk (*) can be used as a wild card; you can add whole domains by using the *@domain format, such
as *@ivanti.com.
You can also add beginning of addresses by using the name@* format, such as spam@* or info@*.

5. Click the Save button to save the list.

You can update this list any time by adding more entries or removing entries that you no longer want to block.

Defining Outlook Folders for Auto-Linking

If you select the options for auto-linking of sending/receiving messages (see Auto-Linking Outlook Messages),
GoldMine watches those folders only in the Personal Folders area. If you use an IMAP connection or have multiple
inboxes that you want GoldMine to track for auto-linking, you can define those folders on the Outlook Folders tab.

NOTE: The folders selected are specific to the individual computer and must be set up individually for each
computer using auto-linking.

To Define the Watched Folders for Auto-Linking

1.

ik wNwN

NOTE

Open the GoldMine menu and select Setup GoldMine Plus or click the button on the GoldMine toolbar in
Outlook.

On the Setup GoldMine Plus for Microsoft Outlook dialog box displays, click the Outlook Folders tab.
Expand the e-mail account tree in the Your Outlook Folders area to view all folders.

Select the desired folder to watch.

Click the Add button to move it to the Folders Tracked for Auto-Linking area.

Repeat the previous step for additional folders to watch.

: If the folder you want to watch has sub-folders that you also want to watch, you must select and add

each sub-folder as well.

6.

Click Close to save your changes.

Setting the Contact/E-Mail Pane Display Options

By default, an e-mail message that is linked to a GoldMine Contact displays the following tabs below the Contact
Information in the GoldMine Panel.

Cases Projecks Opportunities Mokes: Sales

Each tab has commands associated with selected tab, such as Create and Refresh.

GoldMine Administrator's Guide
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To Modify the Contact/E-Mail Panel Tabs

If you want to hide any of these tabs on the GoldMine Panel, follow the steps below.

P W N

In Outlook, open the GoldMine menu and select Setup GoldMine Plus.

Click the Options tab.

Under the Contact/E-Mail Pane section, uncheck the box for any tab you want to hide.
Click Close to apply your changes.

Outlook Calendar

Set the Calendar Display Options

The Outlook Calendar’s GoldMine Panel can display information related to the selected Item, as well as Pending
Sales, Literature Requests, Contact Data, GoldMine Users and Resources, and GoldMine Preview for details for the
appointment. You can determine which of these item is displayed in GoldMine panel by modifying the display
options.

To Modify the Display Options

1.
2.
3.

In Outlook, open the GoldMine menu and select Setup GoldMine Plus.

Click the Options tab.

In the Calendar Pane section, make selections from the following options to determine which items display in
the GoldMine panel on the Calendar pane:

O Show Forecasted Sales

O Show Scheduled Literature Requests

O Hyperlink to GoldMine Calendar

O Hyperlink to GoldMine Activity List

Click Close to apply the changes.

Outlook Tasks

Displaying the Linked Task Details in Outlook

When a task is linked to a GoldMine task, the GoldMine Panel is populated with Task Information and Items for
the linked task. You can select what information and how it is displayed by modifying the Task information display.

To Modify the Display of Task Information

1.
2.
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Click the Setup GoldMine Plus button.
Click the Task Pane tab.
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2 Setup GoldMine Plus for Microseft Outlook

GoldMine Setup | Options | Outlook Folders | Contact Pane  Task Pans | GoldMine Fiekds | Linking Exclusions | Synehronization |
The task pané providés & summans of GoldMing riaimation when viswng bnked task in Ouliook. Choose the hedds and kot to be shown n this pane

Tk Tite - A G E = =2 B I ] |2
Prioeity W E =S U | &
Ttk Notas <Task Title>

a‘n:;ld:m Priority: =Priority>

Addrezz] <Cornpary> <Contack

Addiss2 :::2:;951;“

Address3

Ciy = | <Afdrass2>

Compary <Addressir

Coeact Seve I «Citys, «Statex «Zip=
g

Createat Flerst I <Country>

Createb

C:U.!oll; <Ernall Addrasss

Doy

Oiepartment

Extl

Ext2

Ewtd

Ewtd

Fax

eyl

Fayi2

Feyd

Eepd -

GoldMine User. [USER <<user> -] Cloa

O The panel on the left shows the available fields that you can add to the Task Information panel in Outlook.

O The panel on the right shows the layout of the task information details as the display in the Task
Information panel in Outlook when viewing a task. You can use the formatting tools at the top of this
panel to adjust the color, alignment, and character styles of the display text.

3. Select the area that you want the field in the right panel.
Note that where ever the blinking cursor is in the right panel is where the new field will appear.
Click the field in the left panel, then click the Arrow button to add the field.

5. At the bottom of the Task Pane tab, select the user that this change will affect. If this change should be for all
users, select All users from the list.

6. When you are satisfied with the layout, click the Save button to save your changes.
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Licensing

GoldMine has a fully-scalable licensing structure to meet the needs of individuals and organizations. As your
business matures and GoldMine expands, your organization can change the licensing configurations.

Select from the following topics to learn more about Licensing in GoldMine.

= About GoldMine Licenses

m Using the License Manager

m About Sub-licenses

m Creating Site Licenses

m Creating an Undocked User License
m Creating GoldSync Licenses

m Removing Licenses

About GoldMine Licenses

The single, distributed Master License serves as the authentication mechanism for secure synchronization across
the entire organization, and the License Manager keeps track of your licensing configurations.

Most organizations generally buy one license—a Master License with X number of seats. These seats can then be
assigned to users in various combinations of sub-licenses. For example, an organization can create Site sub-
licenses for their remote office(s) and Undocked sub-licenses for individual remot (mobile) users. One seat should
always be set aside for administrators.

NOTE: When using Outlook Integration with GoldMine, exactly 1 concurrent license is used if you have
GoldMine open and/or are connected to GoldMine within Outlook.

GoldMine Web does not require a separate license; a GoldMine Premium concurrent license is used by each Web
session.

Each login uses licenses as described below:

m Users can log in to GoldMine Premium Edition and GoldMine Web concurrently. However, this is not
recommended practice and will use 2 licenses.

= GoldMine Web:
GoldMine Web is available to all users and each login uses a concurrent GoldMine Premium license per
session. You cannot be logged into to GoldMine Web from 2 different browsers or 2 different machines. The

second login will automatically log out the first session. Users are automatically logged out of the GoldMine
Web after 30 minutes of inactivity and the license is released.

License Types

Master License. This is the primary license (see Master License). It determines what database types are supported
by the master site as well as its synchronization capabilities. It is a precursor to executing any sub-licenses which
stem from it.

GoldSync licenses are issued concurrent with the E license.
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The licensing serial number schema for Master licenses has been changed for the 7.0.4 release, but remains the
same for sub-licenses. See License Serial Number.

Sub-licenses. To issue one of these, install GoldMine with a Master License on your organization’s primary
network. This ensures all sub-licenses maintain security and are authenticated properly during synchronization.

The Undocked license (a special sub-license) is for remote users and can only be licensed for a single user. It can be
sub-licensed from the main GoldMine system or from a Site sub-license.

Increases: Previous increases for Corporate Edition, Standard Edition, and GoldSync (J, R, and N), are now
facilitated by obtaining a new E or G license (which account for the increase and the Master license count).

Symbol Product Description
Master Licenses
GoldMine Corporate Edition
E GoldMine Premium Edition License Supports SQL Server. Includes GoldSync.
G GoldSync License GoldSync sea?t purchased separately and can be
added to E-Licenses.
Sublicenses
U Single sub-license for a remote GoldMine user.
S Multiple-user sub-license for a remote office.
Y GoldSync sub-license for a remote office.

License Serial Number

License HDA
type Number
E-002594-123456-1A2B3C4D5E6F7G8-9H12)J3K4L5M6NF7
LIl | \ J | | | |
Number I—|:‘Version Serial Number Key code
of users

= License type: Alpha-prefix denotes the type of Master license.

= Number of users: First 4 numbers indicate the license count or seats available in the license. The license count
determines the number of users who can log on to GoldMine at one time but does not limit the total number
of named users.

= Version: A 2-digit version number.

= HDA number: A unique 6-digit customer account number, also referred to as the Help Desk Authorization
(HDA) Account.

= Serial number: 15-character (alphanumeric) serial number uniquely identifying the license for an organization.
It is used for registration and support and identifies all sub-licenses as part of the same organization.
Collected in 3 groups of 5 characters during licensing.
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= Key code: 15-character (alphanumeric) key code is a computer-generated check used by GoldMine to verify the
license’s validity. Collected in 3 groups of 5 characters during licensing.

NOTE: The key code is required during installation. Keep the license number and key code in a safe place in
the event it becomes necessary to reinstall the software.

License Manager

Initial licensing information is collected during installation. Subsequent changes and related management
functions are handled through the License Manager.

From the GoldMine Tools menu, select Configure > License Manager.

The central text box lists all installed licenses and any sub-licenses created from this location. Status is displayed
along the right side. Buttons along the bottom allow you to add a New License, add a New Site, add an Undocked
User, Remove License, or View License.

The database support of the Master License is inherited by the site sub-licenses distributed throughout the
organization. GoldSync Synchronization capabilities can be distributed separately to sub-licenses.

NOTE: Licensing information is stored in the license file, Licensegm.bin, created at the time you register.
This file must exist only in the GoldMine root directory of each GoldMine installation.

Master License

New Licenses are required for the 2014.2 release of GoldMine Premium Edition.
= A GoldMine Premium Edition 9 Master License begins with the alpha-prefix of E, G, or M (Example: E-0050xx
where xx is the 2-digit GoldMine version number).

m The E-license is usually a multi-user license for a server installation of GoldMine but can be a single-user license
for a stand-alone computer.

m An E-license includes a GoldSync license for each purchased GoldMine seat.

= Remote site sub-licenses (S- and Y-licenses) and Undocked sub-licenses (U-licenses) are created from the E-
license.

= Type the E-license number and key code you received when you purchased the software.

= If you type an E-license serial number into the text boxes, the GoldSync text box area remains unavailable
because GoldSync is included. Type your G-license information at that time, or later using License Manager.
You do not need to type the G-License number to proceed with licensing GoldMine.

Using the License Manager

Purchase GoldMine with a Master License serial number to provide maximum flexibility for an organization in
controlling the data integrity and security for each user.

Example:
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Purchase a 50-user GoldMine license and a 50-user GoldSync license. Install once on the network. Then, create
two 10-user sublicenses for the 2 branch offices from the Master License. Create GoldSync sublicenses for the 2
branch offices. Then, create undocked sublicenses for the notebook PCs of undocked users. Each license created
from the Master License shares the same GoldMine serial number to provide authentication, ensuring secure
remote synchronization throughout the organization.

Select Tools > Configure > License Manager. The GoldMine License Manager dialog box appears.

NOTE: Also display License Manager from the Undocked Users/Sites dialog box of the GoldSync Site Wizard.
Select Undock Users/Create Sub-License.

License
= Total users/dist: Total available GoldMine E Licenses and the number of licenses distributed (S or U).
= GoldSync Sites: Total number of GoldSync G-Licenses and the number of licenses already distributed (Y).

= Authentication: The code randomly generated upon installation and used by GoldMine to verify sublicenses
were created from the same Master License during synchronization. Reinstalling the Master License
generates a new authentication number and renders all sublicenses incompatible.

= Databases: Database types supported by the current license (SQL Server).

Distributed Licenses
Undocked Users: Number of Undocked license numbers created.
Remote Users/loc: Remote users and total number of sites where these users are distributed.
GoldSync Sites/loc: GoldSync sublicenses and the number of sites for these licenses.

NOTE: A maximum of 16 licenses can be combined within the License Manager.

Tasks Performed Using License Manager

Create New Site sublicenses for branch offices

Creating Site Li
(Master Rights required) reating ofte ticenses

Create Undocked User licenses for remote users

Creati Undocked User Li
working offsite (Master Rights required) reating ah Lndocked User Hcense

Remove a license (Master Right required). Removing Licenses

For more information see the GoldMine Connect

Install GoldMi Local Workstati
nstall Goldviine on Local YWorkstation Installation Guide PDF.

About Sub-licenses

With multiple offices and users, create sub-licenses for each site or user from the Master License. A site sub-
license installs that license on only one remote server. An undocked user sublicense installs that license on one
remote computer. However, you can create multiple site licenses and undocked licenses up to the maximum
permitted by the Master License.
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Site License

A Site License is a multiple-user sub-license for a remote office and is designated with the alpha-prefix S. Have an
S-license for each user at the remote site.

= When creating any sublicense, note the entire license number created by GoldMine. The sub-license includes
additional information needed when typing the license number on the remote computer and displays in its
entirety during the creation process.

m A GoldSync License (Y-license) is required only if you are using an S-license and want to synchronize using
GoldSync. You should have one Y-license to synchronize with the Master License and additional Y-licenses for
Undocked users synchronizing with your site.

m Y licenses are not entered in the Enter GoldMine Serial Number dialog box. Only S licenses are entered during
registration (the GoldSync Section remains disabled). Clicking Next displays an ALERT: Suggested Action(s)! if
you attempt to enter Y licenses in the Enter GoldMine Serial Number dialog box.

m If this installation of GoldMine includes its own GoldSync sites, you enter the applicable Y-type sub-licenses to
properly configure synchronization for this system.

TIP: Highlight the complete serial number in GoldMine, copy it (CTRL+C) and paste it
(CTRL+V) into Notepad.

License

Undocked licenses are sub-licenses created from a Master License or a Site license and are designated by the letter
“U.” This license type is created for users who work with GoldMine at another location, on a laptop, or on a
workstation disconnected from the server copy of GoldMine. Type the U-license, Key Code, and Site Code created
in the License Manager.

Creating Site Licenses

1. Select Tools > Configure > License Manager.

The GoldMine License Manager dialog box opens.
2. Select the Licenses tab and click New Site.

The Create a Site License dialog box opens.

3. At the Distributed License Type area, select GoldMine Site License. Instructions for creating the GoldSync
License follow.

4. Type the Site Name. The name of the site should have no more than 12 characters and spaces, such as Los
Angeles.

5. Type the Number of Users who will need seats at the site. This will be the total number of users included in
the sublicense.

6. Click Create Site Sub-License. The Sub-License for Remote Site [site name] dialog box appears. Select | AGREE
if you accept the licensing terms.
7. GoldMine displays the new sublicense for the remote site, beginning with the letter S, in the field at the

bottom of the dialog box. Make a copy of this number; you need it when licensing the site. When finished,
select Close.
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NOTE

: 1 A unique sublicense number is needed for each remote computer installation. Send the remote site

number to the remote location. The GoldMine administrator at the remote site can then type the license
number during the GoldMine installation.

8.

To complete the process, click OK in the Create a Site License dialog box.

GoldMine adds the sublicense to the Licenses tab browse window under previously installed license(s). The
first character of a site sublicense serial number is S.

To synchronize between the remote site and the Master License site, you need at least one GoldSync License.

To Increase or Decrease Site Sublicenses

Site number of sublicenses can be increased or decreased by using the following procedure:

1.
2.
3.
4.

NOTE

Verify/reset synchronization.

Delete the Site sublicense in the License Manager on the main GoldMine system (see Removing Licenses).
Create a new license with the necessary number of seats and GoldSync sublicenses (Y-Licenses).
Re-license the remote site with the new sublicense.

: Sites are allowed to sublicense undocked users.

Creating an Undocked User License

GoldMine has a sub-license for an individual user called an Undocked License (U-License). This license type is
created for users who work primarily with GoldMine at a remote location on a laptop, notebook, or home office
computer but who also need to log on to the network occasionally. Before creating an undocked consider the
following:

Creating an undocked user decreases the available users of the network site (Master License or Site License) by
one; however, when an undocked user logs on to the site from which they were sub-licensed, they do not
take up an additional seat.

Every user supported by the GoldMine license can have an Undocked license to work on a remote computer.
For example, on a 5-user GoldMine system, 5 Undocked licenses can be created. This is in contrast to creating
an “S” sub-license which requires one seat to remain available from the Master License.

All undocked users, as well as the total number of users that make up the difference in the total number
allowed by the Master License can log on to GoldMine. For example, on a 5-user GoldMine system with 3
undocked users, 3 undocked users plus 2 other users can log on to GoldMine.

If you undock all users, only those users will be able to log in. If you have not assigned master rights to any of
those undocked users, GoldMine administration cannot take place.

When used in combination with GoldSync, administrators can synchronize security settings to undocked users
including new passwords, menu items, and preferences in addition to data.

To work on an undocked basis, users must have an Undocked license on their laptop. Create an Undocked
license from the Master License or a Site license.

To Create an Undocked User License

1.
2.
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From the GoldMine main menu, select Tools > Configure > License Manager.
At the License Manager window, click the Licenses tab and Undock Users.
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3. Atthe Create Undocked User Licenses dialog box, select the check box next to the user you want to create a
sub-license for, and click Create Undocked License.
4. Atthe Sub-Licenses dialog box, review the information and click | Agree.
O The sub-license number for a remote user or an undocked user appears in the Sub-license for Remote Site
[Name of Site] dialog box.
O GoldMine adds the sublicense to the Licenses tab browse window under previously installed license(s). The
first character of a site sublicense serial number is U.

5. Write the sub-license number down or copy it to Windows Notepad.
NOTE: A unique sublicense number is needed for each remote computer installation. Send the remote site

number to the remote location. The GoldMine administrator at the remote site can then type the license
number during the GoldMine installation.

NOTE: Licensing is not necessary on Undocked user installations when installation is done by a One-button
installer package.

Creating GoldSync Licenses

GoldSync licenses are included with GoldMine Premium Edition and are issued concurrent with the E license.
GoldSync seat purchased separately and can be added to E-Licenses. For more information about GoldSync, see
About GoldSync.

To Create a GoldSync License
1. From the GoldMine main menu, open the Tools menu and select Configure > License Manager.

2. Inthe GoldMine License Manager, select the Licenses tab and click New Site. The Create a Site License dialog
box appears.

3. Inthe Distributed License Type area, select GoldSync Site License.
Type the Site Name (no more than 12 characters and spaces).

Type the Number of Users who will need GoldSync licenses at the site (the total number of users included in
the GoldSync sublicense). The site needs at least one GoldSync license to synchronize with the Master
License.

Click Create Site License. The Sub-License for Remote Site [site name] dialog box appears.

Select | AGREE.

The new GoldSync sublicense for the remote site displays. Copy of this number, beginning with the letter Y;
you need it when licensing the site.

NOTE: A unique sublicense number is needed for each remote computer installation. Send the remote site
number to the remote location. The GoldMine administrator at the remote site can then type the license
number during the GoldMine installation.

9. Click Close.

10. Select OK in the Create a Site License dialog box.

NOTE: GoldMine adds the sublicense to the Licenses tab browse window under previously installed license
(s). The first character of a site sublicense serial numberis Y.
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Undocked Users

IMPORTANT: Do not allow undocked users to synchronize with an updated GoldMine system until they have
updated to the same version the updated site is using.

To update undocked users after performing an upgrade on the main GoldMine system, locate the gmsetup.exe
file. Send the gmsetup.exe file to the undocked users by one of the following methods: copying it to a CD or flash
drive, posting it on an FTP site or cloud server, e-mailing it, or placing it on an accessible network drive.

Include directions for executing the gmsetup.exe file and what the undocked users should expect after the
upgrade.

After the users update to the same version of GoldMine, they can synchronize with the master site. To change the
registration information, select Update Registration Information.

Removing Licenses

In a multi-license GoldMine installation, it be necessary to delete sublicenses such as site licenses, undocked user
licenses, or GoldSync licenses. You cannot delete E or G-Licenses. Only users with Master Rights can delete
licenses.

1. Select Tools > Configure > License Manager. The GoldMine License Manager dialog box appears.

2. From the Licenses tab, select the sublicense to delete and then click Remove License.

3. Click Yes to remove the license.

IMPORTANT: Removing licenses will prevent those licenses from being able to synchronize with GoldMine.

Updating Registration Information

The registration information for GoldMine is entered during product installation. However, you can make changes
to this information in the License Manager. Only the master user is allowed to update registration information.

To Update Registration Information

1. Tools > Configure > License Manager.
2. Click the Registration tab and make the desired registration changes as needed.
3. Click Close.
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Integration

GoldMine can be integrated with .NET. For more information, refer to the following topics:
m Integrating with .NET

NOTE: For specific details regarding installation and configuration refer to the product’s installation guide.

Integrating with .NET

The new APl integrates with GoldMine by providing an XML-based programming interface and COM server. It is
compatible with Microsoft .NET development tools (VB.NET and C#). The XML wrapper provides access to
functions from the non-XML capable API available of previous GoldMine versions.

Also, user-interface integration tools let developers interact. For instance, replace DDE with COM, to gain:
= Implementation of current technology instead of DDE.
= Compatibility with COM-capable development tools.
m Compatibility with .NET applications.
= Ability to grow into a full Ul APL.
= Ability to rewrite the Excel/Word link.

= Easier implementation of an XML-based interface.

The COM server implements the relevant DDE functions. An application that previously used DDE can
communicate to GoldMine using this interface.

The description has 2 parts:
= The XML API
m The Ul APl to run
The XML APl and the Ul APl use the same basic schema to perform actions:
<GMAPI call="callName'"><dataname="DataName">XXXXXX</data>...</GMAPI>
Eventually, this will evolve into a retro-written XML-schema and DTD for the full APlIs.

The XML APl wraps the existing GM API into a simpler interface. Low-level functions performing actions needed by
the non-XML API programmer are hidden. Failures are self-documented (no return messages).

Suggested Prerequisites
= Using the interfaces (developers and Technology partners): A working knowledge of COM and XML (or ability
to build well-formed XML strings).

= End users: A working knowledge of the standard function calls for the older gmx32.dll version of the GoldMine
APL.

See http://www.goldmine.com/goldmine-support/ for access to our Self-Service portal, Knowledgebase,
Community, and contact information.
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