Ivanti Device and Application Control 5.1 U5

Quick Start Guide

ivanti Endpoint Security
powered by HEAT
Notices

Version Information
Ivanti Device and Application Control Quick Start Guide - Ivanti Device and Application Control Version 5.1 Update 5 - Published: December 2019
Document Number: 02_101_5.1 Update 5

Copyright Information
This document contains the confidential information and/or proprietary property of Ivanti, Inc. and its affiliates (referred to collectively as “Ivanti”), and may not be disclosed or copied without prior written consent of Ivanti.
Ivanti retains the right to make changes to this document or related product specifications and descriptions, at any time, without notice. Ivanti makes no warranty for the use of this document and assumes no responsibility for any errors that can appear in the document nor does it make a commitment to update the information contained herein.
For the most current product information, please visit: www.ivanti.com
Copyright® 2019, Ivanti. All rights reserved.
Ivanti and its logos are registered trademarks or trademarks of Ivanti, Inc. and its affiliates in the United States and/or other countries. Other brands and names may be claimed as the property of others.

Protected by patents, see www.ivanti.com/patents.
# Table of Contents

**Preface: About This Document** ................................................................................................................. 7
  Typographical Conventions .......................................................................................................................... 7

**Chapter 1: System Requirements** ............................................................................................................ 9
  Minimum Hardware Requirements ............................................................................................................... 10
  Supported Operating Systems .................................................................................................................. 11
  Supported Databases .................................................................................................................................. 13
  Other Software Requirements .................................................................................................................... 14
  Recommended Configuration ...................................................................................................................... 15
  Client Supported Languages ..................................................................................................................... 16

**Chapter 2: Installing Ivanti Device and Application Control Components** ........................................... 17
  Installation Overview ........................................................................................................................................ 18
  Installation Checklist ....................................................................................................................................... 18
  Installing the Database ................................................................................................................................... 20
  Generating a Key Pair ..................................................................................................................................... 23
  Installing the Application Server .................................................................................................................. 25
  Installing the Management Console ............................................................................................................ 32
  Installing the Client ....................................................................................................................................... 35

**Chapter 3: Using Device Control** ............................................................................................................ 43
  Product Overview ......................................................................................................................................... 43
  Device Control Server, Database and Client Process .................................................................................. 44
  Using the Management Console ................................................................................................................... 45
  The Device Permissions Setup Process ...................................................................................................... 45
  Using the Management Console ................................................................................................................... 46
    Logging In to the Management Console .................................................................................................... 46
    Logging Out of the Management Console ............................................................................................... 47
    Device Control Modules ............................................................................................................................ 47
    Getting Started .......................................................................................................................................... 48
  Managing Devices ......................................................................................................................................... 48
    Device Permission Default Settings .......................................................................................................... 48
    Device Types Supported ............................................................................................................................. 49
    Device Explorer Window ............................................................................................................................ 51
    Manage Devices .......................................................................................................................................... 55
    Add Computers .......................................................................................................................................... 56
    Assign Permissions by Devices ................................................................................................................... 57
    Assign Temporary Permissions to Users .................................................................................................... 59
    Assign Scheduled Permissions to Users ..................................................................................................... 60
    Add Shadowing .......................................................................................................................................... 61
    Sending Updates to All Computers ............................................................................................................. 66
  Authorizing CD/DVDs .................................................................................................................................... 67
  Add CD/DVD Media ......................................................................................................................................... 67
  Log Explorer Templates ................................................................................................................................. 68
  View Administrator Activity .......................................................................................................................... 68
Chapter 4: Using Application Control

Product Overview

Application Control Server, Database and Client Process

Using the Management Console

The File Authorization Setup Process

Using Application Control

Logging In to the Management Console

Logging Out of the Management Console

Application Control Modules

Getting Started

Building a Central File Authorization List

Importing Standard File Definitions

Authorizing File Execution

Creating a File Scanning Template

Scanning Files on a Client Computer

Adding a File Group

Assigning Files to File Groups

Creating Parent-Child Relationships

Assigning File Groups to Users

Sending Updates to All Computers

Viewing Database Records

Local Authorization

Log Explorer Templates

View Administrator Activity

Upload Latest Log Files

Reporting

Opening a Report

Printing a Report

Saving a Report

File Groups by User

User by File Group

User Options
Preface

About This Document

This Quick Start Guide is a resource written for all users of Ivanti Device and Application Control 5.1 Update 5. This document defines the concepts and procedures for installing, configuring, implementing, and using Ivanti Device and Application Control 5.1 Update 5.

Tip: Ivanti documentation is updated on a regular basis. To acquire the latest version of this or any other published document, please refer to the Ivanti Product Documentation (https://help.ivanti.com).

Typographical Conventions

The following conventions are used throughout this documentation to help you identify various information types.

Table 1: Typographical Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>bold</strong></td>
<td>Buttons, menu items, window and screen objects.</td>
</tr>
<tr>
<td><strong>bold italics</strong></td>
<td>Wizard names, window names, and page names.</td>
</tr>
<tr>
<td><strong>italics</strong></td>
<td>New terms, options, and variables.</td>
</tr>
<tr>
<td>MONOSPACE UPPERCASE</td>
<td>Keyboard keys.</td>
</tr>
<tr>
<td>BOLD UPPERCASE</td>
<td>SQL Commands.</td>
</tr>
<tr>
<td>monospace</td>
<td>File names, path names, programs, executables, command syntax, and property names.</td>
</tr>
</tbody>
</table>
Chapter 1

System Requirements

The following sections describe the minimum system requirements necessary for successful installation of Ivanti Device and Application Control and the languages supported by the client.

The listed specifications are a minimum; larger network environments, may require additional hardware and software resources. The system requirements for Ivanti Device and Application Control are listed in the following topics.

**Important:** For installation or upgrade to Ivanti Device and Application Control version 5.1 Update 5:

- You must have a valid license file that is issued specifically for version 4.5 or later. Confirm that you have the required license file available before you begin installation.
- License files issued before Ivanti Device and Application Control version 4.5 will not work with the Application Server and may cause your Application Servers to stop working.
- The Ivanti Device and Application Control 4.5 license must be installed before you install or upgrade the Ivanti Device and Application Control database, and then the Application Server.
- Request a new license file using the Downloads tab on the Self-Service Portal.
Minimum Hardware Requirements

The minimum Ivanti Device and Application Control hardware requirements depend upon your service network environment, including the type of database supported, the number of Application Servers you need to support a distributed network, and the number of subscribed clients.

The hardware requirements for Ivanti Device and Application Control vary depending upon the number of servers and clients you manage. The following minimum hardware requirements will support up to:

- 200 connected Ivanti Device and Application Control clients for Device Control
- 50 connected Ivanti Device and Application Control clients for Application Control

Table 2: Minimum Hardware Requirements

<table>
<thead>
<tr>
<th>Ivanti Device and Application Control Component</th>
<th>Requirement</th>
</tr>
</thead>
</table>
| Database                                       | • 1 GB (4 GB recommended) memory  
• Pentium® Dual-Core CPU processor or AMD equivalent  
• 3 GB minimum hard disk drive  
• 100 MBits/s NIC |
| Application Server                             | • 512 MB (1 GB recommended) memory  
• Pentium® Dual-Core CPU or AMD equivalent  
• 3 GB minimum hard disk drive  
• 100 MBits/s NIC |
| Management Console                             | • 512 MB (1 GB recommended) memory  
• 15 MB hard disk drive for installation, and 150 MB additional for application files  
• 1024 by 768 pixels for display |
| Client                                         | • 256 MB (1 GB recommended) memory  
• 10 MB hard disk drive for installation, and several additional GB for full shadowing feature of Device Control  
• 100 MBits/s NIC |
# Supported Operating Systems

Ivanti Device and Application Control supports multiple Microsoft Windows operations systems for the Application Server, Management Console, database, and client.

The operating system requirements for Ivanti Device and Application Control components are outlined as follows.

Table 3: Operating System Requirements

<table>
<thead>
<tr>
<th>Ivanti Device and Application Control Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database</td>
<td>One of the following:</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 R2 with SP1 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2012 (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2012 R2 (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2016, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2019, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td>Application Server</td>
<td>One of the following:</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2008 R2 with SP1 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 R2 (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2016, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2019, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td>Management Console</td>
<td>One of the following:</td>
</tr>
<tr>
<td></td>
<td>• Windows 7 SP1 (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2008 R2 with SP1 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 R2 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2016, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2019, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows 8 and 8.1 (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Windows 10 (32-bit and 64-bit)</td>
</tr>
<tr>
<td>Ivanti Device and Application Control Component</td>
<td>Requirement</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Client</td>
<td>One of the following:</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2008 R2 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 R2 (64 bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2016, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2019, Standard, Datacenter and Essentials Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Windows 7 SP 1 (32-bit and 64-bit) with KB3033929</td>
</tr>
<tr>
<td></td>
<td>• Windows Embedded Standard 7 SP1 (32-bit and 64-bit) with KB3033929</td>
</tr>
<tr>
<td></td>
<td>• Windows 7 Thin PC</td>
</tr>
<tr>
<td></td>
<td>• Windows 8 (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Windows 8.1 (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Windows Embedded 8.1 Industry Pro and Industry Enterprise (64-bit) <strong>NOTE</strong>: Both these editions are identified as Windows Embedded 8.1 Industry by Microsoft.</td>
</tr>
<tr>
<td></td>
<td>• Windows 10 Education, Enterprise, and Professional editions (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenApp 7.12</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenApp 7.14.1</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenApp 7.15</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenApp 7.17</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenApp 7.18</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenDesktop 7.12</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenDesktop 7.14.1</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenDesktop 7.15</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenDesktop 7.17</td>
</tr>
<tr>
<td></td>
<td>• Citrix XenDesktop 7.18</td>
</tr>
</tbody>
</table>

**Important**: Windows 7 SP1 (32-bit and 64-bit) and Windows Embedded Standard 7 SP1 (32-bit and 64-bit) both required **KB3033929 (Security Update for Windows 7)** to be installed prior to Ivanti Device and Application Control being installed.
**Supported Databases**

Ivanti Device and Application Control supports multiple releases of Microsoft® SQL Server®. You should choose the database instance required by your network operating environment and the number of Application Servers and subscribed clients the application must support.

The database requirements for Ivanti Device and Application Control components are outlined as follows.

Table 4: Database Requirements

<table>
<thead>
<tr>
<th>Ivanti Device and Application Control Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database</td>
<td>One of the following:</td>
</tr>
<tr>
<td></td>
<td>• Microsoft SQL Server 2008 / 2008 R2, Standard, Enterprise, Express Edition (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft SQL Server 2012, Standard, Enterprise, Express Edition (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft SQL Server 2014, Standard, Enterprise, Express Edition (32-bit and 64-bit)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft SQL Server 2016, Standard, Enterprise, Express Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft SQL Server 2017, Standard, Enterprise, Express Edition (64-bit only)</td>
</tr>
<tr>
<td></td>
<td>• Microsoft SQL Server 2019, Standard, Enterprise, Express Edition (64-bit only)</td>
</tr>
</tbody>
</table>
Other Software Requirements

Ivanti Device and Application Control requires the following additional software.

Additional software requirements for Ivanti Device and Application Control components are outlined as follows.

Table 5: Other Software Requirements

<table>
<thead>
<tr>
<th>Ivanti Device and Application Control Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database</td>
<td>No additional software requirements.</td>
</tr>
<tr>
<td>Application Server</td>
<td>If you will be encrypting Windows user accounts for centralized Device Control encryption, you will need to install an enterprise level Certificate Authority. See Microsoft Certificate Authority (<a href="http://technet.microsoft.com/en-us/library/cc756120.aspx">http://technet.microsoft.com/en-us/library/cc756120.aspx</a>) for additional information about certificates. <strong>Attention:</strong> Certificate authority installation applies to Device Control only for centralized encryption capability. Certificate authority installation applies to both Device Control and Application Control for secure server communications. A Certificate Authority is required to use secure communications between clients and servers, and intra-server communications.</td>
</tr>
<tr>
<td>Client</td>
<td>No additional software requirements.</td>
</tr>
</tbody>
</table>
Recommended Configuration

To maximize Ivanti Device and Application Control for operation in a Microsoft Windows environment, you should configure your network environment database and client components using the following suggested configurations.

The recommended configurations for Ivanti Device and Application Control components are outlined as follows. These settings represent the usual default settings, but should be confirmed before beginning Ivanti Device and Application Control installation.

Table 6: Recommended Configuration

<table>
<thead>
<tr>
<th>Ivanti Device and Application Control Component</th>
<th>Requirement</th>
</tr>
</thead>
</table>
| Database                                      | • Change the Windows **Event Viewer** settings to 1024 KB and choose to overwrite events as necessary.  
• Change Windows **Performance** settings to prioritize for background applications. |
| Application Server                            | None recommended. |
| Management Console                            | None recommended. |
| Client                                        | • If you are using Active Directory, configure a corresponding Domain Name System (DNS) server as Active Directory (AD) integrated and create a reverse lookup zone, to provide for name resolution within the Management Console.  
• Configure NIC to receive IP from DHCP service.  
• Change the Windows **Event Viewer** settings to 1024 KB and choose to overwrite events as necessary. |
Client Supported Languages

The Ivanti Device and Application Control client supports multiple languages in text format.

The Ivanti Device and Application Control client is supported in the following languages:

- English
- French
- Italian
- German
- Spanish
- Japanese
- Simplified Chinese
- Traditional Chinese
- Russian
- Dutch
- Portuguese
- Swedish
Chapter 2

Installing Ivanti Device and Application Control Components

Ivanti Device and Application Control component installation requires that you follow a series of interdependent tasks in a prescribed order. Before you begin, you must have a valid license key for each software application(s) that your are installing.

Successful installation of Ivanti Device and Application Control requires you to install components in the following order:

1. Install the database.
2. Generate and save a public and private key pair. This action is not required, however, Ivanti strongly recommends the use of a public-private key pair to provide the highest level of security.
3. Install the Application Server(s).
4. Install the Management Console.
5. Install and deploy the client.
**Installation Overview**

Ivanti Device and Application Control component installation requires that you follow a series of interdependent tasks in a prescribed order. Before you begin, you must have a valid license key for each software application(s) that you are installing.

Use the following process to identify tasks for installing components installing Ivanti Device and Application Control, for your convenience this process refers to the Installation Checklist on page 18.

![Figure 1: Ivanti Device and Application Control Product Solution Installation Process Flow](image)

**Installation Checklist**

The installation checklist outlines the detailed tasks that you must perform when installing the Ivanti Device and Application Control solutions.

This checklist guides you through the installation process.

**Important:** For installation or upgrade to Ivanti Device and Application Control version 5.1 Update 5:

- You must have a valid license file that is issued specifically for version 4.5 or later. Confirm that you have the required license file available before you begin installation.
- License files issued before Ivanti Device and Application Control version 4.5 will not work with the Application Server and may cause your Application Servers to stop working.
- The Ivanti Device and Application Control 4.5 license must be installed before you install or upgrade the Ivanti Device and Application Control database, and then the Application Server.
- Request a new license file using the **Downloads** tab on the Self-Service Portal.

To begin your installation:
1. Copy the Ivanti Device and Application Control license file to the `\Windows\System32` or `\Windows\SysWOW64` folder, and rename the file to `endpoint.lic`. The license file may be installed after installing the database, however, the license file must be installed before installing the Application Server.

2. Download the Ivanti Device and Application Control application software from the Self-Service Portal.

3. Create a device, media, or software application inventory which lists the items that you want Ivanti Device and Application Control to control.

4. Document company policy that defines:
   - Device permissions.
   - Shadowing requirements.
   - Device encryption requirements.
   - Ivanti Device and Application Control administrators and their roles.
   - Global domain groups for Ivanti Device and Application Control administrators.

5. Plan your Ivanti Device and Application Control network architecture, based on capacity requirements, that list the Application Server host names and IP addresses.

6. Create a dedicated Application Server domain user rights service account and set the following:
   - **User cannot change password.**
   - **Password never expires.**

   The domain account must have local administration rights when you plan to use the TLS communication protocol for client-Application Server and inter-Application Server data transfers.

7. Create **Impersonate a client after authentication** user rights for the Application Server. See **Impersonate a Client After Authentication** (http://support.microsoft.com/kb/821546) for additional information about impersonating a client after authentication user rights.

8. Verify that the Application Server domain account has **Log on as a service** user rights. See **Add the Log on as a service right to an account** (http://technet.microsoft.com/en-us/library/cc739424(WS.10).aspx) for additional information about logging on as a service user rights.

9. Install Microsoft® **Internet Information Services** on the same computer as the certification authority, otherwise the enterprise root certificate cannot be generated. See **Internet Information Services (IIS)** (http://www.iis.net) for additional information about installing **Internet Information Services**.

10. Install a Microsoft enterprise root certification authority to enable removable device encryption for Device Control. See **Install a Microsoft enterprise root certification authority** (http://technet.microsoft.com/en-us/library/cc776709.aspx) for additional information about installing an enterprise root certificate.


13. To install multiple Application Server s, create a shared file directory on a file server to share the Datafile directory component. This action is only required if you will be using more than one Application Server.

14. Complete **Generating a Key Pair** on page 23. This action is recommended, but not required.
15. Complete Installing the Application Server on page 25.

**Important:** The Application Server service account must have database owner (DBO) rights to the Ivanti Device and Application Control database.

17. Complete Installing the Client on page 35.
18. Test your Ivanti Device and Application Control product solution installation for functionality.

## Installing the Database

The Ivanti Device and Application Control database is the first component that you install. The database serves as the central repository for device permissions rules and executable file authorizations.

**Prerequisites:**

**Important:** For installation or upgrade to Ivanti Device and Application Control version 5.1 Update 5:

- You must have a valid license file that is issued specifically for version 4.5 or later. Confirm that you have the required license file available before you begin installation.
- License files issued before Ivanti Device and Application Control version 4.5 will not work with the Application Server and may cause your Application Servers to stop working.
- The Ivanti Device and Application Control 4.5 license must be installed before you install or upgrade the Ivanti Device and Application Control database, and then the Application Server.
- Request a new license file using the Downloads tab on the Self-Service Portal.

**Caution:** When installing SQL server updates, ensure SQL server restarts properly as this may prevent SXS server from starting as the database will be unavailable.

Before you can successfully install the Ivanti Device and Application Control database, you must:

- Verify that you satisfy the minimum hardware and software system requirements.
- If you will be using a database cluster, you must specify an alternate TDS port during SQL server setup. See Creating a Server Alias for Use by a Client (SQL Server Configuration Manager) (http://msdn.microsoft.com/en-us/library/ms190445.aspx) for additional information about creating a server alias. You can install the Ivanti Device and Application Control database on a server cluster, where there are at least two servers in the cluster running SQL Server. For additional information regarding database clustering, see Microsoft Cluster Service (MSCS) Installation Resources (http://support.microsoft.com/kb/259267).

1. Log in to a computer as an administrative user with access to a Microsoft® SQL Server®.
2. Close all programs running on the computer.
3. From the location where you saved the Ivanti Device and Application Control application software, run the `\server\db\Db.exe` file.

**Step Result:** The *Installation Wizard Welcome* page opens.

![Welcome Page](image2.png)

4. Click **Next**.

**Step Result:** The *License Agreement* page opens.

![License Agreement Page](image3.png)

5. Review the license agreement and, if you agree, select *I accept the terms in the license agreement*.

6. Click **Next**.

**Step Result:** The *Destination Folder* page opens.

![Destination Folder Page](image4.png)
7. You may choose an installation destination folder other than the default folder C:\Program Files \Ivanti\Device and Application Control\. 
   a) Click Change
      
      **Step Result:** The *Change Current Destination Folder* page opens.

      ![Change Current Destination Folder Page]

      Figure 5: Change Current Destination Folder Page

   b) Select a folder from the **Look in:** field.
   c) Click **OK**.
      
      **Step Result:** The *Change Current Destination Folder* closes, and the *Destination Folder* page changes to reflect the new location.

8. Click Next.
   
   **Step Result:** The *Ready to Install the Program* page opens.

   ![Ready to Install the Program Dialog]

   Figure 6: Ready to Install the Program Dialog

9. Click **Install**.
   
   A progress bar runs on the page, showing installation progress.
   
   **Step Result:** The *Completed* page opens.

10. Click **Finish**.

    **Result:** Ivanti Device and Application Control setup runs the SQL installation scripts and creates the Ivanti Device and Application Control database for the SQL Server database instance that you specified.
Generating a Key Pair

The Application Server uses an asymmetric encryption system to communicate with a client, using a public-private key pair that you generate during installation.

The Application Server and Ivanti Device and Application Control clients contain a embedded default public and private key pair that should only be used with an evaluation license. Ivanti provides a Key Pair Generator utility, which generates a key pair for fully licensed application installations. The key pair ensures the integrity for communication between the Application Server and clients.

When an Application Server cannot find a valid key pair at startup, the event is logged and Ivanti Device and Application Control uses the default key pair.

Caution: When you are using Device Control, do not change the key pair:

- For media encrypted before exchanging a key pair, which will result in disabling password recovery for the previously encrypted media.
- During a Ivanti Device and Application Control upgrade installation which will result in the loss of access to media previously encrypted centrally and subsequent loss of data.
- During a Ivanti Device and Application Control upgrade installation when client hardening is enabled, which will cause Application Control and Device Control installations to fail.

1. From the location where you saved the Ivanti Device and Application Control application software, run the `server\keygen\keygen.exe` file.

   **Step Result:** The *Key Pair Generator* dialog opens.

   ![Key Pair Generator Dialog](image)

   Figure 7: Key Pair Generator Dialog

2. In the **Directory** field, enter the name of the temporary directory where you will save the key pair.

3. In the **Seed** field, type a random alphanumeric text string.

   This text is used to initiate the random number generator; the longer the text string the more secure the key pair.
4. Click **Create keys**.

   **Step Result:** The **Key Pair Generator** confirmation dialog opens.

   ![Key Pair Generator Dialog](image)

   Figure 8: Key Pair Generator Dialog

5. Click **OK**.

   **Step Result:** You return to the **Key Pair Generator** dialog.

6. Click **Exit**.

   **Result:** The keys are saved as `sx-private.key` and `sx-public.key` files in the directory you specified.

   **After Completing This Task:**

   Distribute the key pair by copying the `sx-private.key` and `sx-public.key` files to `c:\windows\system32` (32-bit systems) or `c:\windows\syswow64` (64-bit systems) on the computer(s) where you are installing the Application Server. At startup, the Application Server searches all drive locations for a valid key pair, stopping at the first valid key pair.
Installing the Application Server

The Application Server processes Ivanti Device and Application Control client activities and is the only application component that connects to the database. One or more Application Servers communicate device and application control information between the Ivanti Device and Application Control database and Ivanti Device and Application Control client(s).

Prerequisites:

Before you can successfully install the Application Server, you must:

- Verify that a valid Ivanti Device and Application Control license file is listed in `c:\windows\system32` (32-bit systems) or `c:\windows\syswow64` (64-bit systems), and file name is `endpoint.lic`.

**Important:** For installation or upgrade to Ivanti Device and Application Control version 5.1 Update 5:

- You must have a valid license file that is issued specifically for version 4.5 or later. Confirm that you have the required license file available before you begin installation.
- License files issued before Ivanti Device and Application Control version 4.5 will not work with the Application Server and may cause your Application Servers to stop working.
- The Ivanti Device and Application Control 4.5 license must be installed before you install or upgrade the Ivanti Device and Application Control database, and then the Application Server.
- Request a new license file using the Downloads tab on the Self-Service Portal.

- Verify that you satisfy the minimum hardware and software system requirements.

- When using TLS protocol confirm TCP ports 33115 and 65229 are open. When not using TLS protocol open TCP port 65129. Depending upon how firewalls are setup in your environment, these ports may be closed.
- Configure the TCP/IP protocol to use a fixed IP address for the computer that runs the Application Server.
- Configure the Application Server host computer to perform fully qualified domain name (FQDN) resolution for the Ivanti Device and Application Control clients that the server manages.
- Ensure that the Application Server host computer account is configured to read domain information using the Microsoft Windows Security Account Manager. See Security Account Manager (SAM) (http://technet.microsoft.com/en-us/library/cc756748.aspx) for additional information about the Microsoft Windows Security Account Manager.
- Synchronize the Application Server's system clock with the Ivanti Device and Application Control database server's system clock using the Microsoft Windows time service. See Time Service (http://support.microsoft.com/kb/816042) for details about using the Microsoft Windows time service.
1. Log in with administrative user access to the computer where you are installing the Application Server.

**Important:** For Active Directory environments, log in using the dedicated Application Server domain user rights service account. The Application Server installation process configures the Application Server service account for access to the database.

2. Close all programs running on the computer.

3. From the location where you saved the Ivanti Device and Application Control application software, run `\server\sxs\Server.exe`.

4. Click **OK**.

**Step Result:** The *Installation Wizard Welcome* page opens.

5. Click **Next**.

**StepResult:** The *License Agreement* page opens.

6. Review the license agreement and, if you agree, select **I accept the terms in the license agreement**.

![Welcome Page](image1)

![License Agreement Page](image2)
7. Click **Next**.

**Step Result:** The **Setup** dialog opens when the setup process detects an operating system that is subject to security changes concerning Remote Procedure Calls (RPC).

![Setup Dialog](image1.png)

**Figure 11: Setup Dialog**

8. Click **Yes**.

**Step Result:** A confirmation dialog opens after the registry value is reset.

![Confirmation Dialog](image2.png)

**Figure 12: The Setup Dialog**

9. Click **OK**.

**Step Result:** The **Destination Folder** page opens.

![Destination Folder](image3.png)

**Figure 13: Destination Folder Page**
10. You may choose an installation destination folder other than the Ivanti Device and Application Control default folder C:\Program Files\Ivanti\Device and Application Control. 

   a) Click Change.

      **Step Result:** The *Change Current Destination Folder* page opens.

      ![Change Current Destination Folder Page](image)

      Figure 14: Change Current Destination Folder Page

   b) Select a folder from the *Look in:* field.
   c) Click OK.

      **Step Result:** The *Change Current Destination Folder* closes, and the *Destination Folder* page changes to reflect the new location.

11. Click Next.

    **Step Result:** The *Service Account* page opens.

    ![Service Account Page](image)

    Figure 15: Service Account Page

12. Type the name of the user or domain in the **User Account** field for access to the Application Server. Enter domain account information using the Domain\User format, and local account information using the Computer\User format. Ivanti Device and Application Control supports use of standard NetBIOS computer names up to fifteen (15) characters long.

    **Tip:** This is the user name that you created when you configured the domain service account for the Application Server.

13. In the **Password** field, type the user account access password.
14. Click Next.

**Step Result:** The *Database Server* page opens.

![Database Server Page]

15. Type the name of the database instance for the Application Server connection, using the `servername\instancename` format.

The default database instance is automatically populated, when installed on the same computer. Alternately, the `instancename` is not required if the database is installed in the default instance of Microsoft SQL Server.

16. Click Next.

**Step Result:** The *Datafile directory* page opens.

![Datafile Directory Page]
17. You may choose a folder other than the Ivanti Device and Application Control default folder, **C:\DataFileDirectory\**, where Application Server log, shadow, and scan files are stored.

**Tip:** Use a permanent network share when you are installing more than one Application Server or a dedicated file server. To improve performance for a multi-server installation, assign a separate data file directory to each server to provide load balancing; although more than one server can access the same data file directory. Use a **Universal Uniform Name Convention** path name; do not use a mapped drive name.

a) Click **Change**.

**Step Result:** The **Select datafile directory** page opens.

![Select Datafile Directory Page](image)

Figure 18: Select Datafile Directory Page

b) Type the name of the datafile directory in the **Folder name:** field.
c) Click **OK**.

18. Click **Next**.

**Step Result:** The **Server communication protocol** page opens.

![Server Communication Protocol Page](image)

Figure 19: Server Communication Protocol Page

19. Select an encryption option.

**Important:** Do not select **Apply encryption via TLS - setup will generate a TLS certificate** as it is no longer supported.
20. Click Next.

**Step Result:** The *Server communication protocol* page opens.

![Server Communication Protocol Ports Page](image)

21. Specify the communication port(s).

**Restriction:** The port field(s) shown depend upon the encryption communication protocol that you selected previously.

22. Click Next.

**Step Result:** The *Syslog Server* page opens.

![Syslog Server Page](image)

23. Type the name or the IP address of the *SysLog* server in the *SysLog server address* field.

**Important:** This step is optional. You do not have to specify a *Syslog* server.

24. Select from the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audit Logs</td>
<td>Logs changes to policy administered through the Management Console.</td>
</tr>
<tr>
<td>System Logs</td>
<td>Logs system events.</td>
</tr>
<tr>
<td>Agent Logs</td>
<td>Logs events uploaded directly from the Ivanti Device and Application Control client.</td>
</tr>
</tbody>
</table>
25. Click **Next**.

**Step Result:** The *Ready to Install Program* page opens.

![Ready to Install Program Page](image)

26. Click **Install**.

A progress bar runs on the page, showing installation progress.

**Step Result:** The *Completed* page opens.

27. Click **Finish**.

**Result:** The Application Server files are installed and the server establishes a connection to the Ivanti Device and Application Control database.

---

### Installing the Management Console

The Management Console is the administrative tool that used to configure and run the Ivanti Device and Application Control software.

**Prerequisites:**

Before you can successfully install the Management Console, you must:

- Verify that you satisfy the minimum hardware and software system requirements.

- Install the Application Server.

1. Log in as an administrative user to the computer where you are installing the Management Console.
2. Close all programs running on the computer.
3. From the location where you saved the Ivanti Device and Application Control application software, run the `\server\smc\Console.exe`.

**Attention:** The Management Console requires the Microsoft® Visual C++ 2017 Redistributable Package for proper operation. You may receive a message prompting you to allow setup to trigger the redistributable package installation, if Visual C++ Libraries are not already installed. After the redistributable package installs, the Management Console resumes installation as follows.

![Microsoft Visual C++ 2017 Redistributable Package Setup](image)

**Figure 23: Microsoft Visual C++ 2017 Redistributable Package Setup**

**Step Result:** The *Installation Wizard Welcome* page opens.

![Welcome Page](image)

**Figure 24: Welcome Page**

4. Click Next.

**Step Result:** The *License Agreement* page opens.

![License Agreement Page](image)

**Figure 25: License Agreement Page**

5. Review the license agreement and, if you agree, select *I accept the terms in the license agreement*. 

6. Click **Next**.

**Step Result:** The *Select Installation Folder* page opens.

![Select Installation Folder](image)

Figure 26: Setup Type Page

7. Select the features you want to install:

**Note:** The installation features shown depend upon the application you are licensed for.

a) Select the features that you want to install.

The installation features shown depend upon the application that you are licensed for.

<table>
<thead>
<tr>
<th>Feature</th>
<th>License Type(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Management Console</td>
<td>Device Control</td>
</tr>
<tr>
<td></td>
<td>Application Control</td>
</tr>
<tr>
<td>Client Deployment Tool</td>
<td>Device Control</td>
</tr>
<tr>
<td></td>
<td>Application Control</td>
</tr>
<tr>
<td>Standard File Definitions</td>
<td>Application Control</td>
</tr>
<tr>
<td>Authorization Wizard</td>
<td>Application Control</td>
</tr>
</tbody>
</table>

b) You may choose *C:\Program Files (x86)\Ivanti\Device and Application Control\* or change the destination folder.

8. Click **Next**.

**Step Result:** The *Ready to Install* page opens.

![Ready to Install](image)

Figure 27: Ready to Install Page
9. Click **Install**.
   A progress bar runs on the page, showing installation progress.
   **Step Result:** The **Completed** page opens.

10. Click **Finish**.
   **Result:** The Management Console files are installed.

---

**After Completing This Task:**
Define Ivanti Device and Application Control administrator access as described in the [Ivanti Device Control User Guide](https://help.ivanti.com) or the [Ivanti Application Control User Guide](https://help.ivanti.com) depending upon your license type. By default, only users who are members of the **Administrators** group for the computer running the Management Console can connect to the Application Server.

---

**Installing the Client**

The Ivanti Device and Application Control client manages permissions for device access and user access to software applications for endpoint computers.

**Prerequisites:**

Before you can successfully install the Ivanti Device and Application Control client, you must:

- Verify that you satisfy the minimum hardware and software system requirements.
- Copy the **sx-public.key** file for the Ivanti Device and Application Control client to the **Client** folder located where you downloaded the Ivanti Device and Application Control software. The Ivanti Device and Application Control client installer detects the public key during installation and copies the key to the target directory (`%windir%\sxdata`).
- Install the Application Server.
- Install the Management Console.
- When installing Application Control, you must ensure that the **Execution blocking** default option is set to **Non-blocking mode**; otherwise the Ivanti Device and Application Control client computer will not restart after Ivanti Device and Application Control client installation because executable system files cannot run until they are centrally authorized from the Management Console.
1. Verify that the domain information in the Ivanti Device and Application Control database is synchronized as follows:

   a) From the Management Console, select **Tools > Synchronize Domain Members**.

      **Step Result:** The **Synchronize Domain** dialog opens.

      ![Synchronize Domain Dialog](image)

      Figure 28: Synchronize Domain Dialog

   b) Enter the name of the domain that you want to synchronize.

      **Note:** When you enter a computer name that is a domain controller, the domain controller is used for synchronization. This is useful when replication between domain controllers is slow.

   c) Click **OK**.

2. Log in as an administrative user to the computer where you are deploying the Ivanti Device and Application Control client.

3. Close all programs running on the computer.

4. From the location where you saved the Ivanti Device and Application Control application software, run `\client\Client.exe` file.

   **Step Result:** The **Installation Wizard Welcome** page opens.

5. Click **Next**.

   **Step Result:** The **License Agreement** page opens.

6. Review the license agreement, and, if you agree, select **I accept the terms in the license agreement**.
7. Click Next.

**Step Result:** The *Encrypted Communication* page opens.

![Encrypted Communication Page](image)

8. Select one of the following options that matches the option you selected when installing the Application Server:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server is using unencrypted protocol</strong></td>
<td>Communication between the Application Server and Ivanti Device and Application Control client is not using the TLS communication protocol. Communication is not encrypted but is signed using the private key.</td>
</tr>
<tr>
<td><strong>Authentication certificate will be retrieved from a CA</strong></td>
<td>Communication between the Application Server and Ivanti Device and Application Control client uses the TLS communication protocol. Communication is encrypted and the digital certificate is retrieved automatically during installation.</td>
</tr>
</tbody>
</table>

**Important:** Do not select *Apply encryption via TLS - setup will generate a TLS certificate* as it is no longer supported.

**Tip:** Ivanti recommends that you use the automatic TLS retrieval option to deploy Certificate Authority infrastructure for issuing valid digital certificates.

**Step Result:** If you opt to manually generate a certificate during setup, the *Client Authentication* dialog opens.

![Client Authentication Dialog](image)
9. To manually generate a certificate during setup specify the computer certificate location and parameters from the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate certificate signed by certificate located in store</td>
<td>Generates a digital certificate during installation by using a signature certificate located in the local user store.</td>
</tr>
<tr>
<td>Generate certificate signed by certificate located in file</td>
<td>Generates a digital certificate during installation by using a signature certificate located in a specified file.</td>
</tr>
<tr>
<td>Import into store</td>
<td>Imports a signature certificate into the local user store.</td>
</tr>
<tr>
<td>Certificate parameters</td>
<td>Specifies the certificate parameters for the Cryptographic service provider, Key length, Validity, and Signature.</td>
</tr>
</tbody>
</table>

10. Click Next.

   **Step Result:** The *Ivanti Device and Application Control* Application Server page opens.

   ![Application Server's Page](image)

   Figure 32: Application Server's Page

11. Specify up to three server names using fully qualified domain names (FQDN) or IP addresses that are managed from the Management Console.

   **Caution:** Do not use IP address(es) when using the TLS communication protocol for encryption. You can only use FQDNs for when using the TLS communication protocol.
12. Verify that the Ivanti Device and Application Control client connects to the Application Server by clicking **Test**.

**Caution:** You can proceed with client installation if the Application Server is unavailable, by clicking **OK** in the following dialog. The client can establish a connection with the server later, when the server is available.

![Error Dialog](image)

**Figure 33: Error Dialog**

**Step Result:** By default, Ivanti Device and Application Control connects with the first available server and retrieves default policy settings from the server.

13. If you are specifying more than one server, select or deselect the **Select a server at random to spread the load** option.

14. Click **Next**.

**Step Result:** The **Destination Folder** page opens.

![Destination Folder Page](image)

**Figure 34: Destination Folder Page**
15. You may choose an installation destination folder other than the Ivanti Device and Application Control default folder `C:\Program Files\Ivanti\Device and Application Control\`, by clicking **Change**.

**Step Result:** The *Change Current Destination Folder* page opens.

![Change Current Destination Folder Page](image)

16. Select a folder from the **Look in:** field.
17. Click **OK**.

**Step Result:** The *Change Current Destination Folder* closes, and the *Destination Folder* page changes to reflect the new location.

18. Click **Next**.

**Step Result:** The “*Add or Remove Programs*” list page opens.

![Add or Remove Programs List Page](image)

19. You may select one of the following options, which are not required to proceed with installation:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Don’t display this product</strong></td>
<td>Does not display the Ivanti Device and Application Control component names in the <em>Add or Remove Programs</em> list in the Windows <em>Control Panel</em>.</td>
</tr>
<tr>
<td><strong>Don’t display the Remove button for this product</strong></td>
<td>Displays the Ivanti Device and Application Control component names in the <em>Add or Remove Programs</em> list in the Windows <em>Control Panel</em> without the Remove option.</td>
</tr>
</tbody>
</table>
20. Click Next.

**Step Result:** The *NDIS Device Control* page opens.

**Note:** NDIS enables Device Control to control 802.1x wireless adapters. If you do not need this protection, you may disable it here.

![Figure 37: NDIS Device Control Page](image)

21. Select the disable protection for NDIS devices check box to allow the use of wireless devices.

22. Click Next.

**Step Result:** The *Ready to Install the Program* page opens.

23. Click Install.

**Step Result:** A progress bar runs on the page, showing installation progress.

**Attention:** The *Setup* dialog warning opens when there is an invalid, non-reachable server address and no policy file exists.

24. Select one of the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abort</td>
<td>Does not retrieve the policy file and cancels the installation process.</td>
</tr>
<tr>
<td>Retry</td>
<td>Attempts to retrieve the policy file and continue setup.</td>
</tr>
<tr>
<td>Ignore</td>
<td>Skips policy file retrieval and continues setup, creating the risk of blocking the computer from all device and executable file access.</td>
</tr>
</tbody>
</table>

**Danger:** If you select Ignore, the Ivanti Device and Application Control suite installs with the most restrictive default file execution policy that denies use of all devices and/or executable files. This type of installation will deny you access to devices and software that you use on your computer, which can make the computer inaccessible. When you install a client offline for use with Application Control you must provide a policy settings file. Refer the [Ivanti Application Control User Guide](https://help.ivanti.com) for more information about creating and exporting policy settings files.

**Step Result:** The *Completed* page opens.
25. Click **Finish**.

**Result:** The Ivanti Device and Application Control client is installed and connects to the Application Server.

**After Completing This Task:**
You must restart your computer system for the Ivanti Device and Application Control client configuration changes to become effective and enable the use of the Ivanti Device and Application Control client.
Chapter 3

Using Device Control

This chapter explains how Device Control works and describes how to define and manage device permissions.

Ivanti Device and Application Control solutions include:

- Device Control, which prevents unauthorized transfer of applications and data by controlling access to input and output devices, such as memory sticks, modems, and PDAs.
- Device Control client for Embedded Devices, which moves beyond the traditional desktop and laptop endpoints to a variety of platforms that include ATMs, industrial robotics, thin clients, set-top boxes, network area storage devices and the myriad of other systems.
- Application Control, which delivers granular control of application execution in an enterprise environment.
- Application Control Server Edition, which delivers application control to protect enterprise servers, such as web servers, e-mail servers, and database servers.

Product Overview

The Device Control software application is based on a multi-tier software architecture that processes and stores data for Application Control and Device Control. Users can interact with the application through the client interface. A separate Management Console provides a user interface for network administrators.

The primary components of the Device Control solution are:

- The Device Control database which serves as the central repository of authorization information for devices and applications.
- One or more Application Servers that communicate between the database, the protected clients, and the Management Console.
- The Device Control client, which is installed on each computer, either end-point or server, that you want to protect.
- The Management Console, which provides the administrative user interface for the Application Server.
The following figure illustrates the relationships between the Device Control components.

![Diagram showing Device Control Component Relationships](image)

**Device Control Server, Database and Client Process**

The Application Server communicates between the database and the protected client computers. The following describes the communication process flow between the Device Control servers, database, and clients when using Device Control.

![Diagram showing Device Control Process Flow](image)
Using the Management Console

The Management Console allows the user to communicate with an Application Server to send and retrieve device permissions data from the database. The data is then sent from the server to a Ivanti Device and Application Control client, thereby establishing device control on the client.

The Device Permissions Setup Process

After successfully installing Application Control, an administrator uses the Management Console to configure and define user access permissions and device permission rules required in a Ivanti Device and Application Control environment that specify which devices each user can access, as described by the following process flow.

- **Define Console Administrators**
- **Define User Access**
- **Add Domain and Workgroup Computers**
- **Add Devices, Groups, and Models**
- **Add Permissions for Devices, Device Classes, Device Groups, Device Models, and Computers**
- **Assign Computer-Specific Access to Devices for Users and/or User Groups**

The **Enterprise Administrator** defines administrative roles for network **Administrators** that have restricted access to the Management Console.

After defining **Administrator roles**, the **Enterprise Administrator** assigns the roles to **Administrators** using the **User Access** tool.

**Administrators** add computers to a domain group or computer workgroup in the **Machine-specific settings** structure of the **Device Explorer**.

Define user access permission rules for a devices, device classes, device groups, device models, and computers, by assigning one or more users or user groups to the devices. Initially, the default permissions for all devices that connect to a computer running the Ivanti Device and Application Control client is **None**, which means that all user access is denied.

Assign permission rules for users to access devices, device classes, device groups, device models, and computers.

Assign computer-specific permission rules for users to access devices and device classes.

Permissions determine access to devices for authorized users or groups on any computer protected by Ivanti Device and Application Control. You can change rules to grant, extend, or deny permissions. You can allow access to CD/DVD-ROMs for specific users or groups that otherwise do not have access as defined by permissions policies, because users cannot use unauthorized CD/DVDs.
Using the Management Console

The Management Console provides direct access to system management, configuration, file authorization, reporting, and logging functions.

The Management Console allows the user to communicate with an Application Server to send and retrieve device permissions data from the database. The data is then sent from the server to a Ivanti Device and Application Control client, thereby establishing device control on the client.

Logging In to the Management Console

You access the application by logging in to the Management Console.

1. Select **Start** > **Programs** > **Ivanti** > **Endpoint Security** > **Ivanti Device and Application Control Management Console** > **Ivanti Device and Application Control Management Console**.

   **Step Result:** Each time you access the Management Console, the **Connect to Ivanti Device and Application Control Application Server** dialog appears.

2. From the **Application Server** drop-down list, select the Application Server you want to connect to.

   You can type the server name as an IP address with port if required in square brackets, NetBios name, or fully qualified domain name in the **Application Server** field.

3. Select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use current user</strong></td>
<td>By default the system connects to the Application Server using your credentials.</td>
</tr>
<tr>
<td><strong>Log in as</strong></td>
<td>Type the user name in the <strong>Username</strong> field and type the password in the <strong>Password</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip:</strong> Precede the user name by a computer workstation name and backslash for a local user, or by a domain name and backslash for domain users.</td>
</tr>
</tbody>
</table>

4. Click **OK**.

   **Step Result:** The **Connect to Ivanti Device and Application Control Application Server** dialog closes.

**Result:** The **Ivanti Device and Application Control Management Console** window opens.
Logging Out of the Management Console
When you log out from the Management Console you can choose to terminate the administrative session or disconnect from the Application Server.

1. To disconnect from the Application Server, select File from the navigation bar.
2. Select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disconnect</td>
<td>The Management Console remains open.</td>
</tr>
<tr>
<td>Exit</td>
<td>The Management Console closes.</td>
</tr>
</tbody>
</table>

**Result:** The Disconnect or Exit action terminates your current administrative session.

Device Control Modules
The Device Control Modules provide access to the functions necessary for configuring and managing and are grouped into three modules, represented by the icons in the Modules section of the Control Panel.

The following table describes the functions of the Modules icons.

**Table 7: Device Control Modules**

<table>
<thead>
<tr>
<th>Module</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Explorer</td>
<td>🌐</td>
<td>Grants access to input/output (I/O) devices for specific users or groups. Establishes copy limits and activates file shadowing. Allows users to encrypt removable devices on-the-fly for decentralized encryption.</td>
</tr>
<tr>
<td>Log Explorer</td>
<td>📝</td>
<td>Shows records of files transferred from any computer to authorized I/O devices and the contents of the files (shadowing). Shows user attempts to access or connect unauthorized devices. Provides templates to create customized reports.</td>
</tr>
<tr>
<td>Media Authorizer</td>
<td>🎈</td>
<td>Provides for central encryption of removable devices. Allows for users to access specific CD/DVD. Allows for users to use specific encrypted media.</td>
</tr>
</tbody>
</table>
**Getting Started**

The Management Console can only be accessed by authorized network administrators.

Before you begin to use Ivanti Device and Application Control, you must define the following users in the domain:

- An administrative user with local Administrator rights.
- A Ivanti Device and Application Control client user with domain user rights.

**Managing Devices**

When Device Control is initially installed, all removable storage devices that belong to standard Microsoft Windows® device classes are identified and added to the database. You can set up and manage user access permission rules for the different models and specific device types using the **Device Explorer**.

Using the **Device Explorer** you can add devices and device types for computers and add computers that are not included in the Active Directory structure. You can define general user access permission policies based on the predefined device classes.

**Restriction:** You can add specific device models to all base device classes, except the **PS/2 ports** classes.

**Device Permission Default Settings**

When Device Control is initially installed, default user access permission rules apply to all supported predefined device classes.

The following table describes default permission settings for the predefined devices classes.

<table>
<thead>
<tr>
<th>Device Class</th>
<th>Permission</th>
<th>Shadow</th>
<th>Copy Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>COM/Serial Ports</td>
<td>No access</td>
<td>Disable</td>
<td>Not available</td>
</tr>
<tr>
<td>CD/DVD Drives</td>
<td>No access</td>
<td>Disable</td>
<td>Not available</td>
</tr>
<tr>
<td>Floppy Disk Drives</td>
<td>No access</td>
<td>Disable</td>
<td>Not available</td>
</tr>
<tr>
<td>Keyboards/Mice</td>
<td>Read/Write (Low Priority)</td>
<td>Not available</td>
<td>Not available</td>
</tr>
<tr>
<td>LPT/Parallel Ports</td>
<td>No access</td>
<td>Disable</td>
<td>Not available</td>
</tr>
<tr>
<td>Modems/Secondary Network Access Devices</td>
<td>No access</td>
<td>Disable</td>
<td>Not available</td>
</tr>
<tr>
<td>Portable Devices</td>
<td>No access</td>
<td>Disable</td>
<td>No limit</td>
</tr>
</tbody>
</table>
### Device Types Supported

Device Control supports a wide range of device types that represent key sources of confidential data security breaches. You can define user access permission at the device class level to restrict access to specific device types. Device Control can detect plug-and-play devices.

The device types you can manage using Device Control are described in the following table.

Table 9: Supported Device Types

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Biometric Devices</strong></td>
<td>Includes <em>Password Managers</em> and <em>Fingerprint</em> readers.</td>
</tr>
<tr>
<td><strong>Citrix Network Shares</strong></td>
<td>Includes any mapped drive, whether a mapped network drive or a locally mapped device, when accessed through either a Citrix–delivered application or the Citrix desktop.</td>
</tr>
<tr>
<td><strong>COM/Serial Ports</strong></td>
<td>Includes serial ports and devices that use COM device drivers, such as modems, null modems and terminal adaptors. Some PDA cradles use a virtual serial port, even when connected through the <em>USB</em> port.</td>
</tr>
<tr>
<td><strong>DVD/CD Drives</strong></td>
<td>Includes CD-ROM and DVD access for full device lock and unlock.</td>
</tr>
<tr>
<td><strong>Floppy Disk Drives</strong></td>
<td>Includes disk drive access for complete lock and unlock mode or read-only mode of conventional diskettes and high capacity drives.</td>
</tr>
<tr>
<td><strong>Imaging Devices</strong></td>
<td>Includes USB or SCSI devices, scanners, and webcam.</td>
</tr>
<tr>
<td><strong>Keyboards/Mice</strong></td>
<td>Includes keyboards/mice that use USB, PS/2, and Bluetooth.</td>
</tr>
<tr>
<td><strong>LPT/Parallel Ports</strong></td>
<td>Includes conventional parallel printer ports and variants such as ECB and Dongles.</td>
</tr>
<tr>
<td><strong>Modems/Secondary Network Access Devices</strong></td>
<td>Includes internal and external devices. Secondary network devices do not connect through normal channels.</td>
</tr>
<tr>
<td><strong>Palm Handheld Devices</strong></td>
<td>Includes conventional types of this device.</td>
</tr>
<tr>
<td>Device Type</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Portable Devices</strong></td>
<td>Includes smart storage devices such as MP3 players, digital still cameras, mobile phones, mobile storage devices, and Windows Mobile 6.x OS PDAs.</td>
</tr>
<tr>
<td><strong>Printers</strong></td>
<td>Includes print devices attached directly to a print server or directly to a network through a network adapter card.</td>
</tr>
<tr>
<td><strong>PS/2 Ports</strong></td>
<td>Includes the conventional type of port used to connect keyboards.</td>
</tr>
<tr>
<td><strong>Removable Storage Devices</strong></td>
<td>Includes chip- and disk-based devices that are not floppy or CD-ROM devices, such as Jaz and PCMCIA hard drives and USB memory devices such as memory stick, Disk on Key, AIP, and most USB-connected MP3 players and digital cameras.</td>
</tr>
<tr>
<td><strong>Note:</strong></td>
<td>Non-system hard drives are treated as removable storage devices.</td>
</tr>
<tr>
<td><strong>RIM Blackberry Handhelds</strong></td>
<td>Includes handheld computers and mobile phones from Research in Motion (RIM) BlackBerry connected to a computer through a USB port.</td>
</tr>
<tr>
<td><strong>Smart Card Readers</strong></td>
<td>Includes eToken and fingerprint readers for smart cards.</td>
</tr>
<tr>
<td><strong>Tape Drives</strong></td>
<td>Includes conventional internal and external tape drives of any capacity.</td>
</tr>
<tr>
<td><strong>User Defined Devices</strong></td>
<td>Includes devices that do not fit standard categories, such as some PDAs, non-Compaq iPAQ, USB, non-Palm handheld USB, Qtec, HTC and webcams.</td>
</tr>
<tr>
<td><strong>Virtualized USB Devices</strong></td>
<td>Includes generic redirects to USB devices in virtualized environments (Citrix and VMWare).</td>
</tr>
<tr>
<td><strong>Windows CE Handheld Devices</strong></td>
<td>Includes the HP iPAQ® or XDA, Windows Mobile 5 CE® devices and Windows CE® computers connected through a USB port.</td>
</tr>
<tr>
<td><strong>Wireless Network Interface Cards (NICs)</strong></td>
<td>Includes the device option to configure client permission rules use a wireless LAN adaptor.</td>
</tr>
</tbody>
</table>
**Device Explorer Window**

An administrator uses the *Device Explorer* hierarchy to create and manage device and computer user groups, as well as, assign permission rules for online, offline, temporary and scheduled device use. The *Device Explorer* module is also used to create and manage file shadowing rules.

The main window of the *Device Explorer* module displays a hierarchical structure of device classes, which is divided into two primary levels:

- **Default settings** which contain the user access permission rules that apply to every computer.
- **Machine-specific settings** which contain unique user access permission rules that apply to a specific computer or group of computers.

![Device Explorer Main Window](image)

**Figure 40: Device Explorer Main Window**

The *Device Explorer* window is further divided into the following columns:

**Table 10: Device Explorer Window Column Descriptions**

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Devices</td>
<td>Lists device classes and users or user groups with permission to access devices.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Shows a description of the type of permission provided to users and user groups listed in the <em>Devices</em> column.</td>
</tr>
<tr>
<td>Priority</td>
<td>Shows a priority of <strong>High</strong> or <strong>Low</strong> assigned to rules listed in the <em>Permissions</em> column.</td>
</tr>
<tr>
<td>Filters</td>
<td>Shows a description of the file type filtering rules assigned to rules listed in the <em>Permissions</em> column.</td>
</tr>
<tr>
<td>Details</td>
<td>Shows a description of permissions rules details.</td>
</tr>
<tr>
<td>Comments</td>
<td>Ivanti Device and Application Control administrators can select permission rules and enter comments by clicking the <em>Comments</em> column heading.</td>
</tr>
</tbody>
</table>
Permissions Dialog
An administrator uses the Permissions dialog to create and manage permission rules for devices and associate these rules with user and user group access rights.

The Permissions dialog is the primary tool that an administrator uses to:

- Assign and manage user access permission rules for devices connected to client computers.
- Force encryption of removable storage media that users are permitted to access.

The Permissions dialog is composed of five panels:

- User/Group
- Permissions
- Encryption
- Bus
- Drive

Figure 41: Permission Dialog

The following tables described the Permissions dialog panels.

Table 11: User/Group Panel

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Shows the name of the user or user group.</td>
</tr>
<tr>
<td>Location</td>
<td>Shows the user domain or work group name.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Lists the rules defined by the Permissions panel.</td>
</tr>
<tr>
<td>Priority</td>
<td>Shows the permission priority specified as High or Low.</td>
</tr>
<tr>
<td>Filters</td>
<td>Shows the file types that the user or user group can access.</td>
</tr>
</tbody>
</table>
Using Device Control

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope</td>
<td>Shows the permission defined in the <em>Encryption</em>, <em>Bus</em>, and <em>Drive</em> panels.</td>
</tr>
</tbody>
</table>

Table 12: Permissions Panel

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read</td>
<td>A user or user group has read access.</td>
</tr>
<tr>
<td>Write</td>
<td>A user or user group has write access.</td>
</tr>
<tr>
<td>Encrypt</td>
<td>A user or user group can encrypt devices.</td>
</tr>
<tr>
<td>Decrypt</td>
<td>A user or user group can decrypt an encrypted device.</td>
</tr>
<tr>
<td>Export to file</td>
<td>The passphrases or public keys from user certificates are used to create a symmetric key for device encryption. When the <strong>Self Contained Encryption</strong> option is selected, the encryption key can be stored in a separate file and password protected. This is the most secure method, because the encryption key and the encrypted data can be transported separately.</td>
</tr>
<tr>
<td>Export to media</td>
<td>The passphrases or public keys from user certificates are used to create the symmetric key used to encrypt a device. When the <strong>Self Contained Encryption</strong> option is selected, the encryption key can be stored on the same device used for encryption and password protected. The only protection of the data is the password itself.</td>
</tr>
<tr>
<td>Import</td>
<td>When the <strong>Self Contained Encryption</strong> option is selected, a user can access encrypted media by specifying a separate key file, which is not stored on the encrypted media, and providing the associated password.</td>
</tr>
</tbody>
</table>

**Restriction:** Permission to **Encrypt**, **Decrypt**, **Export to file**, **Export to media**, and **Import** is available only for the **Removable Storage Devices** class.

Table 13: Encryption Panel

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Self Contained Encryption</td>
<td>The assigned <em>Permissions</em> apply to the device when encrypted with Device Control self-contained encryption technology.</td>
</tr>
<tr>
<td>BitLocker Encryption</td>
<td>The assigned <em>Permissions</em> apply to the device when encrypted with BitLocker Drive Encryption.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Unencrypted (Unencrypted or unknown encryption type)</td>
<td>The assigned Permissions apply to the device when unencrypted or encrypted with an unsupported technology.</td>
</tr>
</tbody>
</table>

Table 14: Bus Panel

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>Permissions apply when a device is connected through any bus connection.</td>
</tr>
<tr>
<td>USB</td>
<td>Permissions apply when a device is connected through a USB 1.1 and 2.0 or higher standard interface.</td>
</tr>
<tr>
<td>Firewire</td>
<td>Permissions apply when a device is connected through a Firewire IEEE 1394 standard interface.</td>
</tr>
<tr>
<td>ATA/IDE</td>
<td>Permissions apply when a device is connected through the ATA/IDE, SDATA-1, SATA-2 and eSATA variants interfaces.</td>
</tr>
<tr>
<td>SCSI</td>
<td>Permissions apply when a device is connected through the SCSI narrow, wide and ultra variants interfaces.</td>
</tr>
<tr>
<td>PCMCIA</td>
<td>Permissions apply when a device is connected through the PCMCIA CARDBUS interface, including the Expresscard/34 and /54 variants.</td>
</tr>
<tr>
<td>Bluetooth</td>
<td>Permissions apply when a device is connected through the Bluetooth standard interface.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> A Bluetooth device must be restarted for a permission change to take effect.</td>
</tr>
<tr>
<td>IrDA</td>
<td>Permissions apply when a device is connected through the IrDA (infrared) standard interface.</td>
</tr>
</tbody>
</table>

Restriction: Only standard interface types supported by the device class you select are available for defining permissions.

Table 15: Drive Panel

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Both</td>
<td>Permission rules apply to the hard drive and non-hard drive for the device class selected.</td>
</tr>
<tr>
<td>Hard Drive</td>
<td>Permission rules apply only to the hard drive for the device class selected.</td>
</tr>
<tr>
<td>Options</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Non-Hard Drive</td>
<td>Permission rules apply to the non-hard drive for the device class (including Removable Storage Devices) selected.</td>
</tr>
</tbody>
</table>

**Manage Devices**

Within a device class, you can create groups that contain models or unique device IDs. Managing devices in groups reduces the administrative burden for assigning and tracking device permissions.

You can assign device permissions at the following levels:

- Class
- Group
- Model
- Unique Device ID

**Restriction:** You can not add specific device model types to the **PS/2 Ports** class.

1. In the Management Console select **View > Modules > Device Explorer**.
2. In the hierarchical device structure shown in the **Device Explorer** window, right-click **Default settings**.
3. Select **Manage Devices** from the right-mouse menu.

   **Step Result:** The **Manage Devices** dialog opens.

   ![Manage Devices Dialog](image)

4. Click **Add new**.

   **Step Result:** The **Devices** dialog opens.

   ![Devices Dialog](image)
5. Click the ellipses to show a list of computer names registered in the Active Directory, synchronized to the database, and/or logged in to the network.

6. Select a computer from the **Select Computer** dialog and click **OK**.

7. Click **Get Devices**.

   **Step Result:** The **Devices** dialog refreshes to show a list of devices detected for the computer you selected. Information available:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local Name</td>
<td>Customizable name associated with the device in the Management Console.</td>
</tr>
<tr>
<td>Detected Name</td>
<td>Device name as detected by the agent.</td>
</tr>
<tr>
<td>Type</td>
<td>Functional capability of the device. For example, Removable Storage Device or Printer.</td>
</tr>
<tr>
<td>Online</td>
<td>Indicates the connection status of the device to the endpoint (Yes or No). Unknown displays when a device on a pre-4.6 endpoint is queried by the Management Console.</td>
</tr>
<tr>
<td>Time</td>
<td>Time and date the device was last detected.</td>
</tr>
<tr>
<td>Unique ID</td>
<td>Unique identifier for the device.</td>
</tr>
</tbody>
</table>

8. Select device(s) using the check box adjacent to the device name.

9. Click **Add Devices**.

   **Step Result:** The **Devices** dialog refreshes showing the devices you added as greyed selections.

   **Tip:** You can save a log entry for all the devices connected to the selected computer by clicking **Save Log**.

10. Click **Close**.

   **Result:** The new device(s) are shown in the **Device Explorer** window.

**Add Computers**

You can add computers to a domain group or computer workgroup in the **Machine-specific settings** structure of the **Device Explorer**.

When Device Control is used for computers in a workgroup, rather than a domain, then there is no domain controller list of users. You must add the computers individually to a workgroup.

1. In the Management Console select **View > Modules > Device Explorer**.

2. Right-click the **Machine-specific settings** level in the hierarchical device structure.
3. From the right-mouse menu, select Insert Computer.

4. From the Select Computer dialog, click Search.

5. Select one or more computers from the list shown.
   a) To add a computer that is not listed, click Add.
   b) Type the name of the computer to be added in the corresponding field.

6. Click OK.

**Result:** The computers you selected are added to the domain group.

**Tip:** You can drag-and-drop computers from one group to another, or you can right-click a computer and use Cut and Paste from the right-mouse menu.

---

### Assign Permissions by Devices

You can assign permission rules for users to access devices and device classes with any computer the user selects.

Permission rules can be assigned in the Device Explorer to the:

- Root node of the Default settings hierarchy.
- Device class node of the Default settings hierarchy.
- Device group within a device class node shown in the Default settings hierarchy.
- Device by make and/or model.
- Device by unique serial number.

**Note:** Root node permissions are assigned to the root of the Device Explorer hierarchy and apply to all devices for specific users or user groups.

1. In the Management Console select View > Modules > Device Explorer.
2. Right-click a node from the Default settings division of the Device Explorer hierarchical structure.
3. Select Add/Modify Permissions from the right-mouse menu.

**Step Result:** The Permissions dialog opens.

4. Click Add.

**Step Result:** The Select Group, User, Local Group, Local User dialog opens.

5. Click Search or Browse.

6. Select a user or user group.

7. Click OK.

8. In the Permissions dialog, select the user or user group to assign user access permission rules.
9. Select the permission options.

**Important:** Only the permissions options available for the device or device class selected are shown.

10. To limit user access to certain file types, click Filter.

**Restriction:** File filtering is available only for the Removable Storage Devices, Floppy Disk Drives, Portable Devices and CD/DVD Drives device classes.

**Step Result:** The File Type Filtering dialog opens.

![File Type Filtering Dialog](image)

11. Select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All file types (Import/Export)</td>
<td>Permission rules apply to all file types that are imported and exported by the user or user group for the specified device or device class.</td>
</tr>
<tr>
<td>Only files selected from this list:</td>
<td>Permission rules apply to only to selected file types that are imported and/or exported by the user or user group for the specified device or device class.</td>
</tr>
</tbody>
</table>

A complete list of the file filter types supported by Device Control is shown in the Targets panel. Select file types using the check boxes adjacent to the file type name. You can also select Manage custom file types... to add, edit or remove custom file types.

12. In the Permissions panel, select one or both of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td>Allows a user to copy files from the Ivanti Device and Application Control client computer to an external device.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>Import</td>
<td>Allows a user to copy files from an external device to the Ivanti Device and Application Control client computer.</td>
</tr>
</tbody>
</table>

**Important:** You must select **Import** or **Export** at a minimum, to enforce file filtering rules.

13. Click **OK**.

14. In the **Permissions** dialog, click **OK**.

**Result:** The Permissions, Priority, and Filters you assign to the device or device class are shown in the Device Explorer hierarchical structure.

**After Completing This Task:**
You should send new or updated permissions immediately to Ivanti Device and Application Control client computers using the Control Panel > Tools > Send Updates option. If you do not send updates to protected clients immediately, they automatically receive updates when they restart or at next user log in.

**Assign Temporary Permissions to Users**
You can assign time-limited, once-per-occurrence permission rules on a computer-specific basis for user access to a device.

An administrator can allow access to a device for a limited period without having to subsequently delete the permission. This provides some reduction in administrative burden.

1. In the Management Console select **View > Modules > Device Explorer**.

2. From the Machine-specific settings division of the Device Explorer hierarchical structure, select computer or computer group.

3. Right-click a device or device class.

4. Select Add Temporary Permissions from the right-mouse menu.

   **Step Result:** The Choose User on (per selected device) dialog opens.

5. Click **Add**.

   **Step Result:** The Select Group, User, Local Group, Local User dialog opens.

6. Click Search or Browse to select a user or user group.

7. Select a user or user group and click **OK**.

   **Step Result:** The Choose Permission dialog opens.

8. Click Next.

9. Select the Read and/or Write permissions that you want to apply.
10. Click Next.
   
   **Step Result:** The **Choose Period** dialog opens.

11. Select one of the following options:

<table>
<thead>
<tr>
<th>Options</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Immediately</td>
<td>Permission rules apply immediately (within 5 minutes).</td>
</tr>
<tr>
<td>From</td>
<td>Permission rules apply for the period you specify.</td>
</tr>
</tbody>
</table>

12. Click Next.

13. Click Finish.

**Result:** The temporary permission access rules appear in the **Details** column of the **Device Explorer** window.

**Assign Scheduled Permissions to Users**

You can schedule user access permissions rules to limit the use of devices to hourly and daily periods of the week.

You can assign global or computer-specific scheduled device permissions for users and user groups.

1. In the Management Console select **View > Modules > Device Explorer**.

2. In the **Default settings** division of the **Device Explorer** hierarchical structure, right-click a device or device class.

3. Select **Add Schedule** from the right-mouse menu.
   
   **Step Result:** The **Choose User on Default Settings** dialog opens, per selected device.

4. Click **Add**.
   
   **Step Result:** The **Select Group, User, Local Group, Local User** dialog opens.

5. Click **Search** or **Browse** to select a user or user group.

6. Select a user or user group and click **OK**.
   
   **Step Result:** The **Choose User on Default Settings** (per selected device) dialog opens.

7. Select the user or user group and click **Next**.

8. Select from the listed user access options.

   **Restriction:** Only user access options for the device class selected are shown.

9. Click **Next**.
   
   **Step Result:** The **Choose Timeframe** dialog opens.
10. Specify hourly time ranges using the To and From field dropdown lists.
11. Select one or more weekdays from the Weekdays panel.
12. Click Next.
13. Click Finish.

**Result:** The scheduled permission access rule appears in the Details column of the Device Explorer window.

### Add Shadowing

An administrator can establish visibility for the file content read from and written to devices connected to clients. This type of visibility is referred to as file shadowing.

File shadowing can be applied to the following device classes:

- **COM/Serial Ports**
- **DVD/CD Drives**

**Note:** When burning to a CD/DVD/BD, files burned only during a single/first session are shadowed.

- **LPT/Parallel Ports**
- **Floppy Disk Drives**
- **Modem/Secondary Network Access Devices**
- **Printers**

**Note:**
- You can only assign shadowing to the main printer class under default settings or to a special PC under Machine-specific settings.
- Only print jobs sent to printers that use the Microsoft Windows Print Spooler service are shadowed.

- **Removable Storage Devices**

You can also apply file shadowing to:

- Device groups
- Computer-specific devices or device model types

1. In the Management Console select View > Modules > Device Explorer.
2. From the Default settings division of the Device Explorer hierarchy, right-click a device, device class, or device type.
3. Select Add Shadow from the right-mouse menu.
4. Click Add.

**Step Result:** The Select Group, User, Local Group, Local User dialog opens.
5. Select the user or user group and click **Next**.

   **Step Result:** The **Choose Bus** dialog opens.

   ![Choose Bus Dialog](image)

   Figure 45: Choose Bus Dialog

6. Select **All** or individual bus types.

   **Important:** The available bus types shown are dependent upon the device class you select. The **Encryption** panel is only active, with all options selected by default, for the **Removable Storage Devices** and **DVD/CD Drives** device classes.

7. Select a **Drive** option.

8. Click **Next**.

   **Step Result:** The **Choose Permissions** dialog opens.

   ![Choose Permissions Dialog](image)

   Figure 46: Choose Permission Dialog

9. In the **Read** and/or **Write** panels, choose one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disabled</td>
<td>File content copying is not active.</td>
</tr>
<tr>
<td>FileName</td>
<td>File content copying is not active; only the file name for a file copied to or from a device is saved in the Ivanti Device and Application Control database.</td>
</tr>
</tbody>
</table>
**Table:**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>File content copying is active.</td>
</tr>
</tbody>
</table>

**Restriction:** Only the **Write** panel is active for the **COM/Serial Ports, LPT/Parallel Ports** and **Printers** device classes.

10. Click Next.

11. From the **Finish** dialog, click **Finish**.

**Result:** The shadow rule permission details are shown in the **Permissions** column of the **Device Explorer** hierarchical structure. The shadow permission details are displayed in the **Permissions** column of the **Device Explorer** module. A value of **R** means that shadowing is enabled for files read to and from the device, **W** means that it is on when files are written to and from the device; no letter means that shadowing is enabled for both reading and writing files. You can review shadowed files using the **Log Explorer** module.

**View Shadow Files**

To view shadow files, you can use predefined templates. When a predefined template does not contain the type of data that you want to review, you can create your own template query to view shadow files.

**Prerequisites:**

To view shadow files, Ivanti recommends that you show only log entries that display attachments by filtering templates.

The file name, date, and administrator name are logged for every instance a shadowed file is accessed.

1. In the Management Console select **View > Modules > Log Explorer > Templates**.

   **Step Result:** The **Select and edit template** dialog opens.

2. Select a predefined shadow template from the list shown.

   **Caution:** Avoid opening files exceeding 350 MB unless sufficient resources are available.

3. Click **Select**.

4. Click **Query**.

5. To view shadow files using a custom query:

   a) Click **Settings**.
   b) Select **Attachment**.
   c) Click **Criteria**.
   d) Select **With**.
   e) Click **OK**.
f) Click **Execute Query**.

**Step Result:** The **Select and edit template** dialog closes and the query runs.

**Result:** When the **Shadow** rule is enforced, the entries listed show attached files that are exact copies of the shadowed files:

- Copied to or from authorized devices
- Read by users

Depending on the selected fields, the date shown for shadow files are:

- **Traced On** - when files were copied or read, to or from, the device
- **Transferred On** - when a file was uploaded to the database

Device Control tracks the:

- User name for the copied file
- Computer name used for the copy action
- Filename
- Content
- Device name

**After Completing This Task:**
Once you list the files, right-click any attachment showing the **True** value, which indicates that the full content is shadowed, and select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View</strong></td>
<td>Allows you to view the contents of the file in an internal binary viewer</td>
</tr>
<tr>
<td></td>
<td>administered by Device Control.</td>
</tr>
<tr>
<td><strong>Open</strong></td>
<td>Opens the file with the associated application as defined in Windows</td>
</tr>
<tr>
<td></td>
<td>Explorer®. If there is no association, this command is equivalent to Open</td>
</tr>
<tr>
<td></td>
<td>With.</td>
</tr>
<tr>
<td><strong>Restriction:</strong></td>
<td>Only available for full shadowing and when selecting one log registry.</td>
</tr>
<tr>
<td><strong>Open with</strong></td>
<td>Allows you choose the application that opens the file.</td>
</tr>
<tr>
<td><strong>Restriction:</strong></td>
<td>Only available for full shadowing and when selecting one log registry.</td>
</tr>
<tr>
<td><strong>Save as</strong></td>
<td>Allows you to save the file to a local or network drive and use an external</td>
</tr>
<tr>
<td></td>
<td>utility or program to open the file.</td>
</tr>
</tbody>
</table>
Filtering Templates
You can create subsets of the templates listed in the Select and Edit Templates dialog.
You can select multiple filtering criteria to narrow the focus of template sets shown, thereby reducing the number of templates that are listed.

1. From the Management Console, select View > Modules > Log Explorer > Templates.
   **Step Result:** The Select and Edit Templates dialog opens.

2. Click Filter.
   **Step Result:** The Filter dialog opens.

   ![Filter Dialog](image)

   Figure 47: Filter Dialog

3. Select one or more of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Private</td>
<td>Shows templates visible only to the template owner and Enterprise Administrator.</td>
</tr>
<tr>
<td>Published</td>
<td>Shows templates visible to all Management Console users within your system that can be:</td>
</tr>
<tr>
<td></td>
<td>• accessed and used by any user,</td>
</tr>
<tr>
<td></td>
<td>• edited, and saved by the owner and Enterprise Administrators,</td>
</tr>
<tr>
<td></td>
<td>• edited but not saved by Administrators.</td>
</tr>
<tr>
<td>Shared</td>
<td>Shows templates viewed and changed by any Management Console users within your system.</td>
</tr>
<tr>
<td>Non-scheduled</td>
<td>Shows templates used to generate specific reports.</td>
</tr>
<tr>
<td>Scheduled</td>
<td>Shows templates automatically run periodically to generate regular reports. These are saved in a shared folder on your network or e-mailed to specified recipients.</td>
</tr>
<tr>
<td>Created by others</td>
<td>Shows templates created by users other than the Enterprise Administrator.</td>
</tr>
</tbody>
</table>
4. Click OK.

Result: A subset of all available templates is shown.

Sending Updates to All Computers
After you define or update device permissions or file permissions, you can send the information to all client computers immediately. Otherwise, updated information will automatically upload the next time a user logs in or the computers are restarted.

1. From the Management Console, select **Tools > Send Updates to All Computers**.

   **Step Result:** The **Send updates to all computers** dialog opens.

2. Select one of the following options from the **Send updates to all computers** dialog.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Yes</strong></td>
<td>Immediately updates connected computers. Ivanti Device and Application Control can take a long time to send updates depending on the number of computer connections. The Management Console dialog remains open until the Application Server finishes sending the updates.</td>
</tr>
<tr>
<td><strong>No</strong></td>
<td>Asynchronously updates connected computers. The Management Console dialog closes while the Application Server finishes sending the updates. You can continue working with the console while the update is done in the background.</td>
</tr>
<tr>
<td><strong>Cancel</strong></td>
<td>Closes the <strong>Send updates to all computers</strong> dialog and halts the update process.</td>
</tr>
</tbody>
</table>

Result: Updates are distributed to all computers running the Ivanti Device and Application Control clients that are registered in the Application Server(s) online table(s). A message appears in the **Output** window when the updates are complete.

Remember: Any computer that is switched off, locked, or disconnected from the network receives the updates at the next network connection.
Authorizing CD/DVDs

The Device Control **Media Authorizer** module provides administrators the ability to encrypt non-bootable hard disk or flash removable storage media, and authorize user access to the encrypted media. Removable storage media are defined for Device Control as any device recognized by the Windows *removable storage devices* class through the *plug-and-play* feature.

With the **Media Authorizer** you can:

- Add CD/DVD media to the database.
- Authorize user access to individually specified CD/DVD media in the network environment.
- Perform centralized data encryption for removable storage media.
- Perform centralized data encryption for removable storage media used when computers and users are connected to your network environment.
- Rename CD/DVD disk media that has been added to the database.
- Authorize user access to encrypted removable storage media in the network environment.
- Export encryption keys to provide access to encrypted media used outside your network environment.

Add CD/DVD Media

An administrator can add CD/DVD media to the database.

**Prerequisites:**

To successfully add CD/DVD media to the database, the following conditions must be met:

- The administrator have **Read** or **Read/Write** permission assigned as using the **Device Explorer** module.
- A client is installed on the same computer as the Management Console where user access is authorized.

1. In the Management Console select **View > Modules > Media Authorizer**.
2. Click **Add CD/DVD**.
   - **Step Result:** You are prompted to insert a CD/DVD.
3. Insert the CD/DVD.
   - **Step Result:** The **Media Authorizer** calculates a unique cryptographic signature and displays the **Media Name** dialog.
4. Click **OK**.
   - **Result:** The **Media Name** label is used to register the CD/DVD in the database.
Log Explorer Templates

The operation of the Log Explorer module is based on templates that allow you to generate custom reports containing results that match specific criteria.

A template is a set of rules used for displaying audit and activity log data in the Log Explorer. You can create your own templates or use predefined ones created by Ivanti.

**Note:** The list of predefined templates depends upon your license type.

View Administrator Activity

You can use the Log Explorer module to monitor Ivanti Device and Application Control administrator activity.

Administrator activity includes changing user access rights, device permissions, and file authorizations. Access to audit log information depends upon administrative user access rights established when you define user access rights in the Tools module.

1. From the Management Console, select View > Modules > Log Explorer.
   
   **Step Result:** The Log Explorer window opens.

2. Select the Audit by Admin template.
   
   **Note:** You may also use a template that you create.

3. Click Query.

   **Result:** A list of administrator audit log events is shown in the Log Explorer window.

Upload Latest Log Files

You may need to view the most current log information to help you quickly troubleshoot problems or verify that permissions or authorizations are set correctly.

Clients upload log information to the Application Server at the time specified when you define default options. You can use the Log Explorer to fetch log activity as needed, rather than waiting for the next log activity upload.

1. From the Management Console, select View > Modules > Log Explorer.
   
   **Step Result:** The Log Explorer window opens.
2. Click Fetch Log.

   **Step Result:** The Select Computer dialog opens and prompts you to specify the client computer to fetch the logs from.

   ![Figure 48: Fetch Logs - Select Computer](image)

3. Click **Search** or **Browse** to select from a list.

4. Click **OK**.

   **Result:** The computer logs are uploaded to the Application Server and stored in the database. Updated log files are shown in the Log Explorer window.

   **Restriction:** The time delay between retrieving the log entries from the client and the availability of the latest logs depends on the queue size and the database availability at the time of upload.

---

**Reporting**

Ivanti Device and Application Control provides pre-defined reports designed to provide a comprehensive view of your computing environment for activities.

Reports provide a way to view current device permission policy information. Reports are generated as HTML files that are displayed in the main window of any module. You can be print, copy, convert, save, and modify as necessary. In addition to the standard reports, you can customize and generate your own reports, using the Log Explorer module.

After saving a report, you can view it using any web browser that you system supports. You can change the date format for a report by selecting **Windows Control Panel > Regional and Language Options**. The regional options or settings vary according to the Windows operating system you are using.

**Opening a Report**

You open a report by selecting a predefined report type listed in the Reports module.

1. From the Management Console, select Reports.

2. Select a report type from the list.

   **Result:** The report you select is displayed as an HTML file in the Management Console main window.
**Printing a Report**  
You may print a report that you generate.

1. From the Management Console, select **File > Print**.  
   **Step Result:** The standard Windows **Print** dialog opens.

2. Select a printer.
3. Click **Print**.  
   **Step Result:** The Windows **Print** dialog closes.

**Saving a Report**  
You may save a report that you generate.

1. From the Management Console, select **File > Save as**.  
   **Step Result:** The **Windows** dialog for saving a web page opens.

2. Select the file path.
3. Type the file name.
4. Select the file type from the **Save as type** dropdown list.
5. Select an encoding method from the **Encoding** dropdown list.
6. Click **Save**.  
   **Step Result:** The **Windows** dialog for saving a web page closes.
User Permissions Report

You can generate a report that shows the permission rules defined for each user or user group that you specify. You may select one or more users to view report results for. The name of the specific user you select is shown preceding the report results.

User Permissions

**Local System** (Well-known User)

<table>
<thead>
<tr>
<th>Device</th>
<th>Computer</th>
<th>Permissions</th>
<th>Priority</th>
<th>Details</th>
<th>User / Group Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>C:驱动/ Serial Ports</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>DVD/CD Drive</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>Removable Storage Devices</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>USB/Parallel Ports</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>Modem/Secondary Network Access Devices</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>PSC/ Port</td>
<td>Default Settings</td>
<td>Read/Write</td>
<td>Low</td>
<td>n/a</td>
<td>Everyone</td>
</tr>
<tr>
<td>Wireless NICs</td>
<td>Default Settings</td>
<td>Read/Write</td>
<td>High</td>
<td>n/a</td>
<td>Everyone</td>
</tr>
</tbody>
</table>

**Guest** (Local User)

<table>
<thead>
<tr>
<th>Device</th>
<th>Computer</th>
<th>Permissions</th>
<th>Priority</th>
<th>Details</th>
<th>User / Group Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>C:驱动/ Serial Ports</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>DVD/CD Drive</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>Removable Storage Devices</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>USB/Parallel Ports</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>Modem/Secondary Network Access Devices</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>PSC/ Port</td>
<td>Default Settings</td>
<td>Read/Write</td>
<td>Low</td>
<td>n/a</td>
<td>Everyone</td>
</tr>
<tr>
<td>Wireless NICs</td>
<td>Default Settings</td>
<td>Read/Write</td>
<td>High</td>
<td>n/a</td>
<td>Everyone</td>
</tr>
</tbody>
</table>

**Everyone** (Well-known Group)

<table>
<thead>
<tr>
<th>Device</th>
<th>Computer</th>
<th>Permissions</th>
<th>Priority</th>
<th>Details</th>
<th>User / Group Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>C:驱动/ Serial Ports</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>DVD/CD Drive</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>Removable Storage Devices</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>USB/Parallel Ports</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>Modem/Secondary Network Access Devices</td>
<td>Default Settings</td>
<td>Disabled</td>
<td>High</td>
<td>Shadow Override</td>
<td>Everyone</td>
</tr>
<tr>
<td>PSC/ Port</td>
<td>Default Settings</td>
<td>Read/Write</td>
<td>Low</td>
<td>n/a</td>
<td>Everyone</td>
</tr>
<tr>
<td>Wireless NICs</td>
<td>Default Settings</td>
<td>Read/Write</td>
<td>High</td>
<td>n/a</td>
<td>Everyone</td>
</tr>
</tbody>
</table>

Figure 49: User Permissions Report

The following table describes the report columns.

Table 17: User Permissions Column Descriptions

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Shows the name of the device class or a specific device.</td>
</tr>
<tr>
<td>Computer</td>
<td>Shows whether default permission settings apply to all computers or computer-specific permission setting apply to a specific computer or groups of computers.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Shows the type(s) of permission that applies to the device class.</td>
</tr>
<tr>
<td>Priority</td>
<td>Shows whether the permission is applied with a high or low priority. A low priority indicates that computer-specific exceptions to the permissions rules shown can be applied.</td>
</tr>
</tbody>
</table>
## Computer Permissions Report

You can generate a report that shows the permissions rules defined for specific computers.

### Table 18: Computer Permissions Column Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer</td>
<td>Shows the name of the computer selected for the report.</td>
</tr>
<tr>
<td>User/Group Name</td>
<td>Shows the name of the user or user group assigned to the permission rule.</td>
</tr>
<tr>
<td>Device</td>
<td>Shows the name of the device class or a specific device.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Shows the type(s) of permission that applies to the device class.</td>
</tr>
<tr>
<td>Priority</td>
<td>Shows whether the permission is applied with a high or low priority. A low priority indicates that computer-specific exceptions to the permissions rules shown can be applied.</td>
</tr>
<tr>
<td>Details</td>
<td>Show whether the file shadowing and/or copy limit rules are applied to the permission rule.</td>
</tr>
</tbody>
</table>
Using the Device Control Client

The client provides user access to encryption options for CD/DVDs and removable storage devices. A user can encrypt and manage devices with the client, provided that the network administrator establishes the necessary device permission and user access policies with the Management Console.
Chapter 4

Using Application Control

This chapter explains how Application Control works and describes how to scan, import, and manage software file authorizations.

Ivanti Device and Application Control solutions include:

• Device Control, which prevents unauthorized transfer of applications and data by controlling access to input and output devices, such as memory sticks, modems, and PDAs.
• Device Control client for Embedded Devices, which moves beyond the traditional desktop and laptop endpoints to a variety of platforms that include ATMs, industrial robotics, thin clients, set-top boxes, network area storage devices and the myriad of other systems.
• Application Control, which delivers granular control of application execution in an enterprise environment.
• Application Control Server Edition, which delivers application control to protect enterprise servers, such as web servers, e-mail servers, and database servers.

Product Overview

Ivanti Device and Application Control software is based on a multi-tier software architecture that processes and stores data for Application Control and Device Control. Users can interact with the application through the client interface. A separate Management Console provides a user interface for network administrators.

The primary components of the Application Control solution are:

• The Application Control database which serves as the central repository of authorization information for devices and applications.
• One or more Application Servers that communicate between the database, the protected clients, and the Management Console.
• The Management Console, which provides the administrative user interface for the Application Server.
• The Application Control client, which is installed on each computer, either endpoint or server, that you want to protect.
The following figure illustrates the relationships between the Ivanti Device and Application Control components.

Figure 51: Application Control Component Relationships
Application Control Server, Database and Client Process

The Application Server communicates between the database and the protected client computers. The following describes the communication process flow between the Application Servers, database, and clients when using Application Control.

Using the Management Console

The Management Console allows the user to communicate with an Application Server to send and retrieve file authorization data from the database. The data is sent from the server to a client, thereby establishing application control on the client. The Management Console provides direct access to system management, configuration, file authorization, reporting, and logging functions.

The File Authorization Setup Process

After successfully installing Application Control, an administrator uses the Management Console to configure and define user access permissions and file authorization rules required in an Ivanti Device and Application Control environment that specify which executable files, scripts, and macros each user can use, as described by the following process flow.

You can use standard Microsoft file definitions to quickly build a central file authorization list for executable files, macros, and scripts.
You can assign administrator access rights using the **User Access** tool. An **Administrator** has restricted access to the Management Console and can be assigned various administrative roles by an **Enterprise Administrator**.

After defining **Administrator** roles, you can use the **User Access** tool to assign the defined roles to **Administrators**.

File groups simplify the process of administering large numbers of executable, script, and macro files for users. Instead of individually authorizing files, you can group files together logically by creating file groups.

Ivanti Device and Application Control verifies which file group is associated with an executable, script, or macro and whether the user has access permission for the file group. You can assign specific permissions to local users and user groups. Only authorized applications and scripts assigned to a user or a user group can run on the client.

After creating the file groups and parent-child relationships you want to use, you can assign file groups to users or user groups.

You can create a template and scan a target computer running the client. You can scan all files on a computer, or you can create a template to scan selected directories or specific file types for example, *.exe, *.com, *.dll, *.ocx, *.sys, *.drv, *.cpl, *.vbs, *.js, to reduce the scan time required.

After you create the necessary file groups and required parent-child relationships, you can assign executable files, scripts, and macros to file groups.

Activating **Execution blocking** prohibits user access to unauthorized files. Local authorization is permitted only for the administrators and LocalSystem account.

Once you identify all your files, categorize them into file groups, and assign the file groups to users or user groups, these files are centrally authorized and immediately available to be run by all allowed users.
When a user wants to run an executable, script, or macro, the following actions take place automatically:

- A file that is identified as an executable, script, or macro, by the operating system is stored in the Ivanti Device and Application Control database ready for execution (but not actually executed).
- A file is identified by Ivanti Device and Application Control as an executable, script, or macro, has the entire file content checked to determine its digital signature (hash) before being allowed to execute by the operating system.
- The digital signature is compared to the digital signatures (stored in a central file authorization list) for files that are authorized to run.
- If, and only if, the file signature corresponds exactly to a file signature in the central file authorization list, in other words, the digital signatures are identical and the file is authorized for execution for the user or computer requesting authorization, can the file run.

Note: When an executable file is launched by the user, Application Control will identify and determine the digital signature (hash) of that executable regardless of the current mode (blocking or non-blocking). Although rarely detected by the user, this process of identifying the executable and determining the hash could result in a noticeable delay on some systems.

Using Application Control

The Management Console provides direct access to system management, configuration, file authorization, reporting, and logging functions.

The Management Console allows the user to communicate with an Application Server to send and retrieve file authorization data from the database. The data is sent from the server to a client, thereby establishing application control on the client. The Management Console provides direct access to system management, configuration, file authorization, reporting, and logging functions.

Logging In to the Management Console

You access the application by logging in to the Management Console.

1. Select Start > Programs > Ivanti > Endpoint Security > Ivanti Device and Application Control Management Console > Ivanti Device and Application Control Management Console.

   Step Result: Each time you access the Management Console, the Connect to Ivanti Device and Application Control Application Server dialog appears.

2. From the Application Server drop-down list, select the Application Server you want to connect to. You can type the server name as an IP address with port if required in square brackets, NetBIOS name, or fully qualified domain name in the Application Server field.
3. Select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use current user</td>
<td>By default the system connects to the Application Server using your credentials.</td>
</tr>
<tr>
<td>Log in as</td>
<td>Type the user name in the <strong>Username</strong> field and type the password in the <strong>Password</strong> field.</td>
</tr>
<tr>
<td><strong>Tip:</strong></td>
<td>Precede the user name by a computer workstation name and backslash for a local user, or by a domain name and backslash for domain users.</td>
</tr>
</tbody>
</table>

4. Click **OK**.

**Step Result:** The *Connect to Ivanti Device and Application Control Application Server* dialog closes.

**Result:** The *Ivanti Device and Application Control Management Console* window opens.

**Logging Out of the Management Console**

When you log out from the Management Console you can choose to terminate the administrative session or disconnect from the Application Server.

1. To disconnect from the Application Server, select **File** from the navigation bar.

2. Select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disconnect</td>
<td>The Management Console remains open.</td>
</tr>
<tr>
<td>Exit</td>
<td>The Management Console closes.</td>
</tr>
</tbody>
</table>

**Result:** The **Disconnect** or **Exit** action terminates your current administrative session.
Application Control Modules

The Application Control Modules provide access to the functions necessary for configuring and managing and are grouped into several modules, represented by the icons in the Modules section of the Control Panel.

The Application Control Modules provide access to the functions necessary for configuring and managing Ivanti Device and Application Control and are grouped into five modules, represented by the icons in the Modules section of the Control Panel:

Table 19: Application Control Modules

<table>
<thead>
<tr>
<th>Module</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Explorer</td>
<td>![Icon]</td>
<td>Shows the list of executable files, scripts, and macros that are stored in the Ivanti Device and Application Control database and manages file assignment details.</td>
</tr>
<tr>
<td>Exe Explorer</td>
<td>![Icon]</td>
<td>Builds a list of executable files, scripts, and macros that are allowed to run on Ivanti Device and Application Control clients, and assigns files to file groups.</td>
</tr>
<tr>
<td>Log Explorer</td>
<td>![Icon]</td>
<td>Shows logs of applications, scripts, and macros that were run, files for which access was denied, and files authorized locally.</td>
</tr>
<tr>
<td>Scan Explorer</td>
<td>![Icon]</td>
<td>Scans a computer or domain to identify executable files, scripts, and macros to be authorized, and assigns files to a file group using templates.</td>
</tr>
<tr>
<td>User Explorer</td>
<td>![Icon]</td>
<td>Links users or user groups with file groups, granting permission to use the files assigned to file groups.</td>
</tr>
</tbody>
</table>

Getting Started

The Management Console can only be accessed by authorized network administrators.

Before you begin to use Ivanti Device and Application Control, you must define the following users in the domain:

- An administrative user with local **Administrator** rights.
- A Ivanti Device and Application Control client user with domain user rights.

Building a Central File Authorization List

You can use Standard File Definitions (SFD) to simplify the task of building a central file authorization list.

Standard File Definitions (SFDs) contain digital signatures corresponding to standard executable files that are distributed with Microsoft Windows operating systems.
Using SFDs:

- Simplifies initial setup.
- Includes information necessary to automatically allocate files to predefined file groups and assign files to well-known user and user groups.
- Minimizes the risk of authorizing tampered versions of operating system files.
- Simplifies operating system upgrades because Ivanti Device and Application Control recognizes the standard files, and respective default file groups. Ivanti Device and Application Control automatically saves upgraded file definitions to the same locations as the originals.

The following table describes the system users/groups that can access the default SFD file groups.

<table>
<thead>
<tr>
<th>File Group Name</th>
<th>Users/Groups Assigned</th>
</tr>
</thead>
<tbody>
<tr>
<td>16 Bit Applications</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>Accessories</td>
<td>Administrators (group), Everyone (group)</td>
</tr>
<tr>
<td>Administrative Tools</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>Boot files</td>
<td>Local Service (user), LocalSystem (user), Network Service (user)</td>
</tr>
<tr>
<td>Communication</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>Control Panel</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>DOS Applications</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>Entertainment</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>Logon files</td>
<td>Everyone (group)</td>
</tr>
<tr>
<td>Ivanti Device and Application Control</td>
<td>Administrators (group), Everyone (group)</td>
</tr>
<tr>
<td>support files</td>
<td></td>
</tr>
<tr>
<td>Setup</td>
<td>Administrators (group)</td>
</tr>
<tr>
<td>Windows Common</td>
<td>Everyone (group)</td>
</tr>
</tbody>
</table>
Importing Standard File Definitions
You can use standard Microsoft file definitions to quickly build a central file authorization list for executable files, macros, and scripts.

1. From the Management Console, select **Tools > Import Standard File Definitions**.

   **Step Result:** The *Import Standard File Definitions* dialog opens.

   ![Import Standard File Definitions Dialog](image)

   **Figure 53: Import Standard File Definitions Dialog**

2. Click **Add**.

   **Step Result:** The *Open* dialog opens and displays files with an `.sfd` extension.

   **Tip:** You can import standard file definitions from the Self-Service Portal by downloading to a local computer and unzipping the archived files.

3. Select the standard definition file(s) to import.

4. Click **Open**.

   **Step Result:** The file(s) are shown in the *Add* window.

5. Select one or more of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Assign File Groups to Well Known Users Automatically</strong></td>
<td>Assigns the executable files, scripts, and macros found in the scan to the system users/groups.</td>
</tr>
<tr>
<td><strong>Process Known Files Automatically</strong></td>
<td>The wizard adds the file to the database if they have the same name but different digital signature.</td>
</tr>
<tr>
<td><strong>Import SFD with file hashes and create predefined File Groups:</strong></td>
<td>Ivanti Device and Application Control automatically imports standard file definition digital signatures, then creates and assigns the files to predefined file groups.</td>
</tr>
</tbody>
</table>
6. Click Import.
7. After importing standard file definitions, click OK.
8. Click Close.

**Result:** The designated standard file definitions are now authorized and assigned to respective predefined file groups and system users/groups.

**Caution:** When you import standard file definitions, you should authorize logon and boot files. If these are not authorized, the system will not work properly. This is especially important for system updates.

**After Completing This Task:** Assign the imported predefined file groups to users/groups, if you did not select the Assign File Groups to Well Known User Automatically option.

### Authorizing File Execution

An initial scan using the Scan Explorer module allows you to quickly add executable files, scripts, and macros to the Ivanti Device and Application Control database.

Once your initial scan is complete, you create files groups and assign the authorized files to file groups. You manage the files added to the database with the User Explorer and Database Explorer modules by linking file groups to users or user groups. Files not added to the database are designated as unauthorized and are denied execution.

### Creating a File Scanning Template

You can create a template to identify new file authorization changes to make when new software is installed.

You can scan for files by creating a template with the following rules:

- Scan all executables matching the pattern `*.exe` or `*.dll` in the `%SYSTEMROOT%` directory and subdirectories.
- Scan all files matching the pattern `*.exe` or `*.dll` in the `%PROGRAMFILES%` directory and subdirectories.
1. From the Management Console, select View > Modules > Scan Explorer > Perform New Scan > Create New Template.

**Step Result:** The Create New Template dialog opens.

![Create New Template Dialog](image)

2. In the **New Template name** field, enter the name for the new template.
3. Click **Add**.

**Step Result:** The New Rule dialog opens.

![New Rule Dialog](image)

4. In the **Scan files matching the pattern (use * wildcard for all files)** field, enter the name patterns to use for scanning.

**Caution:** When you specify wildcard masks, for example: *.com, you can miss scanning for files that do not use standard file extensions such as: *.exe, or *.dll, and so forth. The result is that these types of files will not be authorized, which means that these applications will not work or work properly.

5. In the **In directory** field, enter the path name for the directory you want to scan.
6. Select one or more of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include subdirectories</td>
<td>Scan subdirectories of the root directory.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Scan executables</td>
<td>Scan for executable files and ignore all other file types. The scan also searches for 16-bit executables.</td>
</tr>
<tr>
<td><strong>Attention:</strong></td>
<td>If you do not select the Scan Executables option, you must specify the *.exe and *.sys for the matching pattern to scan for these types of files.</td>
</tr>
</tbody>
</table>

7. Click **OK**.

   **Step Result:** The **New rule** dialog closes and the rules you define appear on the **Rules** box.

8. Click **Save**.

   **Result:** The **Perform New Scan** dialog lists the new template in the **From Template** drop-down list.

### Scanning Files on a Client Computer

You can scan all files on a computer, or you can create a template to scan selected directories or specific file types for example, *.exe, *.com, *.dll, *.ocx, *.sys, *.drv, *.cpl, *.vbs, *.js, to reduce the scan time required.

**Prerequisites:**

Before you scan a computer, create a file scanning template.

**Important:** If you are using Application Control with Device Control enabled, you must set the following Device Control permissions before performing a scan on a secondary hard drive.

**Device Class:** Removable

**User:** LocalSystem

**Permissions:** Read

**Encryption:** Unencrypted (Unencrypted or unknown encryption type)

**Bus:** All

**Drive:** Hard Drive

1. From the Management Console, select **View > Modules > Scan Explorer**.

   **Step Result:** The **Scan Explorer** window opens.
2. Click **Perform New Scan**.

   **Step Result:** The **Perform New Scan** dialog opens.

   ![Perform New Scan Dialog](image)

   Figure 56: Perform New Scan Dialog

3. In the **From Template** field, select a template from the drop-down list.

4. Click the ellipsis button adjacent to the **On Computer** field.
   a) Type the computer name.
   b) Click **Search** or **Browse**.
   c) Select the computer from the list.
   d) Click **OK**.

   You can type the computer name directly or use wildcard, such as * and ?.

   **Step Result:** The **Select Computer** dialog opens.

5. Click **Start Scan**.

   **Step Result:** The **Perform New Scan** dialog opens.

   ![Perform New Scan Dialog - Comment](image)

   Figure 57: Perform New Scan Dialog - Comment

6. Enter a name or comment to distinguish this scan in the **Comment** field.
7. Click OK.

**Result:** Ivanti Device and Application Control scans the specified file directories, calculates digital signatures for all executable files, scripts, and macros, and adds these digital signatures to the database. The results are shown in the *Scan Explorer* main window as follows.

![Scan Explorer Window](image_url)

**Adding a File Group**

File groups simplify the process of administering large numbers of executable, script, and macro files for users. Instead of individually authorizing files, you can logically group files together logically by creating file groups.

1. In the Management Console, select **View > Modules > Exe Explorer > Explorer > Manage File Groups**.

   **Step Result:** The *File Group Management* dialog opens.

2. Click **Add File Group**.

   **Step Result:** The *Add File Group* dialog opens.

3. Enter the name of the file group in the **File Group** field.

4. Click **OK**.

   **Step Result:** The file group is added to the **File Groups** list.

5. Click **Close**.

**Result:** The file group is added to the list. You can now assign files to the new file group.

**Note:** You must grant dedicated accounts such as *Local System* the right to use the appropriate file groups containing services. For example, if you create a Windows File Group where you place all operating system executable files (including Windows services that run with the *Local System* account), you should grant *Local System* the right to use this Windows file group.
Assigning Files to File Groups
After you create the necessary file groups and required parent-child relationships, you can assign executable files, scripts, and macros to file groups.

1. In the Management Console, select **View > Modules > Database Explorer**.
2. Select the file(s) to assign to a file group.
3. Right-click the file selection.
4. Select the **Assign to File Group** option.

   **Step Result:** The **Assign Files to a File Group** dialog opens.

![Assign Files to File Groups Dialog](image)

Table 21: Assign Files to File Groups Columns

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Name of the file including extension.</td>
</tr>
<tr>
<td>File Path</td>
<td>Complete file path name, including the drive.</td>
</tr>
<tr>
<td>Current File Group</td>
<td>The file group to which the file currently belongs. Files that are not assigned to a file group are designated as <strong>&lt;Not Authorized&gt;</strong>.</td>
</tr>
<tr>
<td>Suggested File Group</td>
<td>A proposed file group based on the file name. A file having the same name as another file in the database is suggested to belong to the same file group as the initial file.</td>
</tr>
</tbody>
</table>

5. Select a file group from the drop-down list in the **Suggested File Group** column.
6. Click **OK**.

**Result:** The file(s) are now assigned to the designated file group.

**Note:** You can assign a script or macro to a file group as a script, as distinguished from an executable file.
Creating Parent-Child Relationships

You administer parent-child relationships between file groups using the *Database Explorer Groups* tab.

**Prerequisites:**

You must create parent and child file groups before creating parent-child relationships.

Parent-child relationships may be direct or indirect. A direct relationship exists when a file group has a direct line of descendants between parent and child file groups. All other file group relationships are indirect relationships.

1. From the Management Console, select **View > Modules > Database Explorer**.

   **Step Result:** The *Database Explorer* page opens.

2. Select the **Groups** tab.

3. Select the desired group from the **File Groups** list.

4. To assign a relationship, by selecting a file group from the **Relationships** list and click one of the following:
   - **Add child**
   - **Add parent**
   - **Remove**

   **Step Result:** The **Type** column changes from **Available** to:
   - **Child**
   - **Parent**
   - **Child (Indirect)**
   - **Parent (Indirect)**

**Result:** The parent-child relationship associations are shown with one of the following icons indicating the relationship status:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌈</td>
<td>The file group is a parent of the one selected in the <strong>File Groups</strong> panel.</td>
</tr>
<tr>
<td>➡️</td>
<td>The file group is child of the one selected in the <strong>File Groups</strong> panel.</td>
</tr>
<tr>
<td>🌈</td>
<td>The file group is an indirect parent of the one selected in the <strong>File Groups</strong> panel.</td>
</tr>
<tr>
<td>➡️</td>
<td>The file group is an indirect child of the one selected in the <strong>File Groups</strong> panel.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>📁</td>
<td>A file group created by an Ivanti Device and Application Control administrator that can be deleted or renamed.</td>
</tr>
<tr>
<td>📄</td>
<td>A file group created by the program that is blocked and cannot be deleted.</td>
</tr>
</tbody>
</table>

**Note:** You cannot delete indirect relationships, you must first proceed to the directly related file group and then remove the relationship.
The following examples demonstrate hierarchical parent-child file group relationships.

**Example:**

The file group **16 Bit Applications** is the parent of **Accessories**, and also has indirect child **Alternative** and **CAD software**:

![Figure 60: File Group Parent Relationship](image)

**The File Group** **Accounting** is the child of **Marketing** who also has an indirect child **Payroll**:

![Figure 61: File Group Child Relationship](image)

This is the consequence of the following parent-child assignments:

![Figure 62: File Group Parent-Child Relationship](image)

When assigning the file group **Payroll** to a user or user group; there is also an indirect assignment because of this relationship:

![Figure 63: File Group Indirect Assignment](image)

You can view indirect parent-child relationship assignments by using the **File Groups by User** tab of the **User Explorer** module.

**Assigning File Groups to Users**

After creating file groups and parent-child relationships you want to use, you can assign file groups to users or user groups.

1. In the Management Console, select **View > Modules > User Explorer**.
   
   **Step Result:** The **User Explorer** window opens.

2. Select the **File Groups by User** tab.
3. In the Users, Groups, Computers and Domains panel, select a user or user group.

4. Select one or more file groups from the Not Authorized list.

5. Select one of the following options:

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authorize</td>
<td>Adds the selected file group to the list of file groups directly</td>
</tr>
<tr>
<td></td>
<td>authorized for the selected user or user group.</td>
</tr>
<tr>
<td>Authorize All</td>
<td>Adds the names of file listed as Not Authorized to file groups</td>
</tr>
<tr>
<td></td>
<td>directly authorized for the selected user or user group.</td>
</tr>
</tbody>
</table>

**Note:** Changes to file authorizations or user membership for a file group can remove users that are indirectly authorized for a file group.

**Result:** The user or user group is now assigned to the designated file group.

**After Completing This Task:**
You can send the updated authorization(s) immediately to the client computers using the Control Panel > Tools > Send Updates option. If you do not send updates to protected clients, they automatically receive updates when they restart or at next user log in.

**Sending Updates to All Computers**
After you define or update device permissions or file permissions, you can send the information to all client computers immediately. Otherwise, updated information will automatically upload the next time a user logs in or the computers are restarted.

1. From the Management Console, select Tools > Send Updates to All Computers.

   **Step Result:** The Send updates to all computers dialog opens.

2. Select one of the following options from the Send updates to all computers dialog.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Immediately updates connected computers. Ivanti Device and Application Control can take a long time to send updates depending on the number of computer connections. The Management Console dialog remains open until the Application Server finishes sending the updates.</td>
</tr>
<tr>
<td>No</td>
<td>Asynchronously updates connected computers. The Management Console dialog closes while the Application Server finishes sending the updates. You can continue working with the console while the update is done in the background.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the <em>Send updates to all computers</em> dialog and halts the update process.</td>
</tr>
</tbody>
</table>

**Result:** Updates are distributed to all computers running the Ivanti Device and Application Control clients that are registered in the Application Server(s) online table(s). A message appears in the *Output* window when the updates are complete.

**Remember:** Any computer that is switched off, locked, or disconnected from the network receives the updates at the next network connection.

**Viewing Database Records**

The *Database Explorer* module displays a list of the executable, script, and macro files, digital signatures, and assigned file groups stored in the Ivanti Device and Application Control database.

1. From the Management Console, select **View > Modules > Database Explorer**.

   **Step Result:** The *Database Explorer* page opens.

   ![Database Explorer Module](image)

   **Figure 64: Database Explorer Module**

2. Select the **Files** tab.

3. Type a file name in the **File name** field. You can use wild cards (* and ?).

4. Select a file group from the **File Group** list.

5. Click **Search**.

**Result:** You can view the files stored in the database including the digital signature and file group assignment.

**Caution:** Your request may process slowly when you have a large Ivanti Device and Application Control database.
Local Authorization

Local authorization allows users to locally authorize executable files, scripts, and macros that are not in the central authorization list. Then, the user can then use the software locally, providing users with the flexibility to run specific software applications without first requesting central authorization. You should limit use of this feature to avoid compromising the central network protection policy provided by Application Control.

Prerequisites:

- Using **Tools > Default Options**, verify that:
  - On the **Computer** tab, the **Local Authorization** default option is **Enabled**.
    **Tip:** You can also use this option to disable local authorization on all computers.
  - On the **User/User Group** tab, **Execution Blocking** default option is set to: **Ask user for *.exe only**, for the **Blocking mode**. The user is prompted to authorize the executable only. After the executable file is authorized, any DLLs or other executable files used by the authorized file will automatically be authorized.
    **Tip:** You may type a customized user notification message in the **Notification Text** field, such as: Do you want to authorize this file locally?
  - On the **User Explorer** module **File Groups by User** tab, the users and user groups permitted to use local authorization are listed.

1. Log in to a Ivanti Device and Application Control client computer using a locally authorized user or user group account.

2. Select an executable file, script, or macro to run that is not centrally authorized.

**Step Result:** The **Ivanti Device and Application Control - Unauthorized Application Detected** dialog shows detailed information about the application that is about to run.

![Unauthorized Application Detected](image)

Figure 65: Ivanti Device and Application Control - Unauthorized Application Detected
3. Select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deny</td>
<td>Denies local authorization of the specific executable file, script, or macro. The user is notified the next time an attempt is made to run the software application.</td>
</tr>
<tr>
<td>Deny All</td>
<td>Denies local authorization of all executable file, scripts, and macros.</td>
</tr>
<tr>
<td>Authorize</td>
<td>Authorizes the program locally only for that specific computer.</td>
</tr>
</tbody>
</table>

Result: A progress bar appears at the bottom of the dialog. The *Ivanti Device and Application Control - Unauthorized Application Detected* dialog closes and the authorized application runs or is denied, based on the option selected.

**Note:** The file is automatically denied and the dialog closes, if you do not respond within the time-out period.

**Log Explorer Templates**

The operation of the *Log Explorer* module is based on templates that allow you to generate custom reports containing results that match specific criteria.

A template is a set of rules used for displaying audit and activity log data in the *Log Explorer*. You can create your own templates or use predefined ones created by Ivanti.

**Note:** The list of predefined templates depends upon your license type.

**View Administrator Activity**

You can use the *Log Explorer* module to monitor Ivanti Device and Application Control administrator activity.

Administrator activity includes changing user access rights, device permissions, and file authorizations. Access to audit log information depends upon administrative user access rights established when you define user access rights in the *Tools* module.

1. From the Management Console, select **View > Modules > Log Explorer**.

   **Step Result:** The *Log Explorer* window opens.

2. Select the **Audit by Admin** template.

   **Note:** You may also use a template that you create.
Using Application Control

3. Click Query.

Result: A list of administrator audit log events is shown in the Log Explorer window.

Upload Latest Log Files
You may need to view the most current log information to help you quickly troubleshoot problems or verify that permissions or authorizations are set correctly.

Clients upload log information to the Application Server at the time specified when you define default options. You can use the Log Explorer to fetch log activity as needed, rather than waiting for the next log activity upload.

1. From the Management Console, select View > Modules > Log Explorer.
   Step Result: The Log Explorer window opens.

2. Click Fetch Log.
   Step Result: The Select Computer dialog opens and prompts you to specify the client computer to fetch the logs from.

   ![Figure 66: Fetch Logs - Select Computer]

3. Click Search or Browse to select from a list.

4. Click OK.

Result: The computer logs are uploaded to the Application Server and stored in the database. Updated log files are shown in the Log Explorer window.

Restriction: The time delay between retrieving the log entries from the client and the availability of the latest logs depends on the queue size and the database availability at the time of upload.

Reporting
Ivanti Device and Application Control provides pre-defined reports designed to provide a comprehensive view of your computing environment for activities.

Reports provide a way to view current device permission policy information. Reports are generated as HTML files that are displayed in the main window of any module. You can be print, copy, convert, save,
and modify as necessary. In addition to the standard reports, you can customize and generate your own reports, using the **Log Explorer** module.

After saving a report, you can view it using any web browser that you system supports. You can change the date format for a report by selecting **Windows Control Panel > Regional and Language Options**. The regional options or settings vary according to the Windows operating system you are using.

**Opening a Report**

You open a report by selecting a predefined report type listed in the **Reports** module.

1. From the Management Console, select **Reports**.
2. Select a report type from the list.

**Result:** The report you select is displayed as an HTML file in the **Management Console** main window.

**Printing a Report**

You may print a report that you generate.

1. From the Management Console, select **File > Print**.
   
   **Step Result:** The standard Windows **Print** dialog opens.

2. Select a printer.
3. Click **Print**.

   **Step Result:** The Windows **Print** dialog closes.

**Saving a Report**

You may save a report that you generate.

1. From the Management Console, select **File > Save as**.

   **Step Result:** The **Windows** dialog for saving a web page opens.

2. Select the file path.
3. Type the file name.
4. Select the file type from the **Save as type** dropdown list.
5. Select an encoding method from the **Encoding** dropdown list.
6. Click **Save**.

   **Step Result:** The **Windows** dialog for saving a web page closes.
File Groups by User
You can generate a report showing the file groups assigned to an individual user or users in a group.

Table 23: File Groups by User Report Row Description

<table>
<thead>
<tr>
<th>Row Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>Full user name including domain.</td>
</tr>
<tr>
<td>User Group</td>
<td>Full user group name including domain.</td>
</tr>
<tr>
<td>Direct Group File</td>
<td>Group files directly authorized to the user or user group by the administrator.</td>
</tr>
<tr>
<td>Authorization</td>
<td></td>
</tr>
<tr>
<td>Indirect Group File</td>
<td>Group files indirectly authorized to the user or user group through a parent-child relationship with file groups that are directly authorized for the user or user group.</td>
</tr>
<tr>
<td>Authorization</td>
<td></td>
</tr>
<tr>
<td>Warning Message</td>
<td>Warns that you do not have permission to view the user or user group file group assignments selected.</td>
</tr>
</tbody>
</table>
User by File Group

You can generate a report showing the users assigned to each file group. The report shows the users directly and indirectly assigned to the file group.

User by File Group Report

1. 16 Bit Applications
   Everyone (Unknown Group)

2. Assessories
   Everyone (Unknown Group)
   Marketing (Domain Group)

3. Administrative Tools
   Everyone (Unknown Group)

4. Boot files
   Everyone (Unknown Group)

5. CAD
   >>> No user within your administration scope is associated with this file group <<<

Figure 68: User by File Group Report

The following table describes the report rows.

Table 24: User by File Group Report Row Description

<table>
<thead>
<tr>
<th>Row Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct Group File Authorization</td>
<td>Group files directly authorized to the user or user group by the administrator.</td>
</tr>
<tr>
<td>Indirect Group File Authorization</td>
<td>Group files indirectly authorized to the user or user group through a parent-child relationship with file groups that are directly authorized to the user or user group.</td>
</tr>
<tr>
<td>User Name</td>
<td>Full user name including domain.</td>
</tr>
<tr>
<td>User Group</td>
<td>Full user group name including domain.</td>
</tr>
<tr>
<td>Warning Message</td>
<td>Warning that you do not have permissions to view the file group assignments selected.</td>
</tr>
</tbody>
</table>
User Options

You can generate a report showing the Ivanti Device and Application Control options settings status. The report settings describe the types of Application Control activities that the user is permitted and that are monitored by Ivanti Device and Application Control.

<table>
<thead>
<tr>
<th>Option</th>
<th>User / Group</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Execution blocking</td>
<td>default</td>
<td>(*) blocking mode</td>
</tr>
<tr>
<td>Administrator</td>
<td>default</td>
<td>Non-blocking mode</td>
</tr>
<tr>
<td>Log level</td>
<td>default</td>
<td>Non-blocking mode</td>
</tr>
<tr>
<td>Execution propagation</td>
<td>default</td>
<td>(*) for events logged</td>
</tr>
<tr>
<td>Execution log</td>
<td>default</td>
<td>(*) log access denied</td>
</tr>
<tr>
<td>Execution notification</td>
<td>default</td>
<td>(*) no notifications</td>
</tr>
<tr>
<td>Managed User Protection</td>
<td>default</td>
<td>(*) Disabled</td>
</tr>
<tr>
<td>Reduced login</td>
<td>default</td>
<td>(*) No reduced login</td>
</tr>
<tr>
<td>Reduced login timeout</td>
<td>default</td>
<td>(*) 600</td>
</tr>
</tbody>
</table>

Figure 69: User Options Report

The following table describes the report columns.

Table 25: User Options Column Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>The name of the option shown the <strong>Default Options</strong> dialog.</td>
</tr>
<tr>
<td>User/Group</td>
<td>The user or user group for which this option is set; <strong>Default</strong> is the value configured for all users and represents the default value.</td>
</tr>
<tr>
<td>Setting</td>
<td>The actual value of the option; the asterisk (*) indicates that the option is set to the default value.</td>
</tr>
</tbody>
</table>