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Getting Started with HEAT LANrev
Introduction
Thank you for choosing LANrev! The LANrev suite is a uniquely
seamless multiplatform client management solution for managing all of
your macOS and Windows workstations in a single unified console on
the platform of your choice. All LANrev components – including the
server, admin console, and clients – can be mixed and matched from
either platform. You’ll find that there are often multiple ways to
accomplish the same task within LANrev so it’s up to you to decide
which one fits into your workflows and works best in your computing
environment.
This guide is by no means comprehensive but is meant to help you
quickly get up and running with LANrev in the shortest possible amount
of time. It does not explain nor show you how to use some of the more
advanced and subtle features of the suite. For more information or help
with LANrev, the following resources are available:
•
•

•
•
•

The built-in context sensitive help. This is accessible via the
Help menu.
The complete LANrev user guides. The macOS user guide PDF
can be found at the root level of the distribution DMG disk
image. The Windows user guide can be accessed from the
LANrev program group in the Windows Start menu.
The LANrev support forums at community.heatsoftware.com/
community/products/heat-unified-endpoint-management.
The LANrev tech notes at http://support.heatsoftware.com.
LANrev technical support at www.heatsoftware.com/support.

Minimum system requirements
Server:
•
•

macOS 10.6 or up
Windows Vista or Server 2003 or above
On Windows Server 2016, PowerShell 2.0 or above is required.

Admin:
•
•

macOS 10.10 or up
Windows Vista or Server 2003 or above

Client:
•
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macOS 10.5 or up
Mac OS X 10.4–10.4.11 support is available via Absolute
Manage Agent version 6.7.1
Mac OS X 10.3.9 support is available via Absolute Manage
Agent version 6.1.5
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•

Mac OS X 10.3–10.3.8 support is available via LANrev Agent
version 4.5.x
Mac OS X 10.2 support is available via LANrev Agent version
4.0.4
Windows XP or up (including Windows Server 2003 and up)

Installing LANrev Server
Installing LANrev Server is a very simple process. On a Mac, open
LANrev Server.pkg; on a PC, open setup.exe for LANrev Server, accept
the license agreement, and click Next or Continue through the rest of
the prompts to complete the installation.

Installing the LANrev admin console and activating
LANrev
Upon first launch of the LANrev admin console, you are required to
register your LANrev installation and create a default superadministrator account. Store the information for this account in a safe place.
You should create a separate admin account for everyday use instead of
using the default superadministrator account.
1.

Launch the LANrev Admin setup.exe file and click Next through the
rest of the prompts to complete the installation.

2. Launch the admin console. When prompted, enter the IP address
or DNS name of your LANrev server (do not enter “localhost”,
“127.0.0.1”, or “::1”, even if the admin console is installed on the
same computer as the server), leave the Name and Password
fields blank, and click Login.
3. Click Next or Continue through the rest of the prompts until you
reach the registration screen.
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4. In the registration dialog, enter your registration information. If you
do not have any, complete the Name and Company fields and click
the Demo button for a 45-day 10-seat evaluation. Then click Next or
Continue until you reach the administrator setup screen.

5. Enter the username and password you want to use for the default
superadministrator account. Click Continue and then Setup.

Logging into the admin console for the first time
Launch the LANrev Admin application. At the authentication dialog,
enter the IP address or DNS name of your server and the credentials
for the default superadministrator account you created previously.

Exporting an SSL certificate for the server
Setting up a LANrev installation requires you to specify an SSL
certificate in several places to allow the system to authenticate the
server. Export this certificate now:
1.

In LANrev Admin, choose Window > Server Center.
The Server Center window is displayed.

2. In the sidebar at the left of the window, click Server > Server
Settings.
The server settings are displayed in the main part of the window.
3. Click the Save Certificate button at the bottom right of the
window.
A standard Save dialog is displayed.
4. Save the certificate in a convenient location.

Getting Started with LANrev

3

Configuring LANrev admin console preferences

You can name it as desired, as long as you keep the “.pem”
filename extension.

Configuring LANrev admin console preferences
These settings are separate for each user basis and are stored in the
user profiles. Editing these settings helps optimize the performance of
your admin console.
1.

Choose Edit > Settings.

2. In the General tab, check the Try waking up target computer
first option to activate wake-on-LAN globally. This will make it
easier to manage laptops or desktops that have a power
management policy in place that puts them to sleep.

3. In the Deployment Center tab enter the default Windows domain
admin credentials for the Agent Deployment Center to use to push
install the LANrev clients.
4. To specify a software distribution server that is assigned to the
agents when they are deployed:
-

-

Click the Set button for the SD Server.
The Server Properties dialog is displayed.
Enter the DNS name or IP address of your LANrev server
in the Server address field.
Click the Set button.
A standard Open dialog is displayed.
Select the SSL certificate that you have previously
exported (see “Logging into the admin console for the first
time”, above) and click Open.
Click OK.

This step is optional; you can skip it if you do not plan to use
LANrev to distribute software.
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5. To specify an license monitoring server that is assigned to the
agents when they are deployed, repeat the process in step 4,
except that you begin by clicking the Set button for the LM server.
This step is optional; you can skip it if you do not plan to use
LANrev to monitor software licenses.
6. To specify an inventory server that is assigned to the agents when
they are deployed:
-

7.

Click the + button in the lower left of the window.
The Inventory Server Properties dialog is displayed.
Enter the DNS name or IP address of your LANrev server
in the Server address field.
Click the Set button.
A standard Open dialog is displayed.
Select the SSL certificate that you have previously
exported and click Open.
Optionally, check and uncheck options in the Send
inventory section to specify the types of information that
the server is to collect from the agents.
Click OK.

If you have a very large Windows domain or Active Directory
environment, disable the Auto-scan when window opens option
for the Active Directory and Windows Networking protocols. This
will speed up the launching of the admin console but it means that
you will have to manually request a scan of these zones in the
Agent Deployment Center.

8. In the Remote Control tab, move your preferred remote control
applications to the top of the list and enter default connection
credentials where possible. Note that the application has to already
exist on the admin console and the target computers.
9. If you want to deploy the Agent using a local installer, click the
Export Installer Package button in the Deployment Center tab
and save the package to a convenient location.
You can skip this step if you will deploy the Agent using a different
method. Deployment options are discussed in “Installing LANrev
Agent” on page 10.
10. Close the Settings window.

Configuring the LANrev Server preferences
These settings affect the server and are stored on the server itself. Of
particular importance are the database maintenance and backup
settings for disaster recovery.
1.
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Choose Window > Server Center.
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2. Click Server Setup in the category bar at the top of the Server
Center window and click Server > Server Settings in the left-hand
sidebar.
3. In the General tab enable the database maintenance and backup.

Consult the LANrev Disaster Recovery Guide for best practices on
configuring these settings. We recommend that you run the
database maintenance every day, back up the database every three
days, and keep seven backups. These values can be adjusted
depending on the amount of free disk space available and the size
of your LANrev databases.
4. In the Client Info Titles tab enter the new names to customize
these titles. They are meant to be used for things that LANrev
cannot gather automatically about a client computer such as asset
tags and building locations. These fields can be filled in locally on
each managed computer via the LANrev Agent preference pane or
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control panel, or remotely from the admin console via the Agent
Settings command.

5. If you plan on basing your LANrev admin accounts on Active
Directory (AD) user accounts, switch to the Active Directory tab
and enter the name of any user groups from which you want
LANrev to be able to pull user accounts for this purpose. Your
LANrev server must be bound for AD for this to work. Click the plus
sign and enter just the name of the desired AD user group itself.

Setting up an admin hierarchy
Sufficient care should be taken in determining who on your IT staff has
access to which computers and what they can do on them. LANrev’s
Getting Started with LANrev
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granular role-based administration model allows you to do just that. The
following instructions will show you how to add a regular superadministrator account for yourself for everyday usage.
1.

Choose Window > Server Center.

2. Click Administrators in the category bar at the top of the Server
Center window and click Administration > Administrators in the
left-hand sidebar.
3. Right-click Administrators and choose Administrator Setup >
New Administrator from the context menu.
4. Fill in the Name, Password, and Verify fields, enable the
Superadministrator and Can manage all computers options, and
click OK.
5. To create a LANrev admin account based on an Active Directory
account, click Administration > Active Directory in the left-hand
sidebar and then drag an Active Directory user account from the
right-hand pane onto the Administrators entry in the left-hand
sidebar.
6. Exit the LANrev admin console and log back in using your new
credentials.

Discovering client computers
LANrev’s Agent Deployment Center (ADC) offers multiple ways of
discovering client computers for performing an initial push installation
of the LANrev client software.
Client computers must meet certain requirements for push installations to work:
•
•

•

On macOS, SSH (remote login) must be enabled.
On Windows:
File and Printer Sharing must be enabled.
Simple file sharing must be disabled.
User Account Control must be disabled.
On Linux, SSH must be enabled.

These conditions apply only to push-installing LANrev Agent, not
normal operation. If they cannot be met, there are other installation
methods (using login scripts or group policies on Windows, manual

Getting Started with LANrev

8

Discovering client computers

installation by locally executing the installer, using an MDM server) that
are described in the LANrev User Guide.
NOTE An admin console can only push-install the LANrev client to targets
using a similar authentication system. So a Mac admin console can only
push install LAnrev Agent to other Macs or Linux computers, and a PC
admin console can only push-install LANrev agent to other PCs.
However, no such issues exist for LANrev Server, so any server can
always serve any platform.
1.

Choose Window > Agent Deployment Center.

2. To discover clients:
-

-

You do not need to do anything to discover client
computers in the Bonjour zone (as long as Bonjour is
installed on your admin console computer). This typically
can only discover clients on the same subnet as your
admin console unless your routers have been reconfigured
to support Bonjour across subnets.
To discover client computers via Windows Networking or
Active Directory, right-click that particular zone and choose
Refresh from the context menu. These are the most
efficient ways to discover clients.

The status of each discovered client is indicated by a colored dot,
as described below in “Indicators in the Agent Deployment Center
window”.
3. If you cannot discover clients via one of the methods described in
step 2 or if you want the Agent to be installed automatically on
computers that are discovered, create and scan a custom zone as
described in the following steps.
4. Right-click Custom Zones in the Agent Deployment Center
window sidebar and choose New Custom Zone from the context
menu.
Discovering clients via custom zones has the following benefits:
-

-

You can specify a different set of credentials for each
custom zone.
Autodeployment which lets you automatically push install
the LANrev client without having to monitor the ADC.

5. Click the plus sign to add additional entries. You can add targets by
either IP address, IP address range, or host name.
If you want to discover a client via host name, choose Host Name
from the leftmost pop-up menu. To use an IP address range,
choose is in the range from the second pop-up menu.
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6. To discover the devices in a custom zone, expand Custom Zones
and double-click the desired zone. A gear icon appears next to a
custom zone while it is being scanned.

Indicators in the Agent Deployment Center window
The status of each discovered device in the zones in the Agent
Deployment Center window is indicated by a colored dot:
Green dot: LANrev Agent is current.
Yellow dot: LANrev Agent is present but outdated.
Red dot: No LANrev Agent present; installing an agent is possible.
Grey dot: No LANrev Agent present, and no agent can be installed. A
common reason is that you are trying to install across platforms (i.e.,
from the Windows Admin to a Mac or Linux client or vice versa), which
is not possible with the Agent Deployment Center. Other reasons
include: The device is not a computer, or Window File and Printer
Sharing is disabled on a Windows client.

Installing LANrev Agent
You can install LANrev Agent in different ways:
•
•

•

•

Manual push installation from LANrev.
We recommend this method for limited evaluations of LANrev.
Automatic push installation from LANrev.
We recommend this method for full deployment throughout a
network zone.
Automatic pull installation using an MDM server.
We recommend this method for large-scale installations and
ongoing integration of new devices.
By executing a local installer.
We recommend this method only when technical issues
interfere with centralized installation using one of the two
above methods.

All methods are described below.

Push-installing
the client
software
manually

Custom zone autodeployment scans can repeatedly generate more
traffic (many small packets) than your network admins might like. In
that case (or for a limited deployment) your best option would be to
push install the client software without autodeployment.
1.

Make sure that the computers in your network meet the
requirements listed in “Discovering client computers”, above.
In particular, you will not be able to push-install onto computers
that do not have the proper network access settings. If you are
unable to access the admin$ share from the admin console, pushinstallation is not possible.
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2. Once LANrev has finished discovering client computers (see
“Discovering client computers”, above), highlight the ones with a
red dot in front of them in the Agent Deployment Center, right-click
and choose Install Agent from the context menu.

For an explanation of the colored-dot status indicators, see
“Indicators in the Agent Deployment Center window”.
3. Enter your Windows domain admin credentials and click OK.
The SD Server, LM Server, and Inventory servers fields should
already be populated; if they are not, you may need to set up the
settings, as described in “Configuring LANrev admin console
preferences”.
4. Check the Connection Status and Deployment Result columns
on the far right of the Agent Deployment Center window to
monitor the status of the installation. Your agents should appear in
the Computers window within a minute or two.
If you installed a non-customized client manually, it may not show
up in the Computers window but will show up in the Agent
Deployment Center with a green dot and an empty Inventory
Server field. On these clients, you need to specify the servers
manually, as described in the following steps.
5. To specify servers manually for clients, select and right-click them,
and choose Set Inventory Server from the context menu.
The Inventory Server Properties dialog opens.
6. To specify an inventory server for the agents:
-
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Click the + button in the lower left of the window.
The Inventory Server Properties dialog is displayed.
Enter the DNS name or IP address of your LANrev server
in the Server address field.
Click the Set button.
A standard Open dialog is displayed.
Select the SSL certificate that you have previously
exported (see “Exporting an SSL certificate for the server”
on page 3) and click Open.
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-

7.

Optionally, check and uncheck options in the Send
inventory section to specify the types of information that
the server is to collect from the agents.
Click OK.

To specify a software distribution server that is assigned to the
agents when they are deployed:
-

-

Click the Set button for the SD Server.
The Server Properties dialog is displayed.
Enter the DNS name or IP address of your LANrev server
in the Server address field.
Click the Set button.
A standard Open dialog is displayed.
Select the SSL certificate that you have previously
exported (see “Logging into the admin console for the first
time”, above) and click Open.
Click OK.

This step is optional; you can skip it if you do not plan to use
LANrev to distribute software.
8. To specify an license monitoring server that is assigned to the
agents when they are deployed, repeat the process in step 4,
except that you begin by clicking the Set button for the LM server.
This step is optional; you can skip it if you do not plan to use
LANrev to monitor software licenses.
9. Click OK to assign the specified servers to the selected clients.
Your agents should appear in the Computers window within a
minute or two.

Automatically
push-installing
the agent

For a full deployment of LANrev Agent, you can automate the installation by activating auto-deployment. This installs the agent on each
computer that meets the requirements (see “Discovering client
computers” on page 8) and is discovered in one of the custom zones.
Auto-deployment is available only for custom zones. If you have not
already done so, set up custom zones as described in “Discovering
client computers”.
To enable auto-deployment:
1.

Make sure that the computers in your network meet the
requirements listed in “Discovering client computers” on page 8.
In particular, you will not be able to push-install onto computers
that do not have the proper network access settings. If you are
unable to access the admin$ share from the admin console, pushinstallation is not possible.

2. Choose Window > Agent Deployment Center.
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3. In the sidebar, right-click a custom zone and choose Edit Custom
Zone from the context menu.
The Custom Zone dialog opens.
4. Check the Repeat scan every option and enter a time interval.

This is the interval in which LANrev checks the zone for new
computers.
5. In the Auto Deployment tab, check Automatically deploy agents
and specify the software distribution, license monitoring, and
inventory servers as described in “Push-installing the client
software manually”, above (step 6 to step 8).
6. Click OK.

Deploying the
agent using an
MDM server

Setting up enrollment of computers through an MDM server, which
includes the installation of the agent, requires the installation and setup
of additional software.

Deploying the
agent using a
local installer

Locally installing LANrev Agent works like any other local software
installation. However, to meet the authentication requirements, the
installer must first be customized with the address and SSL certificate
of the LANrev Server in your network.

This process is not covered in this manual; if you are interested in
setting it up, it is described in the LANrev User Guide.

To customize the agent installer and deploy the agent:
1.

Make sure that you have properly specified the servers for the
deployment, as described in “Configuring LANrev admin console
preferences” (step 3 to step 7) and exported the installer package
(step 9).

2. Execute the installer on each computer on which you want to install
an agent.
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Configuring the client
You only need to do this if you deployed the default agent instead of a
customized one. The customized agent installer will automatically
configure these settings for you but it is still a good idea to confirm that
they are correct.
To assign the correct server to the clients:
1.

Select all your agents in the Computers window.

2. Choose Commands > Agent Settings.
3. In the General tab check the Include in OS patch management
option.

4. In the Servers tab’s Software Distribution Server and License
Monitoring Server sections, fill in the Address fields with the IP
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address or DNS name of your LANrev server and click the Set
buttons to select the server certificates.

5. Click the Execute icon in the upper left corner of the window.

Populating all the optional inventory information for a
client if it is not already there
If you preconfigured your agent installers then you might not have to
run some of these commands as the optional inventory might already
be present.
1.

Select all agents in the Computers window.

2. Choose Commands > Gather Inventory Information.
3. Check all options in the window and click the Execute icon.
4. Choose Commands > Gather Installed Software.
5. Check all checkboxes, choose either the Applications folder or the
Boot volume option, and click the Execute icon.
You can also force agents to send in optional inventory automatically by
specifying the desired options for selected agents in the Commands >
Agent Settings dialog.

Creating a custom inventory report
Creating an inventory report involves two basic steps:
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1.

Narrowing down the field to just the client computers you want to
include in the report

2. Deciding which inventory items you want to display about them
To create a new standard computer group in the Computers window
select all the computers you want to include, right-click and choose
Make Group from Selected Computers from the context menu.
To create a smart computer group, right-click anywhere in the left-hand
sidebar of the Computers window and choose New Smart Group
from the context menu. Enter the name of any information items you
want to use for selection criteria on the left, choose a comparison
operator in the middle, and enter the comparison value on the right.
You can get a list of available information items by choosing Window >
Information Items. You can start typing the name of the desired
information item and LANrev will try to autocomplete the name for you.
Click the pull-down for the left-hand field before typing to get a
complete list of all information items or after entering a few letters to
get a partial list of just information items that begin with those letters.
To add more selection criteria click the plus button.

To change which information items are displayed in the custom
inventory report, right-click the column header area and choose
Configure Columns from the context menu. Information items can be
added by copying or dragging them from the Information Items window
into the columns drawer. To remove information items select them and
click the Remove button. To search for an information item in the
Information Items window enter a part of its name in the search field at
the top and press the Enter key.
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Configuring software distribution and patch management
Software
distribution
setup

These steps only need to be completed once during the initial software
distribution setup.
1.

Select all agents in the Computers window.

2. Choose Commands > Agent Settings, click the Servers tab, and
verify that the Address field in the Software Distribution Server
area contains the address of your server.
If it does not, change it so it does, click the Set button and choose
the server certificate, and click the Execute icon.
3. Choose Windows > Server Center.
4. Click Software Distribution in the category bar at the top of the
Server Center window and click Software Packages in the lefthand sidebar. No objects should be displayed in the main part of
the window.
5. Right-click the Distribution Points section and choose Software
Distribution > New Distribution Point from the context menu.
A distribution point is an agent computer you designate to host
packages for software distribution. That means that only computers
which appear with a green dot in the Computers window can be
selected as distribution points.
6. Fill the dialog in as follows:
-
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Server name: The name by which you will identify the
distribution point.
Server address: The IP address or DNS name of the agent
computer which you want to make a distribution point.
Packages root path: The path of the directory on the
chosen agent computer where you want software
packages to be stored for deployment. For Windows
agents, use the form c:\path\to\folder; for Mac agents, use
the /path/to/folder format. The specified directory does not
have to exist and will be created automatically by the
LANrev Agent on the distribution point computer.
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-

7.

Server type: Check the Is master distribution point
option.

Click OK.

8. Choose Server > Save Distribution and Licensing Info.
9. Click again the Software Packages section in the left-hand sidebar.
It should now list two packages named “LANrev Agent (macOS)”
and “LANrev Agent (Windows)”.

Creating a
distribution
group

To deploy a software package, you must first create a software package
definition for it and then assign it to a distribution group. Agent
computers will check in every 60 minutes by default for new assigned
software packages, install them, and report the installation status back
to the LANrev server.
To create a standard distribution group:
1.
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Click the Computer Groups > Unassigned Computers section in
the left-hand sidebar.
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2. Select the desired computers in the right-hand pane, right-click
them, and choose Make Group from Selected Computers from
the context menu.
To create a smart distribution group:
1.

Right-click Computer Groups and choose Computer Groups >
New Smart Computer Group from the context menu.

2. Enter the name of any information items you want to use for
selection criteria on the left, pick a comparison operator in the
middle, and enter the comparison value on the right.
You can get a list of available information items by going to
Window > Information Items. You can start typing the name of
the desired information item and LANrev tries to autocomplete the
name for you. Click the pull-down for the left-hand field before
typing to get a complete list of all information items or after
entering a few letters to get a partial list of just information items
that begin with those letters.

3. To add more selection criteria, click the plus button.
4. Click OK.
If you have an existing computer group that you would like to also use
for software distribution, you can convert it to a distribution group by
dragging it from the Computers window to the Computer Groups
section in the sidebar of the Server Center window.

Creating a
software
package for
deployment
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macOS software package definitions must be created on an macOS
admin console due to Windows not understanding macOS file system
resource forks.
1.

In the Server Center window, right-click the Software Distribution
> Software Packages section in the left-hand sidebar and choose
Software Distribution > New Software Package from the
context menu.
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2. In the Package tab enter the name for the application you wish to
deploy in the Package Name field and click the New Payload
button.

3. In the Payload window specify a name for the payload, click the
Select button, and select the installer file (PKG, VISE, DMG, MSI,
MSP, MSU, setup.exe or other installer executable) you wish to
deploy.
4. If there are other files included as part of the installation check the
Transfer all files in folder containing selected object option.
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5. Enable the Selected object is executable or installer package
option and click OK.

6. Check options as desired in the Installation Options tab. For
macOS installations, be sure to check Requires admin privileges
if the installer writes anything to directories outside of the user’s
home profile (which almost every installer does). For Windows
packages, specify the system account user installation context.

7.
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If you wish to improve the end user’s experience then set
Download payloads to Before user dialog so that the installation
can begin immediately once the user has approved it (as opposed
to a possibly lengthy software download beginning at that point).
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8. In the User Interaction tab set whichever options best fit your
computer environment. For example, if you want end users to
know about software installations, choose the Inform user before
installation and Display progress to user options. If you prefer to
deploy software silently, choose Install without asking instead.
9. Expand the Software Distribution > Software Packages section
in the left-hand sidebar and select your new package so its details
are displayed in the right-hand pane. You might have to increase the
size of the Server Center window for all the details to be visible.
10. In the Groups package is assigned to area in the lower left corner
of the pane, check your new distribution group to assign your
package to it. Alternatively you could also drag the package on top
of the distribution group within the Computer Groups section of
the sidebar to assign it.
11. Choose Server > Save Distribution and Licensing Info.
12. To trigger a software distribution now instead of waiting 60 minutes
for it to happen automatically select any agent computer, choose
Commands > Run Software Distribution Check, and click the
Execute icon.
13. If the software distribution job never shows up in the Software
Distribution > Installation Status > General Log section of the
Server Center window, search the support site for article 20696
and see whether you may have missed a step in setting it up.

Configuring
patch
management

Agent computers must be enrolled in patch management for:
•
•

LANrev to be able to generate missing OS patch packages for
them.
LANrev to be able to deploy assigned patch packages to them

Agent computers will only check for, generate, and install missing OS
patches once every 24 hours. If you want to force this to happen now
you must send them a Run Software Distribution Check command.

Collecting information on missing patches
To collect information about missing patches when agents are not set
up to send this information automatically:
1.

Select all agents in the Computers window.

2. Choose Commands > Gather Installed Software.
3. Check only the Scan for missing operating system patches
option and click the Execute icon.
4. Choose Window > Missing Operating System Patches and
check the four built-in categories. If no computers are listed here,
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all your agent computers are either up to date or do not have
network access to an update server.

Generating missing OS patches
To generate missing OS patches:
1.

Choose Window > Server Center. Click Software Distribution in
the category bar at the top of the Server Center window and click
Software Distribution > Mac OS Patches> Unconfirmed
Patches or Software Distribution > Windows Patches >
Unconfirmed Patches in the left-hand sidebar.

2. If the categories are empty, select all agents and choose
Commands > Agent Settings. In the General tab, verify that
Include in patch management is checked for these agent
computers.
3. If that is correct then select the agent computers in the
Computers window and choose Commands > Run Software
Distribution Check. Return to the Unconfirmed Patches section
in the Server Center window in a few minutes and some patches
should be listed there.
4. If your agents are missing patches but they still don’t show up in
Unconfirmed Patches, search the support site for article 20696
and see whether you may have missed a step in setting it up.
To approve a patch, simply assign it to a distribution group just like any
other software package. OS patches will also appear in installation
status reports just like custom software packages. In general it is
easiest to assign an approved patch to the All Macs or All PCs default
smart groups. LANrev Agent is intelligent enough to only install an
assigned patch if the target actually needs it. If an agent determines
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that the target is not missing an assigned patch or the end user has
already installed it manually it will ignore the assigned patch.

Configuring license monitoring
Software audits with the Gather Installed Software command can tell
you how many copies of applications are installed on client computers
but they cannot reconcile your licensing for you to tell you if are within
compliance or not. Software auditing information, which includes
statistics reports and reports about which computers have which
applications installed, can be found by choosing Window > Installed
Software.
The License Monitoring Center allows you to track specific licensed
applications (either by installed copies or by floating licenses) and
remain compliant with your existing software license agreements. It
also allows you to track your purchasing information for these specific
applications. The “prohibited” license type can optionally be set to
terminate and delete applications you do not want end users to be able
to launch or install.
1.

Select all agents in the Computers window.

2. Choose Commands > Agent Settings, click the Servers tab, and
verify that the Address field in the License Monitoring Server
area contains the address of your server.
If it does not, change it so it does, click the Set button and choose
the server certificate, and click the Execute icon.
3. Choose Window > Server Center.
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4. Click License Monitoring in the category bar at the top of the
Server Center window, right-click the License Specifications
section in the left-hand sidebar, and choose License Monitoring >
New License Specification from the context menu.
5. Enter a name for the new specification and choose the file type by
which you want to identify the software. Add any desired subcriteria to more precisely identify the software.
6. Check Meter application usage and Terminate launched
application if licenses exceeded.

7.

Enter a license count in Licenses owned and choose a license
type. If you want to enter purchase tracking information leave this
field blank and click the Purchase Tracking tab.

8. Click the + button to add a new purchase entry.
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9. Fill in the Purchase, Vendor, Maintenance, and Notes subtabs as
needed in the bottom half of the window and click OK when you
are done.

10. Expand the License Monitoring > License Specifications section
in the left-hand sidebar and select your new license specification so
its details are displayed in the right-hand pane.
11. In the Groups specification is assigned to area in the lower left
corner of the pane, check your new distribution group to assign
your license specification to it. Alternatively you could also drag the
license specification on top of the distribution group within the
Computer Groups section of the sidebar to assign it.
12. Choose Server > Save Distribution and Licensing Info.
13. To trigger a license monitoring scan now instead of waiting 60
minutes for it to happen automatically, select an agent computer
anywhere, choose Commands > Run License Monitoring, and
click the Execute icon.
14. Check the Fully compliant and Licenses exceeded reports in the
License Monitoring > Reports section in the left-hand sidebar to
see how many of your agents registered as having the application
present as defined in your license specifications. To find out which
agents have the application installed check the Software usage
report.
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