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Disclaimer
This documentation, as well as the software described in it, is confidential and contains proprietary
information protected by non-disclosure agreements. No part of this documentation may be reproduced
in any form or disclosed to any party not bound by a non-disclosure agreement without the express
written consent of Ivanti

Ivanti reserves the right to revise this documentation and to periodically make changes in the content
hereof without obligation of such revisions or changes unless required to do so by prior agreement.

Information contained herein is believed to be correct, but is provided solely for guidance in product
application and not as a warranty of any kind. Ivanti assumes no responsibility for use of this
information, nor for any infringements of patents or other rights of third parties resulting from the use of
this information.

Ivanti
698 West 10000 South Suite 500, South Jordan, UT, 84095 USA

©2017 Ivanti. All rights reserved. Computrace and Absolute are registered trademarks of Absolute
Software Corporation. All other trademarks are property of their respective owners.

Application version: 8.9
Last updated (day/month/year): 20/09/2016
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About LiveTime
LiveTime is a comprehensive IT Service Management (ITSM) solution, compliant with all core aspects
of Information Technology Infrastructure Library (ITIL) v2011 best practices. LiveTime combines
people, process, and information technology so that IT services can align with the needs of the
business.

Built on a foundation of data from all areas of the organization, IT can use certified best practices to
apply precise control over the levels of service it delivers, predicting potential points of failure, and
making real-time decisions for the most efficient and cost-effective outcome.

LiveTime is built to provide a flexible and customizable environment that easily fits your organization.
You can leverage native applications for iOS, Android, and other mobile devices to access the console
remotely. You can also use more than 140 widgets to create a flexible and customized environment to
efficiently monitor progress and carry out your work and these can be extended through the inbuilt
custom report writer and/or with the help of our professional services team.
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About the Administrator Portal
As an administrator, you can use LiveTime to configure the customized settings within the application,
enable or disable user privileges, and control synchronization with third-party tools.

The Administrator Portal has five tabs:
● User - Allows you to create accounts for users and customers, and also define user

assignment templates for adding users to multiple teams and escalation layers
● Reports - Provides you with real-time system and login reports. You can also download

system logs here
● My Account - Allows you to view and configure your account details or create alerts
● Setup - Allows you to define how customers and users can interact with the system, to

customize the application, and to synchronize it with third-party tools
● CMS - Allows you to configure relationship types, warranty durations, and the Incident

Analyzer for problem management

NOTE If you are logged in to LiveTime as a role other than administrator, you can quickly access the
Administrator Portal by clicking [Setup] at the right of the menu bar.
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What's New?
LiveTime 8.9 enhances search capabilities, email functions, report builder outputs and adds customer
requests. Highlights include the following:

l AMIE synchronization tasks are now capable of performing delta scans rather than full
scans on the synchronization interval

l CMDB data imports from CSV content has many additional fields that can be specified
l Depreciation calculations have been moved into a background task so a stored depre-
ciated value can be reported on

l Added highlights to several key fields in request management to help users identify time
sensitive tasks

l My Tasks list now supports custom fields irrespective of request type
l Request and Item lists in the customer portal can now be customized by the administrator
l Implemented rolling surveys so performance can be monitored and compared to past
intervals

l Improved survey results display to aid visibility of performance

For a complete list of new features, fixes, and enhancements in LiveTime 8.9, refer to the Release
Notes.
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Using the Online Help
Online help is available throughout the application if you need assistance with completing a task. The
help is context sensitive, so when you open it, you see information that is relevant to the screen you
are currently working in.

To access the online help, click Help at the top right corner of the screen.

Help for the screen you are working in opens in your browser.
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Basic Procedures
Within all areas of LiveTime, there are common conventions for working with elements. So whether
you are handling requests, customers, items, or item types, the procedure for creating, editing, or
deleting these elements is the same.

NOTE When entering details relating to any element throughout the system, required information is
marked with a I.

I Denotes mandatory fields

Creating an Element
To create an element:

1. Navigate to the appropriate section.

● For example, if you want to create a customer, navigate to User > Customers.

2. Click New in the upper left corner of the list of customers.

● A new Customer Information window opens.

3. Fill in the appropriate details.

4. Click Save.

● The new customer now exists in the system and appears in the list of customers.

Editing an Element
To edit an element:

1. Navigate to the appropriate section.

● For example, if you want to edit a customer, navigate to User > Customer.

2. In the list of elements, click the link for the entry that you want to edit.

● For example, to edit a customer, click his or her Customer Name. The Customer
Information screen opens.
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3. Click Edit in the upper left of the window.

4. Update the necessary information.

5. Click Save.

Deleting an Element
NOTE Not all user roles have the privileges to delete elements. For more information, see User Roles
& Privileges.

To delete an entry:

1. Navigate to the appropriate section.

● For example, if you want to delete a customer, navigate to User > Customer.

2. In the list of elements, click the link for the entry that you want to delete.

● For example, to delete a customer, click his or her Customer Name. The Customer
Information screen opens.
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3. Click Edit in the upper left of the window.

4. Click Delete at the bottom of the section.

Exporting Lists to PDF and Excel
You can export most lists within the system to PDF and Excel. This functionality is available wherever
the PDF and Excel buttons are visible.

NOTE To customize the view of an Excel export, create a list view with your preferred columns, use
the list view you created, and click the Excel button. See List Views for more information on
customizing a list.

Printing from LiveTime
To print information from LiveTime, use your browser's print functionality. In Internet Explorer, you can
print the screen you are currently working in by clicking File > Print.

Be sure to enable the print background setting in your browser for better formatted and more user-
friendly hard copies of screens. In Internet Explorer, this setting is found here: Tools > Internet
Options > Advanced > Printing > Print background colors and images.

Navigating within the Application
Use the links and buttons within the application screens, and avoid using your browser's forward and
back buttons. Following this guideline ensures the application maintains control of your session and
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refreshes data appropriately.

"Apply" and "Save" Buttons
In many screens where you edit elements, both the Apply button and Save button are available. Both
buttons save any changes you make within the screen you are working in, but the application's
behavior is slightly different:

● When you click the Apply button, your changes are saved and you remain in edit mode. This
button is useful if you want to save changes intermittently while continuing to work on an
element.

● When you click the Save button, your changes are saved and you are taken out of edit mode.
This button is useful if you have finished working with an element and want to move to another
part of the application.
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Configuration Steps
Use these basic configuration steps as a guide to assist you with customizing LiveTime for your
environment. This process requires you to switch between Administrator and Supervisor roles, so your
account must be set up with these two roles while you are configuring LiveTime. You can customize
roles for your account within the User tab of the Administrator Portal.

At a high level, the configuration process includes the following tasks:
● Enabling the system to work with email
● Setting the privileges for how customers and technicians can interact with the system, and

how requests and the system will behave
● Customizing the look and feel of the system, although this can be done at a later stage, if

preferred
● Creating customers and users in the system
● Configuring the day-to-day elements within the application, which are part of creating and

managing requests, including:
○ Setting the timeframes for managing requests
○ Defining trigger points for escalations by configuring SLAs
○ Detailing the steps a request will move through by customizing workflows, which includes

setting the stages of the workflow where timers will trigger automatic warnings and
escalations, and defining the team(s) of technicians who will be associated with the
customized workflows and SLAs

● Customizing the Configuration Management Database (CMDB)
○ This step is often considered the most complex part of the configuration process, as this

is where the service environment, including physical and service items, is mapped into the
system with associated relationships. When designing the CMDB, you first create the
templates for all the different item categories, then refine them as Item Type templates.
These templates define the information recorded and issue classification when customers
log requests.

● Importing items using AMIE or CSV files
○ This step includes associating items with customers or organizational units, who can log

requests against the assigned items.

Setting Up Billing
If your organization is using billing to manage contracts, it is recommended that you enable this feature
before configuring other settings to prevent system disruptions.

To enable billing:

1. Log in as the administrator.

2. In the Administrator Portal, go to Setup > Billing.

3. Set the Enable Contracts option to Yes.

4. Complete the required information (see Billing for more information).

5. Click Save.

Configuring LiveTime for Your Environment
In the Administrator Portal:
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1. Customize default access for the Supervisor role (See: User)

● Include incident management, service level management, and if applicable, request
fulfillment, problem management, and change management. Adjust the user timezone, if
applicable.

2. Configure email setup and email messages (See: Setup > Email)

● This step allows the system to manage requests via email. After completing the
information in the Server and Setup tabs, you can customize the content for automated
system emails. While you do not have to complete the content customization at this point,
you should at a minimum update the signature included in the automated emails (located
on the last page of the Templates tab) to reflect your service organization name.

3. Enable system privileges (See: Setup > Privileges)

● You should review each option in the User, Customer, Request, and System tabs located
under Setup > Privileges. If you are unsure about what an option refers to, click Help in
the upper right of the screen for an explanation of each option. Note that you can always
adjust these options in the future. Be sure to set the appropriate time zone within the
Customers tab before importing customers and users through an authentication server to
ensure this setting is correct on all newly created accounts. It is recommended that all
users set their own time zone (in the Home > My Account tab) during their initial login.

4. Customize banners and welcome page message (See: Setup > Customize)

● You can complete this step now if the images are available, or you can return to this step
at a later stage.

5. Create customers and users, which include Supervisor, Technician, and Partner
accounts

● If you are using an authentication server to create customer and user accounts, go to
Setup > Authentication. (See: Setup > Authentication, Active Directory Integration, or
LDAP Integration)

● If you are creating accounts directly in the system using internal authentication, go to the
User tab. (See: Customers and Users)

● You can also associate organizational unit information with customers or users in the
Supervisor view within the User > Organizational Units tab. If your import includes the
name of an organizational unit that matches what is recorded in the system, the details
from the information recorded internally are applied to the customer or user.

● When using Active Directory for user authentication, the server-side user group definitions
and subgroups must be of the ‘Universal Distribution’ type. You cannot add the ’Domain
User’ group or any other security group to a user group. For more information about
working with directory servers, see Active Directory Integration.

Move to the User Portal by clicking [User] at the right of the menu bar.

6. Set up service level agreements (SLAs) (See: Service Level Management)

● If you do not have SLA details at this time, you can use the system's default SLA.

7. If applicable, create operational level agreements (OLAs) and underpinning contracts
(UCs) (See: OLAs or UCs)

● If OLAs or UCs are in place at your service organization, you can map them into the
system now. Alternatively, you can add them later if needed.
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8. Customize or create workflows (See: Incident & Problem Workflows and Service Request &
Change Workflows)

● The system includes default workflows across all processes. You may find the default
workflows are sufficient, or you may want to customize them to suit your service
organization requirements. You can also create completely new workflows if needed.

9. Create teams (See: Teams)

● By default, the system includes a "Process" team and "Unknown" team. You should edit
the existing Process team, including defining the way it works, assigning the relevant
technicians, associating the workflows that the team will support, and setting the
technicians to work in the appropriate escalation layer(s). You should create teams for all
processes that the system will manage, such as incident management, problem
management, change management, and request fulfillment, although you may find it easier
to finish one process first and return to finish the other processes at a later time.

Move to the Administrator Portal by clicking [Setup] at the right of the menu bar.

10. Assign default teams and SLAs for requests (See: Setup > Privileges > Requests)

● These settings are applied to all newly created items and item types that result from an
AMIE import.

Move to the User Portal by clicking [User] at the right of the menu bar.

11. Configure the CMDB, by first customizing categories

● The system includes a number of default categories under Configuration > Categories,
which should be sufficient for most organizations. You can customize categories in
several ways:

● Within each category, you can customize the field labels that correspond to the item
attributes recorded in the system. (See: Configuration Categories)

● You can also define the stages that a category can move through in its lifecycle within the
Lifecycle tab. (See: Category Life Cycle)

● Finally, you can customize the types of issues that can be reported against a category in
the Classifications tab. (See: Category Classifications)

12. Create service type templates and service items

● If your service organization wants to fast track the capability to manage requests in the
system, you should create service items in the Service Catalog to allow customers and
technicians to log and manage requests within LiveTime:

● Create a type using the service category for each service being offered.
● Create the service item with the type template you just created. For the service to be

available in the Service Catalog, be sure its status is set to an active, non pre-production
state. If you want customers to access the service on the Customer Portal, you should
also set its Service Item Lifecycle State to Customer Visible.

13. Create item types (See: Item Types)

● If you are not automatically creating types as part of an AMIE or CSV import, you can
perform this task in the Configuration > Types tab. Here, you can associate the category
template with the type template, set the default teams and SLA, and refine the
classifications for issues reported against items.

● If you are importing using a CSV file or AMIE, you can skip this step.

Move to the Administrator Portal by clicking [Setup] at the right of the menu bar.
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14. Within the Setup tab, complete the item import (See: AMIE Import or CSV Import)

● After you successfully complete an item import, a supervisor may have to refine the type
templates that the import created if the default settings do not apply. This task does not
need to be completed immediately, and can be done on an ad hoc basis (whenever a type
template is opened in edit mode, the system will prompt the user to set any required
information before saving).

Move to the User Portal by clicking [User] at the right of the menu bar.

15. Within the Configuration tab, create items (See: Items)

● If you are creating items directly within the system, go to Configuration > Items. When
you create a new item, you associate it with an item type template, which applies all the
default information set within the Categories and Types tabs. You then assign ownership
of the item, which could include everyone (a global item), one or more specific customers,
or organizational units. You record the specific attributes of an item in the Details tab, and
you can create relationships with other items in the system within the Relationships tab,
either now or at some point in the future.

● You can also map items to services, if required. (See: Service Catalog)

Implementing the Processes
For information on implementing processes, refer to the following topics:

● Request Fulfillment
● Incident Management
● Problem Management
● Change Management
● Release & Deployment Management

Deleting Records
Before you begin to populate the database and use the system, it is important to note that records for
customers, technicians, items, item types, and knowledge base categories or articles are only disabled
within the application when the Delete option is selected, not deleted from the database. This behavior
preserves the integrity of your data while maintaining audit trails if they are ever required.

Do not manually deleted records from the database as this action may invalidate existing relationships
in the application and cause it to crash.
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User Tab
On the User tab, you can create, edit, and delete the following elements:

● Customers
● Users
● Assignments

You can synchronize the system with a directory server to import user details. If you want to modify
the imported users, you must do this through the appropriate server console, not LiveTime (see
Authentication for more information).

Alternatively, you can import customers using a CSV file.

NOTE If you are creating new user accounts directly in the system and want to set up a new
administrator, you must do this within the User tab of the Administrator Portal.

User Roles
Users can have one of the following roles:

● Technician
● Supervisor
● Partner
● Team Leader

and one or more of:
● Administrator
● Customer
● Finance
● Manager

When users have more than one role, they can easily switch between roles by selecting the [Setup],
[User], or [Customer] link displayed in the menu bar next to their login name. See Changing Roles for
more information.

User Availability
In the user list view, you can find out the availability of users by checking their "Available" status. This
status is based on a user's work hours, which are set in the Schedule tab, and on his or her vacation
status.

The following icons may be displayed in the list view:

Available Status Description
The user is not on leave and is available for request assignment based on his or her
assigned work hours.

The user is not on leave but is not available for request assignment based on his or
her assigned work hours.
Or, if no hours are set within the Schedule tab when the Define Work Hours option
is enabled within Setup > Privileges > User and the user is not on vacation, the
system will consider the user to be unavailable.

The user has the On Vacation option enabled.
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Customers Tab
On the Customers tab, you can create, modify, and delete customer accounts within the system.

A customer is a user assigned the Customer Role. They can be internal or external to the organization.
Customers can raise, update, and if relevant, approve requests through the Customer Portal or email.
Service Desk staff can also generate requests on behalf of the customer.

Within this tab, you can manually create customers or import them from a CSV file. The system also
allows you to import and synchronize customers from a directory server (see Authentication for more
information).

NOTE If you are importing customers using a directory server and the mixed mode authentication
method is disabled, the option to create customers within the Users tab is not available.

If your organization is using organizational units (configured by a supervisor) or customer custom fields
(configured by an administrator), it is recommended that these features be configured prior to creating
customers.

For more information, see the following topics: 
● Creating and Managing Customers Using Internal Authentication
● Importing Customers Using a CSV File
● Importing Customers using LDAP/Active Directory Server
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Creating and Managing Customers Using Internal
Authentication
Use the Customer Information screen to create new customers and view and edit customer details.
It is also possible to set customer roles, line managers, and default login details.

When you create a customer, the following four tabs are available in the Customer Information
screen:

● Contact
● Aliases
● Items
● Contracts

Contact Tab
Use this tab to enter contact information for a customer when creating a new account.

NOTE If you plan to create custom fields for use in the Customer Information screen, it is
recommended that you complete the configuration of these fields prior to creating users. See Custom
Fields for more information.

Creating a Customer Account Using Internal Authentication

To create a customer account using internal system authentication:

1. Go to User > Customers.

2. Click New.

3. In the Customer Information screen, enter details for the customer in the following fields:

Customer Information Fields
Access

Title If enabled, select the appropriate title from the list. (This field is displayed if the
Enable Titles option is set to Yes in the Setup > Privileges > Customer tab.)

First Name* Customer's first name.

Last Name* Customer's last name.

Username* The login user name credentials for the customer. If this field is imported from
LDAP or Active Directory, it cannot be edited. Otherwise, enter a user name.
Note that the value must be unique.

Password/Confirm
Password

By default, a new customer's password ishis or her email address, or you can
enter a random string here by changing the Passwords option in Setup >
Privileges > System (see Authentication for more information).
Customers can reset their password from the Customer Portal, or a Service
Desk user can reset it in the customer's account details using the Reset
Password button in the Customer Information tab.

Web access If enabled, web access allows customers to view their account information and
incidents through the Customer Portal.

Contact
Primary Email* The customer's email address. The customer receives system messages at this
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Customer Information Fields
address.

Send To This field becomes when the Aliases tab contains alternate email addresses
for the customer.
Select the most appropriate email address to use as the default for customer
correspondence. If the Send To field contains an alias address,
correspondence is not sent to the customer's primary email address, unless
specified in the Customer CCs field on the Request Information tab.

Org. Unit The organizational unit (for example, a company or department) associated
with the customer.
Supervisors can create organizational units in User > Organizational Units.

Line Manager If relevant, assign a system user who can approve and reject requests made by
this customer, as part of the change management or service request approval
process. (You cannot edit this information if the line manager details are set
through LDAP synchronization.)

Room This field is visible if the Display Rooms option is enabled in Setup >
Privileges > Customer and there are room details configured in organizational
units.

Address 1 First line of the customer's address.

Address 2 Second line of the customer's address.

City The customer's city details

State The customer's state details. If regions are configured in the system, options
display for the state once you select a country.

Zip/Postcode The customer's area code.

Country The customer's country. The country selected determines the time zone and
state options for the customer.

Email Locale The default language for email correspondence.

Phone The customer's phone details.

Fax The customer's fax number.

Pager The customer's pager details.

Mobile You can enter a mobile number as a contact number or for use with SMS (Short
Message Service). The system can send an SMS to notify the assigned
technician when a request is created.

SMS Override SelectOverride Address? and enter SMS gateway override details for the
customer, if a number other than the one in the Mobile field should be used to
send and receive updates through SMS. Enter the complete SMS details in
email address format; for example, 000777891@smsgateway.provider.com.

Partner
Customer of Select the partner organization to associate with the customer. The partner

organization is an external service provider who manages the customer's
request.
(You enable this option in Setup > Privileges > User > Edit Customer
Partner. Supervisors define partner organizations in the User > Partner
Organizations tab.)

2 6



L i v e T im e A d m in i s tr a to r P o r ta l –
O n l i n e H e l p

C re a t i n g a n d M a n a g i n g C u s to m e rs U s i n g In te rn a l
A u th e n t i c a t i o n

Customer Information Fields
Locale

Time zone Customers automatically adopt the default timezone set for the system.
However, you can manually adjust a customer's timezone here if needed.

Last Login Auto-populated with the date and time the customer last logged in to the
system.

Host The IP address of the last login for the customer.

GPS The GPS coordinates of the last known address for the customer. (This field is
displayed when the Record GPS option is enabled in Setup > Privileges >
Customer.)

Roles
Current* You can assign multiple roles to a customer here.

NOTE If you select the Technician role, you must also allocate a Supervisor.

Default Portal The user interface customers assigned multiple roles access by default when
they log in to the system.

NOTE If you set the customer's Default Portal to Customer, his or her user
details are not accessible in the Users list, but included in the list within the
User > Customer tab.

Details
Notes Enter any relevant information about the customer here.

* Denotes mandatory fields

4. Click Done.

Emailing Customer Credentials
To email newly created customers the details of their system login, click the Email button within the
Customer Information screen. If the Passwords option in Setup > Privileges > System is set to
Random, clicking Email resets the password and forwards the details to the customer. If Password
Questions is enabled in Setup > Privileges > System, clicking Email sends a link to the customer
directing him or her to a security questions page and resets the password based on the answers
provided. Customers must complete this process within an hour of the email being sent.

Downloading Customer Information in vCard Format
Click the vCard button within the Customer Information screen to download and open the customer's
information in an electronic business card format (vCard), which you can email or save outside the
system.

Aliases Tab
Use the Aliases tab to enter additional email addresses for a customer. Email addresses in the Aliases
tab allow the customer to send emails to the system or to team support addresses from more than one
address. The system then creates requests from these customer emails. The system sends
notifications for requests created using an address in the Aliases tab to the customer's main email
address and also copies the alias address used to create the request.

If you create one or more alias email addresses for a customer, a Send To field is shown on the
Customer Information screen, which allows you to set the most appropriate email address as the
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default for customer correspondence. If you set the Send To field to an alias address, the customer's
primary email address is not included in the cc list, unless specified in the Request Information tab
cc list.

Adding an Alias Email Address

To add an alias email address for a customer:

1. Go to User > Customers.

2. Select the customer name.

3. In the Aliases tab of the Customer Information screen, click Edit.

4. Click Add.

5. Enter an alias email address.

6. Click Save.

7. Click Done.

● After you create an alias email address for a customer, a Send To field is shown on the
Customer Information screen, which allows you to set an alias email address as the
default for customer correspondence.

Removing an Alias Email Address
To remove an alias email address, in the Aliases tab, click Edit and select the checkbox next to the
relevant email address, then click Remove.

Items Tab
When you first open the Items tab, it lists all items assigned to the customer. To view shared items,
select the Include Shared option. To view the details of an item, select the Item No. hyperlink. Click
the Excel button to output the item list to Excel format.
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Adding an Item

To add an item to a customer:

1. Go to User > Customers.

2. Select the customer name.

3. In the Items tab of the Customer Information window, click Edit.

4. Click Add.

5. In the Find Item page, search for the relevant item.

● For details regarding an advanced item search, see Advanced Search.

6. Select the Item # hyperlink of the item you want to associate with the customer.

7. Click Save.

8. Click Done.

Removing an Item
To remove an item, in the Items tab, click Edit and select the checkbox next to the relevant item, then
click Remove.

Contracts Tab
The Contracts tab shows a customer's current contract status. Customers can have an SLA or
contract associated with them when the Enable Contracts option in Setup > Billing is enabled. A
customer can have only one active contract.
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Creating a New Contract

To create a new contract for a customer:

1. Go to User > Customers.

2. Select the customer name.

3. In the Contracts tab of the Customer Information screen, click Edit.

4. Click Add.

5. Select a service level from the list.

● When selected, the screen expands to display the Time, Start Date and End Date fields.

6. Define the contract time period by selecting an option from the Time list and completing the
necessary fields.

● For the Per Customer contract type, the following options are available:
● Subscription: The Start Date and End Date are automatically completed by the system,

but can be edited if required.
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● Time Limited Subscription: The Support Hours field is shown where you should enter
the number of support hours the customer purchased. Also, you should complete the Start
Date and End Date fields manually, entering the length of time for the subscription period.

● Support Hours: You should enter the number of support hours the customer purchased.
● Support Hours By Month: You should define the number of support hours covered per

month and on which day of the month the contract is designated as the rollover day. The
Start Date and End Date fields are automatically completed as an annual contract
subscription, but can be edited as required.
If theStart Date is set as a future date, the Pending Contract status is assigned (see
Pending Contracts for more information).

7. Click Save.

8. Click Next.

9. On the Contracts tab, click Save.

10. Click Done.

Deleting a Contract

To delete a current contract, click next to the contract number. Alternatively, to delete a current or
queued contract, within the Contracts > Customers tab select the checkbox next to the relevant
Contract # and click Delete.

Items Tab
You can use the Items tab within User > Customers > Contracts to view all the items with a
contract that the customer owns.

Audit Tab
You can use the Audit tab within User > Customers > Contracts to view the list of requests with the
time recorded against the contract. The Summary view shows the list of requests with total number of
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notes and time allocated to the contract, while the Detail view includes a breakdown of all notes and
the associated time related to each request.

Searching for Customers
To search for Customers within the Users>Customers tab:

1. Go to User > Customers.

2. Click Search.

3. Enter any known customer details.

● Or, for a complete customer list, enter a Created Before or Created After date.

4. Click Search.

● The results are shown in a table with the customer name and contact information.

5. Select the customer name to open the Customer Information screen or select the email
address to send an email to the customer.

Re-enabling Deleted Accounts
As an administrator, you have the ability to reactivate deleted customer accounts.

To enable a deleted account:

1. Within the User > Customers tab, click Search.

2. Toggle the Account Status option to Deleted.

3. Click Search.

● A list of deleted customers is shown.

4. Select a customer to re-enable.

5. In the Customer Information screen, click the Enable button to reactivate the account.

● The customer account becomes active and is available within the system.
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Importing Customers Using a CSV File
You can import customers instantly using a CSV (comma-separated values) text file.

 The following fields are required within the text file for importing customers:
● First Name
● Last Name
● Email Address
● Username (this value must be unique)
● Password

To import customers using a CSV file:

1. Go to User > Customers.

TheCustomers screen opens.

2. Click Import.

TheCustomer Importwizard opens.

To view a template that illustrates the fields the application is looking for and the data types (see
below), click theDownload Template link.

The following fields should be visible in the CSV file:
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Title (char 128),First Name (char 64), Last Name (char 64), Email Address (char 64), Company
(char 64), Department (char 64),Primary Company Contact (int 1), Primary Department Contact
(int 1),Address 1 (char 128), Address 2 (char 128), City (char 64), State (char 32), Postcode/ Zip
(char 20), Country (char 64), Phone (char 20), Mobile (char 20), Fax (char 20), Pager (char 32),

The designation in parentheses after each field name signifies what type of data the import utility
expects to see in each field. For instance:

● ’First Name (char 64)’ means that the first name field cannot exceed 64 characters.
● 'Company Contact (int 1)' means that a 1 in the field will assume the customer is the

primary contact for the company. If the field is left empty or completed with a zero, the
system assumes the customer is not a primary contact.

● Fields marked as ‘Unique’ must be unique in the system.
● 'Locale (char 5)' is the email locale for the customer and, if empty, is set to the option

selected in the Default Locale field in Setup > Email > Setup.
● 'Line Manager Username (char 128)' is the customer's username as recorded in the

system or to be created as part of the CSV import.

If the Partner option was enabled in the application setup, you can assign a partner to a customer
by defining the 'Partners Email' field within the CSV file.

NOTE The name specified in the 'Country' field must be the same as what is found within
the application. If the spelling is different in the CSV file, a customer's country details will not
be imported.

3. Click Choose File and select a CSV file to use for the import.

4. Click Upload.

The system shows you a list of fields that aremapped to the corresponding fields in the CSV file.

* Fields marked with a I aremandatory.
* Fields marked with a I that do not contain matching system records automatically create new
records in system.

5. Adjust mapped fields, if necessary.
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6. Select the Ignore First Line option if the imported CSV file uses its first line as a header to
define the field information. Leave the box unchecked if the CSV file begins with usable data.

7. Select theWeb Access option if you want the imported customers to have immediate access
to the Customer Portal.

If you do not select this option, customers will not be able to log in to the application until they are
given web access within theCustomer Information > Contact tab.

8. Click Import.

The results of the import attempt are shown. If the import was successful, the new customer
details are now available in the system.

9. Click Done.

After you complete the customer import, youmay be required tomanually configure additional
fields, including the following:

● Room (if relevant)
● User Roles
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Importing Customers Using LDAP/Active Directory
Server
You can connect the application to a directory server for customer and user authentication purposes.
This process removes the need to create customer and user accounts, allowing you to work with
infrastructure already in place to synchronize accounts and access levels with an existing directory
server.

As part of the mapping process, if a value does not exist on the directory server for a mapped field, a
drop-down menu will not be available in LiveTime for that field, nor will users be able to edit it.

If you use a directory server, a customer’s password is not visible within LiveTime, regardless of
whether the customer is new or existing in the system. This is because the system validates the
customer’s account against a directory server account rather than an internally authenticated account.
The customer's password resides in the directory server’s database and is therefore not accessible
through LiveTime.

Also, customers using LDAP or Active Directory authentication are not able to edit their first name, last
name, LDAP/ADS username, or email address. These fields are stored on the directory server, and
cannot be modified within LiveTime.

To import customers using a directory server, see Authentication.
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Users Tab
The Users tab allows you to create, modify, and delete user accounts in the system.

Users can have one of the following roles:
● Technician
● Supervisor
● Partner
● Team Leader

and one or more of:
● Administrator
● Customer
● Finance
● Manager

It is possible for users to have multiple roles. For example, technicians may also be assigned the
Customer role so they can log requests related to their own equipment. When a users have more than
one role, they can switch between interfaces easily (see Changing Roles for more information).

You can create user accounts within the application or import them from one or more directory servers.

If you are using custom fields for users, you should configure these fields prior to creating users (see
Custom Fields for more information).

For more information, see the following topics:
● Creating User Accounts Using Internal Authentication
● Importing User Accounts Using LDAP/Active Directory Server
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Creating and Managing Users Using Internal
Authentication
If you are creating users within the system that are to be assigned to support teams, you must allocate
one of the following roles to them:

● Technician
● Team Leader
● Supervisor
● Partner

Only the above user roles can work on requests. For more information regarding specific user roles in
the system, see About User Roles.

When you create a new user, the following tabs are available:
● Information
● Schedule
● Aliases
● Team
● Skills
● Types

Information Tab
Within the Information tab, you can create, view, and edit user details. You can also customize user
roles, process assignment, and default logins within this tab.

Creating a User

To create a user:

1. Go to User > Users.

2. Click New.

3. In the User Information window, enter details for the new user.

User Information Fields
Title Select a title from the list. (This field is displayed if the Enable Titles option is set to

Yes in Setup > Privileges > Customer.)

First Name* Enter the user's first name.

Last Name* Enter the user's last name.

Username* Enter a system user name (this value must be unique).

Password* Enter a password for the user.

NOTE You can change passwords in the Users tab or users can reset their
password under their My Account tab.

Roles* Assign a role for the user. Each role has associated permissions (see Roles for
more information).
Every technician must be assigned to a supervisor.
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User Information Fields

NOTE While you can assign more than one role to a user, a user can have only
one role of Supervisor, Team Leader, Partner, or Technician.

Default
Portal*

Select the interface that a user with multiple roles accesses by default when he or
she logs in to the system.

NOTE If the user's default portal is set to Customer, his or her user details will not
be accessible in the Users list, but included in the list within the User > Customers
tab.

Assignment
Template

This option is visible if job assignment templates are configured in the User >
Assignments tab.
Select a template to assign the new user to multiple teams, escalation layers, and
processes.

Operations
Processes

Assign the licensed access for request fulfillment, incident management, and
problem management.
Assigning processes to users gives them access to support those processes and
enables them to be assigned as team members for those processes' teams. See
User Processes for more information.

Change
Processes

Assign the licensed access for change management, release management, and
deployment management.

NOTE Users assigned release management are automatically assigned
deployment management.

Internal
Processes

Enable the user's privilege to maintain service level management, configuration
management, and knowledge management.
Selecting the Configuration and Knowledge options displays additional fields that
enable you to set granular controls for those processes.

NOTE The Finance role is limited to the processes of configuration management
and service level management.

Knowledge If the knowledge management process is enabled for the user, you can configure
his or her privilege to create, edit, delete, and publish knowledge base articles
(KBAs).

Configuration If the configuration management process is enabled for the user, you can configure
their privilege to create, edit, and delete Items within the CMDB on a per-task basis.

Customer
Org Unit

This field is visible if the user is also a customer within the system. Enter company or
department details that apply to the user in their role as a customer.

Line
Manager

This field is visible if the user is also a customer within the system. You cannot edit
the information if the line manager details are set by LDAP synchronization.
If relevant, assign a system user with the Customer role who can approve/reject
requests made by this customer.

Primary
Email*

Enter the user's email address. System messages are sent to this address.

Send To This field is visible if the user is also a customer and has alternate email addresses
entered on the Aliases tab.
Select the most appropriate email address to use as the default for customer
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User Information Fields
correspondence. If you set the Send To field to an alias address, the primary
address is not included in the cc list, unless specified in the cc list of the Request
Information tab.

Phone Enter telephone details.

Mobile You can enter a mobile number as a contact number or for use with SMS (Short
Message Service). The system can send an SMS to notify the assigned technician
when a request is raised.

SMS
Override

SelectOverride Address? and enter SMS gateway override details for the user, if a
number other than the one in the Mobile field should be used to send and receive
updates through SMS. Enter the complete SMS details in email address format; for
example, 000777891@smsgateway.provider.com.

Fax Enter fax details.

Pager Enter pager details.

Salary You can enter an annual salary. The system uses this value for reporting.

Chargeback
Rate*

This field is available when the Enable Chargebacks option is enabled at Setup >
Advanced > Billing.
Select the default hourly rate this user should charge for services rendered. The
selected rate is used when the user bills customers in arrears for support they have
received in response to a request, unless the user adjusts the rate manually within
the request. Chargeback rates available here are defined in the User Portal at
Finance > Chargeback by users with the Finance role.

Forum
Moderator

Select this option to designate the user as a forum moderator. See Forums for more
information.

Survey
Manager

Select this option to allow the user to create and manage surveys in the system.

Supervisor* Select a supervisor if the user is a technician. You must allocate a supervisor to
users with the Technician role.

Partner For If you assign a user the Partner role, you must also assign his or her associated
partner organization in this field.

Partner If the user is also a customer, this field allows you to associate the customer with a
partner organization who will handle his or her requests when logged in the system.

Available Shows if the user is available to take on requests. This availability is based on work
hours configured in the user's Schedule tab and his or her vacation status. If no
hours are set within the Schedule tab when Define Works Hours is enabled within
Setup > Privileges > User and the user is not on vacation, the system will consider
him or her to be unavailable.

Assignment This field is visible when Assignment Control is enabled in Setup > Privileges >
User.
Set to Off if the user should not be assigned new requests, irrespective of their
availability status.

On Vacation Placing technicians on vacation excludes them from being assigned new requests
automatically. When On Vacation is activated, the system does not reassign a
technician's existing requests.

Survey Opt Set to Yes if you want to exclude this user from all future customer surveys.
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User Information Fields
Out

Training This option is only visible for technicians, and when enabled, allows them to be
included in teams to view requests but does not allow them to put the request in edit
mode or add notes.

Email Locale Adjust the default language for email correspondence, if required.

Country The user automatically adopts the default country set for the system. However, you
can manually adjust the country here for the specific user.

State Set the state information based on the country selected, if required.

Time zone The user automatically adopts the default time zone set for the system. However,
you can manually adjust the time zone here for the specific user.

GPS The GPS coordinates of the last known address for the user.

* Denotes mandatory fields

4. Click Done.

Emailing User Details
To email users regarding their system log in credentials, click the Email button within the User
Information screen. If the Passwords option in Setup > Privileges > System is set to Random,
clicking Email resets the password and forwards the details to the user. If Password Questions is
enabled in Setup > Privileges > System, clicking Email sends a link to the user directing him or her
to a security questions page and resets the password based on the answers provided. Customers
must complete this process within an hour of the email being sent.

Downloading User Information in vCard Format
Click the vCard button within the User Information screen to download and open the user's
information in an electronic business card format (vCard), which you can email or save outside the
system.

Schedule Tab
By default, the Schedule tab includes the On Vacation option, which you can set to Yes when the
user takes leave. The system automatically reassigns the user's active requests if the Vacation
Reassign option is enabled in Setup > Privileges > User. If this option is not enabled, a supervisor
needs to manually reassign the requests, if required.

If the Define Work Hours and Scheduled Vacations options are enabled in Setup > Privileges >
User, this additional functionality is available within the Schedule tab.
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Defining Work Hours
Use the lists underWorking Hours to set the hours of work when the user is available during the
week. Based on what is set here, the system assigns requests to the users during their available
hours. However, if no other technicians are available for requests based on their defined work hours,
the system assigns users new requests outside of their set work hours.

NOTE If the Define Work Hours option is enabled, you must define the hours of work for
technicians, otherwise the system ignores the technician assignment logic and automatically allocates
new requests to the team lead.

Scheduling Leave
The Scheduled Vacation option allows supervisors to pre-book leave in the system for users. There
are no restrictions on the number of days that can be set as vacation, and based on the configuration,
when a leave period begins, the system automatically reassigns active requests to other available
users applying the technician assignment logic. If a request was initially drawn from a queue, it does
not return to the queue but is reassigned to the most relevant technician based on the technician
assignment logic.

To schedule user leave as a supervisor:

1. Go to User > Users.

2. Select the name of the user.

3. Click the Schedule tab.

4. Click Edit.
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5. Select to expand Vacation Details.

6. Enter the reason for leave in the Purpose field.

7. Complete the Start Date and End Date details.

8. Click Save.

● When the Start Date arrives, the system stops assigning new requests to the user. After
the scheduled End Date, the user again becomes available.

NOTE If the user on vacation is a team lead for any team that has no technicians available
for new request assignment, the system allocates new requests to the team lead, regardless
of his or her vacation status.

● When you log in to the system as a supervisor, the events calendar in Home > Calendar
shows when users are on vacation:

Aliases Tab
Use the Aliases tab to enter additional email addresses for a user. Email addresses in the this tab
allow the user to send emails to the system or to team support addresses from more than one address.
The system then creates requests from these emails. Notifications for requests created using an
address in the Aliases tab are sent to the user's main email address and copied to the alias address
used to create the request.

NOTE This tab is applicable only if the user has the Customer role.
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When you create one or more alias email addresses for a user, a Send To field is shown on the
Customer Information screen, which allows you to set the most appropriate email address as the
default for customer correspondence. When the Send To field is set to an alias address, the user's
primary email address is not included in the cc list, unless specified in the Request Information tab
cc list.

Adding an Alias Email Address

To add an alias email address for a user:

1. Go to User > Users.

2. Select the user's name.

3. In the Information tab of the User Information screen, click Edit.

4. Click the Aliases tab.

5. Click Add.

6. Enter an alias email address.

7. Click Save.

● After you create an alias email address for a user, a Send To field is shown on the User
Information screen, which allows you to set an alias email address as the default for
customer correspondence.

NOTE Aliases are applicable only if the user has a Customer role.

Team Tab
The Team tab lists teams associated with the selected user. Use this tab to assign the user to one or
more support teams, making the additions by team or job assignment templates that are configured in
the system. Processes selected in the Information Tab for the user determine the teams available in
the Team tab.

Once you assign a user to a team, a supervisor must configure the escalation layers for the team to
include the new user. However, you can easily add the user to layer one of escalation when you
associate him or her with a new team by selecting the Assign new users to layer one option within
this tab. Also, if assignment templates exist in the system, by selecting a team template, you can
automatically add the user to teams, escalation layers, and work groups configured within the selected
template.
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NOTE The user must have the relevant processes enabled for support teams to show in team search
results. If you select an assignment template and it includes teams for processes not enabled for the
user, those teams will not be available for addition.

Adding Users to Teams

To add a user to a team within the Team tab:

1. Click Edit.

2. Ensure Team is selected in the Add By list,

3. Enter a team name in the Find Team (Name) field and click .

● Or, leave the field empty and click . The teams for processes that the user is assigned
are shown in the search results.

4. Select the Assign new user to layer one option, if relevant.

5. Select a team name from the search results.

6. Click Save.

Adding Users to Teams Using Assignment Templates

To add a user to a team within the Team tab using assignment templates:

1. Click Edit.

2. Select Team Template from the Add By list.

● Job assignment templates that have been configured in the User > Assignments tab are
shown, but only including teams consistent with the processes assigned to the user.

4 5



L i v e T im e A d m in i s tr a to r P o r ta l –
O n l i n e H e l p

C re a t i n g a n d M a n a g i n g U s e rs U s i n g In te rn a l
A u th e n t i c a t i o n

3. Select one or more template options.

4. Click Save.

● The user is automatically included in the teams, escalation layers, and work groups
configured in the template.

Removing Users from Teams

To remove a user from a team:

1. Go to User > Users.

2. Select the name of the user.

3. Click the Team tab.

4. Click Edit.

5. Select to remove a team assignment.

6. Click Save.

7. Click Done.

NOTE If a user is the team lead or the only person assigned to an escalation layer, he or she
cannot be removed from a team under this tab.

Skills Tab
Use this tab to assign any specific classifications that a supervisor, technician, or partner should
handle. The system assumes that anything you include in this tab is an area of expertise for the
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users, which allows the system to automatically route requests logged against these Classifications
to the most appropriate user.

NOTE Prior to using the Skills tab, a supervisor should configure items and classifications.

Assigning a Classification

To assign a classification:

1. Go to User > Users > Skills.

2. Click Edit.

3. Click Add.

4. Select the Item Category.

5. Select an Item Type, if relevant.

6. Select a Classification. You can select * to assign all classifications as skills or you can
choose a specific classification.

● The list includes all classifications configured for the item category and the item type, if
you selected an item type.

7. Click Save.

8. Click Done.

NOTE Classifications you assign to a user are based on either the classifications of an item
category or an item type, hence why two columns are shown. However, the Item Type
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column only includes information when the classification you select is specific to that item
type, and not directly related to the item category.

Removing a Classification

To remove a classification:

1. Go to User > Users.

2. Select the name of the user.

3. In the Skills tab, click Edit.

4. Select the checkbox next to the classification(s) you want to remove.

5. Click Remove.

6. Click Done.

Org Unit Tab
Use this tab to assign one or more organizational units to a supervisor, technician, or partner. The
system directs requests logged by these organizational units to the assigned users. If you assign
users to support organizational units, the Find Customer option during the request creation process
shows the Supported Org. Units Only option. This option limits the customer search results to
those customers who belong to the organizational units that the logged in user is assigned to support.

Assigning an Organizational Unit

To assign an organizational unit to a user:

1. Go to User > Users > Org Units.

2. Click Edit.

3. In the Find Org. Unit (Name) field, enter any known organizational unit details or leave the
field blank to return the full list of units recorded in the system.
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4. Click .

5. Select the organizational unit name to associate it with the user.

● You can select multiple units, if required.

6. Click Save.

Removing an Organization Unit

To remove the association between a user and an organizational unit:

1. Go to User > Users.

2. Select the name of the user.

3. In the Org Units tab, click Edit.

4. Select next to the organizational unit(s) you want to remove.

5. Click Save.

6. Click Done.

Re-enabling Deleted Accounts
As an administrator, you have the ability to reactivate deleted user accounts.

To enable a deleted account:

1. Within the User > Users tab, click the Search button.

2. Select Deleted as the Account Status search option.

3. Click Search.

● A list of deleted users is shown.

4. Select the name of the user whose account you want to re-enable.

● The User Information page opens.

5. Click the Enable button.

● The user account becomes active and is available within the application.
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Importing Users Using LDAP/Active Directory Server
You can connect the system to a directory server for user authentication purposes. This process
removes the need to create user accounts, allowing you to work with infrastructure already in place to
synchronize user accounts and access levels with an existing directory server.

As part of the mapping process, if a value does not exist on the directory server for a mapped field, a
drop-down menu will not be available in LiveTime for that field, nor will users be able to edit it.

If you use a directory server, a user’s password is not visible within LiveTime, regardless of whether
the user is new or existing in the system. This is because the system validates the user’s account
against a directory server account rather than a system account. The user's password resides in the
directory server’s database and is therefore not accessible through LiveTime.

Also, users using LDAP or Active Directory authentication are not able to edit their first name, last
name, LDAP/ADS username, or email address. These fields are stored on the directory server and
cannot be modified within LiveTime.

To import users using a directory server, see Authentication.
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Assignments Tab
The Assignments tab allows you to create job function templates for new and existing users. These
templates provide a way in the system to easily assign users to multiple teams, escalation layers,
organizational units, and for new users, processes all at once. Administrators and supervisors can
apply these templates within the User Information screen for new users, and within the Team tab of
the User Information screen for existing users who are assigned the relevant processes.

For example, you might create a "Frontline Support" template to assign a user to layer 1 of your
incident team and to a work group of a service request team. You may also want to assign the user to
an update customer group within a change management team. You could then easily apply the
template within the User Information screen to all users created directly in the system. Or, if a user
was created using a directory server, you could apply the template within the Team tab of the User
Information screen.

Creating an Assignment Template
Before creating an assignment template, be sure all the relevant teams, escalation layers, groups, and
organizational units exist in the system. If you create additional teams, escalation layers, groups, or
organizational units at a later date, you can easily update the assignment template.

To create an assignment template:

1. Go to User > Assignments.

2. Click New.

3. Enter the Template Name.

4. Click Add.

5. In the Find Team (Name) field, enter a name to find a specific team, or leave the field blank

to return a list of all teams, then click .
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6. Select the name of the team you want to add to the template.

7. Select an option from the Layer list.

8. Click Save.

9. In the Find Org. Unit (Name) field, enter a name to find a specific organizational unit, or

leave the field blank to return a list of all organizational units, then click .

10. Click Save.

11. Repeat steps 4 to 10, until you have created all relevant assignments for the template.

● The template is now available within the User Information screen for new user creation,
or within the Teams tab for existing users.

Editing an Assignment Template
To make changes to an existing user assignment template, such as adding or removing teams,
related layers, or group assignment:

1. Go to User > Assignments.
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2. Select the name of the template you want to edit.

3. Click Edit.

4. To remove a team/layer association, select the checkbox next to the team name and click
Remove.

5. To add a team/layer association, click Add.

6. Enter a name to find a specific team, or leave the field blank to return a list of all teams, then

click .

7. Select the name of the team you want to add to the template.

8. Select an option from the Layer list.
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9. Click Save.

10. To remove an organizational unit from the template, click next to it. To add an
organizational unit, use the Find Org. Unit (Name) field.

11. To save all changes, click Save.

Deleting an Assignment Template
To delete an assignment template from the system:

1. Go to User > Assignments.

2. Click on the name of the template you want to delete.

3. Click Edit.

4. Click Delete.

5. In the warning message, click OK.

Applying Assignment Templates to New Users
For new users created directly in the system, you can apply an assignment template within the User
Information screen. When you apply a template, the system automatically associates the newly
created user with all relevant processes, teams, escalation layers, and groups. To remove a team
assignment after a template has been applied during new user creation, deselect the process and the
team name will be removed from the assigned list.
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To use an assignment template for a new user:

1. Go to User > Users.

2. Click New.

3. Enter the user's details.

4. From the Assignment Template list, select the template you want to apply to the user.

● All relevant processes are automatically selected for the user.

5. Clear any processes that do not apply to the user.

● The team association is automatically removed from the Team Name list.

6. Complete the remaining user details, including assigning a supervisor and email address.

7. Click Save.

Applying Assignment Templates to Existing Users
For users who have active accounts in the system and are assigned the relevant processes,
assignment templates are available within the Team tab of the User Information screen.

To apply a template to an existing user:

1. Go to User > Users.

2. Select the name of a user.

3. Click Edit.

4. Verify the user has all the relevant processes with the User Information screen.

5. Click the Team tab.

6. From the Add By list, select the Team Template option.
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7. Select the relevant template from the Templates list

8. Click Save.
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About User Roles
There are eight access levels that determine the functionality and privileges available within LiveTime.
These access levels include the Administrator and Customer roles, plus six user roles:

● Supervisor
● Technician
● Partner
● Manager
● Finance
● Team Leader

A user can have more than one role but only one of the following licensed roles:
● Supervisor
● Partner
● Technician
● Team Leader

If an individual has multiple roles within the system, you can assign a default role to allow for quicker
access to the most commonly used functionality.

Default Portal
For individuals who have more than one role in the system, you can define a default portal for them.
When they log in to the system, their default portal is shown and they can move to other portals using
the links provided next to their login name at the top right of the screen. For example, if a user is also
an administrator and customer, next to his or her login name, the [Setup] and [Customer] links are
available for quick access to these portals.

Default portal options include the following:
● [Customer]
● [Setup], for administrators
● [User], for those assigned a Supervisor, Technician, Partner, Finance, Team Leader, and

Manager role

Users or administrators who are also customers can access the Customer Portal through the
[Customer] link located at the top right of their screen. While logged in as a customer, you can access
the User Portal and Admin Portal links within the Customer Portal sidebar menu.
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To move to another portal:

1. Log in using the credentials for your default user role.

2. Click the [Setup], [User], or [Customer] link, as required.

● The system switches to the selected portal.
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User Processes
LiveTime includes the following processes to help manage the different types of requests an
organization can encounter:

● Request fulfillment
● Incident management
● Problem management
● Change management
● Release and deployment management
● Service level management
● Configuration management (which incorporates service catalog management and service

portfolio management)
● Knowledge management

NOTE Request fulfillment, problem management, change management, and release and deployment
management apply based on your LiveTime installation license.

When you create user accounts, you also allocate processes to the user, which gives the user access
to requests and information specific to each assigned process.

Providing a user access to incident management, problem management, change management, and
request fulfillment means the user can be assigned as a member of support teams within those
processes.

Users who have service level management enabled have access to the Service tab they log in to the
application. This tab allows users to create and edit SLAs, OLAs, and underpinning contracts.

Users who have configuration management and knowledge management enabled have options to
define control at a more granular level in the User Information screen, and these users can be
assigned permission to create, edit, delete, and publish elements within these processes.

The following user roles have limitations on the processes they can be assigned:
● The Finance role can only be assigned configuration management and service level

management
● The Manager role can be assigned all processes, but with 'Read Only' access.
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User Roles & Privileges
Administrator Supervisor

Team
Leader

Technician Partner Finance Manager Customer

Setup

Email setup
and email
customization

Create
custom fields

Set user,
customer &
system
privileges

UI
customization

Dynamic
database
switching

Schedule
LDAP / ADS
integration

Item import
via AMIE or
CSV file

Customer
import

Scheduled
reports

Incident
Analyzer for
problem
management

Enable billing
module

Customize
workflows

Customize
system
messages
and keywords

Chat

Context
sensitive help

Create users
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Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

Assign user
roles &
processes

Create teams,
escalation
layers & work
groups

Create
customers

1 1 1 1 1

Enable
customer
access

View/edit
customer

Search
customers

Re-enable
deleted users
& customers

Create
organizational
units

Assign
contracts to
organizational
units

Incident Management

Create / edit
incidents

Delete
incidents

View / edit
other
technicians'
incidents

2 1, 2

Re-assign
incidents

2 1 1

Escalate
incidents

2 1 1

View all
incidents

2 1, 2

Handshaking

Incident
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Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

groups

Impact
analysis

View
proposed
solutions

Incident
analysis

Subscribe to
RSS feeds

Request Fulfillment

Create / edit
service
requests

Delete service
requests

View/edit
other
technicians’
service
requests

2 1, 2 1

View all & re-
assign service
request

2 1, 2 1

Approve
service
request

Escalate
service
request status

Handshaking

View
proposed
solutions

Service
request
groups

Impact
analysis

Update
workflow
status

Problem Management
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Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

Create / edit
problems

Delete
problems

View / edit
other
technicians’
problems

2 1, 2

Re-assign
problems

2 1 1

Escalate
problems

2 1 1

View all
problems

2 1, 2

Create known
errors

Impact
analysis

View
proposed
solutions &
workarounds

Problem
analysis

Create
workarounds

Change Management

Create / edit
change
requests

Delete
change
requests

View / edit
other
technicians’
change
requests

2 1, 2 1

View all & re-
assign
change
request

2 1, 2 1

Escalate
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Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

change
request /
modify
change
request status

Approve
change
request

Change
groups

Impact
analysis

Create back
out procedure

Update
workflow
status

Release & Deployment Management

Create /
delete tasks

Edit tasks

View / edit
other
technicians’
tasks

2 1, 2 1

View all & re-
assign tasks

2 1, 2 1

Define a
release

Define a
deployment
package

Control
release
lifecycle

Create and
modify
workflow

Service Asset & Configuration Management, Service Portfolio Management, Service Catalog
Management

Create / edit /
delete items

1 1 1 1 1 1

View / edit
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Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

items

Search items

Re-enable
deleted items

Create item
categories &
category
classifications

Create item
types & type
classifications

Create
outages

View outages

Assign
contracts

Service Level Management

Define SLAs

Define
underpinning
contracts

Define OLAs

Create
vendors

Create SLA
breach codes

View SLA
breaches

Financial Management

Create
purchase
orders

Process
purchase
orders

Create and
assign
contracts

Process
contracts

Create and
process

6 5



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p U s e r R o l e s & P r i v i l e g e s

Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

invoices

Create,
manage &
view item
costs

Forecast
service item
costs

Knowledge Management

Create
articles / FAQs

1 1 1 1 1

Publish
articles

1 1 1 1 1

Create article
groups

Search
articles

Administer
forums

1 1 1 1

Create /
modify / reply
to topic
threads

1 1 1 1 1

Create
surveys

1 1 1 1 1

Complete
surveys

Reports

KPI reports

Service
request
reports

Incident
reports

Problem
reports

Change
request
reports

Configuration
reports

Service

6 6



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p U s e r R o l e s & P r i v i l e g e s

Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

agreement
reports

Contract
reports

Organization
reports

Technician
reports

Knowledge
reports

Finance
reports

Login reports

System
reports

Build reports

Custom
reports

Home

Create alerts 1 1

View alerts

Enable quick
calls

Create quick
call templates

Set user
preferences

Disable
receiving
personal
email

Dashboard
across
processes

Customer Portal

Create / view /
edit requests

Edit & close
existing
requests

1

View
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Administrator Supervisor
Team
Leader

Technician Partner Finance Manager Customer

proposed
solutions

Search
knowledge
base

View FAQs

View service
catalog

1

Create items 1

View outages

Chat with
technician
regarding
request

1

Search
forums

1

Complete
surveys

Subscribe to
RSS feeds

1 Privilege must be enabled in the system setup.
2 Privilege applies only within the context of the user's team.
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Administrator Role
The Administrator role performs system configuration and setup tasks, including the following:

● Customizing the application and automated messages
● Configuring the interaction between external systems, including the directory servers and

asset management tools
● Enabling customer, user, request, and system privileges
● For systems with problem management configured, setting parameters for automatic problem

identification and creation

While multiple administrators can exist in the system, it is recommended that organizations create only
one, or at maximum, two administrators. Only an existing administrator can create other administrator
accounts.

NOTE If a user has multiple roles that include Supervisor, Technician, Finance, or Manager, the
privileges of these roles are consolidated within a single User Portal (see Changing Roles for more
information).
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Supervisor Role
The Supervisor role provides maximum access to the system for day-to-day management of the
service desk and for configuration control.

NOTE If a user has multiple roles that include Supervisor, Technician, Finance, or Manager, the
privileges of these roles are consolidated within a single User Portal (see Changing Roles for more
information).

Supervisors can do the following:
● Create user and customer accounts
● Assign roles and processes
● Build workflows (when assigned the service level management process)
● Configure the Configuration Management Database (CMDB)
● Allocate technicians to teams and escalation layers

The Configuration Management Database (CMDB) is the central data repository for LiveTime. The
CMDB allows for the centralized management of IT infrastructure through configuration items ("items").
Within LiveTime, everything is tied to items in the CMDB. Supervisors control the configuration of the
CMDB, which includes:

● Item categories
● Lifecycle templates
● Item types
● Classifications
● Configuration items

NOTE The ability to create items can also be assigned to other roles, if an administrator has enabled
this option.

7 0



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p T e a m L e a d e r R o l e

Team Leader Role
The Team Leader role oversees the day-to-day operations of a specific team of technicians. Duties of
this role include ensuring a team is meeting its service commitments, monitoring the performance of
team members, and handling request escalations.

Team leaders have all the privileges of a technician, plus the following:
● Create item categories and category classifications
● Access a broader range of reports
● View teams
● Edit the teams they are assigned to

NOTE If a user has multiple roles that include Supervisor, Team Leader, Technician, Finance, or
Manager, the privileges of these roles are consolidated within a single User Portal (see Changing
Roles for more information).
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Technician Role
The Technician role is intended for service desk staff who work on requests.

Technicians are allocated support processes and can then be assigned to teams and escalation layers.
Technicians can belong to any number of teams within the processes they are allocated.

NOTE If a user has multiple roles that include Supervisor, Technician, Finance, or Manager, the
privileges of these roles are consolidated within a single User Portal (see Changing Roles for more
information).

When enabled by an administrator, technicians can do the following:
● Create new customers
● Create new items
● Reassign requests
● Edit other technicians' requests
● Create alerts
● Create, edit, publish, and delete knowledge base articles by default

NOTE Every technician must be assigned to a supervisor.
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Partner Role
The Partner role is assigned to a partner organization and has the same privileges as the Technician
role, but partners can only view and support customers associated with their assigned partner
organization.

Partners can do the following:
● Manage their customers
● Manage their customers' requests
● Create and maintain their customers' items
● View reports

Every partner must be associated with a partner organization, which is done manually within the User
Information screen or within the Partner Organization > Technician tab. Partner organizations help
manage requests between customers or organizational units and external service providers within
LiveTime. Multiple partners can be available within a team and assigned at relevant levels of
escalations for working on requests.

If you create a partner and do not associate the account with a partner organization, the partner cannot
be assigned to a team and therefore cannot be assigned to work on requests.

When a request is created for a partner organization's customer, the system automatically allocates it
to the partner associated with that organization.
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Manager Role
The Manager role oversees the activities of the Service Desk or specific processes. Managers have
access to most parts of the system, primarily on a read-only basis.

You can also give manager access to users who do not actively participate in the day-to-day
happenings of service and support teams, but may require detailed information about the actions and
status of requests.

A manager can do the following:
● Create customers
● View requests within their allocated processes
● Access the full range of reports
● Create and modify items
● Approve service requests and change requests (based on LiveTime license type)

Users who must manage the Service Desk and be included in teams with edit access to requests
should be allocated the Supervisor role.

NOTE If a user has multiple roles that include Supervisor, Technician, Finance, or Manager, the
privileges of these roles are consolidated within a single User Portal (see Changing Roles for more
information).
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Finance Role
The Finance role drives service costing models and, if relevant, maintains the billing module using
system contracts and purchase orders. Users with the Finance role have the processes of service
level management and configuration management enabled by default.

NOTE If a user has multiple roles that include Supervisor, Technician, Finance, or Manager, the
privileges of these roles are consolidated within a single User Portal (see Changing Roles for more
information).

The Finance role can do the following:
● Create customers and items
● Project end-to-end service costs
● Complete access to SLAs and OLAs
● Access reports
● Bill for services
● Process payment for invoices
● Cancel maintenance contracts
● Manage IT and service assets

NOTE The Finance role is the only role with the privilege to process the payment of invoices (relevant
for systems that have the Enable Invoices option enabled in Setup > Billing).
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Customer Role
The Customer role is for users who submit service requests, incidents, and possibly change requests
to the service desk.

Customers can do the following, based on the system configuration:
● Create and manage requests through email
● Create, view, or edit their requests through the Customer Portal
● Self-diagnose issues using the knowledge base
● Access proposed solutions during the request creation process
● Participate in a live chat with technicians to discuss issues
● Subscribe to RSS feeds for the latest information on their requests
● Access the knowledge base, forums, and FAQs
● Access their items' outages information
● View all services offered by the service organization, if enabled for the system
● Approve service requests and change requests (based on LiveTime license type)
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Reports
You can use the Reports tab to view:

● Login reports
● System reports
● Email log
● System log

These reports provide you with details of system activity in real time. The reports outline who has
logged into the system and how the application is performing. You can use the login report to log out
users who have closed a session without logging out.

Within the Log tab, you can view the system log files and export them when needed.
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Login Reports
The information displayed on the Reports > Login tab includes the following:

● Recent Logins, with IP addresses, host details, and login dates for users who recently
accessed the system

● Alert Manager Statistics, showing active alerts in the system. Users can create alerts
manually and the system can create alerts automatically to notify users about service and
support activities.

● A list of current sessions, with a Logout option next to each session.
NOTE If you click Logout, you end the user's session. This action may be required if a user
has disconnected from the system without logging out and needs access to log back in. This
action is not required if the Terminate Active Session option is set to Yes in Setup >
Privileges > System.
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System Reports
System reports include a real time summary of the system's status and environment.

Report information includes the following:
● Statistics, which includes a summary of key system metrics regarding the current session,

the hosting environment, and memory usage
● Database, which provides overall application and database statistics
● Scheduled Tasks, which lists all background system jobs (including indexing, which allows

supervisors to view that the system is indexing correctly without sticking)
● Java VM Information, which provides details about the Java Virtual Machine running on the

server
● Disk Space, which lets you know how much disk space on the server is free

7 9



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p E m a i l L o g

Email Log
The Reports > Email tab allows you to access a complete list of email activity that occurs within
LiveTime. This list enables you to determine whether an email is successfully sent or if it has failed. If
an email fails to send, the system provides an explanation for the failure. Failed messages can attempt
to be resent by selecting the checkboxes and clicking the 'Resend' button.

The Email Log screen has the following filter views:

Filter Description
All Mail Displays all email activity.

Inbound Mail Lists the emails that have been sent to the system.

Inbound Mail
Errors

List the emails received by the system mailbox in error (for example, from email addresses
with no account).

Outbound Mail Lists the emails that users have sent from the application.

Outbound Sys
Mail

Lists the emails that the system has automatically sent (for example, emails related to
escalations or SLA breaches).

NOTE Automatic system maintenance deletes email log entries older than 14 days.

You can also create custom list filters to use within this screen.

Searching Email Activity
You can conduct searches on inbound and outbound emails recorded in the system email log.

To search for an email:

1. Go to Reports > Email.

2. Click Search.

3. Define the following search options:

Option Description
Start Date Enter the earliest relevant date for the system to include in the search.
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Option Description
End Date Enter the latest relevant date for the system to include in the search.

Direction Define if the search is to include either inbound or outgoing email.

Status Define the email status option to search for:
• Sent email
• Failed to send email
• Email set a Pending status
• Email sent with errors

4. Click Search.

Generating Requests for Email Delivery Errors
If the email log contains failed entries due to email delivery errors (for example, an invalid or missing
email address), and the Create Request option is enabled in the Administrator Portal at Setup >
Email > Errors, you can quickly generate a request to prompt the Service Desk to take appropriate
action (for example, update the customer's record with the correct address).

To generate a request for an email delivery error:

1. Go to Reports > Email.

2. In the email log, select the Date of a failed entry.

3. Click Create Request.

● The system generates a request to address the failed email delivery based on the settings
specified by your administrator. The ID number of the newly-created request is shown in
the Request field. If you have sufficient privileges to view the request, you can select the
ID number to open it.
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System Log File
To assist with the diagnosis of issues that may occur when using the system, you can access system
log files within the Log File Viewer. The information shown here includes the last 250K of the 1MB log
file.

Exporting the Log File
If you are experiencing issues with the application, you can easily export the log file information by

clicking . You can then upload the log file export, which includes system and license
information, to a pre-existing incident or email it to your local system support team.
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My Account Tab
The My Account tab allows you to do the following:

● Edit personal information and notification preferences
● Reset your username and password
● Set password questions, if enabled in the system
● Select your default portal and Home tab landing page
● Set a time zone and date format

NOTE You cannot edit fields imported through an LDAP or Active Directory server.

Editing Account Information
To edit your account information:

1. In the User Portal, go to Home > My Account. In the Administrator Portal, click the My
Account tab.

2. In the Account Information screen, click Edit.

3. Make the required changes.

Field Description
Details

First Name Your first name. If account information is imported from LDAP or Active Directory, this
field is not editable.

Last Name Your last name. If account information is imported from LDAP or Active Directory, this
field is not editable.

Username Your username in the system.

Password To change your password, enter a new value in this field.

Confirm
Password

Re-enter the password to confirm correct entry.

Password
Question
One/Two

Select the challenge questions the system should ask you before sending a new
system password to you if you select the Lost Password link on the login page.
(These fields are visible when the Password Questions option is enabled at Setup >
Privileges > System.)

Answer
One/Two

Enter the answers to the questions you selected.

Email Your email address.

Notifications You can choose to receive system-generated emails when requests are created or
updated. Regardless of the setting in this field, you will receive an email notification if
a request is escalated to you.

Notify on
Vacation

You can choose whether you want to receive system-generated emails regarding
requests while you are away on scheduled vacation.

Survey Opt
Out

Set to Yes if you want to be excluded from all future customer surveys.

Notify Via Select Email, SMS, or Phone as your preferred method of receiving updates from the
system.

8 3



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p M y A c c o u n t T a b

Field Description
This field is visible if you are also a customer in the system and the Customer
Defined Contact option is enabled in Setup > Privileges > Customer. It only applies
if the team has the Customer Notification option set to Customer Defined.

Phone
Mobile
Pager

Your telephone, mobile, and pager details. If these fields are imported from LDAP or
Active Directory, they are not editable.

Date Format Your preferred date format.

Country When you enter your country details, if the country has states, a States list will also
become available. (State options can be configured in the Administrator Portal at
Setup > Localization > Regions.)

Time Zone Your time zone.

Available
for Chat

You can set your availability for a chat request, if the chat feature is enabled.

Supported
Org. Units
Default

When creating requests an searching for items, is the 'Support Org. Units Only' option
selected

Landing
Portal If you have more than one role, you can set which portal to show by default at login.

Home Tab You can select either the My Tasks tab or Dashboard tab as the default landing
page when you log in to the system.

Item List You can select your preferred default view when you visit the Configuration > Items
tab.

Customer
List

You can select your preferred default view when you visit the User > Customers tab.

Computrace
Username If your system is integrated with Absolute Computrace, enter your Customer Center

username.
Entering your Customer Center login credentials here allows you to administer
Absolute Computrace assets directly from within the Service Desk.

NOTE To administer a Computrace asset from the Service Desk, you must first have
the required privileges in Absolute Computrace. For example, if you have sufficient
privileges to perform a Data Delete on a device within Absolute Computrace, you will
be able to perform the same action on that device from the Service Desk.

Password If your system is integrated with Absolute Computrace, enter your Customer Center
password.

LANrev (if per-user logins are required)
Username If your system is integrated with LANrev and your administrator enforces per-user

logins, enter your LANrev username.
Entering your login credentials here allows you to administer LANrev assets directly
from within the Service Desk.

NOTE To administer an asset from the Service Desk, you must have the required
privileges in LANrev. For example, if you have sufficient privileges to perform a
Device Lock on a device within LANrev, you will be able to perform the same action
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Field Description

on that device from the Service Desk.

Password If your system is integrated with LANrev, enter your LANrev password.

4. Click Save.

Teams Tab
Contains a list of all teams within the system that the user is assigned to, and the applicable ITIL
process(es) of those teams

Templates Tab
Home for personal definitions of note templates, allowing technicians to have their own unique style
when communicating with customers using templates

Receiving Email Notifications
If you do not want to receive email notifications when you are assigned a new request or when
changes are made to a request you are assigned to (for example, a customer logging a new request
note), set the Notifications option to No.

Regardless of what you select for the Notifications option, if a request is escalated to you, the
system will send you a notification email.
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Changing Roles
If you have more than one role in the system, you are shown your default portal after logging in to
LiveTime. However, you can easily switch between portals using the links next to your login name at
the top right of the screen.

The roles of Supervisor, Team Leader, Technician, Finance, Partner, and Manager are consolidated
within one User Portal. Therefore, if you have finance, manager, supervisor, and technician access,
you can view all functionality related to these roles within the User Portal. If you are also an
administrator and customer, next to your login name, you will see the [Setup] and [Customer] links
that will bring you to the Administrator Portal and Customer Portal.

If you are an administrator, you access the administration and setup functionality within the
Administrator Portal. If you are also a user and customer, next to your login name, you will see the
[User] and [Customer] links.

Users or administrators who are also customers can access the Customer Portal through the
[Customer] link at the top right of the screen. While logged in as a customer, the links to return to the
User Portal and Administrator Portal are available within the Customer Portal sidebar menu.
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Alerts
You can use alerts to notify users about important issues relevant to them or their environment. In
addition, the system generates alerts for administrators in the following circumstances:

● An ADS/LDAP synchronization has been performed
● An AMIE item import has been completed
● There have been SLA warnings and breaches
● There have been email failures

Alerts that you generate within the My Account tab can act as reminders or notifications for your
personal use, for a specific user, or for users of a particular role. You can schedule alerts to be
published and dismissed at specific times.

Viewing Alerts
When a user receives an alert, a notification icon appears in the Alerts area at the bottom right of the
screen:

To view a received alert:

1. Click the alert icon.

● The Alerts window opens listing all current alerts. The icon to the left indicates whether
the alert is classified as information, a warning, or urgent.

2. Click to close and retain the alerts.

● Or, click to remove an alert from the window and disable the notification icon.

Creating Alerts
To create an alert:

1. Go to My Account > Alerts.

2. Click New.

● The Alerts editor appears.

3. In the Alert Editor, enter details for the alert. 

Alert
Details

Description

Created The current date and time.

Publish The date to publish the alert. Use the calendar icon to the right of the field to select a
date.
Set to a date in the future, or use the default to publish the alert immediately.

Dismiss The date the alert ceases to be available. Use the calendar icon to the right of the field to
select a date. On this date, the alert is removed from a user's Alerts list.

Severity The type of alert to published. You have the following choices:
• Information – for general alerts
• Warning – to warn users of potential issues
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Alert
Details

Description

• Urgent – to publish an urgent actionable message
The icon appearing with the message depends on the type of alert.

User The type of users to receive the alert, which can include the following:
• A specific customer or user – you can use the Find User or Customer field to search
for the user or customer you want to send the alert to

• A user role – the alert goes to all users with that role
• A personal alert – only you can see the alert
• An organizational units – the alert goes to all users in that organizational unit
• Public – visible to anyone who selects the Public Alert link on the login page

Title Enter the title of the alert.

Message Enter the main content of the alert.

4. Click Save.

● If you do not set the Publish date of your alert in the future, it publishes immediately.

5. Click Done.

Deleting Alerts
You can delete alerts within the Alerts list by selecting the checkboxes of one or more alerts and
clicking Delete. Alternatively, you can delete an alert individually within the Alert Editor by clicking
Edit, then Delete.
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SLA Breach Alerts
The system also uses alerts to inform users about SLA breaches. The alert is addressed to the user
and assigned to the request that has failed to reach an SLA target. The breach contains information
such as the affected Request ID and the reason for the SLA breach.
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Setup Tab
The Setup tab allows you to configure LiveTime and control the behavior of the system.

Some of the tasks you can carry out from this tab include the following:
● Configure email, including the customization of all system email templates
● Customize fields and portal messages
● Integrate the system with external applications, define Open ID options, and enable outbound

web services functionality
● Define user, customer, request, and system privileges
● Localize the application, including language of content automatically generated by the system,

public holidays, and time zones for the scheduling functionality
● Enable the billing module for using contracts, purchase orders, and SLA costs
● Import items via a CSV file and AMIE

The areas available within Setup tab include the following:
● Email
● Custom Fields
● Privileges
● Customize
● Localization
● Licenses
● Database
● LDAP
● Security
● Reports
● Billing
● AMIE
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Email
Use the Email tab to configure the system’s incoming and outgoing email settings.

The system uses email to notify customers about the following:
● Login information
● Request creation, updates, and closure
● Contract renewals
● Invoice management
● Purchase order creation

The system uses emails to notify users about the following:
● Request allocation
● Escalations and SLA reminders, warnings, and breaches
● Amendments to requests made by other users
● Addition or removal of requests from groups
● Required request approvals

For detailed information about managing requests using email polling, see Email Polling and Request
Creation.

Server Tab
To enter email server details:

1. Go to Setup > Email > Server.

2. Enter the Receiving and Sending details.
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Server Tab Settings
Receiving

Incoming
Server

The address of the incoming server the system uses to receive emails.

Protocol The protocol of the incoming email account.

Transport This option is visible if IMAP or POP3 is set for the email account protocol. Select
this option to secure the transport layer to encrypt the whole channel, if relevant to
your email server configuration.

Port Leave blank to use the default, or enter a port number.

Interval Enter a timing interval if polling is enabled.
This interval represents the period of time the system uses to check if any
messages need to be polled.

User Name Enter the user name for the incoming mail server.

Password Enter the account password.

Sending
Reply To The default system email address and the account that the email polling feature

uses.

Outgoing
Server

The address of the outgoing (or SMTP) server the system uses to send emails.

Authentication If your SMTP server requires sender identification before sending email, select the
option that best suits your server configuration. The User Name and Password
fields are shown if you select an option other than None.

Port Leave blank to use the default, or enter a port number.

User Name When authentication is required, enter the SMTP authorization details.

Password When authentication is required, enter the account password.

3. Click Save.

Reset Button
To delete the content in all fields within the Server tab, click Reset. The system shows a message
asking you to verify your selection. Click OK to verify and clear all fields.

Test Button
To test if the email configuration is correct for sending email, click Test. This action sends a message
to the administrator using the outgoing server details provided on this screen.
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Setup
The Email > Setup tab allows you to define the behavior of the email polling functionality.

To set the email functionality details:

1. Go to Setup > Email > Setup.

2. Define the settings to suit your organizational requirements:

Setup Tab Options
General Settings

Email
Polling

Enable email polling to allow the application to check for new email received in the
mailbox on the incoming server defined within the Server tab.
When a new message arrives, the system sends a message to the sender
acknowledging his or her message. You can customize system-generated messages
within the Setup > Email > Templates tab.

NOTE You cannot change this option if the Create/Update via Email option is
selected.

Interval Enter the time period the system uses to check the incoming server for any messages
sent to the system.

Include
Banner

Select Yes to include a banner within emails that the system sends.
You can define the banner to use in Setup > Customize > Banners > Public/Email
Banner.

Report
Errors

When enabled, details of any system errors occurring while the application is running
are sent to the development lab.

Email
Failures

When enabled, the system sends an alert to the email address associated with the
default administrator account if an email send or receive event fails.

Copy Type For emails sent within requests, choose whether to copy or blind copy the technicians
in correspondence.

Requests
Create via
Email

Select this option if you want the system to create requests from emails addressed to
the support system and to team addresses aliased on the email server. (See Email
Polling for more information.)

NOTE The Email Polling option is locked to Yes when this option and the Accept
Anonymous option are enabled.

To use this feature, you must also ensure that the Incident and Service Request
options at Setup > Privileges > Customer are set to either Create or Create and
Edit.

Update via
Email

Select this option if you want the system to updaterequests from emails addressed to
the support system and to team addresses aliased on the email server. (See Email
Polling for more information.)

NOTE The Email Polling option is locked to Yes when this option and the Accept
Anonymous option are enabled.

To use this feature, you must also ensure that the Incident and Service Request
options at Setup > Privileges > Customer are set to either Create or Create and
Edit.
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Setup Tab Options
Use
Subject
Actions

When enabled, the system allows limited manipulation of requestsby technicians,
team leaders and supervisors using the subject line. To denote actions append '>>>'
to the end of the subject followed by a semi-colon delimited list of keywords and new
values. Permitted Keywords (and expected values) are:

escalation[Layer Name]
team[Team Name]
technician[User Email]
priority[1-4]
urgency[1-5]
impact[1-5]
status[Status Name]

Generate
Accounts

When enabled, the system will attempt to create a customer account for any sender
from a whitelisted domain, rather than simply rejecting the message. If the originating
domain is not on the whitelist, the email will be rejected.

Accept
Anonymous

When enabled, the system creates requests from emails received from email
addresses that do not exist in the application's database. (Refer below for more
information regarding this setting.)

Notify
Alternate
Team

When enabled, and if there is more than one team created for a process, the
Alternate Team field is shown within the Summary tab of a request. The system
notifies members of the alternate team relative to the settings defined for the current
team, and for new notes, if Technicians is selected in the New Notes screen.

Self Mail When set to Yes, new notes that a technician or customer creates are also sent to
them when they save the note.

Include
Request
Status

When enabled, the system includes the request status within the email subject line of
any correspondence sent from the system regarding a request.

Include
Request
Priority

When enabled, the system includes the request priority within the email subject line
of any correspondence sent from the system regarding a request.

Include
Request
Subject

When enabled, the system includes the content from the subject line of a request
within the email subject line of any correspondence sent from the system regarding a
request.

Team Not
Found

Select how the system should handle requests received from emails that are
incorrectly addressed or aliased. By default, this option is set to Reply Email, which
sends an automatic reply to the email sender using the NoTeamFound error
message template without creating the request.
Alternatively, if you have default process teams configured at Setup > Privileges >
Requests, you can select one of these teams here. When the system receives an
incorrectly addressed or aliased email, it automatically creates a request and assigns
it to the team you selected without notifying the email sender about the error.

Message
Size Limit

Set the limit (in megabytes) for file attachments in email correspondence. When an
attachment is larger than the limit set here, it is replaced with a link that the email
recipient can use to download the file. If this value is set to 0, attachments of any size
are included in emails.

IMPORTANT When setting this limit, keep in mind that email servers your external
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Setup Tab Options

customers use may also have their own email size limits. In this case, even though
emails with very large attachments can be sent from the Service Desk, your
customers may not be able to receive them.

Notes
Parse
Instance
Prefix

The system uses an instance prefix to process email correspondence from multiple
instances. If this functionality is not required, set the option to No.

Default
Recipients

You can define the default email settings for the recipient groups found within the
notes editor for requests. Define the groups that are more likely to be sent every new
note created for a request.

Default
Locale

Set the default language to use for email correspondence. This option is applied to
the Email Locale field in the Customer Information and User Information screens
and can adjusted on a per account basis, as required.

NOTE You can define the content for automated emails sent from the system for
languages other than English within the Setup > Localization > Content tab.

3. Click Save.

Receiving Emails from Anonymous Email Addresses
When the Accept Anonymous option is enabled, the system creates requests from emails received
from addresses not recorded in the application. This process involves the system user being assigned
as the customer, and the original sender being added to the email address list in the Notify section.

Note that enabling this option may increase the likelihood of spam emails being converted into
unwanted requests in the system. Email administrators should ensure they perform regular spam
filtering when the Accept Anonymous option is enabled. LiveTime does not monitor, parse, or filter
emails before creating requests from emails.
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SMS
Use the Setup > Email > SMS tab to configure the details of the SMS service providers that should
be applied within the customer and user account information screens. Within this tab, you can define
the default SMS provider, which the system applies to customer account information when the
customer or user selects SMS notification as the preferred method of notification.

This tab also allows you to customize the subject line for providers that require a security token or
account number in the subject line, with the message to be sent in the body. On install, the default
setting is set to Subject, not requiring an account number or security token as the provider only
requires email server information. This setting can be customized to meet your provider's requirements.

To configure SMS settings:

1. Go to Setup > Email > SMS.

2. Set the Target location for sent messages:

● Subject: Select when the system is to include the message content in the email subject
field, as the service provider only needs to know the email server details.

● Body: Select when the system is to include the message content in the email body,
allowing a System Subject to be configured as required by the service provider, with
content such as an account number or security token.

3. Click Save.

To edit the details of default entries:

1. Select the SMS service provider whose details you want to edit.

2. Edit the details.
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3. Click Save.

To add a service provider:

1. Click New.

2. Enter the Name and Gateway details.

3. Select Save.

4. Set the default service provider from the Default list, if required.

5. Click Save.
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Email Content Templates
You can customize the content and template details for emails that the system automatically
generates within the Templates tab.

The system generates labels for the templates in English, but you can customize these labels within
the Setup > Localization > Content tab.

The filter views within the Templates tab include the following:

View
Option

Description

Email
Content
Templates

Allows you to customize the content of and insert parameters in emails that the system
automatically generates.

Email
Summary
Tables

Allows you to configure the content of templates that are included in automatically-generated
emails that summarize the specific details of the matter at hand. See Summary Templates for
more information.

Email
Keywords

Allows you to enter alternative words for the system to use when sending mail and parsing
emails received at the support email address.
See Keywords for a description of where the system uses these words.

Error
Message
Templates

Allows you to customize the error messages that the system automatically generates. See Error
Messages for more information.

Out of
Office
Subjects

Allows you to customize multiple out of office strings for the system to identify in incoming email
subject lines, so it knows to ignore the email. See Out of Office for more information.

SMS
Templates

Allows you to customize the content of and insert parameters in text messages that the system
automatically generates.

Configuring Email Content Templates
You can configure content for the automatically generated email messages sent by the system within
the Email Content Templates filter screen of the Setup > Email > Templates tab. In addition to
customizing the content of the messages, you can also insert parameters to call specific details
sourced from the database.

You can configure template parameters, as well as the look and feel of email messages sent about
knowledge base articles, items, requests, invoices, and contracts within the Email Summary Tables
filter screen of the Setup > Email > Templates tab.

To configure messages:

1. Go to Setup > Email > Templates and select the Email Content Templates filter.

● A list of available email templates is shown.
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Email Templates
Account
Information

Message sent to provide customers or users with the login details of their account.

Account
Information
Subject

Content to include in the email subject line when customers or users are emailed the
login details of their account.

Approve
Change

Message sent to managers when a change request moves to an approval state.
The configured message must ask managers to be specific with their reply, using:
• The words 'accept' or 'yes' to accept the change
• The words 'reject' or 'no' to reject the change

Approve
Service
Request

Message sent to managers when a service request moves to an approval state.
The configured message must ask managers to be specific with their reply, using:
• The words 'accept' or 'yes' to accept the change
• The words 'reject' or 'no' to reject the change

Closed
Prefix

Included at the beginning of the email when a request is closed.

Closed
Timeout

Used by the handshake facility and prefaces emails sent as incident notes using the
Propose button.

Close
Request

Message included in the email that uses the handshaking facility and proposes a
solution to the customer.

Close
Request
Link

Message sent with a hyperlink to enable customers to keep a request open after a
possible solution has been sent to them. This template is used in conjunction with the
Close Request message when a technician uses the handshaking facility to propose
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Email Templates
a note as a solution.

Contract
Expired
Message

Email sent to customers when their contract has expired and they log a new request
or they have existing requests still open after the expiration date.

Contract
Time
Elapsed

Subject line for Contract Expired Message.

Contract
Time Low

Email sent to customers when the amount of time remaining on their contract triggers
the low time percentage threshold. (The default percentage is defined in the Setup >
Billing > Contracts tab.)

Create
Change

Included at the beginning of the email to customers when they first create a change
request.

Create
Incident

Included at the beginning of the email to customers when they first create incidents.

Create
Problem

Included at the beginning of the email to customers when they first create a problem.

Create
Service
Request

Included at the beginning of the email to customers when they first create a service
request.

Invoice
Prefix

Included at the beginning of an email to the customer with a newly created invoice.
(This email content is also used for the email sent to customers when the Enable
Contracts option in Setup > Billing is enabled and the number of days for the
Contract Renewal Time is triggered.)

Item Status
Change
Prefix

Included at the beginning of the email sent to a customer when an item status has
been amended and the option to notify the customer is selected in the Item
Information tab.

LDAP
Information

Sent to provide a new customer or user the login details of their account after a
directory server synchronization.

New
Attachment
To Tech

Sent to a user when a new attachment is added to a request in the Customer Portal.

No Account Message sent to customers when they have attempted to log incidents through email
but are not registered with the system.

NOTE You can customize the subject line of this email in the Error Message
Templates filter of the Setup > Email > Templates tab.

No Contract
Create
Request
Summary

Message sent to customers to inform them that work cannot commence on a newly
logged request as no contract is in place.

No Contract
Reminder
Summary

Reminder message sent to customers to inform them that work cannot commence on
a newly logged request as no contract is in place.

Note
Closed

Email sent to customers when they have sent an email to the system regarding a
request is already closed.
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Email Templates
Prefix

Note Prefix Included each time a new note is associated with an existing request.

Password
Lost

Sent to provide customers or users with their login information as a result of them
selecting the Forgot Password link on the login page.

Password
Question

Sent to provide customers or users with a challenge question for resetting their login
password as a result of them selecting the Forgot Password link on the login page.
(You can enable the Password Questions option on the Setup > Privileges >
System tab. The customer or user can set the questions and answers within the My
Account Information screen.)

Password
Reset

Sent to provide customers or users their login information after their password has
been reset within the Customer Information or User Information screen.

Planned
Outage
Prefix

Included in the email sent when an item is scheduled to be taken offline.

Request
Accepted
Prefix

Acknowledgment sent to the person responsible for a request in an approval state
when the request is approved.

Request
Deescalate
From To

When a request is manually de-escalated, this message is sent to the newly
assigned technician.

Request
Deescalate
Not
Available

When a request is manually de-escalated, this message is sent to the previously
assigned technician to let him or her know that the request is no longer available to
work on.

Request
Escalate
From To

When a request is manually escalated, this message is sent to the newly assigned
technician.

Request
Escalate
Not
Available

When a request is manually escalated, this message is sent to the previously
assigned technician to let him or her know that the request is no longer available to
work on.

Request
Reassigned
Manager
Prefix

This message is sent when the manager responsible for processing the approval of a
request is changed, and is sent to the previously assigned manager.

Request
Reassigned
Manager To
Tech Prefix

The message sent when a request moves from a manager approval state to the
newly assigned technician.

Request
Reassign
Prefix

When a request is reassigned, this message is sent with the request details to the
previously assigned user.

Request
Reassign
To Prefix

When a request is reassigned, this message is sent with the request details to the
newly assigned user.
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Email Templates
Request
Rejected
Prefix

Acknowledgment sent to the person responsible for a request in an approval state
when a request is rejected.

Request
Status
Changed
Prefix

Message sent when the status of a request is moved from Pending-No Contract to
the default open state of the assigned workflow. This message is sent to the assigned
technician.

Request
Status
Changed
Subject

Message sent when the status of a request is moved from Pending-No Contract to
the default open state of the assigned workflow. This message is sent to the assigned
technician.

Request
Workaround

Message sent when a workaround is applied to a request in the Analysis tab and
emailed to the customer.

Responder Message sent from the monitored email account when the system does not accept
new requests via email.

Signature The details included at the bottom of emails sent from the system.

NOTE You can customize signatures on a per team basis in the Setup >
Localization > Content tab.

Sla
Breached

Email sent to the assigned user when an SLA is breached.

Sla
Breached
Subject

The content in the subject line of an email sent to an assigned user and service level
manager, and if configured within the SLA, to the team lead when an SLA is
breached.

Sla Time
Elapsed

Sent to the assigned user and service level manager, and if configured within the
SLA, to the team lead when an SLA reminder or warning is triggered.

Sla Time
Elapsed
Subject

The content in the subject line of an email sent to an assigned user and service level
manager, and if configured within the SLA, the team lead, when an SLA reminder or
warning is triggered.

Survey
Completed

Thank-you message automatically generated for customers who have submitted a
completed survey.

Survey
Completed
Subject

The content in the subject line of the Survey Completed email.

Survey
Customer
Satisfaction
Subject

The content in the subject line of an email sent to customers inviting them to complete
a customer satisfaction survey.

Survey
Invitation
Subject

The content in the subject line of the Survey Prefix email.

Survey
Prefix

Message sent when a customer or user is invited to complete a survey.

Survey
Reminder

Message sent to customers or users to remind them to complete a survey.
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Email Templates
Prefix

Survey
Reminder
Subject

The content in the subject line of the Survey Reminder Prefix email.

Survey
Score
Notification

Message sent when the Low Score Email option is enabled in a survey and a survey
respondent scores below the configured Trigger Score. This message is sent to the
email addresses entered in the survey's settings for follow-up purposes.

Survey
Score
Notification
Subject

The content in the subject line of the Survey Score Notification email.

2. Select the required message name link.

● The default message text is shown.

3. Edit the message including inserting any relevant parameters.

4. Click Save.

NOTE ApproveChange, ApproveServiceRequest, CreateProblem, CreateChange, and
CreateServiceRequest do not apply to the Help Desk edition of LiveTime.

Using Email for Manager Approval
As the system allows managers to approve or reject RFCs and service requests through email, the
automatically generated emails must include specific instructions for the manager to use the words
"accept" or "yes" to approve, or "reject" or "no" to reject in their reply. This usage is essential as the
system only recognizes these key words when it automatically processes the email reply from the
manager.

1 0 3



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p E m a i l C o n te n t T e m p l a te s

NOTE This feature is not applicable to the Help Desk edition of LiveTime.

To use the manager approval process through email, you must enable the email polling functionality in
the system's email setup and an incoming email address must be present in the relevant team details.
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Email Parameters
The options included in the Insert Parameter list found within the Email Content Templates originate
from the following areas of the system.

Parameters for the AccountInformation, LDAPInformation, and PasswordInformation templates:

Parameter Source
Account
Type

The default user role derived from the Customer Information or User Information screen.

First Name Derived from the Customer Information or User Information screen.

Full Name Derived from the Customer Information or User Information screen and combines the first
and last name.

Password Derived from the Customer Information or User Information screen.

Title Derived from the Customer Information or User Information screen.

NOTE This option is available if Enable Titles is selected within Setup > Privileges >
Customer.

Username Derived from the Customer Information or User Information screen.

Parameters for the Request, ApproveChange, ApproveServiceRequest, Closed, and
ClosedTimeout templates:

Parameter Source
Classification Drawn from the Classification field in the Summary tab of a request.

Close Date Shows the Close Date as recorded in the Service Terms information of the request.

Country Derived from the Country field in the Customer tab of a request.

Customer First
Name

Shows the first name of the customer who logged the request.

Customer Last
Name

Shows the last name of the customer who logged the request.

Customer
Name

Shows the name of the customer who logged the request.

Customer
Phone

Derived from the Contact Phone field in the Summary tab of a request.

Customer
Room

Derived from the Item Room field in the Summary tab of a request.

Date Style Detail drawn from the Setup > Privileges > Customer tab.

Due Date Derived from the Service Terms window in the Summary tab of a request.

Email Locale Derived from the Contact tab of the Customer Information screen.

FSC Date Derived from the Service Terms window in the Summary tab of a change request.

Handshaking
Close Days

Derived from the organizational unit associated with the customer or number of default days
defined in the Setup > Privileges > Requests tab.

Identifier Derived from the Item Identifier field in the Summary tab of a request.

Item # Derived from the item details recorded in the Customer tab of a request.

Item Type Derived from the item details recorded in the Customer tab of a request.
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Parameter Source
Last Note ID Shows the system-generated note identification number as a hyperlink, for the note last

added to a request. When customers or users select this link, they are brought to the
Request Information screen for that request inside the system.

Notes Details the number of notes added to a request.

Open Date Derived from the Service Terms window in the Summary tab of a request.

Org Unit Derived from the Organizational Unit field in the Customer tab of a request.

Priority Derived from the priority details as recorded in the Summary tab of a request.

Process Shows if the request is a service request, incident, problem, or change request.

Report Date Shows the date the request was logged with the service desk

Request
Description

Derived from the initial description entered for the request, as recorded in the Summary tab.

Request Id Shows the system-generated request identification number.

Request URL Shows the request identification number as a URL that allows the customer to enter the
system within the specific request screen.

SLA
Resolution
Time

Shows the targetrequest resolution time according to the applicable Service Level
Agreement

SLA
Response
Time

Shows the targetrequest response time according to the applicable Service Level
Agreement

SLA
Restoration
Time

Shows the targetrequest restoration time according to the applicable Service Level
Agreement

Schedule
Date

Derived from the forward schedule of change date entered for the request

Subject Derived from the subject entered for the request that is populated from an email subject line
or directly into the application, and recorded in the Summary tab.

Team Shows the team assigned to manage the request.

Team Phone Displays the team telephone number as recorded in the Team Information screen.

Technician
First Name

Shows the first name of the technician assigned to the request

Technician
Last Name

Shows the last name of the technician assigned to the request

Technician
Name

Shows the name of the technician assigned to the request.

Title Derived from Customer Information or User Information screen.

NOTE This option is available if Enable Titles is selected within Setup > Privileges >
Customer.

Parameter for the ContractTime templates:

Parameter Source
Threshold Draws the percentage from the Threshold field in the Setup > Billing > Contracts tab.
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Parameters for the Invoice templates:

Parameter Source
Adjustment Drawn from the Cost Calculations field, and is the amount that is deducted

from the sub-total.

Customer Name Derived from the Customer Details Name field on the invoice.

Customer Title Derived from the Customer Information screen.

NOTE This option is available if Enable Titles is selected within Setup >
Privileges > Customer.

Delivery Status Shows the assigned Delivery Status from the invoice.

Due Date Drawn from the Order Details of the invoice.

Entered By Drawn from the Order Details of the invoice.

Invoice # Shows the system-generated invoice number.

Invoice Date Drawn from the Order Details of the invoice.

Invoice Status Derived from the Status field of the invoice.

Line Items Total Derived from the Costs section of the invoice and shows the overall cost for
items on the invoice.

List of Item Type Line Items When items are associated with an invoice, shows the details recorded in the
Item Type field.

List of Maintenance
Contract Line Items

When contracts are associated with an invoice, shows the details recorded in
the Contract Type Name field.

Notes Shows any details recorded in the Notes field of the invoice.

Order Date Drawn from the Order Details and shows the date the invoice was received.

Org Unit Derived from the Customer Details and shows the customer's associated
organizational unit.

PO Number Drawn from the Order Details and shows the purchase order number
associated with the invoice.

Payment Date Shows date of payment for the invoice based on details recorded in the
Invoice Status section.

Payment Status Shows if payment has been received for the invoice based on details
recorded in the Invoice Status section.

Processed By Drawn from the Order Details and shows the name of the user who
processed payment of the invoice.

Shipping Shows the shipping costs as derived from the Costs section of the invoice.

Shipping Date Derived from the Status section of the invoice and shows the expected
shipping date of goods.

Tax Drawn from the Costs section and shows the tax applied to the invoice.

Tax Rate Drawn from the Costs section and shows the tax rate applied to the invoice.

Terms and Conditions Shows details recorded in the Terms and Conditions field of the invoice.

Total The grand total of the invoice, including tax and any adjustments.

Tracking Number Drawn from the Tracking Number field within the Status section of the
invoice.
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Parameters for the ItemStatusChange template:

Parameter Source
Category Shows the item category from the Item Information tab.

Criticality Shows the assigned criticality of the item as recorded in the Item Information tab.

Item Number Shows the item number as recorded in the Item Information tab.

Item Type Details the item type as entered in the Item Information tab.

Status Shows the status of the item as recorded in the Item Information tab.

Parameter for the NewAttachment template:

Parameter Source
File Name Allows the file name of the newly received attachment to be included in the email to the user.

Parameters for the Escalation templates:

Parameter Source
Current
Technician

Shows the name of the newly assigned technician.

Previous
Technician

Shows the name of the technician who was previously assigned the request.

Process Shows the ITIL process of the request; for example, change management or incident
management.

Request ID Shows the request identification number.

Parameters for the Request Status Update templates:

Parameter Source
New Status Shows the details of the newly assigned workflow state.

Previous
Status

Shows the status name previously assigned to the request.

Process Shows the ITIL process of the request; for example, change management or incident
management.

Request ID Shows the request identification number.

Parameters for the SLA templates:

Parameter Source
Hr/Min Shows the time as recorded in hours or minutes, based on the SLA configuration.

Name Shows the name of the SLA.

Phase Shows the SLA phase of Response Time, Restoration Time, or Resolution Time.

Process Shows the ITIL process of the request; for example, change management or incident
management.

Time
Elapsed

Shows the amount of time passed for the phase of the SLA.

Time Limit Shows the amount of total time associated with the phase of the SLA.
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Parameters for the Survey templates:

Parameter Source
Description Shows the content included in the Description field of the survey.

Name Shows the title of the survey.

Number of Questions Shows the number of questions included in the survey.
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Email Summary Tables
Automated email messages the system sends in relation to requests, knowledge base articles, items,
invoices, and contracts include a summary table of information. You can customize the information
included in these tables, as well as their look and feel, within the Email Summary Tables filter screen
of the Templates tab.

While knowledge of HTML is useful when customizing the templates, it is not mandatory.

The templates for messages that you can configure within this screen include the following:

Message Description
Article
Summary

Email that notifies the user about the pending review date of a knowledge base article.

Group
Summary

Email sent to the User when a request group is created, updated, or closed.

Invoice
Summary

Email sent to customers that summarizes their invoice information and is included in all
correspondence regarding the invoice. This summary is forwarded with the Invoice Prefix
content that is configured in the Email Content Templates filter view of the Setup > Email >
Templates tab.
This template is also used for the email sent to customers when the Enable Contracts option
in Setup > Billing is enabled and the number of days for the subscription "Contract Renewal
Time" is triggered.

Item
Summary

Email sent to a customer when a service item moves into an inactive state if the email
notification option is selected within the item.

Maintenance
Contract

Email sent to customers including their service maintenance contract details.
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Message Description
Summary

Request
Summary

Email sent to users when a request is created or updated.

Survey
Summary
(General)

Included in system-generated emails regarding survey notification and reminders.

Survey
Summary
(Serviced
Customers)

Included in system-generated emails regarding survey notification and reminders to serviced
customers.

To customize the message template:

1. Go to Setup > Email > Templates.

2. Select the Email Summary Tables filter.

3. Select the name of the template you want to customize.

4. Click Edit.

5. Modify the table, as required.

● As part of the customization, you can use system parameters included in the Insert
Parameter list. These parameters help you ensure the customized template uses the
correct format for the information included in the email.

Icon Description
Insert
Parameter

The list options ensure that the correct HTML format is used for these details to be
included in the customized message.

Restore
Default

Restores the system default email message.

6. Adjust the Date Style format, if relevant.

7. Click Save.

Template Field Options
Article Summary
This template is included in the system-generated emails for knowledge base article reviews.

Field Source
Article ID Knowledge base article (KBA) number.

Article Title Displays content drawn from the Title field.

Article Type Shows if it is a general article, solution workaround, or FAQ.

Content Drawn from the Title field of a KBA.

Created Displays the date the article was created.

Overview Derived from the Problem field of a KBA.
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Group Summary
This template is included in system-generated emails when a request group is created, updated, and
closed.

Field Source
Description Derived from the Description field on the Details tab of a request group.

Group # The identifying group number generated by the system for the request group.

List of Active Requests Indicates the number of requests in an active state contained in the request group.

Name Drawn from the Name field on the Details tab of a request group.

Start Date Derived from the date that a request group is created.

Status Derived from the Status field on the Details tab of a request group.

Invoice Summary
This template is used when the Email button is selected within the Invoice Editor screen and when
an invoice is created and updated.

Field Source
Adjustment Drawn from the Cost Calculations field, and is the amount that is deducted

from the sub-total.

Customer Name Derived from the Customer Details Name field on the invoice.

Customer Title Derived from Customer Information screen.

NOTE This option is available if the Enable Titles option is enabled within
Setup > Privileges > Customer.

Delivery Status Shows the assigned delivery status from the invoice.

Due Date Drawn from the Order Details of the invoice.

Entered By Drawn from the Order Details of the invoice.

Invoice # Shows the system-generated invoice number.

Invoice Date Drawn from the Order Details of the invoice.

Invoice Status Derived from the Status field of the invoice.

Line Items Total Derived from the Costs section of the invoice and shows the overall cost for
items on the invoice.

List of Item Type Line Items When items are associated with an invoice, shows the details recorded in the
Item Type field.

List of Maintenance
Contract Line Items

When contracts are associated with an invoice, shows the details recorded in
the Contract Type Name field.

Notes Shows any details recorded in the Notes field of the invoice.

Order Date Drawn from the Order Details and shows the date the invoice was received.

Org Unit Derived from the Customer Details and shows the customer's associated
organizational unit.

PO Number Drawn from the Order Details and shows the purchase order number
associated with the invoice.

Payment Date Shows date of payment for the invoice based on details recorded in the
Invoice Status section.
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Field Source
Payment Status Shows if payment has been received for the invoice based on details

recorded in the Invoice Status section.

Processed By Drawn from the Order Details and shows the name of the user who
processed payment of the invoice.

Shipping Shows the shipping costs as derived from the Costs section of the invoice.

Shipping Date Derived from the Status section of the invoice and shows the expected
shipping date of goods.

Tax Drawn from the Costs section and shows the tax applied to the invoice.

Tax Rate Drawn from the Costs section and shows the tax rate applied to the invoice.

Terms and Conditions Shows details recorded in the Terms and Conditions field of the invoice.

Total The grand total of the invoice, including tax and any adjustments.

Tracking Number Drawn from the Tracking Number field within the Status section of the
invoice.

Item Summary
This template is included in system-generated emails for item status changes:

Field Source
Category Shows the item category from the Item Information tab.

Criticality Shows the assigned criticality of the item as recorded in the Item Information tab.

Item Number Shows the item number as recorded in the Item Information tab.

Item Type Details the item type as entered in the Item Information tab.

Status Shows the status of the item as recorded in the Item Information tab.

Maintenance Contract Summary
This template is included in system-generated emails regarding the creation and update of service
contracts.

Field Source
Contract # Shows the system-generated contract number.

Contract Type Specifies if the contract is a per incident or per item contract.

End Date Includes the date the current contract date ends.

Invoice # Shows the system-generated invoice number.

Remaining Shows the amount of time remaining on a contract.

SLA Includes the name of the SLA included as part of the contract.

Start Date Shows the commencement date of the current valid contract.
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Maintenance Contract Summary By Month
This template is included in system-generated emails regarding the creation and update of service
contracts that are automatically renewed on a monthly or quarterly basis.

Field Source
Contract # Shows the system-generated contract number.

Contract Type Specifies if the contract is a per incident or per item contract.

End Date Includes the date the current contract date ends.

Interval End Date Shows the contract.

Interval Remaining Shows the contract.

Interval Start Date Shows the contract.

Invoice # Shows the system-generated invoice number.

Remaining Shows the amount of time remaining on a contract.

SLA Includes the name of the SLA included as part of the contract.

Start Date Shows the commencement date of the current valid contract.

Outage Summary
This template is included in system-generated emails related to planned outages.

Field Source
Outage Items Shows the details of items associated with the outage.

Outage Reason Displays the content of the Reason field in the Outage Information screen.

Outage Related Requests Shows requests related to the outage.

Outage Schedule Details the start and end date of the outage.

Request Summary
The request summary template is included in emails relating to the creation, update, and closure of
requests.

Field Source
Classification Derived from the Classification field in the Summary tab of a request.

Close Date Derived from the Service Terms window in the Summary tab of a request.

Country Derived from the Country field window in the Customer tab of a request.

Customer
Name

Derived from the Customer field in the Summary tab of a request.

Customer
Phone

Derived from the Contact Phone field in the Summary tab of a request.

Customer
Room

Derived from the Item Room field in the Summary tab of a request.

Date Style Detail drawn from the Setup > Privileges > Customer tab.

Due Date Derived from the Service Terms window in the Summary tab of a request.

Email Locale Derived from the Customer Information details screen and defines the language used by
emails sent from the system.

1 1 4



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p E m a i l S u m m a ry T a b l e s

Field Source
FSC Date Derived from the Service Terms window in the Summary tab of a change request.

Handshaking
Close Days

Drawn from the Setup > Privileges > System tab, unless overridden by the number of days
defined in the User > Organizational Units > Details tab of the User Portal.

Identifier Derived from the Item Identifier field in the Summary tab of a request.

Item # Derived from the item details recorded in the Customer tab of a request.

Item Type Derived from the item details recorded in the Customer tab of a request.

Last Note Id Shows the system-generated note identification number as a hyperlink for the note last
added to a request. When customers or users select the link, they are brought to the Request
Information screen for that request inside the system.

Notes Details the number of notes added to a request.

Open Date Derived from the Service Terms window in the Summary tab of a request.

Org Unit Derived from the Org Unit field window in the Customer tab of a request.

Priority Derived from the priority details as recorded in the Summary tab of a request.

Process Shows if the request is a service request, incident, problem, or change request.

Request
Description

Derived from the initial description entered for the request, as recorded in the Summary tab.

Request Id Shows the system-generated request identification number.

Request
URL

Shows the system-generated request identification number as a hyperlink. When customers
or users select the link, they are brought to the Request Information screen for that request
inside the system.

Subject Derived from the subject entered for the request that is populated from an email subject line
or directly into the application, and recorded in the Summary tab.

Team Shows the team assigned to manage the request.

Team Phone Shows the team telephone number as recorded in the Team Information screen.

Technician
Name

Shows the name of the technician assigned to the request.

Survey Summary (General)
This template is included in system-generated emails regarding survey notification and reminders.

Field Source
Title Shows the name given to the survey.

Description Drawn from the Survey Description field.

Survey Link Shows the URL the respondent can click to complete the survey.

Survey Summary (Serviced Customers)
This template is included in system-generated emails regarding survey notification and reminders to
serviced customers.

Field Source
Title Shows the name given to the survey.

Description Drawn from the Survey Description field.
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Field Source
Survey Link Shows the URL the respondent can click to complete the survey.

{{Request Type}}
Link

Shows the URL the respondent can click to access the closed request, which is the
subject of the survey.
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Email Keywords
The system uses keywords to identify how to handle inbound and outbound email.

The following table includes a list of all keywords that the system uses, which words can be
customized, and where they in the appear in the application:

Keyword Direction Description
Accept Inbound "Accept" or "Yes" is used to approve requests and must be included in the

approval email.

Accepted Outbound Included in the subject line for emails generated when a request has been
accepted and sent to the person responsible for managing the approval.

AddToGroup Outbound Not used.

Article Outbound Included in the subject line of emails sent to customers that contain
knowledge base articles.

Author Outbound Included in the content of forum update messages.

AutoReply Outbound Included in the subject line of emails for error messages.

ChangeRequest Inbound
Outbound

Customer must include in the email subject line when updating a change
request.
Automatically included in the subject line of change request emails.

ChatLog Outbound Used in the subject line of emails sent to the customer with a copy of a chat
transcript.

Classification Inbound Included in the subject line of emails with keyword “Item” (for example, Item
Classification). Cannot be used alone.

Closed Outbound Included in the subject line of emails responding to requests (for example,
Incident Closed).

Contract Outbound Used in the subject line of emails regarding contract activity (for example,
Contract Active or Contract Low).

Created Outbound Included in the subject line of emails responding to the creation of a request
(for example, Request Created or Invoice Created).

Customer Outbound Keyword in the subject line of emails regarding a contract status (for
example, Customer Name Contract Active).

DeEscalated Outbound Included in the subject line of emails to users regarding a request being de-
escalated.

Deleted Outbound Included in the subject line of emails regarding a deleted request or invoice
(for example, Request Deleted).

Delivered Outbound Included in the subject line of emails regarding an invoice (for example,
Item Delivered).

Details Outbound Included in the subject line of emails responding to a request (for example,
Request Details or Invoice Details).

Escalated Outbound Included in the subject line of emails responding to a request (for example,
Request Escalated).

Forum Outbound Keyword in subject line (for example, Forum Update).

Group Outbound Not used.

Hours Inbound Used in emails when the system refers to hours (for example, in SLA and
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Keyword Direction Description
&
Outbound

contract emails).

Incident Inbound
Outbound

Customer must include in the subject line of an email when updating
incidents.
Automatically included in the subject line for emails generated regarding
incidents.

IncidentQueue Outbound Inserted as the technician name when a request is assigned to the request
queue and the Technician Name is configured as a parameter in the
outgoing email.

Invoice Outbound Keyword in the subject line of emails (for example, Invoice Created or
Invoice Delivered).

Item Inbound
Outbound

Keyword in the subject line of emails (for example, Item Classification).
Keyword in the subject line of emails (for example, Item # Contract Active or
Item # Status Update).

Minutes Inbound
&
Outbound

Used in emails when the system refers to minutes (for example, in SLA and
contract emails).

NewNote Outbound Included in content of email advising that a new note has been added to a
request.

NewSolution Outbound Not used.

No Inbound "Reject" or "No" is used to reject requests and must be included in the
rejection email.

OrgUnit Outbound Keyword in the subject line of emails regarding contract status (for example,
OrgUnit Name Contract Active).

PlannedOutage Outbound Included in the subject line of automated email notifications about planned
item outages.

Prefix Inbound
&
Outbound

Included as prefix in the email subject line.

Problem Outbound Automatically included in the subject line for emails generated regarding
service requests.

Reassigned Outbound Included in the subject line of emails sent regarding reassigned requests.

ReceivedMessage Outbound Included in the content of emails replying to the customer who attempts to
update a request that has already been closed. (Subject line request
closed.)

Reject Inbound "Reject" or "No" is used to reject requests and must be included in the
rejection email.

Rejected Outbound Included in the subject line for emails generated when a request has been
rejected, and is sent to the person responsible for managing the approval.

Reminder Outbound Reminding the manager to process a request that is waiting for approval.

Resolution Outbound Included in the subject line for emails generated regarding SLA resolution
times.

Resolved Outbound Included in the subject line for emails generated regarding SLA resolution
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Keyword Direction Description
times.

Response Outbound Included in the subject line for emails generated regarding SLA response
times.

Restoration Outbound Included in the subject line for emails generated regarding SLA restoration
times.

ReviewReminder Outbound Included in the subject line of emails reminding the user to review an article
(for example, ReviewReminder Article #).

Service Request Inbound
Outbound

Customer must include in the subject line of the email when updating a
service request.
Automatically included in the subject line for emails generated regarding
service requests.

SolutionCreated Outbound Included in the subject line of emails to the customer when a solution has
been created for an open request.

SolutionFound Outbound Included in the subject line of emails to the customer when a solution has
been found and applied to an open request.

Status Outbound Included in the subject line of emails (for example, Item # Status Update).

SystemWarning Outbound Warning of unpaid invoice.

Unknown Outbound Used in emails when the value of parameters selected for inclusion are not
known.

Unpaid Outbound Warning of unpaid invoice.

Updated Outbound Included in the subject line of emails (for example, Request Updated).

Yes Inbound "Accept" or "Yes" is used to approve requests and must be included in the
approval email.

Customizing Keywords
To allow the system to recognize an alternative word for a system keyword:

1. Go to Setup > Email > Templates.

2. Choose the Email Keywords filter view.

3. Select the name of the keyword you want to customize.

1 1 9



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p E m a i l K e y w o rd s

4. Click Edit.

5. Enter the customized word.

6. Click Save.
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Error Message Templates
The system automatically generates and sends error messages in relation to various application
activities. The following table includes details for when the system uses each error message:

Message Description
ApprovalRequiredContent The main content of an email sent to a customer attempting to edit a request

that is currently in “Approval” state. Such requests cannot be edited until
approval is given.

ApprovalRequiredSubject Email subject line content for ApprovalRequiredContent emails.

InvalidTeam The main content of an email sent regarding the system receiving an email
that includes an address and name of a team that does not match. For
example, the email may have been intended for a change team but used an
incident team address, or vice versa.

NoAccessToItemContent The main content of an email sent when the system receives a request via
email that includes an item number in the subject line that the customer
does not have access to.

NoAccessToItemSubject The subject line of NoAccessToItemContent emails.

NoIncidentFoundContent The main content of an email sent by the system when it cannot find the
incident number referred to in a received email.

NoIncidentFoundSubject Email subject line content for NoIncidentFoundContent emails.

NoPermissionChangeContent The body of the email sent when a customer tries to log a change request
through email and the Create Change Requests option is disabled in the
Setup > Privileges > Customer tab.

NoPermissionChangeSubject The subject line content included in NoPermissionChangeContent emails.

NoPermissionIncidentContent The body of the email sent when a customer tries to log incidents through
email and the Create Incidents option is disabled in the Setup > Privileges
> Customer tab.

NoPermissionIncidentSubject The subject line content included in NoPermissionIncidentContent emails.

NoPermissionProblemContent The body of the email sent when a customer sends a request to a problem
management team.

NoPermissionProblemSubject The subject line content included in NoPermissionProblemContent emails.

NoPermissionRequestContent The body of the email sent when a customer tries to log a service request
through email and the Create Service Requests option is disabled in the
Setup > Privileges > Customer tab.

NoPermissionRequestSubject The subject line content included in NoPermissionRequestContent emails.

NoServiceIncidentContent The content of the email sent when customers try to log incidents for a
service by including the item number in the subject line of their email
addressed to the incident team, and the Service Incidents option is
disabled in the Setup > Privileges > Customer tab.

NoTeamFound The main content of an email that the system sends when it receives an
email sent to a team email address not in the system.

NoUserFound The subject line included in the NoAccount emails.

NOTE You can configure the content for emails the system sends when it
receives emails from addresses that do not exist in the system (the
NoAccount template) in the Email Content Templates filter of the Setup >
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Message Description

Email > Templates tab.

RequestCreationErrorContent The system-generated email sent when an error occurs during the creation
of a request. An example of an error is if the database becomes unavailable
during the request creation process.

RequestCreationErrorSubject The subject line content included in the RequestCreationErrorContent
email.

UnauthorizedApprove The email sent when a manager sends an email attempting to approve a
change but does not have approval permission enabled.

UnrecognizedAction The email sent when a manager sends an email attempting to accept or
reject a change but does not use the keywords YES, ACCEPT, NO, or
REJECT.

To edit a message:

1. Go to Setup > Email > Templates.

2. Select the Error Message Templates filter.

3. Select the error message you want to edit.

4. Click Edit.

5. Update the message content.

6. Click Save.
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Out of Office Subjects
Customizing these templates allows the system to identify incoming email subject lines with out of
office messages in different languages. The system then ignores emails with this content in the
subject line.

To add or edit out of office subject templates:

1. Go to Setup > Email > Templates.

2. Select the Out of Office Subjects filter.

3. Click New or select the message you want to edit.

4. Add or amend the subject line content that the system should identify as out of office email.

5. Click Save.
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SMS Templates
You can configure the templated text and parameters for SMS messages that the system sends
regarding requests and item outages within the SMS Templates filter screen of the Templates tab.

You can customize the templates for the following system messages:

SMS Templates Description
ApproveChangeSMS SMS sent to managers when a change request moves to

an approval state.

ApproveServiceRequestSMS SMS sent to managers when a service request moves into
an approval state.

ClosedRequestSMS Included at the beginning of the SMS when a request is
closed.

ClosedTimeoutSMS Used by the handshake facility and prefaces an SMS sent
as incident notes using the Propose button.

CloseRequestLinkSMS SMS sent with a hyperlink to enable customers to keep a
request open after a possible solution has been sent to
them. If the customer selects the link, the automated close
process is deactivated.

CloseRequestSMS SMS sent when the handshaking facility is applied and the
technician proposes a solution to the customer.

CreateRequestSMS SMS sent to a customer when a request is created.

DeleteRequestSMS SMS sent to a user when a request is deleted.

GroupCreateSMS SMS sent to a user when a request group has been
created in the system.

InvoicePrefixSMS SMS sent to a customer with a newly created invoice.

ItemStatusChangeSMS SMS sent to a customer when an item status is changed.

NewAttachmentToTechSMS SMS sent to a technician when a customer uploads an
attachment to a request in the Customer Portal.

NoteClosedPrefixSMS SMS sent to when a new note is added to a closed
request.

NoteClosedSMS SMS sent to customers when they have attempted to add a
note to a request that is already closed.

NotePrefixSMS SMS sent each time a new note is associated with an
existing request.

PlannedOutageSMS Included in the SMS sent when an item is scheduled to be
taken offline.

RequestDeescalateFromToSMS SMS sent when a request is manually de-escalated. This
message is sent to the newly assigned technician.

RequestDeescalateNotAvailableSMS SMS sent when a request is manually de-escalated. This
message is sent to the previously assigned technician to
let him or her know that the request is no longer available
to work on.

RequestEscalateFromToSMS SMS sent when a request is manually escalated. This
message is sent to the newly assigned technician.
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SMS Templates Description
RequestEscalateNotAvailableSMS SMS sent when a request is manually escalated. This

message is sent to the previously assigned technician to
let him or her know that the request is no longer available
to work on.

RequestReassignedManagerPrefixSMS This SMS is sent when the manager responsible for
processing the approval of a request is changed. This
message is sent to the previously assigned manager.

RequestReassignedManagerToTechPrefixSMS The message included in an SMS when a request moves
from a manager approval state to the newly assigned
technician.

RequestReassignPrefixSMS When a request is reassigned, this SMS is sent with the
request details to the previously assigned user.

RequestReassignToPrefixSMS When a request is reassigned, this SMS is sent with the
request details to the newly assigned user.

RequestStatusChangedPrefixSMS The content of an SMS sent when the status of a request is
moved from Pending-No Contract to the default open
state of the assigned workflow. This message is sent to the
assigned technician.

To customize an SMS message template:

1. Go to Setup > Email > Templates.

2. Select the SMS Templates filter.

3. Select the SMS template you want to edit.

● The HTML editor opens.

Icon Description
Insert Parameter The list options provides specific details to be included in the SMS message.

Restore Defaults Restores the system default SMS message.

4. Modify the message as required.

● As part of the customization, you can use the existing parameters included in the Insert
Parameter list. Parameters ensure the customized message uses the correct format for
the included information.

5. Click Save.
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SMS Parameters
The following are parameters for new and updated request templates:

Parameter Source
Process Shows if the request is a service request, incident, problem, or change request.

New Status Shows the workflow state assigned to the request.

Request Id Shows the system-generated request identification number.

Request URL Provides a direct link to the request.

The following are parameters for the group templates:

Parameter Source
Group # Shows the Group ID number.

Group URL Provides a direct link to the request group.

Group Type Identifies the group as service request, incident, problem, or change request.

The following are parameters for the invoice template:

Parameter Source
Invoice # Shows the invoice number.

Invoice URL Provides a direct link to the invoice.

The following are parameters for the item status change templates:

Parameter Source
Item Number Shows the item number as recorded in the Item Information tab.

Status Shows the status of the item as recorded in the Item Information tab.

The following is the parameter for the new attachment template:

Parameter Source
File Name Allows the file name of the newly received attachment to be included in the email to the user.

The following are parameters for the planned outage templates:

Parameter Source
Outage End
Date

Drawn from the End Date field in the Configuration > Outages screen
of the User Portal.

Outage Items Shows the items associated with the planned outage in the
Configuration > Outages screen of the User Portal.

Outage Start
Date

Drawn from the Start Date field in the Configuration > Outages screen
of the User Portal.

The following are parameters for the escalation templates:

Parameter Source
Current Shows the name of the newly assigned technician.
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Parameter Source
Technician

Previous
Technician

Shows the name of the technician who was previously assigned the request.

Process Shows the ITIL Process of the request; for example, change management or incident
management.

Request ID Shows the request identification number.
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Errors
Use the Errors tab to configure how the Service Desk can handle email messages that are not
successfully delivered to customers.

When the system sends an email to a customer (for example, to provide an update on incident status),
and the email bounces back as undeliverable, managers and supervisors can create a request for the
Service Desk to take appropriate action (for example, update the customer's record with the correct
address) based on settings you define within this tab. When you enable this feature, managers and
supervisors can quickly generate a request in the User Portal by clicking the Create Request button
from a failed email log entry at Reports > Email.

To enable request creation for email delivery errors:

1. Go to Setup > Email > Errors.

2. Set the Create Request option to Yes.

3. Complete the following fields:

Request
Details

Description

Request
Type

The type of request the system should create for the Service Desk to address the
email delivery error.

Customer The user who the system should assign the generated requests to.
If you select (System User), the system places all generated requests in the
assignment queue.

Item The item the system should assign to the generated requests.

Classification The item classification the system should assign to the generated requests.

Subject The subject for the generated requests.

4. Click Save.
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Custom Fields
The Custom Fields tab allows you to customize screens in the system to meet the specific
requirements of your organization by creating additional fields for different parts of the application.

You can customize these fields in the following ways:
● Setting the data type
● Defining the style
● Defining if the field is required or includes a description
● Determining whether the customer can view or edit the field (for incident, change, and service

request custom fields only)

NOTE A maximum of five custom fields is allowed for each option.

Enabling a Custom Field
To enable a custom field:

1. Go to Setup > Custom Fields.

2. From the Category list, select the area of the application that you want to add the custom field
to.

● The list shown includes all screens where you can add custom fields.

Custom
Fields

Custom Field Locations

Articles Additional field for articles in the knowledge base.

Change
Requests*

Additional field for a change request.

Customers Additional field for customer information.

Groups Additional field for service request, incident, problem, and change groups.

Incidents Additional field for incident information.

Invoices Additional field for invoices. (Option available when Enable Invoices is enabled in
Setup > Billing .)
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Custom
Fields

Custom Field Locations

Org Units Additional field for an organizational unit.

Partner
Orgs

Additional field for partner organization.

LDAP/ADS
Accounts

You can use customized LDAP/ADS fields to map to a directory server when importing
user account details. See Authentication for more information.

Problems* Additional field for problem details.

Releases* Additional field for release management details.

Service
Requests*

Additional field for service request information.

SLAs Additional field for the Service Level Agreement Information screen.

Users Additional field for the Users Information screen.

Purchase Additional field for purchase orders. (Option available when Enable Purchase Orders
is enabled in Setup > Billing.)

* Problems, Change Requests, Releases, and Service Requests do not apply to the Help
Desk edition of LiveTime.

3. Select the custom field you want to define.

● An editable window opens.

4. From the Active field, select Yes.

● When activated, a list of options is shown.
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Option Description
Field Label Enter a name for the custom field. (This field is mandatory.) 

NOTE The label you enter within this field is applied to the English interface. For
other languages, configure this label in the Setup > Localization > Content tab.

Active Defines the custom field visibility.

Required Defines if the field is mandatory when displayed.

Data Type The format required for the field.
Select from the following data types:
• String (text or list)
• Number - Custom field that requires a number
• Boolean (radio buttons)
• Date - Custom field that requires a value in a date format
• Currency - A currency can be defined for the field
• Hyperlink - A URL can be included in the field

Style Based on the selected data type, the way the data will be displayed.
• String custom field - Either an open text field or a list
• Boolean custom field - Uses radio buttons to define Yes/No or True/False
• Number custom field - Either numerical or rating

Unique When enabled, the system prevents the duplication of data within the customized field.
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Option Description
Value

Input
Validation

When enabled, the Input Mask and User Mask can be defined.
Input Mask: A regular expression to use for data validation of values entered by a
user (for example, ZIP/post code or telephone number)
User Mask: A user-friendly representation of the Input Mask that customers can
understand if it appears in a validation error message.

Enable
Description

When enabled, a Description field is shown allowing you to enter details of what
information the custom field is expected to capture. These details are accessible next
to the custom field on the relevant screen.

Defining Lists
When you select the Data Type: String and Style: List options, the List Contents field is shown,
which provides the facility to create a drop down list for options within the custom field.

To create a new list entry within the List Contents field:

1. Right-click the Entries link.

2. Select Create from the menu.A New node link is added.

3. Enter the name of the list entry.

4. Click outside the field to save the entry.

5. Repeat this process until you have added all desired list entries.

● To create a nested list, right-click on the relevant list entry and repeat the above process.
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6. To move an existing entry to a new position, select the entry, then drag and drop the entry into
its new location.

7. When all the relevant details have been defined for the custom field, click Save.

Custom Fields for Incidents, Change Requests, and Service Requests
If you are defining a custom field for incidents, change requests, or service requests, additional options
are available. These include the following:

Option Description
Customer
Visible

If enabled, the custom field is visible in the Customer Portal; otherwise it can only be viewed in
the User Portal.

Customer
Editable

Allows the customer to edit the content within this field.

Default
Value

The custom field will automatically be populated with the value entered here when a request is
created. This value can be edited within the request screen, if required.
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NOTE If Customer Visible is set to No for a required field, you must define a Default Value. These
settings enable the customer to save a new request without seeing the relevant field.

LDAP/ADS Accounts Custom Fields
You can use the LDAP/ADS custom fields to define specific customer and user fields configured
within LDAP/ADS. These custom fields are completed when users and customers are entered
manually or imported using a CSV file.

If Mixed Mode LDAP is applied, the same set of custom fields are used. These fields are listed with
the label Mixed Mode within the Custom Field Category filter list.
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Privileges Tab
The Privileges tab contains global setup options that govern the application behavior, customer and
user interaction with the system, and system defaults.

As a best practice, privileges are set upon initial configuration of the system; however, you can make
changes at a later time if required.

There are five tabs within Setup > Privileges:
● User
● Customer
● Requests
● Items
● System
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User Privileges
Within the Setup > Privileges > User tab, you can configure privileges for technicians and partners
by customizing the options within the Technicians area of the screen. This customization also
includes enabling functionality related to all user work hours and public holidays. You can also adjust
defaults for users across the knowledge management and configuration management processes.

Some of the privileges you can customize for technicians include the following:
● Create new customers
● Create new items
● Reassign requests
● Edit other technicians' requests
● Create, edit, publish, and delete knowledge base articles by default

NOTE Privileges assigned to technicians are also applied to partners.

Configuring User Privileges
To configure user privileges:

1. Go to Setup > Privileges > User.

2. Click Yes to enable or No to disable a privilege option.

User Privileges
Technicians

Create
Customers

Allows technicians to create customer accounts.

View All
Requests

Allows technicians to view all requests assigned to their team for the processes they
are allocated.
It also allows technicians to edit requests that are assigned to fellow team members,
as it provides a My Team Requests filter in the list view.

Reassign
Requests

Allows technicians to reassign requests to another team and technician when the
View All Requests option is enabled.

Duplicate
Requests

Allows technicians to copy requests to fast track request creation. Supervisors have
this privilege by default.

Manual
Request
Time

Disables the timer that automatically monitors and records the time when a request
is in edit mode.

NOTE This option is not available when Enable Contracts is enabled in the Setup
> Billing tab, as users must manually add time worked on a request to notes.

Note Time
Unit

Defines the unit (in minutes) to record the time taken for entering notes in the
system. Default value is 1.
If you use a unit other than the default value of 1 minute, automatic recording of time
is disabled and users can manually specify the amount of time they spend entering
notes, in the unit you specify here.

Non-zero
Note Time

Prevents technicians from entering a note time of zero when adding notes to
requests.

Update Enables technicians to add notes to requests that are assigned a workflow exit
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User Privileges
Closed
Requests

state.

Search All
Items

Within the Items tab of a request, the All Items option is shown in the Find Item box
for technicians, if this option is enabled.

Include
Globals
Default

By enabling this option, the Include Global* Options is selected by default in the
Find Item field when a user is creating a request.

Supported
Orgs Default

Determines whether technicians see default search results within requests based
on the organizational units they support.

Subject
Required

Determines whether completing the subject field is mandatory for users during the
request creation process.

Technician
Alerts

Allows technicians to create system alerts.

Define Work
Hours

Allows the technician's availability to be configured within the Users > Schedule
tab. This scheduling ensures that requests are only forwarded to the user during the
defined work hours, unless there are no other users available.
If this option is enabled, work hours must be defined for each user, otherwise the
built-in technician assignment logic is ignored and all new requests are assigned to
the team lead.

Available
Threshold

Interval prior to a technicians work hours starting that they should start to be
considered for requests to be assigned to them

Assignment
Control

When enabled, provides the Assignment option within the User Information
screen. This option allows a supervisor or administrator to turn request assignment
off for a user who is available in the system.

Scheduled
Vacations

Allows leave to be scheduled for users within the Users > Schedule tab. This
scheduling allows vacations to be planned and automatically detected by the
system when the user commences leave. The system does not assign users new
requests when they are on vacation.

Vacation
Reassign

This option becomes available when the Scheduled Vacations option is enabled.
When enabled, this option ensures active requests of the user commencing leave
are automatically re-assigned to available technicians within the user's team.

Observe
Public
Holidays

Ensures the system gives consideration to public holidays when calculating SLA
times, escalations, and breaches.

NOTE When enabled, the Public Holidays sub-menu option is available within the
Setup > Localization > Holidays tab.

Edit
Customer
Partner

Allows customers to be assigned to partners within the Customer Information tab.

Create
Outage

Enables a technician to create outages for items.

Force
Analysis

When enabled, the system proposes relevant solutions within the Analysis tab
during the request creation process.

Force
Classification

If enabled, when a technician creates a request, the system disregards the default
classification from the request's item category and requires the technician to
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User Privileges
Selection explicitly select a classification for the request.

Force
Closure
Code
Selection

If enabled, technicians must select a closure code when closing a request.

Workload
Measure

Determines the workload the system should consider during request assignment:
• All - All requests assigned to a user (except those in an exit state) should be
considered

• Active - Only requests in an active state should be considered

Technician
Leave
Visible

If enabled, allows technicians to view each other's vacation on the Home
> Calendar screen of the User Portal, provided they are members of the same team.

Show Merge If enabled, the Merge button becomes available to technicians in request lists,
enabling them to combine duplicate requests into one entry.

Configuration
Roles Sets the default privileges for the user role's ability to create, edit, and delete item

information in the CMDB.

Knowledge
Roles Configures the default knowledge base authoring permissions for each user role.

3. Click Save.
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Customer Privileges
Customer privileges specify the options that are available to customers within the Customer Portal.

Enabling Customer Privileges
To enable customer privileges:

1. Go to Setup > Privileges > Customer.

2. Select Yes to enable or No to disable a privilege option.

Customer
Privileges

Description

Customers
Create
Account

Allows customers to create their own account from the login page.

Default Web
Access

Define the default setting for web access on newly created customer accounts.

Incident Define if customers can view, create, or edit incidents in the Customer Portal.

Change
Request

Define if customers can view, create, or edit change requests in the Customer
Portal.

Service
Request

Define if customers can view, create, or edit service requests in the Customer Portal.

Service
Incidents

If the option to create incidents in the Customer Portal is enabled, this functionality
can be refined by defining if incidents can be logged against service items. If this
option is disabled, services are not included in the Category list during the incident
creation process.
Also, if a customer attempts to log incidents against a service through email by
including the item number in the subject line, and this option is disabled, the system
sends an error message. You can customize the NoServiceIncidentContent error
message using the Error Message Template filter in the Setup > Email >
Templates tab.

Default
Request
Type

Defines the request type that should be selected by default when a customer
creates a request in the Customer Portal.
If you choose [Force Customer Selection], the customer must explicitly select a
request type.

Edit Shared
Requests

When enabled, customers who can view shared requests are also permitted to edit
these requests (for example, they can add notes or upload attachments).

Items Define if customers can view, create, or edit their own item details within the
Customer Portal.

Show Only
Active Items

Allows customers to only view items that are marked as Active in the system.

Show
Subject Field

Shows the Subject field above the Description field in the Customer Portal.

Subject
Required

(This option is visible if Show Subject Field is set to Yes.)
Determines if customers are required to specify a subject for requests they create in
the Customer Portal.
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Customer
Privileges

Description

Show Priority Enables customers to view and set the priority of their requests. Alternatively, the
urgency can be shown, which will be associated with the item criticality to set the
priority. SelectOff to disable this functionality completely.

Item ID
search

Allows customers to search by an item's ID when creating a new request.

Force
Classification

If enabled, when a customer creates a request, the system disregards the default
classification from the request's item category and requires the customer to explicitly
select a classification for the request.

Force Search When enabled, proposes solutions for incidents based on the item type,
classification, and description provided.

Create
Forum
Topics

Allows customers to create a new forum topic through the Customer Portal.

Display
Email
Language

When enabled, allows customers to specify a preferred language within their profile
settings in the Customer Portal.

Display
Room

Shows the room for an item when creating a request.

View
Technician

Allows customers to view the details of the technician assigned to their request in
the Customer Portal.

Show All
Services

Enables the Service Catalog link in the Services tab of the Customer Portal. This
link allows customers to view and log requests against all services offered by the
support organization for example, request access to a service). Services listed here
are not assigned an exit item lifecycle state.

Show
Vendor
Performance

Allows customers to see third-party vendors' performance against their defined
service level targets when they deliver services under an underpinning contract.

Show
Service
Targets

Displays the response, restoration, and resolution targets for the SLA assigned to
the request in the Customer Portal.

Show Notify
Others

Displays the 'Notify Others' field in the request editor in the Customer Portal.

Enable RSS When enabled, provides the RSS Requests menu option in the Customer Portal.

Enable Titles When enabled, shows the Titles tab within Setup > Localization, which can be
customized. This list is then shown in the Title field in the User Information and
Customer Information screen. See Titles for more information.

Enable Item
Shadow

When enabled, if requests are logged against an item in the Customer Portal,
technicians can amend the item assigned to the request without the customer
seeing the change.

Customer
Defined
Contact

When enabled, this option allows customers to define their preferred method of
contact in their profile or My Account screen. Their preference applies when a team
has the Customer Notification option set to Customer Defined.

Record GPS When enabled, the GPS location of customers when they last logged into the
Customer Portal is recorded within their Customer Information screen.
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Customer
Privileges

Description

Mandatory
Org. Unit
Code

When enabled, the Org. Unit Code field must be completed during the creation of
an organizational unit or partner organization.

Default Date
Style

Sets the default date format to be used across the application.

Default
Timezone

Sets the default time zone across the application. This setting can be overridden on
a per-user basis if users set their time zone for their login account.

Customers'
Default
Landing
Page

Sets the default landing page of the customer portal for all customers (default is
'Home')

LDAP/AD (visible when an LDAP/AD connection is configured)
Include
Customers

Set to Yes if the system should import customer details when synchronized with an
LDAP/AD server.

Mixed Mode Allows customer accounts to be created directly through the system, as well as
being imported through LDAP/AD.

Show
Domain List

(This option is visible if multiple domains are configured in the system.)
Determines if the list of available domains is published to the login page. If this is set
to 'no', all users authenticating via a directory server must use their UPN, or fully
qualified login name, which includes the domain data.

Default
Domain

(This option is visible if multiple domains are configured in the system.)
Determines which domain is selected for customers by default on the login page.

View Shared Requests (request visibility options for the Customer Portal)
By
Ownership

Allows requests to be viewed by all owners of the item, when logged against a
shared item.
(See the table below for toggle option outcomes.)

By Org Unit (This option is available when the By Ownership option is enabled.)
Allows requests to be viewed by all customers of an organizational unit assigned to
the item, when logged against a shared item.

Include
Global Items

(This option is available when the By Ownership option is enabled.)
Allows requests to be viewed by all customers of an organizational unit assigned to
the item, when logged against a global item.

Close
Shared
Requests

Allows customers to close any requests associated with items they own, even if they
did not submit the request.

3. Click Save.

Setting the View Shared Requests Options
When setting the visibility of requests logged against shared items, refer to the table below to ensure
the correct visibility option is configured for your organizational requirements:
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By
Ownership

By Org
Unit

Shared Request Visibility

No Only visible to the customer who logged the request.

Limited No Visible to the customer who logged the request and other owners in the same
organizational unit assigned to the item.

Limited Limited Visible to the customer who logged the request and members of the organizational
unit he or she belongs to, if the organizational unit is also assigned to the item.

Limited Yes Visible to owners within all organizational units assigned to the item.

Yes No Visible to the customer who logged the request and other assigned owners.

Yes Limited Visible to the customer who logged the request, other members of the organizational
unit the customer logging the request belongs to, and other owners assigned to the
item .

Yes Yes Visible to everyone who shares the item assigned to the request.
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Request Privileges
The Setup > Privileges > Requests tab allows you to control the functionality available for requests
and to set default requirements. These privileges are applied throughout the system.

Enabling Request Privileges
To enable request privileges:

1. Go to Setup > Privileges > Requests.

2. Select Yes to enable or No to disable a privilege option.

Requests Tab Options
Requests

Enable Escalation
Control

Allows escalation to be enabled or disabled on a per-request basis. This
option is only available to supervisors.

Queues Allows teams to use a holding bay for requests that are received through email
or the Customer Portal. The queues can be enabled within the Team
Information screen, on a per-team basis.

Control
Deployments via
RFC

When enabled, change requests are automatically created from newly entered
deployments, and require approval before work commences on the
deployment.

Control CMS via
RFC

When enabled, changes that technicians make within the CMDB generate a
change request that requires approval before the change is implemented.

Customer CMS via
RFC

When enabled, customers creating items in the Customer Portal generate a
change request that requires approval before the change is implemented in
the CMDB.

Email AMIE RFCs This option is available when Control CMS via RFC is set to Yes. Select who
should receive system-generated emails notifying of change requests that are
created as a result of an AMIE synchronization:
• Per Team - The system sends emails according to the notification settings of
the team assigned to the change request.

• None - The system does not send emails.
• Technician - Only the technician assigned to the change request receives
the email.

• Layer - Only users in the change request's current escalation layer receive
the email.

• All Layers - Users in all escalation layers associated with the change
request receive the email.

• Team - All members of the team assigned to the change request receive the
email.

Minimum Solution
Relevance

Defines the minimum degree of relevancy for content included in the
Description field of a request when the system automatically searches the
knowledge base to propose solutions.

Enable Quick
Calls

Enables the functionality that allows a supervisor to profile requests using
quick call templates. Other users can also use these templates when creating
new requests.
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Requests Tab Options
Request Priority
(Derived/Selected)

Select Derived to allow the system to derive the priority based on urgency and
impact of the request. Select Selected to manually apply the priority from a list
of options.

Default Priority This option is available when the Request Priority is set to Selected. The
selection made here is automatically applied as the default priority for newly
created requests.

Handshaking Enables notifications to be sent to customers using the Propose button within
a request, stating the request will be closed if no reply is received from them
within a set number of days.
• The Solution button within an open request is not accessible when the
Handshaking option is enabled.

• When enabled, if problems or changes are closed, any related requests are
moved to the Pending - Approval status, not to the default Closed status.

Handshaking
Close Action

Sets the system default number of days to lapse before a request closes if the
customer does not respond to the handshake email notification. This setting
can be adjusted on a per organizational unit basis.

NOTE To allow customers to re-open a request using the link in the
handshake email, the web server must be using Port 80.

Approval
Reminder

To automatically send managers reminder emails regarding requests requiring
their approval, set this option to Yes.
The content of the reminder email is drawn from the ApproveChange or
ApproveServiceRequest template. These templates are configured within the
Setup > Email > Templates tab.

Approval
Reminder Action

When Approval Reminder is set to Yes, define the number of days to lapse
before the system sends a reminder.

Default Notes
Visibility

Sets the system default visibility of notes when added to requests. If you expect
that the majority of notes will be emailed to customers, select Public.

Private Note
Response

Allows private notes to be considered triggers for the SLA response timer to
have been met. The use of this option implies that customers are notified
outside of the service desk when their request has been 'responded' to.

Allow Unknown When set to No and a user opens a request that is assigned the Unknown
Service item, the user is prompted to update the item before saving the
request.

Archive Requests When enabled, the number of days a request is closed before being removed
from the List View and archived.
Requests that are archived have attachments removed and are no longer
included in the full text index for searching. Archived requests are still
accessible for reporting purposes and attribute-based searches.

Purge Requests Only available when request archiving is in use. When enabled, this defines
the number of years a request is archived before being completely deleted
from the system.
Requests that are purged will be completely removed from the system and no
trace of them will remain. Requests purged using this option can NOT be re-
instated.
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Requests Tab Options
Disable All
Owners
Notification Option

When set to Yes, the All Owners notification option is disabled in a request's
Summary tab. Technicians can use the All Owners option if they want all
customers who share an item to be notified when changes are made to
incidents involving the shared item.

Show Hidden
Attachments

When enabled, attachments associated with hidden attachment types are
shown by default in a request's Attachments tab. Users can hide these
attachments by clearing the Show Hidden Attachments checkbox within the
request.

Show Item
Attachments

When enabled, attachments associated with items and types are shown in the
customer portal during the request creation process to facilitate the provision of
forms for users to complete. Attachments on Items and Types need to be
marked 'Public' in order for them to be published in this way.

Default Note View Allows the administrator to dictate if the default view of notes will show the
abbreviated form (requiring user to click the note ID to view the full content), or
if the list of notes will show the full note content, increasing the scrolling
required, but decreasing the need to enter note records to see the content).

Auto Edit Mode When enabledif a user can edit a request that they view, the request will
automatically open in edit mode (saving the technician from having to click
edit). This does have the consequence of the request being in edit mode and
responsive to changes.

Default SLA Used as the default SLA when a new request is created without an SLA
defined for the item, customer, or organizational unit.

Default Incident
Team* (required if
using AMIE)

Sets the default incident team, which is used for AMIE integration and also set
as a default support team for item types.

Default Problem
Team* (required if
using AMIE)

Sets the default problem team, which is used for AMIE integration and also set
as a default support team for item types.

Default Change
Team* (required if
using AMIE)

Sets the default change team, which is used for AMIE integration and also set
as a default support team for item types.

Default Request
Team* (required if
using AMIE)

Sets the default request team, which is used for AMIE integration and also set
as a default support team for item types.

Default Search
Status

Sets the default behavior for searching requests:
• All - The system defaults to search all requests, both active and inactive
• Active - The system default to search only active requests
• Inactive - The system default to search only inactive requests
Users can override this default behavior by selecting a specific request status
when performing a search.

Review Options
Review SLA When enabled, the Review Date field in the Service Level Information screen

is shown. If you enable this option, you should also set the default number of
days between reviewing SLAs and the number of days before the review date
for an alert reminder.
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Requests Tab Options
Review RFC When enabled, the Review Date field in the RFC Information tab is shown. If

you enable this option, you should also set the default number of days
between reviewing RFCs and the number of days before the review date for an
alert reminder.

KBA (Knowledge Base Article) Options
Control KBA via
Request

When enabled, a request is generated when the KBA is created, deleted, or
amended, and only a user with publishing privileges can publish to the KB.

Request Type Specify the type of request to generate when new or amended KB content is
moved to a Pending Publication state.
(The options available are based on the ownership of change and service
request licenses.)

Default SLA Set the default SLA to use for when requests are logged regarding updates in
the knowledge base. Applying an SLA here determines which workflow and
team receives the requests for approval, as with any other request logged in
the system.

* Should be set after teams have been configured.

3. Click Save.
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Item Privileges
The Setup > Privileges > Items tab allows you to control the functionality available for items, as well
as set the visibility of details for current and planned outages when items become unavailable.

Configuring Item Privileges
To configure item privileges:

1. Go to Setup > Privileges > Items.

2. Select Yes to enable or No to disable a privilege option.

Option Description
General

Edit Item
Numbers

Allows users to edit the identification number of an item.

NOTE If you import items using AMIE, any edits users make to identification
numbers are overwritten upon synchronization.

Display Item
Numbers in
Relationships

When enabled, items are represented by their item number instead of their item
type within relationship maps. (Relationship maps are accessible within the
Relationships tab of an item.)

Depreciation
Interval

The depreciation interval controls how and when the depreciated value of an
item is calculated, and if it's stored
• Dynamic - The system calculates the depreciated value in real-time when an
item record is displayed and the value is not persisted

• Monthly - The system re-calculates the value each month, and stores the value
in the database

• Quarterly - The system re-calculates the value each quarter, and stores the
value in the database

• Annually - The system re-calculates the value each year, and stores the value
in the database

Planned Outages
Current
Outages

Determines if the Outages section is visible in the Customer Portal.

Planned
Outages

Determines if the Planned Outages section is visible in the Customer Portal.

Show Affected
Items

Allows customers viewing an outage in the Customer Portal to see the items that
are affected by the outage.

Show Affected
Users

Allows customers viewing an outage in the Customer Portal to see the users that
are affected by the outage.

Minimum
Criticality

Defines the minimum level of criticality required for items to be listed in the
outages sections of the Customer Portal.

Show Inactive
Items

Includes inactive items in the outages sections of the Customer Portal.
An inactive item is an item that is currently not in use by your organization.

Show Change
Requests

Allows customers viewing an outage in the Customer Portal to see change
requests related the outage.

Search Outages Allows customers to search outages in the Customer Portal using a customer
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Option Description
email address or item number.

Public Outages
Current
Outages

When enabled, the View Outages link is shown on the login screen, allowing
anyone to view current outages without logging in to the system.

Planned
Outages

When enabled, the View Planned Outages link is shown on the login screen,
allowing anyone to view planned outages without logging in to the system.

Show Affected
Items

Allows anyone viewing a public outage to see the items that are affected by the
outage.

Show Affected
Users

Allows anyone viewing a public outage to see the users that are affected by the
outage.

Minimum
Criticality

Defines the minimum level of criticality required for items to be listed in the public
outages sections.

Show Inactive
Items

Includes inactive items in the public outages sections.
An inactive item is an item that is currently not in use by your organization.

Show Change
Requests

Allows anyone viewing a public outage to see change requests related the
outage.

Search Outages Allows anyone to search public outages using a customer email address or item
number.

3. Click Save.
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System Privileges
The Setup > Privileges > System tab allows you to control the following options:

● Knowledge base
● Surveys
● Forums
● Chat
● Other general settings

Enabling System Privileges
To enable system privileges:

1. Go to Setup > Privileges > System.

2. Select Yes to enable or No to disable a privilege option.

System
Privileges

Description

General Settings
Host Address To be completed with details of the machine hosting the application, if required.

Public
Knowledge
Base

Allows access to the public knowledge base on the login page.

Public
Surveys

Provides access to public surveys on the login page.

Public Alerts When enabled, alerts whose visibility is set to Everyone are made available on the
login page.

Passwords When LDAP or Active Directory authorization is not used, internal authentication is
used. To define the password type the system should use, select one of the
following:
• Random: The system generates a random string whenever a password is reset.
• Email: The user's email address is used as the password.
• Manual: Allows the user to manually create a password.

Password
Questions

Enables the ability to set security questions within the My Account screen for
customers and users, which are referenced when resetting or resending login
credentials.

Show Forgot
Password
Link

When enabled the login page shows a link to allow users to reset their passwords
(when using internal authentication).

Session
Timeout

The number of minutes the system waits before terminating idle sessions.

NOTE Ensure that the session timeout on the server hosting the application is
equal to or greater than the value set here.

Terminate
Active
Session

When enabled, if users attempt to log in to the system when they already have an
active session, they are prompted to end the active session to allow for the new
login.

Limit Failed When enabled, helps prevent brute-force password hacking for a given login. After

1 4 9



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p S y s te m P r i v i l e g e s

System
Privileges

Description

Logins three failed login attempts, the system locks out an account for a set number of
minutes (defined by the Lockout Period option).

Lockout
Period

When Limit Failed Logins is enabled, the number of minutes the system locks an
account after three failed login attempts. Default value is 10.

Accept All
SSL

When enabled, the system accepts any SSL certificate for browser sessions and
does not perform verification on the certificate's authenticity.

NOTE This setting should be used with caution in production environments. It is
best practice to leave this option disabled and configure self-signed SSL certificates
on the Setup > Security > Certificates tab.

Default Name
Pattern

Select the order for names in the system when first and last names are shown
together on a screen.

Outbound
Web Services

When enabled, request workflow states and item lifecycle states can be assigned a
'listener', which allows these details to be updated in external systems. (Refer to the
Absolute Global Support website for details on how to develop a listener.)

OpenID
Provider

Enables the system to function as an OpenID provider for user authentication
across network resources as the user authentication source.
The OpenIDProvider URL should be the following:
<PROTOCOL>://<SERVER>/LiveTime/WebObjects/LiveTime.woa/wa/providerLook
up
The protocol should be set to "http" or "https" and the server details should include
where the system is hosted.

Social
Authenticatio
n

Enables the system to delegate authentication of users and/or customers to one or
more external providers (for example, Facebook, Google, or Yahoo). Providers to
use as delegates are configured in the Setup > Security tab.

Forum Options
Use Forums This option enables all forums within the system.

Default Sort
Order

Sets the default forum topic sort order to either ascending or descending.

Public
Forums

This option enables public forums to be viewed from the login page without
requiring a system account.

Chat Options
Enable Chat Select Yes to activate the chat facility within the application.

Chat Request
Assignment

Set to Technician if customers should be restricted to chatting only with the
technician assigned to their request. Set to Team to allow customers to chat with
any member of the team assigned to their request.

Default
Technician
Availability

Sets the default availability for chat status in the Account Information screen of
newly created technicians.

KBA Review Options
Review KBA When enabled, a Review Date field is shown on the KBA Information screen. If

you enable this option, you should also set the default number of days between
reviewing KBAs and the number of days before the review date for an alert
reminder.
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3. Click Save.

Rebuilding the System Index
Click the Re-index button at the bottom of the Setup > Privileges > System tab to rebuild the
system index. If the search engine appears to be failing text searches, this process will recreate the
index. The indexing rebuild runs as a background process.

The system re-indexes the following content and attachments when you click Re-index:
● Knowledge base
● Forums
● All requests
● Items
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Customize
The Setup > Customize tab allows you to customize the look and feel of the application to match
your organization's branding and provide control over the data exposed to customers with they access
the customer portal.

Banners Tab
You can replace system banners with the appropriate banners from your own organization:

● All graphics that you use should be in PNG format
● The dimensions of the Application Banner should be 200 x 60 pixels
● The dimensions of all other banners should be 500 x 70 pixels

Adding a Customized Banner

To add a customized banner:

1. Go to Setup > Customize > Banner.

Banner
Type

Description

Application Visible on the login page of the system.

User Visible in the User Portal (interface for the Supervisor, Technician, Administrator,
Partner, Finance, and Manager roles).

Public/Email Displayed on public portals for knowledge, outages, surveys, and forums. This
banner is also included in emails when the Include Banner option in Setup > Email
> Setup is set to Yes.

Customer Visible in the Customer Portal.

NOTE You can upload banners for partner organizations in the User > Partner
Organizations > Banners tab of the User Portal. This banner overrides the Customer
Banner for customers associated with the partner organization.

2. To use custom banners, select the Use Custom checkbox at the top of the Banners screen.

3. To upload a new banner, click New, then click Browse. A window opens allowing you to
browse to your image file.

4. Browse to the location of the image and click .
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5. Repeat the process until all desired banners have been replaced.

6. Click Save.

NOTE When Enable Purchase Orders is enabled within the Setup > Billing tab, the option
to upload a logo for system-generated purchase orders is shown. The graphic should be a
PNG file that is 150 x 150 pixels.

Portals Views Tab
You can customize the fields displayed in the customer portal lists for each of:

● Incidents (requests)
● Items
● Services

NOTE The full range of fields visible in the technician portal is available for use in the customer portal
and the onus is on the administrator to ensure that appropriate request, item or service detail
isdisplayed to customers.

Customizing a Portal View

To customize the content of a customer portal list:

1. Go to Setup > Customize > Portal Views.

2. Select the list you want to customize from the drop down.

3. Select each 'column' you want to modify and set the desired value

4. Click Save.
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CSS Tab
You can further customize the look and feel of the system using cascading style sheets (CSS) to
amend the following elements:

● Colors
● Fonts
● Tabs
● Graphics

See CSS Tab for more information.

Dashboard Tab
Professional Services can be engage to create additional dashboard content. The dashboard tab exists
to provide a location for which dashboard additions can be uploaded into LiveTime. Several of the
default widgets use this technique and appear as the default entries.

Cloud Tab
Provides an ability for Administrators to customize the endpoints of cloud web services in future should
such a need arise.
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Cascading Style Sheets (CSS)
Use the CSS tab to customize the look and feel of banner backgrounds and tabs within the system.
Knowledge of working with cascading style sheets is recommended if you are making changes to
these settings.

The options available for configuration include the following:

CSS Editor
Application Banners

div.login-panel div.login-header
div.login-title-custom

Controls the style of the customized banner on the login page.

div.login-panel div.login-header
div.login-title-container

Controls the style of the default banner on the login page.

div.login-panel div.login-header
span.login-app-logo

Controls the helpdesk icon graphic on the login page.

#header .customPngBanner Controls the style of the customized banner within the User Portal.

#header .defaultBanner Controls the style of the default banner graphic within the User
Portal.

#header .customPngBanner Controls the style of the customized banner within the Customer
Portal and public access pages.

#pageHeader .defaultBanner Controls the style of the default banner within the Customer Portal
and public access pages.

Menu Options (User Portal)
#menu a.active Controls the highlight on the active (main) menu selection.

submenu a:hover Controls (in tandem with the span extension) the mouseover
(hover) on the submenu tabs.

#submenu a:hover span Controls (in tandem with the hover default above) the mouseover
(hover) on the submenu tabs.

#submenu a.active Controls the highlight applied to the selected submenu options.

If unwanted changes are made to the system CSS, you can click the Default button to revert to the
original system CSS.
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Dashboard
Use this tab to manage third-party widgets for display within the User Portal. After you add widgets,
they become available in the Widget Directory, which users can access by clicking the Add Widget
button on their Home > Dashboard screen.

All widget settings, including which user roles have access to a widget and the category a widget
belongs to, are predetermined within the widget file.

To upload a third-party widget:

1. Go to Setup > Customize > Dashboard.

2. Click New.

3. Browse and select a valid widget file.

4. Click .

To delete third-party widgets:

1. Go to Setup > Customize > Dashboard.

2. Select the checkboxes of the widgets you want to delete.

3. Click Delete.
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Regions
Use this tab to customize the geographic regions or states that are available within the system for
each country. This information is applied to customers and organizational units when their contact
details are being defined. When you make a selection from the customer or organizational unit Country
list within the information screen, the resulting options available in the States list are drawn from the
regions defined here.

Customizing a Country
To edit a country:

1. Go to Setup > Localization > Regions.

2. Select the name of the country you want to edit.

3. Toggle the Default Time Zone to specify the default timezone for that country

4. Toggle the 'State Label' to customize the appearance of the 'State' field label in the editors.

Defining a State for a Country
To define a state or region for a country:

1. Go to Setup > Localization > Regions.

2. Select the name of the country that you want to add states to.

3. Click to add another state.
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4. Enter the name and representative initials for the state, and select the relevant time zone.

5. Click Save.

6. Repeat steps 3 to 5 to add more states.

Editing States
To edit a state or region for a country:

1. Go to Setup > Localization > Regions.

2. Select the name of the country whose states you want to edit.

3. Select the name of the state you want to edit.

4. Edit the name, initials, and time zone details as desired.

5. Click Save.

Deleting a State
To delete a state or region for a country:

1. Go to Setup > Localization > Regions,

2. Select the name of the country whose state you want to delete.

3. Select the name of the state you want to delete.

4. Click Delete.

5. Click Save.
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Searching for Countries and States
To find a country or state within a country, you can use the search feature.

To conduct a search:

1. Go to Setup > Localization > Regions.

2. Click Search.

3. Enter the known details.

● Search options include Country Name, Continent, and State within a country.

4. Click Search.
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Hours
For the ease of configuring technicians' scheduled hours of work and customizing hours of operation
for service level agreements, you can create work hour templates within the Setup > Localization >
Hours tab. These templates are then made available throughout the application wherever hours of
operation are defined.

Creating Work Hour Templates
To create a work hour template:

1. Go to Setup > Localization > Hours.

2. Click New.

● You can also create a work hour template based on an existing template by selecting a
template and clicking Duplicate.

3. Enter the Template Name (this field is required).

4. Set the hours of operation.

5. Click Save.

Editing a Work Hour Template
To edit a default or customized work hour template: 

1. Go to Setup > Localization > Hours.

2. Select the name of the template you want to edit.

3. Edit the hours, as required.

4. Click Save.

Deleting a Work Hour Template
To delete a default or customized work hour template:

1. Go to Setup > Localization > Hours.

2. Select the name of the template you want to delete.

3. Click Delete.

● A warning message is shown.

4. Click OK.
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Content
Use the Content tab to localize automated messages, the user interface, system objects, and content
for language files that the application uses.

You can apply the localized content to customers and users by setting the Email Locale option in their
account information screen.
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You can localize content across the following elements and messages:
● Email Keywords
● Emal Message Templates
● Email Summary Tables
● Email Team Templates
● Error Message Templates
● General Custom Fields
● Item Type Request Fields
● SMS Message Templates
● System Objects
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NOTE You should localize user interface content, email, and SMS messages after you have
configured and reviewed them within the Setup > Email and Setup > Customize tabs, respectively.

Localizing System Content
To localize system content:

1. Go to Setup > Localization > Content.

2. Select the locale that you want to customize.

3. From the Category list, select the element you want to customize.

4. Within the list shown after you select a category, choose the element to customize.
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5. Click Edit.

6. Edit the content and format, if required.
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7. Click Save.
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Events, SLAs, and Technician Assignment
The Events tab allows you to configure the system to automatically account for non-service days of
the Service Desk, regardless of its location. This tab forms part of the technician assignment facility,
as the system logic considers events (such as public holidays) in relation to service level requirements
and technician availability. For example, if your Service Desk has a global customer base and office
locations in multiple countries, you can configure the observed public holidays for each of the different
countries and states. Then when a customer logs a request in one country where the Service Desk
has a public holiday, the system can assign the new request to a technician in a region that does not
have the holiday.

The system also adjusts the SLA timers in relation to breaches and escalations, where relevant. This
means that once a public holiday starts (at midnight in the location where the holiday falls), the due
dates of all requests are moved forward for the period of time that the public holiday is in effect.

Accessing Events Functionality
To configure the events functionality, first enable the Observe Public Holidays option in the Setup >
Privileges > User tab. This option provides access to a fully configurable list of public holidays within
the Setup > Localization > Events tab.

Creating New Events
By default, the system includes national public holidays for a number of countries, which you can
access by selecting a country from the Filter list. This list can be expanded to include any country,
including relevant holidays for a country's different states or provinces.

NOTE You must adjust the dates for rescheduled holidays on an annual basis. Tip: Use the
scheduled quick call functionality within the User Portal on the Home > Quick Calls tab to create the
annual task automatically.

To create a new event for any country, state, or province:

1. Go to Setup > Localization > Events.

2. Click New.

3. Complete the field details.

4. If you selected Custom Schedule as the Interval, select .

● The Date field for rescheduling the event is shown. This field allows you to adjust the day
the public holiday is observed, and caters for instances where the public holiday falls on
the weekend but is observed on either the Monday or Friday. You must account for this
adjustment on an annual basis for all relevant holidays.

5. Enter the date and click Save.

● The date is saved as a rescheduled entry.

6. Click Save.
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Importing Events
In addition to using default events or creating new events, you may also import multiple events from a
CSV file.

NOTE Use the provided CSV template that shows the expected fields and format for importing
events.

To import events for any number of country & state/province combinations:

1. Go to Setup > Localization > Events.

2. Click Import.

3. Download the CSV template.

4. Complete the template using your preferred editor and save it as a CSV file.

5. Click Choose File, select the CSV file you created, and click Upload.

6. Map the fields to the respective attributes required for the import. If you used the template file,
these fields populate automatically.

7. Click Import.

Deleting a Rescheduled Entry
To change a rescheduled entry for an event, you must delete the existing entry. Note that you cannot
delete historical entries as they may be required for historical reference purposes.

To delete a rescheduled entry for an event:

1. Go to Setup > Localization > Events.

2. Select the link of the relevant event.

3. Select the relevant Rescheduled Entry link.

4. Click the Delete button.

● A warning window opens.
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5. Click OK within the warning window.

Public Holidays System Logic
The system applies a public holiday logic to SLAs on a per-SLA basis. This process allows for the
system to include SLAs that observe the public holidays and others that do not.

For public holidays to be considered in relation to an SLA, the Pause on Holiday option must be
enabled for the specific SLA in the User Portal. This option is only visible within the SLA Editor
screen when the Observe Public Holidays option is enabled at Setup > Privileges > User.

When the Pause on Holiday option is enabled, note the following:
● When a public holiday occurs for technicians, their assigned requests have their SLA timers

adjusted only if the Pause on Holiday option is enabled for the specific SLA. SLA timers fire
normally for any requests using an SLA that does not have this option set.

● The amount of time a request is paused relies on the SLA open hours, which can be defined
as 24 hours or specific hours of operation. For example, where the SLA open hours are defined
as 9:00 a.m. to 5:00 p.m. weekdays, the base time of eight hours is applied to pause the SLA.

● If the Service Desk is opened for part of the day that is declared a public holiday, the Open
Hours set for the public holiday are deducted from the SLA open hours. For example, if the
public holiday was observed from 12:00 p.m., where the SLA open hours are defined from 9:00
a.m. to 5:00 p.m., the base time would be reduced by three hours and the SLA paused for five
hours.

● If the due date falls on a public holiday and the hours applied to pause the SLA do not push the
due date to normal operating hours, then:
○ For 24x7 support: the system pushes the due date to midnight, or the beginning of the next

service day
○ For configured support hours or "normal support": the due date is pushed to the start time

of the next "open" day
● If the request operation that works 9:00 a.m. to 5:00 p.m. Monday to Friday, and a request's

due date is 2:00 p.m. on the Friday, the due date is pushed to 9:00 a.m. the following Monday.
In a workflow status where an OLA applies, the OLA is adjusted by the same amount that the
SLA is paused.

● When the Pause on Holiday option is enabled for a new request that is logged with the
system during public holiday hours, if the system cannot find an available technician for
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request assignment, it assigns the request to a technician in the first layer of escalation, based
on the technician assignment logic. This scenario generally applies to organizations where the
Service Desk team is based in one location. (If all technicians have their On Vacation status
set to Yes, the request is assigned to the team lead.)

● If a technician is not available to work on the request, and the new request is assigned an SLA
with the Pause on Holiday option enabled, the due date is calculated based on the time the
request is created plus the number of hours left of the public holiday. For example, if an SLA's
open hours are paused for 24 hours (a full day), for a request created at 8:00 p.m., the due
date is calculated using the target of the SLA priority plus four hours (as there are four hours
remaining in the public holiday).
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Titles
The Titles tab is available when the Use Titles option is enabled in the Setup > Privileges >
Customer tab. Titles you configure here become options to select from within the Customer
Information and User Information screens.

Editing a Title
You can rename or resort titles listed in Setup > Localization > Titles as required.

To edit a pre-existing title:

1. Go to Setup > Localization > Titles.

2. Select the title that you want to edit.

3. Edit the Title, if required.

4. Update the Sort Order, if required.

● This setting changes where the title appears in the drop-down list options when the Title
list is available in the Customer Information and User Information screens.

5. Click Save.

Creating a Title
To create an additional title list option:
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1. Go to Setup > Localization > Titles.

2. Click New.

3. Enter the Title details.

4. Enter a Sort Order number.

● This setting defines where the title appears in the drop-down list options when the Title list
is available in the Customer Information and User Information screens.

5. Click Save.

Deleting a Title
To delete a title:

1. Go to Setup > Localization > Titles.

2. Select the title you want to delete.

3. Click Delete.
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Licenses
The Licenses tab shows information about the currently installed license for LiveTime. You can view
details of the current license, hosting server, and licensed users from this tab. You can also install a
new license here.

Viewing a License
To view a license:

1. Go to Setup > Licenses > License.

2. You can check license information on the following topics:

License Information
Product Identifies which version of LiveTime is currently installed.

Licensee The organization that holds the license.

User
Limit

The maximum number of non-customer users who are allowed to use the system. Value
inside brackets indicates how many licenses are already in use.

Incident
Roles

The number of individual incident management licenses purchased.

Request
Roles*

The number of individual request fulfillment licenses purchased.

Problem
Roles*

The number of individual problem management licenses purchased.

Change
Roles*

The number of individual change management licenses purchased.

License
Type

Details on whether the current license is permanent or temporary.

MAC The MAC address of the host server.

Valid
Host

Shows Yes if the MAC address in the license key matches the MAC address of the
deployment server.

Status Indicates whether the license is currently valid.

* Not applicable in the Help Desk edition of LiveTime.

Updating License Information
The License tab allows you to enter a new license using a license key and certificate for the
application.

To update license information:

1. Go to Setup > Licenses > License.

2. Click New.

3. Enter the License Key for the application.

4. Enter the Certificate details.

5. Click Next.

6. Click Save.
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● The License tab shows the updated license details.

Host Tab
The Host tab shows the host name and IP address for the server where the application is deployed.

Users Tab
The Users tab lists all current users of the system, including their assigned processes. You can filter
the list based on process by using the Filter list in the top right of the tab.

NOTE The process filter and columns (Problem Process, Change Process, and Request Process)
do not apply in the Help Desk edition of LiveTime.
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Database
Use this section to specify the database connection details that the system should use to connect to
the database.

Configuring Database Settings
To configure database settings:

1. Go to Setup > Database.

2. Click Edit.

3. Enter or modify database connection details.

Database Setup
Database Type Select the type of database.

Server Host Enter the IP address of the server host.

Server Port Enter the server port number.

Database Enter the database name.

User name Enter the username for the database.

Password Enter the password for the database.

4. Click the Test button to verify the details entered and check the connection.

5. Click Save.

NOTE You must restart the system for any changes to take effect.
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Test Button
Allows you to validate the database connection details between the service management application
and the database. A system message lets you know whether the connection is successful.

Advanced Button
Allows you to change the default connection type, as well as generate scripts based on the database
selected. When you click the Advanced button, the Connection Type list becomes available,
allowing you to select the Java Database Connectivity (JDBC) connection. This option is set by
default to Internal JDBC.

NOTE Changing the connection type to Custom JDBC Driver allows you to change the driver. This
option is NOT recommended.

The buttons available provide the following functionality:

Advanced
Settings

Description

Create Generates a SQL creation script for the connected database that the database administrator
can use to create the system database.

Upgrade Allows the database administrator to upgrade to the database for a new release.

NOTE Before upgrading, be sure to make a backup of the existing database.

Drop Creates a script that the database administrator can run against an existing system database
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Advanced
Settings

Description

to erase the schema and content.
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Migration
Use this section to perform a migration of LiveTime data from your existing database to another
database. You may need to migrate your database if, for example, you are moving from an evaluation
to a production version of the product, or you need to move from your current database platform to
another supported platform (for example, from Oracle to SQL Server).

IMPORTANT During the migration process, the system is locked down to prevent any changes to
the database. If any errors occur while data is being migrated, the entire process stops and the
database reverts to its previous state.

To perform a database migration:

1. Go to Setup > Database > Migration.

2. Enter the connection details for the target database.

Target Database
Database Type Select the type of database you are migrating to.

Server Host Enter the IP address of the server host.

Server Port Enter the server port number.

Database Enter the database name.

Username Enter the username for the database.

Password Enter the password for the database.

3. Click the Test button to verify the details entered and check the connection.

4. Click Start.
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Authenticating Users
There are several ways to authenticate LiveTime users. By default, the system uses its internal
authentication mechanism but there is also the option to authenticate against one or more directory
servers, or to use external providers.

Internal Authentication
Using internal authentication requires an administrator or supervisor to create accounts for all users by
manually entering their contact information, access levels, and password. This user information is then
saved to the system database. The typical case for using internal authentication is when your
implementation includes few users, or when you have no pre-existing directory server. Typically, the
administrator configures user accounts prior to announcing the system is operational, and from that
point on, maintains the accounts as necessary. (See Create Customers or Create Users for more
information.)

External Providers
External providers that follow OpenID or OAuth standards can also be used to verify a customer's or
user's online identity. These standards address single sign-on by not relying on a centralized website
to confirm a person's identity and provide seamless authentication between third-party authentication
utilities and LiveTime. You can configure external providers within the Setup > Security tab, and
customers or users who have accounts with the configured providers (for example, Facebook, Google,
or Yahoo) can log in to the system by selecting the relevant icon on the login page.

Directory Server Authentication (External Authentication)
The system allows the administrator to connect to one or more directory servers for user authentication
purposes. This process removes the need to manually create user accounts as it allows LiveTime to
synchronize user accounts and access levels with the existing directory server. This method of
authentication has the added benefit of allowing you to work with your organization's existing
infrastructure. (See AD Authentication or LDAP Authentication for more information.)

Directory Server Groups
Because the system uses roles to grant access within the application, users must be assigned to
groups on the directory server that correspond to the roles within LiveTime to allow for the proper
synchronization of access levels.

The default group names the system expects to find on the directory server are the following:
● Administrators
● Supervisors
● Technicians
● Partners
● Managers
● Finance
● Customers

You can customize these group names in the LDAP/Active Directory Advanced tab. Users can belong
to more than one group: for example, if a user holds the roles of Technician and Manager, he or she
would belong to the Technicians and Managers groups.
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NOTE Users can have only one of the Partner, Supervisor, or Technician roles. Therefore, they can
belong to only one of these groups. However, they may also belong to any other group, or combination
of groups.

The following fields may or may not be mapped to the directory server, depending on the options set by
the system administrator:

● First Name
● Last Name
● Email
● Phone
● Mobile
● Pager
● Address
● City
● Zip
● Country

Email Address
All user accounts must include an email address to be successfully imported into the system. If
additional fields are mapped from the directory server to corresponding fields in the application, a drop-
down menu containing all the optional values for the field is available beside the mapped field. Choose
the correct value from each list.

Mixed Mode Authentication
The application can use mixed mode authentication, which is a combination of internal and external
authentication. In this mode, LiveTime synchronizes with a directory server to import user and
customer details, and allows you to be create customer accounts directly within the system. This
feature is useful if your organization is using LiveTime for both internal and external customer support.

To enable mixed mode authentication, after the system has connected to the directory server, go to
Setup > Privileges > Customer and enable the Include Customers option, then set the Mixed
Mode option to Yes.

NOTE If LiveTime authenticates against a directory server, all user accounts validate against the
server except for the application default administrator. The default administrator account details can be
modified within the My Account tab of the application.
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Active Directory Integration
Active Directory is a unique implementation of the LDAP standard that requires communication to
conform to Microsoft Windows authentication protocols. To meet this requirement, it is necessary to
enter all domains from which users authenticate. You can synchronize multiple sources of Active
Directory with the system, if required.

Configuring Active Directory Integration
To configure the Active Directory integration:

1. Go to Setup > LDAP.

2. Click New.

3. Enter the server name.

4. Select Active Directory from the Type list.

5. Define all the domains from which users will be authenticated.

● You must enter domains in both Windows NT and Windows 2000 domain naming formats
since Active Directory conforms to the authentication protocols of these operating
systems.

● Input entries with care as the system domain editor does not validate them against the
directory server.

● Here is an example of both naming conventions for a domain:
● For mydomain.mycompany.com

Windows NT style = MYDOMAIN
Windows 2000 style = mydomain.mycompany.com

6. Click New and enter domain information.

7. Click Save.

8. Select the Default Domain, which the system uses in the following three ways:

● The domain shown on the login page
● The domain to authenticate against when synchronizing with the directory server

1 8 0



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p A c t i v e D i re c to r y In te g ra t i o n

● The domain where the system expects to find user groups

9. Enter all other required fields to configure the directory server:

Settings Description
Security Determines how the integration layer authenticates. For Active Directory, this option

should be set to Cleartext – Username + Password. Anonymous connections to
Active Directory are rarely enabled.

Server
Host

Enter the hostname or IP address of the Active Directory server. On a Windows NT
domain, this value is the primary domain controller.

Server
Port

The default Active Directory server port is 389. This value rarely needs to be changed.

Username Used by the system to authenticate against the Active Directory server when reading
account information. The domain prefix/suffix will be appended, based on the default
domain, when connecting to the server.

Password Enter the password for the username account.

Users
Node

The component of the base domain name that refers to the location of the user groups.
For example, assume the location of the user groups is the following:
ou=UserGroups, ou=MIS, dc=myoffice, dc=mycompany, dc=com
(See LDAP/Active Directory Advanced Settings for information on group configuration.)
Groups must be in the default domain, in this case myoffice.mycompany.com. The
Users Node only needs the location of the groups within the default domain, so the
Users Node in this example is: ou=UserGroups, ou=MIS.

Default
Timezone

Select the default time zone to be applied to all user accounts imported through Active
Directory.

10. Click Save.

11. Repeat the above process to add more than one directory server for setting user access.

Adding Domain Aliases
If your Active Directory server uses domain aliases, you can add these aliases to the Active Directory
integration setup. The system uses these aliases as alternative names for your configured Active
Directory domain.

NOTE You must set up integration with your Active Directory server before you can add aliases (see
"Configuring Active Directory Integration" above).

To add a domain alias:

1. Go to Setup > LDAP.

2. Click New.

3. Enter the server name.

4. Select Active Directory from the Type list.

5. Enter the domain alias.

● You must enter domains in both Windows NT and Windows 2000 domain naming formats
since Active Directory conforms to the authentication protocols of these operating
systems.
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● Input entries with care as the system domain editor does not validate them against the
directory server.

6. Select the Alias checkbox.

7. From the Target list, select the Active Directory server that you are creating an alias for.

8. Click Save.

Test Button
The Test button creates a connection to the Active Directory server, applying the configuration
settings. If successful, the system attempts to determine how many users are in each group and
opens a Results screen.

NOTE If the test fails, an error message indicates the cause of the failure.

Sync Button
The Sync button runs the synchronization process to import all users from the directory server. You
might perform this manual synchronization if new Active Directory accounts have been created and
those users require immediate access to the system.

Only one synchronization can run at a time. When multiple users need access to the system, create
the accounts, then run a single manual synchronization.

A manual synchronization may take some time depending on the connection speed with the external
service. Manual synchronization works best for small directories. Larger Active Directory
implementations can take some time to propagate the changes, so account information may not be
immediately available.

Importing Partners
Partners are imported like any 'User' role, however partner accounts can be unique in that they may
not necessarily be defined in the AD/LDAP server as they are typically third parties, external to the
organization. To support this usage scenario it is possible to specify the partner role to use Mixed
Mode' authentication, so these accounts can also be defined locally within the LiveTime instance.

Importing Customers
You can import customer details using Active Directory by enabling this option, if required. When the
system is set up to synchronize with Active Directory, go to Setup > Privileges > Customer and
enable the Include Customers option.
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If there is a need to create customers using both Active Directory and the system's internal
authentication capability, you can also enable mixed mode authentication. After you set the Include
Customers option to Yes, set the Mixed Mode option to Yes to allow customers to be created both
directly in the system and using Active Directory.

Imported Account Usernames
Accounts imported from Active Directory use the UPN as the username, as opposed to the Windows
NT style login. The domain component of the UPN is derived from the selected domain in the popup on
the login page, which means users need to enter only their login name to connect to LiveTime.

LiveTime passes login details directly to the directory server for authentication and does not retain
these details.
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LDAP Server Integration
You can synchronize multiple types and sources of directory servers with the system at any one time.
LiveTime supports many Lightweight Directory Access Protocol (LDAP) servers, including the
following:

● Open LDAP
● 389 Directory Server
● NetIQ eDirectory

NOTE Since LDAP follows a standard, the settings detailed here should also apply to other server
implementations.

Configuring LDAP Server Integration
To configure LDAP server integration:

1. Go to Setup > LDAP.

2. Click New.

3. Enter the server name.

● (If the system is to synchronize with ZENworks, ensure the server name matches the
user source name used by ZENworks.)

4. Select LDAP Server from the Type list.

5. Enter all other required fields to configure the LDAP server:

Fields Description
Security Secure Socket Layering (SSL) encryption is provided for Active Directory and LDAP

server integration. Details entered here determine how the integration layer
authenticates.
User authentication can be with Secure Socket Layering (SSL) or Clear Text. Select
Anonymous or Username + Password.
If you select Anonymous, ensure anonymous access to the directory is available.

Server
Host

Enter the host name or IP address of the LDAP server.

Server
Port

This is the LDAP server port. The default is 389.

Username The system authenticates the username against the LDAP server. Leave this field
blank for anonymous connections.
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Fields Description
Where a username is provided, 389 Directory Server allows internal users to connect
as the account name, so using ‘cn=Directory Manager’ is acceptable.
OpenLDAP expects the fully qualified domain name for the user, regardless of access
level, so at the very least ‘cn=Manager,dc=example,dc=com’.
For other accounts, the user Base DN is required. Users logging in need only enter
their login name; it is assumed the login name is unique across the entire directory.

Password If a user account is specified in the Username field, enter the account password.

Base DN The base domain name refers to the domain location of the user groups. For example,
assume that the location of the user groups is the following:
ou=UserGroups,ou=MIS,dc=myoffice,dc=mycompany,dc=com
The above string would be the Base DN.

Default
Timezone

Select the default time zone to apply to all user accounts imported using the directory
server.

Test Button
TheTest button creates a connection to the LDAP server using the configuration settings. If
successful, the system attempts to determine how many users are in the top level of each group and
opens a Results screen.
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NOTE If the test fails, an error message details the cause of the failure.

Sync Button
The Sync button runs the synchronization process manually. It is most useful for the initial
deployment, and when new directory server accounts have been created for users who require
immediate access to the system.

If you are using certificates, ensure you enter the certificate details in the Certificates tab before
synchronizing.

Only one synchronization can run at a time. For multiple users needing access, create the accounts on
the LDAP server, then run a single manual synchronization.

A manual synchronization may take some time depending on the connection speed with the external
service. Manual synchronization works best for small directories, as larger directories take more time
to propagate changes.

Importing Customer Details
You can import customer details using LDAP by enabling this option, if required. When the system is
set up to synchronize with LDAP, go to Setup > Privileges > Customer and enable the Include
Customers option.

If there is a need to create customers using both LDAP and the system's internal authentication
capability, you can also enable mixed mode authentication. Set the Mixed Mode option to Yes to allow
customers to be created directly in the system and using LDAP.

Configuring Your LDAP Server
When configuring your LDAP server to integrate with LiveTime, you must create new groups (up to
seven) in a common location where the LDAP user specified in LiveTime has read access. These
groups must conform to the object class "groupOfUniqueNames" rather than "groupOfNames", as
"groupOfUniqueNames" contains the required "uniqueMember" attribute.
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LDAP/Active Directory Advanced Settings
Before setting up the LDAP/Active Directory configuration within the system, you should customize
the settings on the Advanced tab. The default setup assumes that the user groups the system uses to
authenticate match what is on the server, and that the user information imported matches the attributes
available on the server.

Setting LDAP/Active Directory Advanced Options
To configure the advanced options for LDAP/Active Directory:

1. Go to Setup > LDAP.

2. Click Edit.

3. Click the Advanced tab of the selected directory server.

4. Enter the relevant details for the fields, as required:

Field Description
Revert to
Defaults

Resets the installation defaults.

Update
Schedule

Sets a routine synchronization to update the system with current AD/LDAP accounts.
Select the desired interval from Daily,Weekly, Bi-Weekly,Monthly, Bi-Monthly,
Quarterly, Every X Hours, or Every X Days

Next Start &
Frequency

Sets the day of the week and time the system is to start automatically synchronizing
with the directory server. In the case of the 'Every X Hours' and Every X Days' options,
the Frequency can also be entered.

User
Groups

Provides imported users roles. (The system looks for these groups by default.)
You can customize the user group names, but each group must have a unique name.
The group names on the directory server must be identical to the user group names
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Field Description
entered here.
Members of each group are assigned the appropriate role within the system. To
assign multiple roles to users, make sure they are members of each of the required
groups. Users can have only one of the Supervisor, Technician, or Partner roles but
they can also have any other role or combination of roles.

Attribute
Mapping

Maps attributes from the directory server to corresponding fields in the system. Native
system fields are First Name, Last Name, Email (a unique email address must be
included for the system to create a user account), Phone,Mobile, Pager, Address,
City, Zip, and Country.

NOTE Mandatory user information for new and existing user accounts includes the
First Name, Last Name, and Email attributes. If these details are not available, the
application cannot validate an existing user account and automatically reassigns any
open or active requests to another valid user.

Standard: Next to each field is a list of default fields specific to either the LDAP or
Active Directory server type. For each native name, default fields are preselected. Use
the default mapping or select the mapping attribute as required.
Custom: Select a custom option to manually enter an attribute field.

Notes LDAP attribute that defines the correspnding 'Notes' field in the directory server that
will be imported.

GUID Global Unique Identifier:
• For ADS, select objectGUID
• For OpenLDAP, select entryUUID
• For eDirectory, selectGUID

LDAP User
fields/Mixed
Mode User
fields

The LDAP User field headings are replaced with any custom LDAP/ADS accounts
fields that you create in Setup > Custom Fields (see Custom Fields), or Mixed Mode
user fields if the Mixed Mode option is enabled in the Server tab.
Use the list to select the appropriate mapping to the matching directory server field or
select Custom to manually enter a field.

Customer
Orgs

Organizational unit relationships can also be mapped from the authentication server.
By default this functionality is not enabled. To activate customer organizational unit
mapping, select Yes for the Import Customer Organizational Units option and
define where the company and department information should be derived from.

Line
Managers

LDAP attribute that defines a customer's line manager, which the system uses for
processing approvals on service and change requests. Only system users with the
Customer role can be assigned as line managers.

Title LDAP attribute that defines a customer's title which can be imported and displayed
near the customers name so they are addressed appropriately when contacting the
service desk.

5. Click Save.

Mapping Fields to the Matching Directory Server Field
The LDAP User field headings are replaced with any custom LDAP/ADS fields that you create in
Setup > Custom Fields (see Custom Fields for more information). Use the list to select the
appropriate mapping to the matching directory server field or select Custom to manually enter a field.
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The system imports user details when synchronization with the Active Directory/LDAP server takes
place. You cannot modify imported fields through LiveTime directly; you must use the appropriate
directory server console instead.

Importing Customer Organizational Units
You can also import organizational unit relationships from the directory server. By default, this
functionality is not enabled. To activate customer organizational unit mapping, select Yes for the
Import Customer Org Units option.

NOTE Details of the organizational units do not populate upon this synchronization, only the
organizational unit names. For the organizational unit details to populate to customer or user
information, you must create the organizational unit in the User > Organizational Units tab of the
User Portal and ensure the organizational unit name is identical to what is stored in the directory
server. If the details are not identical, the system creates another organizational unit.
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Social Authentication
The Social Authentication screen is available when the Social Authentication option is enabled
within the Setup > Privileges > System tab. This functionality delegates the authentication of
customers and users to external providers. Users and customers who have accounts with external
providers recorded in the system can log in by clicking the appropriate icon shown on the system login
page.

You can use the Social Authentication screen to configure the external providers you want to use to
verify the online identity of customers and users accessing the system. By default, the system
includes the details for Facebook, Google, and Yahoo, which you can enable by opening the relevant
link and selecting Yes.

Enabling Default Providers
To use the default external provider options of Facebook, Google, or Yahoo to authenticate
customer and user access:

1. Go to Setup > Security.

2. Select the name of the external provider you want to enable.

3. Click Edit.

4. Set the Enable option to Yes.

5. For providers using the OAuth standard, enter the API Key and API Secret from the provider.

● To access these values, you must set up your own developer account with the provider
using the callback URL specific to your installation of LiveTime.

6. Click Save.

● The external provider icon is now visible on the system login page.
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To remove a default external provider, follow the above steps, but click the Delete button within the
Details view of the provider.

Defining a Provider
To enter the account details for an external provider:

1. Go to Setup > Security.

2. Click New.

3. Complete the Name field.

4. Set the Enable option to Yes.

5. Click to upload the icon to show on the system login page for the provider.

6. Click Choose File to search for the image file.

● The image must be 32 x 32 pixels.

7. Click to upload the file.

8. Enter the URL for the provider

9. Click Save.

● The icon for the external provider is now active on the system login page.
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Scheduling Reports
The Setup > Reports > Schedule tab allows you to configure the system to automatically send
reports through email to supervisors, technicians, finance users, partners, and managers on a regular
basis. You can define the content of the email on a per-role basis and you can use either default
reports or those built using the system report builder.

Setting Up Scheduled Reports
To set up scheduled reports:

1. Select Setup > Reports.

2. Select the name of the role that you want to set up reports for.

3. Set the Active option to On and enter the scheduled report details:

Setting Description
Interval Define how often the automated reports should be sent.

Next Start Using the calendar, set the time and date the report should next be emailed to the
user role group.

Date Range Set the number of previous days, weeks, or months that the report should be
calculated over.

Page Size Set the page format size for the report.

Selected
Reports

Click to add or to remove reports in this schedule.

4. Click to add reports to the schedule.

5. Select the report Category.

● The Name list is refined based on the Category you select. For example, if you set KPI
as the Category, the Name list includes all types of KPI summary reports included by
default in the system.
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6. Define the report Name and any other required options.

● Based on the Name you select, the options to create a trend report or define the results by
specific parameters (for example, customer name or item type) are shown.

7. Click Add.

● Repeats the above steps to associate all the required reports with the scheduled reports
email.

8. Click Test, if required.

9. Search and select the user who should receive the test report.

10. Click Test.

● The system sends a test copy of the report to the defined user with the test interval range
based on one day, week, or month, not the actual number defined in the Previous field for
the scheduled reporting period.

11. Click Save.

● Repeat the above process for all relevant user roles.
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AMIE Mappings for Servers
The Asset Management Import Engine (AMIE) integrates with the following inventory management
products:

● Centennial Discovery 2005 and 9
● Express Software Manager 9.0 and 9.5
● LANrev 6.9+ / Absolute Manage 6.0 / LANrev 5.1
● HP Universal CMDB 8.0
● LANDesk 8.5, 9.0, and 9.0 (Hardware)
● LANrev 5.1
● LOGINventory 4.3+
● Manage Engine Desktop Central 7.0
● Microsoft SMS 2003 SP1 and Microsoft SCCM 2007
● Spiceworks 4.0+
● ZENworks Asset Management 6.5+
● ZENworks Configuration Management 11.1 and 11.1 (Hardware)

The following tables outline the default AMIE mappings for each server type.

Centennial Discovery 2005 and 9
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "Hardware.size"

VALUE_PREFIX ""

VALUE_SUFFIX "MHz"

FIELD2 = "RAM"
FIELD "field2"

VALUE "Hardware.size"

VALUE_PREFIX ""

VALUE_SUFFIX "KB"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "Client.macAddr1"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE "Client.ipaddr1"

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Hardware
FIELD5 = "Network Name"

FIELD "field5"

VALUE "Client.sysMachine"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD6 = "Platform"
FIELD "field6"

VALUE "Windows"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE "Hardware.driver"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Item Category Software
FIELD3 = "Version"

FIELD "field3"

VALUE "Products.versionName"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Express Software Manager 9.0 and 9.5
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE “machinehardware.c_processor”

VALUE_PREFIX ""

VALUE_SUFFIX "Mhz"

FIELD2 = "RAM"
FIELD "field2"

VALUE “machinehardware.c_ram“

VALUE_PREFIX ""

VALUE_SUFFIX "B"

FIELD3 = "MAC Address"
FIELD "field3"
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Item Category Hardware
VALUE “machine.nicaddress“

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE “machine.ipaddress”

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE “machine.name”

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE “machinehardware.machineserialnumber”

VALUE_PREFIX ""

VALUE_SUFFIX ""

LANrev 6.9+ / Absolute Manage 6.0
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "computer.PROPCPUSPEED"

VALUE_PREFIX ""

VALUE_SUFFIX "Mhz"

FIELD2 = "RAM"
FIELD "field2"

VALUE "computer.PROPPHYSICALMEMORYSIZE"

VALUE_PREFIX ""

VALUE_SUFFIX "B"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "computer.PROPPRIMARYMACADDRESS"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"
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Item Category Hardware
VALUE "network.PROPIPADDRESS"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE "network.PROPWINHOST"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE "computer.PROPMACHINESERIALNO"

VALUE_PREFIX ""

VALUE_SUFFIX ""

HP Universal CMDB 8.0
Item Category Hardware
FIELD2 = "RAM"

FIELD "field2"

VALUE "CDM_NT_1.A_NT_PHYSICAL_MEMORY"

VALUE_PREFIX "B"

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE "CDM_HOST_1.A_HOST_HOSTNAME"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Item Category Software
FIELD1 = "Path"

FIELD "field1"

VALUE "CDM_APPLICATION_1.A_APPLICATION_PATH"

VALUE_PREFIX ""

VALUE_SUFFIX "MHz"

FIELD3 = "Version"
FIELD "field3"

VALUE "CDM_APPLICATION_1.A_APPLICATION_VERSION_NUMBER"

VALUE_PREFIX ""

VALUE_SUFFIX ""

1 9 7



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p A M IE M a p p i n g s fo r S e rv e rs

LANDesk 8.5, 9.0, and 9.0 (Hardware)
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "Processor.mhzSpeed"

VALUE_PREFIX ""

VALUE_SUFFIX "MHz"

FIELD2 = "RAM"
FIELD "field2"

VALUE "Memory.bytesTotal"

VALUE_PREFIX ""

VALUE_SUFFIX "B"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "NetworkSoftware.nicAddress"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE "TCP.address"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE "Computer.deviceName"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD6 = "Platform"
FIELD "field6"

VALUE "Windows"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE "Computer.compSystem.serialNum"

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Software
FIELD1 = "Path"

FIELD "field1"

VALUE "software.path"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD3 = "Version"
FIELD "field3"

VALUE "FileInfo.version"

VALUE_PREFIX ""

VALUE_SUFFIX ""

LANrev 5.1
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE “hardware_info.CPUSpeed“

VALUE_PREFIX ""

VALUE_SUFFIX "Mhz"

FIELD2 = "RAM"
FIELD "field2"

VALUE “hardware_info.PhysicalMemorySize”

VALUE_PREFIX ""

VALUE_SUFFIX "B"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE “hardware_info.PrimaryMACAddress“

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE “network_adapter_info.IPAddress“

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE “network_adapter_info.WinHost“

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Hardware
FIELD10 = "Serial Number"

FIELD "field10"

VALUE “hardware_info.MachineSerialno”

VALUE_PREFIX ""

VALUE_SUFFIX ""

LOGINventory 4.3+
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "LI_CUP.LI_NAME"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD2 = "RAM"
FIELD "field2"

VALUE "LI_SYSTEM.LI_PCMEMORY"

VALUE_PREFIX ""

VALUE_SUFFIX "MB"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "LI_NET.LI_MACADDRESS"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE "LI_NET.LI_IPADDRESS"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE  "LI_PCINFO.LI_PCNAME"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE  "LI_SYSTEM.LI_SERIAL"

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Software
FIELD3 = "Version"

FIELD "field3"

VALUE  "LI_SOFTWARE.LI_VERSION"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Manage Engine Desktop Central 7.0
Item Category Hardware
FIELD2 = "RAM"

FIELD "field2"

VALUE "invcomputer.TOTAL_RAM_MEMORY_MB"

VALUE_PREFIX "MB"

VALUE_SUFFIX ""

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "resourcemacip.MAC_ADDRESS"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE "resourcemacip.IP_ADDRESS"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE "invcomputeros.SERIAL_NUMBER"

VALUE_PREFIX ""

VALUE_SUFFIX

Item Category Software
FIELD3 = "Version"

FIELD "field3"

VALUE "invsw.SOFTWARE_VERSION"

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Microsoft SMS 2003 SP1 and Microsoft SCCM 2007
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "Processor_DATA.currentClockSpeed0"

VALUE_PREFIX ""

VALUE_SUFFIX "MHz"

FIELD2 = "RAM"
FIELD "field2"

VALUE "PC_Memory_DATA.totalPhysicalMemory0"

VALUE_PREFIX ""

VALUE_SUFFIX "B"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "Network_DATA.macaddress0"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE "Network_DATA.ipaddress0"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE "Computer_System_DATA.propName0"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD6 = "Platform"
FIELD "field6"

VALUE "Windows"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE ""

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Software
FIELD3 = "Version"

FIELD "field3"

VALUE "SoftwareProductMap.productVersion"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Spiceworks 4.0+
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE “devices.processor_type“

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD2 = "RAM"
FIELD "field2"

VALUE “devices.memory”

VALUE_PREFIX ""

VALUE_SUFFIX "B"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE “devices.mac_address”

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD "field4"

VALUE “devices.ip_address”

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD "field5"

VALUE “devices.name”

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE “devices.serial_number”

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Printers & Scanners
FIELD5 = "IP Address"

FIELD "field5"

VALUE “devices.ip_address“

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD6 = "Serial Number"
FIELD "field6"

VALUE “devices.serial_number”

VALUE_PREFIX ""

VALUE_SUFFIX ""

Item Category Network Infrastructure
FIELD5 = "IP Address"

FIELD "field5"

VALUE “devices.ip_address“

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD6 = "Serial Number"
FIELD "field6"

VALUE “devices.serial_number”

VALUE_PREFIX ""

VALUE_SUFFIX ""

ZENworks Asset Management 6.5+
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "NC_CPU.speed"

VALUE_PREFIX ""

VALUE_SUFFIX "MHz"

FIELD2 = "RAM"
FIELD "field2"

VALUE "NC_Workstation.totalMemory"

VALUE_PREFIX ""

VALUE_SUFFIX "MB"

FIELD3 = "MAC Address"
FIELD "field3"
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Item Category Hardware
VALUE "NC_Workstation.lanaddress"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD " field4"

VALUE " NC_Workstation.ipaddress"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD " field5"

VALUE " NC_Workstation.machinename"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD6 = "Platform"
FIELD "field6"

VALUE "Windows"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE "NC_Workstation.serialNumber"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Item Category Software
FIELD3 = "Version"

FIELD "field3"

VALUE "NC_Product.model"

VALUE_PREFIX ""

VALUE_SUFFIX ""

ZENworks Configuration Management 11.1 and 11.1 (Hardware)
Item Category Hardware
FIELD1 = "CPU"

FIELD "field1"

VALUE "NC_CPU.speed"

VALUE_PREFIX ""

VALUE_SUFFIX "MHz"
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Item Category Hardware
FIELD2 = "RAM"

FIELD "field2"

VALUE "NC_Workstation.totalMemory"

VALUE_PREFIX ""

VALUE_SUFFIX "MB"

FIELD3 = "MAC Address"
FIELD "field3"

VALUE "NC_Workstation.lanaddress"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD4 = "Network Address"
FIELD " field4"

VALUE " NC_Workstation.ipaddress"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD5 = "Network Name"
FIELD " field5"

VALUE " NC_Workstation.machinename"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD7 = "OS Version"
FIELD "field7"

VALUE " NC_Workstation.osmodel"

VALUE_PREFIX ""

VALUE_SUFFIX ""

FIELD10 = "Serial Number"
FIELD "field10"

VALUE "NC_Workstation.serialnumber"

VALUE_PREFIX ""

VALUE_SUFFIX ""

Item Category Software
FIELD20 = "Platform String"

FIELD "field10"

VALUE "NC_Workstation.osproduct"

VALUE_PREFIX ""

VALUE_SUFFIX ""
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Item Category Software
FIELD3 = "Version"

FIELD "field3"

VALUE "NC_Product.model"

VALUE_PREFIX ""

VALUE_SUFFIX ""
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AMIE Customized Mapping
The customized mapping functionality provides you with greater control over the item type and
category information accessed during the item import process. This functionality allows you to
customize queries by defining parameters for importing items.

Exporting the Parameters File
Before you can import items into LiveTime, you must define the parameters of the items to import in an
XML file, which you can generate from the application.

To export the parameters file:

1. Go to Setup > AMIE > Customize.

2. From the Operation list, select Export Configuration.

3. Select the type of server that contains the items you want to import into LiveTime.

4. Click Export.

● The system generates an XML file, which you can save in a preferred location.

Customizing the Parameters File
To customize the item import, you must modify the parameters file you generated in the previous
procedure.

To modify the parameters file:

1. In the text editor of your choice, open the XML file you generated from LiveTime.

2. Modify the properties as required.

● The example below explains how you can customize a Centennial 2006 6.1 configuration.

Server Type Identifier
The first line within the XML file displays the following three fields:

<IMPORT_DEFN SERVER="Centennial" VERSION="2006 6.1" AUTHOR="Ivanti">

They identify an entry for an asset management server type. By modifying these fields, you can create
another configuration for Centennial 2006 6.1; for example:

<IMPORT_DEFN SERVER="Centennial" VERSION="2006 6.1 (Bob's Config)"
AUTHOR="Bob">
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This newly configured name will be the Server Type listed as an option when setting up the Asset
Management Import Engine (AMIE).

Item Categories
The configuration mapping file is divided into "blocks" of item categories. In each block, you can define
a number of instructions to execute during AMIE's import process. For example:

<ITEM CATEGORY="Hardware" ID_KEY_FORMAT="Client.Client">

● "ITEM CATEGORY" instructs AMIE to import all items within the defined XML block as
generic “Hardware”. If you want to be more specific about your import for Hardware, you
could break this category down into sub-categories; for example: “Computer”, “Printer”, and
“Network Peripheral”.

● Assuming the selected asset management server supports the inventory control of these
individual categories, defining an XML block for each category allows you to import each
hardware item as a “Computer, “Printer”, or “Network Peripheral”.

● The ”ID_KEY_FORMAT” attribute illustrates the format of the primary key field for this
category in the asset management database. In the example, “Client.Client” says that the
“Client” column of the “Client” table contains the primary key for your hardware.

NOTE This attribute only affects systems that support the feature of manually editing the
Item Number field (when the Edit Item Numbers option is enabled in Setup > Privileges >
System). To use editable item numbers when AMIE is enabled, the Edit Asset Mgmt IDs
option must also be set to Yes.

Item Properties
Item properties are typically the fields that describe the item details, such as “CPU”, “RAM”, and
“Serial Number”. The instructions to retrieve property data are defined in the "<QUERY ...>" and
"<ITEM_PROPERTY ...>" elements.

"<QUERY>" element:
● Define the "QUERY" property to locate the table data.
● For example, the query below retrieves the "CPU" data for hardware. The "QUERY

NAME" (cpu) is used to reference the property field as described later.
<QUERY NAME="cpu">SELECT cpu FROM com.livetime.assetimport.Hardware

cpu WHERE cpu.propClient = :ASSETID and cpu.propHardwareType = 4</QUERY>

"<ITEM_PROPERTY>" element:
● Define the "ITEM PROPERTY" to extract column data for the above query.
● Each of these entries maps an item property from the asset management server to

LiveTime. For example, the value in the CPU field of the asset management server is
mapped to the CPU field of the application database.

<ITEM_PROPERTY FIELD="field1" VALUE_PREFIX="" VALUE="cpu.propAsize"
VALUE_SUFFIX="MHz" TYPE="LOOKUP" />

The following table contains an explanation for each of these attributes:

Attribute Description
ITEM_ Name of the field that exists in the system database. The field "field1" for the
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Attribute Description
PROPERTY
FIELD

"Hardware" item category maps to the "CPU" field.
For a current entity-relationship diagram that includes these database fields, please
contact Global Support.

VALUE_
PREFIX

Prefixes the actual value returned from the asset management server database.

VALUE Can either be a hard-coded value, or a value you want to import from the asset
management server database (see the TYPE attribute below).
The example defines a string using the query.property notation, which references the
actual value in the database.
In the example, the VALUE attribute is "cpu.propAsize":
• "cpu" - The query name where the results are contained (the "Hardware" table).
• "propAsize" - The property name where the actual CPU value is stored (the "SIZE"
column).

In most cases, the property name is identical to the database column name, with the
first letter capitalized followed by lowercase characters. Property names are always
pre-appended with the word “prop” to ensure uniqueness in the import process.
Take these guidelines into consideration when defining custom properties.

VALUE_
SUFFIX

Suffixes the actual value returned from the asset management server database. In the
example, this value is "Mhz" as it represents the CPU field.
Suffixing "Mhz" in this case gives the imported value more meaning.

TYPE "LOOKUP" - Retrieves the data from the VALUE attribute as specified using the
query.property notation.
"QUOTED" - Treats the VALUE attribute as a hard-coded value.

NOTE Query entries allow AMIE to retrieve necessary data from the asset management
server database. You can write AMIE queries in a query language called HQL, which is similar
to SQL. For more information on HQL and some examples on how to write HQL queries, see
http://docs.jboss.org/hibernate/orm/3.3/reference/en/html/queryhql.html.

Item Relationships
When defining multiple item category types to import, for example "Hardware" and "Software", you can
specify how they are related. Configuring these properties will allow the system to import items with
predefined relationships.

NOTE Only children items should contain this information, as the system defines relationships from
the bottom up.

In this example, the Centennial 2006 6.1 software relationship block is as follows:
<RELATIONSHIP RELATED_TO="Hardware" TO="is a parent of" NAME="Parent of
/ Child of" FROM="is a child of" CLASS="1000" INHERIT_OWNERSHIP="1">
<NATIVE_ID_QUERY>SELECT computer.client FROM
com.livetime.assetimport.Client computer WHERE computer.propAddress is
not null and computer.client :SW_ASSETID.0</NATIVE_ID_QUERY>
</RELATIONSHIP>

This "Parent of / Child of" relationship already exists as one of the factory-supplied relationship types.
However, you can create and map any newly defined relationships as part of the import process.
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The following table contains explanations for the attributes and child elements:

Attribute Description
RELATED_TO The item category another item category can relate to. For example, you can relate

"Software" to "Hardware".

TO A label describing the relationship from the parent to the child.
For example: [Hardware] is a parent of [Software]

NAME The name of the relationship.

FROM A label describing the relationship from the child to the parent.
For example: [Software] is a child of [Hardware]

CLASS "1000" - Hierarchical-based relationship.
"2000" - Connection-based relationship.

INHERIT_
OWNERSHIP

"1" - Propagates ownership data (customer and organizational unit) from each parent
item to all of its children.
"0" - Relationship does not inherit parent ownership data.

Uploading and Editing the Parameters File
After you have customized the parameters file, you need to import it back into the system to enable
LiveTime to import the items using your specifications.

To import the parameters file:

1. Go to Setup > AMIE > Customize.

2. From the Operation list, select Upload/Edit Configuration.

3. Select [New Configuration] from the Type list.

4. Click New.

5. Click Choose File.

6. Search for and upload the configured XML parameters file.
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7. Enter the Connection Defaults for the database type, name, username, password, schema,
and catalog, if necessary.

● What you enter here will be the pre-set values when selecting and mapping the new server
type.

8. Click Import to import the XML file.

● When the import is complete, the new configuration file appears as a new server type.

9. You can modify or update the server connection details by clicking Edit and making the
required changes.

10. Click Save.

Using the Customized Server Type
After you import your customized server configuration into the system, you can select it as an option
when configuring AMIE in the Setup tab.

To use the new server type:

1. Go to Setup > AMIE > Setup.

2. Click New.

3. From the Type list, select the customized server.
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4. Configure the Database, Ownership, Discovery, and Synchronization fields.

5. Click Test to confirm the connection, then Save when complete.

For more information on importing items using AMIE, see Importing Items Using Database Mapping.

2 1 3



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e
H e l p

M a n a g i n g Ite m s U s i n g D a ta b a s e M a p p i n g
(A M IE )

Managing Items Using Database Mapping (AMIE)
You can synchronize multiple asset management data sources with LiveTime. When one or more
applications are configured within AMIE, they are listed within Setup > AMIE > Setup.

Importing Items Using Database Mapping
To import items using database mapping:

1. Go to Setup > AMIE > Setup.

2. Click New and customize the Server, Database, Ownership, Discovery, and
Synchronization fields:

Setting Description
Server

Connection Select whether you are importing data from a relational database management
system (RDBMS) or from Absolute Computrace.

Type Select the type of inventory management product that you are importing from.

Identifier An identifying label that is used in list views to inform users about the source of an
item.

Database (available fields may vary depending on database type)
Type Select the database type.

Host Enter the host name or IP address.

Port Enter the port number for the database server.

Path This option is visible when the selected database type stores its data in a file rather
than a network-connected database.
Enter the accessible path to the data file for the database you are mapping. This value
can be one of the following:
• A local file path (on your local machine)
• A mapped network drive file path (in an entirely Windows environment)
• An HTTP/FTP/FTPS fully qualified URL accessible to the server so that LiveTime
can read the data file and import the content. The URL path in this case must begin
with a protocol and end with a trailing "/", and will typically include a username and
password, for example:
ftp://username:password@[TARGET_HOST]/[DATA_FILE_DIR]/

Name Enter the database name.

Username Complete user name details.

Password Complete password details.

Schema Enter the schema type.

Catalog Enter the catalog name. Typically this value would be the name of the database.

Notification (only visible if "Control CMS via RFC" is enabled)
Email
RFC's to
Tech?

Select this option if technicians are to be notified of generated change requests.

Ownership
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Setting Description
Import as
Global

Select this option if items are to be globally owned.

Overwrite Some database types can report only the last logged-in user as the item owner, while
others allow for manual owner assignment. Set this option to No to retain the owners
reported by the AMIE source during synchronization or Yes to replace the reported
owners with the last detected user each time synchronization occurs.

System
User

Select this option to assign imported items to the system user.

Selected
Customer

Select this option to assign imported items to a specific customer.

Ignore
Domain
Info

Select this checkbox if the system is to disregard domain details attached to the user
name inside the AMIE source when assigning an owner.

Discovery
Auto
Create
New Items

This option is only visible when a single AMIE source is defined within AMIE. When
enabled, items are automatically created upon synchronization, relative to the Control
CMS via RFC setting within the Setup > Privileges > Requests tab.
If disabled, a snapshot of imported asset information is listed within the Configuration
> AMIE Snapshots tab of the User Portal.

Merge on
Number
Clash

This option is relevant when the system is importing items from multiple AMIE sources
that use unique item numbers, making number conflicts possible between the sources
during import.
Enable this option to automatically associate an imported data snapshot that has item
number conflicts with existing items in the LiveTime CMDB that have matching pre-
existing item numbers.

Synchronization
Interval Choose a synchronization interval. This field can be left as Never if the database is

synchronized manually.

NOTE Synchronization times vary depending on the connection speed with the
external service and the database size.

Next Start Select the date and time you want synchronization to next start.

3. Click Test to initiate a connection and test the setup.

● If a connection is not made, a system message lets you know which part of the
configuration was not successful.

4. Click Save.

5. To execute the import, click Import.

● After the import is complete, an alert provides the results of the import.
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●

AMIE Import Alert
The system generates alerts for the administrator after the AMIE synchronization is completed. The
Import Alert summary displays the following:

● The details of the system that the synchronization was run against, as it is possible to import
from multiple sources

● The number of assets found in the datasource
● The number of assets automatically created if a single datasource is configured in AMIE and

the auto-create option is enabled; or if the auto-create option is disabled and items already
exist in the system, the number of items that were updated

● The number of AMIE snapshots successfully imported, with a breakdown of new items added
and number of items updated

Delete Options and AMIE
You can delete AMIE configurations through the list view from the Setup > AMIE > Setup tab, or by
clicking on the Server link within the list view, which opens the expanded view for the specific asset
management tool.

When you click the Delete button in the list view of the Setup > AMIE > Setup tab, global-level
"delete" flags are applied to all AMIE-managed items stored in the system; however, the server details
configured in AMIE and their associated snapshots are retained.

The imported items that you delete are not completely removed from the database but are flagged as
not available. By not erasing the items completely, historical data is maintained and allows you to re-
enable these items in the future. Note that the item types associated with the deleted imported items
are not disabled in the application.

If you click the Delete button within the expanded view for the specific asset management datasource,
a configuration-level deletion of the configured server and any related AMIE snapshots occurs.

NOTE You must restart the application after performing either deletion operation to allow the changes
to take effect and prevent unpredictable behavior of the system.
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To delete the server configuration within AMIE and any related snapshots:

1. Go to Setup > AMIE > Setup.

2. Select the name of the server configuration you want to delete.

● The expanded view of the server configuration opens.

3. Click Delete.

● A popup message opens asking you to confirm the deletion action.

4. Click OK.

● A warning message is shown informing you to restart the application server to complete
the deletion process.
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Re-enabling Deleted Items
To re-enable deleted items, you can initiate an item search on deleted Items and restore them within
the User Portal.

To re-enable a deleted item:

1. In the User Portal, go to Configuration > Items.

2. Click Search.

● The Search Items page opens.

3. Enter a search term.

4. Select the Deleted Item Only option.

5. Click Search.

● A list of matching items is shown.

6. To re-enable an item, select the Item No.

7. Click Enable.
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Managing Items Using a CSV File
To import items using a CSV file, you can download and populate a CSV template that contains all
available fields. LiveTime uses a field mapping wizard to match fields in the template to those in the
system. To download the template, go to Setup > AMIE > Import. See Downloading an Item .CSV
Template for more information on configuring the CSV file.

Before Importing a CSV File
To successfully import an item, you must map the following fields:

● Team/s
● Status 

The teams within the CSV file must be created in the system before you can associate them with an
item as part of a CSV import. A supervisor creates teams in the User > Teams tab of the User Portal.

The system imports items based on category (for example, hardware and software), which the
supervisor must configure within the Configuration > Categories tab before conducting a CSV
import. The categories configuration defines the details recorded in the item to be imported into the
system. You must create separate CSV files based on the categories configured, which you can then
individually upload into the application.

For items imported with owners, the Username in the CSV file must match the Username within
LiveTime. If the owner does not exist in the system, the imported item becomes a global item.

NOTE If you want relationships to be created between items on import, you should import parent
items first. If you want to use the system-generated item number for the parent item, you need to
include it in the Parent Item Number field of the related items when you import them.

Importing Items
To import items with a CSV file using the Import Wizard:

1. Go to Setup > AMIE > Import.
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● To access a template that illustrates the fields the application maps and their data types
(see below), click the Download Template link.

● The following fields should be visible in the CSV file:
● Item Number(Unique char 64), Item Type(char 128), Manufacturer(char 128), Incident

Team(char 64), Problem Team(char 64), Change Team(char 64), Request Team(char 64),
Company(char 128), Department(char 128), Room(char 64), Username (char 64), Status
(char 128), Criticality(char 64), Purchase Date(datetime), Cost(decimal), Field(s)[1-40](char
256), Notes(CLOB), Relationship Name(char 256), Parent Item Number(char 64)

● Note the following:
● The 'FieldX' (1-40) labels above will reflect the actual field names as defined in the

selected CMDB category
● The "char ###" designation in parentheses after each field name signifies what type of

data the import utility expects to see in each field. For instance, "Item Type(char 128)"
means that the item type field cannot exceed 128 characters.

● Fields marked as "Unique" must be unique in the system.
● "Room" field details must be in the following format: COMPANY-DEPARTMENT;Room

● When creating a CSV file for a category, to determine the field number of a configured
custom field, select the System defined Ordering option within the Category tab of an
item category. The field labels are then listed in sequential order from one to forty.

2. Select the category of the items you are importing.

● The list consists of all categories that the supervisor has created in the Configuration >
Categories tab of the User Portal.

3. Enter the location of the completed CSV file, or use the Browse button to select the file.
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4. Click Upload.

● The Field Mapping Wizard opens. Fields that you can map to the CSV file are available in
the lists.

5. Review and map the fields from the CSV file.

Field MappingWizard
General

Item Number Unique item number of the item, which the system generates. Alternatively, you
can define the item number in the CSV file yourself if the Edit Item Numbers
option is enabled at Setup > Privileges > Items.

Username User name of the customer owning the item.

Item Type II Item type of the item.

Manufacturer I Sets the manufacturer details of the item.

Incident Team I Incident team assigned to the item.
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Field MappingWizard
Problem Team I Problem team assigned to the item.

Change Team I Change team assigned to the item.

Request Team I Request team assigned to the item

Criticality Sets the default criticality (Critical, High, Moderate, Low, Very Low) for the item.
This field is optional.

Status I Default status of the item.

Company I Company owning the item.

Department I Department owning the item.

Room I The location of the item. The data format in the CSV file to import this information
must be: COMPANY-DEPARTMENT;Room

Service Level Service level agreement assigned to the item.

Date Format Displays the date format required for the contract details to be imported
successfully.

Contract Start
Date

Sets the start date of a contract associated with an item.

Contract End
Date

Sets the end date of a contract associated with an item.

Purchase Date Date the item was purchased.

Cost The cost of the item.

Monthly Cost Sets the service cost on per month basis for the item.

Notes Free text to add notes to the item. This field is optional.

Details
Fields 1 to 20 Custom fields created for the category are available here for mapping to the item

based on information included in the CSV file.

Relationships

Relationship
Name

Defines the description of the relationship between the item set in the Parent Item
Number field.

Parent Item
Number

Identifies the item with which the imported item is related using the item number.

Options

Ignore First Line Option to ignore the first row in the CSV file upon import.

Verbose Errors Detailed description of any errors that occur during the import process.

● I = Information that needs to exist in the system before the import
● I = Fields that are mandatory
NOTE If you want to create relationships between items upon import, you should import
parent items first. If you are using the system-generated item number for the parent item, it
needs to be included in the Parent Item Number field of the related items when you import
them.

6. Select the Ignore First Line checkbox if the first line of the imported CSV file has field
headings.
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● Leave the checkbox clear if the CSV file begins with usable data.

7. Select the Verbose Errors checkbox to record a detailed description of any errors that occur
during the import.

● Leaving the checkbox clear returns a summarized error report.

8. Click Import to bring the mapped field data into the system.

● The Item Import screen shows you the results of the import.

9. Click Done.

Configuring Items After the Import
During the item import, the system creates elements that do not already exist in the database for fields
marked with a blue line within the Field Mapping Wizard, including the following:

● Item Type
● Warranty
● Organizational Units

After an import, you need to further configure all item types that the system automatically created.

To complete item type configuration:

1. In the User Portal, go to Configuration > Types.

2. In the Item Types screen, select the newly created item type.

3. In the Type Information screen, click Edit and complete the following fields:

Item Type
Name Name of the item type.

Manufacturer The manufacturer of the item type. You can create, edit, and delete manufacturers by
using the Edit and New buttons beside the Manufacturer list.

Item
Category

Signifies the type of item. (Hardware, Software, and Service are the default types,
but a supervisor can create more if required.)

Identifier Available options are drawn from the fields defined for the item category selected.
Although this information is not required, the identifier is used to differentiate similar
items that may be in use throughout an organization. For example, if an organization
uses the same printers for all departments, an item category of "Location" could be
configured for the item details and this category could also be used as a secondary
identifier for the printer item.

Criticality Rates the degree of importance of an item type within an organization, which you
can adjust on a per item basis. The "impact" of a request is initially pulled from the
criticality of the item, but can be adjusted within the Request Information screen if
required. Requests logged through the Customer Portal use the criticality of the item
to set the priority of the request.
The Incident Analyzer, if enabled in CMS > Incident Analyzer, can apply the
criticality to automatically detect problems.
The minimum criticality level can also be used to determine the offline items that
appear on outages pages, if the outages pages are enabled in Setup > Privileges >
System.
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Item Type
Icon

To customize the icon for the specific item type, click .

Unit Price The per-unit price of the item type. This field is optional and is used for asset
management purposes. See Finance Role for more information.

Instance
Total

Number of instances owned by the organization.

Assigned Number of instances assigned to customers as items.

Hidden SelectOn to ensure customers cannot view this item type within the list in the
Customer Portal. If all item types use this selection, the Item Type list is completely
removed from the Portal.
Items created using item types with this option enabled do not allow customers to
generate requests against them in the Customer Portal, nor are customers able to
view or receive updates about requests that a user logs against hidden items.

Creation Enabling this option gives customers using the Customer Portal the ability to create
new items using this item type if they have been granted the ability to create items in
Setup > Privileges > Customer. (This option is not available when the Hidden
option is enabled.)

Ignore Share Enabling this option overrides the system-level option for sharing requests raised
against items of this type. Requests raised against items of this type are not
available in the Customer Portal when viewing shared requests is enabled.

Add Forum
Topic

Creates a forum topic using the item type name. This option is only available when
you create a new item type.

Incident
Default

The team of technicians assigned to support incidents received related to the item
type. See Teams for more information.

Problem
Default

The team of technicians assigned to support problems received related to the item
type. See Teams for more information.

Change
Default

The team of technicians assigned to support change requests received related to
the item type. See Teams for more information.

Request
Default

The team of technicians assigned to support service requests received related to the
item type. See Teams for more information.

Service
Level Default

The default service level for the item type. When billing is enabled, service levels
without a cost are listed as an option. The service level with an associated cost can
be applied when an item is created, which ensures item contract payment is
processed.

Support
Levels

All service level agreements assigned to the item type, which are available as
options when a request is created for an item of this type. SLAs listed here are used
within the Costs tab of service types to forecast break even points on the service
relative to the number of users.

Find SLA
(Name) Use this option to assign multiple SLAs to the item type. Click  to view all SLAs or

refine the search by entering a specific name. Select the SLA hyperlink to assign the

SLA to the item type. Click to clear the search field.

4. Click Save.

5. Click the Classification tab to create problem classification for this item type.
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● Click the item type name to continue configuration.

Assigning Multiple Companies and Departments to an Item
You can also use the CSV file import to assign more than one company and department to an item, if
required. To assign multiple companies within the "Company" column of the CSV file, enter the
company names separated by a semicolon (;). If a company does not exist in the system, or it has
been deleted, the system will create it on import.

When importing multiple departments related to multiple companies, you must list the department
related to the company in the same order as the companies and separated by a semicolon. For
example:

Company field: comp1;comp2
Department field: dept1:depart2 or ;dept2 or dept1;

When you perform a CSV import, the system creates any departments that do not exist in the
database or have been deleted.

To assign rooms to one of the locations of this multiple company/department assignment, you must
enter the full details of the company and department into the column followed by a semicolon and the
room number. Here is an example of the room import format:

Company Field:CompName1;CompName2
Department Field:Dept1;Dept2
Room Field: CompName1 - Dept1;Room1

Updating Item Information Using a CSV Import
To easily update multiple items that already exist within the system, you can import the updated
information using a CSV file. For the update to be successful, the item number in the CSV file must
match the item number in the system.

Follow the previous procedure in "Importing Items" and be sure to map the item number field correctly.
If an item number is not included in the CSV file, the system creates a new item in the database.
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Integrating with Endpoint Management
If your organization uses HEAT LANrev or Absolute Computrace to manage the IT assets or user
endpoints in your environment, you can configure LiveTime to work seamlessly with these endpoint
management systems.

After you complete the integration tasks, LiveTime users benefit from the following features:
● Seamless access to real-time asset management data
● More precise root-cause and impact analysis
● Ability to initiate endpoint actions (for example, Device Lock or Data Delete) on managed

devices directly from the Service Desk
● Ability to manage asset-related events that are triggered outside of LiveTime

Integrating LiveTime with LANrev
Enabling the Connection to LANrev

To enable the connection to LANrev:

1. Go to Setup > AMIE > Advanced.

2. Select LANrev from the Server list.

3. Set the Enabled option to Yes.

4. Complete the following fields:

Field Description
General Settings

Connection
Mode

Define how LiveTime connects to LANrev: either directly to the LANrev server or via
the LANrev Web Admin component. Connecting via LANrev Web Admin allows
several additional commands in the endpoiont action toolbox.

Server
Address

Enter the address of the server hosting the instance of LANrev.

Server Port Enter the port number for the LANrev server.

Username Enter the username used to authenticate against the LANrev server.

Password Enter the password associated with the specified username.

IP Field Enter the identifier for the field within the Details tab of an item to be used for a
device’s IP address.

Hostname
Field

Enter the identifier for the field within the Details tab of an item to be used for a
device’s Hostname.

Remote
Enabled
Field

Enter the identifier for the field within the Details tab of an item that indicates whether
LANrev’s remote control feature is enabled on a device.

Android
Field

Enter the identifier for the field within the Details tab of an item that indicates whether
the device is an Android device.

Remote
Port Field

Enter the identifier for the field within the Details tab of an item that indicates the port
to invoke the remote control feature on.

OnDemand
Packages

Enable this option if you want customers to be able to install on-demand software
packages available in LANrev directly from the Customer Portal.
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Field Description
Admin
Console
Link

Enable this option to provide users with a direct link within a request to open a specific
device in the LANrev Admin console. Users must have LANrev Admin installed on
their computer for this link to work.

Global
Login

Are technicians sharing a single login or using their personal LANrev credentials for
endpoint management

Item
Actions

Is the endpoint action toolbox accessible from the item editor itself rather than only
within a request context.

5. Click Test to initiate a connection to the LANrev server and test the setup.

● If the connection is successful, the following message displays at the top right of the
screen:
LiveTimeConnection Successful

● If a connection is not made, the messages states which part of the configuration was not
successful.

6. Click Save.

Mapping to the LANrev Database

To map to the LANrev database using AMIE:

1. After enabling the connection to the LANrev server, go to Setup > AMIE > Setup.

2. Click New.

3. Set the Connection option to RDBMS.

4. From the Type list, select the version of LANrev you are connecting to.

5. Complete the following fields:

Field Description
Server

Identifier  Enter an identifying label. In list views, this label informs users about the source of an
item.

Database (available fields may vary depending on database type)
Type Select the type of database hosted on the LANrev server.

Host Enter the host name or IP address.

Port Enter the port number for the database server.

Path This option is visible when the selected database type stores its data in a file rather
than on a network-connected database.
Enter the accessible path to the data file for the database you are mapping. This value
can be one of the following:
• A local file path (on your local machine)
• A mapped network drive file path (in an entirely Windows environment)
• An HTTP/FTP/FTPS fully qualified URL accessible to the server so that LiveTime can
read the data file and import the content. The URL path must begin with a protocol
and end with a trailing "/", and will typically include a username and password. For
example:
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Field Description
ftp://username:password@[TARGET_HOST]/[DATA_FILE_DIR]/

Name Enter the database name.

Username Enter the username.

Password Enter the password.

Schema Enter the schema type.

Catalog Enter the catalog name. Typically this value is the name of the database.

Ownership
Import as
Global

Enable this option if you want to assign all imported items as global items, which are
available to everyone.

Default
Customer

Enter the customer to assign imported items to by default.

Default
Org. Unit

Enter the organizational unit to assign imported items to by default.

Overwrite This setting is relevant when ownership details for items imported from LANrev clash
with existing ownership details in LiveTime. If set to Yes, the existing ownership details
are overwritten with the new details. If set to No, the new owner of the item is added as
an additional user in LiveTime.

Ignore
Domain
Info

Select this option if the system should disregard domain details attached to the
username inside the AMIE source when assigning an owner.

Discovery
Auto
Create
New Items

If enabled, items are automatically created upon synchronization, relative to the
Control CMS via RFC setting within the Setup > Privileges > Requests tab.
If disabled, a snapshot of imported asset information is listed within the Configuration >
AMIE Snapshots tab of the User Portal.

Merge on
Number
Clash

This setting is relevant when the identifier of an item imported from HEAT LANrev
matches that of an existing item in LiveTime. If set to Yes, the system considers the two
items as the same item and associates the AMIE snapshot with the existing item. If set
to No, the system treats the two items as distinct items.

Synchronization
Interval Set the time period the system uses to synchronize with the HEAT LANrev database.

NOTE Synchronization times vary depending on the connection speed with the
external service and the database size.

Next Start Using the calendar, set the time and date the system should next synchronize with the
HEAT LANrev database.

6. Click Test to initiate a connection to the HEAT LANrev database and test the setup.

● If the connection is successful, the system displays a confirmation message.
● If a connection is not made, the message states which part of the configuration was not

successful.

7. Click Save.
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Integrating LiveTime with Absolute Computrace
Integrating with Absolute Computrace involves multiple steps depending on your desired level of
integration:

● Enabling the connection to the Computrace server – This step allows LiveTime to read
data from Absolute Computrace. After establishing a connection, the system can retrieve
alerts that Computrace generates (for example, when the lease on a device is near expiration).
The system can then automatically generate requests prompting the Service Desk to address
these alerts.

● Mapping to the Computrace database using AMIE – This step allows LiveTime to pull
hardware and mobile device category items stored within Computrace. The system then
generates configuration items to represent this data within LiveTime.

● Configuring user access – Users need to update their account settings with their Absolute
Computrace credentials in the User Portal at Home > My Account. These credentials are
required to ensure LiveTime adheres to the security policies of Absolute Computrace. For
example, if a user has sufficient privileges to view the history of a device or perform endpoint
actions on a device within Absolute Computrace, the user will have the same rights within the
Service Desk.
NOTE To perform endpoint actions from the Service Desk, technicians must have Security
Administrator privileges within Absolute Computrace, and must adhere to existing security
policies (for example, using required two-factor authentication).

Enabling the Connection to Computrace

To enable the connection to the Computrace server:

1. Go to Setup > AMIE > Advanced.

2. Select Absolute Computrace from the Server list.

3. Set the Computrace Enabled option to Yes.

4. Complete the following fields:

Field Description
General Settings

Computrace
Host

Enter the address of the server hosting Absolute Computrace Web Services gateway.
This address is typically “https://secureapi.absolute.com”.

Username Enter the username to authenticate against the Absolute Computrace server for
retrieval of event data.

Password Enter the password associated with the specified username.

OS Field Enter the field number within the Details tab of an item to be used for a device’s
operating system information.

Report
Attachment
Type

When a report is generated as a result of an endpoint action, the report is attached to
the request after the action is completed. Select the report attachment type to include
with the request.

Polling
Enabled

Enable this option if you want the system to check the Computrace server for event
data updates.

Polling
Interval

Enter the time period (in minutes) the system uses to check the Computrace server
for event data updates.
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Field Description
(mins)

Request
Type

Select the type of request the system generates when it retrieves a Computrace alert.

Request
Customer

Select the user who the system assigns the generated requests to.
If you select (System User), the system places all generated requests in the
assignment queue.

Customer
Visible

Select whether customers can see requests the system generates as a result of
Computrace alerts. When set to No, requests related to Computrace alerts, as well as
their notifications, are not visible to customers.

5. Click Test to initiate a connection to the Absolute Computrace server and test the setup.

● If the connection is successful, the following message displays at the top right of the
screen:
Successfully connected to Absolute Computrace

● If a connection is not made, the message states which part of the configuration was not
successful.

6. Click Save.

Mapping to the Computrace Database

To map to the Computrace database using AMIE:

1. After enabling the connection to the Computrace server, go to Setup > AMIE > Setup.

2. Click New.

3. Set the Connection option to Computrace.

4. From the Type list, select the version of Computrace you are connecting to.

5. Complete the following fields:

Field Description
Server

Identifier Enter an identifying label. In list views, this label informs users about the source of an
item.

Host Enter the address of the server hosting Absolute Computrace Web Services gateway
(specified at Setup > AMIE > Advanced).

Username Enter the username to authenticate against the Absolute Computrace server for
retrieval of event data (specified at Setup > AMIE > Advanced).

Ownership
Import as
Global

Enable this option if you want to assign all imported items as global items, which are
available to everyone.

Default
Customer

Enter the customer to assign imported items to by default.

Default
Org. Unit

Enter the organizational unit to assign imported items to by default.

Overwrite This setting is relevant when ownership details for items imported from Absolute
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Field Description
Computrace clash with existing ownership details in LiveTime. If set to Yes, the existing
ownership details are overwritten with the new details. If set to No, the new owner of
the item is added as an additional user in LiveTime.

Ignore
Domain
Info

Select this option if the system should disregard domain details attached to the
username inside the AMIE source when assigning an owner.

Discovery
Auto
Create
New Items

If enabled, items are automatically created upon synchronization, relative to the
Control CMS via RFC setting within the Setup > Privileges > Requests tab.
If disabled, a snapshot of imported asset information is listed within the Configuration >
AMIE Snapshots tab of the User Portal.

Merge on
Number
Clash

This setting is relevant when the identifier of an item imported from Absolute
Computrace matches that of an existing item in LiveTime. If set to Yes, the system
considers the two items as the same item and associates the AMIE snapshot with the
existing item. If set to No, the system treats the two items as distinct items.

Synchronization
Interval Set the time period the system uses to synchronize with the Computrace database.

NOTE Synchronization times vary depending on the connection speed with the
external service and the database size.

Next Start Using the calendar, set the time and date the system should next synchronize with the
Computrace database.

6. Click Test to initiate a connection to the Computrace database and test the setup.

● If the connection is successful, the system displays a confirmation message.
● If a connection is not made, the message states which part of the configuration was not

successful.

7. Click Save.
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Integrating with ZENworks
You can configure LiveTime to work seamlessly with ZENworks Configuration Management. As a first
step, you can use ZENWorks as a provider for authenticating users and customers. On a day to day
basis, users can leverage ZENworks' remote control and bundle management capability within a
request, which helps increase users' efficiency and manage their workload.

Enabling Social Authentication
To enable authentication of users and customers through ZENworks, you must first enable the Social
Authentication option within Setup > Privileges > System.

Once enabled, you can configure the ZENworks location details and OpenID information within the
Setup > AMIE > ZENworks tab.

Defining ZENworks Settings
To define the ZENworks server information and OpenID provider details:

1. Go to Setup > AMIE > ZENworks.

2. Complete all the following fields:

AMIE
General Settings

Server
Address

Address of the server hosting the ZENworks instance.

IP Field By default within the AMIE mapping file, Field 4 within the Details tab of an item is used
for the IP address (Network Address) of a device. You can edit this value if required.

OS
Field

By default within the AMIE mapping file, Field 20 within the Details tab of an item is used
to record the OS information of a device. You can edit this value if required.

OpenID Provider
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AMIE
Name Enter ZENworks as the OpenID provider name.

Icon By default, the ZENworks icon that is available on the login page for customers and
users accessing the system.

URL The OpenID provider URL is automatically generated based on the Server Address
when you click the Save button.

3. Click Save.

Reset Button
Click the Reset button for the system to generate a new certificate that allows the LiveTime to
communicate with ZENworks. When selected, the system shows an information message providing
the location details for downloading the new certificate.

Completing ZENworks Integration
To complete the ZENworks integration:

● Import customer and user details from the eDirectory authentication server
● Import Items using AMIE and ZENworks 11

When validating account details of users and customers accessing LiveTime, the system queries two
locations for unique identifiers:

● Details in the GUID field imported from eDirectory for the customer or user
● The customer's or user's email address
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Billing
The Billing module within LiveTime allows users to create invoices and purchase orders, as well as
manage customer support contracts. This functionality exists to allow support organizations to charge
customers for support services provided, and manage items purchased with service contracts.

When you enable the Billing module with purchase orders, the Invoices and Purchase Orders menus
are available within the Finance tab of the User Portal. Purchase orders can simplify the tracking of
where and when new items are purchased or leased. While this feature is not meant to replace an
organization's existing PO system, it is designed to easily link a specific PO number (and its
associated vendor and date information) with an item. 

The Invoices section allows customers to be billed for products (in the form of items) or support
services (through a prepaid contract or in arrears) that the organization provides to them. Users can
create an invoice when a customer orders an item and service contract. Alternatively, users can create
invoices for service contracts alone, as the item may already exist in the system.

Invoices can be generated through the following screens:
● Within the Invoices section
● When a request is created against an out-of-contract item
● When an item, customer, or organizational unit is created or edited to assign a new SLA

The billing options include the following:
● Purchase orders
● Contracts
● Invoices

Setting Description
Enable
Purchase
Orders

Allows users to track items from the moment an order is placed to its delivery and
implementation. POs cover leased and purchased Items.

Enable
Invoices

Allow users to charge customers for support services and products. When you activate
invoices, you must also enable contracts and/or chargebacks.

Payment
Required

(This option is visible when invoices are enabled.)
Setting Payment Required to Yes requires line items on invoices to be paid before they
become active in the system. Users cannot work on any requests logged against an unpaid
contract or item until payment is received.

NOTE Only a finance user can process invoice payments.

Enable
Contracts

Allows users to manage customer service agreements over a specific time period through the
use of prepaid contracts.

Enable
Chargebacks

(This option is visible when invoices are enabled.)
Allows users to bill customers in arrears for support services after these services are
provided.

Display SLA
Prices

Enables SLA price fields to be visible in the SLA Editor screen. This setting allows the
supervisor to allocate costs to SLAs and assists with the calculation of break even point costs
for service items. This setting is automatically enabled when Enable Invoices is set to Yes.
See SLAs for more information.

Tax Rate (This option is visible when purchase orders or invoices are enabled.)
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Setting Description
(Percentage) Enter the rate to calculate tax on an invoice subtotal.

Purchase
Order
Company
Details

(This option is visible when purchase orders are enabled.)
Enter any details related to your organization that you want to appear on purchase orders.

Request
Warning
TIme

(This option is visible when invoices are enabled.)
When a customer has not paid a contract and has raised a request, the system can send a
reminder email stating that payment is due. Use this field to specify the length of time in hours
from the opening of the incident before sending a reminder email.

Request
Cancel Time

(This option is visible when invoices are enabled.)
Specifies a waiting time for requests with a status of Pending-Unpaid before they are
cancelled.

Invoice
Warning
Time

(This option is visible when invoices are enabled.)
Enter the number of days prior to the due date to send the customer a reminder email
regarding non-payment of an invoice.

Default
Invoice Due

(This option is visible when invoices are enabled.)
Enter the number of days from the date of issue in which payment of an invoice is due.

Email
Notifications

(This option is visible when contracts are enabled.)
Enables the system to update finance users through automated emails regarding invoice
and/or contract related matters.

Terms and
Conditions

(This option is visible when invoices are enabled.)
Enter any terms and conditions that you want to appear on invoices emailed to the customer.

Currency Defines the currency that the system uses for all financial transactions.
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Purchase Orders
Purchase orders (POs) can simplify the tracking of where and when new items are purchased or
leased. While this feature is not meant to replace an organization's original PO system, it is designed
to easily link a specific PO number (and its associated vendor and date information) with an item.

Enabling Purchase Orders
To enable purchase orders:

1. Go to Setup > Advanced > Billing.

2. Set the Enable Purchase Orders option to Yes.

3. Set the default tax rate.

● The percentage amount you enter here is applied by default to all POs.

4. Enter the company details to use in POs.

5. Select the preferred currency for POs from the Currency list.

6. Click Save.

NOTE You can apply a logo to system-generated POs by adding the graphic within the
Setup > Customize tab. (This option is only available when the purchase orders functionality
is enabled within the Setup > Advanced > Billing tab.)

The Purchase Order menu is available within the Finance tab for finance, supervisor, and technician
users, when you enable this functionality.
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Contracts
A contract is made up of a service level agreement (SLA) and a service delivery period (start and end
time). Contracts can be used to manage an entitlement to service from a start date through to an end
date.

Contracts and invoices are used together when the Service Desk needs to charge its customers in
advance for any support provided. In this case, billing within the system occurs on a per-contract
basis.

Contracts can be created for different elements to suit organizational needs and can cover the
following individual elements:

● Items
● Customers
● Organizational units
● Requests

Pending contracts are contracts that have a start date set in the future. They automatically become
active on the contract start date or can be enabled manually.

Enabling Contracts
To enable a contract:

1. Go to Setup > Advanced > Billing.

2. Set the Enable Contracts option to Yes.

● A Contracts tab becomes available.

3. Set the Email Notifications option for finance users.

● When enabled, the system sends automated emails to finance users regarding matters
relating to POs, invoices, and contracts.

4. Set the Currency for all financial transactions the system manages.

5. Select the Contracts tab and define the parameters for contracts.

Option Description
Subscription

Contract
Renewal
Time

The system can automatically send a contract renewal invoice before a contract expires.
Enter the number of days prior to the contract expiration date for the system to send the
renewal invoice.
For contracts not to be automatically created, leave this field blank.
(You can customize the information for the invoice in the InvoiceSummary template
within the Email Summary Templates filter at Setup > Email > Templates. The system
sends this template with the InvoicePrefix email, which you can edit in the Email
Content Templates filter at Setup > Email > Templates.)

Default
Contract
Duration

The system sets the default contract renewal period to 12 months. You can adjust or
delete the entry as required.

Time
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Option Description
Low
Time
Alert

The system can automatically create an alert within the Customer Portal for customers
that have time-based contracts (that is, they have purchased a quantity of support hours).
The system can send the alert based on the percentage of hours that the customer has
used.

Low
Time
Email

The system can automatically send an email to customers who are getting close to using
all their support hours in their time-based contracts. The system can send the email
based on the percentage of hours that the customer has used.
You can customize the email content in the ContractTimeLow template at Setup >
Email > Templates.

Expiration
Time
Expired

When a customer's contract is expired when a user is working on a request, this option
specifies if the user can complete the request even though the contract has expired, and
if the system should lock out the user until the customer has purchased additional time.
If you select Complete Request, the following options are shown:
• Rollover - The time used to resolve the issue will be subtracted from the customer's
renewed contract.

• Ignore - The time used to resolve the issue, even though the customer contract has
expired, is not allocated to a future contract.

(You can customize the subject line and content for the automated emails sent on
contract expiration in the ContractTimeElapsed template at Setup > Email >
Templates.)

6. Click Save.
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Invoices
Invoices are used for the billing of prepaid (contracts) and postpaid (chargebacks) services, and can
also be used for purchase orders. In addition, invoices can be used to maintain the purchasing of items
as well as contracts for these and existing items.

When you enable invoices, you must also enable contracts and/or chargebacks.

To enable invoices:

1. Go to Setup > Advanced > Billing.

2. Set the Enable Invoices option to Yes.

3. Complete all the necessary fields.

Options Description
Enable
Contracts

Allows users to manage customer service agreements over a specific time period
through the use of prepaid contracts.

Enable
Chargebacks

Allows users to bill customers in arrears for support services after these services are
provided.

Payment
Required

Setting Payment Required to Yes requires line items on invoices to be paid before
they become active in the system. Users cannot work on any requests logged
against an unpaid contract or item until payment is received.

NOTE Only a finance user can process invoice payments.

Note Time
Unit

Defines the unit (in minutes) to record the time taken for entering notes in the
system. Default value is 1.
If you use a unit other than the default value of 1 minute, automatic recording of time
is disabled and users can manually specify the amount of time they spend entering
notes, in the unit you specify here.

Tax Rate
(Percentage)

The rate used to calculate tax on an invoice subtotal.

Request
Warning
Time

When a customer has not paid a contract and has raised a request, the system can
send a reminder email stating that payment is due. Use this field to specify the
length of time in hours from the opening of the incident before sending a reminder
email.

Request
Cancel Time

Specifies a waiting time for requests with a status of Pending-Unpaid before they
are cancelled.

Invoice
Warning
Time

Enter the number of days prior to the due date to send the customer a reminder
email regarding non-payment of an invoice.

Contract
Renewal
Time

The system can automatically send a contract renewal invoice before the end of a
contract. Enter the number of days prior to the contract expiry to send the renewal
invoice.

Default
Invoice Due*

Enter the number of days to calculate an invoice due date.

Email
Notifications

Enables the system to update finance users, through automated emails, regarding
matters relating to POs, invoices, and contracts.

Terms and Text in this field is included in the invoice emailed to the customer.
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Options Description
Conditions

Purchase
Order
Company
Details

This option is available if purchase orders option also enabled.
Enter the company details to include in purchase orders.

Currency Select the currency for all financial transactions within the system.

*Denotes mandatory field. 

4. Click Save.
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Logging
Use the Logging tab when Absolute Global Support needs more detail about the system's behavior.
Do not edit the contents of this tab unless Absolute Global Support instructs you to do so.

When required, Absolute Global Support will provide you with instructions to enable specific debugging
output that may clarify certain system behaviors.

If you have been asked to edit a specific logger, first look for it in the Logger Name column. If it is
present, select it and adjust the log level as instructed by Absolute Global Support. If the logger is not
present, click Add, enter the name of the logger exactly as provided, set the log level, and click Save.

After your support case is resolved, it is recommended that you reset the logging back to its default
behavior, either by reverting the logger you edited back to its original log level, or by removing the
logger you created for the debugging exercise.
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Single Sign On
When configured, single sign-on (SSO) allows customers and users who have logged on to their
networks using their directory server authentication credentials to automatically access LiveTime
without re-entering their login details.

SSO options are available for organizations that use HTTP header-based, single sign-on tools such as
Active Directory Federation Services (AD FS), JOSSO, Shibboleth, or CA Single Sign-On (formerly
SiteMinder). These tools work best with directory server technologies if you want to keep user account
details synchronized. Since some of these tools rely on application server redirects to be implemented,
you should check the documentation of your SSO provider for details on how to activate and use
HTTP header-based single sign-on.

You can also choose to use an SSO solution based on Security Assertion Markup Language (SAML)
authentication. LiveTime supports the version 2.0 specifications of SAML when used in conjunction
with AD FS.

Enabling Single Sign-On
To enable SSO:

1. Go to Setup > Advanced > Single Sign On.

2. Click Edit.

3. Under Single Sign On, enable the Active option.

4. Complete all fields:

Fields Description
HTTP Headers

Session
ID

Enter the name of the HTTP header that contains the SSO session ID. You can view all

the headers by clicking .

Username Enter the name of the HTTP header that contains the login of the user attempting to
access LiveTime.

Email Enter the name of the HTTP header that contains the email address of the user
attempting to access LiveTime.

5. To view all session headers, click .

6. Click Save.

Configuring SSO Using SAML Authentication and AD FS
To use SSO with SAML authentication and Active Directory Federation Services (AD FS), ensure the
following prerequisites have been met:

● LiveTime is deployed on a server that is Secure Sockets Layer (SSL) enabled
● Your AD FS server is properly configured and running
● Your Java Runtime Environment (JRE) contains the Java Cryptography Extension (JCE)

Unlimited Strength Jurisdiction Policy Files

To configure SSO using SAML authentication and AD FS:

1. From your AD FS server, do the following:
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● Export the AD FS token-signing certificate to an X.509 certificate file.
● Note the SAML 2.0 authentication endpoint URL.

2. Go to Setup > Advanced > Certificates and import the certificate you saved in step 1.

3. Go to Setup > Advanced > Single Sign On.

4. Click Edit.

5. Under SAML Authentication, enable the Active option.

6. If you have configured SAML authentication in the system previously and are reattempting the
configuration, click Reset SAML Certificates.

7. Complete all fields:

Fields Description
SAML Authentication

IdP URL Enter the SAML 2.0 authentication endpoint URL from your AD FS server.

IdP Certificate Select the token-signing certificate you imported into the system.

8. Click Save.

9. Next to SP Metadata, select the Download link and save the metadata XML file associated .

10. From your AD FS server, do the following:

● Add LiveTime as a new Relying Party Trust using the metadata XML file you saved in the
previous step. Ensure the Relying Party Trust you created is using the SHA-1 secure hash
algorithm.

● Add the following claim rules to the Relying Party Trust you created:
○ Get Email (Send LDAP Attributes as Claims)
○ Email to Name ID (Transform an Incoming Claim)
○ Get Surname (Send LDAP Attributes as Claims)
○ Get Given Name (Send LDAP Attributes as Claims)

Single Sign Off
1. Determine the single sign off URL for the IdP

Complete the Logout URL field appropriately

Fields Description
Single Sign On

Logout URL Enter the SAML 2.0 logout URL from your AD FS server.
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Social
To better track, capture, and respond to issues that customers may raise through social media
platforms, you can enable social media integration within the Help Desk. Through the use of widgets
on the Dashboard of the User Portal, this type of integration allows technicians to see what customers
are saying about the organization in real time. When necessary, technicians can respond to customer
feedback through social media or create a request in the system to address an issue, all from within
the widget.

Before you can set up social media integration, you need the login details of the corporate social media
account you are integrating with. This account's profile is the sender of all social media comments that
originate from the Help Desk, not the individual technician's name.

After you set up social media integration, technicians can add widgets found in the Social category of
the Widget Directory to manage feedback originating from social media.

Enabling Facebook Integration
To enable Facebook integration:

1. Go to Setup > Advanced > Social.

2. From the Social Media list, select Facebook.

3. Set the Facebook Enabled option to Yes.

4. Select the Please authorize LiveTime App by clicking here link.

5. In the window that opens, log in to Facebook using the corporate account you want to
integrate with

6. Follow the instructions for authorizing LiveTime to access the corporate public profile and post
to Facebook.

NOTE To ensure customers can read comments posted from the Help Desk, you must
choose to share posts with the public when prompted.

7. After you have successfully authorized LiveTime, close the window.

8. On the Social tab, click Save.

Enabling Twitter Integration
To enable Twitter integration:

1. Go to Setup > Advanced > Social.

2. From the Social Media list, select Twitter.

3. Set the Twitter Enabled option to Yes.

4. Select the Please authorize Absolute by following this link then enter the pin number
below link.

5. In the window that opens, enter the login details of the corporate account you want to integrate
with, and follow any instructions for authorizing LiveTime to access the corporate page and
post to Twitter.

● Be sure to note the PIN that Twitter has generated for you.

6. On the Social tab, enter the PIN from Twitter.
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7. Click Save.
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Certificates
If you are using a self-signed SSL certificate to secure web traffic for LiveTime, the Certificates tab
allows you to import your certificate so that the system knows it can be trusted. This tab is visible
when the Accept All SSL option is set to No at Setup > Privileges > System.

To import a self-signed SSL certificate:

1. Go to Setup > Advanced > Certificates.

2. Click New.

3. In the Host name field, enter the address of the web server where your self-signed SSL
certificate is installed.

4. In the Certificate field, enter the certificate's content.

NOTE The certificate must follow X.509 standards and include the proper start and end

markers. For more information, click the icon.

5. Click Save.
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C o n f i g u ra t i o n M a n a g e m e n t S y s te m (C M S )
T a b

Configuration Management System (CMS) Tab
Within the ITIL framework, the Configuration Management System (CMS) includes the Knowledge
Management Database (KMDB) and the Configuration Management Database (CMDB). Within the
CMS tab, you can define elements that the CMDB uses, such as the terminology that describes item
relationships and durations of warranties used by service contracts.

This tab also allows you to define parameters within incident management to implement proactive
problem management.

NOTE The Incident Analyzer tab does not apply to the Help Desk edition of LiveTime.
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Relationships
You can define relationships between configuration items in the CMDB to create a service catalog. The
catalog allows users to assess the impact of a request on the organization. To build a catalog, you
must define the relationships within the properties of a configuration item within configuration
management.

To assist with the building of a CMDB, you can refine the list of relationship types available for the
supervisor.

Editing or Creating Relationship Types
To edit or create a relationship type:

1. Go to CMS > Relationships.

● The Relationship Types screen opens.

2. To edit, select an existing relationship, or to create a relationship, click New.
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3. Enter or edit the fields as required:

Relationship Types
Relationship

Class Select either a Hierarchical or Connection class.
Hierarchical describes ownership, such as a parent/child relationship; for
example, an operating system hosting an application.
Connection defines a connection association; for example, an application
accessing a database.

Name Enter a name that reflects the nature of the relationship for both component or
service views. For example, component view name = Deployed in/Host of.

Labels (each relationship between items can be described from a service oriented or
component oriented view)

Service Oriented
(Parent - Child)

A service oriented view describes relationships top down with the service at the
top. For example, the email provision service would be at the top level with
relationships between configuration items described, ending at an individual
user.

Component
Oriented
(Child - Parent)

A component oriented view starts from the bottom up, with the service being the
top layer.

Inherit Parents
Ownership

When this option is enabled, child items that use this relationship type inherit
the parent item's owners.

Inherit Cost When this option is enabled, child items that use this relationship type inherit
the costs associated with parent item.

4. Click Save.

● The following table contains sample relationship labels:
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Relationship Class Relationship Name Current Item Relationship Label Related Item
Service Host of/Installed on Application is host of Server

Component Host of/Installed on Application is installed on Server

Deleting a Relationship Type
To remove an entry on the Relationship Types screen:

1. Go to CMS > Relationships.

2. On the Relationship Types screen, select the relationship that you want to delete.

3. Click Delete.

● A warning message is shown.

4. Click OK in the warning message.
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Durations
Use the Durations menu to configure periods of time to use for warranty and lease durations.
Durations are available as a list when a default warranty service level agreement (SLA) is assigned to
an item type. The duration selected determines the length of the warranty period.

NOTE Within the User Portal, durations are available within the Service tab.

Within purchase orders, the lease durations are available when a PO is created for leased Items to
specify the lease period. 

Within the Durations menu, a number of default durations exist. You can edit these durations or create
new ones.

Creating or Editing Durations
To create or edit durations:

1. Go to CMS > Durations.

● (In the User Portal, as a supervisor, go to Service > Durations.)

2. Click New to create a new duration, or select an Interval Name to edit an existing duration.

3. Enter or edit the interval name.

4. Enter or edit the time period for the duration.

5. Click Save.
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Deleting a Duration
To delete a duration:

1. Go to CMS > Durations.

2. On the Durations screen, select the duration that you want to delete.

3. Click Delete.

● A warning message is shown.

4. Click OK in the warning message.
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Incident Analyzer
Use the Incident Analyzer menu to set parameters that provide proactive incident and problem
analysis. The Analysis Engine automates inter-process escalation between the incident management
and problem management processes. The Analysis Engine automatically groups similar incidents into
a problem based on the criteria you set in the Incident Analyzer tab. Also, the Analysis Engine is able
to retrieve problems relevant to an incident and present them for consideration.

NOTE The Incident Analyzer menu is available if your LiveTime implementation includes problem
management. The Incident Analyzer does not apply to the Help Desk edition of LiveTime.

A problem is used to manage a number of incidents related to one cause or incidents associated with
highly critical items. Problems are managed through the problem management process.

Configuring the Incident Analyzer
To configure the Incident Analyzer:

1. Go to CMS > Incident Analyzer.

2. Set the Analysis Engine Status to On.
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3. Enable the relevant Incident Analyzer functions.

4. Define the relevant parameters for the following options:

Field Description
Full Text
Matching

Searches for matching text between incidents and problems. The recommended
Relevance percentage is between 75% and 80%.

Item
Classification

Searches incidents based on matching the item and problem classifications. If the
number of incidents entered in the Problem Threshold is met within the time
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Field Description
Interval entered, the system creates a new problem.

Item Type
Classification

Searches by matching item type and problem classification of incidents. If the
matching number of incidents in the Problem Threshold for the time Interval is met,
the system creates a new problem.

NOTE You should use either Item Classification or Item Type Classification
exclusively.

Infrastructure
Impact

Automatically escalates an incident to a problem if the number of related items
affected by the incident is equal to or greater than the value entered here.

Infrastructure
Criticality

Automatically escalates an incident to a problem if an incident's item criticality is
equal to or greater than the value selected here.

Problem
Impact

Used to calculate the relevant impact rating that is assigned to an auto-created
problem.
The system multiplies by 4 the number entered in theWeighting field to get the
required number of affected users to apply the highest problem impact of Severe.
The system calculates the number of affected users on the number of owners
attached to an item.
An integer between 1 and 6 is recommended forWeighting.

Problem
Urgency

Used to calculate the relevant urgency rating that is assigned to an auto-created
problem.
Applied when a new problem is created or an incident is added to an existing
problem.
The system multiplies by 4 the number entered in theWeighting field to get the
required number of current incidents or problems to apply the rating of Urgent .
An integer between 1 and 4 is recommended forWeighting.

5. Click Save.
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Attachments
Use the Attachments tab to create a catalog of attachment types that allows users to classify files
they upload as attachments.

File attachments can accompany a variety of elements within LiveTime, including service requests,
incidents, problems, change requests, releases, configuration items, configuration types, SLAs,
contracts, knowledge base articles, purchase orders, and invoices.

Because users can potentially upload a large number of file attachments in a variety of areas within the
system, it is best practice to create a catalog that allows these attachments to be better organized and
more easily identified. With this process in place, users can assign an attachment type to the file they
are attaching at the point of upload.

To create a catalog of attachment types:

1. Go to CMS > Attachments.

2. Under the Details section, review the default catalog tree. Add or delete attachment types
based on the requirements of your organization:

● To add an attachment type, right-click the node under which you want to add the
attachment type and select Create from the menu.

● To delete an attachment type, right-click the attachment type and select Delete from the
menu.

NOTE You can also rename an attachment type by right-clicking it and selecting
Rename from the menu.

3. To limit the availability of an attachment type to specific processes, right-click the attachment
type, select Process from the menu, and ensure only the processes you want associated with
the attachment type are checked.

4. To hide attachments that are associated with this attachment type within requests, right-click
the attachment type and select Hidden from the menu.

● When this option is enabled, files that are classified using this attachment type will not be
visible on the Attachments tab of a request, unless the Show Hidden Attachments
checkbox is selected on this tab. This checkbox is selected by default when the Show
Hidden Attachments option is enabled at Setup > Privileges > Requests.

5. If you want to designate an attachment type as the default for a specific element (for example,
Additional Detail for knowledge base articles), right-click the attachment type, select
Process from the menu, then select the desired default element.

2 5 6



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e H e l p E m b e d d i n g a S u p p o r t F o rm

Embedding a Support Form
To embed a support form so customers can create requests directly from a website, add the following
script, with an amendment to the "protocol" and "baseHost" details, to the target website page source:

<script type="text/javascript" defer="defer">
var protocol = "https://"; // use "http://" if not running ssl
var baseHost = "servicedesk.mycompany.com"; // service desk hostname
document.write(unescape("%3Cscript src='" + protocol + baseHost + "/LiveTime/js/livetime.js'
type='text/javascript'%3E%3C/script%3E"));
</script>

In the above script, adjust the details for the "protocol" and "baseHost" to those of the server hosting
LiveTime.

The following functionality is now accessible from your designated website:

The following is an example of the request form available for customers to complete:
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C o n f i g u r i n g E m a i l P o l l i n g a n d R e q u e s t
C re a t i o n

Configuring Email Polling and Request Creation
The email polling feature automatically manages incoming support requests through email, which helps
organizations respond quickly and efficiently to customer inquiries and minimizes time-consuming data
entry tasks for technicians.

Enabling Email Polling
By itself, the email polling feature acts as an auto-responder.

To enable email polling:

1. In the Administrator Portal, go to Setup > Email > Server.

2. Enter the server details.

● These fields include the system accounts for the incoming and outgoing mail servers. If
you are using Microsoft Exchange Server, use full email addresses for the system
accounts in the User Name fields and ensure the Authentication option is set to Login.

3. Click Save.

4. Click the Setup tab.

5. Set the Email Polling option to Yes.

6. Enter a value in the Interval field.

● This value specifies (in minutes) how long the system should wait between automated
scans of the system email account. At the specified interval, the system automatically
scans the inbox of the system email address for messages.

7. Define the remaining General Settings, Requests, and Notes fields:

Setup Tab Options
General Settings

Email Polling Enable Email Polling to allow the application to check for new email received in
the mailbox on the incoming server defined within the Server tab.
For new messages that are received, the system sends a message to the sender
acknowledging his or her message. You can customize system-generated
messages within the Setup > Email > Templates tab.

NOTE This option is locked to Yes if the Create/Update via Email option is
selected.

Interval Enter the time period (in minutes) the system uses to check the incoming server for
any received messages.

Include
Banner

Select Yes to include a banner within emails sent from the system.
You can customize the banner at Setup > Customize > Banners.

Email Errors When enabled, details of any system errors occurring while the application is
running are sent to the development lab.

Copy Type For emails sent within requests, define if the technician should be copied or blind
copied on the correspondence.

Requests
Create/Update Select this option to enable requests to be created from emails addressed to the
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Setup Tab Options
via Email system and to team addresses aliased on the email server.

NOTE The Email Polling option is locked to Yes when this option is selected and
the Accept Anonymous option is shown.

To use this feature, you must also ensure that the Incident and Service Request
options at Setup > Privileges > Customer are set to either Create or Create and
Edit.

Accept
Anonymous

When enabled, the system creates requests from emails received from email
addresses that do not exist in the application's database. (See below for more
information regarding this setting.)

Notify
Alternate
Team

When enabled, and if there is more than one team created for a process, the
Alternate Team field is shown within the Summary tab of a request. Members of
the alternate team are notified relative to the settings defined for the current team,
and for new notes if Technicians is selected in the New Notes screen.

Self Mail When set to Yes, new notes created by a technician or customer are also sent to
them when they save the note.

Include
Request
Status

When enabled, the system includes the request status within the email subject line
of any correspondence sent from the system regarding a request.

Include
Request
Priority

When enabled, the system includes the request priority within the email subject
line of any correspondence sent from the system regarding a request.

Include
Request
Subject

When enabled, the system includes the content from the subject line of a request
within the email subject line of any correspondence sent from the system regarding
a request.

Notes
Parse
Instance Prefix

The instance prefix is used to process email correspondence from multiple
instances. If this functionality is not required, set the option to No.

Default
Recipients

Within the notes editor for requests, you can define the default email settings for
the recipient groups. Define the groups who are more likely to be sent every new
note created related to a request.

Default Locale Set the default language to use for email correspondence. The option set here is
applied to the Email Locale field in the Customer Information and User
Information screens and can adjusted on a per account basis, as required.

NOTE You can define the content for automated emails sent from the system for
languages other than English within the Setup > Localization > Content tab.

8. Click Save.

9. Customize the content of emails that the system automatically sends within the Templates
tab, including the Handshaking (CloseRequest), No Account, and Signature templates. Within
the Prefix template, you can also edit the message prefix the system uses to recognize
correspondence related to requests stored in the system.

If the Create/Update via Email option is not enabled, the system sends an automatic reply to the
sender. This email informs the sender that requests cannot be received through email, and that he or
she must use the Customer Portal to log a request. You can configure the content of this message in
Setup > Email > Templates.
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NOTE Before using the email polling feature, ensure that the main system email accounts inbox is
empty. Otherwise, the system acts on any messages in the inbox either with an auto-response
message to the sender the creation of requests for the messages, depending on the application's
settings.

Use special caution if the main system email account is an IMAP account. Unlike POP accounts,
messages generally are not removed from an IMAP server's inbox after they are read. Failure to clear
out the inbox prior to using the email polling feature could result in auto-responses being sent to (or
requests being created for) every message in the inbox.

Creating Requests Through Email
If the Create/Update via Email option is enabled, the system attempts to either create a new request
or update an existing one each time a message arrives in the system inbox.

To activate this feature:

1. Go to Setup > Email > Setup.

2. Select the Create/Update via Email checkbox.

3. Click Save.

4. Go to Setup > Privileges > Customer.

5. Set the Incident and Service Request options to either Create or Create and Edit.

6. Click Save.

7. If all team members should receive a copy of the notification that a new request has been
received, set the Notify Alternate Team option within the Information tab of the team.

To create a request using email, a customer with a pre-existing account can simply send an email
message describing the issue to the appropriate team email address (refer to "Setting Up Team
Aliases" below).

When a new message arrives, the system identifies the customer by matching the sender's email
address against the addresses of customers registered in the database. If it fails to find a match, an
email is sent to the sender notifying him or her to create an account before creating requests through
email. You can configure the content of this message in the NoAccount template under Setup >
Email > Templates.

If the system finds a matching customer account, and the address that the email was sent to belongs
to an existing team, it automatically creates a request. The body of the email becomes the main text of
the request description. Any attachments included with the email are also attached to the request. The
new request is assigned a priority type of Medium, and uses the default Classification - General.

If the customer only owns a single item, the system automatically assigns this item to the request and
runs the standard system SLA check of customer/organizational unit/item to verify which SLA should
be assigned to the request.

If the customer owns multiple Items, the system can automatically assign the relevant item upon
request creation if the customer prefixes the email subject with "Item #" followed by the item
identification number as recorded in the CMDB. If the customer has an account in the system and is
assigned as an owner of the item, the system refers to relationships and skills configured in the
CMDB, resulting in the request being routed to the most relevant technician for the job.
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In the case where the “Item #” is not included in the email subject line, and if the matching customer is
assigned zero or multiple items, the new request uses the Unknown item and the system default SLA.
The system assigns the request to the team or technician who supports the Unknown item. When the
item is changed from Unknown to a specific item, the team or technician assigned may change based
on the team configured to support the item. The system may also automatically reset the SLA as it
applies the SLA derivation logic of Customer/Organizational Unit/Item to assign the relevant SLA.

After the system creates the request, it also adds an entry to the request audit trail stating the request
was generated through email. The customer and the assigned technician then receive emails notifying
them of the request number and details.

Monitoring Tools and Request Creation
For the system to automatically create requests from emails sent by monitoring tools, the monitoring
tool must be created as a customer within the system. The email address the monitoring tool uses can
be the system default support address or a specific team address (see "Setting Up Team Aliases"
below). After the system creates the request, it adds an entry to the request audit trail stating the
request was generated through email. The monitoring tool customer account and the assigned
technician receive emails notifying them of the request number and details.

If the monitoring tool customer account is assigned to a single item, the system automatically
associates this item with the request and runs the standard system SLA check of
customer/organizational unit/item to verify which SLA should be assigned to the request.

If the monitoring tool customer account is associated with multiple items within the CMDB, the system
can automatically assign a specific item upon request creation if the monitoring tool email prefixes the
email subject with ‘Item #’ followed by the item identification number as recorded in the CMDB. In this
situation, if multiple customers own the item and if the request is to be associated with a different
customer after the request is created, technicians can update the customer details to move it from the
monitoring tool customer account within the Customer tab of the request summary.

In the case where the “Item #” is not included in the email subject line, and if the matching monitoring
tool customer account is assigned zero or multiple items, the new request uses the Unknown item and
the system default SLA. The system assigns the request to the team or technician who supports the
Unknown item. When the item is changed from Unknown to a specific Item, the team or technician
assigned may change based on the team configured to support the item. The system may also
automatically reset the SLA as it applies the SLA derivation logic of customer/Organizational unit/item
to assign the relevant SLA.

Adding Notes Using Email
Managing requests through email is handled by the application sending its initial email with the subject
line prefixed by the ‘Incident #’, or in the case of change management, prefixing the RFC subject line
with ‘Change Request #’, followed by a series of numbers that make up the individual request
identification number. Customers simply reply to this email and the system assigns their
correspondence to the relevant request and uploads any attachments to their request. Technicians can
also reply to these emails to update the request, if convenient.

When the note has been created, the system adds an entry to the request audit trail indicating that a
note was added via email. The customer and assigned technician are then sent emails alerting them to
the creation of a new note.

2 6 2



L i v e T im e A d m in i s tr a to r P o r ta l – O n l i n e
H e l p

C o n f i g u r i n g E m a i l P o l l i n g a n d R e q u e s t
C re a t i o n

Setting Up Team Aliases
For an incoming message to result in the successful creation of a request, it must be addressed either
to the main system email address or to an email account that is an alias for the main system account
and assigned to an existing incident, change, or service request team.

For example, if your main system email address is support@yourcompany.com and you want to set up
three teams – Team A, Team B, and Team C – those three teams should use email addresses that are
aliases for support@yourcompany.com:

● teamA@yourcompany.com should forward messages to support@yourcompany.com
● teamB@yourcompany.com should forward messages to support@yourcompany.com
● teamC@yourcompany.com should forward messages to support@yourcompany.com

NOTE Consult the documentation that came with your mail server for information on setting up email
aliases. If you are using Microsoft Exchange Server, you must create a distribution group for each alias
you want to use, assign the email address of the alias as the group's name, and add the main system
email address as a member within the group's properties.

Using this technique, any message that is sent to teamA@yourcompany.com,
teamB@yourcompany.com, or teamC@yourcompany.com is automatically forwarded to
support@yourcompany.com. The email polling mechanism then picks up those messages and
responds accordingly. The resulting request is assigned to a technician within the team the message
was addressed to.

An alternate configuration involves setting a single team's email address to the main system address,
which bypasses the need for aliases but does not allow the system to funnel requests to specific
teams.

Troubleshooting
If you have trouble setting up or using email polling and creation, keep the following tips in mind:

● For the request creation feature to work properly, both the Email Polling and Create/Update
via Email options must be selected within the Setup > Email > Setup tab.

● Only emails sent to the main system address or to an alias that is currently in use by an
existing team can be accepted.

● All pertinent information regarding the main system email address and the incoming and
outgoing mail servers must be completed correctly.

● Ensure the customer sending the email has a valid email address within the system.

NOTE Only incidents, change requests, and service requests can be created via email. If a users
attempt to send an email to a problem team, the system sends a reply email informing them that they
must send their email to a different incident, change request, or service request team for their request
to be logged with the system.
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Extending the Application Using Web Services
The Web Services interface enables third party applications to interact directly with LiveTime in a
secure and controlled fashion. The interface is based on the SOAP standard for Web Services. For
more information about SOAP Web Services, please see http://www.w3.org/standards/webofservices/.

The system's Web Services interface is intended for developers to use to extend the application's
accessibility and requires a basic familiarity with Java. For detailed information and instructions, please
visit http://developer.livetime.com/developer/.
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About Internationalization and Localization
Internationalization is the process of designing an application so that it can be adapted to various
languages and regions without engineering changes. Sometimes the term internationalization is
abbreviated as i18n, because there are 18 letters between the first "i" and the last "n".

LiveTime is an internationalized program that has the following characteristics:
● The addition of localized data that allows the same executable to run worldwide
● Textual elements, such as status messages and user interface (UI) labels, are not hard-coded

in the program but stored outside the source code and retrieved dynamically
● Support for new languages does not require re-compilation
● Culturally-dependent data, such as dates and currencies, appear in formats that conform to the

end user's region and language
● The application's localization resources are easily accessible

Localization is the process of adapting software for a specific region or language by adding locale-
specific components and by translating text. The term localization is often abbreviated as l10n,
because there are 10 letters between the "l" and the "n".

Overview of the Localization Process
LiveTime's internationalized framework is very intuitive and flexible, which allows you to localize it for
a particular language and character encoding schema.

The primary task when localizing the application is translating the user interface elements in the
external text file LiveTime.properties.

The following steps are a guide through the localization process. The example included assumes
French localization of the application and uses the ISO-8859-1 character set.

1. Ensure your desktop’s operating system has the appropriate character set installed

● The localization file and rendering requires the character set to be available for data entry
and data presentation.

2. Ensure you create the relational database management system (RDBMS) using the
appropriate character set

● This step is required so that French data entry can be successfully saved and retrieved
from the database.

3. Specify the correct character set encoding for the system

● Edit the ‘Properties’ file (located in the /CONTAINER_APPS_PATH>/LiveTime/WEB-
INF/LiveTime.woa/Contents/Resources folder) and specify the character set to use for
presentation to the end user. This character set is sent to the end users to control
presentation in both the user interface and outbound email.

4. Edit the UI strings in the external properties file

● The ‘LiveTime.properties’ file (located in the /CONTAINER_APPS_
PATH>/LiveTime/WEB-INF/LiveTime.woa/Contents/Resources folder) stores the
externalized user interface content. The default format of the file is plain text with ISO-
8859-1 character set encoding. You can create alternative versions of this file in any text
editor that allows you to save using the character set you require.
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● The first step in creating a local version of this file is to save a copy of it for the language
you are localizing into. For this example of the French translation, there is no need to
worry about the file encoding. Simply save a copy of the file called ‘livetime_fr.properties’.
Simple Messages
The copy of this file consists of a collection of name-value pairs, with each broken up into
clusters representing user interface components.
For example:
ClassName.greetings=Hello
ClassName.farewell=Goodbye
ClassName.inquiry=How are you?
The ‘name’ or ‘key’ section (for example, "ClassName.greetings") of these strings is of little
relevance to the end user except to note that if they are changed, the system is not able to
look them up.
The ‘value’ component of these pairs (for example, "Hello") represents the corresponding
user interface value. The (French) translator can safely edit these values and they will appear
within the system.
ClassName.greetings=Bonjour
ClassName.farewell=Au revoir
ClassName.inquiry=Comment allez-vous?
Compound Messages
Compoundmessages contain variable that LiveTime substitutes into amessage at run time.
For example, in themessage "Hello Sunshine", the string "Sunshine" may vary. This
message is difficult to translate because the position of the string in the sentence is not the
same in all languages, or alternatively, the applicationmay need to generate the value based
on some business logic.
Where this substitution is necessary, the localized strings can have a set of braces
containing an id number (known as a substitution variable). The system replaces these
blocks at run time with the requested text. The localized version of a given stringmust
contain the same number of substitution variables.
For example:
ClassName.helloSunshine=hello {0}
This string renders as “hello sunshine”; however, we couldmodify themessage to read
“sunshine, hello” by doing the following:
ClassName.helloSunshine={0}, hello

5. Edit the locale definitions file

● The ‘LiveTimeLocales.xml’ file (located in the /CONTAINER_APPS_
PATH>/LiveTime/WEB-INF/LiveTime.woa/Contents/Resource folder) defines the
language code and character set used to process the strings defined in the external
properties file.

● Typically, this character set is the one you used when saving the external properties file.
By default, the following language locale is selected:

● <LOCALE language="en" country="" charset="ISO-8859-1"/>
● To enable the French external properties file to behave correctly, comment the above line

and uncomment the following line:
● <LOCALE language="fr" country="" charset="ISO-8859-1"/>
● For convenience, the file already contains many different values so it is just a matter of

uncommenting the necessary entry.
● If an entry for your locale language does not exist, you can define it in the file by supplying

the language code, country code, and character set, as illustrated in the above examples.
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6. Ensure all file names are correct

● The names of the localized files follow a standard. In the French example, "livetime_
fr.properties" was the resulting file name. The ‘fr’ component of this name comes from the
ISO 639-1 standard. A full list of these codes is available at
http://www.loc.gov/standards/iso639-2/php/English_list.php.

Example of the login page translated:
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Supported Platforms for Database Mapping
The Setup > AMIE tab allows you to import items from an external asset management database using
database mapping (AMIE) or using a CSV file.

You can use database mapping with AMIE in conjunction with common asset management systems,
including:

● Centennial Discovery 2005, 9
● Express Software Manager 9.0, 9.5
● HEAT LANrev 6.9+ / Absolute Manage 6.0+ / LANrev 5.1
● HP Universal CMDB 8.0
● LANDesk 8.5, 9.0, 9.0 (Hardware)
● LiveTime Discovery 2005, 2007
● LOGINventory 4.3
● Manage Engine Desktop Central 7.0
● Microsoft SMS Version 2003 SP1
● Microsoft SCCM 2007
● Spiceworks 4.0+
● ZENworks Asset Management 6.5+
● ZENworks Configuration Management 11.1, 11.1 (Hardware)

If your organization manages items externally, you can still easily import them into LiveTime by using a
CSV file. For more information, see the following topics on importing items:

● Managing Items Using Database Mapping (AMIE)
● Managing Items Using a CSV File
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