Security Controls

PowerShell API Requirements

The following are required in order to use the API feature:

Ivanti Security Controls 2018.3 or later

The API and Windows PowerShell components and modules are automatically installed with Ivanti Security Controls 2018.3 or later. No configuration is required.

Must be run from the Ivanti Security Controls console.

The API commands will run in a user session on the console. The user’s context is handed off to the Protect service so that the lifetime is decoupled from the interactive session.

Windows PowerShell v4.0 or later must be installed on the console.

The Windows PowerShell console must be run with administrator rights.

The STProtect API module must be imported before executing any PowerShell commands.


Was this article useful?