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Welcome

WELCOME
Thank you for choosing Shavlik Protect, a unified IT management platform used for
managing and protecting Wndows-based machines and VMware ESXi hypervisors.
Shavlik Protect provides you with one centralized and common interface that you can
use to perform several essential IT management functions, including patch
management, asset inventory, power management, antivirus, antispyware, Active
Protection, virtualization management, IT management tools, extensive reporting, and
more.
Shavlik Protect is available within two different product bundles.
•

Shavlik Protect Standard: This is the basic product offering that includes
patch management, asset inventory, and a limited number of scripts for IT
management.

•

Shavlik Protect Advanced: This is the full-featured product offering that
includes patch management, asset inventory, antivirus & antispyware, power
management, and full ITScripts capabilities.

To quickly get you up and running with Shavlik Protect we have created this quick
start guide. To learn how to use the product simply follow the directions in this
document.

Beyond This Quick Start Guide
If after using this quick start guide you are interested in learning even more about
Shavlik Protect, please see the following Web page:
http://www.shavlik.com/support/training-videos
This Web page contains a number of video tutorials. The tutorials walk you through
the product interface, showing you exactly how easy it is to use Shavlik Protect and
how to get the maximum benefit from the product.

Shavlik Protect 9.2 Quick Start Guide

5

Installing Shavlik Protect

INSTALLING SHAVLIK PROTECT

Downloading Shavlik Protect
Shavlik Protect can be downloaded from the following Web page:
http://www.shavlik.com/downloads/

Installing Shavlik Protect
When you purchased Shavlik Protect or registered for the trial version, you received
download instructions and one or more license keys. To install Shavlik Protect, simply
follow the on-screen instructions. If you need assistance, please refer to the Shavlik
Protect Installation Guide available at:
http://www.shavlik.com/support/protect/documentation

Activating Shavlik Protect
In order to use the full product you must activate it by entering the license key(s).
Simply select Help -> Enter/refresh license key and follow the on-screen
instructions. The license key is contained in the e-mail message sent to you by Shavlik.
Note: Without entering a license key, many of the important features in the product
will be unavailable. If you have not already received a license key, please contact your
sales representative.
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USING SHAVLIK PROTECT
Agentless
Patch
Management
Tasks
Tip: To view a
video tutorial on
this topic, click the
video icon.

Performing a Patch Scan
Performing a scan is only a click away. The Shavlik Protect interface allows you to
work with the application in several different ways. Quick and simple scans can be
performed directly from the home page. More advanced scans can be enabled by
creating unique machine groups and scan templates. For complete details on
performing patch scans see Agentless Patch Management Tasks > Performing
Patch Scans in the Help system.
Try it yourself:
1. On the home page, in the Select/confirm targets area, select My Machine.
2. In the Select schedule area verify that Now is selected, and in the
Select/confirm operation area verify that Security Patch Scan is selected.
3. Click Scan now.
Note: The scan is performed using the credentials of the currently logged on user.
Valid credentials must be specified when performing scans and deployments on
other machines.
This will immediately begin a scan of your machine using the default scan
template. During the scan process the latest patch data files are automatically
downloaded and the Operations Monitor dialog shows the current status of the
scan.

4. Review the scan results by clicking the View results link.
Note: For information on performing scheduled scans, see the tutorial available at:
http://www.shavlik.com/support/training-videos.
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Reviewing Scan Results
You can access scan results a couple of different ways:
•

You can view the results for a scan you just performed by clicking the View
results link from within the Operations Monitor.

•

You can view the results for prior scans by selecting Results at the top of the
navigation pane and then selecting the desired scan.

This view is called Scan View and provides detailed information about a scan.
1. In the top-right pane, select the machine you just scanned.
2. In the middle pane you can view a variety of information, including:
•
•
•
•
•

The
The
The
The
The

number of service packs that are missing
number of patches that are missing
number of patches that are installed
products (applications) that were scanned on the machine
number of patches that are missing for each of the scanned products

3. In the bottom pane you can view detailed information about any patch you select
in the middle pane.
4. For more information on interpreting scan results, press F1 to view the Help
system.
Complete information on interpreting patch scan results is available within the
Help system at Agentless Patch Management Tasks > Interpreting Patch
Scan Results (Scan View).
5. To view scan results using Machine View, select View > Machines.
Complete information on using Machine View is available within the Help system at
Common Tasks > Using Machine View.
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Deploying Patches
Once you’ve identified a missing patch that you’d like to deploy, simply right-click the
patch and then deploy the patch to the selected machine. You can choose to deploy
with the default deployment template, or you can create your own custom deployment
template. Patches can be deployed immediately, at a specified future time, upon next
reboot, or can be copied to remote machines for manual deployment at a later time.
Missing patches can also be automatically deployed upon completion of an immediate
or scheduled scan.
Try it yourself:
Patches can be deployed from either Machine View or Scan View. The Machine View
process is illustrated here; the process within Scan View is very similar.
1. To get to Machine View, select View > Machines.
2. In the top pane, select the machine you just scanned.
3. In the middle pane, expand the Patch Missing list.
4. Identify a missing patch that you would like to deploy.
5. Right-click the missing patch and select Deploy > Selected Patches.
For example:

6. If prompted to assign default credentials, click New, specify administrative
credentials for the machine, click Save and then click Assign.
Complete information on specifying and using credentials can be found in the Help
system at Installation and Setup > Supplying and Managing Credentials.
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7. On the Deployment Configuration dialog, make sure Install immediately is
selected and then click Deploy.
8. Watch the Operations Monitor dialog for detailed information about each step
being performed in the deployment process.
Assuming you used the default deployment template, the final step in the
deployment will be to reboot your machine. While you are waiting for the reboot
to occur, you can view the pending deployment task by selecting View >
Deployment Tracker.
9. After your machine reboots, start Shavlik Protect again.
10. Within the navigation pane, in the Results list, select the deployment you just
performed.
Details about the deployment are displayed on the right side of the window. The
top pane displays a list machines involved in the deployment and shows how many
patches each machine received. The lower pane provides information about how
the patches were deployed.
For more detailed information, see Agentless Patch Management Tasks >
Deploying Patches in the Help system.

Rolling Back Patches
Shavlik Protect provides the ability to uninstall selected patches. Not all patches can be
uninstalled. The ability to “roll back” a patch is dependent upon the patch vendor. Only
patches identified by the rollback icon

can be uninstalled.

You can uninstall a patch from Scan View or Machine View. You simply right-click the
patch and then select Uninstall Selected. For example:
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Generating Reports
Once you’ve completed a patch scan and deployment, you can generate any of a
number of customizable reports to provide analysis of the state of your desktop and
network security. Reports can be customized by scan date, machine group, or risk
level. Once a report is generated, you can view, print, or save the report. You can also
export the report to different formats or e-mail it to designated recipients. Shavlik
Protect reports are robust, gathering all information stored in the console, not just the
information generated in the most recent scan/patch implementation. This function
allows administrators to track the history of all patch activity on each machine.
Try it yourself:
1. From the program menu select Tools > Create report.
2. In the Select report to view box select the report you want to generate (for
example, Executive Summary).
3. Near the bottom of the Reports dialog click Generate report.
For detailed information about generating reports, see Common Tasks > Reports in
the Help system.
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Antivirus and
Antispyware
Tasks

You perform antivirus and antispyware tasks using agents. Simply create an agent
policy and then install the agent on a machine.
Important! Before using a threat task on agent machines, it is strongly
recommended that you remove all other antivirus and antispyware programs that may
be running on the agent machines. Using multiple threat programs on the same
machine may cause serious performance issues.

Create an Agent Policy
To create a new Shavlik Protect Agent policy:
1. From the main menu select New > Agent Policy.
The Agent Policy Editor is displayed.

2. Type a name for the new agent policy.
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Configure an Agent Policy
There are many different configuration options for an agent policy. For this example
you will configure a policy with a simple patch task and a very basic threat task, using
the default settings in most cases. You can also configure an agent policy to perform
asset and power tasks but those features are not used in this example.

Tip: To view a
video tutorial on
this topic, click the
video icon.

On the Patch Tab
Click Add a Patch Task and type a name for the task. For example, you might name
it Eval Patch Task. The patch task options are displayed. Feel free to simply use the
default values. You might consider clearing the Deploy patches check box on the
Scan and deploy options sub-tab if you do not want all missing patches to be
deployed later on when you test the agent. Do not click Save and update Agents
just yet.

On the Threat Tab
Click Add a Quick Scan Threat Task and type a name for the task. For example,
you might name it Eval Threat Task. The threat task options are displayed. Feel free to
simply use the default values.
On the Exceptions Sub-Tab
Select Always allow files, type winword.exe and then click Add. This tells your
threat task(s) and Active Protection that you always want Microsoft Word to be
allowed to run. This is a very simple example of how to use the Always Allow and
Never Allow lists. For more examples, click the Examples link.
On the Active Protection Sub-Tab
Make sure the Enable Active Protection check box is enabled.
Active Protection is a real-time service used to detect known and unknown threats
before they infect an agent machine. It sits quietly in the background of a machine
and monitors for attempts to change security configuration settings and values. If it
detects an attempt to change a setting it can respond a number of different ways,
depending on how it is configured. Feel free to simply use the default configuration.

Save the Agent Policy
In the bottom-right corner of the Agent Policy Editor dialog, click Save and update
Agents.
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Tip: To view a
video tutorial on
this topic, click the
video icon.

Install the Agent on the Console Machine
For simplicity, in this example you will install the agent onto your console machine.
You can, of course, install the agent on any of the machines in your organization.
1. Go to Machine View by selecting View > Machines.
2. Select the machine you scanned previously (this should be your console machine).
3. Right-click the machine and then select Agents > Install / Reinstall with
Policy and then select the agent policy you just created.
The Operations Monitor is displayed. It shows the status of the different steps
involved in the installation process. For example:

Using the Agent
The agent should now be installed on your console machine. You can launch the agent
a number of different ways:


Select Start > All Programs > Shavlik Protect > Shavlik Protect
Agent



Tap or click the Shavlik Protect Agent icon on the desktop



Double-click the Shavlik Protect Agent service icon that resides in your
machine's system tray

The Shavlik Protect Agent client program is displayed. For example:
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1. In the button tray located in the lower-left corner, click Patch.
2. In the Active Function pane located immediately above the button tray, click the
patch task you created earlier (e.g. Eval Patch Task).
Wait for the patch scan to complete. You can review the results in the right-hand
pane. Click Overview in the button tray to view the patch status of your machine.
3. In the button tray, click Threat.
4. In the Active Function pane located immediately above the button tray, click the
threat task you created earlier (e.g. Eval Threat Task).
Wait for the threat scan to complete. You can review the results in the right-hand
pane. Click Overview in the button tray to view the threat status of your
machine.
Results from agent-based patch tasks and threat tasks are also rolled up to the
console and can be viewed using either Machine View or Threat Events View.
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Performing AV Scans on Specific Files, Folders, or Drives
If an agent is configured with a threat task or if Active Protection is enabled, the user
of the machine can initiate an antivirus scan on a specific file, folder, or drive on the
machine. This is done by right-clicking the desired item within Windows Explorer and
then selecting Scan with Shavlik Protect. For example:

The results of the scan are displayed in the agent's threat log. The results are also
reported to the console and available for viewing using either Machine View or Threat
Events View.
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EXPLORING THE MANY OTHER POWERFUL FEATURES OF
SHAVLIK PROTECT
The topics discussed up until now are designed to get you up and running quickly with
Shavlik Protect and get a feel for the core capabilities of the product. There are of
course many, many other powerful features and we encourage you to explore them on
your own.

Machine Groups
Create a machine group and see how easy it is to manage the different physical
machines, virtual machines, domains, and organizational units in your organization.
For details, access the Help system and read the Installation and Setup > Using
Machine Groups topics.

Patch Groups
Create a patch group and see how they can be used to control exactly which patches
are scanned for and deployed to the machines in your organization. For details, access
the Help system and read the Agentless Patch Management Tasks > Using
Patch View > Creating Patch Groups topics.
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Patch Scan Templates
Create a new patch scan template and learn about all the ways it can be configured in
order to address your specific scanning needs. For details, access the Help system and
read the Agentless Patch Management Tasks > Patch Scan Templates topics.
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Tip: To view a
video tutorial on
this topic, click the
video icon.

Tip: To view a
video tutorial on
this topic, click the
video icon.

Asset Inventory Features
Create a new asset scan template and then use it in a scan to learn about your
software, hardware, and virtual assets. For details, access the Help system and read
the Agentless Asset Inventory Tasks topics.

Power Management Features
Read through the Agentless Power Management Tasks topics in the Help system
to learn how you can use Shavlik Protect to prepare your machines for maintenance
tasks and to reduce power consumption and operating costs. If you decide to test the
reboot or shut down feature be sure to do so on a non-critical target machine.
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Tip: To view a
video tutorial on
this topic, click the
video icon.

Tip: To view a
video tutorial on
this topic, click the
video icon.

ITScripts Feature
The ITScripts feature supports the use of PowerShell 4.0 and WinRM 2.0, enabling you
to execute a variety of scripts on the console and on remote target machines. It also
enables you to start a Windows PowerShell session between the console and a
selected machine. For details see IT Management Tools > ITScripts in the Help
system.

Virtual Inventory Feature
The Virtual Inventory feature is used to manage and track the vCenter Servers and the
ESXi hypervisors (ESXi hosts) that are used in your organization. You can use the
Virtual Inventory feature to:
•

Add vCenter Servers and ESXi hypervisors to Shavlik Protect

•

View basic configuration information about the vCenter Servers and the ESXi
hypervisors

•

Perform a scan of the managed and unmanaged ESXi hypervisors

•

View the security bulletins that have already been installed on the managed and
unmanaged ESXi hypervisors

•

View the security bulletins that are missing on the managed and unmanaged ESXi
hypervisors

•

Deploy any missing security bulletins to the ESXi hypervisors

For details, access the Help system and read the Installation and Setup >
Managing Your vCenter Server and ESXi Hypervisors topics.
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