Upgrade Requirements

New System Requirements

The following operating systems are no longer supported for use by the Security Controls console:

Windows 7 SP1

Windows Server 2008 R2 SP1

A new version of the Microsoft Visual C++ Redistributable for Visual Studio 2015 – 2019 is available, so this will likely be identified as missing during the prerequisite check of the upgrade process.

For a complete list of requirements for the console, your agentless clients and your agent-based clients, see System Requirements.

User Account Requirements for Performing an Upgrade

In order to perform an upgrade, your user account must meet the following requirements:

The user performing the database upgrade must be a member of the db_owner role.

If you have multiple consoles that share a database and are linking an additional console to a database that is already upgraded, the user account you use must be a member of the following database roles:

db_datareader

db_datawriter

STExec

STCatalogupdate

In addition, the service account used for background operations must be a member the db_owner role. If your account is a member of the db_securityadmin and db_accessAdmin roles, the database upgrade tool will automatically attempt to map and configure the required roles for you.

Related Topics

Upgrade Procedure

Upgrade Tasks Performed on the Console