Avalanche powered by Wavelink

Home 

Upgrading to a Cloned Environment (Recommended)

The recommended method of upgrading from Avalanche 5.3 to 6.0 and newer is accomplished by creating a clone of your existing Avalanche installation, upgrading it to the latest version of Avalanche, and then redirecting all devices to the new server. This process ensures your data and working environment are still accessible for use throughout the upgrade. You can still upgrade Avalanche in place, but Ivanti recommends creating a cloned environment to avoid system downtime.

Consider this method of upgrading if one or both of the following conditions apply:

If you plan to install the Enterprise Server and Mobile Device Server at one location

If your existing PostgreSQL database is local to the Enterprise Server

For a video tutorial of this process, watch this video on YouTube:

Upgrade Process Video

If you use LDAP user accounts in Avalanche 5.3, before you begin the upgrade process, ensure that you know the password for the amcadmin account. LDAP user accounts will not be migrated and will be created as new accounts with no permissions the first time they log in to Avalanche 6.2. To recover the amcadmin password, contact Ivanti Support.

To upgrade Avalanche using a cloned environment:

1.Create a backup of your current Avalanche databases and software packages.

2.Install Avalanche 5.3.1 on the new system. If you are running a version of Avalanche that is earlier than Avalanche SE 5.3.1, you must also upgrade your existing system to Avalanche 5.3.1. To obtain the install files, contact Ivanti Support.

3.On the new system, install Microsoft SQL Server. For instructions on setting up SQL Server, see Setting Up Microsoft SQL Server.

When upgrading from Avalanche 5.3 and Microsoft SQL Server is not local to the Enterprise Server, the following tools must also be manually installed:

Microsoft SQL Server 2012 Native Client
Microsoft ODBC Driver 11 for SQL Server
Microsoft Command Line Utilities 11 for SQL Server

4.Configure the server with your existing databases to allow remote access. For more information, see Allowing Remote Access to the Database.

5.Run the Avalanche installer as an upgrade. The installer will prompt you for information about how to connect to the databases.

6.Merge the software packages backup with the avapackages folder located at C:\Program Files\Wavelink\Avalanche.

7. (Optional) Install or upgrade additional device servers.

8. Obtain SSL certificates and GCM/ APNS credentials to connect smart devices. For information on obtaining SSL certificates, see SSL Certificates. For more information about connecting devices, see Connecting Devices to the Avalanche Server.

9.Smart devices must be using 6.2 enablers to use the Central File Store and receive new or migrated file payloads. Download 6.2 Enablers from the download site and install them on your smart devices. Software payloads can be used to distribute enablers to devices. AIDC devices will still use 5.3 enablers.

10.(Optional) If you want devices to connect to a different device server, use a network profile or smart device profile with the new server address to redirect devices.


Was this article useful?    

The topic was:

Inaccurate

Incomplete

Not what I expected

Other