Installation

Before starting the Xtraction installation process, make sure you've reviewed the system requirements. For details, see System requirements.

Product setup includes four major parts:

1.Completing the pre-installation checklist, which includes downloading and installing your Xtraction license files and setting up the Xtraction database.

2.Installing the Xtraction application and configuring required and optional settings.

3.Configuring the data model settings.

4.Completing post-installation steps.

1. Pre-installation checklist

IMPORTANT: Xtraction servers require a license before they can be used. There are two ways to obtain a license, either by downloading one from the Ivanti Licensing Portal or by using the license credentials available in the Licensing Portal to automatically license Xtraction. Selecting the automatic method enables you to choose which licensable features are to be consumed by the Xtraction server. It also means that you won't have to download and apply a new license should the manually generated one expire.

If you choose to use automatic licensing, you can select the required licensing features from the Xtraction Settings page > Licensing tab:

Selecting the Automatic or Manual option does not prevent you from choosing the other method if you modify your installation or update your license files at a later date. In either case, your license files are available from the Ivanti Licensing Portal.

For troubleshooting tips related to licensing, register with the Ivanti community to view this article: Troubleshooting automatic and manual licensing.

Download the data model files (i.e., connectors) that you're entitled to:

For third-party connectors, do so from the Ivanti Licensing Portal. For details, view this article on the Ivanti community: How to download Xtraction licenses and connectors from Ivanti.

For Ivanti product connectors, go to Connector Downloads, where you must first register to log in.

You’ll configure the data model settings after installing Xtraction, as explained below.

Install Internet Information Server (IIS) on your Xtraction server and ensure it’s working correctly.

(Optional) If your target application database is on Oracle, install Oracle Client on your Xtraction server and configure it to access that database.

Set up the Xtraction database using the procedure below. You'll create an empty Xtraction database with two user accounts:

The first account needs read-only access to the target application database(s) on which Xtraction will report (this usually is not the Xtraction database itself).

The second account needs read, write, and owner access to the Xtraction database in order to create tables. After installing Xtraction, you’ll run the Xtraction Settings utility for the first time. The Settings utility will use this account to create the required tables in the database.

2. Install the Xtraction application

You can install the Xtraction application on the same server as the Xtraction database, or a different one. The installation process needs to run using an account with administrator privileges that has administrative rights on the Xtraction server. Administrative access is required only for installation.

You must run the installer from a local drive, not a network share. Installations run from a network share will fail.

The Xtraction Settings utility runs near the end of the installation process. You can configure the required product settings as part of installation or cancel and configure them later. Other optional settings are also available and may be useful to your installation.

3. Configure the data model settings

This section provides the minimum steps required for using the data model file with Xtraction. For details about further customizing the data model for your environment, see the Data Model Editor User Guide (PDF).

Before running Xtraction, you need to configure the data model selected earlier.

First, you must rename the Datamodel.dat file that was installed with the default instance of Xtraction. You can find this file in the …\Xtraction Software\Xtraction\Data\Configuration\ folder where Xtraction was installed.

Rename the Datamodel.dat to Datamodel.old. Next, copy the data model file that you downloaded from the Connector Downloads page or Ivanti Licensing Portal (as discussed in the pre-installation checklist) and save it as Datamodel.dat.

Next, open the provided Data Model Editor tool to change several settings and get the data model up and running. In a default installation, a shortcut to the editor is placed on the desktop. Otherwise, it can be found in the …\Xtraction Software\Xtraction\Tools\ folder where Xtraction was installed.

Load the data model

By default, there is no saved data model associated with Xtraction when it's installed. The very first time you use the Data Model Editor and load a data model, you’ll need to browse to the folder as noted above where you saved the data model obtained from the Ivanti Licensing Portal. To load a data model, click the File > Open menu and select the Datamodel.dat.

Add connection strings

For each data source in your data model, you need to provide a read-only connection string so that Xtraction can connect to that data source. Open the Connection String Editor by clicking the Tools > Connection String Editor menu.

The Connection String Editor dialog displays all of the data sources within your data model. To edit a connection string, click the appropriate connection item and then click the ellipsis button.

If your data model contains data sources that connect to the same physical database, after setting up the first connection string, you can copy the information by selecting the appropriate items, right-clicking the connection to copy, and selecting Copy.

When finished, click the File > Save menu to save the data model file. The connection strings are encrypted and associated with the server where the file was opened and saved to a file called Datamodeldb.dat.

If you copy the data model file to a different server, you'll need to re-enter the connection string details there, where they'll be encrypted and saved in a Datamodeldb.dat file on that server. Each Datamodeldb.dat file is specific to the server it's created on and will not work if copied elsewhere.

Update target application URLs

When displaying lists of records in Xtraction, an end user can double-click a record to launch the associated application’s website to display that record in the native application. For this to work, Xtraction has to know the URL for the website. To update the URLs within the data model, click the Tools > URL Editor menu.

By default, a placeholder is included with the URLs, and you’ll need to update this based on your environment. You can edit URLs in the grid or click the Find & Replace button to edit multiple URLs at once.

Use the Find & Replace dialog to replace these placeholders with the correct address. Below are some examples of search-and-replace strings based on different scenarios.

Standard URL:

Sample URL: http://appserver/Remote/...

Search for: [WEBSERVER]

Replace with: appserver

HTTPS:

Sample URL: https://appserver/Remote/...

Search for: https://[WEBSERVER]

Replace with: https://appserver

Alternate port:

Sample URL: http://appserver:8080/Remote/…

Search for: [WEBSERVER]

Replace with: appserver:8080

Update the schema or table owner

Depending on your database setup, it may be necessary to modify the schema/owner where the tables are located. To update the schema/owner, click the Tools > Schema/Owner Editor menu. The Schema/Owner Editor dialog displays the entire data model and enables you to check the appropriate tables to update.

Simply enter the name of the schema/owner and click the Update button. Repeat this process for each set of tables.

4. Post-installation steps

Once the installation process is complete, it's necessary to finish up with some post-installation steps.

IIS settings

If you’ve chosen to use an Active Directory account against your Xtraction database, this is where you’ll need to configure the Identity setting. For details about using AD, see Enhanced Active Directory integration.

For Windows 2008 or higher servers, confirm the following IIS settings before running Xtraction for the first time:

Basic Settings: Verify that Xtraction is running within its own application pool, which should’ve been created during installation.

Advanced Settings: If any of your application databases use Integrated Security to connect to the Xtraction database, update the Identity setting:

In IIS, locate the Xtraction application pool.

Open Advanced Settings.

Change the Identity setting to the user account used to access the database. The Xtraction application will now execute as the user account specified. This account needs the correct permissions to the file system in order to read the Xtraction web files (located by default at C:\Program Files\Xtraction Software\Xtraction\Web\Server\).

Xtraction Task Manager

The Xtraction Task Manager is a Windows service used to run the scheduled exports of dashboards, documents, and custom reports. Task Manager is installed by default into Windows services but may need to be configured for your environment.

Xtraction Alerts

Xtraction Alerts is a Windows service used to run the alert checks defined within Xtraction. The Alerts service is installed by default into Windows services but may need to be configured for your environment.

New installations require a certificate replacement

For all new installations of Xtraction (not direct upgrades), the software automatically configures itself to use SSL/HTTPS by default. This means that you must carry out a final procedure as part of the post-installation process—we recommend replacing the self-signed certificate with one from a Trusted Certificate Authority so that users don’t see an error message from their browser when they attempt to log in.

Should your organization require it, Xtraction can still be used with HTTP instead.

Now that the post-installation process is complete, you're ready to use the product. For details, see Running Xtraction.